Добровольные пожертвования

Уважаемые читатели сборника!

1) Если Вам понравился мой сборник "Полезные советы для Windows 7".
2) Если Вы нашли в нем необходимую Вам информацию.
3) Если решение предложенное в каком-либо совете помогло Вам.

Вы можете перечислить любую сумму добровольного пожертвования по следующим реквизитам:

Номер счета (кошелька): 410011300279781

Способы пополнения кошелька электронной платёжной системы Яндекс.Деньги (Yandex.Money):
https://money.yandex.ru/prepaid/?from=imainprep

Моментальное перечисление денег на кошелек без комиссии возможно в терминалах Сбербанка и Связного.

Номер счета (кошелька): RU087205943

Способы пополнения кошелька электронной платёжной системы RBK Money:
http://www.rbkmoney.com/ru/sposoby-oplaty-v-seti

В большинстве терминалов зачисление денег на кошелек осуществляется моментально и комиссия за данную операцию не снимается.

E886157771012 — номер кошелька для перевода в евро.
Z467348269094 — номер кошелька для перевода в американских долларах.
R178486713335 — номер кошелька для перевода в российских рублях.
U308963992842 — номер кошелька для перевода в украинских гривнах.

Способы пополнения кошелька электронной платёжной системы Webmoney:
http://www.webmoney.ru/rus/addfunds/index.shtml

Для пожертвования средств на данный кошелек нажмите на кнопку Donate под флажком с указанной валютой.

$ USD
€ EUR
£ GBP


История версий

Дополнительная информация о порядке внесения изменений:

Принципы добавления новых советов:

1) Если из раздела ничего не перемещалось, то каждый новый совет добавляется в конец списка соответствующего раздела.
2) Если из текущего раздела что-либо перемещалось в другой раздел сборника, то взамен перемещенного совета добавляется либо последний из текущего списка раздела, либо добавляется новый совет с соответствующей тематикой.
(За исключением рокировок - когда совет из текущего раздела меняется местом с советом из другого раздела.)

Размер дополнений различен от изменения нескольких букв в одном, до полного переписывания заново другого.

Принципы смыслового или стилистического обновления имеющихся советов:

1) Информация добавляется в конец существующего совета.
2) Информация исправляется внутри самого совета.
3) Информация перезаписывается полностью взамен имеющейся.
4) Изменяется структура совета - добавляется пошаговость.
5) Исправляются опечатки первого и второго типа.

Опечатки первого типа - не изменяющие смысловой нагрузки (пример):

введите комманду -> введите команду
запустите програму -> запустите программу

Опечатки второго типа - изменяющие смысловую нагрузку (пример):

taskkill /IM /F explorer.exe -> taskkill /F /IM explorer.exe
Опечатки второго типа почти не встречаются. Их исправление происходит ещё в процессе проверки совета перед добавлением в сборник, так как изначально создается черновой вариант совета в блокноте, а затем он вручную превращается в готовый htm-файл.

Поэтому, в связи с выше изложенным, обо всех изменениях указывается - обобщенно.

Так что, если Вам понадобилось решение, используйте встроенные мною в сборник вкладки: алфавитный Указатель - для поиска по названию совета или Поиск - для поиска по слову или фразе.

Количество советов в сборнике равно номер его версии умноженный на число 100.

Изменения в версии 5.95.

Содержимое некоторых советов обновлено.
Исправлены найденные опечатки в тексте.
Добавлено 12 новых советов.

Изменения в версии 5.83.

Содержимое некоторых советов обновлено.
Заменены неработающие ссылки.
Добавлено 2 новых совета.

Изменения в версии 5.81.

Изменена и оптимизирована структура сборника.
На странице "Стартовая страница" добавлены ссылки на подразделы. Для их отображения нажмите на значок плюса.
Страница "Общий список советов", содержит полный список советов без их содержимого.
Страница "Главная страница" с содержимым советов спрятанным под спойлерами разделена на отдельные страницы по разделам.
Изменен способ отображения рисунков. Все изображения обернуты в специально созданную мною оболочку в Windows стиле.
Переписана "Инструкция использования данного справочника".
Раздел "Установка" переименован в "Установка, Обновления, Языки".
Исправлены найденные ошибки.
Заменены неработающие ссылки.
Изменены наименования и расположения некоторых советов.
Некоторые советы дополнены новой информацией.
Удален 1 совет, так как он теперь входит в состав другого.
Добавлено 13 новых советов.

Изменения в версии 5.69.

Несколько советов обновлено.
Несколько советов переименовано.
В разделе "Устранение неполадок - Администрирование и Интерфейс" на первое место добавлен новый совет, имеющийся первый совет перемещен на второе место, а второй в конец списка.
Удален 1 совет, так как он теперь входит в состав другого.
Добавлено 7 новых советов.

Изменения в версии 5.63.

Немного подробнее написан текст в нескольких советах.
Заменены тексты reg-файлов и готовые reg-файлы, на более расширенные версии, в совете 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
Заменены пути указанные в сборнике для папок History и Temporary Internet Files на более точные.
Добавлено 6 новых советов.

Изменения в версии 5.57.

Заменены неработающие ссылки.
Некоторые советы дополнены и обновлены.
Несколько советов переименовано.
Заменено и добавлено несколько новых изображений.
Удалено 2 совета, так как они теперь входят в состав других.
Добавлено 4 новых совета.

Изменения в версии 5.55.

Исправлены найденные ошибки.
Многие советы обновлены и/или дополнены.
Некоторые советы переименованы.
Обновлено и добавлено несколько изображений в имеющиеся советы.
Удалено 4 совета.
Добавлено 59 новых советов.

Изменения в версии 5.00.

Имеющиеся советы обновлены и/или дополнены.
Переименовано 3 совета.
В разделе Твики Реестра - Администрирование и Безопасность. на третье место добавлен новый совет "3. Запуск редактора реестра от имени пользователя TrustedInstaller, для удаления и редактирования заблокированных разделов.", текущий третий совет перемещен в конец списка.
Переписан заново совет 4. Список сочетаний клавиш используемых в Windows 7. из раздела Разное.
Добавлено выделение клавиш клавиатуры.
В оболочку справки добавлена кнопка Шрифт (циклически изменяющая при нажатии размер (увеличение/уменьшение) шрифта в сборнике).
Добавлен новый раздел Портабелизация.
Добавлено 31 новых советов.

Изменения в версии 4.69.

Исправлены найденные ошибки.
Имеющиеся советы обновлены и/или дополнены.
Заменены устаревшие ссылки на новые.
Некоторые изображения заменены новыми.
Оптимизирован размер всех изображений.
Оптимизирован код перехода к разделам из советов.
Использован другой алгоритм компиляции chm-файла.
Благодаря указанным выше действиям уменьшился размер файла сборника.
Добавлено 12 новых советов.

Изменения в версии 4.57.

Исправлены найденные ошибки.
Несколько советов переименованы.
Имеющиеся советы обновлены и/или дополнены.

Добавлен второй вариант в совет 18. Добавление или замена языка интерфейса в Windows 7 Home или Windows 7 Professional. из раздела "Установка".
В отличие от первого варианта, второй вариант дополнительно к редакциям Home Basic (Домашняя Базовая), Home Premium (Домашняя Расширенная) или Professional (Профессиональная) позволяет изменить язык интерфейса в редакции Windows 7 Starter (Начальная).
В связи с этим данный совет переименован в 18. Изменение языка интерфейса в Windows 7 Starter/Home Basic/Home Premium/Professional.
Совет 30. Отслеживание изменений на диске и в реестре, путем сравнения снимков системы. из раздела Администрирование переписан заново, из-за найденного более лучшего решения.
В разделе Твики Реестра - Администрирование и Безопасность на второе, третье и четвертое место добавлены новые советы, а имеющиеся на данных местах советы перемещены в конец списка.
Остальные новые советы, относящиеся к разделу "Твики Реестра - Администрирование и Безопасность." добавлены как обычно в конец списка.
А также другие дополнения и обновления информации в советах.

Добавлено 19 новых советов.

Изменения в версии 4.38.

Имеющиеся советы дополнены.
Исправлены найденные ошибки.
Добавлено 11 новых советов.

Изменения в версии 4.27.

Имеющиеся советы дополнены.
Изменено месторасположение советов в разделе Администрирование.
Добавлено 16 новых советов.

Изменения в версии 4.11.

Имеющиеся советы дополнены.
Исправлены найденные ошибки.
Раздел "Интерфейс - Внешний Вид." переименован в "Интерфейс - Отображение."
Создана специальная оболочка для облегчения работы с данными в таблицах. Ее возможности:
- Отображение (скрытие) необходимого числа столбцов.
- Сортировка данных в убывающем или возрастающем порядке.
- Поиск по таблице
- Выделение (снятие выделения) необходимого числа строк.
- Фиксация надзаголовка и подзаголовка таблицы - доступно только на отдельной странице совета.
- Разбиение таблицы на страницы, с возможностью выбора числа отображаемых строк и возможностью постраничного перехода - доступно только на общей странице советов.
Все крупные таблицы в сборнике, а также те в которых необходима сортировка или поиск переделаны для работы с указанной выше оболочкой, внешний вид остальных таблиц оставлен без изменений.
Инструкция по работе с данной оболочкой добавлена на страницу "Инструкция использования данного справочника".
Изменено месторасположение многих советов, на их место перемещены либо последние из идентичного раздела, либо добавлены новые.
В числе новых советов, в раздел "Настройки" на первое место добавлен "1. Конфигурация служб Windows 7 по умолчанию, способы их запуска и отключения.", текущий первый совет переименован и перемещен в раздел "Интерфейс - Взаимодействие".
Удален 1 совет.
Добавлено 22 новых совета.

Изменения в версии 3.90.

Изменена структура сборника, позволив уменьшить размер сборника.
Удалены отдельные html-страницы разделов; ссылки на них заменены ссылками на якоря в главной странице сборника.
Внесены изменения в стартовую страницу, инструкцию использования данного справочника, в Содержание и Указатель.
Совет №24 из раздела Устранение неполадок - Администрирование и Интерфейс перемещен в раздел Устранение неполадок - Устройства и BSOD. На его место добавлен новый совет.
Исправленные найденные ошибки.
Изменено наименование некоторых советов.
Многие советы дополнены и обновлены.
Добавлено 12 новых советов.

Изменения в версии 3.78.

Добавлен новый раздел в сборник Твики Реестра - Общие.
В "Историю версий" добавлена дополнительная информация о порядке внесения изменений.
Исправленные найденные ошибки.
Некоторые советы дополнены.
Добавлено 11 новых советов.

Изменения в версии 3.67.

Некоторые советы дополнены.
Добавлено 9 новых советов.

Изменения в версии 3.58.

Некоторые советы дополнены.
Добавлено 13 новых советов.

Изменения в версии 3.45.

Изменен очень яркий фон текстового поля с желтого на более мягкий оливковый-зеленый.
Некоторые советы дополнены.
Изменено месторасположение советов и разделов
Добавлена Дополнительная информация в Инструкцию использования данного справочника.
Исправлены найденные ошибки.
Удален 1 совет.
Добавлено 29 новых советов.

Изменения в версии 3.17.

Переработана структура сборника, включая содержание и индекс
В разделе Твики Реестра созданы тематические подразделы.
Изменено наименование и месторасположение советов.
Многие советы переписаны и объединены с другими.
Дополнена инструкция использования данного справочника.
Заменены теги длинных цитат на теги текстового поля.
Обновлены ссылки на некоторые программы.
Заменены изображения в некоторых советах.
Заменен шрифт кнопки Показать/Скрыть.
Вид курсора при наведении на кнопку приобретает форму руки.
Оптимизирован код для уменьшения размера сборника
Исправлены найденные ошибки.
Добавлено 28 новых советов.

Изменения в версии 2.90.

Исправлены ошибки в html-коде и в индексе.
Некоторые советы обновлены.
Добавлено 10 новых советов.

Изменения в версии 2.80.

В раздел Интерфейс добавлены 2 подраздела: "Внешний вид" и "Взаимодействие"
Исправлены найденные ошибки
Изменено наименование и/или месторасположение некоторых советов.
Некоторые советы дополнены.
Добавлено 15 новых советов.

Изменения в версии 2.65.

Исправлены найденные ошибки
Изменено месторасположение некоторых советов.
Некоторые советы обновлены.
Добавлено 10 новых советов.

Изменения в версии 2.55.

Исправлены найденные ошибки.
Изменено наименование и/или месторасположение некоторых советов.
Некоторые советы дополнены или переписаны заново.
Добавлено 12 новых советов.
В том числе, переписан заново совет из раздела Тонкие настройки: 8. Использование всей оперативной памяти в 32-битных Windows.

Изменения в версии 2.43.

Подраздел Интерфейс и загрузка из раздела Устранение неполадок переименован в Администрирование и Интерфейс.
Изменено месторасположение некоторых советов.
Многие советы дополнены и/или переписаны заново.
Исправлены найденные ошибки
Добавлен 21 новый совет.

Изменения в версии 2.22.

Исправлены незначительные ошибки.
Некоторые советы дополнены и переписаны заново.
Добавлено 10 новых советов.

Изменения в версии 2.12.

Исправлена ошибка дублирования неотображенных советов в коде.
Часть советов дополнена.
Добавлено 4 новых совета.

Изменения в версии 2.08.

Исправлен порядок в Индексе.
Добавлено 4 новых совета.
Удален 1 совет.

Изменения в версии 2.05.

Переработана структура сборника.
Советы из раздела "Устранение неполадок" рассортированы на подразделы.
Советы из "Твики реестра - Восстановление" перемещены в подразделы "Устранение неполадок".
Для удобочитаемости переход к странице подраздела, заменен на переход к якорю внутри страницы раздела.
Некоторые советы переименованы и обновлены.
Информация об изображениях и ссылки на них изменены в соответствии с новой структурой сборника.
Добавлено 3 новых совета.

Изменения в версии 2.02.1.

Исправлена ошибка ссылок и нумерации нескольких советов в Содержании и Указателе.

Изменения в версии 2.02.

Добавлен эффект прокручивания изображений колесом мыши(курсор при прокручивании должен быть на изображении)
Некоторые советы обновлены.
Добавлено 12 новых советов.

Изменения в версии 1.90.

Удалено несколько советов.
Некоторые советы обновлены.
Добавлено 16 новых советов.
Исправлены незначительные ошибки.

Изменения в версии 1.77.

Многие советы обновлены и переписаны заново
Добавлен новый раздел Виртуализация, поэтому переработана структура сборника
Обновлены ссылки на некоторые программы
Произведен точный перерасчет количества советов.
Добавлено 28 новых советов

Изменения в версии 1.49.

Переработан индекс сборника, что позволяет осуществить более точный поиск, через вкладку Указатель или вкладку Поиск
Исправлены грамматические, орфографические и синтаксические ошибки
Обновлены несколько советов
Добавлено 9 советов

Изменения в версии 1.40.

Добавлен новый раздел Твики Реестра с подразделами, поэтому переработана структура сборника
Многие советы заменены или обновлены
Исправлена ошибка, при которой внешние ссылки указанные на отдельных страницах некоторых советов, открывались в самой справке. Теперь они открываются в новом окне интернет браузера.
Добавлен 1 совет

Изменения в версии 1.39.

Исправлены грамматические, орфографические и синтаксические ошибки
Добавлен 1 совет

Изменения в версии 1.38.

Обновлены ссылки на версии программ.
Исправлена ссылка на изображение в одном из советов
Добавлен 1 совет

Изменения в версии 1.37.8.

Исправлены грамматические, орфографические и синтаксические ошибки
Исправлены ссылки на некоторые страницы и изображения
Добавлен 1 совет

Изменения в версии 1.37.

Исправлены ошибки распознавания кодировки на некоторых страницах
Многие советы заменены или обновлены
Если в совете более одного изображения, то они сгруппированны в галерею
Добавлено 8 советов

Изменения в версии 1.29.

Добавлена функция предпросмотра для изображений(увеличение по клику) в общем списке и в страницах разделов
Добавлена История версий
Добавлено 4 совета

Изменения в версии 1.25.1.-1.25.3.

Исправлены грамматические и синтаксические ошибки

Изменения в версии 1.25.

Исправлены грамматические и синтаксические ошибки
Заменены некоторые ссылки
Добавлен 1 совет

Изменения в версии 1.24.

Переписан исходный код страниц
Улучшена (упрощена) навигация в сборнике
Советы сгруппированы по темам (разделам)
Спойлерам добавлен эффект слайда
Спойлеры оставлены только в общем списке и в списках разделов
Убраны спойлеры в отдельных страницах для каждого совета
Добавлены меняющиеся надписи на кнопках.
Исправлены старые и добавлены новые советы (14 штук)

Изменения в версии 1.10.

Исправлена невозможность выделения в общем списке после 49 совета
Исправлена невозможность выделения в 49 совете
Заменены ссылки на оригинальные скрипты
Добавлено принудительное определение кодировки как windows-1251
Добавлено 2 новых совета

Версия 1.08.

Первая версия

Перейти на Стартовую страницу.
Перейти к началу Общего списка советов.


Инструкция использования данного справочника

Для полноценной работы со сборником, рекомендуется развернуть его на полный экран.

Открытие раздела или совета.

Общий список советов - страница, на которой содержится полный список советов, находящихся во всех разделах.
Страницы разделов - страницы, на которых содержатся сгрупированные по темам советы и их содержимое, спрятанное под спойлеры.

Чтобы развернуть определенный раздел в содержании сборника, для отображения входящих в него советов и/или подразделов, нажмите значок плюс.
Чтобы свернуть определенный раздел в содержании сборника, для скрытия входящих в него советов и/или подразделов, нажмите значок минус.

Чтобы открыть отдельную страницу необходимого Вам совета:

1) Нажмите на наименование совета слева, в содержании сборника.
2) Нажмите на наименование совета в общем списке советов.
3) Нажмите на наименование совета на странице раздела, к которому относится выбранный Вами совет.

Чтобы перейти в необходимый Вам раздел:

1) Нажмите на наименование раздела слева, в содержании сборника.
2) Нажмите на наименование раздела в общем списке советов.
3) Нажмите на ссылку, находящуюся в конце текста совета, относящегося к данному разделу.

Чтобы прочитать совет на странице раздела, нажмите на кнопку "Показать".
Произойдет открытие спойлера и на текущей странице под названием совета отобразится его содержимое. Нажатие на кнопку "Скрыть" приведет к закрытию спойлера.

Здесь расположен пример текста, чтобы Вам было понятно, как работает кнопка Показать/Скрыть.

Принципы работы с изображениями в сборнике.

1) При нажатии на миниобраз изображения, оно увеличится.
2) Чтобы переместить развернутое изображение, нажмите левой кнопкой мыши в той части изображения, где курсор имеет следующий вид [image] и передвиньте изображение в сторону, а затем отпустите кнопку мыши.

3) Чтобы закрыть изображение нажмите на значок или за пределами изображения.

Если в совете несколько изображений, то чтобы перейти к следующему изображению:

1) Нажмите на правую часть изображения.
2) Прокрутите колесико мыши вниз.
3) Нажмите на значок .

Если в совете несколько изображений, то чтобы перейти к предыдущему изображению:

1) Нажмите на левую часть изображения
2) Прокрутите колесико мыши вверх.
3) Нажмите на значок .

Чтобы начать показ изображений в режиме слайдов нажмите .

Чтобы остановить показ изображений в режиме слайдов нажмите .

Если исходный размер изображения превышает размер области окна, то чтобы развернуть отображаемое изображение до его исходных размеров нажмите .
Чтобы свернуть развернутое изображение обратно нажмите .

Принципы работы с текстовым полем.

1) Если текст, который Вам необходимо добавить в reg-файл, bat-файл, cmd-файл или другой файл имеет большое количество строк, то при чтении совета на странице раздела для компактности отображаемой информации текстовое поле будет иметь полосы прокрутки. Используйте их для перемещение вправо или вниз текста. Также Вы можете воспользоваться колесиком мышки.

Чтобы полностью увидеть отображенный текст, без вертикальной полосы прокрутки откройте отдельную страницу совета.

2) Для выделения, копирования и вставки всего текста из текстового поля (идентичное отображенному выше) сделайте следующее:
2.1) Нажмите правой кнопкой мыши в любом месте текстового поля и выберите пункт Выделить все
2.2) Щелкните правой кнопкой мыши на выделенном тексте и выберите пункт Копировать (текст будет скопирован в буфер обмена)
2.3) Щелкните правой кнопкой мыши в окне текстового редактора и выберите пункт Вставить.

Работа со специальной оболочкой для таблиц.

1) Кнопка "Показать / Скрыть столбцы" позволяет Вам отобразить или спрятать необходимые столбцы.
Для осуществления данных действий установите или снимите флажок напротив названия столбца.
Для закрытия списка выбора столбцов, щелкните либо в любом месте затемненного прозрачного слоя, либо на саму кнопку "Показать / Скрыть столбцы".
2) Для выделения отдельной строки щелкните на ней левой кнопкой мыши.
Кнопка "Выделить все" - выделяет все строки в таблице.
Кнопка Снять выделение - снимает все установленные выделения строк.
3) Для поиска необходимых Вам данных, введите их в текстовое поле и нажмите кнопку "Поиск"
4) Для сортировки строк таблицы, выберите столбец, относительно данных которого будет производит© сортировка и щелкните на его верхнем заголовоке.
Для сортировки таблицы, используя несколько столбцов, удерживая нажатой клавишу ⇑ Shift - щелкните по заголовкам столбцов.
5) Для выбора числа одновременно отображаемых строк выберите из ниспадающего меню, необходимое Вам значение.
При выборе слова Все - отобразятся все строки таблицы.
6) Переход по страницам таблицы осуществляется либо нажатием на номер страницы, либо на кнопки (Первая, Предыдущая, Следующая, Последняя) указыващие направление.

Правила поиска необходимой информации в справочнике.

Если Вам необходимо найти конкретный совет и Вы знаете с какого слова или фразы он начинается, то для его поиска:

1) Перейдите на вкладку Указатель, находящуюся рядом с вкладкой Содержание.
2) Введите ключевое слово или фразу для поиска и нажмите кнопку Вывести.

Если Вам необходимо найти совет, в котором есть искомое слово или фраза, то для его поиска:

1) Перейдите на вкладку Поиск, находящуюся за вкладкой Содержание.
2) Введите ключевое слово или фразу для поиска и нажмите кнопку Разделы.
3) В списке найденных советов, выберите необходимый Вам совет и нажмите кнопку Показать.

Добавление часто используемого совета в список Избранное.

Если Вам необходимо добавить часто используемый совет в Избранное, то для его добавления:

1) Откройте через Содержание, Указатель или Поиск совет, который Вы желаете добавить в Избранное.
2) Перейдите на вкладку Избранное, находящуюся за вкладкой Поиск.
3) Нажмите кнопку Добавить

Дополнительная информация.

При чтении большинства советов следует учитывать, особенности настроек системы, используемой автором сборника.

1) Система работает под управлением встроенной учетной записи администратора.
(Смотрите 11. Включение встроенной учетной записи администратора.)

2) Контроль учетных записей отключен.
(Панель управления → Учетные записи пользователей → Изменение параметров контроля учетных записей)

3) В окне Настройка меню "Пуск" (правой кнопкой мыши на кнопку Пуск → Свойства → Настроить) изменены настройки:

3.1) Переключатель Администрирование установлен в значение Отображать в меню "Все программы" и "Пуск".
3.2) Переключатель Панель управления установлен в значение Отображать как меню.
3.3) Установлен флажок Команда "Выполнить".

4) Параметры папок настроены следующим образом:

В разделе Щелчки мыши переключатель установлен в значение:
Открывать одним щелчком, выделять указателем → Подчеркивать подписи значков при наведении.

В разделе Область переходов установлены оба флажка Показать все папки и Автоматически разворачивать до текущей папки.

5) В ниспадающем меню Просмотр на "Панели управления" выбрано значение Крупные значки.

Перейти на Стартовую страницу.


Общий список советов.

Установка, Обновления, Языки.

1. Добавление вручную нового устройства (драйвера).

2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

3. Определение неизвестного устройства в Диспетчере устройств.

4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

5. Установка Windows 7 с USB флеш-накопитЈ (флешки).

6. Создание DVD или USB флеш-диска для установки Windows в режиме EFI (UEFI).

7. Интегрирование языковых пакетов и обновлений в дистрибутив Windows 7.

8. Добавление и использование новых языков интерфейса в Windows.

9. Автоматическое введение ключа при инсталляции Windows.

10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

11. Где можно скачать последние обновления для Windows 7?

12. Повышение оценки производительности жесткого диска.

13. Автоматическая установка OEM-информации.

14. Автоматическая установка OEM-Logo.

15. Установка локальных наборов тем и настроек, а также пакетов обновления, предоставленных в виде CAB-файлов.

16. Автоматическая установка обновлений Windows.

17. Отключение сообщения "Эта программа, возможно, установлена неправильно".

18. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1.

19. Проверка установленных версий .NET Framework и установка отсутствующих.

20. Быстрый запуск командной строки из среды предустановки Windows.

21. Интегрирование Сервисного Пакета в установочный ISO-образ Windows 7.

22. Создание установочного образа Windows с двумя видами разрядности (32-бит и 64-бит) в одном iso-образе.

23. Прямые ссылки с официального сайта Microsoft для скачивания сервисного Пакета обновлений 1 (SP1) для Windows 7.

24. Изменение языка интерфейса в редакциях Windows 7 Starter/Home Basic/Home Premium/Professional.

25. Установка Windows 7 без создания учетной записи и имени компьютера, а также добавление драйверов в систему на этапе установки Windows.

26. Добавление и удаление сведений об играх имеющихся в системе, в папку Обозреватель игр (Игры).

27. Интегрирование MSDaRT в установочный ISO-образ Windows 7.

28. Список буквенных и числовых обозначений идентификаторов языка.

Настройки.

1. Конфигурация служб Windows 7 по умолчанию, способы их запуска и отключения.

2. Быстрое отображение (скрытие) значков в области уведомлений.

3. Изменение параметров загрузки в Windows 7 (msconfig вместо boot.ini).

4. Принудительная установка числа ядер, используемых при загрузке.

5. Установка временной зоны из командной строки в Windows 7.

6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

7. Отключение (включение) неиспользуемых компонентов Windows.

8. Отмена (изменение) ассоциирования типов файлов с определенными программами.

9. Отключение всплывающих подсказок.

10. Изменение функции кнопки питания на корпусе Вашего компьютера.

11. Быстрый переход к часто используемой папке.

12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

13. Установка пользовательского разрешения экрана.

14. Создание диска восстановления системы и загрузка с него.

15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

17. Способы доступа к элементам Панели управления.

18. Отключение залипания клавиш, озвучивания данного действия и озвучивания нажатия клавиши CAPS LOCK, NUM LOCK, или SCROLL LOCK.

19. Добавление своей программы в утилиту msconfig (Конфигурация системы).

20. Настройка параметров индексирования для ускорения выполнения поиска в системе.

21. Выполнение задачи (запуск программы) после выхода из спящего режима или гибернации.

22. Автоматическая очистка журнала недавно открывавшихся документов при выходе из системы.

23. Отключение автоматической загрузки процесса sidebar.exe (Гаджеты рабочего стола Windows).

24. Удаление компонента Windows Media Center или отключение его автозапуска.

25. Отключение индексирования файлов для ускорения работы Windows.

26. Изменение времени затрачиваемого на автоматический выбор пункта из списка загрузок.

27. Просмотр списка устройств, которым разрешено выводить компьютер из ждущего режима, а также разрешение и запрет выполнения данного действия.

28. Изменение количества используемых ядер процессора и приоритета для запущенного приложения.

Администрирование.

1. Получение полного доступа к файлу или папке.

2. Запуск командной строки от имени (с правами) администратора.

3. Изменение прав доступа и владельца для файла (папки), используя Проводник или командную строку.

4. Автоматический вход в систему и отключение экрана пользователей при запуске.

5. Отключение или изменение параметров контроля учетных записей (UAC).

6. Быстрый запуск программы с правами администратора.

7. Убирание запрещающего значка с папки.

8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

9. Переименование учетных записей и перемещение их папок профиля.

10. Установка заданных атрибутов для всех файлов с определенным расширением в указанной папке и ее подпапках.

11. Включение встроенной учетной записи администратора.

12. Изменение фонового рисунка в экране авторизации пользователей (экране приветствия).

13. Установка службы TrustedInstaller в качестве владельца папки или файла.

14. Изменение пароля или новой учетной записи администратора, используя средства восстановления системы.

15. Определение процесса которому принадлежит текущее окно.

16. Удаление данных о серийном номере из системы для предотвращения его хищения.

17. Создание точки восстановления системы при старте системы без использования апплета "Защита системы".

18. Запуск программ с правами администратора без выдачи уведомлений Контроля Учетных Записей.

19. Запрещение запуска Диспетчера задач.

20. Добавление своей иконки в список рисунков учетных записей.

21. Отключение кэширования экскизов.

22. Поиск приложений автоматически загружающихся при запуске компьютера.

23. Отслеживание приложений, создающих неизвестные файлы на диске.

24. Создание, отключение и удаление учетной записи пользователя.

25. Запуск приложения от имени другого пользователя.

26. Переименование папки локальной учетной записи пользователя.

27. Ввод пароля в окне смены пользователей при отсутствии необходимой раскладки клавиатуры.

28. Ограничение разрешенных действий для пользователей, имеющих временный доступ к компьютеру.

29. Защита доступа к компьютеру с использованием USB Ключа, хранящегося на флеш накопителе.

30. Отслеживание изменений на диске и в реестре, путем сравнения снимков системы.

31. Добавление пункта "Запуск от имени администратора" в контекстное меню для VBS-скриптов.

32. Отключение контроля учетных записей (UAC) только для администраторов.

33. Запрещение закрепления программ в меню Пуск и на панели задач.

34. Добавление оснастки "Редактор локальной групповой политики" в папку Администрирование или в Панель управления.

35. Удаление точки восстановления системы, а также извлечение из нее необходимого Вам файла или папки.

36. Создание и использование флеш-диска для сброса пароля своей учетной записи.

37. Установка оснасток "Редактор локальной групповой политики" (облегченная версия) и "Локальная политика безопасности" (полная версия) в редакциях Windows 7 Starter/Home Basic/Home Premium/Professional.

38. Включение шифрования файла подкачки.

Интерфейс.

Интерфейс - Отображение.

1. Изменение размера иконки на рабочем столе.

2. Управление положением и размерами окон с помощью клавиатуры.

3. Где скачать и как установить дополнительные темы для Windows 7?

4. Изменение ширины и высоты меню Пуск.

5. Включение/отключение прозрачного заголовка окна вместо матового.

6. Принудительное включение отключенного эффекта прозрачности - Aero Glass.

7. Улучшение качества передачи цветов монитором.

8. Включение и отключение Области переходов.

9. Расширение функциональности часов в трее или изменение их вида.

10. Добавление дополнительных операций к окнам.

11. Добавление командной строке эффекта прозрачности - Aero Glass.

12. Определение цветового кода любой точки экрана на мониторе.

13. Создание темы оформления с использованием RSS-обоев.

14. Изменение фонового рисунка рабочего стола в Windows 7 Starter.

15. Изменение размера окон предпросмотра на панели задач.

16. Добавление в контекстное меню рабочего стола пункта "Имя и расположение текущего файла фона".

17. Замена фона папки в Проводнике.

18. Сохранение созданной Вами схемы указателей мыши в файл, для дальнейшего использования.

19. Добавление отображения эскизов и детальной информации для файлов .mkv в Проводнике Windows.

20. Использование флажков для выделения (выбора) файлов и папок.

21. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

22. Закрепление конкретной папки на панели задач Windows 7.

23. Настройка списка элементов, отображаемых в диалоговом окне открытия и сохранения файлов Windows.

24. Отображение часто используемых команд для диалогового окна "Выполнить" в меню Пуск.

25. Размещение любого окна Windows поверх других.

26. Изменение загрузочного экрана (включая шарики и текст) в Windows 7 на любой другой.

27. Включение всех Аэро эффектов, поддержки тем Аэро и активация панели Персонализация в Windows Начальная и Windows Домашняя Базовая.

28. Включение/отключение отображения системных значков (Компьютер, Панель Управления и Корзина) на рабочем столе.

29. Изменение цвета Aero в случайном порядке или используя заданный список цветов.

30. Отключение горизонтального смещения при выборе файла в Проводнике.

31. Отключение и включение отображения эскизов из контекстного меню.

32. Добавление пункта "Показать/Скрыть скрытые файлы и папки" в контекстное меню.

33. Добавление отображения полного пути к папке в строку заголовка окна.

34. Быстрое удаление всех закрепленных значков из панели задач.

35. Установка Windows DreamScene для добавления возможности использования *.MPG или *.WMV видеофайлов в качестве фона рабочего стола.

36. Очистка списка Последние для программы прикрепленной на панели задач.

37. Изменение иконок для устройств в папке "Устройства и принтеры".

38. Местонахождение большинства значков (иконок) в Windows.

39. Инвертирование и замена цветов в одноцветном файле изображения c прозрачным фоном.

40. Создание и редактирование BMP-изображений с 32-битной глубиной цвета.

41. Изменение фонового изображения боковой панели Проводника.

42. Замена или удаление кнопки Пуск на панели задач.

43. Переключение тем оформления Windows используя командную строку.

44. Редактирование темы или файла стиля оформления Windows для изменения внешнего вида различных элементов системы.

45. Замена иконки яў определенного типа файла.

Интерфейс - Взаимодействие.

1. Открытие диспетчера задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту.

2. Использование средней кнопки мыши при работе с панелью задач.

3. Перезапуск Проводника или рабочего стола.

4. Запуск команд Windows Shell, используя названия и {GUID} объектов.

5. Создание ярлыка для функции Windows Flip 3D (переключение между окнами под углом).

6. Использование переменных окружения для быстрого перехода к системным папкам.

7. Установка положения курсора в диалоговом окне на кнопке, выбираемой по умолчанию.

8. Уточнение даты и времени загрузки системы.

9. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

10. Закрытие всех запущенных приложений одним кликом.

11. Открытие командной строки из конкретной папки.

12. Просмотр файлов .nfo и .diz с ASCII графикой.

13. Использование возможности Windows Flip 3D в Windows 7 Домашняя базовая и Начальная.

14. Запуск программы с параметрами командной строки из контекстного меню Проводника.

15. Расчет хеш-суммы для любого файла, а также открытие .sfv и .md5 файлов, используемых для контроля целостности файлов.

16. Быстрая вставка путей к файлу или папке в окно команд Windows 7.

17. Запуск командной строки из "Диспетчера задач" без ввода команды CMD.

18. Изменение действий осуществляемых системой при использовании щелчков мыши.

19. Команды для распаковки *.cab, *.exe, *.msi, *.msp и *.msu файлов от Microsoft.

20. Быстрое открытие ещё одной копии приложения.

21. Cохранение настроек интерфейса в Windows.

22. Переключение с активного окна на неактивное, путем наведении на него курсора.

23. Создание ярлыка для очистки буфера обмена.

24. Обнаружение указателя мыши на рабочем столе.

25. Быстрый постоянный доступ к собственной папке из меню Пуск.

26. Добавление, изменение и удаление пунктов в контекстном меню.

27. Добавление пункта "Диспетчер устройств" в контекстное меню Компьютер на рабочем столе.

28. Добавление вкладки Icons в Свойства файла.

29. Добавление ярлыков программ в список "Избранное" Проводника.

30. Открытие одновременно двух рядом расположенных копий Проводника.

31. Закрепление программы в меню Пуск или на панели задач, используя скрипт.

32. Открытие папок Проводника в новых вкладках, как в интернет браузере.

33. Создание ярлыка для быстрого доступа к настройкам Визуальные эффекты.

34. Сохранение часто используемых условий поиска в Проводнике.

35. Автоматическое закрытие окна команд сразу после запуска программы с помощью CMD-файла.

36. Установка клавиши Backspace в Проводнике для перехода в папку, расположенную на уровень выше.

37. Запуск командных файлов (.bat, .cmd) без отображения окна команд.

38. Одновременное переименование большого количества файлов и папок.

39. Активация функции прокрутки у неактивного окна или невыбранной части активного окна.

Сети (Интернет и Локальная).

1. Настройка локальной сети между компьютерами.

2. Создание собственной Wi-Fi точки доступа без использования роутера.

3. Объединение или удаление сетевых размещений (подключений).

4. Автоматическое подключение к ADSL-интернету при запуске Windows.

5. Автоматическое VPN-подключение к интернет при запуске Windows.

6. Отключение запроса пароля при использовании папки общего доступа.

7. Просмотр исходного кода любой страницы в интернете.

8. Использование swf-файлов взаимодействующих с удаленным приложением, на локальном компьютере.

9. Сохранение интернет соединения при переключении между пользователями.

10. Перемещение HOST, LMHOST и других файлов из Windows\System32\drivers\etc в другое место.

11. Поиск на веб-сайтах из Проводника (Windows Explorer).

12. Смена динамического IP-адреса, для обхода времени ожидания на файлообменниках.

13. Включение и настройка общего доступа к файлам и папкам.

14. Автоматическая загрузка последних версий драйверов и реалистичных значков для подключенных устройств.

15. Вычисление сайтов посещаемых пользователем в приватном режиме просмотра браузера.

16. Месторасположение кэша браузера и его просмотр.

17. Отключение автоматической отправки сведений на сервера корпорации Microsoft, собранных программой улучшения качества программного обеспечения.

18. Добавление индикатора сетевой активности на панель задач.

19. Создание ярлыка для запуска Internet Explorer в режиме приватного просмотра.

20. Создание ярлыка в папке Компьютер для просмотра часто используемого ftp как одного из дисков.

21. Быстрая очистка истории обзора Internet Explorer при помощи специально созданного ярлыка.

22. Поиск необходимого файла на крупнейших файлобменниках.

23. Создание url-файла, для перехода на указанную страницу в интернете.

24. Восстановление содержимого файла hosts по умолчанию.

25. Одновременное использование сайтов (скриптов) из локальной сети и из интернета, при включенном VPN-подключении к интернету.

26. Открытие сайта из другой страны не прописывая в браузере прокси-сервера.

27. Включение log-файла журнала брандмауэра Windows.

28. Удаление из Internet Explorer плагина, у которых отсутствует или заблокирована кнопка Удалить.

29. Закрепление вебсайта на панели задач, а также отключение и восстановление данной возможности.

30. Установка вручную плагина VLC Web Plugin для программы Mozilla Firefox.

31. Быстрый доступ к редактированию файла Hosts.

32. Отключение использования вкладок в Internet Explorer.

33. Переустановка браузера Internet Explorer.

34. Открытие сайтов использующих IPv6 протокол без внесения изменения в настройки системы.

35. Просмотр интернет-страницы (html-документа) в предыдущей версии Internet Explorer из текущей версии.

36. Сохранение видео с интернета на компьютер.

37. Смена поиска по умолчанию в Mozilla Firefox.

38. Добавление ссылки Поиск в Интернете при использовании поиска в меню Пуск.

39. Обмен файлами между компьютерами без создания локальной сети и использования облачных хранилищ данных.

40. Подключение и настройка общего доступа к сетевому принтеру.

Тонкие настройки.

1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

2. Удаление значка "Центр поддержки" из области уведомлений на панели задач.

3. Удаление текста под значком ярлыка или файла.

4. Создание (восстановление) панели быстрого запуска (Quick Launch).

5. Разблокирование файла используемого какой-либо программой для действий с ним.

6. Удаление надписей из правого нижнего угла рабочего стола.

7. Смена названия операционной системы c Максимальная на Ultimate.

8. Использование всей оперативной памяти в 32-битных Windows.

9. Изменение папки открываемой по умолчанию в Проводнике.

10. Добавление или Ёмой запуск папки Все задачи (Расширенная Панель Управления).

11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.

12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.

14. Перемещение системных папок и изменение их путей.

15. Скрытие выбранных дисков из окна папки "Компьютер".

16. Добавление или удаление элементов из контекстного меню "Отправить".

17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

18. Замена элементов в диалоговом окне открытия/сохранения файлов.

19. Изменение настроек режима самовосстановления для повышения производительности Windows.

20. Изменение стандартной мелодии запуска Windows 7.

21. Отключение журналирования для ускорения работы диска и освобождения дискового пространства.

22. Распределение файла подкачки между несколькими жесткими дисками яў увеличения производительности системы.

23. Регистрация необходимых и выгрузка из памяти неиспользуемых библиотек (dll-файлов).

24. Обход ограничения времени доступа к компьютеру при включенной функции Родительский контроль.

25. Использование файлов autorun.inf и desktop.ini для задания собственных значков на съемных накопитЈх.

26. Сохранение настроенных параметров групповой политики для последующего использования.

27. Удаление с панели задач кнопки "Сверуть все окна", показывающей рабочий стол.

28. Использование командной строки яў управления файлом подкачки pagefile.sys.

29. Разблокировка курсора мыши при достижении края экрана.

30. Сохранение изображения в программе Ножницы (Snipping Tool) с расширением написанным по умолчанию маленькими буквами.

31. Отключение и включение Панели задач.

32. Изменение сообщений на экране пользователей при входе или выходе из системы (Welcome, Shutting down, Logging off, Please wait).

33. Уменьшение места занимаемого на диске папкой WinSxS.

Виртуализация.

1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

3. Установка и загрузка Windows 7 из VHD-файла.

4. Установка Windows 7 на виртуальный диск в VHD-файл.

5. Конвертирование тома жесткого диска в VHD-файл.

6. Конвертирование DVD-образа Windows 7 в VHD-файл.

7. Включение Aero Glass в Windows на Virtual PC.

8. Установка Windows 7 в виртуальную машину VirtualBox.

9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.

10. Установка Windows 7 в виртуальную машину VMware Workstation.

11. Создание общей папки яў виртуальной и основной Windows в VirtualBox.

12. Создание общей папки яў виртуальной и основной Windows в Microsoft Virtual PC.

13. Создание общей папки яў виртуальной и основной Windows в VMware Workstation.

14. Запуск старых 16-битных приложений и DOS-игр в Windows, используя программу DosBox.

15. Отключение синхронизации времени с хостовой системой в виртуальной машине VirtualBox.

16. Отключение синхронизации времени с хостовой системой в виртуальной машине Microsoft Virtual PC.

17. Отключение синхронизации времени с хостовой системой в виртуальной машине VMware Workstation.

18. Открытие виртуальных образов дисков (*.mdx, *.mds/*.mdf, *.iso, *.nrg), монтирование их в виртуальные приводы.

19. Настройка параметров для использования интернета в VMware Workstation, при наличии VPN-соединения.

20. Проведение тестирования программ в виртуальной системе.

Портабелизация.

1. Принципы работы Portable-программы и подготовка компьютера к её созданию.

2. Создание Portable-версии приложения в программе Cameyo.

3. Создание Portable-версии приложения в программе Spoon Virtual Application Studio.

4. Создание Portable-версии приложения в программе VMware ThinApp.

5. Создание Portable-версии приложения, используя PortableApps.com Launcher и PortableApps.com Installer.

6. Создание Portable-версии приложения, используя Portable App Creator и PortableApps.com Installer.

7. Создание Portable-версии приложения в программе P-Apps.

8. Создание Portable-версии приложения в программе Evalaze.

9. Создание Portable-версии приложения в программе Enigma Virtual Box.

10. Создание Portable-версии приложения, используя Universal Extractor и WinRAR.

11. Создание Portable-версии приложения, используя Universal Extractor, UPX и Bat_To_Exe_Converter.

Твики Реестра.

Твики Реестра - Общие.

1. Запуск программы "Редактор реестра", создание и применение reg-файла.

2. Создание и переименование раздела или параметра, а также изменение параметра в редакторе реестра.

3. Аббревиатуры используемые для обозначения веток реестра.

4. Быстрый переход в необходимый раздел реестра.

5. Отключение вывода диалогового окна при применении reg-файла.

6. Значения разделов реестра ControlSet001, ControlSet002 и CurrentControlSet.

7. Создание и удаление разделов или параметров реестра используя reg-файл.

8. Создание и удаление разделов или параметров реестра используя командную строку.

9. Добавление возможности создания файла реестра (reg-файла) из контекстного меню.

10. Альтернативные программы используемые для редактирования реестра.

11. Изменение параметров реестра, используя установочный диск.

Твики Реестра - Администрирование и Безопасность.

1. Получение полного доступа к разделу реестра, используя программу regedit или командную строку.

2. Запуск редактора реестра от имени пользователя Система, для удаления и редактирования заблокированных разделов.

3. Запуск редактора реестра от имени пользователя TrustedInstaller, для удаления и редактирования заблокированных разделов.

4. Запрещение создания и изменения значения параметров в указанном разделе реестра.

5. Отключение проверки подписи для загруженных программ.

6. Удаление устаревших значков из области уведомления панели задач.

7. Очистка истории расположений фонов рабочего стола в Windows 7.

8. Удаление папки Общие Документы и пользовательского профиля Общие.

9. Отключение и включение контекстного меню в Проводнике, на рабочем столе и на панели задач.

10. Удаление пункта меню Файл из Проводника.

11. Запрещение запуска программ.

12. Удаление записей из истории диалогового окна "Выполнить".

13. Удаление и восстановление предупреждающего окна о внесении изменений в msconfig (Конфигурация системы).

14. Удаление лишних записей из утилиты msconfig (Конфигурация системы).

15. Отключение напоминания о необходимости перезагрузки после установки обновлений.

16. Запуск нескольких копий редактора реестра одновременно.

17. Дополнительные параметры для настройки функций "Защита системы" и "Восстановление системы".

18. Запрещение запуска командной строки и обработки пакетных файлов (bat, cmd).

19. Удаление сведений об использованном USB-флэш диске.

20. Удаление программ в Безопасном Режиме, использующих установщик Windows Installer.

21. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

22. Отключение отображения последних открывавшихся документов в меню Пуск.

23. Запрещение добавления программ в разделы реестра отвечающие за автозагрузку.

24. Открытие окна команд с правами администратора из контекстного меню Проводника.

25. Сохранение и восстановление содержимого раздела реестра, а также его владельца и разрешений.

26. Добавление пунктов "Запуск от имени администратора" и "Извлечь все" в контекстное меню MSI файлов.

27. Запрещение отображения окна "Программы и компоненты" и его элементов.

28. Отключение или включение отображения истории запросов в строке поиска Проводника.

29. Удаление и восстановление пунктов меню из диалогового окна Безопасность Windows (Ctrl+Alt+Del).

30. Добавление в Панель управления оснастки "Учетная запись опытного пользователя" (netplwiz), для расширенного управления учетными записями.

31. Настройка параметров, отвечающих за информацию, отображаемую в оснастке Программы и компоненты, а также за удаление установленных программ.

32. Отключение запоминания последнего пользователя и включение запроса имени пользователя и пароля на экране пользователей.

33. Удаление или добавление из контекстного меню исполняемых файлов пункта Запуск от имени другого пользователя.

34. Включения требования ввода пароля администратора для отключения контроля учетных записей при необходимости запуска программы с повышенными правами.

35. Отключение возможности записи на компакт-диск.

36. Добавление собственной программы в список "Программы по умолчанию".

Твики Реестра - Настройки и Интерфейс.

1. Включение скрытых настроек электропитания.

2. Добавление классического всплывающего меню Программы (Programs) в меню Пуск.

3. Добавление функции произвольного выравнивания иконок в Проводнике.

4. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

5. Настройка диалога переключения между окнами ("Alt"+"Tab").

6. Настройка диалогового окна "Выбор программы".

7. Включение окна выбора начальных параметров при запуске проигрывателя Windows Media.

8. Изменение действия по умолчанию при перетаскивании файлов между папками в Проводнике.

9. Удаление пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов.

10. Удаление и восстановление стрелок на ярлыках Windows.

11. Удаление папок из Рабочего стола в области переходов Проводника.

12. Отключение суффикса "-Ярлык" при создании новых ярлыков.

13. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

14. Отключение диалога "Не удалось открыть файл".

15. Максимально возможное отключение сглаживания шрифтов (ClearType) в Windows 7.

16. Изменение набора кнопок на панели Проводника Windows 7.

17. Изменение состава меню "Упорядочить" на панели Проводника Windows 7.

18. Изменение отображаемых по умолчанию свойств для файла в Проводнике.

19. Изменение используемых по умолчанию столбцов в Проводнике для папок, при выборе отображения в виде таблицы.

20. Изменение пунктов контекстного меню "Сортировка" используемых по умолчанию в Проводнике.

21. Запрещение подмены функции кнопки "Завершения работы" при необходимости обновления системы.

22. Постоянное отображение команд "Открыть окно команд" и "Копировать как путь" в контекстном меню Проводника.

23. Добавление произвольного системного ActiveX-элемента в Рабочий стол области переходов Проводника.

24. Изменение вида приглашения в командной строке.

25. Изменение языка интерфейса установленного по умолчанию (язык системы), для возможности его удаления или правильного определения программами.

26. Настройка вида, используемого по умолчанию для папок в Проводнике и в диалоговом окне "Открыть/Сохранить файл".

27. Удаление открываемых путей из истории в адресной строке Проводника.

28. Добавление отображения логотипа и сопутствующей информации.

29. Изменение режима работы полос прокрутки.

30. Включение отключенного диалога подтверждения удаления в аплете "Программы и компоненты".

31. Настройка анимации иконки пользователя в меню Пуск.

32. Изменение интервала автоматической синхронизации времени компьютера с сервером.

33. Удаление области уведомлений (System Tray) с панели задач.

34. Отключение всплывающего уведомления "Цветовая схема изменена на Windows 7 — упрощенный стиль".

35. Отключение и включение отображения эскизов панели задач.

36. Удаление и восстановление вкладок из окна Свойства файла.

37. Запрещение и разрешение изменения положения панели задач на экране.

38. Настройка мигания иконки фоновой программы на панели задач, требующей активизации.

39. Удаление и восстановление пункта Настроить папку из контекстного меню.

40. Удаление и восстановление пунктов Открыть в новом окне и Добавить в библиотеку из контекстного меню дисков и папок.

41. Удаление пункта "Следующее фоновое изображение рабочего стола" из контекстного меню рабочего стола.

42. Удаление и восстановление пункта Отправить в контекстном меню.

43. Удаление и восстановление пунктов из раздела Дополнительные параметры на вкладке Вид в диалоговом окне Параметры папок.

44. Удаление пункта SkyDrive Pro из контекстного меню.

45. Использование реестра для управления файлом подкачки pagefile.sys.

46. Замена мест расположения в диалоговых окнах "Открыть" и "Сохранить как" на собственные значения.

Твики Реестра - Дополнительная функциональность.

1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

2. Добавление пункта "Открыть в блокноте" в контекстное меню файлов.

3. Добавление системных ярлыков в папку Компьютер.

4. Добавление произвольной команды в контекстное меню рабочего стола.

5. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".

6. Добавление пункта "Удалить содержимое папки" в контекстное меню.

7. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

8. Добавление своего ярлыка папки или программы в папку Компьютер.

9. Добавление в контекстное меню DLL- или OCX-файлов пунктов "Регистрация" и "Отмена регистрации".

10. Увеличение кэша памяти яў вида папок.

11. Добавление опций "Выполнить", "Поиск" и "Очистить корзину" в контекстное меню рабочего стола.

12. Создание меню с ярлыками избранных приложений в контекстном меню рабочего стола.

13. Ускорение запуска Windows и выключения компьютера.

14. Ускорение анимации всплывающего меню в меню Пуск.

15. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

16. Настройка параметров всплывающих эскизов окон в панели задач.

17. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

18. Добавление кнопки запуска необходимой программы на панель Проводника Windows 7.

19. Добавление кнопки "Открыть в текстовом редакторе" на панель Проводника Windows 7.

20. Добавление кнопок "Копировать в папку" и "Переместить в папку" на панель Проводника Windows 7.

21. Добавление собственной папки в Рабочий стол области переходов Проводника.

22. Скрытие апплетов отображаемых в Панели управления.

23. Увеличение пространства, отведенного в NTFS для главной таблицы файлов.

24. Увеличение процессорного времени, выделяемого программе, работающей на переднем плане.

25. Отключение выгрузки драйверов режима ядра и системного кода режима ядра из оперативной памяти на диск.

26. Удаление пункта "Восстановить прежнюю версию" из контекстного меню Проводника.

27. Переименование Панели управления в области переходов и на рабочем столе.

28. Переименование папки Избранное в области переходов.

29. Переименование папки Сеть в области переходов.

30. Изменение иконки Панели управления.

31. Изменение иконок элементов в Панели управления при просмотре как Крупные значки/Мелкие значки.

32. Изменение иконок для элементов в меню Пуск.

33. Добавление подменю "Запустить с приоритетом" в контекстное меню exe-файлов.

34. Добавление подменю "Запустить на процессоре" в контекстное меню exe-файлов.

35. Добавление в контекстное меню BAT, CMD, LOG, REG, TXT, VBS файлов всплывающего меню Копировать в буфер обмена.

Удаление и добавление программ из списка в окне "Выбор программы" (Открыть с помощью).

37. Добавление каскадного меню "Сжатие до реального размера" в контекстное меню файлов и папок.

38. Добавление каскадных меню Панель управления, Администрирование, Стандартные, Служебные и Специальные возможности в контекстное меню рабочего стола.

39. Добавление пункта "Очистить корзину без подтверждения" в контекстное меню Корзины.

Твики Реестра - Устройства и Сети.

1. Автоматическое VPN-подключение к интернет при запуске Windows (реестр).

2. Конвертирование reg-файлов в *.inf формат из контекстного меню, с помощью утилиты.

3. Включение клавиш-индикаторов Num Lock, Caps Lock, Scroll Lock при загрузке.

4. Отмена автозапуска для носителей и устройств.

5. Уменьшение фрагментируемости больших файлов на диске.

6. Изменение состояния встроенного динамика персонального компьютера.

7. Переназначение гнезд звуковой карты Realtek используя реестр.

8. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

9. Удаление цифры при пересоздании адаптера сети в Диспетчере устройств.

10. Отключение или переназначение клавишы Caps Lock.

11. Отключение USB порта после Безопасного извлечения устройства.

12. Отключение сообщения: "Хотите выполнить проверку и исправление ошибок на ..." для съемных дисков.

13. Отключение проверки системой наличия подключения к Интернет используя функцию NCSI и изменение ее параметров.

14. Увеличение скорости передачи данных для USB-носителей.

15. Изменение иконки яў *.url файлов, при использовании браузера Internet Explorer по умолчанию.

16. Удаление и восстановление вкладок в оснастке Свойства обозревателя из Панели управления.

17. Удаление и восстановление возможности изменения масштаба в Internet Explorer.

18. Добавление в контекстное меню рабочего стола пункта "Безопасное извлечение устройства".

19. Настройка отображения букв дисков в папке Компьютер.

20. Настройка параметров, отвечающих за установку драйверов.

21. Удаление сведений о месторасположениях для поиска драйверов.

22. Изменение версии Interenet Explorer эмулируемой для CHM-файлов справки и других приложений.

Устранение неполадок.

Устранение неполадок - Администрирование и Интерфейс.

1. Общие рекомендации для устранения неполадок и восстановления работоспособности системы.

2. Использование оснастки «Просмотр событий» для выявления неполадок в работе Windows.

3. Решение проблемы с доступом к wim-файлу при работе с программой Dism.

4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

5. Причины перехода цветовой схемы на упрощенный стиль.

6. Выбор настроек во время установки яў предотвращения замены русских букв знаками вопросов.

7. Решение проблемы с неправильным отображением русских букв.

8. Запись последовательности действий пользователя для анализа их разработчиком.

9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

10. Восстановление загрузки Windows 7 без установочного диска.

11. Восстановление стандартного анимированного экрана загрузки Windows 7.

12. Восстановление значений реестра и асоциаций с программами по умолчанию для различных типов файлов.

13. Моргание игр в режиме OpenGL.

14. Исправление невозможности запуска службы Центра обеспечения безопасности.

15. Исправление отсутствия компонентов в окне "Включение или отключение компонентов Windows".

16. Исправление невозможности изменения настроек User Account Control (UAC).

17. Диагностика проблемы высокой загрузки процессора и частых обращений к жесткому диску при запуске или выключении Windows.

18. Устранение проблемы открытия папок в отдельном окне, при установленном положении переключателя "Открывать папки в одном и том же окне".

19. Удаление лишних пунктов из Диспетчера загрузки Windows.

20. Извлечение файлов Windows 7 из установочного DVD и замена ими поврежденных системных файлов.

21. Настройка периодичности создания точек восстановления системы.

22. Восстановление веток реестра из резервных копий службы System Restore в Windows 7.

23. Использование "чистой загрузки" для устранения неполадок в работе Windows.

24. Сброс пароля для учетной записи администратора.

25. Устранение неполадок с поиском и индексированием.

26. Исправление проблемы, когда автоматически не обновляется значок корзины, после ее очистки.

27. Исправление ошибки из журнала событий: "Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".

28. Перезагрузка в Безопасный Режим при отсутствии данного пункта в меню Диспетчера загрузки.

29. Исправление ошибки 4201, возникающей при попытке запуска службы Журнал событий Windows (Windows Event Log).

30. Способы исправления ошибок при работе с программой sysprep.

31. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

32. Восстановление фонового рисунка в экране авторизации пользователей (экране приветствия).

33. Получение информации о проблемах при запуске и при завершении работы Windows 7.

34. Решение проблем в работе компонента "Защита системы" и/или оснастки "Восстановление системы".

35. Исправление ошибок связанных с отсутствием папки Desktop в папках "C:\Windows\System32\config\systemprofile" и/или "C:\Windows\SysWOW64\config\systemprofile".

36. Исправление ошибки: Недостаточно места для создания файла для хранения файла теневой копии.

37. Решение проблем: "Консоль управления не может создать оснастку" и "MMC не удается инициализировать оснастку".

38. Решение проблемы при запуске Планировщика заданий: Задание <имя_задачи>: Образ задачи поврежден или изменен.

39. Изменение параметров отправки отчета при отказе работы программы.

40. Использование монитора ресурсов для уточнения цели ожидания приложением, которое не отвечает.

41. Исправление ошибки 0x80071A91 выдаваемой каким-либо из элементов Windows.

42. Исправление ошибки: "... не является внутренней или внешней командой исполняемой программой или пакетным файлом".

43. Решение проблемы с некорректной работой анимации или Диспетчера окон рабочего стола (dwm.exe).

44. Исправление ошибки "Не удалось открыть объект групповой политики на этом компьютере. Возможно, у вас недостаточно прав."

45. Исправление ошибки "Пространство имен "Microsoft.Policies.Sensors.WindowsLocationProvider" уже определено как целевое пространство имен для другого файла в хранилище".

Устранение неполадок - Рабочий стол, Проводник, Панель задач.

1. Исправление исчезновения панели быстрого запуска после перезагрузки.

2. Исправление сбоев возникающих при установке, обновлении или удалении программы с помощью установщика Windows (msiexec.exe).

3. Восстановление пункта "Выполнить" в меню "Пуск".

4. Убирание появляющейся в меню Пуск полоски, пропадающей при повторном открытии.

5. Восстановление ассоциации для *.cpl файлов.

6. Исправление вылета Проводника при нажатии правой кнопки мыши на файле или папке.

7. Восстановление исчезнувшей языковой панели.

8. Исправление ошибки, когда папки "Недавние места" и "Недавние документы" пустые.

9. Удаление появившейся на рабочем столе папки "Недавние места".

10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"

11. Исправление неполадок в работе гаджетов.

12. Восстановление функциональности пункта "Закрепить программу в панели задач".

13. Пользовательские папки отображаются обычными иконками.

14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

15. Восстановление поиска в Проводнике и в меню Пуск.

16. Исправление всплывающей подсказки оказывающейся за панелью задач Windows.

17. Решение проблемы пропадания значков в панели задач.

18. Удаление ярлыков на отсутствующие в системе элементы в папке "Недавние места".

19. При загрузке Windows автоматически открывается окно Проводника.

20. Восстановление запуска Exe-файлов в системе.

21. Исправление ошибки Проводника "Не удалось найти этот элемент" (Could not find this item).

22. Исправление появляющегося окна предупреждения системы безопасности "Неизвестный издатель", при открытии программы из меню Пуск.

23. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

24. Проводник не обновляет содержимое папки.

25. Создание ярлыка и комбинации клавиш для закрытия зависших приложений и перезапуска Проводника.

26. Восстановление в всплывающем меню "Создать" пункта "Папку".

27. Исправление отсутствия в папке Все программы из меню Пуск папки "Стандартные".

28. В папке "Библиотеки" вложенные папки (Изображения, Видео, Документы, Музыка) стали отображаться на английском языке.

29. Восстановление пропавшего из контекстного меню пункта создания текстового документа (txt-файл).

30. Решение проблемы в работе AeroPeek, при которой рабочий стол не показывается при наведении мыши на край панели задач.

31. Исправление нечитабельности текста под значками на рабочем столе при использовании однотонного фонового изображения.

32. Восстановление пункта "Очистить список последних элементов" в контекстном меню "Недавние документы".

33. Очистка кэша эскизов, для решения проблем с их отображением.

34. Изменение атрибутов папки или файла при недоступном поле для установки флажка атрибутов в свойствах объекта в Проводнике.

35. Исправление проблемы появления в меню Вид пункта Расширенная плитка вместо Плитка.

36. Исправление ошибки, когда перетаскивается сначала рамка Проводника, а затем окно.

37. Удаление рекламных баннеров с рабочего стола.

Устранение неполадок - Устройства и BSOD.

1. При использовании сторонних плееров для видео, выкидывает в BSOD.

2. В папке "Компьютер" не отображаются DVD-дисководы.

3. В Windows и Nero не стираются диски DVD RW и CD RW.

4. Определение драйвера, вызвавшего BSOD.

5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

6. В Windows x64 стало показывать меньше памяти, чем есть.

7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.

9. Исправление появившихся красных крестиков на значках локальных дисков.

10. Восстановление автозапуска для всех типов приводов и устройств.

11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.

12. Cистема находит Bluetooth-адаптер, а Bluetooth-устройства его не обнаруживают.

13. Восстановление значка "Безопасное извлечение устройства".

14. Решение проблемы пропадания места на системном жестком диске.

15. Windows не определяет второй жесткий диск после установки.

16. Не переименовывается диск (не меняется метка тома) в Windows 7.

17. Отключение отображения внутренних жестких дисков в "Безопасное извлечение устройств и дисков".

18. Проверка драйверов для выявления неполадок в работе Windows.

19. При установке Windows, в окне выбора раздела на диске создается раздел с нулевым размером.

20. Определение устройства выведшего Windows 7 из спящего режима.

21. Отключение автоматической перезагрузки при появлении синего экрана смерти (BSOD).

22. Восстановление используемых по умолчанию планов электропитания.

23. Сброс (обнуление) всех значений индекса производительности.

24. Восстановление неработающего жесткого диска или флеш-диска (флешки), используя низкоуровневое форматирование.

Устранение неполадок - Локальная сеть и Интернет.

1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

2. В настройках сети пропадает или периодически не определяется шлюз, указанный по умолчанию.

3. Устранение ошибок в работе Центра обновления Windows (Windows Update).

4. Решение проблемы с punkbuster на Windows 7.

5. Исправление длительного времени задержки (лагов) в компьютерных сетях.

6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

7. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

8. Устранение неполадки в Центре обновления Windows: Некоторые параметры задаёт системный администратор.

9. Постоянно пропадает подключение к локальной сети и/или интернету.

10. Восстановление пропавших иконок для htm/html/mht/url файлов.

11. Ошибки, возникающие при создании подключений удаленного доступа и VPN-подключений и способы их решения.

12. Исправление ошибки Internet Explorer: "Internet Explorer has stopped working".

13. Восстановление исходного состояния компонентов Центра обновления Windows.

14. Не получается включить сетевое обнаружение в дополнительных параметрах общего доступа.

15. Восстановление в Mozilla Firefox окна "Выход из Firefox" с кнопками "Сохранить и Выйти", "Выйти" и "Отмена".

16. Ftp-сервер при вводе адреса в Проводнике открывается в Internet Explorer.

17. Восстановление пропавшего звука в интернет браузерах.

18. Удаление и/или переименование сетей с названиями Сеть 2 (Network 2), Сеть 3 (Network 3) и т.д..

Разное.

1. Сравнение версий Windows 7.

2. Открытие файлов справки с расширением .hlp.

3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

4. Список сочетаний клавиш используемых в Windows 7.

5. Перезагрузка компьютера в безопасный режим без использования клавиатуры (клавиши F8) при загрузке.

6. Определение букв назначенных дискам в среде восстановления или среде предустановки.

7. Автоматическое переключение русской и английской раскладок клавиатуры.

8. Удаление Windows 7 без форматирования раздела и без потери данных.

9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы).

10. Активация Windows 7 по телефону, используя лицензионный ключ.

11. Быстрое переключение с одного монитора на другой или с монитора на проектор.

12. Где можно скачать справочник от Microsoft, содержащий полное описание утилит командной строки?

13. Уточнение времени работы компьютера с момента последней загрузки.

14. Автоматическая очистка временных папок при выходе из Windows.

15. Отключение Центра отправки Microsoft Office.

16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

18. Удаление установленного обновления.

19. Создание значков управления состоянием компьютера.

20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

21. Удаление данных без возможности восстановления.

22. Выполнение дефрагментации дисков в Windows 7 используя командную строку.

23. Уменьшение размера файла изображения без потери качества.

24. Где можно скачать последнюю версию DirectX?

25. Запуск программы с определенной датой без изменения системных настроек.

26. Изменение атрибутов и времени/даты создания, изменения и открытия (доступа) файла.

27. Список всех обновлений вошедших в SP1 с краткими объяснениями и ссылками.

28. Список горячих клавиш, используемых в окне команд Windows 7.

29. Получение информации о длительности загрузки Windows 7.

30. Скрытие одного файла в другом используя альтернативные потоки данных в NTFS.

31. Извлечение файлов из cab-архива, созданного в InstallShield.

32. Восстановление экранной заставки Windows Energy из предыдущих версий Windows.

33. Быстрое чтение QR-кодов, "Data Matrix"-кодов.

34. Соответствие наименований папок в Windows XP и Windows 7.

35. Способы вставки среднего и длинного тире в Проводнике и в Microsoft Word.


Стартовая страница

Полезные советы для Windows 7 от Nizaury v.5.95.

Полезные советы для Windows 7 - это сборник советов, в котором содержится полезная информация для простого решения ошибок и вопросов, возникающих при работе с Windows 7.
Основная цель сборника: Помочь большему количеству пользователей успешно работать с Windows 7 и уверенно ориентироваться в её среде.
Для полноценной работы со сборником, рекомендуется развернуть его на полный экран.

Ссылки яў скачивания новых версий сборника:

Ссылка на Google Drive.
Ссылка на Microsoft OneDrive.
Ссылка на Mediafire.

Информацию о рабочих ссылках Вы также можете найти на официальном блоге(сайте) сборника.

Инструкция использования данного справочника

Общий список советов

Перейти к разделу:

Установка, Обновления, Языки.
Настройки.
Администрирование.
Интерфейс. +
Интерфейс - Отображение
Интерфейс - Взаимодействие
Сети (Интернет и Локальная).
Тонкие настройки.
Виртуализация.
Портабелизация.
Твики Реестра. +
Твики Реестра - Общие.
Твики Реестра - Администрирование и Безопасность.
Твики Реестра - Настройки и Интерфейс.
Твики Реестра - Дополнительная функциональность.
Твики Реестра - Устройства и Сети.
Устранение неполадок. +
Устранение неполадок - Администрирование и Интерфейс.
Устранение неполадок - Рабочий стол, Проводник, Панель задач.
Устранение неполадок - Устройства и BSOD.
Устранение неполадок - Локальная сеть и Интернет.
Разное.

История версий

Официальный блог(сайт) сборника: http://nizaury.blogspot.com
Гостевая книга на сайте: http://nizaury.blogspot.com/2009/12/blog-post_07.html

E-mail автора сборника: psdw7@yahoo.com


1. Получение полного доступа к файлу или папке.

Если Вам приходится копировать/перемещать файлы в системные папки с заменой имеющегося файла, то Вам может пригодиться решение, добавляющее в контекстное меню файлов и папок пункт "Стать владельцем и задать полный доступ к объекту". Это сэкономит Вам время затрачиваемое на смену владельца и прав, а также упростит данное действие.

1) Создайте необходимый Вам reg-файл, в зависимости от установленной версии Windows.
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "admin.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Если у Вас установлена изначально русская версия Windows скопируйте данный текст:

Если у Вас установлена изначально английская версия Windows + русский языковой пакет скопируйте данный текст:

2) Примените созданный Вами reg-файл.
2.1) Щелкните на reg-файле правой кнопкой мыши и выберите пункт Слияние (Merge).
2.2) Нажмите в первом появившемся окне кнопку Да (Yes), а в следующем кнопку ОК.

Чтобы воспользоваться добавленным пунктом меню:

1) Щелкните на файле или папке правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту".
2) В любых окнах, если они появятся нажимите кнопку Да(Yes).

Скачать готовый reg-файл: Full_access.zip

Full_access_eng.reg - примените, если Вы используете английскую версию Windows.
Название пункта меню указано на английском языке, название группы администраторов указано на английском языке.
Full_access_eng+rus_mui.reg - примените, если Вы используете английскую версию Windows и русский языковой пакет.
Название пункта меню указано на русском языке, название группы администраторов указано на английском языке.
Full_access_rus.reg - примените, если Вы используете русскую версию Windows.
Название пункта меню указано на русском языке, название группы русском указано на английском языке.

Если Вы не знаете на каком языке у Вас названа группа администраторов, то чтобы это узнать выполните следующие действия.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

Если Вам необходимо изменить права доступа, а после использования файла вернуть все права обратно, то Вы можете воспользоваться программой TakeOwnershipEx, которая обладает следующими возможностями:

  • Получение прав на один или сразу несколько файлов. В диалоге открытия Вы можете выбрать сразу несколько файлов, выделяя их мышкой и удерживая клавишу Ctrl или ⇑ Shift.
    Выбранным файлам в качестве владельца выставляется группа локальных "Администраторов", и предоставляется полный доступ для этой группы.

  • Восстановление прав. Если Вы получили права владельца и полный доступ, утилита запоминает, какие права у файла были до этого, и потом Вы в любой момент можете их вернуть на место.

    • Перейти к началу раздела Администрирование.


2. Запуск командной строки от имени (с правами) администратора.

Если Вы работаете под учетной записью обычного администратора, то командная строка от имени администратора запускается так:

Вариант 1.

1) В строке поиска меню Пуск введите команду: cmd.
2) Щелкните на найденном файле cmd.exe правой кнопкой мыши и выберите пункт Запуск от имени администратора

Вариант 2.

В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.

Вариант 3.

1) Нажмите кнопку Пуск
2) Перейдите Все Программы → Стандартные
3) Щелкните правой кнопкой мыши на Командная строка и выберите пункт Запуск от имени администратора.

Если Вы работаете под встроенной учетной записью администратора, то кроме указанных выше вариантов Вы можете использовать еще один вариант:

Вариант 4.

1) Запустите диалоговое меню Выполнить.
В зависимости от Ваших настроек: Откройте Пуск → Выполнить или нажмите комбинацию клавиш Win   + R.
2) Введите команду: cmd и нажмите Enter ↵.

Вариант 5.

В адресной строке Проводника введите %ComSpec% и нажмите Enter ↵. Данное действие откроет окно команд, с указанием в пути папки из которой было запущено.

Перейти к началу раздела Администрирование.


3. Изменение прав доступа и владельца для файла (папки), используя Проводник или командную строку.

Случается, что при работе с файлами или папками Вам бывает необходимо изменить для них владельца и права доступа.

Смена владельца файла или папки, используя Проводник.

1) Щелкните правой кнопкой мыши на файле или папке и выберите пункт Свойства.
2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
3) Перейдите на вкладку Владелец и нажмите кнопку Изменить.
4) Выполните одно из следующих действий:

  • Чтобы назначить владельцем пользователя или группу из списка, в окне Изменить владельца на выберите нового владельца и нажмите ОК.
  • Чтобы назначить владельцем пользователя или группу, которых нет в списке:

    • 1) Нажмите кнопку Другие пользователи и группы
    2) Если владельцем необходимо установить службу TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    3) Если владельцем необходимо другого пользователя или группу, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    3.1) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.

    5) В окне Изменить владельца на: выберите добавленную группу или пользователя.
    6) Чтобы сменить владельца всех субконтейнеров и объектов в папке, установите флажок Заменить владельца субконтейнеров и объектов и нажмите кнопку ОК.

    Изменение разрешений для доступа к файлам и папкам, используя Проводник.

    1) Щелкните правой кнопкой мыши на файле или папке и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
    3) Нажмите кнопку Изменить разрешения и выполните одно из следующих действий:
    3.1) Чтобы изменить разрешения для существующей группы или пользователя, выберите имя этой группы или пользователя и нажмите кнопку Изменить.
    3.1.1) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.
    3.2) Чтобы изменить разрешения для группы или пользователя, которого нет в списке Элементы разрешений, нажмите кнопку Добавить.

    3.2.1) Если необходимо изменить разрешения для службы TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    3.2.2) Если необходимо изменить разрешения для другого пользователя или группы, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    3.2.3) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.
    3.2.4) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.

    3.3) Чтобы удалить группу или пользователя из списка Элементы разрешений, нажмите кнопку Удалить.

    Далее рассказывается как можно изменить разрешения или сменить владельца, используя командную строку запущенную от имени администратора.
    Если после использовании команды, разрешения или владелец не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение владельца файла (папки) на указанного Вами пользователя, используя командную строку.

    Примеры:

    Параметры:

    /T - операция выполняется для всех соответствующих файлов и каталогов, расположенных в указанных в имени каталогах.
    /C - выполнение операции продолжается при любых файловых ошибках. Сообщения об ошибках по-прежнему выводятся на экран.
    /L - операция выполняется над самой символической ссылкой, а не над ее целевым объектом.
    /Q - команда icacls подавляет сообщения об успешном выполнении.

    Изменение разрешений для файла (папки), используя командную строку.

    Разрешения:

    F - полный доступ
    M - доступ на изменение
    RX - доступ на чтение и выполнение
    R - доступ только на чтение
    W - доступ только на запись
    D - доступ на удаление

    Примеры:

    Об остальных возможностях команды icacls Вы сможете узнать введя команду: icacls /?

    Перейти к началу раздела Администрирование.


4. Автоматический вход в систему и отключение экрана пользователей при запуске.

Если Вы являетесь единственным пользавателем компьютера и используете для входа в систему пароль, то Вы можете автоматизировать процесс ввода пароля при входе в систему.
Для этого выполните указанные ниже действия.

1) Нажмите на клавиатуре Win   + R .
2) В появившемся окне введите команду: netplwiz или control userpasswords2 и нажмите Enter ↵.
3) В окне Учетные записи пользователей во вкладке Пользователи выделите свою учетную запись и уберите флажок напротив Требовать ввод имени пользователя и пароля.
4) Нажмите Принять.
5) В открывшемся окне Автоматический вход в систему будут три поля - Пользователь, Пароль и Подтверждение.
Введите свой пароль в поле Пароль и еще раз - в поле Подтверждение и нажмите ОК.
6) Перезагрузите компьютер.

Перейти к началу раздела Администрирование.


5. Отключение или изменение параметров контроля учетных записей (UAC).

1) Нажмите на клавиатуре комбинацию клавиш Win   + R.
2) Введите: UserAccountControlSettings и нажмите клавишу Enter ↵.
3) Для установки минимального значения передвиньте ползунок на предпоследнее деление и нажмите кнопку ОК.
4) Для отключения контроля учетных записей (UAC) передвиньте ползунок на последнее деление и нажмите кнопку ОК.
5) Перезагрузите компьютер.

Перейти к началу раздела Администрирование.


6. Быстрый запуск программы с правами администратора.

Удерживая Ctrl + ⇑ Shift нажмите на иконку приложения (у Вашей учетной записи, должны быть права администратора).

Перейти к началу раздела Администрирование.


7. Убирание запрещающего значка с папки.

1) Нажмите правой кнопкой мыши на папке с которой Вы хотите убрать значок замка и выберите Свойства
2) Перейдите на вкладку Безопасность
3) Нажимите на кнопки Изменить → Добавить → Дополнительно → Поиск
4) В результатах поиска удерживая нажатой клавишу Ctrl, выберите следующие имена: система; Администраторы; Прошедшие проверку; и нажмите ОК
5) В окне группы или пользователи выберите система; и установите флажок на Полный доступ, после выберите Администраторы; и снова установите флажок на Полный доступ, а затем выберите Прошедшие проверку; и также установите флажок на Полный доступ.
6) Нажмите ОК

При возникновении окон "Ошибка применения безопасности" нажмите Продолжить.

Также Вы можете воспользоваться следующим решением.

1) Создайте и примените reg-файл(например: admin.reg) как описано в Администрирование: 1. Получение полного доступа к файлу или папке.
2) Щелкните на папке и выберите пункт "Стать владельцем и задать полный доступ к объекту"
3) В любых окнах, если они появятся нажмите Да(Yes)

Перейти к началу раздела Администрирование.


8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer (английская версия или русская версия) или Sysinternals AutoRuns (английская версия или русская версия), и вовсе лучше всегда запускать с повышенными привилегиями.
Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl + ⇑ Shift + Enter ↵.
3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

1) Запускаете планировщик заданий (Пуск → Все программы → Стандартные → Служебные → Планировщик заданий)
2) Нажимаете "Создать задачу"
3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
5) Указываете путь к нужному приложению и нажимаете "Открыть"
6) Нажимаете "ОК", затем снова "ОК"
7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" → "Ярлык")
8) В поле Расположение объекта введите:

где mytask_admin - имя созданной нами задачи. Если в имеми содержаться пробелы, обязательно укажите его в кавычках.
9) Введите имя ярлыка и нажмите Готово

Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

Ссылка для скачивания: ElevatedShortcut.zip

Перейти к началу раздела Администрирование.


9. Переименование учетных записей и перемещение их папок профиля.

Чтобы переименовать учетную запись и/или переместить ее папку профиля, воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1. Переименование не активированной встроенной учетной записи администратора и перемещение ее папки профиля.

Для переименования профиля выполните действия указанные в пунктах с первого по пятый.
Если переименовывать папку не требуется, а необходимо только перенести, то перейдите сразу к шестому пункту.

1) Откройте меню Выполнить: Пуск → Выполнить (либо Win   + R)
2) Введите secpol.msc и нажмите Enter ↵.
3) Перейдите в Локальные Политики → Параметры Безопасности
4) Щелкните правой кнопкой на параметре "Учетные записи: переименование учетной записи администратора" и выберите пункт Свойства.
5) В текстовом поле введите желаемое имя для встроенной учетной записи администратора (Например: Super-Admin) и нажмите кнопку ОК.
6) Введите в строке поиска меню Пуск команду: cmd, нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени администратора".
7) Введите в командной строке указанную ниже командуEnter ↵

Вместо Имя_пользователя укажите имя встроенной учетной записи администратора.
Администратор - для русской версии, Administrator - для английской версии с русским языковым пакетом.
Либо укажите заданное Вами имя (Например, Super-Admin), если Вы изменили стандартное.

8) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
9) На экране пользователей выберите встроенную учетную запись администратора (Например: Super-Admin).
10) После загрузки рабочего стола, нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
11) На экране пользователей выберите обычную учетную запись администратора.
12) Откройте папку C:\Users и скопируйте Вашу папку профиля встроенной учетной записи администратора в любое желаемое место (Например в D:\Accounts).
13) Скачайте и запустите скрипт SIDList.vbs для выяснения, какое значение идентификатора безопасности пользователя (SID) соответствует, Вашей учетной записи (Username).
14) Введите в строке поиска меню Пуск команду: regedit, нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени администратора".
15) Перейдите к разделу: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – уточненный Вами идентификатор безопасности пользователя.
16) Щелкните правой кнопкой мыши на параметре ProfileImagePath и укажите новое расположение для папки профиля встроенной учетной записи администратора. (Например в D:\Accounts\Super-Admin)
17) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
18) На экране пользователей выберите встроенную учетную запись администратора (Например: Super-Admin).
19) Откройте папку C:\Users и удалите Вашу старую папку профиля встроенной учетной записи администратора. (Например: C:\Users\Super-Admin)

Вариант 2. Переименование любой учетной записи и перемещение ее папки профиля.

Для переименования профиля выполните действия указанные в пунктах с первого по двенадцатый.
Если переименовывать папку не требуется, а необходимо только перенести, то перейдите сразу к тринадцатому пункту.

1) Откройте Пуск → Панель управления → Учетные записи пользователей и нажмите на ссылку Управление другой учетной записью.
2)Нажмите на Вашу учетную запись и на открывшейся странице выберите пункт Создание учетной записи.
3) Введите имя для временной учетной записи (Например: Test), установите переключатель в значение Администратор и нажмите кнопку Создание учетной записи.
4) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
5) На экране пользователей выберите созданную Вами временную учетную запись. (Например: Test)
6) Скачайте и установите программу Unlocker.
7) Откройте меню Выполнить: Пуск → Выполнить (либо Win   + R)
8) Введите netplwiz, нажмите Enter ↵.
9) Установите флажок Требовать ввод имени пользователя и пароля
10) Выделите учетную запись, которую Вы желаете переименовать и нажмите кнопку Свойства.
11) В текстовом поле Пользователь введите новое имя для Вашей учетной записи и нажмите кнопку ОК.
12) Снимите флажок Требовать ввод имени пользователя и пароля и нажмите кнопку ОК и еще раз ОК.
13) Откройте папку C:\Users, нажмите на папке профиля Вашей учетной записи правой кнопкой мыши и выберите пункт Unlocker.
14) В ниспадающем списке выберите Переименовать, укажите новое имя папки профиля Вашей учетной записи, соответствующее Вашему новому имени пользователя и нажмите кнопку ОК. (Например: NewUser)
15) Нажмите на кнопку Разблокировать Все, либо кнопку ОК.
16) Снова нажмите на папке профиля Вашей учетной записи правой кнопкой мыши и выберите пункт Unlocker.
17) В ниспадающем списке выберите Переместить, укажите новое расположение папки профиля Вашей учетной записи и нажмите кнопку ОК. (Например в D:\Accounts)
18) Нажмите на кнопку Разблокировать Все, либо кнопку ОК.
19) Скачайте и запустите скрипт SIDList.vbs для выяснения, какое значение идентификатора безопасности пользователя (SID) соответствует, Вашей учетной записи (Username).
20) Введите в строке поиска меню Пуск команду: regedit, нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени администратора".
21) Перейдите к разделу: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – уточненный Вами идентификатор безопасности пользователя.
22) Щелкните правой кнопкой мыши на параметре ProfileImagePath и укажите новое расположение для папки профиля Вашей учетной записи. (Например в D:\Accounts\NewUser)
23) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
24) На экране пользователей выберите Вашу переименнованную/перемещенную учетную запись (Например: NewUser).
25) Откройте Пуск → Панель управления → Учетные записи пользователей и нажмите на ссылку Управление другой учетной записью.
26) Нажмите на временную учетную запись и на открывшейся странице выберите пункт Удаление учетной записи.
27) Нажмите на кнопку Удалить файлы, а затем на кнопку Удаление учетной записи.

Вариант 3. Перемещение папки профиля, путем создания символической ссылки (точки соединения) на перемещенную папку профиля.

1) Откройте Пуск → Панель управления → Учетные записи пользователей и нажмите на ссылку Управление другой учетной записью.
2)Нажмите на Вашу учетную запись и на открывшейся странице выберите пункт Создание учетной записи.
3) Введите имя для временной учетной записи (Например: Test), установите переключатель в значение Администратор и нажмите кнопку Создание учетной записи.
4) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
5) На экране пользователей выберите созданную Вами временную учетную запись. (Например: Test)
6) Скачайте и установите программу Unlocker.
7) Откройте папку C:\Users, нажмите на папке профиля Вашей учетной записи правой кнопкой мыши и выберите пункт Unlocker.
8) Нажмите на папке профиля Вашей учетной записи правой кнопкой мыши и выберите пункт Unlocker.
9) В ниспадающем списке выберите Переместить, укажите новое расположение папки профиля Вашей учетной записи и нажмите кнопку ОК. (Например в D:\Accounts)
10) Нажмите на кнопку Разблокировать Все, либо кнопку ОК.
11) Скачайте утилиту Junction от SysInternals.
Она позволяет создавать точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог.
12) Скопируете junction.exe из архива в папку C:\Windows\System32.
13) Создайте символическую ссылку (точку соединения) для перемещенной папки с указанием на предыдущее месторасположение.

Например:

14) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
15) На экране пользователей выберите Вашу учетную запись.
16) Откройте Пуск → Панель управления → Учетные записи пользователей и нажмите на ссылку Управление другой учетной записью.
17) Нажмите на временную учетную запись и на открывшейся странице выберите пункт Удаление учетной записи.
18) Нажмите на кнопку Удалить файлы, а затем на кнопку Удаление учетной записи.

Вариант 4. Изменение пути к каталогам пользователей при установке Windows.

Вы можете изменить расположение папки Пользователи (Users), в которой будут храниться профили пользователей, ещё при установке Windows.

1) Создайте файл Autounattend.xml следующего содержания:
2) Скопируйте его в папку \Sources установочного диска.
3) Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

Перейти к началу раздела Администрирование.


10. Установка заданных атрибутов для всех файлов с определенным расширением в указанной папке и ее подпапках.

Если Вы желаете изменить атрибуты для файлов с определенным разрешением в какой-нибудь папке, не используя командную строку, то Вы можете создать для этого специальный скрипт (vbs-файл).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Attributes.vbs")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Скопируйте полученный файл в папку C:\Windows
Теперь, когда Вам потребуется задать атрибуты для файлов:
6) Откройте Пуск → Выполнить (Win   + R)
7) Введите Attributes.vbs и нажмите Enter ↵.

Также Вы можете скачать готовый vbs-файл: Attributes.zip

Перейти к началу раздела Администрирование.


11. Включение встроенной учетной записи администратора.

Вариант 1.

1) Запустите оснастку Локальные пользователи и группы (Local Users an Groups)
(Win   + R → lusrmgr.msc → ОК)
2) В меню слева нажмите на папку Пользователи (Users)
3) Щелкните правой кнопкой учетную запись Администратор (Administrator) и выберите Свойства (Properties).
4) Откроется окно Свойства: Администратор (Administrator Properties).
5) На вкладке Общие (General) снимите флажок Отключить учетную запись (Acount is disabled) и нажмите кнопку OK.

Учетная запись администратора теперь включена.

Вариант 2.

1) Нажмите кнопку Пуск
2) Введите в строке поиска cmd
3) Щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора

Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду

В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:

Чтобы переключиться на данную учетную запись: нажмите на кнопку Пуск, нажмите на стрелочку рядом с Завершение работы и выберите Сменить пользователя.

Перейти к началу раздела Администрирование.


12. Изменение фонового рисунка в экране авторизации пользователей (экране приветствия).

Вариант 1. Использование редактора локальной групповой политики.

1) Откройте меню Пуск, введите в строке поиска gpedit.msc и нажмите Enter ↵. (Win   + R → gpedit.msc → ОК)
2) Перейдите по пути слева Конфигурация пользователя → Административные шаблоны → Система → Вход в систему.
3) Щелкните дважды по параметру Всегда использовать настраиваемый вход в систему.
4) Установите переключатель на значение Включить и нажмите ОК.
5) Закройте редактор локальной групповой политики.
6) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
7) Поместите сюда jpg-файл Вашего фонового рисунка с разрешением, идентичным рабочему столу.
8) Переименуйте его в backgroundDefault.jpg

Размер jpg-изображения не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

Вариант 2. Редактирование реестра Windows.

1.1) Если Вы не переключаетесь между темами Windows, то создайте ключ типа DWORD с названием OEMBackground в разделе реестра

1.2) Если Вы переключаетесь между темами Windows, то создайте ключ типа DWORD с названием UseOEMBackground в разделе реестра

2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
4) Поместите сюда свой файл
5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

background768x1280.jpg
background900x1440.jpg
background960x1280.jpg
background1024x1280.jpg
background1280x1024.jpg
background1024x768.jpg
background1280x960.jpg
background1600x1200.jpg
background1440x900.jpg
background1920x1200.jpg
background1280x768.jpg
background1360x768.jpg
backgroundDefault.jpg - в случае использования другого разрешения монитора

Размер изображений не должен превышать 256Кб.
Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

Вариант 3. Редактирование файла imageres.dll.

1) Откройте с помощью программы Restorator файл C:\Windows\System32\imageres.dll
2) Откройте папку IMAGE и замените ресурсы с 5031 по 5043 файлами jpg-изображений, которыми Вы хотите заменить фоновый рисунок экрана авторизации пользователей (экрана приветствия). Каждое Ваше jpg-изображение должно иметь идентичное разрешение и глубину цвета, соответствующее замещаемому ресурсу.
3) Сохраните внесенные изменения нажав Ctrl + S
4) Перезагрузите компьютер.

Вариант 4. Использование специальной программы.

1) Скачайте архив программы tweakslogon.zip
2) Разархивируйте файл в любую папку и запустите TweaksLogon.exe
3) Нажмите на кнопку Change Logon Screen.
4) В открывшемся окне выберите изображение и нажмите Открыть (Open)
5) Если Ваше изображение больше 245 кб, то программа предложит Вам его сжать. Нажмите Да (Yes)
6) Если Вы уже меняли с помощью данной программы фоновый рисунок, то программа сообщит вам об этом. Нажмите Ок Чтобы вернуть стандартный фоновый рисунок нажмите кнопку Revert to Default Logon Screen.

Перейти к началу раздела Администрирование.


13. Установка службы TrustedInstaller в качестве владельца папки или файла.

У многих системных папок и файлов владельцем, имеющим права доступа на запись/удаление является служба TrustedInstaller. Конечно Вы можете задать права себе, если Вы являетесь администратором на компьютере, но это может привести к неполадкам в работе. Например, если Вы измените владельца папки winsxs для доступа к ней и не вернете обратно права TrustedInstaller, то некоторые программы могут не запуститься.

Если Вы удалили ее из групп и пользователей в свойствах папки (файла) на вкладке Безопасность, то чтобы вернуть обратно в качестве владельца службу TrustedInstaller Вам необходимо сделать следующее:

1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
3) В открывшемся окне перейдите на вкладку Владелец и нажмите кнопку Изменить...
4) Нажмите кнопку Другие пользователи или группы... , в текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
5) В окне Изменить владельца на: выберите TrustedInstaller и нажмите ОК.
Если необходимо также изменить владельца вложенных папок, то перед нажатием на кнопку ОК установите флажок Заменить владельца подконтейнеров и объектов.

Также Вам необходимо добавить службу TrustedInstaller в список групп и пользователей, имеющих доступ к папке (файлу).

1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
2) Перейдите на вкладку Безопасность
3) Нажмите кнопку Изменить..., а в открывшемся окне кнопку Добавить... .
4) В текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
5) Установите флажок в колонке Разрешить напротив разрешения Полный доступ
6) Нажмите на кнопки ОК.

Перейти к началу раздела Администрирование.


14. Изменение пароля или создание новой учетной записи администратора, используя средства восстановления системы.

Чтобы сбросить пароль учётной записи администратора (или создать новую) без использования дополнительных программ, Вам понадобится либо установочный диск Windows 7, либо диск восстановления системы, либо LiveCD с Windows PE.

Часть №1 - Настройка запуска командной строки перед экраном входа в Windows.

1) Загрузитесь с установочного диска Windows 7 или с диска восстановления.
2) Откройте командную строку Восстановление системы → Далее → Командная строка.
3) Запустите редактор реестра. В командной строке наберите regedit и нажмите Enter ↵.
4) Выделите раздел HKEY_LOCAL_MACHINE и выберите пункт Загрузить куст в меню Файл.
5) Перейдите на диск, где установлена Windows 7, и откройте файл: C:\Windows\System32\config\SYSTEM
6) Введите произвольное имя для загружаемого раздела. Например: NewAdmin.
7) Перейдите в раздел HKEY_LOCAL_MACHINE\NewAdmin\Setup
8) Измените значение параметров (Щелчок правой кнопкой мыши на параметре → Изменить):
8.1) Для параметра CmdLine введите значение cmd.exe и нажмите ОК.
8.2) Для параметра SetupType измените значение с 0 на 2 и нажмите ОК.
9) Выделите раздел NewAdmin в HKEY_LOCAL_MACHINEи выберите пункт Выгрузить куст в меню Файл.
10) Извлеките установочный диск или диск восстановления системы, закройте редактор реестра и командную строку, нажмите Перезагрузка в окне параметров восстановления.

Часть №2 - Создание нового пароля или новой учетной записи администратора.

Создание нового пароля.

1) Продолжайте обычный вход в Windows 7 и перед входом в систему Вы увидите окно командной строки.
2) Введите команду net user, чтобы отобразить все имеющиеся учётные записи.
3) Для создания нового пароля введите следующую команду и подтвердите её выполнение клавишей Enter ↵:

Если имя или пароль содержат пробелы, вводите их в "кавычках".

Создание новой учётной записи.

Если у Вас отсутствует учетная запись администратора, то для ее создания введите приведенные ниже команды, нажимая после каждой клавишу Enter ↵.

Для русской (локализованной) Windows:

1) Создание нового пользователя.

2) Добавление пользователя в группу Администраторы (Administrators).

3) Удаление пользователя из группы Пользователи (Users).

Для английской Windows:

1) Создание нового пользователя.

2) Добавление пользователя в группу Администраторы (Administrators).

3) Удаление пользователя из группы Пользователи (Users).

По окончании ввода закройте окно командной строки. Используйте созданную учетную запись для входа в Windows.

Перейти к началу раздела Администрирование.


15. Определение процесса которому принадлежит текущее окно.

1) Скачайте Sysinternals Process Explorer (английская версия или русская версия)
2) Разархивируйте в любую папку и запустите программу procexp.exe.
3) На панели инструментов Process Explorer нажмите левой кнопкой мыши на "значок-прицел".
4) Не отпуская левой кнопки мыши, наведите "прицел" на интересующее Вас окно.
5) Отпустите кнопку мыши и программа Process Explorer, выделит принадлежащий окну процесс (по умолчанию синим цветом).

Перейти к началу раздела Администрирование.


16. Удаление данных о серийном номере из системы для предотвращения его хищения.

Если Вы имеете твердую или надежную электронную копию серийного номера установленной Windows 7, то для предотвращения его хищения Вы можете удалить информацию о нем из системы. Для этого у вашей учётной записи должны быть права Администратора.

1) Запустите командную строку от имени администратора
В строке поиска меню "Пуск" наберите cmd.exe и нажмите Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵.

Здесь slmgr.vbs - скрипт обслуживания подсистемы Software License Manager, управления лицензированием программного обеспечения.
Опция cpky символизирует Clear Product Key.

Перейти к началу раздела Администрирование.


17. Создание точки восстановления системы при старте системы без использования апплета "Защита системы".

Если Вам необходимо создать точку восстановления системы при старте системы не используя апплет "Защита системы", то Вы можете создать указанного ниже содержания скрипт и добавить ярлык для него в автозагрузку.

В фоновом режиме без вывода сообщений и окон:

С выводом окна для введения наименования для точки восстановления:

1) Скопируйте выбранный Вами код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Создайте ярлык для созданного Вами файла скрипта в Автозагрузку.
5.1) Удерживая нажатой клавишу Alt перетяните иконку файла скрипта в папку Автозагрузка в меню Пуск.

Перейти к началу раздела Администрирование.


18. Запуск программ с правами администратора без выдачи уведомлений Контроля Учетных Записей.

Если Вам необходимо часто запускать какую-либо программу от имени администратора при включенном Контроле Учетных Записей и Вы не собираетесь его полностью отключать, то Вы можете воспользоваться программой Elevated Shortcut

Это приложение, автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает необходимый ярлык. Программа, запущенная таким ярлыком, выполняется с привилегиями администратора, но запускается без запроса UAC (Контроля учётных записей). Elevated Shortcut предназначена для пользователей, считающих функцию контроля учётных записей(UAC) в Windows 7 полезной и которым требуется запускать какое-либо приложение всегда с повышенными правами (Sysinternals Process Explorer (английская версия или русская версия)).
Существует следующие варианты создания ярлыка:

Вариант 1.

1) Открываете Пуск → Все программы → Elevated Shortcut и запускаете программу.
2) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
3) В зависимости от выбранного Вами языка интерфейса (из ниспадающего списка в нижнем левом углу) нажмите Создать ярлык (New Shortcut)
4) Укажите в текстовом поле Файл на который будет создан ярлык (Target Path) - путь к запускаемому файлу программы или путь к иконке для нее.
5) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
6) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
7) Нажмите ОК и ещё раз ОК и закройте программу.

Вариант 2.

1) Удерживая нажатой клавишу ⇑ Shift нажмите правой кнопкой мыши на файле, для которого Вы желаете добавить ярлык.
2) В контекстном меню выберите пункт ElevatedShortcut
3) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
4) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
5) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
6) Нажмите ОК и ещё раз ОК и закройте программу.

Перейти к началу раздела Администрирование.


19. Запрещение запуска Диспетчера задач.

1) Запустите редактор системных политик: Пуск → Выполнить → gpedit.msc (Win   + R → gpedit.msc → ОК).
2) Слева в дереве политик выберите Конфигурация пользователя → Административные шаблоны → Система → Варианты действий после нажатия Ctrl + Alt + Delete.
3) В правом окне щелкните на Удалить диспетчер задач и выберите пункт Изменить
4) Установите переключатель в значение Включить и нажмите ОК.
5) Перезагрузите компьютер.

Перейти к началу раздела Администрирование.


20. Добавление своей иконки в список рисунков учетных записей.

По умолчанию рисунки учетных записей располагаются в следующей папке:
C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

Перейти к началу раздела Администрирование.


21. Отключение кэширования экскизов.

Если у Вас включено отображение скрытых файлов в Windows, то обычно в папке с изображениями находится файл Thumbs.db. Данный файл используется операционной системой для хранения эскизов изображений папки для режима Эскизы страниц Проводника. Thumbs.db создаётся в каждой папке, которая содержит изображения, при первом отображении её содержимого.
Thumbs.db является скрытым файлом, и обычно не виден в Проводнике, и может содержать эскизы уже удалённых изображений. Поэтому, он может быть случайно передан постороннему лицу, которое может узнать компрометирующую информацию.

Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Профессиональная", "Корпоративная", "Максимальная", выполните следующие действия:

1) В строке поиска меню Пуск введите gpedit.msc и нажмите Enter ↵
2) В запустившемся Редакторе локальной групповой политики выберите раздел Конфигурация пользователя
3) Откройте Административные шаблоны → Компоненты Windows → Проводник Windows
4) В панели справа найдите политику Отключить кэширование экскизов в скрытых файлах thumbs.db.
5) Дважды щелкните на ней, чтобы открыть ее Свойства
6) В открывшимся окне установите переключатель в значение Включить.
7) Нажмите ОК
8) В панели справа найдите политику Отключить кэширование экскизов изображений.
9) Дважды щелкните на ней, чтобы открыть ее Свойства
10) В открывшимся окне установите переключатель в значение Включить.
11) Нажмите ОК

Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Домашняя базовая" и "Домашняя расширенная", выполните следующие действия:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) В меню Правка выберите Создать → Параметр DWORD (32 бита).
4) Задайте имя параметра NoThumbnailCache
5) Дважды щелкните на данном параметре и введите значение 1.
6) Откройте раздел реестра HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows
7) В меню Правка выберите Создать → Раздел.
8) Задайте имя раздела Explorer
9) Откройте созданный Вами раздел HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Explorer
10) В меню Правка выберите Создать → Параметр DWORD (32 бита).
11) Задайте имя параметра DisableThumbsDBOnNetworkFolders
12) Дважды щелкните на данном параметре и введите значение 1.
13) Закройте редактор реестра и перезапустите компьютер.

Перейти к началу раздела Администрирование.


22. Поиск приложений автоматически загружающихся при запуске компьютера.

Если у Вас при запуске Windows запускается какое-либо приложение, которое Вы хотите удалить из автозагрузки, то Вы можете либо проанализировать объекты находящиеся Пуск → Все программы → Автозагрузка и указанные ниже разделы реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

Но есть более лучший способ, позволяющий сделать более тщательный анализ автоматически запускаемых приложений - воспользоваться программой AutoRuns: английская версия или русская версия созданной Марком Руссиновичем.

Данная программа проверяет большее количество мест, из которых происходит автозапуск программ.

Просто запустите средство Autoruns, и оно покажет, какие приложения настроены на автоматический запуск, а также представит полный список разделов реестра и каталогов файловой системы, которые могут использоваться для задания автоматического запуска. Элементы, которые показывает программа Autoruns, принадлежат к нескольким категориям: объекты, автоматически запускаемые при входе в систему, дополнительные компоненты Проводника, дополнительные компоненты Internet Explorer (включая объекты модулей поддержки обозревателя (BHO)), библиотеки DLL инициализации приложений, подмены элементов, объекты, исполняемые на ранних стадиях загрузки, библиотеки DLL уведомлений Winlogon, службы Windows и многоуровневые поставщики услуг Winsock. Чтобы просмотреть автоматически запускаемые объекты требуемой категории, достаточно выбрать нужную вкладку.

Параметр Hide Signed Microsoft Entries (Не показывать элементы с цифровой подписью Microsoft) из раздела меню Options позволяет сосредоточить внимание на автоматически запускаемых элементах сторонних производителей, если такие элементы были добавлены в систему. Кроме того, можно просматривать объекты, настроенные на автоматический запуск для других учетных записей, имеющихся в системе.

Для просмотра свойств исполняемого объекта, настроенного на автоматический запуск, необходимо выделить этот объект и воспользоваться пунктом меню или кнопкой панели инструментов Properties (Свойства). Если в системе запущена программа Process Explorer: английская версия или русская версия, а выделенный исполняемый файл используется каким-либо активным процессом, то при выборе в меню Entry (Элемент) пункта Process Explorer (Process Explorer) откроется диалоговое окно свойств процесса, использующего выделенный объект.

Чтобы перейти к разделу реестра или каталогу файловой системы, который отображается в окне программы, либо к настройке объекта, запускаемого автоматически, достаточно выделить нужный элемент и воспользоваться командой меню или кнопкой панели инструментов Jump to (Перейти к).

Чтобы отключить объект, запускаемый автоматически, нужно снять соответствующий ему флажок. Удалить такой объект можно с помощью команды меню или кнопки панели инструментов Delete (Удалить).

Чтобы просмотреть автоматически запускаемые элементы для учетных записей других пользователей, достаточно выбрать нужный пункт меню User (Пользователь).

Перейти к началу раздела Администрирование.


23. Отслеживание приложений, создающих неизвестные файлы на диске.

Если у Вас на диске постоянно какая-либо программа записывает непонятные файлы, то Вы можете определить создающее их приложение, воспользовавшись утилитой от Microsoft: Process Monitor.

1) Запустите программу Process Monitor
Так как программа отслеживает несколько типов системной активности (реестр, файловую систему, сеть и процессы), то Вам необходимо оставить только включенной активность файловой системы.
2) Оставьте на Панели инструментов включенным значок Show File System Activity, и отключите значки Show Registry Activity, Show Network Activity и Show Process and Tread Activity, Show Profiling Events
3) Примените фильтр, чтобы отсеять необходимые Вам значения. Для запуска фильтра нажмите сочетание клавиш Ctrl + L.
4) В первом ниспадающем списке выберите значение Path - обозначает путь к искомому файлу (имя файла также учитывается).
5) Во втором ниспадающем списке выберите значение contains - условие, учитывая которое будет производится отсеивание, в данном случае обозначает «содержит» (перев. с англ.)
Также Вы можете, выбрать вариант begins with (начинается с) или ends with (заканчивается на).
6) В текстовом поле введите либо желаемое имя файла, либо имя папки, где создаются неизвестные файлы.
7) В последнем ниспадающем списке выберите значение Include - указывает фильтру, что заданные условия должны быть включены в результаты отсеивания.
8) Нажмите кнопку Add, чтобы добавить фильтр в список и ОК, чтобы применить фильтр.

Если полученных результатов очень много, то Вы можете добавить дополнительные фильтры, либо указав какие действия надо отслеживать, либо исключив определенные процессы.
Примеры дополнительных фильтров:

Process Name – Is – Имя процесса – Exclude.
Operation – Is – CreateFile – Include

Перейти к началу раздела Администрирование.


24. Создание, отключение и удаление учетной записи пользователя.

Чтобы создать новую учетную запись, то воспользуйтесь одним из предложенных ниже вариантов:

Вариант 1.

1) Войдите в систему от имени другого пользователя с правами администратора (Например, используя учетную встроенную запись администратора)
2) Запустите оснастку Локальные пользователи и группы (Win   + R → lusrmgr.msc → OК)
3) В меню слева нажмите на папку Пользователи
4) Щелкните правой кнопкой мыши на свободном от текста месте в центральной колонке или в главном меню выберите пункт Действие и нажмите на пункт Новый пользователь.
5) Введите желаемые Вами значения полей. (При необходимости, для более подробного объяснения элементов нажмите кнопку Справка)
В поле Пользователь - введите имя учетной записи, которое будет использовано в папке C:\Users при создании папки Вашего профиля. (Например: MaxZol)
В поле Полное имя - введите имя учетной записи, которое будет указано на экране приветствия Windows (Например: Максим Золотарев)
Поле Описание можете оставить пустым, в полях Пароль и Подтверждение введите идентичные значения пароля.
6) Снимите флажок Требовать смены пароля при следующем входе в систему.
7) Нажмите кнопку Создать, а затем кнопку Закрыть.
Будет создана учетная запись с правами обычного пользователя. Если же Вам необходимо изменить ее на учетную запись администратора, то:
7.1) Щелкните правой кнопкой на созданную Вами учетную запись и выберите пункт Свойства.
7.2) Перейдите на вкладку Членство в группах и нажмите кнопку Добавить, затем кнопку Дополнительно, а затем кнопку Поиск.
7.3) В результатах поиска выберите группу Администраторы (Administrators) и нажимайте на кнопки ОК, пока не вернетесь в список пользователей.
8) В меню Пуск, наведите курсор на стрелочку рядом с завершением работы, выберите пункт Выйти из системы и войдите в систему используя вновь созданную учетную запись.

Вариант 2.

1) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей
2) Нажмите на ссылку Управление другой учетной записью
3) Нажмите на ссылку Создание учетной записи
4) Введите имя учетной записи, которое будет указано на экране приветствия Windows.
5) Выберите тип учетной записи: Обычный доступ или Администратор.
6) Нажмите на кнопку Создание учетной записи
Учетная запись будет создана по умолчанию без пароля. Если же Вам необходимо его установить, то:
6.1) Щелкните правой кнопкой на созданную Вами учетную запись и нажмите ссылку Создание пароля.
6.2) в полях Новый пароль и Подтверждение пароля введите идентичные значения пароля и нажмите на кнопку Создать пароль
7) В меню Пуск, наведите курсор на стрелочку рядом с завершением работы, выберите пункт Выйти из системы и войдите в систему используя вновь созданную учетную запись.

Если у Вас на экране приветствия Windows появляются две или более учетных записей пользователей, то Вы можете отключить те из них, в которых Вы не нуждаетесь.

1) Запустите оснастку Локальные пользователи и группы (Win   + R → lusrmgr.msc → OК)
2) В меню слева нажмите на папку Пользователи
3) Щелкните правой кнопкой на учетную запись, которую Вы желаете отключить и выберите пункт Свойства.
4) Откроется окно свойств учетной записи.
5) На вкладке Общие установите флажок Отключить учетную запись и нажмите ОК.
6) Выйдите и войдите в систему под другим именем пользователя или перезагрузите компьютер для применения сделанных изменений.

Если же Вам необходимо удалить учетную запись пользователя, то воспользуйтесь одним из предложенных ниже вариантов:

Вариант 1.

1) Войдите в систему от имени другого пользователя с правами администратора (Например, используя учетную встроенную запись администратора)
2) Запустите оснастку Локальные пользователи и группы (Win   + R → lusrmgr.msc → OК)
3) В меню слева нажмите на папку Пользователи
4) Щелкните правой кнопкой на учетную запись, которую Вы желаете удалить и выберите пункт Удалить.
5) Выйдите и войдите в систему под другим именем пользователя или перезагрузите компьютер для применения сделанных изменений.
6) Откройте папку C:\Users и удалите папку соответствующую наименованию отключенного/удаленного Вами пользователя.

Вариант 2.

1) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей
2) Нажмите на ссылку Управление другой учетной записью
3) Выберите учетную запись, которую Вы желаете удалить.
4) Нажмите на ссылку Удаление учетной записи
5) Нажмите кнопку Удалить файлы для полного удаления всех папок и файлов связанных с данной учетной записью.
Если Вам необходимо сохранить содержимое рабочего стола и папок входящих в Библиотеки, то нажмите кнопку Сохранение файлов.
6) Нажмите на кнопку Удаление учетной записи

Перейти к началу раздела Администрирование.


25. Запуск приложения от имени другого пользователя.

Чтобы запустить приложение от имени другого пользователя выполните следующие действия:

1) Нажмите клавишу ⇑ Shift, и удерживая её, щелкните правой кнопкой мыши по исполняемому файлу.
2) В появившемся контекстном меню выберите Запуск от имени другого пользователя.
3) В открывшемся окне введите логин и пароль пользователя, от имени которого нужно запустить программу и нажмите ОК.

Примечание. Учетная запись пользователя, от имени которого запускается программа, должна быть защищена паролем.

Чтобы создать ярлык для запуска приложения от имени другого пользователя выполните следующие действия:

1) Нажмите клавишу Alt, и удерживая её, перетяните иконку исполняемого файла туда, где Вы желаете создать ярлык.
2) Нажмите правой кнопкой мыши на созданном Вами ярлыке и выберите пункт Свойства.
3) В поле Объект введите следующую команду:

где:

Runas - служит для запуска программы с разрешениями, отличными от тех, которые предоставляет текущая учетная запись.
/user:учетная_запись_пользователя - задает имя учетной записи пользователя, которая будет использована для запуска программы.
program - задает команду или программу, которая будет запущена с помощью учетной записи, указанной в параметре /user.

Если имя пользователя состоит из двух и более слов разделенных пробелом, то его необходимо заключать в кавычки.
Если программа, которую необходимо запустить не расположена в одной из системных папок, то путь к программе указывается полностью и заключается в кавычки.

Чтобы использовать учетную запись администратора на своем компьютере, в качестве параметра /user: введите одно из следующих значений:

Чтобы использовать данную команду в качестве администратора домена, введите одно из следующих значений параметра:

Перейти к началу раздела Администрирование.


26. Переименование папки локальной учетной записи пользователя.

Переименование локальной учетной записи пользователя в оснастках: Локальные пользователи и группы (lusrmgr.msc) и Управление компьютером (compmgmt.msc) не изменяет имени папки пользователя, находящейся по умолчанию в папке: C:\Users, а обычное переименование папки может привести к неработоспособности профиля.
Для осуществления данного действия Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Войдите в систему от имени другого пользователя с правами администратора (Например, используя учетную встроенную запись администратора)
Если Вы работаете под своей учетной записью, то для входа от имени другого пользователя Вам необходимо воспользоваться пунктом Выйти из системы.
2) Откройте в Проводнике папку C:\Users и переименуйте имя папки соответсвующей необходимому Вам профилю со старого наименования на новое.
3) Откройте Панель управления\Система и безопасность\Администрирование и запустите Управление компьютером.
4) Слева, в дереве консоли пройдите Управление компьютером\Служебные\Локальные пользователи и группы\Пользователи
5) Щелкните правой кнопкой мыши на учетную запись пользователя, для которой требуется изменить папку, а затем щелкните Свойства.
6) Перейдите на вкладку Профиль и в разделе Домашняя папка и установите переключатель в значение Путь.
7) Введите полный путь к переименованной папке (например C:\Users\NewUser) и нажмите ОК.

Вариант 2.

1) Войдите в систему от имени другого пользователя с правами администратора (Например, используя учетную встроенную запись администратора)
Если Вы работаете под своей учетной записью, то для входа от имени другого пользователя Вам необходимо воспользоваться пунктом Выйти из системы.
2) Откройте в Проводнике папку C:\Users и переименуйте имя папки соответсвующей необходимому Вам профилю со старого наименования на новое.
3) Запустите редактор реестра (Win   + R → regedit → ОК)
4) В главном меню откройте диалоговое окно поиска Правка → Найти... (Ctrl + F)
5) Выполните поиск по старому имени папки и замените в найденном параметре значение на новое имя папки.
6) Продолжите поиск и замените все возможные из найденных значений.
7) Выполните выход из системы и войдите в систему под учетной записью для которой Вы изменяли значения реестра.

Вариант 3.

1) В строке поиска Пуск введите слово перенос и в списке результатов выберите Средство переноса данных Windows.
2) В открывшемся окне нажмите кнопку Далее.
3) Нажмите Внешний диск или USB-устройство флеш-памяти
4) Нажмите Это мой исходный компьютер
5) Дождитесь пока произведется оценка данных входящих в профили имеющиеся на компьютере
6) Установите флажок напротив учетной записи, которую Вы желаете переместить.
7) Нажмите под ней на ссылку Настройка, а затем на ссылку Дополнительно.
8) Выберите желаемые параметры для переноса и нажмите кнопку Сохранить, а затем нажмите кнопку Далее.
9) В случае необходимости введите пароль для защиты данного файла, в остальных случаях оставьте данное поле пустым и нажмите кнопку Сохранить.
10) Задайте имя файла и выберите место для сохранения файла переноса и нажмите кнопку Сохранить.
11) По окончании создания файла нажмите кнопку Далее, еще раз Далее, а затем Закрыть.
12) В строке поиска Пуск введите слово перенос и в списке результатов выберите Средство переноса данных Windows.
13) В открывшемся окне нажмите кнопку Далее.
14) Нажмите Внешний диск или USB-устройство флеш-памяти
15) Нажмите Это мой новый компьютер, а затем Да.
16) Выберите место,где Вы сохранили файла переноса и щелкните на нем.
17) Нажмите под учетной записью на ссылку Настройка, а затем на ссылку Дополнительно.
18) Выберите желаемые параметры для переноса и нажмите кнопку Сохранить
19) Нажмите на ссылку Дополнительные параметры и в открывшемся окне перейдите на вкладку Сопоставление учетных записей пользователей.
20) В ниспадающем списке Учетная запись пользователя на новом компьютере выберите пункт Создание пользователя.
21) Введите имя пользователя и пароль (при необходимости) и нажмите кнопку Создать, а затем на кнопку Сохранить.
22) Нажмите кнопку Перенести, а после завершения переноса нажмите кнопку Закрыть.
23) Выйдите из системы воспользовавшись пунктом Выйти из системы из меню Пуск.
24) Войдите в систему от имени созданного Вами пользователя.
25) Удалите старую учетную запись пользователя и соответствующую ей папку, для этого воспользуйтесь решением предложенным в совете Администрирование: 24. Создание, отключение и удаление учетной записи пользователя.

Также Вы можете воспользоваться одним из решений предложенным в совете Администрирование: 9. Переименование учетных записей и перемещение их папок профиля., указав в качестве нового месторасположения полный путь к папке с новым наименованием, но с тем же расположением.

Перейти к началу раздела Администрирование.


27. Ввод пароля в окне смены пользователей при отсутствии необходимой раскладки клавиатуры.

Если Вы задали пароль на русском языке в английской Windows или пароль на русском языке в русской Windows, то Вы можете столкнуться с ситуацией, когда невозможно ввести пароль в окне смены пользователей, по причине отсутствия необходимой раскладки клавиатуры.

В таком случае для ввода пароля Вы можете воспользоваться ASCII символами.

Для ввода буквы из другой раскладки клавиатуры Вам необходимо, удерживая нажатой клавишу Alt нажать на цифровой клавиатуре 0 (ноль), а затем сразу число, соответствующее необходимой Вам клавише.

Например, для ввода английской буквы t в русской раскладке клавиатуры:

1) Нажмите и удерживайте клавишу Alt
2) Нажмите 0 (ноль) и сразу за ним число 1, 1, 6
3) Отпустите клавишу Alt, и вы увидите результат.

или

для ввода русской буквы т в английской раскладке клавиатуры:

1) Нажмите и удерживайте клавишу Alt
2) Введите 0 (ноль) и сразу за ним число 2, 4, 2
3) Отпустите клавишу Alt, и вы увидите результат.

Таблица ASCII символов для русской и английской клавиатуры приведена ниже.

Кириллица | Значение | Латиница | Значение
А | 192 | A | 65
Б | 193 | B | 66
В | 194 | C | 67
Г | 195 | D | 68
Д | 196 | E | 69
Е | 197 | F | 70
Ж | 198 | G | 71
З | 199 | H | 72
И | 200 | I | 73
Й | 201 | J | 74
К | 202 | K | 75
Л | 203 | L | 76
М | 204 | M | 77
Н | 205 | N | 78
О | 206 | O | 79
П | 207 | P | 80
Р | 208 | Q | 81
С | 209 | R | 82
Т | 210 | S | 83
У | 211 | T | 84
Ф | 212 | U | 85
Х | 213 | V | 86
Ц | 214 | W | 87
Ч | 215 | X | 88
Ш | 216 | Y | 89
Щ | 217 | Z | 90
Ъ | 218 | a | 97
Ы | 219 | b | 98
Ь | 220 | c | 99
Э | 221 | d | 100
Ю | 222 | e | 101
Я | 223 | f | 102
а | 224 | g | 103
б | 225 | h | 104
в | 226 | i | 105
г | 227 | j | 106
д | 228 | k | 107
е | 229 | l | 108
ж | 230 | m | 109
з | 231 | n | 110
и | 232 | o | 111
й | 233 | p | 112
к | 234 | q | 113
л | 235 | r | 114
м | 236 | s | 115
н | 237 | t | 116
о | 238 | u | 117
п | 239 | v | 118
р | 240 | w | 119
с | 241 | x | 120
т | 242 | y | 121
у | 243 | z | 122
ф | 244 |  |
х | 245 |  |
ц | 246 |  |
ч | 247 |  |
ш | 248 |  |
щ | 249 |  |
ъ | 250 |  |
ы | 251 |  |
ь | 252 |  |
э | 253 |  |
ю | 254 |  |
я | 255 |  |

Перейти к началу раздела Администрирование.


28. Ограничение разрешенных действий для пользователей, имеющих временный доступ к компьютеру.

Вариант 1.

1.1) Запустите оснастку Локальные пользователи и группы (Win   + R → lusrmgr.msc → ОК)
1.2) Включите встроенную гостевую учетную запись пользователя. Дважды щелкните на профиль Гость, уберите флажок с Отключить учетную запись и нажмите OK.
1.3) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей и нажимаете ссылку Управление другой учетной записью.
При желании, можете поставить на свою учетную запись пароль.
1.4) Нажмите на учетную запись Гость, а затем нажмите на кнопку Включить.
1.5) Для перехода в гостевую учетную запись щелкните на стрелочке рядом с Завершение работы и выберите пункт Сменить пользователя. Обратный переход аналогично.

Вариант 2.

2.1.1) Запустите оснастку Редактор локальной групповой политики (Win   + R → gpedit.msc → ОК)
2.1.2) В Административные шаблоны, дважды щелкните на элементе Все параметры
2.1.3) Отсортируйте элементы по-названию.
2.1.4) Включите необходимые Вам параметры начинающиеся со слов Запретить .... Для этого, дважды щелкните на необходимом элементе установите переключатель в значение Включить и нажмите Ок.

Также в оснастке Редактор локальной групповой политики Вы можете осуществлять контроль за приложениями, на основе создаваемых Вами правил, разрешать или запрещать запуск затрагиваемых файлов, основываясь на их атрибутах. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные конкретным издателем (например, Microsoft) или находящиеся по определеному пути (Например: C:\Program Files\Mozilla Firefox). Для этого Вам необходимо создать Исполняемые правила, используя мастер правил AppLocker.
Для создания нового правила сделайте следующее:

2.2.1) Пройдите в Конфигурация компьютера → Конфигурация Windows → Параметры безопасности → Политики управления приложениями → AppLocker.
2.2.2) Нажмите на Исполняемые правила
2.2.3) В меню оснастки Редактор локальной групповой политики нажмите Действие и выберите пункт Создать новое правило..., также Вы можете щелкнуть правой кнопкой мыши в правой части окна и также выбрать из списка пункт Создать новое правило....

Вариант 3.

3) Воспользуйтесь программой Deep Freeze или аналогичной ей, данная программа позволяет заморозить текущее состояние системы. С её помощью можно сохранить текущую конфигурацию системы, к которой машина будет автоматически возвращаться после перезагрузки. При этом абсолютно не имеет значения что делает пользователь - устанавливает новые программы, удаляет системные файлы или работает в сети - после перезагрузки вы получите девственно чистую машину.
Для отключения Deep Freeze надо нажать Ctrl + ⇑ Shift + Alt + F6 и выбрать Boot Thawed, для удаления Deep Freeze сначала его надо отключить, а потом запустить установочный файл и выбрать Uninstall.

Перейти к началу раздела Администрирование.


29. Защита доступа к компьютеру с использованием USB Ключа, хранящегося на флеш накопителе.

Если в Вашем распоряжении имеется свободный флэш накопитель в любом его виде, то Вы можете усилить имеющуюся у Вас на компьютере степень защиты Windows от нежелательных пользователей.
Для этого Вам необходимо скачать и установить специальную программу USBLogonKey, которая позволит Вам использовать Ваш флэш накопитель в виде USB ключа для входа в Windows.

Основными возможностями программы являются:

Двух-факторная авторизация: Физический USB ключ + PIN код.
Пароль автоматически передается в систему с USB ключа.
Удобная авто-блокировка компьютера – при отключении USB флэш диска. Вернулись – подключили USB диск, и вы снова в работе – не отвлекаясь на пароли.
Данные на USB ключе зашифрованы алгоритмом AES-256 (стандарт шифрования в США). Ключ невозможно подделать путем копирования файлов на другой диск. Пароль на ключе в открытом виде не хранится.
Защиту компьютера невозможно обойти, загрузив компьютер в Safe Mode (безопасный режим загрузки Windows, где многие программы защиты отключены).
PIN код для защиты USB ключа от нежелательного использования для входа в систему.

Настройка USB-Ключа:

1) Подключите Ваш флеш накопитель, установите данную программу и запустите ее.
2) Нажмите Настроить USB Ключ
Большинство дальнейших настроек в данном окне происходит при нажатии на соответствующую ссылку.
2.1) Выберите пользователя, который будет входить с данным USB Ключем
2.2) Если у Вас одновременно подключено несколько флеш накопителей, то укажите какой из них необходимо использовать в виде USB Ключа.
2.3) Введите Ваш текущий пароль к Windows установленный в системе.
2.4) Установите PIN код для защиты USB Ключа.
2.5) Настройте аварийный вход в систему, для этого напишите один или несколько вопросов и ответы на них.
2.6) Нажмите кнопку Настроить USB Ключ.
2.7) В появившемся окне, сообщающем, что USB Ключ успешно установлен, нажмите кнопку ОК и Вы вернетесь обратно в основное окно.
3) Нажмите кнопку Настроить опции.
3.1) Установите какое действие будет выполняться при отключении USB Ключа.
3.2) Установите флажок Разрешить вход в Windows только с помощью USB Ключа.
3.3) Оставьте установленным флажок USB Ключ будет работать в SafeMode. Данное действие позволит сохранить Вашу защиту в безопасном режиме Windows.
3.4) Укажите количество допустимых ошибок при наборе PIN кода.
3.5) Нажмите кнопку ОК для возвращения в основное окно.

Создание сложного пароля.

4) Если Ваш текущий пароль к Windows кажется Вам легким, то для создания нового пароля в основном окне программы нажмите кнопку Сменить пароль.
4.1) Введите Ваш PIN код, созданный на шаге 2.4 данной инструкции и нажмите кнопку ОК.
4.2) Нажмите на ссылку Создать сложный пароль, для генерации случайного цифро-буквенного пароля или введите новый пароль самостоятельно.
4.3) Создайте подсказку к паролю в случае необходимости.
4.4) Нажмите кнопку Сменить пароль. В новом открывшемся окне нажмите кнопку ДА, а затем кнопку ОК.
5) Закройте окно программы и перезагрузите компьютер.

Хотя данная программа позволяет создать сложный пароль, рекомендуется использовать данную возможность только лишь для генерации сложных паролей, а сам пароль менять непосредственно в системе.
При замене пароля на новый в системе не забудьте выполнить заново действия до шага 2.7 данной инструкции.

Неверный ввод PIN кода:

В случае неверного ввода PIN кода, Вы будете предупреждены об этом. После использования всех попыток для правильного ввода - USB ключ будет заблокирован.
Войти в систему будет возможно только при помощи аварийного входа, ответив правильно на вопрос созданный на шаге 2.5 данной инструкции.
Если Вы генерировали программой сложный цифро-буквенный пароль, то в конце диалога восстановления измените его на собственный, так как если Вы оставите текущий пароль без изменений, то Вам после перезагрузки необходимо будет его ввести.
Впрочем, если Вы этого не сделали то, после перезагрузки в окне пользователей нажмите кнопку Сменить пользователя, выберите пункт Войти с USB Ключом и заново нажмите Аварийный вход и измените пароль на собственный.

Разблокировка ключа:

1) Войдите в Windows используя заново созданный пароль и запустите программу для настройки USB Ключа
2) Нажмите Настроить USB Ключ
3) Нажмите ссылку Снять блокировку, введите PIN код и нажмите кнопку ОК.

Теперь Вы снова можете использовать данный USB Ключ. Не забудьте заново установить новый сложный пароль.

Перейти к началу раздела Администрирование.


30. Отслеживание изменений на диске и в реестре, путем сравнения снимков системы.

Если Вы контролируете состояние Windows, то Вам может оказаться полезна программа SysTracer.
Данная программа используется для снятия снимков состояния системы, с целью их дальнейшего сравнения с другими снимками этой же системы. Данная программа позволяет отследить:

- изменения реестра
- изменения файловой системы
- изменения запущенных служб и процессов
- изменения установленных приложений и библиотек

Инструкция использования:

1) Скачайте программу SysTracer с официального сайта или зеркала.
2) Запустите программу и на вкладке Snapshots нажмите кнопку Take snapshot.
3) Задайте название для снимка в текстовом поле Name и нажмите кнопку Start.
Это создаст снимок текущего состояния системы.
После внесения каких-либо изменений в систему (например установка/удаление программы) создайте новый снимок текущего состояния системы.
4) В ниспадающем списке напротив Compare snapshot выберите начальный снимок системы.
5) В ниспадающем списке напротив with выберите снимок, созданный после внесения изменений в систему.
6) Нажмите кнопку Compare для выявления внесенных изменений в систему.
7) Установите переключатель напротив View mode в значение Only differences - это покажет только различия.

Изменения в реестре Вы можете посмотреть на вкладке Registry. Изменения в файловой системе Вы можете увидеть на вкладке Files. Запущенные или завершенные процессы, библиотеки, службы будут указаны на вкладке Aplications.

Вновь добавленные элементы будут отмечены зеленым, измененные - синим, а удаленные элементы - красным цветом.

Для удаления снимка(-ов), выделите его(их) и нажмите кнопку Delete snapshot(s).

Перейти к началу раздела Администрирование.


31. Добавление пункта "Запуск от имени администратора" в контекстное меню для VBS-скриптов.

Если Вы не работаете под встроенной учетной записью администратора, то запустить VBS-скрипт напрямую Вы не сможете.
Одним из решений для данной ситуации является добавление в контекстное меню VBS-скриптов пункта "Запуск от имени администратора".
Данный пункт позволит Вам запускать VBS-скрипты сразу из Проводника, не используя командную строку запущенную от имени администратора.

1) Скачайте архив elevateWHSScript.zip с официального сайта или с зеркала и распакуйте его в отдельную папку.
2) Нажмите правой кнопкой мыши на файле ElevateWSHScript.inf и выберите в контекстном меню пункт Установить.

После выполнения установки в контекстном меню VBS-скриптов появится пункт Запуск от имени администратора.
Чтобы удалить данный пункт из контекстного меню: откройте Пуск → Панель управления → Программы и компоненты и выберите запись Повышение прав для WSH скриптов.

Перейти к началу раздела Администрирование.


32. Отключение контроля учетных записей (UAC) только для администраторов.

Многие предпочитают отключать контроль учетных записей (UAC), для отключения уведомлений.
Если же на компьютере, присутствуют учетные записи без привилегий администратора, то наиболее правильным вариантом будет отключение UAC, только для учетных записей с привилегиями администратора.

Чтобы это сделать, Вам необходимо воспользоваться оснасткой Локальная политика безопасности:

1) Нажмите кнопку Пуск, в строке поиска введите команду secpol.msc и нажмите клавишу Enter ↵.
2) Откройте Локальные политики → Параметры безопасности
3) Дважды щелкните на Контроль учетных записей: поведение запроса на повышение прав для администраторов в режиме одобрения администратором
4) В ниспадающем списке выберите пункт Повышение без запроса и нажмите кнопку ОК.
5) Закройте оснастку Локальная политика безопасности и перезагрузите компьютер.

Перейти к началу раздела Администрирование.


33. Запрещение закрепления программ в меню Пуск и на панели задач.

Если Вам необходимо запретить закрепление программ на панели задач или в меню Пуск, то воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1.

1) В строке поиска меню Пуск введите команду gpedit.msc и нажмите Enter ↵.
2) Перейдите в раздел Конфигурация пользователя → Административные шаблоны → Меню «Пуск» и панель задач.
3) Нажмите правой кнопкой мыши на необходимом параметре и выберете пункт Изменить:

Запретить закрепление программ в панели задач - Удаляет пункт из контекстного меню, а уже закрепленные значки остаются.
Удалить закрепленные программы из панели задач - Удаляет пункт из контекстного меню, а уже закрепленные значки будут скрыты (не удалены).
Удалить список программ, закрепленных в меню "Пуск" - Удаляет пункт из контекстного меню, а уже закрепленные значки будут скрыты (не удалены).

4) В открывшемся окне установите переключатель в значение Включить.
5) Нажмите OK и закройте Редактор локальной групповой политики.
6) Перезагрузите компьютер.

Вариант 2.

Создайте и примените необходимый Вам reg-файл из указанных ниже, а после его применения перезагрузите компьютер.

Запретить закрепление программ в панели задач:

Удалить закрепленные программы из панели задач:

Удалить список программ, закрепленных в меню "Пуск":

Перейти к началу раздела Администрирование.


34. Добавление оснастки "Редактор локальной групповой политики" в папку Администрирование или в Панель управления.

Чтобы добавить оснастку Редактор локальной групповой политики в папку Администрирование:

1) Откройте папку C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools
2) Щелкните правой кнопкой мыши по свободному пространству папки и выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите:

4) Нажмите кнопку Далее и укажите в качестве названия ярлыка наименование оснастки - Редактор локальной групповой политики.
5) Нажмите на кнопку Готово.
6) Нажмите правой кнопкой мыши на созданном Вами ярлыке и выберите пункт Свойства.
7) Укажите в строке Комментарий фразу: Эта оснастка позволяет редактировать объекты локальной групповой политики, хранимые на компьютере.
8) Нажмите ОК для сохранения изменений.

Для добавления оснастки Редактор локальной групповой политики в Панель управления, создайте и примените reg-файл, указанного ниже содержания:

Для удаления данной оснастки из Панели управления, создайте и примените reg-файл, указанного ниже содержания:

Перейти к началу раздела Администрирование.


35. Удаление точки восстановления системы, а также извлечение из нее необходимого Вам файла или папки.

Еженедельно в системе автоматически создаются контрольные точки восстановления.
Также это происходит перед значительными системными событиями, такими как установка программ или драйверов устройств.
Если Вы желаете удалить неактуальную для Вас точку восстановления или извлечь из нее какие-нибудь файлы и папки, не применяя самой точки восстановления, то в этом Вам поможет программа System Restore Explorer.

1) Скачайте версию требующую установки с официального сайта или портативную версию с альтернативной ссылки.
2.1) Для версии требующей установки: Установите программу, откройте Пуск → Все программы → System Restore Explorer и запустите ее.
2.2) Для портативной версии: Распакуйте архив в любую папку и запустите программу.

Чтобы удалить какую-либо точку восстановления системы:

1) Выберите желаемую точку восстановления и нажмите клавишу Delete.
2) В открывшемся окне нажмите кнопку Да.

Чтобы извлечь какой-либо файл, папку или несколько файлов и папок из точки восстановления:

1) Выберите желаемую точку восстановления и нажмите кнопку Mount.
Указанная Вами точка восстановления будет смонтирована в систему и открыта в Проводнике, как обычная папка (Например: C:\HarddiskVolumeShadowCopy2).
2) Скопируйте необходимые Вам папки и файлы в любую другую папку (Например: D:\Recovered).
3) Переключитесь обратно в программу System Restore Explorer и нажмите кнопку Unmount.

Перейти к началу раздела Администрирование.


36. Создание и использование флеш-диска для сброса пароля своей учетной записи.

Для создания флеш-диска для сброса пароля выполните указанные ниже действия:

1.1.1) Откройте Пуск → Выполнить (Win   + R)
1.1.2) Введите указанную ниже команду и нажмите Enter ↵.

1.2) Либо введите в строке поиска меню Пуск слово: пароля и выберите пункт Создание дискеты сброса пароля.
2) Подсоедините флеш-диск к Вашему компьютеру и нажмите кнопку Далее.
3) Выберите в ниспадающем меню Ваш флеш-диск и нажмите кнопку Далее.
4) Введите текущий пароль для учетной записи из которой Вы создаете флеш-диск для сброса пароля и нажмите кнопку Далее.
5) Дождитесь надписи Выполнено: 100% и нажмите кнопку Далее.
6) Нажмите кнопку Готово для завершения работы мастера создания флеш-диска для сброса пароля.

Для использования флеш-диска для сброса пароля выполните указанные ниже действия:

1) Введите на экране пользователей неправильный пароль в поле для ввода пароля к учетной записи и нажмите Enter ↵.
2) Подсоедините флеш-диск к Вашему компьютеру и нажмите на появившуюся ссылку Восстановить пароль...
Если у Вас включено использование классического окна для входа в систему, то данная ссылка появится, только после верного ведения имени пользователя.
3) В открывшемся окне Мастер сброса пароля нажмите кнопку Далее.
4) Выберите в ниспадающем меню Ваш флеш-диск и нажмите кнопку Далее.
5) Введите новый пароль в первом и втором текстовом поле.
6) Введите подсказку для восстановления забытого пароля и нажмите кнопку Далее.
7) Нажмите кнопку Готово для завершения работы мастера сброса пароля.
Примечание: Вам не надо создавать заново флеш-диск для сброса пароля, так как новый пароль будет записан на него взамен старого.
8) Введите Ваш новый пароль в поле для ввода пароля к учетной записи и нажмите Enter ↵ для входа в систему.

Перейти к началу раздела Администрирование.


37. Установка оснасток "Редактор локальной групповой политики" (облегченная версия) и "Локальная политика безопасности" (полная версия) в редакциях Windows 7 Starter/Home Basic/Home Premium/Professional.

В редакциях Windows 7 Starter/Home Basic/Home Premium/Professional отсутствует возможность использования оснасток Редактор локальной групповой политики и Локальная политика безопасности.
Вы можете воспользоваться указанным ниже решением, чтобы установить облегченную версию оснастки gpedit.msc и полнофункциональную версию secpol.msc.

1) Скачайте архив gpedit+secpol.zip и распакуйте его в любую папку.
2) Запустите от имени администратора файл Gpedit Installer.exe.
3) Скопируйте в папку C:\Windows\System32 с заменой файлы gpedit.dll, gpedit.msc и secpol.msc.
Для 64-битной версии скопируйте их дополнительно в папку C:\Windows\SysWOW64.
4) Перезагрузите компьютер.

Теперь Вы можете пользоваться облегченной версией оснастки Редактор локальной групповой политики (gpedit.msc) и полнофункциональной версией оснастки Локальная политика безопасности (secpol.msc).
Для их запуска:

1) Откройте меню Выполнить: Пуск → Выполнить (либо Win   + R)
2) Введите gpedit.msc или secpol.msc и нажмите Enter ↵.

Перейти к началу раздела Администрирование.


38. Включение шифрования файла подкачки.

Если Вы желаете повысить безопасность Вашего компьютера, то включите шифрование файла подкачки.
Это поможет сберечь от злоумышленников приватные данные, которые могут оказаться в файле подкачки.

Вариант 1.

1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
2) Введите в командной строке необходимые Вам команды из указанных ниже и нажмите Enter ↵.

Включение шифрования файла подкачки:

Отключение шифрования файла подкачки:

Проверка текущего состояния шифрования файла подкачки:

3) Перезагрузите компьютер.

Вариант 2.

Создайте и примените один из указанных ниже reg-файлов, после чего перезагрузите компьютер.

Включение шифрования файла подкачки:

Отключение шифрования файла подкачки:

Перейти к началу раздела Администрирование.


Администрирование.

1. Получение полного доступа к файлу или папке.

Если Вам приходится копировать/перемещать файлы в системные папки с заменой имеющегося файла, то Вам может пригодиться решение, добавляющее в контекстное меню файлов и папок пункт "Стать владельцем и задать полный доступ к объекту". Это сэкономит Вам время затрачиваемое на смену владельца и прав, а также упростит данное действие.

1) Создайте необходимый Вам reg-файл, в зависимости от установленной версии Windows.
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "admin.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Если у Вас установлена изначально русская версия Windows скопируйте данный текст:

Если у Вас установлена изначально английская версия Windows + русский языковой пакет скопируйте данный текст:

2) Примените созданный Вами reg-файл.
2.1) Щелкните на reg-файле правой кнопкой мыши и выберите пункт Слияние (Merge).
2.2) Нажмите в первом появившемся окне кнопку Да (Yes), а в следующем кнопку ОК.

Чтобы воспользоваться добавленным пунктом меню:

1) Щелкните на файле или папке правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту".
2) В любых окнах, если они появятся нажимите кнопку Да(Yes).

Скачать готовые reg-файлы: Full_access.zip

Full_access_eng.reg - примените, если Вы используете английскую версию Windows.
Название пункта меню указано на английском языке, название группы администраторов указано на английском языке.
Full_access_eng+rus_mui.reg - примените, если Вы используете английскую версию Windows и русский языковой пакет.
Название пункта меню указано на русском языке, название группы администраторов указано на английском языке.
Full_access_rus.reg - примените, если Вы используете русскую версию Windows.
Название пункта меню указано на русском языке, название группы русском указано на английском языке.

Если Вы не знаете на каком языке у Вас названа группа администраторов, то чтобы это узнать выполните следующие действия.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

Если Вам необходимо изменить права доступа, а после использования файла вернуть все права обратно, то Вы можете воспользоваться программой TakeOwnershipEx, которая обладает следующими возможностями:

  • Получение прав на один или сразу несколько файлов. В диалоге открытия Вы можете выбрать сразу несколько файлов, выделяя их мышкой и удерживая клавишу Ctrl или ⇑ Shift.
    Выбранным файлам в качестве владельца выставляется группа локальных "Администраторов", и предоставляется полный доступ для этой группы.

  • Восстановление прав. Если Вы получили права владельца и полный доступ, утилита запоминает, какие права у файла были до этого, и потом Вы в любой момент можете их вернуть на место.

    • 2. Запуск командной строки от имени (с правами) администратора.

    Если Вы работаете под учетной записью обычного администратора, то командная строка от имени администратора запускается так:

    Вариант 1.

    1) В строке поиска меню Пуск введите команду: cmd.
    2) Щелкните на найденном файле cmd.exe правой кнопкой мыши и выберите пункт Запуск от имени администратора

    Вариант 2.

    В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.

    Вариант 3.

    1) Нажмите кнопку Пуск
    2) Перейдите Все Программы → Стандартные
    3) Щелкните правой кнопкой мыши на Командная строка и выберите пункт Запуск от имени администратора.

    Если Вы работаете под встроенной учетной записью администратора, то кроме указанных выше вариантов Вы можете использовать еще один вариант:

    Вариант 4.

    1) Запустите диалоговое меню Выполнить.
    В зависимости от Ваших настроек: Откройте Пуск → Выполнить или нажмите комбинацию клавиш Win   + R.
    2) Введите команду: cmd и нажмите Enter ↵.

    Вариант 5.

    В адресной строке Проводника введите %ComSpec% и нажмите Enter ↵. Данное действие откроет окно команд, с указанием в пути папки из которой было запущено.

    3. Изменение прав доступа и владельца для файла (папки), используя Проводник или командную строку.

    Случается, что при работе с файлами или папками Вам бывает необходимо изменить для них владельца и права доступа.

    Смена владельца файла или папки, используя Проводник.

    1) Щелкните правой кнопкой мыши на файле или папке и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
    3) Перейдите на вкладку Владелец и нажмите кнопку Изменить.
    4) Выполните одно из следующих действий:

  • Чтобы назначить владельцем пользователя или группу из списка, в окне Изменить владельца на выберите нового владельца и нажмите ОК.
  • Чтобы назначить владельцем пользователя или группу, которых нет в списке:

    • 1) Нажмите кнопку Другие пользователи и группы
    2) Если владельцем необходимо установить службу TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    3) Если владельцем необходимо другого пользователя или группу, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    3.1) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.

    5) В окне Изменить владельца на: выберите добавленную группу или пользователя.
    6) Чтобы сменить владельца всех субконтейнеров и объектов в папке, установите флажок Заменить владельца субконтейнеров и объектов и нажмите кнопку ОК.

    Изменение разрешений для доступа к файлам и папкам, используя Проводник.

    1) Щелкните правой кнопкой мыши на файле или папке и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
    3) Нажмите кнопку Изменить разрешения и выполните одно из следующих действий:
    3.1) Чтобы изменить разрешения для существующей группы или пользователя, выберите имя этой группы или пользователя и нажмите кнопку Изменить.
    3.1.1) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.
    3.2) Чтобы изменить разрешения для группы или пользователя, которого нет в списке Элементы разрешений, нажмите кнопку Добавить.

    3.2.1) Если необходимо изменить разрешения для службы TrustedInstaller, в качестве имени объекта в поле Введите имена выбираемых объектов (примеры) введите: NT SERVICE\TrustedInstaller и нажмите кнопку ОК.
    3.2.2) Если необходимо изменить разрешения для другого пользователя или группы, то нажмите кнопку Дополнительно, а затем кнопку Поиск.
    3.2.3) В результатах поиска выберите необходимую Вам группу или пользователя и нажмите кнопку ОК.
    3.2.4) Установите необходимые Вам флажки Разрешить или Запретить напротив каждого разрешения и нажмите кнопку ОК, а затем кнопку Применить.

    3.3) Чтобы удалить группу или пользователя из списка Элементы разрешений, нажмите кнопку Удалить.

    Далее рассказывается как можно изменить разрешения или сменить владельца, используя командную строку запущенную от имени администратора.
    Если после использовании команды, разрешения или владелец не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение владельца файла (папки) на указанного Вами пользователя, используя командную строку.

    Примеры:

    Параметры:

    /T - операция выполняется для всех соответствующих файлов и каталогов, расположенных в указанных в имени каталогах.
    /C - выполнение операции продолжается при любых файловых ошибках. Сообщения об ошибках по-прежнему выводятся на экран.
    /L - операция выполняется над самой символической ссылкой, а не над ее целевым объектом.
    /Q - команда icacls подавляет сообщения об успешном выполнении.

    Изменение разрешений для файла (папки), используя командную строку.

    Разрешения:

    F - полный доступ
    M - доступ на изменение
    RX - доступ на чтение и выполнение
    R - доступ только на чтение
    W - доступ только на запись
    D - доступ на удаление

    Примеры:

    Об остальных возможностях команды icacls Вы сможете узнать введя команду: icacls /?

    4. Автоматический вход в систему и отключение экрана пользователей при запуске.

    Если Вы являетесь единственным пользавателем компьютера и используете для входа в систему пароль, то Вы можете автоматизировать процесс ввода пароля при входе в систему.
    Для этого выполните указанные ниже действия.

    1) Нажмите на клавиатуре Win   + R .
    2) В появившемся окне введите команду: netplwiz или control userpasswords2 и нажмите Enter ↵.
    3) В окне Учетные записи пользователей во вкладке Пользователи выделите свою учетную запись и уберите флажок напротив Требовать ввод имени пользователя и пароля.
    4) Нажмите Принять.
    5) В открывшемся окне Автоматический вход в систему будут три поля - Пользователь, Пароль и Подтверждение.
    Введите свой пароль в поле Пароль и еще раз - в поле Подтверждение и нажмите ОК.
    6) Перезагрузите компьютер.

    5. Отключение или изменение параметров контроля учетных записей (UAC).

    1) Нажмите на клавиатуре комбинацию клавиш Win   + R.
    2) Введите: UserAccountControlSettings и нажмите клавишу Enter ↵.
    3) Для установки минимального значения передвиньте ползунок на предпоследнее деление и нажмите кнопку ОК.
    4) Для отключения контроля учетных записей (UAC) передвиньте ползунок на последнее деление и нажмите кнопку ОК.
    5) Перезагрузите компьютер.

    6. Быстрый запуск программы с правами администратора.

    Удерживая Ctrl + ⇑ Shift нажмите на иконку приложения (у Вашей учетной записи, должны быть права администратора).

    7. Убирание запрещающего значка с папки.

    1) Нажмите правой кнопкой мыши на папке с которой Вы хотите убрать значок замка и выберите Свойства
    2) Перейдите на вкладку Безопасность
    3) Нажимите на кнопки Изменить → Добавить → Дополнительно → Поиск
    4) В результатах поиска удерживая нажатой клавишу Ctrl, выберите следующие имена: система; Администраторы; Прошедшие проверку; и нажмите ОК
    5) В окне группы или пользователи выберите система; и установите флажок на Полный доступ, после выберите Администраторы; и снова установите флажок на Полный доступ, а затем выберите Прошедшие проверку; и также установите флажок на Полный доступ.
    6) Нажмите ОК

    При возникновении окон "Ошибка применения безопасности" нажмите Продолжить.

    Также Вы можете воспользоваться следующим решением.

    1) Создайте и примените reg-файл(например: admin.reg) как описано в Администрирование: 1. Получение полного доступа к файлу или папке.
    2) Щелкните на папке и выберите пункт "Стать владельцем и задать полный доступ к объекту"
    3) В любых окнах, если они появятся нажмите Да(Yes)

    8. Запуск приложений в Windows 7 c повышенными привилегиями без отключения UAC.

    Многие пользователи считают функцию контроля учётных записей(UAC) в Windows 7 весьма полезной и не отключают её . Но иногда всё же требуется запустить приложение с повышенными правами, а некоторые приложения, такие как, например, Sysinternals Process Explorer (английская версия или русская версия) или Sysinternals AutoRuns (английская версия или русская версия), и вовсе лучше всегда запускать с повышенными привилегиями.
    Конечно, Вы можете воспользоваться одним из простых способов, и постоянно щелкать уведомления UAC:

    1) Нажмите правой клавишей мыши по значку нужного приложения и выберите пункт "Запуск от имени администратора"
    2) Нажмите Пуск, в строке поиска наберите нужную команду и нажмите Ctrl + ⇑ Shift + Enter ↵.
    3) Щелкните правой клавишей мыши по нужному ярлыку и выберите пункт "Свойства". Или перейдите на вкладку "Совместимость" и установите флажок "Выполнять эту программу от имени администратора"

    Есть также и другой способ, через создание высокопривилегированной задачи системного планировщика заданий. Способ немного сложнее предыдущих, но запросы UAC не отображаются.

    1) Запускаете планировщик заданий (Пуск → Все программы → Стандартные → Служебные → Планировщик заданий)
    2) Нажимаете "Создать задачу"
    3) Указываете Имя для новой задачи и ставите флажок "Выполнять с наивысшими правами"
    4) Переходите на вкладку Действия, нажимаете "Создать", в следующем окне нажимаем "Обзор"
    5) Указываете путь к нужному приложению и нажимаете "Открыть"
    6) Нажимаете "ОК", затем снова "ОК"
    7) Создайте ярлык на рабочем столе ( Нажмите правую кнопку мыши, выберете "Создать" → "Ярлык")
    8) В поле Расположение объекта введите:

    где mytask_admin - имя созданной нами задачи. Если в имеми содержаться пробелы, обязательно укажите его в кавычках.
    9) Введите имя ярлыка и нажмите Готово

    Но есть и более легкий способ, создания ярлыка, при запуске которого не отображаются запросы UAC - это использовать приложение Elevated Shortcut.
    Оно автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает на рабочем столе необходимый ярлык. Просто перетащите необходимый исполняемый файл на окно программы Elevated Shortcut.

    Ссылка для скачивания: ElevatedShortcut.zip

    9. Переименование учетных записей и перемещение их папок профиля.

    Чтобы переименовать учетную запись и/или переместить ее папку профиля, воспользуйтесь одним из предложенных ниже вариантов.

    Вариант 1. Переименование не активированной встроенной учетной записи администратора и перемещение ее папки профиля.

    Для переименования профиля выполните действия указанные в пунктах с первого по пятый.
    Если переименовывать папку не требуется, а необходимо только перенести, то перейдите сразу к шестому пункту.

    1) Откройте меню Выполнить: Пуск → Выполнить (либо Win   + R)
    2) Введите secpol.msc и нажмите Enter ↵.
    3) Перейдите в Локальные Политики → Параметры Безопасности
    4) Щелкните правой кнопкой на параметре "Учетные записи: переименование учетной записи администратора" и выберите пункт Свойства.
    5) В текстовом поле введите желаемое имя для встроенной учетной записи администратора (Например: Super-Admin) и нажмите кнопку ОК.
    6) Введите в строке поиска меню Пуск команду: cmd, нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени администратора".
    7) Введите в командной строке указанную ниже командуEnter ↵

    Вместо Имя_пользователя укажите имя встроенной учетной записи администратора.
    Администратор - для русской версии, Administrator - для английской версии с русским языковым пакетом.
    Либо укажите заданное Вами имя (Например, Super-Admin), если Вы изменили стандартное.

    8) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
    9) На экране пользователей выберите встроенную учетную запись администратора (Например: Super-Admin).
    10) После загрузки рабочего стола, нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
    11) На экране пользователей выберите обычную учетную запись администратора.
    12) Откройте папку C:\Users и скопируйте Вашу папку профиля встроенной учетной записи администратора в любое желаемое место (Например в D:\Accounts).
    13) Скачайте и запустите скрипт SIDList.vbs для выяснения, какое значение идентификатора безопасности пользователя (SID) соответствует, Вашей учетной записи (Username).
    14) Введите в строке поиска меню Пуск команду: regedit, нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени администратора".
    15) Перейдите к разделу: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – уточненный Вами идентификатор безопасности пользователя.
    16) Щелкните правой кнопкой мыши на параметре ProfileImagePath и укажите новое расположение для папки профиля встроенной учетной записи администратора. (Например в D:\Accounts\Super-Admin)
    17) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
    18) На экране пользователей выберите встроенную учетную запись администратора (Например: Super-Admin).
    19) Откройте папку C:\Users и удалите Вашу старую папку профиля встроенной учетной записи администратора. (Например: C:\Users\Super-Admin)

    Вариант 2. Переименование любой учетной записи и перемещение ее папки профиля.

    Для переименования профиля выполните действия указанные в пунктах с первого по двенадцатый.
    Если переименовывать папку не требуется, а необходимо только перенести, то перейдите сразу к тринадцатому пункту.

    1) Откройте Пуск → Панель управления → Учетные записи пользователей и нажмите на ссылку Управление другой учетной записью.
    2)Нажмите на Вашу учетную запись и на открывшейся странице выберите пункт Создание учетной записи.
    3) Введите имя для временной учетной записи (Например: Test), установите переключатель в значение Администратор и нажмите кнопку Создание учетной записи.
    4) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
    5) На экране пользователей выберите созданную Вами временную учетную запись. (Например: Test)
    6) Скачайте и установите программу Unlocker.
    7) Откройте меню Выполнить: Пуск → Выполнить (либо Win   + R)
    8) Введите netplwiz, нажмите Enter ↵.
    9) Установите флажок Требовать ввод имени пользователя и пароля
    10) Выделите учетную запись, которую Вы желаете переименовать и нажмите кнопку Свойства.
    11) В текстовом поле Пользователь введите новое имя для Вашей учетной записи и нажмите кнопку ОК.
    12) Снимите флажок Требовать ввод имени пользователя и пароля и нажмите кнопку ОК и еще раз ОК.
    13) Откройте папку C:\Users, нажмите на папке профиля Вашей учетной записи правой кнопкой мыши и выберите пункт Unlocker.
    14) В ниспадающем списке выберите Переименовать, укажите новое имя папки профиля Вашей учетной записи, соответствующее Вашему новому имени пользователя и нажмите кнопку ОК. (Например: NewUser)
    15) Нажмите на кнопку Разблокировать Все, либо кнопку ОК.
    16) Снова нажмите на папке профиля Вашей учетной записи правой кнопкой мыши и выберите пункт Unlocker.
    17) В ниспадающем списке выберите Переместить, укажите новое расположение папки профиля Вашей учетной записи и нажмите кнопку ОК. (Например в D:\Accounts)
    18) Нажмите на кнопку Разблокировать Все, либо кнопку ОК.
    19) Скачайте и запустите скрипт SIDList.vbs для выяснения, какое значение идентификатора безопасности пользователя (SID) соответствует, Вашей учетной записи (Username).
    20) Введите в строке поиска меню Пуск команду: regedit, нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени администратора".
    21) Перейдите к разделу: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\SID, где SID – уточненный Вами идентификатор безопасности пользователя.
    22) Щелкните правой кнопкой мыши на параметре ProfileImagePath и укажите новое расположение для папки профиля Вашей учетной записи. (Например в D:\Accounts\NewUser)
    23) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
    24) На экране пользователей выберите Вашу переименнованную/перемещенную учетную запись (Например: NewUser).
    25) Откройте Пуск → Панель управления → Учетные записи пользователей и нажмите на ссылку Управление другой учетной записью.
    26) Нажмите на временную учетную запись и на открывшейся странице выберите пункт Удаление учетной записи.
    27) Нажмите на кнопку Удалить файлы, а затем на кнопку Удаление учетной записи.

    Вариант 3. Перемещение папки профиля, путем создания символической ссылки (точки соединения) на перемещенную папку профиля.

    1) Откройте Пуск → Панель управления → Учетные записи пользователей и нажмите на ссылку Управление другой учетной записью.
    2)Нажмите на Вашу учетную запись и на открывшейся странице выберите пункт Создание учетной записи.
    3) Введите имя для временной учетной записи (Например: Test), установите переключатель в значение Администратор и нажмите кнопку Создание учетной записи.
    4) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
    5) На экране пользователей выберите созданную Вами временную учетную запись. (Например: Test)
    6) Скачайте и установите программу Unlocker.
    7) Откройте папку C:\Users, нажмите на папке профиля Вашей учетной записи правой кнопкой мыши и выберите пункт Unlocker.
    8) Нажмите на папке профиля Вашей учетной записи правой кнопкой мыши и выберите пункт Unlocker.
    9) В ниспадающем списке выберите Переместить, укажите новое расположение папки профиля Вашей учетной записи и нажмите кнопку ОК. (Например в D:\Accounts)
    10) Нажмите на кнопку Разблокировать Все, либо кнопку ОК.
    11) Скачайте утилиту Junction от SysInternals.
    Она позволяет создавать точки соединения, исполняющие роль символической ссылки одного каталога компьютера на другой каталог.
    12) Скопируете junction.exe из архива в папку C:\Windows\System32.
    13) Создайте символическую ссылку (точку соединения) для перемещенной папки с указанием на предыдущее месторасположение.

    Например:

    14) Нажмите кнопку Пуск → стрелку рядом с Завершение работы → Выйти из системы
    15) На экране пользователей выберите Вашу учетную запись.
    16) Откройте Пуск → Панель управления → Учетные записи пользователей и нажмите на ссылку Управление другой учетной записью.
    17) Нажмите на временную учетную запись и на открывшейся странице выберите пункт Удаление учетной записи.
    18) Нажмите на кнопку Удалить файлы, а затем на кнопку Удаление учетной записи.

    Вариант 4. Изменение пути к каталогам пользователей при установке Windows.

    Вы можете изменить расположение папки Пользователи (Users), в которой будут храниться профили пользователей, ещё при установке Windows.

    1) Создайте файл Autounattend.xml следующего содержания:
    2) Скопируйте его в папку \Sources установочного диска.
    3) Помимо папки \Sources файл Autounnattend.xml следует положить в корень дистрибьютива.

    10. Установка заданных атрибутов для всех файлов с определенным расширением в указанной папке и ее подпапках.

    Если Вы желаете изменить атрибуты для файлов с определенным разрешением в какой-нибудь папке, не используя командную строку, то Вы можете создать для этого специальный скрипт (vbs-файл).

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Attributes.vbs")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    5) Скопируйте полученный файл в папку C:\Windows
    Теперь, когда Вам потребуется задать атрибуты для файлов:
    6) Откройте Пуск → Выполнить (Win   + R)
    7) Введите Attributes.vbs и нажмите Enter ↵.

    Также Вы можете скачать готовый vbs-файл: Attributes.zip

    11. Включение встроенной учетной записи администратора.

    Вариант 1.

    1) Запустите оснастку Локальные пользователи и группы (Local Users an Groups)
    (Win   + R → lusrmgr.msc → ОК)
    2) В меню слева нажмите на папку Пользователи (Users)
    3) Щелкните правой кнопкой учетную запись Администратор (Administrator) и выберите Свойства (Properties).
    4) Откроется окно Свойства: Администратор (Administrator Properties).
    5) На вкладке Общие (General) снимите флажок Отключить учетную запись (Acount is disabled) и нажмите кнопку OK.

    Учетная запись администратора теперь включена.

    Вариант 2.

    1) Нажмите кнопку Пуск
    2) Введите в строке поиска cmd
    3) Щелкните правой кнопкой мыши ярлык командной строки и выберите пункт Запуск от имени администратора

    Для включения встроенной учетной записи Администратор в русской версии Windows используйте команду

    В системе с английской локализацией встроенная учетная запись администратора называется Administrator, поэтому команда будет выглядеть так:

    Чтобы переключиться на данную учетную запись: нажмите на кнопку Пуск, нажмите на стрелочку рядом с Завершение работы и выберите Сменить пользователя.

    12. Изменение фонового рисунка в экране авторизации пользователей (экране приветствия).

    Вариант 1. Использование редактора локальной групповой политики.

    1) Откройте меню Пуск, введите в строке поиска gpedit.msc и нажмите Enter ↵. (Win   + R → gpedit.msc → ОК)
    2) Перейдите по пути слева Конфигурация пользователя → Административные шаблоны → Система → Вход в систему.
    3) Щелкните дважды по параметру Всегда использовать настраиваемый вход в систему.
    4) Установите переключатель на значение Включить и нажмите ОК.
    5) Закройте редактор локальной групповой политики.
    6) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
    7) Поместите сюда jpg-файл Вашего фонового рисунка с разрешением, идентичным рабочему столу.
    8) Переименуйте его в backgroundDefault.jpg

    Размер jpg-изображения не должен превышать 256Кб.
    Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

    Вариант 2. Редактирование реестра Windows.

    1.1) Если Вы не переключаетесь между темами Windows, то создайте ключ типа DWORD с названием OEMBackground в разделе реестра

    1.2) Если Вы переключаетесь между темами Windows, то создайте ключ типа DWORD с названием UseOEMBackground в разделе реестра

    2) Присвойте ему значение 1 (1 означает, что функция включена, 0 - выключена)
    3) Создайте в папке %windir%\system32\oobe\ папку info, а в ней папку backgrounds (%windir%\system32\oobe\info\backgrounds)
    4) Поместите сюда свой файл
    5) Переименуйте его в необходимое имя (зависит от разрешения монитора):

    background768x1280.jpg
    background900x1440.jpg
    background960x1280.jpg
    background1024x1280.jpg
    background1280x1024.jpg
    background1024x768.jpg
    background1280x960.jpg
    background1600x1200.jpg
    background1440x900.jpg
    background1920x1200.jpg
    background1280x768.jpg
    background1360x768.jpg
    backgroundDefault.jpg - в случае использования другого разрешения монитора

    Размер изображений не должен превышать 256Кб.
    Если же изображение не может быть загружено по иным причинам (неверное соотношение сторон, размер и т.д.), загружается стандартное изображение из файла imagesres.dll.

    Вариант 3. Редактирование файла imageres.dll.

    1) Откройте с помощью программы Restorator файл C:\Windows\System32\imageres.dll
    2) Откройте папку IMAGE и замените ресурсы с 5031 по 5043 файлами jpg-изображений, которыми Вы хотите заменить фоновый рисунок экрана авторизации пользователей (экрана приветствия). Каждое Ваше jpg-изображение должно иметь идентичное разрешение и глубину цвета, соответствующее замещаемому ресурсу.
    3) Сохраните внесенные изменения нажав Ctrl + S
    4) Перезагрузите компьютер.

    Вариант 4. Использование специальной программы.

    1) Скачайте архив программы tweakslogon.zip
    2) Разархивируйте файл в любую папку и запустите TweaksLogon.exe
    3) Нажмите на кнопку Change Logon Screen.
    4) В открывшемся окне выберите изображение и нажмите Открыть (Open)
    5) Если Ваше изображение больше 245 кб, то программа предложит Вам его сжать. Нажмите Да (Yes)
    6) Если Вы уже меняли с помощью данной программы фоновый рисунок, то программа сообщит вам об этом. Нажмите Ок

    Чтобы вернуть стандартный фоновый рисунок нажмите кнопку Revert to Default Logon Screen.

    13. Установка службы TrustedInstaller в качестве владельца папки или файла.

    У многих системных папок и файлов владельцем, имеющим права доступа на запись/удаление является служба TrustedInstaller. Конечно Вы можете задать права себе, если Вы являетесь администратором на компьютере, но это может привести к неполадкам в работе. Например, если Вы измените владельца папки winsxs для доступа к ней и не вернете обратно права TrustedInstaller, то некоторые программы могут не запуститься.

    Если Вы удалили ее из групп и пользователей в свойствах папки (файла) на вкладке Безопасность, то чтобы вернуть обратно в качестве владельца службу TrustedInstaller Вам необходимо сделать следующее:

    1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
    3) В открывшемся окне перейдите на вкладку Владелец и нажмите кнопку Изменить...
    4) Нажмите кнопку Другие пользователи или группы... , в текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
    5) В окне Изменить владельца на: выберите TrustedInstaller и нажмите ОК.
    Если необходимо также изменить владельца вложенных папок, то перед нажатием на кнопку ОК установите флажок Заменить владельца подконтейнеров и объектов.

    Также Вам необходимо добавить службу TrustedInstaller в список групп и пользователей, имеющих доступ к папке (файлу).

    1) Щелкните правой кнопкой на папке (файле) и выберите пункт Свойства.
    2) Перейдите на вкладку Безопасность
    3) Нажмите кнопку Изменить..., а в открывшемся окне кнопку Добавить... .
    4) В текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
    5) Установите флажок в колонке Разрешить напротив разрешения Полный доступ
    6) Нажмите на кнопки ОК.

    14. Изменение пароля или новой учетной записи администратора, используя средства восстановления системы.

    Чтобы сбросить пароль учётной записи администратора (или создать новую) без использования дополнительных программ, Вам понадобится либо установочный диск Windows 7, либо диск восстановления системы, либо LiveCD с Windows PE.

    Часть №1 - Настройка запуска командной строки перед экраном входа в Windows.

    1) Загрузитесь с установочного диска Windows 7 или с диска восстановления.
    2) Откройте командную строку Восстановление системы → Далее → Командная строка.
    3) Запустите редактор реестра. В командной строке наберите regedit и нажмите Enter ↵.
    4) Выделите раздел HKEY_LOCAL_MACHINE и выберите пункт Загрузить куст в меню Файл.
    5) Перейдите на диск, где установлена Windows 7, и откройте файл: C:\Windows\System32\config\SYSTEM
    6) Введите произвольное имя для загружаемого раздела. Например: NewAdmin.
    7) Перейдите в раздел HKEY_LOCAL_MACHINE\NewAdmin\Setup
    8) Измените значение параметров (Щелчок правой кнопкой мыши на параметре → Изменить):
    8.1) Для параметра CmdLine введите значение cmd.exe и нажмите ОК.
    8.2) Для параметра SetupType измените значение с 0 на 2 и нажмите ОК.
    9) Выделите раздел NewAdmin в HKEY_LOCAL_MACHINEи выберите пункт Выгрузить куст в меню Файл.
    10) Извлеките установочный диск или диск восстановления системы, закройте редактор реестра и командную строку, нажмите Перезагрузка в окне параметров восстановления.

    Часть №2 - Создание нового пароля или новой учетной записи администратора.

    Создание нового пароля.

    1) Продолжайте обычный вход в Windows 7 и перед входом в систему Вы увидите окно командной строки.
    2) Введите команду net user, чтобы отобразить все имеющиеся учётные записи.
    3) Для создания нового пароля введите следующую команду и подтвердите её выполнение клавишей Enter ↵:

    Если имя или пароль содержат пробелы, вводите их в "кавычках".

    Создание новой учётной записи.

    Если у Вас отсутствует учетная запись администратора, то для ее создания введите приведенные ниже команды, нажимая после каждой клавишу Enter ↵.

    Для русской (локализованной) Windows:

    1) Создание нового пользователя.

    2) Добавление пользователя в группу Администраторы (Administrators).

    3) Удаление пользователя из группы Пользователи (Users).

    Для английской Windows:

    1) Создание нового пользователя.

    2) Добавление пользователя в группу Администраторы (Administrators).

    3) Удаление пользователя из группы Пользователи (Users).

    По окончании ввода закройте окно командной строки. Используйте созданную учетную запись для входа в Windows.

    15. Определение процесса которому принадлежит текущее окно.

    1) Скачайте Sysinternals Process Explorer (английская версия или русская версия)
    2) Разархивируйте в любую папку и запустите программу procexp.exe.
    3) На панели инструментов Process Explorer нажмите левой кнопкой мыши на "значок-прицел".
    4) Не отпуская левой кнопки мыши, наведите "прицел" на интересующее Вас окно.
    5) Отпустите кнопку мыши и программа Process Explorer, выделит принадлежащий окну процесс (по умолчанию синим цветом).

    16. Удаление данных о серийном номере из системы для предотвращения его хищения.

    Если Вы имеете твердую или надежную электронную копию серийного номера установленной Windows 7, то для предотвращения его хищения Вы можете удалить информацию о нем из системы. Для этого у вашей учётной записи должны быть права Администратора.

    1) Запустите командную строку от имени администратора
    В строке поиска меню "Пуск" наберите cmd.exe и нажмите Ctrl + ⇑ Shift + Enter ↵.
    2) Введите указанную ниже команду и нажмите Enter ↵.

    Здесь slmgr.vbs - скрипт обслуживания подсистемы Software License Manager, управления лицензированием программного обеспечения.
    Опция cpky символизирует Clear Product Key.

    17. Создание точки восстановления системы при старте системы без использования апплета "Защита системы".

    Если Вам необходимо создать точку восстановления системы при старте системы не используя апплет "Защита системы", то Вы можете создать указанного ниже содержания скрипт и добавить ярлык для него в автозагрузку.

    В фоновом режиме без вывода сообщений и окон:

    С выводом окна для введения наименования для точки восстановления:

    1) Скопируйте выбранный Вами код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Создайте ярлык для созданного Вами файла скрипта в Автозагрузку.
    5.1) Удерживая нажатой клавишу Alt перетяните иконку файла скрипта в папку Автозагрузка в меню Пуск.

    18. Запуск программ с правами администратора без выдачи уведомлений Контроля Учетных Записей.

    Если Вам необходимо часто запускать какую-либо программу от имени администратора при включенном Контроле Учетных Записей и Вы не собираетесь его полностью отключать, то Вы можете воспользоваться программой Elevated Shortcut

    Это приложение, автоматизирует процесс создания задачи планировщика для запуска приложения с повышенными привилегиями и создает необходимый ярлык. Программа, запущенная таким ярлыком, выполняется с привилегиями администратора, но запускается без запроса UAC (Контроля учётных записей). Elevated Shortcut предназначена для пользователей, считающих функцию контроля учётных записей(UAC) в Windows 7 полезной и которым требуется запускать какое-либо приложение всегда с повышенными правами (Sysinternals Process Explorer (английская версия или русская версия)).
    Существует следующие варианты создания ярлыка:

    Вариант 1.

    1) Открываете Пуск → Все программы → Elevated Shortcut и запускаете программу.
    2) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
    3) В зависимости от выбранного Вами языка интерфейса (из ниспадающего списка в нижнем левом углу) нажмите Создать ярлык (New Shortcut)
    4) Укажите в текстовом поле Файл на который будет создан ярлык (Target Path) - путь к запускаемому файлу программы или путь к иконке для нее.
    5) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
    6) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
    7) Нажмите ОК и ещё раз ОК и закройте программу.

    Вариант 2.

    1) Удерживая нажатой клавишу ⇑ Shift нажмите правой кнопкой мыши на файле, для которого Вы желаете добавить ярлык.
    2) В контекстном меню выберите пункт ElevatedShortcut
    3) В появившемся окне Контроля Учетных Записей нажмите кнопку Да
    4) Укажите в текстовом поле Папка в которую поместить ярлык (Folder to store shortcut) - путь, где будет сохранен ярлык.
    5) Если для запуска необходим какой-нибудь параметр, то введите его в текстовое поле Параметры командной строки (Command line arguments)
    6) Нажмите ОК и ещё раз ОК и закройте программу.

    19. Запрещение запуска Диспетчера задач.

    1) Запустите редактор системных политик: Пуск → Выполнить → gpedit.msc (Win   + R → gpedit.msc → ОК).
    2) Слева в дереве политик выберите Конфигурация пользователя → Административные шаблоны → Система → Варианты действий после нажатия Ctrl + Alt + Delete.
    3) В правом окне щелкните на Удалить диспетчер задач и выберите пункт Изменить
    4) Установите переключатель в значение Включить и нажмите ОК.
    5) Перезагрузите компьютер.

    20. Добавление своей иконки в список рисунков учетных записей.

    По умолчанию рисунки учетных записей располагаются в следующей папке:
    C:\ProgramData\Microsoft\User Account Pictures\Default Pictures
    Вы можете поместить в нее свое изображение и оно будет отображаться автоматически при выборе параметра изменения рисунка учетной записи в оснастке "Учетные записи пользователей". При этом рисунок должен быть в формате .bmp и иметь размер 128x128 пикселей.

    21. Отключение кэширования экскизов.

    Если у Вас включено отображение скрытых файлов в Windows, то обычно в папке с изображениями находится файл Thumbs.db. Данный файл используется операционной системой для хранения эскизов изображений папки для режима Эскизы страниц Проводника. Thumbs.db создаётся в каждой папке, которая содержит изображения, при первом отображении её содержимого.
    Thumbs.db является скрытым файлом, и обычно не виден в Проводнике, и может содержать эскизы уже удалённых изображений. Поэтому, он может быть случайно передан постороннему лицу, которое может узнать компрометирующую информацию.

    Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Профессиональная", "Корпоративная", "Максимальная", выполните следующие действия:

    1) В строке поиска меню Пуск введите gpedit.msc и нажмите Enter ↵
    2) В запустившемся Редакторе локальной групповой политики выберите раздел Конфигурация пользователя
    3) Откройте Административные шаблоны → Компоненты Windows → Проводник Windows
    4) В панели справа найдите политику Отключить кэширование экскизов в скрытых файлах thumbs.db.
    5) Дважды щелкните на ней, чтобы открыть ее Свойства
    6) В открывшимся окне установите переключатель в значение Включить.
    7) Нажмите ОК
    8) В панели справа найдите политику Отключить кэширование экскизов изображений.
    9) Дважды щелкните на ней, чтобы открыть ее Свойства
    10) В открывшимся окне установите переключатель в значение Включить.
    11) Нажмите ОК

    Чтобы отключить кэширование экскизов в скрытых файлах Thumbs.db, в версиях Windows 7: "Домашняя базовая" и "Домашняя расширенная", выполните следующие действия:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) В меню Правка выберите Создать → Параметр DWORD (32 бита).
    4) Задайте имя параметра NoThumbnailCache
    5) Дважды щелкните на данном параметре и введите значение 1.
    6) Откройте раздел реестра HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows
    7) В меню Правка выберите Создать → Раздел.
    8) Задайте имя раздела Explorer
    9) Откройте созданный Вами раздел HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Explorer
    10) В меню Правка выберите Создать → Параметр DWORD (32 бита).
    11) Задайте имя параметра DisableThumbsDBOnNetworkFolders
    12) Дважды щелкните на данном параметре и введите значение 1.
    13) Закройте редактор реестра и перезапустите компьютер.

    22. Поиск приложений автоматически загружающихся при запуске компьютера.

    Если у Вас при запуске Windows запускается какое-либо приложение, которое Вы хотите удалить из автозагрузки, то Вы можете либо проанализировать объекты находящиеся Пуск → Все программы → Автозагрузка и указанные ниже разделы реестра:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

    Но есть более лучший способ, позволяющий сделать более тщательный анализ автоматически запускаемых приложений - воспользоваться программой AutoRuns: английская версия или русская версия созданной Марком Руссиновичем.

    Данная программа проверяет большее количество мест, из которых происходит автозапуск программ.

    Просто запустите средство Autoruns, и оно покажет, какие приложения настроены на автоматический запуск, а также представит полный список разделов реестра и каталогов файловой системы, которые могут использоваться для задания автоматического запуска. Элементы, которые показывает программа Autoruns, принадлежат к нескольким категориям: объекты, автоматически запускаемые при входе в систему, дополнительные компоненты Проводника, дополнительные компоненты Internet Explorer (включая объекты модулей поддержки обозревателя (BHO)), библиотеки DLL инициализации приложений, подмены элементов, объекты, исполняемые на ранних стадиях загрузки, библиотеки DLL уведомлений Winlogon, службы Windows и многоуровневые поставщики услуг Winsock. Чтобы просмотреть автоматически запускаемые объекты требуемой категории, достаточно выбрать нужную вкладку.

    Параметр Hide Signed Microsoft Entries (Не показывать элементы с цифровой подписью Microsoft) из раздела меню Options позволяет сосредоточить внимание на автоматически запускаемых элементах сторонних производителей, если такие элементы были добавлены в систему. Кроме того, можно просматривать объекты, настроенные на автоматический запуск для других учетных записей, имеющихся в системе.

    Для просмотра свойств исполняемого объекта, настроенного на автоматический запуск, необходимо выделить этот объект и воспользоваться пунктом меню или кнопкой панели инструментов Properties (Свойства). Если в системе запущена программа Process Explorer: английская версия или русская версия, а выделенный исполняемый файл используется каким-либо активным процессом, то при выборе в меню Entry (Элемент) пункта Process Explorer (Process Explorer) откроется диалоговое окно свойств процесса, использующего выделенный объект.

    Чтобы перейти к разделу реестра или каталогу файловой системы, который отображается в окне программы, либо к настройке объекта, запускаемого автоматически, достаточно выделить нужный элемент и воспользоваться командой меню или кнопкой панели инструментов Jump to (Перейти к).

    Чтобы отключить объект, запускаемый автоматически, нужно снять соответствующий ему флажок. Удалить такой объект можно с помощью команды меню или кнопки панели инструментов Delete (Удалить).

    Чтобы просмотреть автоматически запускаемые элементы для учетных записей других пользователей, достаточно выбрать нужный пункт меню User (Пользователь).

    23. Отслеживание приложений, создающих неизвестные файлы на диске.

    Если у Вас на диске постоянно какая-либо программа записывает непонятные файлы, то Вы можете определить создающее их приложение, воспользовавшись утилитой от Microsoft: Process Monitor.

    1) Запустите программу Process Monitor
    Так как программа отслеживает несколько типов системной активности (реестр, файловую систему, сеть и процессы), то Вам необходимо оставить только включенной активность файловой системы.
    2) Оставьте на Панели инструментов включенным значок Show File System Activity, и отключите значки Show Registry Activity, Show Network Activity и Show Process and Tread Activity, Show Profiling Events
    3) Примените фильтр, чтобы отсеять необходимые Вам значения. Для запуска фильтра нажмите сочетание клавиш Ctrl + L.
    4) В первом ниспадающем списке выберите значение Path - обозначает путь к искомому файлу (имя файла также учитывается).
    5) Во втором ниспадающем списке выберите значение contains - условие, учитывая которое будет производится отсеивание, в данном случае обозначает «содержит» (перев. с англ.)
    Также Вы можете, выбрать вариант begins with (начинается с) или ends with (заканчивается на).
    6) В текстовом поле введите либо желаемое имя файла, либо имя папки, где создаются неизвестные файлы.
    7) В последнем ниспадающем списке выберите значение Include - указывает фильтру, что заданные условия должны быть включены в результаты отсеивания.
    8) Нажмите кнопку Add, чтобы добавить фильтр в список и ОК, чтобы применить фильтр.

    Если полученных результатов очень много, то Вы можете добавить дополнительные фильтры, либо указав какие действия надо отслеживать, либо исключив определенные процессы.
    Примеры дополнительных фильтров:

    Process Name – Is – Имя процесса – Exclude.
    Operation – Is – CreateFile – Include

    24. Создание, отключение и удаление учетной записи пользователя.

    Чтобы создать новую учетную запись, то воспользуйтесь одним из предложенных ниже вариантов:

    Вариант 1.

    1) Войдите в систему от имени другого пользователя с правами администратора (Например, используя учетную встроенную запись администратора)
    2) Запустите оснастку Локальные пользователи и группы (Win   + R → lusrmgr.msc → OК)
    3) В меню слева нажмите на папку Пользователи
    4) Щелкните правой кнопкой мыши на свободном от текста месте в центральной колонке или в главном меню выберите пункт Действие и нажмите на пункт Новый пользователь.
    5) Введите желаемые Вами значения полей. (При необходимости, для более подробного объяснения элементов нажмите кнопку Справка)
    В поле Пользователь - введите имя учетной записи, которое будет использовано в папке C:\Users при создании папки Вашего профиля. (Например: MaxZol)
    В поле Полное имя - введите имя учетной записи, которое будет указано на экране приветствия Windows (Например: Максим Золотарев)
    Поле Описание можете оставить пустым, в полях Пароль и Подтверждение введите идентичные значения пароля.
    6) Снимите флажок Требовать смены пароля при следующем входе в систему.
    7) Нажмите кнопку Создать, а затем кнопку Закрыть.
    Будет создана учетная запись с правами обычного пользователя. Если же Вам необходимо изменить ее на учетную запись администратора, то:
    7.1) Щелкните правой кнопкой на созданную Вами учетную запись и выберите пункт Свойства.
    7.2) Перейдите на вкладку Членство в группах и нажмите кнопку Добавить, затем кнопку Дополнительно, а затем кнопку Поиск.
    7.3) В результатах поиска выберите группу Администраторы (Administrators) и нажимайте на кнопки ОК, пока не вернетесь в список пользователей.
    8) В меню Пуск, наведите курсор на стрелочку рядом с завершением работы, выберите пункт Выйти из системы и войдите в систему используя вновь созданную учетную запись.

    Вариант 2.

    1) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей
    2) Нажмите на ссылку Управление другой учетной записью
    3) Нажмите на ссылку Создание учетной записи
    4) Введите имя учетной записи, которое будет указано на экране приветствия Windows.
    5) Выберите тип учетной записи: Обычный доступ или Администратор.
    6) Нажмите на кнопку Создание учетной записи
    Учетная запись будет создана по умолчанию без пароля. Если же Вам необходимо его установить, то:
    6.1) Щелкните правой кнопкой на созданную Вами учетную запись и нажмите ссылку Создание пароля.
    6.2) в полях Новый пароль и Подтверждение пароля введите идентичные значения пароля и нажмите на кнопку Создать пароль
    7) В меню Пуск, наведите курсор на стрелочку рядом с завершением работы, выберите пункт Выйти из системы и войдите в систему используя вновь созданную учетную запись.

    Если у Вас на экране приветствия Windows появляются две или более учетных записей пользователей, то Вы можете отключить те из них, в которых Вы не нуждаетесь.

    1) Запустите оснастку Локальные пользователи и группы (Win   + R → lusrmgr.msc → OК)
    2) В меню слева нажмите на папку Пользователи
    3) Щелкните правой кнопкой на учетную запись, которую Вы желаете отключить и выберите пункт Свойства.
    4) Откроется окно свойств учетной записи.
    5) На вкладке Общие установите флажок Отключить учетную запись и нажмите ОК.
    6) Выйдите и войдите в систему под другим именем пользователя или перезагрузите компьютер для применения сделанных изменений.

    Если же Вам необходимо удалить учетную запись пользователя, то воспользуйтесь одним из предложенных ниже вариантов:

    Вариант 1.

    1) Войдите в систему от имени другого пользователя с правами администратора (Например, используя учетную встроенную запись администратора)
    2) Запустите оснастку Локальные пользователи и группы (Win   + R → lusrmgr.msc → OК)
    3) В меню слева нажмите на папку Пользователи
    4) Щелкните правой кнопкой на учетную запись, которую Вы желаете удалить и выберите пункт Удалить.
    5) Выйдите и войдите в систему под другим именем пользователя или перезагрузите компьютер для применения сделанных изменений.
    6) Откройте папку C:\Users и удалите папку соответствующую наименованию отключенного/удаленного Вами пользователя.

    Вариант 2.

    1) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей
    2) Нажмите на ссылку Управление другой учетной записью
    3) Выберите учетную запись, которую Вы желаете удалить.
    4) Нажмите на ссылку Удаление учетной записи
    5) Нажмите кнопку Удалить файлы для полного удаления всех папок и файлов связанных с данной учетной записью.
    Если Вам необходимо сохранить содержимое рабочего стола и папок входящих в Библиотеки, то нажмите кнопку Сохранение файлов.
    6) Нажмите на кнопку Удаление учетной записи

    25. Запуск приложения от имени другого пользователя.

    Чтобы запустить приложение от имени другого пользователя выполните следующие действия:

    1) Нажмите клавишу ⇑ Shift, и удерживая её, щелкните правой кнопкой мыши по исполняемому файлу.
    2) В появившемся контекстном меню выберите Запуск от имени другого пользователя.
    3) В открывшемся окне введите логин и пароль пользователя, от имени которого нужно запустить программу и нажмите ОК.

    Примечание. Учетная запись пользователя, от имени которого запускается программа, должна быть защищена паролем.

    Чтобы создать ярлык для запуска приложения от имени другого пользователя выполните следующие действия:

    1) Нажмите клавишу Alt, и удерживая её, перетяните иконку исполняемого файла туда, где Вы желаете создать ярлык.
    2) Нажмите правой кнопкой мыши на созданном Вами ярлыке и выберите пункт Свойства.
    3) В поле Объект введите следующую команду:

    где:

    Runas - служит для запуска программы с разрешениями, отличными от тех, которые предоставляет текущая учетная запись.
    /user:учетная_запись_пользователя - задает имя учетной записи пользователя, которая будет использована для запуска программы.
    program - задает команду или программу, которая будет запущена с помощью учетной записи, указанной в параметре /user.

    Если имя пользователя состоит из двух и более слов разделенных пробелом, то его необходимо заключать в кавычки.
    Если программа, которую необходимо запустить не расположена в одной из системных папок, то путь к программе указывается полностью и заключается в кавычки.

    Чтобы использовать учетную запись администратора на своем компьютере, в качестве параметра /user: введите одно из следующих значений:

    Чтобы использовать данную команду в качестве администратора домена, введите одно из следующих значений параметра:

    26. Переименование папки локальной учетной записи пользователя.

    Переименование локальной учетной записи пользователя в оснастках: Локальные пользователи и группы (lusrmgr.msc) и Управление компьютером (compmgmt.msc) не изменяет имени папки пользователя, находящейся по умолчанию в папке: C:\Users, а обычное переименование папки может привести к неработоспособности профиля.
    Для осуществления данного действия Вы можете воспользоваться одним из предложенных ниже вариантов.

    Вариант 1.

    1) Войдите в систему от имени другого пользователя с правами администратора (Например, используя учетную встроенную запись администратора)
    Если Вы работаете под своей учетной записью, то для входа от имени другого пользователя Вам необходимо воспользоваться пунктом Выйти из системы.
    2) Откройте в Проводнике папку C:\Users и переименуйте имя папки соответсвующей необходимому Вам профилю со старого наименования на новое.
    3) Откройте Панель управления\Система и безопасность\Администрирование и запустите Управление компьютером.
    4) Слева, в дереве консоли пройдите Управление компьютером\Служебные\Локальные пользователи и группы\Пользователи
    5) Щелкните правой кнопкой мыши на учетную запись пользователя, для которой требуется изменить папку, а затем щелкните Свойства.
    6) Перейдите на вкладку Профиль и в разделе Домашняя папка и установите переключатель в значение Путь.
    7) Введите полный путь к переименованной папке (например C:\Users\NewUser) и нажмите ОК.

    Вариант 2.

    1) Войдите в систему от имени другого пользователя с правами администратора (Например, используя учетную встроенную запись администратора)
    Если Вы работаете под своей учетной записью, то для входа от имени другого пользователя Вам необходимо воспользоваться пунктом Выйти из системы.
    2) Откройте в Проводнике папку C:\Users и переименуйте имя папки соответсвующей необходимому Вам профилю со старого наименования на новое.
    3) Запустите редактор реестра (Win   + R → regedit → ОК)
    4) В главном меню откройте диалоговое окно поиска Правка → Найти... (Ctrl + F)
    5) Выполните поиск по старому имени папки и замените в найденном параметре значение на новое имя папки.
    6) Продолжите поиск и замените все возможные из найденных значений.
    7) Выполните выход из системы и войдите в систему под учетной записью для которой Вы изменяли значения реестра.

    Вариант 3.

    1) В строке поиска Пуск введите слово перенос и в списке результатов выберите Средство переноса данных Windows.
    2) В открывшемся окне нажмите кнопку Далее.
    3) Нажмите Внешний диск или USB-устройство флеш-памяти
    4) Нажмите Это мой исходный компьютер
    5) Дождитесь пока произведется оценка данных входящих в профили имеющиеся на компьютере
    6) Установите флажок напротив учетной записи, которую Вы желаете переместить.
    7) Нажмите под ней на ссылку Настройка, а затем на ссылку Дополнительно.
    8) Выберите желаемые параметры для переноса и нажмите кнопку Сохранить, а затем нажмите кнопку Далее.
    9) В случае необходимости введите пароль для защиты данного файла, в остальных случаях оставьте данное поле пустым и нажмите кнопку Сохранить.
    10) Задайте имя файла и выберите место для сохранения файла переноса и нажмите кнопку Сохранить.
    11) По окончании создания файла нажмите кнопку Далее, еще раз Далее, а затем Закрыть.
    12) В строке поиска Пуск введите слово перенос и в списке результатов выберите Средство переноса данных Windows.
    13) В открывшемся окне нажмите кнопку Далее.
    14) Нажмите Внешний диск или USB-устройство флеш-памяти
    15) Нажмите Это мой новый компьютер, а затем Да.
    16) Выберите место,где Вы сохранили файла переноса и щелкните на нем.
    17) Нажмите под учетной записью на ссылку Настройка, а затем на ссылку Дополнительно.
    18) Выберите желаемые параметры для переноса и нажмите кнопку Сохранить
    19) Нажмите на ссылку Дополнительные параметры и в открывшемся окне перейдите на вкладку Сопоставление учетных записей пользователей.
    20) В ниспадающем списке Учетная запись пользователя на новом компьютере выберите пункт Создание пользователя.
    21) Введите имя пользователя и пароль (при необходимости) и нажмите кнопку Создать, а затем на кнопку Сохранить.
    22) Нажмите кнопку Перенести, а после завершения переноса нажмите кнопку Закрыть.
    23) Выйдите из системы воспользовавшись пунктом Выйти из системы из меню Пуск.
    24) Войдите в систему от имени созданного Вами пользователя.
    25) Удалите старую учетную запись пользователя и соответствующую ей папку, для этого воспользуйтесь решением предложенным в совете Администрирование: 24. Создание, отключение и удаление учетной записи пользователя.

    Также Вы можете воспользоваться одним из решений предложенным в совете Администрирование: 9. Переименование учетных записей и перемещение их папок профиля., указав в качестве нового месторасположения полный путь к папке с новым наименованием, но с тем же расположением.

    27. Ввод пароля в окне смены пользователей при отсутствии необходимой раскладки клавиатуры.

    Если Вы задали пароль на русском языке в английской Windows или пароль на русском языке в русской Windows, то Вы можете столкнуться с ситуацией, когда невозможно ввести пароль в окне смены пользователей, по причине отсутствия необходимой раскладки клавиатуры.

    В таком случае для ввода пароля Вы можете воспользоваться ASCII символами.

    Для ввода буквы из другой раскладки клавиатуры Вам необходимо, удерживая нажатой клавишу Alt нажать на цифровой клавиатуре 0 (ноль), а затем сразу число, соответствующее необходимой Вам клавише.

    Например, для ввода английской буквы t в русской раскладке клавиатуры:

    1) Нажмите и удерживайте клавишу Alt
    2) Нажмите 0 (ноль) и сразу за ним число 1, 1, 6
    3) Отпустите клавишу Alt, и вы увидите результат.

    или

    для ввода русской буквы т в английской раскладке клавиатуры:

    1) Нажмите и удерживайте клавишу Alt
    2) Введите 0 (ноль) и сразу за ним число 2, 4, 2
    3) Отпустите клавишу Alt, и вы увидите результат.

    Таблица ASCII символов для русской и английской клавиатуры приведена ниже.

    Кириллица | Значение | Латиница | Значение
А | 192 | A | 65
Б | 193 | B | 66
В | 194 | C | 67
Г | 195 | D | 68
Д | 196 | E | 69
Е | 197 | F | 70
Ж | 198 | G | 71
З | 199 | H | 72
И | 200 | I | 73
Й | 201 | J | 74
К | 202 | K | 75
Л | 203 | L | 76
М | 204 | M | 77
Н | 205 | N | 78
О | 206 | O | 79
П | 207 | P | 80
Р | 208 | Q | 81
С | 209 | R | 82
Т | 210 | S | 83
У | 211 | T | 84
Ф | 212 | U | 85
Х | 213 | V | 86
Ц | 214 | W | 87
Ч | 215 | X | 88
Ш | 216 | Y | 89
Щ | 217 | Z | 90
Ъ | 218 | a | 97
Ы | 219 | b | 98
Ь | 220 | c | 99
Э | 221 | d | 100
Ю | 222 | e | 101
Я | 223 | f | 102
а | 224 | g | 103
б | 225 | h | 104
в | 226 | i | 105
г | 227 | j | 106
д | 228 | k | 107
е | 229 | l | 108
ж | 230 | m | 109
з | 231 | n | 110
и | 232 | o | 111
й | 233 | p | 112
к | 234 | q | 113
л | 235 | r | 114
м | 236 | s | 115
н | 237 | t | 116
о | 238 | u | 117
п | 239 | v | 118
р | 240 | w | 119
с | 241 | x | 120
т | 242 | y | 121
у | 243 | z | 122
ф | 244 |  |
х | 245 |  |
ц | 246 |  |
ч | 247 |  |
ш | 248 |  |
щ | 249 |  |
ъ | 250 |  |
ы | 251 |  |
ь | 252 |  |
э | 253 |  |
ю | 254 |  |
я | 255 |  |

    28. Ограничение разрешенных действий для пользователей, имеющих временный доступ к компьютеру.

    Вариант 1.

    1.1) Запустите оснастку Локальные пользователи и группы (Win   + R → lusrmgr.msc → ОК)
    1.2) Включите встроенную гостевую учетную запись пользователя. Дважды щелкните на профиль Гость, уберите флажок с Отключить учетную запись и нажмите OK.
    1.3) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей и нажимаете ссылку Управление другой учетной записью.
    При желании, можете поставить на свою учетную запись пароль.
    1.4) Нажмите на учетную запись Гость, а затем нажмите на кнопку Включить.
    1.5) Для перехода в гостевую учетную запись щелкните на стрелочке рядом с Завершение работы и выберите пункт Сменить пользователя. Обратный переход аналогично.

    Вариант 2.

    2.1.1) Запустите оснастку Редактор локальной групповой политики (Win   + R → gpedit.msc → ОК)
    2.1.2) В Административные шаблоны, дважды щелкните на элементе Все параметры
    2.1.3) Отсортируйте элементы по-названию.
    2.1.4) Включите необходимые Вам параметры начинающиеся со слов Запретить .... Для этого, дважды щелкните на необходимом элементе установите переключатель в значение Включить и нажмите Ок.

    Также в оснастке Редактор локальной групповой политики Вы можете осуществлять контроль за приложениями, на основе создаваемых Вами правил, разрешать или запрещать запуск затрагиваемых файлов, основываясь на их атрибутах. К примеру, можно создать правило, позволяющее запускать все приложения, подписанные конкретным издателем (например, Microsoft) или находящиеся по определеному пути (Например: C:\Program Files\Mozilla Firefox). Для этого Вам необходимо создать Исполняемые правила, используя мастер правил AppLocker.
    Для создания нового правила сделайте следующее:

    2.2.1) Пройдите в Конфигурация компьютера → Конфигурация Windows → Параметры безопасности → Политики управления приложениями → AppLocker.
    2.2.2) Нажмите на Исполняемые правила
    2.2.3) В меню оснастки Редактор локальной групповой политики нажмите Действие и выберите пункт Создать новое правило..., также Вы можете щелкнуть правой кнопкой мыши в правой части окна и также выбрать из списка пункт Создать новое правило....

    Вариант 3.

    3) Воспользуйтесь программой Deep Freeze или аналогичной ей, данная программа позволяет заморозить текущее состояние системы. С её помощью можно сохранить текущую конфигурацию системы, к которой машина будет автоматически возвращаться после перезагрузки. При этом абсолютно не имеет значения что делает пользователь - устанавливает новые программы, удаляет системные файлы или работает в сети - после перезагрузки вы получите девственно чистую машину.
    Для отключения Deep Freeze надо нажать Ctrl + ⇑ Shift + Alt + F6 и выбрать Boot Thawed, для удаления Deep Freeze сначала его надо отключить, а потом запустить установочный файл и выбрать Uninstall.

    29. Защита доступа к компьютеру с использованием USB Ключа, хранящегося на флеш накопителе.

    Если в Вашем распоряжении имеется свободный флэш накопитель в любом его виде, то Вы можете усилить имеющуюся у Вас на компьютере степень защиты Windows от нежелательных пользователей.
    Для этого Вам необходимо скачать и установить специальную программу USBLogonKey, которая позволит Вам использовать Ваш флэш накопитель в виде USB ключа для входа в Windows.

    Основными возможностями программы являются:

    Двух-факторная авторизация: Физический USB ключ + PIN код.
    Пароль автоматически передается в систему с USB ключа.
    Удобная авто-блокировка компьютера – при отключении USB флэш диска. Вернулись – подключили USB диск, и вы снова в работе – не отвлекаясь на пароли.
    Данные на USB ключе зашифрованы алгоритмом AES-256 (стандарт шифрования в США). Ключ невозможно подделать путем копирования файлов на другой диск. Пароль на ключе в открытом виде не хранится.
    Защиту компьютера невозможно обойти, загрузив компьютер в Safe Mode (безопасный режим загрузки Windows, где многие программы защиты отключены).
    PIN код для защиты USB ключа от нежелательного использования для входа в систему.

    Настройка USB-Ключа:

    1) Подключите Ваш флеш накопитель, установите данную программу и запустите ее.
    2) Нажмите Настроить USB Ключ
    Большинство дальнейших настроек в данном окне происходит при нажатии на соответствующую ссылку.
    2.1) Выберите пользователя, который будет входить с данным USB Ключем
    2.2) Если у Вас одновременно подключено несколько флеш накопителей, то укажите какой из них необходимо использовать в виде USB Ключа.
    2.3) Введите Ваш текущий пароль к Windows установленный в системе.
    2.4) Установите PIN код для защиты USB Ключа.
    2.5) Настройте аварийный вход в систему, для этого напишите один или несколько вопросов и ответы на них.
    2.6) Нажмите кнопку Настроить USB Ключ.
    2.7) В появившемся окне, сообщающем, что USB Ключ успешно установлен, нажмите кнопку ОК и Вы вернетесь обратно в основное окно.
    3) Нажмите кнопку Настроить опции.
    3.1) Установите какое действие будет выполняться при отключении USB Ключа.
    3.2) Установите флажок Разрешить вход в Windows только с помощью USB Ключа.
    3.3) Оставьте установленным флажок USB Ключ будет работать в SafeMode. Данное действие позволит сохранить Вашу защиту в безопасном режиме Windows.
    3.4) Укажите количество допустимых ошибок при наборе PIN кода.
    3.5) Нажмите кнопку ОК для возвращения в основное окно.

    Создание сложного пароля.

    4) Если Ваш текущий пароль к Windows кажется Вам легким, то для создания нового пароля в основном окне программы нажмите кнопку Сменить пароль.
    4.1) Введите Ваш PIN код, созданный на шаге 2.4 данной инструкции и нажмите кнопку ОК.
    4.2) Нажмите на ссылку Создать сложный пароль, для генерации случайного цифро-буквенного пароля или введите новый пароль самостоятельно.
    4.3) Создайте подсказку к паролю в случае необходимости.
    4.4) Нажмите кнопку Сменить пароль. В новом открывшемся окне нажмите кнопку ДА, а затем кнопку ОК.
    5) Закройте окно программы и перезагрузите компьютер.

    Хотя данная программа позволяет создать сложный пароль, рекомендуется использовать данную возможность только лишь для генерации сложных паролей, а сам пароль менять непосредственно в системе.
    При замене пароля на новый в системе не забудьте выполнить заново действия до шага 2.7 данной инструкции.

    Неверный ввод PIN кода:

    В случае неверного ввода PIN кода, Вы будете предупреждены об этом. После использования всех попыток для правильного ввода - USB ключ будет заблокирован.
    Войти в систему будет возможно только при помощи аварийного входа, ответив правильно на вопрос созданный на шаге 2.5 данной инструкции.
    Если Вы генерировали программой сложный цифро-буквенный пароль, то в конце диалога восстановления измените его на собственный, так как если Вы оставите текущий пароль без изменений, то Вам после перезагрузки необходимо будет его ввести.
    Впрочем, если Вы этого не сделали то, после перезагрузки в окне пользователей нажмите кнопку Сменить пользователя, выберите пункт Войти с USB Ключом и заново нажмите Аварийный вход и измените пароль на собственный.

    Разблокировка ключа:

    1) Войдите в Windows используя заново созданный пароль и запустите программу для настройки USB Ключа
    2) Нажмите Настроить USB Ключ
    3) Нажмите ссылку Снять блокировку, введите PIN код и нажмите кнопку ОК.

    Теперь Вы снова можете использовать данный USB Ключ. Не забудьте заново установить новый сложный пароль.

    30. Отслеживание изменений на диске и в реестре, путем сравнения снимков системы.

    Если Вы контролируете состояние Windows, то Вам может оказаться полезна программа SysTracer.
    Данная программа используется для снятия снимков состояния системы, с целью их дальнейшего сравнения с другими снимками этой же системы. Данная программа позволяет отследить:

    - изменения реестра
    - изменения файловой системы
    - изменения запущенных служб и процессов
    - изменения установленных приложений и библиотек

    Инструкция использования:

    1) Скачайте программу SysTracer с официального сайта или зеркала.
    2) Запустите программу и на вкладке Snapshots нажмите кнопку Take snapshot.
    3) Задайте название для снимка в текстовом поле Name и нажмите кнопку Start.
    Это создаст снимок текущего состояния системы.
    После внесения каких-либо изменений в систему (например установка/удаление программы) создайте новый снимок текущего состояния системы.
    4) В ниспадающем списке напротив Compare snapshot выберите начальный снимок системы.
    5) В ниспадающем списке напротив with выберите снимок, созданный после внесения изменений в систему.
    6) Нажмите кнопку Compare для выявления внесенных изменений в систему.
    7) Установите переключатель напротив View mode в значение Only differences - это покажет только различия.

    Изменения в реестре Вы можете посмотреть на вкладке Registry. Изменения в файловой системе Вы можете увидеть на вкладке Files. Запущенные или завершенные процессы, библиотеки, службы будут указаны на вкладке Aplications.

    Вновь добавленные элементы будут отмечены зеленым, измененные - синим, а удаленные элементы - красным цветом.

    Для удаления снимка(-ов), выделите его(их) и нажмите кнопку Delete snapshot(s).

    31. Добавление пункта "Запуск от имени администратора" в контекстное меню для VBS-скриптов.

    Если Вы не работаете под встроенной учетной записью администратора, то запустить VBS-скрипт напрямую Вы не сможете.
    Одним из решений для данной ситуации является добавление в контекстное меню VBS-скриптов пункта "Запуск от имени администратора".
    Данный пункт позволит Вам запускать VBS-скрипты сразу из Проводника, не используя командную строку запущенную от имени администратора.

    1) Скачайте архив elevateWHSScript.zip с официального сайта или с зеркала и распакуйте его в отдельную папку.
    2) Нажмите правой кнопкой мыши на файле ElevateWSHScript.inf и выберите в контекстном меню пункт Установить.

    После выполнения установки в контекстном меню VBS-скриптов появится пункт Запуск от имени администратора.
    Чтобы удалить данный пункт из контекстного меню: откройте Пуск → Панель управления → Программы и компоненты и выберите запись Повышение прав для WSH скриптов.

    32. Отключение контроля учетных записей (UAC) только для администраторов.

    Многие предпочитают отключать контроль учетных записей (UAC), для отключения уведомлений.
    Если же на компьютере, присутствуют учетные записи без привилегий администратора, то наиболее правильным вариантом будет отключение UAC, только для учетных записей с привилегиями администратора.

    Чтобы это сделать, Вам необходимо воспользоваться оснасткой Локальная политика безопасности:

    1) Нажмите кнопку Пуск, в строке поиска введите команду secpol.msc и нажмите клавишу Enter ↵.
    2) Откройте Локальные политики → Параметры безопасности
    3) Дважды щелкните на Контроль учетных записей: поведение запроса на повышение прав для администраторов в режиме одобрения администратором
    4) В ниспадающем списке выберите пункт Повышение без запроса и нажмите кнопку ОК.
    5) Закройте оснастку Локальная политика безопасности и перезагрузите компьютер.

    33. Запрещение закрепления программ в меню Пуск и на панели задач.

    Если Вам необходимо запретить закрепление программ на панели задач или в меню Пуск, то воспользуйтесь одним из предложенных ниже вариантов.

    Вариант 1.

    1) В строке поиска меню Пуск введите команду gpedit.msc и нажмите Enter ↵.
    2) Перейдите в раздел Конфигурация пользователя → Административные шаблоны → Меню «Пуск» и панель задач.
    3) Нажмите правой кнопкой мыши на необходимом параметре и выберете пункт Изменить:

    Запретить закрепление программ в панели задач - Удаляет пункт из контекстного меню, а уже закрепленные значки остаются.
    Удалить закрепленные программы из панели задач - Удаляет пункт из контекстного меню, а уже закрепленные значки будут скрыты (не удалены).
    Удалить список программ, закрепленных в меню "Пуск" - Удаляет пункт из контекстного меню, а уже закрепленные значки будут скрыты (не удалены).

    4) В открывшемся окне установите переключатель в значение Включить.
    5) Нажмите OK и закройте Редактор локальной групповой политики.
    6) Перезагрузите компьютер.

    Вариант 2.

    Создайте и примените необходимый Вам reg-файл из указанных ниже, а после его применения перезагрузите компьютер.

    Запретить закрепление программ в панели задач:

    Удалить закрепленные программы из панели задач:

    Удалить список программ, закрепленных в меню "Пуск":

    34. Добавление оснастки "Редактор локальной групповой политики" в папку Администрирование или в Панель управления.

    Чтобы добавить оснастку Редактор локальной групповой политики в папку Администрирование:

    1) Откройте папку C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools
    2) Щелкните правой кнопкой мыши по свободному пространству папки и выберите в контекстном меню Создать → Ярлык.
    3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите:

    4) Нажмите кнопку Далее и укажите в качестве названия ярлыка наименование оснастки - Редактор локальной групповой политики.
    5) Нажмите на кнопку Готово.
    6) Нажмите правой кнопкой мыши на созданном Вами ярлыке и выберите пункт Свойства.
    7) Укажите в строке Комментарий фразу: Эта оснастка позволяет редактировать объекты локальной групповой политики, хранимые на компьютере.
    8) Нажмите ОК для сохранения изменений.

    Для добавления оснастки Редактор локальной групповой политики в Панель управления, создайте и примените reg-файл, указанного ниже содержания:

    Для удаления данной оснастки из Панели управления, создайте и примените reg-файл, указанного ниже содержания:

    35. Удаление точки восстановления системы, а также извлечение из нее необходимого Вам файла или папки.

    Еженедельно в системе автоматически создаются контрольные точки восстановления.
    Также это происходит перед значительными системными событиями, такими как установка программ или драйверов устройств.
    Если Вы желаете удалить неактуальную для Вас точку восстановления или извлечь из нее какие-нибудь файлы и папки, не применяя самой точки восстановления, то в этом Вам поможет программа System Restore Explorer.

    1) Скачайте версию требующую установки с официального сайта или портативную версию с альтернативной ссылки.
    2.1) Для версии требующей установки: Установите программу, откройте Пуск → Все программы → System Restore Explorer и запустите ее.
    2.2) Для портативной версии: Распакуйте архив в любую папку и запустите программу.

    Чтобы удалить какую-либо точку восстановления системы:

    1) Выберите желаемую точку восстановления и нажмите клавишу Delete.
    2) В открывшемся окне нажмите кнопку Да.

    Чтобы извлечь какой-либо файл, папку или несколько файлов и папок из точки восстановления:

    1) Выберите желаемую точку восстановления и нажмите кнопку Mount.
    Указанная Вами точка восстановления будет смонтирована в систему и открыта в Проводнике, как обычная папка (Например: C:\HarddiskVolumeShadowCopy2).
    2) Скопируйте необходимые Вам папки и файлы в любую другую папку (Например: D:\Recovered).
    3) Переключитесь обратно в программу System Restore Explorer и нажмите кнопку Unmount.

    36. Создание и использование флеш-диска для сброса пароля своей учетной записи.

    Для создания флеш-диска для сброса пароля выполните указанные ниже действия:

    1.1.1) Откройте Пуск → Выполнить (Win   + R)
    1.1.2) Введите указанную ниже команду и нажмите Enter ↵.

    1.2) Либо введите в строке поиска меню Пуск слово: пароля и выберите пункт Создание дискеты сброса пароля.
    2) Подсоедините флеш-диск к Вашему компьютеру и нажмите кнопку Далее.
    3) Выберите в ниспадающем меню Ваш флеш-диск и нажмите кнопку Далее.
    4) Введите текущий пароль для учетной записи из которой Вы создаете флеш-диск для сброса пароля и нажмите кнопку Далее.
    5) Дождитесь надписи Выполнено: 100% и нажмите кнопку Далее.
    6) Нажмите кнопку Готово для завершения работы мастера создания флеш-диска для сброса пароля.

    Для использования флеш-диска для сброса пароля выполните указанные ниже действия:

    1) Введите на экране пользователей неправильный пароль в поле для ввода пароля к учетной записи и нажмите Enter ↵.
    2) Подсоедините флеш-диск к Вашему компьютеру и нажмите на появившуюся ссылку Восстановить пароль...
    Если у Вас включено использование классического окна для входа в систему, то данная ссылка появится, только после верного ведения имени пользователя.
    3) В открывшемся окне Мастер сброса пароля нажмите кнопку Далее.
    4) Выберите в ниспадающем меню Ваш флеш-диск и нажмите кнопку Далее.
    5) Введите новый пароль в первом и втором текстовом поле.
    6) Введите подсказку для восстановления забытого пароля и нажмите кнопку Далее.
    7) Нажмите кнопку Готово для завершения работы мастера сброса пароля.
    Примечание: Вам не надо создавать заново флеш-диск для сброса пароля, так как новый пароль будет записан на него взамен старого.
    8) Введите Ваш новый пароль в поле для ввода пароля к учетной записи и нажмите Enter ↵ для входа в систему.

    37. Установка оснасток "Редактор локальной групповой политики" (облегченная версия) и "Локальная политика безопасности" (полная версия) в редакциях Windows 7 Starter/Home Basic/Home Premium/Professional.

    В редакциях Windows 7 Starter/Home Basic/Home Premium/Professional отсутствует возможность использования оснасток Редактор локальной групповой политики и Локальная политика безопасности.
    Вы можете воспользоваться указанным ниже решением, чтобы установить облегченную версию оснастки gpedit.msc и полнофункциональную версию secpol.msc.

    1) Скачайте архив gpedit+secpol.zip и распакуйте его в любую папку.
    2) Запустите от имени администратора файл Gpedit Installer.exe.
    3) Скопируйте в папку C:\Windows\System32 с заменой файлы gpedit.dll, gpedit.msc и secpol.msc.
    Для 64-битной версии скопируйте их дополнительно в папку C:\Windows\SysWOW64.
    4) Перезагрузите компьютер.

    Теперь Вы можете пользоваться облегченной версией оснастки Редактор локальной групповой политики (gpedit.msc) и полнофункциональной версией оснастки Локальная политика безопасности (secpol.msc).
    Для их запуска:

    1) Откройте меню Выполнить: Пуск → Выполнить (либо Win   + R)
    2) Введите gpedit.msc или secpol.msc и нажмите Enter ↵.

    38. Включение шифрования файла подкачки.

    Если Вы желаете повысить безопасность Вашего компьютера, то включите шифрование файла подкачки.
    Это поможет сберечь от злоумышленников приватные данные, которые могут оказаться в файле подкачки.

    Вариант 1.

    1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
    1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
    2) Введите в командной строке необходимые Вам команды из указанных ниже и нажмите Enter ↵.

    Включение шифрования файла подкачки:

    Отключение шифрования файла подкачки:

    Проверка текущего состояния шифрования файла подкачки:

    3) Перезагрузите компьютер.

    Вариант 2.

    Создайте и примените один из указанных ниже reg-файлов, после чего перезагрузите компьютер.

    Включение шифрования файла подкачки:

    Отключение шифрования файла подкачки:


Интерфейс.

Интерфейс - Отображение.

1. Изменение размера иконки на рабочем столе.

1) Щелкните правой кнопкой мыши на рабочем столе.
2) Откройте пункт Вид и выберите размер: Крупные значки; Обычные значки; Мелкие значки;
или удерживая нажатой клавишу Ctrl прокрутите колесо мыши.

2. Управление положением и размерами окон с помощью клавиатуры.

Чтобы легко и быстро управлять положением и размерами окон, Вы можете воспользоваться следующими комбинациями клавиш на клавиатуре.

Win + ↑ | Развернуть окно на весь экран.
Win + ⇑ Shift + ↑ | Растянуть окно до верхней и нижней части экрана.
Win + ↓ | Свернуть в окно, либо свернуть на панель задач.
Win + ← | Развернуть и прикрепить окно к левому краю экрана.
Win + → | Развернуть и прикрепить окно к правому краю экрана.

3. Где скачать и как установить дополнительные темы для Windows 7?

Скачать дополнительные темы для Вашей Windows 7 Вы можете на официальной странице тем от Microsoft: Галерея персонализации
После скачивания понравившейся Вам темы, нажмите на скачавшийся themepack-файл и Windows автоматически его установит.
Также дополнительные темы и обои для Windows находятся в скрытой папке - C:\Windows\Globalization\MCT.

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win   + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

4. Изменение ширины и высоты меню Пуск.

Для изменения высоты меню Пуск проделайте следующее:

1) Нажмите правой кнопкой мыши на кнопке Пуск и выберите пункт Свойства.
2) Нажмите кнопку Настроить... .
3) Установите минимально необходимое для Вас значение напротив пункта Отображать недавно использовавшиеся программы в количестве: .
4) Снимите флажки и установите переключатель в значение Не отображать этот элемент напротив неиспользуемых Вами пунктов меню.
5) Нажмите ОК для внесения сделанных Вами изменений.

Для изменения ширины меню Пуск воспользуйтесь одним из указанных ниже вариантов.

Напоминание: Для применения указанных ниже вариантов у Вас должен быть отключен Контроль учетных записей
(Панель управления → Учетные записи пользователей → Изменение параметров контроля учетных записей)

Вариант 1. Копирование файла из другой локализации.

1) Скачайте и установите программу Unlocker.
2) Откройте Пуск → Панель управления → Персонализация
3) Установите тему Классическая.
4) Воспользовавшись советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование, задайте полный доступ к файлам aero.msstyles.mui расположенным в папке C:\Windows\Resources\Themes\Aero\ru-RU и папке локализации из которой Вы желаете скопировать файл aero.msstyles.mui (Например: C:\Windows\Resources\Themes\Aero\en-US)
5) Скопируйте файл aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\en-US в папку C:\Windows\Resources\Themes\Aero\ru-RU.
6) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
7) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
8) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
9) Перезагрузите компьютер.
10) Откройте Пуск → Панель управления → Персонализация
11) Установите любую тему Aero.

Вариант 2. Изменение значений параметров в файле aero.msstyles.mui.

1) Скачайте и установите программу Unlocker.
2) Откройте Пуск → Панель управления → Персонализация
3) Установите тему Классическая.
4) Воспользовавшись советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование, задайте полный доступ к файлу aero.msstyles.mui расположенному в папке C:\Windows\Resources\Themes\Aero\ru-RU.
5) Откройте данный файл - aero.msstyles.mui с помощью программы Restorator.
6) Нажмите клавишу F6 для включения режима редактирования.
7) Измените значения строк со 113 по 132 в строковой таблице в данном файле, на значения данных строк в строковой таблице взятые из файла, расположенного в папке локализации (Например: C:\Windows\Resources\Themes\Aero\en-US)

8) Нажмите клавиши F8, чтобы принять изменения и Ctrl + S, чтобы сохранить файл и закройте Restorator.
9) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
10) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
11) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
12) Перезагрузите компьютер.
13) Откройте Пуск → Панель управления → Персонализация
14) Установите любую тему Aero.

Вариант 3. Используя специальную программу.

Установка новых размеров ширины меню Пуск.

1) Скачайте и установите программу Unlocker.
2) Откройте Пуск → Панель управления → Персонализация
3) Установите тему Классическая.
4) Воспользовавшись советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование, задайте полный доступ к файлу aero.msstyles.mui расположенному в папке C:\Windows\Resources\Themes\Aero\ru-RU.
5) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
6) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
7) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
8) Скачайте программу Start Menu Width (польск. Szerokość Menu Start) переведенную мною с польского на русский язык.

Данная программа позволяет:

- Изменить ширину левой и правой части меню Пуск.
- Изменить ширину для правой части, где указываются последние файлы открываемые программой.
- Изменить ширину окна с результатами поиска.

9) Распакуйте архив в любую папку и запустите программу.
9.1) Для запуска программы необходим установленный Microsoft .NET Framework 4.0 или Microsoft .NET Framework 4.5.2.
10) Выберите из ниспадающего списка Шаблоны готовый шаблон с размерами меню Пуск. Например: Windows 7 (ENG) - для установки размеров меню соответствующих размеров из английской версии Windows.
11) Нажмите ОК для принятия изменений.
12) Нажмите кнопку Перезагрузить позже.
13) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
14) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
15) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
16) Откройте Пуск → Панель управления → Персонализация
17) Установите любую тему Aero.

Восстановление изначальных размеров ширины меню Пуск.

1) Откройте Пуск → Панель управления → Персонализация
2) Установите тему Классическая.
3) Запустите программу Start Menu Width и нажмите кнопку Восстановление.
4) Нажмите кнопку Да в окне Восстановление.
5) Нажмите кнопку Перезагрузить позже, а затем кнопку ОК.
6) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
7) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
8) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.

Рекомендации к работе с программой Start Menu Width (польск. Szerokość Menu Start):

1) Для успешной работы удаляйте все содержимое папки C:\Windows\rescache с помощью Unlocker до начала и после использования программы Start Menu Width.
2) Устанавливайте тему Классическая, для изменения настроек без перезагрузки компьютера.
3) Восстанавливайте оригинальные настройки перед внесением следующих изменений.
4.1) Используйте шаблоны.
4.2) При установке размеров вручную, не устанавливайте значения всех параметров одновременно на максимум, либо намного больше Ваших оригинальных размеров меню.

5. Включение/отключение прозрачного заголовка окна вместо матового.

Вариант 1.

1) Скачайте архив Disable_Blur.zip, с созданными мною скриптами.
2) Распакуйте архив и откройте папку Eng, если у Вас английская версия или английская + русский MUI.
3) Распакуйте архив и откройте папку Rus, если у Вас русская версия.

Все указанные далее в данном варианте совета файлы, необходимо запускать от имени администратора.
Чтобы это осуществить, щелкните правой кнопкой мыши на необходимый файл и выберите пункт Запуск от имени Администратора (Run as Administrator).

4) В зависимости от разрядности Вашей операционной системы запустите патч:
4.1) Если у Вас 32-битная версия Windows 7, то запустите файл Patch 32-bit System Files.bat.
4.2) Если у Вас 64-битная версия Windows 7, то запустите файл Patch 64-bit System Files.bat.

Патч заменит в папке %WINDIR%\system32\ имеющиеся у Вас файлы dwm.exe и udwm.dll их версиями из бета версии Windows 7.
Оригинальные файлы будут сохранены как dwm.backup и udwm.backup.
После окончания выполнения патча заголовки окон станут, как прозрачное стекло - без размывки заднего плана.

Теперь для включения или отключения матовости у заголовков окон, Вам необходимо будет только запустить один из указанных ниже bat-файлов:
5) Запустите файл Enable Blur.bat - чтобы включить у заголовков окон эффект матового стекла - с размывкой заднего плана.
6) Запустите файл Disable Blur.bat - чтобы отключить у заголовков окон эффект матового стекла и включить эффект прозрачного стекла - без размывки заднего плана.

7) Чтобы восстановить системные файлы запустите файл Restore System Files.bat.

Вариант 2.

1) Скачайте архив TrueTransparency.zip со специальной программой.
2) Распакуйте его и запустите файл TrueTransparency.exe
3) На панели задач появится значок программы. Щелкните на нем правой кнопкой мыши.
4) Выберите нужный язык в всплывающем меню Language(Языки),
5) В меню Skins (Внешний вид) выберите одну из предложенных тем прозрачности (Например: Aero2).

Вариант 3.

1) Скачайте архив Windows7AeroBlurTweaker.zip
2) Распакуйте его и запустите файл Windows 7 Aero Blur Tweaker.exe со специальной программой.
Нажмите кнопку Hide Blur, чтобы отключить у заголовков окон эффект матового стекла и включить эффект прозрачного стекла - без размывки заднего плана.
Нажмите кнопку Show Blur, чтобы включить у заголовков окон эффект матового стекла и отключить эффект прозрачного стекла - с размывкой заднего плана.

6. Принудительное включение отключенного эффекта прозрачности - Aero Glass.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM
3) Установите значение Dword-параметра Composition равным 1.
4) Установите значение Dword-параметра CompositionPolicy равным 2.
5) Установите значение Dword-параметра ColorizationOpaqueBlend равным 1.
Также Вы можете скачать и применить готовый reg-файл enableaero.zip
6) Перезапустите "Диспетчер сеансов диспетчера окон рабочего стола".
6.1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
6.2) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.

7) Откройте Пуск → Панель управления → Система.
8) Слева в списке нажмите ссылку Дополнительные параметры системы.
9) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
10) На вкладке Визуальные эффекты убедитесь, что у Вас установлены флажки напротив указанных ниже пунктов:

Включение композиции рабочего стола
Включить эффект прозрачности
Использование стилей отображения для кнопок и окон

7. Улучшение качества передачи цветов монитором.

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет Вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова средства калибровки цветов монитора сделайте следующее:

1) Нажмите кнопку Пуск
2) В строке поиска введите dccw.exe и нажмите клавишу Enter ↵.

Вы можете запустить калибровку цветов и другим способом:

1) Откройте Пуск → Панель управления
2) Перейдите по ссылкам Оформление и персонализация → Экран
3) В левой области выберите пункт Калибровка цветов.

8. Включение и отключение Области переходов.

Область переходов – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить Область переходов можно так:

1) Нажмите вверху слева Упорядочить→Представление
2) Поставьте или уберите галочку в пункте Область переходов

9. Расширение функциональности часов в трее или изменение их вида.

Если Вы желаете расширить функциональность часов в трее, то предлагаю Вам воспользоваться программой Stoic Joker's T-Clock x32/x64.

Используя данную программу Вы сможете:

- Добавить секунды к часам
- Изменить внешний вид часов и/или даты
- Запустить таймер или секундомер
- Создать Будильник
- Настроить прозрачность панели задач
- Добавить программу в список Быстрого Запуска

1) Скачайте программу Stoic Joker's T-Clock x32/x64.
Официальная ссылка на английскую версию программы: Stoic Joker's T-Clock x32/x64,
Ссылка на русскую версию программы Stoic Joker's T-Clock x32/x64, переведенную мною (Nizaury).
2) Распакуйте архив и перейдите в папку, соответствующую разрядности Вашей системы.
3) Запустите программу.

Для изменения внешнего вид часов и/или даты:

1) Щелкните правой кнопкой мыши на расширенные часы в трее и выберите пункт T-Clock Properties (Настройки T-Clock).
2) Перейдите на вкладку Clock Text (Текст Часов) и в ниспадающем меню Font (Шрифт) выберите шрифт поддерживающий кирилицу, а также его качество, размер и начертание.
3) Перейдите на вкладку Time Format (Формат Времени) и укажите необходимые для отображения данные.
4) Нажмите кнопку ОК.

Для добавления своей программы в список быстрого запуска:

1) Щелкните правой кнопкой мыши на расширенные часы в трее и выберите пункт T-Clock Properties (Настройки T-Clock).
2) Перейдите на вкладку Quicky Menus (Настройка Меню).
3) Щелкните дважды на строке в разделе Add Menu Item (Добавить Пункт Меню).
В зависимости от того на какой строке Вы щелкните ей будет присвоен соответствующий номер.
4) Программа переключится на вкладку Menu Item Details (Детали Пункта Меню).
5) Задайте название пункта меню, укажите путь к файлу программы.
6) В разделе Save Changes to Custom Menu List Now? (Сохранить Изменения в Списке Меню?) нажмите кнопку ОК и закройте окно настроек.

Для сохранения настроек программы:

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Stoic Joker's
3) Щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Экспортировать.
4) Выберите месторасположение reg-файла и задайте его наименование.
5) Нажмите кнопку Сохранить и закройте редактор реестра.
Теперь после переустановки Windows Вам достаточно будет только применить созданный Вами reg-файл, и все Ваши настройки программы Stoic Joker's T-Clock будут восстановлены.

Если Вы изменили местонахождение папки, содержащей файлы Clock_RUS.exe и Clock_ENG.exe,
то Вам необходимо указать адрес рабочей папки в значении параметра ExePath в разделе HKEY_CURRENT_USER\Software\Stoic Joker's\T-Clock 2010

Примечание:

П.1) Для добавления программы в папку Автозагрузка:
Установите флажок Start T-Clock 2010 When Windows Starts (Запускать T-Clock при запуске Windows) на вкладке About (О программе) и нажмите кнопку ОК. Во всплывшем окне нажмите Да.
П.2) Для отображения даты и часов на двух строках вместо одной:
Установите флажок CR (Link Break) (Перенос Строки) на вкладке Time Format (Формат Времени) и нажмите кнопку ОК.

10. Добавление дополнительных операций к окнам.

К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет данная программа.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • cвернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу

11. Добавление командной строке эффекта прозрачности - Aero Glass.

Для добавления командной строке эффекта прозрачности (Aero Glass) сделайте следующее:

1) Скачайте архив: GlassCMD.zip
2) Распакуйте его и запустите исполняемый файл минискрипта Glass CMD.exe.
3) Запустите командную строку(Win   + R → CMD →Ok) и увидите эффект прозрачности (Aero Glass).
Для использования данного эффекта скрипт Glass CMD.exe должен быть запущен. При закрытии Glass CMD.exe эффект прозрачности пропадет.
При желании Вы можете добавить данный скрипт-программу в папку Автозагрузка в меню Пуск.
Если Вы не хотите, чтобы в области уведомлений (трее) отображался значок скрипта, то в файле Settings.ini, который идет в архиве в комплекте с исполняемым файлом скрипта, установите значение параметра HideTrayIcon равным 1.

12. Определение цветового кода любой точки экрана на мониторе.

Для того чтобы узнать цветовой код любой точки экрана на Вашем мониторе скачайте и установите небольшую, но функциональную программу ColorPic.

Данная программа абсолютно бесплатна и Вы можете скачать её с официального сайта: http://www.iconico.com/colorpic/index.aspx

Мощные средства для регулировки цвета позволяют Вам с легкостью менять индивидуальные цвета. С помощью четырех графических миксеров Вы сможете регулировать RGB, оттенки, насыщенность и код цвета. У Вас будет возможность просматривать CMYK печатные коды цвета, а для идеальной точности использовать увеличитель экрана. Вы сможете сохранять множество цветовых палитр для их использования в любом приложении.

Содержащийся в программе раздел "Mixer" предоставляет Вам четыре мощных графических способа для анализа и изменения выбранного цвета. Цвета могут быть выбраны из любых шестиугольных форм, измененных миксером или настроенных шестью индивидуальными слайдерами для оттенков, насыщенности, кода и красных, зеленых и голубых цветовых компонентов. ColorPic также делает отчеты для регулировки голубого, пурпурного, желтого и черного цветовых кодов.

Кроме того, ColorPic также предлагает возможность увеличения, предоставляя Вам супер детальную картинку при выборе цвета. Программа имеет простой в использовании слайдер для увеличения, который позволяет Вам выбирать или разовую пробу или 3x3 или 5x5 средний цвет из любого места на Вашем экране.

Будучи неоценимым средством для любого графического дизайнера или веб-разработчика и будучи постоянно самым популярным бесплатным цветоподборщиком в сети, самая последняя версия ColorPic предлагает мощные средства для выбора цвета, которые до сих пор доступны только в дорогих приложениях.

Использовать программу очень просто:

1) Запускаете программу
2) Наводите курсор в то место, цвет которого желаете узнать.
3) Нажимаете Ctrl + G и в первой ячейке сохраняется информация о цвете.
4) Затем выделяете следующую ячейку и проделываете указанное выше для определения другого цвета.

13. Создание темы оформления с использованием RSS-обоев.

В интернете существует много программ позволяющих менять картинки на рабочем столе, автоматически скачивая их из интернета. Но Вам необязательно скачивать дополнительную программу, так как возможность обновления фона рабочего стола используя интернет имеется в самой Windows. Для этого Вам необходимо создать новую тему для Windows со ссылкой на RSS ленту, в качестве новостей транслирующую картинки.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Замените {themename} на название темы (Например: RSS Wallpapers), а вместо {rssfeedurl} впишите адрес ленты, транслирующей картинки.

Например:

http://feeds.feedburner.com/bingimages
http://api.flickr.com/services/feeds/photos_public.gne
http://feeds.nationalgeographic.com/ng/News/News_Main
http://mlewallpapers.com/4x3_rss.php

3) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .theme. Например: RSS_Wallpappers.theme
4) Щелкните два раза по получившемуся файлу.
5) В окне Подписаться на RSS канал?(Subscribe to RSS Feed?) выберите пункт Загружать вложения (Download Attachments).

Многие RSS ленты рекомендуют (хотя и необязательно) в Панель управления\Оформление и персонализация\Персонализация\Фоновый рисунок рабочего стола установить положение изображения По центру.

Готовые 4 схемы Вы можете скачать по ссылке: rssthemes.zip

14. Изменение фонового рисунка рабочего стола в Windows 7 Starter.

Вариант 1. Вручную используя реестр Windows.

1) Запустите Редактор реестра. Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter ↵ (или Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_CURRENT_USER\Control Panel\Desktop
3) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."

4.1) Если Вы первый раз изменяете фоновое изображение:

4.1.1) Нажмите кнопку Дополнительно
4.1.2) Перейдите на вкладку Владелец, выделите свое имя в окне Изменить владельца на: и нажмите кнопку Применить
4.1.3) Перейдите на вкладку Разрешения и уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажимаете кнопку Удалить.
4.1.4) Нажмите поочередно кнопки Добавить... → Дополнительно... → Поиск
4.1.5) В результатах поиска выберите Все и нажмите кнопку "OK", и еще раз "ОК".
4.1.6) В окне Элемент разрешения для "Desktop" напротив значения Полный доступ установите флажок в столбце Разрешить и нажмите несколько раз кнопки ОК.

4.2) Если Вы во второй раз изменяете фоновое изображение или если у Вас в "Группы и Пользователи" уже есть группа "Все" и Вы являетесь владельцем объекта:

4.2.1) Выделите группу Все, нажав на нее.
4.2.2) В части окна Разрешения для группы "Все" установите флажок Полный доступ в столбике Разрешить и нажимаете ОК.

5) Найдите строковый параметр Wallpaper и дважды щелкните на нем.
6) Введите путь к изображению, которое Вы хотите использовать как обои рабочего стола и нажмите ОК.
7) По умолчанию, положение изображения устанавливается По центру, если Вам необходимо другое положение, то дополнительно измените:

Параметр TileWallpaper на значение 1, чтобы Замостить изображение.
Параметр WallpaperStyle на значение 2, чтобы Растянуть изображение.

8) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."
9) Выделите группу Все, нажав на нее.
10) Уберите флажок в столбце Разрешить напротив значения Полный доступ и нажмите кнопку ОК.
Если Вы не уберете данный флажок, то система установит стандартные обои рабочего стола.
11) Перезайдите в систему или перезагрузите компьютер.

Вариант 2. Автоматически используя специальную программу.

1) Скачайте архив программы StarterBackgroundChanger.zip
2) Разархивируйте файл в любую папку и установите нужную Вам языковую версию программы.
3) Нажмите правой кнопкой мыши на рабочем столе и выберите в контекстном меню пункт Персонализация (Personalize)
4) Нажмите кнопку Обзор... (Browse...).
5) Выберите необходимое Вам изображение и нажмите кнопку Открыть (Open).
6) Выберите положение рисунка и нажмите Применить (Apply), чтобы установить рисунок не выходя из программы или ОК, чтобы установить рисунок и выйти их программы.
7) Чтобы установить стандартное изображение выберите в ниспадающем меню Фоновый рисунок Windows по умолчанию и нажмите кнопку ОК.

15. Изменение размера окон предпросмотра на панели задач.

Если Вам необходимо изменить размер окон предпросмотра, расстояние между ними, размер бордюра и время задержки, то в этом Вам поможет программа Windows 7 Taskbar Thumbnail Customizer.

1) Скачайте архив с программой W7TTC.zip
2) Распакуйте архив и запустите программу.
3) Настройте параметры программы в соответствие с Вашими запросами.

Maximum Size - максимальный размер окна предпросмотра
Minimum Size - минимальный размер окна предпросмотра

X Spacing - расстояние между окнами предпросмотра по-горизонтали
Y Spacing - расстояние между окнами предпросмотра по-вертикали

Top Margin - размер верхнего бордюра
Bottom Margin - размер нижнего бордюра
Left Margin - размер левого бордюра
Right Margin - размер правого бордюра

Delay Time - время задержки до появления окна предпросмотра

16. Добавление в контекстное меню рабочего стола пункта "Имя и расположение текущего файла фона".

Если у Вас большое количество изображений используется в качестве фоновых изображений рабочего стола, то когда необходимо найти текущее изображение, Вам приходится просматривать большое количество файлов.
Чтобы сберечь затраченное Вами на поиск файла время, Вы можете добавить в контекстное меню рабочего стола пункт Имя и расположение текущего файла фона.

1) Создайте в папке C:\Windows текстовый файл указанного ниже содержания и сохраните его с именем WPTargetDir.vbs.

2) Для добавления пункта Имя и расположение текущего файла фона в контекстное меню рабочего стола, создайте и примените reg-файл следующего содержания:

При использовании данного пункта меню, скрипт откроет в Проводнике папку содержащую файл текущего изображения и выделит его.

2) Для удаления пункта Имя и расположение текущего файла фона из контекстного меню рабочего стола, создайте и примените reg-файл следующего содержания:

Готовый комплект данных файлов Вы можете скачать по ссылке: WPTargetDir.zip

17. Замена фона папки в Проводнике.

Проще всего для замены фона в папке использовать следующие программы:

Windows 7 Folder Background Changer

1) Запустите программу Windows 7 Folder Background Changer
2) Нажмите кнопку Browse и выберите фоновое изображение
3) Нажмите Change Background Image, чтобы установить фоновое изображение или кнопку Remove Background Image, чтобы убрать фоновое изображение.
4) Для изменения фонового изображения во вложенных папках, установите флажок Apply To Sub Folders.

AveFolderBg - данная программа добавляет дополнительную вкладку в свойства каждой папки.

1) После распаковки архива, откройте папку в соответствии с разрядностью Вашей Windows и установите программу используя файл install.bat
2) Перезапустите Windows или перезайдите в систему.
3) Щелкните правой кнопкой мыши и выберите Свойства
4) Перейдите на вкладку Folder Background
5) Нажмите кнопку Set Image, выбираете изображение и нажимаете Открыть. Для удаления изображения используйте кнопку Remove Image.
6) Для изменения фонового изображения во вложенных папках, установите флажок Apply to subfolders also.
7) Нажмите кнопку Применить или ОК.

18. Сохранение созданной Вами схемы указателей мыши в файл, для дальнейшего использования.

Созданные Вами схемы для указателей мыши прописываются в реестре.
Если Вы желаете сохранить созданную Вами тему для дальнейшего применения после переустановки, то сделайте следующее:

1) Откройте Пуск → Панель управления → Мышь
2) Перейдите на вкладку Указатели
3) В окне Настройка измените необходимые Вам курсоры.
4) Нажмите кнопку Сохранить как, введите название сохраняемой темы и нажмите ОК.
5) В окне Свойства:Мышь снова нажмите ОК.
6) Запустите редактор реестра (Win   + R → regedit → ОК)
7) Откройте раздел HKEY_CURRENT_USER\Control Panel\Cursors\Schemes
8) Экспортируйте данный раздел в reg-файл.
8.1) В главном меню выберите Файл → экспорт
9) Задайте имя файла и нажмите кнопку Сохранить.

Система создаст reg-файл, который Вы сможете использовать в дальнейшем. Например, после переустановки Windows.
Если при создании схемы для указателей Вы использовали файлы отсутствующие в системе, то после переустановки Windows, перед применением reg-файла скопируйте их в те же месторасположения.

19. Добавление отображения эскизов и детальной информации для файлов .mkv в Проводнике Windows.

Если Вы хотите, чтобы у Вас отображались эскизы для mkv-файлов и детальная информация для них, то Вы можете воспользоваться одним из следующих решений.

1) Скачайте и установите DivX Software.

или скачайте и установите Microsoft .NET Framework 4.5.2 и выберите один из следующих вариантов.

2) Скачайте и установите отдельно Icaros, в программе нажмите кнопку Activate Icaros. Более поздние бета-версии программы можно найти на последних страницах ее темы на форуме автора.
3) Скачайте и установите набор кодеков Shark007 Windows 7 Codecs. В 64-битной версии Windows дополнительно установите x64 Components.
4) Скачайте и установите набор кодеков K-Lite Codec Pack.

Независимо от того какой пакет кодеков Вы решите выбрать Shark007 Windows 7 Codecs или K-Lite Codec Pack, для отображения эскизов и информации для mkv файлов они оба используют Icaros.

20. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения файлы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Пуск → Панель Управления → Параметры Папок и перейдите на вкладку Вид.
Отметьте параметр "Использовать флажки для выбора элементов" и нажмите ОК.
Теперь слева возле каждого файла и папки появилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

21. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок.
Исправить это можно с помощью бесплатной программы 7Stacks.

Данная программа является своего рода продолжением развития панели быстрого запуска, только интерфейс сделан в стиле Windows 7 — в виде стеков.
Она позволяет объединить в одну кнопку на панели задач несколько файлов, папок или приложений.
Это может быть весьма удобным для быстрого доступа к программам отсортированным по разделам.

Официальная сайт: http://alastria.com/software/7stacks/
Русская версия программы: 7stacks_Rus.7z.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д.

Порядок действий:

1) Создайте папку
2) Сложите в нее ярлыки приложений, необходимых Вам в создаваемом меню.
3) Запустите 7Stacks
4) Выберите созданную Вами папку
5) Настройте оформление и создайте ярлык на рабочем столе.
6) Перетащите данный ярлык в панель задач.

22. Закрепление конкретной папки на панели задач Windows 7.

Если Вы перетащите папку на панель задач, то она закрепится во всплывающем списке (подменю) Проводника. Чтобы закрепить отдельно папку на панели задач сделайте следующее:

1) Щелкните правой кнопкой мыши на рабочем столе и выберите Создать → Ярлык.
2) В поле Расположение объекта введите:

(вместо C:\MyFolder введите фактический адрес прикрепляемой папки).
3) В поле Имя ярлыка введите название папки (в нашем случае это MyFolder) и нажмите Готово.
4) Щелкните правой кнопкой по созданному ярлыку и в появившемся контекстном меню выберите пункт Закрепить на панели задач.

Примечание. Каждая закрепленная папка будет открываться в отдельном процессе.

23. Настройка списка элементов, отображаемых в диалоговом окне открытия и сохранения файлов Windows.

1) Щелкните на кнопке Пуск
2) В строке поиска введите gpedit.msc и нажмите клавишу Enter ↵.
3) Откройте узел Конфигурация пользователя →Административные шаблоны → Компоненты Windows → Проводник Windows → Общее диалоговое окно открытия файлов.
4) Дважды щелкните на политике Элементы, отображаемые в панели мест.
5) Щелкните на переключателе Включить.
6) Используйте текстовые поля Элемент 1 — Элемент 5 для ввода путей к папкам, которые требуется отображать в панели мест. Ими могут быть локальные или сетевые папки.
7) Щелкните на кнопке OK, чтобы ввести политику в действие.

24. Отображение часто используемых команд для диалогового окна "Выполнить" в меню Пуск.

Когда Вы вводите в диалоговом окне Выполнить какие-либо команды, то они сохраняются в разделе реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU
Данные команды сохраняются в значениях параметров от "a" до "z". А порядок их отображения регулируется параметром MRUList.
Вы можете добавлять свои команды в реестр, изменяя значения для данных параметров.
Но у данного способа есть один существенный недостаток - новые значения перезаписываются поверх уже имеющихся.
В качестве решения, Вы можете добавить наиболее часто используемые команды в диалоговое окно Выполнить в виде списка. Для этого выполните указанные ниже действия.

1) Откройте папку содержащую файл shell32.dll.mui

Для 32-битной версии: C:\Windows\System32\ru-RU
Для 64-битной версии(также): C:\Windows\SysWOW64\ru-RU

2) Задайте полный доступ к файлу shell32.dll.mui, для этого воспользуйтесь советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
3) Скачайте архив Patch_ExtendedRun.zip и распакуйте его в любую папку.
4) Щелкните на exe-файле правой кнопкой мыши и выберите пункт Запуск от имени администратора.
5) Нажмите кнопку Start для применения патча.

Внимание: Памятку устанавливать только на оригинальные ОС, работоспособность на различного рода сборках не гарантируется.

Кроме указанного патча, также существует альтернатива диалоговому окну Выполнить программа Run-Command.
Используя данную программу Вы сможете добавлять в Избранное наиболее часто используемые команды.
Для более тонкой настройки программы используйте ini-файл.
Для переключения языка нажмите #LNG.
Для закрытия программы нажмите Выход (Exit), нажатие на крестик свернет программу в трей.

25. Размещение любого окна Windows поверх других.

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl + F12 и окно становится OnTop по отношению ко всем открытым.

26. Изменение загрузочного экрана (включая шарики и текст) в Windows 7 на любой другой.

Данный совет рекомендуется опытным пользователя и тем у кого есть записанный образ Windows 7 на DVD или флэш-диск для восстановления файлов в случае сбоя системы.
Для изменения загрузочного экрана Windows 7 Вам понадобиться программа Windows 7 Boot Updater.
Зайдите на сайт: Coder for life и скачайте последнюю её версию.

Описание опций:

Переключатели в графе Animation:
Default - По умолчанию
Static Image - Используется для выбора статического изображения в качестве загрузочного логотипа.

Animation - Используется для выбора папки содержащей файлы для анимации.
Анимация может быть:

1) В одном BMP-файле размером 200x21000 пикселей, где все кадры анимации расположены сверху вниз подряд
2) В виде отдельных 105 последовательных изображений размером 200x200 в формате BMP, PNG, GIF, или TIFFs файлов. В нумерации всегда необходимо использовать три цифры, начиная с цифры 000 и заканчивая цифрой 104 (000, 001, ..., 103, 104).

Background (верхняя надпись) - цвет фона всего экрана.

Переключатели в графе Method:

Simple - Используется для заливки фона одним цветом.
Complete - Используется для выбора собственного изображения в качестве картинки для фона. При установке данного переключателя, нажмите кнопку Select Background Image и выберите желаемую картинку.

Параметры в графе Messages:

В ниспадающем списке напротив пункта Count (Количество текстовых строк): None - Ниодной, 1 Message - 1 Текстовая строка (нижныя), 2 Messages - Обе текстовых строки.
Background (нижныя надпись) - цвет фона для текстовых сообщений.

Вкладка Message 1 - Нижныя текстовая строка
Вкладка Message 2 - Верхняя текстовая строка

Text - текст сообщения выводимый в текстовой строке
Font Color - Цвет шрифта
Position - Позиция по вертикали, относительно верхнего края экрана.
Font Size - Размер шрифта

Особенности запуска.

Если у Вас Английская версия Windows:

1) Запустите исполняемый файл программы от имени администратора (используя меню, вызываемое правой кнопкой мыши).
Внимание: Программа может загрузиться с небольшой задержкой - подождите.
2) Измените необходимые Вам значения.
3) Нажмите кнопку Play, чтобы просмотреть сделанные изменения.
4) Если результат Вас устраивает нажмите кнопку Apply.
5) Закройте программу и перезагрузите компьютер, чтобы увидеть результат.

Если у Вас Английская версия Windows + русский языковой пакет:

1) Переключите язык интерфейса для экрана приветствия на Английский.
1.1) Нажмите кнопку Пуск, выберите последовательно компоненты Панель управления → Часы, язык и регион → Язык и региональные стандарты.
1.2) Перейдите на вкладку Языки и клавиатуры, в разделе Язык интерфейса выберите английский язык в списке и нажмите кнопку ОК, а затем Выйти из ситемы сейчас.
1.3) Снова войдите в систему, нажмите кнопку Пуск, выберите последовательно компоненты Control Panel → Clock, Language, and Region → Change display language.
1.4) В открывшемся диалоговом окне перейдите на вкладку Administrative и щелкните на кнопке Copy settings.
1.5) В открывшемся окне установите флажок у пункта Welcome screen and system accounts.
1.6) Во всплывшем окне нажмите Cancel и перейдите на вкладку Keyboards and Languages.
1.7) В разделе Display Language выберите русский язык в списке и нажмите кнопку ОК, а затем Log off now.
1.8) Снова войдите в систему.
2) Запустите исполняемый файл программы от имени администратора (используя меню, вызываемое правой кнопкой мыши).
Внимание: Программа может загрузиться с небольшой задержкой - подождите.
3) Измените необходимые Вам значения.
4) Нажмите кнопку Play, чтобы просмотреть сделанные изменения.
5) Если результат Вас устраивает нажмите кнопку Apply.
6) Закройте программу и перезагрузите компьютер, чтобы увидеть результат.

Если у Вас Русская версия Windows:

1) Скопируйте файл winload.exe.mui из папки C:\Windows\System32\ru-RU в папку C:\Windows\System32\en-US
2) Запустите исполняемый файл программы от имени администратора (используя меню, вызываемое правой кнопкой мыши).
Внимание: Программа может загрузиться с небольшой задержкой - подождите.
3) Измените необходимые Вам значения.
4) Нажмите кнопку Play, чтобы просмотреть сделанные изменения.
5) Если результат Вас устраивает нажмите кнопку Apply и закройте программу.
6) Закройте программу
7) Переместите файл winload.exe.mui обратно из папки C:\Windows\System32\en-US в папку C:\Windows\System32\ru-RU
8) Перезагрузите компьютер, чтобы увидеть результат.
Если у Вас возникнут проблемы с доступом к файлу winload.exe.mui, то Вы можете воспользоваться решением предложенным в совете 1. Получение полного доступа к файлу или папке. из раздела Администрирование.

Если Вы уже изменяли загрузочный экран с помощью данной программы и решили изменить его снова, то прежде чем это сделать восстановите резервные копии файлов:
Щелкните в главном меню пункт Options и выберите пункт Restore Backups
Если у Вас изначально русская версия Windows, то верните восстановленный файл winload.exe.mui обратно из папки C:\Windows\System32\en-US в папку C:\Windows\System32\ru-RU

27. Включение всех Аэро эффектов, поддержки тем Аэро и активация панели Персонализация в Windows Начальная и Windows Домашняя Базовая.

Создан специальный патч, позволяющий активировать панель Персонализации и включить все эффекты Аэро (Aero Glass, Aero Peek, Aero Shake, Aero Snap, Windows Flip 3D), отключенные в версиях Windows Начальная (Starter) и Windows Домашняя Базовая (Home Basic). Также данный патч добавляет панель Персонализации и поддержку тем\стилей Аэро, имеющуюся в старших редакциях Windows.

Добавляемые Аэро эффекты:

Aero Glass — прозрачные (с размывкой заднего плана) заголовки.
Aero Peek — позволяет отобразить рабочий стол поместив указатель мыши на специальную кнопку в правом углу панели задач.
Aero Shake — позволяет свернуть/восстановить окна, достаточно захватить заголовок окна и немного «потрясти».
Aero Snap — быстрое разворачивание окна на полэкрана, весь экран или только по вертикальной оси.
Windows Flip 3D — прокрутка окон под углом.
Миниатюры окон, появляющиеся при наведении на кнопку окна на панели задач.

1) Скачайте архив PersonalizationPanel-AeroPatch.zip с патчем по официальной или по альтернативной ссылке и распакуйте его.
2) Отключите используемый Вами антивирус на время установки. Если у Вас включен Контроль учетных записей (UAC), то отключите его.
2.1) Нажмите Win   + R, введите команду UserAccountControlSettings и нажмите Enter ↵.
2.2) Передвиньте ползунок в самое нижнее значение и нажмите кнопку ОК, а затем кнопку Да.
2.3) Перезагрузите компьютер.
3) Щелкните правой кнопкой мыши на файле Personalization Panel .exe и выберите "Запустить от Администратора".
4) В окне "Установить Панель персонализации?" нажмите кнопку ОК.
5) Перезагрузите компьютер.
6) Если Вам необходим Контроль учетных записей (UAC), то включите его.
7) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
(Доступ к панели Персонализация добавится также и в Панель управления)
8) В разделе темы Aero выберите тему Windows 7. (Также Вы можете скопировать для использования темы Aero из Windows 7 Максимальная или скачать их из интернета.)

Для удаления патча воспользуйтесь апплетом Программы и Компоненты из Панели управления.

28. Включение/отключение отображения системных значков (Компьютер, Панель Управления и Корзина) на рабочем столе.

1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация
2) Слева в открывшемся окне щелкните по ссылке Изменение значков рабочего стола
3) Для добавления значка на рабочий стол, в разделе Значки рабочего стола - установите флажок рядом с названием нужного Вам элемента.
4) Для удаления значка с рабочего стола, в разделе Значки рабочего стола - снимите флажок рядом с названием нужного Вам элемента.
5) Нажмите кнопку ОК.

29. Изменение цвета Aero в случайном порядке или используя заданный список цветов.

Если Вам нехватает цветовой гаммы Windows для изменения цвета Aero или же Вы хотите использовать расширенные возможности изменения цвета Aero, то Вы можете воспользоваться программой AeroRainbow.
Данная программа позволяет изменять цвета Aero в случайном порядке или по заранее подобранному списку. У пользователя программы есть возможность выбрать скорость замены цвета, подбирать цвет под обои или активное окно.

AeroRainbow умеет менять цвет окон Aero в Windows 7 "на лету", используя:
- цвет текущих обоев;
- цвет текущего открытого окна;
- цвет из списка ваших любимых цветов;
- случайно созданный цвет.
- возможность использовать в качестве источника цвета окон только иконку активного открытого окна.
- два алгоритма расчёта цвета окон (основной цвет источника и средний цвет источника) для режимов "Цвет обоев" и "Цвет активного окна/иконки".

Скачать: AeroRainbow.zip

Подробнее о настройках:

Группа переключателей Цвет окон позволяет определить, каким образом менять цвет окон.

Случайный цвет - цвет окон всегда будет случайным. Для уточнения следующего цвета окон, щелкните по иконке в трее левой кнопкой мыши.
Правый квадрат показывает цвет, в который будут окрашены окна Aero. Если данный цвет Вам не нравится, щелкните на нем, для его замены на другой (актуально для режима случайного выбора цвета окон).

Опция Использовать вот эти цвета позволяет Вам создать и использовать свой собственный список цветов, в который Вы хотите окрашивать окна. Используйте + и -, чтобы добавлять и удалять цвета.
Регулятор Скорость позволяет указать для режимов Использовать вот эти цвета и Случайный цвет скорость, с которой будут меняться цвета окон.
Крайнее левое положение означает самую быструю смену цвета окон, крайнее правое - самое медленное.

Цвет окон определяется обоями - программа анализирует фоновый рисунок рабочего стола, и устанавливает наиболее подходящий под него цвет окон Aero.
Цвет окон определяется активным окном - программа вычисляет средний цвет открытого активного окна, и использует его в качестве цвета окон Aero. Например, при открытии командной строки цвет Aero окрасится в черный, при открытии программы Far - в синий, а при открытии пустого блокнота - в белый. Вы можете установить флажок Использовать только цвет значка, в этом случае в качестве значения цвета возьмётся не всё окно, а только его иконка. например, если активно окно браузера Opera - Aero будет окрашено в красный цвет, так как иконка окна бразуера Opera красная, а если открыт Блокнот, то окна будут окрашены в синий цвет - цвет иконки окна этой программы.

В AeroRainbow предусмотрены два варианта расчёта цвета окон для режимов Цвет окон определяется активным окном и Цвет окон определяется обоями:
Вычислять главный цвет - программа рассчитывает преобладающий цвет обоев, активного окна или значка активного окна (максимальное значение красного, зеленого или синего канала цвета).
Вычислять средний цвет - цвет окон получается из среднего значение красного, зеленого или синего канала цвета обоев, активного окна или значка активного окна.

Иконка в трее - позволяет отключить или включить иконку в трее. Вы можете отключить иконку, тем самым сэкономив место в системном трее. В этом случае управление параметрами программы, а также выход из неё можно выполнять специально обученными ярлыками, которые создает инсталлятор на рабочем столе.

30. Отключение горизонтального смещения при выборе файла в Проводнике.

Если у Вас для отображения файлов установлен Вид → Список, то при выборе файла, система автоматически сместит по-горизонтали столбец, в котором находится файл.
Чтобы отключить данную функцию воспользуйтесь предложенным ниже решением.

1) Скачайте программу Folder Options X.
С официального сайта: английская версия
С зеркала: русская версия
2) Закройте все окна Проводника.
3) Если Вы установили английскую версию, то откройте в меню Пуск папку T800 Productions и запустите программу. Если Вы скачали русскую версию, то запустите программу из папки, куда Вы распаковали архив.
4) Снимите все флажки и нажмите кнопку Apply (Применить).
5) Установите флажок Disable full row select (Отключить горизонтальное смещение при выборе файла в Проводнике) и нажмите кнопку OK.
6) Перезайдите в систему или перезагрузите компьютер.

31. Отключение и включение отображения эскизов из контекстного меню.

1) Скачайте и распакуйте в любую папку архив: togglethumbs.zip
2) Скопируйте файл togglethumbs.vbs в Вашу папку Windows.
3) Примените reg-файл install.reg для добавления пункта в контекстное меню.

Чтобы отключить или включить эскизы для изображений в папке: щелкните правой кнопкой мыши на пустом пространстве папки и выберите пункт Включить/Отключить эскизы изображений.

Для удаления пункта из контекстного меню примените reg-файл uninstall.reg

32. Добавление пункта "Показать/Скрыть скрытые файлы и папки" в контекстное меню.

1) Скачайте и распакуйте в любую папку архив: ShHFF.zip
2) Скопируйте файл ShHFF.vbs в Вашу папку Windows.
3) Примените reg-файл Add_ShHFF.reg для добавления пункта в контекстное меню.

Чтобы отключить или включить отображение скрытых файлов и папок: щелкните правой кнопкой мыши на пустом пространстве папки и выберите пункт Показать/Скрыть скрытые файлы и папки.

Для удаления пункта из контекстного меню примените reg-файл: Remove_ShHFF.reg

33. Добавление отображения полного пути к папке в строку заголовка окна.

Если Вы желаете добавить отображение полного пути к папке в строке заголовка окна, то Вы можете воспользоваться следующим решением.

1) Скачайте и распакуйте в любую папку архив: AeroBar.zip
2) Запустите файл AeroBar.exe

При желании Вы можете добавить ярлык для запуска данной программы в Пуск → Все программы →Автозагрузка.

34. Быстрое удаление всех закрепленных значков из панели задач.

Чтобы быстро удалить все значки закрепленные в панели задач, создайте bat-файл с указанным ниже содержанием и запустите его от имени администратора.

35. Установка Windows DreamScene для добавления возможности использования *.MPG или *.WMV видеофайлов в качестве фона рабочего стола.

В Windows Vista Ultimate присутствовал модуль Windows DreamScene, который позволял устанавливать в качестве фона рабочего стола видеофайлы *.MPG или *.WMV.
Вы можете вернуть данную возможность, используя предложенное ниже решение.
Обязательным условием является выбор в диалоговом окне Персонализация любой из Aero тем.

Установка.

1) Скачайте архив EnableDreamScenes.zip
2) Распакуйте его в любую папку и запустите программу Enable DreamScenes.exe.
3) Нажмите кнопку Enable, а затем кнопку Reboot windows ?.
4) Нажмите кнопку Да, чтобы перезагрузить компьютер.

Использование.

1) Щелкните правой кнопкой мыши на файле *.MPG или *.WMV и выберите пункт Set as Desktop Backgroud, чтобы установить видеофайл в качестве фона рабочего стола.
2) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Pause Dreamscene, чтобы приостановить воспроизведение видеофайла.
3) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Play Dreamscene, чтобы продолжить воспроизведение видеофайла.

Чтобы отключить воспроизведение видеофайла:

4.1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация → Фон рабочего стола.
4.2) В ниспадающем меню Расположение изображения выберите Фоны рабочего стола Windows.
4.3) Выберите любое изображение и нажмите кнопку Сохранить изменения.

Видеообои в *.WMV формате Вы можете скачать http://www.dreamscene.org/gallery.php

36. Очистка списка Последние для программы прикрепленной на панели задач.

Чтобы самостоятельно очистить список Последние в прикрепленном значке на панели задач, выполните указанные ниже действия:

1) Откройте в Проводнике папку %AppData%\Microsoft\Windows\Recent\AutomaticDestinations
В данной папке хранятся истории списков Последние для программ прикрепленных на панели задач.
2.1) Если Вы желаете удалить все списки, то удалите полностью все файлы.
2.2) Если Вы желаете удалить список для какой-либо конкретной программы, то Вам необходимо удалить только один из файлов .automaticDestinations-ms, который соответствует Вашей программе.

Чтобы выяснить какой из данных файлов соответствует Вашей программе есть два способа:

1) Удалять по одному файлу из данной папки. После удаления необходимого файла, список очистится.
2) Переместить куда-нибудь все файлы из данной папки и добавлять их по одному. Все списки очистятся. После добавления необходимого файла, появится список Последние для нужной программы.

Также рекомедуется полностью очистить содержимое папки %AppData%\Microsoft\Windows\Recent\CustomDestinations.

37. Изменение иконок для устройств в папке "Устройства и принтеры".

Если система выбрала неправильный значок для устройства в папке "Устройства и принтеры" или Вам не нравятся предложенная иконка, то Вы можете изменить его воспользовавшись одним из предложенных ниже решений.

Вариант 1. Изменение общего файла иконок.

1) Откройте в программе Restorator файл DDORes.dll, расположенный в папке C:\Windows\System32
2) Откройте папку Иконка и перетяните на ресурс с имеющейся иконкой, файл иконки, которым Вы хотите ее заменить.
3) Сохраните внесенные изменения нажав Ctrl + S

Для 64-битных Windows проделайте указанное выше с файлом DDORes.dll, расположенным в папке C:\Windows\SysWOW64.
Внимание: Изменение иконки в файле DDORes.dll для ошибочно определенного значка на другой, может привести к некорректному отображению иконки для устройств с правильно определенным значком.

Вариант 2. Создание метаданных для устройства.

1) Скачайте и установите программу Devices and Printers Metadata Authoring Wizard
2) Перезагрузите компьютер.
3) Откройте папку Пуск → Панель управления → Устройства и принтеры
4) Щелкните правой кнопкой мыши на устройстве, для которого Вы желаете изменить иконку и выберите пункт Create metadata package.
Информация: В случае появления какой-нибудь из ошибок Framework нажмите Продолжить.
5) На вкладке Icons перетащите иконку, которой Вы собираетесь заменить имеющуюся в черный квадрат.
Внимание: Иконка должна содержать в себе несколько вариантов одной и той же иконки с разными размерами, иметь прозрачный фон и гладкие края, и должна соответствовать требованиям размера и глубины цвета, указанным в таблице справа.
6) Для продолжения нажмите Next.
7) На вкладке Description заполните поля Required Fields.
7.1) В поле Model Name укажите Имя Модели (Описание устройства) устройства.
7.2) В поле Manufacturer укажите Производителя (Изготовителя) устройства.
8) Для продолжения нажмите Next.
9) На вкладке Categories укажите Тип устройства (Класс устройства).
10) Для продолжения нажмите Next.
11) На вкладке Associations в разделе Hardware ID нажмите на кнопку плюс.
12) Введите значение ИД оборудования и нажмите кнопку ОК.
13) Установите флажок напротив добавленного пункта с Вашим устройством.
14) Для продолжения нажмите Next.
15) На вкладке Options нажмите Next.
16) На вкладке Finish установите флажок Copy package to your system’s local metadata store и нажмите кнопку Finish.
17) Откройте папку %LOCALAPPDATA% (C:\Users\Имя_Пользователя\AppData\Local) и удалите файл кэша иконок IconCache.db.
18) Перезагрузите компьютер.

Необходимые данные для заполнения полей:

1) Откройте Панель управления → Диспетчер устройств
2) Нажмите на устройстве правой кнопкой мыши и выберите пункт Свойства
3) Перейдите на вкладку Сведения.
4) Используя либо ниспадающий список, либо колесико мыши для прокрутки найдите необходимые Вам значения.

38. Местонахождение большинства значков (иконок) в Windows.

Если Вы хотите использовать одну из иконок (значков) Windows, то большую их часть Вы можете найти в следующих файлах:

C:\Windows\System32\shell32.dll
C:\Windows\System32\imageres.dll
C:\Windows\System32\ddores.dll

Для извлечения необходимой Вам иконки:

1) Откройте один из предложенных файлов, с помощью программы Restorator.
2) В панели Дерево ресурсов откройте папку Иконка
3) Выберите любую из понравившихся Вам иконок.
4) В панели Дерево ресурсов щелкните правой кнопкой мыши на данном ресурсе и выберите Извлечь... → Извлечь как "имя_ресурса.ico"
5) Выберите папку для извлечения и нажмите Сохранить

Вы также можете извлечь все иконки сразу, для этого:
6) В панели Дерево ресурсов щелкните правой кнопкой мыши на папке Иконка и выберите Извлечь... → Извлечь все как тип "Иконка"
7) Выберите папку для извлечения и нажмите OK

39. Инвертирование и замена цветов в одноцветном файле изображения c прозрачным фоном.

Встроенного редактора Paint в Windows хватает для выполнения базовых задач с изображениями с непрозрачным фоном.
Но если Вам необходимо инвертировать или заменить(закрасить) цвет рисунка в файле изображения с прозрачным фоном, то программа Paint сделает это вместе с фоном.

Чтобы быстро инвертировать или заменить цвет в таких файлах, не Вы можете воспользоваться одним из предложенных ниже вариантов:

Вариант 1. Используя командную строку.

1) Откройте страницу http://www.imagemagick.org/download/binaries/
2) Скачайте zip-архив с программой ImageMagick (Файл выглядит примерно так: ImageMagick-X.X.X-X-X-x86-windows.zip, вместо X - номер версии) и распакуйте его в любую папку.
3) Откройте данную папку и скопируйте файл convert.exe в папку к Вашему изображению.
4) Удерживая нажатой клавишу ⇑ Shift щелкните правой кнопкой мыши на папке содержащей изображение. (В примере C:\Images\)
5) Выберите пункт Открыть окно команд.
6) Введите указанную ниже команду и нажмите Enter ↵.

Для инвертирования цветов (замены цвета на противоположный, например, черный на белый):

Для указания требуемого цвета:

или

Для указания требуемого цвета (с ранее необрабатываемым в программе изображением):

Для указания требуемого цвета (с изображением для которого уже были инвертированы цвета):

Внимание: не забудьте поставить запятую в данной команде.

где:
-negate - параметр для инвертирования цветов в изображении.
+level-colors - параметр для установки необходимого цвета в конечном изображении.
В качестве цвета Вы можете указывать его текстовое название, его шестнадцатиричное значение или цветовую модель rgb.
image.png - исходный файл
image2.png - конечный файл

Вариант 2. Используя графическую оболочку.

1) Скачайте и установите программу Paint.NET
2) Откройте программу.
3.1) Перекиньте на окно программы Ваш файл с изображением и нажмите кнопку Открыть.
или
3.2) В меню Файл нажмите Открыть, выберите Ваш файл и нажмите кнопку Открыть.

Для инвертирования цветов (замены цвета на противоположный, например, черный на белый) нажмите сочетание клавиш Ctrl+⇑ Shift+I (или выберите в меню Коррекция пункт Инвертировать цвета).

Для замены цвета в изображении на желаемый, Вам нужно будет указать с какого на какой цвет вы собираетесь заменять.

Указание исходного цвета:

1) В меню Инструмент выберите пункт Пипетка или нажмите клавишу K.
2) Нажмите в изображении левой кнопкой мыши на рисунок, чтобы определить его цвет.

или

1) В окне Палитра в ниспадающем списке выберите пункт Основной и нажмите кнопку Больше >>.
2) Укажите необходимый Вам цвет либо выбрав его из палитры, либо введя его шестнадцатиричное значение или цветовую модель rgb.

Указание конечного цвета:

1) В окне Палитра в ниспадающем списке выберите пункт Дополнительный.
2) Укажите необходимый Вам цвет либо выбрав его из палитры, либо введя его шестнадцатиричное значение или цветовую модель rgb.

Замена цвета:

1) В меню Инструмент выберите пункт Замена цвета или нажмите клавишу R.
2) Установите параметр Чувствительность равным 50% (для изменения необходимо передвинуть ползунок)
3) В поле ширина установите наиболее подходящий размер кисти.
4) Удерживая нажатой правую кнопку мыши проведите по элементам изображения которые Вы желаете перекрасить в другой цвет, после чего отпустите кнопку мыши.

Сохраните изображение с новым именем:

1) В меню Файл выберите пункт Сохранить как... или нажмите сочетание клавиш Ctrl+⇑ Shift+S
2) Укажите необходимое имя для файла и нажмите кнопку Сохранить.
3) В окне Параметры сохранения нажмите кнопку ОК.

40. Создание и редактирование BMP-изображений с 32-битной глубиной цвета.

При редактировании некоторых ресурсов Windows одним из обязательных условий является использование bmp-изображения с 32-битной глубиной цвета.
Чтобы создать такое изображение воспользуйтесь одним из указанных ниже вариантов.

Вариант 1. Конвертирование имеющегося png-изображения в bmp-изображение с 32-битной глубиной цвета.

1) Создайте в программе Paint.NET png-изображение с 32-битной глубиной цвета.
2) Скачайте и распакуйте в любую папку архив AlphaConv.zip
3) Запустите программу AlphaConv.
4) В ниспадающем списке выберите значение .bmp.
Внимание: Программа перезаписывает готовые файлы поверх имеющихся.
5) Перекиньте на окно программы Ваше png-изображение.
Готовый bmp-файл появится появится рядом в папке.

Если Вы снимите флажок Convert only 32-bit images (with alpha channel), то программа AlphaConv сможет преобразовывать png-изображения с меньшей глубиной цвета.
Но существует вероятность того, что система может распознать Ваше изображение некоректно или не распознать его.

Вариант 2. Создание нового и редактирование bmp-изображение с 32-битной глубиной цвета.

1) Скачайте и распакуйте в любую папку архив Pixelformer.zip
2) Запустите программу Pixelformer.
3) Преобразуйте (отредактируйте) имеющееся у Вас изображение или создайте новое.
4) Закройте программу.
При закрытии нажмите Yes, чтобы сохранить проект или No, чтобы выйти без сохранения.

Открытие jpg, png или bmp-файла изображения для редактирования:

1) В меню File выберите пункт Import... или нажмите Ctrl+⇑ Shift+O.
2) Выберите любой bmp, jpg или png-файл и нажмите кнопку Открыть.
3) В меню Image выберите пункт Properties... или нажмите Alt+⇑ Shift+I, а затем P.
4) Установите переключатель в значение RGB color with alpha channel (32 bpp) и нажмите кнопку OK.
5) Используя инструменты программы отредактируйте изображение.

Создание нового bmp-файла:

1) В меню File выберите пункт New или нажмите Ctrl+N.
2) Укажите размеры создаваемого изображения. В поле Width - ширину, а в поле Height - высоту.
3) Установите переключатель в значение RGB color with alpha channel (32 bpp) и нажмите кнопку OK.
4) Используя инструменты программы создайте Ваше новое изображение.

Сохранение сделанных изменений в bmp-файл с 32-битной глубиной цвета:

1) В меню File выберите пункт Export... или нажмите Ctrl+⇑ Shift+S.
2) Укажите имя и месторасположение создаваемого bmp-файла и нажмите кнопку Сохранить.
3) Установите переключатель в значение A8:R8:G8:B8 (32 bpp) и нажмите кнопку OK.

41. Изменение фонового изображения боковой панели Проводника.

Для применения указанных ниже решений полностью отключите контроль учетных записей (Win   + R → UserAccountControlSettings), передвинув ползунок в самый низ и перезагрузив компьютер.

Вариант 1. Без внесения изменений в системный файл.

1) Скачайте и распакуйте архив ThemeResourceChanger.zip
2) Установите программу Theme Resource Changer той же разрядности, что и у Вашей Windows.
Если окно команд самостоятельно не закроется у Вас по окончании установки, то закройте его вручную.
3) Перезагрузите компьютер.
4) Откройте Панель управления\Оформление и персонализация\Параметры папок → вкладка Вид
5) Снимите флажок Запускать окна с папками в отдельном процессе и нажмите кнопку ОК.
4) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
5) Установите тему в которую Вы желаете внести изменения.
6.1) Если Вы используете одну из стандартных(не классических) тем Windows, то откройте папку C:\Windows\Resources\Themes\Aero\.
6.2) Если Вы используете стороннюю тему, то откройте папку данной темы.
7) Создайте в ней папку с именем shell32.dll (Например: C:\Windows\Resources\Themes\Aero\shell32.dll\)
8.1) Для установки фонового изображения боковой панели Проводника, скопируйте в данную папку png-файл с именем 633.png и размером 200x551 пикселей.
8.2) Для убирания диагональных полос под фоновым изображением боковой панели Проводника, скачайте архив shell32_dll_632_wihout_lines.zip и скопируйте из него файл 632.png.

Вариант 2. С внесением изменений в системный файл.

Внимание: Данный вариант Вы используете на свой страх и риск.
Если что-либо пойдет не так система может перестать загружаться и Вам придется востанавливать измененые файлы, используя среду восстановления или MSDaRT-диск.

1) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
2) Установите тему Классическая.
3) Скачайте и распакуйте архив Full_access.zip
4) Примените reg-файл в соответствии с языковыми особенностями Вашей системы.

Full_access_eng.reg - примените, если Вы используете английскую версию Windows.
Название пункта меню указано на английском языке, название группы администраторов указано на английском языке.
Full_access_eng+rus_mui.reg - примените, если Вы используете английскую версию Windows и русский языковой пакет.
Название пункта меню указано на русском языке, название группы администраторов указано на английском языке.
Full_access_rus.reg - примените, если Вы используете русскую версию Windows.
Название пункта меню указано на русском языке, название группы русском указано на английском языке.

5) Откройте папку C:\Windows\System32
6) Нажмите правой кнопкой на файл shell32.dll и выберите пункт Стать владельцем и задать полный доступ к объекту
7) Скопируйте файл shell32.dll на рабочий стол.
8) Откройте данный файл с помощью программы Restorator.
9) Откройте папку Точечный рисунок

10.1) Для установки фонового изображения боковой панели Проводника:

Перетяните на ресурс 633 bmp-файл изображения.
Изображение должно быть размером 200x551 пикселей.

10.2) Для убирания диагональных полос под фоновым изображением боковой панели Проводника:

10.2.1) Скачайте архив shell32_dll_632_wihout_lines.zip и распакуйте в любую папку.
10.2.2) Перетяните файл 632.bmp из этой папки на ресурс 632.

11) Нажмите сочетание клавиш Ctrl + S, чтобы сохранить изменения.
12) Переименуйте оригинальный файл shell32.dll в папке C:\Windows\System32 на _shell32.dll.
13) Переместите с рабочего стола Ваш модифицированный файл shell32.dll в папку C:\Windows\System32

В 64-битной версии повторите указанные действия для файла shell32.dll из папки C:\Windows\SysWOW64.

14) Перезагрузите компьютер.
15) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
16) Установите любую аэро-тему или тему "Windows 7 - упрощенный стиль".

42. Замена или удаление кнопки Пуск на панели задач.

Замена кнопки Пуск в аэро-темах и теме "Windows 7 - упрощенный стиль".

Чтобы заменить кнопку Пуск воспользуйтесь одним из предложенных ниже вариантов.
Для их полнофункциональной работы полностью отключите контроль учетных записей (Win   + R → UserAccountControlSettings), передвинув ползунок в самый низ и перезагрузив компьютер.
Большую коллекцию BMP-картинок с кнопкой Пуск Вы можете скачать по ссылке: Start_Button_Images.zip
Для преобразования их в png-файл с 32-битной глубиной цвета, воспользуйтесь программой AlphaConv, выбрав в ниспадающем списке .png и перекинув на окно программы необходимый Вам bmp-файл.

Вариант 1. Theme Resource Changer - без внесения изменений в системный файл.

1) Скачайте и распакуйте архив ThemeResourceChanger.zip
2) Установите программу Theme Resource Changer той же разрядности, что и у Вашей Windows.
Если окно команд самостоятельно не закроется у Вас по окончании установки, то закройте его вручную.
3) Перезагрузите компьютер.
4) Откройте Панель управления\Оформление и персонализация\Параметры папок → вкладка Вид
5) Снимите флажок Запускать окна с папками в отдельном процессе и нажмите кнопку ОК.
6) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
7) Установите тему Классическая.
8.1) Если Вы используете одну из стандартных тем Windows, то откройте папку C:\Windows\Resources\Themes\Aero\.
8.2) Если Вы используете стороннюю тему, то откройте папку данной темы.
9) Создайте в ней папку с именем explorer.exe (Например: C:\Windows\Resources\Themes\Aero\explorer.exe\)
10) Создайте и скопируйте в данную папку необходимые из указанных ниже png-файлов:

6801.png, 6805.png, 6809.png размером 54x162 для стандартного размера элементов 100%.
6802.png, 6806.png, 6810.png размером 66x198 для стандартного размера элементов 125%.
6803.png, 6807.png, 6811.png размером 81x243 для стандартного размера элементов 150%.
6804.png, 6808.png, 6812.png размером 106x318 для стандартного размера элементов 200%.

11) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
12) Установите любую аэро-тему или тему "Windows 7 - упрощенный стиль". После каждой перезагрузки компьютера кнопка Пуск будет восстанавливаться в изначальный вид.
Вам необходимо будет переключаться в "Классическую тему" и обратно, чтобы система снова сменила кнопку Пуск на замененную.
Но Вы можете автоматизировать этот процесс:
1) Скопируйте из папки ThemeSwitch, содержащейся в архиве ThemeResourceChanger.zip программу ThemeTool.exe в папку C:\Windows\System32.
2) Скопируйте в папку автозагрузки или добавьте в реестр файл (не ярлык!) Classic-Aero-Classic_ThemeSwitcher.vbs
Вы можете заменить значение ""%windir%\Resources\Themes\aero.theme""" в данном файле на Вашу собственную тему.

Вариант 2. Редактор ресурсов - с внесением изменений в системный файл.

Внимание: Данный вариант Вы используете на свой страх и риск.
Если что-либо пойдет не так система может перестать загружаться и Вам придется востанавливать измененые файлы, используя среду восстановления или MSDaRT-диск.

1) Скачайте и распакуйте архив Full_access.zip
2) Примените reg-файл в соответствии с языковыми особенностями Вашей системы.

Full_access_eng.reg - примените, если Вы используете английскую версию Windows.
Название пункта меню указано на английском языке, название группы администраторов указано на английском языке.
Full_access_eng+rus_mui.reg - примените, если Вы используете английскую версию Windows и русский языковой пакет.
Название пункта меню указано на русском языке, название группы администраторов указано на английском языке.
Full_access_rus.reg - примените, если Вы используете русскую версию Windows.
Название пункта меню указано на русском языке, название группы русском указано на английском языке.

3) Откройте папку C:\Windows
4) Нажмите правой кнопкой на файл explorer.exe и выберите пункт Стать владельцем и задать полный доступ к объекту
5) Скопируйте файл explorer.exe на рабочий стол.
6) Откройте данный файл с помощью программы Restorator.
7) Откройте папку Точечный рисунок
8) Создайте bmp-файлы кнопки Пуск с 32-битной глубиной цвета с указанными ниже именами:

6801.bmp, 6805.bmp, 6809.bmp размером 54x162 для стандартного размера элементов 100%.
6802.bmp, 6806.bmp, 6810.bmp размером 66x198 для стандартного размера элементов 125%.
6803.bmp, 6807.bmp, 6811.bmp размером 81x243 для стандартного размера элементов 150%.
6804.bmp, 6808.bmp, 6812.bmp размером 106x318 для стандартного размера элементов 200%.

9) Перетяните их на ресурсы с идентичным именем.
10) Нажмите сочетание клавиш Ctrl + S, чтобы сохранить изменения.
11) Переименуйте Ваш модифицированный файл файл explorer.exe в explorer1.exe
12) Скопируйте его с рабочего стола в папку C:\Windows
13) Удерживая нажатой клавишу ⇑ Shift щелкните в Проводнике правой кнопкой мыши на папке Windows и выберите пункт Открыть окно команд.
14) Нажмите правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
15) Установите тему Классическая.
16) Переключитесь обратно в окно команд и поочередно введите указанные ниже команды, нажимая после ввода каждой из них Enter ↵.

Данная команда закроет все процессы Проводника.

Данные команды переименуют оригинальный файл Проводника explorer.exe в _explorer.exe, а Ваш модифицированный файл explorer1.exe в explorer.exe.
После чего будет запущен Проводник.

17) Нажмите правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
18) Установите любую аэро-тему или тему "Windows 7 - упрощенный стиль".

Вариант 3. Windows 7 Start Orb Changer.

Чтобы заменить кнопку Пуск:

1) Скачайте архив Windows_7_Start_Orb_Changer.zip, распакуйте его в любую папку и запустите программу.
2) Нажмите кнопку Change, выберите png-файл с картинками для кнопки Пуск и нажмите кнопку Открыть.
3) В окне Succes нажмите кнопку OK.

Чтобы вернуть обратно оригинальную кнопку Пуск:

1) Запустите программу Windows 7 Start Orb Changer.
2) Нажмите кнопку Restore.
3) В случае появления ошибки:
3.1) Нажмите кнопку ОК.
3.2) Нажмите Ctrl+⇑ Shift+Esc
3.3) В Диспетчере задач перейдите Файл → Новая задача (Выполнить...)
3.4) Введите команду explorer и нажмите клавишу Enter ↵.

Удаление кнопки Пуск.

1) Скачайте программу Start Killer c официального сайта (установщик) или с зеркала (портативная версия).
2) Установите и запустите программу, если скачали по официальной ссылке или просто распакуйте архив и запустите (в соответствии с разрядностью Вашей Windows), если скачали с зеркала.
3) Когда Start Killer запустится, он автоматически удалит кнопку Пуск с Вашей панели задач.
Но Вы по-прежнему сможете открыть меню Пуск нажав на клавиатуре комбинацию клавиш Ctrl + Esc или просто нажав клавишу с логотипом Windows.
4) Start Killer будет отображать иконку в области уведомлений.

Если Вы захотите, чтобы программа Start Killer запускалась автоматически при старте Windows, то:

1) Нажмите правой кнопкой мыши на значок в области уведомлений и выберите пункт Settings.
2) Установите флажок Load on system startup и нажмите кнопку ОК.

Если Вы выйдите из программы Start Killer, то кнопка Пуск снова отобразится на панели задач.

43. Переключение тем оформления Windows без использования окна Персонализация.
Чтобы переключиться на другую тему оформления Windows путем ввода команды в диалоговом окне Выполнить, в окне команд или указав его в пакетном файле, воспользуйтесь одним из предложенных ниже вариантов:

Вариант 1. С открытием окна Персонализация после смены темы.

Введите в диалоговом окне Выполнить (Win   + R) или в окне команд (Win   + R → cmd) указанную ниже команду:

где:

Path to theme - укажите путь к переключаемой теме.
name.theme - укажите имя темы.

Примеры:

После переключения темы откроется окно Персонализация.

Вариант 2. Без открытия окна Персонализация после смены темы.

1) Cкачайте программу ThemeTool от Microsoft, входящую в средства устранения неполадок.
2) Распакуйте архив в любую папку и скопируйте программу в папку C:\Windows\System32.
3) Введите в диалоговом окне Выполнить (Win   + R) или в окне команд (Win   + R → cmd) указанную ниже команду:

где:

changetheme - параметр для изменения темы.
Path to theme - укажите путь к переключаемой теме.
name.theme - укажите имя темы.

Примеры:

Также Вы можете создать vbs-скрипт (обычный текстовый файл с расширением .vbs вместо .txt), который будет переключать тему без отображения окна команд:

44. Редактирование темы или файла стиля оформления Windows для изменения внешнего вида различных элементов системы.

Если для изменения внешнего вида Windows количество доступных по умолчанию в системе возможностей Вам кажется недостаточно, то для внесения более детальных изменений Вы можете воспользоваться указанными ниже программами.
На время работы с программами "Контроль учетных записей" рекомендуется отключить.

Для применения указанных ниже решений:

1) Полностью отключите контроль учетных записей (Win   + R → UserAccountControlSettings), передвинув ползунок в самый низ и перезагрузив компьютер.
2) В зависимости от разрядности Вашей системы воспользуйтесь патчем Theme Patcher для модификации файлов themeservice.dll, themeui.dll, uxtheme.dll.
Данный патч добавит в них возможность использования сторонних тем. Патч необходимо запускать от имени администратора.

Вариант 1. Theme Resource Changer.

Данная программа позволит Вам установить собственные png-изображения, вместо используемых системой bmp-файлов (точечных рисунков) или ico-файлов иконок из системных файлов.
Вы сможете немного отредактировать используемую Вами тему, изменить внешний вид кнопки Пуск, фоновых изображений для панелей Проводника, стрелок навигации и других иконок без внесения изменений в системные файлы.

1) Скачайте и распакуйте архив ThemeResourceChanger.zip
2) Установите программу Theme Resource Changer той же разрядности, что и у Вашей Windows.
Если окно команд самостоятельно не закроется у Вас по окончании установки, то закройте его вручную.
3) Перезагрузите компьютер.
4) Откройте Панель управления\Оформление и персонализация\Параметры папок → вкладка Вид
5) Снимите флажок Запускать окна с папками в отдельном процессе и нажмите кнопку ОК.
4) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
5) Установите тему в которую Вы желаете внести изменения.
6.1) Если Вы используете одну из стандартных тем Windows, то откройте папку C:\Windows\Resources\Themes\Aero\.
6.2) Если Вы используете стороннюю тему, то откройте папку данной темы.
7) Создайте в ней, три папки с именами:

explorer.exe
explorerframe.dll
shell32.dll

8) Поместите в указанные папки PNG-файлы изображений (не BMP), которые Вы желаете использовать вместо оригинальных ресурсов, расположенных в файлах, соответствующих именам данных папок.
Копируемые изображения должны иметь номера ресурсов и размеры идентичные оригинальным.

Например:

Чтобы заменить фоновое изображения боковой панели Проводника добавьте в папку C:\Windows\Resources\Themes\Aero\shell32.dll\ файл 633.png размером 200x551 пикселей.
Чтобы заменить кнопку Пуск:

6801.png, 6805.png, 6809.png размером 54x162 для стандартного размера элементов 100%.
6802.png, 6806.png, 6810.png размером 66x198 для стандартного размера элементов 125%.
6803.png, 6807.png, 6811.png размером 81x243 для стандартного размера элементов 150%.
6804.png, 6808.png, 6812.png размером 106x318 для стандартного размера элементов 200%.

Чтобы заменить рамку пользователя:

7013.png размером 64x64 для стандартного размера элементов 100%.
7014.png размером 80x80 для стандартного размера элементов 125%.
7015.png размером 96x96 для стандартного размера элементов 150%.
7016.png размером 128x128 для стандартного размера элементов 200%.

Вы можете найти необходимый Вам ресурс используя любой редактор ресурсов (Например, Restorator).

Условия для использования Вашего png-файла изображения:

1) Имя png-файла должно соответствовать имени заменяемого ресурса.
2) Размеры png-файла при замене ресурса являющегося точечным рисунком (bmp-файлом) должны быть идентичны.
3) Размеры png-файла при замене ресурса являющегося иконкой (ico-файлом) должны быть 256x256.
4) Используемый Вами png-файл должен находится в папке, соответствующей названию файла в котором содержится ресурс.
5) Для применения заменяемого ресурса вместо оригинального переключайтесь в Классическую тему, а затем обратно в аэро-тему или тему "Windows 7 - упрощенный стиль".

Чтобы отменить внесенные в используемую Вами тему изменения, удалите добавленные Вами png-файлы.

Оригинальную инструкцию на английском языке от автора программы, Вы сможете найти внустри архива с программой ThemeResourceChanger.zip.

Вариант 2. Windows Style Builder.

Данная программа является очень мощным решением, позволяющая изменить любой шрифт, размер, цвет и фон любого элемента интерфейса.

Чтобы изменить внешний вид какого-либо элемента (шрифт, кнопку, полосу прокрутки, фон и др.) выполните следующий порядок действий.

1) Скачайте и распакуйте в любую папку архив WindowsStyleBuilder.zip, и установите программу Windows Style Builder.
2) Откройте папку C:\Windows\Resources\Themes
3) Создайте в ней папку с именем Вашей будущей темы. (Например: MyTheme).
4) Запустите программу Windows Style Builder.
5) Внесите необходимые изменения в стиль оформления Windows и нажмите кнопку Save (Сохранить)
6) Откройте папку созданную Вами папку. (C:\Windows\Resources\Themes\MyTheme)
7) Сохраните созданный стиль Windows. (Например: mytheme.msstyles)

Если Вы используете новую версию программы, то при сохранении стиля установите флажок Write .theme file для сохранения сделанных Вами изменений как отдельной темы.
Ваша тема будет сохранена там где Вы укажете.

8) Во всплывшем окне нажмите кнопку Use Visual Style (Использовать визуальный стиль)
9) При повторном редактировании файла и принятии сделанных изменений нажмите во всплывшем окне кнопку Use Aero (Использование Aero), а затем кнопку Use Visual Style (Использовать визуальный стиль)

Если Вы используете старую версию программы, то для сохранения темы выполните следующее:

10) Нажмите правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
11) В разделе Мои темы щелкните правой кнопкой мыши на мини-изображение Несохраненая тема и выберите пункт Сохранить тему.
12) Введите имя темы (Например: MyTheme) и нажмите кнопку Сохранить.
Ваша тема будет сохранена в папке %LOCALAPPDATA%\Microsoft\Windows\Themes.

Подробные инструкции использования программы Вы можете скачать по ссылке: WindowsStyleBuilder_Manuals.zip

45. Замена иконки для определенного типа файла.

Чтобы изменить иконку, используемую для расширения файла по умолчанию, воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1.

1) Скачайте архив DefaultProgramsEditor.zip и распакуйте в любую папку.
2) Откройте данную папку, нажмите правой кнопкой мыши на exe-файл и выберите пункт Запуск от имени администратора.
3) В ней нажмите File Type Settings → Icon.
4) Выберите из списка расширение Вашего файла и нажмите кнопку Next.
5) Нажмите кнопку Browse и выберите файл иконки .ico или файлы .exe или .dll, которые содержат иконку. (Например exe-файл программы ,которая может открывать данное расширение).
6) Нажмите кнопку ОК, затем кнопку Save Icon, а после кнопку ОК.
7) Закройте программу.

Вариант 2.

1) Найдите в ветке реестра HKEY_CLASSES_ROOT раздел с расширением Вашего файла (например: .txt)
2) Откройте данный раздел (Пример: HKEY_CLASSES_ROOT\.txt)
3) Уточните какое значение указано у параметра По умолчанию (Пример: txtfile)
4) Откройте в ветке реестра HKEY_CLASSES_ROOT раздел с данным именем (Пример: HKEY_CLASSES_ROOT\txtfile)
5) Откройте в нем ветку DefaultIcon (Пример: HKEY_CLASSES_ROOT\txtfile\DefaultIcon)
6) Замените значение у параметра По умолчанию на значение необходимой Вам иконки.

Интерфейс - Взаимодействие.

1. Открытие диспетчера задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту.

Вариант 1

Нажмите комбинацию клавиш Ctrl + ⇑ Shift + Esc.

Вариант 2

Щелкните правой кнопкой на панели задач и выберите пункт Запустить диспетчер задач (Start Task Manager).

2. Использование средней кнопки мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

3. Перезапуск Проводника или рабочего стола.

Вариант 1. Только клавиатура.

1) Нажмите комбинацию клавиш Ctrl + Esc
2) Нажмите →
3) Нажмите комбинацию клавиш Ctrl + ⇑ Shift + F10
4) Нажмите ↓, чтобы перейти на пункт Выход из Проводника (Exit Explorer) и нажмите Enter ↵.
5) Нажмите комбинацию клавиш Ctrl + ⇑ Shift + Esc
6) Нажмите последовательно: Alt, затем ↓ и нажмите Enter ↵.
7) Введите команду explorer и нажмите клавишу Enter ↵.

Вариант 2. Частичное использование Диспетчера задач.

1) Откройте меню Пуск
2) Удерживая нажатым комбинацию клавиш Ctrl + ⇑ Shift, щелкните правой кнопкой мыши кнопку Завершение работы (Shut Down).
3) В контекстном меню выберите пункт Выход из Проводника (Exit Explorer).
4) Нажмите комбинацию клавиш Ctrl + ⇑ Shift + Esc
5) Нажмите Файл → Новая задача (Выполнить...) или в английской версии File → New Task (Run...)
6) Введите команду explorer и нажмите кнопку ОК

Вариант 3. Полное использование Диспетчера задач.

1) Откройте Диспетчер задач (Task Manager)
1.1) Щелкните правой кнопкой мыши пустую область на панели задач и выберите команду Запустить диспетчер задач или нажмите сочетание клавиш Ctrl + ⇑ Shift + Esc
2) Перейдите на вкладку Процессы (Processes)
3) Щелкните правой кнопкой мыши на процесс explorer.exe и выберите пункт Завершить процесс (End Process). Если у Вас несколько процессов с таким названием, то повторите данное действие для каждого процесса explorer.exe.
4) Нажмите Файл → Новая задача (Выполнить...) или в английской версии File → New Task (Run...)
5) Введите команду explorer и нажмите кнопку ОК

4. Запуск команд Windows Shell, используя названия и {GUID} объектов.

Microsoft Windows Shell - интерпретатор команд операционной системы (ОС), обеспечивающий интерфейс для взаимодействия пользователя с функциями системы. Позволяет получить доступ к диалоговым окнам, к файловой системе, запускать программы и изменять системные настройки.
Для быстрого перехода к компонентам Windows используется команда shell.
GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Использование GUID гарантирует, что две версии одного компонента могут иметь одно и то же имя, но быть отличимыми по GUID. Microsoft применяет GUID в качестве идентификаторов для большого количества своих объектов. Зная GUID Вы сможете открыть многие компоненты Windows: элементы Панели управления, системные папки, различные программы и настройки.

Для запуска любого из объектов Windows, используя {GUID}, применяется команда:

где {GUID} - идентификатор {GUID} нужного Вам объекта. Например, для запуска Панели управления наберите команду:

Вы можете поискать нужные Вам {GUID} в разделе реестра HKEY_CLASSES_ROOT\CLSID или воспользоваться таблицей №1.

Таблица №1.

Русское название элемента | Английское название элемента | Команда
Flip 3D (Win+Tab) | Flip 3D (Win+Tab) | Shell:::{3080F90E-D7AD-11D9-BD98-0000947B0257}
Fusion Cache | Fusion Cache | Shell:::{1D2680C9-0E2A-469d-B787-065558BC7D43}
Internet Explorer | Internet Explorer | Shell:::{871C5380-42A0-1069-A2EA-08002B30309D}
Microsoft Outlook | Microsoft Outlook | Shell:::{2559a1f5-21d7-11d4-bdaf-00c04f60b9f0}
Windows CardSpace | Windows CardSpace | Shell:::{78CB147A-98EA-4AA6-B0DF-C8681F69341C}
Windows SideShow | Windows SideShow | Shell:::{E95A4861-D57A-4be1-AD0F-35267E261739}
Автозапуск | AutoPlay | Shell:::{9C60DE1E-E5FC-40f4-A487-460851A8D915}
Автономные файлы | Offline Files | Shell:::{D24F75AA-4F2B-4D07-A3C4-469B3D9030C4}
Администрирование | Administrative Tools | Shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Архивация и восстановление | Backup and Restore | Shell:::{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}
Библиотеки | Libraries | Shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Биометрические устройства | Biometric Devices | Shell:::{0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}
Брандмауэр Windows | Windows Firewall | Shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423}
Восстановление | Recovery | Shell:::{9FE63AFD-59CF-4419-9775-ABCC3849F861}
Восстановление системы | System Restore | Shell:::{3f6bc534-dfa1-4ab4-ae54-ef25a74e0107}
Все задачи | All Tasks | Shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Все элементы панели управления | All Control Panel Items | Shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Выполнить | Run | Shell:::{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}
Гаджеты рабочего стола | Desktop Gadgets | Shell:::{37efd44d-ef8d-41b1-940d-96973a50e9e0}
Дата и Время | Date and Time | Shell:::{E2E7934B-DCE5-43C4-9576-7FE4F75E7480}
Датчик расположения и другие датчики | Location and Other Sensors | Shell:::{E9950154-C418-419e-A90A-20C5287AE24B}
Диспетчер устройств | Device Manager | Shell:::{74246bfc-4c96-11d0-abef-0020af6b0b7a}
Диспетчер учетных данных | Credential Manager | Shell:::{1206F5F1-0569-412C-8FEC-3204630DFB70}
Домашняя группа | HomeGroup | Shell:::{67CA7650-96E6-4FDD-BB43-A8E774F73A57}
Домашняя группа - папка | HomeGroup folder | Shell:::{6785BFAC-9D2D-4be5-B7E2-59937E8FB80A}
Защитник Windows | Windows Defender | Shell:::{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}
Звук | Sound | Shell:::{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}
Значки области уведомлений | Notification Area Icons | Shell:::{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}
Игровые устройства | Game Controllers | Shell:::{259EF4B1-E6C9-4176-B574-481532C9BCE8}
Игры | Games | Shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
Избранное | Favorites | Shell:::{323CA680-C24D-4099-B94D-446DD2D7249E}
Инфракрасная связь | Infrared | Shell:::{A0275511-0E86-4ECA-97C2-ECD8F1221D08}
Карта сети | Network Map | Shell:::{E7DE9B1A-7533-4556-9484-B26FB486475E}
Компоненты Windows | Windows Features | Shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Компьютер | Computer | Shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина | Recycle Bin | Shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Мои Документы | My Documents | Shell:::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Настройка доступа программ и умолчаний | Set Program access and Windows defaults | Shell:::{2559a1f7-21d7-11d4-bdaf-00c04f60b9f0}
Недавние места | Recent Places | Shell:::{22877a6d-37a1-461a-91b0-dbda5aaebc99}
Общие | Public | Shell:::{4336a54d-038b-4685-ab02-99bb52d3fb8b}
Панель управления (заданного Вами вида) | Control Panel | Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Панель управления (Категория) | Control Panel (Category) | Shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Параметры индексирования | Indexing Options | Shell:::{87D66A43-7B11-4A28-9811-C86EE395ACF7}
Параметры папок | Folder Options | Shell:::{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}
Параметры планшетного компьютера | Tablet PC Settings | Shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}
Параметры шрифта | Font settings | Shell:::{93412589-74D4-4E4E-AD0E-E0CB621440FD}
Переносные устройства | Portable Devices | Shell:::{35786D3C-B075-49b9-88DD-029876E11C01}
Перо и сенсорные устройства | Pen and Touch | Shell:::{F82DF8F7-8B9F-442E-A48C-818EA735FF9B}
Персонализация | Personalization | Shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | Shell:::{241D7C96-F8BF-4F85-B01F-E2B043341A4B}
Поиск Windows | Search | Shell:::{2559a1f0-21d7-11d4-bdaf-00c04f60b9f0}
Получение программ | Get Programs | Shell:::{15eae92e-f17a-4431-9f28-805e482dafd4}
Принтеры | Printers | Shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Приступая к работе | Getting Started | Shell:::{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}
Программы и компоненты | Programs and Features | Shell:::{7b81be6a-ce2b-4676-a29e-eb907a5126c5}
Программы по умолчанию | Default Programs | Shell:::{17cd9488-1228-4b2f-88ce-4298e93e0966}
Рабочий стол | Desktop | Shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}
Распознавание речи | Speech Recognition | Shell:::{58E3C745-D971-4081-9034-86E34B30836A}
Расположение по умолчанию | Default Location | Shell:::{00C6D95F-329C-409a-81D7-C46C66EA7F33}
Родительский контроль | Parental Controls | Shell:::{96AE8D84-A250-4520-95A5-A47A7E3C548B}
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | Shell:::{0DF44EAA-FF21-4412-828E-260A8728E7F1}
Свойства речи | Text to Speech | Shell:::{D17D1D6D-CC3F-4815-8FE3-607E7D5D10B3}
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | Shell:::{A304259D-52B8-4526-8B1A-A1D6CECC8243}
Свойства: Интернет | Internet Properties | Shell:::{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}
Свойства: Клавиатура | Keyboard Properties | Shell:::{725BE8F7-668E-4C7B-8F90-46BDB0936430}
Свойства: Мышь | Mouse Properties | Shell:::{6C8EEC18-8D75-41B2-A177-8831D59D2D50}
Сетевые подключения | Network Connections | Shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сетевые подключения в Области уведомления | Network Connections in Notification area | Shell:::{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}
Сеть | Network | Shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Система | System | Shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE}
Сканеры и камеры | Scanners and Cameras | Shell:::{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}
Соседние пользователи | People Near Me | Shell:::{5224F545-A443-4859-BA23-7B5A95BDC8EF}
Справка и Поддержка | Windows Help and Support | Shell:::{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}
Счетчики и средства производительности | Performance Information and Tools | Shell:::{78F3955E-3B90-4184-BD14-5397C15F1EFC}
Телефон и модем | Phone and Modem | Shell:::{40419485-C444-4567-851A-2DD7BFA1684D}
Управление беспроводными сетями | Manage Wireless networks | Shell:::{1FA9085F-25A2-489B-85D4-86326EEDCD87}
Управление цветом | Color Management | Shell:::{B2C761C6-29BC-4f19-9251-E6195265BAF1}
Установленные обновления | Installed Updates | Shell:::{d450a8a1-9568-45c7-9c0e-b4f9fb4537bd}
Устранение неполадок | Troubleshooting | Shell:::{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}
Устройства Bluetooth | Bluetooth Devices | Shell:::{28803F59-3A75-4058-995F-4EE5503B023C}
Устройства и принтеры | Devices and Printers | Shell:::{A8A91A66-3A7D-4424-8D24-04E180695C7A}
Учетные записи пользователей | User Accounts | Shell:::{60632754-c523-4b62-b45c-4172da012619}
Центр мобильности Windows | Windows Mobility Center | Shell:::{5ea4f148-308c-46d7-98a9-49041b1dd468}
Центр обновления Windows | Windows Update | Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
Центр поддержки | Action Center | Shell:::{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}
Центр синхронизации | Sync Center | Shell:::{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}
Центр специальных возможностей | Ease of Access Center | Shell:::{D555645E-D4F8-4c29-A827-D93C859C4F2A}
Центр управления сетями и общим доступом | Network and Sharing Center | Shell:::{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}
Шифрование диска BitLocker | BitLocker Drive Encryption | Shell:::{D9EF8727-CAC2-4e60-809E-86F80A666C91}
Экран (размер текста) | Display (size of text) | Shell:::{C555438B-3C23-4769-A71F-B6D3D9B6053A}
Электропитание | Power Options | Shell:::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Язык и региональные стандарты | Region and Language | Shell:::{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}
Русское название элемента | Английское название элемента | Команда

Для некоторых системных папок, Вы можете создать их копии, в любом, необходимом для Вас месте. Такие папки не будут занимать место на диске, а будут служить символическими ссылками на оригинальные. Для создания такой папки-ссылки:

1) Создайте в любом нужном Вам месте новую папку (Щелчок ПКМ → Создать → Папку)
2) Переименуйте её следующим образом:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Принцип запуска команд Shell, используя имя объектов, намного легче. Данный способ не требует от Вас знания большого количества цифр и букв, и позволяет снизить величину ошибок при наборе команды. Его основное применение - открытие системных папок.

Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет в Проводнике будет открыта папка: C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Для запуска любого из объектов Windows, используя его имя, применяется команда:

Вы можете найти нужные Вам имена объектов в разделах ветки реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FolderDescriptions или воспользоваться таблицей №2.

Таблица №2.

Имя программы или папки | Адрес папки | Команда
32-разрядный Internet Explorer | C:\Program Files\Internet Explorer или C:\Program Files (x86)\Internet Explorer | shell:InternetFolder
Common Files (в 32-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommon
Common Files (в 64-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommonX64
Common Files (в 64-битной Windows 7) | C:\Program Files (x86)\Common Files | shell:ProgramFilesCommonX86
Cookies | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies | shell:Cookies
Credentials | C:\Users\User-Name\AppData\Roaming\Microsoft\Credentials | shell:CredentialManager
Crypto | C:\Users\User-Name\AppData\Roaming\Microsoft\Crypto | shell:CryptoKeys
DeviceMetadataStore | C:\ProgramData\Microsoft\Windows\DeviceMetadataStore | shell:Device Metadata Store
Documents | C:\Users\Public\Documents | shell:Common Documents
Fonts (шрифты) | C:\Windows\Fonts | shell:Fonts
Gadgets | C:\Program Files\Windows Sidebar\Gadgets | shell:default Gadgets
Gadgets | C:\Users\User-Name\AppData\Local\Microsoft\WindowsSidebar\Gadgets | shell:Gadgets
GameExplorer | C:\ProgramData\Microsoft\Windows\GameExplorer | shell:PublicGameTasks
GameExplorer (Обозреватель игр) | C:\Users\User-Name\AppData\Local\Microsoft\Windows\GameExplorer | shell:GameTasks
History | C:\Users\User-Name\AppData\Local\Microsoft\Windows\History | shell:History
ImplicitAppShortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts | shell:ImplicitAppShortcuts
Local | C:\Users\User-Name\AppData\Local | shell:Local AppData
LocalLow | C:\Users\User-Name\AppData\LocalLow | shell:LocalAppDataLow
Low | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies\Low | shell:Cookies\Low
Network Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\NetworkShortcuts | shell:NetHood
Printer Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\PrinterShortcuts | shell:PrintHood
Program Files | C:\Program Files | shell:ProgramFiles
Program Files (x86) (в 64-битной Windows 7) | C:\Program Files (x86) | shell:ProgramFilesX86
Program Files (в 64-битной Windows 7) | C:\Program Files | shell:ProgramFilesX64
ProgramData | C:\ProgramData | shell:Common AppData
Protect | C:\Users\User-Name\AppData\Roaming\Microsoft\Protect | shell:dpapiKeys
Quick Launch (Быстрый запуск) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch | shell:Quick Launch
Resources (содержит темы Windows) | C:\Windows\Resources | shell:ResourceDir
Ringtones | C:\ProgramData\Microsoft\Windows\Ringtones | shell:CommonRingtones
Roaming | C:\Users\User-Name\AppData\Roaming | shell:AppData
SendTo (элементы контекстного меню Отправить) | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\SendTo | shell:SendTo
System32 | C:\Windows\System32 | shell:System
SystemCertificates | C:\Users\User-Name\AppData\Roaming\Microsoft\SystemCertificates | shell:SystemCertificates
SysWOW64 | C:\Windows\SysWOW64 | shell:SystemX86
Templates | C:\ProgramData\Microsoft\Windows\Templates | shell:Common Templates
Templates | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Templates | shell:Templates
Temporary Internet Files | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Temporary Internet Files | shell:Cache
User Pinned (Закрепленные элементы) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned | shell:User Pinned
User-Name (файлы Вашей учетной записи) | C:\Users\User-Name | shell:UsersFilesFolder
User-Name (Ваш учетный профиль) | C:\Users\User-Name | shell:Profile
Windows (главная папка системы) | C:\Windows | shell:Windows
Автозагрузка | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup | shell:Common Startup
Автозагрузка | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup | shell:Startup
Администрирование | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Administrative Tools
Администрирование | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Common Administrative Tools
Библиотеки | Библиотеки | shell:Libraries
Библиотеки | Библиотеки | shell:UsersLibrariesFolder
Видео | Библиотеки\Видео | shell:VideosLibrary
Временная папка для записи | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Burn\Burn | shell:CD Burning
Все элементы панели управления | Панель управления\Все элементы панели управления | shell:ControlPanelFolder
Главное меню | C:\ProgramData\Microsoft\Windows\Start Menu | shell:Common Start Menu
Главное меню | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu | shell:Start Menu
Документы | Библиотеки\Документы | shell:DocumentsLibrary
Домашняя группа | Домашняя группа | shell:HomeGroupFolder
Загрузки | C:\Users\User-Name\Downloads | shell:downloads
Згрузки | C:\Users\Public\Downloads | shell:CommonDownloads
Игры | Игры | shell:Games
Избранное | C:\Users\User-Name\Favorites | shell:Favorites
Изображения | C:\Users\Public\Pictures | shell:CommonPictures
Изображения | C:\Users\User-Name\Pictures | shell:My Pictures
Изображения | Библиотеки\Изображения | shell:PicturesLibrary
Компьютер | Компьютер | shell:MyComputerFolder
Контакты | C:\Users\User-Name\Contacts | shell:Contacts
Конфликты | Панель управления\Все элементы панели управления\Центр синхронизации\Конфликты | shell:ConflictFolder
Корзина | Корзина | shell:RecycleBinFolder
Мои видеозаписи | C:\Users\User-Name\Videos | shell:CommonVideo
Мои видеозаписи | C:\Users\User-Name\Videos | shell:My Video
Мои документы | C:\Users\User-Name\Documents | shell:Personal
Моя Музыка | C:\Users\Public\Music | shell:CommonMusic
Моя музыка | C:\Users\User-Name\Music | shell:My Music
Музыка | Библиотеки\Музыка | shell:MusicLibrary
Настройка синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Настройка синхронизации | shell:SyncSetupFolder
Недавние документы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Recent | shell:Recent
Образцы видео | C:\Users\Public\Videos\Sample Videos | shell:SampleVideos
Образцы изображений | C:\Users\Public\Pictures\Sample Pictures | shell:SamplePictures
Образцы музыки | C:\Users\Public\Music\Sample Music | shell:SampleMusic
Общие | C:\Users\Public | shell:Public
Папка с рингтонами Windows 7 | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Ringtones | shell:Ringtones
Поиск Windows | search-ms: | shell:SearchHomeFolder
Поиски (информация о поисках) | C:\Users\User-Name\Searches | shell:Searches
Получение программ | Панель управления\Все элементы панели управления\Получение программ | shell:AddNewProgramsFolder
Пользователи | C:\Users | shell:UserProfiles
Принтеры | Все элементы панели управления\Принтеры | shell:PrintersFolder
Программы | C:\ProgramData\Microsoft\Windows\Start Menu\Programs | shell:Common Programs
Программы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu\Programs | shell:Programs
Программы и компоненты | Панель управления\Все элементы панели управления\Программы и компоненты | shell:ChangeRemoveProgramsFolder
Рабочий стол | C:\Users\Public\Desktop | shell:Common Desktop
Рабочий стол | C:\Users\User-Name\Desktop | shell:desktop
Результаты синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Результаты синхронизации | shell:SyncResultsFolder
Сетевые подключения | Панель управления\Все элементы панели управления\Сетевые подключения | shell:ConnectionsFolder
Сеть | Сеть | shell:NetworkPlacesFolder
Сохраненные игры | C:\Users\User-Name\Saved Games | shell:SavedGames
Ссылки | C:\Users\User-Name\Links | shell:Links
Установленные обновления | Программы и компоненты\Установленные обновления | shell:AppUpdatesFolder
Центр синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации | shell:SyncCenterFolder
Имя программы или папки | Адрес папки | Команда

Чтобы создать ярлык, используя названия или {GUID} команды Windows Shell, в поле Укажите расположение объекта введите:

или

или

Например, для создания ярлыка папки Компьютер, в поле Укажите расположение объекта введите:

или

Для упрощения работы с командами Windows Shell Вы можете скачать небольшую бесплатную программу Shell Dump.
Данная программа проанализирует Ваш реестр и отобразит список команд, которые Вы можете использовать. Вам всего лишь достаточно выбрать команду и нажать кнопку Run для ее запуска.

5. Создание ярлыка для функции Windows Flip 3D (переключение между окнами под углом).

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

Для переключения между окнами в режиме Flip3D, Вы можете использовать комбинацию клавиш Win   + Tab ↹ или же удерживая нажатой клавишу Win   прокручивать колесо мыши.

6. Использование переменных окружения для быстрого перехода к системным папкам.

Для быстрого перехода в системные папки Вы можете воспользоваться переменными, введя их в адресной строке Проводника и нажав клавишу Enter ↵.
Чтобы узнать какие из переменных присутствуют в Вашей системе:

1) Введите в строке поиска меню Пуск cmd и нажмите Enter ↵.
2) В окне команд введите команду set и нажмите Enter ↵.
В таблице ниже приведен полный список стандартных переменных окружения Windows.

Переменная | Соответствие расположению в системе
%ALLUSERSPROFILE% | C:\ProgramData
%APPDATA% | C:\Users\UserName\AppData\Roaming
%CommonProgramFiles% | C:\Program Files\Common Files
%CommonProgramFiles(x86)% | C:\Program Files (x86)\Common Files
%CommonProgramW6432% | C:\Program Files\Common Files
%ComSpec% | Запуск cmd.exe из папки, в которой будет употреблен
%HOMEDRIVE% | C:\
%HOMEPATH% | C:\Users\UserName
%LOCALAPPDATA% | C:\Users\UserName\AppData\Local
%ProgramData% | C:\ProgramData
%ProgramFiles% | C:\Program Files
%ProgramW6432% | C:\Program Files
%ProgramFiles(x86)% | C:\Program Files (x86)
%PSModulePath% | C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%PUBLIC% | C:\Users\Public
%SystemDir% | C:\Windows\System32
%SystemDrive% | C:\
%SystemRoot% | C:\Windows
%TEMP% | C:\Users\UserName\AppData\Local\Temp
%TMP% | C:\Users\UserName\AppData\Local\Temp
%USERPROFILE% | C:\Users\UserName
%windir% | C:\Windows

Если Вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер → Свойства → Дополнительные параметры системы → Дополнительно → Переменные среды
2) Нажмите Создать...
3) Укажите Имя переменной и Значение переменной
4) Нажмите на каждое ОК
5) Перезагрузите компьютер (иначе она не будет работать)

7. Установка положения курсора в диалоговом окне на кнопке, выбираемой по умолчанию.

Для многих пользователей весьма удобным считается, чтобы курсор мыши при открытии диалогового окна занимал позицию на кнопке Открыть, Сохранить или аналогичной по умолчанию. Данное действие позволяет Вам сэкономить время необходимое для наведения курсора.

1) Откройте Панель управления → Мышь
2) Перейдите на вкладку Параметры указателя
3) В графе "Исходное положение в диалоговом окне" установите флажок "На кнопке, выбираемой по умолчанию"
4) Нажмите ОК.

8. Уточнение даты и времени загрузки системы.

Вариант 1.

Если Вам необходимо узнать дату и время установки Windows на компьютер или дату и время когда компьютер был запущен, то сделайте следующее:

1) Запустите командную строку с правами администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду systeminfo

В графе с одноименным названием Вы найдете необходимое Вам значение.

Вариант 2.

1) Скачайте с сайта Microsoft программу uptime.exe (http://support.microsoft.com/kb/232243)
2) Скопируйте ее в папку C:\Windows\System32
3) Запустите командную строку с правами администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4) Введите команду uptime.exe.

Вариант 3.

Скачайте и установите специальный гаджет.

systemuptime.zip

9. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

10. Закрытие всех запущенных приложений одним кликом.

Утилита под названием Close All Windows позволяет закрыть все работающие приложения с помощью всего одного клика. Она не требует установки и не использует ресурсов, так как посылает только команду "Закрыть" всем действующим приложениям.

1) Скачайте программу CloseAll
2) Распакуйте архив в удобное Вам место для использования.
3) Откройте папку 1.3
4) Переместите файл на панель задач файл CloseAll.exe, если у Вас 32-битная версия, или файл CloseAll_x64.exe, если у вас 64-битная система.

Чтобы назначить клавишу быстрого вызова и добавить исключения для программ, которые закрываться не будут:

1) Щелкните правой кнопкой мыши на иконке в панели задач.
2) Щелкните правой кнопкой мыши на "Close All Windows" и нажмите Свойства
3) В поле Быстрый вызов нажмите нужное сочетание клавиш, для сопоставления выбранной комбинации с программой.
4) В поле Объект добавьте -x="программа.exe"
Для добавления нескольких программ разделите их "|", например:

5) Нажмите ОK для сохранения настроек.

В версии 2.0 при запуске программы откроется окно, в котором Вам необходимо будет установить флажки напротив программ, которые Вы желаете закрыть и нажать кнопку ОК.

11. Открытие командной строки из конкретной папки.

1)Нажмите на клавиатуре клавишу ⇑ Shift.
2) Удерживая ее нажатой, щелкните правой кнопкой мыши на папке из которой Вы желаете открыть командную строку.
3) В контекстном меню нажмите пункт Открыть окно команд (“Open Command Window Here”).

12. Просмотр файлов .nfo и .diz с ASCII графикой.

Часто вместе со скаченной Вами в интернете игрой или программой может присутствовать .nfo или .diz файл.
В нем помимо информации, необходимой Вам для установки, также может содержаться ASCII графика - изображения в текстовом файле нарисованные при помощи знаков (букв и символов).
Для их корректного отображения Вы можете скачать и установить программу GetDiz

13. Использование возможности Windows Flip 3D в Windows 7 Домашняя базовая и Начальная.

Несмотря на то, что некоторые из советов сборника помогают решить проблему с отсутствием в домашней базовой версии Windows 7 возможностей присутствующих в других версиях Windows, их использование не добавляет функции Windows Flip 3D.
Однако, чтобы полностью ощутить радость от использования переключения между окнами под углом, Вы можете скачать программу стороннего производителя.

Ссылка для скачивания: WFlip.zip

14. Запуск программы с параметрами командной строки из контекстного меню Проводника.

Чтобы запустить программу с параметрами - обычно Вам необходимо: либо создать ярлык к программе и при создании указать параметры, либо Пуск → Открыть (Win   + R) ввести программу, указав путь к ней и затем дописать параметры.
Всё это проще позволит сделать программа ExecParm. Данная программа является позволяет запускать исполняемые(.exe, .com) и командные файлы(.cmd, .bat) с параметрами, используя расширение встраиваемое в контекстное меню Проводника. Чтобы его использовать Вам сделайте следующее:

1) Скачайте архив программы ExecParm с необходимой разрядностью: 32-битная, 64-битная .
2) Распакуйте архив в любую папку.
3) Откройте папку с распакованным содержимым. В ней будут три файла: ExecParm.txt, Execparm.dll, Execparm.inf)
4) Щелкните правой кнопкой мыши по файлу Execparm.inf и выберите Установить
Данное действие добавит пункт в контекстное меню для запуска приложения с параметрами.
5) Щелкните правой кнопкой по исполняемому файлу и выберите в контекстном меню пункт Execute With Parameters...
6) Введите необходимые параметры для запуска программы и нажмите ОК.

15. Расчет хеш-суммы для любого файла, а также открытие .sfv и .md5 файлов, используемых для контроля целостности файлов.

Случается, что при выкладывании файла, автор указывает значения контрольных сумм (хеш-сумм) данного файла, таких как md5, crc32, sha-1 или других.
Данные значения необходимы, чтобы проверить целостность полученных данных или же сравнить с уже имеющимся значением аналогичного файла.

Существует много программ предлагающих расчитать значения хеш-функций, но наиболее удобной из них является программа HashTab.

Данная программа добавляет в окно Свойства для любого файла дополнительную вкладку Хеш-суммы файлов.
При переходе на данную вкладку программа HashTab автоматически расчитает значение выбранных Вами хеш-функций.
По умолчанию расчитываются значения md5, crc32, sha-1.

Если Вам необходимы значения других хеш-сумм, то:

1) На вкладке Хеш-суммы файлов нажмите ссылку Настройки.
2) Установите в открывшемся окне флажки рядом с необходимой Вам хеш-функцией и нажмите ОК
Выбирать сразу все не рекомендуется, так как это может привести к длительному вычислению значений хеш-сумм.

Чтобы сравнить хеш-суммы двух аналогичных файлов:

1) На вкладке Хеш-суммы файлов выберите необходимую хеш-функцию для сравнения (по умолчанию используется crc32)
2) Нажмите кнопку Сравнить файл.
2) Выберите необходимый Вам файл для сравнения и нажмите кнопку Открыть.
Если хеш-сумма окажется другой, то рядом с ее значением появится красный крест.
Если хеш-сумма окажется идентичной, то рядом с ее значением появится зеленый флажок.

При скачивании с торрент-трекеров или при распаковке какого-либо архива Вы можете обнаружить среди файлов SFV-файл или MD5-файл.

Данные файлы необходимы для контроля целостности файлов, находящихся рядом в папке, используя контрольную сумму для ее проверки.
При открытии SFV-файла или MD5-файла текстовым редактором внутри можно найти имя файла и его контрольную сумму.
Чтобы не сравнивать вручную каждое значение хеш-суммы файла с упомянутым в SFV-файле или MD5-файле, Вы можете воспользоваться программой QuickSFV.

Для этого, в соответствии с разрядностью Вашей операционной системы скачайте и установите текущую версию (Current version) программы QuickSFV.
Если Вам необходимо проверить хеш-сумму только одного из файлов, находящихся в папке рядом с SFV-файлом или MD5-файлом, то щелкните на проверяемом файле правой кнопкой мыши и выберите пункт Verify Individual File.
Для проверки хеш-сумм всех файлов щелкните на SFV-файле или MD5-файле.
Если значения хеш-сумм окажутся идентичными, то рядом с именем файла появится зеленый флажок, а в колонке Status отобразится значение ОК.

16. Быстрая вставка путей к файлу или папке в окно команд Windows 7.

Наиболее часто используемым способом вставки путей к файлу или папке в окно команд Windows (окно командной строки) является следующее:

1) Выделяете в адресной строке Проводника путь к папке.
2) Щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
3) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить → Вставить
А если необходимо еще добавить имя и расширение файла, то:
4) Щелкаете по файлу правой кнопкой мыши и выбираете Переименовать.
5) Выделяете имя и расширение файла, щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
6) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить → Вставить

В Windows 7 существуют более быстрые способы сделать это:

Способ 1.

1) Удерживая нажатой клавишу ⇑ Shift щелкните правой кнопкой мыши на папке или файле, путь к которому Вы желаете добавить в окно команд Windows (окно командной строки).
2) В контекстном меню выберите пункт Копировать как путь (“Copy as path”).
3) Щелкните внутри окна команд и выберите пункт Вставить.

Способ 2.

Перетащите файл или папку (путь к которому Вы желаете добавить) напрямую внутрь окна команд Windows.

Примечание: Окно из которого вы перетаскиваете файл или папку в окно команд, должно иметь более высокие или одинаковые права и разрешения, чем само окно команд.

17. Запуск командной строки из "Диспетчера задач" без ввода команды CMD.

1) Запустите Диспетчер задач нажав на клавиатуре комбинацию клавиш Ctrl + ⇑ Shift + Esc.
2) Удерживая нажатой клавишу Ctrl выберите в главном меню пункт Файл и щелкните → Новая задача (Выполнить...)

Примечание:

Если у Вас включен Контроль учётных записей (UAC) или Диспетчер задач запущен в ограниченной учётной записи, окно команд откроется без прав администратора.
Если у Вас отключен Контроль учётных записей (UAC) или Диспетчер задач запущен с правами администратора, окно команд откроется с правами администратора.

18. Изменение действий осуществляемых системой при использовании щелчков мыши.

Если Вы привыкли к поведению мыши в браузере, то Вы можете переключить режим используемый при щелчке мышью в системе на идентичный. Для этого выполните следующие действия:

1) Откройте Панель управления в режиме просмотра всех элементов: Пуск → Панель управления\Все элементы панели управления
2) Запустите Параметры папок
3) На вкладке Общие установите значение переключателя в
Открывать одним щелчком, выделять указателем → Подчеркивать подписи значков при наведении
4) Нажмите ОК.

19. Команды для распаковки *.cab, *.exe, *.msi, *.msp и *.msu файлов от Microsoft.

Приведенные в примерах команды подразумевают, что Вы запустили окно команд из папки, где находится сам файл.
Чтобы запустить окно команд из папки, где расположен исходный файл, удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке и выберите пункт Открыть окно команд.

Microsoft Cabinet File (.cab):

Команда для запуска:

Пример:

Microsoft Hotfix Installer (.exe):

Команда для запуска:

Пример:

Windows Installer Package (.msi):

Команда для запуска:

Пример:

Microsoft Update Standalone Package (.msu):

Команда для запуска:

Пример:

Microsoft Patch File (.msp)

Скачайте программу MSI_Extractor, распакуйте архив и скопируйте файл msix.exe в папку C:\Windows\System32

Команда для запуска:

Пример:

Также Вы можете распаковать .msu, .cab или .exe файл обновления, используя программу KB_Extractor.
Чтобы распаковать данный файл перекиньте его на значок программы KB_Extractor.exe и распакованные файлы и папки из данного обновления окажутся в папке %TEMP% .

20. Быстрое открытие ещё одной копии приложения.

Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу ⇑ Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добиться кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

21. Cохранение настроек интерфейса в Windows.

Чтобы у Вас в Windows корректно сохранялись настройки, например такие как настройки гаджетов рабочего стол, расположение значков на панели и т.д. Вам возможно понадобиться установить пароль на учетную запись администратора и работать из под нее.

Для создания пароля к своей учетной записи сделайте следующее:

1) Откройте папку Учетные записи пользователей в Панели управления.

Панель управления\Все элементы панели управления\Учетные записи пользователей
Панель управления\Учетные записи пользователей и семейная безопасность\Учетные записи пользователей

2) Нажмите ссылку Создание пароля своей учетной записи.
3) Введите новый пароль и его подтверждение.
4) Нажмите кнопку Создать пароль.

Также, может помочь отключение контроля учетных записей (UAC).

22. Переключение с активного окна на неактивное, путем наведении на него курсора.

В Windows существует параметр, позволяющий активизировать окно при наведении на него указателя мыши. Данное использование мыши облегчает выбор или активацию окон, позволяя переключиться на неактивное окно при наведении на него указателя мыши без необходимости выполнения щелчка.

Для настройки данной возможности мыши сделайте следующее:

1) Откройте Панель управления → Центр специальных возможностей
2) Нажмите на ссылку Облегчение работы с мышью (изменение параметров мыши или другого указывающего устройства).
3) В разделе Упрощенное управление окнами установите флажок "Активизировать окно при наведении на него указателя мыши" и нажмите кнопку ОК.

или так:

1) Введите в строке поиска меню Пуск слово: мыши.
2) В списке результатов выберите: Изменение параметров мыши.
3) В разделе Упрощенное управление окнами установите флажок "Активизировать окно при наведении на него указателя мыши" и нажмите кнопку ОК.

23. Создание ярлыка для очистки буфера обмена.

Если Вам приходится часто работать с данными содержащими конфиденциальную информацию (пароли, номера кредитных карт и т.д.) или же с данными большого объема, используя буфер обмена, то Вам наверняка может потребоваться его очистить.

Для создания специального ярлыка, осуществляющего очистку буфера обмена, выполните указанные ниже действия.

1) Щелкните правой кнопкой мыши по свободному пространству рабочего стола.
2) Выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите:

4) Нажмите кнопку Далее и укажите название ярлыка, после чего нажмите на кнопку Готово.
Теперь достаточно запустить созданный ярлык и буфер обмена будет очищен.

5) Замените иконку командной строки на более подходящую:
5.1) Нажмите правой кнопкой мыши на созданном Вами ярлыке и выберите пункт Свойства.
5.2) В открывшемся окне нажмите кнопку Сменить значок
5.3) Выберите необходимую Вам иконку для отображения и нажмите кнопку ОК.

24. Обнаружение указателя мыши на рабочем столе.

Если Вам бывает необходимо быстро найти курсор мыши на экране, то Вы можете включить функцию обнаружения курсора на экране.

1) В строке поиска меню Пуск введите слово Мышь и нажмите Enter ↵ или откройте Панель управления и выберите компонент Мышь
2) Перейдите на вкладку Параметры указателя
3) В разделе Видимость установите флажок Обозначить расположение указателя при нажатии клавиши Ctrl и нажмите кнопку ОК.

Теперь, чтобы обнаружить курсор мыши нажмите сочетание клавиш Win   + Ctrl и месторасположение курсора обозначится кольцами.

25. Быстрый постоянный доступ к собственной папке из меню Пуск.

Если Вам необходимо добавить собственную папку в меню Пуск для быстрого доступа к часто используемым файлам, то Вы можете сделать это следующим образом.

1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт Свойства.
2) В открывшемся окне нажмите кнопку Настроить.
3) Установите для элемента ТВ-записи переключатель в желаемое значение и нажмите ОК в каждом окне:
3.1) Отображать как меню, для доступа из меню Пуск к файлам в Вашей папке.
3.2) Отображать как ссылку, для открытия Вашей папки из меню Пуск.
4) Откройте меню Пуск, щелкните правой кнопкой мыши на элемент ТВ-записи и выберите пункт Свойства.
5) В открывшемся окне нажмите кнопку Добавить папку, укажите какую папку Вы желаете добавить и нажмите кнопку Добавить папку.
При необходимости Вы можете удалить папку Общедоступные ТВ-записи, выделив ее и нажав кнопку Удалить. Вы можете добавить любое количество папок.
6) В зависимости от содержимого Вашей папки укажите, как ее необходимо оптимизировать.
7) Нажмите кнопку ОК.
8) Откройте меню Пуск, щелкните правой кнопкой мыши на элемент ТВ-записи и выберите пункт Переименовать.
9) Введите желаемое имя для отображаемого элемента в меню Пуск.

26. Добавление, изменение и удаление пунктов в контекстном меню.

Если Вам необходимо добавить или удалить пункт в контекстном меню, то наиболее простым способом это сделать является программа Ultimate Windows Context Menu Customizer.
Созданные пункты меню могут служить ссылкой на системные папки (Компьютер, Рабочий стол), произвольные папки и файлы. Вы также можете добавлять ссылки на веб-страницы.

Скачать программу Вы можете по ссылке: Ultimate Windows Context Menu Customizer

Добавление произвольного пункта в контекстное меню:

1) Запустите программу от имени администратора.
2) Выберите расположение пункта контекстного меню из списка Context Menu Location.
3) В поле Text введите текст, который будет отображаться в контекстном меню.
4) В текстовом поле Command введите команду, которая будет выполняться при нажатии пункта контекстного меню.
Чтобы созданный Вами пункт меню открыл файл, введите путь к файлу. Вы можете нажать на кнопку ..., чтобы найти файл.
Чтобы созданный Вами пункт меню открыл папку, введите explorer, пробел и путь к папке.
Чтобы созданный Вами пункт меню открыл веб-страницу, введите имя браузера (chrome для Google Chrome, firefox для Mozilla Firefox, iexplore для Internet Explorer), пробел и адрес веб-страницы.
5) В текстовом поле Icon введите путь к иконке. Вы можете нажать на кнопку ..., чтобы найти иконку.
6) Из ниспадающего меню Position выберите местоположение пункта контекстного меню. (Top - Вверху, Middle - Посередине, Bottom - Внизу)
7) Установите флажок Extended, чтобы пункт контекстного меню появлялся только, когда Вы нажимаете клавишу Shift и щелкаете правую кнопку мыши.
8) Установите флажок Disabled, чтобы временно отключить пункт контекстного меню.
9) Нажмите кнопку Add Item и созданный Вами пункт будет добавлен в контекстное меню.

Добавление предопределенного пункта в контекстное меню:

1) Запустите программу от имени администратора.
2) Выберите расположение пункта контекстного меню из списка Context Menu Location.
3) Выберите пункт/пункты, которые необходимо добавить из списка Add Pre-Defined Items.
4) Нажмите кнопку Add Item и созданный Вами пункт будет добавлен в контекстное меню.

Изменение пункта в контекстном меню:

1) Запустите программу от имени администратора.
2) Выберите расположение пункта контекстного меню из списка Context Menu Location.
3) Выберите из списка Context Menu Items пункт, который требуется изменить и область Add/Edit Item будет заполнена.
4) Измените поля в области Add/Edit Item, как Вам нравится, и нажмите кнопку Edit Item.

Удаление пункта из контекстного меню:

1) Запустите программу от имени администратора.
2) Выберите расположение пункта контекстного меню из списка Context Menu Location.
3) Выберите из списка Context Menu Items пункт/пункты, которые Вы хотите удалить.
4) Нажмите кнопку Remove Item.

27. Добавление пункта "Диспетчер устройств" в контекстное меню Компьютер на рабочем столе.

Если у Вас на рабочем столе присутствует значок Компьютер, то Вам может пригодиться в его контекстном меню пункт Диспетчер устройств.
Для быстрого добавления данного пункта в контекстное меню потребуется программа – Ultimate Windows Context Menu Customizer

1) Запустите программу от имени администратора.
2) Выберите в списке Context Menu Location пункт Computer.
3) В поле Text введите текст: Диспетчер устройств
4) В текстовом поле Command введите команду: control hdwwiz.cpl
5) Нажмите кнопку Add Item

28. Добавление вкладки Icons в Свойства файла.

Если Вы работаете с иконками файлов, то для упращения работы Вам может понадобиться программа IconViewer.
Данная программа позволяет напрямую из Проводника узнать какие иконки содержаться внутри того или иного файла и сохранить их в виде *.ico файлов.
IconViewer добавляет дополнительную вкладку Icons в окно Свойства, вызываемое из контекстного меню, появляющегося при нажатии правой кнопки мыши.

Скачать программу Вы можете по ссылке: http://www.botproductions.com/iconview/download.html
Примечание: Скачивайте версию программы в соответствии с разрядностью Вашей операционной системы (32-бит/64-бит).

29. Добавление ярлыков программ в список "Избранное" Проводника.

Список «Избранное» в Проводнике Windows служит для доступа к часто используемым папкам, однако при желании Вы можете добавить туда и ярлыки к часто используемым программам.

1) Введите в адресной строке Проводника %userprofile%\Links или C:\Users\имя_пользователя\Links, чтобы открыть папку со ссылками.
2) Скопируйте в данную папку, ярлыки которые Вы желаете увидеть в левой колонке Проводника в списке «Избранное».

По-умолчанию ярлыки в списке расположены в алфавитном порядке, но Вы можете передвинуть любой из них прямо в списке.

Примечание: Некоторые приложения, для которых в свойствах ярлыка не задан прямой путь к исполняемому файлу, могут не запуститься таким образом. Поэтому для них необходимо создать новый ярлык, учитывая данный факт.

30. Открытие одновременно двух рядом расположенных копий Проводника.

Если Вы желаете открыть одновременно два окна Проводника расположенных рядом, то Вы можете сделать это воспользовавшись созданным мною скриптом.

1) Скачайте архив TESBS.zip и распакуйте его в любую папку (Например: C:\TESBS)
2) Щелкните правой кнопкой мыши на пустом месте в папке и выберите Создать → Ярлык
3) В поле Расположение объекта введите указанную ниже команду и нажмите кнопку Далее.

где, C:\TESBS - путь к vbs-файлу.

4) Введите имя ярлыка (Например: Два Проводника Рядом) и нажмите Готово.

Для смены значка у ярлыка.

5.1) Щелкните правой кнопкой мыши на созданном ярлыке и выберите пункт Свойства.
5.2) Нажмите кнопку Сменить значок на вкладке Ярлык.
5.3) В поле Искать значки в следующем файле введите: C:\Windows\System32\shell32.dll и нажмите Enter ↵.
5.4) Выберите желаемый значок и нажмите кнопку ОК.

Для закрепления данного ярлыка в панели задач.

6) Щелкните правой кнопкой мыши на созданном ярлыке и выберите пункт Закрепить на панели задач.

Примечание: Изменяйте значок перед закреплением ярлыка в панели задач.

31. Закрепление программы в меню Пуск или на панели задач, используя скрипт.

Если Вы желаете закрепить программу на панели задач или в меню Пуск не используя контекстного меню, то Вы можете это сделать используя vbs-скрипт.

1) Скачайте и распакуйте в любую папку архив: PinUnpinItemScript.zip
2) В зависимости от языка Вашей системы скопируйте в папку C:\Windows файл PinItem.vbs из папки Eng(для английской версии) или Rus(для русской версии).
3) Запустите командную строку (Win+R → cmd → OK)
4) Введите необходимую Вам команду, используя шаблон и нажмите Enter ↵:

Параметры:

/item:"Путь к объекту" - Путь к объекту для закрепления.
/taskbar - (параметр) Закрепить на панели задач вместо меню ""Пуск"".
/unpin - (параметр) Открепить закрепленный объект.

Примеры:

Закрепить программу Calc.exe в меню Пуск:

Открепить программу Calc.exe из меню Пуск:

Закрепить программу Calc.exe на панели задач:

Открепить программу Calc.exe с панели задач:

Примечание:

П1) Скрипт не открепляет объекты закрепленные с помощью контекстного меню, только закрепленные при помощи скрипта.
П2) Скрипт не закрепляет объекты, если закрепление запрещено групповой политикой или параметром NoPinningToTaskbar в реестре.

32. Открытие папок Проводника в новых вкладках, как в интернет браузере.

Если Вы желаете, чтобы у Вас в Проводнике появилась возможность открывать вкладки также как в интернет браузере, то скачайте для этого программу QTTabBar.

Сайты для скачивания:

http://qttabbar.wikidot.com/download - требует установки Microsoft .Net Framework 4.0, включения вручную панелей QTTabBar, QT Button Bar и множества дополнительных настроек.
http://qttabbar.sourceforge.net/ - не требует установки Microsoft .Net Framework 4.0

Далее в совете описывается версия не требующая установки Microsoft .Net Framework 4.0.

1) Чтобы подключить русский языковой файл:

1.1) Зайдите на сайт http://sourceforge.net/projects/qttabbar/files/Language%20Files/
1.2) Скачайте файл Lng_QTTabBar_Russian.xml.
1.3) Скопируйте его в папку C:\Program Files\QTTabBar (для 64-битной Windows в папку C:\Program Files (x86)\QTTabBar)
1.4) Щелкните на свободном месте на панель вкладок QTTabBar и выберите пункт Options.
1.5) Перейдите на вкладку General
1.6) В поле Language file укажите путь к Вашему файлу Lng_QTTabBar_Russian.xml и нажмите кнопку ОК.
1.7) Перезапустите Проводник.

2) Чтобы открыть необходимую Вам папку в новой вкладке, щелкните по ней средней кнопкой мыши или перетащите ее на панель вкладок QTTabBar.

При щелчке на значок рядом с названием вкладки отобразится содержимое папки.

Для быстрого перехода между вкладками Вы можете использовать комбинацию клавиш Ctrl + Tab ↹.

3) Чтобы закрыть вкладку, щелкните по ней правой кнопкой мыши и выберите пункт Закрыть или нажмите на кнопку с крестиком на панели QTTab Standard Buttons.

4) Чтобы открытые Вами вкладки запомнились после закрытия Проводника и отобразились при повторном его открытии:

4.1) Щелкните на свободном месте на панель вкладок QTTabBar и выберите пункт Настройки.
4.2) Перейдите на вкладку Окно
4.3) Установите флажок Восстановить вкладки и нажмите кнопку ОК.

33. Создание ярлыка для быстрого доступа к настройкам Визуальные эффекты.

Если Вам бывает необходимо освобождать ресурсы компьютера, путем отключения визуальных эффектов, для работы с ресурсоемкими приложениями, то Вы можете создать значок для быстрого доступа к данным настройкам.

Для создания данного ярлыка, выполните указанные ниже действия.

1) Щелкните правой кнопкой мыши по свободному пространству рабочего стола.
2) Выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите:

4) Нажмите кнопку Далее и укажите название ярлыка (Визуальные эффекты), после чего нажмите на кнопку Готово.

5) Чтобы заменить иконку на более подходящую:
5.1) Нажмите правой кнопкой мыши на созданном Вами ярлыке и выберите пункт Свойства.
5.2) В открывшемся окне нажмите кнопку Сменить значок.
5.3) Выберите необходимую Вам иконку для отображения и нажмите кнопку ОК.

34. Сохранение часто используемых условий поиска в Проводнике.

Если Вы часто используете одинаковые значения в поле поиска (например, периодически ищите файлы pdf на компьютере), то Вам пригодится указанное ниже решение, позволяющее сохранить условия для поиска.

1) Щелкните на пустом месте панели задач и нажмите клавишу F3
2) Введите в текстовом поле желаемое значение для поиска.
3) В разделе Повторить поиск в: укажите желаемую область поиска.
4) Нажмите правой кнопкой мыши в свободной области с результатами поиска и выберите в меню Вид - способ представления результатов.
5) Нажмите правой кнопкой мыши в свободной области с результатами поиска и выберите в меню Сортировать - по какой колонке упорядочить результаты и в каком порядке (по возрастанию; по убыванию).
6) Нажмите правой кнопкой мыши в свободной области с результатами поиска и выберите пункт Сохранить условия поиска.
7) Укажите папку, где необходимо сохранить файл с условиями поиска и с каким именем и нажмите кнопку Сохранить.

Когда Вам понадобится найти файлы или папки с сохраненными условиями поиска, то откройте папку куда Вы сохранили файл с условиями поиска и нажмите на него.

Для информации:

Данный файл сохраняет только условия поиска, а не его результ.
Если Вы добавите в систему новые файлы, подходящие под условия поиска, то они также будут включены в результат.

35. Автоматическое закрытие окна команд сразу после запуска программы с помощью CMD-файла.

Обычно, если Вы запускаете программу используя CMD-файл, то окно команд не закрывается до окончания работы программы.
Чтобы Ваше окно команд закрылось сразу после запуска программы, добавьте перед Вашим файлом для запуска программы, команду start с двумя двойными кавычками.

Пример:

С включенным режимом вывода команд на экран:

С выключенным режимом вывода команд на экран:

36. Установка клавиши Backspace в Проводнике для перехода в папку, расположенную на уровень выше.

В предыдущих версиях Windows, клавиша ⟵ Backspace использовалась для перехода в папку, расположенную на один уровень вверх.
В последствии, данное действие для этой клавиши осталось только в диалоговых окнах "Открыть", "Сохранить как".
Клавиша ⟵ Backspace в Проводнике стала выполнять функцию перехода обратно по истории просмотренных папок.
А для перехода в папку, расположенную на уровень выше, стало использоваться сочетание клавиш Alt + ↑ .
Чтобы установить клавишу ⟵ Backspace в качестве клавиши, выполняющей функцию перехода в папку, расположенную на один уровень вверх воспользуйтесь предложенным ниже решением.

Для единоразового использования данной программы:

1) Скачайте и распакуйте в любую папку архив с программой: HTGBack.zip
2) Запустите файл HTGBack.exe.

Для постоянного использования данной программы:

1) Скачайте и распакуйте в любую папку архив с программой: HTGBack.zip
2) Скопируйте файл HTGBack.exe в папку C:\Windows.
3) Создайте и примените reg-файл указанного ниже содержания.

37. Запуск командных файлов (.bat, .cmd) без отображения окна команд.
Чтобы запустить командный файл (.bat, .cmd) без отображения окна команд воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1. Используя vbs-скрипт с указыванием в нем запускаемого командного файла.

1) Создайте специальный скрипт.

1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).

Вместо name.bat - укажите имя Вашего командного файла и путь к нему, если Вы планируете использовать скрипт из другой папки.
Для запуска нескольких командных файлов, повторите данную строку заменив name.bat на другое значение.

1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "HideBatCmdStart.vbs")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Запустите vbs-скрипт и Ваш командный файл запуститься без открытия окна команд.

Вариант 2. Используя единый vbs-скрипт для всех командных файлов.

1) Создайте специальный скрипт.

1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "HideAllStart.vbs")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
2) Скопируйте данный vbs-файл в папку C:\Windows\System32

Для запуска Вашего командного файла Вы можете воспользоваться диалоговым окном Выполнить (Win   + R) или добавить его запуск в папку автозапуска реестра (HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run) используя следующую команду:

Вместо name.bat - укажите имя Вашего командного файла и путь к нему.

Например, для запуска с рабочего стола выполните следующую команду:

Вариант 3. Используя программу стороннего производителя.

1) В соответствии с разрядностью Вашей системы скачайте программу NirCmd: 32-бит или 64-бит
2) Распакуйте архив и скопируйте программу nircmd.exe в папку С:\Windows\System32.

Для запуска Вашего командного файла Вы можете воспользоваться диалоговым окном Выполнить (Win   + R) или добавить его запуск в папку автозапуска реестра (HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run) используя следующую команду:

Вместо name.bat - укажите имя Вашего командного файла и путь к нему.

38. Одновременное переименование большого количества файлов и папок.

Очень часто бывает необходимо переименовать группу файлов или папок по какому-то общему шаблону, а стандартных возможностей Проводника может оказаться недостаточно.
В таких случаях приходится использовать дополнительные программы.
Программ для одновременного переименования большого количества файлов существует очень много, но одной из самых удобных из них является Rename Master.
Используя данную программу, Вы сможете легко и быстро упорядочить коллекции документов, музыки, видеоматериалов и изображений, состоящие из множества по-разному названных файлов и папок.
Кроме стандартных функций (таких как добавление символов в любую часть имени файла, замена текста, смена заглавных букв на строчные и др.) программа позволяет извлекать информацию из свойств файла или из мета-тэгов (в файлах MP3, JPG, JPEG и TIFF).

Чтобы переименовать необходимую Вам группу файлов и/или папок:

1) Скачайте и распакуйте в любую папку архив с программой.
2) Запустите программу.
3) Используя адресную строку идентичную строке Проводника перейдите в папку, где располагаются файлы для переименования.
4) Выберите необходимый Вам способ отображения данных в папке: Files(Файлы), Folders(Папки), Files&Folders(Файлы и Папки).
5) Перейдите на нужную вкладку и отметьте нужную опцию.
6) Задайте условия для переименовывания и нажмите кнопку Rename на первой вкладке.

Наиболее часто ипользуемые условия.

Вкладка Renaming Script:

[01] Remove Words/Numbers - Удаляет фразу или число из имени/расширения файла/папки.
[02] Remove Beginning/Ending - Удаляет определенное количество символов от начала/конца из имени/расширения файла/папки. При установке флажка Replace with заменяет указанным значением.
[03] Remove by Position - Удаляет/оставляет определенное количество символов от и до указанного расположения.
[04] Remove Before/After - Удаляет все до/после заданной фразы. При установке флажка Replace with заменяет указанным значением.
[05] Remove/Replace Expression - Удаляет/заменяет в имени файла фразу начинающуюся/заканчивающуюся с определенного символа/фразы.
[07] Replace/Find and Replace - Находит и заменяет имя/расширение целиком или фразу в имени/расширении на указанное значение.
[09] Select and Move - Перемещает текст до или после указанной фразы, конкретно заданный текст или текст с такого-то по такой-то символ в указанное место в имени файла/папки.
[12] Add to Beginning/Ending - Добавляет указанную фразу в начало/конец имени/расширения файла/папки.
[13] Add by Position - Добавляет указанную фразу в имя/расширение расположенную в определенной позиции относительно начала/конца файла.
[14] Add Before/After - Добавляет указанную фразу в имя/расширение расположенную до/после заданной фразы.
[15] Add Counter - Добавляет порядковый номер в начало/конец имени файла/папки.

Вкладка Case & Wildcards:

Установите флажок Change Case для включения условий переименования.
Установите флажок Preserve Extension для исключения расширения файла из условий переименования.
Установите флажок Detect and capitalize Roman Numerals для преобразования римских цифр из строчных букв в заглавные.

Значения переключателя:

UPPERCASE - Заменяет все бувы на заглавные.
lowercase - Заменяет все бувы на прописные.
Capitalize Words - Заменяет первую букву каждого слова на заглавную, а остальные буквы на строчные.
Capitalize sentence - Заменяет первую букву первого слова на заглавную, а остальные буквы на строчные.
Capitalize with Title Case - Заменяет первую букву каждого слова, не являющегося словом/символом связкой (предлоги, апострофы), на заглавную, а остальные буквы на строчные.

39. Активация функции прокрутки у неактивного окна или не выбранной части активного окна.

По умолчанию в Windows прокрутка привязана к активному окну или выбранной его части, не зависимо от того, где находится сам курсор мыши.
И если Вам понадобиться прокрутить неактивное окно или другую область активного окна, то для этого Вам необходимо будет на него переключиться.

Существует программа Tordex Wheel, которая позволяет убрать данный недостаток Windows.
При ее использовании Вы сможете прокрутить любую часть как активного, так и неактивного окна всего лишь наведя на нее курсор мыши.
После запуска программы в трее появиться ее значок, нажав на который Вы сможете добавить данную программу в автозагрузку.
Для этого Вам необходимо будет щелкнуть правой кнопкой мыши на значок программы и выбрать пункт Run on Startup.

Скачать: http://www.tordex.com/wheel/index.html


Настройки.

1. Конфигурация служб Windows 7 по умолчанию, способы их запуска и отключения.

Если Вы желаете изменить или восстановить значения служб установленных в системе по умолчанию, то Вы можете воспользоваться указанными ниже таблицами, для внесения изменений вручную. (Подробное описание действий находится под таблицами).

Для быстрого восстановления значений всех служб по умолчанию, выполните действия предложенные в одном из указанных ниже вариантов:

Вариант 1.

1) Зайдите на сайт http://technet.microsoft.com/ru-ru/sysinternals/bb897553
2) Скачайте комплект программ PsTools и распакуйте в любую папку.
3) Скопируйте файл PsExec.exe в папку C:\Windows\System32
4) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
5) Введите указанную ниже команду и нажмите Enter ↵:

При первом запуске PsExec надо будет нажать кнопку Agree. При последующих запусках данный запрос выводится не будет.
6) Скачайте архив ServiceDefaultRegistryEntries.zip, содержащий набор reg-файлов для восстановления значений служб по умолчанию и распакуйте в любую папку.
7) В редакторе реестра нажмите Файл → Импорт
В случае появления окна Location is not available (Расположение не доступно) нажмите в нем кнопку ОК.
8) Выберите reg-файл соответствующий редакции и разрядности Вашей Windows и нажмите кнопку ОК.

В безопасном режиме и в обычном режиме загружаются разные службы, поэтому в архиве ServiceDefaultRegistryEntries.zip содержаться две папки с подпапками.
В папке Default находятся reg-файлы для восстановления значения служб по умолчанию в обычном режиме.
В папке SafeMode находятся reg-файлы для восстановления значения служб по умолчанию в безопасном режиме.

9) Перезагрузите компьютер.

Вариант 2.

1) Скачайте архив ServiceDefaultRegistryEntries.zip и распакуйте в любую папку.
2) Перезапустите компьютер
3) До начала запуска Windows нажмите на клавишу F8.
Если клавиша F8 используется материнской платой, то выберите диск на котором у Вас установлена Windows, нажмите Enter ↵, а затем сразу же F8.
4) В появившемся списке вариантов загрузки Дополнительные варианты загрузки (Advanced Boot Options) выберите пункт Устранение неполадок компьютера (Repair Your Computer) и нажмите Enter ↵.
5) Выберите метод ввода с клавиатуры (keyboard input method) - США (US) и нажмите Next (Далее)
6) В списке инструментов выберите командную строку - Командная строка (Command Prompt).
7) Введите команду regedit и нажмите кнопку Enter ↵.
8) В редакторе реестра нажмите Файл → Импорт
9) Выберите reg-файл соответствующий редакции и разрядности Вашей Windows и нажмите кнопку Открыть (Open).

В безопасном режиме и в обычном режиме загружаются разные службы, поэтому в архиве ServiceDefaultRegistryEntries.zip содержаться две папки с подпапками.
В папке Default находятся reg-файлы для восстановления значения служб по умолчанию в обычном режиме.
В папке SafeMode находятся reg-файлы для восстановления значения служб по умолчанию в безопасном режиме.

10) Закройте окна реестра и командной строки и нажмите кнопку Перезагрузка (Restart).

Таблица 1. Общие сведения о службах.

Отображаемое имя (русское) | Отображаемое имя (английское) | Имя службы | Исполняемый файл | Вход от имени
BranchCache | BranchCache | PeerDistSvc | C:\Windows\System32\svchost.exe -k PeerDist | Сетевая служба
DHCP-клиент | DHCP Client | Dhcp | C:\Windows\system32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
DNS-клиент | DNS Client | Dnscache | C:\Windows\system32\svchost.exe -k NetworkService | Сетевая служба
KtmRm для координатора распределенных транзакций | KtmRm for Distributed Transaction Coordinator | KtmRm | C:\Windows\System32\svchost.exe -k NetworkServiceAndNoImpersonation | Сетевая служба
Microsoft .NET Framework NGEN v2.0.50727_X64 Microsoft .NET Framework NGEN v2.0.50727_X86 | Microsoft .NET Framework NGEN v2.0.50727_X64 Microsoft .NET Framework NGEN v2.0.50727_X86 | clr_optimization_v2.0.50727_64 clr_optimization_v2.0.50727_32 | C:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorsvw.exe C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorsvw.exe | Локальная cистема
Microsoft .NET Framework NGEN v4.0.30319_X64 Microsoft .NET Framework NGEN v4.0.30319_X86 | Microsoft .NET Framework NGEN v4.0.30319_X64 Microsoft .NET Framework NGEN v4.0.30319_X86 | clr_optimization_v4.0.30319_64 clr_optimization_v4.0.30319_32 | C:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscorsvw.exe C:\Windows\Microsoft.NET\Framework\v4.0.30319\mscorsvw.exe | Локальная cистема
Parental Controls | Parental Controls | WPCSvc | C:\Windows\system32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Plug-and-Play | Plug and Play | PlugPlay | C:\Windows\system32\svchost.exe -k DcomLaunch | Локальная система
Quality Windows Audio Video Experience | Quality Windows Audio Video Experience | QWAVE | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Superfetch | Superfetch | SysMain | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Telnet | Telnet | TlntSvr | C:\Windows\System32\tlntsvr.exe | Локальная служба
Windows Audio | Windows Audio | AudioSrv | C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Windows CardSpace | Windows CardSpace | idsvc | "C:\Windows\Microsoft.NET\Framework64\v3.0\Windows Communication Foundation\infocard.exe" | Локальная система
Windows Driver Foundation – User-mode Driver Framework | Windows Driver Foundation - User-mode Driver Framework | wudfsvc | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Windows Search | Windows Search | WSearch | C:\Windows\system32\SearchIndexer.exe /Embedding | Локальная система
WMI Performance Adapter | WMI Performance Adapter | wmiApSrv | C:\Windows\system32\wbem\WmiApSrv.exe | Локальная система
Автонастройка WWAN | WWAN AutoConfig | WwanSvc | C:\Windows\system32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Автономные файлы | Offline Files | CscService | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Агент защиты сетевого доступа | Network Access Protection Agent | napagent | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Агент политики IPsec | IPsec Policy Agent | PolicyAgent | C:\Windows\system32\svchost.exe -k NetworkServiceNetworkRestricted | Сетевая служба
Адаптер прослушивателя Net.Msmq | Net.Msmq Listener Adapter | NetMsmqActivator | "C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe" -NetMsmqActivator | Сетевая служба
Адаптер прослушивателя Net.Pipe | Net.Pipe Listener Adapter | NetPipeActivator | "C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe" | Локальная служба
Адаптер прослушивателя Net.Tcp | Net.Tcp Listener Adapter | NetTcpActivator | "C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe" | Локальная служба
Адаптивная регулировка яркости | Adaptive Brightness | SensrSvc | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Архивация Windows | Windows Backup | SDRSVC | C:\Windows\system32\svchost.exe -k SDRSVC | Локальная система
Биометрическая служба Windows | Windows Biometric | WbioSrvc | C:\Windows\system32\svchost.exe -k WbioSvcGroup | Локальная система
Брандмауэр Windows | Windows Firewall | MpsSvc | C:\Windows\system32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Браузер компьютеров | Computer Browser | Browser | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Веб-клиент | WebClient | WebClient | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Виртуальный диск | Virtual Disk | vds | C:\Windows\System32\vds.exe | Локальная система
Вспомогательная служба IP | IP Helper | iphlpsvc | C:\Windows\System32\svchost.exe -k NetSvcs | Локальная система
Вторичный вход в систему | Secondary Logon | seclogon | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Группировка сетевых участников | Peer Networking Grouping | p2psvc | C:\Windows\System32\svchost.exe -k LocalServicePeerNet | Локальная служба
Дефрагментация диска | Disk Defragmenter | defragsvc | C:\Windows\system32\svchost.exe -k defragsvc | Локальная система
Диспетчер автоматических подключений удаленного доступа | Remote Access Auto Connection Manager | RasAuto | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Диспетчер печати | Print Spooler | Spooler | C:\Windows\System32\spoolsv.exe | Локальная система
Диспетчер подключений удаленного доступа | Remote Access Connection Manager | RasMan | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Диспетчер сеансов диспетчера окон рабочего стола | Desktop Window Manager Session Manager | UxSms | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Диспетчер удостоверения сетевых участников | Peer Networking Identity Manager | p2pimsvc | C:\Windows\System32\svchost.exe -k LocalServicePeerNet | Локальная служба
Диспетчер учетных данных | Credential Manager | VaultSvc | C:\Windows\system32\lsass.exe | Локальная система
Диспетчер учетных записей безопасности | Security Accounts Manager | SamSs | C:\Windows\system32\lsass.exe | Локальная система
Доступ к HID-устройствам | Human Interface Device Access | hidserv | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Журнал событий Windows | Windows Event Log | eventlog | C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Журналы и оповещения производительности | Performance Logs & Alerts | pla | C:\Windows\System32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Защита программного обеспечения | Software Protection | sppsvc | C:\Windows\system32\sppsvc.exe | Сетевая служба
Защитник Windows | Windows Defender | WinDefend | C:\Windows\System32\svchost.exe -k secsvcs | Локальная система
Защищенное хранилище | Protected Storage | ProtectedStorage | C:\Windows\system32\lsass.exe | Локальная система
Изоляция ключей CNG | CNG Key Isolation | KeyIso | C:\Windows\system32\lsass.exe | Локальная система
Инструментарий управления Windows | Windows Management Instrumentation | Winmgmt | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Информация о совместимости приложений | Application Experience | AeLookupSvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Клиент групповой политики | Group Policy Client | gpsvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Клиент для NFS | Client for NFS | NfsClnt | C:\Windows\system32\nfsclnt.exe | Сетевая служба
Клиент отслеживания изменившихся связей | Distributed Link Tracking Client | TrkWks | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Координатор распределенных транзакций | Distributed Transaction Coordinator | MSDTC | C:\Windows\System32\msdtc.exe | Сетевая служба
Кэш шрифтов Windows Presentation Foundation 3.0.0.0 | Windows Presentation Foundation Font Cache 3.0.0.0 | FontCache3.0.0.0 | C:\Windows\Microsoft.Net\Framework64\v3.0\WPF\PresentationFontCache.exe | Локальная служба
Ловушка SNMP | SNMP Trap | SNMPTRAP | C:\Windows\System32\snmptrap.exe | Локальная служба
Локатор удаленного вызова процедур (RPC) | Remote Procedure Call (RPC) Locator | RpcLocator | C:\Windows\system32\locator.exe | Сетевая служба
Маршрутизация и удаленный доступ | Routing and Remote Access | RemoteAccess | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Модули ключей IPsec для обмена ключами в Интернете и протокола IP с проверкой подлинности | IKE and AuthIP IPsec Keying Modules | IKEEXT | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Модуль запуска процессов DCOM-сервера | DCOM Server Process Launcher | DcomLaunch | C:\Windows\system32\svchost.exe -k DcomLaunch | Локальная система
Модуль поддержки NetBIOS через TCP/IP | TCP/IP NetBIOS Helper | lmhosts | C:\Windows\system32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Настройка сервера удаленных рабочих столов | Remote Desktop Configuration | SessionEnv | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Немедленные подключения Windows – регистратор настройки | Windows Connect Now - Config Registrar | wcncsvc | C:\Windows\System32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Обнаружение SSDP | SSDP Discovery | SSDPSRV | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Обнаружение интерактивных служб | Interactive Services Detection | UI0Detect | C:\Windows\system32\UI0Detect.exe | Локальная система
Общий доступ к подключению к Интернету (ICS) | Internet Connection Sharing (ICS) | SharedAccess | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Определение оборудования оболочки | Shell Hardware Detection | ShellHWDetection | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Основные службы доверенного платформенного модуля | TPM Base Services | TBS | C:\Windows\System32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Очередь сообщений | Message Queuing | MSMQ | C:\Windows\system32\mqsvc.exe | Сетевая служба
Перенаправитель портов пользовательского режима служб удаленных рабочих столов | Remote Desktop Services UserMode Port Redirector | UmRdpService | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Перечислитель IP-шин PnP-X | PnP-X IP Bus Enumerator | IPBusEnum | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Питание | Power | Power | C:\Windows\system32\svchost.exe -k DcomLaunch | Локальная система
Планировщик заданий | Task Scheduler | Schedule | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Планировщик классов мультимедиа | Multimedia Class Scheduler | MMCSS | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Поддержка элемента панели управления "Отчеты о проблемах и их решениях" | Problem Reports and Solutions Control Panel Support | wercplsupport | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Политика удаления смарт-карт | Smart Card Removal Policy | SCPolicySvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Поставщик домашней группы | HomeGroup Provider | HomeGroupProvider | C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Проводная автонастройка | Wired AutoConfig | dot3svc | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Программный поставщик теневого копирования (Microsoft) | Microsoft Software Shadow Copy Provider | swprv | C:\Windows\System32\svchost.exe -k swprv | Локальная система
Прослушиватель RIP | RIP Listener | iprip | C:\Windows\System32\svchost.exe -k ipripsvc | Локальная служба
Прослушиватель домашней группы | HomeGroup Listener | HomeGroupListener | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Простые службы TCP/IP | Simple TCP/IP Services | simptcp | C:\Windows\System32\tcpsvcs.exe | Локальная служба
Протокол PNRP | Peer Name Resolution Protocol | PNRPsvc | C:\Windows\System32\svchost.exe -k LocalServicePeerNet | Локальная служба
Публикация ресурсов обнаружения функции | Function Discovery Resource Publication | FDResPub | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Рабочая станция | Workstation | LanmanWorkstation | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Распространение сертификата | Certificate Propagation | CertPropSvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Расширяемый протокол проверки подлинности (EAP) | Extensible Authentication Protocol | EapHost | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Сборщик событий Windows | Windows Event Collector | Wecsvc | C:\Windows\system32\svchost.exe -k NetworkService | Сетевая служба
Сведения о приложении | Application Information | Appinfo | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Сервер | Server | LanmanServer | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Сервер упорядочения потоков | Thread Ordering Server | THREADORDER | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Сетевой вход в систему | Netlogon | Netlogon | C:\Windows\system32\lsass.exe | Локальная система
Сетевые подключения | Network Connections | Netman | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Система событий COM+ | COM+ Event System | EventSystem | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Системное приложение COM+ | COM+ System Application | COMSysApp | C:\Windows\system32\dllhost.exe /Processid:{02D4B3F1-FD88-11D1-960D-00805FC79235} | Локальная система
Служба FTP (Майкрософт) | Microsoft FTP Service | FTPSVC | C:\Windows\system32\svchost.exe -k ftpsvc | Локальная система
Служба IIS Admin | IIS Admin Service | IISADMIN | C:\Windows\system32\inetsrv\inetinfo.exe | Локальная система
Служба LPD | LPD Service | LPDSVC | C:\Windows\System32\svchost.exe -k LPDService | Локальная система
Служба SNMP | SNMP Service | SNMP | C:\Windows\System32\snmp.exe | Локальная система
Служба SSTP | Secure Socket Tunneling Protocol Service | SstpSvc | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба автоматического обнаружения веб-прокси WinHTTP | WinHTTP Web Proxy Auto-Discovery Service | WinHttpAutoProxySvc | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба автонастройки WLAN | WLAN AutoConfig | Wlansvc | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба активации Windows | Windows Process Activation Service | WAS | C:\Windows\system32\svchost.exe -k iissvcs | Локальная система
Служба базовой фильтрации | Base Filtering Engine | BFE | C:\Windows\system32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Служба ввода планшетного ПК | Tablet PC Input Service | TabletInputService | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба веб-публикаций | World Wide Web Publishing Service | W3SVC | C:\Windows\system32\svchost.exe -k iissvcs | Локальная система
Служба времени Windows | Windows Time | W32Time | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба загрузки изображений Windows (WIA) | Windows Image Acquisition (WIA) | StiSvc | C:\Windows\system32\svchost.exe -k imgsvc | Локальная служба
Служба индексирования | Indexing Service | CISVC | C:\Windows\system32\CISVC.EXE | Локальная служба
Служба инициатора Майкрософт iSCSI | Microsoft iSCSI Initiator Service | MSiSCSI | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Служба интерфейса сохранения сети | Network Store Interface Service | nsi | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба кэша шрифтов Windows | Windows Font Cache Service | FontCache | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Служба медиаприставки Media Center | Media Center Extender Service | Mcx2Svc | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Служба модуля архивации на уровне блоков | Block Level Backup Engine Service | wbengine | C:\Windows\system32\wbengine.exe | Локальная система
Служба общего доступа к портам Net.Tcp | Net.Tcp Port Sharing Service | NetTcpPortSharing | "C:\Windows\Microsoft.NET\Framework64\v3.0\Windows Communication Foundation\SMSvcHost.exe" | Локальная служба
Служба общих сетевых ресурсов проигрывателя Windows Media | Windows Media Player Network Sharing Service | WMPNetworkSvc | "C:\Program Files\Windows Media Player\wmpnetwk.exe" | Сетевая служба
Служба перечислителя переносных устройств | Portable Device Enumerator Service | WPDBusEnum | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба планировщика Windows Media Center | Windows Media Center Scheduler Service | ehSched | C:\Windows\ehome\ehsched.exe | Сетевая служба
Служба поддержки Bluetooth | Bluetooth Support Service | bthserv | C:\Windows\system32\svchost.exe -k bthsvcs | Локальная служба
Служба поддержки узла приложений | Application Host Helper Service | AppHostSvc | C:\Windows\system32\svchost.exe -k apphost | Локальная служба
Служба политики диагностики | Diagnostic Policy Service | DPS | C:\Windows\System32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Служба помощника по совместимости программ | Program Compatibility Assistant Service | PcaSvc | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба профилей пользователей | User Profile Service | ProfSvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Служба публикации имен компьютеров PNRP | PNRP Machine Name Publication Service | PNRPAutoReg | C:\Windows\System32\svchost.exe -k LocalServicePeerNet | Локальная служба
Служба регистрации ошибок Windows | Windows Error Reporting Service | WerSvc | C:\Windows\System32\svchost.exe -k WerSvcGroup | Локальная система
Служба ресивера Windows Media Center | Windows Media Center Receiver Service | ehRecvr | C:\Windows\ehome\ehRecvr.exe | Сетевая служба
Служба сведений о подключенных сетях | Network Location Awareness | NlaSvc | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Служба состояния ASP.NET | ASP.NET State Service | aspnet_state | C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_state.exe | Сетевая служба
Служба списка сетей | Network List Service | netprofm | C:\Windows\System32\svchost.exe -k LocalService | Локальная служба
Служба технологий активации Windows | Windows Activation Technologies Service | WatAdminSvc | C:\Windows\system32\Wat\WatAdminSvc.exe | Локальная система
Служба уведомления SPP | SPP Notification Service | sppuinotify | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба уведомления о системных событиях | System Event Notification Service | SENS | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Служба удаленного управления Windows (WS-Management) | Windows Remote Management (WS-Management) | WinRM | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Служба управления сетью | Web Management Service | WMSvc | C:\Windows\system32\inetsrv\wmsvc.exe | Локальная служба
Служба хранилища | Storage Service | StorSvc | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба шифрования дисков BitLocker | BitLocker Drive Encryption Service | BDESVC | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Служба шлюза уровня приложения | Application Layer Gateway Service | ALG | C:\Windows\System32\alg.exe | Локальная служба
Службы криптографии | Cryptographic Services | CryptSvc | C:\Windows\system32\svchost.exe -k NetworkService | Сетевая служба
Службы удаленных рабочих столов | Remote Desktop Services | TermService | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Смарт-карта | Smart Card | SCardSvr | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Сопоставитель конечных точек RPC | RPC Endpoint Mapper | RpcEptMapper | C:\Windows\system32\svchost.exe -k RPCSS | Сетевая служба
Средство построения конечных точек Windows Audio | Windows Audio Endpoint Builder | AudioEndpointBuilder | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Телефония | Telephony | TapiSrv | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Темы | Themes | Themes | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Теневое копирование тома | Volume Shadow Copy | VSS | C:\Windows\system32\vssvc.exe | Локальная система
Тополог канального уровня | Link-Layer Topology Discovery Mapper | lltdsvc | C:\Windows\System32\svchost.exe -k LocalService | Локальная служба
Триггеры очереди сообщений | Message Queuing Triggers | MSMQTriggers | C:\Windows\system32\mqtgsvc.exe | Сетевая служба
Удаленный вызов процедур (RPC) | Remote Procedure Call (RPC) | RpcSs | C:\Windows\system32\svchost.exe -k rpcss | Сетевая служба
Удаленный реестр | Remote Registry | RemoteRegistry | C:\Windows\system32\svchost.exe -k regsvc | Локальная служба
Удостоверение приложения | Application Identity | AppIDSvc | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Узел системы диагностики | Diagnostic System Host | WdiSystemHost | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Узел службы диагностики | Diagnostic Service Host | WdiServiceHost | C:\Windows\System32\svchost.exe -k LocalService | Локальная служба
Узел универсальных PNP-устройств | UPnP Device Host | upnphost | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Управление приложениями | Application Management | AppMgmt | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Управление сертификатами и ключом работоспособности | Health Key and Certificate Management | hkmsvc | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Установщик ActiveX (AxInstSV) | ActiveX Installer (AxInstSV) | AxInstSV | C:\Windows\system32\svchost.exe -k AxInstSVGroup | Локальная система
Установщик Windows | Windows Installer | msiserver | C:\Windows\system32\msiexec.exe /V | Локальная система
Установщик модулей Windows | Windows Modules Installer | TrustedInstaller | C:\Windows\servicing\TrustedInstaller.exe | Локальная система
Факс | Fax | Fax | C:\Windows\system32\fxssvc.exe | Сетевая служба
Фоновая интеллектуальная служба передачи (BITS) | Background Intelligent Transfer Service | BITS | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Хост библиотеки счетчика производительности | Performance Counter DLL Host | PerfHost | C:\Windows\SysWow64\perfhost.exe | Локальная служба
Хост поставщика функции обнаружения | Function Discovery Provider Host | fdPHost | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Цветовая система Windows (WCS) | Windows Color System | WcsPlugInService | C:\Windows\system32\svchost.exe -k wcssvc | Локальная служба
Центр обеспечения безопасности | Security Center | wscsvc | C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Центр обновления Windows | Windows Update | wuauserv | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Шифрованная файловая система (EFS) | Encrypting File System (EFS) | EFS | C:\Windows\System32\lsass.exe | Локальная система
Отображаемое имя (русское) | Отображаемое имя (английское) | Имя службы | Исполняемый файл | Вход от имени

Таблица 2. Настройка для служб значений параметра "Тип запуска" в соответствии с редакцией Windows.

Указанные в шапке названия версий Windows, описывают стандартные конфигурации служб по умолчанию в соответствующих редакциях Windows 7.

"Безопасная" - это конфигурация, которую могут использовать 95% из пользователей с небольшими или без побочных эффектов.
Она также сводит к минимуму количество «ошибок» отображаемых в оснастке «Просмотр событий».
Данная конфигурация не гарантирует стопроцентной работы у Вас, но если Вы желаете попробовать изменить настройки служб, то это именно то с чего Вам возможно следовало бы начать.
20 параметров служб было изменено от установленного по умолчанию. Внесенные изменения помечены (*) звездочкой.

"Настроенная" - это конфигурация, позволяющая сократить количество запущенных служб, сохраняя при этом безопасность системы.
Данная конфигурация не гарантирует стопроцентной работы у Вас.
61 параметр служб было изменен от установленного по умолчанию. Внесенные изменения помечены (*) звездочкой.
Данная конфигурация позволяет системе, по-прежнему выполнять многие сетевые функции, такие как: общий доступ к файлам и принтерам, доступ к домашней группе, использование беспроводных сетей (ноутбук), а также оставляет активными несколько "возможностей" связанных с безопасностью: Защитник Windows, Брандмауэр Windows и Центр обновлений Windows.
Эта конфигурация не подходит для пользователей использующих Windows Media Center.

"Минимум" - ВНИМАНИЕ, данная конфигурация отключает многие встроенные функции для Windows 7, а также нескольких возможностей обеспечивающих безопасность. Применять ее могут лишь опытные пользователи.
86 параметров служб было изменено от установленного по умолчанию. Внесенные изменения помечены (*) звездочкой.
Данная конфигурация не подходит для системы, которая непосредственно связана с Интернет, так как Защитник Windows, Брандмауэр Windows и Центр обновлений Windows отключены!
Данная конфигурация не подходит для ноутбука, в связи с тем, что беспроводные сети (также как и Защитник и Брандмауэр) отключены, и не смогут сдержать атаку во время роуминга в случайных беспроводных подключениях за пределами дома.
Такая конфигурация не для системы, где внутренние сетевые атаки являются проблемой. Например: Многофункциональный компьютер с несколькими членами семьи и неопытными пользователями.
Это не для системы, которая обеспечивает сетевые ресурсы, такие как принтеры, Media Center, и библиотеки WMP для других компьютеров, подключенных к локальной сети. Используйте данную конфигурацию на свой собственный риск.
Она приведена здесь в качестве минимальной конфигурации служб для Вашей системы, к которой Вам следует добавлять необходимые для работы службы.

Данные конфигурации

Автоматически - службы в этом состоянии, будут запускаться при загрузке. Некоторые службы, когда больше не будут обходимы, также автоматически остановятся. Если Вы обнаружите службу, которая Вам не требуется, то установите для нее тип запуска в положение Вручную или Отключена.
Автоматически (отложенный запуск) - службы в этом состоянии, будут запущены только после загрузки. Некоторые службы, когда больше не будут обходимы, также автоматически остановятся. Если Вы обнаружите службу, которая Вам не требуется, то установите для нее тип запуска в положение Вручную или Отключена.
Вручную - ручной режим позволяет запускать службы Windows в случае необходимости. Однако, очень немногие службы, когда потребуется будут запущены в ручном режиме. Если Вы предполагаете, что Вам для работы требуется определенная служба, то установите для нее тип запуска в положение Автоматически.
Отключена - эта настройка остановит запуск службы, даже если ее запуск необходим. В оснастке "Просмотр событий" будут показаны жалобы на этот факт. Некоторые службы, пока будут отключены, будут постоянно жаловаться. Однако о данной ситуации можно позаботиться установив тип запуска для службы в положение Вручную.
Запущена - служба при любом установленном значении: Вручную или Автоматически, работает по умолчанию или запускается сразу после загрузки.
Не установлена - данная служба не установлена по умолчанию, для ее установки используйте элемент Компоненты Windows (Панель управления\Все элементы панели управления\Программы и компоненты → Включение или отключение компонентов Windows)
Не доступна - служба не применяется в конкретной версии Windows.
Удалена - данная служба удалена при помощи окна Компоненты Windows (Панель управления\Все элементы панели управления\Программы и компоненты → Включение или отключение компонентов Windows)

По умолчанию в таблице отключено отображение конфигурации для "Windows 7 Начальная", а также для специально настроенных конфигураций: "Безопасная", "Оптимизированная", "Минимум".
Чтобы включить/отключить столбец с нужной конфигурацией Вам необходимо воспользоваться кнопкой "Показать / Скрыть столбцы" в верхнем левом углу таблицы.
Данная кнопка позволяет отобразить или спрятать указанные Вами столбцы.
Для осуществления данных действий установите или снимите флажок напротив названия столбца.
Для закрытия списка выбора столбцов, щелкните либо в любом месте затемненного прозрачного слоя, либо на саму кнопку "Показать / Скрыть столбцы".

Отображаемое имя | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Максимальная | Корпоративная | "Безопасная" | "Настроенная" | "Минимум"
BranchCache | Не доступна | Не доступна | Не доступна | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
DHCP-клиент | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
DNS-клиент | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
KtmRm для координатора распределенных транзакций | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Microsoft .NET Framework NGEN v2.0.50727_X64 Microsoft .NET Framework NGEN v2.0.50727_X86 | Вручную | Вручную | Вручную | Автоматически (Отложенный запуск, Запущена) | Вручную | Автоматически (Отложенный запуск, Запущена) | Вручную | Вручную | Вручную
Microsoft .NET Framework NGEN v4.0.30319_X64 Microsoft .NET Framework NGEN v4.0.30319_X86 | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Автоматически (Отложенный запуск), Запущена) | Не установлена (Вручную) | Не установлена (Автоматически (Отложенный запуск), Запущена) | Вручную | Вручную | Вручную
Parental Controls | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Plug and Play | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Quality Windows Audio Video Experience | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Superfetch | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Telnet | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена | Не установлена | Не установлена
Windows Audio | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Windows CardSpace | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Удалена *
Windows Driver Foundation - User-mode Driver Framework | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Windows Search | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Отключена * | Отключена * | Удалена *
WMI Performance Adapter | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Автонастройка WWAN | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Автономные файлы | Не доступна | Не доступна | Не доступна | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Отключена * | Отключена * | Отключена *
Агент защиты сетевого доступа | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Агент политики IPsec | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Адаптер прослушивателя Net.Msmq | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Адаптер прослушивателя Net.Pipe | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Адаптер прослушивателя Net.Tcp | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Адаптивная регулировка яркости | Не доступна | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Архивация Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Биометрическая служба Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Брандмауэр Windows | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Браузер компьютеров | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Веб-клиент | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Виртуальный диск | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Вспомогательная служба IP | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Отключена * | Отключена * | Отключена *
Вторичный вход в систему | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Группировка сетевых участников | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Дефрагментация диска | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Диспетчер автоматических подключений удаленного доступа | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Диспетчер печати | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Диспетчер подключений удаленного доступа | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Диспетчер сеансов диспетчера окон рабочего стола | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Диспетчер удостоверения сетевых участников | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Диспетчер учетных данных | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Диспетчер учетных записей безопасности | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Доступ к HID-устройствам | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Журнал событий Windows | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Журналы и оповещения производительности | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Защита программного обеспечения | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск)
Защитник Windows | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск) | Отключена *
Защищенное хранилище | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Изоляция ключей CNG | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Инструментарий управления Windows | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Информация о совместимости приложений | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Клиент групповой политики | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Клиент для NFS | Не доступна | Не доступна | Не доступна | Не доступна | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Клиент отслеживания изменившихся связей | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Отключена * | Отключена * | Отключена *
Координатор распределенных транзакций | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Кэш шрифтов Windows Presentation Foundation 3.0.0.0 | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Удалена *
Ловушка SNMP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Локатор удаленного вызова процедур (RPC) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Маршрутизация и удаленный доступ | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена
Модули ключей IPsec для обмена ключами в Интернете и протокола IP с проверкой подлинности | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Модуль запуска процессов DCOM-сервера | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Модуль поддержки NetBIOS через TCP/IP | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Настройка сервера удаленных рабочих столов | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Немедленные подключения Windows – регистратор настройки | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Обнаружение SSDP | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Вручную
Обнаружение интерактивных служб | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Общий доступ к подключению к Интернету (ICS) | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена
Определение оборудования оболочки | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Основные службы доверенного платформенного модуля | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Очередь сообщений | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Перенаправитель портов пользовательского режима служб удаленных рабочих столов | Не доступна | Не доступна | Не доступна | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Перечислитель IP-шин PnP-X | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Питание | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Планировщик заданий | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Планировщик классов мультимедиа | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Поддержка элемента панели управления "Отчеты о проблемах и их решениях" | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Политика удаления смарт-карт | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Поставщик домашней группы | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Отключена *
Проводная автонастройка | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Программный поставщик теневого копирования (Microsoft) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Прослушиватель RIP | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Прослушиватель домашней группы | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Простые службы TCP/IP | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Протокол PNRP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Публикация ресурсов обнаружения функции | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Отключена * | Отключена *
Рабочая станция | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Распространение сертификата | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Расширяемый протокол проверки подлинности (EAP) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Сборщик событий Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Сведения о приложении | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Вручную
Сервер | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Сервер упорядочения потоков | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Сетевой вход в систему | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Сетевые подключения | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Вручную
Система событий COM+ | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Системное приложение COM+ | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Служба FTP (Майкрософт) | Не доступна | Не доступна | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба IIS Admin | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба LPD | Не доступна | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба SNMP | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба SSTP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Служба автоматического обнаружения веб-прокси WinHTTP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба автонастройки WLAN | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Служба активации Windows | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена | Не установлена | Не установлена
Служба базовой фильтрации | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Служба ввода планшетного ПК | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба веб-публикаций | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба времени Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Служба загрузки изображений Windows (WIA) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Служба индексирования | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба инициатора Майкрософт iSCSI | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Служба интерфейса сохранения сети | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Служба кэша шрифтов Windows | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена)
Служба медиаприставки Media Center | Не доступна | Не доступна | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Удалена *
Служба модуля архивации на уровне блоков | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Служба общего доступа к портам Net.Tcp | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Удалена *
Служба общих сетевых ресурсов проигрывателя Windows Media | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Отключена * | Отключена * | Удалена *
Служба перечислителя переносных устройств | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба планировщика Windows Media Center | Не доступна | Не доступна | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Удалена *
Служба поддержки Bluetooth | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Служба поддержки узла приложений | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба политики диагностики | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Отключена * | Отключена *
Служба помощника по совместимости программ | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба профилей пользователей | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Служба публикации имен компьютеров PNRP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба регистрации ошибок Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба ресивера Windows Media Center | Не доступна | Не доступна | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Удалена *
Служба сведений о подключенных сетях | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Служба состояния ASP.NET | Не доступна | Не доступна | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена | Не установлена | Не установлена
Служба списка сетей | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Вручную
Служба технологий активации Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Служба уведомления SPP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Служба уведомления о системных событиях | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Служба удаленного управления Windows (WS-Management) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба управления сетью | Не доступна | Не доступна | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена | Не установлена | Не установлена
Служба хранилища | Не доступна | Не доступна | Не доступна | Вручную | Не доступна | Вручную | Отключена * | Отключена * | Отключена *
Служба шифрования дисков BitLocker | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба шлюза уровня приложения | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Службы криптографии | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Службы удаленных рабочих столов | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Смарт-карта | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Сопоставитель конечных точек RPC | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Средство построения конечных точек Windows Audio | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Телефония | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Темы | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Теневое копирование тома | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Тополог канального уровня | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Триггеры очереди сообщений | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Удаленный вызов процедур (RPC) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Удаленный реестр | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Удостоверение приложения | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Узел системы диагностики | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Узел службы диагностики | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Отключена * | Отключена *
Узел универсальных PNP-устройств | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Управление приложениями | Не доступна | Не доступна | Не доступна | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Управление сертификатами и ключом работоспособности | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Установщик ActiveX (AxInstSV) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Установщик Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Установщик модулей Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Факс | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Удалена *
Фоновая интеллектуальная служба передачи (BITS) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Хост библиотеки счетчика производительности | Не доступна | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Хост поставщика функции обнаружения | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Отключена * | Отключена *
Цветовая система Windows (WCS) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Центр обеспечения безопасности | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск) | Отключена *
Центр обновления Windows | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск) | Отключена *
Шифрованная файловая система (EFS) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Отображаемое имя | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Максимальная | Корпоративная | "Безопасная" | "Настроенная" | "Минимум"

Изменение у службы значения "Тип запуска".

1) Откройте одним из предложенных ниже способов оснастку Службы:

1.1) Откройте Панель управления\Система и безопасность\Администрирование и запустите оснастку Службы.
1.2) Откройте Панель управления\Все элементы панели управления\Администрирование и запустите оснастку Службы.
1.3) Откройте Пуск → Администрирование → Службы.
1.4) В строке поиска меню Пуск или в окне Выполнить (Win   + R) введите services.msc и нажмите Enter ↵.
2) Откройте одним из предложенных ниже способов Свойства необходимой Вам службы:
2.1) Дважды щелкните левой кнопкой мыши на имени необходимой Вам службы.
2.2) Щелкните на необходимой Вам службе правой кнопкой мыши и выберите пункт Свойства.
3) На вкладке Общие, в ниспадающем списке напротив надписи Тип запуска установите желаемое значение.

Управление работой служб из командной строки

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Для выполнения необходимого Вам действия в соответствии с шаблоном введите требуемую команду и нажмите Enter ↵.

Запуск службы:

Установка режима запуска службы:

Используйте кавычки, если имя службы содержит пробелы.
Между знаком равенства и значением параметра должен быть пробел.
Тип запуска: auto (автоматически), demand (вручную), disabled (отключена).

Остановка службы:

Удаление службы:

Примеры:

Для установки типа запуска службы „Windows Search“ в положение отключено введите команду:

Для остановки службы „Windows Search“ введите команду:

Управление работой служб из редактора реестра

1) Запустите редактор реестра (Win   + R → regedit → OK)
2) Откройте раздел: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services.
3) Откройте подраздел необходимой Вам службы. Имя данного подраздела соответствует имени службы.
Пример: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WSearch

Для изменения значения Тип запуска установите значение DWORD-параметра Start на указанные ниже:

Значение DWORD-параметра | Тип запуска
2 | Автоматически
3 | Вручную
4 | Отключена

Чтобы установить Тип запуска в значение Автоматически (отложенный запуск) сделайте следующее:

Установите значение DWORD-параметра Start равным 2.
Создайте в подразделе необходимой Вам службы DWORD-параметр с именем DelayedAutoStart и значением равным 1.

Для изменения значения Исполняемый файл установите значение строкового (String) параметра ImagePath на указанное в таблице.
Для изменения значения Вход от имени службы установите значение строкового (String) параметра ObjectName на указанное ниже:

Значение строкового (String) параметра | Вход от имени
NT AUTHORITY\LocalService | Локальная служба
NT Authority\NetworkService | Сетевая служба
LocalSystem | Локальная система

Примечание: В случае наличия у Вас указанных ниже разделов, замените указанные выше значения для служб и в них.

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\Имя_службы
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Имя_службы

Пример:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\WSearch
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\WSearch

4) Перезагрузите компьютер после внесения изменений.

2. Быстрое отображение (скрытие) значков в области уведомлений.

Чтобы быстро изменить поведение значков уведомлений, не используя диалогового окна Значки области уведомлений, открывающегося при нажатии на ссылку Настроить....

Перетащите нужный значок из скрытой области в область уведомлений для его отображения на панели задач.
Перетащите нужный значок в скрытую область из области уведомлений для его скрытия с панели задач.

3. Изменение параметров загрузки в Windows 7 (msconfig вместо boot.ini).

Начиная с Windows Vista такого файла больше нет, но Вы можете изменить необходимые Вам для загрузки параметры используя инструмент Конфигурация системы.
Окно Конфигурация системы запускается так: Панель управления → Администрирование → Конфигурация системы → Загрузка (или нажав Win   + R → msconfig → ОК)

Данный инструмент позволяет:
- получить информацию о текущей и загружаемой по умолчанию системах;
- выбрать систему, загружаемую по умолчанию;
- удалить ненужную запись из меню загрузки.
- отредактировать время в секундах (таймаут), по истечении которого будет загружена операционная система, выбранная по умолчанию.
- включить\выключить экран приветствия(Без GUI);
- включить\выключить загрузку стандартных драйверов VGA, вместо драйверов экрана, соответствующих видеооборудованию компьютера(Базовое видео).

А через Дополнительные параметры:

- Число процессоров, используемых при загрузке.
- Максимальный объем памяти в мегабайтах, используемый для моделирования конфигурации с малым объемом памяти.

При помощи окна Конфигурация системы нельзя изменить(но это возможно, при помощи программы Bcdedit):

- наименование существующих записей;
- положение записи в меню загрузки.

Для выбора системы, загружаемой по умолчанию, выберите необходимую Вам операционную систему и нажмите кнопку «Использовать по умолчанию».
Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».
Для редактирование таймаута, в нужном поле установите желаемое количество секунд.

Для применения, сделанных Вами изменений - перезагрузите компьютер.

4. Принудительная установка числа ядер, используемых при загрузке.

1) Откройте диалоговое меню Выполнить: Пуск → Выполнить(или Win   + R)
2) Введите msconfig и нажмите OK
3) Перейдите на вкладку Загрузка
4) Нажмите Дополнительные параметры
5) Поставьте флажок напротив значения Число процессоров
6) Выберите в активировавшемся ниспадающем меню число ядер Вашего процессора (По умолчанию 1)
Установка меньшего значения, чем количество ядер Вашего процессора не рекомендуется, так как система может продолжить использование указанного Вами числа ядер и после завершения загрузки.
7) Нажмите OK и перезагрузите компьютер

5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны.
Для изменения временной зоны сделайте следующее:

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду:

3) Выберите необходимую Вам временную зону и введите в соответствии с ней команду.

Например, для установки значения временной зоны по Гринвичу выполните команду:

Замените значение между кавычками на необходимое Вам.
tzutil /g - отображает текущие установки временной зоны;
tzutil /? - выводит справку по работе утилиты.

6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны.

Чтобы задать для данной программы клавишу быстрого вызова, сделайте следующее:

1) Откройте Пуск → Все программы → Стандартные.
2) Щелкните правой кнопкой мыши на программу "Ножницы" и выберите пункт Свойства.
3) Задайте в поле Быстрый вызов необходимую Вам комбинацию клавиш.
Изначально, для использования Вам предложат первые две клавиши Ctrl + Alt +.
Вы можете либо выбрать третью клавишу, либо задать другую комбинацию клавиш.

7. Отключение (включение) неиспользуемых компонентов Windows.

В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них Вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева Включение или отключение компонентов Windows
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но Вами не используются

8. Изменение программы, заданной по умолчанию, для открытия определенного типа файла.

Если Вам необходимо изменить программу, с помощью которой будет открываться определенный тип файла, то Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Щелкните правой кнопкой мыши на файле с необходимым Вам расширением и выберите пункт Свойства.
2) На вкладке "Общие" напротив пункта Приложение нажмите кнопку Изменить.
3) Нажмите на стрелочку напротив Другие программы, выберите необходимую Вам программу из списка и нажмите ОК.
4) Если программа отсутствует в списке, то нажмите кнопку Обзор.
5) В окне "Открыть с помощью", откройте папку Вашей программы, выберите в ней exe-файл и нажмите кнопку Открыть, а затем кнопку ОК.

Вариант 2.

1) Щелкните правой кнопкой мыши на файле с необходимым Вам расширением и выберите одно из имеющихся у Вас пунктов.
1.1) Пункт Открыть с помощью....
1.2) Пункт Открыть с помощью → Выбрать программу... .
2) Нажмите на стрелочку напротив Другие программы, выберите необходимую Вам программу из списка и нажмите ОК.
3) Если программа отсутствует в списке, то нажмите кнопку Обзор.
4) В окне "Открыть с помощью", откройте папку Вашей программы, выберите в ней exe-файл и нажмите кнопку Открыть, а затем кнопку ОК.

Вариант 3. Для неизвестных системе файлов.

1) Щелкните правой кнопкой мыши на файле с необходимым Вам расширением и выберите пункт Открыть.
2) Установите переключатель в значение Выбор программы из списка установленных программ и нажмите кнопку ОК.
3) Выберите необходимую Вам программу из списка и нажмите ОК.
4) Если программа отсутствует в списке, то нажмите кнопку Обзор.
5) В окне "Открыть с помощью", откройте папку Вашей программы, выберите в ней exe-файл и нажмите кнопку Открыть, а затем кнопку ОК.

Вариант 4.

1) Откройте меню Пуск и выберите пункт Панель управления.
2) Установите вид просмотра Крупные значки и выберите Программы по умолчанию.
3) Щелкните на Сопоставление типов файлов или протоколов конкретным программам.
4) Выберите необходимое расширение файла и нажмите кнопку Изменить программу.
5) Нажмите на стрелочку напротив Другие программы, выберите необходимую Вам программу из списка и нажмите ОК.
6) Если программа отсутствует в списке, то нажмите кнопку Обзор.
7) В окне "Открыть с помощью", откройте папку Вашей программы, выберите в ней exe-файл и нажмите кнопку Открыть, а затем кнопку ОК.

Вариант 5.

1) Скачайте архив DefaultProgramsEditor.zip и распакуйте его в любую папку.
2) Щелкните правой кнопкой мыши на файл "Default Programs Editor.exe" и выберите пункт Запуск от имени администратора.
3) Нажмите File Type Settings → Context Menu
4) Выберите необходимое расширение файла и нажмите кнопку Next.
5) Выделите пункт Open или Edit (при отсутствии Open) и нажмите кнопку Edit Selected Command.
6) Нажмите на кнопку Browse рядом с полем Program path.
7) Откройте папку программы, используемой для открытия файлов данного типа, выберите exe-файл и нажмите кнопку Открыть.

8) При желании, Вы также можете выбрать значок для типа файла:
8.1) Нажмите на кнопку Browse рядом с полем Item icon.
8.2) Нажмите на кнопку Обзор...
8.3) Выберите иконку(.ico) или файл содержащий значки(.dll, .exe) и нажмите кнопку Открыть.
8.4) Выберите изображение иконки и нажмите ОК.

9) Нажмите кнопку Next, затем кнопку Save Context Menu, а после ОК и Close.

9. Отключение всплывающих подсказок.

Отключить всплывающие подсказки можно используя Редактор локальной групповой политики.
1) Нажмите Пуск, в поле поиска напишите gpedit.msc и нажмите ОК.
2) Перейдите в раздел Конфигурация пользователя → Административные шаблоны → Меню Пуск и Панель задач.
3) Откройте параметр "Удалить всплывающие подсказки для элементов главного меню",
4) Установите переключатель в значение Включить и нажмите ОК.

10. Изменение функции кнопки питания на корпусе Вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии "Завершение работы". Если Вы перезагружаете компьютер по несколько раз в день, Вам наверное было бы удобнее переключить кнопку выключения в состояние "Перезагрузка". Для этого выполните следующие действия:

1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт меню Свойства.
2) Перейдите на вкладку Меню "Пуск".
3) Переключите значение “Действие кнопки питания” в состояние "Перезагрузка". Также Вы можете выбрать функции "Блокировка", "Смена пользователя" и "Завершение сеанса".

11. Быстрый переход к часто используемой папке.

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке Проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки Проводника.

12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

bcdedit - инструмент, позволяющий изменить значения загрузчика Windows, а также произвести его(загрузчика) восстановление.
Чтобы увидеть предлагаемые системой для изменения параметры: запустите командную строку от имени администратора
(В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵), наберите в ней bcdedit и нажмите Enter ↵.
Все команды, приведенные в данном варианте, необходимо будет запускать в командной строке, запущенной от имени администратора. Также данные команды могут выполняются в командной строке среды восстановления или в командной строке MSDaRT (ранее ERD Commander).

Некоторые значения параметров BCD записаны в фигурных скобках – {}. Это идентификаторы – {CLSID}. Любой идентификатор имеет буквенно-цифровой код вида {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. Стандартные идентификаторы имеют названия, например: {default}, {bootmgr}, {ntldr} и так далее.

Наиболее интересующими нас компонентами являются:

идентификатор – CLSID той или иной записи;
device – показывает раздел, на котором расположены файлы загрузки (это может быть операционная система или папка BOOT);
osdevice – показывает раздел, на котором расположены системные файлы операционной системы. Обычно, значения параметров device и osdevice равны;
path – если device определял раздел диска, который содержит файлы операционной системы, то этот параметр определяет остальной путь к загрузчику операционной системы;
default – показывает ID операционной системы, загружаемой по умолчанию, если операционная система, в которой запустили командную строку, загружается по умолчанию, параметру default присваивается значение {current};
displayorder – показывает порядок, в котором расположены записи о загружаемых системах;
timeout – таймаут(время - по истечении которого будет загружена операционная система), значение показано и устанавливается в секундах;
locale – указывает язык загрузочного меню или меню дополнительных параметров загрузки;
description – показывает название операционной системы, отображающееся в меню загрузки.

Внимание: Если в выполняемой Вами команде, с использованием программы bcdedit.exe, отсутствует параметр /set с дальнейшим указанием идентификатора, то внесенные Вами изменения будут добавлены в Диспетчер загрузки Windows (Windows Boot Manager), а не в Загрузка Windows (Windows Boot Loader)

Перед тем, как начнете вносить необходимые Вам изменения, создайте резервную копию загрузчика. Для этого, создайте на любом диске папку с названием BCDREZ и выполните следующую команду:

где X - буква диска, на котором находится папка BCDREZ.

Если Вы решите вернуть все сделанные Вами изменения к начальным настройкам, то выполните следующую команду:

Для дальнейших примеров, предположим, что наше меню загрузки содержит три записи с идентификаторами {ID1}, {ID2}, {ID3}.

Изменение системы, загружаемой по умолчанию

Введите параметр /default и {ID} той системы, которую Вы хотите загружать по умолчанию. Например, для системы с {ID2} команда:

Данная команда не перемещает запись о системе, загружаемой по умолчанию, на верхнюю строчку меню загрузки.

Изменение расположения записей в меню загрузки

1) Перемещение выбранной записи вверх списка:

2) Перемещение выбранной записи вниз списка:

3) Формирование меню в выбранном порядке:

Изменение таймаута

где XX – время в секундах.

Изменение языка диспетчера загрузки

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение языка меню дополнительных вариантов загрузки

В связи с тем, что программа восстановления запуска, выполняющаяся из среды восстановления, использует параметры "по-умолчанию", меню дополнительных вариантов загрузки, которое появляется при нажатииF8 после наведения на строку меню с нужной операционной системой, может стать англоязычным. Вернуть необходимый Вам язык, можно выполнив следующую команду:

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение названия загружаемой системы

После использования среды восстановления, в названии операционной системы появляется надпись - (восстановлено).
Вы также можете исправить значение "Предыдущая версия Windows" на более удобное Вам "Windows XP" или добавить версию и разрядность к текущей(используемой по умолчанию) версии Windows.
Вы можете изменить это указанной ниже командой:

Например:

Изменение буквы раздела, на котором расположена папка операционной системы и ее загрузочные файлы

где X – буква раздела жесткого диска. Обычно значения device и osdevice совпадают.

Добавление новой операционной системы (Windows Vista или Windows 7) в загрузчик.

1) Скопируйте существующую запись текущей системы с новым названием:

2) Дождитесь сообщение «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
3) Измените значения параметров device и osdevice на соответствующие добавляемой операционной системе.

где X – буква диска, на котором находится операционная система. Вместо крестиков, введите значение {ID}, полученное после успешного окончания копирования.
4) Выполните команду, добавляющую новую запись в диспетчер загрузки:

Запись будет добавлена внизу существующего списка.

Удаление записи загрузки системы из BCD и диспетчера загрузки.

Удаление записи об установленной операционной системе из BCD и диспетчера загрузки выполняется с помощью команды bcdedit /delete {ID}.
Есть особенность выполнения команды: если в качестве ID указывается известная запись, например {ntldr}, то команда должна выполняться с ключом /f:

Если же ID записывается в буквенно-цифровом коде, ключ /f не нужен.

В случае отсутствия одного из файлов, необходимых для работы с загрузчиком, Вы можете скачать архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe; Bootrec.exe)

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

13. Установка пользовательского разрешения экрана.

У некоторых мониторов разрешение экрана может не соответствовать ни одному из предлагаемых Windows.

Если у Вас установлена видеокарта Nvidia Вы можете добавить своё разрешение экрана одним из указанных способов:

Способ 1.

1) Запустить Панель управления Nvidia.
2) Открыть Дисплей → Изменение разрешения → Добавить разрешения... → Создать пользовательское разрешение
3) Задать нужные Вам параметры, протестировать их и добавить его в список для выбора
4) Выбрать его и использовать.

Способ 2.

Используя реестр добавить нужное Вам разрешение в параметр NV_Modes

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{some number}\0000

Также можете найти другие ветки содержащие параметр NV_Modes и также добавить в них необходимое Вам разрешение экрана.

Способ 3. Перед установкой драйвера.

Откройте файл "nv_disp.inf" в папке C:\NVIDIA\Win7\xxx.xx и найдите значение [nv_commonDisplayModes_addreg]
Под ним в NV_Modes будут все доступные разрешения экрана, добавьте туда свое.

Но бывает что даже после указанных выше манипуляций, новое разрешение не хочет добавляться. В таком случае, для принудительного добавления пользовательского разрешения Вам придется использовать специальные программы. Рекомендую поискать в интернете следующие программы:

PowerStrip - Программа управления параметрами видеоподсистемы вашего компьютера, поддерживается огромное разнообразие видео карт. Это - фактически единственная программа своего рода, которая поддерживает видео карты из многочисленного набора чипсетов и поставщиков, одновременно, под любой операционной системой. Программа спокойно сидит в трее и оттуда обеспечивает доступ к более 500 элементов управления над вашими дисплейными аппаратными средствами, включая цветные инструментальные средства коррекции, установки уровня периода экранной геометрии, и драйверо-независимыми элементами управления часов.

Screen Resolution Manager - Программа, позволяющая каждому пользователю компьютера устанавливать свое разрешение экрана. Помимо разрешения можно настроить глубину цвета, частоту, яркость и контрастность, цветовую гамму и другие настройки, которые автоматически вступят в силу после загрузки профиля определенного пользователя.

14. Создание диска восстановления системы и загрузка с него.

Если у вас есть установочный диск Windows 7, создавать диск восстановления необязательно. Если же установочного диска у вас нет, создать диск восстановления нужно обязательно - он вам рано или поздно пригодится. С установочного диска можно загрузиться в среду восстановления Windows RE.

Создание диска восстановления системы

1) Вставьте чистый компакт-диск в привод.
2) Откройте Пуск → Панель Управления → Архивация и восстановление (Backup and Restore)
3) В левой панели щелкните ссылку Создать диск восстановления системы.

Загрузка с диска восстановления системы

1) Вставьте диск восстановления в привод и перезагрузитесь
2) В BIOS должен быть установлен приоритет загрузки с привода. Будет выполнена загрузка в Windows RE.
3) Выберите систему, которую вы хотите восстановить.
4) Установите переключатель Используйте средства восстановления... и нажмите кнопку Далее. Вы увидите окно с вариантами восстановления.

15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Выполните следующие команды, нажимая после введения каждой Enter ↵.

16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

Вы решили заменить или продать один из ваших жестких дисков. Прежде чем это сделать, убедитесь что файлы загрузки Windows 7 не содержаться на удаляемом Вами из системы жестком диске.
Windows 7 хранит свои файлы для загрузки на активном диске, который может отличаться от того на котором установлена Windows 7. Файлами загрузки для Windows 7 являются файл bootmgr и хранилище данных конфигурации загрузки BCD (Boot Configuration Data), находящееся в скрытой и системной папке Boot.

При загрузке Windows 7 проверяет соблюдение 3 условий:

- Является ли диск, с которого выполняется загрузка активным;
- Совместима ли Главная Загрузочная Запись (Master Boot Record - MBR) с bootmgr (Диспетчером загрузки Windows);
- Находиться ли файлы загрузки операционной системы на активном диске должны.

В случае не соблюдения одного из условий, загрузка становится невозможной.

Предположим, что Ваша Windows 7 установлена на диск С:, который не активен. Активным является только диск D:, который Вы собираетесь удалить из системы и на котором находятся Файлы загрузки Windows 7, имеющие атрибуты Скрытый и Системный.

В качестве решения предлагаю Вам выполнить перенесение файлов загрузки Windows 7 с активного раздела (удаляемый жесткий диск) на неактивный раздел (остающийся в системе жесткий диск, с присвоением ему атрибута - Активный).

1) Выяснение атрибутов дисков и присвоение остающемуся в системе жесткому диску атрибута Активный.

Способ 1. Используя оснастку "Управление дисками".

1.1.1) Нажмите Win   + R, в строке "Выполнить" наберите diskmgmt.msc и нажмите OK
1.1.2) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7
Буква тома здесь, идентична букве диска с Window 7 из Мой Компьютер.
1.1.3) Под буквой тома, размером диска и файловой системой будут указаны атрибуты диска. Посмотрите имеет ли наш том атрибут "Активный".
Если да, то Вы сможете спокойно удалить Ваш диск из системы. Если же нет, то Вам необходимо будет присвоить данный атрибут, в соответствии с написанным ниже.
1.1.4) Если Ваша Windows 7 установлена на жесткий диск, разбитый на несколько разделов, то выберите первый слева раздел остающегося у Вас диска, его мы сделаем загрузочным и активным. Если же раздел всего один, то выберите его.
1.1.5) Щелкните правой кнопкой мыши по выбранному разделу и выберите в контекстном меню пункт "Сделать раздел активным". Учтите, что этот раздел должен иметь атрибут "Основной".

Способ 2. Используя командную строку.

1.2.1) Запустите командную строку с правами администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
1.2.2) Последовательно выполните все команды без выхода из командной строки:

где X - номер диска, который предполагается оставить, в списке дисков (команда list disk).

2) Перезапись загрузочного сектора MBR и установка его совместимости с bootmgr:

2.1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe; Bootrec.exe).
2.2) Создайте папку Boot.
2.3) Распакуйте скачанный архив и скопируйте файлы нужной Вам битности в созданную Вами папку Boot.
2.4) Запустите командную строку с правами администратора.

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /force - принудительно отключает один или несколько томов во время обновления загрузочного кода. Необходим, при наличии в конфигурации 2-х и более жестких дисков.

3) Перенесение BCD (Boot Configuration Data) и файла bootmgr на новый активный раздел:

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /l - выбор языковых параметров менеджера загрузки. Если ваша система не русскоязычная, используйте другие значения этого ключа, например, для английского языка - en-US, для немецкого - de-DE, и т.д.
- ключ /s - определяет букву тома, назначенную целевому системному разделу, в который копируются файлы среды загрузки. Это раздел, который мы сделали активным. Windows 7 использует текущий загрузочный раздел (в нашем случае - раздел D:) до завершения своей работы. Поэтому применение этого ключа с указанием буквы нового загрузочного раздела (в нашем случае - раздел С:) - обязательно.

17. Способы доступа к элементам Панели управления.

В разных статьях Вы можете увидеть разное описание пути к одинаковым элементам Панели управления. Такое происходит потому что в Windows существует два вида отображения элементов: Категория(элементы сгруппированы по тематикам) и Крупные или Мелкие значки (элементы отображаются полным списком) Имхо, наиболее удобным является Крупные или Мелкие значки(их полный список).

Существует несколько способов доступа к элементам Панели управления:

1) Через меню Пуск.

Для быстрого доступа к элементам Панели управления, рекомендуется добавить в меню Пуск всплывающее меню содержащее все элементы Панели Управления.
1.1) Нажмите правой кнопкой мыши на кнопке Пуск и щелкните на пункте Свойства.
1.2) Нажмите Настроить...
1.3) Промотайте до записи Панель управления.
1.4) Установите значение переключателя под ней в положение Отображать как меню и нажмите OK
Всплывающее меню Панели управления будет отображаться полным списком, независимо от Вашего выбора вида отображения.

2) Через Проводник Windows.

2.1) Запустите Проводник
2.2) В панели меню выберите Сервис и нажмите Параметры папок
2.3) Под надписью Область переходов установите флажок напротив значения Показать все папки и нажмите OK
Теперь Панель управления будет доступна в Проводнике в Области переходов слева. Преимущество данного способа в том что Вы можете работать, как сразу с полным списком элементов: Проводник → Панель управления → Все элементы панели управления, так и с отдельными разделами: Проводник → Панель управления → Нужный Вам раздел.

3) На рабочем столе.

3.1) Щелкните правой кнопкой мыши на Рабочем столе и нажмите Персонализация
3.2) Щелкните Изменение значков рабочего стола
3.3) Установите флажок напротив Панель управления и нажмите ОК
На Рабочем столе появится ярлык запускающий папку Панель управления. Способ отображения зависит от выбранного Вами значения параметра Просмотр.

4) Запуск папки Панель управления используя {GUID}

Для её запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win   + R) и введите команду:

shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}

5) Запуск элементов Панели управления, используя канонические имена.

Русское название элемента | Английское название элемента | Команда
Русское название элемента | Английское название элемента | Команда
Панель управления | Control Panel | control
Windows CardSpace | Windows CardSpace | control /name Microsoft.CardSpace
Windows SideShow | Windows SideShow | control /name Microsoft.WindowsSideShow
Автозапуск | AutoPlay | control /name Microsoft.AutoPlay
Автономные файлы | Offline Files | control /name Microsoft.OfflineFiles
Администрирование | Administrative Tools | control /name Microsoft.AdministrativeTools
Архивация и восстановление | Backup and Restore | control /name Microsoft.BackupAndRestore
Биометрические устройства | Biometric Devices | control /name Microsoft.BiometricDevices
Брандмауэр Windows | Windows Firewall | control /name Microsoft.WindowsFirewall
Восстановление | Recovery | control /name Microsoft.Recovery
Гаджеты рабочего стола | Desktop Gadgets | control /name Microsoft.DesktopGadgets
Дата и Время | Date and Time | control /name Microsoft.DateAndTime
Датчик расположения и другие датчики | Location and Other Sensors | control /name Microsoft.LocationAndOtherSensors
Диспетчер устройств | Device Manager | control /name Microsoft.DeviceManager
Диспетчер учетных данных | Credential Manager | control /name Microsoft.CredentialManager
Домашняя группа | HomeGroup | control /name Microsoft.HomeGroup
Защитник Windows | Windows Defender | control /name Microsoft.WindowsDefender
Звук | Sound | control /name Microsoft.Sound
Значки области уведомлений | Notification Area Icons | control /name Microsoft.NotificationAreaIcons
Игровые устройства | Game Controllers | control /name Microsoft.GameControllers
Инициатор iSCSI | iSCSI Initiator | control /name Microsoft.iSCSIInitiator
Инфракрасная связь | Infrared | control /name Microsoft.Infrared
Клавиатура | Keyboard | control /name Microsoft.Keyboard
Мышь | Mouse | control /name Microsoft.Mouse
Панель задач и меню "Пуск" | Taskbar and Start Menu | control /name Microsoft.TaskbarAndStartMenu
Папка "Fonts" | Fonts Folder | control /name Microsoft.Fonts
Параметры индексирования | Indexing Options | control /name Microsoft.IndexingOptions
Параметры папок | Folder Options | control /name Microsoft.FolderOptions
Параметры планшетного компьютера | Tablet PC Settings | control /name Microsoft.TabletPCSettings
Перо и сенсорные устройства | Pen and Touch | control /name Microsoft.PenAndTouch
Персонализация | Personalization | control /name Microsoft.Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | RemoteApp and Desktop Connections | control /name Microsoft.RemoteAppAndDesktopConnections
Получение программ | Get Programs | control /name Microsoft.GetPrograms
Приступая к работе | Getting Started | control /name Microsoft.GettingStarted
Программы и компоненты | Programs and Features | control /name Microsoft.ProgramsAndFeatures
Программы по умолчанию | Default Programs | control /name Microsoft.DefaultPrograms
Распознавание речи | Speech Recognition | control /name Microsoft.SpeechRecognition
Расположение по умолчанию | Default Location | control /name Microsoft.DefaultLocation
Родительский контроль | Parental Controls | control /name Microsoft.ParentalControls
Свойства обозревателя | Internet Options | control /name Microsoft.InternetOptions
Свойства речи | Text to Speech | control /name Microsoft.TextToSpeech
Система | System | control /name Microsoft.System
Сканеры и камеры | Scanners and Cameras | control /name Microsoft.ScannersAndCameras
Соседние пользователи | People Near Me | control /name Microsoft.PeopleNearMe
Счетчики и средства производительности | Performance Information and Tools | control /name Microsoft.PerformanceInformationAndTools
Телефон и модем | Phone and Modem | control /name Microsoft.PhoneAndModem
Управление цветом | Color Management | control /name Microsoft.ColorManagement
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control /name Microsoft.DevicesAndPrinters
Учетные записи пользователей | User Accounts | control /name Microsoft.UserAccounts
Центр мобильности Windows | Windows Mobility Center | control /name Microsoft.MobilityCenter
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | control /name Microsoft.ActionCenter
Центр синхронизации | Sync Center | control /name Microsoft.SyncCenter
Центр специальных возможностей | Ease of Access Center | control /name Microsoft.EaseOfAccessCenter
Центр управления сетями и общим доступом | Network and Sharing Center | control /name Microsoft.NetworkAndSharingCenter
Шифрование диска BitLocker | BitLocker Drive Encryption | control /name Microsoft.BitLockerDriveEncryption
Экран (размер текста) | Display (size of text) | control /name Microsoft.Display
Электропитание | Power Options | control /name Microsoft.PowerOptions
Язык и региональные стандарты | Region and Language | control /name Microsoft.RegionAndLanguage
Русское название элемента | Английское название элемента | Команда

При отсутствии в системе необходимого устройства, драйверов или определенных компонентов, соответствующий ему элемент Панели управления может не запуститься.

18. Отключение залипания клавиш, озвучивания данного действия и озвучивания нажатия клавиши CAPS LOCK, NUM LOCK, или SCROLL LOCK.

Чтобы отключить озвучивание перекдючений клавиш клавиатуры, а также залипание клавиш выполните указанные ниже действия.

1) Откройте Пуск → Панель управления → Центр специальных возможностей.
2) Нажмите на ссылку Облегчение работы с клавиатурой.
3) В разделе Упростить набор текста снимите указанные ниже флажки и нажмите кнопку Применить:

Включить озвучивание переключений
Включить озвучивание переключений путем нажатия и удерживания клавиши NUM LOCK в течение 5 секунд.

4) Нажмите на ссылку Настройка залипания клавиш.
5) Снимите все флажки в открывшемся окне и нажмите кнопку ОК.
6) Закройте окно Облегчение работы с клавиатурой.

19. Добавление своей программы в утилиту msconfig (Конфигурация системы).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните с именем mscfgtlc.xml
3) Скопируйте файл в папку C:\Windows\system32\

Например:

или

Добавленная Вами программа появится во вкладке Сервис (Tools).
Для использования русских букв файл необходимо сохранить файл в кодировке UTF-8.
В качестве пути можно указать только файлы из папок Windows или Program Files включая подпапки.

20. Настройка параметров индексирования для ускорения выполнения поиска в системе.

Операционная система Windows использует индекс для выполнения быстрого поиска наиболее часто используемых файлов. По умолчанию индексируются все самые распространенные файлы на компьютере. Повысить производительность поиска в Windows 7 можно, следующим образом.

Добавление или удаление расположения из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter ↵.
2) Щелкните Изменить.
3) Установите или снимите флажок с папок в списке Изменение выбранных расположений, которые Вы желаете добавить или удалить для ускорения поиска, а затем нажмите кнопку ОК.
4) Если в списке отображаются не все расположения на компьютере, нажмите кнопку Показать все расположения. (Если в списке отображаются все расположения на компьютере, кнопка Показать все расположения недоступна.) Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
5) Если требуется добавить папку, исключая некоторые вложенные папки, щелкните папку и затем снимите флажки рядом с теми вложенными папками, которые не требуется индексировать. Эти папки будут отображены в столбце «Исключить» в разделе Сводный список выбранных расположений.

Индексировать все файлы на компьютере не рекомендуется, так как если сделать индекс слишком большим или добавить в индекс расположения системных файлов (например, папки «Program Files»), поиск будет выполняться медленно.

Добавление или удаление типа файла из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter ↵.
2) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
3) Перейдите на вкладку Типы файлов.
4) Снимите флажок с расширений в списке, которые Вы желаете удалить для ускорения поиска.
5) В поле Добавить новое расширение введите расширение имени файла, которые Вы желаете добавить для ускорения поиска, а затем нажмите кнопку Добавить.
6) Установите переключатель в значение Индексировать только свойства при большом количестве выделенных расширений или Индексировать свойства и содержимое файлов при небольшом, а затем нажмите кнопку ОК.

21. Выполнение задачи (запуск программы) после выхода из спящего режима или гибернации.

Чтобы запустить какую-либо программу при выходе из гибернации Вам придется воспользоваться планировщиком заданий.
При выходе системы из спящего режима или гибернации Windows 7 записывает событие с номером 300 в один из журналов событий.
Вы можете посмотреть это в оснастке Просмотр событий (Win   + R → eventvwr.msc → ОК) открыв: Журналов приложений и служб → Microsoft → Windows → Diagnostics-Performance
Использовав данный факт Вы сможете создать необходимую Вам задачу. Для ее создания выполните указанные ниже действия:

1) В строке поиска меню Пуск введите: план и выберите в найденном Планировщик заданий.
2) В правой панели планировщика щелкните Создать простую задачу.
3) Введите имя задачи и нажмите Далее.
4) На странице Триггер задачи установите переключатель в значение При занесении в журнал указанного события и нажмите кнопку Далее.
5) На странице При записи определенного события в журнал укажите нижеследующие значения для параметров и нажмите кнопку Далее.

Журнал: Microsoft-Windows-Diagnostics-Performance
Источник: Diagnostics-Performance
Код события: 300

6) На странице Действие установите переключатель в значение Запустить программу и нажмите кнопку Далее.
7) На странице Запуск программы укажите путь к Вашей программе и дополнительные параметры, если необходимо.

Например, для установки VPN-подключения введите в поле Программа или сценарий:команду rasdial "имя подключения" login password
вместо "имя подключения" - укажите название Вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету

8) Если откроется окно информирующее о том, что Вы включили аргументы в текстовое поле "Программы", то нажмите кнопку Да
9) На странице Сводка нажмите кнопку Готово.
10) Дважды щелкните на созданную Вами задачу в списке, чтобы открыть ее Свойства
11) Перейдите на вкладку Параметры
12) Поставьте флажки напротив:

Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.

13) Уберите флажок Останавливать задачу выполняемую дольше .
14) Если у Вас ноутбук, то перейдите на вкладку Условия и снимите флажок Запускать только при питании от электросети
15) Нажмите кнопку ОК для принятия внесенных изменений.

22. Автоматическая очистка журнала недавно открывавшихся документов при выходе из системы.

Если Вам необходимо при выходе из Windows очистить историю папки «Недавние документы», то Вы можете сделать это воспользовавшись одним из предложенных ниже решений.

Вариант 1. Автоматически, используя оснастку Редактор локальной групповой политики.

1) В строке поиска меню Пуск введите gpedit.msc и нажмите Enter ↵.
2) Перейдите с следующую папку: Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач.
3) Щелкните дважды на пункт Очищать журнал недавно открывавшихся документов при выходе или щелкните правой кнопкой мыши на нем и выберите Изменить.
4) Установите переключатель в значение Включить и нажмите кнопку ОК.
5) Перезагрузите компьютер.

Вариант 2. Автоматически, используя редактор реестра.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте Dword-параметр ClearRecentDocsOnExit и установите его значение равным 1.
4) Перезагрузите компьютер.

23. Отключение автоматической загрузки процесса sidebar.exe (Гаджеты рабочего стола Windows).

Вариант 1.

1) Откройте Пуск → Панель управления → Программы и компоненты.
2) В списке слева нажмите Включение или отключение компонентов Windows.
3) Cнимите флажок Платформа гаджетов Windows и нажмите OK.
4) Перезагрузите компьютер.

Вариант 2.

1) В строке поиска меню Пуск, введите gpedit.msc и нажмите Enter ↵.
2) В меню слева перейдите Политика «Локальный компьютер» → Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Гаджеты рабочего стола
3) Дважды щелкните на параметр Отключить гаджеты рабочего стола или нажмите на нем правой кнопкой мыши и выберите пункт Изменить.
4) Установите переключатель в значение Включить и нажмите OK.
5) Перезагрузите компьютер.

Вариант 3.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте Dword-параметр TurnOffSidebar и установите его значение равным 1.
4) Проверьте присутствует ли в одном из указанных ниже разделов, отвечающих за автозагрузку параметр Sidebar. В случае его обнаружения - удалите его.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

5) Перезагрузите компьютер.

24. Удаление компонента Windows Media Center или отключение его автозапуска.

Вариант 1. Удаление компонента Windows Media Center из системы.

1) Откройте Пуск → Панель управления → Программы и компоненты.
2) В списке слева нажмите Включение или отключение компонентов Windows.
3) В группе Компоненты для работы с мультимедиа снимите флажок Windows Media Center.
4) Перезагрузите компьютер.

Вариант 2. Отключение автозапуска Windows Media Center.

1) Запустите Windows Media Center
2) Перейтите в меню Задачи → Настройка → Общие → Запуск и Поведение
3) Снимите флажок Запускать Windows Media Center при запуске Windows и нажмите Сохранить
4) Откройте Пуск → Панель Управления → Администрирование и запустите Службы (services.msc)
5) Установите Тип запуска для указанных ниже служб в значение Вручную или Отключена.
Для изменения значения параметра дважды щелкните по необходимой Вам службе или щелкните на ней правой кнопкой мыши и выберите пункт Свойства.

Служба медиаприставки Media Center
Служба планировщика Windows Media Center
Служба ресивера Windows Media Center

6) Запустите Редактор реестра (Win   + R → regedit → ОК)
7) Удалите параметр ehTray из разделов реестра отвечающих за автозапуск:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

6) Перезагрузите компьютер.

25. Отключение индексирования файлов для ускорения работы Windows.

Если Вы редко используете поиск файлов на компьютере, то Вы можете добавить быстродействия своей операционной системе, отключив индексирование файлов.
Хотя это и немного замедлит поиск, зато освободит процессорное время и виртуальную память системы.
Для отключения индексирования файлов выполните следующие действия.

1) Откройте Панель управления → Администрирование и запустите Службы (Win   + R → services.msc → ОК)
2) Щелкните дважды на службе Windows Search.
3) Установите тип запуска в значение Отключена и нажмите кнопку ОК.
4) В меню Пуск щелкните правой кнопкой мыши на папку Компьютер и нажмите Открыть.
5) Щелкните правой кнопкой мыши на жестком диске и выберите пункт Свойства.
6) Уберите флажок Разрешить индексировать содержимое файлов на этом диске в дополнение к свойствам файлов и нажмите кнопку ОК.
7) Установите переключатель в значение К диску X:\ и ко всем вложенным папкам и файлам (X:\ - буква Вашего жесткого диска) и нажмите кнопку ОК.
8) Если всплывет окно Отказано в доступе нажмите Продолжить, если всплывет окно Ошибка изменения атрибутов, то выберите пункт Пропустить все.
9) Перезагрузите компьютер.

26. Изменение времени затрачиваемого на автоматический выбор пункта из списка загрузок.

Если Вы желаете уменьшить или увеличить количество времени затрачиваемого на автоматический выбор пункта из списка загрузок, то воспользуйтесь указанным ниже решением.

1.1) Откройте меню Пуск, щелкните правой кнопкой кнопкой мыши на Компьютер и выберите пункт Свойства.

или

1.2) Откройте Пуск → Панель управления → Система.

2) Нажмите на ссылку Дополнительные параметры системы.
3) В разделе Загрузка и восстановление нажмите кнопку Параметры.
4) Установите флажок напротив пункта Отображать список операционных систем, если он не установлен.
5) Введите необходимое Вам значение в секундах от 1 до 999 и нажмите кнопку ОК.

27. Просмотр списка устройств, которым разрешено выводить компьютер из ждущего режима, а также разрешение и запрет выполнения данного действия.

Чтобы показать список, каким устройствам разрешено выводить Ваш компьютер из ждущего, выполните указанные ниже действия.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды и нажмите Enter ↵.

Чтобы запретить какому-либо устройству выводить Ваш компьютер из ждущего, выполните указанные ниже действия.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды и нажмите Enter ↵.

где, имя устройства - полное имя устройства, из списка полученного с помощью команды powercfg -devicequery wake_armed или указанное в Диспетчере устройств.

Чтобы разрешить какому-либо устройству выводить Ваш компьютер из ждущего, выполните указанные ниже действия.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды и нажмите Enter ↵.

где, имя устройства - полное имя устройства, из списка полученного с помощью команды powercfg -devicequery wake_armed или указанное в Диспетчере устройств.

28. Изменение количества используемых ядер процессора и приоритета для запущенного приложения.

Если Вы запустите несколько копий одной программы одновременно для выполнения одинаковых действий (Например, расшифровка забытого Вами пароля для файла), то нагрузка на ядра процессора может быть неправильной.
Чтобы равномерно распределить загрузки на все ядра процессора, рекомендуется для каждого процесса запущенной программы, указать используемые ядра процессора вручную.

Для осуществление этого, выполните указанные ниже действия.

1) Откройте Диспетчер задач Windows, для этого одновременно нажмите Ctrl + ⇑ Shift + Esc
2) Перейдите на вкладку Процессы.
3) В главном меню выберите Вид → Выбрать столбцы... установите флажок напротив пункта Путь к образу и нажмите кнопку ОК.
Это позволит Вам легче найти, необходимый процесс программы, учитывая ее месторасположение.
4) Нажмите правой кнопкой мыши на процесс, соответствующий запущенной программе и выберите пункт Задать соответствие.
5) Установите флажки напротив ядер процессора, которые Вы желаете использовать для данной копии программы и нажмите кнопку ОК.
6) Перейдите к следующей копии процесса запущенной программы и повторите действия указанные в пунктах 4) и 5).

Если кроме программы с которой Вы работаете запущенны одновременно другие программы, которые Вам менее необходимы на данный момент, то Вы можете изменить для них приоритет на более низкий.

Для осуществление этого, выполните указанные ниже действия.

1) Откройте Диспетчер задач Windows, для этого одновременно нажмите Ctrl + ⇑ Shift + Esc
2) Перейдите на вкладку Процессы.
3) В главном меню выберите Вид → Выбрать столбцы... установите флажок напротив пункта Путь к образу и нажмите кнопку ОК.
Это позволит Вам легче найти, необходимый процесс программы, учитывая ее месторасположение.
4) Нажмите правой кнопкой мыши на процесс, соответствующий запущенной программе и выберите пункт Приоритет.
5) Из всплывающего списка выберите пункт Низкий или Ниже среднего.
6) После окончания работы с основной программой рекомендуется вернуть значение приоритета для дополнительных программ в изначальное.


Устранение неполадок.

Устранение неполадок - Администрирование и Интерфейс.

1. Общие рекомендации для устранения неполадок и восстановления работоспособности системы.

Перед тем, как попытаться найти решение для какой-либо проблемы в системе, воспользуйтесь общими рекомендациями для восстановления работоспособности системы.

Вариант 1. Использование точки восстановления.

Используйте данный вариант для возврата системных файлов и параметров к состоянию на определенный момент времени.
В процессе восстановления будут удалены все программы и драйверы, которые были установлены в систему, после выбранной Вами точки восстановления.
Ваши документы (текстовые файлы, рисунки и т.п.) восстановлением затронуты не будут.

1) Нажмите кнопку Пуск.
2.1) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства
или
2.2) В адресной строке Проводника введите Панель управления\Система и безопасность\Система и нажмите Enter ↵.
3) Слева нажмите ссылку Защита системы.
4) В открывшемся окне нажмите кнопку Восстановление.
5) Нажмите кнопку Далее.
6) Установите флажок "Показать другие точки восстановления".
7) Выберите желаемую точку восстановления из списка и нажмите кнопку Далее.
8) Нажмите кнопку "Поиск затрагиваемых программ" для уточнения какие программы и драйверы будут удалены и восстановлены.
9) Нажмите кнопку Закрыть, и если выбранная Вами точка восстановления Вам подходит, то нажмите кнопку Далее.
10) Нажмите кнопку Готово, а затем кнопку Да.

Вариант 2. Проверка диска на наличие ошибок.

Используйте данный вариант для проверки системного диска на наличие ошибок и их исправления.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵.

где:
c: - Системный диск на который у Вас установлена Windows.
/f - парамер, отвечающий за исправление всех ошибок, найденных на диске
/r - парамер, отвечающий за восстановление информации, поддающейся чтению, на поврежденных секторах диска

3) Введите английскую букву y и нажмите Enter ↵.
4) Перезагрузите компьютер.

Вариант 3. Восстановление измененных системных файлов.

Используйте данный вариант для проверки целостности всех защищенных системных файлов и замены неправильных версий правильными.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵.

Вариант 4. Использование средств устранения неполадок.

Используйте данный вариант для автоматического разрешения некоторых распространенных проблем, таких как проблемы при работе с сетью, аппаратным обеспечением и устройствами, проблемы с использованием Интернета, а также проблемы совместимости программ.

1.1) В адресной строке Проводника введите Панель управления\Все элементы панели управления\Устранение неполадок и нажмите Enter ↵.
или
1.2) Нажмите Win   + R, введите указанную ниже команду и нажмите Enter ↵.

2) Слева нажмите ссылку Просмотр всех категорий.
3) В соответствии с описанием запустите необходимое Вам средство устранения неполадок.
4) Щелкните ссылку Дополнительно и снимите флажок Автоматически применять исправления
5) Нажмите кнопку Далее
6) Выбирайте в диалоговом окне ответы на уточняющие вопросы и снова нажимайте кнопку Далее, чтобы продолжить.

Вариант 5. Удаление (восстановление) неправильно работающих программ.

Используйте данный вариант для удаления программ установленных без Вашего ведома или для устранения проблем с неправильно работающими установленными программами.

1.1) В адресной строке Проводника введите Панель управления\Программы\Программы и компоненты и нажмите Enter ↵.
или
1.2) Нажмите Win   + R, введите команду appwiz.cpl и нажмите Enter ↵.
2) Щелкните правой кнопкой мыши на необходимой Вам программе из списка и нажмите Удалить или на пункт Восстановить (если он есть).
Если удаленная Вами программа относится к категории необходимых, то попробуйте найти и установить другую ее версию (более раннюю или более позднюю).

Вариант 6. Удаление программ запускающихся автоматически при запуске Windows.

Используйте данный вариант для отключения программ, стороннних служб, драйверов или назначенных заданий, запускающихся при запуске компьютера.

1) Скачайте и запустите программу Sysinternals AutoRuns (английская версия или русская версия)
2) Для отключения элементов (программ, стороннних служб, драйверов и т.д.), которые не нужно запускать автоматически при запуске системы, снимите флажки рядом с их названиями.
Для полного удаления из автозагрузки, выделите в списке необходимый Вам элемент и нажмите клавишу Delete, а затем клавишу Enter ↵.

Вариант 7. Очистка жесткого диска.

Используйте данный вариант для удаления временных файлов, очистки корзины и удаления других элементов, которые могут вызывать неполадки в работе системы.

1) Нажмите Win   + R, введите команду cleanmgr и нажмите Enter ↵.
2) Выберите диск на который у Вас установлена Windows (По умолчанию диск C:) и нажмите кнопку ОК.
3) Нажмите кнопку Очистить системные файлы и введите пароль администратора, если требуется.
Если Вы работаете с отключенным Контролем учетных записей, то системные файлы доступные для удаления, будут сразу отображены в общем списке.
4) Установите флажки для тех типов файлов, которые требуется удалить, и нажмите кнопку ОК. Желательно установить флажки для всех типов файлов.
5) В окне сообщения нажмите кнопку Удалить файлы.

Вариант 8. Установка последних обновлений.

Используйте данный вариант для устранения проблем связанных с неправильной работой программ, драйверов или проблем с безопасностью.

1.1) В адресной строке Проводника введите Панель управления\Все элементы панели управления\Центр обновления Windows и нажмите Enter ↵.
или
1.2) Нажмите Win   + R, введите указанную ниже команду и нажмите Enter ↵.

2) Слева нажмите ссылку Поиск обновлений и подождите, пока Windows выполнит поиск последних обновлений для вашего компьютера.
3) Нажмите кнопку Установить обновления.

Остальные варианты:

1) Перезагрузите несколько раз компьютер с периодичностью в несколько часов.
Перезагрузка позволит Вам очистить память и завершить ошибочные процессы и службы, которые начали работу.

2) Установите наиболее подходящие (самые новые или более старые) драйвера для имеющегося в Вашей системе оборудования.
Подборка правильных драйверов позволит Вам исправить некорректную работу устройства и улучшить его функциональность.

3) Проверьте Ваш компьютер с помощью антивирусных и антишпионских программ.
Их использование может помочь Вам освободится от устанавленных без Вашего ведома следящих программ, появления неожиданных всплывающих сообщений, самостоятельного запуска программ, звука постоянно работающего жесткого диска.

2. Использование оснастки «Просмотр событий» для выявления неполадок в работе Windows.

Каждые произошедшие в Windows события (Предупреждения, Сведения или Ошибки) записываются в Журналы событий.
Если Вам кажется, что в работе системы наблюдаются какие-то неполадки, то для анализа произошедших событий и выявления среди них ошибок требующих исправления, Вы можете воспользоваться оснасткой «Просмотр событий».

Вы можете запустить данную оснастку любым из указанных ниже вариантов.

1) В строке поиска меню Пуск введите слово просмотр и нажмите на Просмотр событий.
2) Нажмите комбинацию клавиш Win   + R, введите eventvwr.msc и нажмите Enter ↵.
3) Откройте меню Пуск, и выберите во всплывающем меню Администрирование пункт Просмотр событий.
4) Откройте меню Пуск и щелкните правой кнопкой мыши на значке Кoмпьютер, выберите из контекстного меню пункт Управление, в открывшемся окне разверните элемент Служебные программы и щелкните на Просмотр событий.

Все журналы разделены на две категории: Журналы Windows и Журналы приложений и служб, каждая из них объединяет в себе несколько других журналов.

Журналы Windows:

Приложение

В указанном журнале содержатся данные, относящиеся к работе приложений и программ. События, регистрируемые в журнале приложений, определяются разработчиками соответствующих приложений.

Безопасность

Данный журнал содержит такие события, как успешные и неуспешные попытки входа в систему, а также события, относящиеся к использованию ресурсов, такие как создание, открытие и удаление файлов и других объектов.

Установка

В этом журнале содержатся данные, относящиеся к установке приложений.

Система

Данный журнал содержит события, записываемые системными компонентами Windows. Например, в журнале системы регистрируются сбои при загрузке драйвера или других системных компонентов в процессе загрузки системы. Типы событий, которые регистрируются компонентами системы, определены на уровне операционной системы.

Перенаправленные события

Данный журнал используется для хранения событий, собранных с удаленных компьютеров.

Журналы приложений и служб

В этих журналах хранятся события из отдельных приложений или компонентов, а не события, способные повлиять на работоспособность всей системы. Также в них хранятся сведния о неполадках в работе оборудования. Кроме описания, зачастую в комментарии к произошедшему событию можно найти подсказку помогающую быстрее найти решение в сложившийся ситуации.
Данные журналы представляют большей частью интерес для анализа и диагностики проблем или событий у ИТ-специалистов и зачастую не предназначены для обычных пользователей.

3. Решение проблемы с доступом к wim-файлу при работе с программой Dism.

При возникновении ошибок с доступом при работе с wim файлом в программе DISM, Вы можете воспользоваться одним из предложенных вариантов.

Вариант 1. Новые имена папок.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

3) Создаете новую папку для wim-файла и переместите в нее Ваш wim-файл. (Например: вместо текущей папки mWim, создайте новую mWim1)
4) Создайте новую папку, куда Вы будете монтировать Ваш wim-файл для работы. (Например: вместо текущей папки Mount, создайте новую Mount1)
5) Продолжайте работу с новыми папками.

Вариант 2. Старые имена папок.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

3) Переместите Ваш wim-файл в любую другую папку.
4) Удалите папки, которые Вы использовали для wim-файла и монтирования индекса.
5) Создайте заново папки с теми же названиями.
6) Верните wim-файл обратно.
7) Продолжайте работу с теми же папками, что и раньше.

4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Если у Вас возникли проблемы с отображением иконок, то Вам может помочь удаление кэша иконок или изменение его размера.
После удаления кэша - иконки вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов.

Для очистки кэша иконок.

1) В Проводнике откройте папку %USERPROFILE%\AppData\Local\ и удалите файл IconCache.db
2) Перезагрузите компьютер или перезайдите в Windows.

Также Вы можете добавить пункт Rebuild Icon Cache в контекстное меню папок в Проводника. Выбор данного пункта приведет к удалению файла IconCache.db и перезапуску Проводника.
Для добавления указанного пункта в меню:

1) Скачайте и распакуйте архив: Rebuild_Icon_Cache_v2.zip
2) Запустите файл Rebuild Icon Cache.exe. Данное действие скопирует скрипт Rebuild Icon Cache.Vbs в папку Windows.
3) Примените один из reg-файлов:

Install(Bottom).reg - для добавления пункта Rebuild Icon Cache в нижнюю часть контекстного меню папок.
Install(Middle).reg - для добавления пункта Rebuild Icon Cache в среднюю часть контекстного меню папок.
Install(Top).reg - для добавления пункта Rebuild Icon Cache в верхнюю часть контекстного меню папок.

Для увеличения размера кэша иконок.

Создайте и примените reg-файл указанного ниже содержания:

5. Причины перехода цветовой схемы на упрощенный стиль.

Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter ↵
или
1.2) Нажмите Win   + R и введите команду в диалоговом окне Выполнить

2) Нажмите Далее

6. Выбор настроек во время установки для предотвращения замены русских букв знаками вопросов.

На начальном этапе установки выводится окно, содержащее три строчки.
Первая строчка - язык, на котором работает система (английский US или русский RU). При возможности выберите русский.
Вторая строчка - месторасположение компьютера, для выбора страны (от Афганистана и до Ямайки). Выберите страну - Russian Federation.
Третья строчка - язык раскладки клавиатуры по умолчанию. При выборе во второй строчке страны (РФ), здесь автоматически устанавливается русский. Вы можете выбрать здесь любой используемый Вами язык раскладки клавиатуры.

7. Решение проблемы с неправильным отображением русских букв.

Вариант 1.

1.1) Запустите редактор реестра: Win   + R → regedit → ОК или введите regedit в строке поика меню Пуск и нажмите Enter ↵.
1.2) Откройте ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
1.3) Измените значение параметра 1252 с "c_1252.nls" на "c_1251.nls"
1.4) Откройте папку C:\WINDOWS\system32\ и найдите файлы c_1251.nls и c_1252.nls и задайте полный доступ к данным файлам.
1.5) Переименуйте файл c_1252.nls в c_1252.bak.
1.6) Создайте здесь же копию файла c_1251.nls.
1.6.1) Щелкните правой кнопкой мыши на файле и выберите Копировать.
1.6.2) Щелкните правой кнопкой мыши в пустом месте папки C:\WINDOWS\system32\ и выберите Вставить.
1.7) Переименуйте c_1251 - копия.nls в c_1252.nls. В итоге файл c_1252.nls, должен быть переименованной копией c_1251.nls
1.8) Перезагрузите компьютер.
Для 64-битной версии, при необходимости, выполните указанные выше действия в папке C:\Windows\SysWOW64

Если у Вас установлена Русская Windows или Английская+русский MUI, то проделайте также следующее:

2.1) Запустите редактор реестра: Win   + R → regedit → ОК или введите regedit в строке поиска меню Пуск и нажмите Enter ↵.
2.2) Откройте ветку реестра HKEY_CURRENT_USER\Control Panel\International
2.3) Проверьте значение параметров Locale и LocaleName
Параметр Locale должен иметь значение 00000419, а параметр LocaleName должен иметь значение ru-RU
2.4) Если значения параметров другие: дважды щелкните на параметре, который необходимо изменить, введите необходимое значение параметра и нажмите OK.
2.5) Перезагрузите компьютер.

3.1) Откройте Язык и региональные стандарты.
Пуск → Панель управления → Язык и региональные стандарты (или Win   + R → control /name Microsoft.RegionAndLanguage → ОК)
3.2) Перейдите на вкладку Дополнительно. Можете сразу открыть её: Win   + R → control intl.cpl,,3 → ОК
3.3) В блоке Язык программ, не поддерживающих Юникод нажмите на кнопку Изменить язык системы
3.4) Выберите язык системы Русский (Россия) и нажмите ОК.

Вариант 2.

1) Скачайте и распакуйте файл: RusCodePage.zip
2) Откройте необходимую папку для запуска командного файла.

Windows 7 English + Russian MUI - откройте данную папку, если у Вас установлена английская версия+русский языковой пакет, так как группа администраторов обозначается как administrators.
Windows 7 Russian - откройте данную папку, если у Вас установлена русская версия, так как группа администраторов обозначается как администраторы.

3) В соответствии с разрядностью Вашей системы запустите bat-файл.

Для восстановления значений по умолчанию примените bat-файл содержащий в названии файла слово Default.

Вариант 3.

Если у Вас установлена английская Windows 7 и Язык программ, не поддерживающих Юникод установлен в значение Russian (Russia), то попробуйте следующее:

1) Откройте Region and Language.
Start → Control Panel → Region and Language (или Win   + R → control intl.cpl → ОК)
2) В ниспадающем списке под словом Format: выберите любое значение отличающееся от Вашего (Например: English (Belize)) и нажмите кнопку Apply.
3) В ниспадающем списке под словом Format: выберите значение Russian (Russia) и нажмите кнопку Apply.
4) Перейдите на вкладку Keyboards and Languages и нажмите на кнопку Change keyboards...
5) Выделите раскладку клавиатуры соответствующую языку выбранному Вами на втором шаге (Например: English (Belize)) и нажмите кнопку Remove.
6) Нажмите кнопку ОК и еще раз кнопку ОК для применения настроек.

8. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести имя файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

Если при попытке выходе из спящего/ждущего режима Вы попадаете в черный экран или в BSOD (синий экран смерти) Вы можете попробовать несколько способов. Первым делом, скачайте и установите более новые версии драйверов для Вашей видеокарты, чем те что у Вас есть.

Вариант 1. Изменение настроек BIOS:

1) Во времени загрузки зайдите в BIOS (для этого нажмите клавишу Delete после начала загрузки компьютера)
2) В BIOS пройдите на вкладку Power
3) Попробуйте изменить значение параметра Suspend Mode (Auto, S1 (POS) Only, S3 Only) названия может отличаться, ищите похожие со значениями S1, S3.
4) Также попробуйте включить\отключить ACPI 2.0 Support → Enabled\Disabled

Вариант 2. Запрет вывода из спящего режима используя USB мышь или USB клавиатуру.

Некоторые USB-устройства неправильно поддерживают спящий режим Windows. Два основных устройства с помощью которых Вы можете выйти из спящего режима - это клавиатура и мышь. Одно из них может блокировать Вам выход, в таком случае ему надо просто запретить это делать. Внимание: Не запрещайте одновременно клавиатуре и мыши, иначе Вы не сможете выйти из него.

1) Запустите Диспетчер устройств. Для этого пройдите в Пуск → Выполнить (или Win   + R) → devmgmt.msc → OK
2) В Диспетчере устройств разверните узел Мыши и иные указывающие устройства или Клавиатуры
3) Щелкните правой кнопкой на USB-мышь или USB-клавиатуру и выберите пункт Свойства.
4) Откройте вкладку Управление электропитанием.
5) Снимите флажок Разрешить устройству вывод компьютера из спящего режима и нажмите кнопку ОК.

Вариант 3. Отключение спящего/ждущего режима.

1) Пройдите в Пуск → Выполнить (Win   + R) → powercfg.cpl → OK
2) Выберите слева пункт Настройка перехода в спящий режим
3) Присвойте обоим параметрам: Отключать дисплей и Переводить компьютер в спящий режим, значение - Никогда.
Также можно отключить и функцию сна. Выберите пункт "Изменить дополнительные параметры питания". Найдите в окне режим Сон, разверните Сон после и установите значение находящихся там параметров на Никогда
Если несмотря на проделанное выше, компьютер по прежнему продолжает отключаться, то Вам необходимо выполнить ещё некоторые действия:
4) Скачайте reg-файл PowerSettings.reg и примените его.
5) Откройте вкладку Сон
6) Установите следующие значения параметрам, открыв их вкладки:
6.1) Сон после - значение равным 0, оно идентично значению Никогда
6.2) Разрешить политику требуемую системой - значение Да (это предотвратит автоматический переход в ждущий режим)
6.3) Разрешить таймеры пробуждения - Включить (позволит автоматически выводить компьютер из спящего режима при помощи заданных событий)
7) Если у Вас одно из устройств USB например мышь, а второе клавиатура PS/2, то Вы можете отключать USB порт на время работы спящего режима.
Откройте вкладку Параметры USB, а в ней вкладку Параметр временного отключения USB-порта и установите значение в Разрешено.
8) Нажмите OK

10. Восстановление загрузки Windows 7 без установочного диска.

Вариант 1. Автоматически - при помощи среды восстановления Windows RE в Windows 7.

Во время установки Windows 7 на жестком диске автоматически создается служебный раздел, обеспечивающий доступ в среду восстановления Windows RE (Recovery Environment). Используя данный служебный раздел, Вы можете:

- загрузиться в среду восстановления с жесткого диска
- создать компакт-диск, содержащий среду восстановления

1) Выполните загрузку в среду восстановления с жесткого диска или диска восстановления системы.
Для того чтобы войти в меню Дополнительные варианты загрузки, нажмитеF8 после включения компьютера (но до загрузки операционной системы).
2) Выберите первый пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter ↵.
3) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи.
4) Введите пароль администратора. После ввода пароля вы увидите окно с вариантами восстановления.
5) Выберите пункт Восстановление запуска(Startup repair), также иногда может помочь пункт Восстановление системы (System Restore), позволяющий вернуться к точке, созданной до возникновения проблемы.

Вариант 2. Восстановление вручную, с созданием мультизагрузочного меню.

Здесь главное - это добраться до командной строки для введения дальнейших команд.

1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe; Bootrec.exe).
2) Создайте папку Boot.
3) Распакуйте скачанный архив и скопируйте файлы нужной Вам битности в созданную Вами папку Boot.
4) Запустите среду необходимую для работы:
5) Загрузитесь в Windows, установленную на другой диск или в среду восстановления (На жестком диске запускается нажатием, клавишиF8. Если клавишаF8 используется материнской платой, после выбора диска нажмитеF8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter ↵)
6) Запустите командную строку.
В Windows: Win   + R → cmd → ОК.
В среде восстановления: Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt)

Далее все команды вводимые в командную строку будут одинаковы как в Windows, так и в среде восстановления.

1) Windows 7 использует усовершенствованный метод загрузки - хранилище данных конфигурации загрузки. Это хранилище содержит все сведения обо всех операционных системах, установленных на компьютере. Следовательно, загрузчики более ранних операционных систем Windows, не могут быть использованы для ее запуска. Итак, для восстановления, загрузочного сектора Windows 7, перезаписываем загрузочный сектор на всех разделах:

где Х - буква диска, на котором содержится программа Bootsect.exe
2) Если у Вас вторая система Windows XP, то Вам необходимо выполнить ещё ряд действий:

Создайте в хранилище загрузки Windows 7 - хранилище для загрузки Windows XP.

Если же система откажется это делать, значит данное хранилище уже создано, поэтому необходимо его только переименовать:

Далее укажите загрузчику Windows 7 устройство расположения файлов загрузки Windows XP:

Затем укажите загрузчику Windows 7 путь к загрузчику Windows XP:

После добавьте строчку о выборе Windows XP в меню загрузки и расположив ее под остальными:

Также для работы с загрузчиками, Вы можете воспользоваться программой EasyBCD, позволяющей выполнять указанные выше действия, используя графический интерфейс.

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Вариант 3. Восстановление вручную, при помощи bootrec.exe.

1) Загрузитесь в среду восстановления (На жестком диске запускается нажатием, клавишиF8. Если клавишаF8 используется материнской платой, после выбора диска нажмитеF8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter ↵)
2) Выберите операционную систему, которую необходимо восстановить, и нажмите "Next"("Далее").
3) В окне Опции системы восстановления (System Recovery Options) выберите пункт Командная строка (Command Prompt).
4) Откроется окно интерпретатора командной строки cmd.exe, где следует ввести:

Параметр /FixMbr записывает в системный раздел основную загрузочную запись, совместимую с Windows 7. Этот параметр не перезаписывает существующую таблицу разделов. Данный параметр следует использовать для устранения проблем, связанных с повреждением основной загрузочной записи, или если необходимо удалить из основной загрузочной записи нестандартный код.

Параметр /FixBoot записывает в системный раздел новый загрузочный сектор с использованием загрузочного сектора, совместимого с Windows 7. Этот параметр следует использовать, если выполняется хотя бы одно из перечисленных ниже условий.

- Загрузочный сектор Windows 7 был заменен нестандартным загрузочным сектором
- Загрузочный сектор поврежден
- После установки Windows 7 на компьютер была установлена более ранняя версия операционной системы Windows. В данном случае для запуска компьютера вместо диспетчера загрузки Windows (Bootmgr.exe) используется загрузчик Windows NT (NTLDR).

Параметр /RebuildBcd выполняет поиск установленных операционных систем, совместимых с Windows 7, на всех дисках. Кроме того, этот параметр позволяет выбрать установленные системы, которые необходимо добавить в хранилище данных конфигурации загрузки. Этот параметр следует использовать в том случае, если необходимо выполнить полную перестройку данных конфигурации загрузки.

Если Вы не запомнили необходимого Вам значения Вы можете просто ввести:

и утилита выведет справку по доступным ключам командной строки.

11. Восстановление стандартного анимированного экрана загрузки Windows 7.

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, после неудачно внесенных различного рода изменений в загрузчик ОС. Предлагаю Вам простые и действенные решения:

Вариант 1

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду и нажмите Enter ↵: sfc /scannow

Вариант 2

1. Откройте командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2. В открытом окне консоли введите команду:

Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Закройте окно командной строки.
4. Перезагрузите Ваш компьютер.

Вариант 3

1) Откройте диалоговое меню Выполнить: Пуск → Выполнить (или Win   + R)
2) В открытом окне консоли введите команду: msconfig и нажмите OK
3) Перейдите на вкладку "Загрузка" и проверьте не установлен ли флажок напротив значения "Без GUI". Если флажок установлен - снимите его.
4) Закройте окно Конфигурации системы.
5) Перезагрузите компьютер

12. Восстановление значений реестра и асоциаций с программами по умолчанию для различных типов файлов.

Если у Вас возникли проблемы при открытии каких-либо файлов с расширениями определенного типа, исчезла или неправильно отображается иконка для них или пропали записи в реестре, то Вы можете восстановить для данного типа файлов изначальные настройки.

Чтобы применить необходимый Вам reg-файл для восстановления настроек для файлов с заданным расширением:

1) Скачайте архив Restore_Default_File_Extentions.zip и распакуйте в любую папку архив.
2) Щелкните правой кнопкой мыши на reg-файле, содержащем в своем названии, расширение файла для которого Вы желаете восстановить настройки в реестре по умолчанию.
3) Выберите пункт Слияние, а затем нажмите Да → ОК.

или

1) Удерживая нажатой клавишу ⇑ Shift, щелкните правой кнопкой мыши на папке куда Вы распаковали архив и выберите пункт Открыть окно команд.
2) Введите используя команду, используя указанный ниже шаблон и нажмите Enter ↵.

где XXX обозначает необходимое Вам расширение файла.

13. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

14. Исправление невозможности запуска службы Центра обеспечения безопасности.

1) Отключены компоненты от которых зависит данная служба.

1.1) Откройте: Администрирование → Службы
1.2) Проверьте включены ли следующие службы:

- Инструментарий управления Windows
- Удаленный вызов процедур (RPC)
- Модуль запуска процессов DCOM-сервера
- Сопоставитель конечных точек RPC

2) Восстановите начальные параметры в реестре, используя значения с компьютера, на котором данная служба работает.

2.1) Загрузите и примените готовый reg-файл. wscsvc.zip

15. Исправление отсутствия компонентов в окне "Включение или отключение компонентов Windows".

1.1) Запустите редактор реестра: Win   + R → regedit → ОК
1.2) Откройте ветку реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows
1.3) Измените значение параметра CSDVersion на 0.
1.4) Перезагрузите компьютер

2) В соответствии с разрядностью и языком Вашей Windows, скачайте и установите обновление KB947821:

Windows6.1-KB947821-v26-x86.msu
Windows6.1-KB947821-v26-x64.msu

16. Исправление невозможности изменения настроек User Account Control (UAC).

В разделе Панели управления Системы и безопасность Вы можете изменить параметры контроля учетных записей User Account Control (UAC).
Если у Вас при работе в диалоговом окне Параметры управления учетными записями пользователей после перемещения ползунка управления и нажатия кнопки ОК или клавиши Enter ↵, диалоговое окно не закрывается, и/или не вносятся никакие изменения, то вероятнее всего у Вас произошел сбой Реестра.
Вы можете восстановить нормальную работу User Account Control (UAC) одним из 2 способов.

Вариант 1. С помощью специального дополнения от Microsoft.

Скачайте и запустите файл: fixit_kb978591.diagcab

Вариант 2. При помощи созданного Вами reg-файла.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "UAC.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Примените полученный файл UAC.reg (Двойной щелчок → Да)

Готовый reg-файл Вы можете скачать по ссылке: uac_repair.zip.

17. Диагностика проблемы высокой загрузки процессора и частых обращений к жесткому диску при запуске или выключении Windows.

Чтобы определить какая программа или драйвер больше всего загружает Ваш процессор, Вам понадобиться программа от Microsoft - Windows Performance Tools Kit и в дополнение к ней программа XPerfUI от Richard Macdonald, при координации Microsoft.

1) В соответствии с Вашей разрядностью, скачиваете архив: wpt_x86.zip - для 32-бит или wpt_x64.zip - для 64-бит.
2) Устанавливаете программу Windows Performance Tools Kit
3) Копируйте файл XPerfUI.exe в папку с установленной программой и запускаете его.

4) Используя всплывающее меню открываете Tools → Trace Session → Boot Trace
5) В блоке Trace Type выбираете, для какого действия Вы хотите провести диагностику: Boot (для анализа запуска) или Shutdown (для анализа выключения)
6) В блоке Trace Flags устанавливаете переключатель на значение Base, дополнительно отмечаете пункты CSWITCH, DRIVERS, POWER
7) В поле Result path указываете путь, куда будет сохранен результат анализа. (Например: C:\Temp )
8) Нажмите кнопку Start для начала диагностики.

Компьютер перезагрузится.
9) Если Вы выбрали Boot (для анализа запуска), то после перезапуска системы, программа запустит трассировку (процесс пошагового выполнения программы) для данного действия и сохранит результаты в указанную Вами папку.
Если Вы выбрали Shutdown (для анализа выключения), то после перезапуска системы, программа запустит трассировку, снова перезапустит компьютер, снова запустит трассировку и сохранит результаты в указанную Вами папку.

10) Запускаете программу Performance Analyzer. В появившемся окне нажимаете кнопку Да.
Пуск → Все программы → Microsoft Windows Performance Toolkit → Performance Analyzer
или файл xperfview.exe из папки, где установлена программа.
11) Открываете в окне программы (File → Open) etl-файл, являющийся созданным в процессе трассировки log-файлом с результатами анализа. Местом нахождения etl-файла будет папка, указанная Вами при запуске трассировки.
12) Программа загрузит графики.
13) В меню программы нажимаете Graphs и ставите флажок CPU Sampling by Process.
14) В меню программы нажимаете Trace и ставите флажок Load Symbols.
15) Находите график CPU Sampling by Process.
16) Чтобы вывести сводную таблицу, нажимаете на нем правой кнокой мыши и выбираете пункт Summary Table
Процесс с наибольшим значением Weight и будет тем самым процессом, который забирает ресурсы процессора при загрузке или выключении. При нажатии на значок +, рядом с наименованием процесса Вы сможете узнать какой именно файл потребляет больше всего ресурсов процессора.

17) Также Вы можете посмотреть какая программа больше всего делает обращений к жесткому диску. Для этого найдите график Disk I/O в основном окне графиков программы, нажмите на нем правой кнопкой мыши и выберите пункт Summary Table. Процесс с наибольшим значением Service Time и будет тем самым процессом, который больше всего делает обращений к жесткому диску.

18. Устранение проблемы открытия папок в отдельном окне, при установленном положении переключателя "Открывать папки в одном и том же окне".

1) Нажмите Пуск и введите в строке поиска cmd.exe
2) Нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени Администратора".
3) Поочередно введите команды, после написания каждой нажмите Enter ↵.

19. Удаление лишних пунктов из Диспетчера загрузки Windows.

1) Нажмите кнопку Пуск
2) Наберите в строке поиска msconfig и нажмите Enter ↵
3) Перейдите на вкладку Загрузка
4) Выделите строку которую Вы желаете удалить и нажмите кнопку Удалить
5) Нажмите кнопку ОК и перезагрузите компьютер

20. Извлечение файлов Windows 7 из установочного DVD и замена ими поврежденных системных файлов.

Если у Вас в Windows появились поврежденные системные файлы, то Вам нет необходимости сразу переустанавливать Windows, так как Вы можете просто восстановить поврежденный файл используя DVD-диск или образ установочного диска. Вам всего лишь надо удалить имеющийся системный файл и заменить его извлеченным.

Инструкция восстановления системных файлов:

1) Извлеките из установочного диска необходимый файл.
2) Удалите поврежденный файл.
3) Скопируйте на место удаленного файла извлеченный.
4) Перезагрузите компьютер.

Извлечение файлов с диска Windows 7.

Вариант 1. При помощи программы DISM.

Подключение образа в DISM.

1) Вставьте установочный диск Windows 7 в DVD-привод, или смонтируйте ISO-образ.
2) Откройте папку sources и скопируйте из нее файл install.wim на диск D.
Внимание: в качестве папки для подключения образа install.wim НЕЛЬЗЯ использовать корень диска C (тот на котором установлена Windows), так как install.wim содержит системные папки Windows, Program Files, Program Data, Users и др.
3) Создайте папку на диске D и назовите ее, например, Image. В эту папку будет подключен образ install.wim.
4) Откройте Пуск → Все программы → Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
5) Выполните команду:

Пояснения:

dism – встроенная в Windows 7 утилита командной строки, позволяющая подключать образы WIM и управлять ими.
Параметр /Mount-Wim подключает файл WIM.
Параметр /WimFile позволяет указать расположение и имя файла WIM, который нужно подключить.
Параметр /name позволяет указать название выпуска Windows 7, который будет смонтирован.
Параметр /MountDir: указывает папку, в которую будет смонтирован образ WIM.

6) Дождитесь, пока образ подключится. Это может занять несколько минут.
7) Откройте папку D:\Image, найдите в ней (в папках) нужный файл и скопируйте его в любое место на жестком диске.

После копирования нужных файлов образ можно отключить.

Отключение образа в DISM.

1) Закройте все папки и файлы.
2) Откройте Пуск → Все программы → Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
3) Выполните команду:

Пояснения:

Параметр /Unmount-Wim отключает образ.
Параметр /MountDir: указывает папку, в которую смонтирован образ, который нужно отключить.
Параметр /discard отменяет все внесенные в образ изменения.

4) Дождитесь отключения образа.
5) Удалите папку Image и файл install.wim с диска D.

Вариант 2. При помощи программы 7Zip.

1) Скачайте и установите программу 7Zip
2) Cмонтируете образ лицензионного диска с Windows 7 или вставьте установочный DVD-диск.
3) Используя программу 7Zip откройте файл H:\sources\install.wim
где (H:) - буква диска с установкой Windows
4) Откройте в данном файле папку, соответствующую идентичной в системе.
5) Скопируйте файл(простым переносом из программы 7Zip) в идентичную папку в реальной системе.

Способы удаления:

1) Обычное удаление.
Просто нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

2.1) Скачайте и установите программу Unlocker
2.2) Нажмите правой кнопкой мыши на файле и выберите пункт Unlocker.
2.3) В выпадающем меню выберите пункт Удалить и нажмите на кнопку Разблокировать все.

3) Удаление в безопасном режиме.
3.1) Перезагрузите компьютер в безопасный режим.
Для этого нажмите F8 в начале загрузки компьютера до появления логотипа Windows и выберите пункт Безопасный режим.
3.2) Нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

4) Загрузитесь в MSDaRT (ранее ERD Commander).
4.1) Для сопоставления букв дисков целевой операционной системе нажмите Да (Yes).
4.2) В окне выбора опреационной системы не выбирайте никакую систему(должно сняться выделение с какой-либо системы) и нажмите кнопку Далее (Next).
4.3) Нажмите Micosoft Diagnostics and Recovery Toolset → Explorer
4.4) Откройте папку файла, нажмите правой кнопкой мыши на нем и выберите пункт Удалить.

21. Настройка периодичности создания точек восстановления системы.

Чтобы изменить периодичность создания точек восстановления сделайте следующее:

1) Запустите Планировщик заданий. Пуск → Панель управления → Администрирование → Планировщик заданий

2) В дереве слева откройте Библиотека планировщика задач → Microsoft → Windows → SystemRestore

3) Щелкните правой кнопкой мыши в верхнем среднем окне на файл SR и выберите Свойства.

4) В открывшемся окне перейдите на вкладку Триггеры.

5) Нажмите Создать и задайте необходимые Вам временные параметры, либо выберите уже имеющийся триггер (Например, Ежедневно) и нажмите Изменить. Для удаления созданых триггеров выберите его и нажмите Удалить.

6) Нажмите на ОК для принятия изменений.

22. Восстановление веток реестра из резервных копий службы System Restore в Windows 7.

Большая часть системного реестра находится в следующих местах:

Раздел HKEY_CURRENT_USER - в файле C:\Users\ИМЯ_ПОЛЬЗОВАТЕЛЯ\NTUSER.dat.
Все остальные разделы - C:\Windows\system32\config

Если Вам необходимо восстановить какую-то определенную часть системного реестра Windows 7 или Вы хотите посмотреть, какие значения имел определенный ключ, некоторое время назад, то Вам необходимо сделать следующее:

Для примера, получим доступ к предыдущим значениям ключа HKEY_LOCAL_MACHINE\SOFTWARE.

1) Откройте папку C:\Windows\system32. Найдите в ней директорию Config.
2) Щелкните по папке Config правой кнопкой мыши, выберите пункт меню Свойства и перейдите на вкладку Предыдущие версии.
3) Два раза щелкните по папке, относящейся к интересующей вас дате. Вы увидите перечень файлов, для которых доступна предыдущая версия. В данном случае нас интересует файл SOFTWARE, так как именно в нем хранятся ключи раздела HKEY_LOCAL_MACHINE\SOFTWARE.
4) Скопируйте файл в любое удобное вам место, перетащив его в открытое окно Проводника, либо выбрав команду Копировать из контекстного меню файла SOFTWARE.
Предположим, вы поместили его в корень диска D:.
5) Запустите редактор реестра (Пуск → Выполнить → regedit.exe), установите курсор на корневой ключ HKEY_LOCAL_MACHINE и выполните команду главного меню Файл → Загрузить куст...
6) Задайте имя, под которым будет смонтирован файл D:\SOFTWARE (Например: oldsoftware)
7) Доступ к значениям ключей и разделов реестра будет возможен по пути HKEY_LOCAL_MACHINE\oldsoftware.
8) Смонтированный куст представляет собой предыдущую версию HKEY_LOCAL_MACHINE\Software, где Вы можете посмотреть предыдущие значения нужных ключей.
Если значения Вам необходимо поместить в рабочий реестр системы, переходите к следующему пункту.
9) Найдите интересующий Вас ключ или параметр, и экспортируйте его в reg-файл:
10) Выделите ключ, и в его контекстном меню выберите команду Экспортировать.
11) Отредактируйте только что экспортированный файл Блокнотом, заменив все вхождения "\oldsoftware\" на "\SOFTWARE\".
12) Сохраните reg-файл и двойным щелчком мыши по нему импортируйте его в текущий реестр операционной системы.

23. Использование "чистой загрузки" для устранения неполадок в работе Windows.

"Чистая загрузка" - это безопасный режим, в котором компьютер запускается с минимальным количеством работающих программ и служб. Если при запуске компьютера в безопасном режиме ошибок не возникает, это означает, что проблема вызвана одной из программ или служб автозагрузки. В режиме "чистой загрузки" компьютер запускается с отключенными программами и службами автозагрузки, которые затем включаются и отключаются по одной до тех пор, пока источник проблемы не будет локализован.

Действие 1. "Чистая загрузка" системы

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter ↵, чтобы запустить Конфигурация системы.
3) На вкладке Общие установите переключатель на Выборочный запуск
4) Снимите флажок Загружать элементы автозагрузки. (Флажок Использовать оригинальную конфигурацию загрузки недоступен.)
5) Перейдите на вкладку Службы
6) Установите флажок Не отображать службы Майкрософт и нажмите кнопку Отключить все.
7) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 2. Включите половину служб.

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter ↵, чтобы запустить Конфигурация системы.
3) Откройте вкладку Службы и установите флажок Не отображать службы Майкрософт.
4) Установите флажки для половины служб в списке Службы.
5) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 3. Определите возможную причину неисправности.

Если неисправность осталась, повторите действия 1 и 2. В действии 2 снимите в списке Службы установленные флажки.
Если проблема исчезла, повторите действия 1 и 2. В действии 2 установите половину из еще не установленных флажков в списке Службы. Повторяйте эти действия, пока не будут установлены все флажки.
Если в списке Службы осталась выбранной только одна служба и проблема по-прежнему наблюдается, то именно эта служба ее и вызывает.
Если проблема вызвана одной из служб, перейдите к действию 6, в противоположном случае продолжайте поиск неисправности перейдя к действию 4.

Действие 4. Разрешите запуск половины элементов списка автозагрузки.

1) Выполните чистую загрузку, повторив действие 1.
2) Откройте вкладку Автозагрузка и установите флажки для половины элементов списка элементов автозагрузки.
3) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 5. Определите возможную причину неисправности.

Если неисправность осталась, повторите действия 1 и 4. В действии 4 снимите в списке элементов автозагрузки установленные флажки.
Если проблема исчезла, повторите действия 1 и 4. В действии 4 установите половину из еще не установленных флажков в списке элементов автозагрузки. Повторяйте эти действия, пока не будут установлены все флажки.
Если в списке элементов автозагрузки остался только один элемент и проблема по-прежнему наблюдается, то именно этот элемент ее и вызывает.
Если проблема вызвана одним из элементов автозагрузки, перейдите к действию 6.
Если неполадка не вызвана ни одним из элементов автозагрузки, вероятнее всего, ее вызывает одна из служб Майкрософт. Чтобы определить, какая именно служба вызывает неполадку, повторите действия 1 и 2, не устанавливая флажок Не отображать службы Майкрософт в действии 2.

Действие 6. Устраните проблему.

Определив программу или службу, являющуюся причиной проблемы сделайте одно из предложенным действий:

1) Установите более новую версию программы или удалите текущую.
2) Обратитесь к разработчикам программы в службу поддержки.
3) Используя Конфигурация системы снимите флажок проблемного элемента в списке Службы или в списке элементов автозагрузки.
4) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
5) Введите команду и нажмите Enter ↵: sfc /scannow

Действие 7. Перезагрузите систему в обычный режим Windows.

Завершив устранение неполадок, для перезагрузки в обычнй режим Windows выполните описанные далее действия:

1) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter ↵, чтобы запустить Конфигурация системы.
2) На вкладке Общие установите переключатель на Обычный запуск
3) Нажмите кнопку ОК и щелкните Перезагрузка.

24. Сброс пароля для учетной записи администратора.

Вариант 1.

1) Загрузитесь с установочного DVD диска или флеш-накопителя Windows 7.
2) Запустите окно команд нажав комбинацию клавиш ⇑ Shift + F10.
3) Введите regedit и нажмите клавишу Enter ↵. Для переключения раскладок клавиатуры используйте комбинацию клавиш ⇑ Shift + Alt.
4) В редакторе реестра выделите раздел HKEY_LOCAL_MACHINE
5) В главном меню нажмите Файл и выберите пункт Загрузить куст.
6) Перейдите на диск, где установлена Ваша Windows 7 (сопоставление букв дисков может отличаться)
7) Откройте папку <буква_диска>:\Windows\System32\config, выделите файл SYSTEM и нажмите кнопку Открыть
8) Введите произвольное имя для загружаемого раздела. Например: 123 и нажмите кнопку ОК.
9) Перейдите в раздел реестра HKEY_LOCAL_MACHINE\123\Setup
10) Измените значения указанных ниже параметров. Для этого щелкните на необходимом параметре правой кнопкой мыши и выберите пункт Изменить, введите нужное значение и нажмите ОК.
Укажите для параметра CmdLine значение cmd.exe
Укажите для параметра SetupType значение 2
11) Выделите раздел 123 в HKEY_LOCAL_MACHINE.
12) В главном меню нажмите Файл и выберите пункт Выгрузить куст.
13) В открывшемся окне нажмите кнопку Да для подтверждения выгрузки.
14) Закройте редактор реестра и командную строку.
15) Выйдите из установки Windows (для этого закройте окно выбора языковых параметров) и извлеките установочный DVD диск или отсоедините флеш-накопитель.
16) Продолжите обычную загрузку Windows и у Вас откроется окно команд. Вы можете либо задать новый пароль для уже имеющейся учетной записи администратора, либо создать новую учетную запись администратора.
17) Введите команду: net user и нажмите Enter ↵, чтобы отобразить все имеющиеся у Вас учётные записи.

Для сброса пароля введите следующую команду и нажмите клавишу Enter ↵:

Внимание: Если имя пользователя и/или пароль содержат пробелы, то их необходио вводить в кавычках. Например:

Для создания новой учетной записи администратора последовательно введите указанные ниже команды, нажимая после введения каждой клавишу Enter ↵.

В русской (локализованной) версии Windows:

В английской версии Windows:

18) Закройте окно команд и войдите в систему, используя имеющуюся у Вас учетную запись с правами администратора и пароль. Если компьютер после закрытия окна команд зависнет, то просто перезагрузите его и Вы окажетесь в экране пользователей, где Вам необходимо будет ввести пароль.

Вариант 2.

1) Загрузитесь с установочного DVD диска или флеш-накопителя Windows 7.
2) В окне выбора языковых параметров нажмите кнопку Далее (Next)
3) Щелкните на ссылку Восстановление системы
4) Выберите в списке Вашу операционную систему и нажмите кнопку Далее (Next)
5) В списке инструментов для восстановления выберите пункт Командная строка (Command Prompt).
6) Найдите имя диска, где установлена Windows 7, вводя поочередно букву диска с двоеточием и нажимая клавишу Enter ↵. Для просмотра содержимого диска вводите команду dir
7) Введите последовательно указанные ниже команды, нажимая после введения каждой клавишу Enter ↵ (замените c: правильной буквой, если Windows не находится на диске C:)

8) Закройте окно команд и нажмите кнопку Перезагрузка в окне выбора средств восстановления.
9) Когда Вы окажетесь в экране выбора пользователей нажмите пять раз клавишу ⇑ Shift и у Вас откроется окно команд. Вы можете либо задать новый пароль для уже имеющейся учетной записи администратора, либо создать новую учетную запись администратора.
10) Введите команду: net user и нажмите Enter ↵, чтобы отобразить все имеющиеся у Вас учётные записи.

Для сброса пароля введите следующую команду и нажмите клавишу Enter ↵:

Внимание: Если имя пользователя и/или пароль содержат пробелы, то их необходио вводить в кавычках. Например:

Для создания новой учетной записи администратора последовательно введите указанные ниже команды, нажимая после введения каждой клавишу Enter ↵.

В русской (локализованной) версии Windows:

В английской версии Windows:

11) Закройте окно команд.
Если Вы просто изменили пароль, то можете сразу войти в систему, используя новый пароль.
Если Вы создали новую учетную запись с правами администратора, то для ее использования необходимо перезагрузить компьютер.
12) После входа в систему откройте папку C:\Windows\System32 и задайте полный доступ к файлу sethc.exe
13) Скопируйте из корня диска, где установлена Windows 7 в папку C:\Windows\System32 с заменой текущего, файл sethc.exe

Вариант 3.

1) Перезагрузите компьютер в MSDaRT. Создание образа MSDaRT (ранее ERD Commander) описано в совете 9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы). из раздела Разное.
2) В окне "Инициализировать подключение к сети в фоновом режиме?" (Would you like to initialize network connectivity in the background?) нажмите кнопку Нет (No).
3) В окне "Переназначить буквы дисков таким образом, чтобы они соответствовали буквам дисков целевой операционной системы?" (Would you like to remap the drive letters to match the mappings from the target operating system?) нажмите кнопку Да (Yes), чтобы в MSDaRT для обозначения дисков использовались те же буквы, что и в системе с которой Вы будете работать.
4) В окне Выберите метод ввода с клавиатуры (Select a keyboard input method) из ниспадающего списка выберите раскладку клавиатуры США (USA) и нажмите кнопку Далее.
5) В окне для выбора операционной системы для восстановления установите переключатель в значение "Используйте средства восстановления, позволяющие устранить проблемы при запуске Windows." (Use recovery tools that can help fix problems starting Windows.)
6) Выберите в списке Вашу операционную систему и нажмите кнопку Далее.
7) Выберите пункт Micosoft® Diagnostics and Recovery Toolset
8) Щелкните на ссылку Мастер изменения паролей (Locksmith) и в открывшемся окне нажмите кнопку Далее (Next).
9) Из ниспадающего списка выберите учетную запись у которой Вы хотите изменить пароль.
10) Введите одинаковое значение пароля в поля Новый пароль (New Password) и Подтверждение (Confirm Password) и нажмите кнопку Далее (Next).
11) Для закрытия мастера нажмите кнопку Готово (Finish).
12) В окне Средства MSDaRT (MSDaRT Tools) нажмите кнопку Закрыть и нажмите кнопку Перезагрузка в окне выбора средств восстановления.
13) Оказавшись после перезагрузки компьютера в экране пользователей, выберите учетную запись и введите пароль.
14) Появится сообщение о необходимости смены пароля перед первым входом. Нажмите кнопку ОК.
15) Введите в первой строке текущий пароль, заданный в MSDaRT, а во второй и третьей одинаковое значение нового пароля и нажмите на кнопку со стрелкой.
При желании, Вы можете ввести во все три строки одинаковые значения пароля, соответствующие заданному Вами паролю в MSDaRT.

25. Устранение неполадок с поиском и индексированием.

Если результаты поиска отображаются не полностью, а также поиск в системе происходит медленно независимо от установленных настроек, то сделайте следующее:

1) Откройте меню Пуск, введите в строке поиска Устранение неполадок и нажмите Enter ↵.
2) Нажмите кнопку Просмотр всех категорий, а затем выберите раздел Поиск и индексирование.
3) Нажмите кнопку Далее, затем в диалоговых окнах выбирайте ответы для уточнения имеющейся у Вас проблемы и нажимайте соответствующие кнопки.

Если файлы из индексированной папки не отображаются в результатах поиска, то сделайте следующее:

Причиной могут быть параметры безопасности, установленные для этой папки. Для индексирования папки и ее содержимого для нее необходимо установить разрешение система. Для большинства папок данное разрешение уже настроено, но в некоторых случаях разрешение система для папки может отсутствовать.

Добавление для папки разрешения система.

1) Щелкните папку правой кнопкой мыши, выберите пункт Свойства и откройте вкладку Безопасность.
2) Если вариант система не отображается в списке Группы или пользователи, щелкните Изменить.
3) Щелкните Добавить, введите в открывшемся окне система, затем щелкните Проверить имена.
4) В разделе Введите имена выбираемых объектов щелкните система, затем нажимайте кнопку ОК, пока не будут закрыты все открытые диалоговые окна.
5) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter ↵.
6) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
7) В диалоговом окне Дополнительно перейдите на вкладку Параметры индексирования, а затем нажмите кнопку Перестроить. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.

Перестроение индекса может занять несколько часов, и до тех пор пока индекс не будет перестроен, результаты поиска могут быть неполными.

26. Исправление проблемы, когда автоматически не обновляется значок корзины, после ее очистки.

Вариант 1.

1) Запустите текстовый редактор, например «Блокнот».
2) Скопируйте в него текст указанный ниже:

3) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3.1) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DefaultIcon.reg")
3.2) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
4) Примените полученный reg-файл. Щелкните на нем дважды и нажмите кнопку Да, а затем ОК.

Вариант 2.

1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
2) Нажмите ссылку Изменение значков рабочего стола.
3) Выберите значок Корзина (полная) и нажмите кнопку Сменить значок.
4) В диалоговом окне Смена значка, выберите значок полной корзины и нажмите кнопку ОК.
5) Выберите значок Корзина (пустая) и нажмите кнопку Сменить значок.
6) В диалоговом окне Смена значка, выберите значок пустой корзины и нажмите кнопку ОК.
7) В диалоговом окне Параметры значков рабочего стола нажмите кнопку ОК.

27. Исправление ошибки из журнала событий: "Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".

При запуске и использовании (чтение, переход по страницам) в Windows файла справки с расширением *.CHM в журнале событий может появляться сообщение:
"Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".
Это происходит из-за неправильного задания уровня безопасности системой для Местной интрасети в контейнере файла-справки.

Чтобы узнать появляется ли у Вас данная ошибка:

1) Откройте оснастку Просмотр событий
1.1) В строке поиска меню Пуск введите команду eventvwr.msc и нажмите Enter ↵
или
1.2) Пройдите Панель управления\Все элементы панели управления\Администрирование и откройте Просмотр событий.
2) Слева в древовидном списке оснастки Просмотр событий перейдите Просмотр событий (Локальный) → Журналы Windows → Приложение
3) В центральном окне будут описаны события произошедшие при работе с программами.

Для исправления данной ошибки, создайте и примените reg-файл следующего содержания:

28. Перезагрузка в Безопасный Режим при отсутствии данного пункта в меню Диспетчера загрузки.

Если у Вас в меню Диспетчера загрузки (вызывается нажатием клавишиF8 до появления экрана с логотипом Windows) отсутствует пункт для запуска Безопасного режима, то Вы можете попробовать перезагрузиться в Безопасный режим используя утилиту Windows - Настройка системы, для этого:

1) В строке поиска меню Пуск введите команду: msconfig
2) Перейдите на вкладку Загрузка
3) Установите флажок напротив пункта Безопасный режим.
4) Установите переключатель в нужное значение:

Минимальная - загрузка графического интерфейса пользователя ОС Windows (Проводника Windows) в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты отключены.
Другая оболочка - загрузка командной строки Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты и графический интерфейс пользователя отключены.
Восстановление Active Directory - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб и службы каталогов Active Directory.
Сеть - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты включены.

5) Установите необходимые флажки:

Без GUI - во время загрузки Windows экран приветствия не отображается.
Журнал загрузки - вся информация, касающаяся процесса загрузки, сохранится в файле %SystemRoot%\Ntbtlog.txt.
Базовое видео - загрузка графического интерфейса пользователя Windows в минимальном режиме VGA. В этом режиме загружаются стандартные драйверы VGA вместо драйверов экрана, соответствующих видеооборудованию компьютера. Установка данного пункта позволяет загрузиться в безопасный режим при проблемах с драйверами видеокарты.
Информация об ОС - отображает имена загружаемых драйверов в процессе загрузки системы. Устанавливайте, если желаете самостоятельно определить проблемный драйвер или библиотеку мешающие загрузке.

6) Нажмите в текущем окне ОK, затем во всплывшем окне нажмите Перезагрузка.

29. Исправление ошибки 4201, возникающей при попытке запуска службы Журнал событий Windows (Windows Event Log).

Вариант 1.

1) В соответствии с разрядностью Вашего Windows скачайте и установите программу Unlocker
2) В Проводнике откройте папку C:\Windows\System32\LogFiles\WMI
3) Нажмите правой кнопкой на папке RtBackup и в контекстном меню выберите пункт Unlocker.
4) В ниспадающем списке выберите пункт Удалить и нажмите на кнопку Разблокировать Все
5) Перезагрузите компьютер
6) Запустите службу Журнал событий Windows.

Вариант 2.

1) Перезагрузитесь в безопасный режим с полным отключением всех служб (для этого воспользуйтесь утилитой msconfig)
2) Откройте папку C:\Windows\System32\LogFiles\WMI
3) Удалите подпапку RtBackup со всем его содержимым.
Если необходимо, то задайте перед удалением для данной папки полные права. Иногда помогает сначала удаление файлов из папки, а затем самой папки.
4) Перезагрузитесь обратно в нормальный режим.
5) Запустите службу Журнал событий Windows.

30. Способы исправления ошибок при работе с программой sysprep.

Средство подготовки системы (Sysprep) - это технология, которую можно использовать вместе с другими средствами развертывания для установки операционных систем Windows® на новое оборудование.
Средство Sysprep подготавливает компьютер к созданию образа диска или к доставке клиенту путем настройки компьютера для создания нового идентификатора безопасности (SID) при перезапуске компьютера.
Кроме того, средство Sysprep удаляет параметры пользователя и системы, а также данные, которые не нужно копировать на конечный компьютер.
В случае возникновения проблем с ее использованием, Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1. Отключение конфликтующей службы.

1) Нажмите Пуск, введите в строке поиска Services.msc и нажмите Enter ↵ (Пуск → Администрирование → Службы)
2) Дважды щелкните на службу Служба общих сетевых ресурсов проигрывателя Windows Media
3) Установите Тип запуска в значение Отключена и нажмите ОК.
4) Перезапустите sysprep с необходимыми Вам параметрами.

Вариант 2. Завершение процесса конфликтующей службы.

1) Запустите sysprep
2) Выберите необходимые опции
3) Запустите Диспетчер задач (Ctrl + ⇑ Shift + Esc)
4) В Диспетчере задач завершите процесс wmpnetwk.exe
5) В окне sysprep быстро нажмите кнопку OK (до момента перезапуска процесса wmpnetwk.exe)

Вариант 3. Восстановление системы в исходное состояние лицензирования.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду: c:\windows\system32\slmgr.vbs –rearm

Вариант 4.

1) Откройте папку C:\Windows\Panther
2) В случае наличия в данной папке файла unattended.xml откройте его в блокноте
3) Измените используемые по умолчанию значения параметра PersistAllDeviceInstalls с true на false.
4) Сохраните измененные значения и закройте блокнот.
5) Запустите sysprep с необходимыми Вам параметрами.

Вариант 5.

1) Откройте папку C:\Windows\Panther
2) Скопируйте файл setup.etl на другой раздел (диск) во временную папку. Например, в D:\Test
3) Удерживая нажатой клавишу ⇑ Shift, щелкните правой кнопкой мыши на папку D:\Test и выберите пункт Открыть окно команд
4) Введите команду: tracerpt setup.etl -o logfile.csv
5) Закройте окно команд и откройте файл logfile.csv
6) Проанализируйте данный файл на предмет раздела реестра или процесса вызывающего ошибку.
7) Исправьте значение найденных конфликтующих параметров реестра на правильные, завершите конфликтующий процесс или удалите приложение, которому он принадлежит.
8) Запустите sysprep с необходимыми Вам параметрами.

Также рекомендую Вам почитать Техническое руководство по Sysprep от Microsoft Technet Возможно, информация указанная там, также укажет Вам путь к верному решению.

31. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкните правой кнопкой мыши на Компьютер (например в меню Пуск) и выберите Управление.
2) В левом окне выберите Управление дисками
3) Посередине вверху посмотрите, какие из томов не имеют букву.
Если среди томов присутствует раздел размером 200 МБ, то Вы ему букву не изменяете.
4) Присвойте букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкните на нем правой кнопкой мыши и в контекстном меню выберите пункт Изменить букву диска или путь к диску.
5) Нажмите Добавить, выберите букву и нажмите OK.
6) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
7) Откройте Панель управления → Параметры папок
8) Перейдите на вкладку Вид и проверьте установлен ли флажок Отображать буквы дисков, если нет, то установите его.

32. Восстановление фонового рисунка в экране авторизации пользователей (экране приветствия).

Вы можете восстановить (изменить) экран приветствия следующим образом:

1) Откройте в Проводнике папку C:\Windows\System32\oobe\
2) Если в ней присутствует папка info, то удалите ее.
3) Скачайте файл Full_access.zip, разархивируйте его и примените reg-файл.

4) Если у Вас 32-битная Windows, то:

4.1) Откройте папку C:\Windows\System32
4.2) Щелкните на файле imageres.dll правой кнопкой мышки и выберите пункт Стать владельцем и задать полный доступ к объекту

5) Если у Вас 64-битная Windows, то:

5.1) Откройте папку C:\Windows\System32
5.2) Щелкните на файле imageres.dll правой кнопкой мышки и выберите пункт Стать владельцем и задать полный доступ к объекту
5.3) Откройте папку C:\Windows\SysWOW64
5.4) Щелкните на файле imageres.dll правой кнопкой мышки и выберите пункт Стать владельцем и задать полный доступ к объекту

6) Скачайте файл Imageres.dll.zip и разархивируйте его.
7) В соответствии с разрядностью Вашей операционной системы скопируйте файлы в указанные выше папки.
8) Перезагрузите компьютер.

33. Получение информации о проблемах при запуске и при завершении работы Windows 7.

Если запуск Windows или завершение ее работы занимают долгое время, а также если происходит какой-либо сбой, то скорее всего причины приведшие к этому будут записаны в журнале событий.

Для получения информации о причинах возникновения проблемы при запуске системы, сделайте следующее:

1) В диалоговом меню Выполнить (Win   + R) или в строке поиска меню Пуск введите eventvwr.msc и нажмите Enter ↵.
2) В списке слева перейдите Журналы приложений и служб → Microsoft → Windows → Diagnostics-Performance → Работает.

Внимание: Журнал с данными о загрузке системы формируется спустя некоторое время после запуска, поэтому не открывайте журнал сразу после загрузки, а подождите несколько минут.

Каждой загрузке соответствует событие с кодом 100. События с кодами со 101 по 199 описывают причины, приведшие к замедлению(сбою) процесса запуска системы.
Для более удобного анализа информации о загрузке, отфильтруйте журнал:

3) В меню Действия, расположенном справа от основного окна выберите команду Фильтр текущего журнала.
4) В открывшемся окне в поле <Все коды событий> укажите диапазон чисел, для этого введите: 101-199 и нажмите кнопку ОК.
Для того чтобы отменить действия фильтра, в меню Действия выберите команду Очистить фильтр. Для получения информации о причинах возникновения проблемы при завершении работы, сделайте следующее:

1) В диалоговом меню Выполнить (Win   + R) или в строке поиска меню Пуск введите eventvwr.msc и нажмите Enter ↵.
2) В списке слева перейдите Журналы приложений и служб → Microsoft → Windows → Diagnostics-Performance → Работает.

Каждому завершению работы соответствует событие с кодом 200. События с кодами со 201 по 299 описывают причины, приведшие к замедлению(сбою) процесса завершения работы системы.
Для более удобного анализа информации о загрузке, отфильтруйте журнал:

3) В меню Действия, расположенном справа от основного окна выберите команду Фильтр текущего журнала.
4) В открывшемся окне в поле <Все коды событий> укажите диапазон чисел, для этого введите: 201-299 и нажмите кнопку ОК.
Для того чтобы отменить действия фильтра, в меню Действия выберите команду Очистить фильтр.

34. Решение проблем в работе компонента "Защита системы" и/или оснастки "Восстановление системы".

Воспользуйтесь данным советом в случае возникновения указанных проблем:

1) Не работает оснастка Восстановление системы (Пуск → Панель управления → Восстановление).
2) Неактивны кнопки в компоненте Защита системы (Пуск → Панель управления → Система → Защита системы).
3) Невозможно изменить настройки для доступных дисков.
4) Не работает вкладка Предыдущие версии в свойствах файлов.
5) Проблемы при создании точки восстановления системы для какого-либо из дисков.

Для начала проверьте включена ли у Вас функция Защита системы для требуемого диска.

1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
2) Нажмите ссылку Защита системы
3) В открывшемся окне в пункте Параметры защиты Вы увидите перечень дисков, в котором напротив каждого указано, включена защита или нет (сразу после установки Windows 7 защита включена только для диска, на который установлена операционная система).
4) Кликните левой кнопкой мыши по нужному диску и нажмите кнопку Настроить.
5) В открывшемся окне в пункте Параметры восстановления отметьте Восстановить параметры системы и предыдущие версии файлов и нажмите ОК.
6) Создайте точку восстановления системы, нажав на кнопку Создать.

Если указанное выше у Вас не работает или же наоборот все включено, но возникают проблемы, то выполните поочередно действия предложенные далее в вариантах.

Вариант 1.

1) Проверьте права и пользователей установленные для папок System Volume Information на Ваших дисках.
1.1) Щелкните правой кнопкой мыши на папке System Volume Information и выберите пункт Свойства
1.2) Перейдите на вкладку Безопасность.

По умолчанию в разделе группы или пользователи должно стоять только - система (SYSTEM) с полным доступом прав.
Если Вы добавили пользователя или изменили права для пользователя система (SYSTEM), то верните все в изначальные значения.

Вариант 2.

1) Откройте Панель управления → Администрирование и запустите Службы (Win   + R → services.msc → ОК)
Проверьте установленный тип запуска для служб:

Программный поставщик теневого копирования (Microsoft Software Shadow Copy Provider).
Теневое копирование тома (Volume Shadow Copy)

По умолчанию они должны быть установлены в значение Вручную.
2) Если одна из данных служб отключена, то дважды щелкните на нее и в открывшемся окне установите тип запуска в значение Вручную.

Вариант 3.

1.1) Запустите Редактор локальной групповой политики (Win   + R → gpedit.msc → ОК)
1.2) Откройте Конфигурация компьютера → Административные шаблоны → Система → Восстановление системы.

Значения параметров Отключить конфигурацию и Отключить восстановление системы в столбце Состояние должно быть указано Не задана.
Если в столбце Состояние значение для любого из данных параметров указано как Включена, то:

1.3) Щелкните правой кнопкой мыши на необходимом параметре и выберите пункт Изменить
1.4) В открывшемся окне установите переключатель в значение Не задано и нажмите кнопку ОК.

Вариант 4.

Создайте и примените reg-файл с указанным ниже текстом.

где: DiskPercent = Объем дискового пространства, зарезервированный под точки восстановления системы (5%)
RPLifeInterval = Число секунд, в течении которых будут храниться точки восстановления перед их удалением (7776000 секунд или 90 дней)

Вариант 5.

Удалите имеющиеся у Вас точки восстановления и попробуйте создать точку восстановления заново.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите необходимую команду и нажмите Enter ↵:

Удаление всех теневых копий на всех томах: vssadmin delete shadows /all
Удаление теневых копий на томе: vssadmin delete shadows /for=C:

где C: - буква тома

3) Скачайте архив: SCRP+script.zip и распакуйте его.
4) Щелкните правой кнопкой мыши на файле SCRP.exe и выберите пункт Запуск от имени администратора.
5) Перезагрузите компьютер проверьте появилась ли точка восстановления созданная программой. если не появилась, то:
6) Откройте папку куда Вы распаковали архив SCRP+script.zip
7) Откройте папку elevateWHSScript, щелкните правой кнопкой мыши на файле ElevateWSHScript.inf и выберите в контекстном меню пункт Установить
8) Вернитесь в предыдущую папку.
9) Щелкните правой кнопкой мыши на файле crp.vbs и выберите пункт Запуск от имени администратора.
10) Перезагрузите компьютер проверьте появилась ли точка восстановления созданная с помощью скрипта.

Вариант 6.

Измените минимальный размер области хранения теневых копий.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VolSnap
3) Создайте новый параметр типа DWORD (32 бита) c именем MinDiffAreaFileSize
4) Щелкните правой кнопкой мыши по параметру MinDiffAreaFileSize и выберите пункт Изменить...
5) В текстовом поле Значение установите значение: 3000
Данное значение равно 3000 МБ.
6) Перезагрузите компьютер.

Измените максимальный объем хранилища теневой копии.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду vssadmin list shadowstorage и нажмите Enter ↵.
3) Запомните букву в пункте Для тома: и значение пункта Максимальный объем хранилища теневой копии (Предположим он равен 15 GB).
4) Уменьшите значение данного параметра, введя команду и нажав Enter ↵:

5) Верните прежнее значение обратно, введя команду и нажав Enter ↵:

где C: - буква тома, а /Maxsize=15GB - максимальный объем хранилища теневой копии.

35. Исправление ошибок связанных с отсутствием папки Desktop в папках "C:\Windows\System32\config\systemprofile" и/или "C:\Windows\SysWOW64\config\systemprofile".

Если у Вас возникают ошибки связанные с отсутствием папки Desktop в какой-либо из папок "C:\Windows\System32\config\systemprofile" и/или "C:\Windows\SysWOW64\config\systemprofile", то скорее всего У Вас произошло повреждение файла пользователя Система, так как по умолчанию папка Desktop в указанных папках в Windows 7 отсутствует.

Для исправления данной проблемы воспользуйтесь одним из указанных ниже вариантов.

Вариант 1.

1) Откройте папку Вашего профиля в C:\Users (Например: C:\Users\Administrator)
2) Если в ней Вы обнаружите две папки Desktop, то удалите ту которая пустая.
3) Откройте C:\Windows\System32\config\systemprofile
4) Если в ней Вы обнаружите папку Desktop, то удалите ее целиком, если она пустая или удалите ее содержимое, если в ней содержаться какие-либо файлы.
5) Для 64-битных систем дополнительно откройте папку C:\Windows\SysWOW64\config\systemprofile и убедитесь, что в ней присутствует папка Desktop.
Также Вы можете скопировать содержимое папки Desktop из Вашего профиля в папки:
C:\Windows\System32\config\systemprofile и C:\Windows\SysWOW64\config\systemprofile.

Вариант 2.

1) Скачайте и распакуйте архив systemprofile.zip в любую папку.
2) Откройте папку C:\windows\system32\config\systemprofile
3) Удалите все файлы содержащие в названии NTUSER.
4) Откройте папку куда Вы распаковали архив.
5) В зависимости от разрядности Вашей Windows cкопируйте содержимое папки systemprofile_x64 (для 64-битных) или systemprofile_x86 (для 32-битных) в соответствующие папки.
6) Перезагрузите компьютер.

36. Исправление ошибки: Недостаточно места для создания файла для хранения файла теневой копии.

Если у Вас возникает ошибка Недостаточно места для создания файла для хранения файла теневой копии, то для ее решения попробуйте один из предложенных вариантов:

Вариант 1.

Убедитесь, что размер занятого пространства на диске для которого Вы делаете архивацию менее, размера свободного места на диске, куда Вы сохраняете образ системы.
А размер свободного пространства на диске для которого Вы делаете архивацию более 40 МБ.

Вариант 2.

Исключите из архивирования содержимое библиотек и попробуйте снова.

Вариант 3. Очистка места занимаемого USN журналом на скрытом разделе.

Возможно у Вас не хватает места для записи метаданных на скрытом разделе "100 МБ Зарезервировано системой", необходимых для создания архивной копии.
Вам необходимо примерно 40 МБ свободного пространства для этого.

1) В строке поиска меню Пуск введите diskmgmt.msc и нажмите Enter ↵.
2) Щелкните правой кнопкой мыши на разделе размером 100 мегабайт и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву (Пример: Z) и нажмите кнопку OK.
3) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4) Введите последовательно набор команд, нажимая для подтверждения каждой из них клавишу Enter ↵.

5) Повторите архивацию данных.
6) После успешного создания теневой копии, снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете раздел в 100 мегабайт снова Скрытым.

Вариант 4. Удалите скрытый раздел и переместите загрузочные файлы для Windows со скрытого раздела на диск на котором установлена Ваша Windows.

Применяйте данный вариант, только если Вам не помог Вариант 3.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду и нажмите клавишу Enter ↵ для ее подтверждения.

3) В строке поиска меню Пуск введите diskmgmt.msc и нажмите Enter ↵.
4.1) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7.
Буква тома здесь, идентична букве диска с Window 7 из Компьютер.
4.2) Щелкните правой кнопкой мыши по данному разделу и выберите в контекстном меню пункт Сделать раздел активным.
5) Перезагрузите компьютер.
6) В строке поиска меню Пуск введите diskmgmt.msc и нажмите Enter ↵.
7) Щелкните правой кнопкой мыши на разделе размером 100 мегабайт и выберите пункт Удалить том и нажмите кнопку Да.
8) Перезагрузите компьютер и выполните архивацию снова.

37. Решение проблем: "Консоль управления не может создать оснастку" и "MMC не удается инициализировать оснастку".

Если у Вас возникла одна из проблем: Консоль управления не может создать оснастку и/или MMC не удается инициализировать оснастку, то для ее/их решения выполните следующие действия.

1) Откройте папку С:\Users\ВашПрофиль\AppData\Roaming\Microsoft\MMC\ и удалите все файлы находящиеся в ней.
2) Откройте Панель управления\Система и безопасность\Система и нажмите ссылку Дополнительные параметры системы.
3) Нажмите на кнопку Переменные среды.
4) Щелкните дважды на переменную Path в разделе Системные переменные для открытия окна Изменение системной переменной.
5) Проверьте чтобы в текстовом поле Значение переменной среди всех адресов присутствовали следующие адреса, причем, именно в указанном порядке:

Если они отсутствуют, то добавьте их в самое начало. Для отделения их от уже имеющихся значений используйте знак ; (точка с запятой).
6) Откройте Панель управления\Все элементы панели управления\Программы и компоненты
7) Нажмите слева на ссылку Просмотр установленных обновлений.
8) Удалите все обновления из групп Microsoft .NET Framework 4 Client Profile и Microsoft .NET Framework 4 Extended. Перезагрузите компьютер, если система предложит.
9) Нажмите стрелку назад, чтобы вернуться Панель управления\Все элементы панели управления\Программы и компоненты.
10) Удалите программы Microsoft .NET Framework 4 Client Profile и Microsoft .NET Framework 4 Extended. Перезагрузите компьютер, если система предложит.
11) Нажмите слева на ссылку Включение или отключение компонентов Windows.
12) Найдите в списке Microsoft .NET Framework 3.5.1 и снимите флажок (или затененный флажок) и нажмите кнопку ОК. Перезагрузите компьютер, если система предложит.
13) Откройте Панель управления\Система и безопасность\Администрирование и запустите оснастку Службы.
14) Остановите службы Microsoft .NET Framework NGEN v2.0.50727_X86 и Microsoft .NET Framework NGEN v2.0.50727_X64 (для 64-битной Windows)
15) Откройте папку C:\Windows и задайте полный доступ к папке Microsoft.NET используя решение предложенное в совете 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
16) Удалите все возможное содержимое папки C:\Windows\Microsoft.NET.
17) Нажмите Ctrl + ⇑ Shift + Esc, перейдите в Диспетчере задач на вкладку Процессы и завершите все процессы WmiPrvSE.exe.
18) Удалите оставшиеся файлы используя программу Unlocker, упоминаемую в совете 5. Разблокирование файла используемого какой-либо программой для действий с ним. из раздела Тонкие настройки.
Не перезагружайте компьютер!
19) Откройте программой 7zip файл install.wim из папки sources на установочном диске.
20) Откройте в нем папку Windows и извлеките куда-нибудь папку Microsoft.NET.
21) Скопируйте все содержимое из папки Microsoft.NET извлеченной из файла install.wim в папку C:\Windows\Microsoft.NET.
Те у кого отсутствует установочный диск могут скачать готовый архив с папкой Microsoft.NET.
Ссылка: для 32-битной версии Windows 7 или для 64-битной версии Windows 7.
22) Откройте Панель управления\Все элементы панели управления\Программы и компоненты
23) Нажмите слева на ссылку Включение или отключение компонентов Windows.
24) Найдите в списке Microsoft .NET Framework 3.5.1 и установите затененный флажок и нажмите кнопку ОК. Перезагрузите компьютер, если система предложит.
25) Установите Microsoft .NET Framework 4.5.2 (Полная версия).
26) Откройте Панель управления\Система и безопасность\Центр обновления Windows и установите все обновления для Microsoft .NET Framework. Перезагрузите компьютер, если система предложит.
27) Откройте Панель управления\Система и безопасность\Администрирование и запустите оснастку Службы.
28) Установите для служб Microsoft .NET Framework NGEN v2.0.50727_X86, Microsoft .NET Framework NGEN v2.0.50727_X64 (для 64-битной Windows), Microsoft .NET Framework NGEN v4.0.30319_X86 и Microsoft .NET Framework NGEN v4.0.30319_X64 (для 64-битной Windows) тип запуска: Автоматически.
Для этого щелкните дважды на службе, установите тип запуска: Автоматически и нажмите кнопку ОК.
29) Перезагрузите компьютер.
30) Запустите оснастку, в которой была обнаружена указанная ошибка. Проблема должна исчезнуть.

38. Решение проблемы при запуске Планировщика заданий: Задание <имя_задачи>: Образ задачи поврежден или изменен.

Если при запуске Планировщика заданий появляется ошибка Образ задачи поврежден или изменен., то для ее решения выполните следующие действия:

1) Запустите редактор реестра (Win + R → regedit → OK)
2) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree
3) Найдите подраздел, соответствующий поврежденной задаче (в нем должно содержаться ее имя)

Пример:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\Customer Experience Improvement Program\Uploader
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\PerfTrack\BackgroundConfigSurveyor

4) Щелкните на подраздел реестра, соответствующий поврежденной задаче, и запишите значение {GUID} параметра Id.

Пример:

{5380A838-E45C-48BC-AD22-C757867B640E} для задачи Uploader.
{3B28E4FF-1F90-45CB-8090-EB8372567E3E} для задачи BackgroundConfigSurveyor.

5) Запустите Планировщик заданий.
5.1) Откройте меню Пуск → Панель управления → Администрирование → Планировщик заданий или в строке поиска меню Пуск введите taskschd.msc и нажмите Enter ↵.
6) В левой области разверните список Библиотека планировщика заданий и найдите папку с поврежденной задачей.
Обычно ее имя соответствует названию раздела, в котором находится подраздел поврежденной задачи в реестре.
А путь к ней совпадает с путем к подразделу поврежденной задачи в реестре.

Пример:

Библиотека планировщика заданий → Microsoft → Windows → Customer Experience Improvement Program для задачи Uploader.
Библиотека планировщика заданий → Microsoft → Windows → PerfTrack для задачи BackgroundConfigSurveyor.

7) Щелкните на задачу, и запишите значение поля Размещение.
Обычно данное значение соответствует пути к подразделу поврежденной задачи в реестре.

Пример:

\Microsoft\Windows\Customer Experience Improvement Program для задачи Uploader.
\Microsoft\Windows\PerfTrack для задачи BackgroundConfigSurveyor.

8) Закройте Планировщик заданий.
9) Откройте в Проводнике папку C:\Windows\System32\Tasks
10) Откройте в ней папку, используя значение указанное в поле Размещение.

Пример:

C:\Windows\System32\Tasks\\Microsoft\Windows\Customer Experience Improvement Program для задачи Uploader.
C:\Windows\System32\Tasks\\Microsoft\Windows\PerfTrack для задачи BackgroundConfigSurveyor.

11) Скопируйте файл, соответствующий поврежденной задаче в любую временную папку.
12) Удалите файл, соответствующий поврежденной задаче, из папки C:\Windows\System32\Tasks\<путь_к_папке_с_поврежденной_задачей>

Пример:

Удалите файл Uploader из папки C:\Windows\System32\Tasks\Microsoft\Windows\Customer Experience Improvement Program
Удалите файл BackgroundConfigSurveyor из папки C:\Windows\System32\Tasks\Microsoft\Windows\PerfTrack

13) Используя найденное Вами ранее значение {GUID} найдите и удалите подраздел, соответствующий поврежденной задаче, из указанного ниже раздела реестра.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks

Пример:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\{5380A838-E45C-48BC-AD22-C757867B640E} для задачи Uploader.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\{3B28E4FF-1F90-45CB-8090-EB8372567E3E} для задачи BackgroundConfigSurveyor.

14) Используя найденное Вами ранее значение {GUID} найдите и удалите подраздел, соответствующий поврежденной задаче, из указанных ниже разделов реестра.
Задача может находиться только в одном из них.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Boot
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Logon

Пример:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain\{5380A838-E45C-48BC-AD22-C757867B640E} для задачи Uploader.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain\{3B28E4FF-1F90-45CB-8090-EB8372567E3E} для задачи BackgroundConfigSurveyor.

15) Удалите подраздел, соответствующий поврежденной задаче, из указанного ниже раздела реестра.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree

Пример:

Подраздел Uploader из раздела
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\Customer Experience Improvement Program
Подраздел BackgroundConfigSurveyor из раздела
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\PerfTrack

16) Запустите Планировщик заданий.
17) В левой области разверните список Библиотека планировщика заданий и откройте папку, в которой раньше находилась поврежденная задача.

Пример:

Библиотека планировщика заданий → Microsoft → Windows → Customer Experience Improvement Program для задачи Uploader.
Библиотека планировщика заданий → Microsoft → Windows → PerfTrack для задачи BackgroundConfigSurveyor.

18) Щелкните на данной папке правой кнопкой мыши и выберите команду Импортировать задачу.
19) В диалоговом окне Открыть выберите пункт Все файлы (*.*).
20) Откройте временную папку с резервной копией задачи и выберите соответствующий файл.
21) Нажмите кнопку Открыть и в Планировщике заданий появится восстановленная задача.

39. Изменение параметров отправки отчета при отказе работы программы.

Если произошел отказ в работе программы, то в зависимости от настроек системы, Windows предложит либо найти решение в Интернете, либо закрыть программу.
Чтобы настроить какое действие должно выполнятся при отказе в работе программы сделайте следующее:

1) Откройте Панель управления\Система и безопасность\Центр поддержки
2) Разверните группу настроек Обслуживание.
3) В разделе Поиск решений для указанных в отчетах проблем нажмите на ссылку Параметры.

В открывшемся окне Вы увидите несколько значений переключателя от выбора значений которого зависит выполняемые действия при отказе работы программы.

4.1) При выборе значения Автоматически проверять наличие новых решений при нажатии пункта Закрыть программу произойдет закрытие программы, после чего Windows соединится с интернетом и только проверит имеется ли решение для данной проблемы.

4.2) При выборе значения Автоматически проверять на наличие новых решений и при необходимости отправлять дополнительные данные отчета при нажатии пункта Закрыть программу произойдет закрытие программы, после чего Windows соединится с интернетом, проверит имеется ли решение для данной проблемы и при необходимости отправит отчет с данными об ошибке.

4.3) При выборе значения Каждый раз при возникновении проблемы отображать запрос до проверки на наличие решений:

4.3.1) При нажатии пункта Искать решение проблемы в Интернете и закрыть программу (Выполнить поиск решения и закрыть программу) произойдет закрытие программы, после чего Windows соединится с интернетом, проверит имеется ли решение для данной проблемы и при необходимости отправит отчет с данными об ошибке.
4.3.2) При нажатии пункта Закрыть программу произойдет только закрытие программы.

4.4) При выборе значения Не проверять на наличие новых решений при нажатии пункта Закрыть программу произойдет только закрытие программы.

5) Выберите необходимое Вам значение и нажмите кнопку ОК.

40. Использование монитора ресурсов для уточнения цели ожидания приложением, которое не отвечает.

Приложения, которые не отвечают, могут ожидать завершения других процессов.
Возможно также, что для продолжения работы таких приложений необходим доступ к системным ресурсам.
Чтобы просмотреть цепочку ожидания процесса и завершить процессы, которые мешают программе правильно работать, необходимо воспользоваться Монитором ресурсов Windows.
Чтобы проанализировать процесс при помощи монитора ресурсов, выполните следующие действия.

1) Нажмите комбинацию клавиш Win   + R
2) Введите команду resmon и нажмите Enter ↵.
3) Щелкните правой кнопкой мыши на имени исполняемого файла процесса, который нужно проанализировать, и выберите команду Анализ цепочки ожидания.

Если процесс выполняется в нормальном режиме и не ожидает других процессов, то никаких сведений о цепочке ожидания не отображается.
Если процесс ожидает другой процесс, то будет показано дерево зависимостей от других процессов.

Чтобы завершить один или несколько процессов в дереве, установив флажки рядом с именами процессов и нажмите кнопку Завершить процесс.

41. Исправление ошибки 0x80071A91 выдаваемой каким-либо из элементов Windows.

Если у Вас при работе с каким-либо элементом Windows возникает ошибка 0x80071A91, то возможно это является сбоем журнала транзакций файловой системы или журнала общего назначения.
Чтобы исправить данную ошибку воспользуйтесь одним из предложенных ниже решений.

Вариант 1.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

Примечание: Предполагается, что Windows установлена в папке по умолчанию на диске C:\.

Вариант 2.

1) Перезагрузите компьютер
2) До начала запуска Windows нажмите на клавишуF8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter ↵, а затем сразуF8.
3) Выберите пункт Устранение неполадок компьютера (Repair your computer) и нажмите клавишу Enter ↵.
4) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt).
5) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵:

Примечание: Предполагается, что Windows установлена в папке по умолчанию на диске C:\.

6) Закройте командную строку и перезагрузите компьютер обратно в Windows.

42. Исправление ошибки: "... не является внутренней или внешней командой исполняемой программой или пакетным файлом".

Если при запуске какой-либо из системных программ (например: reg, regedit, ipconfig, telnet) у Вас появляется ошибка:

То для её решения воспользуйтесь одним из указанных ниже вариантов:

Вариант 1.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\Environment
3) Проверьте присутствует ли в данном разделе строковый параметр Path
Если данный параметр у Вас отсутствует, то:
3.1) Щелкните правой кнопкой мыши на разделе Environment и выберите Создать → Строковый параметр
3.2) Щелкните правой кнопкой мыши на созданном параметре и выберите Переименовать
3.3) Введите Path и нажмите Enter ↵

4) Щелкните дважды на параметре Path и введите указанное ниже значение, а затем нажмите кнопку ОК.

5) Перезагрузите компьютер.

Вариант 2.

1) Создайте и примените reg-файл указанного ниже содержания.

2) Перезагрузите компьютер.

43. Решение проблемы с некорректной работой анимации или Диспетчера окон рабочего стола (dwm.exe).

Если у Вас некорректно работает анимация окон или Вам кажется, что "Диспетчер окон рабочего стола" (dwm.exe) работает некорректно, то Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1. Перезапуск файла dwm.exe.

Чтобы перезапустить файл dwm.exe, Вам необходимо перезапустить службу "Диспетчер сеансов диспетчера окон рабочего стола".

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.

Вариант 2. Отключение визуальных эффектов, связанных с анимацией.

1) Откройте Пуск → Панель управления → Система.
2) Слева в списке нажмите ссылку Дополнительные параметры системы.
3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
4) На вкладке Визуальные эффекты снимите флажки напротив указанных ниже пунктов и нажмите кнопку ОК:

Анимация в меню "Пуск” и панели задач
Анимация окон при свертывании и развертывании
Анимированные элементы управления и элементы внутри окна
Затухание меню после вызова команды
Эффекты затухания или скольжения при обращении к меню
Эффекты затухания или скольжения при появлении подсказок

44. Исправление ошибки "Не удалось открыть объект групповой политики на этом компьютере. Возможно, у вас недостаточно прав."

Если у Вас при запуске редактора глобальной групповой политики (gpedit.msc) появляется сообщение об ошибке:

Не удалось открыть объект групповой политики на этом компьютере. Возможно, у вас недостаточно прав.

или

Failed to open the Group Policy Object on this computer. You might not have the appropriate rights.

То для исправления данной проблемы:

1) Закройте данное сообщение об ошибке.
2) Запустите Проводник (Windows Explorer).
3) Откройте папку C:\Windows\System32\GroupPolicy и удалите папку Machine (C:\Windows\System32\GroupPolicy\Machine).
4) Запустите редактор глобальной групповой политики (gpedit.msc).

Если удаления папки C:\Windows\System32\GroupPolicy\Machine окажется недостаточным для исправления данной проблемы, то удалите папку C:\Windows\System32\GroupPolicy.

45. Исправление ошибки "Пространство имен "Microsoft.Policies.Sensors.WindowsLocationProvider" уже определено как целевое пространство имен для другого файла в хранилище".

Если у Вас при запуске редактора глобальной групповой политики (gpedit.msc) появляется сообщение об ошибке:

Пространство имен "Microsoft.Policies.Sensors.WindowsLocationProvider" уже определено как целевое пространство имен для другого файла в хранилище.

или

Namespace "Microsoft.Policies.Sensors.WindowsLocationProvider" is already defined as the target namespace for another file in the store.

То для исправления данной проблемы:

1) Скачайте архив TakeOwnershipEx.zip и распакуйте в любую папку.
2) Откройте данную папку, нажмите правой кнопкой мыши на exe-файл и выберите пункт Запуск от имени администратора.
3) Выберите необходимый Вам язык Russian (Русский) или English (Английский) и нажмите кнопку ОК.
4) Нажмите последовательно кнопки Далее, Принимаю, Далее, Установить, Готово (Next, I Agree, Next, Install и Finish).
5) Откройте папку C:\Windows\PolicyDefinitions
6) Щелкните правой кнопкой мыши на файле LocationProviderADM.admx и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
7) Во всплывшем окне нажмите кнопку ОК.
8) Удалите LocationProviderADM.admx
9) Щелкните правой кнопкой мыши на файле Microsoft-Windows-Geolocation-WLPAdm.admx и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
10) Во всплывшем окне нажмите кнопку ОК.
11) Переименуйте файл Microsoft-Windows-Geolocation-WLPAdm.admx в LocationProviderADM.admx
12) Щелкните правой кнопкой мыши на файле LocationProviderADM.admx и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
13) Во всплывшем окне нажмите кнопку ОК.
14) Откройте папку C:\Windows\PolicyDefinitions\en-US
15) Щелкните правой кнопкой мыши на файле LocationProviderADM.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
16) Во всплывшем окне нажмите кнопку ОК.
17) Удалите LocationProviderADM.adml
18) Щелкните правой кнопкой мыши на файле Microsoft-Windows-Geolocation-WLPAdm.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
19) Во всплывшем окне нажмите кнопку ОК.
20) Переименуйте файл Microsoft-Windows-Geolocation-WLPAdm.adml в LocationProviderADM.adml
21) Щелкните правой кнопкой мыши на файле LocationProviderADM.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
22) Во всплывшем окне нажмите кнопку ОК.
23) Откройте папку C:\Windows\PolicyDefinitions\ru-RU
24) Щелкните правой кнопкой мыши на файле LocationProviderADM.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
25) Во всплывшем окне нажмите кнопку ОК.
26) Удалите LocationProviderADM.adml
27) Щелкните правой кнопкой мыши на файле Microsoft-Windows-Geolocation-WLPAdm.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
28) Во всплывшем окне нажмите кнопку ОК.
29) Переименуйте файл Microsoft-Windows-Geolocation-WLPAdm.adml в LocationProviderADM.adml
30) Щелкните правой кнопкой мыши на файле LocationProviderADM.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
31) Во всплывшем окне нажмите кнопку ОК.

Устранение неполадок - Рабочий стол, Проводник, Панель задач.

1. Исправление исчезновения панели быстрого запуска после перезагрузки.

Если Вы создаете панель быстрого запуска, но после перезагрузки она исчезает, то попробуйте любое из предложенных ниже решений.

1) Попробуйте создать панель быстрого запуска со значением отличающимся от Вашего:

%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
%appdata%\Microsoft\Internet Explorer\Quick Launch
C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

2) Установите ползунок контроля учетных записей (UAC) в предпоследнее значение.

3) Создайте и добавьте в реестр следующий reg-файл:

4) Откройте C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer
Добавьте на вкладке Свойства → Безопасность пользователя Все и задайте ему полный доступ.

5) В диалоговом окне Выполнить из меню Пуск (Win   + R) введите команду control userpasswords2 и нажмите Enter ↵.
Поставьте флажок на "Требовать ввод имени пользователя и пароля"

6) В диалоговом окне Выполнить из меню Пуск (Win   + R) введите команду gpedit.msc и нажмите Enter ↵.
Откройте Конфигурация пользователя → Административные Шаблоны → Меню "Пуск" и панель задач
Измените параметр политики Отображение панели быстрый запуск на панели задач на значение Включить.

7) Закройте Языковую панель и установите вместо неё Punto Switcher.

2. Исправление сбоев возникающих при установке, обновлении или удалении программы с помощью установщика Windows (msiexec.exe).

Вариант 1

1) Перейдите Пуск→Все программы→Стандартные
2) Щелкните правой кнопкой мыши на пункт Командная строка и нажмите Запуск от имени Администратора
3) Скопируйте следующую строчку в окно команд и нажмите Enter ↵:

Вариант 2

1) Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter ↵.
2) Перейдите в раздел HKLM\SOFTWARE\Microsoft\SQMClient\Windows
3) Щелкните правой кнопкой мыши на разделе DisabledSessions и нажмите Удалить.

3. Восстановление пункта "Выполнить" в меню "Пуск".

Если у Вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает Вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

4. Убирание появляющейся в меню Пуск полоски, пропадающей при повторном открытии.

Данная ошибка исправлена в Сервисном Пакете 1 (Service Pack 1).

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления→Язык и Региональные Стандарты→Языки и Клавиатуры→Язык интерфейса→выбираете английский
2) Перелогиниваетесь или перезапускаете компьютер
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
Для тех у кого изначально русская, выкладываю данный файл отдельно aero.msstyles.mui.zip

Также Вы можете скачать и запустить от имени Администратора готовый патч: MenuFix_Rus_x86_x64_Final.rar
После его применения понадобиться перезагрузить компьютер.

5. Восстановление ассоциации для *.cpl файлов.

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкните правой кнопкой мыши на любом файле *.cpl и выберите Свойства
2) На вкладке Общие напротив надписи Приложение нажмите кнопку Изменить.
3) В открывшемся окне нажмите кнопку Обзор
4) Зайдите в папку C:\Windows\System32 и выберите файл control.exe
5) Нажмите ОК

6. Исправление вылета Проводника при нажатии правой кнопки мыши на файле или папке.

Скачайте небольшую утилиту ShellExView: английскую версию с официального сайта или русскую версию с зеркала.

Вариант 1.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Запустите ShellExView.
2) Найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

или

1) Нажмите Пуск → Выполнить (Win   + R)
2) Введите команду regsvr32 /u CmdLineExt.dll и нажмите ОК.
3) Перезагрузите компьютер.

Вариант 2.

1) Запустите ShellExView.
2) Сделайте сортировку по столбцу Type (щелкните мышкой на названии столбца). Вас будут интересовать записи, где Type = Context Menu, а в столбце File Extensions есть звездочка.
3) Отключайте записи по очереди, начав с расширений, не принадлежащих Microsoft. Отключение выполняется щелчком правой кнопкой мыши → Disable Selected Items или клавишей F7.
4) Отключив запись, проверьте работу Проводника.

Если Вы отключили все расширения, но проблема не решилась, то запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
Введите команду и нажмите Enter ↵: sfc /scannow

Если данное действие не возымеет успеха, то перезагрузитесь в безопасный режим Windows.
Если в безопасном режиме данная проблема пропадает, тогда всё нормально, значит, проблема вызвана одной из установленных у вас программ, драйверов, кодеков или служб и Вам придется вручную искать причину вызвавшую сбой. Удалять по одной программе, отключать по одной службе или откатываться к предыдущим версиям установленных драйверов, либо используя точки восстановления возвращаться к предыдущим состояниям системы и наблюдать на каком этапе исчезла ошибка.

7. Восстановление исчезнувшей языковой панели.

Исчезновение языковой панели, чаще всего происходит после использования чистильщика или оптимизатора системы.
Перед использованием одного из предложенных вариантов, сделайте следующее:

1) Откройте редактор реестра (Win   + R → regedit → OK )
2) Проверьте, не добавлен ли запрет на запуск языковой панели в следующую папку реестра:

3) Проверьте, присутствует ли в реестре ветки:

Region and Language

Keyboard

4) Проверьте значение параметров, в ветке реестра:реестра:

– значение REG_SZ-параметра AppName должно быть ctfmon.exe
– значение REG_SZ-параметра AppPath должно быть С:\Windows\system32.

где C: - буква диска на который у Вас установлена Windows

Вариант 1

1) Откройте Панель управления → Язык и региональные стандарты
2) Выполните все по пунктам на скриншотах.

3) На вкладке Языки и Клавиатуры нажмите кнопку Изменить клавиатуру.
4) На вкладке Языковая панель установите переключатель в положение Закреплена в панели задач, отметьте флажок Отображать текстовые метки на языковой панели и нажмите OK
5) Щелкните правой кнопкой на панели задач, выбираете Свойства.
6) В пункте Область уведомлений щелкаем кнопку Настроить

7) В открывшемся окне поставьте флажок напротив Всегда показывать все значки и уведомления на панели задач и нажмите OK

Вариант 2

В контекстном меню панели задач уберите флажок со значения Закрепить панель задач, расширьте границы для всех панелей, а затем снова поставьте флажок напротив Закрепить панель задач.

Вариант 3

Найдите файл ctfmon.exe и добавьте его в Автозагрузку или создайте reg-файл со следующим содержанием:

Вариант 4

1) Откройте Языки и службы текстового ввода

Так:

1.1.1) Откройте Пуск → Выполнить (или нажмите на клавиатуре Win   + R)
1.1.2) Введите команду: RunDll32.exe shell32.dll,Control_RunDLL C:\Windows\system32\input.dll
1.1.3) Нажмите OK.

Или так:

1.2.1) Откройте Панель управления\Часы, язык и регион
1.2.2) Нажмите на ссылку Смена раскладки клавиатуры или других способов ввода
1.2.3) Нажмите на кнопку Изменить клавиатуру
2) На вкладке Общие удалите все раскладки клавиатуры кроме Английский
3) На вкладке Языковая панель снимите все флажки и установите переключатель в значение Скрыта
4) Выгрузите вручную библиотеки.
4.1) Откройте Пуск → Выполнить (или нажмите на клавиатуре Win   + R)
4.2) Выполните поочередно команды:

5) Перезагрузите компьютер.
6) Откройте Языки и службы текстового ввода
7) На вкладке Общие добавьте нужные Вам раскладки клавиатуры
8) На вкладке Языковая панель установите переключатель в значение Закреплена в панели задач и установите флажок напротив пункта Отображать текстовые метки на языковой панели.
9) Нажмите OK.

Как альтернативный вариант Вы можете установить программу Punto Switcher, она добавляет собственную языковую панель и функцию автоматического переключения раскладки при неправильном её выборе.

8. Исправление ошибки, когда папки "Недавние места" и "Недавние документы" пустые.

1) Щелкните правой кнопкой мыши на кнопке Пуск и нажмите на Свойства
2) Установите флажки напротив пунктов:
"Хранить и отображать список недавно открывшихся программ в меню "Пуск"
"Хранить и отображать список недавно открывшихся элементов в меню "Пуск" и на панели задач"
3) Нажмите OK.

9. Удаление появившейся на рабочем столе папки "Недавние места".

1) Удалите папку C:\Users\Default\AppData\Roaming\Microsoft\Windows\Recent
2) Перезагрузите компьютер или перезапустите систему
3) Зайдите в C:\Users\Default\AppData\Roaming\Microsoft\Windows\
4) Если Windows 7 не восстановил папку Recent заново, создайте её самостоятельно.

10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"

Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.

11. Исправление неполадок в работе гаджетов.

Если у Вас появились неполадки в работе гаджетов, то для их решения Вы можете воспользоваться одним из предложенных вариантов.

Вариант 1. Если гаджет не работает при отключенном контроле учетных записей (UAC).

1) Создайте reg-файл указанного ниже содержания.

2) Примените его и перезагрузите компьютер.

Вариант 2. Если гаджет погоды, пишет: "Не удалось подключится к службе" (Service unavailable for your region)

Для начала запустите Internet Explorer и проверьте отсутствие в меню Файл установленного флажка Работать автономно.

1) Запустите Диспетчер задач нажав комбинацию клавиш Ctrl + ⇑ Shift + Esc.
2) Завершите процесс sidebar.exe
3) Запустите Гаджеты: щелкните правой кнопкой мыши на рабстоле и выберите в контекстном меню пункт Гаджеты.

Если данного действия оказалось недостаточно, то:

1) Откройте меню Пуск и введите в строке поиска слово: блокнот.
2) Щелкните на найденном блокноте правой кнопкой мыши и выберите пункт "Запуск от имени администратора".
3) Нажмите в блокноте комбинацию клавиш Ctrl + O
4) Перейдите в папку Windows\System32\drivers\etc\
5) Откройте файл hosts.
6) Добавьте следующие строки:

Если указанные действия не помогли, то поставьте другой гаджет погоды, например: AccuWeather.com® Forecast Gadget или HTC Home

Вариант 3. Если после добавления собственного гаджета, не загружается процесс sidebar.exe и/или не работают родные гаджеты.

1) Откройте в Проводнике указанные ниже папки, удалите из них данный гаджет (папку с именем и расширением .Gadget) и перезагрузите систему.

%ProgramFiles%\Windows Sidebar\Gadgets
%ProgramFiles%\Windows Sidebar\Shared Gadgets
%LOCALAPPDATA%\Microsoft\Windows Sidebar\Gadgets

2) Откройте папку %LOCALAPPDATA%\Microsoft\Windows Sidebar\
3) Откройте в блокноте файл Settings.ini и удалите раздел [Hashes] со всеми его значениями.
4) Сохраните файл и перезагрузите компьютер.

Вариант 4. Если групповой политикой полностью отключены гаджеты и/или отключена установка неподписанных гаджетов и/или гаджетов установленных пользователем.

1) Создайте reg-файл указанного ниже содержания.

2) Примените его и перезагрузите компьютер.

Вариант 5. Удаление в реестре лишней зоны безопасности для Internet Explorer.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\
3) Удалите все лишние разделы, кроме разделов с 0-го по 4-й.

Вариант 6. Повторная регистрация необходимых библиотек.

1) Запустите командную строку от имени Администратора (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
2) По очереди введите команды указанные ниже, нажимая после введения каждой Enter ↵:

12. Восстановление функциональности пункта "Закрепить программу в панели задач".

Если у Вас не отображается пункт "Закрепить программу в панели задач":

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Примените созданный reg-файл и перезагрузите компьютер.

Если при выборе пункта "Закрепить программу в панели задач" не закрепляется программа:

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .bat
3) Если выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "test.bat")
4) Если выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Щелкните на созданном Вами файле правой кнопкой мыши и нажмите "Запуск от имени администратора".

13. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в Проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы

Изображения

Музыка

Видео

Поиски

Загрузка

Избранное

Контакты

Рабочий стол

Ссылки

Сохраненные игры

Общий рабочий стол

Общие документы

Общая музыка

Общие изображения

Общее видео

14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

Если при создании, копировании или перемещении на рабочий стол любого документа/ярлыка/папки, после обновления экрана или перезагрузки компьютера, у Вас появляются их дубликаты (точная копия, без (2) в названии), то это означает, что Ваш собственный рабочий стол и общий рабочий стол прописаны в реестре в одной папке. Данная проблема решается указанием для них отдельных отличающихся между собою папок.

1) Запустите Редактор реестра. Для этого в строке поиска в меню Пуск введите regedit и нажмите Enter ↵
2) Откройте раздел: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
3) Измените значение параметра Common Desktop на одно из предложенных ниже:

C:\Users\Public\Desktop - значение Windows по умолчанию
C:\Users\ВашПрофиль\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
5) Измените значение параметра Common Desktop на одно из предложенных ниже:

%Public%\Desktop - значение Windows по умолчанию
%USERPROFILE%\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

15. Восстановление поиска в Проводнике и в меню Пуск.

1) Используя Реестр (Win   + R → regedit)
1.1) Откройте ветку реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
1.2) В случае обнаружения параметра NoFind, удалите его.

2) Используя Панель управления
2.1) Откройте Панель управления\Программы\Программы и компоненты
2.2) Запустите "Включение и отключение компонентов Windows" (или Win   + R → OptionalFeatures.exe)
2.3) Проверьте, включен ли у Вас компонент Windows Search (Поиск Windows).

3) Используя Редактор локальной групповой политики.
3.1) В диалоговом окне Выполнить из меню Пуск (Win   + R) введите команду gpedit.msc и нажмите Enter ↵.
3.2) Откройте Конфигурация пользователя → Административные Шаблоны → Меню "Пуск" и панель задач
3.3) Измените следующие параметры политики на значение Не задана:

- Добавить ссылку "Поиск в Интернете" в меню "Пуск"
- Удалить ссылку "Поиск" из меню "Пуск"

16. Исправление всплывающей подсказки оказывающейся за панелью задач Windows.

Если у Вас возникает ошибка, когда всплывающая подсказка оказывается за панелью задач Windows, и её видно частично или совсем не видно, то Вы можете воспользоваться небольшой программой ToolTipFixer, которая исправляет эту ошибку, возвращая на место всплывающую подсказку.

Скачайте и установите программу ToolTipFixer: с официального сайта или с зеркала

17. Решение проблемы пропадания значков в панели задач.

Это происходит потому, что загружаемые программы пытаются установить иконки раньше, чем Проводник успевает инициировать трей.
Для установки задержки запуска программ, Вы можете воспользоваться менеджером автозагрузки Startup Delayer.

В дополнение к программе воспользуйтесь твиком реестра.

Скачайте и примените его: tray_icons.reg

18. Удаление ярлыков на отсутствующие в системе элементы в папке "Недавние места".

Для удаления ярлыков на отсутствующие в системе элементы из папки "Недавние места" предлагаю Вам следующие варианты решения.

Вариант 1.

1) Откройте в Проводнике папку Недавние документы (%AppData%\Microsoft\Windows\Recent)
Просьба не путать с папкой Недавние места (это другая папка)
2) Щелкните правой кнопкой мыши ярлык на отсутствующий в системе элемент(папку или файл) и выберите пункт Удалить.
3) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Обновить. Данное действие необходимо, чтобы убрать появившуюся на рабочем столе папку Недавние места.

Вариант 2.

Для его выполнения необходима программа Registry Workshop - заменяющая стандартный редактор реестра.

1) Запустите Registry Workshop
2) Нажмите Search (Поиск) → Find...(Поиск...)
3) В открывшемся окне установите переключатель на Search in key: (В разделе:)
4) Введите HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs
5) В текстовом поле Find what: (Запрос:) введите наименование отсутствующего в системе элемента (папки или файла)
6) Нажмите кнопку Find (Поиск)
7) Выделите найденное с помощью левой кнопки мыши или нажмите комбинацию клавиш Ctrl + A, чтобы выделить все.
8) Щелкните на выделенном правой кнопкой мыши и выберите пункт Delete From Registry (Удалить из реестра)

19. При загрузке Windows автоматически открывается окно Проводника.

Варианты решений:

1) Откройте Пуск → Панель управления → Параметры папок → и уберите флажок "Восстанавливать прежние окна папок при входе в систему".
2) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
3) Введите команду и нажмите Enter ↵: sfc /scannow
4) Создайте и примените reg-файл:

20. Восстановление запуска Exe-файлов в системе.

Данные проблема связана с изменением какой-нибудь программой в реестре параметров отвечающих за ассоциации exe-файлов.
Для устранения данной проблемы попробуйте один из следующих вариантов.

Вариант 1.

1) Откройте папку C:\Windows\System32
2) Сделайте копию файла regedt32.exe
3) Переименуйте данную копию в regedt32.com
4) Щелкните на данном файле правой кнопкой мыши и выберите Запуск от имени администратора.
5) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe
6) Удалите раздел UserChoice

Вариант 2.

1) Скачайте файл exefix_win7.zip
2) Разархивируйте его и примените reg-файл.

или же создайте самостоятельно в блокноте reg-файл следующего содержания:

21. Исправление ошибки Проводника "Не удалось найти этот элемент" (Could not find this item).

Если у Вас возникает ошибка "Не удалось найти этот элемент" (Could not find this item), то скорее всего у Вас сбились описания для системных папок, а также возможно данные об их местоположении.

Чтобы это исправить Вам необходимо восстановить значения указанных ниже разделов реестра по умолчанию:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions (дополнительно для 64-битных систем)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders (дополнительно для 64-битных систем)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\ProfileList (дополнительно для 64-битных систем)

Вы можете сделать это скачав и применив один из созданных мною reg-файлов.

1) Скачайте файл NotFindThisItem_Repair.zip
2) Распакуйте его в любую папку.
3) В соответствии с разрядностью Вашей Windows примените reg-файл, восстанавливающий настройки описания папок в изначальные.
4) Перезагрузите компьютер.

22. Исправление появляющегося окна предупреждения системы безопасности "Неизвестный издатель", при открытии программы из меню Пуск.

1) Запустите командную строку от имени Администратора
(Нажмите Пуск → в строке поиска введите cmd → щелкните правой кнопкой мыши по найденному файлу cmd.exe → выберите пункт Запуск от имени Администратора)
2) Поочередно введите команды, нажимая для их выполнения клавишу Enter ↵:

23. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

24. Проводник не обновляет содержимое папки.

Если Вы желаете исправить проблему, когда в Проводнике автоматически не обновляется содержимое папки и приходится нажимать клавишу F5 чтобы обновить ее содержимое, то для этого существует очень большое количество решений и для каждой из систем подходит разное.

Вариант 1. Обновление BIOS до последней версии.

Скачайте и обновите в интернете последнюю версию BIOS для Вашей материнской платы.

Вариант 2. Установите подходящие драйвера.

Установите для Ваших устройств (сетевая карта, жесткие диски, видеокарта, звуковая карта) другие драйвера отличающиеся от Ваших:

- новые с сайта производителя
- старые с прилагаемого к устройству диска
- последние поставляемые службой Windows Update от Microsoft.

Вариант 3. Сhkdsk.

1) Запустите командную строку (Win   + R → cmd → OK).
2) Введите команду chkdsk и нажмите Enter ↵.

Вариант 4. Sfc /scannow.

1) Запустите командную строку (Win   + R → cmd → OK).
2) Введите команду sfc /scannow и нажмите Enter ↵.

Вариант 5. Сброс вида папок в Параметрах папок.

1) В меню Пуск откройте Панель управления
2) Установите Просмотр на Крупные значки и выберите Параметры папок
3) Перейдите на вкладку Вид и нажмите кнопку Сброс вида папок.
4) В открывшемся окне нажмите кнопку Да.

Вариант 6. Изменение значения контроля учетных записей (UAC).

1) Откройте Пуск → Панель управления → Учетные записи пользователей
2) Нажмите на ссылку Изменение параметров контроля учетных записей.
3) Установите переключатель в предпоследнее значение и нажмите кнопку ОК.

Вариант 7. Очистка кэша иконок и увеличение его размера.

1) Откройте Проводник
2) Введите в адресной строке %LOCALAPPDATA% и нажмите Enter ↵.
3) Удалите файл IconCache.db
4) Запустите редактор реестра (Win   + R → regedit → ОК)
5) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
6) Создайте строковый параметр (String-параметр) с именем Max Cached Icons
7) Щелкните на нем дважды введите значение 12000 и нажмите ОК.

Вариант 8. Отключение индексирования файлов.

1) Откройте Панель управления → Администрирование и запустите Службы (Win   + R → services.msc → ОК)
2) Щелкните дважды на службе Windows Search.
3) Установите тип запуска в значение Отключена и нажмите кнопку ОК.
4) В меню Пуск откройте папку Компьютер
5) Щелкните правой кнопкой мыши на жестком диске и выберите пункт Свойства.
6) Уберите флажок Разрешить индексировать содержимое файлов на этом диске в дополнение к свойствам файлов и нажмите кнопку ОК.
7) Установите переключатель в значение К диску X:\ и ко всем вложенным папкам и файлам и нажмите кнопку ОК.
8) Если всплывет окно Отказано в доступе нажмите Продолжить, если всплывет окно Ошибка изменения атрибутов, то выберите пункт Пропустить все.
9) Перезагрузите компьютер.

Вариант 9. Отключение всех не-Microsoft служб и надстроек для Проводника.

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter ↵, чтобы запустить Конфигурация системы.
3) Перейдите на вкладку Службы
4) Установите флажок Не отображать службы Майкрософт и нажмите кнопку Отключить все.
5) Нажмите кнопку ОК и щелкните Перезагрузка.

6) Скачайте небольшую утилиту ShellExView: английскую версию с официального сайта или русскую версию с зеркала.
7) Запустите ShellExView.
8) Найдите среди выведенных ею расширений оболочки - надстройки, которые не принадлежат Microsoft и отключите их.
9) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
10) Перезагрузите компьютер.

Вариант 10. Отключение сетевого обнаружения и общего доступа.

1) Щелкните правой кнопкой мыши на значок Сеть на Панели задач и выберите пункт Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
3) Щелкните на профиль Домашний или рабочий
4) Установите переключатели в значения:

Отключить сетевое обнаружение
Отключить общий доступ к файлам и принтерам

5) Щелкните на профиль Общий
6) Установите переключатели в значения:

Отключить сетевое обнаружение
Отключить общий доступ к файлам и принтерам

7) Нажмите на кнопку Сохранить изменения.

Вариант 11. Отключение пункта "Клиент для сетей Microsoft" в Свойствах "Подключение по локальной сети".

1) Щелкните правой кнопкой мыши на значок Сеть на Панели задач и выберите пункт Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменение параметров адаптера.
3) Щелкните правой кнопкой мыши на Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
4) Снимите флажок Клиент для сетей Microsoft и нажмите кнопку ОК.

Вариант 12. Установка размера буферов передачи и приема сетевой карты на максимальные значения.

1) Щелкните правой кнопкой мыши на значок Сеть на Панели задач и выберите пункт Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменение параметров адаптера.
3) Щелкните правой кнопкой мыши на Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
4) Нажмите кнопку Настроить
5) Перейдите на вкладку Дополнительно
6) Установите для свойств Receive Buffers и Transmit Buffers максимальные значения, и нажмите кнопку ОК.

Вариант 13. Создание дополнительных параметров в реестре с различными значениями.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Измените или создайте в следующих ниже разделах указанные параметры:

2.1) Изменить значение DWORD-параметра NtfsDisableLastAccessUpdate на противоположное в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem.
2.2) Создать DWORD-параметр NoNetCrawling со значением 1 в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced.
2.3) Создать DWORD-параметр NoSimpleNetIDList со значением 1 в разделе HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer.

Вариант 14. Отключение библиотек в панели навигации проводника Windows.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder
3) В списке слева, щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Разрешения.
4) Щелкните левой кнопкой мыши на группу Администраторы:
6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.
7) Дважды щелкните на параметре Attributes и измените его значение с b080010d на b090010d.
8) Закройте редактор реестра и перезапустите компьютер.

Пользователям Windows x64 также следует внести идентичные изменения в раздел:
HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder

Вариант 15. Отключение очистки буфера кэша записей.

1) Откройте Пуск → Панель управления → Диспетчер устройств
2) Разверните объект Дисковые устройства
3) Щелкните правой кнопкой мыши на устройстве и выберите пункт Свойства.
4) Перейдите на вкладку Политика
5) Установите флажок Отключить очистку буфера кэша записей Windows для этого устройства и нажмите кнопку ОК.
Если у Вас несколько дисковых устройств, то повторите данные действия для каждого устройства.

Вариант 16. Изменение режима обновлений для объектов групповой политики в домене.

1) Создайте reg-файл.
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "updatemode.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Примените полученный reg-файл. Щелкните на нем дважды и нажмите кнопку Да.

Вариант 17. Удаление и запрет создания параметра ExpandedState в реестре.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Modules\NavPane
3) Удалите параметр ExpandedState
4) В списке слева, щелкните правой кнопкой мыши на разделе реестра NavPane и выберите пункт Разрешения.
5) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
6) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
7) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
8) Нажмите кнопку Дополнительно и перейдите на вкладку Разрешения
9) Уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажмите кнопку Удалить.
10) Нажмите поочередно кнопки Добавить... → Дополнительно... → Поиск
11) В результатах поиска выберите Все и нажмите кнопку OK, и еще раз ОК.
12) Установите флажок в колонке Разрешить напротив следующих разрешений:

Запрос значения
Перечисление подразделов
Уведомление
Чтение разрешений

13) Нажмите кнопку ОК
14) Перезагрузите компьютер.

Примечание:

Ошибка не появляется и всё автоматически обновляется, если выключена локальная сеть или если завершить все процессы explorer.exe и запустить их заново.

25. Создание ярлыка и комбинации клавиш для закрытия зависших приложений и перезапуска Проводника.

Создание ярлыка и комбинации клавиш для закрытия зависших приложений.

1) Щелкните по рабочему столу и выберите во всплывшем меню Создать → Ярлык.
2) В поле Укажите расположение объекта введите команду

3) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
4) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

Создание ярлыка и комбинации клавиш для перезапуска Проводника.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .cmd. Например: restart_explorer.cmd
3) Щелкните по рабочему столу и выберите во всплывшем меню Создать → Ярлык.
4) В поле Укажите расположение объекта выберите созданный Вами командный файл.
5) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
6) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

26. Восстановление в всплывающем меню "Создать" пункта "Папку".

Если у Вас из всплывающего меню Создать находящегося в основном контекстном меню(вызывается нажатием правой кнопки мыши) пропал пункт Папку, то Вы можете скачать и применить reg-файл содержащий изначальные настройки для данного пункта меню в реестре.

Чтобы применение reg-файла прошло успешно, воспользуйтесь небольшой инструкцией:

1) Измените разрешения (установите полный доступ) и владельца для раздела реестра: HKEY_CLASSES_ROOT\CLSID\{11dbb47c-a525-400b-9e80-a54615a090c0}

1.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
1.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
1.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
1.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
1.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

2) Скачайте и примените reg-файл. NewFolderFix.zip
3) Перезагрузите компьютер. Для желающих создать данный reg-файл самостоятельно его текст:

27. Исправление отсутствия в папке Все программы из меню Пуск папки "Стандартные".

Для исправления данной ситуации Вам необходимо создать новый профиль и скопировать из него необходимые папки.

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter ↵.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в средней части окна и выберите Новый пользователь.
4) Введите любое имя пользователя (Например: Demo) и снимите флажок "Требовать смены пароля при следующем входе в систему"
5) Нажмите Создать, а когда кнопка станет не активной нажмите Закрыть.
6) Выйдите из системы и войдите в систему, используя только что созданную учётную запись.
7) Выйдите из системы и войдите в систему, используя Вашу учётную запись.
8) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter ↵.

где Demo - имя созданной Вами учетной записи.
9) Щелкните правой кнопкой мыши на папке Стандартные (Accessories) и выберите пункт Копировать
10) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter ↵.

где UserName - имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
11) Щелкните правой кнопкой мыши в пустой части окна данной папки и выберите пункт Вставить
12) Перезагрузите компьютер.

Для удаления созданной Вами учетной записи пользователя:

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter ↵.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в списке на имя созданной Вами учетной записи и выберите пункт Удалить
4) Нажмите во всплывшем окне кнопку Да и выйдите из оснастки "Локальные пользователи и группы"
5) Откройте в Проводнике папку C:\Users и удалите папку с именем созданной Вами учетной записи.

28. В папке "Библиотеки" вложенные папки (Изображения, Видео, Документы, Музыка) стали отображаться на английском языке.

Если у Вас пользовательские папки, такие как Изображения, Видео, Документы, Музыка в Проводнике стали отображаться на английском языке, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в данных папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать заново.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Вариант 1. Создайте новый профиль и скопируйте из него необходимые Desktop.ini файлы.

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter ↵.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в средней части окна и выберите Новый пользователь.
4) Введите любое имя пользователя (Например: Demo) и снимите флажок Требовать смены пароля при следующем входе в систему
5) Нажмите Создать, а когда кнопка станет не активной нажмите Закрыть.
6) Выйдите из системы и войдите в систему, используя только что созданную учётную запись.
7) Выйдите из системы и войдите в систему, используя Вашу учётную запись.
8) Откройте Проводник и введите в адресной строке необходимой адрес папки из указанного ниже списка и нажмите Enter ↵.

где Demo - имя созданной Вами учетной записи.
9) Щелкните правой кнопкой мыши на файле desktop.ini и выберите пункт Копировать
10) Введите в адресной строке Проводника адрес папки, соответствующий наименованию папки, откуда Вы скопировали файл desktop.ini и нажмите Enter ↵.

где UserName - замените на имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
Public - имя общей учетной записи (не заменяется).

11) Щелкните правой кнопкой мыши в пустой части окна данной папки и выберите пункт Вставить
12) Перезагрузите компьютер.

Для удаления созданной Вами учетной записи пользователя:

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter ↵.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в списке на имя созданной Вами учетной записи и выберите пункт Удалить
4) Нажмите во всплывшем окне кнопку Да и выйдите из оснастки Локальные пользователи и группы
5) Откройте в Проводнике папку C:\Users и удалите папку с именем созданной Вами учетной записи.

Вариант 2. Создайте файлы desktop.ini самостоятельно в указанных ниже папках.

Создайте вручную в каждой из указанных ниже папок файл desktop.ini с приведенным далее текстом.

где UserName - замените на имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
Public - имя общей учетной записи (не заменяется).

Внимание: перед параметром [.ShellClassInfo] должна быть пустая строка отступ.

Для папки Videos:

Для папки Documents:

Для папки Pictures:

Для папки Music:

29. Восстановление пропавшего из контекстного меню пункта создания текстового документа (txt-файл).

Если у Вас из контекстного меню создать вызываемого нажатием правой кнопки мыши пропал пункт Создать → Текстовый документ (Text Document), то для восстановления возможности создания текстовых документов выполните указанные ниже действия:

1) Создайте reg-файл указанного ниже содержания.

2) Примените его и перезагрузите компьютер.

30. Решение проблемы в работе AeroPeek, при которой рабочий стол не показывается при наведении мыши на край панели задач.

Если у Вас не работает функция AeroPeek, при которой рабочий стол показывается при наведении мыши на край панели задач, то выполните следующие действия:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Установите значение Dword-параметра DisablePreviewDesktop равным 0.
4) Перезагрузите компьютер или перезайдите в систему.
5) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите Свойства.
6) Нажмите на ссылку Дополнительные параметры системы и в открывшемся окне перейдите на вкладку Дополнительно.
7) В разделе Быстродействие нажмите на кнопку Параметры.
8) Установите переключатель на Обеспечить наилучшее быстродействие и нажмите кнопку Применить
9) Установите переключатель в значение Обеспечить наилучший вид и нажмите кнопку ОК.
10) Закройте окно Свойства системы.

31. Исправление нечитабельности текста под значками на рабочем столе при использовании однотонного фонового изображения.

Шрифт, используемый по умолчанию в иконках Рабочего стола отбрасывает тень.
Иногда из-за этого, при наложении текста на однотонное фоновое изображение, его невозможно прочитать.
Решением в данном случае является отключение тени шрифта.

Вариант 1.

1) Щелкните в меню Пуск правой кнопкой мыши на Компьютер и выберите пункт Свойства
2) В открывшемся окне в списке слева щелкните по ссылке Дополнительные параметры системы.
3) Нажмите кнопку Параметры в разделе Быстродействие.
4) Снимите флажок Отбрасывание теней значками на рабочем столе и нажмите ОК.

Вариант 2.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Щелкните дважды на параметре ListviewShadow или щелкните правой кнопкой мыши на нем и выберите Изменить
4) Установите значение данного параметра равным 0.
5) Перезагрузите компьютер.

32. Восстановление пункта "Очистить список последних элементов" в контекстном меню "Недавние документы".

Данную проблему можно исправить следующим образом.

1) Отключите отображение пункта Недавние документы в меню Пуск.
1.1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт Свойства
1.2) Перейдите на вкладку Меню "Пуск" и нажмите кнопку Настроить
1.3) Снимите флажок Недавние документы и нажмите кнопку OK.
2) Откройте в меню Пуск диалоговое окно Выполнить (Win   + R), введите: %AppData%\Microsoft\Windows и нажмите Enter ↵.
3) Щелкните правой кнопкой мыши на папку Недавние документы (Recent) и выберите пункт Удалить.

Если такой пункт отсутствует, то воспользуйтесь программой Unlocker для удаления данной папки.

3.1) В соответствии с разрядностью Вашего Windows cкачайте и установите программу Unlocker
3.2) Нажмите правой кнопкой на файле и в контекстном меню выберите Unlocker.
3.3) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все.

4) Откройте в меню Пуск диалоговое окно Выполнить (Win   + R), введите: shell:recent и нажмите Enter ↵. (Данное действие заново создаст папку Недавние документы.)
5) Перезагрузите компьютер или перезайтите в систему.
6) Включите пункт Недавние документы в меню Пуск.
6.1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт Свойства
6.2) Перейдите на вкладку Меню "Пуск" и нажмите кнопку Настроить
6.3) Установите флажок Недавние документы и нажмите кнопку OK.

33. Очистка кэша эскизов, для решения проблем с их отображением.

Если у Вас возникли проблемы с отображением эскизов, то Вам может помочь удаление кэша эскизов.
Для очистки кэша эскизов, выполните указанные ниже действия.

1) Нажмите комбинацию клавиш Win   + R, в поле Открыть напишите cleanmgr и нажмите OK.
2) Выберите диск на который у Вас установлена Windows (по умолчанию C:) и после оценки объема места, которое можно освободить, отметьте Эскизы и нажмите OK.
Данное действие приведет к удалению из папки %LocalAppData%\Microsoft\Windows\Explorer файлов:

thumbcache_32.db
thumbcache_96.db
thumbcache_256.db
thumbcache_1024.db
thumbcache_idx.db
thumbcache_sr.db

После удаления кэша - эскизы вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов.

34. Изменение атрибутов папки или файла при недоступном поле для установки флажка атрибутов в свойствах объекта в Проводнике.

Если поле для установки флажка для установки атрибутов в свойствах объекта в Проводнике стало неактивным (затенненым), то для изменения атрибутов файла, сделайте следующее.

1) Нажмите кнопку Пуск
2) Перейдите Все Программы → Стандартные
3) Щелкните правой кнопкой мыши на Командная строка и выберите пункт Запуск от имени администратора.
4) Введите необходимую Вам команду в соответствии с указанным ниже шаблоном и нажмите Enter ↵:

Где:

+R - установить атрибут Только чтение
-R - снять атрибут Только чтение

+A - установить атрибут Архивный
-A - снять атрибут Архивный

+S - установить атрибут Только чтение
-S - снять атрибут Только чтение

+H - установить атрибут Скрытый
-H - снять атрибут Скрытый

/S - Обработка файлов с указанными именами в текущем каталоге и во всех его подкаталогах.
/D - Обработка файлов и каталогов.

Пример:

Снятие всех установленных атрибутов, кроме Архивный у папки C:\Users - это сделает папку видимой и разрешит вносить в нее изменения.

35. Исправление проблемы появления в меню Вид пункта Расширенная плитка вместо Плитка.

Если у Вас в контекстном меню Вид, используемом для изменения стиля отображения значков в папке появился пункт Расширенная плитка вместо привычного пункта Плитка, то воспользуйтесь следующим решением:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
3) Удалите подразделы Bags и BagMRU.
4) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
5) Удалите параметр FullRowSelect (если он существует).
6) Перезагрузите компьютер.

или

Создайте и примените reg-файл, указанного ниже содержания.

36. Исправление ошибки, когда перетаскивается сначала рамка Проводника, а затем окно.

Если у Вас при попытке переместить окно Проводника, сначала перетаскивается рамка Проводника, а лишь затем окно, то воспользуйтесь следующим решением:

1) Откройте Пуск → Панель управления → Система.
2) Слева в списке нажмите ссылку Дополнительные параметры системы.
3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
4) На вкладке Визуальные эффекты установите флажок напротив пункта: Отображение содержимого окна при перетаскивании и нажмите кнопку Применить.

Если у Вас уже установлен флажок напротив данного пункта, то снимите его и нажмите кнопку Применить, после чего снова установите флажок и опять нажмите Применить.

Также Вы можете создать reg-файл, указанного ниже содержания, после применения которого Вам будет необходимо перезагрузить компьютер.

37. Удаление рекламных баннеров с рабочего стола.

Если у Вас на экране рабочего стола появился рекламный баннер с требованием указать номер телефона или отправить деньги на интернет-кошелёк, то для его удаления воспользуйтесь предложенной ниже инструкцией.

1) Вставьте или подключите установочный DVD-диск или флеш-диск (флешку) к компьютеру.
2) Перезагрузите компьютер.
3) Нажмите кнопку для вызова загрузочного меню (Boot Menu) (В зависимости от производителя материнской платы F8, F11, F12)
4) Выберите в списке Ваш диск и нажмите клавишу Enter ↵.
5) После загрузки в установочный экран Windows нажмите ⇑ Shift + F10.
6) Введите regedit и нажмите клавишу Enter ↵.
7) Нажмите на раздел HKEY_LOCAL_MACHINE
8) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
9) Откройте папку C:\Windows\System32\config (D:\Windows\System32\config), выберите файл SOFTWARE и нажмите кнопку Открыть (Open).
10) Задайте временное имя для куста (Например: SOFTWARE_original)
11) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows NT\CurrentVersion\Winlogon
12) Щелкните на параметр Shell и нажмите клавишу Enter ↵.
13) Введите указанное ниже значение и снова нажмите клавишу Enter ↵.

14) Щелкните на параметр Userinit и нажмите клавишу Enter ↵.
15) Введите указанное ниже значение (включая запятую) и снова нажмите клавишу Enter ↵.

16) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows NT\CurrentVersion\Windows
17) Щелкните на параметр AppInit_DLLs и нажмите клавишу Enter ↵.
18) Полностью удалите любое указанное значение для данного параметра и снова нажмите клавишу Enter ↵.
19) Откройте поочередно указанные ниже ветки реестра и удалите любые подозрительные программы из автозапуска.

HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\SOFTWARE_original\Wow6432Node\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE_original\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce

20) Нажмите на куст SOFTWARE_original
21) Откройте меню Файл (File) и нажмите Выгрузить куст (Unload Hive)

22) Нажмите на раздел HKEY_USERS
23) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
24) Откройте папку Вашего профиля C:\Users\Username (Например: C:\Users\Nizaury)
25) Введите в поле Имя файла (File name) ntuser.dat и нажмите кнопку Открыть (Open).
26) Задайте временное имя для куста (Например: Username_original)
27) Откройте поочередно указанные ниже ветки реестра и удалите любые подозрительные программы из автозапуска.

HKEY_USERS\Username_original\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\Username_original\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce

28) Нажмите на куст Username_original
29) Откройте меню Файл (File) и нажмите Выгрузить куст (Unload Hive)

Устранение неполадок - Устройства и BSOD.

1. При использовании сторонних плееров для видео, выкидывает в BSOD.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

2. В папке "Компьютер" не отображаются DVD-дисководы.

Уберите флажок в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

3. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски "DVD RW" и/или "CD RW" Вы получаете сообщение: "Не перезаписываемый диск" или "Диск защищён от записи", то это означает, что на диск была добавлена метка из-за которой программы определяют его как DVD-R.

Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис → Настройки → Эмуляция → Игнорировать тип носителя, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.

4. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажмите комбинацию клавиш Win+Pause
2) Щелкните ссылку Дополнительные параметры системы
3) Перейдите на вкладку Дополнительно
4) Нажмите кнопку Параметры в Загрузка и восстановление

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) В соответствии с разрядностью Вашей Windows загрузите и установите Debuggers And Tools for Windows (Автономные средства отладки для Windows): с официального сайта Microsoft или с зеркал: Debuggers And Tools для 32-битной версии Windows и Debuggers And Tools для 64-битной версии Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
4) Скопируйте файл kdfe.cmd в папку C:\Windows\Minidump

Программы необходимые для работы скрипта по умолчанию устанавливаются в папку:

C:\Program Files\Windows Kits\8.1\Debuggers\x86 - для 32-бит.
C:\Program Files\Windows Kits\8.1\Debuggers\x64 - для 64-бит.

Примечание: Если Вы изменили расположение данной папки, то в файле kdfe.cmd необходимо указать другой путь к папке, где расположен файл kd.exe.
Путь к папке указан после параметра set dbgpath=
4) Удерживая нажатой клавишу ⇑ Shift, слева в списке папок щелкните правой кнопкой мыши на папку Minidump, и выберите пункт Открыть окно команд.
5) Введите команду для запуска процесса аннализа дампа и нажмите клавишу Enter ↵ (в примере ниже файл называется Mini1110307-01.dmp)

Если Вы скопировали файл kdfe.cmd в папку C:\Windows\System32, то Вы сможете запустить анализа дампа из любой папки, указав путь к dmp-файлу.

6) Дождитесь завершения анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачайте утилиту BlueScreenView: английская версия, русская версия.
2) Распакуйте архив и запустите программу BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options → Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options → Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы.

5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

Если у Вас появляется какая-либо ошибка синего экрана смерти, и Вы задумываетесь из-за чего же она произошла, то Вы можете:

1) Скачать подборку наиболее часто встречающихся ошибок и способов устранения многих из них: BSOD.rar
2) Почитать на форуме Oszone.net темы входящие в состав темы: Устранение критических ошибок Windows

6. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления→Администрирование→Конфигурация системы>вкладка Загрузка→Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в BIOS:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled

7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

Попробуйте следующие варианты решений:

1) Попробуйте установить другую сборку или версию Windows 7.
2) Сбросьте настройки BIOS в стандартные и установите Windows заново.
3) Обнулите на материнской плате CMOS: либо переустановив и вернув перемычку, либо нажав на кнопку сброса на материнской плате.
4) Установите в списке загрузок с жестких дисков в BIOS, приоритет загрузки Вашего диска с Windows 7 на первое место.
5) Подключите диск выделенный для Windows 7, как Primary Master.

8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.

Если на Вашей мультимедиа или офисной клавиатуре перестали работать дополнительные клавиши расширяющие её функциональность, то сделайте следующее.
Во-первых, проверьте установлено ли у Вас программное обеспечение с диска идущего в комплекте к клавиатуре или с официального сайта.
Если же оно установлено, то одной из наиболее часто встречающихся причин может быть остановка службы Доступ к HID-устройствам.

1) Зайдите в Панель управления\Система и безопасность\Администрирование и запустите Службы или
Нажмите кнопку Пуск, введите в строке поиска services.msc и нажмите клавишу Enter ↵.
2) Проверьте указано ли в колонке Состояние, напротив службы Доступ к HID-устройствам значение: Работает
Если данная служба отключена и не работает, сделайте следующее:
3) Нажмите на ней правой кнопкой мыши и в появившемся меню выберите Свойства
4) Для запуска службы нажмите на кнопку Запустить
5) Также Вы можете установить Тип запуска: Автоматически, и система будет автоматически запускать данную службу при старте Windows.
6) Перейдите на вкладку Восстановление и установите действия выполняющиеся при первом или втором сбое, а также при последующих сбоях на значение Перезапуск службы и нажмите OK.

9. Исправление появившихся красных крестиков на значках локальных дисков.

1) Откройте Панель Управления → Диспетчер Устройств
1.1) Проверьте включены ли все IDE ATA/ATAPI контроллеры
1.2) Проверьте включены ли все Дисковые устройства

2) Если есть общий доступ, попробуйте его отключить
Щелкните правой кнопкой мыши на диске → Общий доступ → Расширенная настройка общего доступа... → Расширенная настройка...

3) Почистите кэш иконок: для этого в папке %USERPROFILE%\AppData\Local\ удалите файл IconCache.db
4) Воспользуйтесь специальными утилитами для оптимизации работы компьютера. Например:

4.1) TuneUp Utilities

4.1.1) Нажмите Overview of all functions (Обзор всех функций) и выберите Change Windows appearance (Изменить оформление Windows)
4.1.2) В меню слева в списке группы Icons (Значки) выберите Repair (Исправление)
4.1.3) Нажмите на кнопку Reload Icons (Перезагрузить значки), а после на кнопку Repair Icon Cache (Восстановить значки)

4.2) Windows 7 Manager

4.2.1) В меню слева во вкладке Information выберите Repair Center
4.2.2) В меню слева в Repair Center нажмите Icon Repair
4.2.3) В разделе Rebuild Icon Cache нажмите Rebuild

10. Восстановление автозапуска для всех типов приводов и устройств.

Вариант 1.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Примените созданный reg-файл и перезапустите компьютер.

Вариант 2.

1) Скачайте решение предложенное компанией Microsoft: MicrosoftFixit50475.msi
2) Запустите программу и следуйте указаниям мастера.

Для информации: Автозапуск могут заблокировать антивирусные программы, эмуляторы виртуальных дисков и программа VMware Workstation, используемой для создания виртуальной машины.

11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.

На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Ссылка для скачивания исправления: KB977178.zip

12. Cистема находит Bluetooth-адаптер, а Bluetooth-устройства его не обнаруживают.

1) Нажмите Win   + R (или Пуск → Выполнить)
2) Введите команду:

или

и нажмите Параметры Bluetooth

3) Установите необходимые Вам настройки.

Чтобы сделать компьютер обнаруживаемым устройствами с поддержкой Bluetooth, установите флажок Разрешить устройствам Bluetooth обнаруживать этот компьютер.
Чтобы разрешить добавление устройств с поддержкой Bluetooth на компьютер, установите флажок Разрешить устройствам Bluetooth подключаться к этому компьютеру.
Чтобы получать уведомления о попытках устройств с поддержкой Bluetooth подключит© к компьютеру, установите флажок Оповещать при подключении нового устройства Bluetooth.

13. Восстановление значка "Безопасное извлечение устройства".

1.1) Создайте и импортируйте в реестр reg-файл указанного ниже содержания. После чего перезагрузите компьютер.

1.2) Перезайдите в систему или перезагрузите компьютер.

2) Откройте Пуск → Выполнить (Win   + R) и запустите поочередно следующие команды

3.1) Щелкните по рабочему столу и выберите во всплывшем меню Создать → Ярлык.
3.2) В поле Укажите расположение объекта введите команду

3.3) Перенесите созданный Вами ярлык на панель задач, чтобы закрепить его там.

Также Вы можете просто запустить окно "Безопасное извлечение устройства" введя команду в диалоговом окне Выполнить (Win   + R) :

14. Решение проблемы пропадания места на системном жестком диске.

Прежде всего выполните проверку жесткого диска, если дело окажется в ошибках, то система поможет Вам их исправить:

1) Нажмите кнопку Пуск и в строке поиска введите cmd
2) Нажмите правой кнопкой мыши на найденной команде и выберите "Запустить от имени Администратора"
3) Введите команду SFC /scannow и нажмите Enter ↵.

Для увеличения свободного пространства Вы можете сделать следующее:

1) Запустите Очистка диска. Нажимаете кнопку Пуск → Все программы → Стандартные → Служебные.
1.1) На вкладке Очистка диска Вы можете удалить временные файлы
1.2) На вкладке Дополнительно Вы можете удалить все точки восстановления, кроме самой последней.

2) Отключите функцию создания точек восстановления или уменьшите размер используемого дискового пространства.
2.1) Нажмите кнопку Пуск
2.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
2.3) Слева нажмите ссылку Защита системы
2.4) В открывшемся окне нажмите кнопку Настроить
2.5) Отключите защиту системы или измените используемый ею размер дискового пространства.

4) Отключите режим гибернации.
4.1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4.2) Введите команду powercfg /h off и нажмите Enter ↵.

5) Измените размер файла подкачки.
5.1) Нажмите кнопку Пуск
5.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
5.3) Слева нажмите ссылку Дополнительные параметры системы
5.4) В разделе Быстродействие нажмите кнопку Параметры
5.5) Перейдите на вкладку Дополнительно и нажмите кнопку Изменить

6) Очистите папку кэша C:\Windows\rescache
7) Очистите папку временных файлов обновлений C:\Windows\SoftwareDistribution\Download
8) Очистите временные папки (карантин) используемой Вами системы защиты (Norton, Kaspersky, Eset 32 и др.), в некоторых стоит отключить трассировки.
9) Скачайте программу Scanner by Steffen Gerlach для анализа содержимого жестких дисков. Эта программа поможет Вам увидеть, какая папка или файл занимает большую часть вашего диска.

15. Windows не определяет второй жесткий диск после установки.

Данное действие иногда происходит по причине неправильной установки скрытого раздела System Reserved (Зарезервировано системой).
Например, если у Вас один жесткий диск, то Windows 7 при инсталляции выделяет скрытый раздел System Reserved (Зарезервировано системой) для защиты загрузочных файлов операционной системы.
Если во время инсталляции были подключены два жестких диска, то иногда Windows может некорректно определить второй жесткий диск и использовать его как скрытый раздел System Reserved (Зарезервировано системой). В результате чего, у него будет отсутствовать буква диска.

Для добавления буквы диска сделайте следующее:

1) Запустите оснастку Управление дисками (В поле поиска меню Пуск введите diskmgmt.msc и нажмите Enter ↵).
2) Находите Ваш диск, у него будет отсутствовать буква диска.
3) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску.
4) В открывшемся окне нажимаете кнопку Добавить выбираете необходимую Вам букву и нажимаете ОК.

Если диск не появился в Проводнике(Windows Explorer), то перезагрузите компьютер.

16. Не переименовывается диск (не меняется метка тома) в Windows 7.

Данная проблема может возникнуть, в результате появления в корне диска файла или папки с именем "Autorun.inf".
Если Вы не создавали его самостоятельно для защиты от вирусов использующих автозапуск, то файл (папка) мог создаться какой-либо программой.
Для исправления данной проблемы сделайте следующее:

1) Откройте Пуск → Панель управления и запустите "Параметры папок"
2) Перейдите на вкладку "Вид" и установите переключатель отвечающий за "Скрытые файлы и папки" в значение "Показывать скрытые папки, файлы и диски".
3) Удалите в корне диска файл или папку с именем "Autorun.inf".
4) Перезагрузите компьютер.
5) Измените метку диска (Win   + R → label.exe → OK)
Если же Вы создали файл "Autorun.inf" сами, то просто добавьте в него следующее:

Вместо Метка тома подставьте необходимое Вам значение.

17. Отключение отображения внутренних жестких дисков в "Безопасное извлечение устройств и дисков".

В Windows 7 система использует универсальный драйвер как для SATA (интерфейс подключения внутренних устройств), так и eSATA (интерфейс подключения внешних устройств).
Поэтому, независимо от того к которому из них подключен жесткий диск система определяет поддерживает ли устройство функцию извлечения "на лету".
Если Ваша система использует режим AHCI, то в списке Безопасное извлечение устройств и дисков на панели задач появятся Ваши жесткие диски. Это обусловлено функциональными особенностями AHCI режима, а именно функцией "горячей" замены (HotPlug), означающей возможность извлечения оборудования в компьютерной системе во время работы.
Если Вы не используете мобильное шасси (Mobile Rack) для внутренних жестких дисков и не планируете их извлекать, то Вы можете отключить их отображение в списке Безопасное извлечение устройств и дисков.

Вариант 1. Установите родные драйвера для чипсета к которому подключены жесткие диски. Например для чипсета Intel, драйвера для технология хранения Intel® Rapid.

Вариант 2. Укажите системе, что устройство должно использовать внутренний порт.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды и нажмите Enter ↵.

Где (n)- номер контроллера, на котором висит диск, а (N) - номер канала. В большинстве случаев по умолчанию это 0 в обоих случаях.

Повторите данное действие для каждого диска, заменив значения на необходимые. Номер контроллера в большинстве случаев по умолчанию равен 0 для каждого из Ваших дисков. Номер канала Вы можете посмотреть в диспетчере устройств, на вкладке Сведения, в свойствах Вашего жесткого диска. Значения каналов имеют порядковые номера, начинающиеся с цифры 0.
Например, если у Вас 2 жестких диска, то Вам, скорее всего, нужно будет ввести следующие команды:

Вариант 3. Использование стороннего программного обеспечения.

1) Скачайте и установите программу USB Safely Remove. Данная программа заменит встроенную в Windows функцию Безопасное извлечение устройств и дисков на собственную утилиту.
2) Для того, чтобы иконка пряталась, когда нет ни одного подключенного устройства, включите опцию "Hide icon when there are no devices to be stopped". Она располагается на закладке настроек "Look and Feel".

18. Проверка драйверов для выявления неполадок в работе Windows.

Если Вы предполагаете, что какой-либо из драйверов работает некорректно или, проанализировав дамп памяти, Вы определили драйвер вызвавший ошибку, то для более тщательной проверки работы драйверов Вы можете самостоятельно выполнить проверку драйверов с помощью встроенного в операционную систему средства проверки Verifier.exe.

Проверка неподписанных драйверов.

1) В строке поиска меню Пуск введите verifier и нажмите Enter ↵.
2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
5) Установите переключатель в значение Автоматически выбирать неподписанные драйверы и нажмите кнопку Далее.

Если неподписанные драйверы обнаружены, система отобразит Вам их список, в котором будут указаны файлы драйверов и их описание. Причем найденные драйвера могут принадлежать как устройствам, так и приложениям. Не закрывайте пока окно средства проверки драйверов и не нажимайте никаких кнопок.

Дальше возможно три варианта предпринимаемых Вами действий.

Вариант 1. Обновление программы или драйвера.

6) Посетите сайт производителя устройства или автора программы и скачайте более новую версию.
7) Переустановите программу или обновите драйвер.
8) После обновления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
9) Перезагрузите компьютер и продолжайте работу в операционной системе.
Если в системе не возникают ошибки связанной с данным драйвером, значит обновление драйвера или программы устранило её.

Вариант 2. Удаление программы или драйвера.

6.1) Удалите программу, которой принадлежит данный драйвер.
6.1.1) Откройте Панель управления\Все элементы панели управления\Программы и компоненты и удалите приложение, которому принадлежит драйвер.
Перед удалением программы убедитесь, что у Вас присутствует ее установочный диск или ее установка сохранена у Вас на диске.

6.2) Удалите драйвер в Диспетчере устройств.
6.2.1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
6.2.2) Нажмите в списке слева на Диспетчер устройств.
6.2.3) В Диспетчере устройств найдите устройство, щелкните по нему правой кнопкой мыши и выберите из контекстного меню пункт Свойства.
6.2.4) Перейдите на вкладку Драйвер и нажмите кнопку Удалить.

7) После удаления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
8) Перезагрузите компьютер и продолжайте работу в операционной системе.

Если в системе не возникают ошибки связанной с данным драйвером, значит удаление драйвера или программы устранило её.

Вариант 3. Проверка неподписанных драйверов.

Внимание! После проверки неподписанных драйверов система может не загрузит© (прежде чем переходить к дальнейшим действиям, прочтите данный вариант до конца).

6) Нажмите кнопку Готово и перезагрузите компьютер.

Если же после перезагрузки появился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

7) Перезагрузите компьютер
8) До начала запуска Windows нажмите на клавишуF8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter ↵, а затем сразуF8.
9) Выберите пункт Безопасный режим
10) Откройте диалоговое меню Выполнить: Пуск → Выполнить или нажмите комбинацию Win   + R
11) Введите команду verifier.exe /reset и нажмите Enter ↵.

Если система загрузилась в обычном режиме, проверка неподписанных драйверов завершилась успешно - они не являются источником проблем.

Проверка подписанных драйверов.

1) В строке поиска меню Пуск введите verifier и нажмите Enter ↵.
2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
5) Установите переключатель в значение Выбрать имя драйвера из списка и нажмите кнопку Далее.
6) Нажмите на заголовок колонки Поставщик для сортировки драйверов по их поставщику.
7) Выберите первые 10-15 драйверов установив напротив них флажки в колонке Проверить.
Не выбирайте все драйверы сразу, так как их проверка займет много времени и ресурсов системы.
8) Нажмите кнопку Готово и перезагрузите компьютер. Если система загрузилась в обычном режиме, проверка выбранных драйверов завершилась успешно - они не являются источником проблем. В таком случае повторите описанные выше действия выбрав следующие 10-15 драйверов.

Если же после перезагрузки появился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

1) Перезагрузите компьютер
2) До начала запуска Windows нажмите на клавишуF8. При появлении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter ↵, а затем сразуF8.
3) Выберите пункт Безопасный режим
4) Откройте диалоговое меню Выполнить: Пуск → Выполнить или нажмите комбинацию Win   + R
5) Введите команду verifier.exe /reset и нажмите Enter ↵. Если проверка всех драйверов завершилась успешно, то скорее всего, драйверы не являются причиной критической ошибки, возникающей в Вашей системе.

19. При установке Windows, в окне выбора раздела на диске создается раздел с нулевым размером.

В случае появления, при установке Windows, в окне выбора раздела на диске - пункта: Незанятое место на диске 0. Полный размер 0.0МБ, свободно 0.0МБ, выполните указанные ниже действия:

Если у Вас несколько дисков, то для выполнения указанной ниже инструкции оставьте подключенным только тот диск, для которого создается нулевой раздел. Остальные диски отключите.

1) Установите в BIOS режим для дисков на IDE.

Если Вы не можете войти в BIOS для изменения настроек (из-за того что компьютер висит), тогда: 1.1) Выключите компьютер, отсоедините SATA-кабель от диска
1.2) Включите компьютер и измените режим.
1.3) Выключите компьютер, подсоедините SATA-кабель к диску
1.4) Включите компьютер

2) Загрузитесь с Вашего Windows 7 DVD, выберите Установить.
3) Когда Вы окажетесь в окне выбора раздела для установки Windows, удалите все возможные разделы на диске. (Не обращая внимания, на то, что остались не удаленными нулевые разделы.)
4) Выйдите из программы установки Windows. Не продолжайте.
5) Перезапустите компьютер. При желании измените в BIOS режим для дисков с IDE на AHCI.
6) Опять загрузитесь с Вашего Windows 7 DVD, и снова выберите Установить.
7) Когда Вы окажетесь в окне выбора раздела для установки Windows, разделов с 0 размером быть не должно.
8) Укажите все доступное пространство для создание одного раздела.
9) Продолжите установку как обычно.

20. Определение устройства выведшего Windows 7 из спящего режима.

Если уходя от компьютера Вы оставили его в спящем режиме, а вернувшись обнаружили что он включен (разбужен), то для определения устройства выведшего Windows из спящего режима сделайте следующее:

1) Запустите командную строку от имени Администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду: powercfg -lastwake и нажмите ОК.
3) Результатом работы данной программы будет указание на идентификатор устройства.

Чтобы узнать, что это за устройство:

4) Запустите Редактор реестра (Win   + R → regedit → ОК)
5) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\.
6) Найдите искомое Вами устройство, согласно полученному при выполнении powercfg результату.
Наименование устройства будет отображено в найденном Вами ключе в параметре DeviceDesc

21. Отключение автоматической перезагрузки при появлении синего экрана смерти (BSOD).

Для этого отключите автоматическую перезагрузку при его появлении:

1) Нажмите комбинацию клавиш "Win+Pause"
2) Щелкните ссылку "Дополнительные параметры системы"
3) Перейдите на вкладку "Дополнительно"
4) Нажмите кнопку "Параметры" в "Загрузка и восстановление"
5) Cнимите флажок "Выполнять автоматическую перезагрузку" и нажмите ОК.

22. Восстановление используемых по умолчанию планов электропитания.

Варинт 1. Сброс и Восстановление всех планов электропитания.

Это может пригодиться, если у Вас отсутствует один или все планы управления электропитанием по умолчанию и Вы хотели бы вернуть все настройки в изначальные.

1) Запустите командную строку от имени администратора. (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
2) В командной строке введите: powercfg -restoredefaultschemes и нажмите Enter ↵.
3) Закройте командную строку и перезагрузите компьютер.

Варинт 2. Восстановление отдельного плана электропитания.

Данный вариант пригодиться, в случае неправильной настройки параметров для отдельного плана электропитания.

1) В строке поиска меню Пуск введите powercfg.cpl и нажмите Enter ↵.
или откройте Панель управления\Все элементы панели управления\Электропитание
2) Выберите план для которого Вы желаете восстановить настройки по умолчанию и нажмите на ссылку Настройка плана электропитания
3) Нажмите на ссылку Восстановить для плана параметры используемые по кмолчанию и нажмите кнопку Да.
или нажмите на ссылку Изменить дополнительные параметры питания, а затем на кнопку Восстановить параметры по умолчанию и кнопку Да.

23. Сброс (обнуление) всех значений индекса производительности.

Вариант 1. Сброс значений индексов и повторная оценка.

Чтобы полностью удалить все значения индекса производительности, Вам необходимо воспользоваться вторым или третьим вариантом.

1) Щелкните правой кнопкой мыши на иконку Компьютер в меню Пуск и выберите пункт Свойства.
2) Щелкните по ссылке Индекс производительности Windows.
3) В меню слева щелкните по ссылке Дополнительные инструменты.
4) Щелкните по ссылке Очистить все значения индекса производительности Windows и выполнить повторную оценку.
Значения индексов сбросятся и будут вычислены заново. В папке C:\Windows\Performance\WinSat\DataStore создастся новый набор xml-файлов с результатами тестов, содержащий в названии дату проведения текущей оценки.

Вариант 2. Удаление значений индексов, используя командную строку.

1) Запустите командную строку от имени администратора. (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
2) Введите указанную ниже команду и нажмите Enter ↵.

3) Закройте командную строку.

Все значения индексов будут удалены. В системе будет указано, что оценка индекса производительности не производилась. Вам необходимо будет самостоятельно произвести оценку.

Вариант 3. Удаление значений индексов, используя Проводник.

1) Откройте в Проводнике папку C:\Windows\Performance\WinSat\DataStore
2) Выделите все xml-файлы и удалите их.
3) Закройте Проводник.

Все значения индексов будут удалены. В системе будет указано, что оценка индекса производительности не производилась. Вам необходимо будет самостоятельно произвести оценку.

24. Восстановление неработающего жесткого диска или флеш-диска (флешки), используя низкоуровневое форматирование.

Если при попытке форматирования Вашего жесткого диска или флеш-диска (флешки) у Вас постоянно показывает ошибку "Windows не удается завершить форматирование".
Если на Ваш жесткий диск или флеш-диск (флешку) невозможно ничего записать или считать с него.
Если Ваш диск перестал определятся средствами Windows.
То Вы можете попытаться восстановить их работоспособность используя программу HDD Low Level Format Tool.

1) Скачайте и распакуйте в любую папку архив HDDLLFTOOL.zip
2) Запустите файл HDDLLFTOOL_Eng.exe (английская версия) или HDDLLFTOOL_Rus.exe (русская версия).
3) Выделите в списке Ваш диск и нажмите кнопку Continue (Продолжить).
4) Перейдите на вкладку LOW-LEVEL FORMAT (НИЗКОУРОВНЕВОЕ ФОРМАТИРОВАНИЕ) и нажмите кнопку FORMAT THIS DEVICE (ФОРМАТИРОВАТЬ ЭТО УСТРОЙСТВО).
При незначительных проблемах для ускорения процесса форматирования Вы можете установить флажок Perfom quick wipe (Выполнять быструю очистку).
Большего эффекта дает низкоуровневое форматирование без установки данного флажка.
5) Нажмите кнопку Да, в окне предупреждающем о потере имеющихся данных в результате форматирования.
6) Когда процесс форматирования достигнет 100% закройте программу.
7) Откройте в Проводнике папку компьютер и щелкните правой кнопкой мыши на Вашем диске.
8) Выберите пункт Форматировать и отформатируйте Ваш диск.
Некоторые диски начинают работать, только если их отформатировать сначала в формат FAT32.
В таком случае, после форматирования в FAT32 переподключите диск и отформатируйте его в другую файловую систему (NTFS, exFAT или FAT).

Устранение неполадок - Локальная сеть и Интернет.

1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженный уровень UAC.

2. В настройках сети пропадает или периодически не определяется шлюз, указанный по умолчанию.

Если у Вас пропадает или периодически не определяется шлюз, указанный по умолчанию в настройках сети, то выполните указанные ниже действия.

Вариант 1.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

где:
route - команда выводящая на экран и/или изменяющая записи в локальной таблице IP-маршрутизации.
add конечная_точка - Добавляет маршрут и определяет конечную точку маршрута. Если данный параметр не указывается, то для маршрута по умолчанию используется значение 0.0.0.0.
-p - при использовании данного параметра с командой add, указанный маршрут добавляется в реестр и используется для инициализации таблицы IP-маршрутизации каждый раз при запуске протокола TCP/IP.
mask маска_сети - Указывает маску подсети (сети). Если данный параметр не указывается, то для маршрута по умолчанию используется значение 0.0.0.0.
шлюз - значение параметра Шлюз по умолчанию IPv4, его можно узнать следующим образом:

2.1) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
2.2) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Отключить
2.3) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Включить
2.4) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите Состояние
2.5) Нажмите на кнопку Сведения и запишите значение параметра Шлюз по умолчанию IPv4

Пример готовой команды с указанным значением шлюза:

3) Перезагрузите компьютер.

Вариант 2.

1) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
2) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Отключить
3) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Включить
4) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите Состояние
5) Нажмите на кнопку Сведения и запишите указанные значения.
6) Нажмите на кнопку Закрыть, а затем нажмите кнопку Свойства
7) Установите курсор на Протокол интернета версии 4 (TCP/IPv4) и нажмите кнопку Свойства.
8) Введите записанные ранее значения параметров-IP вручную и нажмите ОК.
9) Запустите редактор реестра (Win   + R → regedit → ОК)
10) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces
11) Откройте раздел относящийся к Вашему проблемному сетевому соединению. Вы можете определить его по значению параметров, которые Вы записали ранее в пункте 5.
12) Щелкните дважды на параметр DefaultGateway или нажмите на нем правой кнопкой мыши и выберите пункт Изменить
13) Удалите любые пустые строки, оставив только одну строку - значение параметра Шлюз по умолчанию IPv4, которые Вы записали ранее в пункте 5.
14) Перезагрузите компьютер.

3. Устранение ошибок в работе Центра обновления Windows (Windows Update).

Если Центр обновления Windows (Windows Update) выдает у Вас сообщение об ошибке, то для ее исправления Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Отключите используемое Вами антивирусное программное обеспечение
2) Отключите любой из ускорителей интернета.
3) Выполните проверку наличия обновлений.

Вариант 2.

1) В адресной строке Проводника введите Панель управления\Все элементы панели управления\Устранение неполадок и нажмите Enter ↵.
2) В разделе Система и безопасность выберите пункт Устранение неполадок с помощью Центра обновления Windows.
3) В открывшемся окне нажмите кнопку Далее.
4) В случае обнаружения проблемы следуйте указаниям программы.

Вариант 3.

1) Скачайте Microsoft Fix It Tools для восстановления исходных параметров компонентов Центра обновления Windows.
2) Запустите программу и нажмите Применить
3) Нажмите кнопку Выявить проблемы и установить исправления.
4) В случае обнаружения проблемы следуйте указаниям программы.

Вариант 4.

1) В строке поиска меню Пуск введите указанную ниже команду и нажмите Enter ↵: notepad %windir%\system32\drivers\etc\hosts
2) Установите знак # в начале строки перед каждым IP-адресов, относящимся к Microsoft.
3) В главном меню Файл выберите команду Сохранить
4) Перезагрузите компьютер и повторно выполните проверку наличия обновлений.

Вариант 5.

1) Остановите службу Центр обновления Windows
1.1.1) Откройте Пуск → Панель управления → Администрирование → Службы.
1.1.2) Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Остановить.
или
1.2) Введите в командной строке (Win   + R → cmd → ОК) команду net stop wuauserv и нажмите Enter ↵.

2) Введите в адресной строке Проводника %SystemRoot% и нажмите Enter ↵
3) Удалите полностью папку SoftwareDistribution (По умолчанию, C:\Windows\SoftwareDistribution).
Внимание: Данное действие приведет к удалению временных файлов обновлений, а также журнала Центра обновления Windows.

4) Запустите службу Центр обновления Windows
4.1.1) Откройте Пуск → Панель управления → Администрирование → Службы.
4.1.2) Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Запустить.
или
4.2) Введите в командной строке (Win   + R → cmd → ОК) команду net start wuauserv и нажмите Enter ↵.
5) В Центре обновления Windows загрузите и установите все новые обновления.
6) Перезагрузите компьютер и повторно выполните проверку наличия обновлений.

Вариант 6.

1) Нажмите на часы в области уведомлений и в появившемся окне перейдите по ссылке Изменение настроек даты и времени.
2) Перейдите на вкладку Время по Интернету и нажмите на кнопку Изменить параметры.
3) Нажмите на кнопку Обновить сейчас, после обновления нажмите кнопку ОК и еще раз ОК.
4) Повторно выполните проверку наличия обновлений.

4. Решение проблемы с punkbuster на Windows 7.

Вариант 1.

Решение проблемы вылетов игр (Например: COD 5 и Battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136).
1) Обновите PunkBuster:
1.1) Скачайте программу обновления PunkBuster
1.2) Установите программу и запустите ее.
1.3) Добавьте туда игру, для которой нужно обновить punkbuster и нажмите check for updates. По завершению появится сообщение об окончании обновления.
2) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
3) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора. (PnkBstrB.exe еще есть в папке с игрой. Например: C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb).

Вариант 2.

1) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
2) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора.
3) На рабочем столе создайте bat-файл со следующим содержанием:

4) Запускайте данный bat-файл перед запуском игр.

5. Исправление длительного времени задержки (лагов) в компьютерных сетях.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3) Найдите в ней раздел соответствующий интерфейсу, по которому у Вас работает интернет. Если Вы его не нашли, то дальнейшие действия произведите во всех разделах.
4) Создайте DWORD-параметр и назовите его TcpAckFrequency
5) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
6) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.
7) Откройте Пуск → Панель управления → Программы и Компоненты
8) В меню слева нажмите ссылку Включение и отключение компонентов Windows.
9) Найдите пункт Сервер очереди сообщений Майкрософт (MSMQ) (Microsoft Message Queue (MSMQ) Server) и установите на нем флажок. Также установите флажки на всех компонентах внутри.

10) Перезагрузите компьютер.
11) Запустите Редактор реестра (Win   + R → regedit → ОК)
12) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
13) Создайте DWORD-параметр и назовите его TCPNoDelay
14) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
15) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.

6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.

7. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

8. Устранение неполадки в Центре обновления Windows: Некоторые параметры задаёт системный администратор.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте ветку [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
3) Удалите параметр DisableWindowsUpdateAccess
4) Закройте Редактор реестра и перезагрузите компьютер.

9. Постоянно пропадает подключение к локальной сети и/или интернету.

Общие рекомендации:

1) Скачайте и установите новые драйвера для сетевой карты или установите родные драйвера с диска вместо определенных Windows.
2) Разрешите в используемом Вами брандмауре (firewall) для программ, в которых Вы скачиваете файлы - автоматически использовать необходимые порты и передавать необходимые пакеты, в ином случае Ваш firewall может просто отключать соединение при большой нагрузке на сеть, приняв его за атаку.

Вариант 1. Запрещение отключения сетевого адаптера для экономии энергии.

1) Запустите Диспетчер устройств (Win   + R → devmgmt.msc → ОК)
1.1) Откройте меню Пуск
1.2) Нажмите правой кнопкой на Компьютер и выберите пункт Свойства (Панель управления\Все элементы панели управления\Система)
1.3) Нажмите на ссылку Диспетчер устройств
2) Откройте Сетевые адаптеры
3) Щелкните правой кнопкой мыши на Вашем сетевом адаптере и выберите пункт Свойства
4) Перейдите на вкладку Управление электропитанием
5) Уберите флажок Разрешить отключение этого устройства для экономии энергии.

Вариант 2. Отключение протокола интернета версии 6 (TCP/IPv6) и отключение разъединения в случае простоя.

1) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
2) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите Свойства
3) Снимите флажок Протокол интернета версии 6 (TCP/IPv6) и нажмите ОК.
Если помимо локальной сети у Вас присутствует другие типы соединений, то продолжайте далее:
4) Щелкните правой кнопкой мыши на созданном Вами соединении и выберите Свойства
5) Перейдите на вкладку Параметры
6) В ниспадающем списке параметра Время простоя до разъединения установите значение никогда
7) Перейдите на вкладку Сеть
8) Снимите флажок Протокол интернета версии 6 (TCP/IPv6) и нажмите ОК.

Вариант 3. Введение параметров-IP вручную.

1) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
2) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Отключить
3) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Включить
4) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите Состояние
5) Нажмите на кнопку Сведения и запишите указанные значения
6) Нажмите на кнопку Закрыть, а затем нажмите кнопку Свойства
7) Установите курсор на Протокол интернета версии 4 (TCP/IPv4) и нажмите кнопку Свойства.
8) Введите записанные ранее значения параметров-IP вручную и нажмите ОК.

Вариант 4. Настройка параметров сетевого адаптера.

1) Откройте Пуск → Панель управления → Диспетчер устройств
2) Найдите щелкните правой кнопкой мыши по Вашему сетевому адаптеру и выберите пункт Свойства
3) Перейдите на вкладку Дополнительно
4) Установите значение параметра Flow Control (Управление потоком) в положение Disabled (Выключено) и нажмите ОК

Вариант 5. Сброс установленных значений.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите поочередно указанные ниже команды, нажимая после введения каждой, клавишу Enter ↵.

Если после выполнения указанных выше действий пропадет соединение с сетью - проверьте записи в Журнале событий:

1) Пройдите Панель управления\Все элементы панели управления\Администрирование и откройте Просмотр событий.
2) Слева в древовидном списке оснастки откройте Просмотр событий (Локальный) → Журналы Windows и проверьте в каждом из подразделов: Приложения и Система была ли описана какая-нибудь ошибка, связанная с разрывом соединения.

Также свяжитесь со службой поддержки Вашего провайдера и проверьте настройки.

10. Восстановление пропавших иконок для htm/html/mht/url файлов.

Если у Вас в системе пропали значки для htm/html/mht/url файлов, то для их восстановления создайте и примените, в зависимости от браузера используемого по умолчанию, необходимый Вам reg-файл из указанных ниже.

Internet Explorer

Mozilla Firefox в 32-битной Windows.

Mozilla Firefox в 64-битной Windows.

Opera в 32-битной Windows.

Opera в 64-битной Windows.

Google Chrome.

11. Ошибки, возникающие при создании подключений удаленного доступа и VPN-подключений и способы их решения.

Если при подключении к Интернету возникла какая-либо из указанных ниже ошибок, то выполните рекомендуемые действия, для ее исправления.

Ошибка 52.
Варианты исправлений:
Эта ошибка обычно возникает при регистрации компьютера в сети.
Причина - совпадение IP-адреса VPN-соединения (этот адрес назначается автоматически) с IP-адресом, который уже есть в системе.
Убедитесь, что идентичный адрес не используется DVB-платой, Адаптером 1394, Адаптером Microsoft или иным подключением, если такое имеется.

Ошибки с кодами 6XX.

Ошибки 600, 601, 603, 606, 607, 610, 613, 614, 616, 618, 632, 637, 645.
Варианты исправлений:
1) Перезагрузите компьютер.
2) Если ошибка не исчезает, то проверьте Ваш компьютер на предмет наличия вирусов.
3) Удалите недавно установленные программы.
4) Отмените недавно внесенные изменения в настройки Windows.

Ошибки 604, 605, 608, 609, 615, 620.
Варианты исправлений:
1) Перезагрузите компьютер.
2) Если ошибка не исчезает, то удалите и заново создайте VPN-соединение.

Ошибка 611.
Варианты исправлений:
1) Перезагрузите компьютер и убедитесь, что локальная сеть на Вашем компьютере функционирует нормально.
2) Если ошибка не исчезает, то обратитесь в службу технической поддержки, для корректировки имеющихся настроек.

Ошибка 612.
Варианты исправлений:
1) Аналогичен варианту исправления ошибки 611.
2) Возможно на Вашем компьютере не хватает ресурсов (памяти).
3) Попробуйте закрыть запущенные программы.

Ошибка 617.
Варианты исправлений:
1) Подождите несколько минут.
2) Если после нескольких попыток подключение не установилось, то перезагрузите компьютер.

Ошибка 619.
Варианты исправлений:

Вариант 1.

1) В свойствах VPN-соединения откройте вкладку Безопасность.
2) Установите Тип VPN в значение Автоматически (либо убедитесь, что установлено значение рекомендуемое провайдером).
3) В ниспадающем списке выберите "необязательное (подключит© даже без шифрования)".
4) Оставьте установленным только флажок "Незашифрованный пароль (PAP)", если у Вас подключение типа PPTP или флажок "Протокол проверки пароля (CHAP), если у Вас подключение типа L2TP".
5) Нажмите ОК для подтверждения изменения настроек, перезагрузите компьютер и попробуйте подключит© еще раз.
6) Проверьте настройки Вашего брандмауэра, и, если не уверены в их правильности, отключите его.

Вариант 2.

Возможно на балансе Вашего счета недостаточно средств.
Пополните счет и попытайтесь подключит© снова.

Ошибка 629.
Варианты исправлений:
Обратитесь в службу технической поддержки, для корректировки имеющихся настроек.

Ошибка 642, 652.
Варианты исправлений:
1) Откройте Панель управления\Все элементы панели управления\Система.
2) В разделе Имя компьютера, имя домена и параметры рабочей группы нажмите на ссылку Изменить параметры.
3) Нажмите на кнопку Изменить
4) Введите другое имя компьютера и нажмите ОК.
5) Перезагрузите компьютер и попытайтесь подключит© снова.
6) Удалите и заново создайте соединение используемое для подключения к Интернету.
7) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибка 678.
Варианты исправлений:
1) Перезагрузите компьютер и убедитесь, что локальная сеть на Вашем компьютере функционирует нормально.
2) Проверьте настройки соединения и настройки Вашего брандмауэра (firewall).
3) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибка 633.
Варианты исправлений:
Возможно Ваше подключение "зависло".
Перезагрузите компьютер и попытайтесь подключит© снова.

Ошибка 635.
Варианты исправлений:
1) Удалите и заново создайте соединение используемое для подключения к Интернету.
2) В командной строке запущенной с правами администратора выполните команду sfc /scannow.
3) Если ошибка не исчезает, то обратитесь в службу технической поддержки, для корректировки имеющихся настроек.

Ошибки 638, 651.:
Варианты исправлений:
1) Проверьте, правильно ли подключен кабель сети/модема к компьютеру.
2) Проверьте наличие связи между компьютером и сетью с помощью соответствующего индикатора на кабеле и/или модеме.
3) Проверьте наличие питания на Вашем модеме (для модемов с внешним источником питания).
4) Переустановите драйвера сетевой карты или модема и убедитесь в Диспетчере устройств, что они установились корректно.
5) Проверьте правильность установки настроек подключения к интернету.
6) В случае использования отдельного кабеля для подключения, убедитесь, что ипользуете правильный его тип.

Ошибка 650.
Варианты исправлений:
1) Проверьте правильность установки настроек подключения к интернету.
2) В Диспетчере устройств удалите Ваш сетевой адаптер и установите его заново.
3) Проверьте физическую исправность сети.

Ошибка 678.
Варианты исправлений:
1) Проверьте правильность подключения кабеля к компьютеру.
2) Проверьте правильность установки настроек подключения к интернету и настройки Вашего брандмауэра (firewall).

Ошибка 691.
Варианты исправлений:
1) Проверьте правильность введения данных для подключения: логин/пароль.
2) Проверьте баланс средств на Вашем счету.
3) Удалите и заново создайте соединение используемое для подключения к интернету.
4) Перезагрузите компьютер и попробуйте заново подключит© к интернету.
5) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибки с кодами 7ХХ.

Ошибка 711.
Варианты исправлений:

Вариант 1.

Эта ошибка может возникнуть, если не запущены все или некоторые из перечисленных ниже служб.

Диспетчер автоматических подключений удаленного доступа
Диспетчер подключений удаленного доступа
Телефония

Для устранения этой ошибки выполните следующие действия для каждой из указанных выше служб.

1) Нажмите кнопку Пуск
2) Откройте Панель управления → Администрирование → Службы (или Win   + R → services.msc)
3) Щелкните правой кнопкой мыши на одну из указанных выше служб и затем щелкните Свойства.
4) На вкладке Общие в пункте Тип запуска выберите вариант Вручную.
5) Нажмите Применить, а затем нажмите Запустить.

Вариант 2.

1) Скачайте и установите программу Unlocker
2) Откройте папку C:\Windows\System32
3) Щелкните правой кнопкой мыши на папку LogFiles и выберите пункт Unlocker.
4) В ниспадающем списке выберите Переименовать, укажите имя LogFiles_old и нажмите кнопку ОК, и еще раз ОК.
5) В окне Выполнить переименование при следующей загрузке системы? нажмите кнопку Да.
6) Перезагрузите компьютер.

Вариант 3.

1) Щелкните правой кнопкой мыши на папке C:\Windows и выберите пункт Свойства
2) Перейдите на вкладку Безопасность
3) Проверьте, что в окне "Группы и пользователи" присутствуют указанные ниже пользователи и группы с разрешением полного доступа для них: "СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ" (CREATOR OWNER), "система" (SYSTEM), "TrustedInstaller"
Дополнительно могут быть группы "Администраторы" (Administrators), "Пользователи" (Users) со своими правами.
4) Нажмите кнопку Дополнительно и в открывшемся окне перейдите на вкладку Владелец
Проверьте, что владельцем папки Windows является TrustedInstaller
5) Если указано иное, то нажмите кнопку Изменить... → Другие пользователи или группы...
6) В текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
7) В окне Изменить владельца на: выберите TrustedInstaller и нажмите ОК.

Вариант 4.

1) Откройте меню Пуск и в строке поиска введите cmd
2) Щелкните правой кнопкой мыши на найденном файле и выберите строку "Запуск от имени администратора"
3) Введите указанную ниже команду и нажмите Enter ↵:

Ошибки 718, 721, 733, 734, 735, 741, 742, 743.
Варианты исправлений:
1) Убедитесь, что в свойствах TCP/IP подключения по локальной сети все настройки получаются автоматически.
2) Убедитесь, что в настройках протокола TCP/IP VPN-соединения не указан конкретный IP-адрес, и все настройки получаются автоматически.
3) В свойствах VPN-соединения откройте вкладку Безопасность и выберите в ниспадающем списке "необязательное (подключит© даже без шифрования)".
4) Оставьте установленным только флажок "Незашифрованный пароль (PAP)", если у Вас подключение типа PPTP или флажок "Протокол проверки пароля (CHAP), если у Вас подключение типа L2TP".
5) Удалите и заново создайте соединение используемое для подключения к интернету.
6) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибка 769.
Варианты исправлений:
1) Убедитесь, что локальная сеть на Вашем компьютере функционирует нормально (Если она отключена, то включите ее).
2) Проверьте правильность установки настроек подключения к интернету и настройки Вашего брандмауэра (firewall).
Также смотрите варианты исправлений для ошибок 638, 651..

Ошибка 789.
Варианты исправлений:
1) В свойствах VPN-соединения откройте вкладку Безопасность, выберите другой Тип VPN и попробуйте подключит©.
2) Создайте и примените reg-файл указнного ниже содержания.

3) Перезагрузите компьютер.

Ошибка 797.
Варианты исправлений:
1) Откройте Панель управления\Все элементы панели управления\Система.
2) В разделе Имя компьютера, имя домена и параметры рабочей группы нажмите на ссылку Изменить параметры.
3) Нажмите на кнопку Изменить.
4) Введите другое имя компьютера и нажмите ОК.
5) Перезагрузите компьютер и попытайтесь подключит© снова.
6) Переустановите драйвера сетевой карты или модема и убедитесь в Диспетчере устройств, что они установились корректно.
7) Удалите и заново создайте соединение используемое для подключения к интернету.
8) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибки с кодами 8ХХ.

Ошибки 800, 814, 815, 868.
Варианты исправлений:
1) Проверьте компьютер на отсутствие вирусов.
2) Проверьте соединительный кабели, выньте и вставьте его в гнездо сетевой карты.
3) Проверьте правильность установки настроек подключения к интернету и настройки Вашего брандмауэра (firewall).
4) Переустановите драйвера сетевой карты или модема и убедитесь в Диспетчере устройств, что они установились корректно.
5) Убедитесь, что локальная сеть на Вашем компьютере функционирует нормально (Если она отключена, то включите ее).
6) Удалите и заново создайте соединение используемое для подключения к интернету.
7) Попробуйте в свойствах подключения указать другой Тип VPN, а в настройках протокола TCP/IP VPN-соединения принудительно указать используемый провайдером DNS-сервер.
8) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибки с кодами 1XХХ.

Ошибка 1068.
Варианты исправлений:
Смотрите варианты исправлений для ошибки 711.

12. Исправление ошибки Internet Explorer: "Internet Explorer has stopped working".

Вариант 1.

1) Нажмите кнопку Пуск
2) Откройте Панель управления и запустите Свойства обозревателя
3) Перейдите на вкладку Дополнительно
4) Нажмите кнопку Сброс...
5) Прочитайте информационное сообщение и нажмите кнопку Сброс
6) Нажмите Закрыть и перезапустите Internet Explorer.

Вариант 2.

1) Нажмите кнопку Пуск
2) Откройте Панель управления и запустите Свойства обозревателя
3) Перейдите на вкладку Безопасность
4) Уберите флажок Включить защищенный режим.
5) Перезапустите Internet Explorer (если он был запущен).

Вариант 3.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте ветку HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions
3) Удалите все параметры, кроме параметра (По умолчанию)

Вариант 4.

1) Откройте меню Пуск.
2) В строке поиска введите gpedit.msc и нажмите Enter ↵
3) Перейдите к Конфигурация компьютера\Административные шаблоны\Система\Управление связью через Интернет\Параметры связи через интернет
4) Щелкните дважды левой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows.
5) Установите переключатель в значение Включить и нажмите ОK.

13. Восстановление исходного состояния компонентов Центра обновления Windows.

Если у Вас при работе с Центром обновлений Windows (Windows Update) возникает какая-либо ошибка, то воспользуйтесь предложенным ниже решением для исправления большинства из них.

1) Восстановите изначальные значения параметров в реестре для службы Система событий COM+.
1.1) Создайте и примените reg-файл указанного ниже содержания:

2) Восстановите изначальные значения параметров в реестре для службы Фоновая интеллектуальная служба передачи (BITS).
2.1) Создайте и сохраните reg-файл указанного ниже содержания:

2.2) Скачайте комплект программ PsTools, распакуйте в любую папку и скопируйте файл PsExec.exe в папку C:\Windows\System32.
2.3) В строке поиска меню Пуск введите команду: cmd, нажмите на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
2.4) Введите указанную ниже команду и нажмите Enter ↵:

2.5) Перейдите Файл → Импорт (File → Import), укажите созданный Вами reg-файл и нажмите кнопку Открыть.
3) Перезагрузите компьютер.
4.1) Откройте папку C:\ProgramData\Microsoft\Network\Downloader и очистите ее содержимое.
4.2) Если указанная папка отсутствует, то откройте папку C:\ProgramData\Microsoft\Network и создайте в ней папку Downloader
5) Очистите кэш обновлений, а также перезапустите и перерегистрируйте компоненты Центра обновлений Windows (Windows Update).
5.1) Для этого создайте и запустите от имени администратора bat-файл, указанного ниже содержания.
Внимание: Очистка кэша обновлений приведет к очистке списка установленных на данный момент обновлений.

6) Перезапустите компьютер.

Также Вы можете скачать архив WindowsUpdateRepair.zip с готовыми файлами из указанного совета.

EventSystemWin7.reg - восстанавливает службу "Система событий COM+"
BITSWin7.reg - восстанавливает службу "Фоновая интеллектуальная служба передачи (BITS)" применять через пункт Импорт в редактре реестра, запущенном от имени пользователя система.
PsExec.exe - позволяет запустить приложение от имени пользователя система.
Reset_Windows_Update_Full.bat - очищает кэш обновлений, а также перезапускает и перерегистрирует компоненты Центра обновлений Windows.

14. Не получается включить сетевое обнаружение в дополнительных параметрах общего доступа.

1) Откройте Панель управления\Сеть и Интернет\Центр управления сетями и общим доступом
2) Измените расположение для сети на Домашняя сеть щелкнув на ссылку Общественная сеть под Вашим подключением.
3) Откройте Панель управления → Администрирование → Службы и проверьте включены ли у Вас службы

4) Некоторые антивирусные программы также могут блокировать данные действия. Попробуйте отключить антивирусное обеспечение, затем измените настройку и проверьте сохранятся ли настройки.

15. Восстановление в Mozilla Firefox окна "Выход из Firefox" с кнопками "Сохранить и Выйти", "Выйти" и "Отмена".

1) В главном меню откройте Инструменты → Настройки
2) На вкладке Основные в разделе Запуск установите значение "При запуске Firefox: Показывать домашнюю страницу" и нажмите ОК.
3) В адрессной строке введите about:config и нажмите Enter ↵.
4) В строке Фильтр введите browser.showQuitWarning
5) Дважды щелкните на найденном параметре, чтобы его значение переключилось на true.

16. Ftp-сервер при вводе адреса в Проводнике открывается в Internet Explorer.

1) В Internet Explorer откройте Свойства обозревателя.
Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажмите на значок шестеренки.
2) Перейдите на вкладку Дополнительно
3) Установите флажок: Разрешить просмотр FTP-папок (за пределами Internet Explorer)

17. Восстановление пропавшего звука в интернет браузерах.

1) Проверьте уровень громкости в самом Flash плеере.

2) Удалите полностью, а затем поставьте заново:
2.1) Adobe Flash Player.
Удаление: ссылка
Установка: ссылка
2.2) Кодеки в системе (K-lite codeck pack, Shark007 Windows 7 Codecs или др.)
2.3) Браузеры. (Mozilla Firefox, Opera, Google Chrome или др.)
2.4) Драйвера звуковой карты

3) В Internet Explorer, проверьте стоит ли у Вас флажок в пункте Воспроизводить звуки на веб-страницах Сервис → Свойства обозревателя → Дополнительно → Раздел Мультимедиа.

4) Проверьте, установлен ли запуск службы Windows Audio Автоматически.
Панель Управления → Администрирование → Службы → двойной щелчок на Windows Audio → Тип запуска: Автоматически
Затем нажмите Остановить, потом Запустить.

5) Запустите редактор реестра (Win   + R → regedit)
Перейдите к ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32
Проверьте значение строкового(String) параметра wavemapper. Его значение должно быть msacm32.drv. Если данного параметра нет, то создайте его.

18. Удаление и/или переименование сетей с названиями Сеть 2 (Network 2), Сеть 3 (Network 3) и т.д..

Удаление и/или переименование сетей с названиями Сеть 2 (Network 2), Сеть 3 (Network 3) и т.д..

1) Запустите редактор реестра (Win   + R → regedit → ОК)

Если параметры локальной сети задаются автоматически и не требуют настройки.

2) Перейдите в раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles
3) Удалите все имеющиеся подразделы.
4) Перезагрузите компьютер и сеть с названием Сеть (Network) будет создана заново.

Если параметры локальной сети задаются вручную и требуют настройки.

2) Перейдите в раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles
3) Найдите подраздел, в котором значение параметра ProfileName соответствует названию Вашей текущей сети (Сеть 2 (Network 2), Сеть 3 (Network 3) и т.д.).
4) Удалите другие подразделы из раздела HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles, оставив только найденный.
5) Щелкните дважды на параметре ProfileName, измените значение на Сеть (Network) и нажмите Enter ↵.
6) Перезагрузите компьютер и Ваша сеть будет переименована в Сеть (Network).


Портабелизация.

1. Принципы работы Portable-программы и подготовка компьютера к её созданию.

Portable (портабельная, переносимая) программа — программное обеспечение, которое не требует установки для своего запуска, может запускаться с флеш-диска или жесткого диска, вносит минимальные изменения в операционную систему и максимально приближено по функционалу к инсталлируемой версии.
Для создания большинства Portable-программ используется принцип выявления внесенных изменений в системе, путем сравнения первого и второго снимков состояний системы.
Поэтому, состояние операционной системы, на которой будет создаваться Portable-версия программы, желательно должно быть максимально приближенно к свежеустановленной Windows.
Принцип работы Portable-программы состоит либо в эмуляции псевдоустановки в реальную систему, либо в виртуализации ресурсов (разделы реестра, системные папки), необходимых для запуска Portable-программы.
Виртуальная среда в которой виртуализируются ресурсы принято называть "Песочницей".
В большинстве случаев, рядом с exe-файлом, либо в папках %APPDATA% или %LOCALAPPDATA%, создается папка содержащая файлы необходимые для запуска программы.

Не виртуализируются или крайне сложно и проблемно виртуализируются следующие типы приложений:

1) Программы, изначально неподдерживаемые в операционной системе, где производится их запуск;
2) Плагины, Add-in-ы и прочие типы исполняемых и dll файлов которые встраиваются в приложение другого производителя, расширяя его функциональность.
3) Программы взаимодействующее с Windows сервисом запущенным под системным аккаунтом.
4) Программы, требующие установки драйверов устройств. Программа будет работать, если требуемые драйверы предустановлены в системе.
5) Программы с аппаратной защитой от копирования.

Рекомендации при работе с приложениями для создания Portable-программ.
1) Используйте виртуальную систему (VMware Workstation, Oracle VirtualBox) с свежеустановленной Windows для создания Portable-программ.
2) Если в приложении отсутствует функция сравнения изменений в системе и Вам необходимо вручную указать, что добавить, то для выявления изменений в системе используйте программу SysTracer: официальный сайт или зеркало.
3) Установите все возможные обновления через Центр обновления Windows.
4) Отключите Контроль учетных записей:
4.1) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей.
4.2) Нажмите на ссылку Изменение параметров контроля учетных записей.
4.3) Передвиньте ползунок в самое нижнее положение и нажмите ОК.
4.4) Перезагрузите компьютер
5) Отключите Защиту системы ()создание точек восстановления).
5.1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
5.2) Нажмите ссылку Защита системы и в открывшемся окне нажмите кнопку Настроить.
5.3) Установите переключатель в положение Отключить защиту системы и нажмите кнопку ОК.
6) Отключите индексирование файлов.
6.1) Откройте в меню Пуск папку Компьютер или запустите Проводник.
6.2) Щелкните правой кнопкой мыши на жестком диске и выберите пункт Свойства.
6.3) На вкладке Общие снимите флажок Разрешить индексировать содержимое файлов на этом диске в дополнение к свойствам файла и нажмите кнопку Применить.
6.4) Установите переключатель в значение К диску X:\ и ко всем вложенным папкам и файлам (X:\ - буква Вашего жесткого диска) и нажмите кнопку ОК.
6.5) Если всплывет окно Отказано в доступе нажмите Продолжить, если всплывет окно Ошибка изменения атрибутов, то выберите пункт Пропустить все.
7) Отключите имеющиеся в системе службы, работа которых может помешать созданию будущей Portable-программы:

Superfetch
Windows Search
Архивация Windows
Брандмауэр Windows
Защитник Windows
Программный поставщик теневого копирования (Microsoft)
Служба индексирования
Служба регистрации ошибок Windows
Теневое копирование тома
Центр обеспечения безопасности
Центр обновления Windows

7.1) Откройте Панель управления → Администрирование и запустите Службы (Win   + R → services.msc → ОК)
7.2) Щелкните дважды на необходимой службе.
7.3) Установите Тип запуска в значение Отключена и нажмите кнопку Применить.
7.4) Если служба запущена, то нажмите кнопку Остановить и дождитесь остановки службы.
7.5) Нажмите кнопку ОК и закройте Службы.
8) Перезагрузите компьютер.

2. Создание Portable-версии приложения в программе Cameyo.

Для создания Portable-версии приложения в программе Cameyo сделате следующее.

1) Зайдите на сайт http://online.cameyo.com/login.aspx и нажмите Create free account.
2) Создайте аккаунт и подтвердите его со своего e-mail.
3) Зайдите на http://www.cameyo.com и скачайте последнюю версию Cameyo.
4) Запустите скаченный файл, нажмите на ссылку Login вверху программы.
5) Введите Ваши логин и пароль и нажмите кнопку Login.
6) В зависимости от конфигурации Вашей системы и доступности Microsoft .Net Framework Вы увидите один из двух вариантов интерфейса.
6.1) В расширенном варианте перейдите на вкладку Studio и нажмите Capture app localy.
6.2) В упрощенном интерфейсе нажмите Capture installation.

7) Упаковщик программы Cameyo начнет захват снимка текущего состояния Вашей системы.
8) После завершения процесса захвата появится окно с кнопками Install done и Cancel:

Пока ничего в нем не нажимайте.
9) Установите в систему программу которую Вы желаете сделать Portable.
Если Вы желаете, чтобы созданная Вами Portable-программа запускалась с необходимыми Вам настройками, то запустите установленную программу и настройте ее.
Если Вам необходимо, чтобы она была зарегистрирована/активирована, то сделайте это сейчас, в ином случае программа будет запускаться в пробном режиме.
10) Нажмите кнопку Install done. Упаковщик программы Cameyo снова сделает снимок текущего состояния Вашей системы и проанализирует внесенные в систему изменения.
Теперь Вы можете либо нажать либо кнопку ОК и завершить создание Portable-программы, либо нажать кнопку Edit package и отредактировать, что будет в нее упаковано и как программа будет взаимодействовать с системой.

На вкладке General выберите способ взаимодействия программы с системой, в которой она будет запущена.

Isolation mode:

Data mode - приложение может сохранять файлы только на рабочем столе и в папке Документы.
Isolated - приложение не может вносить изменения в систему.
Full access - приложение может вносить изменения в системные файлы и в реестр.

Data storage (для открытия окна настроек нажмите ссылку Change):

Default - при запуске с жесткого диска хранилище данных (рабочая папка) будет создана в системной папке %APPDATA%, а при запуске с флеш-диска - рядом с папкой, содержащей файлы для запуска exe-файла.
Under the executable's directory - хранилище данных (рабочая папка) будет создана рядом с папкой, содержащей файлы для запуска exe-файла.
Custom location - Вы можете указать любое желаемое расположение. Пример, %ExeDir% , что обозначает папку, содержащую файлы для запуска exe-файла.

Icon (для открытия окна настроек нажмите ссылку Change icon) - позволяет установить иконку для Вашей Portable-программы.

На вкладке Files Вы можете выбрать какие файлы будут включены в виртуальный пакет. Это набор файлов которые программа будет использовать. Вы можете удалить или добавить новые папки и файлы.
Названия папок указаны в виде переменных для большей совместимости с системой, в которой будет запущена Portable-программа.

Переменная (значение в дереве программы) | Соответствие расположению в реальной системе
%Program Files% | C:\Program Files
%Windows% | C:\Windows
%Fonts% | C:\Windows\Fonts
%System% | C:\Windows\System32
%Profile% | C:\Users\UserName
%Local AppData% | C:\Users\UserName\AppData\Local
%Internet History% | C:\Users\UserName\AppData\Local\Microsoft\Windows\History
%Internet Temp% | C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files
%AppData% | C:\Users\UserName\AppData\Roaming
%NetHood% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Network Shortcuts
%Recent% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Recent
%SendTo% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo
%Programs% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
%Startup% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
%Templates% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Templates
%Desktop% | C:\Users\UserName\Desktop
%Personal% | C:\Users\UserName\Documents
%Favorites% | C:\Users\UserName\Favorites
%MyPictures% | C:\Users\UserName\Pictures
%MyVideo% | C:\Users\UserName\Videos
%Common AppData% | C:\ProgramData
%Common Profile% | C:\ProgramData
%Common StartMenu% | C:\ProgramData\Microsoft\Windows\Start Menu
%Common Programs% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs
%Common Startup% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
%Common Desktop% | C:\Users\Public\Desktop
Переменная (значение в дереве программы) | Соответствие расположению в реальной системе

На вкладке Registry Вы можете выбрать какие записи реестра будут включены в виртуальный пакет. Это набор разделов и параметров реестра которые программа будет использовать. Вы можете удалить или добавить новые разделы или параметры.

На вкладке Advanced Вы можете выбрать удалять ли следы программы при выходе.

No clean up, leave app ready to run - ничего не удаляется, приложение готово к повторному запуску.
Leave no registry traces - не оставлять следов реестра.
Remove all virtual data upon exit - приложение удаляет все данные и настройки.
Ask for confirmation before removal - спрашивать ли подтверждения при удалении.

11) После внесения желаемых изменений выберите в главном меню File пункт Save (процесс сохранения может занять несколько минут), а затем пункт Exit.
12) Созданная Вами Portable-программа будет помещена в папку Мои документы\Cameyo apps.

Для информации: При первом запуске программы Cameyo, она распаковывает себя в папку %userprofile%\AppData\Roaming\VOS\Cameyo.

3. Создание Portable-версии приложения в программе Spoon Virtual Application Studio.

Для создания Portable-версии приложения в программе Spoon Virtual Application Studio сделате следующее.

1) Зайдите на сайт http://spoon.net
2) Нажмите вверху страницы Apps и выберите пункт Virtual Application Studio.
3) Введите данные необходимые для регистрации и нажмите кнопку SIGN UP.
4) Скачайте и установите программу.
5) Щелкните вверху страницы на Ваш e-mail и нажмите пункт Account Settings.
6) Нажмите внизу страницы на кнопку VIEW CERTIFICATE напротив Spoon Virtual Application Studio.
7) Скопируйте текст из открывшегося окна Spoon Studio License в буфер обмена.
8) Запустите программу Spoon Virtual Application Studio.
9) Откройте Options → Install License Certificate, вставьте текст из буфера обмена и нажмите ОК.
11) Создайте на диске C:\ папку, куда будут сохранены результаты сравнения снимков состояния системы. (Пример: C:\CheatEnginePortable)
12) Нажмите кнопку Capture Before для создания снимка текущего состояния системы.
13) Установите в систему программу которую Вы желаете сделать Portable.
14) Запустите ее, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
15) Если программа требует перезагрузки, то закройте Virtual Application Studio, перезагрузите компьютер, а после перезагрузки запустите снова.
16) Нажмите кнопку Capture and Diff, выберите созданную Вами папку для сохранения результатов и нажмите ОK. (Пример: C:\CheatEnginePortable)

17) Нажмите Filesystem и выберите файлы и папки необходимые для добавления в Portable-программу.

Переменная (значение в дереве программы) | Соответствие расположению в реальной системе
@APPDIR@ (Application Directory) | Папка с запускающим модулем для Portable-программы
@SYSDRIVE@ (System Drive) | C:\
@PROGRAMFILES@ (Program Files) | C:\Program Files
@PROGRAMFILESCOMMON@ (Program Files\Common) | C:\Program Files\Common Files
@WINDIR@ (Windows) | C:\Windows
@SYSTEM@ (System Drive\Windows\System32) | C:\Windows\System32
@PROFILE@ (Current User Directory) | C:\Users\UserName
@APPDATALOCAL@ (Current User Directory\Local Application Data) | C:\Users\UserName\AppData\Local
@APPDATA@ (Current User Directory\Application Data) | C:\Users\UserName\AppData\Roaming
@STARTMENU@ (Current User Directory\Start Menu) | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu
@PROGRAMS@ (Current User Directory\Start Menu\Programs) | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
@STARTUP@ (Current User Directory\Start Menu\Programs\Startup) | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
@TEMPLATES@ (Current User Directory\Templates) | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Templates
@DESKTOP@ (Current User Directory\Desktop) | C:\Users\UserName\Desktop
@DOCUMENTS@ (Current User Directory\My Documents) | C:\Users\UserName\Documents
@FAVORITES@ (Current User Directory\Favorites) | C:\Users\UserName\Favorites
@MUSIC@ (Current User Directory\My Music) | C:\Users\UserName\Music
@PICTURES@ (Current User Directory\My Pictures) | C:\Users\UserName\Pictures
@APPDATACOMMON@ (All Users Directory\Application Data) | C:\ProgramData
@PROFILECOMMON@ (All Users Directory) | C:\ProgramData
@STARTMENUCOMMON@ (All Users Directory\Start Menu) | C:\ProgramData\Microsoft\Windows\Start Menu
@PROGRAMSCOMMON@ (All Users Directory\Start Menu\Programs) | C:\ProgramData\Microsoft\Windows\Start Menu\Programs
@STARTUPCOMMON@ (All Users Directory\Start Menu\Programs\Startup) | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
@TEMPLATESCOMMON@ (All Users Directory\Templates) | C:\ProgramData\Microsoft\Windows\Templates
@DESKTOPCOMMON@ (All Users Directory\Desktop) | C:\Users\Public\Desktop
@DOCUMENTSCOMMON@ (All Users Directory\Documents) | C:\Users\Public\Documents
@FAVORITESCOMMON@ (All Users Directory\Favorites) | C:\Users\Public\Favorites
@MUSICCOMMON@ (All Users Directory\Music) | C:\Users\Public\Music
@PICTURESCOMMON@ (All Users Directory\Pictures) | C:\Users\Public\Pictures
Переменная (значение в дереве программы) | Соответствие расположению в реальной системе

18) Нажмите Registry и выберите, разделы и параметры реестра, необходимые для добавления в Portable-программу.

Значение в дереве программы | Пример соответствия месторасположения
Classes root | HKEY_CLASSES_ROOT
Current User root | HKEY_CURRENT_USER
Local Machine | HKEY_LOCAL_MACHINE
Users root | HKEY_USERS

19) Для любого файла/папки или раздела/параметра реестра Вы можете выбрать один из предложенных в программе режимов изоляции виртуальной среды Portable-программы от основной (хостовой) системы.
В случае возникновения конфликтов между данными в хостовой системе и виртуальной среде, данные в виртуальной среде имеют преимущество.

Full: Portable-программе видны файлы и параметры рестра только из виртуальной файловой системы, даже если идентичные и существует на хост-устройстве. Записи перенаправляются в область данных песочницы.
Merge: Существующие в виртуальной среде файлы и параметры рестра будут объединены с идентичными на хост-машине. Записи в хостовые файлы и параметры рестра будут происходить через хост-устройство, а записи в виртуальные файлы и параметры рестра будут перенаправлены в область данных песочницы.
Write Copy: Используется, когда виртуальному приложению необходимо прочитать из файлов и и параметров рестра уже присутствующих на хост-устройстве, но изоляция хост-устройства по-прежнему необходима. Существующие на хост-устройстве файлы и и параметры рестра видны в виртуальной среде, но любые изменения их содержимого перенаправляются в область данных песочницы.
Hide: Используется, когда файл или параметр рестра на хост-машине может затруднить корректную работу приложения. Файлы и параметры рестра с включенным режимом Hide, не будут найдены Portable-программой во время ее выполнения как в виртуальной файловой системе и виртуальном реестре, так и в хост-системе и хост-реестре.

Чтобы применить выбранный режим ко всем подпапкам:
19.1) Щелкните правой кнопкой мыши на папке и выберите пункт Isolation.
19.2) В ниспадающем списке выберите необходимый Вам режим и установите флажок Apply to Subfolders и нажмите ОК.

Если в Вашей Portable-программе один exe-файл, который Вы желаете запускать, то:

21) В поле Startup File укажите какой файл следует запускать при запуске Portable-программы.
22) Нажмите кнопку Browse рядом с полем Output File, укажите имя и расположение для готового файла Portable-программы и нажмите кнопку Сохранить.
23) Нажмите на круглую кнопку "молоток с диском" и выберите пункт Save Configuration для сохранения внесенных в проект изменений.
24) Нажмите на кнопку Build и начнется сборка Portable-программы, а при появлении сообщения Finished нажмите кнопку ОК.
Ваша Portable-программа готова для использования.

Если в Вашей Portable-программе несколько exe-файлов, который Вы желаете запускать, то:

21) Скачайте и распакуйте архив SpoonStudioExeBuilder.zip, а затем скопируйте файл ExeBuilder.exe в папку к xappl-файлу проекта. (Пример: C:\CheatEnginePortable\Snapshot.xappl)
22) Откройте Setup → Shortcuts → Program Menu и нажмите кнопку Add shortcut.

23) В окне Edit Shortcut Settings нажмите кнопку Edit List.

24) В окне Startup Files выберите основной exe-файл для запуска, установив рядом с ним флажок в графе AutoStart.

25) Если необходимый Вам exe-файл отсутствует в списке, то укажите путь к нему в поле File над горизонтальным разделителем и нажмите Enter ↵.
(Пример: @PROGRAMFILES@\Cheat Engine 6.2\Tutorial-x86_64.exe)
Файл автоматически добавится в список под горизонтальным разделителем.
26) В поле Trigger рядом с дополнительным exe-файлов введите значение, которое позволит его запускать. (Пример: Tutorial-x86_64)
27) Нажмите кнопку ОК и Вы вернетесь в окно Edit Shortcut Settings.
28) В ниспадающем списке Target выберите добавленный файл. (Пример: Tutorial-x86_64.exe)
29) В поле Name введите имя ярлыка для запуска exe-файла и нажмите ОК. (Пример: Cheat Engine tutorial (64-bit))
30) Нажмите кнопку Browse рядом с полем Output File, укажите имя и расположение для готового файла Portable-программы и нажмите кнопку Сохранить.
31) Нажмите на круглую кнопку "молоток с диском" и выберите пункт Save Configuration для сохранения внесенных в проект изменений.
32) Нажмите на кнопку Build и начнется сборка Portable-программы, а при появлении сообщения Finished нажмите кнопку ОК.

33) Закройте программу Spoon Virtual Application Studio.
34) Откройте папку, где находится Ваш xappl-файл проекта и куда Вы сохранили утилиту ExeBuilder. (Пример: C:\CheatEnginePortable)
35) Запустите программу ExeBuilder и нажмите кнопку Proceed, а по завершении создания exe-файлов для запуска отдельных компонентов Portable-программы нажмите кнопку ОК.

36) Скопируйте готовые exe-файлы из папки, где находится Ваш xappl-файл проекта в папку, где находится готовый файл Portable-программы.
Ваша Portable-программа с exe-файлами для запуска отдельных компонентов, готова для использования.

4. Создание Portable-версии приложения в программе VMware ThinApp.

Для создания Portable-версии приложения в программе VMware ThinApp сделате следующее.

1) Откройте страницу https://my.vmware.com/web/vmware/evalcenter?p=vmware-thinapp и перейдите на вкладку Create an Account.
2) В поле First Name введите Ваше имя, в поле Last Name введите Вашу фамилию, в поле Email Address - Ваш e-mail и нажмите Continue.
3) Заполните все поля анкеты отмеченные звездочкой.
4) Установите флажки I agree to the terms and conditions outlined in the My VMware Terms of Use Agreement. и I agree to the terms and conditions outlined in the Evaluation End User License Agreement. и нажмите кнопку Start Free Trial.
5) Откройте письмо пришедшее на Ваш e-mail, указанный при регистрации и нажмите на ссылку activate для активации Вашего аккаунта на сайте VMware.
6) Введите пароль указанный при регистрации и нажмите Continue.
7) Скопируйте серийный номер для программы VMware ThinApp в буфер обмена.
8) Нажмите на ссылку Manually Download рядом с VMware ThinApp X.X.X (где X.X.X - номер версии).
9) Запустите установку программы и нажимайте кнопки Next (Continue).
10) В окне Enter License Key вставьте скопированный серийный номер и нажмите кнопку Enter, а в следующем окне нажмите кнопку Finish.
11) Запустите программу ThinApp Setup Capture из папки VMware в меню Пуск.
12) Нажмите кнопку Next в программе для перехода к следущему шагу.
13) Нажмите кнопку Advanced Scan Locations, выберите какие диски и разделы реестра должны быть просканированы для создания текущего снимка системы и нажмите кнопку ОК.
14) Нажмите кнопку Prescan для создания текущего снимка системы.

15) При появлении окна Setup Capture - Install Application сверните его в Панель задач.

16) Установите в систему программу которую Вы желаете сделать Portable.
17) Запустите ее, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
18.1) Если Ваша программа для продолжения требует перезагрузки, то перезагрузите компьютер.
18.1.1) После перезагрузки автоматически появится окно Setup Capture - Welcome.

18.1.2) Установите переключатель в значение Continue installation process, нажмите кнопку Next и Вы снова окажетесь в окне Setup Capture - Install Application.
18.2) Если Ваша программа для продолжения не требует перезагрузки, то восстановите свернутое окно Setup Capture - Install Application.
19) Нажмите кнопку Postscan для создания нового снимка системы.
20) Нажмите кнопку ОК в маленьком всплывшем окне Setup Capture.
21.1) В окне Setup Capture - Entry Points установите флажок напротив основного exe-файла, если при запуске Portable-программы должен запускаться один исполняемый файл и нажмите кнопку Next.

21.2) В окне Setup Capture - Entry Points установите флажки напротив нескольких exe-файлов, если при запуске Portable-программы должен запускаться любой указанный исполняемый файл из выбранных. (Например: Misrosoft Office) и нажмите кнопку Next.
22) В окне Setup Capture - Manage with Horizon нажмите кнопку Next.
23) В окне Setup Capture - Groups оставьте переключатель установленным по умолчанию в значении Everyone и нажмите кнопку Next.
24) В окне Setup Capture - Isolation выберите режим изоляции виртуальной среды Portable-программы от основной (хостовой) системы и нажмите кнопку Next.

Full write access to non-system directories (Merged Isolation Mode) - Portable-программа может читать и записывать файлы в реальную систему. Изменения, вносимые в системные папки, папки программы и %APPDATA%, будут сохранены в виртуальной среде.
Restricted write access (WriteCopy Isolation Mode) - Запрещает Portable-программе записывать в большиство папок. Рекомендуется для старых или ненадежных программ. Изменения, вносимые вне папок Рабочий стол (Desktop) и Мои документы (Documents), будут сохранены в виртуальной среде.

25) В окне Setup Capture - Sandbox выберите расположение песочницы (рабочей папки, куда будут сохранятся конфигурация и необходимые данные для работы Portable-программы) и нажмите кнопку Next.

User profile (%AppData%\Thinstall) - В папке профиля пользователя (C:\Users\Administrator\AppData\Roaming) в реальной системе будет создана папка Thinstall.
Same directory as the application (use with USB and portable media) - в папке рядом с Portable-программой.
Custom location or network drive - в указанной Вами папке.

26) В окне Setup Capture - Quality Assurance Statics выберите желаете ли Вы отправлять анонимную статистику в компанию VMware (Yes/Да или No/Нет) и нажмите кнопку Next.
27) В окне Setup Capture - Project Settings укажите имя и месторасположение для сохранения Вашего проекта и нажмите кнопку Next.

28.1) В разделе Primary data container окна Setup Capture - Package Settings установите переключатель в значение Use one of the entry points, если программа содержит один исполняемый файл, который должен запускаться при запуске Portable-программы.
Выбор данного пункта приведет к созданию одного exe-файла для запуска основного файла программы.

28.2) В разделе Primary data container окна Setup Capture - Package Settings оставьте переключатель установленным в значение Use separate .DAT file, если при запуске Portable-программы должен запускаться любой указанный исполняемый файл из выбранных. (Например: Misrosoft Office). Также данный пункт рекомендуется выбирать при больших размерах проекта.
Выбор данного пункта приведет к созданию одного dat-файла, включающего в себя виртуальную среду выполнения ThinApp, доступную только для чтения виртуальную файловую систему и виртуальный реестр и отдельных небольших exe-файлов для запуска каждой отдельной программы.
29) В разделе MSI package generation оставьте флажок Generate MSI package не установленным для большинства проектов. Generate MSI package - позволяет упаковать Вашу Portable-программу в msi-файл, являющийся пакетом установщика Windows. Его установка будет производится в папку C:\Program Files. Это может быть удобно администраторам для доставки и развертывания программы на группе машин.
30) В разделе Compression установите флажок Compress virtual package, если Вы желаете уменьшить размер будущей Portable-программы. Внимание: Процесс сжатия потребует значительного времени!
31) Нажмите кнопку Save для сохранения файлов и ключей реестра в папку проекта. Если всплыло окно Setup Capture, то нажмите в нем кнопку Да.
32) В окне Setup Capture – Ready to Build нажмите кнопку Open Project Folder и настройте какие файлы, папки, разделы и параметры реестра должны быть включены в Вашу Portable-программу.

Переменная (значение в дереве программы) | Соответствие расположению в реальной системе
%Drive_c% | C:\
%ProgramFilesDir% | C:\Program Files
%Program Files Common% | C:\Program Files\Common Files
%SystemRoot% | C:\Windows
%Fonts% | C:\Windows\Fonts
%Resources% | C:\Windows\Resources
%Resources Localized% | C:\Windows\Resources\<language_ID>
%SystemSystem% | C:\Windows\System32
%Common AppData% | C:\ProgramData
%Common StartMenu% | C:\ProgramData\Microsoft\Windows\Start Menu
%Common Programs% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs
%Common AdminTools% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools
%Common Startup% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
%Common Templates% | C:\ProgramData\Microsoft\Windows\Templates
%Profiles% | C:\Users
%Common Desktop% | C:\Users\Public\Desktop
%Common Documents% | C:\Users\Public\Documents
%Common Favorites% | C:\Users\Public\Favorites
%Profile% | C:\Users\UserName
%Local AppData% | C:\Users\UserName\AppData\Local
%CDBurn Area% | C:\Users\UserName\AppData\Local\Microsoft\Windows\Burn\Burn
%History% | C:\Users\UserName\AppData\Local\Microsoft\Windows\History
%Internet Cache% | C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files
%TEMP% | C:\Users\UserName\AppData\Local\Temp
%AppData% | C:\Users\UserName\AppData\Roaming
%Cookies% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Cookies
%NetHood% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Network Shortcuts
%PrintHood% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Printer Shortcuts
%Recent% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Recent
%SendTo% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo
%Programs% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
%AdminTools% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools
%Startup% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
%Templates% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Templates
%Desktop% | C:\Users\UserName\Desktop
%Personal% | C:\Users\UserName\Documents
%Favorites% | C:\Users\UserName\Favorites
%My Pictures% | C:\Users\UserName\Pictures
%My Videos% | C:\Users\UserName\Videos
%Drive_m% | M:\
Переменная (значение в дереве программы) | Соответствие расположению в реальной системе

Для удобства редактирования созданного Вами проекта Вы можете воспользоваться программой ThinAppHelper.
Чтобы отредактировать проект Вам необходимо открыть файл Package.ini, находящийся в папке Вашего проекта:
C:\Program Files\VMware\VMware ThinApp\Captures\AppName.
AppName - имя проекта и будущей Portable-программы (Например: C:\Program Files\VMware\VMware ThinApp\Captures\Adobe Reader X (10.1.3) - Russian)

33) Вернитесь в окно Setup Capture – Ready to Build и нажмите кнопку Build, чтобы приступить к созданию Portable-программы.
34) В окне Setup Capture – Build Project оставьте установленным флажок Open folder containing project executables after clicking Finish и нажмите кнопку Finish для завершения процесса создания Portable-программы и открытия папки содержащей готовую Portable-программу.

Если Вы решите пересобрать Вашу Portable-программу, изменив входящие в нее папки, файлы, разделы или параметры реестра, то Вы можете быстро сделать это используя ThinAppHelper. После внесения изменений нажмите на значок молотка, чтобы собрать проект в новую Portable-программу.

5. Создание Portable-версии приложения, используя PortableApps.com Launcher и PortableApps.com Installer.

Так как каждый случай для создания в данной программе уникален, то далее будет приведен самый простой шаблон создания Portable-программы.
Для создания Portable-версии приложения в программе PortableApps.com Platform сделате следующее.

1) Зайдите на сайт http://Portableapps.com/development и скачайте программу PortableApps.com Installer.
2) Установите ее в папку C:\PortableApps\PortableApps.comInstaller.
3) Зайдите на сайт http://Portableapps.com/development и скачайте программу PortableApps.com Launcher.
4) Установите ее в папку C:\PortableApps\PortableApps.comLauncher.
5) Зайдите на сайт http://Portableapps.com/apps/development/nsis_Portable и скачайте программу NSIS Portable (Unicode вариант).
6) Установите ее в папку C:\PortableApps\NSISPortable.
7) Создайте на диске C:\ рабочую папку с именем AppNamePortable, где AppName имя Вашей будущей Portable-программы. (Пример: C:\FoxitReaderPortable)
8) Создайте в данной папке папку с именем App. (Пример: C:\FoxitReaderPortable\App)
9) Скачайте программу SysTracer с официального сайта или зеркала.
10) Используя ее сделайте текущий снимок системы.
11) Установите программу, которую Вы желаете сделать Portable в директорию C:\AppNamePortable\App в соответствии с необходимыми Вам настройками.
(Пример: C:\FoxitReaderPortable\App\Foxit Reader)
12) Запустите ее, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
13) Вернитесь в SysTracer и сделайте новый снимок системы.
14) Проанализируйте внесенные изменения в реестр.
15) Откройте редактор реестра и сделайте экспорт найденных измененных веток реестра.
16) Объедините их в один reg-файл. (Пример: Foxit Software.reg)
17) Создайте в папке C:\AppNamePortable\App папку DefaultData, а в ней папку settings. (Пример: C:\FoxitReaderPortable\App\DefaultData)
18) Скопируйте в нее Ваш reg-файл.
19) Создайте в папке C:\AppNamePortable\App папку AppInfo. (Пример: C:\FoxitReaderPortable\App\AppInfo)
20) Скопируйте из папки C:\PortableApps\PortableApps.comLauncher\App\AppInfo в папку C:\AppNamePortable\App\AppInfo основную иконку для Portable-программы - appinfo.ico и дополнительные иконки - appicon_16.png, appicon_32.png, appicon_128.png. Также Вы можете использовать собственные файлы иконок с идентичными именами и расширениями файла.
21) Создайте в папке C:\AppNamePortable\App\AppInfo файл appinfo.ini, указанного ниже содержания:

Замените AppName на имя Вашей программы. Пример:

22) Создайте в папке C:\AppNamePortable\App\AppInfo папку Launcher. (Пример: C:\FoxitReaderPortable\App\AppInfo\Launcher)
23) Создайте в папке C:\AppNamePortable\App\AppInfo\Launcher файл AppNamePortable.ini, указанного ниже содержания: (Пример: FoxitReaderPortable.ini)

Пример:

24) Скопируйте файл help.html из папки C:\PortableApps\PortableApps.comLauncher в папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable\help.html)
25) Откройте папку C:\PortableApps\PortableApps.comLauncher и запустите файл PortableApps.comLauncherGenerator.exe.
26) Нажмите кнопку Next в программе для перехода к следущему шагу.
27) Укажите папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable) и нажмите кнопку Go.

28) Нажмите кнопку Finish, чтобы выйти.

29) Откройте папку C:\PortableApps\PortableApps.comInstaller и запустите файл PortableApps.comInstaller.exe.
30) Нажмите кнопку Next в программе для перехода к следущему шагу.
31) Укажите папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable) и нажмите кнопку Go.

32) Нажмите кнопку Finish, чтобы выйти.

33) Ваша готовая Portable-программа упакованная в PAF-инсталлятор будет находится в корне диска C:\.

6. Создание Portable-версии приложения, используя Portable App Creator и PortableApps.com Installer.

Для создания Portable-версии приложения, используя программу Portable App Creator сделате следующее.

1) Создайте на диске C:\ рабочую папку с именем AppNamePortable, где AppName имя Вашей будущей Portable-программы. (Пример: C:\FoxitReaderPortable)
2) Создайте в данной папке папку с именем App. (Пример: C:\FoxitReaderPortable\App)
3) Создайте на диске C:\ папку PortableApps (C:\PortableApps)
4) Cкачайте архив с программой PortableAppCreator_0__99_beta_English.zip.
5) Разархивируйте его и установите программу в папку C:\PortableApps\PortableAppCreator.
6) Зайдите на сайт http://www.autoitscript.com/site/autoit/downloads/ и скачайте AutoIt- Self Extracting Archive.
7) Распакуйте данный архив в папку C:\PortableApps\AutoIt.
8) Зайдите на сайт: http://upx.sourceforge.net/#downloadupx и скачайте архив с Ultimate Packer for eXecutables (UPX) для Win32/i386.
9) Скопируйте файл upx.exe из данного архива в папку C:\PortableApps\PortableAppCreator\App\Portable App Creator с заменой имеющегося.
10) Откройте папку C:\PortableApps\PortableAppCreator и запустите файл Portable App Creator.exe.
11) После того как необходимые файлы будут скопированы (Появится надпись: Copied the AutoIt files) нажмите кнопку Continue.
12) Выберите диск на который будет произведена установка программы, которую Вы желаете сделать Portable и нажмите кнопку Next.
13) Нажмите кнопку Browse и выберите установочный файл программы, которую Вы желаете сделать Portable и нажмите кнопку Next.

14) Нажмите кнопку Take 1st Shot или Next для создания снимка текущего состояния системы.

15) Нажмите кнопку Install Application или Next для начала установки программы.
16) Нажмите кнопку ОК в окне напоминающем, что установка должна быть произведена на диск C:\.
17) Установите программу в директорию C:\AppNamePortable\App в соответствии с необходимыми Вам настройками.
(Пример: C:\FoxitReaderPortable\App\Foxit Reader)

18) Нажмите кнопку Get Shortcut Info или Next.
19) Нажмите кнопку Browse рядом с Get the location of the application to run и укажите какой файл следует запускать при запуске Portable-программы.
(Пример: C:\FoxitReaderPortable\App\Foxit Reader\Foxit Reader.exe)

20) Нажмите кнопку Browse рядом с Get the location for the launcher, укажите папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable) и необходимое Вам имя файла для запускающего модуля будущей Portable-програмы.
(Пример: C:\FoxitReaderPortable\FoxitReaderPortable.exe)
21.1) Если Вы желаете использовать встроенный значок Вашей программы, то оставьте переключатель в значении Use the icon of the application to run.
21.2) Если Вы желаете использовать собственный значок, то установите переключатель в значении Use alternative icon, нажмите кнопку Browse рядом и укажите путь к значку.
22) Нажмите кнопку Next для перехода к следущему шагу.
23) Нажмите кнопку Open/Close или Next для запуска Вашей будущей Portable-программы.
24) Если необходимо, зарегистрируйте ее, настройте и установите обновления, после чего закройте.
25) Нажмите кнопку Take 2st Shot или Next для создания нового снимка текущего состояния системы.
26) Нажмите кнопку Process Shots или Next для выявления изменений между снимками. Процесс может занять продолжительное время.
Для уменьшения длительной задержки на данном шаге снимите флажок Compress the software using UPX на шаге Install application.
27) После того как название кнопки Process Shots изменится на Done нажмите кнопку Next для создания Portable-программы.
28) После окончания создания программы нажмите кнопку Done, чтобы завершить работу в программе Portable App Creator и закрыть ее.

29) Если Вы желаете указать какие параметры необходимо добавить в реестр при запуске Portable-программы, то откройте папку C:\AppNamePortable\Data (Пример: C:\FoxitReaderPortable\Data) и используя любой текстовый редактор отредактируйте содержимое файла AppNamePortable.prl (Пример: FoxitReaderPortable.prl).

Запускающий модуль для Вашей Portable-программа готов.
Теперь Вы можете либо скопировать папку C:\AppNamePortable в необходимое Вам расположение (например: флеш-диск), либо заархивировать ее в архив (лучше самораспаковывающийся), либо упаковать используя PortableApps.com Installer, как описано ниже.

30) Зайдите на сайт http://Portableapps.com/development и скачайте программу PortableApps.com Installer.
31) Установите ее в папку C:\PortableApps\PortableApps.comInstaller.
32) Скопируйте файл help.html из папки C:\PortableApps\PortableApps.comInstaller в папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable\help.html)
33) Создайте в папке C:\AppNamePortable\App папку AppInfo. (Пример: C:\FoxitReaderPortable\App\AppInfo)
34) Скопируйте из папки C:\PortableApps\PortableApps.comInstaller\App\AppInfo в папку C:\AppNamePortable\App\AppInfo основную иконку для установщика Portable-программы - appinfo.ico и дополнительные иконки - appicon_16.png, appicon_32.png, appicon_128.png.
35) Скопируйте из папки C:\PortableApps\PortableApps.comInstaller\App\default_bits в папку C:\AppNamePortable\App\AppInfo файл appinfo.ini.
36) Откройте скопированный файл appinfo.ini и добавьте в конец файла в раздел [Control] под Icons=1 параметр Start=AppNamePortable.exe

Должно получит© как в примере ниже:

37) Скопируйте папку Data со всем ее содержимым из папки C:\AppNamePortable в папку C:\AppNamePortable\App. (Пример: C:\FoxitReaderPortable\App\Data)
38) Создайте в папке C:\AppNamePortable папку Other, а в папке Other папку Source. (Пример: C:\FoxitReaderPortable\Other\Source)
39) Создайте в любом текстовом редакторе файл указанного ниже содержания и сохраните его в кодировке UTF-8 с именем PortableApps.comInstallerCustom.nsh в папке C:\AppNamePortable\Other\Source.

40) Откройте папку C:\PortableApps\PortableApps.comInstaller и запустите файл PortableApps.comInstaller.exe.
41) Нажмите кнопку Next в программе для перехода к следущему шагу.
42) Укажите папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable) и нажмите кнопку Go.
42.1) Флажок Interactive Mode оставьте установленным.
43) В окне Enter the Portable app's name введите имя для Portable-программы (Пример: Foxit Reader Portable) и нажмите ОК.
44) В окне Enter the Portable app's App ID нажмите ОК.
45) В окне Enter the publisher укажите свое имя или никнэйм и нажмите ОК.
46) В окне Enter the Portable app's homepage укажите либо адрес своего сайта, либо адрес сайта издателя программы, либо просто введите portableapps.com и нажмите ОК.
47) В окне Enter the app's category укажите к какой категории относится Ваша программа и нажмите ОК. (Пример: Office)
48) В окне Enter the app's description введите описание программы и нажмите ОК.
48.1) Можете взять его из пункта Описание файла на вкладке Подробно в Свойствах exe-файла Вашей программы. (Пример: Best PDF Reader for Everyday Use!)
49) В окне Enter the Portable app's language введите Multilingual и нажмите ОК.

50) В следующих четырех окнах связанных с лицензией нажмите Да.

51) В окне Enter the Portable app's display version укажите полный номер версии программы и нажмите ОК. (Пример: 5.3.0.0423)
52) В окне Enter the Portable app's package version снова укажите полный номер версии программы и нажмите ОК. (Пример: 5.3.0.0423)

53) Нажмите кнопку Finish произойдет создание инсталлятора Вашей Portable-программы.
54) В последнем окне нажмите кнопку Finish, чтобы выйти из программы или установите флажок Test Installer и нажмите кнопку Finish, чтобы протестировать работу Вашей Portable-программы.
55) Ваша готовая Portable-программа упакованная в PAF-инсталлятор будет находится в корне диска C:\.

7. Создание Portable-версии приложения в программе P-Apps.

Для создания Portable-версии приложения в программе P-Apps сделате следующее.

1) Зайдите на сайт http://Portable-app.com/Downloads.aspx
2) Введите название компании и Ваш e-mail, на который Вам пришлют ссылку.
3) Используя полученную в e-mail ссылку, скачайте и запустите скаченный файл.
4) Программа распакует себя рядом в папку с именем, идентичным имени установочного файла и автоматически запустит©.
5) Нажмите кнопку PreScan для создания снимка текущего состояния системы.

6) Нажмите кнопку Next в программе для перехода к следущему шагу.
7) На шаге с надписью Install Your Application сверните программу P-Apps и установите в систему программу которую Вы желаете сделать Portable.

8) После завершения процесса установки запустите Вашу программу, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
9) Разверните программу P-Apps и нажмите кнопку Next в программе для создания нового снимка системы.
Процесс создания нового снимка и сравнения с предыдущим может занять некоторое время.
10) На шаге с надписью Post Scan Completed нажмите кнопку Next для перехода к следущему шагу.

11) На шаге с надписью Launch File укажите какой файл следует запускать при запуске Portable-программы и нажмите кнопку Next.

12) На шаге с надписью Choose the system modes выберите режим изолированности Portable-программы от реальной системы и нажмите кнопку Next:

Low Secured - Portable-программа сможет сохранять данные и файлы в реальной операционной системе в любые месторасположения, за исключением системных папок.
При попытке доступа к ним, данные будут записаны в виртуальную систему. Medium Secured - Portable-программа сможет сохранять данные и файлы, только на Рабочий стол и в пользовательскую папку Мои Документы.
При попытке доступа в другие месторасположения, данные будут записаны в виртуальную систему. High Secured - Portable-программа будет полностью изолирована от реальной системы. любые данные и файлы будут записаны в виртуальную систему.

Изменение режима изолированности Portable-программы может сказаться на времени ее запуска и скорости работы.

13) Укажите, куда следует сохранить готовую Portable-программу и нажмите кнопку Finish.

8. Создание Portable-версии приложения в программе Evalaze.

Для создания Portable-версии приложения в программе Evalaze сделате следующее.

1) Скачайте и запустите программу Evalaze.
2) Нажмите кнопку Start Wizard в окне Welcome to Evalaze или кнопку Wizard в главном окне программы.

3) В появившемся окне нажмите кнопку Next для продолжения.
4) В разделе Application Name введите название для будущей Portable-программы.
5) Выберите папку, куда будут сохранены файлы найденные после сканирования изменений.
6) Нажмите кнопку Select Scan Range и укажите область сканирования (Папки и диски в файловой системе, разделы реестра).

7) Нажмите кнопку Next для создания снимка текущего состояния Вашей системы.
8) Нажмите кнопку Select Setup и выберите установочный файл программы, которую Вы желаете сделать Portable. Начнется обычная установка программы.

9) По завершении процесса установки запустите Вашу программу, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
10) Нажмите кнопку Next в программе Evalaze для перехода к следущему шагу.
11) Нажмите кнопку Next для создания нового снимка текущего состояния Вашей системы.
12) Выберите exe-файл для запуска и нажмите кнопку Next.

13) В ниспадающем списке выберите, где будет располагаться папка с файлами, необходимыми для запуска Portable-программы (папка "песочницы").

Same path as the application - в той же папке, где будет находит© exe-файл Portable-программы.
The users Applicationdata-folder - в папке C:\Users\UserName\AppData\Roaming
Temp directory - во временной папке Вашего профиля C:\Users\UserName\AppData\Local
Static path - принудительно указанной Вами папке.

14) В случае необходимости установите флажки:

Make Application Portable - создает полностью изолированную Portable-программу. (Папка "песочницы" не создается.)
Delete Sandbox After Exit - удалять папку с файлами, необходимыми для запуска Portable-программы после выхода из приложения.

15) Укажите какие данные будут на всплывающем окне при запуске программы или отключите его убрав флажок Show Splash Screen.

16) Нажмите кнопку Next в программе для перехода к следущему шагу.
17) В разделе Output location укажите папку, где будет сохранено готовая Portable-программа.
18) Если у Вас версия программы Professional, то оставьте флажок Save Project установленным и укажите папку, где будет сохранен проект программы Evalaze.
Это позволит Вам в будущем собрать Вашу Portable-программу с модифицированным набором данных.

19) Нажмите кнопку Next в программе для перехода к созданию готового exe-файла Вашей программы.
20) Portable-программа создана. Нажмите Exit, чтобы выйти из программы Evalaze.

Если у Вас версия программы Professional, то для пересборки Portable-программы с другим набором включенных в нее данных:

21) Перезапустите программу Evalaze.
22) Выберите в списке Recent Projects Ваш проект.
23) Перейдите на вкладку Filesystem и выберите файлы необходимые для добавления в Portable-программу.
24) Перейдите на вкладку Registry и выберите разделы и параметры реестра, необходимые для добавления в Portable-программу.
25) Перейдите обратно на вкладку Virtual Application и нажмите на значек Create Application.
26) Укажите месторасположение для сохранения готовой Portable-программы.

9. Создание Portable-версии приложения в программе Enigma Virtual Box.

Для создания Portable-версии приложения в программе Enigma Virtual Box сделате следующее.

1) Зайдите на сайт: http://enigmaprotector.com/ru/aboutvb.html
2) Скачайте и установите последнюю версию Enigma Virtual Box.
3) Установите программу, которую Вы желаете сделать Portable.
4) Запустите ее, если необходимо, зарегистрируйте и настройте, после чего закройте.
5) Запустите программу Enigma Virtual Box, выберите в меню Language пункт Russian и нажмите ОК.
6) Закройте программу и запустите снова.
7) Нажмите кнопку Открыть рядом с полем Введите имя исходного файла.
8) Выберите exe-файл который запускает программу, которую Вы желаете сделать Portable.
9) Выберите имя и месторасположение будущего exe-файла Portable-программы.
10) Откройте в Проводнике папку C:\Program Files.
11) Перетащите папку в которую установилась программа (Пример: папку Foxit Software) в окно Enigma Virtual Box.
12) Переключитесь обратно в программу Enigma Virtual Box.

13) В диалоговом окне выберите из ниспадающего меню пункт %Program Files FOLDER% и нажмите кнопку Принять.
14) Идентичным способом Вы можете добавить другие папки, связанные с Вашей программой.

Переменная (значение в дереве программы) | Соответствие расположению в реальной системе
%DEFAULT FOLDER% | Папка в которую установлена программа. (Выберите, если программа не установлена в папку C:\Program Files)
%Program Files FOLDER% | C:\Program Files
%Program Files, Common FOLDER% | C:\Program Files\Common Files
%AllUsers, ApplicationData FOLDER% | C:\ProgramData
%AllUsers, Documents FOLDER% | C:\Users\Public\Documents
%Local, ApplicationData FOLDER% | C:\Users\UserName\AppData\Local
%History FOLDER% | C:\Users\UserName\AppData\Local\Microsoft\Windows\History
%Internet Cache FOLDER% | C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files
%Temp FOLDER% | C:\Users\UserName\AppData\Local\Temp
%ApplicationData FOLDER% | C:\Users\UserName\AppData\Roaming
%Cookies FOLDER% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Cookies
%My Documents FOLDER% | C:\Users\UserName\Documents
%My Pictures FOLDER% | C:\Users\UserName\Pictures
%WINDOWS FOLDER% | C:\Windows
%SYSTEM FOLDER% | C:\Windows\System32
Переменная (значение в дереве программы) | Соответствие расположению в реальной системе

15) Если Вам неоходимо уменьшить размер будущей Portable-программы, то на вкладке Файлы нажмите на кнопку Опции для файлов.
16) Установите флажок Сжать файлы и нажмите на кнопку Принять. (Процес сжатия может занять продолжительное время.)
17) Если Вам необходимо добавить записи реестра, то перейдите на вкладку Реестр и нажмите на кнопку Опции для реестра.
18) Установите флажок Включить виртуализацию реестра и нажмите на кнопку Принять.
19) Используя меню вызываемое правой кнопкой мыши, вручную создайте необходимые Вам ключи и параметры.
20) Нажмите кнопку Обработать, чтобы начать ее создание.
21) В открывшемся окне Прогресс... нажмите кнопку Запустить.
22) Установите программу в соответствии с необходимыми Вам настройками.
23) В окне Прогресс... нажмите кнопку Закрыть.

10. Создание Portable-версии приложения, используя Universal Extractor и WinRAR.

Для создания Portable-версии приложения, используя Universal Extractor и WinRAR сделате следующее.

1) Скачайте и установите Universal Extractor и WinRAR.
2) Нажмите правой кнопкой мыши на установочном файле Вашей программы и выберите пункт Извлечь с помощью UniExtract.

Содержимое установочного файла будет распаковано рядом с ним, в папку с идентичным названием (Пример: C:\Portable\FoxitReader530.0423_enu_Setup).
3) Откройте данную папку, а в ней откройте папку {app} (Пример: C:\Portable\FoxitReader530.0423_enu_Setup\{app}).
4) Найдите в данной папке exe-файл запускающий программу (Пример: Foxit Reader.exe).
Запустите его, чтобы убедит©, что программа запускается нормально, после чего закройте.
5) Выделите все файлы в папке {app}, щелкните на выделенном правой кнопкой мыши и выберите пункт Добавить в архив.

6) В открывшемся диалоговом окне задайте имя для будущей Portable-версии программы.
7) Установите флажок Создать SFX-архив.
8) В ниспадающем списке Метод сжатия выберите значение Максимальный.

9) Перейдите на вкладку Дополнительно и нажмите кнопку Параметры SFX.

10) В открывшемся окне перейдите на вкладку Установка и в поле Выполнить введите имя exe-файла запускающего программу (Пример: Foxit Reader.exe).

11) Перейдите на вкладку Режимы, установите флажок Распаковать во временную папку и переключатель в значение Скрыть всё.

12) Перейдите на вкладку Обновление и установите нижний переключатель в значение Перезаписывать все файлы без запроса.

13) Если Вы желаете задать значек (ico-файл) для будущей Portable-программы, то перейдите на вкладку Текст и графика и укажите путь к нему в поле Загрузить значок SFX из файла. (В моем примере значек был заранее извлечен программой Restorator из самого Foxit Reader.exe)

14) Нажмите кнопку ОК для подтвержения внесенных настроек.
15) Нажмите кнопку ОК для создания Вашей Portable-программы.

Готовый exe-файл появится в папке {app} (Пример: C:\Portable\FoxitReader530.0423_enu_Setup\{app}).

11. Создание Portable-версии приложения, используя Universal Extractor, UPX и Bat_To_Exe_Converter.

Для создания Portable-версии приложения, используя Universal Extractor, Ultimate Packer for eXecutables (UPX) и Bat_To_Exe_Converter сделате следующее.

1) Скачайте и установите Universal Extractor.
2) Нажмите правой кнопкой мыши на установочном файле Вашей программы и выберите пункт Извлечь с помощью UniExtract.
Содержимое установочного файла будет распаковано рядом с ним, в папку с идентичным названием (Пример: C:\Portable\FoxitReader530.0423_enu_Setup).
3) Откройте данную папку, а в ней откройте папку {app} (Пример: C:\Portable\FoxitReader530.0423_enu_Setup\{app}).
4) Найдите в данной папке exe-файл запускающий программу (Пример: Foxit Reader.exe).
Запустите его, чтобы убедит©, что программа запускается нормально, после чего закройте.
5) Зайдите на сайт: http://upx.sourceforge.net/#downloadupx и скачайте архив с Ultimate Packer for eXecutables (UPX) для Win32/i386.
6) Скопируйте файл upx.exe из данного архива в папку {app} (Пример: C:\Portable\FoxitReader530.0423_enu_Setup\{app}\upx.exe).
7) Удерживая нажатой клавишу ⇑ Shift, щелкните правой кнопкой мыши на папку {app} и выберите пункт Открыть окно команд.
8) Введите указанную ниже команду и нажмите Enter ↵ :

9) Дождитесь окончания сжатия dll и exe-файлов (Данный процесс может занять продолжительное время).
10) После завершения сжатия всех файлов удалите файл upx.exe.
12) В строке поиска меню Пуск введите notepad и нажмите Enter ↵.
13) Введите имя exe-файла запускающего программу. Имя файла содержащее пробелы должно быть указано в кавычках (Пример: "Foxit Reader.exe").
14) Нажмите Ctrl + S, установите тип файла в значение Все файлы (*.*).
15) В поле Имя файла укажите месторасположение и название Вашего bat-файла и нажмите кнопку Сохранить (Пример: C:\Install\FoxitReader530.0423_enu_Setup\{app}\Start.bat).

16) Запустите данный файл, чтобы убедит©, что программа запускается нормально.
17) Скачайте программу Bat_To_Exe_Converter.
18) Распакуйте архив, в зависимости от разрядности Вашей операционной системы откройте папку Windows (32 bit) или Windows (64 bit) и запустите файл Bat_To_Exe_Converter.exe.
19) В поле Batch file укажите путь к Вашему bat-файлу (Пример: C:\Install\FoxitReader530.0423_enu_Setup\{app}\Start.bat).
20) В поле Save as укажите путь для exe-файла будущей Portable-программы (Пример: C:\Install\FoxitReaderPortable.exe).
21) На вкладке Options утановите переключатели в значения:

Invisible application
Temporary directory
Delete at exit

21) Установите флажки Add administrator manifest и Overwrite existing files.

22) Перейдите на вкладку Include и нажмите кнопку Add.

23) Добавьте все файлы, которые необходимы для запуска Вашей программы.
Внимание: Программа Bat_To_Exe_Converter добавляет все файлы из подпапок в одну папку. Программы, которые используют для работы файлы из подпапок работать не будут.
24) Если у Вас есть ico-файл, то Вы можете добавить его как иконку для Portable-программы на вкладке Versioninformations.
25) Нажмите кнопку Compile для создания Вашей Portable-программы.


Разное.

1. Сравнение версий Windows 7.

Доступные возможности | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Корпоративная | Максимальная
Условия продажи | Продажа только по OEM-лицензиям | Продажа в розницу и по OEM-лицензиям (только на развивающихся рынках, включая российский) | Продажа в розницу и по OEM-лицензиям | Продажа в розницу, по OEM и корпоративным лицензиям | Продажа только под корпоративными лицензиями | Продажа в розницу и по OEM-лицензиям
Окончание поддержки | 14.01.2020 | 14.01.2020 | 14.01.2020 | 14.01.2020 | 14.01.2020 | 14.01.2020
Наличие 64-битной версии | Нет | Да | Да | Да | Да | Да
Максимальный размер оперативной памяти (для 64-битных версий) | 2 Гб (для 32-битной версии) | 8 Гб | 16 Гб | 128 Гб | 128 Гб | 128 Гб
Центр восстановления Windows | Нет поддержки домена | Нет поддержки домена | Нет поддержки домена | Да | Да | Да
Функция «Домашняя группа» (создание и присоединение к группе) | Только присоединение | Только присоединение | Да | Да | Да | Да
Интерфейс Windows Aero | Нет | Только базовая тема оформления | Да | Да | Да | Да
Поддержка нескольких мониторов | Нет | Да | Да | Да | Да | Да
Быстрое переключение между пользователями | Нет | Да | Да | Да | Да | Да
Возможность смены фонового рисунка рабочего стола | Нет | Да | Да | Да | Да | Да
Диспетчер рабочего стола | Нет | Да | Да | Да | Да | Да
Центр мобильности Windows | Нет | Да | Да | Да | Да | Да
Multitouch и улучшенное распознавание рукописного ввода | Нет | Нет | Да | Да | Да | Да
Windows Media Center | Нет | Нет | Да | Да | Да | Да
Дополнительные игры | Нет | Нет | Да | Отключены по умолчанию | Отключены по умолчанию | Да
Эмулятор Windows XP(Windows XP Mode) | Нет | Нет | Нет | Да | Да | Да
EFS (система шифрования данных) | Нет | Нет | Нет | Да | Да | Да
Печать с учетом информации о местоположении | Нет | Нет | Нет | Да | Да | Да
Возможность выступать в качестве хост-компьютера Удаленного рабочего стола | Нет | Нет | Нет | Да | Да | Да
Подключение к домену | Нет | Нет | Нет | Да | Да | Да
Возможность даунгрейда до Vista или XP | Нет | Нет | Нет | Да | Да | Да
Поддержка нескольких процессоров | Нет | Нет | Нет | Да | Да | Да
AppLocker | Нет | Нет | Нет | Нет | Да | Да
BitLocker и BitLocker To Go | Нет | Нет | Нет | Нет | Да | Да
Branch Cache | Нет | Нет | Нет | Нет | Да | Да
DirectAccess | Нет | Нет | Нет | Нет | Да | Да
Подсистема для запуска Unix-приложений | Нет | Нет | Нет | Нет | Да | Да
Мультиязычная пользовательская среда | Нет | Нет | Нет | Нет | Да | Да
Загрузка с VHD (файла-образа Microsoft Virtual PC) | Нет | Нет | Нет | Нет | Да | Да
Запуск оснастки lusrmgr.msc (Local Users and Groups) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки gpedit.msc (Local Group Policy Editor) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки secpol.msc (Local Security Policy) | Нет | Нет | Нет | Да | Да | Да
Доступные возможности | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Корпоративная | Максимальная

Windows Aero — анимация окон при открытии, закрытии, сворачивании, восстановления окна, делающая работу с операционной системой более понятной. Прозрачные элементы окон с размывкой заднего плана позволяют пользователю сконцентрироваться только на содержимом активного окна. Компоненты Windows Aero:

Aero Glass — прозрачные (с размывкой заднего плана) заголовки и панели в окнах.
Windows Flip — новый вид меню Alt + Tab ↹, в котором показываются эскизы открытых окон и их значки.
Windows Flip 3D — замена Alt + Tab ↹, вызываемая сочетанием Win   + Tab ↹, теперь все окна выстраиваются в ряд в 3D. При помощи стрелок клавиатуры или колесика мышки можно прокручивать окна.
Aero Shake — позволяет свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти».
Aero Peek — позволяет отображать уменьшенные копии окон при наведении мыши на значок панели задач, переключаться между окнами приложения простым кликом по значку, перетаскивать и фиксировать на панели задач различные окна и приложения, просматривать рабочий стол одним наведением в специальную область экрана и многое другое.
Aero Snap — позволяет движением мыши разворачивать окно на полэкрана, весь экран или только по вертикальной оси.

Диспетчер рабочего стола (англ. Desktop Window Manager, DWM), ранее Desktop Compositing Engine, DCE — система графического интерфейса рабочего стола в Windows Vista и Windows 7, который используется в графическом интерфейсе Windows Aero.

Центр мобильности Windows — объединяет настройки мобильного ПК в одном месте для обеспечения быстрого доступа к ним. Из одного и того же местоположения можно выполнять различные операции, например регулировать громкость мобильного ПК, проверять состояние беспроводного сетевого подключения или настраивать яркость дисплея.

Мультитач (англ. multitouch или multi-touch) — технология, по которой сенсорный экран или тачпад отслеживает одновременно несколько точек нажатия. Например, сближая пальцы рук, можно уменьшить картинку на дисплее, а раздвигая — увеличить. Кроме того, мультитач-экраны позволяют работать с устройством одновременно нескольким пользователям.

Windows Media Center (кодовое имя Freestyle) является приложением для проигрывания мультимедиаконтента (музыки, изображений и потокового телевидения) на домашнем медиацентре.

Encrypting File System (EFS) — система шифрования данных, реализующая шифрование на уровне файлов. Данная система предоставляет возможность «прозрачного шифрования» данных, хранящихся на разделах с файловой системой NTFS для защиты потенциально конфиденциальных данных от несанкционированного доступа при физическом доступе к компьютеру и дискам.

Домен Windows — группа компьютеров одной сети, имеющих единый центр (который называется контроллером домена), использующий единую базу пользователей (то есть учётные записи находятся не на каждом в отдельности компьютере, а на контроллере домена, т.н. сетевой вход в систему), единую групповую и локальную политики, единые параметры безопасности (применимо к томам с файловой системой NTFS), ограничение времени работы учётной записи и прочие параметры, значительно упрощающие работу системного администратора организации, если в ней эксплуатируется большое число компьютеров.

AppLocker — расширенная версия политик ограниченного использования программ. Позволяет разрешать или запрещать запуск программ при определенных условиях. Например, "Разрешить запуск Adobe Acrobat версии выше 7.0".

BitLocker и BitLocker To Go — позволяет защитить все данные, от документов до паролей, путем шифрования всего диска, на котором хранятся системные файлы Windows и данные пользователей. BitLocker используется для встроенных дисков, BitLocker To Go - для съемных запоминающих устройств, таких как внешние жесткие диски и USB-устройства флэш-памяти.

BranchCache — это технология кэширования на ресурсах локальной сети данных, расположенных на удаленных серверах. Если пользователю в локальной сети потребуется файл, который уже был загружен кем-то из пользователей его сети, — он сможет получить его из локального кэш-хранилища, а не использовать канал с ограниченной пропускной способностью.

DirectAccess — обеспечивает доступ пользователей к корпоративной сети при наличии выхода в Интернет. В отличие от большинства традиционных VPN соединений, которые должны быть запущены и прерваны явно действиями пользователя, подключения DirectAccess создаются автоматически компьютером, на котором работает пользователь.

Подсистема для UNIX-приложений — представляет собой многопользовательскую среду UNIX, которая предоставляет инструментарий и библиотеки API переноса приложений для работы на компьютерах под управлением операционной системы Windows.

Загрузка с VHD-файла — использование для загрузки операционной системы Windows - VHD-файла, содержащего в себе виртуальную операционную систему имеющую полную структуру и содержание сходные с жестким диском.

Мультиязычная пользовательская среда (MUI) — Выбор нужного языка интерфейса и возможность переключения между 35 доступными языками.

2. Открытие файлов справки с расширением .hlp.

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe.
Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Официальная ссылка: здесь
Альтернативная ссылка KB917607_WinHlp32.zip

3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

Диалоговое окно Выполнить используется в Windows для открытия программы, папки или документа.
Диалоговое окно Выполнить запускается либо Пуск → Выполнить, либо нажатием комбинации клавиш Win   + R на клавиатуре.
Самые известные команды выполняемые в окне Выполнить это cmd (Командная строка) и regedit (Редактор реестра).
Зная точное названия команды Вы можете запустить любое системное приложения или оснастку Windows.
Чтобы запускать какое-либо приложение в данном диалоговом окне с правами администратора - у Вас должен быть отключен контроль учетных записей.

Для выполнения команды введите её название и нажмите Enter ↵.

Русское название элемента | Английское название элемента | Команда
Ftp-протокол (командная строка) | Ftp-protocol (command prompt) | ftp
Iexpress Wizard (не переведена) | Iexpress Wizard | iexpress
Internet Explorer | Internet Explorer | iexplore
Paint | Paint | mspaint
Wordpad | Wordpad | write
Администратор источников данных ODBC | ODBC Data Source Administrator | odbcad32
Администрирование | Administrative Tools | control admintools
Архивация и восстановление | Backup and Restore | sdclt
Блокнот | Notepad | notepad
Брандмауэр Windows | Windows Firewall | firewall.cpl
Брандмауэр Windows в режиме повышенной безопасности | Windows Firewall with Advanced Security | WF.msc
Визуальные эффекты | Visual Effects | SystemPropertiesPerformance
Включение и отключение компонентов Windows | Turn Windows features on or off | OptionalFeatures.exe
Восстановление системы | System Restore | rstrui
Выйти из системы | Log Out Of Windows | logoff
Дата и Время | Date and Time | timedate.cpl
Дефрагментация диска | Disk Defragmenter | dfrgui
Диспетчер авторизации | Authorization Manager | azman.msc
Диспетчер задач Windows | Windows Task Manager | taskmgr
Диспетчер проверки драйверов | Driver Verifier Manager | verifier
Диспетчер устройств | Device Manager | devmgmt.msc
Диспетчер устройств | Device Manager | hdwwiz.cpl
Дополнительные часы | Additional Clocks | control timedate.cpl,,1
Завершение работы Windows | Shuts Down Windows | shutdown /s
Записки | Sticky Note | StikyNot
Защита БД учетных записей Windows | Securing the Windows Account Database | syskey
Звук | Sound | mmsys.cpl
Звуки (звуковая схема) | Sounds (sound theme) | control mmsys.cpl,,2
Звукозапись | Sound Recorder | soundrecorder
Игровые устройства | Game Controllers | joy.cpl
Инициализация оборудования безопасности для TPM | Initialize the TMP security hardware | TpmInit
Калибровка цветов экрана | Display Color Calibration | dccw
Калькулятор | Calculator | calc
Командная строка | Command Prompt | cmd
Компоненты Windows | Windows Features | OptionalFeatures
Консоль управления(MMC) | Microsoft Management Console | mmc
Конфигурация системы | System Configuration | msconfig
Локальная политика безопасности | Local Security Policy | secpol.msc
Локальные пользователи и группы | Local Users and Groups | lusrmgr.msc
Мастер загрузки изображений Windows | Windows Picture Acquisition Wizard | wiaacmgr
Мастер создания общих ресурсов | Create A Shared Folder Wizard | shrpubw
Мастер установки драйверов устройств | Driver Package Installer | dpinst
Мастер установки оборудования | Add Hardware Wizard | hdwwiz
Микшер громкости | Sound Volume | sndvol
Монитор ресурсов | Resource Monitor | perfmon.exe /res
Монитор ресурсов | Resource Monitor | resmon
Настройка доступа программ и умолчаний | Set Program Access and Computer Defaults | control appwiz.cpl,,3
Настройка Контроля Учетных Записей | User Account Control Settings | UserAccountControlSettings
Ножницы | Snipping Tool | snippingtool
Общие папки | Shared Folders | fsmgmt.msc
Очистка диска | Disk Cleanup Utility | cleanmgr
Панель математического ввода | Math Input Panel | mip
Панель управления | Control Panel | control
Папка "Fonts" | Fonts Folder | fonts
Папка "Загрузки" | "Downloads" Folder | Downloads
Параметры папок | Folder Options | control folders
Перезагрузка | Restart Windows | shutdown /r
Перенос принтеров | Printer Migration | PrintBrmUi
Перо и сенсорные устройства | Pen and Touch | TabletPC.cpl
Персонализация | Personalization | control desktop
Планировщик заданий | Task Sheduler | control schedtasks
Планировщик заданий | Task Sheduler | taskschd.msc
Подключение к удаленному рабочему столу | Remote Desktop Connection | mstsc
Подключение к сетевому проектору | Connect to a Network Projector | NetProj
Подключить к проектору | Connect to a Projector | displayswitch
Получение программ | Get Programs | control appwiz.cpl,,1
Приступая к работе | Getting Started | RunDLL32 oobefldr.dll,ShowWelcomeCenter
Проверка диска | Check Disk Utility | chkdsk
Проверка и восстановление системных файлов | System File Checker (Scan and Repair) | sfc /scannow
Проверка подписи файла | File Signature Verification | sigverif
Проводник | Windows Explorer | explorer
Проводник: C:\ | Windows Explorer: C:\ | \
Проводник: С:\Users\Ваше_имя | Windows Explorer: С:\Users\Your_name | .
Проводник: С:\Users\ | Windows Explorer: С:\Users\ | ..
Программа DiskPart | Disk Partition Manager | diskpart
Программы и компоненты | Programs and Features | appwiz.cpl
Просмотр событий | Event Viewer | eventvwr.msc
Разрешение экрана | Screen Resolution | desk.cpl
Редактор личных знаков | Private Character Editor | eudcedit
Редактор локальной групповой политики | Local Group Policy Editor | gpedit.msc
Редактор реестра | Registry Editor | regedit
Редактор реестра | Registry Editor | regedt32
Редактор титульных страниц факсов | Fax Cover Sheet Editor | fxscover
Результирующая политика | Resultant Set of Policy | rsop.msc
Сведения о системе | System Information | msinfo32
Свойства системы | System Properties | sysdm.cpl
Свойства системы: Дополнительно | System Properties: Advanced | SystemPropertiesAdvanced
Свойства системы: Защита системы | System Properties: System Protection | SystemPropertiesProtection
Свойства системы: Оборудование | System Properties: Hardware | SystemPropertiesHardware
Свойства системы: Удаленный доступ | System Properties: Remote | SystemPropertiesRemote
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | iscsicpl
Свойства: Интернет | Internet Properties | inetcpl.cpl
Свойства: Интернет: Общие | Internet Properties: General | control inetcpl.cpl,,0
Свойства: Интернет: Безопасность | Internet Properties: Security | control inetcpl.cpl,,1
Свойства: Интернет: Конфиденциальность | Internet Properties: Privacy | control inetcpl.cpl,,2
Свойства: Интернет: Содержание | Internet Properties: Content | control inetcpl.cpl,,3
Свойства: Интернет: Подключения | Internet Properties: Connections | control inetcpl.cpl,,4
Свойства: Интернет: Программы | Internet Properties: Programs | control inetcpl.cpl,,5
Свойства: Интернет: Дополнительно | Internet Properties: Advanced | control inetcpl.cpl,,6
Свойства: Клавиатура | Keyboard Properties | control keyboard
Свойства: Мышь | Mouse Properties | control mouse
Свойства: Мышь | Mouse Properties | main.cpl
Свойства: Мышь: Параметры указателя | Mouse Properties: Pointer Options | control main.cpl,,2
Свойства: Мышь: Указатели (схема) | Mouse Properties: Pointers | control main.cpl,,1
Сертификаты | Sertificates | certmgr.msc
Сетевые подключения | Network Connections | control netconnections
Сетевые подключения | Network Connections | ncpa.cpl
Системный монитор | Performance Monitor | perfmon.msc
Служба индексирования | Indexing Service | ciadv.msc
Службы | Services | services.msc
Службы компонентов | Component Services | dcomcnfg
Службы компонентов | Component Services | comexp.msc
Совместимость программы | Program Compatibility | msdt.exe -id PCWDiagnostic
Создать диск восстановления системы | Create a system repair disk | recdisc
Соседние пользователи | People Near Me | collab.cpl
Сохранение имен пользователей и паролей | Stored User Names and Passwords | credwiz
Средство диагностики DirectX | Direct X Troubleshooter | dxdiag
Средство диагностики службы технической поддержки | Microsoft Support Diagnostic Tool | msdt
Средство калибровки дигитайзера | Ditilizer Calibration Tool | tabcal
Средство настройки текста ClearType | ClearType Text Tuner | cttune
Средство переноса данных Windows | Windows Easy Transfer | migwiz
Средство проверки памяти Windows | Windows Memory Diagnostic | MdSched
Средство просмотра XPS | XPS Viewer | xpsrchvw
Стредство записи действий по воспроизведению неполадок | Problem Steps Recorder | psr
Таблица символов | Character Map | charmap
Телефон и модем | Phone and Modem | telephon.cpl
Удаленный помощник Windows | Windows Remote Assistance | msra
Управление дисками | Disk Management | diskmgmt.msc
Управление компьютером | Computer Management | compmgmt.msc
Управление компьютером | Computer Management | compmgmtlauncher
Управление печатью | Print Management | printmanagement.msc
Управление цветом | Color Management | colorcpl
Установка или удаление языков интерфейса | Install or uninstall display languages | lpksetup
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control printers
Учетные записи пользователей | User Accounts | control userpasswords2
Учетные записи пользователей | User Accounts | Netplwiz
Цвет и внешний вид окна | Window Color and Appearance | control color
Центр мобильности Windows | Windows Mobility Center | mblctr
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | wscui.cpl
Центр синхронизации | Sync Center | mobsync
Центр специальных возможностей | Ease of Access Center | utilman
Шифрующая файловая система (EFS) | Encryption File System | rekeywiz
Шрифты (добавление или удаление) | Fonts | control fonts
Экран (размер текста) | Display (size of text) | dpiscaling
Экранная клавиатура | On-Screen Keyboard | osk
Экранная лупа | Magnifier | magnify
Экранный диктор | Microsoft Narrator | narrator
Электропитание | Power Options | powercfg.cpl
Электропитание: Дополнительные параметры | Power Options: Advanced Settings | control powercfg.cpl,,1
Элемент управления WMI | Windows Management Infrastructure | wmimgmt.msc
Язык и региональные стандарты | Region and Language | intl.cpl
Язык и региональные стандарты: Дополнительно | Region and Language: Administrative | control intl.cpl,,3
Язык и региональные стандарты: Расположение | Region and Language: Location | control intl.cpl,,1
Язык и региональные стандарты: Форматы | Region and Language: Formats | control intl.cpl
Язык и региональные стандарты: Языки и клавиатуры | Region and Language: Keyboards and Languages | control intl.cpl,,2
Русское название элемента | Английское название элемента | Команда

Если какой-либо из элементов списка не запускается, то скорее всего это означает что он неустановлен. Многие из компонентов Windows можно установить в Пуск → Панель Управления → Программы и Компоненты → Включение и отключение компонентов Windows

4. Список сочетаний клавиш используемых в Windows 7.

Во многих статьях Вы можете увидеть текст наподобие: Win   + R.
Данный текст обозначает, что Вам необходимо нажать на клавиатуре сочетание клавиши с логотипом Windows и буквы R.
Сочетания клавиш — это комбинации двух или более клавиш, нажав которые, можно выполнять задачи, обычно требующие применения мыши или другого указывающего устройства.
Существуют следующие наиболее часто используемые сочетания клавиш.

Сочетания клавиш для работы с текстом.

Клавиши | Действие
Ctrl + A | Выделить весь текст.
Ctrl + C (или Ctrl + Insert) | Копировать выделенный фрагмент текста.
Ctrl + X | Вырезать выделенный фрагмент текста.
Ctrl + V (или ⇑ Shift + Insert) | Вставить выделенный фрагмент текста.
Ctrl + ← | Переместить курсор в начало предыдущего слова.
Ctrl + → | Переместить курсор в начало следующего слова.
Ctrl + ↑ | Переместить курсор в начало предыдущего абзаца.
Ctrl + ↓ | Переместить курсор в начало следующего абзаца.
⇑ Shift + → | Выделить текст вперед посимвольно.
⇑ Shift + ← | Выделить текст назад посимвольно.
Ctrl + ⇑ Shift + → | Выделить текст от положения курсора до начало следующего слова.
Ctrl + ⇑ Shift + ← | Выделить текст от положения курсора до начало предыдущего слова.
⇑ Shift + Home | Выделить текст от положения курсора до начала строки.
⇑ Shift + End | Выделить текст от положения курсора до окончания строки.
Alt слева + ⇑ Shift | Переключить язык ввода, если используется несколько языков ввода.
Ctrl + ⇑ Shift | Переключить раскладку клавиатуры, если используется несколько раскладок клавиатуры.
Ctrl слева + ⇑ Shift Ctrl справа + ⇑ Shift | Изменение направления чтения текста для языков с письмом справа налево.

Сочетания клавиш для работы с окнами и рабочим столом.

Клавиши | Действие
F5 (или Ctrl + R) | Обновление активного окна или рабочего стола (если активен).
F6 или Tab ↹ | Циклическое переключение между элементами в окне или на рабочем столе.
Alt + Esc | Циклическое переключение между элементами в том порядке, в котором они были открыты.
Alt + Tab ↹ | Циклическое переключение между окнами в обычном режиме.
Ctrl + Alt + Tab ↹ | Открыть окно для переключения между окнами в обычном режиме. Для перехода между ними используйте клавиши со стрелками.
Win + Tab ↹ | Циклическое переключение между элементами (окнами, программами) в режиме Flip3D.
Ctrl + Win + Tab ↹ | Открыть окно для переключения между окнами в режиме Flip3D. Для перехода между ними используйте клавиши со стрелками.
Ctrl + колесо мыши (вверх\вниз) на рабочем столе | Увеличить / Уменьшить размер значков на Рабочем столе.
Удерживая ⇑ Shift + ↑ | Выделение вверх нескольких элементов в окне или на рабочем столе, включая текущий.
Удерживая ⇑ Shift + ↓ | Выделение вниз нескольких элементов в окне или на рабочем столе, включая текущий.
Удерживая Ctrl + Пробел | Выделение любых нескольких отдельных элементов в окне или на рабочем столе. Для перехода ипользовать клавиши стрелок.
Ctrl + A | Выделить все элементы в окне или на рабочем столе.
Ctrl + C (или Ctrl + Insert) | Копирование выделенных элементов.
Ctrl + X | Вырезание выделенных элементов.
Ctrl + V (или ⇑ Shift + Insert) | Вставка выделенных элементов.
Alt + Enter ↵ | Открытие диалогового окна свойств для выбранного файла, папки.
Alt + Пробел | Отображение контекстного меню активного окна.
Alt + F4 | Закрытие текущего элемента или выход из активной программы.
⇑ Shift + F10 | Открытие контекстного меню для выделенного элемента.
Win + ↑ | Развернуть окно на весь экран.
Win + ⇑ Shift + ↑ | Растянуть окно до верхней и нижней части экрана.
Win + ↓ | Свернуть в окно, либо свернуть на панель задач.
Win + ← | Развернуть и прикрепить окно к левому краю экрана.
Win + → | Развернуть и прикрепить окно к правому краю экрана.
Win + M | Свернуть все сворачиваемые окна. Несворачиваемые окна (Например: Свойства файла) останутся на экране.
Win + ⇑ Shift + M | Восстановить все свернутые окна.
Win + D | Показать рабочий стол / Вернуться в программу. Сворачивает и восстанавливает всё, включая несворачиваемые окна.
Win + G | Циклическое переключение между гаджетами.
Win + Home | Свернуть / Восстановить все окна, кроме активного.
Win + Пробел | Показать рабочий стол без сворачивания окон.

Сочетания клавиш для работы с несколькими мониторами.

Клавиши | Действие
Win + ⇑ Shift + ← | Переключит© на левый монитор.
Win + ⇑ Shift + → | Переключит© на правый монитор.
Win + ⇑ Shift + ← | Перемещение окна на левый монитор.
Win + ⇑ Shift + → | Перемещение окна на правый монитор.
Win + P | Выбор режима отображения презентации.

Сочетания клавиш для работы с Панелью задач.

Клавиши | Действие
⇑ Shift + щелчок по значку на панели задач | Открытие программы или быстрое открытие другого экземпляра программы.
⇑ Shift + щелчок правой кнопкой мыши по значку на панели задач | Отображение окна меню для программы.
⇑ Shift + щелчок правой кнопкой мыши по сгруппированному значку на панели задач | Отображение окна меню для группы.
Ctrl + щелчок по сгруппированному значку на панели задач | Циклическое переключение между окнами группы.
Ctrl + ⇑ Shift + щелчок по значку на панели задач | Открытие программы от имени администратора.
Ctrl + Tab ↹ | Переключение между эскизами в одной группе.
Win + Цифра | Запустить / Переключит© в программу, используя расположение ее значка на панели задач. Цифры от 1 до 9 – это порядковый номер приложения на панели задач, считая слева (0 – десятое приложение).
⇑ Shift + Win + Цифра | Запуск нового экземпляра программы, используя расположение ее значка на панели задач.
Ctrl + Win + Цифра | Переключение между окнами программы, начиная с последнего активного, используя расположение ее значка на панели задач.
Alt + Win + Цифра | Открытие списка переходов для программы, используя расположение ее значка на панели задач.
Win + T | Циклическое переключение между значками на панели задач. (Слева направо)
Win + ⇑ Shift + T | Циклическое переключение между значками на панели задач. (Справа налево)
Ctrl + Win + B | Переключение на программу, отображающую сообщение в области уведомлений.
Win (или Ctrl + Esc) | Открытие или закрытие меню «Пуск».
Win + R | Открытие диалогового окна «Выполнить».
Ctrl + ⇑ Shift + Enter ↵ | Запуск выделенной в меню Пуск программы от имени администратора.

Сочетания клавиш для работы в Проводнике Windows.

Клавиши | Действие
Win   + E | Запустить Проводник Windows.
Alt + ← Просмотр предыдущей папки.
Alt + → Просмотр следующей папки.
Alt + ↑ Просмотр папки, расположенной на уровень выше.
Alt + D | Выбор адресной строки.
Alt + P | Отображение области просмотра.
Ctrl + E | Выбор поля поиска.
Ctrl + ⇑ Shift + E | Отображение всех папок, в которые вложена выделенная папка.
Ctrl + F | Выбор поля поиска.
Ctrl + N | Открытие нового окна.
Ctrl + ⇑ Shift + N | Создание новой папки.
Ctrl + W | Закрытие текущего окна.
Ctrl + . | Поворот изображения по часовой стрелке.
Ctrl + , | Поворот изображения против часовой стрелки.
Ctrl + колесо прокрутки мыши | Изменение размера и внешнего вида значков файлов и папок.
Home | Переход к верхней позиции активного окна.
End | Переход к нижней позиции активного окна.
Delete
(или Ctrl + D) 		Удаление выделенного элемента в «Корзину».
⇑ Shift + Delete | Удаление выделенного элемента без помещения его в «Корзину».
F2 | Переименование выделенного элемента.
F4 | Отображение списка предыдущих расположений для адресной строки в проводнике Windows.
F11 | Разворачивание активного окна на весь экран / Сворачивание обратно.
← Свертывание выделенного элемента (если он развернут) или выбор родительской папки.
→ Отображение выделенного элемента (если он свернут) или выделение первой подпапки.
⟵ Backspace | Просмотр предыдущей папки.
Num
Lock + * на цифровой дополнительной клавиатуре 		Отображение всех папок, вложенных в выделенную папку.
Num
Lock + + на цифровой дополнительной клавиатуре 		Отображение содержимого выделенной папки.
Num
Lock + — на цифровой дополнительной клавиатуре 		Свертывание выделенной папки.

Сочетания клавиш для диалогового окна.

Клавиши | Действие
F4 | Отображение элементов активного списка.
⟵ Backspace | Открытие папки на один уровень выше от папки, выделенной в окне «Сохранить как» или «Открыть».
Tab ↹ | Переход вперед по параметрам.
⇑ Shift + Tab ↹ | Переход назад по параметрам.
Ctrl + Tab ↹ | Переход вперед по вкладкам.
Ctrl + ⇑ Shift + Tab ↹ | Переход назад по вкладкам.
Alt + подчеркнутая буква | Выполнение команды (или выбор параметра), которая начинается с этой буквы.
Пробел, удерживая Ctrl или ⇑ Shift | Установка или снятие флажка, если он активен.
↑, ↓, ←, → | Выбор кнопки, если активна группа кнопок.

Сочетания клавиш для работы со справкой Windows.

Клавиши | Действие
F1 | Открытие справки текущего элемента.
Win + F1 | Запустить встроенный диалог Windows: Справка и Поддержка.
F3 | Перемещение курсора в поле «Поиск».
F10 | Переход к меню «Параметры».
Alt + A | Переход на страницу поддержки пользователей.
Alt + C | Отображать оглавление.
Alt + N | Переход к меню «Параметры подключения».
Alt + ← | Возврат к предыдущему просмотренному разделу.
Alt + → | Переход к следующему (ранее просмотренному) разделу.
Alt + Home | Переход на домашнюю страницу справки и поддержки.
Home | Переход в начало раздела.
End | Переход в конец раздела.
Ctrl + F | Поиск в текущем разделе.
Ctrl + P | Вывод раздела на печать.

Сочетания клавиш для работы с Центром специальных возможностей.

Клавиши | Действие
Win   + U | Запустить Центр специальных возможностей.
Num
Lock (удерживать более пяти секунд) 		Включить / Отключить режим озвучивания при нажатии клавиш Caps Lock, Num
Lock и Scroll
Lock .
⇑ Shift (нажать пять раз) | Включить / Отключить режим залипания клавиш (позволяет использовать клавиши ⇑ Shift, Ctrl, Alt, Win   нажимая их по отдельности).
⇑ Shift справа (удерживать более восьми секунд) | Включить / Отключить фильтрацию ввода (позволяет игнорировать краткие и повторные нажатия клавиш).
Alt слева + ⇑ Shift слева + PrtScr (или Print
Screen) 		Включить / Отключить режим высокой контрастности.
Alt слева + ⇑ Shift слева + Num
Lock (или Num) 		Включить / Отключить управление указателем мыши с клавиатуры.

Сочетания клавиш для работы с программой "Экранная лупа".

Клавиши | Действие
Win + + | Запуск программы "Экранная лупа". Увеличить масштаб.
Win + — | Уменьшить масштаб.
Win + Esс | Закрытие программы "Экранная лупа".
Ctrl + Alt + D | Переключение в режим «Закреплено» (увеличенная область показывается в отдельном закрепленном окне).
Ctrl + Alt + F | Переключение в режим «Во весь экран» (увеличивается весь экран).
Ctrl + Alt + L | Переключение в режим «Увеличение» (увеличивается область вокруг указателя мыши).
Ctrl + Alt + R | Изменение размера окна, отображающего увеличенную область экрана.
Ctrl + Alt + Пробел | Предварительный просмотр рабочего стола в полноэкранном режиме.
Ctrl + Alt + I | Инверсия цветов.
Ctrl + Alt + ↑ | Прикрепление окна с увеличенной областью к верхнему краю экрана. («Закреплено») Передвижение окна с увеличенной областью вверх. («Увеличение») Передвижение по увеличенной области вверх. («Во весь экран»)
Ctrl + Alt + ↓ | Прикрепление окна с увеличенной областью к нижнему краю экрана. («Закреплено») Передвижение окна с увеличенной областью вниз. («Увеличение») Передвижение по увеличенной области вниз. («Во весь экран»)
Ctrl + Alt + ← | Прикрепление окна с увеличенной областью к левому краю экрана. («Закреплено») Передвижение окна с увеличенной областью влево. («Увеличение») Передвижение по увеличенной области влево. («Во весь экран»)
Ctrl + Alt + → | Прикрепление окна с увеличенной областью к правому краю экрана. («Закреплено») Передвижение окна с увеличенной областью вправо. («Увеличение») Передвижение по увеличенной области вправо. («Во весь экран»)

Остальные сочетания клавиш.

Клавиши | Действие
Enter ↵ | Заменяет щелчки мышью для запуска приложения, нажатия на кнопку или выбора пункта в меню.
Esc | Идентично нажатию кнопки Отмена в диалоговом окне.
F3
(или Win   + F) 		Открытие встроенного диалогового окна Windows для поиска файла или папки.
Ctrl + F | Открытие окна поиска или переход в поле поиска в активном окне.
Ctrl + Win   + F | Поиск по компьютеру из домена (при нахождении в сети).
Ctrl + ⇑ Shift + Esc | Запуск Диспетчера задач.
Ctrl + Alt + Delete | Вызов окна Безопасность Windows (Включает кнопки Блокировать компьютер, Сменить пользователя, Выйти из системы, Сменить пароль, Запустить диспетчер задач).
Win   + L | Блокирование компьютера или переключение пользователей.
Win   + X | Запустить Центр мобильности Windows.
Win   + Pause
Break 		Запустить элемент Система из Панели Управления (пункт Свойства при нажатии правой кнопкой мыши на Компьютер в меню Пуск).
Удерживая ⇑ Shift при вставке компакт-диска | Предотвращение автоматического воспроизведения компакт-диска.
Ctrl + Tab ↹ | Переключение между элементами (вкладками, окнами, документами) в программах, допускающих одновременное открытие нескольких документов.
Ctrl + F4 | Закрытие активного документа (в программах, допускающих одновременное открытие нескольких документов).
Alt + Enter ↵ | Развернуть активную программу на полный экран / Свернуть в окно.
Alt + подчеркнутая буква Отображение соответствующего меню.
Выполнение команды меню (или другой подчеркнутой команды).
F10 | Активизация строки меню текущей программы.
← Открытие следующего меню слева или закрытие подменю.
→ Открытие следующего меню справа или открытие подменю.
Ctrl + N | Создать...
Ctrl + O | Открыть...
Ctrl + S | Сохранить сделанные изменения.
Ctrl + Z | Отмена действия.
Ctrl + Y
Ctrl + ⇑ Shift + Z 		Повтор действия.

5. Перезагрузка компьютера в безопасный режим без использования клавиатуры (клавиши F8) при загрузке.

Для того, чтобы перезагрузит© в Безопасный режим достаточно во время загрузки нажать клавишуF8 и выбрать пункт Safe Mode. А чтобы вернуться обратно в Нормальный режим достаточно всего лишь перезагрузить компьютер (не нажимаяF8) и система вернется в своё стандартное состояние.
Но на некоторых материнских платах клавишаF8 используется для выбора физического устройства, с которого должен начать загрузку компьютер.
В этом случае необходимо выбрать жесткий диск, на котором установлена операционная система. После нажатия клавиши Enter ↵ необходимо сразу же снова нажимать клавишуF8 до тех пор, пока на экране не появится меню выбора вариантов загрузки ОС Windows. Вы должны успеть сделать это довольно быстро, а иначе начнется обычная загрузка Windows.
Если же нет желания играть на скорость, есть более легкий вариант решения:

1) Откройте Конфигурация системы (Пуск → Выполнить → msconfig → ОК или Win   + R → msconfig → ОК)
2) Перейдите на вкладку Загрузка
3) Поставьте галочку напротив значения Безопасный режим в разделе Параметры загрузки
4) Нажмите ОК и перезагрузите компьютер.
5) Чтобы вернуться обратно в Нормальный режим: находясь в Безопасном режиме уберите данную галочку и перезагрузите компьютер.

6. Определение букв назначенных дискам в среде восстановления или среде предустановки.

Загрузившись в среду восстановления или в среду предустановки Windows, Вы можете столкнуться с необходимостью определения буквы диска.
Например, чтобы запустить приложения с флэш-диска или проверить диск на наличие ошибок.

Виртуальному диску создаваемому в среде восстановления или среде предустановки всегда соответствует буква Х:, а для определения букв остальных дисков Вы можете выбрать одно из предложенных решений.

Вариант 1. По размеру и типу диска.

1) Перейдите в папку X:\Sources; для этого в командной строке введите указанную ниже команду и нажмите Enter ↵:

2) Запустите Блокнот (Notepad); для этого в командной строке введите указанную ниже команду и нажмите Enter ↵:

3) В главном меню блокнота выберите Файл → Открыть (или нажмите сочетание клавиш Ctrl + O)
4) Щелкните на значок Компьютер в области переходов слева

Примечание: Для лучшего отображения содержимого папки Компьютер, дважды щелкните по заголовку окна, чтобы его развернуть.

Вариант 2. По содержимому папки.

Также Вы можете определить буквы дисков напрямую из командной строки.

1) Переходите с диска на диск вводя его букву и нажимая Enter ↵. Например:

Если Вам необходимо перейти к предполагаемой папке на диске, то переключайтесь используя команду:

Например:

2) Для отображения содержимого диска(папки) вводите команду:

7. Автоматическое переключение русской и английской раскладок клавиатуры.

Часто бывает, что напечатав какой-то текст, Вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".

Для того чтобы сохранить Ваше терпение и нервы, существуют две замечательные программы:

Punto Switcher(если вы в основном работаете с русской или английской клавиатурой)
Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером.
Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

8. Удаление Windows 7 без форматирования раздела и без потери данных.

Для удаления Windows 7 описанным здесь способом вам потребуются:

а) MSDaRT (ранее ERD Commander);
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в MSDaRT и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду

Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset → Explorer
2) Как в обычном Проводнике, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы).

Если Вам необходимо:

1) Получить полный доступ к системным файлам и папкам.
2) Получить доступ к системному реестру и настройкам системы.
3) Восстановить неработающую Windows или отдельно какой-либо из ее компонентов.

то воспользуйтесь загрузочным образом с набором средств диагностики и восстановления - Microsoft Diagnostics and Recovery Toolset (MSDaRT).

Вы можете создать образ MSDaRT самостоятельно, на основе имеющегося у вас дистрибутива Windows, или же скачать уже готовый образ, созданный мною.
Создавать образ MSDaRT для Windows 7 и запускать его необходимо с учетом разрядности Вашей операционной системы.

Готовые ISO-образы Microsoft Diagnostics and Recovery Toolset (MSDaRT) для Windows 7 со встроенными Debuggers And Tools:

DART70X86RUS_Disk.zip - архив с самозагружаемым ISO-образом MSDaRT для 32-битной версии Windows 7.
DART70X64RUS_Disk.zip - архив с самозагружаемым ISO-образом MSDaRT для 64-битной версии Windows 7.

Создание iso-образа диска MSDaRT:

1) Вставьте установочный DVD-диск Windows 7 или подключите установочный флеш-накопитель (флешку) или смонтируйте iso-образ дистрибутива Windows 7 в виртуальный дисковод (Alcohol 120%, Daemon Tools, UltraISO), соответствующий разрядности Windows в которой Вы будете создавать образ.
2) В зависимости от разрядности Вашей Windows скачайте и установите мастер создания образа MSDaRT: DaRT70x86.zip - для 32-бит или DaRT70x64.zip - для 64-бит.
3) Скачайте и установите Debuggers And Tools: DebuggersAndTools-x86.zip - для 32-бит или DebuggersAndTools-x64.zip - для 64-бит.
4) Скопируйте файл dbghelp.dll из папки Win7_dbghelp в папку C:\Program Files\Windows Kits\8.1\Debuggers\x86 - для 32-бит или в папку C:\Program Files\Windows Kits\8.1\Debuggers\x64 - для 64-бит.
5) Запустите Пуск → Все программы → Microsoft DaRT 7 → Образ для восстановления DaRT
6) На вкладке "Выбор образа загрузки" укажите диск с Windows 7.

7) Щелкните ОК, затем несколько раз кнопку Далее.
8) На вкладке "Выбор программных средств" нажмите кнопку Далее.
9) На вкладке "Удаленные подключения" установите флажок Разрешить удаленные подключения и нажмите кнопку Далее.
10) На вкладке "Анализатор сбоев" установите переключатель в значение "Использовать средства отладки для Windows из следующей папки."
Укажите папку C:\Program Files\Windows Kits\8.1\Debuggers\x86 - для 32-бит или папку C:\Program Files\Windows Kits\8.1\Debuggers\x64 - для 64-бит и нажмите кнопку Далее.

11) На вкладке "Загрузка определения автономного средства проверки системы" установите переключатель в значение "Нет, загрузить определения вручную позднее" и нажмите кнопку Далее.
12) На вкладке "Дополнительные драйверы" добавьте драйвера в образ, которые автоматически не определяются Windows (если они у Вас есть) и нажмите кнопку Далее.

13) На вкладке "Дополнительные файлы" нажмите кнопку Показать файлы и скопируйте в открывшуюся папку все необходимые Вам файлы, которые Вам могут понадобит© в MSDaRT.
Закройте Проводник и нажмите в мастере создания образа MSDaRT кнопку Далее.

14) На вкладке "Создание образа загрузки" укажите местоположение для сохранения iso-файла созданного образа и нажмите кнопку Далее. По умолчанию образ создается на Рабочем столе.
15) Оставьте установленным или снимите флажок "Записать образ с помощью следующего устройства записи CD/DVD-дисков" и нажмите кнопку Далее.

15.1) Для записи на DVD-диск, вставьте чистый диск в DVD-дисковод и оставьте флажок установленным.
15.2) Для дальнейшей записи на USB флеш-накопитель (флешку) - снимите флажок.
16) В последнем окне нажмите кнопку Готово.

Запись iso-образа MSDaRT на USB флеш-накопитель (флешку).

Данное действие проще всего совершить с помощью программы UltraISO.
1) Открываете образ в UltraISO.
2) В главном меню выбираете Самозагрузка → Записать образ жесткого диска...
3) Нажимаете кнопку Записать

Начало работы с загрузочным носителем (DVD, флеш-диск) MSDaRT.

1) Вставьте загрузочный DVD-диск или подключите флеш-диск с MSDaRT и перезагрузите компьютер.
2) Нажмите клавишу для вызова меню загрузки (Boot menu, BBS Popup). В зависимости от производителя она может быть F8, F11 или F12.
3) Выберите необходимый Вам диск и нажмите Enter ↵.
4) В окне "Инициализировать подключение к сети в фоновом режиме?" (Would you like to initialize network connectivity in the background?) нажмите кнопку Да (Yes), если собираетесь восстанавливать настройки сети (Интернет или Локальной), в остальных случаях нажмите кнопку Нет (No).
5) В окне "Переназначить буквы дисков таким образом, чтобы они соответствовали буквам дисков целевой операционной системы?" (Would you like to remap the drive letters to match the mappings from the target operating system?) нажмите кнопку Да (Yes), чтобы в MSDaRT для обозначения дисков использовались те же буквы, что и в системе с которой Вы будете работать, в остальных случаях нажмите кнопку Нет (No).
6) В окне Выберите метод ввода с клавиатуры (Select a keyboard input method) из ниспадающего списка выберите раскладку клавиатуры и нажмите кнопку Далее (Next).
7) В окне для выбора операционной системы для восстановления установите переключатель в значение "Используйте средства восстановления, позволяющие устранить проблемы при запуске Windows." (Use recovery tools that can help fix problems starting Windows.)
7.1) Для работы с программами, восстанавливающими Windows выберите в списке Вашу операционную систему.
7.2) Для работы с системными файлами и папками (удаление, переименование или их замена) уберите в списке выделение с какой-либо системы.
Для этого установите переключатель в значение "Восстановление компьютера с помошью созданного ранее образа системы." (Restore your computer using a system image that you created earlier), а затем снова выберите пункт "Используйте средства восстановления, позволяющие устранить проблемы при запуске Windows." (Use recovery tools that can help fix problems starting Windows.) или же просто щелкните мышью в свободное пространство под списком операционных систем.
8) Нажмите кнопку Далее (Next).
Примечание: Чтобы запустить Проводник (Windows Explorer), выберите в списке пункт "Microsoft® Diagnostic and Recovery Toolset". В открывшемся окне будет необходимый Вам пункт.

10. Активация Windows 7 по телефону, используя лицензионный ключ.

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵
2) Установите Ваш ключ системы. Введите указанные ниже команды и нажмите Enter ↵.

где, вместо крестиков укажите Ваш лицензионный ключ продукта.

3) Выберите страну в которую Вы будете звонить для активации продукта и нажмите кнопку Далее.
4) Позвоните по бесплатному номеру (в некоторые страны можно бесплатно позвонить через программу Skype) .
5) Робот начнет перечислять варианты активации.
6) Нажмите на телефоне 1 (Активировать продукт Майкрософт).
7) На вопрос на скольких компьютерах установлен продукт, нажмите 1.
8) Когда вас попросят ввести код, введите. В ответ робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
9) Внесите цифры в окно активации.
10) Нажмите Далее. Интернет, может быть отключен (без разницы).
Windows 7 активирована.

11. Быстрое переключение с одного монитора на другой или с монитора на проектор.

Если у Вас к компьютеру подключено несколько мониторов, либо кроме монитора подключен также и проектор, то для быстрого переключения между ними Вы можете воспользоваться указанными ниже сочетаниями клавиш.

Клавиши | Действие
Win + ⇑ Shift + ← | Переключит© на левый монитор.
Win + ⇑ Shift + → | Переключит© на правый монитор.
Win + ⇑ Shift + ← | Перемещение окна на левый монитор.
Win + ⇑ Shift + → | Перемещение окна на правый монитор.
Win + P | Выбор режима отображения презентации.

Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей.
Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

12. Где можно скачать справочник от Microsoft, содержащий полное описание утилит командной строки?

Вы можете скачать справочник от Microsoft (на английском языке), содержащий полное описание утилит командной строки.

1) Перейдите по ссылке http://www.microsoft.com/en-us/download/details.aspx?id=2632
2) Нажмите Download.

13. Уточнение времени работы компьютера с момента последней загрузки.

Вариант 1.

Если Вам необходимо узнать сколько времени работает Ваш компьютер с момента последней загрузки, то Вы можете создать скрипт-файл и запускать его при необходимости.

1) Скопируйте указанный выше код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы узнать сколько времени работает компьютер, просто запустите созданный Вами скрипт, как обычную программу.

Вариант 2.

Скачайте и установите специальный гаджет SystemUptime.

systemuptime.zip

14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите Ctrl + S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите Редактор локальной групповой политики: Пуск → Выполнить → gpedit.msc или Win   + R → gpedit.msc
4) Откройте ветвь Конфигурация пользователя → Конфигурация Windows → Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами командного файла c:\tempdirclean.cmd
7) Нажмите ОК, затем снова ОК.
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите командный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера → Конфигурация Windows → Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

15. Отключение Центра отправки Microsoft Office.

Чтобы отключить Центр отправки (Upload Center) Microsoft Office, выполните указанные ниже рекомендации.

Вариант 1.

1) Запустите Диспетчер задач: Ctrl + ⇑ Shift + Esc
2) Завершите все процессы связанные с Microsoft Office, включая MSOUC.exe и MSOSYNC.exe
3) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4) Введите указанную ниже команду и нажмите Enter ↵. После выполнения команды перезагрузите компьютер.

Где, вместо GUID введите идентификатор для Вашей редакции Microsoft Office.

32-битные версии:

{90150000-0011-0000-0000-0000000FF1CE} = Microsoft Office Professional Plus 2013 / Microsoft Office Профессиональный Плюс 2013
{90150000-0012-0000-0000-0000000FF1CE} = Microsoft Office Standard 2013 / Microsoft Office Стандартный 2013
{90150000-0013-0000-0000-0000000FF1CE} = Microsoft Office Home and Business 2013 / Microsoft Office Для Дома и Бизнеса 2013
{90150000-002F-0000-0000-0000000FF1CE} = Microsoft Office Home and Student 2013 / Microsoft Office Для Дома и Учебы 2013

64-битные версии:

{90150000-0011-0000-1000-0000000FF1CE} = Microsoft Office Professional Plus 2013 / Microsoft Office Профессиональный Плюс 2013
{90150000-0012-0000-1000-0000000FF1CE} = Microsoft Office Standard 2013 / Microsoft Office Стандартный 2013
{90150000-0013-0000-1000-0000000FF1CE} = Microsoft Office Home and Business 2013 / Microsoft Office Для Дома и Бизнеса 2013
{90150000-002F-0000-1000-0000000FF1CE} = Microsoft Office Home and Student 2013 / Microsoft Office Для Дома и Учебы 2013

Например:

Для 32-битной версии Microsoft Office для дома и учебы 2013:

Для 64-битной версии Microsoft Office Professional Plus 2013:

Если Вы не знаете какая у Вас версия или редакция Microsoft Office, то 1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
А если 32-битная версия Microsoft Office установлена на 64-битную Windows, то HKEY_LOCAL_MACHINE \Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall
3) Найдите идентификатор GUID, наподобие упомянутого ранее, указывающий на версию и редакцию Microsoft Office.

Более подробное описание схемы нумерации для идентификаторов GUID кода продукта:

Для Office 2010: http://support.microsoft.com/kb/2186281/ru-ru
Для Office 2013: http://support.microsoft.com/kb/2786054/ru-ru

Вариант 2.

1) Скачайте и запустите программу Sysinternals AutoRuns (английская версия или русская версия)
2) Удалите все записи, которые содержат слова SYNC и путь к которым начинается "C:\Program Files\Microsoft Office"
3) Перезагрузите компьютер.

Вариант 3.

1) Запустите Диспетчер задач: Ctrl + ⇑ Shift + Esc
2) Завершите все процессы связанные с Microsoft Office, включая MSOUC.exe и MSOSYNC.exe
3) Запустите редактор реестра (Win   + R → regedit → ОК)
4) Найдите и удалите все значения MSOSYNC
5) Откройте меню Пуск → Панель управления → Администрирование → Планировщик заданий
6) Щелкните правой кнопкой мыши на задачу "Microsoft Office 15 Sync Maintenance for..."
7) В контекстном меню нажмите Отключить (Disable)
8) Перезагрузите компьютер.

16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

Многие используя в Windows функцию Форматировать, замечали пункт Создание загрузочного диска MS-DOS. Он используется для создания загрузочного диска MS-DOS на определенных типах устройств, для других же типов устройств он заблокирован.
Выясняя откуда Windows берет образ MS-DOS для записи, я узнал что он содержится в файле diskcopy.dll. Но тут появился другой вопрос, а как его оттуда извлечь? Предлагаю Вам несколько способов его извлечения.

Способ 1 Использование редакторов ресурсов.

Открываете файл diskcopy.dll любым редактором ресурсов и извлекаете(сохраняете) ресурс 1 из папки BINFILE как diskcopy.img

Способ 2 Программа Disk Extract

1) Указываете в поле File(s) to search and extract byte sequence (wildcards *.* accepted) - файл для поиска и извлечения необходимого количества байтов: C:\Windows\System32\diskcopy.dll
2) Указываете в поле Byte sequence to find - с какого байта искать: EB3C90
3) Указываете в поле Bytes to copy - сколько байт скопировать: 1474560
4) Указываете в поле Save as - куда и под каким именем сохранить (например так): D:\Temp\diskcopy\diskcopy.img
5) Нажимаете на кнопку Play
6) В появившемся окне Confirm нажимаете Yes

Способ 3 Программа GETBTDSK со скриптом

Запускаете файл GETBTDSK.bat и получаете в итоге готовый файл diskcopy.img
Некоторые антивирусные программы могут воспринять попытку её обращения к системному файлу как разновидность вируса, поэтому для работы скрипта либо изолируйте файл GETBTDSK.EXE, или папку где он находится из поиска антивирусной программой, либо воспользуйтесь первым способом.

Хорошо, образ мы извлекли и у нас есть готовый файл diskcopy.img. Что же дальше, спросите Вы. А дальше, Вы можете:

1) Распаковать полученный файл с помощью программы архиватора 7zip и дальше работать с файлами по-своему усмотрению.

2) Записать загрузочный MS-DOS образ diskcopy.img на USB флеш-накопитель (флешку).

1. Открываете файл diskcopy.img в программе UltraISO
2. Выбираете Самозагрузка → Записать образ жесткого диска...
3. Метод записи оставляете USB-HDD+
4. Нажимаете Записать

Чтобы не искать в интернете эти программы, Вы можете скачать архив с ними: msdosboot.zip

17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

Скачивая какой-либо продукт Microsoft в интернете, помимо его названия Вы можете увидеть дополнительные обозначения в наименовании. Если Вам интересно, что означает "CTP", "Escrow", "LDR", "RC", "RTM" и тому подобное - предлагаю Вам, расшифровку особо часто встречающихся из них.

BBT - Basic Block Tools или Binary Profile Feedback Optimization framework
BBT - пакет инструментов оптимизации, помогающий уменьшить требования к рабочему набору Win32 приложения. Для этого применяется дополнительный статический анализ и эвристика кода. Также в результате мониторинга потока выполнения программы происходит интеграция профиля данных. Для дополнительной компрессии страниц памяти, BBT реорганизовывает статистические данные и секции ресурсов.
BBT - специальный анализатор, оптимизирующий величину кода, путем игнорирования не используемой части, и архивации оставшейся.
Другое значение BBT - это “Black Box Testing”, тестирование "чёрного ящика" или что-то в этом духе.

BVT - Build Verification Test
Небольшой набор тестов, проверяющих уровень качества сборки, на этапе её создания. Например, BVT для Блокнота может выглядеть как: "Запустить, напечатать текст, сохранить, выйти". Если сборка не проходит данный тест, то во избежание дальнейших ошибок при тестировании, она отправляется на доработку. Порядок действий BVT редко меняется, а результаты - тщательно контролируются.

CPP - Customer Preview Program
Программа предварительного ознакомления.

CTP - Community Technology Preview
Предварительный технологический релиз для сообщества, впервые использован для сборки Vista build 5219, так называемый январский CTP.

DNSRV - .NET (DotNet) Server
Раннее кодовое имя Windows Server 2003.

EBS - Essential Business Server
Серверное решение от Microsoft, имеет в своей основе ядро Windows Small Business Server 2008, ориентировано на рынок среднего бизнеса.

EDW - External Developer Workstation
Этот термин, использовался во времена разработки Windows Vista, для обозначения сборок выпущенных между RC и RTM сборками.

Escrow
Сборки, не имеющие серьёзных ошибок. Они, как правило, становятся в итоге Релиз-кандидатами или RTM (после того, как сборка подписана к выпуску).

Exit Criteria
Набор тестов, проверяющих наиболее важные аспекты корректной работы основных функций приложения. Как выглядит тот или иной тест, определяется командой-разработчиком функции, результаты прохождения теста должны точно совпадать с ожидаемыми. Полное прохождение таких тестов ознаменует переход к следующему этапу разработки.

FBL - Feature build lab
Группа разработки какого-либо функционала.

FVT - Feature Verification Tests
Тоже самое, что и BVT, только для конкретной функции.

GA - General Availability
Означает, что програмное обеспечение доступно на основном рынке через Интернет или на каком-либо физическом носителе.

GDR - General Distribution Release
Используется для обновлений и хотфиксов, содержащих только заплатки критических ошибок и исправления, влияющие на стабильность.

HSBS - Home and Small Business Server

IDS - Internal Developer Server

IDW - Internal Developer Workstation

IDX - Internal Developer Client/Server

LCTP - Limited Community Technology Preview
Ограниченный предварительный технологический релиз.

LDR - Limited Distribution Release
Используется для обновлений и хотфиксов, содержащих “прочие” исправления, как правило, для ошибок, возникающих у весьма специфической группы пользователей.

MMS - Mid-Market Server
Раннее название Essential Business Server.

QFE - Quick Fix Engineering
Аналогично LDR.

QHSV - Q Home Server
Раннее название Windows Home Server.

RC - Release Candidate
Качество сборки на данной стадии разработки наиболее близко к стабильному, критические ошибки уже исправлены, однако, в ходе текущего тестирования могут быть найдены новые ошибки.

RDP - Rapid Deployment Program

RTM - Release To Manufacturing
Стабильная сборка, прошедшая все стадии тестирования, в которой исправлены все найденные ошибки, и готовая к применению.

RTW - Release To Web
Это RTM, предназначенный для распространения через Интернет.

SBS - Small Business Server

Self host
Сброки, прошедшие тесты Exit Criteria tests, готовые к более глубокому тестированию.

Self test
Сборки, прошедшие BVT и FVT тесты.

Self toast
Сборки, не прошедшие BVT.
Sign-off
Подписание, означает, что функция/продукт готова к продаже.

TAP - Technology Adoption Program
Программа технологического утверждения, в ходе которого собираются отзывы тестеров, в качестве которых могут выступать и заказчики компании.

TP - Technical Preview

VBL - Virtual Build Lab
Термин обозначает группу разработчиков объединенных в виртуальную лабораторию.

WHS - Windows Home Server

WSSG - Windows Server Solutions Group

WSUS - Windows Server Update Services

18. Удаление установленного обновления.

Если Вы установили обновление в Windows, для добавления дополнительной функции, а оно Вам не понравилось, то Вы можете спокойно его удалить.
Для удаления любого обновления сделайте следующее:

1) Откройте Панель управления\Программы
2) Нажмите на ссылку Просмотр установленных обновлений
3) Нажмите правой кнопкой на любом обновлении, которое желаете удалить и щелкните на появившемся слове Удалить.
4) В случае необходимости, перезагрузите компьютер.

19. Создание значков управления состоянием компьютера.

Для быстрого изменения состояния системы Вы можете создать на рабочем столе ярлыки позволяющие изменить его одним нажатием мыши.

Для создания ярлыков выполните следующие действия:
1) Нажмите правую клавишу мыши на рабочем столе, выберите пункт меню Создать → Ярлык
2) В поле Укажите расположение объекта введите необходимую команду для создания ярлыка и нажмите OK.

Блокировка компьютера

Выход из системы

Завершение работы

Перезагрузка

Сон

Вы также можете скачать архив SystemModesShortcuts.zip с уже готовыми данными ярлыками.

Если Вы желаете добавить указанные ярлыки в виде каскадного меню в контекстное меню рабочего стола, то скачайте и примените reg-файл Add_Power_to_Desktop_Context_Menu.reg из архива PowerMenuDesktop.zip.

20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

Текст из окна сообщения Windows выделить для копирования невозможно, так как он заблокирован. Но Вы можете скопировать данный текст в буфер обмена.
Для того чтобы это нажмите комбинацию клавиш Ctrl + C, а затем вставьте текст из буфера в любой текстовый редактор используя комбинацию клавиш Ctrl + V. Окно, текст которого нужно скопировать, должно быть активным.
Например, попробуйте закрыть окно оснастки Службы при открытом окне свойств отдельной службы, и Вы увидите одно из таких сообщений Windows.

21. Удаление данных без возможности восстановления.

При удалении файла или папки, не происходит полного физического удаления информации, очищается лишь только «оглавление» файловой системы. С помощью утилиты cipher возможно частичное решение этой проблемы, так как существует возможность выполнить очистку свободного места на диске затиранием её.
Место, занимаемое содержимым папки, будет перезаписано нулями, потом единицами, а после этого - набором случайных символов в каждом секторе.

Для полного удаления данных:

1) Удалите необходимые файлы или папки из Вашего каталога, которые должны быть затерты.
2) Запустите командную строку с правами администратора
2.1) Нажмите кнопку Пуск
2.2) В строке поиска введите cmd
2.3) Щелкните на найденной программе правой кнопкой мыши и выберите Запуск от имени администратора
3) В командной строке введите:

каталог - путь к любой папке на разделе подлежащим очистке. (Например: cipher /w:c:\temp) Если Вы удалили папку или файл из корня диска, то Вы можете указать в качестве пути только букву диска. (Например: cipher /w:c:\)

22. Выполнение дефрагментации дисков в Windows 7 используя командную строку.

В Windows существует программа Дефрагментация диска. Данная программа производит упорядочение фрагментированной информации для более эффективной работы дисков и дисководов. Программа дефрагментации диска работает по заданному расписанию, но можно запускать анализ и дефрагментацию дисков вручную. В программе Вы можете увидеть время прошлого запуска, уровень фрагментированности дисков и запланированное время следующего запуска.
Если Вы не отключали планировщик заданий, значение уровня фрагментированности дисков будет равно 0%, а при нажатии кнопки Анализировать диск система покажет уровень фрагментированности не более 10%. При желании Вы можете запустить дефрагментацию вручную нажав кнопку Дефрагментация диска или настроить запуск по расписанию, в удобное для Вас время.

Графический интерфейс программы Вы можете запустить: Пуск → Все программы → Стандартные → Служебные. Однако он весьма ограничен в возможностях, и их хватит начинающему или малоопытному пользователю, если же Вы продвинутый или опытный пользователь, то Вам будет интересен командный режим данной программы.

1) Нажмите кнопку Пуск и в строке поиска наберите cmd
2) Нажмите на найденной программе правой кнопкой мыши и выберите пункт Запуск от имени администратора.
3) Вы можете запустить утилиту defrag.exe используя следующие параметры командной строки:

Параметр | Описание
/A | Анализирует указанный том. Логично выполнить анализ перед ручной дефрагментацией. В результатах будет сказано, каким разделам она нужна.
/C | Выполняет операцию на всех томах. Этот параметр избавляет от необходимости перечислять все буквы разделов при анализе или дефрагментации.
/E | Выполняет операцию на всех томах, кроме указанных. Еще один параметр, экономящий время.
/H | Выполняет операцию с обычным приоритетом (по умолчанию используется низкий). Ускоряет процесс дефрагментации, но может замедлить работу других приложений, обращающихся к диску в это время.
/M | Выполняет операцию на всех томах одновременно в фоновом режиме. Стандартное поведение дефрагментатора – последовательная работа над томами.
/T | Отслеживает текущую операцию на указанном томе.
/U | Выводит прогресс текущей операции на указанном томе в процентном отношении.
/V | Выводит подробный отчет о томах, их фрагментированности, файлах и папках, а также о свободном пространстве и MFT.
/X | Объединяет свободное пространство на указанных томах.
/R | Выполняет частичную дефрагментацию (поведение по умолчанию), пытаясь объединять только фрагменты размером менее 64 Мб.
/W | Выполняет полную дефрагментацию, пытаясь объединять любые фрагменты вне зависимости от их размера.
/F | Выполняет принудительную дефрагментацию, даже если на диске недостаточно свободного пространства.

Примеры команд

Команда | Описание
defrag /A /C /U /V | Анализирует фрагментированность всех разделов, отображая ход операции, и выводит подробный отчет.
defrag C: /W /V | Выполняет полную дефрагментацию раздела C, а затем выводит подробный отчет.
defrag C: /E /H /F | Выполняет дефрагментацию всех разделов кроме C с обычным приоритетом вне зависимости от количества свободного пространства на них.

23. Уменьшение размера файла изображения без потери качества.

Если у Вас хранится большое количество файлов изображений на компьютере или Вы добавляете изображения в текстовые документы или Вы размещаете их в интернете, то данный совет поможет Вам уменьшить занимаемое ими место без потери качества.

1) Скачайте и разархивируйте в любую удобную Вам папку архив PictureBeaver.zip
2) Выделите необходимый Вам файл-изображение, группу файлов или папку с изображениями
3) Перетащите выделенное на файл optimize.wsf.
4) Откроется окно командной строки (процесс действий в окне отображаться не будет), по завершении процесса оптимизации оно само закроется .
5) Результаты появятся в той же папке, где и Ваши исходные файлы изображений. Оптимизированные файлы изображений будут в папке (папках) Optimized, отчёт о сэкономленном объеме в файле Optimization Report.html

Данный скрипт для оптимизации использует программы:

gifsicle - для оптимизации GIF изображений
jpegtran - для оптимизации JPG изображений
optipng - для оптимизации PNG изображений

24. Где можно скачать последнюю версию DirectX?

Полная версия: DirectX End-User Runtimes
Web версия(обновляется раньше, чем полная): DirectX End-User Runtime Web Installer

25. Запуск программы с определенной датой без изменения системных настроек.

Если Вы являетесь разработчиком программного обеспечения и по истечении тестового периода работы Ваша программа должна прекратить работу по причине выхода финальной версии или же Вам просто интересно как будет работать программа при изменении даты, то Вам нет необходимости изменять настройки системы.

Для запуска программы с определенной датой в прошлом или будущем Вы можете скачать программу RunAsDate

Вы можете запустить необходимую Вам программу непосредственно из программы RunAsDate или же создать ярлык для запуска с Рабочего Стола.

26. Изменение атрибутов и времени/даты создания, изменения и открытия (доступа) файла.

Если Вам необходимо изменить дату создания, дату изменения и дату открытия (доступа) файла, то для этого Вы можете воспользоваться программой BulkFileChanger, которую Вы можете скачать здесь.

Чтобы изменить атрибуты и/или любую из указанных времени/дат, сделайте следующее:

1) Добавьте Ваш файл в программу.
1.1) Воспользуйтесь методом тащи-и-бросай (drag-and-drop), просто перекиньте Ваш файл на окно программы.
или
1.2) В главном меню выберите Файл → Добавить файлы (клавиша F2), выберите файл(ы) для добавления и нажмите Открыть.

2) Выделите файл(ы) и в главном меню выберите Действия → Изменить время/атрибуты (клавиша F6)
3) Установите необходимые атрибуты и/или время/дату файла и нажмите кнопку Выполнить.

Примечание. Если Вы не живете в Великобритании, Гренландии, Ирландии, Исландии, Португалии или Канарских островах, то не забудьте снять флажок Время указано по Гринвичу.

27. Список всех обновлений вошедших в SP1 с краткими объяснениями и ссылками.

Если Вам необходимо узнать какие обновления вошли в Сервисный пакет обновлений 1, то Вы можете скачать с сайта Microsoft документ в котором описаны все обновления вошедшие в него, и также даны краткие пояснения и ссылки на страницы самих обновлений.

Скачать: Документация к пакету обновления 1 (SP1) для Windows 7 и Windows Server 2008 R2 (KB976932)

Файл при запуске откроется на странице Legal Disclaimer, для прочтения кратких пояснений к каждому вошедшему в SP1 обновлению и уточнения принадлежащих им ссылок перейдите в xls-файле на страницу Update List.

28. Список горячих клавиш, используемых в окне команд Windows 7.

В окне командной строки также как и в других окнах Windows существует набор используемых горячих клавиш, которые Вы можете использовать.

↑ - переход к раннее введенной команде.
Последовательно нажимая ↑, в командной строке будет появляться предыдущая введенная команда.

↓ - переход к позднее введенной команде.
Перейдя ↑ к самой первой команде, можно вернуться к последней нажимая ↓.

Esc - очистка строки ввода.
При нажатии стрелок для перемещения, переход по истории команд продолжится с того же места, где Вы остановились.

Tab ↹ - автозавершение названия файла/папки.
Пример: Если находясь в корне диска C:, Вы введете команду cd prog и нажмете клавишу Tab ↹, то у Вас автоматически отобразится cd "Program Files".
При наличии объектов с одинаково начинающим© названиями нажимайте Tab ↹, до появления необходимого значения. Подстановка имен происходит в алфавитном порядке.
Если в 64-битной системе, учитывая предыдущий пример, Вы нажмете клавишу Tab ↹ снова, то у Вас автоматически отобразится cd "Program Files (x86)".

F1 - побуквенный ввод выбранной команды из истории команд.

F2 - скопировать в строку ввода часть командной строки, выбранной в истории, от начала строки до указанного Вами символа.
Копируется именно выбранная команда стрелочками, а не тот текст, что введен в данный момент.

Пример работы:
Выберите в истории, необходимую команду. Для примера: cd "Program Files"
Нажмите Esc. Строка очистится.
Нажмите F2. В появившемся диалоге нажмите m. В строке отобразится: cd "Progra

F3 - вставка текущей команды из истории.

F4 - удаление до указанного символа в текущем набранном тексте

F5 - вставка предыдущей команды из истории.

F7 - отображение нумерованного списка историю команд.

F8 - аналог клавиши ↑.

F9 - ввод команды из истории команд по ее номеру. Под номером понимается цифра, присвоенная команде в списке, отображаемом по F7.

Alt + F7 - очистка истории команд.

Ctrl + C - прекращение выполнения текущего командного файла или консольного приложения.

29. Получение информации о длительности загрузки Windows 7.

Каждый раз при загрузке система собирает сведения о скорости загрузки ядра, инициализации драйверов и железа, а также о работе суперпрефетчера.
О данном событии Windows создает отчет, хранящийся в журналах приложений и служб.

Для получения информации о продолжительности загрузки, сделайте следующее:

1) В диалоговом меню Выполнить (Win   + R) или в строке поиска меню Пуск введите eventvwr.msc и нажмите Enter ↵.
2) В списке слева перейдите Журналы приложений и служб → Microsoft → Windows → Diagnostics-Performance → Работает.

Внимание: Журнал с данными о загрузке системы формируется спустя некоторое время после запуска, поэтому не открывайте журнал сразу после загрузки, а подождите несколько минут.

Каждой загрузке соответствует событие с кодом 100.

3) В меню Действия, расположенном справа от основного окна выберите команду Фильтр текущего журнала.
4) В открывшемся окне в поле <Все коды событий> введите код события: 100 и нажмите кнопку ОК.
Для того чтобы отменить действия фильтра, в меню Действия выберите команду Очистить фильтр.

5) В списке событий выберите желаемое по времени событие.
6) Ниже под списком событий расположена информация о текущем выбранном событии. Перейдите на вкладку Подробности.

Для анализа скорости загрузки интерес представляют следующие парамеры:

BootTime – общая длительность загрузки
BootPostBootTime – время с момента появления рабочего стола до полного окончания загрузки
MainPathBootTime — суммированное время до появления рабочего стола, включая все критические сервисы и драйверы, необходимые для основной работы системы

Исходя из этого можно вывести формулу: BootTime = MainPathBootTime + BootPostBootTime

BootKernelInitTime — время инициализации ядра
BootDriverInitTime — время инициализации драйверов
BootDevicesInitTime — время инициализации устройств
BootPrefetchInitTime — время работы суперпрефетчера
BootSmssInitTime — время инициализации диспетчера сеанса
BootPostBootTime — время запуска всех некритических сервисов уже при готовом рабочем столе
BootUserProfileProcessingTime – время загрузки профиля
BootNumStartupApps – количество программ в автозагрузке

Время в данных параметрах журнала указано в миллисекундах. 1 секунда = 1000 милисекунд.
Соответственно для перевода значений в секунды нужно либо разделить его на 1000, либо для получения приблизительного значения - убрать три последних цифры.

Каждому произошедшему событию присваивается определенный уровень.
Уровень события с кодом 100 (загрузка системы) устанавливается в результате достижения определенных условий:

Уровень события 100 | Условие (время в секундах)
Предупреждение | MainPathBootTime < 60 И BootPostBootTime < 30
Ошибка | 60 < MainPathBootTime < 120 И 30 < BootPostBootTime < 60
Критический | MainPathBootTime > 120 ИЛИ BootPostBootTime > 60

Уровень Предупреждение будет присвоен, если у Вас быстро загружается как система (драйверы и службы), так и пользовательская среда (рабочий стол и программы в автозагрузке).
Уровень Ошибка будет присвоен, если общая длительность загрузки (BootTime) более 90 секунд.
Уровень Критический будет присвоен при общей длительности загрузки более двух минут.

30. Скрытие одного файла в другом используя альтернативные потоки данных в NTFS.

Иcпользуя возможности файловой системы NTFS можно спрятать один файл в другой, просто добавив его как альтернативный поток данных.

Добавление одного файла в другой в качестве альтернативного потока данных.

1) Создайте на диске временную папку для работы (Например: D:\Temp) и скопируйте в нее файлы которые Вы желаете объединить.
2) Запустите командную строку (Win   + R → cmd → OK)
3) В соответствии с шаблоном введите команду и нажмите Enter ↵:

где type - команда MS-DOS,
file1 - полный путь к файлу, который будет спрятан в альтернативный поток, включая его имя и расширение,
file2 - полный путь к файлу, в который будет добавлен альтернативный поток, включая его имя и расширение,
file3 - присвоенное имя скрытому файлу альтернативного потока данных. (Может быть идентичным наименованию файла из file1)
Символ перенаправления (>) записывает содержимое файла в другое месторасположение.

Например, чтобы добавить (спрятать) файл file1.pdf в файл file2.jpg введите:

Внимание: После добавления альтернативного потока данных размер файла в Проводнике визуально останется прежним.

Просмотр наличия альтернативных потоков данных в файле.

1) Запустите командную строку (Win   + R → cmd → OK)
2) В соответствии с шаблоном введите команду и нажмите Enter ↵:

где file - полный путь к файлу, включая его имя и расширение, для которого необходимо отобразить альтернативные потоки данных.

Пример:

Открытие скрытого файла в альтернативном потоке данных.

1) Запустите командную строку (Win   + R → cmd → OK)
2) В соответствии с шаблоном введите команду и нажмите Enter ↵:

где program - полный путь к программе, необходимой для открытия альтернативного потока данных,
file - полный путь к файлу, содержащему альтернативный поток данных.
stream - наименование скрытого файла в альтернативном потоке

Примечание: Если Вы желаете добавить (спрятать) в качестве альтернативного потока данных файл-архив, то используйте rar-архив.
Пример открытия rar-архива из альтернативного потока данных:

Удаление альтернативного потока данных:

1) Запустите командную строку (Win   + R → cmd → OK)
2) Переименуйте Ваш файл, для этого в соответствии с шаблоном введите команду и нажмите Enter ↵:

где file - полный путь к файлу, включая его имя и расширение, из которого необходимо удалить альтернативные потоки данных. tempfile - временный файл с любым именем, но с идентичным расширением.

Пример:

3) Удалите временный файл, для этого в соответствии с шаблоном введите команду и нажмите Enter ↵:

Пример:

Если Вы желаете управлять альтернативными потоками данных файлов не только в командной строке, но и в графической оболочке, то скачайте одну из предложенных ниже программ:
1) AlternateStreamView: английская версия, русская версия
2) ADS Tool: английская версия, альтернативная ссылка.
3) NTFS Stream Explorer: многоязычная версия, альтернативная ссылка.

Данные программы позволяют добавить, сохранить в виде отдельного файла и/или удалить альтернативные потоки данных, плюс несколько дополнительных своих функций у каждой.

31. Извлечение файлов из cab-архива, созданного в InstallShield.

Наиболее известные cab-архивы бывают двух типов:

- Microsoft Cab Archive
- InstallShield Cab Archive

Если с извлечением файлов из cab-архивов от Microsoft проблем не возникает, так как их можно распаковать большинством архиваторов, то cab-архивы созданные в InstallShield так просто распаковать не получится.
Данные файлы обычно имеют вид data1.cab, data2.cab. Для получения файлов из них Вам понадобятся специальные программы. В большинстве случаев необходимо открыть файл data1.cab, и данные из других скорее всего подхватятся.

InstallShield Cabinet and Log File Viewer.

Официальная программа InstallShield Cabinet and Log File Viewer от создателей InstallShield: InstallShield_Cabinet_File_Viewer.zip
Чтобы открыть архив используйте меню File → Open
Чтобы просмотреть структуру папок и файлов используйте меню View → Components
Чтобы извлечь файл, выделите его и используйте меню Tools → Extract Files
Основной минус данной программы - извлекает по одному файлу за раз.

ZipScan.

1) Скачайте и распакуйте архив ZipScan.zip
2) Установите программу.
3) Скопируйте файл zd51145.dll в папку программы
В 32-битной Windows скопируйте его в: C:\Program Files\ZipScan
В 64-битной Windows скопируйте его в: C:\Program Files (x86)\ZipScan
4) Выберите в меню File пункт Open Archive File
5) Выделите необходимые Вам файлы для извлечения и щелкните на выделенном правой кнопкой мыши.
6) В контекстном меню выберите пункт Extract, укажите путь для извлечения и нажмите OK.

ISCAB.

Если Вам необходимо извлечь сразу все файлы или несколько файлов, то Вы также можете воспользоваться утилитой ISCAB запускаемой из командной строки.

1) Скачайте и распакуйте архив ISCAB.zip в папку, где находится cab-архив (data1.cab) из которого Вам необходимо извлечь файлы.
2) Удерживая нажатой клавишу ⇑ Shift, щелкните правой кнопкой мыши на данной папке в Проводнике и выберите пункт Открыть окно команд.
3) Введите команду для создания списка файлов, находящихся внутри cab-архива (после опции -i пробела быть недолжно!):

4) Введите команду для извлечения файлов указанных в списке (после опции -i пробела быть недолжно!):

Для изменения пути у какого-либо извлекаемого файла: откройте файл allfiles.ini в текстовом редакторе и добавьте рядом с ним необходимый Вам путь.

Пример.

У Вас в allfiles.ini указано, что файл MyApp.exe будет извлечен в текущую папку.

Вы желаете извлечь файл MyApp.exe в папку C:\MyFolder. Для этого измените указанную выше строчку на следующую:

Если Вы желаете извлечь только некоторые файлы, то отредактируйте в текстовом редакторе файл allfiles.ini, оставив в списке только те файлы, которые Вам необходимы.

32. Восстановление экранной заставки Windows Energy из предыдущих версий Windows.

В предыдущих версиях Windows (Vista и бетаверсии Windows 7) присутствовала экранная заставка Windows Energy, которая не вошла в финальную редакцию.

Чтобы восстановить данную экранную заставку сделайте следующее:

1) Скачайте архив WindowsEnergyScreensaver.zip
2) Распакуйте его в любую папку.
3) Переместите файл Windows Energy.scr в папку C:\Windows\System32

Чтобы выбрать данную заставку экрана.

1) Щелкните на рабочем столе и выберите пункт Персонализация.
2) Нажмите на ссылку Заставка.
3) В открывшемся окне из ниспадающего списка выберите Windows Energy и нажмите кнопку ОК.

33. Быстрое чтение QR-кодов, "Data Matrix"-кодов.

При работе с различными сайтами и документами в интернете Вы можете увидеть изображения похожие на одно из указанных ниже.

QR-код | Data Matrix | Aztec | PDF417

Они являются наиболее популярными разновидностями двухмерных штрих-кодов (2D-штрихкод), и способны вместить большое количество информации.
Чтобы расшифровать их воспользуйтесь одним из предложенных ниже вариантов:

Вариант 1. Распознавание QR-кодов и "Data Matrix" кодов без необходимости открытия изображения в самой программе.

1) Скачайте архив с программой Bar Capture и распакуйте его в любую папку.
BarCapture.zip
2) Запустите программу.
3) Откройте интернет страницу в браузере, pdf-файл или рисунок в просмотрщике изображений с QR-кодом или "Data Matrix" кодом.
4) Нажмите на значек фотоаппарата (Screen Shot).
Код распознается программой автоматически.

Если программа не распознала текст, то это означает, что либо текст плохого качества (нарушена перспектива изображения), либо рядом присутствует мешающая распознаванию информация.
Вам необходимо выделить изображение QR-кода, "Data Matrix"-кода и распознать его снова.

1) Нажмите на значек с двумя перекрещенными уголками (Capture).
2) Выделите изображение с кодом, оставив небольшой отступ с кажой стороны.
Программа автоматически считает изображение и отобразит результат.

Если распознанный текст отобразился непонятными символами, то это означает, что при создании QR-кода, "Data Matrix"-кода использовалась другая кодировка.
Вам необходимо переключить кодировку на другую и снова распознать изображение. Чтобы это сделать выполните следующие действия:

1) В главном меню программы Bar Capture нажмите File.
2) Наведите курсор мыши на пункт Charset и во всплывающем меню выберите другую кодировку.
3) Нажмите на значек фотоаппарата (Screen Shot).

Вариант 2. Распознавание QR-кодов, "Data Matrix", Aztec и PDF417 кодов с необходимостью открытия изображения в самой программе.

Если Вам необходимо кроме QR-кодов и "Data Matrix" кодов, распознать еще и PDF417 или Aztec коды, то для их распознавания Вам потребуется более мощное решение.
Это программы bcTester или BarCodeReader.

Чтобы распознать двухмерный штрихкод в программе bcTester:

1) Скачайте и установите программу bcTester (портативная версия)
2) Нажмите File → Open и укажите изображение со штрихкодом, которое Вы желаете распознать.
3) Откройте меню Barcode и в соответствии с типом штрихкода выберите необходимый Вам пункт.

Чтобы распознать двухмерный штрихкод в программе BarCodeReader:

1) Скачайте и установите программу BarCode Reader SDK for Windows
2) Откройте папку C:\Program Files\Bytescout BarCode Reader SDK
3) Скопируйте папку BarCodeReader в любое удобное для Вас место.
4) Используя оснастку Программы и компоненты удалите программу Bytescout BarCode Reader SDK.
5) Запустите программу BarCodeReader из скопированной папки.
6.1) Нажмите File → Open и укажите изображение со штрихкодом, которое Вы желаете распознать.
или
6.2) Откройте в дереве папок, папку в которой находится изображение и щелкните на нем.
7) Нажмите на панели быстрого доступа кнопку с названием типа штрихкода.
Если у Вас возникли проблемы с некорректным отображением распознанного текста, то измените в настройках программы (Options) кодировку для распознаваемого 2D-баркода (Text Encoding).
Ссылка на извлеченные BarCode Reader + BarCode Generator.

Также Вы можете воспользоваться сайтом в интернете: http://zxing.org/w/decode.jspx

34. Соответствие наименований папок в Windows XP и Windows 7.

Если до Windows 7 Вы раньше пользовались Windows XP, то заметели что многие системные папки стали называться по-другому.
Ниже приводится таблица соответствия старых путей новым.

Расположение в Windows XP | Расположение в Windows 7
C:\Documents and Settings | C:\Users
C:\Documents and Settings\All Users | C:\ProgramData
C:\Documents and Settings\All Users\Application Data | C:\ProgramData
C:\Documents and Settings\All Users\Desktop | C:\Users\Public\Desktop
C:\Documents and Settings\All Users\Documents | C:\Users\Public\Documents
C:\Documents and Settings\All Users\Documents\My Music | C:\Users\Public\Music
C:\Documents and Settings\All Users\Documents\My Pictures | C:\Users\Public\Pictures
C:\Documents and Settings\All Users\Documents\My Videos | C:\Users\Public\Videos
C:\Documents and Settings\All Users\Favorites | C:\Users\Public\Favorites
C:\Documents and Settings\All Users\Start Menu | C:\ProgramData\Microsoft\Windows\Start Menu
C:\Documents and Settings\All Users\Start Menu\Programs | C:\ProgramData\Microsoft\Windows\Start Menu\Programs
C:\Documents and Settings\All Users\Start Menu\Programs\Administrative Tools | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools
C:\Documents and Settings\All Users\Start Menu\Programs\Startup | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
C:\Documents and Settings\All Users\Templates | C:\ProgramData\Microsoft\Windows\Templates
C:\Documents and Settings\UserName | C:\Users\UserName
C:\Documents and Settings\UserName\Application Data | C:\Users\UserName\AppData\Roaming
C:\Documents and Settings\UserName\Cookies | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Cookies
C:\Documents and Settings\UserName\Desktop | C:\Users\UserName\Desktop
C:\Documents and Settings\UserName\Favorites | C:\Users\UserName\Favorites
C:\Documents and Settings\UserName\Local Settings\Application Data | C:\Users\UserName\AppData\Local
C:\Documents and Settings\UserName\Local Settings\Application Data\Microsoft\CD Burning | C:\Users\UserName\AppData\Local\Microsoft\Windows\Burn\Burn
C:\Documents and Settings\UserName\Local Settings\History | C:\Users\UserName\AppData\Local\Microsoft\Windows\History
C:\Documents and Settings\UserName\Local Settings\Temporary Internet Files | C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files
C:\Documents and Settings\UserName\Local Settings\Temp | C:\Users\UserName\AppData\Local\Temp
C:\Documents and Settings\UserName\My Documents | C:\Users\UserName\Documents
C:\Documents and Settings\UserName\My Documents\My Music | C:\Users\UserName\Music
C:\Documents and Settings\UserName\My Documents\My Pictures | C:\Users\UserName\Pictures
C:\Documents and Settings\UserName\My Documents\My Videos | C:\Users\UserName\Videos
C:\Documents and Settings\UserName\My Recent Documents | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Recent
C:\Documents and Settings\UserName\NetHood | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Network Shortcuts
C:\Documents and Settings\UserName\PrintHood | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Printer Shortcuts
C:\Documents and Settings\UserName\SendTo | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo
C:\Documents and Settings\UserName\Start Menu\Programs | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
C:\Documents and Settings\UserName\Start Menu\Programs\Administrative Tools | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools
C:\Documents and Settings\UserName\Start Menu\Programs\Startup | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
C:\Documents and Settings\UserName\Templates | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Templates
Расположение в Windows XP | Расположение в Windows 7

35. Способы вставки среднего и длинного тире в Проводнике и в Microsoft Word.

Используя клавиатуру Вы можете установить только короткое тире (дефис).
Если Вам необходимо добавить в имя папки, файла или в текст среднее или длинное тире, воспользуйтесь предложенным ниже решением.

В Проводнике, Блокноте или других текстовых поля или редакторах.

1) Зажмите клавишу левого Alt
2) Наберите с помощью цифровой клавиатуры цифры 0150 для установки среднего тире или 0151 для установки длинного.
3) Отпустите клавишу Alt.

В Microsoft Word.

1) Наберите:
число 2012 или 2013 для установки среднего тире.
число 2014 или 2015 для установки длинного тире.
2) Нажмите сочетание клавиш Alt + X (икс).


Твики Реестра.

Твики Реестра - Общие.

1. Запуск программы "Редактор реестра", создание и применение reg-файла.

Запуск программы "Редактор реестра":

Вариант 1.

1.1) Откройте меню Пуск → Все программы → Стандартные → Выполнить (или нажмите сочетание клавиш Win   + R)
1.2) Введите команду regedit и нажмите ОК
Если Вы работаете под учетной записью администратора, то при отключенном UAC (контроле учетных записей) програма запустит© с правами администратора.

Вариант 2.

2.1) Откройте меню Пуск
2.2) В строке поиска введите regedit и нажмите Ctrl + ⇑ Shift + Enter ↵ для запуска с правами администратора.

Вариант 3.

3.1) Откройте в Проводнике папку C:\Windows
3.2) Щелкните правой кнопкой мыши на по файлу regedit.exe и выберите пункт Запуск от имени администратора.

Вариант 4.

4.1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4.2) Введите команду regedit и нажмите клавишу Enter ↵.

Создание reg-файла.

Вариант 1.

1.1) Откройте Блокнот (Notepad).
1.1.1) Откройте меню Пуск → Все программы → Стандартные → Блокнот (или нажмите сочетание клавиш Win   + R → введите notepad → нажмите ОК).
1.2) Скопируйте необходимый Вам код в окно программы Блокнот.
1.3) В меню программы нажмите Файл и выберите пункт Сохранить.
1.4) В открывшемся окне:
1.4.1) Укажите место сохранения файла.
1.4.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
1.4.3) Выберите тип файла: Все файлы (*.*).

Внимание:
Если Вы оставите тип файла: Текстовые файлы (*.txt), то имя файла обязательно нужно взять в кавычки. (Например: "Demo.reg")

1.5) Нажмите на кнопку Сохранить.

Вариант 2.

Если у Вас убран флажок Скрывать расширения для зарегистрированных типов файлов в Параметры папок (Панель управления\Оформление и персонализация\Параметры папок → Вкладка Вид), то Вы можете создать reg-файл следующим способом:

2.1) В папке, где Вы хотите создать reg-файл, щелкните правой кнопкой мыши.
2.2) Во всплывшем меню выберите Создать → Текстовый документ.
2.3) Сотрите имя и расширение файла .txt, укажите необходимое Вам имя файла и расширение .reg, нажмите клавишу Enter ↵, а затем кнопку Да.
2.4) Щелкните на созданном Вами файле правой кнопкой мыши и выберите пункт Изменить.
2.5) Скопируйте необходимый Вам код в окно программы Блокнот.
2.6) Нажмите сочетание клавиш Ctrl + S.

Вариант 3.

3.1) Возьмите любой готовый reg-файл.
3.2) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить.
3.3) Скопируйте необходимый Вам код в окно программы Блокнот.
3.4) В меню программы нажмите Файл и выберите пункт Сохранить Как.
3.5) В открывшемся окне:
3.5.1) Укажите место сохранения файла.
3.5.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
3.5.3) Выберите тип файла: Все файлы (*.*).
3.6) Нажмите на кнопку Сохранить.

Применение reg-файла.

Вариант 1.

1) Щелкните два раза левой кнопкой мыши на reg-файле и нажмите кнопку Да.

Вариант 2.

2.1) Щелкните правой кнопкой мыши на reg-файле.
2.2) Выберите пункт Слияние и нажмите кнопку Да.

Вариант 3.

3.1) Откройте меню Пуск → Все программы → Стандартные → Выполнить (или нажмите сочетание клавиш Win   + R)
3.2) Введите команду regedit /s Путь_к_файлу\имя_файла.reg и нажмите ОК (Например: regedit /s D:\myfile.reg)
Для применения многих reg-файлов необходимо, чтобы Вы работали под учетной записью администратора и Контроль Учетных Записей (UAC) был отключен.

Вариант 4.

4.1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4.2) Введите команду regedit /s Путь_к_файлу\имя_файла.reg и нажмите клавишу Enter ↵. (Например: regedit /s D:\myfile.reg)

Внимание: Если у Вас в реестре уже будет присутствовать параметр добавляемый reg-файлом, то при применении reg-файла, имеющиеся значения параметров будут заменены на новые.

2. Создание и переименование раздела или параметра, а также изменение параметра в редакторе реестра.

Вы запустили программу "Редактор реестра" как описано в совете 1. Запуск программы "Редактор реестра", создание и применение reg-файла. из раздела Твики Реестра - Общие. Используя дерево папок открыли нужный Вам раздел, и теперь, Вам необходимо создать, переименовать параметр (раздел), либо изменить значение параметра реестра. Существует несколько способов сделать это.

Создание раздела или параметра в редакторе реестра.

Вариант 1.

1) Щелкните в главном меню пункт Правка.
2) Наведите курсор мыши на пункт меню Создать.
3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

Вариант 2.

1) Щелкните правой кнопкой мыши в любом пустом месте области параметров (правая часть окна).
2) Наведите курсор мыши на пункт меню Создать.
3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

Переименование раздела или параметра в редакторе реестра.

Вариант 1.

1) Выберите раздел или параметр, который Вы желаете переименовать.
2) Щелкните в главном меню пункт Правка, а затем на пункт Переименовать.

Вариант 2.

1) Щелкните правой кнопкой мыши на раздел или параметр, который Вы желаете переименовать.
2) Щелкните левой кнопкой мыши на пункт Переименовать.

Изменение значения параметра в редакторе реестра.

Вариант 1.

1) Выберите параметр, который Вы желаете изменить.
2) Щелкните в главном меню пункт Правка, а затем на пункт Изменить.

Вариант 2.

1) Щелкните правой кнопкой мыши на параметр, который Вы желаете изменить.
2) Щелкните левой кнопкой мыши на пункт Изменить

Вариант 3.

Щелкните дважды на параметре, который Вы желаете изменить.

3. Аббревиатуры используемые для обозначения веток реестра.

Для обозначения пути к разделу или ключу реестра могут использоваться следующие аббревиатуры:

Наименование раздела | Используемая аббревиатура
HKEY_CLASSES_ROOT | HKCR
HKEY_CURRENT_USER | HKCU
HKEY_LOCAL_MACHINE | HKLM
HKEY_USERS | HKU
HKEY_CURRENT_CONFIG | HKCC

4. Быстрый переход в необходимый раздел реестра.

Если для работы с реестром Вы предпочитаете не использовать альтернативные программы, то для быстрого перехода в необходимый Вам раздел реестра Вы можете воспользоваться одним из указанных ниже вариантов.

Вариант 1.

1) Скачайте маленькую бесплатную утилиту от Microsoft: RegJump
2) Распакуйте архив в любую папку и скопируйте файл regjump.exe в папку C:\Windows\System32
3) Теперь любую ветку реестра можно открыть прямо из диалогового меню Выполнить или из строки поиска в меню Пуск.
3.1) В диалоговом меню Выполнить (Win   + R), либо в строке поиска из меню Пуск введите команду regjump и путь к разделу, указав его в кавычках.

Например:

3.2) Нажмите клавишу Enter ↵, при вводе из окна Выполнить или ⇑ Shift + Enter ↵ при вводе в строку поиска:

Вариант 2.

1) Скачайте и установите программу Registry Workshop.
Данная программа позволит Вам переходить в разделы реестра, используя reg:// протокол.
2) Для перехода в любой раздел реестра введите в адресной строке Проводника, Internet Explorer или Mozilla Firefox необходимый Вам адрес ключа в реестре, как указано ниже и нажмите клавишу Enter ↵:

Например:

Вариант 3.

1) Создайте специальный скрипт.

1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "regkey.vbs")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
2) Переместите созданный Вами скрипт в любую удобную Вам папку.
Теперь для открытия раздела реестра:
3) Скопируйте в буфер обмена(Ctrl + C или Щелчок правой кнопкой мыши → Копировать) необходимую Вам ветку реестра.
4) Щелкните на созданный Вами скрипт-файл.

Минусом использования данного скрипта является отсутствие поддержки аббревиатур.

5. Отключение вывода диалогового окна при применении reg-файла.

При запуске reg-файла, система выводит диалоговое окно в котором пользователь должен подтвердить достоверность источника, откуда получены импортируемые в реестр сведения. Для отключения данного окна выполните указанные ниже действия:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CLASSES_ROOT\regfile\shell\open\command
3) Дважды щелкните на параметре По умолчанию и введите значение:

4) Закройте редактор реестра и перезапустите компьютер.

Минусом данного решения является то, что помимо указанного диалогового окна запроса подтверждения, также не будет выводит© окно об успешном импортировании в реестр данных.

6. Значения разделов реестра ControlSet001, ControlSet002 и CurrentControlSet.

Разделы реестра ControlSet содержат информацию о конфигурации системы, такую как драйверы устройств и службы.
При просмотре реестра Вы можете заметить несколько экземпляров ControlSet.
Некоторые из них являются копиями или зеркальными отображения других, а некоторые являются уникальными.

Различное количество подразделов реестра ControlSet может находит© в кустах реестра HKEY_CURRENT_USER, HKEY_LOCAL_MACHINE, HKEY_CURRENT_CONFIG в ветке SYSTEM.
Может существовать несколько ControlSet это зависит от того, как часто Вы изменяете параметры системы или как часто возникают неполадки с выбранными параметрами.
Обычно после установки Windows в реестре могут присутствовать следующие разделы:

\ControlSet001
\ControlSet002
\CurrentControlSet

Раздел ControlSet001 содержит информацию о последней конфигурации с которой Вы загрузили текущую систему.
Раздел ControlSet002 содержит информацию о последней удачной конфигурации или конфигурации последней успешной загрузки Windows.
Раздел CurrentControlSet на самом деле является указателем на один из разделов ControlSetXXX.

Чтобы лучше понять, как используются разделы ControlSet, Вам нужно узнать об еще одном разделе - Select

Раздел Select также находится в ветке SYSTEM и содержит следующие значения:

Current
Default
Failed
LastKnownGood

Каждое из этих значений содержит тип данных REG_DWORD и ссылаться на определенный ControlSet.
Например, если значение Current установлено 0x1, значит CurrentControlSet ссылается на ControlSet001.
Аналогично Если LastKnownGood равно 0x2, то последней удачной конфигурацией является ControlSet002.
Значение Default обычно идентично Current, а значение Failed ссылается на последнюю неудавшуюся загрузку Windows.
Если Вам необходимо изменить параметры системного реестра, то лучше выбрать CurrentControlSet, поскольку она является текущей конфигурацией и если внесенные Вами изменения нанесут вред системе, то Вы по-прежнему сможете воспользоваться последней удачной конфигурацией.

7. Создание и удаление разделов или параметров реестра используя reg-файл.

Добавление значений в реестр, используя reg-файл.

Для добавления раздела в реестр, создайте reg-файл используя следующий шаблон:

Например:

Для добавления(изменения) значения параметра в реестре, создайте reg-файл используя следующий шаблон:

Примеры:

Добавление(изменение) строкового параметра:

Добавление(изменение) параметра DWORD:

Добавление(изменение) двоичного параметра:

Добавление(изменение) параметра (По умолчанию):

Удаление значений из реестра, используя reg-файл.

Для удаления раздела из реестра, создайте reg-файл используя следующий шаблон:

Например:

Для удаления значения (присвоения ему нулевого значения) параметра из реестра, создайте reg-файл используя следующий шаблон:

Для полного удаления параметра из реестра, создайте reg-файл используя следующий шаблон:

Например:

Можно выделить следующие принципы построения reg-файла:

В reg-файле первой должна идти строка: Windows Registry Editor Version 5.00, затем пустая строка, и только после нее раздел, в который следует добавить необходимый Вам параметр.
Значок @ в reg-файле соответствует параметру (По умолчанию).
Название раздела реестра должно быть указано в квадратных скобках: []
При указании в значение параметра пути к файлу или папке используйте два обратных слеша: \\
Значения строкового параметра заключайте в кавычки, за исключением знака минус.
При удалении раздела реестра знак минус добавлятся перед открывающейся квадратной скобкой: [-
При удалении параметра реестра знак минус добавляется после знака равно: =-
При обнулении значения параметра после знака равно ставятся двойные кавычки: =""
При удалении раздела реестра не надо прописывать удаление параметров, имеющихся в данном разделе, так как они удалятся автоматически.

8. Создание и удаление разделов или параметров реестра используя командную строку.

Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.

Внимание: Значения содержащие пробелы должны быть заключены в кавычки.

Добавление значений в реестр, используя командную строку.

Для добавления значений в реестр используется команда REG ADD.

Путь - Полный путь к разделу реестра в виде КОРЕНЬ\Подраздел.
КОРЕНЬ - Корневой радел. Значения [ HKLM | HKCU | HKCR | HKU | HKCC].
Подраздел - Полный путь к разделу реестра в выбранном корневом разделе.

/v - Добавить параметр с определенным именем в указанном разделе.
/ve - Добавить параметр (По умолчанию) в указанный раздел.

/t - Типы данных [REG_SZ | REG_EXPAND_SZ | REG_MULTI_SZ | REG_DWORD | REG_BINARY]
REG_SZ - строковый параметр
REG_EXPAND_SZ - расширяемый строковый параметр
REG_MULTI_SZ - мультистроковый параметр
REG_DWORD - DWORD-параметр
REG_BINARY - Двоичный параметр
По умолчанию, считается равным REG_SZ.

/d - Значение, присваемое добавляемому параметру реестра.
/f - Принудительно перезаписать существующие записи реестра без предупреждения.
\0 - Перенос на другую строку в мультистроковом параметре.
^ - Используется для указывания путей в виде переменных перед знаком процента % в значениях параметров.

Примеры команды REG ADD:

1) Добавить подраздел MyCompany в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE:

2) Добавить строковый параметр с именем: Data и значением: C\MyProgram\MyFile.exe в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

3) Добавить DWORD-параметр с именем: Data и значением: FF (или 0xFF) в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

4) Добавить двоичный параметр с именем: Data и значением: fe340ead в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

5) Добавить расширяемый строковый параметр с именем: Data и значением: %systemroot%\Minidump\* /s в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение:

6) Добавить мультистроковый параметр с именем: Data в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany и указанным ниже значением из двух строк без вывода запроса на подтверждение:

%systemroot%\Minidump\* /s
%systemroot%\memory.dmp

7) Добавить параметр (По умолчанию) со значением: 00000419 в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

Удаление значений из реестра, используя командную строку.

Для удаления значений из реестра используется команда REG DELETE.

Путь - Полный путь к разделу реестра в виде КОРЕНЬ\Подраздел.
КОРЕНЬ - Корневой радел. Значения [ HKLM | HKCU | HKCR | HKU | HKCC].
Подраздел - Полный путь к разделу реестра в выбранном корневом разделе.

/v - Удалить параметр с определенным именем в указанном разделе.
/ve - Удалить значение параметра (По умолчанию) в указанном разделе.
/va - Удалить все параметры в указанном разделе.

/f - Удалить принудительно, без дополнительного предупреждения.

Примеры команды REG DELETE:

1) Удалить подраздел MyCompany из раздела реестра HKEY_LOCAL_MACHINE\SOFTWARE

2) Удалить параметр Data из раздела реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

3) Удалить значение параметра (По умолчанию) в разделе реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

4) Удалить все параметры реестра из раздела реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

9. Добавление возможности создания файла реестра (reg-файла) из контекстного меню.

Если Вы часто создаете reg-файлы, то для Вас будет удобно добавить пункт для их создания в контекстное меню Создать.

Чтобы добавить возможность создания reg-файла из контекстного меню Создать, создайте и примените любой из указанных ниже reg-файлов.

или

10. Альтернативные программы используемые для редактирования реестра.

Входящая в состав Windows программа Редактор реестра (regedit.exe) при всем её великолепии имеет ряд ограничений по функциональности. Например, в ней нет адресной строки. Для полноценной работы с реестром рекомендуется использовать программы сторонних производителей. Наиболее известными являются: Registry Workshop, Registry Commander, RegEditX и Reg Organizer.

Registry Workshop

Данная программа является расширенным редактором системного реестра. Может быть идеальной заменой стандартному редактору, встроенному в операционную систему. В добавок к обычным функциям редактора, программа обладает различными мощными возможностями для полноценного обслуживания реестра, при этом работая быстрее стандартного RegEdit. Все совершенные действия в программе могут быть отменены, даже в случае неоднократного перезапуска этой утилиты. Вы не будете переживать за совершенные ошибки при редактировании реестра, ведь в случае чего, их всегда можно будет отменить. Также Registry Workshop позволяет чистить реестр от различных ошибок и неправильных записей, обнаруживать и уничтожать троянских коней, вирусы и шпионские данные. А также позволяет создавать закладки, резервировать реестр и восстанавливать его из резервной копии, дефрагментировать реестр, сравнивать ветви реестра, открывать REG-файлы в отдельных вкладках и редактировать их.

Возможности Registry Workshop:

» Многоуровневые отмена и повтор действий с сохранением истории на диск.
» Поиск и замена ключей, значений и данных реестра с помощью быстрого поискового алгоритма.
» Сравнение реестра между компьютерами или отдельными REG-файлами с большой скоростью.
» Соединение с реестром мобильных устройств через ActiveSync.
» Вырезание, копирование и вставка ключей и значений реестра.
» Поддержка функции drag and drop.
» Редактирование REG-файлов и POL-файлов в отдельной вкладке.
» Резервирование и восстановление реестра.
» Дефрагментация реестра с предварительным просмотром.
» Добавление раздела или параметра в Избранное.
» Удобное и быстрое управление реестром с помощью адресной строки, закладок и историей посещений.
» Переход к одному и тому же ключу в HKLM, Wow6432Node или HKCU через контекстное меню.
» Открытие несколько окон реестра.
» Редактирование двоичных данных в BYTE, WORD или DWORD форматах.
» Добавление поддержки reg:// протокола в систему, для быстрого перехода в необходимый раздел реестра, используя Internet Explorer, Проводник или Mozilla FireFox.

Registry Commander

Данная программа является является хорошей альтернативой стандартному редактору реестра, который поставляется вместе с Windows. Она предлагает те же самые функции, а также немного больше. Основным различием между Registry Commander и RegEdit, является визуальное отображение данных реестра. Вместо наличия всех ключей слева в виде дерева, они отображаются в том же окне так, как если бы они были обычными папками с файлами.

Возможности Registry Workshop:

» Копирование или Переименовывание/Перемещение всех ключей и значений из одного ключа в другой.
» Вырезание или Копирование ключей и значений из одного места и вставка их в другое.
» Колонка, отображающая размер в байтах данных в значении.
» Поддержка всех 12 типов данных, определенных в файле заголовков "winnt.h". Большинство других редакторов реестра обрабатывают только Строковый (String), Двоичный (Binary), DWORD, Расширяемый Строковый (Expanded Strings) и также иногда Мультистроковый (Multi-String).
» Создание закладок на ключи или значения, позволяющие получить к ним более быстрый доступ. С каждой закладкой можно связать комментарий.
» Поиск в части или во всей базе данных реестра, Вы можете искать не только по ключевому слову, но Вы также можете искать по размеру или типу данных.
» Изменение типа данных для значения. То есть Вы можете изменить строковое в двоичное значение, без изменения данных в значении.
» Возможность интерпретировать одно значение для другого, без изменения данных. Это позволит Вам просматривать строковое значение, сохраненное как двоичное значение или наоборот.
» С помощью reg:// протокола, Вы сможете создавать ссылки на определенный ключ в реестре, он работает так же, как и http:// протокол.
» Добавленный список истории позволит Вам быстро перейти от текущего ключа к предыдущему.

RegEditX

Все новые функции являются интерфейсной настройкой над regedit. Но вначале нужно изменить расположение кнопок, так как по умолчанию они настроены для условно-бесплатной программы Registry Crawler. Выберите "RegEditX | Options" и укажите в качестве редактора Regedit.

Основным отличием от стандартной программы "Редактор реестра" является дополнительная адресная строка. Она очень удобна, когда нужно найти ключ реестра, скопированный, например, с веб сайта. В эту строку можно вставить скопированный путь к ключу. Программа уберет лишние пробелы и откроет соответствующую ветвь реестра. Кроме того, редактор автоматически сохранит строку, и вы сможете быстро получить к ней доступ в следующий раз, выбрав ее из выпадающего списка.

Reg Organizer

Это многофункциональная программа для чистки реестра и его обслуживания. Позволяет просматривать и редактировать системный реестр, проводить поиск и автоматическую замену данных в реестре, осуществлять предварительный просмотр импортируемых reg-файлов (в том числе и из Проводника).
Функция поиска в реестре также предоставляет возможность производить глубокий поиск, находя все ключи, относящиеся к интересующему приложению. Кроме того, Reg Organizer позволяет производить полное удаление программного обеспечения, подчищая все "хвосты", остающиеся в системе после обычного удаления.

Основные возможности программы:

» Редактор реестра для просмотра и редактирования системного реестра, позволяющий производить различные операции c ключами и значениями системного реестра, экспортировать, импортировать, копировать значения ключей и т.д.
» Функция чистки реестра для поиска ненужных записей в реестре, а также для поиска и исправления проблем в реестре.
» Функция поиска в реестре позволяет найти ключи, относящиеся к интересующему Вас приложению, и удалить их при необходимости. Это полезно, например, в случае, когда какое-либо приложение не имеет программы деинсталляции и после его удаления "вручную" в реестре остаются ненужные записи, которые могут приводить к некорректному функционированию других приложений. В то же время, Reg Organizer производит более глубокий поиск и позволяет зачастую найти даже те ключи, связанные с данным приложением, которые не будут найдены другими аналогичными программами.
» Дефрагментация и сжатие реестра. Эти процедуры позволяют повысить скорость работы с реестром и, как следствие, скорость работы Вашей системы в целом.
» Возможность изменения многих "тонких настроек" Windows (tweaks). В частности, Вы можете ускорить работу Вашей системы, приказав системе использовать кэш-память большего объема, или заставив систему выгружать неиспользуемые библиотеки из памяти и т.д.
» Возможность получать информацию о любом ключе реестра и следить за изменениями в нем.
» Предварительный просмотр файлов реестра (*.reg) перед импортом их содержимого, в том числе и непосредственно из Проводника. При просмотре импортируемого reg-файла его содержимое представляется в виде древовидной структуры, что позволяет представить в наглядной форме все ключи, которые будут импортированы в реестр.
» Функциональный редактор файлов реестра для редактирования ключей и параметров, добавления и удаления данных, содержащихся в .reg-файлах.
» Просмотр и редактирование автоматически запускаемых программ, т.е. приложений, которые загружаются при старте Windows или входе в систему.
» Режим поиска и замены в реестре представляет собой удобный инструмент для нахождения (и, при необходимости, изменения) ключей или параметров системного реестра, отвечающих критериям поиска.
» Встроенная функция деинсталляции любых приложений. Она может сделать "снимок" системы до и после установки приложения, после чего можно полностью "откатить" внесенные в систему изменения, как будто приложение не было установлено.
» Инструмент "Чистка дисков" позволяет производить автоматическую чистку жестких дисков вашего компьютера от различных ненужных файлов, а также выполнять поиск и исправление неверных ярлыков.

11. Изменение параметров реестра, используя установочный диск.

Если Вам необходимо изменить параметры реестра, к которым Вы не можете получить доступ из работающей Windows, то Вы можете отредактировать используя установочный диск Windows.
Чтобы сделать это:

1) Вставьте или подключите установочный DVD-диск или флеш-диск (флешку) к компьютеру.
2) Перезагрузите компьютер.
3) Нажмите кнопку для вызова загрузочного меню (Boot Menu) (В зависимости от производителя материнской платы F8, F11, F12)
4) Выберите в списке Ваш диск и нажмите клавишу Enter ↵.
5) После загрузки в установочный экран Windows нажмите ⇑ Shift + F10.
6) Введите regedit и нажмите клавишу Enter ↵.

Для разделов ветки HKEY_LOCAL_MACHINE.

7.1) Нажмите на раздел HKEY_LOCAL_MACHINE
7.2) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
7.2) Откройте папку C:\Windows\System32\config (D:\Windows\System32\config).
7.3) Выберите файл в котором хранятся параметры необходимой Вам ветки реестра и нажмите кнопку Открыть (Open).

HKEY_LOCAL_MACHINE\SAM | C:\Windows\System32\config\SAM
HKEY_LOCAL_MACHINE\SECURITY | C:\Windows\System32\config\SECURITY
HKEY_LOCAL_MACHINE\SOFTWARE | C:\Windows\System32\config\SOFTWARE
HKEY_LOCAL_MACHINE\SYSTEM | C:\Windows\System32\config\SYSTEM

В некоторых случаях вместо диска C: данные файлы следует искать на диске D: в папке D:\Windows\System32\config.

7.4) Задайте временное имя для куста. Например:

SAM_original для HKEY_LOCAL_MACHINE\SAM
SECURITY_original для HKEY_LOCAL_MACHINE\SECURITY
SOFTWARE_original для HKEY_LOCAL_MACHINE\SOFTWARE
SYSTEM_original для HKEY_LOCAL_MACHINE\SYSTEM

7.5) Отредактируйте необходимые Вам параметры в добавленных ветках, идентично редактированию в самой Windows.

Имя добавленной ветки | Имя соответствующей ветки в Windows
HKEY_LOCAL_MACHINE\SAM_original | HKEY_LOCAL_MACHINE\SAM
HKEY_LOCAL_MACHINE\SECURITY_original | HKEY_LOCAL_MACHINE\SECURITY
HKEY_LOCAL_MACHINE\SOFTWARE_original | HKEY_LOCAL_MACHINE\SOFTWARE
HKEY_LOCAL_MACHINE\SYSTEM_original | HKEY_LOCAL_MACHINE\SYSTEM

Пример.

Название необходимых веток для редактирования:
HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE_original\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

Имя соответствующей ветки в Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

Для раздела HKEY_USERS\.DEFAULT.

8.1) Нажмите на раздел HKEY_USERS
8.2) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
8.3) Откройте папку C:\Windows\System32\config (D:\Windows\System32\config), выберите файл DEFAULT и нажмите кнопку Открыть (Open).
8.4) Задайте временное имя для куста (Например: DEFAULT_original)
8.5) Отредактируйте необходимые Вам параметры в ветке HKEY_USERS\DEFAULT_original, идентично редактированию ветки HKEY_USERS\.DEFAULT в самой Windows.

Для раздела HKEY_CURRENT_USER.

9.1) Нажмите на раздел HKEY_USERS
9.2) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
9.3) Откройте папку Вашего профиля C:\Users\ИмяПользователя (Например: C:\Users\Nizaury)
9.4) Введите в поле Имя файла (File name) значение ntuser.dat и нажмите кнопку Открыть (Open).
9.5) Задайте временное имя для куста (Например: Username_original)
9.6) Отредактируйте необходимые Вам параметры в ветке HKEY_USERS\Username_original, идентично редактированию ветки HKEY_CURRENT_USER в самой Windows.

Пример.

Название необходимой ветки для редактирования:
HKEY_USERS\Username_original\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

Имя соответствующей ветки в Windows:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

10) После внесения необходимых изменений нажмите на добавленный Вами куст (SOFTWARE_original, Username_original или др.)
11) Откройте меню Файл (File) и нажмите Выгрузить куст (Unload Hive)
12) Перезагрузите компьютер, чтобы вернуться обратно в Windows.

Твики Реестра - Администрирование и Безопасность.

1. Получение полного доступа к разделу реестра, используя программу regedit или командную строку.

Для поддержания безопасности системы, после внесения изменений в реестр верните исходные права и восстановите владельца.

Изменение разрешений и владельца для получения полного доступа к разделу реестра.

1) Нажмите кнопку Пуск и введите в строке поиска regedit
2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
3) Откройте раздел реестра, права которого Вы желаете изменить.
4) В списке слева, щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Разрешения.
5) Щелкните левой кнопкой мыши на группу Администраторы (Administrators):
6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

7) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
8) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
9) Выделите группу Администраторы (Administrators), установите флажок Полный доступ и нажмите кнопку ОК.

10) Если у Вас отсутствует группа Администраторы (Administrators), то нажмите поочередно кнопки Добавить... → Дополнительно... → Поиск
11) В результатах поиска выберите Администраторы (Administrators) и нажмите кнопку OK, и еще раз ОК.
12) Щелкните левой кнопкой мыши на группу Администраторы (Administrators) и установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

Восстановление настроек, если владельцем являлись служба TrustedInstaller или учетная запись Система.

1) Щелкните правой кнопкой мыши на разделе реестра, права которого Вы желаете восстановить и выберите пункт Разрешения.
2) Щелкните левой кнопкой мыши на группу Администраторы:
3) Снимите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку Применить.
4) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
5) Нажмите кнопку Другие пользователи или группы... и в качестве имени объекта в текстовом поле введите:
  • NT SERVICE\TrustedInstaller , если владельцем являлась служба TrustedInstaller
  • система , если владельцем являлась учетная запись Система (в английской Windows 7 нужно вводить System)

    • 6) В окне Изменить владельца на: выберите TrustedInstaller или система .
    7) Установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.

    Далее рассказывается как можно изменить разрешения, используя командную строку запущенную от имени администратора.
    (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
    Если после использовании команды, разрешения не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение разрешений используя командную строку.

    1) Создайте в любом месте txt-файл (Например в папке D:\Reg создайте файл regperm.txt)
    2) Добавьте в данный файл разделы реестра и присваиваемые им разрешения в следующем формате:

    где куст – имя куста реестра, раздел – имя раздела реестра, а [разрешения] – двоичный числовой формат разрешений.

    Обозначения используемые для кустов реестра:

    Наименование куста реестра | Следует указывать
HKEY_CLASSES_ROOT | \Registry\machine\software\classes
HKEY_CURRENT_USER | \Registry\user\user_sid где user_sid — идентификатор безопасности пользователя.
HKEY_LOCAL_MACHINE | \Registry\machine
HKEY_USERS | \Registry\user
HKEY_CURRENT_CONFIG | \Registry\machine\SYSTEM\CurrentControlSet\Hardware Profiles\0001

    Если Вы не знаете свой SID, то узнать его Вы сможете введя в командной строке команду:

    Двоичные числовые представления разрешений имеют следующий вид (выборочно):

    Значение | Задаваемое разрешение
1 | Администратор, полный доступ
2 | Администратор, чтение
3 | Администратор, чтение и запись
4 | Администратор, чтение, запись и удаление
5 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, полный доступ
6 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, чтение и запись
7 | Все, полный доступ
8 | Все, чтение
9 | Все, чтение и запись
10 | Все, чтение, запись и удаление
11 | Опытные пользователи, полный доступ
12 | Опытные пользователи, чтение и запись
13 | Опытные пользователи, чтение, запись и удаление
17 | Система, полный доступ
18 | Система, чтение и запись
19 | Система, чтение

    Пример:

    Чтобы задать полный доступ группам и пользователям Администратор, СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ и Система для раздела реестра:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer в txt-файл необходимо добавить

    3) Запустите командную строку от имени администратора.
    В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
    4) Введите указанную ниже команду и нажмите Enter ↵:

    Например:

    2. Запуск редактора реестра от имени пользователя Система, для удаления и редактирования заблокированных разделов.

    Бывает, что при редактировании реестра доступ к некоторым разделам закрыт даже для администратора, а при попытке добавить нового пользователя, Вы получаете сообщение: Отказано в доступе.
    В таком случае Вам поможет программа от Microsoft - PsExec. Данная программа позволяет запустить процесс от имени пользователя Система.

    1) Зайдите на сайт http://technet.microsoft.com/ru-ru/sysinternals/bb897553
    2) Скачайте комплект программ PsTools и распакуйте в любую папку.
    3) Скопируйте файл PsExec.exe в папку C:\Windows\System32
    4) Запустите командную строку от имени администратора.
    В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
    5) Введите указанную ниже команду и нажмите Enter ↵:

    Эта команда запустит редактор реестра в интерактивном режиме из системной учетной записи.

    Таким же образом, Вы можете запустить и другие программы для редактирования реестра, например: Registry Workshop.

    Внимание: При работе с PsExec обязательно полностью указывайте путь к программе, которую Вы желаете запустить от имени пользователя Система. А если в пути содержатся пробелы, то заключайте его в кавычки.

    3. Запуск редактора реестра от имени пользователя TrustedInstaller, для удаления и редактирования заблокированных разделов.

    Если Вам необходимо запустить программу от имени пользователя TrustedInstaller, то выполните для этого следующее:

    1) Зайдите на сайт http://developex.com/custom-software/devxexec.html
    2) Скачайте файл devxexec.exe.
    3.1) Если у Вас 32-битная Windows, то скопируйте файл devxexec.exe в папку C:\Windows\System32
    3.2) Если у Вас 64-битная Windows, то скопируйте файл devxexec.exe в папки: C:\Windows\System32 и C:\Windows\SysWOW64
    4) Откройте диалоговое меню Выполнить из меню Пуск (Win   + R)
    5) Введите указанную ниже команду и нажмите Enter ↵:

    Эта команда запустит редактор реестра от имени пользователя TrustedInstaller.

    Таким же образом, Вы можете запустить и другие программы для редактирования реестра, например: Registry Workshop.

    Внимание: При работе с Devxexec обязательно полностью указывайте путь к программе, которую Вы желаете запустить от имени пользователя TrustedInstaller. Если в пути содержатся пробелы, то заключайте его в кавычки.

    4. Запрещение создания и изменения значения параметров в указанном разделе реестра.

    Если Вам необходимо запретить возможность создания или изменения какой-либо программой значений параметров в указанном Вами разделе реестра, то выполните следующие действия:

    1) Запустите Редактор реестра (Win   + R → regedit → OК)
    2) В списке слева, щелкните правой кнопкой мыши на разделе реестра, в котором необходимо запретить создание и/или изменение параметров и выберите пункт Разрешения.
    3) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    4) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    6) Нажмите кнопку Дополнительно и перейдите на вкладку Разрешения
    7) Уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажмите кнопку Удалить.
    8) Нажмите поочередно кнопки Добавить... → Дополнительно... → Поиск
    9) В результатах поиска выберите Все и нажмите кнопку OK, и еще раз ОК.
    10) Установите флажок в колонке Разрешить напротив следующих разрешений:

    Запрос значения
    Перечисление подразделов
    Уведомление
    Чтение разрешений

    11) Нажмите кнопку ОК и перезагрузите компьютер.

    5. Отключение проверки подписи для загруженных программ.

    Избавляет от этого:

    1) Откройте Панель управления → Свойства обозревателя → вкладка Дополнительно
    2) Уберите флажок "Проверка подписи для загруженных программ" и поставьте флажок "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
    3) Создайте и примените reg-файл следующего содержания.

    6. Удаление устаревших значков из области уведомления панели задач.

    После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
    С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

    Скачать готовый reg-файл Вы можете по ссылке: CleanTrayNotify.zip

    7. Очистка истории расположений фонов рабочего стола в Windows 7.

    В окне настроек фонового рисунка рабочего стола (ПКМ на рабочем столе → Персонализация → Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

    1. Фоны рабочего стола Windows;
    2. Библиотека изображений;
    3. Самые популярные фотографии;
    4. Сплошные цвета.

    Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

    Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

    Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на рабочем столе → Персонализация → Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

    8. Удаление папки Общие Документы и пользовательского профиля Общие.

    Для спокойного удаления папки Общие Документы и пользовательского профиля Общие указанные ниже действия рекомендуется выполнять на чистой установленной системе. Если же у Вас система уже установлена, и на ней уже установлены программы, то прежде чем выполнять инструкции ниже скопируйте все папки из C:\Users\Public\* в C:\Users\ВашПрофиль\*

    Вариант 1.

    1) Запустите редактор реестра ( Win   + R → regedit → OK)
    2) Откройте раздел реестра:

    3) Затем нажмите правой кнопкой мыши на правой панели и выберите Создать → Параметр "DWORD".
    4) Дайте этому параметру имя NoSharedDocuments и присвойте ему значение 1
    5) Перезагрузите компьютер

    Вариант 2.

    1) Запустите редактор реестра ( Win   + R → regedit → OK)
    2) Откройте раздел реестра:

    3) Удалите следующий раздел:

    4) Пройдите к разделу реестра:

    5) Удалите следующий раздел (если есть):

    Вариант 3.

    1) Откройте Панель управления\Все элементы панели управления\Система(или Пуск → Компьютер → Свойства)
    2) Откройте Дополнительные параметры системы
    3) Пройдите на вкладку Имя Компьютера и нажмите Идентификация...
    4) Выберите пункт Компьютер предназначен для домашнего использования.
    5) Нажмите Далее, затем Готово, затем ОК
    6) Перезагрузите компьютер

    После того, как воспользуйтесь решением одного из вариантов проделайте следующие действия:

    1) В разделе реестра:

    замените значения с C:\Users\Public\ на C:\Users\ВашПрофиль\

    2) В разделе реестра:

    замените значения с %PUBLIC%\ на %USERPROFILE%\

    3) Удалите папки (если они остались):

    Диск С: → Пользователи → Общие (C:\Users\Public\)
    Библиотеки → Документы → Общие Документы

    Внимание: Если не хотите, чтобы у Вас на рабочем столе появились дублирующиеся иконки файлов, не устанавливайте значение параметра Common Desktop, идентичное рабочему столу Вашего профиля. Например, вместо C:\Users\ВашПрофиль\Desktop укажите C:\Users\ВашПрофиль\Public\Desktop, а вместо %USERPROFILE%\Desktop укажите %USERPROFILE%\Public\Desktop.

    9. Отключение и включение контекстного меню в Проводнике, на рабочем столе и на панели задач.

    Для отключения контекстного меню для иконок на панели задач, создайте и примените reg-файл указанного ниже содержания:

    Для включения контекстного меню для иконок на панели задач, создайте и примените reg-файл указанного ниже содержания:

    Для отключения контекстного меню в Проводнике и на рабочем столе, создайте и примените reg-файл указанного ниже содержания:

    Для включения контекстного меню в Проводнике и на рабочем столе, создайте и примените reg-файл указанного ниже содержания:

    10. Удаление пункта меню Файл из Проводника.

    1) Запустите редактор реестра (Win   + R → regedit → OK).
    2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в NoFileMenu
    5) Измените значение на 1.
    6) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    Данный пункт будет также удален из всех мест, использующих оболочку Windows

    11. Запрещение запуска программ.

    1) Запустите редактор реестра (Win   + R → regedit → OK).
    2) Откройте раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD
    4) Переименуйте его в RestrictRun
    5) Измените значение на 1.
    6) Перезагрузите компьютер.
    7) Создайте подраздел с аналогичным именем RestrictRun
    8) Создайте в разделе (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun) список разрешенных к запуску программ для текущего пользователя.
    8.1) Создайте строковые(String) параметры
    8.2) Укажите названия для создаваемый строковых параметров, начиная с 1 и далее
    8.3) Установите в значениях параметров пути к Вашим приложениям и их имена. Файлы должны указываться с расширением. Например:

    1 REG_SZ regedit.exe
    2 REG_SZ calc.exe
    3 REG_SZ Iexplore.exe

    Не забудьте указать файл regedit.exe, чтобы Вы могли зайти в него и отменить установленные Вами ограничения!
    Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0 или удалить его.

    Если Вы забыли указать regedit.exe в списке или не создали подраздел RestrictRun, чтобы запретить запуск всех программ. Для отмены запрета проделайте следующее:

    1) Перезапустите компьютер.
    2) До начала запуска Windows нажмите на клавишуF8 и выберите пункт Безопасный режим с поддержкой командной строки
    3) В командной строке введите regedit и нажмите Enter ↵.
    4) Откройте раздел реестра HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    5) Удалите ключ RestrictRun или установите его значение на 0.

    12. Удаление записей из истории диалогового окна "Выполнить".

    Если Вы используете диалоговое окно "Выполнить" в меню "Пуск" (Win   + R), то для удаления записей из его истории проделайте следующее.

    1) Запустите редактор реестра: Win   + R → regedit
    2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

    Команды, введенные вами ранее, хранятся в виде значений параметров a,b,c,d и так далее используя буквы английского алфавита.

    3) Для удаления записи - удалите параметр с ненужной командой, и она пропадет из истории диалога "Выполнить".

    13. Удаление и восстановление предупреждающего окна о внесении изменений в msconfig (Конфигурация системы).

    При внесении изменений в утилиту msconfig (Конфигурация системы), появляется окно Настройка системы, в котором Вам предлагается на выбор: либо перезагрузить компьютер, либо выйти без перезагрузки.

    Чтобы отключить данное предупреждение установите флажок Больше не показывать это предупреждение, и окно больше появляться не будет.

    Для восстановления данного окна:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKCU\Software\Microsoft\Shared Tools\MsConfig
    3) Удалите параметр NoRebootUI.

    14. Удаление лишних записей из утилиты msconfig (Конфигурация системы).

    Если в окне утилиты msconfig (Конфигурация системы) скопилось много записей и Вы хотели бы удалить ненужные. То сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKLM\SOFTWARE\Microsoft\Shared Tools\MSConfig
    3) Просмотрите все подразделы данном разделе реестра и удалите ненужные Вам записи.
    4) Также записи могут хранит© в файле mscfgtlc.xml, находящимся в папке C:\Windows\system32\. В 64-битных Windows данный файл также находится в папке C:\Windows\SysWOW64\.
    5) Откройте данный файл Блокнотом, удалите ненужные записи и сохраните. Если Вы хотите удалить все лишние записи, то просто удалите файл mscfgtlc.xml.

    15. Отключение напоминания о необходимости перезагрузки после установки обновлений.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU.
    3) Создайте параметр NoAutoRebootWithLoggedOnUsers типа DWORD и присвойте ему значение 1.

    или

    откройте диалоговое меню Выполнить (Win   + R) и введите команду:

    Для вступления изменений в силу перезайдите в систему или перезагрузите компьютер.

    16. Запуск нескольких копий редактора реестра одновременно.

    Пользователи, которые работают с редактором реестра Windows наверняка сталкивались с ситуацией, когда необходимо сверить содержимое веток реестра. Весьма удобно было бы открыть два редактора реестра, разместить их рядом и сравнить. Однако при повторной попытке запуска программы, система переключает Вас на открытое окно программы. Запуск с удерживанием клавиши Shift тоже не работает.

    Для запуска второй копии редактора реестра:

    1) Откройте диалоговое меню "Выполнить" (Win   + R)
    2) Введите команду regedit, используя параметр -m и нажмите Enter ↵.

    17. Дополнительные параметры для настройки функций "Защита системы" и "Восстановление системы".

    В Windows 7 для функций "Защита системы" и "Восстановление системы" существуют дополнительные настройки, которые скрыты от обычных пользователей. Чтобы их изменить Вам необходимо создать соответствующий настройке параметр в реестре.

    1) Откройте диалоговое меню "Выполнить" (Win   + R)
    2) Введите команду regedit и нажмите Enter ↵.
    3) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\Cfg
    4) Создайте параметр типа DWORD с именем из списка указанного ниже
    5) Щелкните правой кнопкой мыши на созданном параметре и выберите пункт Изменить.
    6) Установите переключатель в положение Десятичная и введите необходимое Вам значение.

    DiskPersent - указывает, какой объем дискового пространства в процентах будет использовать система для точек восстановления.

    CompressionBurst - указывает время сжатия данных в секундах при простое системы. При простое системы в течение времени, указанного в данном параметре System Restore будет упаковывать данные, после чего прекратит свою работу до следующего периода простоя системы.

    DSMin - указывает минимальное количество свободного дискового пространства, которое требуется System Restore. В случае уменьшения свободного дискового пространства до указанного размера точки восстановления системы перестанут создаваться.

    1 день(сутки) равен 86400 секунд, 1 час равен 3600 секунд, 1 минута равна 60 секунд.

    RPGlobalInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой контрольной точки.

    RPLifeInterval - указывает время в секундах, в течение которого будут хранит© точки восстановления перед удалением их с компьютера.

    RPSessionlnterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой системной контрольной точки при включенном компьютере. Значением по умолчанию является ноль, что означает, что эта функция выключена. Вы можете установить свое значение (например, интервал в один час), чтобы программа создавала контрольные точки автоматически через заданный интервал.

    ThawInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед тем, как возобновить свою работу после того, как появилось достаточное количество дискового пространства.

    18. Запрещение запуска командной строки и обработки пакетных файлов (bat, cmd).

    Если Вам необходимо запретить запуск командной строки и выполнение пакетных файлов, то выполните следующие действия:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows
    3) Создайте раздел System
    4) В разделе HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System создайте DWORD-параметр DisableCMD
    Установите значение данного параметра в зависимости от требуемых ограничений:

    2 - Запрещает пользователям запускать окно командной строки Cmd.exe, но не запрещает обработку сценариев в командной строке.
    1 - Запрещает пользователям запускать окно командной строки Cmd.exe, также запрещает обработку сценариев в командной строке.
    0 - Разрешает пользователям запускать окно командной строки Cmd.exe, также разрешает обработку сценариев в командной строке.

    Вы также можете настроить данные параметры в редакторе локальной групповой политики:

    1) В строке поиска меню Пуск или в окне Выполнить (Win   + R) введите gpedit.msc и нажмите Enter ↵.
    2) Перейдите в Конфигурация пользователя\Административные шаблоны\Система
    3) Щелкните дважды на параметре Запретить использование командной строки или щелкните правой кнопкой мыши на нем и выберите Изменить
    4) Установите переключатель в значение Включить, чтобы запретить использование командной строки.
    5) В ниспадающем списке выберите значение Да для запрета обработки сценариев в командной строке.
    Для отмены внесенных изменений установите переключатель в значение Не задано.

    19. Удаление сведений об использованном USB-флэш диске.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра:

    Здесь Вы увидите список разделов, обозначающих подключаемые когда-либо флеш-диски к Вашей системе.
    3) Найдите раздел соответствующий, флеш диску, упоминание о котором Вы хотите удалить из реестра. (Например: Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100)

    4) Откройте данный раздел.
    Путь к данному разделу, в моем примере:

    5) В данном разделе Вы увидите подраздел (Например: AB00000000005136&0)
    Путь к данному подразделу, в моем примере:

    6) Откройте раздел реестра:

    7) Отрывая поочередно каждый из подразделов данного раздела, найдите подраздел содержащий в названии AB00000000005136
    Путь к данному разделу, в моем примере:

    8) Удалите найденные в результате анализа разделы реестра. В моем примере, необходимо удалить следующие разделы:

    9) Перезагрузите компьютер.

    20. Удаление программ в Безопасном Режиме, использующих установщик Windows Installer.

    В большинстве случаев при попытке удаления программы в Безопасном Режиме, если программа не использует собственный инсталлятор (Например: Winamp) Вы получите предупреждающее сообщение:

    Для включения возможности удаления программ в Безопасном Режиме сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal
    3) Создайте здесь раздел MSIService
    4) Присвойте строковому параметру По умолчанию значение Service.
    5) Перезагрузите компьютер.

    21. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

    Как известно, при выделении более 15 файлов команды контекстного меню, такие как "Открыть/Печать/Редактировать" становятся недоступны.
    Для отмены данного ограничения проделайте следующее:

    1) Запустите редактор реестра ( Win   + R → regedit → OK)
    2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
    3) Создайте в нем параметр MultipleInvokePromptMinimum типа DWORD.
    4) Установите значение данного параметра равным 16.

    Для уменьшения количества файлов на которых действует ограничение применения команд, введите значение от 1 до 15.
    При выделении файлов выше выбранного Вами значения команды в контекстном меню примҐться не будут. При указании значения 0 произойдет полное отключение команд, включая команду "Открыть".

    22. Отключение отображения последних открывавшихся документов в меню Пуск.

    1) Запустите редактор реестра (Win   + R → regedit → OK).
    2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте новый параметр NoRecentDocsHistory типа DWORD.
    4) Щелкните правой кнопкой мыши по параметру NoRecentDocsHistory и выберите пункт Изменить
    5) Введите значение 1 и нажмите ОК.
    6) Закройте редактор реестра и перезапустите компьютер.

    Также эти настройки можно установить используя Редактор локальной групповой политики:

    1) Нажмите кнопку Пуск, в строке поиска введите команду gpedit.msc и нажмите клавишу Enter ↵.
    2) Откройте Конфигурация пользователя → Административные шаблоны → Меню «Пуск» и панель задач
    3) Дважды щекните на пункте Не хранить сведения о недавно открывавшихся документах.
    4) Установите переключатель в значение Включить и нажмите кнопку ОК.

    23. Запрещение добавления программ в разделы реестра отвечающие за автозагрузку.

    Если Вы не хотите, чтобы неизвестная программа без предупреждения добавлялась в какой-либо из разделов реестра отвечающих за автозапуск, то после установки всех программ которые Вы желаете добавить в автозагрузку - Вы можете заблокировать доступ к соответствующим разделам реестра.

    Для этого, выполните поочередно для каждого из указанных ниже разделов, решение предложенное в совете 4. Запрещение создания и изменения значения параметров в указанном разделе реестра. из раздела Твики Реестра - Администрирование и Безопасность.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

    Данное решение, может быть неплохим дополнением к мерам по увеличению безопасности системы. Оно позволит Вам не допустить самостоятельного прописывания вирусов, троянов, блокировщиков системы и различных нежелательных программ в автозагрузку.
    Если же у Вас возникнет необходимость добавить какую-либо программу в автозагрузку, то Вы можете либо поместить ее в папку «Автозагрузка» в меню Пуск, либо на время установки программы выставить разрешение «Полный доступ», а затем вернуть разрешения указанные выше.

    Также Вы можете воспользоваться готовыми пакетными bat-файлами, позволяющими заблокировать и разблокировать данные разделы реестра.

    1) Скачайте архив AutorunBlockUnblock.zip, распакуйте в любую папку.
    2) Щелкните правой кнопкой мыши на необходимом файле и выберите пункт Запуск от имени администратора.

    3.1) Для блокировки разделов реестра от внесения изменений:
    Запустите файл autorun_registry_block_rus.bat, если у Вас установлена русская Windows 7.
    Запустите файл autorun_registry_block_eng.bat, если у Вас установлена английская Windows 7 + русский MUI.

    3.2) Для разблокировки разделов реестра от внесения изменений:
    Запустите файл autorun_registry_unblock_rus.bat, если у Вас установлена русская Windows 7.
    Запустите файл autorun_registry_unblock_eng.bat, если у Вас установлена английская Windows 7 + русский MUI.

    24. Открытие окна команд с правами администратора из контекстного меню Проводника.

    Чтобы запустить окно командной строки из контекстного меню Проводника, Вам необходимо удерживая нажатой клавишу ⇑ Shift нажать правой кнопкой мыши на папку и выбрать пункт Открыть окно команд.
    Если же у Вас включен контроль учетных записей (UAC), то при выборе данного пункта откроется обычное окно командной строки.
    Вы можете добавить в контекстное меню пункт, позволяющий открыть из текущей папки окно команд с правами администратора.
    Для добавления указанного выше пункта, воспользуйтесь одним из предложенных ниже вариантов.

    Вариант 1. Если у Вас в контекстном меню нет пункта "Стать владельцем и задать полный доступ к объекту".

    Создайте и примените reg-файл следующего содержания:

    Вариант 2. Если у Вас в контекстном меню есть пункт "Стать владельцем и задать полный доступ к объекту".

    1) Откройте папку C:\Windows\System32
    2) Скопируйте файл cmd.exe в папку C:\Windows
    3) Щелкните правой кнопкой мыши на файле cmd.exe скопированном в папку C:\Windows и выберите пункт Свойства.
    4) Перейдите на вкладку Совместимость
    5) Установите флажок Выполнять эту программу от имени администратора и нажмите кнопку ОК.
    6) Создайте и примените reg-файл следующего содержания:

    Вы можете скачать архив с готовыми reg-файлами по ссылке: ElevatedCMDInContextMenu.zip

    Add_Elevated_CMD_In_Context_Menu.reg - используйте для добавления пункта "Открыть окно команд с правами администратора", при наличии пункта "Стать владельцем и задать полный доступ к объекту".
    Add_Elevated_CMD_In_Context_Menu2.reg - используйте для добавления пункта "Открыть окно команд с правами администратора", при отсутствии пункта "Стать владельцем и задать полный доступ к объекту".

    Remove_Elevated_CMD_In_Context_Menu.reg - используйте для удаления пункта "Открыть окно команд с правами администратора", при наличии пункта "Стать владельцем и задать полный доступ к объекту".
    Remove_Elevated_CMD_In_Context_Menu2.reg - используйте для удаления пункта "Открыть окно команд с правами администратора", при отсутствии пункта "Стать владельцем и задать полный доступ к объекту".

    25. Сохранение и восстановление содержимого раздела реестра, а также его владельца и разрешений.

    Если Вы желаете сохранить содержимое раздела реестра, а также владельца и заданные разрешения, чтобы в последствии их восстановить, то Вы можете воспользоваться одним из предложенных ниже решений:

    Вариант 1. Создание файла куста реестра.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)

    Чтобы сохранить содержимое, заданные разрешения и владельца для раздела:

    2) Перейдите в раздел реестра для которого Вы желаете осуществить указанные выше действия.
    3) Щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Экспортировать.
    4) Задайте имя для файла, в который будут сохранена информация для указанного Вами раздела. (Например: my_regkey_backup.hiv)
    5) В ниспадающем меню Тип файла выберите Файлы кустов реестра и нажмите кнопку Сохранить.

    Чтобы восстановить содержимое, заданные разрешения и владельца для раздела:

    6) Перейдите в раздел реестра для которого Вы желаете восстановить указанное выше.
    7) В главном меню Файл нажмите пункт Импорт.
    8) В ниспадающем меню выберите Файлы кустов реестра
    9) Выберите файл, в который Вы сохранили информацию для указанного Вами раздела и нажмите кнопку Открыть.
    10) Нажмите кнопку Да.
    Внимание: Данное действие полностью удалит все содержимое для указанного Вами реестра. Взамен этого, поверх будут записаны значения из выбранного файла.
    11) Нажмите кнопку ОК.

    Вариант 2. Создание резервной копии реестра (точки восстановления).

    Указанные ниже программы позволяют создать резервную копию (наподобие точки восстановления) для выбранных разделов реестра или для реестра целиком.

    Registry Workshop.

    1) Скачайте архив с программой: Registry Workshop и распакуйте его в любую папку.
    2) Запустите программу и в главном меню Файл выберите пункт Резервирование и восстановление.
    3.1) Для сохранения владельца и разрешений для раздела нажмите кнопку Резервировать.
    3.2) Для восстановления владельца и разрешений для раздела нажмите кнопку Восстановить.
    4) Укажите какие разделы реестра необходимо сохранить/восстановить и нажмите кнопку ОК(Да).

    Mz Registry Backup

    1) Скачайте и установите программу Mz Registry Backup: английская версия или русская версия
    2) Запустите программу и на вкладке Backup Registry (Резервирование реестра) установите переключатель в необходимое значение:

    2.1) Create complete registry backup (Резервная копия всего реестра) - для сохранения резервной копии всего реестра
    2.2) Create custom registry backup (Резервная копия выбранных разделов реестра) - для сохранения резервной копии выбранных разделов реестра

    3) При выборе второго значения переключателя укажите для каких разделов необходимо создать резервную копию.
    4) Введите в поле Description (Описание) - описание для создаваемой резервной копии.
    5) Нажмите кнопку Create Backup Now (Создать резервную копию) для запуска, а по-завершении нажмите кнопку ОК.

    Для восстановления реестра из резервной копии:

    6) Перейдите на вкладку Restore Registry (Восстановление реестра).
    7) Выберите резервную копию и нажмите кнопку Restore Registry Now (Восстановить реестр).
    8) По-завершении нажмите кнопку ОК.

    Внимание: Для восстановления содержимого реестра произойдет перезагрузка компьютера.

    Для большего контроля за изменением содержимого раздела реестра, а также его владельца и разрешений - создавайте больше резервных копий.
    Так как для каждой копии указывается дата и время создания, то Вы можете использовать их как точки восстановления реестра.

    26. Добавление пунктов "Запуск от имени администратора" и "Извлечь все" в контекстное меню MSI файлов.

    Чтобы добавить пункт Запуск от имени администратора в контекстное меню MSI файлов, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Запуск от имени администратора из контекстного меню MSI файлов, создайте и примените reg-файл указанного ниже содержания.

    Чтобы добавить пункт Извлечь все в контекстное меню MSI файлов, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Извлечь все из контекстного меню MSI файлов, создайте и примените reg-файл указанного ниже содержания.

    27. Запрещение отображения окна "Программы и компоненты" и его элементов.

    Для отключения отображения содержимого всех элементов окна Программы и компоненты, создайте и примените reg-файл указанного ниже содержания:

    Для отключения возможности запуска Компоненты Windows, создайте и примените reg-файл указанного ниже содержания:

    Для отключения отображения содержимого списка Установленные программы, создайте и примените reg-файл указанного ниже содержания:

    Для отключения отображения содержимого списка Установленные обновления, создайте и примените reg-файл указанного ниже содержания:

    Для восстановления всех функций окна Программы и компоненты, создайте и примените reg-файл указанного ниже содержания:

    28. Отключение или включение отображения истории запросов в строке поиска Проводника.

    Для отключения отображения истории запросов в строке поиска Проводника, создайте и примените reg-файл указанного ниже содержания:

    Для восстановления отображения истории запросов в строке поиска Проводника, создайте и примените reg-файл указанного ниже содержания:

    Перезагрузите компьютер для принятия изменений.

    29. Удаление и восстановление пунктов меню из диалогового окна Безопасность Windows (Ctrl+Alt+Del).

    Чтобы удалить или восстановить пункты из списка диалогового окна вызываемого нажатием комбинации клавиш Ctrl + Alt + Delete, известного как Безопасность Windows, воспользуйтесь предложенными ниже решениями.

    Для удаления пункта Блокировать компьютер из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

    Для удаления пункта Сменить пароль из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

    Для удаления пункта Сменить пользователя из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

    Для удаления пункта Выйти из системы из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

    Для удаления пункта Запустить диспетчер задач из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

    Для удаления кнопки управления питанием из диалогового окна Безопасность Windows (данные пункты также удалятся из меню Пуск), создайте и примените reg-файл указанного ниже содержания.

    Для удаления кнопки управления питанием на экране переключения пользователей из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

    Для восстановления указанных пунктов из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания:

    30. Добавление в Панель управления оснастки "Учетная запись опытного пользователя" (netplwiz), для расширенного управления учетными записями.

    Чтобы добавить в Панель управления оснастку Учетная запись опытного пользователя (netplwiz), для расширенного управления учетными записями, создайте и примените указанный ниже reg-файл.

    Чтобы удалить из Панели управления оснастку Учетные записи пользователей (netplwiz), для расширенного управления учетными записями, создайте и примените указанный ниже reg-файл.

    31. Настройка параметров, отвечающих за информацию, отображаемую в оснастке Программы и компоненты, а также за удаление установленных программ.

    Каждая установленная программа записывает в реестр необходимую о себе информацию, которая используется элементом Панели управления - Программы и компоненты.

    Сведения, отображаемые для программ на странице Установленные программы, а также параметры задающие настройки их удаления, восстановления или изменения хранятся в разделах веток реестра:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall - в 32-битных и в 64-битных версиях Windows.
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall - только в 64-битных версиях Windows.

    Ниже указаны наиболее используемые из них.

    AuthorizedCDFPrefix - данный строковый параметр указывает ссылку на канал обновлений для приложения.
    Comments - данный строковый параметр указывает текст примечанияк программе.
    Contact - данный строковый параметр указывает контактную информацию для свзи с автором программы.
    DisplayIcon - данный строковый параметр указывает иконку.
    DisplayName — данный строковый параметр указывает название программы.
    DisplayVersion — данный строковый параметр указывает номер версии программы.
    HelpLink - данный строковый параметр указывает ссылку на страницу справки программы. Часто в нем просто указывают ссылку на главную страницу сайта программы.
    HelpTelephone - данный строковый параметр указывает телефон технической службы поддержки программы.
    InstallDate — данный строковый параметр указывает дату, когда была установлена программа. (Например, 20120827).
    InstallLocation — данный строковый параметр указывает путь к папке, в которую была установлена программа.
    InstallSource - данный строковый параметр указывает путь к папке откуда была установлена программа.
    ModifyPath - данный строковый параметр указывает команду, которая будет выполнена при попытке изменения программы.
    ProductID - данный строковый параметр указывает значение кода продукта для программы.
    Publisher — данный строковый параметр указывает издателя (имя автора или название компании) программы.
    Readme - данный строковый параметр указывает путь к файлу Readme. Обычно им является файл Readme.txt.
    RegCompany - данный строковый параметр указывает сведения о зарегистрированной компании программы.
    RegOwner - данный строковый параметр указывает сведения о зарегистрированном владельце программы.
    UninstallString - данный строковый параметр указывает команду, которая будет выполнена при попытке удаления программы.
    URLInfoAbout - данный строковый параметр указывает ссылку на страницу, содержащую информацию о программе. Часто в нем просто указывают ссылку на главную страницу сайта программы.
    URLUpdateInfo - данный строковый параметр указывает ссылку на страницу, где можно скачать обновления к программе. Часто в нем просто указывают ссылку на главную страницу сайта программы.

    EstimatedSize - данный Dword-параметр указывает размер программы в килобайтах.
    Language - данный Dword-параметр указывает язык используемый приложением по умолчанию. Английский - 0x00000409(1033), русский - 0x00000419(1049).
    NoModify - данный Dword-параметр задает возможность изменения программы. Значение параметра равное 1 запрещает изменять установленную программу, значение 0 разрешает.
    NoRemove - данный Dword-параметр задает возможность удаления программы. Значение параметра равное 1 запрещает удалять установленную программу, значение 0 разрешает.
    NoRepair - данный Dword-параметр задает возможность восстановления программы. Значение параметра равное 1 запрещает восстанавливать установленную программу, значение 0 разрешает.
    SystemComponent - данный Dword-параметр указывает является ли программа системной (скрытой). Значение параметра равное 1 запрещает отображение программы в списке Программы и компоненты.
    WindowsInstaller - данный Dword-параметр указывает установленно ли приложение с использованием установщика Windows. Если да, то значение параметра равно 1.
    VersionMajor - данный Dword-параметр указывает основной номер версии программы. Соответствует числу до первой точки в параметре DisplayVersion.
    VersionMinor - данный Dword-параметр указывает дополнительный номер версии программы. Соответствует числу после первой точки в параметре DisplayVersion.

    32. Отключение запоминания последнего пользователя и включение запроса имени пользователя и пароля на экране пользователей.

    По умолчанию в системе на экране пользователей отображаются имена пользователей.
    Данный факт может облегчить доступ в Вашу систему нежелательных пользователей, которым надо будет набрать лишь пароль, чтобы войти.
    Вы можете усилить безопасность собственного компьютера, включив использование классического окна для входа в систему.
    При включении данного параметра, на экране пользователей для входа в систему, будет запрашиваться не только пароль, но и ¤ пользователя.

    Чтобы включить использование классического окна для входа в систему, требующего введения имени пользователя и пароля, создайте и примените указанный ниже reg-файл.

    Чтобы отключить использование классического окна для входа в систему, требующего введения имени пользователя и пароля, создайте и примените указанный ниже reg-файл.

    Примечание:

    Если у Вас не задан пароль, то оставьте отведенное для него поле пустым.
    Для входа пользователей, присоединенных к домену введите в поле Пользователь - Имя домена (Имя компьютера)/Имя пользователя.

    33. Удаление или добавление из контекстного меню исполняемых файлов пункта Запуск от имени другого пользователя.

    При удерживании клавиши ⇑ Shift и нажатии правой кнопкой мыши на исполняемом файле (exe, bat, cmd, msc или msi) в контекстном меню появляется пункт Запуск от имени другого пользователя.

    Чтобы удалить из контекстного меню исполняемых файлов пункт "Запуск от имени другого пользователя", создайте и примените указанный ниже reg-файл.

    Чтобы восстановить в контекстном меню исполняемых файлов пункт "Запуск от имени другого пользователя", создайте и примените указанный ниже reg-файл.

    34. Включения требования ввода пароля администратора для отключения контроля учетных записей при необходимости запуска программы с повышенными правами.

    Если Вы используете Контроль Учетных Записей (UAC) для блокировки запуска программы с повышенными правами, то в качестве дополнительной меры безопасности, Вы можете включить функцию требования пароля администратора для отключения UAC.

    Чтобы включить требование ввода пароля для UAC при запуске программы, создайте и примените указанный ниже reg-файл:

    Чтобы отлючить требование ввода пароля для UAC при запуске программы, создайте и примените указанный ниже reg-файл:

    35. Отключение возможности записи на компакт-диск.

    Чтобы отключить возможность записи на компакт-диск в системе, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить возможность записи на компакт-диск, создайте и примените reg-файл указанного ниже содержания.

    36. Добавление собственной программы в список "Программы по умолчанию".

    Чтобы добавить собственную программу в список Программы по умолчанию, создайте и примените reg-файл, используя шаблон ниже:

    Пояснения к reg-файлу:

    1) Вместо myprogram.exe укажите имя exe-файла, запускающего программу.
    2) Вместо D:\\Programs\\MyProgram\\ укажите путь к exe-файлу программы.
    3) Вместо D:\\Programs\\MyProgram\\FileIcons\\Icon.ico укажите путь к иконке, для файлов сопоставляемых с данной программой.
    4) В остальных местах вместо MyProgram укажите имя программы.
    5) В значении параметра ApplicationDescription введите описание программы.
    6) В значении параметра ApplicationName введите имя программы.
    7) Вместо .ext введите расширение файла, которое должно быть сопоставлено с программой.
    8) Для добавления поддерживаемых расширений:

    8.1) Скопируйте указанные ниже строки яў каждого нового расширения.
    Сделав изменения в соответствии с описанными выше пунктами.

    8.2) Добавьте новое расширение ".ext"="MyProgram.ext" в ветку [HKEY_LOCAL_MACHINE\SOFTWARE\MyProgram\Capabilities\FileAssociations\]
    Сделав изменения в соответствии с описанными выше пунктами.

    Пример:

    Твики Реестра - Настройки и Интерфейс.

    1. Включение скрытых настроек электропитания.

    Чтобы настроить в Windows 7 параметры электропитания, необходимо открыть Панель управления\Система и безопасность\Электропитание. Там можно выбрать нужный план электропитания и при необходимости более детально настроить параметры, перейдя в Настройка плана электропитания → Изменить дополнительные параметры питания.
    Однако более детально настроить параметры электропитания помогает консольная утилита Powercfg. Но работать в командной строке, разбираясь с каждым параметром может занять продолжительное время. Для того чтобы функции предоставляемые powercfg стали доступны Вам в графической оболочке, необходимо внести некоторые изменения в ветке реестра:

    В данной ветке содержатся разделы, отвечающие за определенную группу настроек.
    Например, раздел 0012ee47-9041-4b5d-9b77-535fba8b1442 относится к настройкам управления питанием жесткого диска, а 54533251-82be-4824-96c1-47b60b740d00 к настройкам управления питанием процессора.
    В свою очередь, в каждом из данных разделов есть подразделы, отвечающие за какую-либо настройку электропитания. Описание каждой из настроек указано в значении параметра Description, а её отображение в графической оболочке в значении параметра Attributes. По умолчанию, многие настройки имеют значение параметра Attributes равное «1», для того, чтобы необходимая Вам настройка был виден в графической оболочке, необходимо заменить его на «0». Доступные для отображения настройки, на ноутбуке и стационарном компьютере могут отличаться, в связи с особенностью их систем электропитания.

    Для отображения политики простоя устройств, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке работы жесткого диска, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке кнопок питания, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке управления питания процессора, создайте и примените reg-файл следующего содержания:

    Импортированное значение реестра позволяет увидеть только малую часть параметров, доступных для настройки управлением процессора. Всего их более 30.

    Для отображения скрытых параметров по настройке спящего режима, создайте и примените reg-файл следующего содержания:

    Для отображения скрытых параметров по настройке экрана, создайте и примените reg-файл следующего содержания:

    Также к этому разделу относится настройка параметров графического адаптера, но доступность конкретных настроек будет определяется драйвером.

    У себя в системе я обнаружил 54 скрытых настройки электропитания. Для включения сразу всех скрытых настроек электропитания: экспортируйте всю ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings в reg-файл. Отредактируйте полученный reg-файл: оставьте в нем только наименование веток реестра и их параметры Attributes и присвойте им значения «0».
    Также Вы можете скачать и применить, готовый reg-файл PowerSettings.reg

    2. Добавление классического всплывающего меню Программы (Programs) в меню Пуск.

    Для быстрого доступа к элементам списка Все программы (All Programs), Вы можете добавить его как всплывающее меню взамен меню Избранное (Favorites) или меню Файлы для загрузки (Downloads)

    Вариант 1. Вместо меню Файлы для загрузки (Downloads).

    Если Вы для загрузки файлов из интернета используете собственную папку или сохраняете на Рабочий стол, а также в качестве интернет-браузера используете Internet Explorer, то Вам подойдет данный вариант.

    1) Включите меню Файлы для загрузки (Downloads)
    1.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
    1.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
    1.3) Прокрутите список до пункта Файлы для загрузки (Downloads)
    1.4) Установите переключатель в значение Отображать как меню (Display as a menu), затем нажмите OK.
    2) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter ↵.
    3) Откройте раздел реестра:

    4) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

    5) Откройте раздел реестра:

    6) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

    7) Закройте regedit, и перезагрузите Ваш компьютер.

    Вариант 2. Вместо меню Избранное (Favorites)

    Если Вы для загрузки файлов из интернета используете собственную папку или сохраняете на Рабочий стол, а также в качестве интернет-браузера используете Internet Explorer, то Вам подойдет данный вариант.

    1) Включите меню Файлы для загрузки (Downloads)
    1.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
    1.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
    1.3) Прокрутите список до пункта Файлы для загрузки (Downloads)
    1.4) Установите переключатель в значение Отображать как меню (Display as a menu), затем нажмите OK.
    2) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter ↵.
    3) Откройте раздел реестра:

    4) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

    5) Откройте раздел реестра:

    6) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

    7) Закройте regedit, и перезагрузите Ваш компьютер.

    Теперь, когда Вы нажмете Пуск, в правой его части Вы увидите меню Программы (Programs), наподобие меню в предыдущих версиях Windows.

    Для исключения дублирования, Вы также можете убрать стандартный пункт меню Все программы (All Programs) из меню Пуск.
    Для этого создайте и примените reg-файл следующего содержания:

    Для возвращения стандартного пункта меню Все программы (All Programs) из меню Пуск.
    Для этого создайте и примените reg-файл следующего содержания:

    3. Добавление функции произвольного выравнивания иконок в Проводнике.

    В Windows 7 возможность отключения автоматического выравнивания иконок в Проводнике недоступна. В контекстном меню "Вид" в Проводнике, пункт "Упорядочить значки автоматически" отсутствует, соответственно Вы не можете располагать значки произвольным образом.
    Предложенные ниже варианты включают возможность произвольного выравнивания иконок в Проводнике и добавляют в контекстное меню "Вид" в Проводнике пункты "Выравнивать автоматически" и "Выровнять по сетке".

    Вариант 1.

    1) Скачайте программу Folder Options X.
    С официального сайта: английская версия
    С зеркала: русская версия
    2) Закройте все окна Проводника.
    3) Откройте в меню Пуск папку T800 Productions\Folder Options X и запустите программу.
    3) Снимите все флажки и нажмите кнопку Apply.
    4) Установите флажок Включить произвольное выравнивания иконок в папке и нажмите кнопку OK.
    Установка данного флажка добавляет в контекстное меню Вид: пункты Выровнять автоматически и Выровнять по сетке. Для произвольного выравнивания иконок, флажки рядом с ними должны быть сняты.

    5) Перезайдите в систему или перезагрузите компьютер.

    Вариант 2.

    В виду сложившейся необходимости, для работы данного твика режимы "Плитка" и "Содержимое" были объединены в режим "Расширенная плитка". Чтобы воспользоваться твиком Вы можете скачать и применить готовое решение: DisableAutoArrange.zip

    disableautoarrange.reg - reg-файл вносящий изменения в контекстное меню Проводника
    undo.reg - reg-файл возвращающий все настройки Проводника "по умолчанию".

    Также Вы можете создать данные reg-файлы самостоятельно.

    Для внесения изменений создайте и примените reg-файл следующего содержания:

    Для отмены изменений создайте и примените reg-файл следующего содержания:

    4. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

    Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
    Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

    1) Запустите командную строку от имени администратора. (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
    2) Введите команду

    (команда чувствительна к регистру)
    3) Запустите редактор реестра (Win   + R → regedit → ОК)
    4) Откройте раздел реестра:

    и кликните два раза по значению Path
    5) Измените

    на

    6) Закройте редактор реестра и наслаждайтесь Windows Media Player х64

    Готовые bat-файлы Вы можете скачать по ссылке: WindowsMediaPlayerx64.zip

    5. Настройка диалога переключения между окнами ("Alt"+"Tab").

    1) Запустите Редактор Реестра (Win   + R → Regedit → ОК)
    2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если он отсутствует, то создайте его (щелкните на папке Explorer правой кнопкой мыши, выберите Создать → Раздел и назовите его AltTab).
    В данном разделе создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

    Для создания твика, воспользуйтесь инструкцией:

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Параметры, отвечающие за количество отображаемых столбцов и строк

    Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
    Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за отступы в диалоге переключения между окнами

    Упомянутые ниже параметры указываются в пикселях.

    TopMarginPx - величина верхнего поля, добавляемого в диалог
    SideMarginPx - величина бокового поля, добавляемого в диалог
    BottomMarginPx - величина нижнего поля, добавляемого в диалог
    MinWidthPx - минимальная возможная ширина диалога AltTab
    ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
    ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за значки эскизов окон

    Упомянутые ниже параметры указываются в пикселях.

    OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
    OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
    OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

    Упомянутые ниже параметры указываются в пикселях.
    MaxThumbSizePx - максимальный размер эскизов окон
    MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
    TextButtomPx - высота заголовка диалога переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

    FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
    FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
    FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

    StartAlpha - начальная прозрачность диалога переключения между окнами
    FinalAlpha - конечная прозрачность диалога переключения между окнами

    Пример твика реестра с использованием этих параметров:

    Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt + Tab ↹, создайте DWORD-параметр AltTabSettings в разделе реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1.

    6. Настройка диалогового окна "Выбор программы".

    Когда Вы щелкаете на файле с незарегистрированным в системе расширением, то появляется окно “Выбор программы”, в котором вам предлагается выбрать из предложенного списка программу, способную обработать неизвестный тип файла.
    В данном окне по умолчанию установлен флажок “Использовать выбранную программу для всех файлов такого типа”. Чтобы убрать флажок и заблокировать возможность его установки, Вам необходимо изменить запись в реестре.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел HKEY_CLASSES_ROOT\Unknown\shell\opendlg\command
    3) Измените значение параметра По умолчанию (Default)

    Список программ, которые выводятся в диалоговом окне выбора программы, формируется при помощи списка подразделов раздела HKEY_CLASSES_ROOT\Applications.
    В данном разделе вы можете видеть, что имена подразделов соответствуют именам программ, установленных на вашем компьютере. Если вы хотите, чтобы какая-то из этих программ никогда не выводилась в диалоговом окне выбора программы, то в подразделе этой программы создайте строковый параметр NoOpenWith без какого-либо значения.

    7. Включение окна выбора начальных параметров при запуске проигрывателя Windows Media.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Удалите полностью следующую ветку реестра со всем содержимым:

    Вместо XXXXXX-XXXXXX-XXXXXX-XXXX у Вас будет собственное значение.
    Например: S-1-5-21-83440259-2036283413-1691820529-1000 или S-1-5-21-2717813001-1445373200-4062485642-500

    3) Перезайдите в систему или перезагрузите компьютер.

    8. Изменение действия по умолчанию при перетаскивании файлов между папками в Проводнике.

    При перетаскивании любого файла между двумя папками-окнами Проводника, в Windows 7 по умолчанию выполняется его перемещение. Вы можете самостоятельно настроить действие, которое будет выполняться при перетаскивании файла между папками: копирование; перемещение; создание ярлыка.

    Действие по умолчанию при перетаскивании конкретного типа файлов.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Перейдите в раздел HKEY_CLASSES_ROOT
    3) Найдите раздел интересующего Вас расширения. Для примера возьмем раздел .exe:
    4) Обратите внимание на значение параметра По умолчанию, которое служит идентификатором расширения.
    Для .exe файла данным значением будет exefile, следовательно все параметры необходимо создавать в разделе с идентичным именем.
    5) Откройте раздел реестра: HKEY_CLASSES_ROOT\exefile.
    6) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
    7) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
    8) В текстовом поле Значение: задайте необходимое Вам значение:

    1 - копирование;
    2 - перемещение;
    4 - создание ярлыка.

    Действие по умолчанию для всех файлов при перетаскивании.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_CLASSES_ROOT\*.
    3) Создайте новый параметр типа DWORD c именем DefaultDropEffect
    4) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
    5) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
    6) В текстовом поле Значение: задайте необходимое Вам значение:

    1 - копирование;
    2 - перемещение;
    4 - создание ярлыка.

    9. Удаление пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов.

    Для удаления пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов, создайте и примените reg-файл следующего содержания:

    Для восстановления пункта "Исправление неполадок совместимости" в контекстном меню ярлыков и исполняемых файлов, создайте и примените reg-файл следующего содержания:

    10. Удаление и восстановление стрелок на ярлыках Windows.

    Готовые файлы для убирания стрелок вы можете скачать по ссылке:
    Shortcut_Arrows.zip
    1) Распакуйте и откройте папку нужного вам варианта
    2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat или Remove_Shortcut_Arrow.reg
    3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat или Restore_Shortcut_Arrow.reg

    Вариант 1

    Для удаления стрелок с ярлыков:

    1) Запустите диалоговое окно "Выполнить" (Win   + R)
    2) Скопируйте код указанный ниже и нажмите OK

    Для восстановления стрелок на ярлыках:

    Или в ручную удалите данную ветку.

    Вариант 2

    Для удаления стрелок с ярлыков:

    1) Создайте пустой файл иконки назовите его Blank.ico
    2) Скопируйте его в папку C:\Windows
    3) Запустите диалоговое окно "Выполнить" (Win   + R)
    4) Скопируйте код указанный ниже и нажмите OK

    Для восстановления стрелок на ярлыках:

    1) Удалите файл Blank.ico из папки C:\Windows
    2) Запустите диалоговое окно "Выполнить" (Win   + R)
    3) Скопируйте код указанный ниже и нажмите OK

    Или в ручную удалите данную ветку.

    Побочным эффектом при использовании данного варианта является, появление черных квадратиков вместо стрелочек, если в папке Windows у Вас будет отсутствовать файл Blank.ico.

    Вариант 3

    1) Скопируйте текст в блокнот.
    2) Сохраните как Remove_Shortcut_Arrow.reg (для удаления) или Restore_Shortcut_Arrow.reg (для восстановления).
    3) Выполните файл, чтобы его содержание было внесено в реестр.
    4) Обратите внимание на знак минуса в команде "IsShortCut"=-. Вокруг него нет кавычек. Эта команда удаляет значение IsShortCut и сам ключ IsShortCut. Если вы введёте команду "IsShortCut"="-", то тогда ключ удалён не будет, а его значение поменяется на минус. "IsNotShortCut"="" создаёт ключ и присваивает ему нулевое значение.

    Файл .reg для удаления стрелок с ярлыков

    Файл .reg для восстановления стрелок на ярлыках

    Побочным эффектом при использовании данного варианта является, исчезновение пункта "Закрепить программу в панели задач". Если Вам необходимо будет закрепить какую-либо программу в Панели задач, то воспользуйтесь reg-файлом для восстановления стрелок на ярлыках, закрепите программу, а затем снова воспользуйтесь reg-файлом для удаления стрелок с ярлыков.

    11. Удаление папок из Рабочего стола в области переходов Проводника.

    Если Вы хотите, удалить папки из рабочего стола в области переходов Проводника, воспользуйтесь одним из предложенных ниже вариантов.
    Перед применением решения предложенного в любом из указанных ниже вариантов закройте Проводник.

    Вариант 1

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
    3) Сделайте себе экспорт указанного раздела, на случай восстановления (нажмите правой кнопкой мыши на разделе NameSpace → Экспортировать).
    4) Удалите необходимые Вам разделы:

    Favorites(Избранное) | {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки) | {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа) | {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Документы) | {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер) | {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть) | {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) | {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина) | {645FF040-5081-101B-9F08-00AA002F954E}

    Вариант 2

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder
    где вместо {GUID} вставьте необходимое Вам значение из указанной ниже таблицы.
    Например: HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder
    3) В левой части редактора реестра щелкните правой кнопкой мыши на раздел ShellFolder и выберите из меню пункт Разрешения.
    4) Выделите группу Администраторы, установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.
    5) Щелкните дважды на параметре Attributes и введите значение из таблицы, указанное в колонке Удаление, чтобы удалить желаемую папку.
    Для восстановления папки обратно, введите значение из таблицы, указанное в колонке По умолчанию.

    Наименование | {GUID} | Удаление | По умолчанию
Favorites(Избранное) | {323CA680-C24D-4099-B94D-446DD2D7249E} | a9400100 | a0900100
Libraries(Библиотеки) | {031E4825-7B94-4dc3-B131-E946B44C8DD5} | b090010d | b080010d
Homegroup(Домашняя группа) | {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} | b094010c | b084010c
Computer(Компьютер) | {20D04FE0-3AEA-1069-A2D8-08002B30309D} | b094010c | b084010c
Network(Сеть) | {F02C1A0D-BE21-4350-88B0-7367FC96EF3C} | b0940064 | b0040064
Recycle Bin(Корзина) | {645FF040-5081-101B-9F08-00AA002F954E} | 70 01 00 20 | 40 01 00 20
Папка пользователя (обычно идентична Вашему нику): | {59031a47-3f72-44a7-89c5-5595fe6b30ee} | f094012d | f084012d

    12. Отключение суффикса "-Ярлык" при создании новых ярлыков.

    1) Запустите редактор реестра (Win   + R → regedit → OK).
    2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
    3) В правой части окна, дважды щелкните на параметр реестра "link".
    4) Измените значение на 00 00 00 00.
    5) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    13. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

    1) Запустите редактор реестра (Win   + R → regedit → OK).
    2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) В правой части окна, дважды щелкните на параметр реестра "ShowInfoTip".
    4) Измените значение на 0.
    5) Перезагрузите компьютер.

    Вы можете также создать и применить reg-файл следующего содержания:

    14. Отключение диалога "Не удалось открыть файл".

    Если системе не знаком тип файла, который вы пытаетесь открыть, то сначала выводится диалоговое окно для поиска программы в интернете.

    Система предлагает Вам:

    Поиск соответствия в интернете. Если вы выберите этот вариант, то запускается веб-служба
    shell. windows. com/fileassoc/0409/xml/redir. asp? Ext=fb2 (пример для случая с FB2-файлом).
    Выбор программы из списка установленных программ. Открывает окно выбора программы для открытия файла на локальном компьютере.

    Для того чтобы не выводить окно для поиска файла в интернете, а сразу открывать окно выбора программы, воспользуйтесь одним из предложенных решений:

    1) Откройте редактор реестра (Win   + R → regedit)
    2) Перейдите в раздел реестра HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте DWORD-параметр NoInternetOpenWith и установите его значение равным 1.

    или

    1) Нажмите кнопку "Пуск", и в строке поиска напечатайте cmd.exe.
    2) Щелкните на найденной программе правой кнопкой мыши и нажмите Запуск от имени администратора
    3) В командой строке напечатайте следующее:

    15. Максимально возможное отключение сглаживания шрифтов (ClearType) в Windows 7.

    Если Вы хотите максимально возможно отключить использование ClearType в aero-темах Windows 7, то Вам необходимо сделать следующее.

    Вариант 1.

    1) Отключите ClearType в системе.
    1.1) Откройте Панель управления → Шрифты → Настройка текста ClearType
    1.2) Снимите флажок "Включить ClearType".
    2) Отключите сглаживание любого типа шрифта.
    2.1) Откройте Панель управления → Система → Дополнительные параметры системы
    2.2) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры
    2.3) На вкладке Визуальные эффекты в списке снимите флажок Сгладить неровности экранных шрифтов
    3) Измените шрифт элементов окна.
    3.1) Откройте Панель управления → Персонализация → Цвет окна →Дополнительные параметры оформления
    3.2) Установите для всех элементов вместо шрифта Segoe UI любой другой шрифт. Например: Tahoma; для всех элементов установите размер 8, для элементов "Заголовок активного окна" и "Заголовок неактивного окна", оставьте размер 9.
    4) Запустите редактор реестра (Win   + R → regedit → ОК)
    5) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
    6) Удалите присвоенные значения для указанных ниже параметров:

    Для изменения значения параметра щелкните на необходимом Вам параметре правой кнопкой мыши и нажмите Изменить.

    7) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
    8) Создайте строковый (String) параметр с именем Segoe UI
    9) Щелкните на нем правой кнопкой мыши и нажмите Изменить.
    10) Установите значение параметра Tahoma и нажмите ОК.
    11) Перезагрузите компьютер.

    Примечание:

    П.1) Если крупный шрифт покажется Вам с нечеткими краями установите снятый флажок Сгладить неровности экранных шрифтов обратно.
    П.2) Если шрифт в Проводнике и панели задач кажется расплывчатым, измените в ветке HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes значение параметра Segoe UI с Tahoma на MS Sans Serif
    П.3) При выборе шрифтов Tahoma или MS Sans Serif в калькуляторе пропадает изображение стрелки на клавише стереть последнюю цифру.
    П.4) Указанные действия применимы для 100% размера шрифта. Если у Вас стоит увеличение масштаба шрифта (чаще у широкоформатных мониторов), то проделайте следующее:
    П.4.1) Верните масштаб шрифта в 100% значение.
    П.4.2) Примените указанное в данном совете решение, включая перезагрузку.
    П.4.3) Установите необходимый Вам масштаб

    Вы можете скачать готовые reg-файлы, которые выполняют описанные выше действия: ClearType_on-off.zip
    Описание содержимого архива:

    ClearType-off.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен.
    ClearType_off+FS.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен.
    ClearType_off+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен, изменен шрифт на MS Sans Serif.
    ClearType_off+FS+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен, изменен шрифт на MS Sans Serif.
    ClearType-restore.reg - Восстановить исходные значения по умолчанию.

    Вариант 2. Ручная установка и удаление Windows Aero (Tahoma Font).

    Главным плюсом в отличие от предыдущего варианта является полное удаление привязки системы к шрифту Segoe UI и наличие изображения стрелки в калькуляторе.

    Установка Windows Aero (Tahoma Font).

    1) Скачайте и распакуйте в любую папку файл WindowsAero(TahomaFont).zip
    2) Откройте папку Manual и в соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
    3) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Patch.
    4) Переключите интерфейс Вашей системы на классическую тему.
    5) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles, для этого воспользуйтесь советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
    6) Переименуйте файл aero.msstyles в aero.msstyles.backup.
    7) Скопируйте модифицированный файл aero.msstyles из папки Manual в папку C:\Windows\Resources\Themes\Aero\.
    8) Примените reg-файл "NoSegoe - Tahoma.reg".
    9) Откройте Панель управления → Шрифты → Настройка текста ClearType и снимите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
    10) Перезагрузите компьютер.
    11) Переключите обратно на Aero-тему.

    Удаление Windows Aero (Tahoma Font).

    1) Переключите интерфейс Вашей системы на классическую тему.
    2) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles, для этого воспользуйтесь советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
    3) Удалите файл aero.msstyles
    4) Переименуйте файл aero.msstyles.backup обратно в aero.msstyles.
    5) Откройте папку Manual из папки, где распакован архив и примените reg-файл "NoSegoe - Restore Segoe UI.reg".
    6) В соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
    7) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Restore.
    8) Откройте Панель управления → Шрифты → Настройка текста ClearType и установите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
    9) Перезагрузите компьютер.
    10) Переключите обратно на Aero-тему.

    Вариант 3. Автоматическая установка Windows Aero (Tahoma Font).

    Установка Windows Aero (Tahoma Font).

    1) Скачайте и распакуйте в любую папку файл WindowsAero(TahomaFont).zip
    2) Откройте папку Auto.
    3) Нажмите правой кнопкой мыши на файле Windows Aero (Tahoma Font).exe и выберите пункт Запуск от имени администратора
    4) Нажмите клавишу Next в первом окне, во втором окне установите переключатель в значение I accept the agreement и нажмите кнопку Next.
    5) В окне Information также нажмите кнопку Next.
    6) В окне Select Components установите все флажки и нажмите кнопку Next.
    7) В окне Ready to Install нажмите кнопку Install и запустится установка.
    8) В окне Windows Aero (Tahoma Font) Setup информирующем о переключении интерфейса на классическую тему нажмите кнопку ОК.
    9) После того как программа переключится на классическую тему вернитесь обратно в программу.
    10) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
    11) Установите переключатель в значение Yes, restart the computer now и нажмите кнопку Finish.
    12) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

    Удаление Windows Aero (Tahoma Font).

    1) Откройте Панель управления → Программы и компоненты и щелкните на Windows Aero (Tahoma Font)
    2) В появившемся окне нажмите Да, а в следующем ОК.
    3) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
    4) В окне предлагающем перезапустить компьютер нажмите Да
    5) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

    Примечание:

    П. Если после установки или удаления программа не переключила обратно на Вашу aero-тему, то сделайте это вручную.

    16. Изменение набора кнопок на панели Проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели Проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора кнопок во всех папках Проводника добавьте или удалите кнопки во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для изменения отображаемых кнопок сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра необходимого Вам шаблона.
    Например: для добавления или удаления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    А для добавления или удаления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы изменяете набор кнопок в шаблонах Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать → Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Изменить.
    6) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения кнопок на панели. Значения отделяются друг от друга точкой с запятой (;).
    Например: Windows.Copy;Windows.Paste;Windows.Delete;

    Список возможных кнопок для добавления Вы можете узнать из названий подразделов в ветке реестра:

    В таблице ниже указаны значения наиболее часто используемых кнопок.

    Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей Проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected
Кнопка | Действие | Использование

    В качестве альтернативного варианта Вы можете воспользоваться утилитой Custom Explorer Toolbar.
    Данная программа позволяет Вам изменить отображаемые на панели Проводника кнопки всего лишь в несколько нажатий мыши. Работа в данной программе сводится к следующему:

    1) Выберите в ниспадающем меню Действие, что вы желаете сделать с кнопками Добавить/Удалить.
    2) Выберите в ниспадающем меню Режим панели, событие при котором данная кнопка должна появлятся на панели.
    Например, кнопки Копировать, Вырезать или Удалить уместнее добавить если выбран хотя бы один элемент, а кнопку "Вставить" имеет смысл отобразить, если ничего не выбрано.
    3) В разделе Типы папок установите флажки, в каких шаблонах должны появит© выбранные Вами кнопки.

    17. Изменение состава меню "Упорядочить" на панели Проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели Проводника почти везде присутствуют кнопка Упорядочить, при нажатии на которую появляется меню с определенным набором выполняемых команд и подменю Представление.

    Для изменения пунктов отображающихся в данном меню сделайте следующее:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра:

    Для внесения изменений в меню Упорядочить:

    Для внесения изменений в меню Представление:

    3) Задайте полные права на доступ к выбранному разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Щелкните правой кнопкой мыши на параметре SubCommands и выберите Изменить.
    5) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов списка. Значения отделяются друг от друга точкой с запятой (;) , символ | означает разделитель меню, после него также ставится точка с запятой.

    Список значений параметра SubCommands для меню Упорядочить по умолчанию:

    Список значений параметра SubCommands для подменю Упорядочить по умолчанию:

    Список пунктов возможных для добавления Вы можете узнать из названий подразделов в ветке реестра:

    В таблице ниже указаны значения наиболее часто используемых пунктов.

    Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей Проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected
Кнопка | Действие | Использование

    18. Изменение отображаемых по умолчанию свойств для файла в Проводнике.

    При выделении файла в Проводнике, система отображает в области сведений соответствующую ему информацию. Также сведения отображаются при наведении на него курсора мыши или на вкладке Подробно в окне Свойства, вызываемом из контекстного меню.

    Для настройки сведений, отображаемых для файла в Проводнике, сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел соответствующий наименованию необходимого Вам расширения файла в указанных ниже ветках реестра:

    2.1) чтобы изменить отображаемые сведения для всех пользователей на компьютере (если Вы администратор компьютера):

    2.2) чтобы изменить отображаемые сведения для текущей записи:

    Например, для расширения .mp3 откройте:

    3) Измените значения параметров:

    InfoTip - отвечает за информацию отображаемую во всплывающей подсказке
    PreviewDetails - отвечает за информацию отображаемую в области сведений Проводника
    FullDetails - отвечает за информацию отображаемую во вкладке Подробно в Свойствах файла

    4) Щелкните правой кнопкой мыши на выбранном параметре и выберите Изменить.
    5) После слова prop: добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов в системе. Значения отделяются друг от друга точкой с запятой.

    Например, для файлов с расширением .mp3 Вы можете выставить значение:

    В таблице ниже, указаны значения наиболее часто используемых значений данных параметров.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока
Наименование значения параметра | Отображаемое значение

    19. Изменение используемых по умолчанию столбцов в Проводнике для папок, при выборе отображения в виде таблицы.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    При выборе в Проводнике вида отображения Таблица, система показывает определенные столбцы. Вы можете настроить для любой папки свой собственный набор столбцов, щелкнув правой кнопкой мыши на любом из них и во всплывающем меню выбрав пункт Подробнее..., если же Вам необходимо изменить столбцы отображаемые по умолчанию, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор столбцов в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора столбцов во всех папках Проводника добавьте или удалите значения во всех шаблонах.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки столбцов, используемых по умолчанию в Проводнике, сделайте следующее:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра необходимого Вам шаблона.
    Например: для добавления или удаления столбцев в обычной папке использующей шаблон типа папки «Музыка» откройте:

    А для добавления или удаления столбцев в папке «Музыка», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TopViews
    5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра ColumnList (щелчок правой кнопкой мыши на параметре → Изменить) стоящие после слова prop: .
    6) Для включения необходимого Вам столбца измените значение стоящее перед ним на 0. Цифра 0 перед указанным Вами параметром сообщит системе, что данный столбец необходимо отобразить. Если необходимый Вам столбец отсутствует, то Вы можете добавить его самостоятельно, указав перед ним цифру 0. Значения отделяются друг от друга точкой с запятой (;). Например: для изменения столбцов как на рисунке, в начале совета значение параметра ColumnList примет вид:

    В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока
Наименование значения параметра | Отображаемое значение

    7) Перезагрузите компьютер
    8) Для папок из библиотек, щелкните правой кнопкой мыши внутри основной папки (Видео, Документы, Изображения, Музыка) выберите Упорядочить → Очистить изменения
    9) Для обычных папок измените шаблон на другой вид в Свойства → Настройка, а затем верните обратно.
    10) Также очистите в реестре указанный ниже раздел, удалив все папки кроме AllFolders.

    Очистка данного раздела реестра удалит все настройки яў папок сделанные пользователями, до применения данного совета.

    20. Изменение пунктов контекстного меню "Сортировка" используемых по умолчанию в Проводнике.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    При нажатии правой кнопки мыши в любой папке в Проводнике, система показывает контекстное меню. В данном меню есть пункт Сортировка, содержащий свое собственное меню. Вы можете настроить для любой папки свой собственный вид меню Сортировка, выбрав в нем пункт Подробнее..., если же Вам необходимо изменить вид данного меню отображаемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените вид меню Сортировка в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора пунктов во всех папках Проводника добавьте или удалите значения во всех шаблонах.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки меню Сортировка, используемого по умолчанию в Проводнике, сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте ветку необходимого Вам шаблона.
    Например: для добавления или удаления пунктов в меню Сортировка для обычной папки использующей шаблон типа папки «Музыка» откройте:

    А для добавления или удаления пунктов в меню Сортировка для папки «Музыка», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TopViews
    5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра SortByList (щелчок правой кнопкой мыши на параметре → Изменить) стоящие после слова prop: .
    6) Добавьте к существующим значениям необходимые или удалите ненужные.
    Порядок значений в списке соответствует порядку отображения пунктов в меню. Значения отделяются друг от друга точкой с запятой (;).
    Например:

    В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

    Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока
Наименование значения параметра | Отображаемое значение

    21. Запрещение подмены функции кнопки "Завершения работы" при необходимости обновления системы.

    При наличии обновлений, ожидающих установки, на кнопке завершения работы Windows появляется значок со щитом.

    Если не применить данный твик реестра, то когда имеются обновления, доступные для установки, при выборе в меню Пуск команды Завершение работы по умолчанию выберется действие - Установить обновления и завершить работу.
    Чтобы отключить данную функцию в диалоговом окне Завершение работы Windows и отобразить по умолчанию параметр, выбранный при последнем выключении (Гибернация, Перезагрузка и т. д.), вне зависимости от доступности параметра Установить обновления и завершить работу в списке создайте и примените reg-файл следующего содержания:

    22. Постоянное отображение команд "Открыть окно команд" и "Копировать как путь" в контекстном меню Проводника.

    Если Вы будете удерживать клавишу ⇑ Shift при нажатии правой кнопки мыши, то в контекстном меню появятся дополнительные пункты Открыть командную строку и Копировать как путь.

    Чтобы пункт Открыть командную строку отображался без нажатия ⇑ Shift создайте и примените нижеследующий reg-файл:

    Чтобы заставить пункт Открыть командную строку снова отображаться только при нажатии ⇑ Shift создайте и примените нижеследующий reg-файл:

    Чтобы пункт Копировать как путь отображался без нажатия ⇑ Shift создайте и примените нижеследующий reg-файл:

    Минус такого решения - появляющееся на доли секунды окно командной строки.

    Чтобы заставить пункт Копировать как путь снова отображаться только при нажатии ⇑ Shift создайте и примените нижеследующий reg-файл:

    Если Вам не нравится появляющееся на долю секунды окно командной строки, то Вы можете воспользоваться утилитой NirCmd
    Данная утилита позволяет выполнять команды командной строки без отображения окна команд.
    Для отображения пункта Копировать как путь без нажатия ⇑ Shift, сделайте следующее:

    1) Скачайте утилиту NirCmd в соответствии с разрядностью Вашей Windows
    2) Распакуйте скаченный zip-архив в папку C:\NirCmd
    3) Запустите Редактор реестра (Win   + R → regedit → ОК)
    4) Откройте раздел HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\CopyAsPath\Command
    5) Измените значение параметра По умолчанию на:

    23. Добавление произвольного системного ActiveX-элемента в Рабочий стол области переходов Проводника.

    По умолчанию в Проводнике отображается определенный набор объектов ActiveX: Избранное, Библиотеки, Компьютер и Сеть или более расширенный, если у Вас в настройках элемента Параметры папок установлен флажок Показать все папки.

    Чтобы добавить какой-либо из системных объектов в область переходов, Вам необходимо знать его статистически уникальный 128-битный идентификатор - {GUID}.
    Список всех идентификаторов ({GUID}) находится в разделе реестра: HKEY_CLASSES_ROOT\CLSID\{GUID}. Из данного списка в область переходов, добавить Вы можете, те ActiveX-объекты, которые имеют интерфейс IShellFolder (интерфейс для объектов, расширяющих пространство имен оболочки). Данный факт определяется наличием в {GUID} разделе реестра подраздела ShellFolder.
    Для экономии времени, необходимого на поиск нужного элемента Вы можете воспользоваться утилитой CLSID Dump, позволяющей получить список всех ActiveX-объектов, имеющих IShellFolder интерфейс.

    1) Скачайте CLSID Dump, распакуйте архив и запустите программу.
    2) Найдите в CLSID Dump, необходимый Вам {GUID} ActiveX-объекта и откройте его в реестре:
    2.1) Нажмите в самой программе на кнопку Open Regedit
    или
    2.2) Запустите редактор реестра (Win   + R → regedit → ОК) и откройте раздел

    где вместо {GUID} вставьте найденное Вами значение.
    3) Откройте в данном разделе подраздел ShellFolder.

    Например: элементу "Все задачи" соответствует {GUID} равный {ED7BA470-8E54-465E-825C-99712043E01C}, следовательно необходимо открыть:

    4) Задайте полные права на доступ к разделу HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder.

    4.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    4.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    4.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    4.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    4.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    5) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder присутствует строковый параметр WantsParseDisplayName, то удалите его.
    6) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder отсутствует строковый параметр PinToNameSpaceTree, то создайте его с пустым значением.

    Включите отображение объекта для перечисления.

    7) Если необходимо, измените значение параметра Attributes таким образом, чтобы третья цифра стала равна 0. Например: вместо 20100004 задайте 20000004 .

    Добавьте Ваш ActiveX-объект в пространство имен Рабочего стола.

    8) Перейдите в раздел:

    9) Создайте здесь подраздел с названием идентичным Вашему {GUID}. Например:

    Разрешите отображение Вашего объекта только в области переходов Проводника, исключая отображение его на Рабочем столе.

    11) Перейдите в раздел:

    12) Создайте здесь DWORD-параметр с названием идентичным Вашему {GUID} и задайте ему значение равное 1.
    13) Закройте редактор реестра.
    14) Выйдите из системы и войдите в неё заново или перезагрузите компьютер.

    Описанным выше способом, Вы можете добавить почти любой из ActiveX-объектов имеющих интерфейс IShellFolder.

    24. Изменение вида приглашения в командной строке.

    Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка).

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
    3) Создайте PROMPT типа REG_EXPAND_SZ (расширяемый строковый параметр)
    4) Присвойте ему любое из следующих значений (значения можно объединять):

    $B - | (вертикальная черта)
    $D - текущая дата
    $G - > (знак больше)
    $L - < (знак меньше)
    $N - текущий диск
    $P - текущий диск и путь
    $Q - = (знак равно)
    $T - текущее время
    $V - версия Windows
    $$ - $ (знак доллара)
    $A - & (амперсанд)
    $C - ( (левая скобка)
    $F - ) (правая скобка)
    $S - пробел
    [%computername%] - имя Вашего компьютера
    $_ - переход к началу новой строки экрана

    5) Перезагрузите компьютер.

    Например при введении знгачения:

    Вы увидите строку наподобие:

    25. Изменение языка интерфейса установленного по умолчанию (язык системы), для возможности его удаления или правильного определения программами.

    Иногда бывает, если у Вас установлена английская версия и сверху русский языковой пакет, то некоторые программы, имеющие встроенную функцию определения языка могут некорректно определить язык Вашей системы и автоматически запускаться с английским языком интерфейса.
    Также, если Вы решите удалить английский язык из системы после установки сверху русского языкового пакета, то система не позволит Вам этого сделать. Это происходит потому, что для Windows английский язык - это язык системы или язык интерфейса установленный по умолчанию, а русский язык - дополнительный язык интерфейса.

    Чтобы переключить язык интерфейса установленного по умолчанию создайте и примените reg-файл, после чего перезагрузите компьютер.

    Чтобы установить русский язык, в качестве языка используемого по умолчанию (язык системы):

    Чтобы установить английский язык, в качестве языка используемого по умолчанию (язык системы):

    26. Настройка вида, используемого по умолчанию для папок в Проводнике и в диалоговом окне "Открыть/Сохранить файл".

    При нажатии правой кнопки мыши в любой папке в Проводнике, система показывает контекстное меню. В данном меню есть пункт Вид, используя который Вы можете настроить для любой папки свой собственный вид. Но если же Вам необходимо изменить вид папки используемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените значения в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения вида папок по умолчанию во всех папках Проводника добавьте или удалите значения во всех шаблонах.

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для настройки используемого по умолчанию вида папки, сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) В зависимости от того, для чего Вы хотите настроить используемый по умолчанию вид папки, откройте соответствующий раздел реестра.

    Для использования по умолчанию в Проводнике:

    Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

    3) Создайте раздел, соответствующий GUID выбранного Вами шаблона. Например, для настройки вида папок использующих наиболее часто встречающийся шаблон "Общие элементы" создайте:

    Для использования по умолчанию в Проводнике:

    Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

    4) Создайте в данном разделе три параметра DWORD: IconSize,LogicalViewMode и Mode и задайте им значения в соответствии с нижеследующей таблицей. Для удобства использования значения предоставлены в двух системах исчисления.

    Вид папки: | Система исчисления | IconSize | LogicalViewMode | Mode
Огромные значки | Десятичная | 256 | 3 | 1
 | Шестнадцатеричная | 100 | 3 | 1
Крупные значки | Десятичная | 96 | 3 | 1
 | Шестнадцатеричная | 60 | 3 | 1
Обычные значки | Десятичная | 48 | 3 | 1
 | Шестнадцатеричная | 30 | 3 | 1
Мелкие значки | Десятичная | 16 | 3 | 1
 | Шестнадцатеричная | 10 | 3 | 1
Список | Десятичная | 16 | 4 | 3
 | Шестнадцатеричная | 10 | 4 | 3
Таблица | Десятичная | 16 | 1 | 4
 | Шестнадцатеричная | 10 | 1 | 4
Плитка | Десятичная | 48 | 2 | 6
 | Шестнадцатеричная | 30 | 2 | 6
Содержимое | Десятичная | 32 | 5 | 8
 | Шестнадцатеричная | 20 | 5 | 8

    Например, чтобы установить вид папки Крупные значки создайте DWORD-параметры IconSize=60, LogicalViewMode=3 и Mode=1.

    5) Перезагрузите компьютер или перезайдите в систему.

    Примечание:

    Если Вы ранее в Проводнике вручную изменяли вид для какой-либо папки, то система записала Ваши изменения в реестр, и чтобы желаемый Вами вид папки установился также и в них, то Вам необходимо, выполнить на выбор одно из предложенных действий:

    1) Удалить из раздела HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags все папки, кроме AllFolders
    2) Изменить параметры Mode, LogicalViewMode и IconSize на необходимые Вам значения в разделах:

    где XXX - номер папки (раздела), в который записаны значения измененных Вами параметров.
    {GUID} - данный GUID соответствует типу папки.

    27. Удаление открываемых путей из истории в адресной строке Проводника.

    Когда Вы вводите путь в адресную строку Проводника, то он сохраняется в журнал расположений. И если Вы в дальнейшем нажмете на стрелку вниз в конце адресной строки, то откроется список предыдущих расположений.
    Если Вам необходимо его очистить,то Вы можете либо полностью стереть историю открываемых путей или удалить отдельные записи.

    Чтобы очистить всю Вашу историю посещений в Проводнике, щелкните правой кнопкой мыши на адресной строке и выберите из меню пункт Удалить журнал.

    Чтобы удалить отдельные записи:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TypedPaths
    3) Удалите параметры, в которых содержатся ненужные вам пути.
    4) Перезайдите в систему или закройте все процессы Проводника и запустите его снова.

    28. Добавление отображения логотипа и сопутствующей информации.

    Если Вы купили уже готовый компьютер, собранный какой-либо компанией, то при открытии окна Система (Win   + Pause
    Break    ) Вы скорее всего увидите сведения о производителе.
    Данную информацию обычно принято называть OEM информацией.

    Чтобы изменить или указать собственную OEM информацию, Вы можете воспользоваться одним из предложенных ниже вариантов:

    Вариант 1.

    1) Создайте рисунок с нужным Вам логотипом.
    2) Сохраните его с разрешением 120x120 в формате .bmp (Например, в папке C:\Windows\System32 под именем OEMLogo.bmp).
    3) Запустите редактор реестра (Win   + R → regedit → OK)
    4) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OEMInformation
    5) Создайте строковые параметры с необходимыми Вам значениями. Например:

    Model - Название модели
    Manufacturer - Название фирмы
    SupportPhone - Телефон поддержки
    SupportURL - Адрес сайта службы поддержки
    SupportHours - Время работы тех.поддержки
    Logo - Путь к Вашему логотипу.

    6) Перезагрузите компьютер.

    Также Вы можете создать и применить reg-файл.

    Пример:

    Введите необходимые Вам значения, вместо указанных в примере.

    Вариант 2.

    1) Скачайте и распакуйте в любую папку архив Windows7OemInfoEditor.zip.
    2) Запустите необходимую Вам версию программы.

    Windows7OemInfoEditor_en.exe - оригинальная английская версия программы: Windows 7 Oem Info Editor.
    Windows7OemInfoEditor_ru.exe - версия программы переведенная мною на русский язык: Редактор OEM Информации в Windows 7.

    3) Введите желаемые значения полей и нажмите сначала кнопку Сохранить (Save), а затем кнопку Выйти (Exit).
    4) Перезагрузите компьютер или перезайдите в систему.

    29. Изменение режима работы полос прокрутки.

    По умолчанию, чтобы воспользоваться полосой прокрутки в неактивном окне Вам необходимо переключит© на него.
    Указанные ниже твики реестра позволяют изменить поведение полос прокрутки.
    Чтобы задействовать работу полос прокрутки в данных режимах, Вам необходимо будет только перевести курсор мыши на неактивное окно.

    Вариант 1. Активация полос прокрутки неактивного окна без переключения на него.

    1) Создайте и примените reg-файл следующего содержания

    2) Перезагрузите компьютер или перезайдите в систему.

    Вариант 2. Активация полос прокрутки неактивного окна путем переключения на него.

    1) Создайте и примените reg-файл следующего содержания.

    2) Перезагрузите компьютер или перезайдите в систему.

    Чтобы восстановить изначальные значения создайте и примените reg-файл следующего содержания, после чего перезагрузите компьютер.

    30. Включение отключенного диалога подтверждения удаления в аплете "Программы и компоненты".

    Если Вы в диалоге подтверждения действия, появляющемся при удалении программ в аплете "Программы и компоненты" установили флажок "Больше не показывать это диалоговое окно", то вернуть обратно данное диалоговое окно Вы сможете только внеся изменения в реестр, для этого выполните следующие действия:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\DontShowMeThisDialogAgain
    3) Измените значение параметра {948e51fb-0a48-44f0-86ac-33c36def540c} на YES, либо удалите данный параметр.
    4) Перезагрузите компьютер или перезайдите в систему.

    31. Настройка анимации иконки пользователя в меню Пуск.

    Вверху меню Пуск содержится изображение пользователя, которое меняется при наведении курсора на другой пункт меню.
    Путем внесения изменений в реестр Вы можете изменить скорость анимации яў данной иконки, либо полностью отключить эффект смены изображений.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\StartPage
    3) Создайте в данном разделе, необходимые Вам параметры из указанных ниже.
    4) Для применения внесенных Вами настроек перезагрузите компьютер или перезаудите в систему.

    Настройка времени паузы перед сменой изображения.

    1) Создайте DWORD-параметр StartPanel_FadeDelay
    2) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
    3) Переключите систему исчисления на десятичную и установите значение данного параметра равным времени задержки в миллисекундах (1000 миллисекунд=1 секунда).

    Отключение смены изображений.

    1) Создайте DWORD-параметр StartPanel_FadeDelay
    2) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
    3) Установите значение данного параметра в шестнадцатеричной системе равным FFFFFFFF или в десятеричной 4294967295 .

    Настройка скорости исчезновения текущего изображения.

    1) Создайте DWORD-параметр StartPanel_FadeIn
    2) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
    3) Переключите систему исчисления на десятичную и установите значение данного параметра равным скорости исчезновения текущего значка в миллисекундах (1000 миллисекунд=1 секунда).
    При установке значения параметра StartPanel_FadeIn равным нулю, текущее изображение исчезнет моментально, и начнет появляться новая иконка.

    Настройка скорости ¦вления нового изображения.

    1) Создайте DWORD-параметр StartPanel_FadeOut
    2) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
    3) Переключите систему исчисления на десятичную и установите значение данного параметра равным скорости ¦вления нового значка в миллисекундах (1000 миллисекунд=1 секунда).
    При установке значения параметра StartPanel_FadeOut равным нулю, новое изображение появляется моментально, сразу после исчезновения текущей иконки.

    Отключение анимации при смене изображений.

    Для моментальной смены изображения, без использования анимации установите значений обеих параметров: StartPanel_FadeOut и StartPanel_FadeIn равными нулю.

    32. Изменение интервала автоматической синхронизации времени компьютера с сервером.

    По умолчанию, автоматическая синхронизация времени компьютера с сервером проиходит раз в неделю.
    При такой настройке часы Вашего компьютера могут получить погрешность во времени.
    Поэтому рекомендуется уменьшить интервал между обновлениями, что позволит поддерживать точность хода часов Вашего компьютера.
    Для этого Вам необходимо внести изменения в системный реестр Windows.

    1) Запустите редактор реестра (Win   + R → regedit → OK)
    2) Откройте раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpClient
    3) Измените значение параметра SpecialPollInterval на необходимое Вам.
    Данное значение указывается в секундах. По умолчанию оно равно 604800, что соответствует неделе. Для синхронизации времени каждый час установите значение 3600.
    4) Перезагрузите компьютер.

    33. Удаление области уведомлений (System Tray) с панели задач.

    Если Вы желаете удалить с панели задач область уведомлений (System Tray), то создайте и примените reg-файл указанного ниже содержания, а затем перезагрузите компьютер:

    Чтобы вернуть область уведомлений обратно на панель задач, то создайте и примените reg-файл указанного ниже содержания, а затем перезагрузите компьютер:

    Также Вы можете воспользоваться программой Hide Systemtray, которая позволяет выполнить указанную операции автоматически.

    34. Отключение всплывающего уведомления "Цветовая схема изменена на Windows 7 — упрощенный стиль".

    Если Вы желаете отключить всплывающее уведомление "Цветовая схема изменена на Windows 7 — упрощенный стиль", то Вы можете воспользоваться одним из предложенных ниже вариантов.

    Вариант 1.

    Создайте и примените reg-файл указанного ниже содержания, а после применения перезагрузите компьютер:

    Вариант 2.

    1) Запустите командную строку (Win+R → cmd → OK)
    2) Введите необходимую Вам команду и нажмите Enter ↵:

    Отключение всплывающего уведомления "Цветовая схема изменена на Windows 7 — упрощенный стиль"

    Включение всплывающего уведомления "Цветовая схема изменена на Windows 7 — упрощенный стиль"

    35. Отключение и включение отображения эскизов панели задач.

    Если Вы желаете, чтобы вместо эскизов панели задач для всплывающих подсказок использовался стандартный текст, то сделайте следующее.

    1) Запустите редактор реестра (Win   + R → regedit → OK).
    2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD.
    4) Переименуйте его в TaskbarNoThumbnail
    5) Измените значение на 1.
    6) Перезагрузите компьютер.

    Также Вы можете также создать и применить reg-файл следующего содержания:

    Чтобы вернуть отображение эскизов обратно - удалите параметр TaskbarNoThumbnail из раздела реестра:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    36. Удаление и восстановление вкладок из окна Свойства файла.

    При нажатии правой кнопкой мыши на файле и выборе пункта Свойства откроется окно с информацией о файле.
    При желании Вы можете удалить некоторые из отображаемых вкладок.

    Чтобы удалить вкладку Безопасность из окна Свойства файла создайте и примените указанный ниже reg-файл:

    Чтобы удалить вкладку Подробно из окна Свойства файла создайте и примените указанный ниже reg-файл:

    Чтобы удалить вкладку Предыдущие версии из окна Свойства файла создайте и примените указанный ниже reg-файл:

    Чтобы удалить вкладку Совместимость из окна Свойства файла создайте и примените указанный ниже reg-файл:

    Чтобы восстановить вкладку Безопасность из окна Свойства файла создайте и примените указанный ниже reg-файл:

    Чтобы восстановить вкладку Подробно из окна Свойства файла создайте и примените указанный ниже reg-файл:

    Чтобы восстановить вкладку Предыдущие версии из окна Свойства файла создайте и примените указанный ниже reg-файл:

    Чтобы восстановить вкладку Совместимость из окна Свойства файла создайте и примените указанный ниже reg-файл:

    37. Запрещение и разрешение изменения положения панели задач на экране.

    Чтобы запретить изменение положения панели задач на экране, создайте и примените reg-файл указанного ниже содержания, после чего перезагрузите компьютер.

    Чтобы разрешить изменение положения панели задач на экране, создайте и примените reg-файл указанного ниже содержания, после чего перезагрузите компьютер.

    38. Настройка мигания иконки фоновой программы на панели задач, требующей активизации.

    Существуют определенные моменты, когда на панели задач начинает мигать кнопка программы, требующей активизации (открытия окна, ввода данных и т.д.).
    Вы можете настроить количество миганий иконки, следующим образом:

    1) Запустите редактор реестра (Win   + R → regedit → OK)
    2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
    3) Щелкните правой кнопкой мыши на параметре ForeGroundFlashCount и выберите Изменить.
    4) Установите Система исчисления в значения Десятичная.
    5) Введите необходимое Вам значение и нажмите ОК.
    Внимание: значение 0 не отключает мигание, а заставляет иконку мигать постоянно. Значение по умолчанию равно 7.
    6) Перезагрузите компьютер.

    Вы также можете настроить параметр ForegroundLockTimeout, который указывает величину интервала времени, отведенного на мигание.
    После истечения данного интервала программа, требующая фокус, автоматически перейдет на передний план. Значение данного параметра по умолчанию равно 200000 мс.

    39. Удаление и восстановление пункта Настроить папку из контекстного меню.

    Чтобы удалить пункт Настроить папку из контекстного меню, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить пункт Настроить папку в контекстном меню, создайте и примените указанный ниже reg-файл.

    40. Удаление и восстановление пунктов Открыть в новом окне и Добавить в библиотеку из контекстного меню дисков и папок.

    Для удаления пункта Открыть в новом окне из контекстного меню дисков и папок, создайте и примените reg-файл указанного ниже содержания.

    Для восстановления пункта Открыть в новом окне в контекстном меню дисков и папок, создайте и примените reg-файл указанного ниже содержания.

    Для удаления пункта Добавить в библиотеку из контекстного меню дисков и папок, создайте и примените reg-файл указанного ниже содержания.

    Для восстановления пункта Добавить в библиотеку в контекстном меню дисков и папок, создайте и примените reg-файл указанного ниже содержания.

    41. Удаление пункта "Следующее фоновое изображение рабочего стола" из контекстного меню рабочего стола.

    Чтобы удалить пункт Следующее фоновое изображение рабочего стола из контекстного меню рабочего стола, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить пункт Следующее фоновое изображение рабочего стола из контекстного меню рабочего стола, создайте и примените указанный ниже reg-файл.

    42. Удаление и восстановление пункта Отправить в контекстном меню.

    Чтобы удалить пункт Отправить из контекстного меню, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить пункт Отправить в контекстном меню, создайте и примените указанный ниже reg-файл.

    43. Удаление и восстановление пунктов из раздела Дополнительные параметры на вкладке Вид в диалоговом окне Параметры папок.

    Для настройки дополнительных параметров папок, необходимо открыть Пуск → Панель управления → Параметры папок → Вид.
    Вы можете удалить пункты из данного раздела, используя предложенные ниже решения.

    Чтобы удалить пункт Восстанавливать прежние окна папок при входе в систему (Restore previous folder windows at logon) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Восстанавливать прежние окна папок при входе в систему (Restore previous folder windows at logon) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Всегда отображать значки, а не эскизы (Always Show Icons, Never Thumbnails) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Всегда отображать значки, а не эскизы (Always Show Icons, Never Thumbnails) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Всегда отображать меню (Always show menus) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Всегда отображать меню (Always show menus) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Выводить полный путь в строке заголовка (Display the Full Path in the Title Bar) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Выводить полный путь в строке заголовка (Display the Full Path in the Title Bar) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Запускать окна с папками в отдельном процессе (Launch folder windows in a separate process) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Запускать окна с папками в отдельном процессе (Launch folder windows in a separate process) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Использовать мастер общего доступа (Use Sharing Wizard) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Использовать мастер общего доступа (Use Sharing Wizard) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Использовать флажки яў выбора элементов (Use check boxes to select items) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Использовать флажки яў выбора элементов (Use check boxes to select items) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Отображать буквы дисков (Show drive letters) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Отображать буквы дисков (Show drive letters) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Отображать значки файлов на эскизах (Display file icon on thumbnails) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Отображать значки файлов на эскизах (Display file icon on thumbnails) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Отображать обработчики просмотра в панели просмотра (Show preview handlers in preview panel) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Отображать обработчики просмотра в панели просмотра (Show preview handlers in preview panel в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Отображать описания для папок и элементов рабочего стола (Show pop-up descriptions for folders and desktop items) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Отображать описания для папок и элементов рабочего стола (Show pop-up descriptions for folders and desktop items) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Отображать сведения о размере файлов в подсказках папок (Display file size information in folder tips) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Отображать сведения о размере файлов в подсказках папок (Display file size information in folder tips) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Отображать сжатые или зашифрованные файлы другим цветом (Show encrypted or compressed NTFS files in color) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Отображать сжатые или зашифрованные файлы другим цветом (Show encrypted or compressed NTFS files in color) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт При вводе текста в режиме "Список" (When typing into list view) с обеими его переключателями из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт При вводе текста в режиме "Список" (When typing into list view) с обеими его переключателями в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Скрывать защищенные системные файлы (рекомендуется) (Hide protected operating system files (Recommended)) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Скрывать защищенные системные файлы (рекомендуется) (Hide protected operating system files (Recommended)) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Скрывать пустые диски в папке "Компьютер" (Hide empty drives in the Computer folder) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Скрывать пустые диски в папке "Компьютер" (Hide empty drives in the Computer folder) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Скрывать расширения для зарегистрированных типов файлов (Hide extensions for known file types) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Скрывать расширения для зарегистрированных типов файлов (Hide extensions for known file types) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить пункт Скрытые файлы и папки (Hidden files and folders) с обеими его переключателями из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    Чтобы восстановить пункт Скрытые файлы и папки (Hidden files and folders) с обеими его переключателями в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

    44. Удаление пункта SkyDrive Pro из контекстного меню.

    Чтобы удалить из контекстного меню пункт SkyDrive Pro, добавляемый Microsoft Office, выполните указанные ниже действия:

    1) Запустите редактор реестра (Win   + R → regedit → OK).
    2) Откройте раздел реестра: HKEY_CLASSES_ROOT\AllFilesystemObjects\shell
    3) Удалите подраздел SPFS.ContextMenu.

    45. Использование реестра для управления файлом подкачки pagefile.sys.

    Для создания, изменения или удаления файлов подкачки необходима перезагрузка компьютера.

    1) Запустите редактор реестра (Win   + R → regedit → OK).
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
    3) Измените значение мультистрокового параметра PagingFiles (REG_MULTI_SZ) на одно из указанных ниже, для получения необходимого Вам результата.

    Чтобы установить флажок Автоматически выбирать объем файла подкачки:

    Снятие флажка Автоматически выбирать объем файла подкачки происходит при указании размера файла подкачки яў одного из имеющихся дисков.

    1) Чтобы создать файл подкачки только на диске C: и установить для него значение Размер по выбору системы. И отключить файл подкачки яў всех остальных дисков (соответствует переключателю Без файла подкачки).

    2) Чтобы создать файл подкачки и установить для него значение Размер по выбору системы для нескольких из имеющихся дисков, укажите путь к файлу подкачки на диске и рядом два нуля разделенные пробелом.
    Например:
    При наличие дисков C:, D:, E:, F: установить значение Размер по выбору системы, только для файлов подкачки на дисках C: и E:.
    На дисках D: и F: отключить файл подкачки (соответствует переключателю Без файла подкачки).

    3) Чтобы создать файл подкачки на диске C: и установить для него значение Размер по выбору системы, а на диске D: создать файл подкачки заданного размера.

    Первое число после пути к файлу подкачки указывает исходный размер файла подкачки, а второе число задает максимальный размер файла подкачки.

    4) Чтобы отключить использование всех существующих файлов подкачки (соответствует переключателю Без файла подкачки) полностью очистите значение указанное для мультистрокового параметра PagingFiles (REG_MULTI_SZ).

    Готовые reg-файлы:

    Чтобы установить флажок Автоматически выбирать объем файла подкачки:

    Чтобы снять флажок Автоматически выбирать объем файла подкачки, создать файл подкачки только на диске C: и установить для него значение Размер по выбору системы:

    Чтобы отключить использование всех существующих файлов подкачки (соответствует переключателю Без файла подкачки):

    46. Замена мест расположения в диалоговых окнах "Открыть" и "Сохранить как" на собственные значения.

    Если предложенный список мест расположения в диалоговых окнах "Открыть" и "Сохранить как" Вам кажется неудобным, то для ускорения навигации Вы можете заменить его на собственный.
    Для этого создайте и примените reg-файл, указанного ниже содержания:

    Внимание.: При указании путей к папкам в reg-файле используйте двойной слэш вместо одинарного.

    Для добавления команд Shell, использующих имя объектов, Вы можете воспользоваться таблицей №2 из
    Раздел: Интерфейс - Взаимодействие.
    Совет: 4. Запуск команд Windows Shell, используя названия и {GUID} объектов.

    Твики Реестра - Дополнительная функциональность.

    1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

    Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:

    Например, при распаковке Windows6.1-KB917607-x64.exe, на выходе получаем папку Windows6.1-KB917607-x64.exe_unpacked с извлечёнными файлами.
    Минус один - команда Unpack HotFix встраивается в контекстное меню всех exe-файлов, а не только файлов от Microsoft.

    Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:

    Готовые reg-файлы Вы можете скачать по ссылке: UnpackHotFix.zip

    2. Добавление пункта "Открыть в блокноте" в контекстное меню файлов.

    1) Создайте reg-файл.
    1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Notepad.reg")
    1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    2) Примените полученный reg-файл. Щелкните на нем дважды и нажмите кнопку Да.

    3. Добавление системных ярлыков в папку Компьютер.

    Создайте и примените reg-файлы следующего содержания:

    Администрирование

    Корзина

    Панель управления

    Принтеры и факсы

    Учетные записи пользователей

    4. Добавление произвольной команды в контекстное меню рабочего стола.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "fix.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    5) Примените его.

    Вместо Название команды укажите необходимое Вам название пункта, которое будет отображаться в контекстном меню. Например: Панель управления
    Вместо выполняемая команда укажите какая команда должна быть запущена при нажатии созданного Вами пункта в контекстном меню. Например: control
    Вместо путь к значку иконки укажите путь к иконке, отображаемой рядом с Вашим пунктом в контекстном меню.
    Вместо Расположение укажите месторасположение Вашего пункта в контекстном меню. Top - вверху, Bottom - внизу.

    Описанным выше способом можно добавить практически любую команду.
    Например, reg-файл для добавления пункта Панель управления в контекстное меню рабочего стола будет выглядеть так:

    5. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".

    Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB.
    С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.

    6. Добавление пункта "Удалить содержимое папки" в контекстное меню.

    Как добавить в контекстное меню папки команду для удаления содержимого папки без удаления самой папки? Вы можете создать себе пункт Удалить содержимое папки в контекстном меню и Вам достаточно будет его только выбрать. Вам не придется открывать папку, выделять все файлы и нажимать на клавишу Delete.

    Вариант 1.

    1) Запустите редактор реестра: Win   + R → regedit → ОК
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
    3) Создайте в ней раздел DeleteFolderContent
    4) Создайте в нем строковый(String) параметр MUIVerb со строкой Удалить содержимое папки.
    5) В разделе DeleteFolderContent создайте подраздел command
    6) Измените значение параметра (По умолчанию) раздела command на следующее:

    Вариант 2.

    1) Запустите редактор реестра: Win   + R → regedit → ОК
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
    3) Создайте в ней раздел Удалить содержимое папки
    4) В разделе Удалить содержимое папки создайте подраздел command
    6) Измените значение параметра (По умолчанию) раздела command на следующее:

    Вариант 3.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    Вы можете скачать готовые reg-файлы: DeleteFolderContent.zip

    7. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

    По какой-то неизвестной причине, разработчики Microsoft решили не включать в контекстное меню Проводника пункты Копировать в папку (Copy To) и Переместить в папку (Move To). Используя их, можно легко и быстро скопировать или переместить файл или папку. Для этого, достаточно выбрать желаемое место их размещения в соответствующем диалоговом окне. Для того, чтобы добавить эти команды в контекстное меню, достаточно создать, соответствующие им параметры в реестре.

    Вариант 1

    1) Запустите Редактор Реестра (нажмите копку «Пуск» (Start), введите regedit в строке «Найти программы и файлы» и нажмите Enter ↵).
    2) Откройте ветку реестра HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers
    3) Создайте в ней раздел со следующим именем (включая фигурные скобки):
    Для добавления в контекстное меню пункта Копировать в папку

    Для добавления в контекстное меню пункта Переместить в папку

    4) Нажмите Enter ↵
    5) Перезагрузите Проводник (Windows Explorer) или перезайдите в систему, и данные пункты появятся в контекстном меню.

    Вариант 2

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    5) Примените созданный reg-файл и перезапустите компьютер.

    8. Добавление своего ярлыка папки или программы в папку Компьютер.

    Если Вы часто пользуйтесь какой-либо программой, то помимо добавления её значка на рабочий стол, Вы также можете добавить его в папку Компьютер. Поскольку скопировать напрямую или создать ярлык в данной папке нельзя, то предлагаю Вам решение, как это возможно осуществить.

    1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

    2) Скачайте программу Microsoft Exchange Server GUID Generator
    3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
    4) Установите переключатель на значение Registry Format
    5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
    6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
    7) Вставьте вместо {GUID}, сгенерированный программой GUID.
    Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {FF4A6226-C00B-409e-88A6-6C401C52BD98}
    8) Замените значения "Наименование папки или программы", "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" на необходимые Вам.
    8) Замените значения "Наименование папки или программы", "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" на необходимые Вам.
    Внимание! При указывании пути к иконке и файлу объекта слэш должен быть двойным.
    Например, если путь к программе: C:\MyProgram\MyProgram.exe, то необходимо указать его как: C:\\MyProgram\\MyProgram.exe
    Так как, чаще всего икона программы встроена в саму программу, то значения "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" могут совпадать.
    9) При добавлении ярлыка папки измените "Путь к иконке для ярлыка" на %SystemRoot%\\system32\\SHELL32.dll,4
    А значение "Путь к папке или файлу программы" на explorer /n, /e, C:\\ВашаПапка
    10) После указания всех необходимых значений, нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    10.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
    10.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    11) Примените получившийся reg-файл.

    Пример reg-файла для добавления программы WinDjView в папку Компьютер:

    Пример reg-файла для добавления папки Downloads в папку Компьютер:

    В итоге Вы получите тот же самый эффект, что был упомянут в совете 3 раздела "Твики Реестра - Дополнительная функциональность".

    9. Добавление в контекстное меню DLL- или OCX-файлов пунктов "Регистрация" и "Отмена регистрации".

    Если вам часто приходится работать с ocx-файлами или с dll-файлами, которые требуют регистрации в реестре с помощью Regsvr32.exe, то будет гораздо удобнее внести соответствующую запись в реестр, чем каждый раз использовать командную строку для каждого файла.

    Запустите редактор реестра (Win   + R → regedit → ОК )

    Создание пункта "Регистрация" в меню DLL- или OCX-файлов.

    1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
    2) Создайте раздел Регистрация, а в нем подраздел command
    3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Регистрация\command и HKEY_CLASSES_ROOT\dllfile\Shell\Регистрация\command присвойте строковому параметру По умолчанию значение: regsvr32.exe "%1"

    Создание пункта "Отмена регистрации" в меню DLL- или OCX-файлов.

    1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
    2) Создайте раздел Отмена регистрации, а в нем подраздел command
    3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Отмена регистрации\command и HKEY_CLASSES_ROOT\dllfile\Shell\Отмена регистрации\command присвойте строковому параметру По умолчанию значение: regsvr32.exe /u "%1"

    Теперь при нажатии правой кнопкой мыши на DLL- или OCX-файле, в меню появятся пункты "Регистрация" и "Отмена регистрации".

    Также Вы можете создать reg-файл следующего содержания или скачать готовый Dll_Ocx_register-unregister.reg

    10. Увеличение кэша памяти яў вида папок.

    Можно увеличить количество папок, для которых Windows будет запоминать настройки вида.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
    3) Создайте параметр DWORD BagMRU Size и присвоить ему десятичное значение, например, 20000.

    Также Вы можете создать reg-файл.

    1) Скопируйте код в любой текстовый редактор (например, Блокнот).
    2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: " folder_cache.reg")
    4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

    11. Добавление опций "Выполнить", "Поиск" и "Очистить корзину" в контекстное меню рабочего стола.

    Для быстрого доступа к необходимой Вам системной опции, Вы можете добавить её в контекстное меню рабочего стола. Чтобы это осуществить, Вам необходимо создать и применить reg-файл следующего содержания.

    Добавление пункта Выполнить для вызова одноименного диалогового меню.

    Добавление пункта Поиск для вызова одноименного окна.

    Добавление пункта Очистить корзину.

    Архив с готовыми reg-файлами Вы можете скачать по ссылке: RunSearchRecycleBinContextMenu.zip

    12. Создание меню с ярлыками избранных приложений в контекстном меню рабочего стола.

    Вариант 1.

    Добавление ссылок на избранные программы в контекстное меню рабочего стола Windows сводится к двум частям:

    Часть 1. Создание каскадных меню в контекстном и добавление ярлыков.
    Часть 2. Добавление функциональности ярлыкам путем их регистрации.

    Часть 1. Создание контекстных меню и добавление ярлыков.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте ветку HKEY_CLASSES_ROOT\DesktopBackground\Shell
    3) Создайте в данной ветке новый раздел. Нажмите правой кнопкой мыши на ключе "Shell" и выберите "Создать → Раздел". (Например, Menu1)
    4) Выберите только что созданный раздел "Menu1" и в правой части окна создайте 4 строковых параметра:

    Icon - в значении данного параметра следует указать путь к значку меню.
    Position - данный параметр определяет позицию каскадного меню в контекстном. По умолчанию это середина контекстного меню, но Вы можете выбрать значения Top (сверху) или Bottom (снизу).
    MUIVerb - имя каскадного меню, которое будет отображаться в контекстном меню. Например, "Мои программы", "Браузеры" и т.д.
    SubCommands - содержит список команд, разделенных точкой с запятой (;). Эти команды будут показаны в каскадном меню. Вы не можете напрямую добавить ярлык приложения. Сначала в этом списке Вам нужно дать команде имя, а после этого зарегистрировать ее согласно инструкции во второй части статьи.

    Предположим, что Вы уже создали каскадное меню "Браузеры", и теперь Вы хотите добавить в него ярлыки Internet Explorer и Mozilla Firefox. В таком случае Вам нужно параметру SubCommands задать значение:

    Параметры Icon и Position Вы можете и не создавать, а вот MUIVerb и SubCommands — обязательны.

    Часть 2. Добавление функциональности ярлыкам путем их регистрации.

    Как только Вы добавите ярлыки программ в каскадное меню, Вам необходимо будет их зарегистрировать следующим образом:

    1) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\Shell
    2) Создайте для каждой из команд, указанных ранее в строковом параметре SubCommands, собственный одноименный раздел. В нашем примере мы использовали две команды: firefox и iexplore, поэтому нам нужно создать два раздела с такими же именами.
    3) Выберите созданный раздел и в правой части окна редактора реестра задайте параметру Default (По умолчанию) имя, которые Вы хотите видеть в каскадном меню. Например, введите сюда Internet Explorer (для раздела iexplore) или Mozilla Firefox (для раздела firefox).
    4) Если Вы хотите добавить ярлыку иконку, создайте новый строковой параметр с именем Icon и установите его значением путь к EXE файлу приложения или любой другой иконке.
    Например, чтобы показать иконку Internet Explorer, Вы должны задать параметру Icon значение C:\Program Files\Internet Explorer\iexplore.exe
    5) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
    Выберите его и в правой части окна установите значением Default (По умолчанию) путь к EXE-файлу необходимой программы. Например, если ярлык должен открывать Internet Explorer, то должно быть установлено значение C:\Program Files\Internet Explorer\iexplore.exe

    Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

    Чтобы удалить созданное данным образом каскадное меню, необходимо удалить созданные разделы.

    Вариант 2.

    1) Создайте в ветке реестра HKEY_CLASSES_ROOT\DesktopBackground\Shell раздел с именем Вашего меню (Например, Menu1) и параметрами:

    2) Укажите в параметре Icon путь к иконке для меню, а в параметре MUIVerb - имя каскадного меню.
    3) Параметр SubCommands оставьте пустым.
    4) Создайте в ветке Вашего меню раздел shell. (Например: HKEY_CLASSES_ROOT\DesktopBackground\Shell\Menu1\shell).
    5) Создайте в данном разделе shell для каждого пункта меню собственный раздел. Пункты в полученном меню будут отсортированы по названию данных разделов.
    Чтобы изменить расположение пункта в меню, указывайте его порядковый номер: 01, 02 и так далее до 16. Максимальное число пунктов одном каскадном меню, включая его подменю не может быть более 16.
    Например, чтобы добавить пункты: firefox и iexplore, создайте два раздела с такими же именами.
    6) Выберите созданный раздел и измените значение параметра По умолчанию на имя, которые Вы хотите видеть в каскадном меню.
    Например, укажите Internet Explorer для раздела 01.iexplore и Mozilla Firefox для раздела 02.firefox.
    7) Если Вы хотите добавить ярлыку иконку, создайте новый строковой параметр с именем Icon и установите его значением путь к EXE файлу приложения или любой другой иконке.
    Например, чтобы показать иконку Internet Explorer, Вы должны задать параметру Icon значение C:\Program Files\Internet Explorer\iexplore.exe
    8) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
    9) Измените значение параметра По умолчанию на путь к EXE-файлу необходимой программы. Например, для открытия Internet Explorer установлено значение C:\Program Files\Internet Explorer\iexplore.exe Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

    Главным плюсом данного метода является то, что все пункты меню расположены в папках одного раздела.
    А чтобы удалить меню целиком Вам не надо удалять разделы отвечающие за отдельные пункты меню.
    Достаточно удалить начальный раздел реестра.

    Вариант 3.

    1) Создайте в ветке реестра HKEY_CLASSES_ROOT\DesktopBackground\Shell раздел с именем Вашего меню (Например, Menu1) и параметрами:

    2) Укажите в параметре Icon путь к иконке для меню, а в параметре MUIVerb - имя каскадного меню.
    3) В параметре ExtendedSubCommandsKey укажите путь к папке shell в разделе HKEY_CLASSES_ROOT, где находятся пункты Вашего меню. (Например: DesktopBackground\\ContextMenus\\Menu1 для раздела HKEY_CLASSES_ROOT\DesktopBackground\ContextMenus\Menu1\shell)
    4) Откройте (создайте) ветку реестра путь к которой Вы указали в параметре ExtendedSubCommandsKey и создайте для каждого пункта меню собственный раздел.
    5) Измените в созданных разделах значения параметров По умолчанию на имена, которые Вы хотите видеть для каждого пункта в каскадном меню.
    6) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
    7) Измените значение параметра По умолчанию на путь к EXE-файлу необходимой программы. Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

    Чтобы удалить созданное данным образом каскадное меню, необходимо удалить созданные разделы.

    13. Ускорение запуска Windows и выключения компьютера.

    Если Вы желаете снизить время, затрачиваемое на запуск Windows и/или на выключение компьютера, то создайте и примените reg-файл указанного ниже содержания:

    Значения используемых в данном reg-файле параметров:

    AutoEndTasks = Автоматическое завершение зависших приложений.
    HungAppTimeout = Определяет интервал времени (в миллисекундах), в течение которого программа должна ответить на запрос системы. Если в течение этого времени программа не ответила на запрос, то она считается зависшей.
    LinkResolveIgnoreLinkInfo = Отключение проверки сопоставления ярлыков программам (Каждый раз при загрузке Windows, происходит проверка пути в ярлыках, которые находятся на рабочем столе, и если система не находит программу по указанному в ярлыке пути, то начинает вести ее поиск.)
    LowLevelHooksTimeout = Время ожидания перехватчика событий для обработки команд перед завершением работы Windows. (Например: для перехвата нажатий клавиш клавиатуры или мыши.)
    NoInternetOpenWith = Указывает, следует ли использовать веб-службы Microsoft для поиска приложений, чтобы открыть файлы с необработанными файловыми ассоциа ми.
    NoLowDiskSpaceChecks = Отключение проверки доступного свободного места на диске.
    NoResolveSearch = Запрещает системе осуществлять поиск целевого устройства по его ярлыку.
    NoResolveTrack = Блокирует функциональные возможности системы по отслеживанию NTFS, при поиске целевых файлов ярлыков оболочки;
    WaitToKillAppTimeout = Указывает интервал времени (в миллисекундах), в течение которого программа должна закончить свою работу при завершении работы операционной системы. Если программа не завершит свою работу в течение указанного интервала времени, то она будет завершена автоматически. При этом все несохранённые данные будут утеряны.
    WaitToKillServiceTimeout = Определяет интервал времени (в миллисекундах) в течение которого служба должна закончить свою работу при завершении работы операционной системы.

    Также Вы можете скачать архив Speed_up_Win7.zip с готовыми reg-файлами и применить нужный Вам:

    Speed_up_Win7.reg - файл, содержащий указанные выше параметры для настройки системы.
    Undo_Speed_up_Win7.reg - файл, устанавливающий значение параметров по умолчанию.

    14. Ускорение анимации всплывающего меню в меню Пуск.

    Если Вы желаете изменить время задержки до показа всплывающего меню в меню Пуск, проделайте следующее:

    1)Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
    2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
    3) Создайте в нем(или измените) параметр MenuShowDelay
    4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
    5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    6) Выберите желательное значение от 1 до 4000, означающее задержку в миллисекундах, до показа всплывающего меню в меню Пуск.
    7) Закройте regedit и перезагрузите систему.

    15. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

    Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
    Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

    1) Запустите редактор реестра (Нажмите Win   + R, введите команду regedit.exe и нажмите Ок)
    2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
    3) Измените значение параметра MessageDuration.

    16. Настройка параметров всплывающих эскизов окон в панели задач.

    Изменив несколько настроек в реестре Вы сможете придать своим всплывающим эскизам окон больше эффективности в работе.

    1) Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) Создайте в нем(или измените) параметры:

    ExtendedUIHoverTime - Задержка до появления всплывающего эскиза окна на экране, после наведения курсора мыши на иконку в панели задач.
    ThumbnailLivePreviewHoverTime - Задержка до появления окна программы, после наведения курсора мыши на всплывший эскиз окна.

    4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
    5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    6) В графе Система исчисления установите значение параметра на Десятичная.
    7) Введите необходимое Вам значение. Значение 1000 = 1 секунде.

    8) Откройте в реестре раздел: HKEY_CLASSES_ROOT\SystemFileAssociations\image
    9) Сделайте двойной щелчок на параметре Treatment - Данный параметр изменяет вид бордюра всплывающего эскиза окна.
    10) Выберите необходимое Вам значение:

    0 - Без бордюра
    1 - Бордюр с тенью
    2 - Фоторамка (по умолчанию)
    3 - Видеорамка

    11) Закройте regedit и перезагрузите систему.

    17. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

    Когда Вы наводите курсор на крайнюю кнопку, находящуюся за часами на панели задач (обычно правый нижний угол экрана), система показывает Вам рабочий стол. При желании Вы можете ускорить или замедлить данный процесс.

    1) Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    3) Измените значение параметра DesktopLivePreviewHoverTime. Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
    4) В графе Система исчисления установите значение параметра на Десятичная.
    5) Введите необходимое Вам значение. Значение 1000 = 1 секунде.
    6) Закройте regedit, перезайдите в систему или перезагрузите систему.

    18. Добавление кнопки запуска необходимой программы на панель Проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели Проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопки запуска необходимой программы во все папки Проводника - добавьте кнопку во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопки запуска необходимой программы сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5c4f28b5-f869-4e84-8e60-f11db97c5cc7}

    А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5f4eab9a-6833-4f61-899d-31cf46979d49}

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать → Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {422299D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к программе, которую Вы хотите запустить.

    Примечание:

    Если Вы добавляете программу для открытия в ней файлов, то после указания пути к программе добавьте параметр %*
    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).
    Если Вы добавляете программу которая должна просто запускаться, без открытия в ней файлов, то параметр добавлять не надо.

    19. Добавление кнопки "Открыть в текстовом редакторе" на панель Проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели Проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопки "Открыть в текстовом редакторе" во все папки Проводника - добавьте кнопку во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопки "Открыть в текстовом редакторе" сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Документы» откройте:

    А для добавления кнопки в папку ««Документы»», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать → Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {433399D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) Скачайте файл архив со скриптом texteditor.zip и распакуйте его в любую папку. (Например: C:\Scripts)

    10.1) Вы можете создать его самостоятельно. Для этого скопируйте нижеследующий текст в текстовый редактор и сохраните файл с именем texteditor и расширением *.js .

    11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту:

    Примечание:

    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).

    20. Добавление кнопок "Копировать в папку" и "Переместить в папку" на панель Проводника Windows 7.

    Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

    На панели Проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
    Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
    В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
    Для добавления кнопок "Копировать в папку" и "Переместить в папку" во все папки Проводника - добавьте кнопки во все шаблоны.

    Все шаблоны хранятся в разделах следующей ветки реестра:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes

    Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

    Для добавления кнопок "Копировать в папку" и "Переместить в папку" сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра необходимого Вам шаблона.
    Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

    А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

    3) Задайте полные права на доступ к этому разделу реестра.

    3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
    3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
    3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
    3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
    3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

    4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

    4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
    4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать → Раздел.)

    TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
    TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
    Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

    6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

    7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {455599D4-C2DD-4e24-AAAB-FED22CC8E8DE})
    7.1) Скачайте и распакуйте архив GUIDGen.zip
    7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

    8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

    Title – определяет название кнопки
    InfoTip – определяет название всплывающей подсказки к кнопке

    9) В разделе с уникальным GUID последовательно создайте подразделы:

    shell
    InvokeTask
    command

    10) Скачайте файл архив со скриптом ExplorerBarUtilities.zip и распакуйте его в любую папку. (Например: C:\Scripts)

    11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту: Для создания кнопки "Копировать в папку" измените значение на:

    Для создания кнопки "Переместить в папку" измените значение на:

    Примечание:

    Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).

    21. Добавление собственной папки в Рабочий стол области переходов Проводника.

    Если Вы часто пользуйтесь какой-либо папкой, то Вы можете добавить ее в Рабочий стол области переходов Проводника. Поскольку копирование папки напрямую или создание ярлыка на рабочем столе не добавляет её в область переходов, то предлагаю Вам решение, как это возможно осуществить.

    1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

    2) Скачайте программу Microsoft Exchange Server GUID Generator
    3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
    4) Установите переключатель на значение Registry Format
    5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
    6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
    7) Вставьте вместо {GUID}, сгенерированный программой GUID.
    Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {1a51a488-17d4-4169-a212-a2cf152268b6}
    8) Замените значения "Название папки" и "Путь к папке" на необходимые Вам.
    Внимание! При указывании пути к папке слеш должен быть двойным.
    Например, если путь к папке: C:\My Folder\Downloads, то необходимо указать его как: C:\\My Folder\\Downloads
    9) После указания всех необходимых значений, нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
    9.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
    9.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
    10) Примените получившийся reg-файл.

    Пример reg-файла для добавления папки Downloads в Рабочий стол области переходов Проводника.

    22. Скрытие апплетов отображаемых в Панели управления.

    Существует много способов, чтобы скрыть элементы в Панели Управления. Ниже приводятся, наиболее часто используемые.

    1) Создайте reg-файл используя шаблон в одном из предложенных ниже вариантов.
    2) Примените его.
    3) Перезагрузите систему.

    Вариант 1. Показать все кроме.

    Созданный reg-файл позволяет Вам отобразить все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowCpl
    Чтобы исключить определенные апплеты из Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
    Имена параметров должны быть - непрерывные номера начинающиеся с 1: 1, 2, 3, …
    Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

    Пример reg-файла для английской Windows:

    Вариант 2. Скрыть все кроме.

    Созданный reg-файл позволяет Вам скрыть все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictCpl
    Чтобы отобразить определенные апплеты в Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
    Имена параметров должны быть непрерывные - номера начинающиеся с 1: 1, 2, 3, …
    Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

    Пример reg-файла для английской Windows:

    Русское название элемента | Английское название элемента
Windows CardSpace | Windows CardSpace
Windows SideShow | Windows SideShow
Автозапуск | AutoPlay
Автономные файлы | Offline Files
Администрирование | Administrative Tools
Архивация и восстановление | Backup and Restore
Биометрические устройства | Biometric Devices
Брандмауэр Windows | Windows Firewall
Восстановление | Recovery
Гаджеты рабочего стола | Desktop Gadgets
Дата и Время | Date and Time
Датчик расположения и другие датчики | Location and Other Sensors
Диспетчер устройств | Device Manager
Диспетчер учетных данных | Credential Manager
Домашняя группа | HomeGroup
Защитник Windows | Windows Defender
Звук | Sound
Значки области уведомлений | Notification Area Icons
Игровые устройства | Game Controllers
Инфракрасная связь | Infrared
Клавиатура | Keyboard
Мышь | Mouse
Панель задач и меню ''Пуск'' (кавычки два раза одинарные) | Taskbar and Start Menu
Параметры индексирования | Indexing Options
Параметры папок | Folder Options
Параметры планшетного компьютера | Tablet PC Settings
Перо и сенсорные устройства | Pen and Touch
Персонализация | Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection
Получение программ | Get Programs
Приступая к работе | Getting Started
Программы и компоненты | Programs and Features
Программы по умолчанию | Default Programs
Распознавание речи | Speech Recognition
Расположение по умолчанию | Default Location
Родительский контроль | Parental Controls
Свойства обозревателя | Internet Options
Система | System
Сканеры и камеры | Scanners and Cameras
Счетчики и средства производительности | Performance Information and Tools
Телефон и модем | Phone and Modem
Управление цветом | Color Management
Устранение неполадок | Troubleshooting
Устройства и принтеры | Devices and Printers
Учетные записи пользователей | User Accounts
Центр мобильности Windows | Windows Mobility Center
Центр обновления Windows | Windows Update
Центр поддержки | Action Center
Центр синхронизации | Sync Center
Центр специальных возможностей | Ease of Access Center
Центр управления сетями и общим доступом | Network and Sharing Center
Шифрование диска BitLocker | BitLocker Drive Encryption
Шрифты | Fonts
Экран | Display
Электропитание | Power Options
Язык и региональные стандарты | Region and Language
Русское название элемента | Английское название элемента

    23. Увеличение пространства, отведенного в NTFS для главной таблицы файлов.

    В ядре файловой системы NTFS содержится файл, который называется главной таблицей файлов (MFT). MFT (Master File Table) — главная файловая таблица (база данных), в которой хранится информация о содержимом тома с файловой системой NTFS, представляющая собой таблицу, строки которой соответствуют файлам тома, а столбцы — атрибутам файлов.
    Поскольку средства дефрагментации томов NTFS не могут перемещать записи MFT, а также из-за того, что значительная фрагментация MFT может негативно влиять на быстродействие системы, NTFS резервирует для MFT дисковое пространство, чтобы по мере увеличения размера MFT подвергался минимальной фрагментации.
    По мере появления новых файлов в томе NTFS в файл MFT добавляются новые записи, и, таким образом, размер MFT увеличивается. При удалении файлов из тома NTFS соответствующие записи в файле MFT помечаются как свободные и могут использоваться повторно, однако размер MFT при этом не сокращается. Таким образом, дисковое пространство, используемое этими записями, остается недоступным.
    При переполнении зоны MFT пространство для новых записей MFT начинает выделяться из незарезервированного дискового пространства, что снова приводит к фрагментации MFT.

    Существует параметр реестра, позволяющий увеличить (зарезервировать) пространство, отведенное в NTFS для основной таблицы файлов. Для его добавления выполните следующие действия:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem
    3) В меню Правка выберите Создать → Параметр DWORD (32 бита).
    4) Задайте имя параметра NtfsMftZoneReservation
    5) Дважды щелкните на данном параметре и введите необходимое Вам значение от 1 до 4.
    6) Закройте редактор реестра и перезапустите компьютер.

    Если на ваших разделах NTFS мало файлов, но они большого размера, то наилучшим значением созданного параметра будет 1.
    Если у Вас среднее количество файлов на диске, то оптимальным значением является 2, если же их большое количество, то значение 3.
    Значение 4 (максимальное значение) следует использовать только в случае, если у вас на диске очень большое количество файлов.

    24. Увеличение процессорного времени, выделяемого программе, работающей на переднем плане.

    Для начала убедитесь, что параметр Распределение времени процессора настроен на оптимизацию работы программ. Для этого:

    1) Откройте меню Пуск
    2) Нажмите правой кнопкой мыши на пункт Компьютер и выберите Свойства
    3) В списке слева нажмите на ссылку Дополнительные параметры системы
    4) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
    5) Откройте вкладку Дополнительно и в разделе Распределение времени процессора установите переключатель в значение: программ.

    Теперь Вам необходимо изменить количество квантов выделяемых программе, работающей на переднем плане.
    Квантом называется единица процессорного времени, выделяемая конкретной программе для работы. По истечении квантов, выделенных одной программе, управление будет передано другой программе, ожидающей в очереди (а программа, которая только что работала, будет помещена в конец очереди) — и эта программа будет работать до тех пор, пока не истекут кванты, выделенные для нее. После этого управление перейдет следующей программе из очереди.
    Особенностью Windows является увеличенное количество квантов, которое выделяется программе, работающей в данный момент на переднем плане. То есть, программа переднего плана будет работать быстрее всех программ, работающих в данный момент в фоновом режиме.
    Так реализована многозадачность операционной системы Windows.

    Для изменения количества квантов, выделяемых программе, работающей на переднем плане, сделайте следующее:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\PriorityControl
    3) Дважды щелкните на DWORD-параметре Win32PrioritySeparation и введите необходимое Вам значение.
    4) Закройте редактор реестра и перезапустите компьютер.

    По умолчанию значение равно 2.
    Максимальное значение равно 26 в шестнадцатеричной системе исчисления или 38 в десятичной системе.
    Необходимое Вам значение выясняется экспериментальным путем.
    Не ставьте сразу большое значение, постепенно увеличивайте значение пока не найдете оптимальное.
    Например: На одних машинах улучшения в работе системы с программами будут видны при максимальном значении 26, на других же оптимальным значением может оказаться 12.

    25. Отключение выгрузки драйверов режима ядра и системного кода режима ядра из оперативной памяти на диск.

    Если у Вас на компьютере большое количество оперативной памяти, то приложения будут быстрее откликаться на Ваши действия, если драйвера режима ядра и системный код режима ядра будут оставаться в оперативной памяти.

    За данное действие отвечает параметр реестра DisablePagingExecutive, который определяет, могут ли драйвера режима ядра и системный код режима ядра быть выгружены из оперативной памяти на диск, когда они не используется.

    Значение 0 указывает, что при необходимости драйвера режима ядра и системный код режима ядра могут быть выгружены из оперативной памяти на диск, когда они не используется.
    Значение 1 указывает, что драйвера режима ядра и системный код режима ядра должны оставаться в оперативной памяти.

    Для изменения данного параметра сделайте следующее:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
    3) Дважды щелкните на параметре DisablePagingExecutive и введите значение 1.
    4) Закройте редактор реестра и перезапустите компьютер.

    Если же у Вас такой параметр отсутствует, то создайте в данном разделе реестра DWORD-параметр с указанным именем и значением.

    26. Удаление пункта "Восстановить прежнюю версию" из контекстного меню Проводника.

    Чтобы удалить пункт "Восстановить прежнюю версию" из контекстного меню Проводника, сделайте следующее:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\
    3) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
    4) Откройте раздел реестра: HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\
    5) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
    6) Закройте все процессы Проводника и запустите его заново или перезайдите в систему.

    27. Переименование Панели управления в области переходов и на рабочем столе.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра, соответствующий местонахождению Панели управления, которую Вы желаете переименовать.

    Панель управления в Области переходов: HKEY_CLASSES_ROOT\CLSID\{26EE0668-A00A-44D7-9371-BEB064C98683}
    Панель управления на Рабочем столе: HKEY_CLASSES_ROOT\CLSID\{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}

    3) Задайте полный доступ к данному разделу реестра.
    3.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел {длинное число} и выберите пункт Разрешения.
    3.2) Нажмите кнопку Дополнительно.
    3.3) Перейдите на вкладку Владелец.
    3.4) Выберите Ваш аккаунт администратора и нажмите ОК.
    3.5) Вверху выберите группу Администраторы (Administrators).
    3.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

    4) Щелкните правой кнопкой мыши на параметре LocalizedString и выберите пункт Изменить.
    5) Введите любое значение вместо имеющегося, соответствующее названию, которое Вы желаете задать и нажмите ОК.
    6) Закройте редактор реестра и перезагрузите компьютер.

    Примечание: Для восстановления значения по умолчанию измените значение параметра LocalizedString на указанное ниже:

    28. Переименование папки Избранное в области переходов.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}

    3) Задайте полный доступ к данному разделу реестра.
    3.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел {323CA680-C24D-4099-B94D-446DD2D7249E} и выберите пункт Разрешения.
    3.2) Нажмите кнопку Дополнительно.
    3.3) Перейдите на вкладку Владелец.
    3.4) Выберите Ваш аккаунт администратора и нажмите ОК.
    3.5) Вверху выберите группу Администраторы (Administrators).
    3.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

    4) Щелкните правой кнопкой мыши на параметре LocalizedString и выберите пункт Изменить.
    5) Введите любое значение вместо имеющегося, соответствующее названию, которое Вы желаете задать и нажмите ОК.
    6) Закройте редактор реестра и перезагрузите компьютер.

    Примечание: Для восстановления значения по умолчанию измените значение параметра LocalizedString на указанное ниже:

    29. Переименование папки Сеть в области переходов.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}

    3) Задайте полный доступ к данному разделу реестра.
    3.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел {F02C1A0D-BE21-4350-88B0-7367FC96EF3C} и выберите пункт Разрешения.
    3.2) Нажмите кнопку Дополнительно.
    3.3) Перейдите на вкладку Владелец.
    3.4) Выберите Ваш аккаунт администратора и нажмите ОК.
    3.5) Вверху выберите группу Администраторы (Administrators).
    3.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

    4) Щелкните правой кнопкой мыши на параметре LocalizedString и выберите пункт Изменить.
    5) Введите любое значение вместо имеющегося, соответствующее названию, которое Вы желаете задать и нажмите ОК.
    6) Закройте редактор реестра и перезагрузите компьютер.

    Примечание: Для восстановления значения по умолчанию измените значение параметра LocalizedString на указанное ниже:

    30. Изменение иконки Панели управления.

    Вариант 1. Изменение иконки Панели управления для текущего пользователя.

    1) Создайте и примените reg-файл указанного ниже содержания:

    2) Запустите редактор реестра (Win   + R → regedit → ОК)
    3) Откройте раздел реестра, соответствующий местонахождению Панели управления, для которой Вы желаете изменить значок.

    Панель управления в Области переходов:

    Панель управления в меню Пуск и на Рабочем столе:

    4) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите пункт Изменить.
    5) Укажите путь к иконке, которую Вы желаете задать и нажмите ОК.
    Если Вы собираетесь использовать собственную иконку, то Вам потребуется иконка размером 256x256 пикселей, сделанная для Windows 7 и поддерживающая все возможные для отображения размеры.
    Если же Вы собираетесь использовать иконку из имеющихся в Windows, то Вам необходимо указать полный путь к *.exe или dll-файлу в котором содержится иконка и ее номер в данном файле, используя следующий шаблон:

    Например:

    или

    Наиболее простой способ быстро узнать номер значка - это воспользоваться программой IconViewer, которая добавляет дополнительную вкладку Icons в Свойства файла.
    6) Закройте редактор реестра и перезагрузите компьютер.

    Примечание: Для восстановления значения по умолчанию создайте и примените reg-файл указанного ниже содержания:

    Вариант 2. Изменение иконки Панели управления для всех пользователей.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра, соответствующий местонахождению Панели управления, для которой Вы желаете изменить значок.

    Панель управления в Области переходов:

    Панель управления в меню Пуск и на Рабочем столе:

    3) Задайте полный доступ к данному разделу реестра.
    3.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел DefaultIcon и выберите пункт Разрешения.
    3.2) Нажмите кнопку Дополнительно.
    3.3) Перейдите на вкладку Владелец.
    3.4) Выберите Ваш аккаунт администратора и нажмите ОК.
    3.5) Вверху выберите группу Администраторы (Administrators).
    3.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

    4) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите пункт Изменить.
    5) Укажите путь к иконке, которую Вы желаете задать и нажмите ОК.
    Если Вы собираетесь использовать собственную иконку, то Вам потребуется иконка размером 256x256 пикселей, сделанная для Windows 7 и поддерживающая все возможные для отображения размеры.
    Если же Вы собираетесь использовать иконку из имеющихся в Windows, то Вам необходимо указать полный путь к *.exe или dll-файлу в котором содержится иконка и ее номер в данном файле, используя следующий шаблон:

    Например:

    или

    Наиболее простой способ быстро узнать номер значка - это воспользоваться программой IconViewer, которая добавляет дополнительную вкладку Icons в Свойства файла.
    6) Закройте редактор реестра и перезагрузите компьютер.

    Примечание: Для восстановления значения по умолчанию создайте и примените reg-файл указанного ниже содержания:

    31. Изменение иконок элементов в Панели управления при просмотре как Крупные значки/Мелкие значки.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CLASSES_ROOT\CLSID
    3) В соответствии с таблицей ниже, перейдите в раздел соответствующий элементу в Панели управления, значок для которого Вы желаете заменить.

    Таблица 1.

    Русское название элемента | Английское название элемента | Расположение CLSID в реестре
Windows CardSpace | Windows CardSpace | {78CB147A-98EA-4AA6-B0DF-C8681F69341C}\DefaultIcon
Windows SideShow | Windows SideShow | {E95A4861-D57A-4be1-AD0F-35267E261739}\DefaultIcon
Автозапуск | AutoPlay | {9C60DE1E-E5FC-40f4-A487-460851A8D915}\DefaultIcon
Администрирование | Administrative Tools | {D20EA4E1-3957-11d2-A40B-0C5020524153}\DefaultIcon
Архивация и восстановление | Backup and Restore | {B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}\DefaultIcon
Биометрические устройства | Biometric Devices | {0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}\DefaultIcon
Брандмауэр Windows | Windows Firewall | {4026492F-2F69-46B8-B9BF-5654FC07E423}\DefaultIcon
Восстановление | Recovery | {9FE63AFD-59CF-4419-9775-ABCC3849F861}\DefaultIcon
Гаджеты рабочего стола | Desktop Gadgets | {37efd44d-ef8d-41b1-940d-96973a50e9e0}\DefaultIcon
Дата и Время | Date and Time | {E2E7934B-DCE5-43C4-9576-7FE4F75E7480}\DefaultIcon
Датчик расположения и другие датчики | Location and Other Sensors | {E9950154-C418-419e-A90A-20C5287AE24B}\DefaultIcon
Диспетчер устройств | Device Manager | {74246bfc-4c96-11d0-abef-0020af6b0b7a}\DefaultIcon
Диспетчер учетных данных | Credential Manager | {1206F5F1-0569-412C-8FEC-3204630DFB70}\DefaultIcon
Домашняя группа | HomeGroup | {67CA7650-96E6-4FDD-BB43-A8E774F73A57}\DefaultIcon
Защитник Windows | Windows Defender | {D8559EB9-20C0-410E-BEDA-7ED416AECC2A}\DefaultIcon
Звук | Sound | {F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}\DefaultIcon
Значки области уведомлений | Notification Area Icons | {05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}\DefaultIcon
Инфракрасная связь | Infrared | {A0275511-0E86-4ECA-97C2-ECD8F1221D08}\DefaultIcon
Клавиатура | Keyboard | {725BE8F7-668E-4C7B-8F90-46BDB0936430}\DefaultIcon
Мышь | Mouse Properties | {6C8EEC18-8D75-41B2-A177-8831D59D2D50}\DefaultIcon
Параметры индексирования | Indexing Options | {87D66A43-7B11-4A28-9811-C86EE395ACF7}\DefaultIcon
Параметры папок | Folder Options | {6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}\DefaultIcon
Параметры планшетного компьютера | Tablet PC Settings | {80F3F1D5-FECA-45F3-BC32-752C152E456E}\DefaultIcon
Перо и сенсорные устройства | Pen and Touch | {F82DF8F7-8B9F-442E-A48C-818EA735FF9B}\DefaultIcon
Персонализация | Personalization | {ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}\DefaultIcon
Подключения к удаленным рабочим столам и приложениям RemoteApp | RemoteApp and Desktop Connections | {241D7C96-F8BF-4F85-B01F-E2B043341A4B}\DefaultIcon
Приступая к работе | Getting Started | {CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}\DefaultIcon
Программы и компоненты | Programs and Features | {7b81be6a-ce2b-4676-a29e-eb907a5126c5}\DefaultIcon
Программы по умолчанию | Default Programs | {17cd9488-1228-4b2f-88ce-4298e93e0966}\DefaultIcon
Распознавание речи | Speech Recognition | {58E3C745-D971-4081-9034-86E34B30836A}\DefaultIcon
Родительский контроль | Parental Controls | {96AE8D84-A250-4520-95A5-A47A7E3C548B}\DefaultIcon
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | {0DF44EAA-FF21-4412-828E-260A8728E7F1}\DefaultIcon
Свойства обозревателя | Internet Properties | {A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}\DefaultIcon
Система | System | {BB06C0E4-D293-4f75-8A90-CB05B6477EEE}\DefaultIcon
Счетчики и средства производительности | Performance Information and Tools | {78F3955E-3B90-4184-BD14-5397C15F1EFC}\DefaultIcon
Телефон и модем | Phone and Modem | {40419485-C444-4567-851A-2DD7BFA1684D}\DefaultIcon
Управление цветом | Color Management | {B2C761C6-29BC-4f19-9251-E6195265BAF1}\DefaultIcon
Устранение неполадок | Troubleshooting | {C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}\DefaultIcon
Устройства Bluetooth | Bluetooth Devices | {28803F59-3A75-4058-995F-4EE5503B023C}\DefaultIcon
Устройства и принтеры | Devices and Printers | {A8A91A66-3A7D-4424-8D24-04E180695C7A}\DefaultIcon
Учетные записи пользователей | User Accounts | {60632754-c523-4b62-b45c-4172da012619}\DefaultIcon
Центр мобильности Windows | Windows Mobility Center | {5ea4f148-308c-46d7-98a9-49041b1dd468}\DefaultIcon
Центр обновления Windows | Windows Update | {36eef7db-88ad-4e81-ad49-0e313f0c35f8}\DefaultIcon
Центр поддержки | Action Center | {BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}\DefaultIcon
Центр синхронизации | Sync Center | {9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}\DefaultIcon
Центр специальных возможностей | Ease of Access Center | {D555645E-D4F8-4c29-A827-D93C859C4F2A}\DefaultIcon
Центр управления сетями и общим доступом | Network and Sharing Center | {8E908FC9-BECC-40f6-915B-F4CA0E70D03D}\DefaultIcon
Шифрование диска BitLocker | BitLocker Drive Encryption | {D9EF8727-CAC2-4e60-809E-86F80A666C91}\DefaultIcon
Шрифты | Fonts | {BD84B380-8CA2-1069-AB1D-08000948F534}\DefaultIcon
Экран | Display | {C555438B-3C23-4769-A71F-B6D3D9B6053A}\DefaultIcon
Электропитание | Power Options | {025A5937-A6BE-4686-A844-36FE4BEC8B6D}\DefaultIcon
Язык и региональные стандарты | Region and Language | {62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}\DefaultIcon
Русское название элемента | Английское название элемента | Расположение CLSID в реестре

    4) Задайте полный доступ к данному разделу реестра.
    4.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел DefaultIcon и выберите пункт Разрешения.
    4.2) Нажмите кнопку Дополнительно.
    4.3) Перейдите на вкладку Владелец.
    4.4) Выберите Ваш аккаунт администратора и нажмите ОК.
    4.5) Вверху выберите группу Администраторы (Administrators).
    4.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите пункт Изменить.
    6) Укажите путь к иконке, которую Вы желаете задать и нажмите ОК.

    Примечание: Вам потребуются иконки размером 256x256 пикселей, сделанные для Windows 7 и поддерживающие все возможные для отображения размеры.

    Для восстановления иконки по умолчанию измените значение параметра (По умолчанию) на указанное ниже:

    Таблица 2.

    Русское название элемента | Английское название элемента | Значение параметра по умолчанию
Windows CardSpace | Windows Cardspace | %SystemRoot%\System32\icardres.dll,-4096
Windows SideShow | Windows SideShow | %SystemRoot%\System32\AuxiliaryDisplayCpl.dll,-1
Автозапуск | Autoplay | %SystemRoot%\System32\autoplay.dll,-1
Администрирование | Administrative Tools | %SystemRoot%\System32\imageres.dll,-114
Архивация и восстановление | Backup and Restore | %SystemRoot%\System32\sdcpl.dll,-1
Биометрические устройства | Biometric Devices | %SystemRoot%\System32\biocpl.dll,-1
Брандмауэр Windows | Windows Firewall | C:\Windows\system32\FirewallControlPanel.dll,-1
Восстановление | Recovery | %SystemRoot%\System32\imageres.dll,-1022
Гаджеты рабочего стола | Desktop Gadgets | %ProgramFiles%\Windows Sidebar\Sidebar.exe,-100
Дата и Время | Date and Time | %SystemRoot%\System32\timedate.cpl,-50
Датчик расположения и другие датчики | Location and Other Sensors | %SystemRoot%\System32\SensorsCpl.dll,-1
Диспетчер устройств | Device Manager | %SystemRoot%\system32\devmgr.dll,-201
Диспетчер учетных данных | Credential Manager | %SystemRoot%\system32\Vault.dll,-1
Домашняя группа | HomeGroup | %SystemRoot%\System32\imageres.dll,-1013
Защитник Windows | Windows Defender | %ProgramFiles%\Windows Defender\MsMpRes.dll,-103
Звук | Sound | %SystemRoot%\System32\mmsys.cpl,-100
Значки области уведомлений | Notification Area Icons | %SystemRoot%\System32\taskbarcpl.dll,-1
Инфракрасная связь | Infrared | %SystemRoot%\System32\irprops.cpl,-129
Клавиатура | Keyboard | %SystemRoot%\System32\main.cpl,-200
Мышь | Mouse | %SystemRoot%\system32\main.cpl,-100
Параметры индексирования | Indexing Options | %SystemRoot%\System32\srchadmin.dll,-201
Параметры папок | Folder Options | %SystemRoot%\system32\imageres.dll,-166
Параметры планшетного компьютера | Tablet PC Settings | %SystemRoot%\System32\tabletpc.cpl,-10200
Перо и сенсорные устройства | Pen and Touch | %SystemRoot%\System32\tabletpc.cpl,-10201
Персонализация | Personalization | %SystemRoot%\System32\themecpl.dll,-1
Подключения к удаленным рабочим столам и приложениям RemoteApp | RemoteApp and Desktop Connections | %SystemRoot%\System32\tsworkspace.dll
Приступая к работе | Getting Started | %SystemRoot%\branding\shellbrd\shellbrd.dll
Программы и компоненты | Programs and Features | imageres.dll,-87
Программы по умолчанию | Default Programs | %SystemRoot%\System32\imageres.dll,-24
Распознавание речи | Speech Recognition | %SystemRoot%\System32\Speech\SpeechUX\speechuxcpl.dll,-1
Родительский контроль | Parental Controls | %SystemRoot%\System32\wpccpl.dll,-1
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | %SystemRoot%\System32\imageres.dll,-80
Свойства обозревателя | Internet Options | C:\Windows\System32\inetcpl.cpl,-4487
Система | System | %SystemRoot%\System32\imageres.dll,-149
Счетчики и средства производительности | Performance Information and Tools | %SystemRoot%\System32\PerfCenterCPL.dll,-1
Телефон и модем | Phone and Modem | %SystemRoot%\System32\telephon.cpl,-100
Управление цветом | Color Management | %systemroot%\system32\colorcpl.exe,-5
Устранение неполадок | Troubleshooting | %SystemRoot%\System32\DiagCpl.dll,-1
Устройства Bluetooth | Bluetooth Devices | %systemroot%\system32\DevicePairingFolder.dll,-200
Устройства и принтеры | Devices and Printers | %systemroot%\system32\DeviceCenter.dll,-1
Учетные записи пользователей | User Accounts | %SystemRoot%\System32\usercpl.dll,-1
Центр мобильности Windows | Windows Mobility Center | %SystemRoot%\system32\mblctr.exe,0
Центр обновления Windows | Windows Update | %SystemRoot%\system32\wucltux.dll,-1
Центр поддержки | Action Center | %SystemRoot%\System32\ActionCenterCPL.dll,-1
Центр синхронизации | Sync Center | %SystemRoot%\System32\SyncCenter.dll,-1000
Центр специальных возможностей | Ease of Access Center | %SystemRoot%\System32\accessibilitycpl.dll,-1
Центр управления сетями и общим доступом | Network and Sharing Center | %SystemRoot%\System32\netcenter.dll,-1
Шифрование диска BitLocker | BitLocker Drive Encryption | %SystemRoot%\System32\fvecpl.dll,-1
Шрифты | Fonts | %SystemRoot%\System32\fontext.dll
Экран | Display | %SystemRoot%\System32\Display.dll,-1
Электропитание | Power Options | %SystemRoot%\System32\Powercpl.dll,-1
Язык и региональные стандарты | Region and Language | %SystemRoot%\System32\intl.cpl,-200
Русское название элемента | Английское название элемента | Значение параметра по умолчанию

    32. Изменение иконок для элементов в меню Пуск.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CLASSES_ROOT\CLSID
    3) В соответствии с таблицей ниже, откройте раздел соответствующий элементу в меню Пуск, значок для которого Вы желаете заменить.

    Таблица 1.

    Русское название элемента | Английское название элемента | Расположение CLSID в реестре
Администрирование | Administrative Tools | HKEY_CLASSES_ROOT\CLSID\{D20EA4E1-3957-11d2-A40B-0C5020524153}\DefaultIcon
Выполнить | Run | HKEY_CLASSES_ROOT\CLSID\{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}\DefaultIcon
Игры | Games | HKEY_CLASSES_ROOT\CLSID\{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}\DefaultIcon
Компьютер | Computer | HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon
Недавние документы | Recent Items | HKEY_CLASSES_ROOT\CLSID\{0C39A5CF-1A7A-40C8-BA74-8900E6DF5FCD}\DefaultIcon
Панель управления | Control Panel | HKEY_CLASSES_ROOT\CLSID\{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}\DefaultIcon
Подключение к | Connect To | HKEY_CLASSES_ROOT\CLSID\{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}\DefaultIcon
Программы по умолчанию | Default Programs | HKEY_CLASSES_ROOT\CLSID\{E44E5D18-0652-4508-A4E2-8A090067BCB0}\DefaultIcon
Сеть | Network | HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\DefaultIcon
Справка и Поддержка | Help and Support | HKEY_CLASSES_ROOT\CLSID\{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}\DefaultIcon
Устройства и принтеры | Devices and Printers | HKEY_CLASSES_ROOT\CLSID\{A8A91A66-3A7D-4424-8D24-04E180695C7A}\DefaultIcon
Русское название элемента | Английское название элемента | Расположение CLSID в реестре

    4) Задайте полный доступ к данному разделу реестра.
    4.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел DefaultIcon и выберите пункт Разрешения.
    4.2) Нажмите кнопку Дополнительно.
    4.3) Перейдите на вкладку Владелец.
    4.4) Выберите Ваш аккаунт администратора и нажмите ОК.
    4.5) Вверху выберите группу Администраторы (Administrators).
    4.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

    5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите пункт Изменить.
    6) Укажите путь к иконке, которую Вы желаете задать и нажмите ОК.

    Примечание: Вам потребуются иконки размером 256x256 пикселей, сделанные для Windows 7 и поддерживающие все возможные для отображения размеры.

    Для восстановления иконки по умолчанию измените значение параметра (По умолчанию) на указанное ниже:

    Таблица 2.

    Русское название элемента | Английское название элемента | Расположение CLSID в реестре
Администрирование | Administrative Tools | %SystemRoot%\system32\imageres.dll,-114
Выполнить | Run | %SystemRoot%\system32\imageres.dll,-100
Игры | Games | %SystemRoot%\system32\imageres.dll,-14
Компьютер | Computer | %SystemRoot%\system32\imageres.dll,-109
Недавние документы | Recent Items | %SystemRoot%\system32\imageres.dll,-117
Панель управления | Control Panel | %SystemRoot%\system32\imageres.dll,-27
Подключение к | Connect To | %SystemRoot%\system32\imageres.dll,-171
Программы по умолчанию | Default Programs | %SystemRoot%\system32\imageres.dll,-24
Сеть | Network | %SystemRoot%\system32\imageres.dll,-25
Справка и Поддержка | Help and Support | %SystemRoot%\System32\imageres.dll,-99
Устройства и принтеры | Devices and Printers | %systemroot%\system32\DeviceCenter.dll,-1
Русское название элемента | Английское название элемента | Расположение CLSID в реестре

    33. Добавление подменю "Запустить с приоритетом" в контекстное меню exe-файлов.

    Если Вы желаете запускать программы с различным уровнем приоритета, то Вы можете добавить подменю Запустить с приоритетом в контекстное меню exe-файлов.
    Для использования данной возможности Вы должны быть администратором компьютера и у Вас должен быть отключен Контроль Учетных записей (UAC).
    Иногда, для некоторых программ изменение приоритета может не действовать.
    Для отображения данного пункта в контекстном меню Проводника Вам достаточно нажать правой кнопкой мыши на exe-файле.
    Для отображения данного пункта в контекстном меню элементов меню Пуск или элементов, закрепленных на Панели задач, Вам необходимо удерживать клавишу ⇑ Shift, при нажатии правой кнопкой мыши на файле.

    Чтобы добавить указанное подменю, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить указанное подменю, создайте и примените reg-файл указанного ниже содержания.

    34. Добавление подменю "Запустить на процессоре" в контекстное меню exe-файлов.

    Если Вы желаете запускать программы, используя не все ядра процессора одновременно, а используя какое-либо заданное ядро, то Вы можете добавить подменю Запустить на процессоре в контекстное меню exe-файлов.
    Для использования данной возможности Вы должны быть администратором компьютера и у Вас должен быть отключен Контроль Учетных записей (UAC).
    Иногда, для некоторых программ указание ядра процессора может не действовать.
    Для отображения данного пункта в контекстном меню Проводника Вам достаточно нажать правой кнопкой мыши на exe-файле.
    Для отображения данного пункта в контекстном меню элементов меню Пуск или элементов, закрепленных на Панели задач, Вам необходимо удерживать клавишу ⇑ Shift, при нажатии правой кнопкой мыши на файле.

    1) Уточните количество ядер Вашего процессора 2, 3, 4, 6, 8 или 12.
    1.1) Запустите Диспетчер задач Windows (Ctrl + ⇑ Shift + Esc)
    1.2) Перейдите на вкладку Быстродействие.
    Количество ядер процессора будет соответствовать - количеству столбцов в разделе Хронология загрузки ЦП.

    2) Создайте и примените reg-файл указанного ниже содержания.

    Так как в системе CPU0 соответствует 1 столбцу (ядру процессора), CPU1 соответствует 2 столбцу (ядру процессора), ..., CPU11 соответствует 12 столбцу (ядру процессора), то

    Если у Вас 12 столбцов (ядер процессора), скопируйте весь текст.

    Если у Вас 8 столбцов (ядер процессора), скопируйте текст до строки [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\shell\CPU8Affinity].
    А в параметре SubCommands оставьте только значения CPU0Affinity;CPU1Affinity;CPU2Affinity;CPU3Affinity;CPU4Affinity;CPU5Affinity;CPU6Affinity;CPU7Affinity;

    Если у Вас 4 столбца (ядер процессора), скопируйте текст до строки [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\shell\CPU4Affinity].
    А в параметре SubCommands оставьте только значения CPU0Affinity;CPU1Affinity;CPU2Affinity;CPU3Affinity;

    Чтобы удалить указанное подменю, создайте и примените reg-файл указанного ниже содержания.

    Для информации:
    По своему желанию Вы также можете добавить в меню другие значения в контекстное меню, для этого Вам необходимо Вычислить значение параметра /affinity.
    Принцип вычисления его значения следующий:

    1) Пишите в обратном порядке количество ядер Вашего процессора:
    Например у Вас их восемь.

    ЦП 7 ЦП 6 ЦП 5 ЦП 4 ЦП 3 ЦП 2 ЦП 1 ЦП 0

    2) Снизу пишите желаемое состояние запуска для каждого ядра.

    0 - выключено
    1 - включено

    Например:

    ЦП 7 | ЦП 6 | ЦП 5 | ЦП 4 | ЦП 3 | ЦП 2 | ЦП 1 | ЦП 0
0 | 1 | 1 | 0 | 1 | 1 | 0 | 1

    В данном примере для запуска приложения будут использованы ядра: ЦП 0, ЦП 2, ЦП 3, ЦП 5, ЦП 6, а ядра ЦП 1, ЦП 4, ЦП 7 использоваться не будут.

    3) Запускаете калькулятор и в режиме Программист переводите получившееся у Вас число из двоичной системы (Bin) в десятичную (Dec)

    Например:

    1101101 = 109

    4) А в reg-файле дописываете строки

    35. Добавление в контекстное меню BAT, CMD, LOG, REG, TXT, VBS файлов всплывающего меню Копировать в буфер обмена.

    Если Вы желаете скопировать в буфер обмена содержимое BAT, CMD, LOG, REG, TXT или VBS файла, не открывая его, то Вы можете добавить в контекстное меню для данных файлов подменю Копировать в буфер обмена.

    Чтобы добавить всплывающее меню Копировать в буфер обмена с возможностью выбора кодировки, создайте и примените reg-файл указанного ниже содержания.

    Чтобы удалить данное контекстное меню создайте и примените reg-файл указанного ниже содержания.

    Удаление и добавление программ из списка в окне "Выбор программы" (Открыть с помощью).

    При щелчке правой кнопкой мыши на многих файлах, можно использовать команду Открыть с помощью, чтобы выбрать программу для открытия файла.
    Каждая используемая Вами программа, независимо от того, удалось ли ей открыть указанный Вами файл или нет, добавляется в список отображаемый в окне Выбор программы для данного типа файлов.
    Например, если Вы выберите Paint (mspain.exe) в диалоговом окне Выбор программы, при открытии текстового документа (файл с расширением .txt), программа Paint сохранится в списке Выбор программы для всех текстовых документов, несмотря на то, что используя Paint невозможно открыть текстовые документы.
    Чтобы удалить какую-либо программу из списка Выбор программы, воспользуйтесь предложенным ниже решением.

    Для удаления какой-либо программы из списка Рекомендуемые программы в окне Выбор программы для отдельного типа файла:

    1) Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
    2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.extension\OpenWithList
    где .extension - расширение файла для типов файлов, у которых вы желаете очистить список Открыть с помощью.
    3) Удалите все значения в данном разделе реестра.

    Для удаления какой-либо программы из списка Другие программы в окне Выбор программы:

    1) Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
    2) Откройте в реестре раздел: HKEY_CLASSES_ROOT\Applications
    3) Удалите подраздел, отвечающий за Вашу программу. Он будет иметь название идентичное исполняемому файлу Вашей программы.

    Для добавления какой-либо программы в список Другие программы в окне Выбор программы, создайте и примените указанный ниже reg-файл.

    Укажите вместо ВашаПрограмма - имя исполняемого файла программы.
    Укажите между @="\" и \" %1" путь к исполняемому файлу программы.
    При указании в значение параметра пути к файлу или папке используйте два обратных слеша.

    Пример:

    Для восстановления программ используемых по умолчанию (без удаления уже имеющихся сторонних программ) в списке Другие программы в окне Выбор программы, скачайте и примените reg-файл из архива:
    Open_with_all_defaults.zip

    Также для работы со списком программ окна Выбор программы (Открыть с помощью) Вы можете скачать программу OpenWithView.

    37. Добавление каскадного меню "Сжатие до реального размера" в контекстное меню файлов и папок.

    Если Вы желаете сжать занимаемое папкой или файлом место на Вашем диске до реального размера, то Вы можете добавить для этого специальное всплывающее меню в контекстное меню файлов и папок.

    Чтобы добавить каскадное меню Сжатие до реального размера, создайте и примените указанный ниже reg-файл.

    Чтобы удалить каскадное меню Сжатие до реального размера, создайте и примените указанный ниже reg-файл.

    38. Добавление каскадных меню Панель управления, Администрирование, Стандартные, Служебные и Специальные возможности в контекстное меню рабочего стола.

    Для добавления меню Панель управления в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.
    Ввиду ограничения системой количества разрешенных пунктов для использования в меню, данное меню разделено на три части.

    Для удаления меню Панель управления из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Для добавления меню Администрирование в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Для удаления меню Администрирование из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Для добавления меню Стандартные в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Для удаления меню Стандартные из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Для добавления меню Служебные в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Для удаления меню Служебные из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Для добавления меню Специальные возможности в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Для удаления меню Специальные возможности из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

    Также Вы можете скачать архив FFSMTDM.zip с указанными выше файлами и применить готовые reg-файлы:

    Add_ControlPanel.reg - Добавить каскадное меню Панель управления в контекстное меню рабочего стола.
    Remove_ControlPanel.reg - Удалить каскадное меню Панель управления из контекстного меню рабочего стола.

    Add_Administrative_Tools.reg - Добавить каскадное меню Администрирование в контекстное меню рабочего стола.
    Remove_Administrative_Tools.reg - Удалить каскадное меню Администрирование из контекстного меню рабочего стола.

    Add_Accessories.reg - Добавить каскадное меню Стандартные в контекстное меню рабочего стола.
    Remove_Accessories.reg - Удалить каскадное меню Стандартные из контекстного меню рабочего стола.

    Add_System_Tools.reg - Добавить каскадное меню Служебные в контекстное меню рабочего стола.
    Remove_System_Tools.reg - Удалить каскадное меню Служебные из контекстного меню рабочего стола.

    Add_Ease_of_Access.reg - Добавить каскадное меню Специальные возможности в контекстное меню рабочего стола.
    Remove_Ease_of_Access.reg - Удалить каскадное меню Специальные возможности из контекстного меню рабочего стола.

    39. Добавление пункта "Очистить корзину без подтверждения" в контекстное меню Корзины.

    Если Вы желаете очищать Корзину в Вашей операционной системе без всплывающего сообщения о подтверждении удаления, то Вы можете добавить для данного действия отдельный пункт в контекстное меню Корзины.

    1) Скачайте программу NirCmd с сайта http://www.nirsoft.net/utils/nircmd.html
    2) Распакуйте архив и переместите файл NirCmd.exe в папку C:\Windows\System32
    3) Создайте и примените reg-файл указанного ниже содержания:

    Твики Реестра - Устройства и Сети.

    1. Автоматическое VPN-подключение к интернет при запуске Windows (реестр).

    1) Создайте ваше VPN-подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
    2) Запустите редактор реестра (Win   + R → regedit → ОК)
    3) Откройте необходимый раздел реестра:

    (если хотите сделать автозапуск только для текущего пользователя) или

    (если хотите сделать автозапуск для всех пользователей)
    В этой ветке создайте "строковый параметр" (правой кнопкой мыши → «Создать» → «строковый параметр») с произвольным именем.
    4) В качестве значения созданного параметра внесите строку вида:

    5) Закройте реестр и перезагрузите компьютер.

    2. Конвертирование reg-файлов в *.inf формат из контекстного меню, с помощью утилиты.

    1) Скачайте утилиту Reg2Inf
    2) Скопируйте её в C:\Windows\System32
    3) Создайте и примените reg-файл следующего содержания:

    В контекстное меню reg-файлов добавится пункт reg2inf при нажатии которого созданный Вами reg-файл переконвертируется в inf-файл. Например, файл test.reg переконвертируется в test.reg.inf

    3. Включение клавиш-индикаторов Num Lock, Caps Lock, Scroll Lock при загрузке.

    Если у Вас при входе в систему выключен переключатель клавиатуры Num Lock, то для его включения сделайте следующее.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_CURRENT_USER\Control Panel\Keyboard
    3) Щелкните на параметре InitialKeyboardIndicators правой кнопкой мыши и нажмите Изменить.
    4) Выберите и установите необходимое Вам значение.

    0 – все переключатели выключены.
    1 – Caps Lock включен.
    2 – Num Lock включен.
    3 – Caps Lock и Num Lock включены.
    4 – Scroll Lock включен.
    5 – Caps Lock и Scroll Lock включены.
    6 – Num Lock и Scroll Lock включены.
    7 – Caps Lock, Num Lock и Scroll Lock включены.

    Если же Вам необходимо изменить состояние клавиш-индикаторов до входа в систему, в экране приветствия, то для управления ими измените значение параметра InitialKeyboardIndicators в разделе HKEY_USERS\.DEFAULT\Control Panel\Keyboard

    4. Отмена автозапуска для носителей и устройств.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
    3) Создайте параметр DWORD с именем NoDriveTypeAutoRun

    Допустимые значения ключа:

    0x1 - отключить автозапуск на приводах неизвестных типов
    0x4 - отключить автозапуск съемных устройств
    0x8 - отключить автозапуск НЕсъемных устройств
    0x10 - отключить автозапуск сетевых дисков
    0x20 - отключить автозапуск CD-приводов
    0x40 - отключить автозапуск RAM-дисков
    0x80 - отключить автозапуск на приводах неизвестных типов
    0xFF - отключить автозапуск вообще всех дисков.

    Для информации: параметр NoDriveTypeAutoRun автоматически добавляется в реестр при установке программы VMware Workstation, используемой для создания виртуальной машины.

    Помимо указанных Выше действий, Вы можете также запретить обработку файла autorun.inf.
    Для этого создайте и примените reg-файл следующего содержания:

    Данный параметр подменяет содержимое файла autorun.inf значением из реестра, которое нарочно задаётся пустым/неверным.
    Это приводит к тому, что если на диске и есть файл autorun.inf, то он воспринимается как пустой.

    5. Уменьшение фрагментируемости больших файлов на диске.

    Для того чтобы операционная система при записи файла на диск сначала нашла для него наиболее подходящее по размеру место и поместила его туда, как можно меньше дробя на части сделайте следующее:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
    3) Создайте DWORD-параметр ContigFileAllocSize
    4) Щелкните на нем правой кнопкой мыши и выберите Изменить.
    5) Установите значение 00000200 и нажмите ОК

    Данный параметр определяет максимальный размер нефрагментируемого блока данных на диске. При желании размер такого блока можно еще увеличить. Данная настройка может быть очень полезной при работе с мультимедиа (уменьшается нагрузка на диск и процессор при записи и воспроизведении видео или звуковых файлов).
    Эта настройка полезна тем, у кого много файлов большого размера, при большом количестве маленьких файлов - она становится менее актуальной.

    6. Изменение состояния встроенного динамика персонального компьютера.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_CURRENT_USER\Control Panel\Sound
    3) Измените значение параметра Beep на "No" чтобы отключить и на "Yes" чтобы включить.

    Также Вы можете включить/отключить его в Диспетчере устройств:

    1) Откройте меню Пуск → Панель управления и запустите Диспетчер устройств
    2) В меню Вид установите флажок на Показать скрытые устройства
    3) Откройте Драйверы несамонастраиваемых устройств
    4) Щелкните правой кнопкой мыши на Beep и выберите пункт Свойства
    5) Перейдите на вкладку Драйвер и установите тип автозагрузки на Отключено чтобы отключить и на Авто чтобы включить.
    6) Для изменения текущего состояния нажмите на Остановить чтобы отключить и на Запустить чтобы включить.
    7) Нажмите кнопку ОК для применения настроек.

    7. Переназначение гнезд звуковой карты Realtek используя реестр.

    На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
    Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
    Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

    1) Установите драйвера звуковой карты
    2) Запустите редактор реестра (Win+К → regedit → ОК)
    3) Пройдите к папке

    4) Откройте папку Drv6278_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
    5) Создайте двоичный параметр (Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

    Наиболее часто номера пинов соответствуют указанным ниже значениям.
    Иногда, после установки нового драйвера, номер пина может изменит©. Например: с Pin04 на Pin17.
    Для определения номера пина, выньте необходимый Вам штекер из гнезда и вставьте его заново. Данное действие приведет к созданию пина с необходимым Вам номером в разделе реестра:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\DrvXXXX_DevType_XXXX_SSXXXXXXXX

    Имя (вставлять без кавычек):

    "Pin01" или "Pin14" = Заднее зеленое гнездо
    "Pin02" или "Pin15" = Заднее черное гнездо
    "Pin03" или "Pin16" = Заднее коричневое гнездо
    "Pin04" или "Pin17" = Заднее серое гнездо
    "Pin05" или "Pin18" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
    "Pin07" или "Pin1a" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

    "Pin06" или "Pin19" = Переднее розовое гнездо
    "Pin08" или "Pin1b" = Переднее зеленое гнездо

    Значение (вставлять без кавычек):

    "00 00 00 00" = Линейный вход
    "01 00 00 00" = Микрофон
    "02 00 00 00" = Наушники
    "04 00 00 00" = Передние динамики
    "05 00 00 00" = Тыловые динамики
    "06 00 00 00" = Центральный канал/Сабвуфер
    "07 00 00 00" = Боковые динамики

    Если у Вас после перезагрузки компьютера сбрасываются настройки, то сразу после изменения настроек установите значение параметра ChannelConfig равным 00 00 00 00

    Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

    Drv6278_DevType_0888_SS10438357 - на версию вашего драйвера
    (имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
    Pin04 - на любое значение из списка Имя
    hex:02,00,00,00 - на любое значение из списка Значение (просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики

    8. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

    1) Откройте Редактор групповой локальной политики (Win   + R → gpedit.msc → ОК)
    2) Перейдите в раздел Конфигурация пользователя\Административные шаблоны\Панель управления.
    3) Выберите команду Скрыть указанные элементы панели управления
    4) Установите переключатель в значение Включить.
    5) Нажмите на кнопку Показать.
    6) Добавьте новую запись: Microsoft.DevicesAndPrinters и нажмите ОК.
    7) Запустите редактор реестра (Win   + R → regedit.exe → ОК).
    8) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
    9) Создайте в ней новый раздел {2227a280-3aea-1069-a2de-08002b30309d}.
    10) Присвойте параметру По умолчанию значение - Принтеры (Printers).

    Данную папку Вы сможете увидеть в Панели управления в контекстном меню Пуск, если у Вас установлено значение "Отображать как меню" или при просмотре полного списка всех элементов при её открытии.

    9. Удаление цифры при пересоздании адаптера сети в Диспетчере устройств.

    Вариант 1

    1) Удалите драйвер сетевого адаптера
    2) В ветке реестра

    установите значение адаптера сети на 0.
    3) Создайте драйвер сетевого адаптера

    Вариант 2

    1) Удалите драйвер сетевого адаптера
    2) В ветке реестра

    удалите ваш сетевой адаптер.
    3) Создайте драйвер сетевого адаптера.

    10. Отключение или переназначение клавишы Caps Lock.

    Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра.
    Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра

    Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

    Клавиша Caps Lock будет выполнять действие клавиши Ctrl.

    Клавиша Caps Lock будет выполнять действие клавиши ⇑ Shift.

    Отключает Caps Lock и переназначает действие клавиши Scroll
    Lock     на выполнение Caps Lock.

    Отключает клавишу Caps Lock.

    Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)

    11. Отключение USB порта после Безопасного извлечения устройства.

    Если Вы присоединили USB-устройство к компьютеру с запущенной Windows 7, а затем Отключаете устройство в "Диспетчере устройств" или в "Безопасное Извлечение устройств и дисков", используя иконку в системном трее, то Вы можете наблюдать один из следующих симптомов:
  • USB-устройство показывает продолжающееся признаки яњтельности (такие, как остающийся гореть LED-индикатор)
  • USB-устройство продолжает получать USB-пакеты и продолжает потреблять энергию соответствующую состоянию активного устройства.
  • Физическое отсоединение Отключенного или Безопасно Удаленного USB-устройства может, в некоторых случаях, вызывать ошибку в активной передаче на другое USB-устройство.

    • Чтобы исправить данную ошибку Вам необходимо сделать следующее:

    Для определенного устройства.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags
    3) Откройте в данном разделе подраздел соответствующий, подключенному к Вашему компьютеру USB-устройству.
    4) Если неоходимого Вам раздела нет, то создайте его.

    4.1) Щелкните правой кнопкой мыши на usbflags
    4.2) Выберите пункты Создать → Раздел
    4.3) Задайте имя нового раздела в следующем виде: vvvvpppprrrr
    где vvvv - 4-значный шестнадцатеричный номер, обозначающий Vendor ID устройства
    pppp - 4-значный шестнадцатеричный номер, обозначающий Product ID устройства
    rrrr - 4-значный бинарно-закодированный десятиричный номер, обозначающий Revision number устройства

    Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
    4.3.1) Откройте Пуск → Панель управления → Диспетчер устройств
    4.3.2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
    4.3.3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.

    5) Создайте в открытом разделе HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\usbflags\vvvvpppprrrr параметр DWORD (32 бита) с именем DisableOnSoftRemove
    6) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    7) В текстовом поле Значение: введите 1 и нажмите ОК.

    Для всех устройств:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\usbhub\hubg
    Если данного раздела нет, то создайте его.
    3) Щелкните правой кнопкой мыши и создайте параметр DWORD (32 бита) с именем DisableOnSoftRemove
    4) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    5) В текстовом поле Значение: введите 1 и нажмите ОК.

    12. Отключение сообщения: "Хотите выполнить проверку и исправление ошибок на ..." для съемных дисков.

    Вариант 1

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\AutoCheckSelect
    3) Щелкните на параметре CheckedValue правой кнопкой мыши и нажмите Изменить.
    4) Установите значение 0 и нажмите ОК

    Вариант 2

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
    3) Щелкните на параметре BootExecute правой кнопкой мыши и нажмите Изменить.
    4) По умолчанию значение данного параметра должно быть autocheck autochk *.
    * означает, что все диски выбраны для проверки. Чтобы добавить исключение проверки яў определенного диска, добавьте перед звездочкой параметр /K:<Буква_диска>. Параметр /K отключает проверку диска при его автозапуске. Например для съемного диска H: значение ключа BootExecute примет вид:

    Если Вы желаете добавить несколько дисков в исключения (например: H и I диски), то значение ключа BootExecute примет вид:

    Вариант 3

    1) Откройте меню Пуск
    2) Введите в диалоговом окне Выполнить (Win   + R) или в строке поиска команду msconfig и нажмите Enter ↵.
    3) Перейдите на вкладку Службы и уберите флажок: Определение оборудования оболочки
    4) Откройте меню Пуск
    5) Введите в диалоговом окне Выполнить (Win   + R) или в строке поиска команду services.msc и нажмите Enter ↵.
    6) В открывшейся оснастке Службы щелкаете правой кнопкой мыши на Определение оборудования оболочки и выбираете пункт Свойства
    7) Выбираете Тип запуска - Отключена и нажимаете кнопку Остановить
    8) Нажимаете ОК.

    Данное действие также отключит автозагрузку со съемных носителей.

    13. Отключение проверки системой наличия подключения к Интернет используя функцию NCSI и изменение ее параметров.

    В Windows 7 есть функция Network Connectivity Status Indicator (NCSI) означающая в переводе Индикатор Статуса Сетевого Подключения. За ее работу отвечает служба «Служба сведений о подключенных сетях» (Network Awareness). Одной из задач данной функции является определение определение возможности выхода компьютера в Интернет.

    Порядок определения подключения следующий:

    1) Windows пытается открыть текстовый файл http://www.msftncsi.com/ncsi.txt
    Указанный файл содержит строку Microsoft NCSI. Ожидаемый ответ от сервера – заголовок 200 ОК и данная строка.
    2) Windows проверяет работоспособоность DNS-сервера.
    Для этого NCSI пытается определить IP-адрес хоста dns.msftncsi.com. Ожидаемое значение – 131.107.255.255.

    В результате:

    Если оба шага успешно завершены – система рапортует о наличии соединения с Интернет.
    Если файл ncsi.txt недоступен, а dns.msftncsi.com определяется с другим адресом, либо его IP невозможно установить – система сообщает о недоступности подключения к Интернет.
    Если файл ncsi.txt недоступен, но dns.msftncsi.com определяется корректно – система уведомляет пользователя о возможной необходимости аутентификации посредством браузера.

    Веб сервер, установленный на сайте www.msftncsi.com хранит в логах все IP-адреса, c которых был запрошен файл ncsi.txt. Согласно заявлению Microsoft эти данные не используются для установления личности пользователя, с компьютера которого пришел запрос.

    Изменение настроек NCSI.

    Для изменения адреса веб-сервера, имени и содержимого файла, запрашиваемого NCSI, а также имени и IP-адреса хоста, используемого для проверки DNS выполните следующие действия:

    1) Запустите редактор реестра (Win   + R → regedit → OK)
    2) Откройте раздел: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet
    3) Измените значения указанных ниже параметров данного раздела на необходимые Вам.

    ActiveDnsProbeContent – IP-адрес хоста для проверки DNS
    ActiveDnsProbeHost – имя хоста для проверки DNS
    ActiveWebProbeHost – адрес веб-сайта, на котором размещен файл для проверки наличия подключения к Internet
    ActiveWebProbePath – путь к файлу проверки
    ActiveWebProbeContent – содержимое файла проверки

    Например, Вы размещаете на www.yoursite.com файл test.txt с содержимым Internet Check и изменяете значения на следующие:

    ActiveWebProbeHost на www.yoursite.com
    ActiveWebProbePath на test.txt
    ActiveWebProbeContent на Internet Check

    Отключение функции NCSI.

    1) Запустите редактор реестра (Win   + R → regedit → OK)
    2) Откройте раздел: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet
    3) Измените значение параметра EnableActiveProbing на 0
    4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator
    3) Создайте параметр DWORD, переименуйте его в NoActiveProbe и измените значение на 1

    Также Вы можете создать и применить reg-файл, указанного ниже содержания:

    14. Увеличение скорости передачи данных для USB-носителей.

    У Microsoft существует пакет исправлений для Windows 7, позволяющий изменить максимальный размер передачи данных для USB-носителей с 64 Кб до 2 Мб и немного увеличить скорость работы носитЈ.
    Чтобы воспользоваться этой возможностью, выполните указанные ниже действия.

    1) Скачайте пакет исправлений:

    1.1) Перейдите по ссылке на сайт Microsoft: http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2581464&kbln=ru-ru
    1.2) Выберите исправления ссылки яў которых Вы желаете получить на e-mail.
    1.3) Укажите e-mail для получения ссылок для скачивания, введите набор символов с картинки и нажмите кнопку Запросить исправление.
    1.4) Скачайте файл по полученной ссылке и распакуйте.

    Альтернативная ссылка на архив с уже распакованными версиями пакетов исправлений для обеих разрядностей: KB2581464.zip

    2) Установите обновление Windows6.1-KB2581464-x86.msu или Windows6.1-KB2581464-x64.msu в зависимости от разрядности Windows.

    3) Запустите редактор реестра (Win   + R → regedit → ОК)
    4) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbstor
    5) Создайте в нем раздел VVVVPPPP

    где VVVV - 4-значный шестнадцатеричный номер, обозначающий Vendor ID устройства
    PPPP - 4-значный шестнадцатеричный номер, обозначающий Product ID устройства

    Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
    5.1) Откройте Пуск → Панель управления → Диспетчер устройств
    5.2) Откройте ветку Контроллеры USB
    5.3) Нажмите правой кнопкой мыши на необходимом Вам устройстве (Например: Запоминающее устройство для USB) и выберите пункт Свойства
    5.4) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.

    Например: если у Вас указан ИД оборудования: USB\VID_090C&PID_2000, то Вам необходимо создать раздел 090С2000.

    6) Откройте созданный Вами новый раздел (В моем примере: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbstor\090С2000)
    7) Создайте в нем DWORD-параметр с названием MaximumTransferLength
    8) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
    9) В поле Значение укажите значение в диапазоне от 64 КБ до 2 МБ.
    Например, выберите Десятичное число и введите значение в диапазоне от 65535 (64 КБ) до 2097120 (2 МБ), в соответствиями с рекомендациями Microsoft.
    Либо в диапазоне от 65536 (64 КБ) до 2097152 (2 МБ), в соответствиями с точным соответствием данных значений байтовому эквиваленту.
    10) Нажмите кнопку ОК и перезагрузите компьютер.

    15. Изменение иконки яў *.url файлов, при использовании браузера Internet Explorer по умолчанию.

    Если в качестве браузера по умолчанию в системе Вы используете Internet Explorer, и желаете заменить иконку используемую в системе для *.url файлов, являющим© ярлыками интернета в системе, то Вам необходимо сделать следующее:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Открывая по очереди каждый из указанных ниже разделов реестра измените значение параметра (По умолчанию)

    HKEY_CLASSES_ROOT\ftp\DefaultIcon
    HKEY_CLASSES_ROOT\http\DefaultIcon
    HKEY_CLASSES_ROOT\https\DefaultIcon

    Изначальное значение данного параметра равно: C:\Windows\System32\url.dll,0

    16. Удаление и восстановление вкладок в оснастке Свойства обозревателя из Панели управления.

    Чтобы удалить вкладку Общие в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить вкладку Общие в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы удалить вкладку Безопасность в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить вкладку Безопасность в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы удалить вкладку Конфиденциальность в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить вкладку Конфиденциальность в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы удалить вкладку Содержание в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить вкладку Содержание в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы удалить вкладку Подключения в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить вкладку Подключения в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы удалить вкладку Программы в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить вкладку Программы в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы удалить вкладку Дополнительно в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить вкладку Дополнительно в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

    17. Удаление и восстановление возможности изменения масштаба в Internet Explorer.

    Чтобы удалить возможность изменения масштаба в Internet Explorer, создайте и примените указанный ниже reg-файл.

    Чтобы восстановить возможность изменения масштаба в Internet Explorer, создайте и примените указанный ниже reg-файл.

    18. Добавление в контекстное меню рабочего стола пункта "Безопасное извлечение устройства".

    Чтобы добавить в контекстное меню рабочего стола пункт Безопасное извлечение устройства, создайте и примените указанный ниже reg-файл.

    Чтобы удалить из контекстного меню рабочего стола пункт Безопасное извлечение устройства, создайте и примените указанный ниже reg-файл.

    19. Настройка отображения букв дисков в папке Компьютер.

    Чтобы настроить отображение дисков в папке Компьютер, создайте и примените reg-файл указанного ниже содержания:

    В зависимости от того, какую цифру Вы поставите вместо последней цифры в значении параметра ShowDriveLettersFirst, Вы сможете изменить порядок отображения буквы у диска.

    0 | Отображать буквы всех дисков после их описания. (По умолчанию)
1 | Отображать буквы сетевых дисков перед их описанием, а буквы локальных дисков после их описания.
2 | Не отображать буквы дисков
4 | Отображать буквы всех дисков перед их описанием.

    20. Настройка параметров, отвечающих за установку драйверов.

    При установке в систему нового оборудования происходит установка необходимых для него драйверов.
    Используя реестр Вы можете настроить параметры, влияющие на данный процесс.
    Большинство из них изначально отсутствуют в реестре и Вам необходимо будет их создать.

    Настройка параметров, отвечающих за поиск драйверов.

    Если операционная система находит драйвер для нового оборудования среди драйверов, поставляемых с Windows, то установка драйвера выполняется автоматачески.
    Иначе операционная система предложит Вам либо указать путь к драйверу, либо поискать новый драйвер в Интернете на сайте Microsoft.
    Для настройки параметров, влияющих на поиск драйверов, выполните указанные ниже действия.

    1) Откройте Пуск → Выполнить (Win   + R)
    2) Введите необходимую Вам команду из предложенных ниже и нажмите Enter ↵.

    Параметр DontPromptForWindowsUpdate может иметь следующие значения:

    0x00000000 — отображать запрос поиска новых драйверов на веб-узле корпорации Microsoft.
    0x00000001 — не отображать запрос поиска новых драйверов на веб-узле корпорации Microsoft.

    Параметр DontSearchCD может иметь следующие значения:

    0x00000000 — разрешить поиск новых драйверов на компакт-дисках.
    0x00000001 — запретить поиск новых драйверов на компакт-дисках.

    Параметр DontSearchWindowsUpdate может иметь следующие значения:

    0x00000000 — разрешить поиск новых драйверов на веб-узле корпорации Microsoft.
    0x00000001 — запретить поиск новых драйверов на веб-узле корпорации Microsoft.

    Параметр SearchOrderConfig может иметь следующие значения:

    0x00000000 — не искать в Центре обновления Windows.
    0x00000001 — искать в Центре обновления Windows в первую очередь.
    0x00000002 — искать в Центре обновления Windows в последнюю очередь.

    Настройка установки драйверов, не подписанных корпорацией Microsoft.

    1) Откройте Пуск → Выполнить (Win   + R)
    2) Введите необходимую Вам команду из предложенных ниже и нажмите Enter ↵.

    Параметр AllSigningEqual может иметь следующие значения:

    0x00000000 — отдавать предпочтение драйверам, подписанным корпорацией Microsoft.
    0x00000001 — не различать драйверы, подписанные Microsoft и драйверы с подписью других производителей.

    Параметр BehaviorOnFailedVerify может иметь следующие значения:

    0x00000000 — установка драйверов без цифровой подписи Microsoft разрешена.
    0x00000001 — при установке драйверов без цифровой подписи Microsoft будет выдаваться предупреждение.
    0x00000002 — установка драйверов без цифровой подписи Microsoft запрещена.

    Настройка параметров, влияющих на процесс установки драйверов устройств.

    Чтобы настроить данную группу параметров, воспользуйтесь предложенным ниже решением.

    1) Откройте Пуск → Выполнить (Win   + R)
    2) Введите необходимую Вам команду из предложенных ниже и нажмите Enter ↵.

    Параметр InstallTimeout указывает максимально возможное время установки нового оборудования (в секундах). По истечении данного времени либо устройство должно быть установлено, либо установка будет прекращена и операционная система выдаст сообщение об ошибке. По умолчанию устройство может устанавливаться не более пяти минут, что соответствует 300 секундам или значению 0x0000012с.

    Параметр DisableSendGenericDriverNotFoundToWER может иметь следующие значения:

    0x00000000 — отправлять в Microsoft отчет об ошибке, если драйвер устройства запрашивает дополнительное программное обеспечение в ходе установки.
    0x00000001 — не отправлять в Microsoft отчет об, если драйвер устройства запрашивает дополнительное программное обеспечение в ходе установки.

    Параметр DisableSendRequestAdditionalSoftwareToWER может иметь следующие значения:

    0x00000000 — отправлять в Microsoft отчет об ошибке при установке универсального драйвера операционной системы (вместо драйвера производитЈ).
    0x00000001 — не отправлять в Microsoft отчет об ошибке при установке универсального драйвера операционной системы (вместо драйвера производитЈ).

    Параметр DisableBalloonTips может иметь следующие значения:

    0x00000000 — отображать уведомление "Найдено новое оборудование" в области уведомлений.
    0x00000001 — не отображать уведомление "Найдено новое оборудование" в области уведомлений.

    Параметр DisableSystemRestore может иметь следующие значения:

    0x00000000 — создавать точку восстановления при установке нового драйвера устройства.
    0x00000001 — не создавать точку восстановления при установке нового драйвера устройства.

    Параметр DenyRemovableDevices может иметь следующие значения:

    0x00000000 — разрешить установку и обновление драйверов для съемных устройств.
    0x00000001 — запретить установку и обновление драйверов для съемных устройств.

    21. Удаление сведений о месторасположениях для поиска драйверов.

    Если Вы осуществляли поиск драйверов вручную для устройства установленного на компьютере, то чтобы удалить сведения о месторасположениях для установки драйверов:

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
    3) Щелкните дважды на параметре Installation Sources.
    4) Удалите несуществующие пути в списке значений и нажмите ОК.
    В 64-битной Windows значения данного параметра в разделе HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Setup изменятся автоматически.

    22. Изменение версии Interenet Explorer эмулируемой для CHM-файлов справки и других приложений.

    Некоторые программы использующие для своей работы браузер Interenet Explorer прописывают в реестре какую его версию им использовать.
    Если эмулируемая для программы версия браузера окажется недостаточно высокой, то при просмотре html-файлов может отсутствовать полная или частичная поддержка JavaScript, HTML5 и CSS3.

    Одной из таких программ является программа для просмотра CHM-файлов справки (hh.exe).
    Чтобы изменить какую версию Internet Explorer эмулировать, выполните указанные ниже действия.

    1) Запустите редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION
    3) Создайте DWORD-параметр с именем hh.exe
    4) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить.
    5) Переключите систему исчисления на десятичную и установите значение данного параметра равным необходимой Вам версии.

    9000 - для Internet Explorer 9
    10000 - для Internet Explorer 10
    11000 - для Internet Explorer 11
    и так далее.

    В 64-битной версии Windows дополнительно создайте идентичный DWORD-параметр в разделе:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION


Сети (Интернет и Локальная).

1. Настройка локальной сети между компьютерами.

Соедините между собою с помощью кабеля (витая пара) сетевые карты компьютеров, которые должны быть включены в локальную сеть.
Для объединения более чем 2-х компьютеров подключите сетевые карты компьютеров к хабу (сетевому концентратору), используя для подключения каждого компьютера свой кабель.

I. Установка имени рабочей группы.

1) Откройте меню Пуск, нажмите правой кнопкой мыши на пункт Компьютер и в контекстном меню выберите пункт Свойства.
2) В колонке слева нажмите на ссылку Дополнительные параметры системы.
3) В открывшемся окне Свойства системы, перейдите на вкладку Имя компьютера и нажмите кнопку Изменить.
4) Введите имя рабочей группы (Например: HOMELAN), в которую будут входить компьютеры в локальной сети и нажмите кнопку ОК.

5) В окне Изменение имени компьютера или домена нажмите кнопку ОК, и снова кнопку ОК.
6) В окне Свойства системы нажмите кнопку Закрыть.
7) Во всплывшем окне нажмите кнопку Перезагрузить сейчас.

II. Настройка параметров адаптера.

1) Щелкните правой кнопкой мыши на значок сети на панели задач, выберите пункт Центр управления сетями и общим доступом и перейдите по ссылке слева Изменение параметров адаптера (Win   + R → ncpa.cpl → ОК)

2) Нажмите правой кнопкой мыши на значок Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
3) Снимите флажок напротив Протокол интернета версии 6 (TCP/IPv6) (Internet Protocol Version 6 (TCP/IPv6)).

4) Щелкните на Протокол интернета версии 4 (TCP/IPv4) (Internet Protocol Version 4 (TCP/IPv4)) и нажмите кнопку Свойства.
5) Установите переключатель на Использовать следующий IP-адрес.
6) Введите значение 192.168.1.2 в поле IP-адрес.
7) Введите значение 255.255.255.0 в поле Маска подсети.
8) Введите значение 192.168.1.1 в поле Основной шлюз.
9) Введите значение 192.168.1.1 в поле Предпочитаемый DNS-сервер.
10) Введите значение 192.168.1.0 в поле Альтернативный DNS-сервер.
11) Нажмите кнопку ОК, а затем кнопку Закрыть.

III. Настройка общего доступа к файлам, папкам и принтерам.

1) Щелкните правой кнопкой мыши на значок сети на панели задач, выберите пункт Центр управления сетями и общим доступом и перейдите по ссылке слева Изменить дополнительные параметры общего доступа.
2) Откройте профиль сети Домашний или рабочий.
3) Установите переключатели в значения:

Включить сетевое обнаружение.
Включить общий доступ к файлам и принтерам.
Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках.
Использовать 128-битное шифрование для защиты подключений общего доступа (рекомендуется).
Отключить общий доступ с парольной защитой.
Разрешить Windows управлять подключениями домашней группы (рекомендуется).

4) Откройте профиль сети Общий.
5) Установите переключатели в значения:

Включить сетевое обнаружение.
Включить общий доступ к файлам и принтерам.
Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках.
Использовать 128-битное шифрование для защиты подключений общего доступа (рекомендуется).
Отключить общий доступ с парольной защитой.

6) Нажмите кнопку Сохранить изменения и закройте окно Дополнительные параметры общего доступа.

IV. Открытие общего доступа к папке или диску.

1) В Проводнике щелкните правой кнопкой мыши на папку или диск для которого необходимо открыть общий доступ и выберите пункт Свойства.
2) Перейдите на вкладку Доступ и нажмите кнопку Расширенная настройка.
3) Установите флажок Открыть общий доступ к этой папке и нажмите кнопку Разрешения.
4) Установите для группы Все (Everyone) флажок в колонке Разрешить напротив пункта Полный доступ и нажмите кнопку ОК.

5) В окне Расширенная настройка общего доступа нажмите кнопку ОК.
6) В окне свойств диска или папки перейдите на вкладку Безопасность и нажмите кнопку Изменить.
7) Нажмите кнопку Добавить в окне Разрешения для группы.
8) Введите в текстовом поле слово Все (Everyone) и нажмите кнопку ОК.

9) Установите для группы Все (Everyone) флажок в колонке Разрешить напротив пункта Полный доступ и нажмите кнопку ОК.

10) В окне свойств диска или папки нажмите кнопку Закрыть.

Повторите все описанные в данном совете действия для каждого подсоединяемого к локальной сети компьютера.
При введении IP-адреса для каждого компьютера укажите различающиеся значения.
Например, укажите значение 192.168.1.3 для второго подключаемого компьютера, 192.168.1.4 для третьего подключаемого компьютера и т.д..

2. Создание собственной Wi-Fi точки доступа без использования роутера.

Если у Вас имеется ноутбук или персональный компьютер с беспроводным (Wi-Fi) адаптером и Вы желаете создать собственную точку доступа Wi-Fi, то Вы можете воспользоваться предложенной ниже инструкцией.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.
3) Создайте размещенную сеть:

Укажите вместо имя_сети - имя для для создаваемой Wi-Fi сети (данное имя будет идентификатором SSID).
Укажите вместо пароль_к_сети - пароль для создаваемой Wi-Fi сети (данный пароль будет ключом безопасности пользователя, используемым сетью).

4) Запустите размещенную сеть:

5) Закройте окно команд.
6) Щелкните правой кнопкой мыши на значок сети на панели задач, выберите пункт Центр управления сетями и общим доступом и перейдите по ссылке слева Изменение параметров адаптера (Win   + R → ncpa.cpl → ОК)
7) Нажмите правой кнопкой мыши на значок Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
8) Перейдите на вкладку Доступ и установите флажок Разрешить другим пользователям сети использовать подключение к Интернету данного компьютера.
9) В ниспадающем списке выберите созданное Вами виртуальное соединение и нажмите кнопку ОК, а затем кнопку Закрыть.
10) Щелкните правой кнопкой мыши на значок сети на панели задач, выберите пункт Центр управления сетями и общим доступом и перейдите по ссылке слева Изменить дополнительные параметры общего доступа.
11) Откройте профиль сети Домашний или рабочий.
12) Установите переключатели в значения:

Включить сетевое обнаружение.
Включить общий доступ к файлам и принтерам.
Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках.
Использовать 128-битное шифрование для защиты подключений общего доступа (рекомендуется).
Отключить общий доступ с парольной защитой.
Разрешить Windows управлять подключениями домашней группы (рекомендуется).

13) Откройте профиль сети Общий.
14) Установите переключатели в значения:

Включить сетевое обнаружение.
Включить общий доступ к файлам и принтерам.
Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках.
Использовать 128-битное шифрование для защиты подключений общего доступа (рекомендуется).
Отключить общий доступ с парольной защитой.

15) Нажмите кнопку Сохранить изменения и закройте окно Дополнительные параметры общего доступа.

Чтобы посмотреть состояние размещенной сети - количество клиентов, параметры соединений, протокол работы, воспользуйтесь командой:

Чтобы остановить работу данной сети, воспользуйтесь командой:

Также, для создания собственной Wi-Fi точки доступа Вы можете обратить свое внимание на программы сторонних производителей: Connectify Pro, MyPublicWiFi, mHotSpot.

3. Объединение или удаление сетевых размещений (подключений).

1) Щелкните правой кнопкой мыши на значок Сеть на панели задач и выберите пункт Центр управления сетями и общим доступом
2) Если у Вас отсутствует данный значок, то нажмите комбинацию клавиш Win   + R → введите команду

и нажмите OK
3) Нажмите на значке (дом, офис или скамейка - зависит от типа выбранной Вами сети)
4) В открывшемся окне Настройка свойств сети нажмите на ссылку Объединение или удаление сетевых размещений.
5) Выделите сетевое размещение или несколько сетевых размещений, которые Вы хотите слить в единое сетевое размещение или которые Вы хотите удалить.
Используемые подключения нельзя удалить или слить, для их слия или удаления Вам необходимо отключится от сети.
6) Нажмите кнопку Слияние или Удаление, во всплывшем окне нажмите кнопку Да.

4. Автоматическое подключение к ADSL-интернету при запуске Windows.

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом.
2) Нажмите ссылку Изменение параметров адаптера.
3) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Свойства.
4) Перейдите на вкладку Параметры и снимите флажки Отображать ход подключения, Запрашивать имя, пароль, сертификат и т.д..
5) Нажмите кнопку ОК.
6) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Создать ярлык.
7) В диалоговом окне нажмите Да и у Вас на рабочем столе появится ярлык ADSL-соединения.
8) Откройте Пуск → Все программы .
9) Нажмите правой кнопкой мыши на Автозагрузка и выберите пункт Открыть.
10) Переместите ярлык созданного Вами ADSL-соединения с рабочего стола в открывшуюся папку Автозагрузка.

5. Автоматическое VPN-подключение к интернет при запуске Windows.

Вариант 1

Вы можете добавить задачу в Планировщик заданий.
1) Откройте планировщик задний
1.1) Откройте меню Пуск → Панель управления → Администрирование → Планировщик заданий или в строке поиска меню Пуск введите taskschd.msc и нажмите Enter ↵.
2) Нажмите Создать задачу...
3) На вкладке Общие введите в поле Имя - Имя подключения
4) Перейдите на вкладку Триггеры и нажмите кнопку Создать...
5) Выберите в ниспадающем списке напротив пункта Начать задачу: значение При входе в систему и нажмите ОК.
6) Перейдите на вкладку Действия и нажмите кнопку Создать...
7) Выберите в ниспадающем списке напротив пункта Действие: значение Запуск программы.
8) Введите в поле Программа или сценарий: команду rasdial "имя подключения" login password
вместо "имя подключения" - укажите название Вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету
9) Нажмите кнопку ОК.
10) Перейдите на вкладку Параметры
11) Поставьте флажки напротив:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
12) Уберите флажок Останавливать задачу выполняемую дольше и нажмите ОК.

Вариант 2

1) Скачайте и распакуйте в любую папку файл connect.zip, содержащий скрипт для соединения с интернетом.
2) Щелкните правой кнопкой мыши на файле connect.bat и нажмите Изменить
3) Измените название подключения, логин(имя пользователя) и пароль в соответствии с Вашими настройками и сохраните файл.
4) Скачайте архив со скриптом скрытого запуска:
hs_exec.zip - для использования командного bat-файла, содержащего скрипт запуска
hide_program.zip - для использования яваскрипта, содержащего скрипт запуска
5) Распакуйте архив в ту же самую папку, где у Вас находится файл connect.bat
6) Добавьте в папку автозагрузки (Пуск → Все программы →Автозагрузка) ярлык (не сам файл скрипта) для hide_program.js в случае использования яваскрипта, либо для load.bat в случае использования командного bat-файла.

Вариант 3

1) Создайте командный bat-файл (Например: Connect.bat) следующего содержания:

вместо "имя подключения" - укажите название вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету

2) Добавьте ярлык (не сам файл скрипта) на файл connect.bat в папку автозагрузки (Пуск → Все программы →Автозагрузка)

Внимание: "имя подключения" должно быть на английском иначе может быть ошибка 623.

6. Отключение запроса пароля при использовании папки общего доступа.

Даже если Вы не устанавливали пароль для папки общего доступа, система может у Вас его запросить.

Для отключения данного запроса сделайте следующее:

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
3) В графе Общий доступ с парольной защитой установите переключатель на значение Отключить общий доступ с парольной защитой.

7. Просмотр исходного кода любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

1)Установите расширение Web Developer.
Затем перейдите в меню Web Developer → Код и нажмите Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл → Сохранить страницу как → page.htm

В Internet Explorer

1) Нажмите на значок шестеренки и выберите Средства разработчика (F12)
2) Щелкните на значек курсора (Ctrl + B)
3) Выберите нужный элемент на странице и увидите его код.
4) Для сохранения исходного кода нажмите на значок дискетки
5) Выберите место сохранения файла и нажмите кнопку Сохранить.

8. Использование swf-файлов взаимодействующих с удаленным приложением, на локальном компьютере.

Если Вы попытаетесь запустить локально swf-файл, который должен взаимодействовать с JavaScript на странице или с серверным приложением, запущенным на компьютере или должен загружать данные с удаленного домена, то Flash Player заблокирует его выполнение в целях безопасности.

Для решения проблемы Вы можете воспользоваться следующими вариантами:

Вариант 1.

Если у Вас есть интернет соединение, то воспользуйтесь менеджером настроек (Settings Manager) плеера.

1) Откройте специальную страницу настроек менеджера на сайте Macromedia в любом браузере:
http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html
2) Выберите в ниспадающем списке Изменить местоположение (Edit locations) → Добавить местоположение (Add location) → Обзор файлов
3) Укажите путь к swf-файлу. Вы можете выделить сразу несколько swf-файлов.
4) Перезапустите браузер и откройте локальную страницу с swf-файлом.

Вариант 2.

Если у Вас отсутствует интернет соединение, то можно добавить swf-файл или папку в доверенную зону (Local-Trusted sandbox) используя конфигурационный файл FlashPlayerTrust.

1) Создайте в папке: C:\Имя_пользователя\Administrator\AppData\Roaming\Macromedia\Flash Player\#Security\FlashPlayerTrust любой файл с расширением *.cfg
Где Имя_пользователя - это имя текущего пользователя компьютера.
2) Укажите путь к необходимому Вам swf-файлу или путь к папке в которой он находится. Вы можете указать путь к нескольким swf-файлам сразу, по одному в строке.

При создании файла учитывайте следующее:
- новый путь пишется с новой строки
- комментарии (если необходимы) начинаются с решетки #
- если путь содержит не ASCII символы, файл должен быть в формате UTF-8 или UTF-16
- пути только к локальным папкам и файлам, возможны пробелы, кавычки не желательны

3) Перезапустите браузер и откройте локальную страницу с swf-файлом.

Вариант 3.

Создайте и запустите в папке с Вашими swf-файлами командный bat-файл.

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .bat
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "localswf.bat")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Запустите созданный Вами bat-файл.
6) Перезапустите браузер и откройте локальную страницу с swf-файлом.

9. Сохранение интернет соединения при переключении между пользователями.

При создании нового интернет подключения поставьте флажок на "Разрешить использовать это подключение другим пользователям".
Установление галочки в уже созданном подключении может работать некорректно в некоторых VPN соединениях.

По умолчанию при переключении между пользователями Windows сбрасывает dial-up и некоторые виды других соединений. Можно изменить это поведение следующим образом.

1) Запустите редактор реестра (Win   + R → Regedit → OK)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters
3) Щелкните правой кнопкой мыши на Dword-параметр KeepRASConnections, выберите Изменить и присвойте параметру значение 1
4) Закройте редактор реестра и завершите текущий сеанс для вступления изменений в силу.

Если Вы хотите, чтобы соединения сбрасывались, то используйте значение 0 или удалите этот параметр.

10. Перемещение HOST, LMHOST и других файлов из Windows\System32\drivers\etc в другое место.

Если вы хотите переместить файлы из Windows\System32\drivers\etc в другое место (например, по соображениям безопасности) из папки Windows\System32\drivers\etc, то для этого Вам необходимо выполнить следующее:
1) Скопируйте файлы в новое место
2) Запустите редактор реестра (Win   + R → regedit → ОК).
3) Откройте следующий раздел реестра: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
4) Измените значение параметра DataBasePath на новый путь к папке
5) Перезагрузитесь и удалите файлы из %SystemRoot%\System32\drivers\etc

11. Поиск на веб-сайтах из Проводника (Windows Explorer).

Windows 7 теперь позволяет вести поиск на веб-сайтах из Windows Explorer (Проводника). Данный поиск основан на спецификации OpenSearch.
Чтобы добавить в Windows провайдер OpenSearch, нужно предоставить файл определения в формате OSDX. Этот формат позволяет указывать описательную информацию наряду с необходимыми URL и другими параметрами.
Эти файлы сопоставляются с Windows Explorer и добавляются в папку Searches: C:\Users\{USER}\Searches.
Чтобы создать файл OSDX, нужно предоставить URL для вызова и ¤ провайдера.

1) Откройте текстовый редактор. (Например, Блокнот)
2) Скопируйте и вставьте в него следующий текст:

3) В меню программы нажмите Файл и выберите пункт Сохранить.
3.1) В открывшемся окне укажите место сохранения файла.
3.2) Укажите имя файла и расширение .osdx и обязательно в кодировке UTF-8 (Например: Сохраните его как Bing.osdx)
3.3) Выберите тип файла: Все файлы (*.*).

Дважды щелкните по получившемуся osdx-файлу для внесения дополнений в систему.

Чтобы искать на добавленном Вами веб-сайте из Проводника:

1) Запустите Проводник (Windows Explorer)
2) Откройте папку C:\Users\{USER}\Searches, для чего просто введите %UserProfile%\Searches и нажмите Enter ↵.
3) Выберите установленный Вами поиск, в строке поиска укажите значение для поиска и нажмите Enter ↵.
4) Если Вы хотите, чтобы при нажатии на результат поиска в Проводнике показывались найденная страница, то нажмите на значок включения Области преварительного просмотра (находится, в верхней правой части экрана перед значком вопроса)

Вы можете скачать уже готовые файлы определения (.osdx) по ссылке: OSDX.zip

12. Смена динамического IP-адреса, для обхода времени ожидания на файлообменниках.

Многие файлообменники и программы для скачивания разделяют обычных пользователей по IP адресу. Если Вы не используйте прокси-сервера и при каждом подключении к интернету провайдер дает Вам новый IP адрес, то это означает что у Вас динамический адрес и Вы можете создать командный файл разрывал бы связь и снова соединялся с интернетом. В итоге у вас будет новый адрес и яў файлообменника Вы будете уже новым клиентом.
Данная возможность позволит Вам обойти ограничение по времени и качать без ожиданий.

Инструкция по созданию командного файла:

1) Откройте любой текстовый редактор (Например, Блокнот).
2) Откройте меню Пуск → Все программы → Стандартные → Блокнот (или нажмите сочетание клавиш Win   + R → введите notepad → нажмите ОК)
3) Скопируйте необходимый Вам код в окно программы Блокнот.
4) В меню программы нажмите Файл и выберите пункт Сохранить.
В открывшемся окне:
5) Укажите место сохранения файла.
6) Укажите имя файла и расширение .bat (Например: reconnect.bat)
7) Выберите тип файла: Все файлы (*.*).
8) Для смены IP-адреса запустите созданный Вами командный файл просто щелкнув на нем.

Вариант 1. Внешний динамический адрес, прямое подключение по локальной сети.

Вариант 2. Внешний динамический адрес, подключение через модем или через USB-ADSL.

Способ 1.

Чтобы узнать имя требуемого интерфейса:
1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

Способ 2.

Вариант 3. Внешний динамический адрес, подключение через LAN-ADSL или через роутеры.

Скачиваете и устанавливаете программу Router Control, а файл reconnect.bat создаете в папке программы.

13. Включение и настройка общего доступа к файлам и папкам.

В Windows 7 папка «Общее» заменена на отдельные общие папки яў каждого типа файлов: Общие документы, Общие рисунки, Общая музыка или Общее видео. В Проводнике Вы можете попасть в них через Библиотеки, открыв папку Документы, Рисунки, Музыка или Видео, а затем папку Общие документы, Общие рисунки, Общая музыка или Общее видео.

Предоставление общего доступа к файлам или папкам, находящимся в Общих папках с использованием домашней группы.

1) Нажмите кнопку Пуск и откройте Панель управления.
2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
3) Щелкните Выбор домашней группы и параметров общего доступа.
4) Нажмите на кнопку Создать домашнюю группу
5) Выберите элементы, к которым нужно предоставить общий доступ и нажмите кнопку Далее.
6) В окне с паролем для добавления других компьютеров к домашней группе нажмите кнопку Готово.
7) Нажмите на ссылку Изменить дополнительные параметры общего доступа
8) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
9) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

Предоставление общего доступа к любым файлам или папкам без перемещения их в Общие папки с использованием домашней группы.

I. Настройка конкретных папок или файла для общего доступа.

1) Перейдите в место размещения файла или папки, к которым необходимо предоставить общий доступ.
2) Щелкните файл или папку правой кнопкой мыши и выберите пункт Общий доступ → Конкретные пользователи
3) Введите имя или нажмите стрелку вниз и в ниспадающем меню выберите Все, а затем нажмите кнопку Добавить
4) Напротив имени Все установите необходимый Вам Уровень разрешений:
Чтение - Пользователи могут открывать файл, но им не разрешается изменять или удалять его.
Чтение и запись - Пользователи могут открывать, изменять и удалять файл.
5) Нажмите кнопку Общий доступ. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
6) Нажмите правой кнопкой мышки на папке и выберите Копировать ссылку. Ваша ссылка будет скопирована в буфер обмена. Теперь вставьте ссылку в сообщение электронной почты, мгновенное сообщение или другую программу, или же сохраните в блокноте.
7) По завершении нажмите кнопку Готово.

II. Настройка портов для общего доступа.

1) Откройте Пуск → Панель управления → Система и безопасность и запустите Брандмауэр Windows.
2) Нажмите ссылку Дополнительные параметры, чтобы добавить новые правила для Firewall.
3) В открывшемся окне, в меню слева, выберите Правила для входящих подключений
4) В меню справа нажмите кнопку Создать правило….
5) В открывшемся окне, установите переключатель на тип правила Для порта и нажмите кнопку Далее.
6) Установите переключатель на Протокол TCP.
7) В текстовое поле напротив Определенные локальные порты: впишите через запятую 139, 445 и нажмите кнопку Далее.
8) В следующем окне оставьте установленное по умолчанию значение Разрешить подключение и нажмите кнопку Далее.
9) В окне выбора профилей снова нажмите кнопку Далее.
10) Введите имя и описание Вашего правила. Например: Shared Folders (TSP ports).
11) Нажмите кнопку Готово.

Повторите действия указанные в пунктах с 4) по 11) для типа протокола UDP.
В 6) пункте инструкции установите переключатель на Протокол UDP, в 7) пункте впишите порты 137, 138, а имя задайте Shared Folders (UDP ports).

III. Отключение запроса пароля.

1) Щелкните правой кнопкой мыши на значок сетевого подключения на панели задачи и выберите пункт Центр управления сетями и общим доступом.
2) Просмотрите Ваши активные сети. Тип сетевого размещения используемого для разрешения взаимодействия с другими компьютерами должен быть установлен как Домашняя сеть. Для смены типа сетевого размещения на Домашняя сеть:
2.1) Нажмите мышкой по имеющейся у Вас надписи Сеть предприя или Общественная сеть
2.2) В открывшемся окне выберите Домашняя сеть и нажмите кнопку Закрыть .
Если тип Вашего сетевого размещения уже установлен как Домашняя сеть, то Вам менять его не нужно.
3) Нажмите на ссылку Изменить дополнительные параметры общего доступа
4) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
5) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

Предоставление общего доступа к файлам и папкам, находящимся в Общих папках без использования домашней группы.

1) Нажмите кнопку Пуск и откройте Панель управления.
2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
3) Щелкните Изменить дополнительные параметры общего доступа в левой области
4) Установите переключатели в следующие параметры:

- Включить сетевое обнаружение.
- Включить общий доступ к файлам и принтерам
- Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках (делает доступными папки "Общие документы", "Общая музыка", "Общие рисунки" и "Общее видео")
- Отключить общий доступ с парольной защитой

Примечания

Для включения общего доступа с парольной защитой, необходимо иметь две совершенно одинаковые учетные записи и пароли пользователя на обоих компьютерах.
Если ¤ пользователя и пароль, с которыми выполнен вход в систему, отличаются от зарегистрированного на другом компьютере, к которому осуществляется попытка доступа, возможно, будет запрошена информация для входа в систему.
Если на другом компьютере разрешен доступ всем в сети, автоматическое подключение будет предоставлено с правами гостя. Это означает, что доступ будет предоставлен только к файлам в общих папках.

Если при предоставлении общего доступа у Вас возникают проблемы, то Вы можете использовать средство устранения неполадок для автоматического поиска и устранения некоторых распространенных проблем.

1) Запустите командную строку с правами администратора.
1.1) Откройте Пуск → Все программы → Стандартные
1.2) Щелкните правой кнопкой мыши на Командная строка и выберите Запуск от имени администратора
2) Введите следующую команду и нажмите Enter ↵:

3) Нажмите кнопку Далее и следуйте инструкциям средства устранения неполадок.

14. Автоматическая загрузка последних версий драйверов и реалистичных значков для подключенных устройств.

1) Откройте Пуск → Панель управления → Устройства и принтеры.
2) Щелкните правой кнопкой мыши ¤ компьютера и выберите пункт Параметры установки устройств.
3) Выберите пункт Да, делать это автоматически (рекомендуется) и нажмите кнопку Сохранить изменения.

Windows сохранит фирменные значки производитЈ для подключенных Вами устройств в папку:

%LOCALAPPDATA%\Microsoft\Device Metadata\dmrccache\

Внутри папки, в соответствии с вашим регионом (например, en-US), должны располагаться отдельные папки содержащие в названии GUID для каждого устройства с соответствующими метаданными. Иконка будет находится в папке DeviceInformation каждого устройства.

15. Вычисление сайтов посещаемых пользователем в приватном режиме просмотра браузера.

Приватный режим посещения сайтов в браузерах не сохраняет на компьютере куки-файлы, временные файлы Интернета, журнал просмотра и другие сведения.
Но не смотря на это вся информация о посещенных сайтах в интернете и присутствующих на данном сайте компонентах сохраняется в кэше сопоставления имен клиентов.
В нем хранится такая информация, как IP адрес и ¤ домена, на основе которых можно вычислить адрес посещаемого сайта. Для просмотра данного кэша не требуются права администратора на компьютере.

Для отображения кэша сопоставления имен клиентов выполните следующее:

1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win   + R → cmd → OK) .
2) Введите команду и нажмите Enter ↵:

Чтобы была пауза после отображения каждого экрана выходных данных команды, введите:

3) Если Вам необходимо сохранить данную информацию в текстовый файл выполните команду:

Данные будут сохранены в файл DNScache.txt на диск C: .

Для сбрасывания данных кэша сопоставления имен клиентов выполните следующее:

1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win   + R → cmd → OK) .
2) Введите команду и нажмите Enter ↵::

16. Месторасположение кэша браузера и его просмотр.

Каждый браузер по умолчанию сохраняет содержимое веб-страниц (изображения, flash-ролики, видео, аудио и др.), просмотренных вами на жёсткий диск в кэш, во избежание их повторной загрузки.

Microsoft's Internet Explorer.

Кэш для данного браузера хранится в отдельных профайлах для каждого пользователя по адресу:

С:\Users\Имя_пользователя\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5

Внутри директории \Content.IE5 содержаться дополнительные папки со "случайно" сгенерированными именами, в которых хранит© информация о посещение того или иного веб ресурса, а в файле index.dat, в котором и содержится интересующая нас информация. Файл index.dat для просмотра можно открыть программой Index.dat Analyzer.
Для сканирования содержимого index.dat файлов нажмите кнопку Quick rescan for index.dat files.

Также Вы можете открыть Свойства обозревателя, в графе История просмотра нажать Параметры, а затем кнопку Показать файлы.

Mozilla Firefox.

Mozilla Firefox использует особый алгоритм кэширования страниц. Папка, в которой хранит© интересующая Вас информация:

С:\Users\Имя_пользователя\AppData\Local\Mozilla\Firefox\Profiles\Имя_профиля\Cache

Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке about:cache?device=disk и нажмите Enter ↵.

Opera

Кэш для данного браузера хранится в отдельных подпапках по адресу:

С:\Users\Имя_пользователя\AppData\Local\Opera\Opera\cache

Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке opera:cache и нажмите Enter ↵.

Также Вы можете скачать и использовать для просмотра кэша браузеров Internet Explorer, Mozilla Firefox или Opera программу Cache View Plus. Данная программа позволяет Вам напрямую (в режиме предпросмотра) увидеть файлы находящиеся в кэше файлы в соответствии с их типом: изображения, видео, звуки, swf-файлы.

17. Отключение автоматической отправки сведений на сервера корпорации Microsoft, собранных программой улучшения качества программного обеспечения.

В корпорации Microsoft существует программа улучшения качества программного обеспечения, которая собирает сведения о продуктах Microsoft, а также ограниченные данные о произведенных независимыми компаниями приложениях, которые взаимодействуют с продуктами Microsoft и отсылает их на сервера Microsoft.

Более подробно о ней Вы можете прочитать на сайте: http://www.microsoft.com/products/ceip/ru-ru/default.mspx

Если Вы не желаете участвовать в данной программе, то сделайте следующее:

1) В строке поиска меню Пуск введите команду gpedit.msc и нажмите Enter ↵.
2) Перейдите в папку:

3) Щелкните правой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows и выберите пункт Изменить.
4) Установите переключатель в значение Включить и нажмите кнопку OK.

18. Добавление индикатора сетевой активности на панель задач.

Значок Сеть в области уведомлений на панели задач при наведении на него отображает всего лишь текущее подключение и не мигает при наличии сетевой активности.
Если Вы желаете добавить значок в область уведомлений, позволяющий увидеть размер входящего и исходящего траффика, а также просмотреть статистику подключения, то Вы можете скачать небольшую бесплатную программу Network Activity Indicator, максимально приближенную к интерфейсу Windows.

Если Вы желаете заменить стандартную иконку Сеть на иконку данной программы, то проделайте следующее:

1) Зайдите на сайт: http://www.itsamples.com/network-activity-indicator.html
2) Скачайте программу Network Activity Indicator и язык интерфейса к ней.
3) Распакуйте программу и язык интерфейса для программы в одну и ту же папку.
4) Откройте папку, куда Вы распаковали программу и запустите файл NetworkIndicator.exe
5) Нажмите правой кнопкой мыши на иконку программы и выберите пункт Настройки
6) Установите флажки:
Отображать UDP пакеты
Отображать ICMP пакеты
Запускать при старте Windows
Показывать неактивную иконку если интерфейс отсоединен.
Использовать иконки Vista
7) Нажмите кнопку Применить.
8) Щелкните правой кнопкой мыши на панели задач и выберите пункт Свойства.
9) В графе Область уведомлений щелкните на кнопку Настроить...
10) Нажмите на ссылку Включить или выключить системные значки.
11) Напротив значка Сеть из ниспадающего списка выберите Выкл.
12) Нажмите ОК и еще раз ОК.

19. Создание ярлыка для запуска Internet Explorer в режиме приватного просмотра.

1) Щелкните правой кнопкой мыши на свободном месте рабочего стола, и выберите Создать → Ярлык.

2) Для 32-битных Windows 7:

2.1) В поле Укажите расположение объекта введите:

2.2) Переходите к пункту 4.

3) Для 64-битных Windows 7:

3.1) Чтобы использовать 32-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

3.2) Чтобы использовать 64-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

4) Нажмите кнопку Далее.
5) В поле Введите имя ярлыка напишите Internet Explorer (просмотр InPrivate) и нажмите кнопку Готово. (Примечание: Вы можете указать любое имя для ярлыка.)
6) Теперь Вы можете переместить созданный Вами ярлык в любое удобное для Вас место. Например, Вы можете закрепить ярлык в панели задач.

20. Создание ярлыка в папке Компьютер для просмотра часто используемого ftp как одного из дисков.

1) В Проводнике или в меню Пуск щелкните правой кнопкой мыши на Компьютер
2) Выберите в списке пункт Подключить сетевой диск
3) Нажмите ссылку Подключение к сайту, на котором можно хранить документы и изображения.
4) В открывшем окне нажмите кнопку Далее, а затем снова кнопку Далее.
5) В текстовом поле введите имя ftp-сервера и нажмите кнопку Далее.

Например: ftp://ftp.mozilla.org/pub/firefox/

6) Уберите флажок "Анонимный вход" и введите имя пользователя и нажмите кнопку Далее.
Если яў входа не нужна идентификация пользователя, то оставьте флажок "Анонимный вход" установленным.
7) Введите имя для отображаемого ярлыка в Проводнике и нажмите Далее.
8) Для завершения создания ярлыка нажмите кнопку Готово.

21. Быстрая очистка истории обзора Internet Explorer при помощи специально созданного ярлыка.

Если Вы используете браузер Internet Explorer, то для очистки истории обзора(временных файлов, кэша, паролей и др.) Вы делаете следующее:

1) В Internet Explorer открываете Свойства обозревателя.
Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажимаете на значок шестеренки.
2) На вкладке Общие в графе История просмотра нажимаете кнопку Удалить... .
3) Устанавливаете необходимые флажки и нажимаете кнопку Удалить.

Чтобы ускорить данный процесс Вы можете создать специальный ярлык для очистки определенных данных из истории просмотра Internet Explorer на рабочем столе.

1) Щелкните по рабочему столу правой кнопкой мыши, выберите команды "Создать" - "Ярлык".
2) В текстовом поле введите необходимую Вам команду для запуска.

Удаление истории посещений (журнала):

Удаление Cookies:

Удаление временных файлов/веб страниц:

Удаление данных веб-форм:

Удаление паролей:

Полное удаление всей истории:

Полное удаление всей истории и данных надстроек браузера:

3) Нажмите кнопку Далее
4) Укажите имя для ярлыка и нажмите Готово.

Так же можно комбинировать номера, суммируя их.
Например:

Это удалит временные файлы (+8) и журнал посещений (+1).

22. Поиск необходимого файла на крупнейших файлобменниках.

Если Вам часто бывает необходимо найти какой-либо конкретный файл (видео, музыку, программное обеспечение, документы и т.д.), а крупнейшие поисковики наподобие Google или Bing либо его не находят, либо выдают много лишних результатов после поиска, то существует специальная поисковая система, помогающая найти файлы на различных хостинговых сайтах.

Даннная поисковая система общедоступных файлов помогает найти файлы, соответствующие Вашим критериям, среди тех файлов, которые недавно были отслежены на сайтах их собственным уникальным сканером по поиску информации. Каждая найденная при помощи этого сканера информация хранится в базе данных. Осуществляя поиск используя данную поисковую систему, Вы получаете результаты напрямую из этой базы данных.

Кроме того, на странице результата поиска, в случае его наличия указывается сайт, на котором были обнаружены данные ссылки. Это бывает полезно, если скаченный Вами архив окажется запаролен.

Для обеспечивания лучшего результата поиска не указывайте в текстовом поле разрешение файла, а выбирайте его из ниспадающего списка (при наличие).

Ссылка на поисковую систему: FilesTube

23. Создание url-файла, для перехода на указанную страницу в интернете.

Наверное Вы замечали, что при установке многие программы создают файл .url (Ярлык Интернета), при нажатии на который в браузере открывается домашняя страница программы.

Вы также можете создать такой файл-ссылку, для этого выполните указанные ниже действия:

1) Щелкните правой кнопкой мыши по свободному пространству в папке, где Вы хотите создать url-файл.
2) Выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите адрес страницы в интернете. Например: http://www.google.com
4) Нажмите кнопку Далее и укажите название ярлыка, после чего нажмите на кнопку Готово.

24. Восстановление содержимого файла hosts по умолчанию.

Если в файл hosts были внесены какие-либо изменения, например, для блокировки соединения с определенными сайтами, то Вы можете восстановить параметры файла hosts по умолчанию, для этого выполните указанные ниже действия:

1) Откройте меню Пуск, выберите пункт Выполнить (Win   + R), введите команду %systemroot%\system32\drivers\etc и нажмите кнопку ОК.
Примечание. Если используется 64-разрядная версия Windows, введите команду %systemroot%\SysWOW64\drivers\etc.
2) Переименуйте файл hosts в hosts.old.
3) Создайте новый файл hosts по умолчанию. Для этого выполните указанные ниже действия.
4) Щелкните правой кнопкой мыши в свободном месте в папке %WinDir%\system32\drivers\etc, выберите пункт Создать, щелкните элемент Текстовый документ, введите имя hosts и нажмите клавишу Enter ↵.
5) Нажмите кнопку Да, чтобы подтвердить, что имя файла не будет иметь расширение TXT.
6) Откройте новый файл hosts в текстовом редакторе. Например, откройте файл в программе "Блокнот".
7) Скопируйте в файл приведенный ниже текст.

8) Сохраните и закройте файл.

25. Одновременное использование сайтов (скриптов) из локальной сети и из интернета, при включенном VPN-подключении к интернету.

Если локальный сайт открывается у Вас только при выключенном интернете, а Вы не желаете отключаться от интернета.
Если сайт одновременно использует содержимое как из локальной сети, так и из интернета.
То Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1. Автоматическое определение указанного Вами сайта как локального.

1) Откройте Пуск → Панель управления → Свойства обозревателя
2) Перейдите на вкладку Безопасность
3) Выберите зону Местная интрасеть и нажмите кнопку Узлы.
4) Нажмите кнопку Дополнительно.
5) Введите адрес сайта, который должен определятся как принадлежащий локальной сети и нажмите кнопку Добавить.
6) Закройте окна настроек свойств обозревателя.
7) Закройте все браузера, переподключитесь к интернету и зайдите в браузер снова.

Вариант 2. Использование основного шлюза в удаленной сети.

1) Отключитесь от VPN-подключения, если Вы подключены.
2) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
3) Щелкните правой кнопкой мыши на Вашем VPN-подключении и выберите пункт Свойства.
4) Перейдите на вкладку Сеть
5) Щелкните на Протокол Интернета версии 4 (TCP/IPv4) и нажмите кнопку Свойства.
6) Нажмите кнопку Дополнительно...
7) Снимите флажок Использовать основной шлюз в удаленной сети.
8) Нажмите OK, OK, OK.
9) Подключитесь к VPN-подключению.
10) Если у Вас данный вариант не сработал, то верните флажок обратно.

Вариант 3. Получение автоматических настроек.

1) Отключитесь от VPN-подключения, если Вы подключены.
2) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
3) Щелкните правой кнопкой мыши на Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
4) Щелкните на Протокол Интернета версии 4 (TCP/IPv4) и нажмите кнопку Свойства.
5) Если Вы самостоятельно не устанавливали настройки, то запишите себе куда-нибудь текущие значения полей.
6) Установите переключатели в значения: Получить IP-адрес автоматически и Получить адрес DNS-сервера автоматически.
7) Нажмите OK, OK.
8) Подключитесь к VPN-соединению.
9) Если у Вас данный вариант не сработал, то:
10) Установите переключатели в значения: Использовать следующий IP-адрес и Использовать следующие адреса DNS-серверов.
11) Введите записанные Вами значения обратно.

26. Открытие сайта из другой страны не прописывая в браузере прокси-сервера.

Если Вы желаете, чтобы сайты определяли в качестве страны Вашего местоположения определяли какую-либо другую страну, но при этом не собираетесь прописывать в настройки браузера прокси-сервер, то Вы можете воспользоваться следующим решением.

1) Зайдите на сайт http://sourceforge.net/projects/advtor/ и скачайте программу Advanced Onion Router.
Данная программа использует анонимную сеть TOR, предоставляющую передачу данных в зашифрованном виде.
2) Распакуйте архив и запустите программу.

Прежде всего Вам необходимо добавить в программу черный список серверов.

3) В списке слева перейдите Plugin → IP Blacklist (Blacklist.dll)
4) Введите http://list.iblocklist.com/?list=ijfqtofzixtwayqovmxn и нажмите кнопку Download
5) Дождитесь пока загрузится список.

6) Внизу окна программы Advanced Onion Router нажмите кнопку Connect.
7) Дождитесь когда появится надпись Connected to the OR network.
8) В списке слева перейдите Intercept → Quick Start
9) Справа в окне программы нажмите кнопку Run
10) Укажите путь к Вашему браузеру.
10.1) Откройте папку, где находится Ваш браузер.
10.2) Выделите запускаемый файл программы и нажмите кнопку Открыть.

Запустится браузер, а для скрытия Вашего местоположения будет выбран случайный сервер.

11) Чтобы сменить текущий ip-адрес на новый, нажмите внизу окна программы Advanced Onion Router кнопку New Identity.
12) Чтобы выбрать какую-либо конкретную страну местоположения:
12.1) Нажмите кнопку >> рядом с кнопкой New Identity.
12.2) В ниспадающем списке Country выберите необходимую страну и нажмите кнопку Select.

Примечание:

П.1) Так как черный список серверов часто обновляется, то действия указанные в пунктах с 3 по 5 рекомендуется выполнять периодически.
П.2) Каждый сервер, используемый для скрытия Вашего местоположения может иметь различную скорость.
П.3) Для возврата к собственному местоположению (ip-адресу) просто выйдите из программы Advanced Onion Router и перезапустите браузер.

27. Включение log-файла журнала брандмауэра Windows.

Если Вы используете встроенный в Windows брандмауэр, то для наибольшего контроля за его действиями Вы можете включить ведение log-файла журнала.

Чтобы это сделать, выполните указанные ниже действия:

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵

2) Введите указанные далее команды, нажимая после введения каждой из них клавишу Enter ↵.

2.1) Включите брандмауэр Windows.

2.2) Задайте имя и месторасположение log-файла журнала.

2.3) Задайте максимальный размер log-файла фурнала в килобайтах (Например: 10 МБ = 10240 КБ).

2.4) Включение протоколирования разорванных подключений.

2.5) Включение протоколирования разрешенных подключений.

28. Удаление из Internet Explorer плагина, у которых отсутствует или заблокирована кнопка Удалить.

1) В Internet Explorer нажмите на значек шестеренки и выберите пункт Надстройки.
2) Щелкните правой кнопкой мыши на необходимый Вам плагин и выберите пункт Подробнее.
3) Запишите значения указанные для ID класса, Файл и Папка.
4) Закройте Internet Explorer.
5) В Проводнике откройте указанную папку и удалите (или переименуйте) найденный файл.
6) Запустите редактор реестра (лучше Registry Workshop).
7) Найдите и удалите все папки с названием, содержащим значение ID класса.

29. Закрепление вебсайта на панели задач, а также отключение и восстановление данной возможности.

Чтобы закрепить вебсайт на панели задач, выполните следующие действия.

1) В Internet Explorer нажмите на значек шестеренки и выберите пункт Файл.
2) Во всплывающем меню выберите пункт Добавить сайт в меню "Пуск".
3) В открывшемся окне нажмите кнопку Добавить.
4.1) Щелкните правой кнопкой мыши на появившийся в панели задач значок и выберите пункт Закрепить программу в панели задач.

или

4.2.1) Нажмите кнопку Пуск → Все программы
4.2.2) Щелкните правой кнопкой мыши на Вашем сайте и выберите пункт Закрепить на панели задач.

Примечание: Все сайты кроме панели задач, также закрепляются в папке Все программы в меню Пуск. Если там они Вам не нужны, то Вы можете их оттуда удалить.

При желании Вы можете отключить возможность закрепления файлов в меню Пуск и на панели задач, для этого создайте и примените указанный ниже reg-файл:

Чтобы восстановить возможность закрепления сайта на панели задач, создайте и примените reg-файл указанного ниже содержания:

30. Установка вручную плагина VLC Web Plugin для программы Mozilla Firefox.

Многие сайты, осуществляющие потоковое вещание различных телеканалов в интернете, требуют установки специальных плагинов "Windows Media Player Firefox Plugin" и "VLC Web Plugin".

Если яў установки плагина "Windows Media Player Firefox Plugin", Вам достаточно лишь скачать небольшой файл с самим плагином, то для установки новой версии плагина VLC Web Plugin Вам необходимо установить VLC media player (Videolan) и выбрать во время установки пункт Web plugins.

Чтобы установить последнюю версию плагина VLC Web Plugin, при этом не устанавливая сам плеер, Вы можете воспользоваться предложенным ниже решением.

1) Зайдите на сайт http://nightlies.videolan.org/build/win32/last/
2) Скачайте zip-архив с программой VLC media player и разархивируйте его в любую папку.
3) Закройте Mozilla Firefox.
4) Скопируйте из папки, куда Вы разархивировали zip-архив в папку C:\Program Files (x86)\Mozilla Firefox\browser\plugins файлы axvlc.dll, libvlc.dll, libvlccore.dll, npvlc.dll и папку plugins.
Для старых версий Mozilla Firefox копировать необходимо в папку: C:\Program Files (x86)\Mozilla Firefox\Plugins.
5) Запустите Mozilla Firefox.

31. Быстрый доступ к редактированию файла Hosts.

Если Вам приходится работать с программами, которым необходимо запрещать доступ к интернету, и Вы делаете это с помощью файла hosts из папки C:\Windows\System32\drivers\etc, то Вы можете воспользоваться указанными ниже решениями для быстрого доступа к нему.

Вариант 1.

Для создания специального ярлыка, открывающего в Блокноте файл hosts, выполните указанные ниже действия.

1) Щелкните правой кнопкой мыши по свободному пространству рабочего стола.
2) Выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите:

4) Нажмите кнопку Далее и укажите название ярлыка (Например, Редактировать HOSTS), после чего нажмите на кнопку Готово.
Теперь достаточно запустить созданный ярлык и файл hosts откроется в Блокноте для редактирования.

Вариант 2.

Для добавления в контекстное меню рабочего стола пункта Редактировать HOSTS файл, создайте и примените указанный ниже reg-файл.

Чтобы удалить пункт Редактировать HOSTS файл из контекстного меню рабочего стола, создайте и примените указанный ниже reg-файл.

32. Отключение использования вкладок в Internet Explorer.

Чтобы отключить использование вкладок в Internet Explorer:

1) Откройте Пуск → Панель управления → Свойства обозревателя
2) В разделе вкладки нажмите на кнопку Параметры.
3) Снимите установленный флажок Включить обзор с вкладками (после запуска) и нажмите кнопку ОК.
4) Перезапустите Internet Explorer (если он был у Вас запущен).

33. Переустановка браузера Internet Explorer.

Чтобы переустановить Internet Explorer, Вам для начала необходимо его полностью удалить.
Так как удаление Internet Explorer через "Пуск → Панель управления → Программы и компоненты → Включение или отключение компонентов Windows" его полностью не удаляет, то для полного его удаления воспользуйтесь предложенным ниже решением.

1) Скачайте и установите программу Unlocker.
2) Зайдите на сайт http://windows.microsoft.com/ru-RU/internet-explorer/downloads/ie и скачайте последнюю версию Internet Explorer.
Для удобства поместите скаченный файл установки Internet Explorer на рабочий стол.
3) Щелкните правой кнопкой мыши по значку Internet Explorer на панели задач (в случае его наличия там) и выберите пункт Изъять программу из панели задач.
4) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd, щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
5) В окне команд введите указанную ниже команду и нажмите клавишу Enter ↵.

При ¦влении окон с ошибкой 0x8007005 нажимайте кнопку ОК или клавишу Enter ↵.
6) Откройте папку C:\Program Files\Internet Explorer и выделите все ее содержимое.
7) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
8) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
В 64-битной версии Windows повторите действия описанные в пунктах с пятого по седьмой для папки C:\Program Files (x86)\Internet Explorer.
9) Перезагрузите компьютер.
10) Снова запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd, щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
11) В окне команд снова введите команду указанную ниже и нажмите клавишу Enter ↵.

При ¦влении окон с ошибкой 0x8007005 нажимайте кнопку ОК или клавишу Enter ↵.
12) Перезагрузите компьютер.
13) Запустите с рабочего стола установщик Internet Explorer и нажмите кнопку Установить.
14) Щелкните в окне установщика на слово Проводник.
15) Установите переключатель в значение Закрыть программы (Моя работа сохранена) и нажмите кнопку Продолжить.
После окончания установки Internet Explorer автоматически запустится.
16) Щелкните правой кнопкой мыши по значку Internet Explorer на панели задач и выберите пункт Закрепить программу в панели задач.
17) Закройте Internet Explorer, нажав при закрытии на кнопку Закрыть все вкладки.

34. Открытие сайтов использующих IPv6 протокол без внесения изменения в настройки системы.

Если у Вас отсутствует возможность открывать сайты использующие IPv6, и Вы не можете или не хотите вносить изменения в настройки системы, то Вы можете воспользоваться специальными прокси-сайтами, позволяющими открывать через них необходимые Вам ipv6 сайты.

http://www.ipv6proxy.net/

Вводите Ваш ipv6 сайт и нажимаете кнопку GO.

http://www.sixxs.net/tools/gateway/

В поле рядом с кнопкой Browse over IPv4 введите Ваш ipv6 сайт и нажимаете данную кнопку.

35. Просмотр интернет-страницы (html-документа) в предыдущей версии Internet Explorer из текущей версии.

Чтобы просмотреть как выглядит страница при открытии в предыдущей версии браузера:

1) Запустите имеющуюся у Вас версию Internet Explorer.
2) Откройте необходимую страницу или html-документ.
3) Нажмите клавишу F12.
4) Нажмите сочетание клавиш Alt+B и выберите из списка версию Internet Explorer в которой Вы желаете просмотреть html-документ.

36. Сохранение видео с интернета на компьютер.

Чтобы скачать видео с большинства сайтов Вы можете воспользоваться одним из предложенных вариантов.

Вариант 1.

Скачайте и установите специальное дополнение для интернет-браузера, которое сгенерирует Вам прямую ссылку(и) для скачивания.
Достаточно всего лишь проиграть видео в течение несколько секунд.
Такие дополнения обычно либо добавляют кнопку Download (Скачать) под просматриваемое Вами видео, либо кнопку-значек на панель навигации, панель дополнений (она же строка состояний).
Наиболее популярными из них являются:

1) SaveFrom.net helper (работает во всех браузерах)
2) Video DownloadHelper: стабильная, бета версии. (дополнение для Mozilla Firefox)
3) FVD Video Downloader (дополнение для Opera)

Вариант 2.

Скачайте и установите менеджер загрузок Internet Download Manager.
Основными плюсами данной программы, по сравнению с дополнениями, являются поддержка Internet Explorer и закачка потокового rtmp-видео (данный способ вещания используется большинством веб-камер).
Данная программа содержит специальную панель скачивания небольшого размера, которая позволит Вам скачать просматриваемое видео.
Для этого:
1) Запустите воспроизведение видеофайла и установите необходимое качество видео.
В течение несколько секунд у Вас появится панель скачивания.
2) Нажмите на значок воспроизведения на этой панели, а затем нажмите кнопку Начать качать.
3) Если Вы скачиваете потоковое видео, то нажмите кнопку Стоп, а затем кнопку Да, для прекращения записи, в остальных случаях закачка завершится сама.
Для повторной закачки потокового видео иногда может понадобится перезагрузить браузер.
Для повторной закачки обычного видео просто обновите страницу и повторите указанные выше действия.

37. Смена поиска по умолчанию в Mozilla Firefox.

Если какая-либо программа изменила в Firefox Ваш поисковой движок на собственный, то для его восстановления сделайте следующее:

Щелкните в поле Поиск на значок лупы и выберите необходимый Вам поисковой движок.
Если браузер для поиска продолжит использовать другой движок, то:

1) Введите в адресной строке Firefox:

about:config

2) Нажмите на кнопку подтверждающую, что Вы будете осторожны.
3) Введите в поле поиска параметр keyword.url
3) Измените его значение на:

Для Google.Com:
http://www.google.com/search?&q=

Для Yandex.Ru:
http://yandex.ru/yandsearch?text=

Для Bing.Com:
http://www.bing.com/search?q=

38. Добавление ссылки Поиск в Интернете при использовании поиска в меню Пуск.

В Windows Vista была предложена новая функция. При наборе текста в поле поиска меню Пуск, прямо над окном поиска появлялась ссылка "Поиск в Интернете". При её нажатии набранный текст посылался напрямую в браузер, используемый по умолчанию для поиска.
В Windows 7 данная функция по умолчанию отключена. Microsoft удалила его из меню "Пуск". Чтобы включить "Поиск в Интернете" через меню «Пуск» необходимо проделать следующие действия.

1) Откройте диалоговое меню Выполнить (Win   + R)
2) Введите gpedit.msc.
3) Перейдите в раздел Конфигурация пользователя → Административные шаблоны → «Меню «Пуск» и панель задач».
4) Нажмите правой кнопкой мыши на строке Добавить ссылку «Поиск в интернете» в меню «Пуск» и выберете пункт «Изменить».
5) В открывшемся окне установите переключатель в значение «Включить».
6) Нажмите «OK» и закройте Редактор локальной групповой политики.

Также Вы можете создать reg-файл, выполняющий данную функцию или скачать и применить уже готовый. После применения перезайдите в систему или перезагрузите компьютер.

Готовый файл: AddSearchInternetLinkInStartMenu.zip

39. Обмен файлами между компьютерами без создания локальной сети и использования облачных хранилищ данных.

Если Вам необходимо создать собственное хранилище файлов на одном компьютере, так чтобы их можно было скачать с другого компьютера, используя адрес в интернете, то воспользуйтесь предложенной ниже инструкцией.

1) Скачайте архив с программой HFS ~ Http File Server и распакуйте его в любую папку.
2) Откройте данную папку, нажмите правой кнопкой мыши на exe-файл и выберите пункт Запуск от имени администратора.
3) В случае появления окна фаервола, разрешите программе доступ в сеть.
4) В окне с запросом Do you want HFS in your shell context menu? нажмите кнопку Yes для добавления программы в контекстное меню Проводника или кнопку No для отказа.
5) Нажмите Menu → IP adress → Find external address
6) Во всплывшем окне нажмите кнопку ОК.
7) Нажмите Port:any введите 8080 и нажмите кнопку ОК.
8) В окне Virtual File System нажмите правой кнопкой мыши на косую черту рядом с домиком и воспользуйтесь:
8.1) пунктом Add files → Open для добавления файлов
8.2) пунктом Add folder from disk → Real folder для добавления папки.
9) Нажмите на кнопку Server is currently OFF.
Теперь Вы можете использовать Ваш IP-адрес и номер порта, как доступ к Вашему файловому хранилищу.
Пример: (Ваш адрес к папке будет выглядеть подобным образом)
http://159.148.75.20:8080/Temp

Если у Вас не открывается доступ по созданной Вами ссылке, то:

1) Добавьте программу Http File Server (hfs.exe) в используемый Вами фаервол и разрешите ей доступ к порту 8080 как на исходящие, так и на входящие соединения.
2.1) В настройках Вашего роутера (при его наличии) найдите настройку Переадресация портов, Перенаправление портов, Виртуальный сервер, Port Forwarding или Virtual Server.
2.2) Добавьте доступ к порту 8080 для IP-адреса присвоенного роутером Вашему компьютеру (Пример: 192.168.1.111).

40. Подключение и настройка общего доступа к сетевому принтеру.

1) Настройте локальную сеть и параметры общего доступа, в соответствии с инструкцией из совета Настройка локальной сети между компьютерами из раздела Сети (Интернет и Локальная).
2) Подключите Ваш принтер к основному компьютеру.
Если Ваш принтер подключен к USB-порту, то в большинстве случаев драйвера для Вашего принтера будут установлены автоматически.
Если Ваш принтер не был обнаружен системой, то установите драйвера для него самостоятельно.
3) Откройте меню Пуск и нажмите пункт Панель управления.
4) Установите вид просмотра Крупные значки и выберите Устройства и принтеры.
5) Щелкните на Ваш принтер и в открывшемся окне нажмите Настройка принтера.
6) Перейдите на вкладку Доступ.
7) Установите флажок Общий доступ к данному принтеру.
8) В поле Имя общего ресурса введите имя Вашего принтера и нажмите кнопку ОК.
9) На сетевом компьютере откройте меню Пуск и нажмите пункт Панель управления.
10) Установите вид просмотра Крупные значки и выберите Устройства и принтеры.
11) Нажмите на Установка принтера.
12) Щелкните на Добавить сетевой, беспроводной или Bluetooth-принтер.
13) Нажмите на Необходимый принтер отсутствует в списке.
14) Установите переключатель в значение Выбрать общий принтер по имени и нажмите кнопку Обзор.
15) Откройте компьютер к которому подключен Ваш принтер.
16) Щелкните правой кнопкой мыши на Вашем принтере и нажмите пункт Выбрать.
17) В окне Установка принтера нажмите кнопку Далее и еще раз кнопку Далее, а затем кнопку Готово.


Тонкие настройки.

1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново. Одним из решений в такой ситуации является отключение гибернации.

1) Запустите командную строку с правами администратора
1.1) В строке поиска в меню Пуск введите cmd
1.2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора
2) Введите команду и нажмите Enter ↵:

Чтобы выключить гибернацию:

Чтобы включить:

Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

2. Удаление значка "Центр поддержки" из области уведомлений на панели задач.

Если во время работы у Вас в трее появился флаг "Центра поддержки", и Вы хотите его убрать, то проделайте следующее.

1) Щелкните правой кнопкой мыши на свободное место на панели задач и нажмите пункт Свойства
2) Нажмите кнопку Настроить...
3) Щелкните по ссылке Включить или выключить системные значки
4) Напротив надписи Центр поддержки выберите из ниспадающего списка значение Выкл нажмите ОК.

3. Удаление текста под значком ярлыка или файла.

1) Щелкните правой кнопкой мыши на иконке и нажмите Переименовать.
2) Удерживая нажатой клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5, 5.
Данная комбинация позволяет добавить невидимый символ с кодом 255 в название ярлыка или файла.
Для переименования несколько ярлыков/файлов, находящихся рядом, добавляйте к каждому следующему дополнительно на один невидимый символ больше.
Для введения нескольких символов подряд отпускайте клавишу Alt после каждого введения цифр 2, 5, 5.

4. Создание (восстановление) панели быстрого запуска (Quick Launch).

1) Щелкните правой кнопкой мыши по панели задач и наведите курсор на Панели (Toolbars )
2) Нажмите на пункт Создать панель инструментов... (New Toolbar)
3) Введите путь к папке: %appdata%\Microsoft\Internet Explorer\Quick Launch и нажмите клавишу Enter ↵.
4) Нажмите кнопку Выбор папки (Select Folder).
5) Щелкните правой кнопкой мыши по панели задач и уберите флажок Закрепить панель задач.
6) Щелкните левой кнопкой мыши на панели Quick Launch и не отпуская клавиши перетащите панель в левую сторону.
7) Щелкните правой кнопкой мыши на панели Quick Launch и уберите флажки Показывать подписи и Показывать заголовок.
8) Щелкните правой кнопкой мыши по панели задач и поставьте флажок Закрепить панель задач.

5. Разблокирование файла используемого какой-либо программой для действий с ним.

Если при попытке удаления, переименования или перемещения файла или папки, система не позволяет Вам сделать этого, так как файл (папка) используется другим приложением или у Вас нет прав доступа для осуществления данного действия, то для разблокировки используемого файла (папки) Вы можете воспользоваться замечательной утилитой Unlocker.
Программа является дополнением к Проводнику Windows, а ее вызов осуществляется через контекстное меню, вызываемое нажатием правой кнопкой мыши на файле (папке).

Инструкция:

1) В соответствии с разрядностью Вашего Windows cкачайте и установите программу Unlocker
2) Нажмите правой кнопкой на файле и в контекстном меню выберите Unlocker.
3) Выберите необходимое Вам действие и нажмите на кнопку Разблокировать Все.
Если блокирующий дескриптор не найден, то после выбора необходимого Вам действия нажмите на кнопку ОК.
4) В окне Готово нажмите ОК.

Для замены защищенного файла Windows сделайте следующее:

1) Скопируйте файл(ы) для дальнейшей замены в буфер обмена.
2) С помощью инструкции выше, удалите заменяемый(е) Вами файл(ы).
3) После удаления файла(ов), вставьте заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления, так как система может восстановить файл из кэша)
4) Перезайдите в систему или перезагрузите компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, удалите содержимое папки C:\Windows\rescache и в случае необходимости проделайте описанное выше ещё раз.

6. Удаление надписей из правого нижнего угла рабочего стола.

Чтобы удалить водяные знаки на рабочем столе, такие как "Пробная копия", "Только для тестов", "Тестовый режим", воспользуйтесь одним из предложенных вариантов.

Вариант 1.

1) Откройте с помощью программы Restorator или PE Explorer файлы:

C:\Windows\System32\ru-RU\user32.dll.mui
C:\Windows\System32\en-US\user32.dll.mui

2) В разделе Строковая таблица (String) удалите строчки с 715 по 718 включительно и строки 737 и 738 .

715 %wsWindows %ws
716 %ws Сборка %ws
717 Пробная копия.
718 Только для тестов.

737 Ваша копия Windows не является подлинной
738 Тестовый режим

3) Перезагрузите компьютер.
Если после перезагрузки надписи не исчезли, то Вам необходимо перестроить кэш MUI.
4) Нажмите кнопку Пуск и в строке поиска введите cmd
5) Щелкните правой кнопкой мыши на найденной программе и выберите пункт Запуск от имени администратора
6) Введите команду: mcbuilder и нажмите Enter ↵
7) Перезагрузите компьютер.

Вариант 2.

1) Скачайте архив UniversalWatermarkRemover.zip и распакуйте его в любую папку.
2) Нажмите правой кнопкой мыши на exe-файл и выберите пункт "Запуск от имени администратора"
3) Нажмите в программе кнопку Remove.
4) В появившемся окне нажмите кнопку Да для перезапуска системы.

Для восстановления удаленных водяных знаков нажмите в программе кнопку Restore.

Если при запуске программы у Вас неактивна кнопка Remove, а активна кнопка Restore, то для удаления водяных знаков:

1) Нажмите кнопку Restore, а затем кнопку Да для перезапуска системы.
2) После перезапуска Windows, снова запустите программу Universal Watermark Remover и нажмите кнопку Restore, а затем кнопку Да для перезапуска системы.
Водяные знаки должны исчезнуть после перезагрузки системы.

7. Смена названия операционной системы c Максимальная на Ultimate.

Чтобы заменить название операционной системы Windows c Максимальная на Ultimate Вы можете воспользоваться одним из приведенных ниже вариантов.

Вариант 1. Замена c Максимальная на Ultimate в экране пользователей.

1) В соответствии с разрядностью Вашей Windows скачайте и установите английский языковой пакет.

Для 32-bit (x86) Windows 7 без SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe

Для 64-bit (x64) Windows 7 без SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe

Для 32-bit (x86) Windows 7 с установленным SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x86-en-us_783d6dd59e2ec8fb0995a059c9c121795bde46c8.exe

Для 64-bit (x64) Windows 7 с установленным SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x64-en-us_9b9c8a867baff2920507fbf1e1b4a158572b9b87.exe

2) Откройте Пуск → Панель управления → Язык и региональные стандарты
3) Перейдите на вкладку Языки и клавиатуры, выберите язык интерфейса English и нажмите кнопку ОК.
4) Нажмите кнопку Выйти из системы сейчас.
5) Зайдите обратно в систему.
6) Откройте Start → Control Panel → Region and Language
7) Перейдите на вкладку Administrative и нажмите кнопку Copy settings
8) Установите флажок Welcome screen and system accounts и нажмите кнопку ОК.
9) Нажмите кнопку Cancel и перейдите на вкладку Keyboard and Languages.
10) Выберите язык интерфейса русский и нажмите кнопку ОК.
11) Нажмите кнопку Log off now.
12) Зайдите обратно в систему.

Теперь у Вас в экране смены пользователей будет надпись Windows Ultimate.

Вариант 2. Замена файла basebrd.dll.mui из русской версии Windows на аналогичный из английской.

1) Скачайте файл Full_access.zip, разархивируйте его и примените reg-файл.
2) Откройте папку C:\Windows\Branding\Basebrd\ru-RU\
3) Щелкните на файле basebrd.dll.mui правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту"
4) Скопируйте файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US в папку C:\Windows\Branding\Basebrd\ru-RU, подтвердив замену.
4.1) В случае отсутствия папки C:\Windows\Branding\Basebrd\en-US, скачайте архив basebrd.dll.mui_en.zip с английскими версиями файлов.
4.2) Распакуйте архив и скопируйте файл basebrd.dll.mui аналогичной разрядности Вашей системы в созданную Вами папку C:\Windows\Branding\Basebrd\en-US.
5) Создайте и примените reg-файл указанного ниже содержания.

Также Вы можете скачать и применить готовый reg-файл: welcome_screen_lang.zip

6) Перезагрузите компьютер.

Вариант 3. Удаление папки C:\Windows\Branding\Basebrd\ru-RU\.

1) Скачайте файл Full_access.zip, разархивируйте его и примените reg-файл.
2) Щелкните на папке C:\Windows\Branding\Basebrd\ru-RU\ правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту"
3) Удалите папку C:\Windows\Branding\Basebrd\ru-RU\
Не обнаружив ее Windows возмет данные из английских версий файлов.
4) Создайте и примените reg-файл указанного ниже содержания.

Также Вы можете скачать и применить готовый reg-файл: welcome_screen_lang.zip

5) Перезагрузите компьютер.

Вариант 4. Использование патча.

1) Отключите антивирусное программное обеспечение
2) Скачайте файл Rename_To_Ultimate_Patch.rar и разархивируйте данный архив с патчем.
3) Запустите файл Run.cmd
4) Нажмите на клавиатуре клавишу S для замены надписи c Максимальная на Ultimate.
5) Дождитесь перезагрузки компьютера.
6) Включите антивирусное программное обеспечение.

8. Использование всей оперативной памяти в 32-битных Windows.

Данная программа добавляет второе ядро для загрузки операционной системы: ntkr128g.exe
Статьи (на английском), объясняющие причины использования 32-битными системами меньше памяти чем установлено и помогающие понять принцип работы данной программы:

http://support.microsoft.com/kb/978610
http://www.geoffchappell.com/notes/windows/license/memory.htm

Вариант 1.

1) Скачайте ReadyFor4GB от deepxw.
2) Распакуйте его в любую папку и запустите ReadyFor4GB.exe

3) Нажмите на кнопку Check, затем на кнопку Apply.

4) Нажмите на кнопку Да (Yes) для пропатчивания ntkrnlpa.exe

5) Нажмите на кнопку ОК для подтверждения места сохранения файла ntkr128g.exe

6) Закройте окно программы ReadyFor4GB.
7) Нажмите правой кнопкой мыши на файл AddBootMenu.cmd и выберите пункт Запуск от имени администратора
8) Нажмите клавишу "Y" для подтверждения или клавишу "Q" для выхода, и нажмите Enter ↵.

9) Дождитесь окончания работы скрипта и закройте программу.

10) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора

11) Нажмите клавишу "Y" для подтверждения.

Резервная копия "user32.dll.mui" будет сохранена как \Windows\System32\en-US\user32.dll.mui.backup.
Строка "en-US" зависит от языка Вашей системы.
12) Дождитесь окончания патча и перезагрузите компьютер.
13) Компьютер перезагрузится, покажет Диспетчер загрузки Windows (Windows Boot Manager) и загрузит Microsoft Windows [128GB with ntkr128g.exe]

14) Если надпись "Тестовый режим" после перезагрузки осталась на Вашем рабочем столе, то Вам надо перестроить кэш MUI. Для этого:
14.1) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора
14.2) Нажмите клавишу "R" для подтверждения.

14.3) Дождитесь окончания перестройки кэша, а затем перезагрузите компьютер.

Примечание:

П.1) Файлы обязательно запускать от имени администратора, и только в операционной системе Windows 7 x86 (32-Bit).
П.2) Для удаления записи о другой Windows из диспетчера загрузки:
П.2.1) Запустите Конфигурация системы: Панель управления → Администрирование → Конфигурация системы (или нажав Win   + R → msconfig → ОК)
П.2.2) Перейдите на вкладку Загрузка.
П.2.3) Выделите пункт загрузки, который Вы желаете удалить и нажмите кнопку Удалить.
П.3) Если после применения патча у Вас по-прежнему показывает значение менее 4 Гб, то Вы можете скачать архив с готовым файлом ntkr128g.exe и скопировать его в папку C:\Windows\System32.

Вариант 2.

1) Скачайте c официального сайта и распакуйте архив PatchPae2.zip.
2) Скопируйте файл PatchPae2.exe в папку C:\Windows\System32.
3) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵
Убедитесь, что командная строка открылась в папке C:\Windows\System32.
4) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.

5) Скопируйте сгенерированный {GUID} в буффер обмена.
5.1) Щелкните на окне команд правой кнопкой мыши и выберите пункт Пометить.
5.2) Мышью выделите {GUID}, а затем нажмите Enter ↵ для копирования текста в буффер обмена.
6) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.
Вместо {GUID} вставляйте скопированный Вами в буффер обмена сгенерированный {GUID}.
6.1) Щелкните на окне команд правой кнопкой мыши и выберите пункт Вставить.

7) Закройте окно команд и перезагрузите компьютер.

Также Вы можете воспользоваться специально созданным мною командным файлом с автоскритом.
Данный автоскрипт самостоятельно пропатчит системные файлы и добавит дополнительный пункт в загрузочное меню.
Внимание: по завершении работы патча произойдет перезагрузка компьютера!

1) Скачайте и распакуйте архив PatchPae2_Autopatch.zip.
2) Нажмите правой кнопкой мыши на файл Autopatch_Win7.cmd и выберите пункт Запуск от имени администратора.

Если Вы решите отказаться от использования всей памяти и вернуться обратно к непропатченным файлам Windows, то воспользуйтесь файлом Restore_Win7.cmd.
Данный файл также необходимо запускать от имени администратора и по окончании его исполнения также произойдет перезагрузка компьютера.

Если и после этого у Вас не появится 4 гб памяти, то видимо Ваша оперативная память не отдает доступ к необходимым адресам памяти.
Следовательно для использования полностью всей оперативной памяти рекомендую Вам установить 64-битную Windows.

9. Изменение папки открываемой по умолчанию в Проводнике.

Если Вы желаете, чтобы нажатие на кнопку Проводник (Windows Explorer) приводило в указанную Вами папку, вместо Библиотеки (Libraries), то воспользуйтесь предложенной ниже инструкцией.

1) Нажмите правой кнопкой мыши на значок Проводника в Панели задач.
2) Нажмите правой кнопкой мыши на Проводник
3) Нажмите левой кнопкой мыши на Свойства
4) Измените поле Объект (Target) на %SystemRoot%\explorer.exe /n, /e, С:\My Folder
где C:\My Folder - путь к Вашей папке.
Для запуска папки Компьютер измените на значение: %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Пуск, то вам потребуется изменить поле Объект в свойствах ярлыка Проводник в папке Стандартные (Accessories) из меню Пуск.
Комбинация клавиш Win+E откроет Проводник в «Компьютере»

10. Добавление или Ёмой запуск папки Все задачи (Расширенная Панель Управления).

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win   + R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:

1) ПКМ на Рабочем столе → Персонализация → Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win   + R → Regedit → OK) по адресу:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из Проводника, тот может открыть её введя в адресную строку Windows Explorer:

2) Нажимаете ПКМ → Создать → Библиотека
3) Переименовываете её. Например: Обои яў рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация → Фон рабочего стола → и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалит© из системы(из той папки, в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации Проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Ссылка для скачивания программы: Librarian2.zip.

13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.

Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

Для установки необходимы права локального администратора.

1) Скачайте архив MouseRate.zip и распакуйте его в папку.
2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
5) Откройте папку HIDUSBF
6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
8) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Если у Вас появится сообщение о неподписанных драйверах - не волнуйтесь, все нормально. Подпишем его программой Driver Signature Enforcement Overrider, о которой упоминалось в совете Как добавить подпись к драйверам? из раздела Установка. На время её работы UAC(Контроль учетных записей пользователей) в Windows должен быть отключен.

1) Запустите файл dseo13b.exe из папки Driver Signature Enforcement Overrider и выберите там "Enable Test Mode".
2) Перезапустите компьютер.
3) После перезапуска снова откройте файл dseo13b.exe и выберите "Sign a system file".
4) В окне пропишите: "C:\Windows\System32\Drivers\HIDUSBF.sys". Если вы сделали это правильно, то вы увидите сообщение: "Система была подписана успешно" ("The system file has been signed succesfully")
5) Снова перезапустите компьютер.
6) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
7) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

14. Перемещение системных папок и изменение их путей.

Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящим© в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей продеайте следующее:

1) Создайте новую папку, желательно с аналогичным перемещаемой папке наименованием.
2) Откройте в Проводнике (Windows Explorer) → Рабочий стол\Ваш Профиль (Например: Рабочий стол\Администратор)
3) Щелкните правой кнопкой мыши на название папки, которую Вы собираетесь переместить (Например: Мои Документы) и выберите Свойства.
4) Откройте вкладку Расположение
5) Нажмите кнопку Переместить и укажите путь к созданной Вами новой папке
6) Далее система спросит Вас: Переместить все файлы из старого расположения в новое? (Рекомендуемый ответ - Да)
7) Согласитесь с новыми параметрами применяя их и выходите.
8) Перезагрузите Компьютер.

15. Скрытие выбранных дисков из окна папки "Компьютер".

Если Вы используйте флэш-диск для ускорения работы системы (ReadyBoost) или у Вас установлен картридер который Вы используйте для чтения только одного типа карт, то у Вас может появится желание скрыть выбранные Вами диски из папки Компьютер. Чтобы сделать это Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Откройте меню Пуск, введите в строке поиска gpedit.msc и нажмите Enter ↵. (Win   + R → gpedit.msc → ОК)
2) Перейдите по пути слева Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Проводник Windows..
3) Щелкните дважды по параметру Скрыть выбранные диски из окна "Мой компьютер".
4) Установите переключатель на значение Включить.
5) В раскрывающемся списке выберите одну из предложенных комбинаций и нажмите ОК.

Вариант 2.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр NoDrives типа DWORD
4) Значение данного параметра обрабатывается Windows в двоичной системе исчисления, но указывается в реестре в десятичной или шестнадцатеричной.
Для расчета двоичного значения воспользуйтесь таблицей.

Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0

В данной таблице каждой букве соответствует цифра, которая может быть либо единицей, либо нулём. Единица означает "скрыть диск", ноль - "показать диск".
Для получения числа в двоичной системе исчисления замените для диска который Вы желаете скрыть цифру 0 на цифру 1.

Например, для скрытия дисков A, B, F, G заменив цифры с 0 на 1 получится следующий вид:

Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 1 | 1

Так как значение параметра формируется Windows в двоичной системе исчисления, а для добавления в реестр Вам необходимо данное значение в шестнадцатиричной или десятиричной системе, то для преобразования значения из одной системы исчисления в другую воспользуйтесь калькулятором Windows.

5) Запустите Калькулятор (Пуск → Все программы → Стандартные)
6) В меню программы нажмите Вид и выберите значение Программист
7) Установите переключатель в значение Bin
8) Введите значение полученное с помощью таблицы. В моем примере это число 1100011.
9) Установите переключатель в значение Dec
10) Скопируйте полученное число(Правка → Копировать или Ctrl + C) в буфер обмена или запомните его. В моем примере 99.
11) Закройте калькулятор и вернитесь в редактор реестра.
12) Измените значение параметра NoDrives на полученное Вами в калькуляторе значение.

12.1) Щелкните правой кнопкой мыши по параметру и выберите пункт Изменить...
12.2) Установите переключатель на значение Десятичная
12.3) В текстовое поле введите запомненное Вами число из калькулятора или нажмите Ctrl + V, если Вы копировали в буфер обмена.

16. Добавление или удаление элементов из контекстного меню "Отправить".

При попытке открыть более 15 элементов сразу используя меню, вызываемое правой кнопкой мыши в Проводнике, пункт меню Открыть пропадет.
Если Вам необходимо открыть большее количество элементов одновременно, то Вы можете сделать это добавив нужную Вам программу в контекстное меню "Отправить".

Для добавления своей программы в контекстное меню "Отправить":

1) Откройте папку C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo , где UserName - Ваше имя пользователя.
Также Вы можете открыть данную папку так:
1.1) В адресной строке Проводника введите команду shell:SendTo и нажмите Enter ↵.
1.2) Нажмите Win   + R, введите команду shell:SendTo и нажмите Enter ↵.
2) Создайте в открывшейся папке ярлык для необходимой Вам программы:
2.1) Используйте меню, вызываемое правой кнопкой мыши. Создать → Ярлык → Укажите расположение программы → Введите имя ярлыка
2.2) Удерживая нажатой клавишу Alt скопируйте Вашу программу в вышеуказанную папку и переименуйте ярлык.

Для удаления какого-либо из пунктов меню "Отправить":

1) Откройте Пуск → Выполнить (Win   + R)
2) Введите команду: shell:sendto и нажмите Enter ↵.
3) Удалите ярлык, соответствующий необходимому Вам пункту меню.

Для восстановления удаленных системных пунктов меню "Отправить" по умолчанию.

1) Скачайте архив SendTo.zip и распакуйте в любую папку.
2) Откройте Пуск → Выполнить (Win   + R)
3) Введите команду: shell:sendto и нажмите Enter ↵.
4) Скопируйте все ярлыки, соответствующие необходимым Вам пунктам меню, из папки куда Вы распаковали архив в папку SendTo.

17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

Скопируйте необходимый Вам ярлык в папку C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Windows\Network Shortcuts
где Имя пользователя - это имя Вашей учетной записи (Например: Администратор).

18. Замена элементов в диалоговом окне открытия/сохранения файлов.

Вы можете заменить стандартные папки из диалогового окна открытия/сохранения файлов на указанные Вами.

1) Откройте меню Пуск
2) В строке поиска введите gpedit.msc
3) Откройте папку Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Проводник Windows.\Общее диалоговое окно открытия файлов
4) Сделайте двойной щелчок мышью на Элементы, отображаемые в панели мест
5) Установите переключатель на значение Включить
6) Введите в текстовых полях напротив Элементов, пути к папкам и нажмите ОК.
Для добавления папки Рабочий стол необходимо ввести: shell:desktop

19. Изменение настроек режима самовосстановления для повышения производительности Windows.

Если Вы периодически, не реже раза в неделю, делаете проверку файловой системы и пустого дискового пространства используя утилиту CHKDSK, то возможно Вас заинтересует изменение настроек режима самовосстановления. Это изменение позволит Вам повысить производительность Вашей операционной системы, путем высвобождения ресурсов затрачиваемых на данный режим.

1) Запустите командную строку от имени администратора.
1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
2) Проверьте состояние функции самовосстановления, для этого введите в командной строке и нажмите Enter ↵:

Где ИМЯ_ДИСКА - буква присвоенная жесткому диску или одному из его разделов. Например:

3) Включите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Данное действие необходимо для получения возможности смены режима самовосстановления. Введите в командной строке и нажмите Enter ↵:

4) Перезагрузите компьютер.
5) Снова запустите командную строку от имени администратора.
6) Переключите режим общего восстановления, в режим однократной проверки ошибок при первом случае повреждения. Для этого введите в командной строке и нажмите Enter ↵:

7) Отключите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Для этого введите в командной строке и нажмите Enter ↵:

8) Перезагрузите компьютер.

Вы можете отключить функцию самовосстановления как у отдельных дисков (разделов), так и у всех сразу, повторив приведенный выше порядок действий для каждого из них. Данное решение работает только с дисками отформатированными в файловую систему NTFS.

Внимание. Побочным эффектом при выборочном отключении проверки (на отдельных дисках) может быть срабатывание защитного антивирусного программного обеспечения.

20. Изменение стандартной мелодии запуска Windows 7.

В предыдущих версий Windows, стандартная мелодия запуска находилась в папке C:\Windows\Media.
В операционной системе Windows 7 стандартная мелодия запуска содержится в файле библиотеки: imageres.dll, находящемся в папке C:\Windows\System32
Для изменения данного файла воспользуйтесь программами: Restorator или PE Explorer.
Перед изменением файла убедитесь, что у Вас очищена папка C:\Windows\rescache

В программе PE Explorer:

1) Откройте файл imageres.dll
2) Нажмите комбинацию клавиш Ctrl + R или перейдите в меню View → Resources
3) Откройте папку WAVE, щелкните правой кнопкой мыши на ресурс 5080 и выберите пункт Edit Resource
4) В открывшемся окне нажмите комбинацию клавиш Ctrl + O или на значок папки со стрелочкой.
5) Выберите мелодию в формате WAV для замены, после нажмите ОК, а затем Yes

В программе Restorator:

1) Откройте файл imageres.dll
2) Откройте папку WAVE и перетяните на ресурс 5080 файл, которым Вы хотите заменить мелодию запуска.
3) Сохраните внесенные изменения нажав Ctrl + S

Также Вы можете воспользоваться специальной программой, позволяющей легко изменить используемую мелодию запуска по умолчанию: Startup Sound Changer

21. Отключение журналирования для ускорения работы диска и освобождения дискового пространства.

Чтобы отключить журналирования для диска, сделайте следующее:

1) Запустите командную строку (Win   + R → cmd → OK)
2) Введите в командной строке:

где H: - буква диска для которго необходимо отключить журналирование.

Если возникнет необходимость включить журналирование опять, то сделать сделайте следующее:

1) Запустите командную строку (Win   + R → cmd → OK)
2) Введите в командной строке:

22. Распределение файла подкачки между несколькими жесткими дисками яў увеличения производительности системы.

Файл подкачки (Pagefile.sys) — это скрытый файл на жестком диске компьютера, который используется системой Windows по принципу оперативной памяти. Файл подкачки и физическая память вместе составляют виртуальную память. По умолчанию Windows хранит файл подкачки в разделе, в котором установлена операционная система.
Рекомендуемый размер файла подкачки должен быть примерно в 1,5 - 3 раза больше общего объема оперативной памяти.

Если у вас установлено 2 (или более) жестких диска,то для повышения быстродействия работы системы оптимальным решением будет создание одного файла подкачки в загрузочном разделе, а второго — в разделе, который используется реже (на другом жестком диске, если такой имеется). Кроме того, для второго файла подкачки по возможности лучше всего отвести отдельный раздел, где нет других данных и системных файлов. Система в первую очередь использует файл подкачки из менее загруженного раздела (а не файл подкачки из загрузочного раздела, количество обращений к которому намного больше).

По умолчанию система использует файл подкачки динамически, то есть размер файла изменяется автоматически, в зависимости от текущей потребности операционной системы. В большинстве же случаев наилучшая производительность системы достигается при статическом размере файла подкачки, так как это не требуется каждый раз изменять размер файла подкачки, что снижает его фрагментацию.

Учитывая описанное выше сделайте следующее:

1) Откройте Панель управления → Система.
2) Слева в списке нажмите ссылку Дополнительные параметры системы.
3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
4) Откройте вкладку Дополнительно и в разделе Виртуальная память нажмите кнопку Изменить.
5) Снимите флажок Автоматически выбирать объем файла подкачки.
6) Выберите диск, на котором Вы хотите создать файл подкачки.
7) Установите переключатель в значение Указать размер
8) Введите в поля Исходный размер (МБ) и Максимальный размер (МБ) одинаковые размеры создаваемого файла подкачки в мегабайтах, равного величине в 1,5 - 3 раза больше общего объема оперативной памяти.
9) Нажмите кнопку Задать,
10) Выберите следующий диск и проделайте указанные выше операции, после чего нажмите кнопку ОК.
11) Перезагрузите компьютер.

23. Регистрация необходимых и выгрузка из памяти неиспользуемых библиотек (dll-файлов).

Чтобы загрузить в память определенную библиотеку (dll-файл) Вам необходимо ее зарегистрировать. Для того, чтобы это сделать введите команду:

Если dll-файл расположен в системной папке (System32), то:

Например:

Если dll-файл расположен не в системной папке, то:

Например:

Чтобы выгрузить из памяти определенную библиотеку (dll-файл) Вам необходимо отменить ее регистрацию.

Если dll-файл расположен в системной папке (System32), то:

Например:

Если dll-файл расположен не в системной папке, то:

Например:

Если Вам необходимо освободить часть оперативной памяти, то Вы можно сделать это добавив в реестр параметр, отвечающий за автоматическую выгрузку из памяти неиспользуемых библиотек.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
3) В меню Правка выберите Создать → Параметр DWORD (32 бита).
4) Задайте имя параметра AlwaysUnloadDll
5) Дважды щелкните на данном параметре и введите значение 1.
6) Закройте редактор реестра и перезапустите компьютер.

24. Обход ограничения времени доступа к компьютеру при включенной функции Родительский контроль.

Для обхода ограничения по времени при включенной функции Родительский контроль Вам необходимо изменить системное время в BIOS.

1) Cразу после включения компьютера, до появления окна "Запуск Windows" нажмите клавишу для входа в BIOS.
Наиболее распространённые — Delete , F2 , F10 или Esc.
2) Зайдите в раздел Standart CMOS Features (Standart CMOS Setup) или перейдите на вкладку Main и измените системное время и дату на необходимую Вам.
3) Нажмите клавишу F10 для выхода с сохранением настроек.

25. Использование файлов autorun.inf и desktop.ini для задания собственных значков на съемных накопитЈх.

Если Вам необходимо, чтобы в любой системе, где Вы используете Ваш съемный накопитель (Например: флеш-диск), отображались идентичные значки яў самого устройства и/или для находящихся на нем папок, то специально для этого Вам потребуется создать файлы конфигурации или файл сведений.

Чтобы установить значок для самого устройства, создайте в любом текстовом редакторе файл autorun.inf, который сохраните в корне Вашего накопитЈ.
Данные об иконке укажите в соответствии со следующим шаблоном:

Пример 1.

Пример 2.

Чтобы установить значок для папки, находящейся на данном устройстве, создайте в любом текстовом редакторе файл desktop.ini, который сохраните в самой папке.
Данные об иконке укажите в соответствии со следующим шаблоном:

Пример 1.

Пример 2.

Чтобы во всех системах значек распознавался корректно, рекомендуется указывать значек из файлов расположенных на самом съемном накопителе.

26. Сохранение настроенных параметров групповой политики для последующего использования.

Чтобы перенести(сохранить) настройки Вашей "локальной груповой политики" выполните следующие действия.

1) Экспортируйте в reg-файлы содержимое разделов реестра:

HKEY_CURRENT_USER\Software\Policies
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Editor
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
HKEY_LOCAL_MACHINE\SOFTWARE\Policies

для 64-битных версий также:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Group Policy
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies

2) Скопируйте куда-нибудь указанные ниже папки со всем содержимым:

C:\Windows\PolicyDefinitions
C:\Windows\System32\GroupPolicy
C:\Windows\System32\GroupPolicyUsers

для 64-битных версий также:

C:\Windows\SysWOW64\GroupPolicy
C:\Windows\SysWOW64\GroupPolicyUsers

Примечание: в системе должно быть включено отображение скрытых папок и файлов.

3) После переустановки Windows примените созданные Вами reg-файлы.
Для получения полного доступа к разделам реестра воспользуйтесь решением предложенным в совете: 1. Получение полного доступа к разделу реестра, используя программу regedit или командную строку. из раздела Твики Реестра - Администрирование и Безопасность.

4) Загрузитесь в MSDaRT (ранее ERD Commander) или в командную строку с загрузочного диска (⇑ Shift + F10) и перекопируйте содержимое Вашей папки PolicyDefinitions в C:\Windows\PolicyDefinitions.

27. Удаление с панели задач кнопки "Сверуть все окна", показывающей рабочий стол.

Если Вы желаете освободить дополнительное место на панели задач, то Вы можете удалить с панели задач кнопку Сверуть все окна, показывающую рабочий стол при наведении.
Чтобы это сделать, Вам понадобится скачать программу Windows 7 Show Desktop Button Remover:
с официального сайта или зеркала.

Для удаления кнопки с панели задач нажмите в программе Remove Show Desktop Button.
Для возвращения кнопки "Сверуть все окна" обратно нажмите в программе Add Show Desktop Button.

28. Использование командной строки яў управления файлом подкачки pagefile.sys.

Для создания, изменения или удаления файлов подкачки необходима перезагрузка компьютера.

1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
2) Введите в командной строке необходимые Вам команды из указанных ниже и нажмите Enter ↵:

Чтобы снять флажок Автоматически выбирать объем файла подкачки:

или

Чтобы установить флажок Автоматически выбирать объем файла подкачки:

или

Прежде чем использовать дальнейшие команды, Вам необходимо снять флажок Автоматически выбирать объем файла подкачки.

Чтобы отключить использование существующего файла подкачки (соответствует переключателю Без файла подкачки):

где:
name="C:\\pagefile.sys" - расположение файла подкачки.

Чтобы отключить использование всех существующих файлов подкачки (соответствует переключателю Без файла подкачки):

Чтобы создать файл подкачки (соответствует переключателю Размер по выбору системы):

Чтобы принудительно задать размер существующего файла подкачки (соответствует переключателю Указать размер):

где:
name="C:\\pagefile.sys" - расположение файла подкачки.
InitialSize - исходный размер файла подкачки
MaximumSize - максимальный размер файла подкачки

Чтобы просмотреть общую информацию об имеющихся у Вас файлах подкачки:

Чтобы просмотреть дополнительную информацию о файлах подкачки, если Вы принудительно задавали их размер.

29. Разблокировка курсора мыши при достижении края экрана.

В Windows присутствует возможность продолжения движения мыши с противоположной стороны при достижении текущего края экрана.
Чтобы воспользоваться данной функцией Вам понадобится программа Unlimited Mouse.

Для активации разблокировки краев экрана.

1) Скачайте и распакуйте в любую папку архив UnlimitedMouse.zip
2) Запустите программу Unlimited Mouse и щелкните правой кнопкой мыши на значке в области уведомлений.
3) В контекстном меню нажмите на пункт Unlock mouse.

Чтобы снова включить блокировку краев экрана: либо закройте программу, либо в ее контекстном меню выберите пункт Lock mouse.

30. Сохранение изображения в программе Ножницы (Snipping Tool) с расширением написанным по умолчанию маленькими буквами.

Если Вы используете программу Ножницы (Snipping Tool) для создания скриншотов экрана, то Вы наверное заметили одну неприятную особенность в ее работе.
Данная программа сохраняет файлы с разрешениями написанными большими буквами. Многим пользователям приходится вручную их исправлять на маленькие.
(.GIF → .gif, .JPG → .jpg, .PNG → .png, .MHT → .mht)
Выполните указанные ниже действия, чтобы расширение файла по умолчанию сохранялось написанным маленькими буквами.

1) Откройте в Проводнике папку C:\Windows\System32
2) Щелкните правой кнопкой мыши на файле SnippingTool.exe и выберите пункт Свойства.
3) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
4) Перейдите на вкладку Владелец и нажмите кнопку Изменить.
5) В окне Изменить владельца на выберите группу Администраторы (Administrators), нажмите ОК.
6) Перейдите на вкладку Разрешения и нажмите кнопку Изменить разрешения.
7) Выберите группу Администраторы (Administrators) и нажмите кнопку Изменить.
8) Установите все флажки Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК, а затем кнопку Применить.
9) Во всплывшем окне с предупреждением нажмите кнопку Да.
10) Нажмите в каждом окне кнопки ОК, чтобы закрыть их.
11) Скачайте и запустите любой hex-редактор (Например: HxD)
12) Откройте в нем файл C:\Windows\System32\SnippingTool.exe
13.1) В 32-битной версии программы Snipping Tool пройдите к строке 000101E0.
13.2) В 64-битной версии программы Snipping Tool пройдите к строке 000033C0.
14) Замените код отвечающий за крупные буквы в названии расширения, на код отвечающий за маленькие буквы.

Таблица Hex-кодов для замены.

C:\Windows\System32\SnippingTool.exe
Windows 32-Bit (000101E0)
Windows 64-Bit (000033C0)
MHT | 4D 00 48 00 54 | → | mht | 6D 00 68 00 74
JPG | 4A 00 57 00 47 | → | jpg | 6A 00 77 00 67
GIF | 47 00 49 00 46 | → | gif | 67 00 69 00 66
PNG | 50 00 4E 00 47 | → | png | 70 00 6E 00 67

5) Нажмите Ctrl + S, чтобы сохранить сделанные изменения в файле.
Теперь Ваша программа Ножницы (Snipping Tool) будет сохранять расширение строчными (маленькими) буквами.

Вы можете скачать архив с готовыми версиями программы Ножницы (Snipping Tool) для обеих разрядностей Windows 7 по ссылке ниже.
SnippingToolLowercaseExtension.zip

31. Отключение и включение Панели задач.

Чтобы полностью отключить Панель задач воспользуйтесь любой из предложенных ниже программ.

Hide Taskbar
Запустите программу и нажмите сочетание клавиш Ctrl + Esc для включения или выключения отображения Панели задач.
Особенности данной программы:

- Не исчезает кнопка Пуск
- Выделение объектов и вызов контекстного меню на месте отключенной Панели задач не работает.

Ссылка для скачивания: Hide Taskbar

Taskbar Eliminator

Особенности данной программы:

- Исчезает кнопка Пуск
- Работает выделение объектов и вызов контекстного меню на месте отключенной панели задач.
- Если Вы закроете программу Taskbar Eliminator, когда Панель задач будет скрыта, то Вам необходимо будет снять флажок Автоматически скрывать панель задач в Свойствах Панели задач для повторного ее отображения.

Нажмите сочетание клавиш Alt + T для включения или выключения отображения Панели задач.
Нажмите сочетание клавиш Ctrl + Alt + T для отображения окна настроек программы.

Ссылка для скачивания: Taskbar Eliminator

32. Изменение сообщений на экране пользователей при входе или выходе из системы (Welcome, Shutting down, Logging off, Please wait).

Когда Вы входите или выходите из Windows, а также когда Вы завершаете работу компьютера, на экране пользователей отображаются соответствующие сообщения.

Если яў экрана пользователей у Вас установлен английский язык.

При входе в Windows - Welcome.
При завершении работы или перезагрузке Windows - Shutting down....
При выходе из системы - Logging off....
При ожидании системы - Please wait....

Если яў экрана пользователей у Вас установлен русский язык.

При входе в Windows - Добро пожаловать.
При завершении работы или перезагрузке Windows - Завершение работы....
При выходе из системы - Завершение сеанса....
При ожидании системы - Пожалуйста, подождите....

Чтобы изменить данные значения, воспользуйтесь предложенным ниже решением.

1) Скачайте и установите программу Unlocker.
2) Учитывая язык, использующийся у Вас на экране пользователей, откройте соответствующую папку:
Для английского языка: C:\Windows\System32\en-US\
Для русского языка: C:\Windows\System32\ru-RU\
3) Воспользовавшись советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование, задайте полный доступ к файлам: winlogon.exe.mui и wininit.exe.mui.
4) Скопируйте данные файлы на Рабочий стол.
5) В зависимости от того, какую надпись Вы желаете изменить откройте с помощью программы Restorator необходимый Вам файл.

winlogon.exe.mui - для изменения надписей: Добро пожаловать (Welcome), Завершение сеанса... (Logging off...) и Пожалуйста, подождите... (Please wait...).
wininit.exe.mui - для изменения надписей: Завершение работы... (Shutting down...)

6) Откройте раздел Строковая таблица (String) → Русский (Russian) или Английский (English).
7) Нажмите клавишу F6 для включения режима редактирования.
8.1) Для изменения надписей: Добро пожаловать (Welcome) измените в файле winlogon.exe.mui значения в строках 1002 и 1005.
8.2) Для изменения надписей: Завершение сеанса... (Logging off...) измените в файле winlogon.exe.mui значение в строке 1003.
8.3) Для изменения надписей: Пожалуйста, подождите... (Please wait...) измените в файле winlogon.exe.mui значение в строке 1008.
8.4) Для изменения надписей: Завершение работы... (Shutting down...) измените в файле wininit.exe.mui значение в строке 1002.
9)Нажмите клавиши F8, чтобы принять изменения и Ctrl + S, чтобы сохранить файл и закройте Restorator.
10) Скопируйте измененные Вами файлы winlogon.exe.mui и/или wininit.exe.mui с рабочего стола обратно в соответствующую папку:
Для английского языка: C:\Windows\System32\en-US\
Для русского языка: C:\Windows\System32\ru-RU\
11) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
12) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
13) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
14) Перезагрузите компьютер.

33. Уменьшение места занимаемого на диске папкой WinSxS.

Спустя некоторое время, после использования Windows, размер папки C:\Windows\WinSxS, в которой расположено хранилище компонентов системы может увеличиваться.

Вариант 1. Очистка устаревших компонентов.

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵.

Данная команда очистит следы от установки сервисного пакета и предыдущие версии замененных компонентов.

Вариант 2. Сжатие папки средствами Windows.

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
Вводите поочередно указанные ниже команды, нажимая после ввода каждой из них Enter ↵.
2) Перейдите в папку Windows.

3) Остановите службы "Установщик Windows" (msiserver) и "Установщик модулей Windows" (TrustedInstaller) и измените для них тип запуска.

Внимание: Перед знаком равно пробела быть недолжно, пробел обязан быть только после знака равно.

4) Сохраните в файл список управления доступом, чтобы восстановить позже

5) Установите себя в качестве владельца папки WinSxS.

6) Установите для себя права полного доступа к папке WinSxS.

7) Сожмите папку WinSxS средствами системы.

8) Восстановите TrustedInstaller в качестве владельца папки WinSxS.

9) Восстановите из ранее сохраненного файла права доступа к папке WinSxS.

Вариант 3. Создание жестких ссылок на более новые версии файла.

Внимание: Примерно в 20% случаев данный вариант может привести к непоправимым последствиям, исправить которые можно будет только переустановкой системы.
Используйте его под свою ответственность.
Перед запуском скрипта, закройте все запущенные у Вас программы, завершите запущенные процессы и не запускайте их до окончания работы скрипта.

1) Скачайте и распакуйте архив со скриптом WinsxsLite v1.88 и необходимыми программами яў его работы:

Если яў Вас приоритетными являются английский и русский языки, то переходите ко второму пункту данного совета.
Если яў Вас приоритетными являются другие языки, то для добавления/изменения приоритетных языков:
1.1) Откройте в текстовом редакторе файл WinsxsLite.bat
1.2) Добавьте необходимый Вам язык под каждой найденной строкой ru-ru=KEEP или измените его.
Например: uk-ua=KEEP, he-il=KEEP
1.3) Нажмите Ctrl + S для сохранения изменений.

2) Щелкните правой кнопкой мыши на файл WinsxsLite.bat и выберите пункт Запуск от имени администратора.
3) Введите q и нажмите Enter ↵ для создания файла конфигурации и выхода из программы.
4) Повторно запустите файл WinsxsLite.bat от имени администратора.
5) Введите 1 и нажмите Enter ↵ для выбора действий, относящихся к первой фазе работы скрипта.
6) Введите s и нажмите Enter ↵ для начала сканирования.
По результатам сканирования будет создан файл ToDo1.txt, содержащий лист файлов, которые должны быть заменены жесткими ссылками на более новые их версии.
7) Введите 1 и нажмите Enter ↵ для выбора действий, относящихся к первой фазе работы скрипта.
8) Введите a и нажмите Enter ↵ для применения результатов сканирования в дальнейшей работе скрипта.
9) Введите q и нажмите Enter ↵ для выхода из программы.
10) Перезагрузите компьютер.
11) Повторно запустите файл WinsxsLite.bat от имени администратора.
12) Введите 2 и нажмите Enter ↵ для выбора действий, относящихся к второй фазе работы скрипта.
13) Введите s и нажмите Enter ↵ для начала сканирования.
По результатам сканирования на основе выбранных языковых приоритетов, будет создан файл ToDo2.txt, содержащий лист файлов, которые должны быть заменены жесткими ссылками на их английскую версию.
14) Введите 2 и нажмите Enter ↵ для выбора действий, относящихся к второй фазе работы скрипта.
15) Введите a и нажмите Enter ↵ для применения результатов сканирования в дальнейшей работе скрипта.
Незамененными на жесткие ссылки останутся только те языковые версии файлов, которые были добавлены Вами на первом шаге данной инструкции. По умолчанию - это русские языковые версии файлов.
16) Введите q и нажмите Enter ↵ для выхода из программы.
17) Перезагрузите компьютер.
18) Повторно запустите файл WinsxsLite.bat от имени администратора.
19) Введите q и нажмите Enter ↵ для выхода из программы.


Установка.

Установка, Обновления, Языки.

1. Добавление вручную нового устройства (драйвера).

1) Нажмите кнопку Пуск, введите в строке поиска hdwwiz и нажмите Enter ↵. (или Win   + R → hdwwiz → ОК)
2) В открывшемся окне, нажмите Далее (Next)
3) В следующем окне выберите Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list) и нажмите Далее (Next)
4) Выберите в списке самую верхнюю строчку Показать все устройства (Show all devices) и нажмите Далее (Next)
5) В следующем окне нажмите на кнопку Установить с диска (Install From Disk), в нижнем правом углу.
6) В открывшемся окне нажмите кнопку Обзор (Browse) и укажите путь к файлу драйвера (inf-файл), затем нажмите ОК, а после Далее (Next)
7) Подтвердите желание установить нажатием Далее (Next)

2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

Все обновления, которые Вы скачиваете или устанавливаете через внутреннюю службу Windows Центр обновления Windows (Windows Update) хранятся в папке: C:\Windows\SoftwareDistribution\Download, а также в подпапках внутри неё. После установки обновлений, Вы можете сохранить их себе на компьютер просто скопировав из папки нужный Вам файл. Файлы содержащие в своем названии -express, могут повторно не установит©. Следовательно Вы можете их и не копировать.

3. Определение неизвестного устройства в Диспетчере устройств.

Узнайте VendorID(VEN) или DeviceID(DEV) устройства.

Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
1) Откройте Пуск → Панель управления → Диспетчер устройств
2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.
4) Зайдите на сайт: http://www.pcidatabase.com и введите одно из найденных Вами значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:

Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные

там тоже это указывается.

4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Для поиска драйверов, используя VendorID(VEN) или HardwareID(DEV) воспользуйтесь сайтом с постоянно обновляющейся базой данных: http://devid.info

Если Вам не удалось найти на данном сайте необходимые драйвера, то для поиска драйверов для Ваших устройств, Вы можете воспользоваться специальными программами: DevID Agent, либо программой DriverChecker которая имеет постоянно обновляющуюся базу драйверов.

5. Установка Windows 7 с USB флеш-накопитЈ (флешки).

Создание загрузочного флеш-диска.

Вариант 1. Используя командную строку.

Подготовка USB флеш-накопитЈ (флешки) для будущей загрузки и установки Windows 7:

1) Подключите USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
2) В строке поиска меню Пуск введите cmd.exe, щелкните на найденном правой кнопкой мыши и нажмите Запуск от имени администратора
3) Запустите утилиту управления дисками diskpart, дождитесь приглашения DISKPART>
4) Выполните команду list disk (отображает список всех дисков ПК)
5) Найдите среди них Ваш диск USB. (Пример: Disk 2)
6) Выполните команду select disk # (где # – это номер Вашего USB-драйва, полученного в предыдущей команде). (Пример: select disk 2).
Данная команда указывает diskpart, что все дальнейшие операции будут проводит© с данным диском.
7) Выполните команду clean (стирает все данные и разделы на USB диске).
8) Выполните команду create partition primary (создает новый раздел на диске).
9) Выполните команду select partition 1 (выбирает раздел, как объект для дальнейших манипЈций).
10) Выполните команду active – делает выбранный раздел активным.
11) Выполните команду format fs=NTFS – форматирует раздел в файловую систему NTFS.
12) Выполните команду assign – активирует процесс подключения устройства, получения букв для созданных разделов (если включен Автозапуск – всплывет окно, как будто Вы только что подключили USB-диск)
13) exit – выходит из diskpart в командную строку.

14) Вставьте имеющийся у Вас дистрибутив Windows 7 в дисковод, или смонтируете образ в виртуальный диск.
15) Допустим, что он у Вас установлен в дисковод H:, тогда в командной строке (не в diskpart !!!) выполните команду:

где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
16) Скопируйте все файлы с Вашего дистрибутива на Ваш USB флеш-накопитель (флешку). Используйте для этого либо Windows Explorer, либо команду:

Всё, USB-драйв готов.

Для ускорения процесса копирования опытные пользователи могут воспользоваться программой RichCopy, она является графической оболочкой команды robocopy, и включает в себя большое количество настроек. В число многочисленных параметров входят сортировка файлов по атрибутам и папкам, предотвращение ошибок, смена атрибутов, тайминг копирования, редактирование отметки о времени, установка количества потоков и размера используемого кэша.

Вариант 2. Используя программу от Microsoft - Windows 7 USB/DVD Download Tool.

1) Скачайте программу Windows 7 USB/DVD Download Tool (установщик) или Windows 7 USB/DVD Download Tool (портабельная версия)
2) Установите и запустите программу.
3) Укажите на первом шаге путь к Вашему ISO-файлу и нажмите кнопку Next.

4) Нажмите на втором шаге кнопку USB Device

5) Нажмите на третьем шаге кнопку Begin copying

6) На четвертом шаге запустится процесс создания установочного загрузочного флеш-диска.

7) По окончании процесса создания закройте программу.

Информация: Программа Windows 7 USB/DVD Download Tool форматирует флеш-диск в файловую систему NTFS. Данная система не подходит для установки Windows 7 с флеш-диска в режиме EFI.

Вариант 3. Используя программу стороннего произодителя - UltraISO.

1) Вставьте Ваш флеш-диск в USB-порт.
2) Откройте ISO-образ Windows программой UltraISO

2.1) Щелкните на ISO-файле правой кнопкой мыши и выберите пункт Открыть, используя UltraISO
или
2.2) В программе UltraISO в меню Файл нажмите на пункт Открыть, выберите нужный Вам образ Windows 7 и нажмите Открыть.

3) Убедившись, что образ открыт - выберите в меню Самозагрузка пункт Записать образ Жесткого диска
4) В списке Disk Drive:, выберите Ваш флеш-накопитель, в пункте Метод записи: USB-HDD+ и нажмите Записать.
5) В появившемся окне об уничтожении информации Подсказка, нажмите кнопку Да. Дождитесь, когда завершится запись (от 5 до 20 минут).

Особенности установки с флеш-диска.

1) Вставьте флеш-диск в USB-порт и перезагрузите компьютер.
2) Сразу после начала перезапуска нажмите на клавиатуре клавишу для входа в BIOS.
Наиболее распространённые — Delete , F2 , F10 или Esc.
3) В BIOS установите загрузку в первую очередь с USB-HDD+.
4) Сохраните настройки и выйдите из BIOS. Компьютер перезапустит© и начнет загрузку с флеш-накопитЈ.
5) Процесс установки мало чем отличается от установки с загрузочного DVD-диска, но есть один момент.
Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, необходимо снова зайти в BIOS и установить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку.
Иначе, возможно, загрузка снова пойдет с флеш-диска.

Если Вы не желаете изменять очередность загрузки в BIOS, то сразу после запуска компьютера, но до начала установки вызовите загрузочное меню и выбрать в нем Ваш флеш-диск.
Наиболее распространённые клавиши для вызова загрузочного меню — F8 , F11 , F12 или Esc.

6. Создание DVD или USB флеш-диска для установки Windows в режиме EFI (UEFI).

На компьютерах поддерживающих UEFI интерфейс для улучшения работоспособности операционной системы, рекомендуется устанавливать Windows в режиме EFI.
Для установки Windows в режиме EFI Вам понадобит© образ 64-битной операционной системы Windows 7 SP1 или новее.
Системный диск на который будет установлена Windows в режиме EFI, должен быть размечен в 64-битной версии Windows утилите Diskpart (не Acronis!!!) и отконвертирован в формат GPT.

Вариант 1. Создание USB флеш-диска для установки Windows в режиме EFI.

1) Создайте стандартный флеш-накопитель (флешку) для установки Windows 7.

Ваш загрузочный флеш-диск должен быть отформатирован в файловую систему FAT32, чтобы быть распознанным как загрузочное устройство UEFI.
Для создания флеш-диска Windows 7 в режиме EFI не используйте утилиту Microsoft - Windows 7 USB/DVD Download Tool. Данная утилита форматирует установочный флеш-диск в NTFS.

1.1) Подключите USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
1.2) В строке поиска меню Пуск введите cmd.exe, щелкните на найденном правой кнопкой мыши и нажмите Запуск от имени администратора
1.3) Введите поочередно команды, нажимая после ввода каждой из них клавишу Enter ↵.

где # – это номер Вашего USB-драйва, полученного в предыдущей команде.
Указанные далее команды приведут к полной очистке всего содержимого на выбранном диске.

1.4) Распакуйте ISO-файл образа установочного диска во временную папку и скопируйте все его содержимое на созданный Вами флеш-диск.

Для создания загрузочного диска Вы также можете воспользоваться программой UltraISO.
Данная программа сразу создает установочный флеш-диск отформатированный в файловую систему FAT32.
Инструкцию Вы можете прочитать в третьем варианте совета 5. Установка Windows 7 с USB флеш-накопитЈ (флешки). из раздела Установка, Обновления, Языки.

2) Откройте на Вашем установочном флеш-диске папку *:\efi (* - буква Вашего флеш-диска с установочными файлами Windows 7).
3) Создайте новую папку внутри данной папки с именем boot. (*:\efi\boot).
4) Скопируйте все содержимое папки *:\efi\microsoft\boot в созданную Вами папку *:\efi\boot .
5) Используя архиватор 7-zip откройте файл *:\sources\boot.wim или *:\sources\install.wim .
6) Перейдите в архиве в папку *:\sources\boot.wim\1\Windows\Boot\EFI\ .
7) Скопируйте из данной папки в архиве файл bootmgfw.efi в созданную Вами папку *:\efi\boot на флеш-диске.
8) Переименуйте скопированный файл bootmgfw.efi (*:\efi\boot\bootmgfw.efi) в bootx64.efi (*:\efi\boot\bootx64.efi)

Теперь в созданной Вами папке *:\efi\boot\ должно быть все содержимое, скопированное из папки *:\efi\microsoft\boot и файл bootx64.efi полученный из boot.wim или install.wim.
Для некоторых материнских плат дополнительно требуется скопировать файл bootx64.efi в корень флеш-диска либо с идентичным именем файла, либо с именем shellx64.efi.

Вариант 2. Создание DVD диска для установки Windows в режиме EFI.

1) Скачайте архив с программой Microsoft CD/DVD Premastering Utility и распакуйте его в любую папку.
2) Скопируйте файл oscdimg.exe в папку C:\Windows\System32.
3) Распакуйте ISO-файл образа установочного диска во временную папку. (Например, в папку D:\Win_7_x64)
4) В строке поиска меню Пуск введите cmd.exe, щелкните на найденном правой кнопкой мыши и нажмите Запуск от имени администратора
5) Введите указанную ниже команду для создания ISO-файла образа установочного диска и нажмите клавишу Enter ↵.

где:

-l - Задает метку тома. Не используйте пробелы.
-m - Игнорирует ограничение максимального размера образа.
-o - Оптимизирует хранилище используя алгоритм хэширования MD5 для сравнения файлов.
-u1 - Создает образ, который имеет как файловую систему UDF, так и файловую систему ISO 9660. Файловая система ISO 9660 записывается с использованием имен файлов 8.3, совместимых с DOS. Файловая система UDF записывается с использованием имен файлов в Юникоде.
-p - Указывает значение для идентификатора платформы в каталоге El Torito. Для представления системы UEFI используется идентификатор EF. Не используйте пробелы.
-e - Отключает эмуляцию дискеты в каталоге El Torito.
-b - Указывает файл загрузочного сектора El Torito, который будет записан в загрузочном секторе или секторах диска. Не используйте пробелы.
D:\Win_7_x64 – Указывает расположение исходных файлов.
D:\Win_7_x64_UEFI.iso – Указывает путь к создаваемому ISO-файлу.

Особенности установки Windows в режиме EFI.

- Если Вы разгоняли какое-либо аппаратное обеспечение, то восстановите настройки в стандартные значения.
- В UEFI/BIOS установите в значение AHCI для SATA режима и включите ACPI 2.0, если отключено.
- Если загрузка с устройства не происходит, то в UEFI/BIOS установите Ваш флеш-диск первым в очереди загрузки.
- Если у Вас имеются как USB 3.0 порты, так и USB 2.0, то для успешной установки рекомендуется подключить флеш-диск в USB 3.0 порт.
(Флеш-диски USB 2.0 можно успешно подключить к порту USB 3.0.) Скопируйте на Ваш флеш-диск папку с драйверами яў порта USB 3.0.

1) Подсоедините флеш-диск и перезагрузите компьютер.
2) Нажмите при загрузке клавишу для вызова Boot Menu. (В зависимости от производитЈ материнской платы F8, F11 или F12)
3) Выберите в списке "UEFI:[имя Вашего устройства]".

При установке на чистый неразмеченный диск перейдите к седьмому пункту.
При установке на диск уже имеющий какие-либо разделы и использующий MBR, вместо GPT, продолжите со следующего пункта.
4) После загрузки в установочный экран Windows нажмите ⇑ Shift + F10.
5) Введите поочередно команды, нажимая после ввода каждой из них клавишу Enter ↵.

где # – это номер Вашего жесткого диска, на который будет установлена Windows, полученный в предыдущей команде.
Указанные далее команды приведут к полной очистке всего содержимого на выбранном диске.

6) Закройте окно команд и продолжите установку Windows.
7) Укажите драйвера для порта USB 3.0, если Вы подключали флеш-диск к нему вместо порта USB 2.0.
8) В окне выбора диска для установки Windows, выделите пункт Неразмеченное место на диске и нажмите кнопку Создать у Вас автоматически будет создано 3 раздела (системный раздел EFI (ESP), резервный раздел Майкрософт (MSR) и основной раздел Windows.)
9) Выберите основной раздел и продолжите установку Windows в режиме EFI, как обычную установку.

Примечание: Если установка завершилась успешно, а система не загружается, то в UEFI/BIOS установите "Windows Boot Manager" первым в очереди загрузки.

7. Интегрирование языковых пакетов и обновлений в дистрибутив Windows 7.

Вариант 1 вручную с помощью DISM.

Для работы Вам потребуются программа DISM, входящая в состав Windows 7 и программа UltraISO

Внесение изменений в install.Wim (Для добавления языка в систему, которую Вы установите)
1) Создаете на диске D: папки ISO, Lip, Mount и mWim
2) Распаковываете в папку D:\ISO iso-образ Вашего установочного диска.
3) Изменяете текст файла lang.ini в папке D:\ISO\sources на следующий:

4) Копируете файл языкового пакета lp.cab и все файлы обновлений (MSU и CAB) в папку Lip
5) Создаете в папке D:\Lip папку uLip
6) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл install.wim
7) Запускаете командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
8) Узнаете номер индекса Вашей Windows 7, используя команду:

9) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса Вашей операционной системы (Например, для Windows 7 Enterprise независимо от разрядности он равен 1, для 32-битной версии Windows 7 Ultimate он равен 5, а для 64-битной версии Windows 7 Ultimate он равен 4), используя команду:

10) Интегрируете языковой пакет и обновления:
Для интеграции языкового пакета введите команду:

Для интеграции обновления, используйте команду аналогичную предыдущей, подставляя вместо lp.cab, наименование интегрируемого обновления. Вот пример интеграции произвольного обновления:

11) ПримҐете все настройки яў русского языка командой:

Примеры запуска команд DISM для установки локальных настроек:

12) Демонтируете образ с сохранением изменений:

Демонтаж без сохранения:

13) Удаляете файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Перемещаете файл install.wim из папки D:\mWim в папку D:\ISO\Sources

Внесение изменений в Boot.Wim (Для добавления языка в программу установки запускаемую с установочного DVD или флеш-диска при старте компьютера)
1) Распаковываете lp.cab в папку D:\Lip\uLip

2) Очищаете папку D:\Mount (удаляете из нее любые следы, которые могли остаться от работы с файлом install.wim)
3) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл boot.wim
4) Монтируете файл boot.wim в папку D:\Mount (индекс указываете 2, так как он соответствует программе установки)

5) Добавляете в boot.wim русский язык:

6) Добавляете в boot.wim файлы лицензий:

7) Изменяете текст файла lang.ini в папке D:\Mount\sources на следующий:

8) Демонтируете файл boot.wim с сохранением:

9) Перемещаете файл boot.wim из папки D:\mWim в папку D:\ISO\Sources

Работа с папкой будущего образа.

1) Добавляете русский язык, в программу установки запускаемую в среде Windows или с Live-CD:

2) Добавляете файлы лицензий, в программу установки запускаемую в среде Windows или с Live-CD.:

3) Удаляете с диска D: папки Lip, Mount и mWim
4) Используя программу UltraISO создаете iso-образ установочного диска.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программами DISM Tool или DISM GUI. Они позволяет выполнить, все необходимые Вам команды, используя графический интерфейс. С их помощью Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(Add Packages в DISM Tool или Package Management в DISM GUI). Ссылка на архив с программами: DISM_Graphical.zip

Вариант 2. Используя программу RT Se7en Lite.

Данная программа интегрирует языковой пакет только в будущую систему (install.wim). Программа установки (boot.wim) остается на оригинальном языке.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте архив с программой RT Se7en Lite и распакуйте его в любую папку.
3) Установите программу необходимой Вам разрядности в зависимости от того, с каким ISO-образом Вы собираетесь работать.
4) Нажмите кнопку Browse и выберите пункт Select OS Path.
5) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
6) В появившемся окне List of operating system выберите Вашу редакцию Windows 7 и нажмите ОК.
7) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок Integration.
8) В столбце слева нажмите кнопку Integration.
9) Перейдите на вкладку Language Packs и нажмите кнопку Add.
10) Укажите путь к Вашему cab-файлу языкового пакета и нажмите Открыть.
11) Нажмите кнопку Apply, а затем кнопку Commit.
12) В окне Do you want to enable ISO bootable task? нажмите Да.
13) Нажмите кнопку Finish, а затем кнопку Да.
14) Используя программу UltraISO создаете iso-образ установочного диска.

Вариант 3 с помощью интегратора

1) Скачайте W7Mount.zip
2) Распакуйте архив и запустите программу.
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дождитесь успешного выполнения и увидите результат.

Вариант 4 с помощью командного файла скрипта.

1) Скачайте LPIntegrator.zip
2) Распакуйте скачанный архив в папку
3) Нажмите правой кнопкой мыши на файле LPIntegrator.bat и щелкните на пункте меню Изменить
4) Измените значение параметра set LANG=ru-RU, на язык интегрируемого языкового пакета, где en-US - для английского языка, de-DE - для немецкого языка и т.д.
5) Сохраните изменения и закройте редактирование.
6) Запустите LPIntegrator.bat
7) Выберите версию Вашего образа Windows 7
8) Распакуйте ISO-образ в папку C:\7Work\DVD или скопируйте туда все файлы Вашего инсталляционного диска.
9) Скопируйте языковой пакет, который Вы хотите интегрировать в папку C:\7Work\LP
10) Скопируйте обновления, которые Вы хотите интегрировать в папку C:\7Work\CABS
11) Нажмите любую клавишу(например, Enter ↵) для продолжения.

8. Добавление и использование новых языков интерфейса в Windows.

Для добавления языков интерфейса необходимо установить дополнительные языковые файлы. После установки языковых файлов можно просматривать текст мастеров, диалоговых окон, меню, разделов справки и прочих элементов Windows на другом языке. Существуют 2 варианта добавления новых языков интерфейса: первый - через Центр обновления Windows(Windows Update), а второй - скачав и установив файл языкового пакета вручную. Перед началом работы измените в Панели Управления (Control Panel) способ просмотра(View by), вместо Категория(Category) на Крупные (Large icons) или Мелкие значки(Small icons).

Вариант1. Через Центр обновления Windows(Windows Update)

1) Откройте Центр обновления Windows

Пуск → Все программы → Центр обновления Windows (Start → All Programs → Windows Update)
или
Панель управления\Все элементы панели управления\Центр обновления Windows (Control Panel\All Control Panel Items\Windows Update)

1a) Также вы можете нажать Win   + R, в поле Выполнить ввести указанную ниже команду и нажать ОК

2) Выберите пункт Необязательных обновлений XX шт. доступны (XX options updates are available)
3) Поставьте флажок напротив нужного Вам языкового пакета (Language Pack) и нажмите ОК

Вариант 2. При наличии файла языка интерфейса lp.cab

1) Заходите в Панель Управления(Control Panel)
2) Открываете Язык и региональные стандарты (Regional and Language)
3) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
4) Нажимаете Установить или удалить язык (Install/uninstall languages...)
4a) Также вы можете нажать Win   + R, в поле Выполнить ввести lpksetup и нажать ОК
5) Нажимаете Установить языки интерфейса (Install display languages)
6) Нажимаете кнопку Обзор...(Browse...)
7) Указываете путь к папке с lp.cab и нажимаете ОК
8) Выбираете необходимый Вам язык и нажимаете Далее(Next)

Вариант 3. Установка файла скачанного с сервера Windows Update

Вы можете установить необходимый Вам язык интерфейса, скачав exe-файл по прямой ссылке с сервера Windows Update и просто запустив его.

Смена Вашего языка интерфейса на новый:

1) Заходите в Панель Управления(Control Panel)
1.1) Открываете Язык и региональные стандарты (Regional and Language)
1.1a) Также вы можете нажать Win   + R, в поле Выполнить ввести intl.cpl и нажать ОК
1.2) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
2) Выбираете в пункте Выберите язык интерфейса (Choose a display language:) нужный Вам язык и нажимаете ОК
3) Нажимаете кнопку Выйти из системы сейчас (Log off now)
4) В появившемся экране выбираете своего пользователя.
5) В случае необходимости вводите свой пароль и попадаете в Windows на выбранном Вами языке

9. Автоматическое введение ключа при инсталляции Windows.

Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.

Вариант 1. Для 32-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

Вариант 2. Для 64-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузит© в специальный режим Windows.
1) Сразу после включения компьютера нажмитеF8. Далее Вы попадете либо в меню Дополнительные варианты загрузки, либо в меню выбора диска для загрузки.
2) Вам нужно меню Дополнительные варианты загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter ↵, а затем быстро нажмитеF8 до начала запуска Windows.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter ↵
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов.
Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобит© программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С официального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то Вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появит© маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи воспользуйтесь советом 6. Удаление надписей из правого нижнего угла рабочего стола. из раздела Тонкие настройки.

Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriver Plus она добавит небольшое изменение в загрузчик, которое автоматизирует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriver Plus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriver Plus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник → Компьютер → Локальный диск (C:)
1.2) В Панели меню выберите Сервис → Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriver Plus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win   + R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом месте нахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву (Например: Z) и нажмите кнопку OK
2.5) Откройте Проводник → Компьютер → Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriver Plus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriver Plus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win   + R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник → Компьютер → Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriver Plus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win   + R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник → Компьютер → Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriver Plus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriver Plus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriver Plus перезагрузитесь.

В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

11. Где можно скачать последние обновления для Windows 7?

Компания Microsoft периодически выпускает обновления для Windows.
Чтобы скачать какое-либо из них, воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1.

1) Откройте в браузере Internet Explorer официальный сайт Каталог Центра обновления Майкрософт:

http://catalog.update.microsoft.com/v7/site/home.aspx

2) Когда сайт предложит установить надстройку Microsoft Update Catalog, нажмите кнопку Установить.
3) При ¦вления окна Контроля Учетных Записей нажмите кнопку Да.
4) В текстовом поле поиска введите номер Вашего обновления и нажмите кнопку Поиск (Search).
5) Нажмите кнопку Добавить (Add), чтобы добавить необходимое Вам обновление в корзину загрузки. (Не забывайте про наличие разрядности у обновлений!)
6) Щелкните пункт просмотреть корзину (view basket) под полем Поиск, чтобы просмотреть корзину загрузки.
7) Нажмите кнопку Загрузить (Download) для начала загрузки обновления.
8) В открывшемся окне нажмите кнопку Обзор (Browse), укажите папку, в которую будет сохранено обновление и нажмите ОК.
Также Вы можете ввести полный путь к папке вручную.
9) Нажмите кнопку Продолжить (Continue), чтобы начать загрузку.
10) После завершения загрузки, нажмите кнопку Закрыть (Close), чтобы закрыть окно загрузки.

Также Вы можете поискать обновления на сайтах:

Microsoft Download Center.
Microsoft Knowledge Base monitoring

Вариант 2.

1) Скачайте файл WHDownloader.zip и распакуйте архив в любую папку.
2) Щелкните правой кнопкой мыши на файл програмы и выберите пункт Запуск от имени администратора.
3) Нажмите на стрелочку в верхнем левом углу (Download all Latest Update Lists) для скачивания списков всех последних обновлений.
4) Выберите в ниспадающем списке (Select a Category) версию Вашей Windows соответствующей разрядности (Например: Windows 7-x64).
5) Установите флажки напротив обновлений, которые Вы желаете скачать.
6) Нажмите на кнопку Download в нижнем левом углу.
Обновления будут скачены в папку Updates, находящуюся в папке программы WHDownloader.

12. Повышение оценки производительности жесткого диска.

Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

Для устранения неполадок перед изменением режима SATA загрузочного диска включите драйвер AHCI в реестре. Для этого выполните следующие действия:

1) Закройте все программы Windows.
2) Откройте меню Пуск, в окне Начать поиск введите regedit и нажмите клавишу ВВОД.
3) Если откроется окно Учетные записи пользователей, нажмите кнопку Продолжить.
4) Найдите и выберите один из следующих подразделов реестра:

5) На правой панели щелкните правой кнопкой мыши параметр Start в столбце Имя, затем нажмите Изменить.
6) В поле Значение введите 0 и нажмите кнопку ОК.
7) В меню Файл выберите команду Выход, чтобы закрыть редактор реестра.

13. Автоматическая установка OEM-информации.

Предлагаю Вашему вниманию файл ответов, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

Используемые параметры:

Extend - расширение раздела до размеров всего свободного неразмеченного пространства на диске. Если установлено значение true, раздел будет расширен. Если установлено значение false, необходимо указать размер с помощью параметра Size. Для каждого раздела задается либо значение параметра Extend, либо значение параметра Size, но никак не оба.
Order - порядковый номер операции по созданию раздела на диске. Нумерация начинается с единицы. В примере указано значение 1, т. е. раздел будет создан первым.
Size - размер раздела в мегабайтах.В первый раздел будет установлена Windows 7, поэтому не рекомендуется создавать раздел малого размера.
Type - тип раздела. Можно создать основной (Primary) или дополнительный (Extended) раздел.
Active - назначает раздел активным. Для назначения используется значение true. Так как на основной раздел установится Windows 7, то этот раздел следует назначить активным.
Format - формат файловой системы. Установка Windows 7 возможна только на файловую систему NTFS.
Label - метка тома. Установите по своему усмотрению.
Letter - буква диска. Логично задать для первого раздела букву C.
PartitionID - идентификатор раздела, по сути - его порядковый номер. Нумерация начинается с единицы.
DiskID - идентификатор диска. Значение 0 обозначает первый физический диск
NetworkLocation - задает тип сети, к которой подключается пользователь
WillWipeDisk - удаление всех разделов жесткого диска. Если установлено значение true, все разделы будут удалены.
WillShowUI - отображение интерфейса программы установки. Значение OnError предписывает программе установки отображать интерфейс в случае ошибки.
InputLocale - раскладка клавиатуры.
SystemLocale - язык для программ, не поддерживающих Юникод. Для русской Windows 7 указывается ru-RU, а для английской - en-US.
UILanguage - язык интерфейса операционной системы.
UserLocale - пользовательские параметры отображения чисел, денежных единиц, дат и времени.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.
Для 32-битных систем замените значение processorArchitecture="x64" на processorArchitecture="amd86"

Внимание!!! Предложенный файл ответов в данном совете стирает все разделы и логические диски при установке.

Для редактирования файла Autounattend.xml в графическом режиме воспользуйтесь программой Windows System Image Manager (WSIM), входящей в состав Microsoft Windows AIK.
Если же Вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам №9 и №14 из данного раздела (Установка, Обновления, Языки.).

14. Автоматическая установка OEM-Logo.

Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

1) Создайте в папке \Sources установочного диска папки: \$OEM$\$$\SYSTEM32\
2) Скопируйте Ваш файл oemlogo.bmp, содержащий изображение с Вашим логотипом в папку \Sources\$OEM$\$$\System32\oemlogo.bmp установочного диска.
3) Для 64-битных систем замените значение processorArchitecture="x86" на processorArchitecture="amd64"

15. Установка локальных наборов тем и настроек, а также пакетов обновления, предоставленных в виде CAB-файлов.

Чтобы добавить локальный набор тем и настроек в Windows, выполните следующие действия:

1) Найдите локальный набор тем и настроек и скопируйте его в доступное расположение.
2) Запустите командную строку от имени администратора.
2.1) Нажмите кнопку Пуск и в строке поиска введите cmd
2.2) Щелкните правой кнопкой мыши на найденном файле cmd.exe и выберите пункт Запуск от имени администратора
3) В окне командной строки введите следующую команду:

Например, если Вы скопируйте файл Windows-LocalPack-RU-Package.cab в папку «C:\Local Packs», то Вам необходимо будет ввести следующую команду:

Содержимое всех локальных наборов тем и настроек устанавливается в ходе работы программы установки Windows в скрытый каталог "%WINDIR%\globalization\MCT"

Описанным выше способом, можно установить любой пакет обновления, предоставленный в виде CAB-файла.

16. Автоматическая установка обновлений Windows.

Вариант 1. Использование Bat-файла (для MSU и CAB обновлений).

1) Создайте папку Updates
2) Создайте в папке Updates файл Update.bat с указанным ниже содержанием.
2.1) Для этого скопируйте код в любой текстовый редактор (например, Блокнот).
2.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .bat
2.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Update.bat")
2.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

3) Создайте в папке Updates папки CAB и MSU.
4) Поместите в папку CAB все файлы обовлений с расширением .cab (Пример файла: Windows6.1-KB123456-x64.cab)
5) Поместите в папку MSU все файлы обовлений с расширением .msu (Пример файла: Windows6.1-KB123456-x64.msu)
6) Запустите Update.bat и дождитесь закрытия окна командной строки.

Для правильности работы скрипта проверьте у себя соблюдение следующих пунктов:

1) Убедитесь, что разрядность обновлений (х86\х64) соответствует разрядности Вашей системы.
2) В имени файла не должно быть слова EXPRESS, такое обновление копировать бесполезно, оно не установится.
3) Файл Update.bat должен находит© в папке на один уровень выше папок CAB и MSU.

Скачать готовый Update.bat

Вариант 2. Использование программы Windows 7 Update Pack Tool.

Наиболее простым решением для автоматической установки обновлений является программа Windows 7 Update Pack Tool.

Инструкция:

1) Скачайте Windows 7 Update Pack Tool
2) Создайте новую папку. Например: Updates
3) Поместите в неё файл Update.exe
4) Поместите в неё все обновления с расширениями .msu и .cab, которые Вы желаете установить.
5) Создайте внутри Вашей папки Updates папку SpecialUpdates
6) Поместите в папку SpecialUpdates все обновления с расширениями .msi и .exe, которые Вы желаете установить.
7) Запустите файл Update.exe
8) Выберите пункт Install updates. Для этого нажмите на клавиатуре цифру 1 и затем Enter ↵.
9) Программа произведет поиск обновлений: .msu и .cab в главной папке, и .msi и .exe в папке SpecialUpdates
10) Нажмите любую клавишу(например: Enter ↵) и программа установит обновления
11) По окончании установки программа напишет список устанавливаемых обновлений и попросит перезагрузки.
12) Перезагрузите компьютер и Вы получите систему с установленными обновлениями.

17. Отключение сообщения "Эта программа, возможно, установлена неправильно".

Если при установке какого-либо приложения Вы решили отменить установку или в случае, когда с приложением были известны какие-либо проблемы совместимости, Windows может отобразить подобное окно:

За данную функцию отвечает "Помощник по совместимости программ". Вы можете отключить его используя следующие варианты:

Вариант 1.

1) В строке поиска меню Пуск или в окне Выполнить (Win   + R) введите services.msc и нажмите Enter ↵
2) Щелкните дважды на службу "Служба помощника по совместимости программ" ("Program Compatibility Assistant") или щелкните правой кнопкой мыши на ней и выберите Свойства
3) Измените значение Тип запуска на "Отключена".
4) Нажмите кнопку Остановить ("Stop")

Вариант 2.

1) В строке поиска меню Пуск или в окне Выполнить (Win   + R) введите gpedit.msc и нажмите Enter ↵.
2) Перейдите в Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Совместимость приложений
3) Щелкните дважды на параметре "Отключение помощника по совместимости программ" или щелкните правой кнопкой мыши на нем и выберите Изменить
4) Выставите значение "Включить".

Вариант 3.

Отключение для текущего пользователя.

Отключение для всех пользователей.

18. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1.

По указанным ниже ссылкам Вы сможете скачать языковые пакеты для Windows 7 и языковые пакеты для Windows 7 с установленным сервисным Пакетом обновлений 1 (SP1) напрямую с сайта Microsoft.

Чтобы скачать необходимый Вам языковой пакет нажмите на прямую ссылку напротив выбранного Вами языка.
Также Вы можете самостоятельно вручную сделать полную ссылку. Для этого добавьте к имени файла языкового пакета (независимо от разрядности) указанному в колонке Прямая ссылка место расположения файла:

Для Windows 7:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/
Например, если ¤ файла языкового пакета латышского языка для 64-битной версии Windows 7: windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe

Для Windows 7 SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/
Например, если ¤ файла языкового пакета латышского языка для 32-битной версии Windows 7 SP1: windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x86-ar-sa_210ccc96338a1ff683803eb4034e5f53d6d54c97.exe
Bulgarian | Болгарский | windows6.1-kb972813-x86-bg-bg_2e5d91b00775e0f974d4ec213fc20d470ff6850e.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x86-zh-cn_ab024143b556395e6638e26712b1e0f3bc031fcf.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x86-zh-hk_90617b75cfaab716a43e7c082b00490a6d475376.exe
Croatian | Хорватский | windows6.1-kb972813-x86-hr-hr_d8a4131aee5d5de039a3a0dc517ca0c07ebc3472.exe
Czech | Чешский | windows6.1-kb972813-x86-cs-cz_2759680ec6e2f4a7629c7d02b1fbce0a0d410a4e.exe
Danish | Датский | windows6.1-kb972813-x86-da-dk_e1c57a4dcbd336ac73e349a9bb9d30de17ac093f.exe
Dutch | Нидерландский | windows6.1-kb972813-x86-nl-nl_194a2ca7b589e77b0be73b822f77760823183c51.exe
English | Английский | windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe
Estonia | Эстонский | windows6.1-kb972813-x86-et-ee_3a99769fac5d6a11e6616297f842a9074c045699.exe
Finnish | Финский | windows6.1-kb972813-x86-fi-fi_dd1973cc63ab7dea0e5d660af06869a8beefe36a.exe
French | Французский | windows6.1-kb972813-x86-fr-fr_1878fd391b990054787a14b0db4a5db00b793bf1.exe
German | Немецкий | windows6.1-kb972813-x86-de-de_1b86ff9b8f4c517dd341d76f24c74399278b05fc.exe
Greek | Греческий | windows6.1-kb972813-x86-el-gr_1f366d5e4fbde7df89b106821236fc1d3b3c9230.exe
Hebrew | Иврит | windows6.1-kb972813-x86-he-il_a3d6a6ae858f33ffa11a14c2a966e6603c134ef9.exe
Hungarian | Венгерский | windows6.1-kb972813-x86-hu-hu_12feb47da4bb28f60b6a30d379044356581c20f8.exe
Italian | Итальянский | windows6.1-kb972813-x86-it-it_079a3afeb88f14d24a3b4204812225e78c2e0bb8.exe
Japanese | Японский | windows6.1-kb972813-x86-ja-jp_08758c23cc64a53949072d53dd7bf6bbc8b45420.exe
Korean | Корейский | windows6.1-kb972813-x86-ko-kr_bb2de1652c37394be4de87438661b129f8b56908.exe
Latvian | Латышский | windows6.1-kb972813-x86-lv-lv_8b7a0b361dd37f7cd3926f798a79a90d378b18b2.exe
Lithuanian | Литовский | windows6.1-kb972813-x86-lt-lt_7aee9ce232cb46701f479fafdb0aea369ce1ad6a.exe
Norwegian | Норвежский | windows6.1-kb972813-x86-nb-no_d65ea89195cf5f7d3170ccb1db7bae3c157f5b24.exe
Polish | Польский | windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x86-pt-br_0a3fe79820d6d199dd43495d4efa5c40f270e45a.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x86-pt-pt_4165bd9cd083abd8ddd81986e18b1fd86aab5ce9.exe
Romanian | Румынский | windows6.1-kb972813-x86-ro-ro_e1c324236046eb608e478570cf4396776ff02a72.exe
Russian | Русский | windows6.1-kb972813-x86-ru-ru_f4df4bcb8d3194323f17a086a17f46dd0c9c492a.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x86-sr-latn-cs_6e049bae4d75b82405b28455e2def0a0d0055a9c.exe
Slovak | Словацкий | windows6.1-kb972813-x86-sk-sk_dd2ce36a7e94fceff650cb892b8c954b8af6025a.exe
Slovenian | Словенский | windows6.1-kb972813-x86-sl-si_17786270766d556ba9bf3693762cb98805df9f50.exe
Spanish | Испанский | windows6.1-kb972813-x86-es-es_1943a073d8f00e387301deb22cd177bf77319ee8.exe
Swedish | Шведский | windows6.1-kb972813-x86-sv-se_687085e8bbdf9c17a668b801f28f7f9c74e7a86a.exe
Thai | Тайский | windows6.1-kb972813-x86-th-th_780885dd42c039d9926ac004c76ba3ba9c30c6d0.exe
Turkish | Турецкий | windows6.1-kb972813-x86-tr-tr_13015cb75811f874c83fdd679beb4c22c930a57c.exe
Ukrainian | Украинский | windows6.1-kb972813-x86-uk-ua_0a467bf14bc4f524c18877f570a20c58e91ceba9.exe
Английское название языка | Русское название языка | Прямая ссылка

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x64-ar-sa_aaac936bd625c12b607dffea19fab8be9cfa28f6.exe
Bulgarian | Болгарский | windows6.1-kb972813-x64-bg-bg_155634f17868659db4b65cfeff57059b2436515f.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x64-zh-cn_a649e9af1e28514d48bdc51f7956be08060e54bc.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x64-zh-hk_d428bc1cca4aea20163936e6687221c0e6b99ec4.exe
Croatian | Хорватский | windows6.1-kb972813-x64-hr-hr_06468f799a1c1f295bc3abbc85c14116e2645122.exe
Czech | Чешский | windows6.1-kb972813-x64-cs-cz_f136df3188c54ff234ca77253fee2cf3e91966b7.exe
Danish | Датский | windows6.1-kb972813-x64-da-dk_2b7590d389ca96af6f367408150cb6bc9aa8f4b4.exe
Dutch | Нидерландский | windows6.1-kb972813-x64-nl-nl_2ac14543f6e46c61ae226d7f0f5aee7f4d500e9f.exe
English | Английский | windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe
Estonian | Эстонский | windows6.1-kb972813-x64-et-ee_3c0479d7049109bcb42fd9ec59d1c65449704687.exe
Finnish | Финский | windows6.1-kb972813-x64-fi-fi_4378f72d1233b00e2bdfc680a13f62ae11ab0fcb.exe
French | Французский | windows6.1-kb972813-x64-fr-fr_0e50cd2ea794e4cdfac861b194d2e996b7bbc8d8.exe
German | Немецкий | windows6.1-kb972813-x64-de-de_399ac15b2d55fd5dea0770d98825d7e75f4ad533.exe
Greek | Греческий | windows6.1-kb972813-x64-el-gr_9ae588ba70896f9100a10cb8ed68a79678d6fc32.exe
Hebrew | Иврит | windows6.1-kb972813-x64-he-il_86c22105bb32269c9c0deaf2710fcb1531a29817.exe
Hungarian | Венгерский | windows6.1-kb972813-x64-hu-hu_e5c47bffe398b9ace42d4326de2646a6172d39b5.exe
Italian | Итальянский | windows6.1-kb972813-x64-it-it_3f0f5d78202e074e17a495beec821e1d326a8e2a.exe
Japanese | Японский | windows6.1-kb972813-x64-ja-jp_9d73b1c1270deacbe7a2329559476a94daddb848.exe
Korean | Корейский | windows6.1-kb972813-x64-ko-kr_e6b3322c3865cfd328d84376e192c4f9d41aa0e6.exe
Latvian | Латышский | windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe
Lithuanian | Литовский | windows6.1-kb972813-x64-lt-lt_ede5a878aae2b0d64e81ff739e950b6f105df580.exe
Norwegian | Норвежский | windows6.1-kb972813-x64-nb-no_1b7f93a0906a62eecd6b200979f8df986a7556f1.exe
Polish | Польский | windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x64-pt-br_276b65f3b6b2657c8fe936f9841dc1243e02dc7b.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x64-pt-pt_f8310aa4a73841aec29b3f4e74ecaece56b695e9.exe
Romanian | Румынский | windows6.1-kb972813-x64-ro-ro_810f2d590dd5aac92561eea5884ed1c70f34dbd9.exe
Russian | Русский | windows6.1-kb972813-x64-ru-ru_f0acfc688d609ee45d43cc60c6412a3071a665bd.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x64-sr-latn-cs_275e0a17cbec543aa1bd7eebc883a1d21c11b514.exe
Slovak | Словацкий | windows6.1-kb972813-x64-sk-sk_15f397de2ceaaff8dbfe670bcc6c013791a297c3.exe
Slovenian | Словенский | windows6.1-kb972813-x64-sl-si_8cfc82e0d15ed94634d3da69674008dc56755b93.exe
Spanish | Испанский | windows6.1-kb972813-x64-es-es_2e593c26d9e23ad8176224a53c68a04f996ee014.exe
Swedish | Шведский | windows6.1-kb972813-x64-sv-se_1f4c415e0f4ca77064d597975f6ac7a9e0b8af63.exe
Thai | Тайский | windows6.1-kb972813-x64-th-th_080c8631d44a53c34ffdab8fd73820572dd87be4.exe
Turkish | Турецкий | windows6.1-kb972813-x64-tr-tr_6bd6660158289e0b5d4b5a7f7fded6e3528a9a04.exe
Ukrainian | Украинский | windows6.1-kb972813-x64-uk-ua_c6c4e44c9d903049a4c60fed9d42effa18f345bd.exe
Английское название языка | Русское название языка | Прямая ссылка

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x86-ar-sa_5add6e4a36127029d431ba98d99708c44ef9b53f.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x86-bg-bg_a8a5013e477366119cfdc5fbda43b904755db450.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x86-zh-cn_ae61ea226215f96fc95be33201ffc96755ac7eb5.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x86-zh-hk_411a6bb68728f12f5ced712d9a33fee9ebe0b0b3.exe
Croatian | Хорватский | windows6.1-kb2483139-x86-hr-hr_685e217ce007af8005db4726087893d04e19dade.exe
Czech | Чешский | windows6.1-kb2483139-x86-cs-cz_bb5061f4bd24437dd31a3714e1b54318ced7e63a.exe
Danish | Датский | windows6.1-kb2483139-x86-da-dk_67fecaab0a940e2e537bc8dcd8a9ebb8ab4ed102.exe
Dutch | Нидерландский | windows6.1-kb2483139-x86-nl-nl_b7e1c3046b218fb45a665ab5f5ed8a5ea8125760.exe
English | Английский | windows6.1-kb2483139-x86-en-us_783d6dd59e2ec8fb0995a059c9c121795bde46c8.exe
Estonian | Эстонский | windows6.1-kb2483139-x86-et-ee_d0f798de315b696bf560b559f6f90064687c0b7b.exe
Finnish | Финский | windows6.1-kb2483139-x86-fi-fi_5259ca6a22a981dbdee352dde5b8e65c2fddd407.exe
French | Французский | windows6.1-kb2483139-x86-fr-fr_f57427487dfc2f49da67cac22480ab1f48983d22.exe
German | Немецкий | windows6.1-kb2483139-x86-de-de_acb9b88b96d432749ab63bd93423af054d23bf81.exe
Greek | Греческий | windows6.1-kb2483139-x86-el-gr_5aeecda7e1d689a083975128901da8156751dfc5.exe
Hebrew | Иврит | windows6.1-kb2483139-x86-he-il_1849d14777a76c7c5b4ef766490dccc8aed5c56b.exe
Hungarian | Венгерский | windows6.1-kb2483139-x86-hu-hu_a7a5af62c59ab7a4e8cb0f21242b42606b95195b.exe
Italian | Итальянский | windows6.1-kb2483139-x86-it-it_1d54a8d0047674fc1b5b6f41292a0074d9fe3cc5.exe
Japanese | Японский | windows6.1-kb2483139-x86-ja-jp_bc46078938ae9129c7ce86a9c176fa517e4c0a3d.exe
Korean | Корейский | windows6.1-kb2483139-x86-ko-kr_18f213428cc6fde96d8c76c6dd91446348e86ce6.exe
Latvian | Латышский | windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe
Lithuanian | Литовский | windows6.1-kb2483139-x86-lt-lt_297c5ee6e98ab646b14f1492716b67cc0970fcd8.exe
Norwegian | Норвежский | windows6.1-kb2483139-x86-nb-no_5bd6fc76ad54b7a232d4ceb4a5f5c7c366bf90b6.exe
Polish | Польский | windows6.1-kb2483139-x86-pl-pl_c460a8c1392d7f3d35d1c0b37e56017d3552d245.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x86-pt-br_6e1d337b2fd56669d461e82601aa51004fecbd24.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x86-pt-pt_5cc92ef98ed177b2f6bbae3a0420ee2f12764fab.exe
Romanian | Румынский | windows6.1-kb2483139-x86-ro-ro_d8d9b2b4c5c457fe6a7dcb09a5f645cfe77cc30c.exe
Russian | Русский | windows6.1-kb2483139-x86-ru-ru_6532a8f36ad7d15277d5d60da92555f0fbee4daa.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x86-sr-latn-cs_e3d9acfcc9f608cf7687bd3b5ee7f0d9658b7bc9.exe
Slovak | Словацкий | windows6.1-kb2483139-x86-sk-sk_4c7b17a6cb292b09bede4c8731ad4f24cd09ab2a.exe
Slovenian | Словенский | windows6.1-kb2483139-x86-sl-si_de7f366819e1c12954557e3e65b7c0f059f49b67.exe
Spanish | Испанский | windows6.1-kb2483139-x86-es-es_6aef75f7d83edaabc2a921a6b157cc7005628286.exe
Swedish | Шведский | windows6.1-kb2483139-x86-sv-se_bd65af75e8995bd865d93c8d8c8a35091499083f.exe
Thai | Тайский | windows6.1-kb2483139-x86-th-th_8248f2b209d65a39ddaeb36e1782fcc0f6664f73.exe
Turkish | Турецкий | windows6.1-kb2483139-x86-tr-tr_228dfa5fbaa4606b17f93d6fcd51c8c85c0f1fd3.exe
Ukrainian | Украинский | windows6.1-kb2483139-x86-uk-ua_7f01db99ad2b2d41598bfc71aaa9bd4be04b6369.exe
Английское название языка | Русское название языка | Прямая ссылка

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x64-ar-sa_f07f2cc7b55b17076eebceea2c2c2826b08b8f63.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x64-bg-bg_e4c9392592ed2d4a8c7ec68270b5140430df197a.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x64-zh-cn_2c1884b4fdf6c8e91986369d88bbcaae01c6f187.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x64-zh-hk_285282b1e2f750eeed91466918443b657968d977.exe
Croatian | Хорватский | windows6.1-kb2483139-x64-hr-hr_e7c6d648436d81466af331ab1ece07dd22be5fda.exe
Czech | Чешский | windows6.1-kb2483139-x64-cs-cz_1ea5b71d701e2480017b464b6560a2987e0d8971.exe
Danish | Датский | windows6.1-kb2483139-x64-da-dk_d753d19cc1a0fe95aef21548193393c04a6a8024.exe
Dutch | Нидерландский | windows6.1-kb2483139-x64-nl-nl_12c90c70d408b08f51f500d6e974878a5d662398.exe
English | Английский | windows6.1-kb2483139-x64-en-us_9b9c8a867baff2920507fbf1e1b4a158572b9b87.exe
Estonian | Эстонский | windows6.1-kb2483139-x64-et-ee_b4fd94f6e461e21b7eec54d1e379e2807861aea2.exe
Finnish | Финский | windows6.1-kb2483139-x64-fi-fi_223465e1b382484d1d82f8f2ccfcd9ed2f902c76.exe
French | Французский | windows6.1-kb2483139-x64-fr-fr_0f18e2a244dd9ff04664112a82776d2bd2177798.exe
German | Немецкий | windows6.1-kb2483139-x64-de-de_4f4ce6bd38530b4a02199172863b21a0cba13773.exe
Greek | Греческий | windows6.1-kb2483139-x64-el-gr_583791fea2fea71725388a746844d5be6488ca45.exe
Hebrew | Иврит | windows6.1-kb2483139-x64-he-il_617029400059f0847d7d90d4da673ae4ed43ebd9.exe
Hungarian | Венгерский | windows6.1-kb2483139-x64-hu-hu_1c298d99baf7af3d830dcd1e2632eeb65d7ee395.exe
Italian | Итальянский | windows6.1-kb2483139-x64-it-it_6d8223c065d6974d833d0eaa162f3ceb7680850f.exe
Japanese | Японский | windows6.1-kb2483139-x64-ja-jp_aeaf7e9b0b6c2173bf757330017a7f655f1f8715.exe
Korean | Корейский | windows6.1-kb2483139-x64-ko-kr_0ea76f748e3d5309d568147ad1337b2664090944.exe
Latvian | Латышский | windows6.1-kb2483139-x64-lv-lv_3919fb044a307144f1fc55cf4313aff45cde9a46.exe
Lithuanian | Литовский | windows6.1-kb2483139-x64-lt-lt_c894f0a591735553ba68f9fb94b1b85133ca922c.exe
Norwegian | Норвежский | windows6.1-kb2483139-x64-nb-no_78df68604970041a6337b4058a3e5339f79e50b4.exe
Polish | Польский | windows6.1-kb2483139-x64-pl-pl_24d00a966a7a75132c3af5627634483d3e2d01e7.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x64-pt-br_f8035731c55d774c95c7c673aedfd42d52479294.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x64-pt-pt_78485491088298110a3e78b7a5f95e55ff7808df.exe
Romanian | Румынский | windows6.1-kb2483139-x64-ro-ro_6e7a63541f2cb534dab3db719330fee5cfbb4e0f.exe
Russian | Русский | windows6.1-kb2483139-x64-ru-ru_0587eb296a2f04e0d3699650d39b53ee18b97a79.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x64-sr-latn-cs_5f487007933585def54c67087895e74e25e699a9.exe
Slovak | Словацкий | windows6.1-kb2483139-x64-sk-sk_f1fb8a395d7d656649830f4f06496a5311ad572a.exe
Slovenian | Словенский | windows6.1-kb2483139-x64-sl-si_84606ed6bc061c72f756bbc061621b490fb761f7.exe
Spanish | Испанский | windows6.1-kb2483139-x64-es-es_fdbdf4061b960324efb9eedf7106df543ed8ce33.exe
Swedish | Шведский | windows6.1-kb2483139-x64-sv-se_81051fe3083afdb4f2d1d23752c587de9bb35025.exe
Thai | Тайский | windows6.1-kb2483139-x64-th-th_dc9c0cc12ae488ed3e8dcaecb4392eef91ec213b.exe
Turkish | Турецкий | windows6.1-kb2483139-x64-tr-tr_07e7e3b34426fe68be813e911d3843b941a268b7.exe
Ukrainian | Украинский | windows6.1-kb2483139-x64-uk-ua_1ca449545a2bcfdeeed6080768186fc29f163504.exe
Английское название языка | Русское название языка | Прямая ссылка

Если необходимый Вам язык отсутствует в данных таблицах, то это означает, что для данного языка вместо языкового пакета Вы можете скачать, только пакет интерфейса пользователя.
Такие пакеты устанавливаются в любом выпуске Windows 7 и предоставляют переведенную версию только самых широко используемых диалоговых окон, пунктов меню и содержимого справки. В качестве базы для их установки в системе должен быть установлен требуемый базовый язык (Английский, Испанский, Русский или др.)
Русская версия страницы загрузки пакетов интерфейса пользователя (не языковых пакетов!):
http://windows.microsoft.com/ru-ru/windows/language-packs
Английская версия страницы загрузки пакетов интерфейса пользователя (не языковых пакетов!):
http://windows.microsoft.com/en-US/windows/language-packs

19. Проверка установленных версий .NET Framework и установка отсутствующих.

«.NET Framework – всесторонняя и согласованная модель программирования Майкрософт для построения приложений, обладающих превосходным интерфейсом пользователя, прозрачными и безопасными средствами љзи, а также возможностью создания разнообразных бизнес-процессов». Платформа .NET Framework используется для разработки и последующего запуска приложений. Если разработчик пишет приложение с использованием одной из версий .NET Framework, то для запуска этого приложения потребуется аналогичная версия .NET Framework на компьютере пользователя.

.NET Framework 1.0 - 1.1

Версия 1.0 практически не используется, в состав ОС не входит.
Версия 1.1 используется редко, в состав ОС не входит. Устанавливать только при необходимости.

Если установка .NET Framework 1.1 и пакета обновления (SP1) завершаться ошибкой, то в ручном режиме данная программа устанавливается так:

1) Создайте на диске С: папку DotNet в корне диска "С" (C:\DotNet).
2) Скачайте в созданную папку Предназначенный для повторного распространения пакет платформы Microsoft® .NET версии 1.1 и Пакет обновления Service Pack 1 для платформы Microsoft .NET версии 1.1.
3) Запустите командную строку с правами администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4) Последовательно введите следующие команды и подтвердите выполнение каждой из них клавишей "Enter":

5) Ответьте положительно на вопросы в диалоговых окнах и продолжите ввод команд:

После ввода последней команды начнётся установка. Через несколько минут окна автоматически закроются - установка завершена.

.NET Framework 2.0 - 3.5.1

Версии 2.0 - 3.5.1 являются компонентами Windows 7 (Пуск → Панель управления → Программы и компоненты → Включение и отключение компонентов Windows).
Скачать .NET Framework 3.5 с пакетом обновления 1 (SP1) (полный пакет)

.NET Framework 4.0

Полная версия .NET Framework 4.0 предназначена в первую очередь для разработчиков ПО, клиентский профиль разработан для выполнения клиентских приложений и обеспечения быстрого развёртывания технологий Windows Presentation Foundation (WPF) и Windows Forms. Клиентский профиль распространяется в виде рекомендуемого обновления KB982670.

Скачать .NET Framework 4 (Полная версия)
Скачать .NET Framework 4 (Клиентский профиль)

.NET Framework 4.5.2

Скачать .NET Framework 4.5.2 (Полная версия)

Проверка наличия установленных версий

Вы можете проверить какие версии .NET Framework установлены в Вашей системе воспользовавшись программой .NET Version Detector

Или открыв раздел системного реестра (Win   + R → regedit → ОК): HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP

20. Быстрый запуск командной строки из среды предустановки Windows.

Если Вам необходимо быстро воспользоваться окном команд (командной строкой) за пределами основной среды Windows, и у Вас есть установочный DVD или флеш-диск, то Вы можете запустить командную строку сразу из первого окна программы установки Windows. Чтобы выполнить это сделайте следующее:

1) Загрузитесь с установочного DVD или флеш-диска
2) В первом окне нажмите сочетание клавиш ⇑ Shift + F10.

Откроется окно команд (командная строка) в которой Вы сможете либо ввести необходимую Вам команду, либо запустить необходимую Вам программу.

21. Интегрирование Сервисного Пакета в установочный ISO-образ Windows 7.

Вариант 1. При помощи команды Dism.

1) Создайте папки необходимые для работы (Например, на диске D: папки Temp, SP1, mWim и Mount)
2) Откройте окно команд в папке, где у Вас находится exe-файл сервисного пакета
2.1) Удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке в области переходов.
2.2) В контекстном меню выберите пункт Открыть окно команд
3) Распакуйте exe-файл сервисного пакета во временную папку, используя команду:
Для 64-битной версии:

Для 32-битной версии:

4) Закройте окно команд.
5) Откройте в Проводнике папку D:\Temp и запустите в ней окно команд как описано в пункте 2.
6) Распакуйте cab-файл KB976932, используя команду:
Для 64-битной версии:

Для 32-битной версии:

7) Закройте окно команд.
8) Откройте в Проводнике папку D:\SP1 и запустите в ней окно команд как описано в пункте 2.
9) Распакуйте все cab-файлы языков в папку D:\SP1, поочередно выполнив команды (соглашаясь, если система спросит о перезаписи):

10) После окончания распаковки удалите все cab-файлы языков, используя команду:

11) Распакуйте cab-файл NestedMPPContent.cab в папку D:\SP1, используя команду (соглашаясь, если система спросит о перезаписи):

12) После окончания распаковки удалите cab-файл NestedMPPContent.cab, используя команду:

13) Удалите из папки D:\SP1 файлы cabinet.cablist.ini и old_cabinet.cablist.ini, используя команду:

14) Закройте окно команд.
15) В папке D:\SP1 откройте в любом текстовом редакторе файл update.ses, замените все Absent на Installed и сохраните изменения.
16) В папке D:\SP1 откройте в любом текстовом редакторе файл update.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
17) В папке D:\SP1 откройте в любом текстовом редакторе файл Для 64-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~amd64~~6.1.1.17514.mum

или

Для 32-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~x86~~6.1.1.17514.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
18) Скопируйте файл install.wim из папки \Sources Вашего установочного ISO-образа в папку D:\mWim
19) Узнаете номер индекса Вашей Windows 7, используя команду:

20) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса (Например, для 64-битной версии Windows 7 Enterprise он равен 1), используя команду:

21) Интегрируете сервисный пакет, используя команду:

22) Демонтируйте образ с сохранением изменений, используя команду:

23) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

24) Если Вас устраивает размер получившегося файла install.wim, то замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\mWim\install.wim
25) Если Вас не устраивает размер получившегося файла install.wim, то Вы можете осуществить его сжатие.

25.1) Скачайте и установите (Пакет автоматической установки Windows® (AIK) для Windows® 7) или выше.
Если у Вас Windows 7 SP1, то также скачайте Дополнительный компонент пакета автоматической установки Windows® (AIK) для Windows® 7 с пакетом обновления 1 (SP1), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.
25.2) Создайте дополнительную папку необходимую для работы (Например, на диске D: папку Compress)
25.3) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
25.4.1) Если в Вашем install.wim содержится один образ (Например: Windows 7 Enterprise), то введите следующую ниже команду, нажав после ее ввода клавишу Enter ↵:

25.4.2) Если в Вашем install.wim содержится несколько образов (Например: Windows 7 Ultimate), то для создания итогового файла install.wim выполните указанную выше команду для каждого образа, заменяя индекс 1 на соответствующий, и нажимая после ввода каждой из них клавишу Enter ↵.

Например для 32-битной версии Windows 7 Ultimate:

Например для 64-битной версии Windows 7 Ultimate:

26) Замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\Compress\install.wim
27) Удалите папки Compress, Mount, mWim, SP1 и Temp.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программами DISM Tool или DISM GUI. Они позволяет выполнить, все необходимые Вам команды, используя графический интерфейс. С их помощью Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(Add Packages в DISM Tool или Package Management в DISM GUI). Ссылка на архив с программами: DISM_Graphical.zip

Вариант 2. Используя программу RT Se7en Lite.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте архив с программой RT Se7en Lite и распакуйте его в любую папку.
3) Установите программу необходимой Вам разрядности в зависимости от того, с каким ISO-образом Вы собираетесь работать.
4) Нажмите кнопку Browse и выберите пункт Select OS Path.
5) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
6) В появившемся окне List of operating system выберите Вашу редакцию Windows 7, установите флажок Slipstream Service Pack и нажмите ОК.
7) В появившемся окне RT Service Pack Slipstream нажмите нопку Browse
8) Укажите путь к exe-файлу сервисного пакета (windows6.1-KB976932-X64.exe или windows6.1-KB976932-X86.exe) и нажмите Открыть.
9) Нажмите кнопку Start и дождитесь завершения.
10) Нажмите кнопку Proceed.
11) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок ISO Bootable.
12) В столбце слева нажмите кнопку ISO Bootable
13) В ниспадающем меню ----Select a mode---- выберите пункт Create Image
14) В текстовом поле Volume name укажите какое имя для ISO-образа будет использоваться при монтировании.
15) Нажмите кнопку Make ISO для создания ISO-образа установочного диска с интегрированным сервисным пакетом.
16) Введите имя файла и нажмите кнопку Сохранить.

22. Создание установочного образа Windows с двумя видами разрядности (32-бит и 64-бит) в одном iso-образе.

В этом руководстве Вы будете работать с диском D:, но Вы можете выбрать любую букву диска.

Вариант 1. Быстрый и простой способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Ultimate (x86)
Windows 7 Enterprise (x86) (при необходимости)
Windows 7 Ultimate (x64)
Windows 7 Enterprise (x64) (при необходимости)

Программное обеспечение:

Шестнадцатеричный редактор (Например: HxD)
Пакет автоматической установки Windows® (AIK) для Windows® 7
Если у Вас Windows 7 SP1, то также скачайте Дополнительный компонент пакета автоматической установки Windows® (AIK) для Windows® 7 с пакетом обновления 1 (SP1), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.

1) Скачайте iso-образ Windows (AIK), смонтируйте его и установите Windows (AIK).
2) Если у Вас Windows 7 SP1, то также скачайте iso-образ Дополнительного компонента для Windows (AIK), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.

Этап 1: Упорядочивание файлов.

1) Создайте следующие папки:

D:\AIO\DVD
D:\AIO\DVD\sourc64
D:\AIO\ISO
D:\AIO\WIMs

2) Извлеките содержимое образа Windows 7 Ultimate (x86) в папку D:\AIO\DVD
3) Удалите все файлы с расширением .clg и файл ei.cfg из папки D:\AIO\DVD\sources, чтобы разблокировать все x86 версии Windows 7.
4) Переместите install.wim из папки D:\AIO\DVD\sources в папку D:\AIO\WIMs
5) Переименуйте файл install.wim в ULTx86.wim
6) Извлеките файл install.wim из образа Windows 7 Ultimate (x64) в папку D:\AIO\WIMs
7) Переименуйте файл install.wim в ULTx64.wim
8) При необходимости извлеките файлы install.wim из образа Windows 7 Enterprise (x86) и Windows 7 Enterprise (x64) в папку D:\AIO\WIMs, и переименуйте их в ENTx86.wim и ENTx64.wim соответственно.
9) Извлеките содержание папки sources (за исключением install.wim, ei.cfg и всех файлов .clg) из образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD\sourc64.
10) Скопируйте файл setup.exe из корня образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD как setup64.exe

Этап 2. Создание Wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии Windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter ↵:

Примечание: Вы можете пропустить команды для Windows 7 Enterprise, если Вы решили их не включать.

Этап 3: Изменение BCD

Здесь Вы измените файл данных конфигурации загрузки BCD, чтобы добавить консоль восстановления для 64-битной Windows.

1) Запустите командную строку с правами администратора.
2) Перейдите к папке D:\AIO\DVD введя нижеследующие команды, нажимая после ввода каждой из них клавишу Enter ↵:

3) Сделайте копию загрузчика по умолчанию, выполнив команду:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

4) Установите новый загрузчик, чтобы загружать 64-битную PE, выполнив команды:

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

5) Установите время ожидания загрузки по умолчанию:

Этап 4. Добавление поддержки обновлений во время установки яў 64-битных систем.

Так как добавление данной возможности в двухразрядную сборку Windows предполагает Hex-редактирование файлов, то минусом здесь является поломка цифровой подписи.
Но это является наиболее простым способом решения проблемы с обновлениями.

1) Откройте файл D:\AIO\DVD\setup64.exe в hex-редакторе.
2) Найдите и замените все значения Юникодовой строки (без учета регистра) с sources\ на sourc64\.
Хотя данное действие сломает подпись, но оно не нарушит работоспособность самой программы, так как обе строки имеют одинаковую длину.
3) Откройте файл D:\AIO\DVD\sourc64\autorun.dll и замените все значения Юникодовой строки (без учета регистра) с sources\setup.exe на sourc64\upg64.cmd
4) Cоздайте в папке D:\AIO\DVD\sourc64 файл названный upg64.cmd, содержащих следующее:

Использование командного файла добавит второй небольшой минус, до начала установки на короткое время появится окно команд.

5) Измените содержание файла autorun.inf в папке D:\AIO\DVD на следующее:

Этап 5: Создание ISO-образа (опционально)

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующую команду и нажмите клавишу Enter ↵:

Указанные здесь параметры:

-u2 - Создает образ, который имеет файловую систему UDF.
-l - Задает метку тома. Между параметрами l и метка пробелов быть не должно.
-b - Указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - Включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - Игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

Вариант 2. Сложный и долгий способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Enterprise (x86)
Windows 7 Enterprise (x64)

Программное обеспечение:

Шестнадцатеричный редактор (Например: HxD)
Пакет автоматической установки Windows® (AIK) для Windows® 7
Если у Вас Windows 7 SP1, то также скачайте Дополнительный компонент пакета автоматической установки Windows® (AIK) для Windows® 7 с пакетом обновления 1 (SP1), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.
Текстовый редактор с возможностью сохранения в кодировке 866. (Например: AkelPad)

1) Скачайте iso-образ Windows (AIK), смонтируйте его и установите Windows (AIK).
2) Если у Вас Windows 7 SP1, то также скачайте iso-образ Дополнительного компонента для Windows (AIK), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.

Этап 1: Подготовка к работе.

1) Создайте указанную ниже структуру папок с подпапками:

D:
│
└─AIO
   │
   ├───DVD
   │    │
   │    └───sources
   │           │
   │           ├───x64
   │           │
   │           └───x86
   ├───WIMs
   ├───ISO
   ├───offline
   └───temp
         ├───x64
         └───x86

2) Скопируйте все папки и все файлы, исключая папку sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD
3) Скопируйте содержимое папки sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD\sources\x64, исключая файлы:

4) Переместите файл install_Windows 7 ENTERPRISE.clg из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\temp\x64
5) Переместите файл install.wim из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\WIMs
6) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx64.wim
7) Извлеките файл install_Windows 7 ENTERPRISE.clg из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\temp\x86
8) Извлеките файл install.wim из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\WIMs
9) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx86.wim

Этап 2. Создание файла install.wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии Windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) В Командной строке средств развертывания введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter ↵:

Этап 3. Создание файлов winpe.wim.

1) В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter ↵:

2) Создайте в папке в D:\AIO\temp\x86 командный файл startnet.cmd:
3) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

4) Создайте в папке в D:\AIO\temp\x64 командный файл startnet.cmd:
5) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

6) Смонтируйте файл D:\AIO\temp\x86\winpe.wim, выполнив команду:

7) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x86 соглашаясь на замену.
8) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x86 в папку D:\AIO\offline\Windows\System32
9) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
10) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
11) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\x86_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
12) Демонтируйте образ с сохранением.

13) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Смонтируйте файл D:\AIO\temp\x64\winpe.wim, выполнив команду:

15) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x64 соглашаясь на замену.
16) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\offline\Windows\System32
17) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
18) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
19) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\amd64_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
20) Демонтируйте образ с сохранением.

21) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

22) Экспортируйте образы winpe:

Этап 4. Создание файлов ответов.

1) Запустите из меню Диспетчер образов системы Windows (расположен в папке Microsoft Windows AIK в меню Пуск)
2) Нажмите в главном меню Файл → Выбрать образ Windows
3) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x86
4) Нажмите в главном меню Файл → Новый файл ответов
5) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

6) На панели Файл отчетов пройдите:

7) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
8) На панели Файл отчетов пройдите:

9) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 1
10) На панели Файл отчетов пройдите:

11) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
12) Нажмите в главном меню Файл → Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x86.xml
13) Нажмите в главном меню Файл → Закрыть файл ответов, а затем Закрыть образ Windows

14) Нажмите в главном меню Файл → Выбрать образ Windows
15) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x64
16) Нажмите в главном меню Файл → Новый файл ответов
17) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

18) На панели Файл отчетов пройдите:

19) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
20) На панели Файл отчетов пройдите:

21) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 2
22) На панели Файл отчетов пройдите:

23) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
24) Нажмите в главном меню Файл → Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x64.xml
25) Нажмите в главном меню Файл → Закрыть файл ответов, а затем Закрыть образ Windows

Этап 5: Добавление в загрузочное меню пункты для выбора разрядности установки.

1) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x86).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter ↵:

2) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x64).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter ↵:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Установите время ожидания загрузки по умолчанию::

Этап 6: Добавление в загрузочное меню пункты для выбора разрядности среды восстановления.

1) Добавьте файлы сред восстановления системы (winre.wim) для каждой разрядности:

1.1) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.2) Скопируйте из папки D:\AIO\DVD\sources\install.wim\1\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.3) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x86.wim
1.4) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.5) Скопируйте из папки D:\AIO\DVD\sources\install.wim\2\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.6) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x64.wim

2) Добавьте новые записи в загрузочное меню для среды восстановления Windows x86:
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter ↵:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Добавьте новые записи в загрузочное меню для среды восстановления Windows x64:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

(Если в D:\AIO\DVD\boot\ появились файлы BCD.LOG, bcd.LOG1, bcd.LOG2 - их можно удалить)

Этап 7: Создание ISO-образа.

1) Скопируйте bcd из папки D:\AIO\DVD\boot в папку D:\AIO\DVD\efi\microsoft\boot заменяя оригинал.
2) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
3) Введите нижеследующую команду и нажмите клавишу Enter ↵:

Указанные здесь параметры:

-u2 - Создает образ, который имеет файловую систему UDF.
-l - Задает метку тома. Между параметрами l и метка пробелов быть не должно.
-b - Указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - Включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - Игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

24. Изменение языка интерфейса в Windows 10 Single Language.

На большинстве новых моделей ноутбуков или стационарных компьютеров изначально установлена Windows 7 Home Basic, Windows 7 Home Premium или Windows 7 Professional. Данные версии не поддерживают установку нового языка и его смену, используя стандартные возможности Windows. Если Вам необходимо изменить язык в одной из таких версий Windows 7, то порядок действий следующий.

Вариант 1.

1) Создайте папку, в которой будут выполняться все промежуточные операции, например C:\Work.
1.1) Откройте Windows Explorer (анг.) или Windows-Explorer (нем.) или Проводник (рус.) и перейдите на диск C:
1.2) Щелкните правой кнопкой мыши и выберите New → Folder (анг.) или Neu → Ordner (нем.) или Создать → Папку (рус.)

2) Создайте папку для языкового файла C:\Lang, куда переложите lp.cab.
Чтобы добыть файл lp.cab из exe-установщика языкового пакета, запустите скаченный exe-файл и когда рядом появится файл lp.cab быстро скопируйте его.

3) Перезагрузите компьютер в Windows Boot Manager (анг.) или Windows-Start-Manager (нем.) или Диспетчер загрузки Windows (рус.), для этого нажмите клавишу F8 после экранов BIOS, но до появления загрузочного экрана системы.
4) В списке установленных систем выберите Windows 7, и еще раз нажмите клавишу F8.
5) В появившемся списке вариантов загрузки Advanced Boot Options (анг.) или Erweiterte Startoptionen (нем.) или Дополнительные варианты загрузки (рус.) выберите первый пункт — Repair Your Computer (анг.) или Computer reparieren (нем.) или Устранение неполадок компьютера (рус.).
6) В списке инструментов выберите командную строку Command Prompt (анг.) или Eingabeaufforderung (нем.) или Командная строка (рус.).
7) Найдите имя диска, где установлена Windows 7. Переходите между дисками, используя C:, D: и т.д. и найдите текущий по содержимому с помощью команды dir.
Для примера предположим, что Вы обнаружили Windows на диске D: . Далее работаем с DISM (Deployment Image Servicing and Management tool).

Далее приводится последовательный алгоритм команд, выполнив которые, вы получите локализованную версию вашей Windows 7.

1) Проверьте список языковых пакетов, установленных в системе.

Параметр /image:d: указывает, что Вы нашли папку Windows и Program files, т.е. установленную Windows 7 на диске D: .
Если в списке пакетов, Вы обнаружили необходимый Вам, содержащий строку 'Client-LanguagePack', то добавлять новый языковой пакет не надо и Вы можете перейти к 3 шагу.
2) Установите новый языковой пакет в систему.

Параметр /scratchdir указывает папку, в которую для обработки будет распаковано содержимое lp.cab.
3) Укажите системе язык, необходимый для использования по умолчанию.

Это может быть любой из установленных в системе языков, например en-US или de-DE.
4) Проверьте установленные языковые параметры:

Если напротив строки Default system UI language: (анг.) или Standardmäßige Benutzeroberflächenschprache des Systems (нем.) или Язык пользовательского интерфейса по умолчанию: (рус.) указано буквенное обозначение Вашего языка, то закройте окно и перезагрузите компьютер.
5) В Windows 7 запустите командную строку с правами администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
6) Смените язык экрана загрузки.

или буквенное обозначение языка, который Вам нужен.
7) Смените язык менеджера загрузки (вызывается клавишейF8 перед загрузкой Windows)

Внимание: DISM может выдать ошибку доступа в том случае, если вы открывали в командной строке какие-либо папки на разделе с системой. В этом случае сначала верните командную строку в корень этого раздела, выполнив команду cd \ .

Вариант 2.

1) В соответствии с разрядностью и наличием установленного сервисного пакета Вашей Windows cкачайте необходимый Вам языковой пакет.
Ссылки указаны в совете 18. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1. из раздела Установка, Обновления, Языки.

2) Запустите скаченный exe-файл и когда рядом появится файл lp.cab быстро скопируйте его на диск C:\
3) Запустите командную строку от имени Администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.

Далее приводится последовательный алгоритм команд, выполнив которые, вы получите локализованную версию вашей Windows 7. После ввода каждой команды нажимайте на клавиатуре Enter ↵.

4) Установите новый языковой пакет в систему.

5) Смените язык экрана загрузки.

где ln-LN – выбранное обозначение языка. Для русского замените его на значение ru-RU, для английского – en-US и т.д.

6) Измените язык диспетчера загрузки

где ln-LN – выбранное обозначение языка. Для русского замените его на значение ru-RU, для английского – en-US и т.д.

7) Изменените язык меню дополнительных вариантов загрузки

где ln-LN – выбранное обозначение языка. Для русского замените его на значение ru-RU, для английского – en-US и т.д.

8) Создайте и примените указанный ниже reg-файл.

где 0419 (00000419) соответствует числовому обозначению идентификатора русского языка. Для изменения на английский язык укажите значения 0409 (00000409), для немецкого языка - 0407 (00000407).

9) Перезагрузите компьютер.

Для переключения между установленными языками интерфейса, замените в указанном выше файле реестра числовое обозначение идентификатора языка на необходимое Вам, примените reg-файл и перезагрузите компьютер.

25. Установка Windows 7 без создания учетной записи и имени компьютера, а также добавление драйверов в систему на этапе установки Windows.

Если Вам необходимо установить драйвера для устройств в процессе установки Windows 7.
Если Вы желаете не создавать собственную учетную запись и не указывать имя компьютера.
Воспользуйтесь для этого предложенным ниже решением.

1) Начните обычную установку Windows 7.
2) Сразу после первой перезагрузки нажмите клавишу F8.
3) Выберите пункт Безопасный режим (Safe Mode) и нажмите Enter ↵.
4) При ¦влении окна о невозможности продолжить установку в безопасном режиме не нажимая кнопки ОК, нажмите ⇑ Shift + F10.

Установка драйверов.

5) В командной строке введите compmgmtlauncher и нажмите Enter ↵.
У Вас загрузится оснастка Управление компьютером (Computer Management).
6) Перейдите Служебные программы → Диспетчер устройств (System Tools → Device Manager).
7) Щелкните правой кнопкой мыши на устройстве для которого необходимо установить драйвер и выберите пункт Обновить драйверы (Update Driver Software).
8) Выберите пункт Выполнить поиск драйверов на этом компьютере (Browse my computer for device software).
9) Укажите в поле Искать драйверы в следующем месте путь (Search for driver software in this location) путь к папке с драйверами и нажмите кнопку Далее (Next).
10) Закройте оснастку оснастка Управление компьютером (Computer Management) и командную строку.
11) Нажмите кнопку ОК в окне о невозможности продолжить установку в безопасном режиме.
Компьютер перезагрузится и продолжит установку в обычном режиме.

Включение встроенной учётной записи администратора, вместо создания собственной учетной записи.

12) При ¦влении окна ввода имени пользователя и имени компьютера нажмите ⇑ Shift + F10.
13) В окне команд введите команду compmgmtlauncher и нажмите клавишу Enter ↵.
14) Перейдите Служебные программы → Локальные пользователи и группы → Пользователи (System Tools → Local Users an Groups → Users)
15) Щелкните правой кнопкой учетную запись Администратор (Administrator) и выберите Свойства (Properties).
16) Откроется окно Свойства: Администратор (Administrator Properties).
17) На вкладке Общие (General) снимите флажок Отключить учетную запись (Acount is disabled) и нажмите кнопку OK.
18) В командной строке введите explorer и нажмите Enter ↵.
19) В командной строке введите taskmgr и нажмите Enter ↵.
20) Выделите приложение msoobe и нажмите Снять задачу (End Task) → Завершить сейчас (End Now).
21) Подождите немного и Windows самостоятельно загрузится на рабочий стол.
22) Закройте Диспетчер задач Windows (Windows Task Manager), окно команд, настройте расположение сети и перезагрузите компьютер.
Ваша Windows готова к работе.

26. Добавление и удаление сведений об играх имеющихся в системе, в папку Обозреватель игр (Игры).

Многие игры во время установки записывают сведения о себе в специальную папку Обозреватель игр (Пуск → Все программы → Игры → Обозреватель игр).
Если Вы установили игру, а игра не добавилась в указанную папку, то Вы можете сделать это самостоятельно, используя программу Game Explorer Builder, переведенную мною на русский язык.

Добавление сведений об игре в папку Обозреватель игр.

1) Скачайте архив GameExplorerBuilder_RUS.zip и распакуйте в любую папку.
2) Запустите программу Game Explorer Builder.
3) Щелкните правой кнопкой мыши в области списка программы и откройте Добавить игру → Создать ресурс.
4) На вкладке Общие укажите имя и описание игры.
5) На вкладке Детали введите версию игры, ее дату выпуска и минимальную и рекомендуемую оценку параметров компьютера для игры.
6) На вкладке Разработчики нажмите на значок Добавить запись и укажите имя и веб-сайт разработчика.
7) На вкладке Издатели нажмите на значок Добавить запись и укажите имя и веб-сайт издателя.
8) На вкладке Жанры нажмите на значок Добавить запись и укажите жанр игры.
9) На вкладке Рисунки нажмите на текстовое поле под словом Иконка и укажите путь к иконке (ico-файл) программы.
10) Затем нажмите на текстовое поле под словосочетанием Обложка игры и укажите путь к обложке игры (png, jpg или bmp-файл) программы.
11) Нажмите на текстовое поле под словосочетанием Выходной файл и укажите где и под каким именем следует сохранить файл ресурсов.
По умолчанию создается файл GDFResource.dll.
Хотя Вы можете задать любое имя файла и расположение, рекомендуется не изменять название dll-файла и сохранять его в самой папке игры.
12) Нажмите кнопку Создать для создание dll-файла ресурсов с информацией об игре. Откроется окно установки файла ресурсов.
13) В разделе Ярлыки нажмите на значок Добавить запись.
14) Введите в текстовом поле Имя слово Играть.
15) Нажмите на текстовое поле напротив слова Ярлык, укажите файл запускающий игру и нажмите кнопку ОК.
16) В разделе Ссылки техподдержки нажмите на значок Добавить запись.
17) Введите в текстовом поле Имя слово Техподдержка (Поддержка, Тех.Помощь или др.).
18) Введите в текстовом поле Ссылка адрес техподдержки в интернете и нажмите кнопку ОК.
19) Нажмите кнопку Установить, чтобы добавить из созданного Вами dll-файла сведения об игре в Обозреватель игр.

Удаление сведений об игре из папки Обозреватель игр.

1) Выделитие игру, информацию о которой Вы желаете удалить из Обозревателя игр.
2) Щелкните на выделенном правой кнопкой мыши и выберите Выбранные игры → Удалить выбранные.
3) Нажмите кнопку Да для подтверждения.

27. Прямые ссылки с официального сайта Microsoft для скачивания сервисного Пакета обновлений 1 (SP1) для Windows 7.

Если Вам необходимо скачать сервисный Пакет обновлений 1 (SP1) для Windows 7, то Вы можете сделать это, воспользовавшись указанными ниже прямыми ссылками с сайта Microsoft.

ISO-образ, содержащий Пакеты обновлений 1 (SP1) для обоих разрядностей Windows 7 (x86 и x64):

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/7601.17514.101119-1850_Update_Sp_Wave1-GRMSP1.1_DVD.iso

Сервисный Пакет обновлений 1 (SP1) для 32-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X86.exe

Сервисный Пакет обновлений 1 (SP1) для 64-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X64.exe

28. Список буквенных и числовых обозначений идентификаторов языка.

Если Вы желаете установить языковой пакет или изменить языковые параметры системы при помощи командной строки, reg-файла или путем редактирования реестра, то Вам могут понадобит© буквенные или числовые обозначения локальных идентификаторов языка.
Ниже приводится их список.

Языковые пакеты

Английское название языка | Русское название языка | Буквенный идентификатор языка (имя языка) | Шестнадцатеричный идентификатор языка | Десятичный идентификатор языка
Arabic (Saudi Arabia) | Арабский (Саудовская Аравия) | ar-SA | 0x0401 | 1025
Bulgarian (Bulgaria) | Болгарский (Болгария) | bg-BG | 0x0402 | 1026
Chinese (Hong Kong S.A.R.) | Китайский (Гонконг) | zh-HK | 0x0c04 | 3076
Chinese (PRC) | Китайский (КНР) | zh-CN | 0x0804 | 2052
Chinese (Taiwan) | Китайский (Тайвань) | zh-TW | 0x0404 | 1028
Croatian (Croatia) | Хорватский (Хорватия) | hr-HR | 0x041a | 1050
Czech (Czech Republic) | Чешский (Республика Чехия) | cs-CZ | 0x0405 | 1029
Danish (Denmark) | Датский (Дания) | da-DK | 0x0406 | 1030
Dutch (Netherlands) | Голландский (Нидерланды) | nl-NL | 0x0413 | 1043
English (United States) | Английский (США) | en-US | 0x0409 | 1033
Estonian (Estonia) | Эстонский (Эстония) | et-EE | 0x0425 | 1061
Finnish (Finland) | Финский (Финляндия) | fi-FI | 0x040b | 1035
French (France) | Французский (Франция) | fr-FR | 0x040c | 1036
German (Germany) | Немецкий (Германия) | de-DE | 0x0407 | 1031
Greek (Greece) | Греческий (Греция) | el-GR | 0x0408 | 1032
Hebrew (Israel) | Иврит (Израиль) | he-IL | 0x040d | 1037
Hungarian (Hungary) | Венгерский (Венгрия) | hu-HU | 0x040e | 1038
Italian (Italy) | Итальянский (Италия) | it-IT | 0x0410 | 1040
Japanese (Japan) | Японский (Япония) | ja-JP | 0x0411 | 1041
Korean (Korea) | Корейский (Республика Корея) | ko-KR | 0x0412 | 1042
Latvian (Latvia) | Латышский (Латвия) | lv-LV | 0x0426 | 1062
Lithuanian (Lithuania) | Литовский (Литва) | lt-LT | 0x0427 | 1063
Norwegian, Bokmål (Norway) | Норвежский, букмол (Норвегия) | nb-NO | 0x0414 | 1044
Polish (Poland) | Польский (Польша) | pl-PL | 0x0415 | 1045
Portuguese (Brazil) | Португальский (Бразилия) | pt-BR | 0x0416 | 1046
Portuguese (Portugal) | Португальский (Португалия) | pt-PT | 0x0816 | 2070
Romanian (Romania) | Румынский (Румыния) | ro-RO | 0x0418 | 1048
Russian (Russia) | Русский (Россия) | ru-RU | 0x0419 | 1049
Serbian (Latin, Serbia) | Сербский (латиница, Сербия) | sr-Latn-CS | 0x081a | 2074
Slovak (Slovakia) | Словацкий (Словакия) | sk-SK | 0x041b | 1051
Slovenian (Slovenia) | Словенский (Словения) | sl-SI | 0x0424 | 1060
Spanish (Spain) | Испанский (Испания) | es-ES | 0x0c0a | 3082
Swedish (Sweden) | Шведский (Швеция) | sv-SE | 0x041d | 1053
Thai (Thailand) | Тайский (Таиланд) | th-TH | 0x041e | 1054
Turkish (Turkey) | Турецкий (Турция) | tr-TR | 0x041f | 1055
Ukrainian (Ukraine) | Украинский (Украина) | uk-UA | 0x0422 | 1058
Английское название языка | Русское название языка | Буквенный идентификатор языка (имя языка) | Шестнадцатеричный идентификатор языка | Десятичный идентификатор языка

Пакеты интерфейса пользователя

Такие пакеты устанавливаются в любом выпуске Windows 7 и предоставляют переведенную версию только самых широко используемых диалоговых окон, пунктов меню и содержимого справки.

Английское название языка | Русское название языка | Буквенный идентификатор языка (имя языка) | Шестнадцатеричный идентификатор языка | Десятичный идентификатор языка
Afrikaans (South Africa) | Африкаанс (Южная Африка) | af-ZA | 0x0436 | 1078
Albanian (Albania) | Албанский (Албания) | sq-AL | 0x041c | 1052
Amharic (Ethiopia) | Амхарский (Эфио ) | am-ET | 0x045e | 1118
Armenian (Armenia) | Армянский (Армения) | hy-AM | 0x042b | 1067
Assamese (India) | Ассамский (Индия) | as-IN | 0x044d | 1101
Azeri (Latin, Azerbaijan) | Азербайджанский (латиница, Азербайджан) | az-Latn-AZ | 0x042c | 1068
Basque (Basque) | Баскский (Страна Басков) | eu-ES | 0x042d | 1069
Bengali (Bangladesh) | Бенгальский (Бангладеш) | bn-BD | 0x0845 | 2117
Bengali (India) | Бенгальский (Индия) | bn-IN | 0x0445 | 1093
Bosnian (Cyrillic, Bosnia and Herzegovina) | Боснийский (кириллица, Босния и Герцеговина) | bs-Cyrl-BA | 0x201a | 8218
Bosnian (Latin, Bosnia and Herzegovina) | Боснийский (латиница, Босния и Герцеговина) | bs-Latn-BA | 0x141a | 5146
Catalan (Catalan) | Каталанский (Каталония) | ca-ES | 0x0403 | 1027
Filipino (Philippines) | Филиппинский (Филиппины) | fil-PH | 0x0464 | 1124
Galician (Galician) | Галисийский (Галисия) | gl-ES | 0x0456 | 1110
Georgian (Georgia) | Грузинский (Грузия) | ka-GE | 0x0437 | 1079
Gujarati (India) | Гуджарати (Индия) | gu-IN | 0x0447 | 1095
Hausa (Latin, Nigeria) | Хауса (латиница, Нигерия) | ha-Latn-NG | 0x0468 | 1128
Hindi (India) | Хинди (Индия) | hi-IN | 0x0439 | 1081
Icelandic (Iceland) | Исландский (Исландия) | is-IS | 0x040f | 1039
Igbo (Nigeria) | Игбо (Нигерия) | ig-NG | 0x0470 | 1136
Indonesian (Indonesia) | Индонезийский (Индонезия) | id-ID | 0x0421 | 1057
Inuktitut (Latin, Canada) | Инуктитут (латиница, Канада) | iu-Latn-CA | 0x085d | 2141
Irish (Ireland) | Ирландский (Ирландия) | ga-IE | 0x083c | 2108
isiXhosa (South Africa) | Исикоса (Южная Африка) | xh-ZA | 0x0434 | 1076
isiZulu (South Africa) | Исизулу (Южная Африка) | zu-ZA | 0x0435 | 1077
Kannada (India) | Каннада (Индия) | kn-IN | 0x044b | 1099
Kazakh (Kazakhstan) | Казахский (Казахстан) | kk-KZ | 0x043f | 1087
Khmer (Cambodia) | Кхмерский (Камбоджа) | km-KH | 0x0453 | 1107
Kiswahili (Kenya) | Суахили (Кения) | sw-KE | 0x0441 | 1089
Konkani (India) | Конкани (Индия) | kok-IN | 0x0457 | 1111
Kyrgyz (Kyrgyzstan) | Киргизский (Киргизия) | ky-KG | 0x0440 | 1088
Luxembourgish (Luxembourg) | Люксембургский (Люксембург) | lb-LU | 0x046e | 1134
Macedonian (Former Yugoslav Republic of Macedonia) | Бывшая Югославская Республика Македония | mk-MK | 0x042f | 1071
Malay (Brunei Darussalam) | Малайский (Бруней-Даруссалам) | ms-BN | 0x083e | 2110
Malay (Malaysia) | Малайский (Малайзия) | ms-MY | 0x043e | 1086
Malayalam (India) | Малаялам (Индия) | ml-IN | 0x044c | 1100
Maltese (Malta) | Мальтийский (Мальта) | mt-MT | 0x043a | 1082
Maori (New Zealand) | Маори (Новая Зеландия) | mi-NZ | 0x0481 | 1153
Marathi (India) | Маратхи (Индия) | mr-IN | 0x044e | 1102
Nepali (Nepal) | Непальский (Непал) | ne-NP | 0x0461 | 1121
Norwegian, Nynorsk (Norway) | Норвежский, нюнорск (Норвегия) | nn-NO | 0x0814 | 2068
Oriya (India) | Ория (Индия) | or-IN | 0x0448 | 1096
Persian | Фарси | fa-IR | 0x0429 | 1065
Punjabi (India) | Пенджабский (Индия) | pa-IN | 0x0446 | 1094
Quechua (Peru) | Кечуа (Перу) | quz-PE | 0x0c6b | 3179
Serbian (Cyrillic, Serbia) | Сербский (кириллица, Сербия) | sr-Cyrl-CS | 0x0c1a | 3098
Sesotho sa Leboa (South Africa) | Северный сото (Южная Африка) | nso-ZA | 0x046c | 1132
Setswana (South Africa) | Тсвана (Южная Африка) | tn-ZA | 0x0432 | 1074
Sinhala (Sri Lanka) | Сингальский (Шри-Ланка) | si-LK | 0x045b | 1115
Tamil (India) | Тамильский (Индия) | ta-IN | 0x0449 | 1097
Tatar (Russia) | Татарский (Россия) | tt-RU | 0x0444 | 1092
Telugu (India) | Телугу (Индия) | te-IN | 0x044a | 1098
Urdu (Islamic Republic of Pakistan) | Урду (Исламская Республика Пакистан) | ur-PK | 0x0420 | 1056
Uzbek (Latin, Uzbekistan) | Узбекский (латиница, Узбекистан) | uz-Latn-UZ | 0x0443 | 1091
Vietnamese (Vietnam) | Вьетнамский (Вьетнам) | vi-VN | 0x042a | 1066
Welsh (United Kingdom) | Валлийский (Соединенное Королевство) | cy-GB | 0x0452 | 1106
Yoruba (Nigeria) | Йоруба (Нигерия) | yo-NG | 0x046a | 1130
Английское название языка | Русское название языка | Буквенный идентификатор языка (имя языка) | Шестнадцатеричный идентификатор языка | Десятичный идентификатор языка


Виртуализация.

1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

VHD (Virtual Hard Disk) - это формат файлов, используемых виртуальными машинами для эмуляции жесткого диска. Вы сможете создать себе виртуальный диск и использовать его для хранения виртуальных операционных систем, программ и других файлов в одном файле-образе, который можно открыть различными программами виртуализации или виртуальными машинами. Виртуальные жесткие диски позволяют нескольким операционным системам одновременно находит© на одном компьютере.

Вариант 1. Работа с виртуальными дисками используя графический интерфейс.

Создание виртуального жесткого диска.

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win   + R) введите diskmgmt.msc и нажмите Enter ↵.
3) Откроется оснастка "Управление дисками". В панели меню выберите пункт Действие и нажмите на Создать виртуальный жесткий диск

4) В открывшемся окне укажите:

4.1) Имя файла и его расположение. Вы можете как написать это вручную, так и нажав на кнопку Обзор и воспользовавшись диалоговым окном Просмотр файлов виртуального диска
4.2) Размер виртуального диска. Возле текстового поля, в которое нужно ввести размер диска, присутствует раскрывающийся список, где можно выбрать размер жесткого диска. Доступные значения – мегабайты, гигабайты и терабайты. Создайте размер не меньше 20 ГБ.
4.3) Тип виртуального диска. Динамически расширяемый дисковый образ обеспечивает объем пространства, необходимый для хранения данных.
Размер VHD-файла в момент создания диска небольшой, но увеличивается по мере добавления данных на диск. Распределение данных осуществляется в блоках. При удалении данных с виртуального жесткого диска размер VHD-файла автоматически не уменьшается. Фиксированный размер создает VHD-файл, размер которого задается при создании виртуального жесткого диска. Размер VHD-файла остается постоянным независимо от объема хранимых данных.
5) Нажмите на кнопку «ОК».

Чтобы диспетчер локальных дисков смог получить доступ к созданному Вами виртуальному диску его необходимо инициализировать и создать на нем простой том. Для этого также используется оснастка "Управление дисками".

Инициализация виртуального жесткого диска.

1) Найдите Ваш виртуальный диск и щелкните на нем правой кнопкой мыши
2) Нажмите на пункт Инициализировать диск

3) Выберите стиль разделов - MBR и нажмите OK

Создание простого тома на виртуальном жестком диске.

После того как Вы проинициализировали Ваш виртуальный диск, на нем необходимо создать простой том.

1) Найдите Ваш виртуальный диск и щелкните на нераспределенной области справа от него
2) Нажмите на пункт Создать простой том

3) В первом диалоге Мастера создания простого тома нажмите на кнопку Далее
4) В диалоге указания размера тома, укажите размер будущего тома в мегабайтах и нажмите на кнопку Далее

5) В диалоге Назначение буквы диска или пути укажите букву для будущего диска и нажмите на кнопку Далее

6) В диалоге Форматирование раздела укажите нужную файловую систему, размер кластера, название диска и установите флажок возле опции Быстрое форматирование - для того, чтобы диск был сразу отформатирован. После чего нажмите на кнопку Далее

7) Для принятия всех настроенных параметров в диалоге Завершение мастера создания простого тома нажмите на кнопку Готово.
8) Виртуальный диск появится в таблице дисков. В оснастке управления дисками, значок виртуального диска визуально отличается от значков физических дисков. В Проводнике Windows виртуальные диски выглядят так же, как и физические.

Присоединение виртуального жесткого диска.

Если у Вас уже имеется созданный виртуальный жесткий диск, то Вы также можете присоединить его в оснастке "Управление дисками".

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win   + R) введите diskmgmt.msc и нажмите Enter ↵.
3) В панели меню выберите пункт Действие и нажмите на Присоединить виртуальный жесткий диск.

4) Укажите расположение для виртуального жесткого диска на компьютере и нажмите OK Указать расположение Вы можете либо введя значение вручную, либо нажав на кнопку Обзор, и используя диалоговое окно Просмотр файлов виртуального диска. Если Вам не нужно записывать данные на диск, то в этом диалоге можно установить флажок Только для чтения.

Отсоединение (удаление) виртуального жесткого диска.

1) Найдите виртуальный диск, который хотите отсоединить, нажмите на нем правой кнопкой мыши
2) Нажмите на пункт Отсоединить виртуальный жесткий диск

3) Если Вы желаете отсоединить виртуальный диск без удаления его из системы, то нажмите OK. Для полного удаления диска из системы, отметьте Удалить виртуальный диск после удаления диска и после этого нажмите OK.

Вариант 2. Работа с виртуальными дисками используя программу Diskpart в командной строке.

Создание виртуального жесткого диска.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) В командной строке наберите Diskpart и нажмите Enter ↵
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для создания виртуального диска воспользуйтесь командой Create Vdisk. Синтаксис команды следующий:

Где:

File=<"имя_файла"> - Указание полного пути и имени файла виртуального диска.
Maximum=<n> - Максимальное дисковое пространство, предоставляемое виртуальным диском, заданное в мегабайтах (МБ).
[Type={Fixed|Expandable}] - Используется для указания формата виртуального диска. Существует два значения для данного параметра:
Fixed создает файл виртуального диска фиксированного размера;
Expandable создает динамически расширяемый образ виртуального диска.
[Source=<"имя_файла">] - Путь к существующему файлу виртуального диска для предварительного заполнения нового файла виртуального диска. При использовании параметра Source данные из исходного файла виртуального диска копируются блок за блоком в создаваемый файл виртуального диска. Если Вы при копировании динамического диска не укажете параметр Type=Expandable, то копия будет создана максимального размера выделенного для исходного диска, независимо от его текущего размера.

Примеры использования команды:

Присоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) В командной строке наберите Diskpart и нажмите Enter ↵
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk. Синтаксис команды следующий:

Пример использования команды:

4) Для присоединения выбранного виртуального диска воспользуйтесь командой Attach Vdisk. Синтаксис команды следующий:

[Readonly] - Присоединяет виртуальный диск в режиме только для чтения. Любая операция записи приведет к возникновению ошибки ввода-вывода устройства.
[Usefilesd] - Указывает, что для виртуального диска следует использовать дескриптор безопасности самого виртуального файла. Если параметр не указан, то у диска не будет явно заданного дескриптора безопасности, если не был также задан параметр SD=(строка SDDL).
[SD=<строка sddl>] - Задает дескриптор безопасности в формате SDDL. По умолчанию дескриптор безопасности обеспечивает доступ, аналогичный любому физическому диску. Дополнительные сведения о формате строки SDDL см. в справке по команде Create Vdisk.

Примеры использования команды:

Отсоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) В командной строке наберите Diskpart и нажмите Enter ↵
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk.
4) Для отсоединения выбранного виртуального диска воспользуйтесь командой Detach Vdisk.

2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

Для работы Вам потребуются:

1) Пакет автоматической установки Windows® (AIK) для Windows® 7
2) Архиватор 7-zip
3) Программа GImageX v2.1.1 (русская версия) или GImageX (английская версия)
4) Программа WinImage
5) MSDaRT (ранее ERD Commander)
5.1) Мастера для сборки MSDaRT образа: DaRT70x86.zip - для 32-бит или DaRT70x64.zip - для 64-бит.
или
5.2) Готовые образы MSDaRT: DART70X86RUS_Disk.zip - для 32-бит или DART70X64RUS_Disk.zip - для 64-бит.

Вариант 1

1) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
2.1) Запустите утилиту WinImage и откройте в ней VHD-образ. В открывшемся диалоге щелкните ОК.
2.2) Выделите справа все файлы и щелкните на выделенном правой кнопкой.
2.3) Выберите Extract, затем щелкните Browse и выберите папку VHD. Чуть ниже выберите Extract with pathname.
Дождитесь завершения процесса распаковки. Если ¦вится ошибка, просто нажмите Продолжить.

3) Используя программу 7zip, распакуйте ISO-образ установочного диска с Windows 7 в папку C:\DVD
4) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
5) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
6) Распакуйте lp.cab в папку C:\Lip\uLip выполнив в консоли команду:

7) При помощи GimageX узнаете индекс Ultimate

8) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

9) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

10) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

11) Перезагрузите компьютер.
Примечание: Команды DISM Вы можете также выполнять в командной строке MSDaRT, чтобы не думать о проблемах доступа к папкам.
12) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:

14) Интегрируете LIP в install.wim

15) ПримҐете все настройки яў русского языка командой:

16) Копируете все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer)
17) Демонтируете install.wim с сохранением изменений из C:\Mount:

18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount

19) Добавляете в boot.wim русский язык:

20) Добавляете в boot.wim файлы лицензий:

21) Правите текст файла (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer) C:\Mount\sources\lang.ini

22) Демонтируете boot.wim с сохранением изменений из C:\Mount:

23) Правите текст файла (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:

24) Заменяете файл (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

1) Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter ↵.
2) В верхнем меню нажимаете Действие → Присоединить виртуальный жесткий диск.
3) Указываете местонахождение VHD-образа, жмете ОК

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на USB флеш-накопитель (флешку) или DVD.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программами DISM Tool или DISM GUI. Они позволяет выполнить, все необходимые Вам команды, используя графический интерфейс. С их помощью Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(Add Packages в DISM Tool или Package Management в DISM GUI). Ссылка на архив с программами: DISM_Graphical.zip

3. Установка и загрузка Windows 7 из VHD-файла.

Вариант 1

Первое, что потребуется - это сам VHD-образ. Второе - необходимо подготовить логический диск. Вы можете воспользоваться любым диском, на котором не установлено никакой другой операционной системы, и на котором имеется 15-25 Гб свободного места. Третье, это утилита WinImage.

1) Запустите утилиту WinImage.
2) Откройте в Winimage Ваш VHD-образ.
3) В открывшемся диалоге нажмите ОК.
4) Выделите справа все файлы.
5) Нажмите на выделенном правой кнопкой мыши и выберите Extract
6) Нажмите Browse и выберите предварительно подготовленный диск.
7) Ниже выберите Extract with pathname. Дождитесь завершения процесса распаковки.
8) После завершения распаковки скачайте и запустите утилиту EasyBCD.
9) В окне приложения нажмите Add/Remove Entries
10) В поле Add entries выберите имя для Вашей новой операционной системы (к примеру, Windows 7 - VHD)
11) Укажите тип (Windows Vista/7)
12) Выберите диск, на который Вы извлекли содержимое образа.
13) Нажмите Add entry, а затем вверху нажмите Save. В списке теперь должно быть два пункта.
14) Зайдите в раздел Change Settings
15) Выберите в качестве ОС, загружаемой по умолчанию, Windows 7 - VHD.
16) Нажмите Save settings и перезагрузите компьютер.

Вариант 2 как основная система.

1) Создайте папку VHD на любом разделе диска.
2) Откройте VHD-образ утилитой WinImage
3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите пункт Extract
4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения процесса распаковки.
5) Перезагрузите компьютер в MSDaRT (ранее ERD Commander), чтобы не думать о проблемах доступа к папкам.
Создание образа MSDaRT описано в совете 9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы). из раздела Разное.
6) Выберите пункт Micosoft Diagnostics and Recovery Toolset → Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
7) Перенесите все файлы из папки VHD на диск C:/. Для этого:
7.1) Откройте папку VHD и выделите все файлы.
7.2) Щелкните правой кнопкой мыши на них, нажмите "move to" и выберите диск С:\
8) Удалите папку VHD.
9) Перезагрузитесь снова в MSDaRT. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончании поиска нажмите repair and restart (исправить и перезагрузит©).

Вариант 3 как вторая система.

Способ 1. Автоматически.

1) Создайте папку VHD на любом разделе диска.
2) Откройте VHD-образ утилитой WinImage.
3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите Extract.
4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения распаковки.
5) Перезагрузите компьютер в MSDaRT (ранее ERD Commander), чтобы не думать о проблемах доступа к папкам.
Создание образа MSDaRT описано в совете 9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы). из раздела Разное.
6) Выберите Micosoft Diagnostics and Recovery Toolset → Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
7) Перенесите все файлы из папки VHD на диск C:/. Папка VHD → выделите все файлы → щелкните правой кнопкой → параметр move to → выберите диск С:\
8) Удалите папку VHD.
9) Перезагрузитесь снова в MSDaRT. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажмите repair and restart (исправить и перезагрузит©).
10) После перезагрузки нам станет доступен выбор из двух ОС. Нас интересует вторая Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Выберите её и ждите пока закончится настройка системы.
В процессе, компьютер будет два раза перезагружен, не забывайте после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено).
11) Если загружаетесь через Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено) , то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все). Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить → compmgmt.msc). Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкните правой кнопкой мыши на диске, выберите Change Drive Letter and Paths, нажмите Add, выберите любую букву для диска, ОК, диск доступен.

Способ 2. В ручную без Winimage, при помощи программы Bcedit.

Для данного способа используйте программу bcedit, входящую в состав средств Windows или средств Восстановления.

1) Запустите командную строку от имени администратора в Windows или в командной строке средств Восстановления, или в MSDaRT (при запуске необходимо выбрать текущую систему). Все дальнейшие команды вводите в командной строке.
2) При помощи указанной команды, скопируйте существующую запись текущей системы с новым названием:

3) Дожидаетесь сообщения «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
Указанный в данном сообщении буквенно-цифровой код, подставляйте в команды, указанные ниже вместо {ID}:
4) Укажите раздел, на котором расположены файлы загрузки (device) и раздел, на котором расположены системные файлы операционной системы (osdevice). Так как у нас виртуальный диск, то значения параметров device и osdevice будут равны.

где X:\DIR\filename.vhd – полный путь к файлу VHD и указание имени файла.
5) Для форсирования автоматического определения в Windows диска через соответствующий уровень абстракции — Hardware Abstraction Layer (разрешать ли операционной системе ускоренное автоматическое определение версии HAL и файла ядра при загрузке), выполните следующую команду:

6)Установите добавленную систему на последнее место в списке загрузок

7) Перезагрузите компьютер

Если посмотреть на диски, присутствующие в системе, будет видно, что помимо виртуального диска на 16 Гб (обведен оранжевым), с которого, собственно, загружена Windows 7, также присутствуют второй раздел виртуального диска на 200 Мб под системные файлы и реальный(!) жесткий диск, установленный на компьютере. Если открыть диск, где ранее располагался vhd-файл, то можно обнаружить, что его размер увеличился до тех самых 16Гб, причем размер этот теперь строго ограничен.

Некоторые сайты также советуют внести в листинг menu.lst(должен появится при загрузке компьютера) следующие изменения:

4. Установка Windows 7 на виртуальный диск в VHD-файл.

Установив систему на виртуальный диск, в один VHD-файл, Вы получаете такие преимущества по сравнению с обычной системой:

1) сможете сделать копию операционной системы просто скопировав VHD-файл
2) сможете тестировать бета версии программ, не беспокоясь за систему
3) сможете изучать систему, экспериментировать с реестром, не боясь её испортить.

Однако существуют некоторые ограничения при установке Windows на VHD-диск, отмечу наиболее актуальные из них:

1) Если VHD-файл поместить на диске, зашифрованном с помощью BitLocker, загрузка из этого файла будет невозможна. Использование BitLocker в системе, установленной на VHD-диск, хотя и возможно, но не является поддерживаемой конфигурацией.
2) Для установки на VHD-диск можно использовать только Windows 7 Корпоративную (Enterprise) и Windows 7 Максимальную (Ultimate). Другие редакции тоже можно установить на VHD-диск, однако по лицензионным соображениям они не будут оттуда запускаться.
3) Система, установленная на VHD-диск, не может переходить в состояние гибернации, вместо нее возможно только использование спящего режима.
4) Каждая система на VHD-диске должна иметь отдельную лицензию и активироваться.
5) Имеется некоторое снижение производительности системы, при работе Windows на VHD-диске.
6) Не работает функция оценки индекса производительности.

1) Вставьте установочный диск Windows 7 в привод, загрузитесь с него
2) Доходите до шага мастера установки, где Вас просят выбрать или создать тот раздел диска, на который будет установлена Windows 7.
3) Нажмите комбинацию клавиш ⇑ Shift + F10.
Это сочетание клавиш предоставит доступ к командной строке. Напечатайте в ней Diskpart и нажмите Enter ↵.
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Введите в DISKPART следующую команду:

Она означает - создать файл win7.vhd расширяемого типа, максимальный размер ограничить 30 Гигабайтами. Замените E: на имя диска, на котором вы хотите хранить создаваемый файл.

4) Смонтируйте VHD-файл, чтобы он был доступен программе установки:

5) После успешного выполнения всех операций, набираете команду exit для выхода из утилиты diskpart, и еще раз команду exit – уже в приглашении CMD.EXE для закрытия командной строки.

6) Вы снова окажетесь в окне Выберите раздел для установки.
7) Нажмите кнопку Обновить, расположенную под списком дисков и Вы увидите Ваш новый диск
8) Так как на нем ещё нет разделов, то будет написано Незанятое место на диске...
9) Выберите его и нажмите Настройка диска
10) Щелкните на кнопке "Создать", укажите объем создаваемого радела и щелкните на кнопке "Применить".
11) Ещё раз убедитесь, что Вы выбрали созданный Вами виртуальный диск и нажмите Далее, игнорируя предупреждение: Невозможно установить Windows на диск...

Процесс установки Windows 7 на раздел VHD-диска продолжится так, как будто это обычный логический раздел жесткого диска. При этом будет не только установлена новая ОС, но и подменен загрузчик на "физическом" системном разделе для успешного старта с VHD. При установке Windows 7 на "чистую" систему, мастер установки автоматически создаст на диске системный раздел в 100МБ, на котором помещается загрузчик, а уже для самой системы создаст отдельный раздел.

5. Конвертирование тома жесткого диска в VHD-файл.

Для создания VHD-файлов из томов жесткого диска, Вам необходимо воспользоваться утилитой Disk2vhd. Она позволяет создать VHD-образ прямо с запущенной операционной системы. Для своей работы, программа использует Модуль теневого копирования тома (Volume Snapshot), являющийся функцией используемой операционной системой для создания последовательных снимков томов на определенный момент времени. Таким образом, Вы сможете создать VHD-файл прямо на том же разделе, который в него упаковываете. При создании VHD-файла, программа включает в него только системный том и исключает разделы с данными.

Созданный утилитой виртуальный диск может быть подключен к виртуальной машине как IDE-диск. Не используйте VHD-файл, для загрузки через менеджер загрузки Windows 7 на реальной машине. Windows специальным образом подписывает жесткие диски, и присваивает VHD-диску новый уникальный идентификатор. При попытке загрузки с VHD система выдаст ошибку об отсутствии загрузочного диска или просто перезагрузится без уведомления пользователя. Но при использовании данного VHD-образа в Virtual PC, система отлично стартует и работает.

Для работы с Вашим VHD-файлом Вы также можете использовать оснастку Управление дисками (diskmgmt.msc).
Если снимаете образ системного диска, и у вас есть раздел восстановления (System Reserved), не забудьте включить его в VHD-образ, так как без него система не загрузится. Для создания VHD-файла сделайте следующее:

1) Скачайте программу Disk2vhd
2) Разархивируйте скачанный архив и запустите Disk2vhd
3) В поле под VHD File name укажите путь и ¤ создаваемого Вами VHD-файла.
4) Установите флажки напротив томов жесткого диска, которые необходимо включить в создаваемый Вами VHD-файл.
5) Нажмите Create

Для создания скриптов утилита поддерживает командную строку:

Укажите какие тома необходимо включить в VHD-файл или используйте * для конвертирования всех томов.

6. Конвертирование DVD-образа Windows 7 в VHD-файл.

Для конвертирования DVD-образа Windows 7 в VHD-файл, Вам потребуются Пакет автоматической установки Windows® (AIK) для Windows® 7 и инструмент командной строки WIM2VHD

WIM2VHD - это сценарий Windows Scripting Host, предназначенный для использования в командной строке и позволяющий создать аппаратно-независимый VHD-файл из инсталляционного диска Windows 7, при инициализации которого система минует стадию начальной загрузки и распаковки файлов и будет готова к определению оборудования компьютера, на котором она запущена.

Суть метода заключается в преобразовании файла install.wim в VHD-файл.

1) Установите Пакет автоматической установки Windows® (AIK) для Windows® 7
2) Поместите скаченный файл WIM2VHD.WSF в папку C:\Program Files\Windows AIK\Tools\x86\, если используете 32-разрядную систему, или в C:\Program Files\Windows AIK\Tools\amd64\, если 64-разрядную.
3) Запустите командную строку с правами администратора, для чего нажмите "Пуск", в поле поиска введите cmd.exe и нажмите Ctrl + ⇑ Shift + Enter ↵.
4) Перейдите в папку со скриптом используя команду CD . Например:

Для 32-битной Windows:

Для 64-битной Windows:

Измените пути на соответствующие Вашей системе.

5) Запустите скрипт wim2vhd. Для этого, введите в командной строке следующее:

Командная строка расшифровывается так:
Взять файл h:\sources\install.wim, и редакцию Ultimate преобразовать в e:\vhd\win7.vhd

6) Дождитесь окончания операции.

7) Для подключения полученного VHD-файла к имеющемуся загрузчику Windows 7, используйте команду:

Команда дублирует загрузочную запись текущей запущенной Windows 7. Вместо "Windows 7 Virtual" Вы можете написать любое значение.

8) Bcdedit выведет на экран {GUID} только что созданной записи-дубликата - скопируйте его в буфер обмена и используйте для внесения VHD-файла в опции загрузки:

Для информации:

Работа скрипта WIM2VHD базируется на использовании утилиты imagex.exe из WAIK.
Более подробную информацию и другие примеры использования скрипта WIM2VHD Вы можете прочитать в прилагаемом файле "WIM2VHD Documentation.pdf".

7. Включение Aero Glass в Windows на Virtual PC.

1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Нажмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

В итоге, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

8. Установка Windows 7 в виртуальную машину VirtualBox.

VirtualBox - специальная программа для создания в памяти ПК виртуальных компьютеров. Каждый виртуальный компьютер может содержать произвольный набор виртуальных устройств и отдельную операционную систему. Область применения виртуальных компьютеров очень широка - от выполнения функций по тестированию ПО до создания целых сетей, которые легко масштабировать, распределять нагрузку и защищать. VirtualBox распространяется бесплатно, с открытым исходным кодом.

1) Скачайте последнюю версию программы VirtualBox с официального сайта: http://www.virtualbox.org/wiki/Downloads
2) Установите ее на свой компьютер.

2.1) Запустите установщик; В первом окне нажмите Next
2.2) Выберите необходимые Вам компоненты для установки и нажмите пункт Next.
2.3) Нажмите Next, а затем Yes для начала установки.
2.4) Нажмите на кнопку Install. Внимание: После нажатия кнопки Install произойдет разрыв связи с сетью (как локальной, так и Интернет)
2.5) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
2.6) В последнем окне оставьте флажок, чтобы приступить к созданию виртуальной машины сразу или уберите флажок для создания виртуальной машины позднее. Нажмите кнопку Finish. Если Вы убрали флажок, то для запуска программы воспользуйтесь значком на рабочем столе.

3) В главном окне программы нажмите на кнопке Создать. Откроется Мастер создания новой виртуальной машины. Нажмите кнопку Вперед.
4) Введите имя виртуальной машины, в разделе Тип ОС установите значения:
Операционная система: Microsoft Windows
Версия: Windows 7.
Нажмите кнопку Вперед.

5) Введите размер оперативной памяти, выделяемый для виртуальной машины.
Внимание: Память будет выделяться из физической памяти установленной в Вашем компьютере. Не устанавливайте память ниже 512 Мегабайт и выше 50% от размера установленной физической памяти. Нажмите кнопку Вперед.
6) Выберите загрузочный виртуальный жесткий диск. Установите переключатель в значение: Создать новый жесткий диск. Нажмите кнопку Вперед.

7) Откроется Мастер создания нового виртуального диска. Нажмите кнопку Вперед.
8) Выберите тип виртуального жесткого диска. Динамический образ изначально займет немного места, и будет расширяться постепенно. Фиксированный образ сразу создаст диск указанного размера - это может занять продолжительное время. Нажмите кнопку Вперед.

9) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\.VirtualBox.
Выберите размер виртуального жесткого диска. (По умолчанию 20 Гигабайт). Нажмите кнопку Вперед.

10) Нажмите на кнопку Готово и Вы вернетесь в предыдущее окно, где будут указаны параметры создаваемой Вами виртуальной машины. Нажмите на кнопку Финиш в окне Итог, и Вы создадите новую виртуальную машину.

Виртуальная машина для установки на нее Windows 7 создана.

11) Перед началом установки Windows 7 на Вашу виртуальную машину ее необходимо настроить. Для настройки Вашей виртуальной машины нажмите на кнопку Свойства.
12) В разделе настроек из списка слева выберите Дисплей. Установите размер видеопамяти, доступной для виртуальной машины не менее 26 Мегабайт. Поставьте флажки яў элементов настроек Включить 3D-ускорение и Включить 2D-ускорение видео.

13) В разделе настроек из списка слева выберите Носители.
14) Нажмите значок DVD-диска рядом с ниспадающим меню в графе Атрибуты.

Если у Вас установочный диск Windows 7 записан на DVD-диск, то вставьте его в DVD-привод и выберите привод с соответствующей буквой. Также установите флажок для Разрешить прямой доступ.
Если у Вас установочный диск Windows 7 имеется в виде ISO-образа, то выберите пункт Выбрать образ оптического диска... нажмите на значок папки, чтобы открыть Менеджер виртуальных носителей
15) В окне Выберите образ оптического диска выберите файл образа и нажмите Открыть.
16) Ваш образ добавится в дерево настроек Носители информации. Нажмите кнопку OK.

17) Вы окажетесь в основном окне программы. Нажмите на кнопку Старт
18) Если ¦вятся информационные окна, то нажмите в них на кнопку OK
19) Щелкните кнопкой мыши внутри экрана виртуальной машины, и в информационном окне нажмите на кнопку Захватить
20) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
21) После завершения установки Windows 7 на виртуальную машину, VirtualBox сразу запустит Вам Windows 7 внутри виртуальной машины.

22) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Control.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Дополнения гостевой ОС. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Устройства → Установить Дополнения гостевой ОС

23) Во всплывшем окне Автозапуск нажмите VBoxWindowsAdditions.exe и установите программу.
23.1) В появляющихся окнах контроля учетных записей нажмите Да.
23.2) Для перехода к каждому последующему шагу нажмите Next, для установки кнопку Install, для завершения Finish.
23.3) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
24) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Машина → Закрыть → Выключить машину.
25) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Старт.

9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.
Microsoft Virtual PC - это мощная программа, которая позволяет эмулировать на одном компьютере работу сразу нескольких виртуальных машин. Каждая из таких машин может находит© под управлением своей собственной операционной системы (Windows любой версии, Netware, Linux, Solaris и т.д.), выполнять уникальную задачу, иметь собственную конфигурацию и т.д.

1) Скачайте последнюю версию программы Virtual PC с официального сайта:
http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=24439
2) Установите программу. Внимание программа установки без предупреждения выключит соединение с сетью (как локальной, так и Интернет).
3) Скачайте и установите обновление KB958162.msp для Virtual PC
4) Запустите программу. Нажмите кнопку Пуск → Все программы → Microsoft Virtual PC
5) В окне с надписью: "You are not running on a supported operating system" нажмите ОК.
6) В окне New Virtual Machine Wizard нажмите кнопку Next. Данное окно Вы также можете запустить нажав кнопку New в Virtual PC Console или в меню File выбрать New Virtual Machine Wizard.

7) Установите переключатель на Create a Virtual Machine. Нажмите кнопку Next.

8) Выберите имя и расположение для файла Вашей виртуальной машины. По умолчанию имя файла New Virtual Machine, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\Documents\My Virtual Machines. Нажмите кнопку Next.
9) Выберите тип операционной системы. В связи с отсутствием пункта Windows 7 в Virtual PC, выберите Windows Vista или Other. Нажмите кнопку Next.

10) Установите переключатель на Adjusting the RAM. Выберите необходимое Вам количество оперативной памяти выделяемое виртуальной машине, не менее 512 Мегабайт. Нажмите кнопку Next.

11) Установите переключатель на A new virtual hard disk, чтобы создать новый виртуальный образ. Нажмите кнопку Next.
12) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, к котрой добавлено Hard Disk, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке:
C:\Users\UserName\Documents\My Virtual Machines\ИмяВиртуальнойМашины\
Укажите величину создаваемого вами виртуального жесткого диска в мегабайтах. Рекомендую указать 20480 Мб (20 Гб). Для информации: 1 Гб = 1024 Мб. Нажмите кнопку Next.

13) Нажмите кнопку Finish, для создания виртуальной машины. Вы снова окажетесь в окне Virtual PC Console.
14) Выберите созданную Вами виртуальную машину и нажмите кнопку Start
15) Виртуальная машина начнет свою работу и остановится с сообщением: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device, поскольку отсутствует инсталляционный диск с Windows 7. Выберите команду CD>Capture CD Image и укажите образ ISO с Windows 7.

16) Перезагрузите виртуальную машину, выбрав команду Action → Ctrl + Alt + Del или нажав Alt + Del в окне виртуальной машины.
17) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
18) После завершения установки Windows 7 на виртуальную машину, Microsoft Virtual PC сразу запустит Вам Windows 7 внутри виртуальной машины.
19) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Alt справа.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Virtual Machine Additions. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Action → Install or Update Virtual Machine Additions и нажмите Continue.

20) Во всплывшем окне Автозапуск нажмите Setup.exe и установите программу.
21) Нажмите Yes по окончанию установки Virtual Machine Additions и виртуальная машина перезагрузится.
22) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Action → Close → Turn Off и нажмите OK.
23) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Start.

10. Установка Windows 7 в виртуальную машину VMware Workstation.

VMware Workstation — популярная программа для виртуализации систем. VMware Workstation является массивным решением для разработчиков программного обеспечения и системных админов, создающих и тестирующих полно-комплексные сетевые приложения класса серверов, работающие в разнообразных средах.

1) Откройте страницу Download VMware Workstation Trial и нажмите кнопку Download Now, рядом с VMware Workstation XX for Windows (где XX - номер версии).
2) Запустите установку программы и нажимайте кнопки Next (Continue).
3) В окне Enter License Key нажмите кнопку Skip, а в следующем окне нажмите кнопку Finish.
4) Запустите программу VMware Workstation, установите переключатель в значение "I want to try VMware Workstation 12 for 30 days", введите свой e-mail и нажмите кнопку Continue, а в следующем окне нажмите кнопку Finish.
Для использования демонстрационной версии:
5) В окне VMware Workstation Activation нажмите кнопку Close.
Для ввода имеющегося у Вас серийного номера:
6) В окне VMware Workstation Activation нажмите Help → Enter Serial Number...
7) В открывшемся окне нажмите Enter Serial Number..., введите новый серийный номер и нажмите ОК.
8) В главном окне программы нажмите на значок New Vitual Machine.

9) Установите переключатель на Typical (recommended). Нажмите кнопку Next.

10) Установите переключатель на Installer disk image file (iso). Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Next.

11) Выберите из ниспадающего списка Вашу редакцию Windows 7, укажите свой инсталляционный код Windows 7, имя пользователя и пароль и нажмите кнопку Next.
Если Вы решили ввести эти данные позже, то после нажатия кнопки Next, нажмите на кнопку Yes.

12) Выберите имя и расположение для файла Вашей виртуальной машины. Нажмите кнопку Next.

13) Задайте размер Вашего виртуального жесткого диска в гигабайтах и укажите, как следует создать виртуальный диск - одним (single) или несколькими (multiple) файлами.
Размер виртуального диска изначально будет создан небольшого размера, и будет увеличиваться при добавлении программ, файлов, данных в виртуальную машину.

14) Установите флажок Power on this virtual machine after creation и нажмите кнопку Finish, для начала создания виртуальной машины.

После завершения автоматической установки Windows 7 на виртуальную машину, VMware Workstation сразу запустит Windows 7 внутри виртуальной машины, установит дополнительные инструменты VMware Tools, а также в случае наличия у Вас подключения к Интернету, установит все необходимые драйвера.
VMware Tools позволят Вам одновременно использовать курсор мыши как в виртуальной системе, так и в основной. Плюс к этому Вы сможете копировать файлы из/в виртуальную машину, а также использовать единый буфер обмена.
Используйте комбинацию клавиш Ctrl + Alt для разблокировки курсора мыши одновременного использования мыши как в виртуальной системе, так и в основной.

15) Для выключения виртуальной машины, завершите работу в виртуальной Windows 7 как в обычной Windows. Пуск → Завершение работы.
16) Для включения виртуальной машины, перейдите на вкладку с названием Вашей виртуальной машины (по умолчанию Windows 7) и нажмите ссылку Power on this virtual machine или щелкните на Вашу виртуальную машину в списке слева и нажмите кнопку Power on this virtual machine, расположенную под меню File.

Дополнительная информация:

Чтобы отключить Easy Install и установить Windows в обычном режиме.

1) На шаге выбора iso-образа для установки Вашей операционной системы, установите переключатель в значение I will install the operating system later и нажмите кнопку Next.
2) Выберите из ниспадающего списка Windows 7 или Windows 7 x64, в соответствии с разрядностью устанавливаемой системы, и нажмите кнопку Next.

3) Выберите имя и расположение для файла Вашей виртуальной машины, и нажмите кнопку Next.
4) Задайте размер Вашего виртуального жесткого диска в гигабайтах и укажите, как следует создать виртуальный диск - одним (single) или несколькими (multiple) файлами.
5) Нажмите кнопку Finish, чтобы закрыть мастер предварительных настроек виртуальной машины.
6) Щелкните на Вашу виртуальную машину в списке слева и нажмите ссылку Edit virtual machine settings
7) Нажмите в списке устройств на пункт CD/DVD (IDE) или CD/DVD (SATA) и установите переключатель на Use ISO image file.

8) Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Открыть, а затем кнопку ОК.
9) Запустите Вашу виртуальную машину. Щелкните на Вашу виртуальную машину в списке слева и нажмите ссылку Power on this virtual machine.
И у Вас начнется обычная установка Windows.

Чтобы отключить сообщение об отсутствии floppy-дисковода:

1) Откройте VMware Workstation, но систему, пока не запускайте.
2) В разделе Devices щелкните дважды на слово Floppy.
3) В открывшемся окне Virtual Machine Settings выделите пункт Floppy и нажмите кнопку Remove.
4) Нажмите кнопку ОК.
Должно стать как на скриншоте выше.
Теперь Вы можете запускать виртуальную Windows.

Если у Вас возникли проблемы с входом в интернет после установки VMware Workstation:

1) Зайдите в Панель управления\Сеть и Интернет\Сетевые подключения
2) Отключите VMware Network Adapter VMnet1 и VMware Network Adapter VMnet8.
3) Перезагрузите компьютер.

11. Создание общей папки яў виртуальной и основной Windows в VirtualBox.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VirtualBox и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Устройства → Общие папки

2) Нажмите на клавиатуре кнопку Insert, либо нажмите на значок папки с плюсом.

3) Установите флажок для параметра Создать постоянную папку.
4) В ниспадающем меню рядом с текстом Путь к папке выберите пункт Другой....
5) Укажите путь к Вашей папке и нажмите на каждую кнопку ОК.

Если Вы хотите, чтобы гостевая ОС автоматически подключала данную папку в процессе загрузки поставьте флажок у Авто-подключение.
Если Вы хотите, чтобы общая папка была постоянной для данной машины установите флажок у Создать постоянную папку, иначе выбранная общая папка будет временной.
6) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник → Сеть → VBOXSVR → Ваша папка

12. Создание общей папки яў виртуальной и основной Windows в Microsoft Virtual PC.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину Microsoft Virtual PC и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Edit → Settings или нажмите сочетание клавиш: правый Alt + E

2) Выберите в списке Shared Folders и нажмите кнопку Share Folder...

3) Установите флажок на Share Every Time, укажите Вашу общую папку и установите букву диска в виде которого будет отображаться папка в виртуальной Windows, затем нажмите OK.

4) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник → Компьютер → Отключенное сетевое устройство (назначенная вами буква диска)

13. Создание общей папки яў виртуальной и основной Windows в VMware Workstation.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VMware Workstation и хостовой (реальной) Windows 7, сделайте следующее:

1) В списке виртуальных машин щелкните правой кнопкой мыши на Вашей виртуальной машине и выберите пункт Settings или же на вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) нажмите ссылку Edit virtual machine settings

2) Перейдите на вкладку Options и выделите пункт Shared Folders
3) Установите переключатель в положение Always enabled и поставьте флажок Map as a network drive in Windows guests.

4) Нажмите кнопку Add..., а затем кнопку Next.
5) Нажмите кнопку Browse. Укажите путь к Вашей общей папке в хостовой (реальной) Windows 7 и ее имя в виртуальной Windows, затем нажмите OK.

6) Нажмите кнопку Next, а затем кнопку Finish. Выйдите из опций нажав кнопку OK.
7) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник → Компьютер → Shared Folders → Ваша папка

14. Запуск старых 16-битных приложений и DOS-игр в Windows, используя программу DosBox.

Для запуска старых 16-битных приложений и DOS-игр в Windows, Вы можете использовать программную среду DosBox. Чтобы Вам легче было в ней работать Вы можете воспользоваться одной из предлагаемых на сайте графических оболочек.

1) Скачайте и установите графическую оболочку D-Fend Reloaded
2) Нажмите Файл → Настройки программы.
3) Перейдите на вкладку Язык в Пользовательский интерфейс и установите значения параметров в соответствии с языковыми требованиями программы, которую Вы собираетесь запустить и нажмите ОК.
4) Чтобы добавить новое 16-битное приложение (DOS-игру), просто перетащите мышкой ZIP-архив с программой или распакованную папку с файлами приложения (игры) в окно программы.
5) В зависимости от выбранного Вами действия, появится окно Импорт архива или окно Импорт папки.
6) В данном окне нажмите ОК и профиль для данной игры добавится в программу, чтобы Вы могли в любой момент запустить её.
7) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить настройку.
8) Настройте параметры запуска игры и выйдите из программы настройки.
9) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить программу.

Дополнения:

Переключение между экранным и оконным режимами осуществляется комбинацией клавиш Alt + Enter ↵.
Звуковую карту указывать Sound Blaster/Sound Blaster Pro
Иногда для выхода приходится в ручную вводить команду Exit и нажимать Enter ↵.

15. Отключение синхронизации времени с хостовой системой в виртуальной машине VirtualBox.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение VirtualBox.
2) Откройте окно команд из папки, куда установлена программа и в которой находится утилита VBoxManage.exe.
Для этого щелкните правой кнопкой мыши по паке, удерживая нажатой клавишу ⇑ Shift и выберите Открыть окно команд.
3) Введите указанную ниже команду:

Где: <name> - имя Вашей виртуальной машины, а <-msec> - разница в миллисекундах между текущей датой и той, что требуется. Указанное значение будет постоянно отматываться назад.

Для получения необходимого Вам значения в милисекундах воспользуйтесь утилитой Date Offset Calculator

16. Отключение синхронизации времени с хостовой системой в виртуальной машине Microsoft Virtual PC.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение Microsoft Virtual PC.
2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (С:\Users\ИмяПользователя\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines) и имеет расширение .vmс
3) Найдите тег </microsoft> и вставьте перед ним нижеследующий текст:

4) Найдите тег </bios> и вставьте перед ним нижеследующий текст:

В итоге у Вас должно получит© примерно так:

Если у Вас уже имеются указанные разделы, но значения параметров установлены true, то просто измените их на false.

5) Сохраните файл и запустите Virtual PC.
6) Зайдите в BIOS виртуальной машины, и установите необходимую Вам дату и время, и после перезагрузки/выключения машины они не будут синхронизированы с хостовой системой.

17. Отключение синхронизации времени с хостовой системой в виртуальной машине VMware Workstation.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение VMware Workstation.
2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (C:\Users\ИмяПользователя\Documents\Virtual Machines) и имеет расширение .vmx
3) Добавьте в конце файла нижеследующие строки:

Параметры с первого до предпоследнего отключают синхронизацию времени с хостовой машиной при различных операциях.
Последний параметр rtc.startTime определяет дату в биосе при запуске машины. Его значение – это требуемая дата в формате Unix Timestamp, равняется количеству секунд прошедших с полночи с 31 декабря 1969 года на 1 января 1970 года до необходимой Вам даты и времени.

Для получения необходимого Вам значения скачайте программу конвертер: Unix Timestamp Converter или воспользуйтесь онлайн конвертером: Unix Time Convertion

4) Сохраните файл и перезапустите VMware Workstation.

Внимание: После внесения изменений проверьте отсутствие дублирующихся строк, иначе машина не запустится.

18. Открытие виртуальных образов дисков (*.mdx, *.mds/*.mdf, *.iso, *.nrg), монтирование их в виртуальные приводы.

Часто в интернете выкладывают виртуальные образы дисков имеющие расширения *.mdx, *.mds/*.mdf, *.iso, *.nrg. После скачивания данных файлов, возникает вопрос о способе их дальнейшего использования.
Для работы с ними, Вам необходимо установить эмулятор виртуальных дисков. Это позволит Вам монтировать и демонтировать виртуальные диски в виртуальные приводы, что анологично тому как Вы вставляете и вынимаете DVD/Blue-Ray диск из дисковода. Для монтирования виртуальных образов дисков Вы можете использовать следующие программы:

DAEMON Tools Lite

1) Скачайте программу и установите ее.
1.1) В процессе установки выберите значение переключателя Бесплатная лицензия и убедитесь,что в компонентах установлен флажок SPTD.
2) Запустите программу DAEMON Tools Lite и нажмите в ней на значек шестеренки яў запуска элемента программы Настройки
3) В списке слева выберите пункт Интеграция.
4) Выделите все типы файлов и нажмите кнопку Применить, а затем кнопку Закрыть.
5) Теперь для монтирования виртуального диска, щелкните правой кнопкой мыши на файле образа и выберите пункт Открыть.
Файл будет автоматически смонтирован в виртуальный привод и запустит© автозапуск для диска (если он у Вас не отключен) .
6) Для демонтирования диска, щелкните правой кнопкой мыши по виртуальному диску в папке Компьютер и выберите пункт Извлечь.
При использовании гаджета для монтирования нажмите значок Play, для демонтирования файла нажмите на значок Stop.

Alcohol 52% Free Edition

1) Скачайте программу и установите ее.
2) Запустите программу Alcohol 52% и в главном меню выберите Сервис → Настройки
3) В списке слева выберите пункт Ассоциации файлов и нажмите кнопку Выбрать все
4) Установите флажок Другие расширения и введите mdx, а затем нажмите кнопку ОК.
5) Теперь для монтирования виртуального диска, щелкните на файле образа правой кнопкой мыши и выберите пункт Смонтировать образ.
Файл будет автоматически смонтирован в виртуальный привод и запустит© автозапуск для диска (если он у Вас не отключен) .
6) Для демонтирования диска, щелкните правой кнопкой мыши по виртуальному диску в папке Компьютер и выберите пункт Демонтировать образ.

WinCDEmu

1) Скачайте программу и установите ее.
2) Для монтирования виртуального диска, щелкните на файле образа правой кнопкой мыши и выберите пункт Выбрать букву диска и монтировать.
3) Выберите необходимую Вам букву для виртуального диска и нажмите ОК.
Файл будет автоматически смонтирован в виртуальный привод и запустит© автозапуск для диска (если он у Вас не отключен).
4) Для демонтирования диска, щелкните правой кнопкой мыши по виртуальному диску в папке Компьютер и выберите пункт Извлечь.

19. Настройка параметров для использования интернета в VMware Workstation, при наличии VPN-соединения.

Если у Вас в реальной (хостовой) Windows для входа в интернет используется vpn-подключение, то иногда виртуальная Windows может не правильно определять сеть, что приводит к отсутствию интернета в виртуальной системе.
Чтобы настроить интернет в виртуальной системе сделайте следующее:

1) Закройте программу VMware Workstation, если она у Вас запущена.
2) Отключите VPN-подключение к интернету.
3) Откройте Пуск → Все программы → VMware и запустите Virtual Network Editor (vmnetcfg.exe).
4) Нажмите на кнопку Restore Default, а затем в всплывшем окне нажмите кнопку Да.
5) После того как программа переустановит драйвера и пересоздаст заново виртуальные сети нажмите кнопку ОК.
6) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом.
7) Нажмите ссылку Изменение параметров адаптера.
8) Щелкните правой кнопкой мыши на Вашем VPN-соединении и выберите пункт Свойства.
9) Перейдите на вкладку Доступ и в ниспадающем списке выберите VMware Network Adapter VMnet8.
10) Установите флажок Разрешить другим пользователям сети использовать подключение к Интернету данного компьютера и нажмите кнопку ОК.
11) Во всплывшем окне Сетевые подключения нажмите Да.
12) Подключите VPN-подключение к интернету.
13) В списке виртуальных машин щелкните правой кнопкой мыши на Вашей виртуальной машине и выберите пункт Settings.
14) Щелкните на пункт Network Adapter.
15) В разделе Network Connection установите переключатель в значение Custom: Specific virtual network.
16) В ниспадающем списке выберите VMnet8 (NAT) и нажмите кнопку ОК.
17) Запустите Вашу виртуальную Windows и она автоматически определит существующее подключение к интернету.

20. Проведение тестирования программ в виртуальной системе.

Вы установили виртуальную Windows, чтобы в ней проверять незнакомые программы прежде, чем устанавливать их в хостовую (основную) Windows.
Чтобы собранных Вами сведений Вам хватило бы для анализа программы, в процессе ее тестирования Вы должны выявить:

1) Какие неизвестные службы добавляются в систему?

Откройте Панель управления → Администрирование → Службы и найдите службы неявляющиеся стандартными.

Используя Sysinternals Process Explorer (английская версия или русская версия).

2) Какие процессы загружает установленная программа при запуске?
3) Какие процессы остаются загруженными после закрытия программы?
4) Сколько ресурсов процессора, оперативной памяти, графической памяти использует программа?
5) Как часто происходит чтение/запись на диск?
6) Сколько ресурсов сети использует программа?

Общие индикаторы расположены в верхней части Sysinternals Process Explorer.
Чтобы просмотреть данные о процессе, нажмите правой кнопкой мыши на процессе (файле) и выберите пункт Properties (Свойства).
Наиболее необходимая Вам информация находится на вкладках: Performance Graph (График производительности), GPU Graph (График ГП), Performane (Производительность), Disk and Network (Диски и Сети).

Используя Sysinternals AutoRuns (английская версия или русская версия).

7) Какие записи настроеные на запуск в процессе загрузки или входа в систему, добавляются в папку автозагрузки или в разделы реестра отвечающие за автозагрузку?

Используя SysTracer (официальный сайт или зеркало).

8) Внесенные изменения на диске и в реестре после установки программы.
9) Оставшиеся следы на диске и в реестре после удаления программы.

Создайте три точки яў сравнения: до установки, после установки и после удаления и сравните сначала первую точку со второй, а затем первую точку с третьей.
Подробнее описано в совете 30. Отслеживание изменений на диске и в реестре, путем сравнения снимков системы. из раздела Администрирование.

После проведения подобного анализа, Вы решаете, необходимо ли Вам использование тестируемой программы на хостовой (основной) Windows.


1. Изменение размера иконки на рабочем столе.

1) Щелкните правой кнопкой мыши на рабочем столе.
2) Откройте пункт Вид и выберите размер: Крупные значки; Обычные значки; Мелкие значки;
или удерживая нажатой клавишу Ctrl прокрутите колесо мыши.

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Отображение.


2. Управление положением и размерами окон с помощью клавиатуры.

Чтобы легко и быстро управлять положением и размерами окон, Вы можете воспользоваться следующими комбинациями клавиш на клавиатуре.

Win + ↑ | Развернуть окно на весь экран.
Win + ⇑ Shift + ↑ | Растянуть окно до верхней и нижней части экрана.
Win + ↓ | Свернуть в окно, либо свернуть на панель задач.
Win + ← | Развернуть и прикрепить окно к левому краю экрана.
Win + → | Развернуть и прикрепить окно к правому краю экрана.


3. Где скачать и как установить дополнительные темы для Windows 7?

Скачать дополнительные темы для Вашей Windows 7 Вы можете на официальной странице тем от Microsoft: Галерея персонализации
После скачивания понравившейся Вам темы, нажмите на скачавшийся themepack-файл и Windows автоматически его установит.
Также дополнительные темы и обои яў Windows находятся в скрытой папке - C:\Windows\Globalization\MCT.

Вы можете разблокировать 5 дополнительных тем, поочередно запустив их.
Для этого, запустите диалоговое окно "Выполнить" (Win   + R) и наберите в нем:
C:\Windows\Globalization\MCT\MCT-AU\Theme\AU.theme
C:\Windows\Globalization\MCT\MCT-CA\Theme\CA.theme
C:\Windows\Globalization\MCT\MCT-GB\Theme\GB.theme
C:\Windows\Globalization\MCT\MCT-US\Theme\US.theme
C:\Windows\Globalization\MCT\MCT-ZA\Theme\ZA.theme

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Отображение.


4. Изменение ширины и высоты меню Пуск.

Для изменения высоты меню Пуск проделайте следующее:

1) Нажмите правой кнопкой мыши на кнопке Пуск и выберите пункт Свойства.
2) Нажмите кнопку Настроить... .
3) Установите минимально необходимое для Вас значение напротив пункта Отображать недавно использовавшиеся программы в количестве: .
4) Снимите флажки и установите переключатель в значение Не отображать этот элемент напротив неиспользуемых Вами пунктов меню.
5) Нажмите ОК для внесения сделанных Вами изменений.

Для изменения ширины меню Пуск воспользуйтесь одним из указанных ниже вариантов.

Напоминание: Для применения указанных ниже вариантов у Вас должен быть отключен Контроль учетных записей
(Панель управления → Учетные записи пользователей → Изменение параметров контроля учетных записей)

Вариант 1. Копирование файла из другой локализации.

1) Скачайте и установите программу Unlocker.
2) Откройте Пуск → Панель управления → Персонализация
3) Установите тему Классическая.
4) Воспользовавшись советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование, задайте полный доступ к файлам aero.msstyles.mui расположенным в папке C:\Windows\Resources\Themes\Aero\ru-RU и папке локализации из которой Вы желаете скопировать файл aero.msstyles.mui (Например: C:\Windows\Resources\Themes\Aero\en-US)
5) Скопируйте файл aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\en-US в папку C:\Windows\Resources\Themes\Aero\ru-RU.
6) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
7) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
8) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
9) Перезагрузите компьютер.
10) Откройте Пуск → Панель управления → Персонализация
11) Установите любую тему Aero.

Вариант 2. Изменение значений параметров в файле aero.msstyles.mui.

1) Скачайте и установите программу Unlocker.
2) Откройте Пуск → Панель управления → Персонализация
3) Установите тему Классическая.
4) Воспользовавшись советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование, задайте полный доступ к файлу aero.msstyles.mui расположенному в папке C:\Windows\Resources\Themes\Aero\ru-RU.
5) Откройте данный файл - aero.msstyles.mui с помощью программы Restorator.
6) Нажмите клавишу F6 для включения режима редактирования.
7) Измените значения строк со 113 по 132 в строковой таблице в данном файле, на значения данных строк в строковой таблице взятые из файла, расположенного в папке локализации (Например: C:\Windows\Resources\Themes\Aero\en-US)

8) Нажмите клавиши F8, чтобы принять изменения и Ctrl + S, чтобы сохранить файл и закройте Restorator.
9) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
10) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
11) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
12) Перезагрузите компьютер.
13) Откройте Пуск → Панель управления → Персонализация
14) Установите любую тему Aero.

Вариант 3. Используя специальную программу.

Установка новых размеров ширины меню Пуск.

1) Скачайте и установите программу Unlocker.
2) Откройте Пуск → Панель управления → Персонализация
3) Установите тему Классическая.
4) Воспользовавшись советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование, задайте полный доступ к файлу aero.msstyles.mui расположенному в папке C:\Windows\Resources\Themes\Aero\ru-RU.
5) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
6) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
7) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
8) Скачайте программу Start Menu Width (польск. Szerokość Menu Start) переведенную мною с польского на русский язык.

Данная программа позволяет:

- Изменить ширину левой и правой части меню Пуск.
- Изменить ширину для правой части, где указываются последние файлы открываемые программой.
- Изменить ширину окна с результатами поиска.

9) Распакуйте архив в любую папку и запустите программу.
9.1) Для запуска программы необходим установленный Microsoft .NET Framework 4.0 или Microsoft .NET Framework 4.5.2.
10) Выберите из ниспадающего списка Шаблоны готовый шаблон с размерами меню Пуск. Например: Windows 7 (ENG) - для установки размеров меню соответствующих размеров из английской версии Windows.
11) Нажмите ОК для принятия изменений.
12) Нажмите кнопку Перезагрузить позже.
13) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
14) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
15) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
16) Откройте Пуск → Панель управления → Персонализация
17) Установите любую тему Aero.

Восстановление изначальных размеров ширины меню Пуск.

1) Откройте Пуск → Панель управления → Персонализация
2) Установите тему Классическая.
3) Запустите программу Start Menu Width и нажмите кнопку Восстановление.
4) Нажмите кнопку Да в окне Восстановление.
5) Нажмите кнопку Перезагрузить позже, а затем кнопку ОК.
6) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
7) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
8) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.

Рекомендации к работе с программой Start Menu Width (польск. Szerokość Menu Start):

1) Для успешной работы удаляйте все содержимое папки C:\Windows\rescache с помощью Unlocker до начала и после использования программы Start Menu Width.
2) Устанавливайте тему Классическая, для изменения настроек без перезагрузки компьютера.
3) Восстанавливайте оригинальные настройки перед внесением следующих изменений.
4.1) Используйте шаблоны.
4.2) При установке размеров вручную, не устанавливайте значения всех параметров одновременно на максимум, либо намного больше Ваших оригинальных размеров меню. Перейти к началу Общего списка советов.


5. Включение/отключение прозрачного заголовка окна вместо матового.

Вариант 1.

1) Скачайте архив Disable_Blur.zip, с созданными мною скриптами.
2) Распакуйте архив и откройте папку Eng, если у Вас английская версия или английская + русский MUI.
3) Распакуйте архив и откройте папку Rus, если у Вас русская версия.

Все указанные далее в данном варианте совета файлы, необходимо запускать от имени администратора.
Чтобы это осуществить, щелкните правой кнопкой мыши на необходимый файл и выберите пункт Запуск от имени Администратора (Run as Administrator).

4) В зависимости от разрядности Вашей операционной системы запустите патч:
4.1) Если у Вас 32-бит версия Windows 7, то запустите файл Patch 32-bit System Files.bat.
4.2) Если у Вас 64-бит версия Windows 7, то запустите файл Patch 64-bit System Files.bat.

Патч заменит в папке %WINDIR%\system32\ имеющиеся у Вас файлы dwm.exe и udwm.dll их версиями из бета версии Windows 7.
Оригинальные файлы будут сохранены как dwm.backup и udwm.backup.
После окончания выполнения патча заголовки окон станут, как прозрачное стекло - без размывки заднего плана.

Теперь для включения или отключения матовости у заголовков окон, Вам необходимо будет только запустить один из указанных ниже bat-файлов:
5) Запустите файл Enable Blur.bat - чтобы включить у заголовков окон эффект матового стекла - с размывкой заднего плана.
6) Запустите файл Disable Blur.bat - чтобы отключить у заголовков окон эффект матового стекла и включить эффект прозрачного стекла - без размывки заднего плана.

7) Чтобы восстановить системные файлы запустите файл Restore System Files.bat.

Вариант 2.

1) Скачайте архив TrueTransparency.zip
2) Распакуйте его и запустите файл TrueTransparency.exe со специальной программой.
3) На панели задач появится значок программы. Щелкните на нем правой кнопкой мыши.
4) Выберите нужный язык в всплывающем меню Language(Языки),
5) В меню Skins (Внешний вид) выберите одну из предложенных тем прозрачности (Например: Aero2).

Вариант 3.

1) Скачайте архив Windows7AeroBlurTweaker.zip
2) Распакуйте его и запустите файл Windows 7 Aero Blur Tweaker.exe со специальной программой.
Нажмите кнопку Hide Blur, чтобы отключить у заголовков окон эффект матового стекла и включить эффект прозрачного стекла - без размывки заднего плана.
Нажмите кнопку Show Blur, чтобы включить у заголовков окон эффект матового стекла и отключить эффект прозрачного стекла - с размывкой заднего плана. Перейти к началу Общего списка советов.


6. Принудительное включение отключенного эффекта прозрачности - Aero Glass.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM
3) Установите значение Dword-параметра Composition равным 1.
4) Установите значение Dword-параметра CompositionPolicy равным 2.
5) Установите значение Dword-параметра ColorizationOpaqueBlend равным 1.
Также Вы можете скачать и применить готовый reg-файл enableaero.zip
6) Перезапустите "Диспетчер сеансов диспетчера окон рабочего стола".
6.1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
6.2) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.

7) Откройте Пуск → Панель управления → Система.
8) Слева в списке нажмите ссылку Дополнительные параметры системы.
9) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
10) На вкладке Визуальные эффекты убедитесь, что у Вас установлены флажки напротив указанных ниже пунктов:

Включение композиции рабочего стола
Включить эффект прозрачности
Использование стилей отображения для кнопок и окон


7. Улучшение качества передачи цветов монитором.

Windows 7 предлагает новый мастер калибровки экрана (Display Colour Calibration Wizard), который поможет Вам должным образом установить настройки цвета, яркости и контраста, а ClearType tuner сделает текст резким и контрастным. Для вызова средства калибровки цветов монитора сделайте следующее:

1) Нажмите кнопку Пуск
2) В строке поиска введите dccw.exe и нажмите клавишу Enter ↵.

Вы можете запустить калибровку цветов и другим способом:

1) Откройте Пуск → Панель управления
2) Перейдите по ссылкам Оформление и персонализация → Экран
3) В левой области выберите пункт Калибровка цветов. Перейти к началу Общего списка советов.


8. Включение и отключение Области переходов.

"Область переходов" – это специальная панель (дерево папок), которая находится слева в каждой папке.
Она выполняет функцию командной оболочки, обеспечивая быстрый доступ к папкам, которые содержат нужные файлы. Быстрое выполнение различных операций – таких, как копирование, удаление, архивирование файлов и папок, открытие сохраненного запроса поиска.
При большом числе файлов на экране, иногда необходимо отключить "Область переходов", для увеличения одновременно отображаемых файлов.

Включить или отключить "Область переходов" можно так:

1) Нажмите вверху слева Упорядочить→Представление
2) Поставьте или уберите галочку в пункте "Область переходов"

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Отображение.


9. Расширение функциональности часов в трее или изменение их вида.

Если Вы желаете расширить функциональность часов в трее, то предлагаю Вам воспользоваться программой Stoic Joker's T-Clock x32/x64.

Используя данную программу Вы сможете:

- Добавить секунды к часам
- Изменить внешний вид часов и/или даты
- Запустить таймер или секундомер
- Создать Будильник
- Настроить прозрачность панели задач
- Добавить программу в список Быстрого Запуска

1) Скачайте программу Stoic Joker's T-Clock x32/x64.
Официальная ссылка на английскую версию программы: Stoic Joker's T-Clock x32/x64,
Ссылка на русскую версию программы Stoic Joker's T-Clock x32/x64, переведенную мною (Nizaury).
2) Распакуйте архив и перейдите в папку, соответствующую разрядности Вашей системы.
3) Запустите программу.

Для изменения внешнего вид часов и/или даты:

1) Щелкните правой кнопкой мыши на расширенные часы в трее и выберите пункт T-Clock Properties (Настройки T-Clock).
2) Перейдите на вкладку Clock Text (Текст Часов) и в ниспадающем меню Font (Шрифт) выберите шрифт поддерживающий кирилицу, а также его качество, размер и начертание.
3) Перейдите на вкладку Time Format (Формат Времени) и укажите необходимые для отображения данные.
4) Нажмите кнопку ОК.

Для добавления своей программы в список быстрого запуска:

1) Щелкните правой кнопкой мыши на расширенные часы в трее и выберите пункт T-Clock Properties (Настройки T-Clock).
2) Перейдите на вкладку Quicky Menus (Настройка Меню).
3) Щелкните дважды на строке в разделе Add Menu Item (Добавить Пункт Меню).
В зависимости от того на какой строке Вы щелкните ей будет присвоен соответствующий номер.
4) Программа переключится на вкладку Menu Item Details (Детали Пункта Меню).
5) Задайте название пункта меню, укажите путь к файлу программы.
6) В разделе Save Changes to Custom Menu List Now? (Сохранить Изменения в Списке Меню?) нажмите кнопку ОК и закройте окно настроек.

Для сохранения настроек программы:

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Stoic Joker's
3) Щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Экспортировать.
4) Выберите месторасположение reg-файла и задайте его наименование.
5) Нажмите кнопку Сохранить и закройте редактор реестра.
Теперь после переустановки Windows Вам достаточно будет только применить созданный Вами reg-файл, и все Ваши настройки программы Stoic Joker's T-Clock будут восстановлены.

Если Вы изменили местонахождение папки, содержащей файлы Clock_RUS.exe и Clock_ENG.exe,
то Вам необходимо указать адрес рабочей папки в значении параметра ExePath в разделе HKEY_CURRENT_USER\Software\Stoic Joker's\T-Clock 2010

Примечание:

П.1) Для добавления программы в папку Автозагрузка:
Установите флажок Start T-Clock 2010 When Windows Starts (Запускать T-Clock при запуске Windows) на вкладке About (О программе) и нажмите кнопку ОК. Во всплывшем окне нажмите Да.
П.2) Для отображения даты и часов на двух строках вместо одной:
Установите флажок CR (Link Break) (Перенос Строки) на вкладке Time Format (Формат Времени) и нажмите кнопку ОК. Перейти к началу Общего списка советов.


10. Добавление дополнительных операций к окнам.

К сожалению, многие разработчики не столь тщательно занимаются интерфейсом своих программ. Часто бывает, что у довольно хорошей программами неудачный интерфейс. Отсутствуют какие-либо нужные вам кнопки. А бывает вам надо сравнить два окна или скопировать из одного в другое, а для этого необходимо поместить окно поверх других. Вот тут вам и поможет программа AWM.

Добавляет дополнительные функции для окон:
  • свернуть при запуске/деактивации, развернуть при запуске, закрыть при запуске, изменить положение/размер (например: в пикселях) при запуске
  • зафиксировать положение/размер (например: в пикселях), изменить приоритет выполнения при запуске/деактивации;
  • свернуть в область уведомлений, поверх других окон, позади остальных, прозрачность, через дополнительные кнопки заголовка окна
  • и многие другие.
Скачать программу Перейти к началу Общего списка советов.


11. Добавление командной строке эффекта прозрачности - Aero Glass.

Для добавления командной строке эффекта прозрачности (Aero Glass) сделайте следующее:

1) Скачайте архив: GlassCMD.zip
2) Распакуйте его и запустите исполняемый файл минискрипта Glass CMD.exe.
3) Запустите командную строку(Win   + R → CMD →Ok) и увидите эффект прозрачности (Aero Glass).
Для использования данного эффекта скрипт Glass CMD.exe должен быть запущен. При закрытии Glass CMD.exe эффект прозрачности пропадет.
При желании Вы можете добавить данный скрипт-программу в папку Автозагрузка в меню Пуск.
Если Вы не хотите, чтобы в области уведомлений (трее) отображался значок скрипта, то в файле Settings.ini, который идет в архиве в комплекте с исполняемым файлом скрипта, установите значение параметра HideTrayIcon равным 1.


12. Определение цветового кода любой точки экрана на мониторе.

Для того чтобы узнать цветовой код любой точки экрана на Вашем мониторе скачайте и установите небольшую, но функциональную программу ColorPic.

Данная программа абсолютно бесплатна и Вы можете скачать её с официального сайта: http://www.iconico.com/colorpic/index.aspx

Мощные средства для регулировки цвета позволяют Вам с легкостью менять индивидуальные цвета. С помощью четырех графических миксеров Вы сможете регулировать RGB, оттенки, насыщенность и код цвета. У Вас будет возможность просматривать CMYK печатные коды цвета, а для идеальной точности использовать увеличитель экрана. Вы сможете сохранять множество цветовых палитр для их использования в любом приложении.

Содержащийся в программе раздел "Mixer" предоставляет Вам четыре мощных графических способа для анализа и изменения выбранного цвета. Цвета могут быть выбраны из любых шестиугольных форм, измененных миксером или настроенных шестью индивидуальными слайдерами яў оттенков, насыщенности, кода и красных, зеленых и голубых цветовых компонентов. ColorPic также делает отчеты для регулировки голубого, пурпурного, желтого и черного цветовых кодов.

Кроме того, ColorPic также предлагает возможность увеличения, предоставляя Вам супер детальную картинку при выборе цвета. Программа имеет простой в использовании слайдер для увеличения, который позволяет Вам выбирать или разовую пробу или 3x3 или 5x5 средний цвет из любого места на Вашем экране.

Будучи неоценимым средством для любого графического дизайнера или веб-разработчика и будучи постоянно самым популярным бесплатным цветоподборщиком в сети, самая последняя версия ColorPic предлагает мощные средства для выбора цвета, которые до сих пор доступны только в дорогих приложениях.

Использовать программу очень просто:

1) Запускаете программу
2) Наводите курсор в то место, цвет которого желаете узнать.
3) Нажимаете Ctrl + G и в первой ячейке сохраняется информация о цвете.
4) Затем выделяете следующую ячейку и проделываете указанное выше для определения другого цвета. Перейти к началу Общего списка советов.


13. Создание темы оформления с использованием RSS-обоев.

В интернете существует много программ позволяющих менять картинки на рабочем столе, автоматически скачивая их из интернета. Но Вам необязательно скачивать дополнительную программу, так как возможность обновления фона рабочего стола используя интернет имеется в самой Windows. Для этого Вам необходимо создать новую тему для Windows со ссылкой на RSS ленту, в качестве новостей транслирующую картинки.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Замените {themename} на название темы (Например: RSS Wallpapers), а вместо {rssfeedurl} впишите адрес ленты, транслирующей картинки.

Например:

http://feeds.feedburner.com/bingimages
http://api.flickr.com/services/feeds/photos_public.gne
http://feeds.nationalgeographic.com/ng/News/News_Main
http://mlewallpapers.com/4x3_rss.php

3) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .theme. Например: RSS_Wallpappers.theme
4) Щелкните два раза по получившемуся файлу.
5) В окне Подписаться на RSS канал?(Subscribe to RSS Feed?) выберите пункт Загружать вложения (Download Attachments).

Многие RSS ленты рекомендуют (хотя и необязательно) в Панель управления\Оформление и персонализация\Персонализация\Фоновый рисунок рабочего стола установить положение изображения По центру.

Готовые 4 схемы Вы можете скачать по ссылке: rssthemes.zip


14. Изменение фонового рисунка рабочего стола в Windows 7 Starter.

Вариант 1. Вручную используя реестр Windows.

1) Запустите Редактор реестра. Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter ↵ (или Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_CURRENT_USER\Control Panel\Desktop
3) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."

4.1) Если Вы первый раз изменяете фоновое изображение:

4.1.1) Нажмите кнопку Дополнительно
4.1.2) Перейдите на вкладку Владелец, выделите свое имя в окне Изменить владельца на: и нажмите кнопку Применить
4.1.3) Перейдите на вкладку Разрешения и уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажимаете кнопку Удалить.
4.1.4) Нажмите поочередно кнопки Добавить... → Дополнительно... → Поиск
4.1.5) В результатах поиска выберите Все и нажмите кнопку "OK", и еще раз "ОК".
4.1.6) В окне Элемент разрешения для "Desktop" напротив значения Полный доступ установите флажок в столбце Разрешить и нажмите несколько раз кнопки ОК.

4.2) Если Вы во второй раз изменяете фоновое изображение или если у Вас в "Группы и Пользователи" уже есть группа "Все" и Вы являетесь владельцем объекта:

4.2.1) Выделите группу Все, нажав на нее.
4.2.2) В части окна Разрешения для группы "Все" установите флажок Полный доступ в столбике Разрешить и нажимаете ОК.

5) Найдите строковый параметр Wallpaper и дважды щелкните на нем.
6) Введите путь к изображению, которое Вы хотите использовать как обои рабочего стола и нажмите ОК.
7) По умолчанию, положение изображения устанавливается По центру, если Вам необходимо другое положение, то дополнительно измените:

Параметр TileWallpaper на значение 1, чтобы Замостить изображение.
Параметр WallpaperStyle на значение 2, чтобы Растянуть изображение.

8) Щелкните правой кнопкой мыши на папке Desktop в древовидном списке слева, и нажмите пункт "Разрешения..."
9) Выделите группу Все, нажав на нее.
10) Уберите флажок в столбце Разрешить напротив значения Полный доступ и нажмите кнопку ОК.
Если Вы не уберете данный флажок, то система установит стандартные обои рабочего стола.
11) Перезайдите в систему или перезагрузите компьютер.

Вариант 2. Автоматически используя специальную программу.

1) Скачайте архив программы StarterBackgroundChanger.zip
2) Разархивируйте файл в любую папку и установите нужную Вам языковую версию программы.
3) Нажмите правой кнопкой мыши на рабочем столе и выберите в контекстном меню пункт Персонализация (Personalize)
4) Нажмите кнопку Обзор... (Browse...).
5) Выберите необходимое Вам изображение и нажмите кнопку Открыть (Open).
6) Выберите положение рисунка и нажмите Применить (Apply), чтобы установить рисунок не выходя из программы или ОК, чтобы установить рисунок и выйти их программы.
7) Чтобы установить стандартное изображение выберите в ниспадающем меню Фоновый рисунок Windows по умолчанию и нажмите кнопку ОК. Перейти к началу Общего списка советов.


15. Изменение размера окон предпросмотра на панели задач.

Если Вам необходимо изменить размер окон предпросмотра, расстояние между ними, размер бордюра и время задержки, то в этом Вам поможет программа Windows 7 Taskbar Thumbnail Customizer.

1) Скачайте архив с программой W7TTC.zip
2) Распакуйте архив и запустите программу.
3) Настройте параметры программы в соответствие с Вашими запросами.

Maximum Size - максимальный размер окна предпросмотра
Minimum Size - минимальный размер окна предпросмотра

X Spacing - расстояние между окнами предпросмотра по-горизонтали
Y Spacing - расстояние между окнами предпросмотра по-вертикали

Top Margin - размер верхнего бордюра
Bottom Margin - размер нижнего бордюра
Left Margin - размер левого бордюра
Right Margin - размер правого бордюра

Delay Time - время задержки до появления окна предпросмотра


36. Добавление в контекстное меню рабочего стола пункта "Имя и расположение текущего файла фона".

Если у Вас большое количество изображений используется в качестве фоновых изображений рабочего стола, то когда необходимо найти текущее изображение, Вам приходится просматривать большое количество файлов.
Чтобы сберечь затраченное Вами на поиск файла время, Вы можете добавить в контекстное меню рабочего стола пункт Имя и расположение текущего файла фона.

1) Создайте в папке C:\Windows текстовый файл указанного ниже содержания и сохраните его с именем WPTargetDir.vbs.

2) Для добавления пункта Имя и расположение текущего файла фона в контекстное меню рабочего стола, создайте и примените reg-файл следующего содержания:

При использовании данного пункта меню, скрипт откроет в Проводнике папку содержащую файл текущего изображения и выделит его.

2) Для удаления пункта Имя и расположение текущего файла фона из контекстного меню рабочего стола, создайте и примените reg-файл следующего содержания:

Готовый комплект данных файлов Вы можете скачать по ссылке: WPTargetDir.zip Перейти к началу Общего списка советов.


17. Замена фона папки в Проводнике.

Проще всего для замены фона в папке использовать следующие программы:

Windows 7 Folder Background Changer

1) Запустите программу Windows 7 Folder Background Changer
2) Нажмите кнопку Browse и выберите фоновое изображение
3) Нажмите Change Background Image, чтобы установить фоновое изображение или кнопку Remove Background Image, чтобы убрать фоновое изображение.
4) Для изменения фонового изображения во вложенных папках, установите флажок Apply To Sub Folders.

AveFolderBg - данная программа добавляет дополнительную вкладку в свойства каждой папки.

1) После распаковки архива, откройте папку в соответствии с разрядностью Вашей Windows и установите программу используя файл install.bat
2) Перезапустите Windows или перезайдите в систему.
3) Щелкните правой кнопкой мыши и выберите Свойства
4) Перейдите на вкладку Folder Background
5) Нажмите кнопку Set Image, выбираете изображение и нажимаете Открыть. Для удаления изображения используйте кнопку Remove Image.
6) Для изменения фонового изображения во вложенных папках, установите флажок Apply to subfolders also.
7) Нажмите кнопку Применить или ОК. Перейти к началу Общего списка советов.


18. Сохранение созданной Вами схемы указателей мыши в файл, для дальнейшего использования.

Созданные Вами схемы для указателей мыши прописываются в реестре.
Если Вы желаете сохранить созданную Вами тему для дальнейшего применения после переустановки, то сделайте следующее:

1) Откройте Пуск → Панель управления → Мышь
2) Перейдите на вкладку Указатели
3) В окне Настройка измените необходимые Вам курсоры.
4) Нажмите кнопку Сохранить как, введите название сохраняемой темы и нажмите ОК.
5) В окне Свойства:Мышь снова нажмите ОК.
6) Запустите редактор реестра (Win   + R → regedit → ОК)
7) Откройте раздел HKEY_CURRENT_USER\Control Panel\Cursors\Schemes
8) Экспортируйте данный раздел в reg-файл.
8.1) В главном меню выберите Файл → экспорт
9) Задайте имя файла и нажмите кнопку Сохранить.

Система создаст reg-файл, который Вы сможете использовать в дальнейшем. Например, после переустановки Windows.
Если при создании схемы для указателей Вы использовали файлы отсутствующие в системе, то после переустановки Windows, перед применением reg-файла скопируйте их в те же месторасположения.


19. Добавление отображения эскизов и детальной информации для файлов .mkv в Проводнике Windows.

Если Вы хотите, чтобы у Вас отображались эскизы для mkv-файлов и детальная информация для них, то Вы можете воспользоваться одним из следующих решений.

1) Скачайте и установите DivX Software.

или скачайте и установите Microsoft .NET Framework 4.5.2 и выберите один из следующих вариантов.

2) Скачайте и установите отдельно Icaros, в программе нажмите кнопку Activate Icaros. Более поздние бета-версии программы можно найти на последних страницах ее темы на форуме автора.
3) Скачайте и установите набор кодеков Shark007 Windows 7 Codecs. В 64-битной версии Windows дополнительно установите x64 Components.
4) Скачайте и установите набор кодеков K-Lite Codec Pack.

Независимо от того какой пакет кодеков Вы решите выбрать Shark007 Windows 7 Codecs или K-Lite Codec Pack, для отображения эскизов и информации для mkv файлов они оба используют Icaros.


20. Использование флажков для выделения (выбора) файлов и папок.

В Windows есть удобная возможность помечать для выделения файлы и папки с использованием флажков (чекбоксов). Это удобнее чем выделять объекты удерживая Ctrl, но эта функция отключена по умолчанию. Для ее включения проделайте следующее:
Откройте Пуск → Панель Управления → Параметры Папок и перейдите на вкладку Вид.
Отметьте параметр "Использовать флажки яў выбора элементов" и нажмите ОК.
Теперь слева возле каждого файла и папки ¦вилась возможность отметить их поставив флажок, а в заголовках колонок сортировки можно поставить флажок для выделения всех объектов открытой папки.

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Отображение.


21. Объединение нескольких различных приложений(папок или иконок) в один значок на Панели задач.

Одним из самых явных изменений в Windows 7 является новая панель задач, в которой вместо кнопок отображаются иконки, и все окна приложения объединяются под одну кнопку. Со временем, когда на компьютере установлено много программ, на панели задач начинает не хватать места для кнопок.
Исправить это можно с помощью бесплатной программы 7Stacks.

Данная программа является своего рода продолжением развития панели быстрого запуска, только интерфейс сделан в стиле Windows 7 — в виде стеков.
Она позволяет объединить в одну кнопку на панели задач несколько файлов, папок или приложений.
Это может быть весьма удобным для быстрого доступа к программам отсортированным по разделам.

Официальная сайт: http://alastria.com/software/7stacks/
Русская версия программы: 7stacks_Rus.7z.

Она создает подменю для кнопок, позволяя отсортировать программы по разделам – игры, программы для интернета, и т.д.

Порядок действий:

1) Создайте папку
2) Сложите в нее ярлыки приложений, необходимых Вам в создаваемом меню.
3) Запустите 7Stacks
4) Выберите созданную Вами папку
5) Настройте оформление и создайте ярлык на рабочем столе.
6) Перетащите данный ярлык в панель задач. Перейти к началу Общего списка советов.


22. Закрепление конкретной папки на панели задач Windows 7.

Если Вы перетащите папку на панель задач, то она закрепится во всплывающем списке (подменю) Проводника. Чтобы закрепить отдельно папку на панели задач сделайте следующее:

1) Щелкните правой кнопкой мыши на рабочем столе и выберите Создать → Ярлык.
2) В поле Расположение объекта введите:

(вместо C:\MyFolder введите фактический адрес прикрепляемой папки).
3) В поле Имя ярлыка введите название папки (в нашем случае это MyFolder) и нажмите Готово.
4) Щелкните правой кнопкой по созданному ярлыку и в появившемся контекстном меню выберите пункт Закрепить на панели задач.

Примечание. Каждая закрепленная папка будет открываться в отдельном процессе. Перейти к началу Общего списка советов.


23. Настройка списка элементов, отображаемых в диалоговом окне открытия и сохранения файлов Windows.

1) Щелкните на кнопке Пуск
2) В строке поиска введите gpedit.msc и нажмите клавишу Enter ↵.
3) Откройте узел Конфигурация пользователя →Административные шаблоны → Компоненты Windows → Проводник Windows → Общее диалоговое окно открытия файлов.
4) Дважды щелкните на политике Элементы, отображаемые в панели мест.
5) Щелкните на переключателе Включить.
6) Используйте текстовые поля Элемент 1 — Элемент 5 для ввода путей к папкам, которые требуется отображать в панели мест. Ими могут быть локальные или сетевые папки.
7) Щелкните на кнопке OK, чтобы ввести политику в действие.

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Отображение.


24. Отображение часто используемых команд для диалогового окна "Выполнить" в меню Пуск.

Когда Вы вводите в диалоговом окне Выполнить какие-либо команды, то они сохраняются в разделе реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU
Данные команды сохраняются в значениях параметров от "a" до "z". А порядок их отображения регулируется параметром MRUList.
Вы можете добавлять свои команды в реестр, изменяя значения для данных параметров.
Но у данного способа есть один существенный недостаток - новые значения перезаписываются поверх уже имеющихся.
В качестве решения, Вы можете добавить наиболее часто используемые команды в диалоговое окно Выполнить в виде списка. Для этого выполните указанные ниже действия.

1) Откройте папку содержащую файл shell32.dll.mui

Для 32-битной версии: C:\Windows\System32\ru-RU
Для 64-битной версии(также): C:\Windows\SysWOW64\ru-RU

2) Задайте полный доступ к файлу shell32.dll.mui, для этого воспользуйтесь советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
3) Скачайте архив Patch_ExtendedRun.zip и распакуйте его в любую папку.
4) Щелкните на exe-файле правой кнопкой мыши и выберите пункт Запуск от имени администратора.
5) Нажмите кнопку Start для применения патча.

Внимание: Памятку устанавливать только на оригинальные ОС, работоспособность на различного рода сборках не гарантируется.

Кроме указанного патча, также существует альтернатива диалоговому окну Выполнить программа Run-Command.
Используя данную программу Вы сможете добавлять в Избранное наиболее часто используемые команды.
Для более тонкой настройки программы используйте ini-файл.
Для переключения языка нажмите #LNG.
Для закрытия программы нажмите Выход (Exit), нажатие на крестик свернет программу в трей.


25. Размещение любого окна Windows поверх других.

При работе с огромным количеством открытых окон, документов, таблиц и программ очень часто хочется, чтобы окно оставалось поверх всех открытых окон (OnTop) даже при потере фокуса. Для этого можно использовать программу DeskPins.

Программа предназначена для того, чтобы закреплять любые приложения поверх всех окон Windows. Нужно просто перетащить кнопку с иконки программы на заголовок того окна, которое нужно закрепить, и нажать кнопку мыши — теперь закрепленное окно всегда будет на самом верху. Закреплять и откреплять активные окна можно с помощью горячих клавиш, есть также возможность автоматического закрепления окон. Нажимаете Ctrl + F12 и окно становится OnTop по отношению ко всем открытым.


26. Изменение загрузочного экрана (включая шарики и текст) в Windows 7 на любой другой.

Данный совет рекомендуется опытным пользователя и тем у кого есть записанный образ Windows 7 на DVD или флэш-диск для восстановления файлов в случае сбоя системы.
Для изменения загрузочного экрана Windows 7 Вам понадобит© программа Windows 7 Boot Updater.
Зайдите на сайт: Coder for life и скачайте последнюю её версию.

Описание опций:

Переключатели в графе Animation:
Default - По умолчанию
Static Image - Используется для выбора статического изображения в качестве загрузочного логотипа.

Animation - Используется для выбора папки содержащей файлы для анимации.
Анимация может быть:

1) В одном BMP-файле размером 200x21000 пикселей, где все кадры анимации расположены сверху вниз подряд
2) В виде отдельных 105 последовательных изображений размером 200x200 в формате BMP, PNG, GIF, или TIFFs файлов. В нумерации всегда необходимо использовать три цифры, начиная с цифры 000 и заканчивая цифрой 104 (000, 001, ..., 103, 104).

Background (верхняя надпись) - цвет фона всего экрана.

Переключатели в графе Method:

Simple - Используется для заливки фона одним цветом.
Complete - Используется для выбора собственного изображения в качестве картинки для фона. При установке данного переключателя, нажмите кнопку Select Background Image и выберите желаемую картинку.

Параметры в графе Messages:

В ниспадающем списке напротив пункта Count (Количество текстовых строк): None - Ниодной, 1 Message - 1 Текстовая строка (нижнЯя), 2 Messages - Обе текстовых строки.
Background (нижнЯя надпись) - цвет фона для текстовых сообщений.

Вкладка Message 1 - НижнЯя текстовая строка
Вкладка Message 2 - Верхняя текстовая строка

Text - текст сообщения выводимый в текстовой строке
Font Color - Цвет шрифта
Position - Позиция по вертикали, относительно верхнего края экрана.
Font Size - Размер шрифта

Особенности запуска.

Если у Вас Английская версия Windows:

1) Запустите исполняемый файл программы от имени администратора (используя меню, вызываемое правой кнопкой мыши).
Внимание: Программа может загрузит© с небольшой задержкой - подождите.
2) Измените необходимые Вам значения.
3) Нажмите кнопку Play, чтобы просмотреть сделанные изменения.
4) Если результат Вас устраивает нажмите кнопку Apply.
5) Закройте программу и перезагрузите компьютер, чтобы увидеть результат.

Если у Вас Английская версия Windows + русский языковой пакет:

1) Переключите язык интерфейса для экрана приветствия на Английский.
1.1) Нажмите кнопку Пуск, выберите последовательно компоненты Панель управления → Часы, язык и регион → Язык и региональные стандарты.
1.2) Перейдите на вкладку Языки и клавиатуры, в разделе Язык интерфейса выберите английский язык в списке и нажмите кнопку ОК, а затем Выйти из ситемы сейчас.
1.3) Снова войдите в систему, нажмите кнопку Пуск, выберите последовательно компоненты Control Panel → Clock, Language, and Region → Change display language.
1.4) В открывшемся диалоговом окне перейдите на вкладку Administrative и щелкните на кнопке Copy settings.
1.5) В открывшемся окне установите флажок у пункта Welcome screen and system accounts.
1.6) Во всплывшем окне нажмите Cancel и перейдите на вкладку Keyboards and Languages.
1.7) В разделе Display Language выберите русский язык в списке и нажмите кнопку ОК, а затем Log off now.
1.8) Снова войдите в систему.
2) Запустите исполняемый файл программы от имени администратора (используя меню, вызываемое правой кнопкой мыши).
Внимание: Программа может загрузит© с небольшой задержкой - подождите.
3) Измените необходимые Вам значения.
4) Нажмите кнопку Play, чтобы просмотреть сделанные изменения.
5) Если результат Вас устраивает нажмите кнопку Apply.
6) Закройте программу и перезагрузите компьютер, чтобы увидеть результат.

Если у Вас Русская версия Windows:

1) Скопируйте файл winload.exe.mui из папки C:\Windows\System32\ru-RU в папку C:\Windows\System32\en-US
2) Запустите исполняемый файл программы от имени администратора (используя меню, вызываемое правой кнопкой мыши).
Внимание: Программа может загрузит© с небольшой задержкой - подождите.
3) Измените необходимые Вам значения.
4) Нажмите кнопку Play, чтобы просмотреть сделанные изменения.
5) Если результат Вас устраивает нажмите кнопку Apply и закройте программу.
6) Закройте программу
7) Переместите файл winload.exe.mui обратно из папки C:\Windows\System32\en-US в папку C:\Windows\System32\ru-RU
8) Перезагрузите компьютер, чтобы увидеть результат.
Если у Вас возникнут проблемы с доступом к файлу winload.exe.mui, то Вы можете воспользоваться решением предложенным в совете 1. Получение полного доступа к файлу или папке. из раздела Администрирование.

Если Вы уже изменяли загрузочный экран с помощью данной программы и решили изменить его снова, то прежде чем это сделать восстановите резервные копии файлов:
Щелкните в главном меню пункт Options и выберите пункт Restore Backups
Если у Вас изначально русская версия Windows, то верните восстановленный файл winload.exe.mui обратно из папки C:\Windows\System32\en-US в папку C:\Windows\System32\ru-RU


27. Включение всех Аэро эффектов, поддержки тем Аэро и активация панели Персонализация в Windows Начальная и Windows Домашняя Базовая.

Создан специальный патч, позволяющий активировать панель Персонализации и включить все эффекты Аэро (Aero Glass, Aero Peek, Aero Shake, Aero Snap, Windows Flip 3D), отключенные в версиях Windows Начальная (Starter) и Windows Домашняя Базовая (Home Basic). Также данный патч добавляет панель Персонализации и поддержку тем\стилей Аэро, имеющуюся в старших редакциях Windows.

Добавляемые Аэро эффекты:

Aero Glass — прозрачные (с размывкой заднего плана) заголовки.
Aero Peek — позволяет отобразить рабочий стол поместив указатель мыши на специальную кнопку в правом углу панели задач.
Aero Shake — позволяет свернуть/восстановить окна, достаточно захватить заголовок окна и немного «потрясти».
Aero Snap — быстрое разворачивание окна на полэкрана, весь экран или только по вертикальной оси.
Windows Flip 3D — прокрутка окон под углом.
Миниатюры окон, появляющиеся при наведении на кнопку окна на панели задач.

1) Скачайте архив PersonalizationPanel-AeroPatch.zip с патчем по официальной или по альтернативной ссылке и распакуйте его.
2) Отключите используемый Вами антивирус на время установки. Если у Вас включен Контроль учетных записей (UAC), то отключите его.
2.1) Нажмите Win   + R, введите команду UserAccountControlSettings и нажмите Enter ↵.
2.2) Передвиньте ползунок в самое нижнее значение и нажмите кнопку ОК, а затем кнопку Да.
2.3) Перезагрузите компьютер.
3) Щелкните правой кнопкой мыши на файле Personalization Panel .exe и выберите "Запустить от Администратора".
4) В окне "Установить Панель персонализации?" нажмите кнопку ОК.
5) Перезагрузите компьютер.
6) Если Вам необходим Контроль учетных записей (UAC), то включите его.
7) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
(Доступ к панели Персонализация добавится также и в Панель управления)
8) В разделе темы Aero выберите тему Windows 7. (Также Вы можете скопировать для использования темы Aero из Windows 7 Максимальная или скачать их из интернета.)

Для удаления патча воспользуйтесь апплетом Программы и Компоненты из Панели управления.


28. Включение/отключение отображения системных значков (Компьютер, Панель Управления и Корзина) на рабочем столе.

1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация
2) Слева в открывшемся окне щелкните по ссылке Изменение значков рабочего стола
3) Для добавления значка на рабочий стол, в разделе Значки рабочего стола - установите флажок рядом с названием нужного Вам элемента.
4) Для удаления значка с рабочего стола, в разделе Значки рабочего стола - снимите флажок рядом с названием нужного Вам элемента.
5) Нажмите кнопку ОК.

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Отображение.


29. Изменение цвета Aero в случайном порядке или используя заданный список цветов.

Если Вам нехватает цветовой гаммы Windows для изменения цвета Aero или же Вы хотите использовать расширенные возможности изменения цвета Aero, то Вы можете воспользоваться программой AeroRainbow.
Данная программа позволяет изменять цвета Aero в случайном порядке или по заранее подобранному списку. У пользователя программы есть возможность выбрать скорость замены цвета, подбирать цвет под обои или активное окно.

AeroRainbow умеет менять цвет окон Aero в Windows 7 "на лету", используя:
- цвет текущих обоев;
- цвет текущего открытого окна;
- цвет из списка ваших любимых цветов;
- случайно созданный цвет.
- возможность использовать в качестве источника цвета окон только иконку активного открытого окна.
- два алгоритма расчёта цвета окон (основной цвет источника и средний цвет источника) для режимов "Цвет обоев" и "Цвет активного окна/иконки".

Скачать: AeroRainbow.zip

Подробнее о настройках:

Группа переключателей Цвет окон позволяет определить, каким образом менять цвет окон.

Случайный цвет - цвет окон всегда будет случайным. Для уточнения следующего цвета окон, щелкните по иконке в трее левой кнопкой мыши.
Правый квадрат показывает цвет, в который будут окрашены окна Aero. Если данный цвет Вам не нравится, щелкните на нем, для его замены на другой (актуально для режима случайного выбора цвета окон).

Опция Использовать вот эти цвета позволяет Вам создать и использовать свой собственный список цветов, в который Вы хотите окрашивать окна. Используйте + и -, чтобы добавлять и удалять цвета.
Регулятор Скорость позволяет указать для режимов Использовать вот эти цвета и Случайный цвет скорость, с которой будут меняться цвета окон.
Крайнее левое положение означает самую быструю смену цвета окон, крайнее правое - самое медленное.

Цвет окон определяется обоями - программа анализирует фоновый рисунок рабочего стола, и устанавливает наиболее подходящий под него цвет окон Aero.
Цвет окон определяется активным окном - программа вычисляет средний цвет открытого активного окна, и использует его в качестве цвета окон Aero. Например, при открытии командной строки цвет Aero окрасится в черный, при открытии программы Far - в синий, а при открытии пустого блокнота - в белый. Вы можете установить флажок Использовать только цвет значка, в этом случае в качестве значения цвета возьмётся не всё окно, а только его иконка. например, если активно окно браузера Opera - Aero будет окрашено в красный цвет, так как иконка окна бразуера Opera красная, а если открыт Блокнот, то окна будут окрашены в синий цвет - цвет иконки окна этой программы.

В AeroRainbow предусмотрены два варианта расчёта цвета окон для режимов Цвет окон определяется активным окном и Цвет окон определяется обоями:
Вычислять главный цвет - программа рассчитывает преобладающий цвет обоев, активного окна или значка активного окна (максимальное значение красного, зеленого или синего канала цвета).
Вычислять средний цвет - цвет окон получается из среднего значение красного, зеленого или синего канала цвета обоев, активного окна или значка активного окна.

Иконка в трее - позволяет отключить или включить иконку в трее. Вы можете отключить иконку, тем самым сэкономив место в системном трее. В этом случае управление параметрами программы, а также выход из неё можно выполнять специально обученными ярлыками, которые создает инсталлятор на рабочем столе. Перейти к началу Общего списка советов.


30. Отключение горизонтального смещения при выборе файла в Проводнике.

Если у Вас для отображения файлов установлен Вид → Список, то при выборе файла, система автоматически сместит по-горизонтали столбец, в котором находится файл.
Чтобы отключить данную функцию воспользуйтесь предложенным ниже решением.

1) Скачайте программу Folder Options X.
С официального сайта: английская версия
С зеркала: русская версия
2) Закройте все окна Проводника.
3) Если Вы установили английскую версию, то откройте в меню Пуск папку T800 Productions и запустите программу. Если Вы скачали русскую версию, то запустите программу из папки, куда Вы распаковали архив.
4) Снимите все флажки и нажмите кнопку Apply (Применить).
5) Установите флажок Disable full row select (Отключить горизонтальное смещение при выборе файла в Проводнике) и нажмите кнопку OK.
6) Перезайдите в систему или перезагрузите компьютер. Перейти к началу Общего списка советов.


31. Отключение и включение отображения эскизов из контекстного меню.

1) Скачайте и распакуйте в любую папку архив: togglethumbs.zip
2) Скопируйте файл togglethumbs.vbs в Вашу папку Windows.
3) Примените reg-файл install.reg для добавления пункта в контекстное меню.

Чтобы отключить или включить эскизы для изображений в папке: щелкните правой кнопкой мыши на пустом пространстве папки и выберите пункт Включить/Отключить эскизы изображений.

Для удаления пункта из контекстного меню примените reg-файл uninstall.reg


32. Добавление пункта "Показать/Скрыть скрытые файлы и папки" в контекстное меню.

1) Скачайте и распакуйте в любую папку архив: ShHFF.zip
2) Скопируйте файл ShHFF.vbs в Вашу папку Windows.
3) Примените reg-файл Add_ShHFF.reg для добавления пункта в контекстное меню.

Чтобы отключить или включить отображение скрытых файлов и папок: щелкните правой кнопкой мыши на пустом пространстве папки и выберите пункт Показать/Скрыть скрытые файлы и папки.

Для удаления пункта из контекстного меню примените reg-файл: Remove_ShHFF.reg


33. Добавление отображения полного пути к папке в строку заголовка окна.

Если Вы желаете добавить отображение полного пути к папке в строке заголовка окна, то Вы можете воспользоваться следующим решением.

1) Скачайте и распакуйте в любую папку архив: AeroBar.zip
2) Запустите файл AeroBar.exe

При желании Вы можете добавить ярлык для запуска данной программы в Пуск → Все программы →Автозагрузка.


34. Быстрое удаление всех закрепленных значков из панели задач.

Чтобы быстро удалить все значки закрепленные в панели задач, создайте bat-файл с указанным ниже содержанием и запустите его от имени администратора.


35. Установка Windows DreamScene для добавления возможности использования *.MPG или *.WMV видеофайлов в качестве фона рабочего стола.

В Windows Vista Ultimate присутствовал модуль Windows DreamScene, который позволял устанавливать в качестве фона рабочего стола видеофайлы *.MPG или *.WMV.
Вы можете вернуть данную возможность, используя предложенное ниже решение.
Обязательным условием является выбор в диалоговом окне Персонализация любой из Aero тем.

Установка.

1) Скачайте архив EnableDreamScenes.zip
2) Распакуйте его в любую папку и запустите программу Enable DreamScenes.exe.
3) Нажмите кнопку Enable, а затем кнопку Reboot windows ?.
4) Нажмите кнопку Да, чтобы перезагрузить компьютер.

Использование.

1) Щелкните правой кнопкой мыши на файле *.MPG или *.WMV и выберите пункт Set as Desktop Backgroud, чтобы установить видеофайл в качестве фона рабочего стола.
2) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Pause Dreamscene, чтобы приостановить воспроизведение видеофайла.
3) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Play Dreamscene, чтобы продолжить воспроизведение видеофайла.

Чтобы отключить воспроизведение видеофайла:

4.1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация → Фон рабочего стола.
4.2) В ниспадающем меню Расположение изображения выберите Фоны рабочего стола Windows.
4.3) Выберите любое изображение и нажмите кнопку Сохранить изменения.

Видеообои в *.WMV формате Вы можете скачать http://www.dreamscene.org/gallery.php Перейти к началу Общего списка советов.


36. Очистка списка Последние для программы прикрепленной на панели задач.

Чтобы самостоятельно очистить список Последние в прикрепленном значке на панели задач, выполните указанные ниже действия:

1) Откройте в Проводнике папку %AppData%\Microsoft\Windows\Recent\AutomaticDestinations
В данной папке хранятся истории списков Последние для программ прикрепленных на панели задач.
2.1) Если Вы желаете удалить все списки, то удалите полностью все файлы.
2.2) Если Вы желаете удалить список для какой-либо конкретной программы, то Вам необходимо удалить только один из файлов .automaticDestinations-ms, который соответствует Вашей программе.

Чтобы выяснить какой из данных файлов соответствует Вашей программе есть два способа:

1) Удалять по одному файлу из данной папки. После удаления необходимого файла, список очистится.
2) Переместить куда-нибудь все файлы из данной папки и добавлять их по одному. Все списки очистятся. После добавления необходимого файла, появится список Последние для нужной программы.

Также рекомедуется полностью очистить содержимое папки %AppData%\Microsoft\Windows\Recent\CustomDestinations.


37. Изменение иконок для устройств в папке "Устройства и принтеры".

Если система выбрала неправильный значок для устройства в папке "Устройства и принтеры" или Вам не нравятся предложенная иконка, то Вы можете изменить его воспользовавшись одним из предложенных ниже решений.

Вариант 1. Изменение общего файла иконок.

1) Откройте в программе Restorator файл DDORes.dll, расположенный в папке C:\Windows\System32
2) Откройте папку Иконка и перетяните на ресурс с имеющейся иконкой, файл иконки, которым Вы хотите ее заменить.
3) Сохраните внесенные изменения нажав Ctrl + S

Для 64-битных Windows проделайте указанное выше с файлом DDORes.dll, расположенным в папке C:\Windows\SysWOW64.
Внимание: Изменение иконки в файле DDORes.dll для ошибочно определенного значка на другой, может привести к некорректному отображению иконки яў устройств с правильно определенным значком.

Вариант 2. Создание метаданных для устройства.

1) Скачайте и установите программу Devices and Printers Metadata Authoring Wizard
2) Перезагрузите компьютер.
3) Откройте папку Пуск → Панель управления → Устройства и принтеры
4) Щелкните правой кнопкой мыши на устройстве, для которого Вы желаете изменить иконку и выберите пункт Create metadata package.
Информация: В случае появления какой-нибудь из ошибок Framework нажмите Продолжить.
5) На вкладке Icons перетащите иконку, которой Вы собираетесь заменить имеющуюся в черный квадрат.
Внимание: Иконка должна содержать в себе несколько вариантов одной и той же иконки с разными размерами, иметь прозрачный фон и гладкие края, и должна соответствовать требованиям размера и глубины цвета, указанным в таблице справа.
6) Для продолжения нажмите Next.
7) На вкладке Description заполните поля Required Fields.
7.1) В поле Model Name укажите Имя Модели (Описание устройства) устройства.
7.2) В поле Manufacturer укажите ПроизводитЈ (ИзготовитЈ) устройства.
8) Для продолжения нажмите Next.
9) На вкладке Categories укажите Тип устройства (Класс устройства).
10) Для продолжения нажмите Next.
11) На вкладке Associations в разделе Hardware ID нажмите на кнопку плюс.
12) Введите значение ИД оборудования и нажмите кнопку ОК.
13) Установите флажок напротив добавленного пункта с Вашим устройством.
14) Для продолжения нажмите Next.
15) На вкладке Options нажмите Next.
16) На вкладке Finish установите флажок Copy package to your system’s local metadata store и нажмите кнопку Finish.
17) Откройте папку %LOCALAPPDATA% (C:\Users\Имя_Пользователя\AppData\Local) и удалите файл кэша иконок IconCache.db.
18) Перезагрузите компьютер.

Необходимые данные для заполнения полей:

1) Откройте Панель управления → Диспетчер устройств
2) Нажмите на устройстве правой кнопкой мыши и выберите пункт Свойства
3) Перейдите на вкладку Сведения.
4) Используя либо ниспадающий список, либо колесико мыши яў прокрутки найдите необходимые Вам значения. Перейти к началу Общего списка советов.


38. Местонахождение большинства значков (иконок) в Windows.

Если Вы хотите использовать одну из иконок (значков) Windows, то большую их часть Вы можете найти в следующих файлах:

C:\Windows\System32\shell32.dll
C:\Windows\System32\imageres.dll
C:\Windows\System32\ddores.dll

Для извлечения необходимой Вам иконки:

1) Откройте один из предложенных файлов, с помощью программы Restorator.
2) В панели Дерево ресурсов откройте папку Иконка
3) Выберите любую из понравившихся Вам иконок.
4) В панели Дерево ресурсов щелкните правой кнопкой мыши на данном ресурсе и выберите Извлечь... → Извлечь как "имя_ресурса.ico"
5) Выберите папку для извлечения и нажмите Сохранить

Вы также можете извлечь все иконки сразу, для этого:
6) В панели Дерево ресурсов щелкните правой кнопкой мыши на папке Иконка и выберите Извлечь... → Извлечь все как тип "Иконка"
7) Выберите папку для извлечения и нажмите OK Перейти к началу Общего списка советов.


39. Инвертирование и замена цветов в одноцветном файле изображения c прозрачным фоном.

Встроенного редактора Paint в Windows хватает для выполнения базовых задач с изображениями с непрозрачным фоном.
Но если Вам необходимо инвертировать или заменить(закрасить) цвет рисунка в файле изображения с прозрачным фоном, то программа Paint сделает это вместе с фоном.

Чтобы быстро инвертировать или заменить цвет в таких файлах, не Вы можете воспользоваться одним из предложенных ниже вариантов:

Вариант 1. Используя командную строку.

1) Откройте страницу http://www.imagemagick.org/download/binaries/
2) Скачайте zip-архив с программой ImageMagick (Файл выглядит примерно так: ImageMagick-X.X.X-X-X-x86-windows.zip, вместо X - номер версии) и распакуйте его в любую папку.
3) Откройте данную папку и скопируйте файл convert.exe в папку к Вашему изображению.
4) Удерживая нажатой клавишу ⇑ Shift щелкните правой кнопкой мыши на папке содержащей изображение. (В примере C:\Images\)
5) Выберите пункт Открыть окно команд.
6) Введите указанную ниже команду и нажмите Enter ↵.

Для инвертирования цветов (замены цвета на противоположный, например, черный на белый):

Для указания требуемого цвета:

или

Для указания требуемого цвета (с ранее необрабатываемым в программе изображением):

Для указания требуемого цвета (с изображением для которого уже были инвертированы цвета):

Внимание: не забудьте поставить запятую в данной команде.

где:
-negate - параметр для инвертирования цветов в изображении.
+level-colors - параметр для установки необходимого цвета в конечном изображении.
В качестве цвета Вы можете указывать его текстовое название, его шестнадцатиричное значение или цветовую модель rgb.
image.png - исходный файл
image2.png - конечный файл

Вариант 2. Используя графическую оболочку.

1) Скачайте и установите программу Paint.NET
2) Откройте программу.
3.1) Перекиньте на окно программы Ваш файл с изображением и нажмите кнопку Открыть.
или
3.2) В меню Файл нажмите Открыть, выберите Ваш файл и нажмите кнопку Открыть.

Для инвертирования цветов (замены цвета на противоположный, например, черный на белый) нажмите сочетание клавиш Ctrl+⇑ Shift+I (или выберите в меню Коррекция пункт Инвертировать цвета).

Для замены цвета в изображении на желаемый, Вам нужно будет указать с какого на какой цвет вы собираетесь заменять.

Указание исходного цвета:

1) В меню Инструмент выберите пункт Пипетка или нажмите клавишу K.
2) Нажмите в изображении левой кнопкой мыши на рисунок, чтобы определить его цвет.

или

1) В окне Палитра в ниспадающем списке выберите пункт Основной и нажмите кнопку Больше >>.
2) Укажите необходимый Вам цвет либо выбрав его из палитры, либо введя его шестнадцатиричное значение или цветовую модель rgb.

Указание конечного цвета:

1) В окне Палитра в ниспадающем списке выберите пункт Дополнительный.
2) Укажите необходимый Вам цвет либо выбрав его из палитры, либо введя его шестнадцатиричное значение или цветовую модель rgb.

Замена цвета:

1) В меню Инструмент выберите пункт Замена цвета или нажмите клавишу R.
2) Установите параметр Чувствительность равным 50% (для изменения необходимо передвинуть ползунок)
3) В поле ширина установите наиболее подходящий размер кисти.
4) Удерживая нажатой правую кнопку мыши проведите по элементам изображения которые Вы желаете перекрасить в другой цвет, после чего отпустите кнопку мыши.

Сохраните изображение с новым именем:

1) В меню Файл выберите пункт Сохранить как... или нажмите сочетание клавиш Ctrl+⇑ Shift+S
2) Укажите необходимое имя для файла и нажмите кнопку Сохранить.
3) В окне Параметры сохранения нажмите кнопку ОК.


40. Создание и редактирование BMP-изображений с 32-битной глубиной цвета.

При редактировании некоторых ресурсов Windows одним из обязательных условий является использование bmp-изображения с 32-битной глубиной цвета.
Чтобы создать такое изображение воспользуйтесь одним из указанных ниже вариантов.

Вариант 1. Конвертирование имеющегося png-изображения в bmp-изображение с 32-битной глубиной цвета.

1) Создайте в программе Paint.NET png-изображение с 32-битной глубиной цвета.
2) Скачайте и распакуйте в любую папку архив AlphaConv.zip
3) Запустите программу AlphaConv.
4) В ниспадающем списке выберите значение .bmp.
Внимание: Программа перезаписывает готовые файлы поверх имеющихся.
5) Перекиньте на окно программы Ваше png-изображение.
Готовый bmp-файл появится появится рядом в папке.

Если Вы снимите флажок Convert only 32-bit images (with alpha channel), то программа AlphaConv сможет преобразовывать png-изображения с меньшей глубиной цвета.
Но существует вероятность того, что система может распознать Ваше изображение некоректно или не распознать его.

Вариант 2. Создание нового и редактирование bmp-изображение с 32-битной глубиной цвета.

1) Скачайте и распакуйте в любую папку архив Pixelformer.zip
2) Запустите программу Pixelformer.
3) Преобразуйте (отредактируйте) имеющееся у Вас изображение или создайте новое.
4) Закройте программу.
При закрытии нажмите Yes, чтобы сохранить проект или No, чтобы выйти без сохранения.

Открытие jpg, png или bmp-файла изображения для редактирования:

1) В меню File выберите пункт Import... или нажмите Ctrl+⇑ Shift+O.
2) Выберите любой bmp, jpg или png-файл и нажмите кнопку Открыть.
3) В меню Image выберите пункт Properties... или нажмите Alt+⇑ Shift+I, а затем P.
4) Установите переключатель в значение RGB color with alpha channel (32 bpp) и нажмите кнопку OK.
5) Используя инструменты программы отредактируйте изображение.

Создание нового bmp-файла:

1) В меню File выберите пункт New или нажмите Ctrl+N.
2) Укажите размеры создаваемого изображения. В поле Width - ширину, а в поле Height - высоту.
3) Установите переключатель в значение RGB color with alpha channel (32 bpp) и нажмите кнопку OK.
4) Используя инструменты программы создайте Ваше новое изображение.

Сохранение сделанных изменений в bmp-файл с 32-битной глубиной цвета:

1) В меню File выберите пункт Export... или нажмите Ctrl+⇑ Shift+S.
2) Укажите имя и месторасположение создаваемого bmp-файла и нажмите кнопку Сохранить.
3) Установите переключатель в значение A8:R8:G8:B8 (32 bpp) и нажмите кнопку OK.


41. Изменение фонового изображения боковой панели Проводника.

Для применения указанных ниже решений полностью отключите контроль учетных записей (Win   + R → UserAccountControlSettings), передвинув ползунок в самый низ и перезагрузив компьютер.

Вариант 1. Без внесения изменений в системный файл.

1) Скачайте и распакуйте архив ThemeResourceChanger.zip
2) Установите программу Theme Resource Changer той же разрядности, что и у Вашей Windows.
Если окно команд самостоятельно не закроется у Вас по окончании установки, то закройте его вручную.
3) Перезагрузите компьютер.
4) Откройте Панель управления\Оформление и персонализация\Параметры папок → вкладка Вид
5) Снимите флажок Запускать окна с папками в отдельном процессе и нажмите кнопку ОК.
4) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
5) Установите тему в которую Вы желаете внести изменения.
6.1) Если Вы используете одну из стандартных(не классических) тем Windows, то откройте папку C:\Windows\Resources\Themes\Aero\.
6.2) Если Вы используете стороннюю тему, то откройте папку данной темы.
7) Создайте в ней папку с именем shell32.dll (Например: C:\Windows\Resources\Themes\Aero\shell32.dll\)
8.1) Для установки фонового изображения боковой панели Проводника, скопируйте в данную папку png-файл с именем 633.png и размером 200x551 пикселей.
8.2) Для убирания диагональных полос под фоновым изображением боковой панели Проводника, скачайте архив shell32_dll_632_wihout_lines.zip и скопируйте из него файл 632.png.

Вариант 2. С внесением изменений в системный файл.

Внимание: Данный вариант Вы используете на свой страх и риск.
Если что-либо пойдет не так система может перестать загружаться и Вам придется востанавливать измененые файлы, используя среду восстановления или MSDaRT-диск.

1) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
2) Установите тему Классическая.
3) Скачайте и распакуйте архив Full_access.zip
4) Примените reg-файл в соответствии с языковыми особенностями Вашей системы.

Full_access_eng.reg - примените, если Вы используете английскую версию Windows.
Название пункта меню указано на английском языке, название группы администраторов указано на английском языке.
Full_access_eng+rus_mui.reg - примените, если Вы используете английскую версию Windows и русский языковой пакет.
Название пункта меню указано на русском языке, название группы администраторов указано на английском языке.
Full_access_rus.reg - примените, если Вы используете русскую версию Windows.
Название пункта меню указано на русском языке, название группы русском указано на английском языке.

5) Откройте папку C:\Windows\System32
6) Нажмите правой кнопкой на файл shell32.dll и выберите пункт Стать владельцем и задать полный доступ к объекту
7) Скопируйте файл shell32.dll на рабочий стол.
8) Откройте данный файл с помощью программы Restorator.
9) Откройте папку Точечный рисунок

10.1) Для установки фонового изображения боковой панели Проводника:

Перетяните на ресурс 633 bmp-файл изображения.
Изображение должно быть размером 200x551 пикселей.

10.2) Для убирания диагональных полос под фоновым изображением боковой панели Проводника:

10.2.1) Скачайте архив shell32_dll_632_wihout_lines.zip и распакуйте в любую папку.
10.2.2) Перетяните файл 632.bmp из этой папки на ресурс 632.

11) Нажмите сочетание клавиш Ctrl + S, чтобы сохранить изменения.
12) Переименуйте оригинальный файл shell32.dll в папке C:\Windows\System32 на _shell32.dll.
13) Переместите с рабочего стола Ваш модифицированный файл shell32.dll в папку C:\Windows\System32

В 64-битной версии повторите указанные действия для файла shell32.dll из папки C:\Windows\SysWOW64.

14) Перезагрузите компьютер.
15) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
16) Установите любую аэро-тему или тему "Windows 7 - упрощенный стиль".


42. Замена или удаление кнопки Пуск на панели задач.

Замена кнопки Пуск в аэро-темах и теме "Windows 7 - упрощенный стиль".

Чтобы заменить кнопку Пуск воспользуйтесь одним из предложенных ниже вариантов.
Для их полнофункциональной работы полностью отключите контроль учетных записей (Win   + R → UserAccountControlSettings), передвинув ползунок в самый низ и перезагрузив компьютер.
Большую коллекцию BMP-картинок с кнопкой Пуск Вы можете скачать по ссылке: Start_Button_Images.zip
Для преобразования их в png-файл с 32-битной глубиной цвета, воспользуйтесь программой AlphaConv, выбрав в ниспадающем списке .png и перекинув на окно программы необходимый Вам bmp-файл.

Вариант 1. Theme Resource Changer - без внесения изменений в системный файл.

1) Скачайте и распакуйте архив ThemeResourceChanger.zip
2) Установите программу Theme Resource Changer той же разрядности, что и у Вашей Windows.
Если окно команд самостоятельно не закроется у Вас по окончании установки, то закройте его вручную.
3) Перезагрузите компьютер.
4) Откройте Панель управления\Оформление и персонализация\Параметры папок → вкладка Вид
5) Снимите флажок Запускать окна с папками в отдельном процессе и нажмите кнопку ОК.
6) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
7) Установите тему Классическая.
8.1) Если Вы используете одну из стандартных тем Windows, то откройте папку C:\Windows\Resources\Themes\Aero\.
8.2) Если Вы используете стороннюю тему, то откройте папку данной темы.
9) Создайте в ней папку с именем explorer.exe (Например: C:\Windows\Resources\Themes\Aero\explorer.exe\)
10) Создайте и скопируйте в данную папку необходимые из указанных ниже png-файлов:

6801.png, 6805.png, 6809.png размером 54x162 для стандартного размера элементов 100%.
6802.png, 6806.png, 6810.png размером 66x198 для стандартного размера элементов 125%.
6803.png, 6807.png, 6811.png размером 81x243 для стандартного размера элементов 150%.
6804.png, 6808.png, 6812.png размером 106x318 для стандартного размера элементов 200%.

11) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
12) Установите любую аэро-тему или тему "Windows 7 - упрощенный стиль". После каждой перезагрузки компьютера кнопка Пуск будет восстанавливаться в изначальный вид.
Вам необходимо будет переключаться в "Классическую тему" и обратно, чтобы система снова сменила кнопку Пуск на замененную.
Но Вы можете автоматизировать этот процесс:
1) Скопируйте из папки ThemeSwitch, содержащейся в архиве ThemeResourceChanger.zip программу ThemeTool.exe в папку C:\Windows\System32.
2) Скопируйте в папку автозагрузки или добавьте в реестр файл (не ярлык!) Classic-Aero-Classic_ThemeSwitcher.vbs
Вы можете заменить значение ""%windir%\Resources\Themes\aero.theme""" в данном файле на Вашу собственную тему.

Вариант 2. Редактор ресурсов - с внесением изменений в системный файл.

Внимание: Данный вариант Вы используете на свой страх и риск.
Если что-либо пойдет не так система может перестать загружаться и Вам придется востанавливать измененые файлы, используя среду восстановления или MSDaRT-диск.

1) Скачайте и распакуйте архив Full_access.zip
2) Примените reg-файл в соответствии с языковыми особенностями Вашей системы.

Full_access_eng.reg - примените, если Вы используете английскую версию Windows.
Название пункта меню указано на английском языке, название группы администраторов указано на английском языке.
Full_access_eng+rus_mui.reg - примените, если Вы используете английскую версию Windows и русский языковой пакет.
Название пункта меню указано на русском языке, название группы администраторов указано на английском языке.
Full_access_rus.reg - примените, если Вы используете русскую версию Windows.
Название пункта меню указано на русском языке, название группы русском указано на английском языке.

3) Откройте папку C:\Windows
4) Нажмите правой кнопкой на файл explorer.exe и выберите пункт Стать владельцем и задать полный доступ к объекту
5) Скопируйте файл explorer.exe на рабочий стол.
6) Откройте данный файл с помощью программы Restorator.
7) Откройте папку Точечный рисунок
8) Создайте bmp-файлы кнопки Пуск с 32-битной глубиной цвета с указанными ниже именами:

6801.bmp, 6805.bmp, 6809.bmp размером 54x162 для стандартного размера элементов 100%.
6802.bmp, 6806.bmp, 6810.bmp размером 66x198 для стандартного размера элементов 125%.
6803.bmp, 6807.bmp, 6811.bmp размером 81x243 для стандартного размера элементов 150%.
6804.bmp, 6808.bmp, 6812.bmp размером 106x318 для стандартного размера элементов 200%.

9) Перетяните их на ресурсы с идентичным именем.
10) Нажмите сочетание клавиш Ctrl + S, чтобы сохранить изменения.
11) Переименуйте Ваш модифицированный файл файл explorer.exe в explorer1.exe
12) Скопируйте его с рабочего стола в папку C:\Windows
13) Удерживая нажатой клавишу ⇑ Shift щелкните в Проводнике правой кнопкой мыши на папке Windows и выберите пункт Открыть окно команд.
14) Нажмите правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
15) Установите тему Классическая.
16) Переключитесь обратно в окно команд и поочередно введите указанные ниже команды, нажимая после ввода каждой из них Enter ↵.

Данная команда закроет все процессы Проводника.

Данные команды переименуют оригинальный файл Проводника explorer.exe в _explorer.exe, а Ваш модифицированный файл explorer1.exe в explorer.exe.
После чего будет запущен Проводник.

17) Нажмите правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
18) Установите любую аэро-тему или тему "Windows 7 - упрощенный стиль".

Вариант 3. Windows 7 Start Orb Changer.

Чтобы заменить кнопку Пуск:

1) Скачайте архив Windows_7_Start_Orb_Changer.zip, распакуйте его в любую папку и запустите программу.
2) Нажмите кнопку Change, выберите png-файл с картинками яў кнопки Пуск и нажмите кнопку Открыть.
3) В окне Succes нажмите кнопку OK.

Чтобы вернуть обратно оригинальную кнопку Пуск:

1) Запустите программу Windows 7 Start Orb Changer.
2) Нажмите кнопку Restore.
3) В случае появления ошибки:
3.1) Нажмите кнопку ОК.
3.2) Нажмите Ctrl+⇑ Shift+Esc
3.3) В Диспетчере задач перейдите Файл → Новая задача (Выполнить...)
3.4) Введите команду explorer и нажмите клавишу Enter ↵.

Удаление кнопки Пуск.

1) Скачайте программу Start Killer c официального сайта (установщик) или с зеркала (портатив версия).
2) Установите и запустите программу, если скачали по официальной ссылке или просто распакуйте архив и запустите (в соответствии с разрядностью Вашей Windows), если скачали с зеркала.
3) Когда Start Killer запустится, он автоматически удалит кнопку Пуск с Вашей панели задач.
Но Вы по-прежнему сможете открыть меню Пуск нажав на клавиатуре комбинацию клавиш Ctrl + Esc или просто нажав клавишу с логотипом Windows.
4) Start Killer будет отображать иконку в области уведомлений.

Если Вы захотите, чтобы программа Start Killer запускалась автоматически при старте Windows, то:

1) Нажмите правой кнопкой мыши на значок в области уведомлений и выберите пункт Settings.
2) Установите флажок Load on system startup и нажмите кнопку ОК.

Если Вы выйдите из программы Start Killer, то кнопка Пуск снова отобразится на панели задач.


43. Переключение тем оформления Windows используя командную строку.

Чтобы переключит© на другую тему оформления Windows путем ввода команды в диалоговом окне Выполнить, в окне команд или указав его в пакетном файле, воспользуйтесь одним из предложенных ниже вариантов:

Вариант 1. С открытием окна Персонализация после смены темы.

Введите в диалоговом окне Выполнить (Win   + R) или в окне команд (Win   + R → cmd) указанную ниже команду:

где:

Path to theme - укажите путь к переключаемой теме.
name.theme - укажите имя темы.

Примеры:

После переключения темы откроется окно Персонализация.

Вариант 2. Без открытия окна Персонализация после смены темы.

1) Cкачайте программу ThemeTool от Microsoft, входящую в средства устранения неполадок.
2) Распакуйте архив в любую папку и скопируйте программу в папку C:\Windows\System32.
3) Введите в диалоговом окне Выполнить (Win   + R) или в окне команд (Win   + R → cmd) указанную ниже команду:

где:

changetheme - параметр для изменения темы.
Path to theme - укажите путь к переключаемой теме.
name.theme - укажите имя темы.

Примеры:

Также Вы можете создать vbs-скрипт (обычный текстовый файл с расширением .vbs вместо .txt), который будет переключать тему без отображения окна команд:


44. Редактирование темы или файла стиля оформления Windows для изменения внешнего вида различных элементов системы.

Если яў изменения внешнего вида Windows количество доступных по умолчанию в системе возможностей Вам кажется недостаточно, то для внесения более детальных изменений Вы можете воспользоваться указанными ниже программами.
На время работы с программами "Контроль учетных записей" рекомендуется отключить.

Для применения указанных ниже решений:

1) Полностью отключите контроль учетных записей (Win   + R → UserAccountControlSettings), передвинув ползунок в самый низ и перезагрузив компьютер.
2) В зависимости от разрядности Вашей системы воспользуйтесь патчем Theme Patcher для модификации файлов themeservice.dll, themeui.dll, uxtheme.dll.
Данный патч добавит в них возможность использования сторонних тем. Патч необходимо запускать от имени администратора.

Вариант 1. Theme Resource Changer.

Данная программа позволит Вам установить собственные png-изображения, вместо используемых системой bmp-файлов (точечных рисунков) или ico-файлов иконок из системных файлов.
Вы сможете немного отредактировать используемую Вами тему, изменить внешний вид кнопки Пуск, фоновых изображений для панелей Проводника, стрелок навигации и других иконок без внесения изменений в системные файлы.

1) Скачайте и распакуйте архив ThemeResourceChanger.zip
2) Установите программу Theme Resource Changer той же разрядности, что и у Вашей Windows.
Если окно команд самостоятельно не закроется у Вас по окончании установки, то закройте его вручную.
3) Перезагрузите компьютер.
4) Откройте Панель управления\Оформление и персонализация\Параметры папок → вкладка Вид
5) Снимите флажок Запускать окна с папками в отдельном процессе и нажмите кнопку ОК.
4) Нажмите правой кнопкой мыши на Рабочем столе и выберите пункт Персонализация.
5) Установите тему в которую Вы желаете внести изменения.
6.1) Если Вы используете одну из стандартных тем Windows, то откройте папку C:\Windows\Resources\Themes\Aero\.
6.2) Если Вы используете стороннюю тему, то откройте папку данной темы.
7) Создайте в ней, три папки с именами:

explorer.exe
explorerframe.dll
shell32.dll

8) Поместите в указанные папки PNG-файлы изображений (не BMP), которые Вы желаете использовать вместо оригинальных ресурсов, расположенных в файлах, соответствующих именам данных папок.
Копируемые изображения должны иметь номера ресурсов и размеры идентичные оригинальным.

Например:

Чтобы заменить фоновое изображения боковой панели Проводника добавьте в папку C:\Windows\Resources\Themes\Aero\shell32.dll\ файл 633.png размером 200x551 пикселей.
Чтобы заменить кнопку Пуск:

6801.png, 6805.png, 6809.png размером 54x162 для стандартного размера элементов 100%.
6802.png, 6806.png, 6810.png размером 66x198 для стандартного размера элементов 125%.
6803.png, 6807.png, 6811.png размером 81x243 для стандартного размера элементов 150%.
6804.png, 6808.png, 6812.png размером 106x318 для стандартного размера элементов 200%.

Чтобы заменить рамку пользователя:

7013.png размером 64x64 для стандартного размера элементов 100%.
7014.png размером 80x80 для стандартного размера элементов 125%.
7015.png размером 96x96 для стандартного размера элементов 150%.
7016.png размером 128x128 для стандартного размера элементов 200%.

Вы можете найти необходимый Вам ресурс используя любой редактор ресурсов (Например, Restorator).

Условия для использования Вашего png-файла изображения:

1) Имя png-файла должно соответствовать имени заменяемого ресурса.
2) Размеры png-файла при замене ресурса являющегося точечным рисунком (bmp-файлом) должны быть идентичны.
3) Размеры png-файла при замене ресурса являющегося иконкой (ico-файлом) должны быть 256x256.
4) Используемый Вами png-файл должен находится в папке, соответствующей названию файла в котором содержится ресурс.
5) Для применения заменяемого ресурса вместо оригинального переключайтесь в Классическую тему, а затем обратно в аэро-тему или тему "Windows 7 - упрощенный стиль".

Чтобы отменить внесенные в используемую Вами тему изменения, удалите добавленные Вами png-файлы.

Оригинальную инструкцию на английском языке от автора программы, Вы сможете найти внустри архива с программой ThemeResourceChanger.zip.

Вариант 2. Windows Style Builder.

Данная программа является очень мощным решением, позволяющая изменить любой шрифт, размер, цвет и фон любого элемента интерфейса.

Чтобы изменить внешний вид какого-либо элемента (шрифт, кнопку, полосу прокрутки, фон и др.) выполните следующий порядок действий.

1) Скачайте и распакуйте в любую папку архив WindowsStyleBuilder.zip, и установите программу Windows Style Builder.
2) Откройте папку C:\Windows\Resources\Themes
3) Создайте в ней папку с именем Вашей будущей темы. (Например: MyTheme).
4) Запустите программу Windows Style Builder.
5) Внесите необходимые изменения в стиль оформления Windows и нажмите кнопку Save (Сохранить)
6) Откройте папку созданную Вами папку. (C:\Windows\Resources\Themes\MyTheme)
7) Сохраните созданный стиль Windows. (Например: mytheme.msstyles)

Если Вы используете новую версию программы, то при сохранении стиля установите флажок Write .theme file для сохранения сделанных Вами изменений как отдельной темы.
Ваша тема будет сохранена там где Вы укажете.

8) Во всплывшем окне нажмите кнопку Use Visual Style (Использовать визуальный стиль)
9) При повторном редактировании файла и принятии сделанных изменений нажмите во всплывшем окне кнопку Use Aero (Использование Aero), а затем кнопку Use Visual Style (Использовать визуальный стиль)

Если Вы используете старую версию программы, то для сохранения темы выполните следующее:

10) Нажмите правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
11) В разделе Мои темы щелкните правой кнопкой мыши на мини-изображение Несохраненая тема и выберите пункт Сохранить тему.
12) Введите имя темы (Например: MyTheme) и нажмите кнопку Сохранить.
Ваша тема будет сохранена в папке %LOCALAPPDATA%\Microsoft\Windows\Themes.

Подробные инструкции использования программы Вы можете скачать по ссылке: WindowsStyleBuilder_Manuals.zip


45. Замена иконки яў определенного типа файла.

Чтобы изменить иконку, используемую для расширения файла по умолчанию, воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1.

1) Скачайте архив DefaultProgramsEditor.zip и распакуйте в любую папку.
2) Откройте данную папку, нажмите правой кнопкой мыши на exe-файл и выберите пункт Запуск от имени администратора.
3) В ней нажмите File Type Settings → Icon.
4) Выберите из списка расширение Вашего файла и нажмите кнопку Next.
5) Нажмите кнопку Browse и выберите файл иконки .ico или файлы .exe или .dll, которые содержат иконку. (Например exe-файл программы ,которая может открывать данное расширение).
6) Нажмите кнопку ОК, затем кнопку Save Icon, а после кнопку ОК.
7) Закройте программу.

Вариант 2.

1) Найдите в ветке реестра HKEY_CLASSES_ROOT раздел с расширением Вашего файла (например: .txt)
2) Откройте данный раздел (Пример: HKEY_CLASSES_ROOT\.txt)
3) Уточните какое значение указано у параметра По умолчанию (Пример: txtfile)
4) Откройте в ветке реестра HKEY_CLASSES_ROOT раздел с данным именем (Пример: HKEY_CLASSES_ROOT\txtfile)
5) Откройте в нем ветку DefaultIcon (Пример: HKEY_CLASSES_ROOT\txtfile\DefaultIcon)
6) Замените значение у параметра По умолчанию на значение необходимой Вам иконки. Перейти к началу Общего списка советов.


1. Открытие диспетчера задач, одной комбинацией клавиш, а не ctrl+alt+del и клик по пункту.

Вариант 1

Нажмите комбинацию клавиш Ctrl + ⇑ Shift + Esc.

Вариант 2

Щелкните правой кнопкой на панели задач и выберите пункт Запустить диспетчер задач (Start Task Manager). Перейти к началу Общего списка советов.


2. Использование средней кнопки мыши при работе с панелью задач.

Если щелкнуть средней кнопкой мышки на приложении в панели задач, откроется новое окно приложения. А если же средней кнопкой щелкнуть на окошке превью, которое всплывает над иконой программы, то это закроет данную программу или окно.

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Взаимодействие.


3. Перезапуск Проводника или рабочего стола.

Вариант 1. Только клавиатура.

1) Нажмите комбинацию клавиш Ctrl + Esc
2) Нажмите →
3) Нажмите комбинацию клавиш Ctrl + ⇑ Shift + F10
4) Нажмите ↓, чтобы перейти на пункт Выход из Проводника (Exit Explorer) и нажмите Enter ↵.
5) Нажмите комбинацию клавиш Ctrl + ⇑ Shift + Esc
6) Нажмите последовательно: Alt, затем ↓ и нажмите Enter ↵.
7) Введите команду explorer и нажмите клавишу Enter ↵.

Вариант 2. Частичное использование Диспетчера задач.

1) Откройте меню Пуск
2) Удерживая нажатым комбинацию клавиш Ctrl + ⇑ Shift, щелкните правой кнопкой мыши кнопку Завершение работы (Shut Down).
3) В контекстном меню выберите пункт Выход из Проводника (Exit Explorer).
4) Нажмите комбинацию клавиш Ctrl + ⇑ Shift + Esc
5) Нажмите Файл → Новая задача (Выполнить...) или в английской версии File → New Task (Run...)
6) Введите команду explorer и нажмите кнопку ОК

Вариант 3. Полное использование Диспетчера задач.

1) Откройте Диспетчер задач (Task Manager)
1.1) Щелкните правой кнопкой мыши пустую область на панели задач и выберите команду Запустить диспетчер задач или нажмите сочетание клавиш Ctrl + ⇑ Shift + Esc
2) Перейдите на вкладку Процессы (Processes)
3) Щелкните правой кнопкой мыши на процесс explorer.exe и выберите пункт Завершить процесс (End Process). Если у Вас несколько процессов с таким названием, то повторите данное действие для каждого процесса explorer.exe.
4) Нажмите Файл → Новая задача (Выполнить...) или в английской версии File → New Task (Run...)
5) Введите команду explorer и нажмите кнопку ОК Перейти к началу Общего списка советов.


4. Запуск команд Windows Shell, используя названия и {GUID} объектов.

Microsoft Windows Shell - интерпретатор команд операционной системы (ОС), обеспечивающий интерфейс для взаимодействия пользователя с функциями системы. Позволяет получить доступ к диалоговым окнам, к файловой системе, запускать программы и изменять системные настройки.
Для быстрого перехода к компонентам Windows используется команда shell.
GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Использование GUID гарантирует, что две версии одного компонента могут иметь одно и то же имя, но быть отличимыми по GUID. Microsoft примҐет GUID в качестве идентификаторов для большого количества своих объектов. Зная GUID Вы сможете открыть многие компоненты Windows: элементы Панели управления, системные папки, различные программы и настройки.

Для запуска любого из объектов Windows, используя {GUID}, примҐется команда:

где {GUID} - идентификатор {GUID} нужного Вам объекта. Например, для запуска Панели управления наберите команду:

Вы можете поискать нужные Вам {GUID} в разделе реестра HKEY_CLASSES_ROOT\CLSID или воспользоваться таблицей №1.

Таблица №1.

Русское название элемента | Английское название элемента | Команда
Flip 3D (Win+Tab) | Flip 3D (Win+Tab) | Shell:::{3080F90E-D7AD-11D9-BD98-0000947B0257}
Fusion Cache | Fusion Cache | Shell:::{1D2680C9-0E2A-469d-B787-065558BC7D43}
Internet Explorer | Internet Explorer | Shell:::{871C5380-42A0-1069-A2EA-08002B30309D}
Microsoft Outlook | Microsoft Outlook | Shell:::{2559a1f5-21d7-11d4-bdaf-00c04f60b9f0}
Windows CardSpace | Windows CardSpace | Shell:::{78CB147A-98EA-4AA6-B0DF-C8681F69341C}
Windows SideShow | Windows SideShow | Shell:::{E95A4861-D57A-4be1-AD0F-35267E261739}
Автозапуск | AutoPlay | Shell:::{9C60DE1E-E5FC-40f4-A487-460851A8D915}
Автономные файлы | Offline Files | Shell:::{D24F75AA-4F2B-4D07-A3C4-469B3D9030C4}
Администрирование | Administrative Tools | Shell:::{D20EA4E1-3957-11d2-A40B-0C5020524153}
Архивация и восстановление | Backup and Restore | Shell:::{B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}
Библиотеки | Libraries | Shell:::{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Биометрические устройства | Biometric Devices | Shell:::{0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}
Брандмауэр Windows | Windows Firewall | Shell:::{4026492F-2F69-46B8-B9BF-5654FC07E423}
Восстановление | Recovery | Shell:::{9FE63AFD-59CF-4419-9775-ABCC3849F861}
Восстановление системы | System Restore | Shell:::{3f6bc534-dfa1-4ab4-ae54-ef25a74e0107}
Все задачи | All Tasks | Shell:::{ED7BA470-8E54-465E-825C-99712043E01C}
Все элементы панели управления | All Control Panel Items | Shell:::{21EC2020-3AEA-1069-A2DD-08002B30309D}
Выполнить | Run | Shell:::{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}
Гаджеты рабочего стола | Desktop Gadgets | Shell:::{37efd44d-ef8d-41b1-940d-96973a50e9e0}
Дата и Время | Date and Time | Shell:::{E2E7934B-DCE5-43C4-9576-7FE4F75E7480}
Датчик расположения и другие датчики | Location and Other Sensors | Shell:::{E9950154-C418-419e-A90A-20C5287AE24B}
Диспетчер устройств | Device Manager | Shell:::{74246bfc-4c96-11d0-abef-0020af6b0b7a}
Диспетчер учетных данных | Credential Manager | Shell:::{1206F5F1-0569-412C-8FEC-3204630DFB70}
Домашняя группа | HomeGroup | Shell:::{67CA7650-96E6-4FDD-BB43-A8E774F73A57}
Домашняя группа - папка | HomeGroup folder | Shell:::{6785BFAC-9D2D-4be5-B7E2-59937E8FB80A}
Защитник Windows | Windows Defender | Shell:::{D8559EB9-20C0-410E-BEDA-7ED416AECC2A}
Звук | Sound | Shell:::{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}
Значки области уведомлений | Notification Area Icons | Shell:::{05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}
Игровые устройства | Game Controllers | Shell:::{259EF4B1-E6C9-4176-B574-481532C9BCE8}
Игры | Games | Shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
Избранное | Favorites | Shell:::{323CA680-C24D-4099-B94D-446DD2D7249E}
Инфракрасная связь | Infrared | Shell:::{A0275511-0E86-4ECA-97C2-ECD8F1221D08}
Карта сети | Network Map | Shell:::{E7DE9B1A-7533-4556-9484-B26FB486475E}
Компоненты Windows | Windows Features | Shell:::{67718415-c450-4f3c-bf8a-b487642dc39b}
Компьютер | Computer | Shell:::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина | Recycle Bin | Shell:::{645FF040-5081-101B-9F08-00AA002F954E}
Мои Документы | My Documents | Shell:::{450D8FBA-AD25-11D0-98A8-0800361B1103}
Настройка доступа программ и умолчаний | Set Program access and Windows defaults | Shell:::{2559a1f7-21d7-11d4-bdaf-00c04f60b9f0}
Недавние места | Recent Places | Shell:::{22877a6d-37a1-461a-91b0-dbda5aaebc99}
Общие | Public | Shell:::{4336a54d-038b-4685-ab02-99bb52d3fb8b}
Панель управления (заданного Вами вида) | Control Panel | Shell:::{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
Панель управления (Категория) | Control Panel (Category) | Shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}
Параметры индексирования | Indexing Options | Shell:::{87D66A43-7B11-4A28-9811-C86EE395ACF7}
Параметры папок | Folder Options | Shell:::{6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}
Параметры планшетного компьютера | Tablet PC Settings | Shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}
Параметры шрифта | Font settings | Shell:::{93412589-74D4-4E4E-AD0E-E0CB621440FD}
Переносные устройства | Portable Devices | Shell:::{35786D3C-B075-49b9-88DD-029876E11C01}
Перо и сенсорные устройства | Pen and Touch | Shell:::{F82DF8F7-8B9F-442E-A48C-818EA735FF9B}
Персонализация | Personalization | Shell:::{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection | Shell:::{241D7C96-F8BF-4F85-B01F-E2B043341A4B}
Поиск Windows | Search | Shell:::{2559a1f0-21d7-11d4-bdaf-00c04f60b9f0}
Получение программ | Get Programs | Shell:::{15eae92e-f17a-4431-9f28-805e482dafd4}
Принтеры | Printers | Shell:::{2227A280-3AEA-1069-A2DE-08002B30309D}
Приступая к работе | Getting Started | Shell:::{CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}
Программы и компоненты | Programs and Features | Shell:::{7b81be6a-ce2b-4676-a29e-eb907a5126c5}
Программы по умолчанию | Default Programs | Shell:::{17cd9488-1228-4b2f-88ce-4298e93e0966}
Рабочий стол | Desktop | Shell:::{3080F90D-D7AD-11D9-BD98-0000947B0257}
Распознавание речи | Speech Recognition | Shell:::{58E3C745-D971-4081-9034-86E34B30836A}
Расположение по умолчанию | Default Location | Shell:::{00C6D95F-329C-409a-81D7-C46C66EA7F33}
Родительский контроль | Parental Controls | Shell:::{96AE8D84-A250-4520-95A5-A47A7E3C548B}
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | Shell:::{0DF44EAA-FF21-4412-828E-260A8728E7F1}
Свойства речи | Text to Speech | Shell:::{D17D1D6D-CC3F-4815-8FE3-607E7D5D10B3}
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | Shell:::{A304259D-52B8-4526-8B1A-A1D6CECC8243}
Свойства: Интернет | Internet Properties | Shell:::{A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}
Свойства: Клавиатура | Keyboard Properties | Shell:::{725BE8F7-668E-4C7B-8F90-46BDB0936430}
Свойства: Мышь | Mouse Properties | Shell:::{6C8EEC18-8D75-41B2-A177-8831D59D2D50}
Сетевые подключения | Network Connections | Shell:::{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сетевые подключения в Области уведомления | Network Connections in Notification area | Shell:::{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}
Сеть | Network | Shell:::{208D2C60-3AEA-1069-A2D7-08002B30309D}
Система | System | Shell:::{BB06C0E4-D293-4f75-8A90-CB05B6477EEE}
Сканеры и камеры | Scanners and Cameras | Shell:::{00f2886f-cd64-4fc9-8ec5-30ef6cdbe8c3}
Соседние пользователи | People Near Me | Shell:::{5224F545-A443-4859-BA23-7B5A95BDC8EF}
Справка и Поддержка | Windows Help and Support | Shell:::{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}
Счетчики и средства производительности | Performance Information and Tools | Shell:::{78F3955E-3B90-4184-BD14-5397C15F1EFC}
Телефон и модем | Phone and Modem | Shell:::{40419485-C444-4567-851A-2DD7BFA1684D}
Управление беспроводными сетями | Manage Wireless networks | Shell:::{1FA9085F-25A2-489B-85D4-86326EEDCD87}
Управление цветом | Color Management | Shell:::{B2C761C6-29BC-4f19-9251-E6195265BAF1}
Установленные обновления | Installed Updates | Shell:::{d450a8a1-9568-45c7-9c0e-b4f9fb4537bd}
Устранение неполадок | Troubleshooting | Shell:::{C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}
Устройства Bluetooth | Bluetooth Devices | Shell:::{28803F59-3A75-4058-995F-4EE5503B023C}
Устройства и принтеры | Devices and Printers | Shell:::{A8A91A66-3A7D-4424-8D24-04E180695C7A}
Учетные записи пользователей | User Accounts | Shell:::{60632754-c523-4b62-b45c-4172da012619}
Центр мобильности Windows | Windows Mobility Center | Shell:::{5ea4f148-308c-46d7-98a9-49041b1dd468}
Центр обновления Windows | Windows Update | Shell:::{36eef7db-88ad-4e81-ad49-0e313f0c35f8}
Центр поддержки | Action Center | Shell:::{BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}
Центр синхронизации | Sync Center | Shell:::{9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}
Центр специальных возможностей | Ease of Access Center | Shell:::{D555645E-D4F8-4c29-A827-D93C859C4F2A}
Центр управления сетями и общим доступом | Network and Sharing Center | Shell:::{8E908FC9-BECC-40f6-915B-F4CA0E70D03D}
Шифрование диска BitLocker | BitLocker Drive Encryption | Shell:::{D9EF8727-CAC2-4e60-809E-86F80A666C91}
Экран (размер текста) | Display (size of text) | Shell:::{C555438B-3C23-4769-A71F-B6D3D9B6053A}
Электропитание | Power Options | Shell:::{025A5937-A6BE-4686-A844-36FE4BEC8B6D}
Язык и региональные стандарты | Region and Language | Shell:::{62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}
Русское название элемента | Английское название элемента | Команда

Для некоторых системных папок, Вы можете создать их копии, в любом, необходимом для Вас месте. Такие папки не будут занимать место на диске, а будут служить символическими ссылками на оригинальные. Для создания такой папки-ссылки:

1) Создайте в любом нужном Вам месте новую папку (Щелчок ПКМ → Создать → Папку)
2) Переименуйте её следующим образом:

Все задачи - All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}
Администрирование - Administrative Tools.{D20EA4E1-3957-11d2-A40B-0C5020524153}
Библиотеки - Libraries.{031E4825-7B94-4dc3-B131-E946B44C8DD5}
Компьютер - Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Корзина - Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}
Персонализация - Personalize.{ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}
Принтеры - Printers and Faxes.{2227A280-3AEA-1069-A2DE-08002B30309D}
Программы - Programs Folder.{7BE9D83C-A729-4D97-B5A7-1B7313C39E0A}
Сетевые подключения - Network Connections.{7007ACC7-3202-11D1-AAD2-00805FC1270E}
Сеть (WORKGROUP) - Network Places.{208D2C60-3AEA-1069-A2D7-08002B30309D}
Учетные записи пользователей - User Accounts.{60632754-c523-4b62-b45c-4172da012619}

Принцип запуска команд Shell, используя имя объектов, намного легче. Данный способ не требует от Вас знания большого количества цифр и букв, и позволяет снизить величину ошибок при наборе команды. Его основное применение - открытие системных папок.

Например, для быстрого перехода в папку Панели Быстрого Запуска, которая присутствует в Windows, но не добавлена на Панель Задач, достаточно написать команду shell:Quick Launch. При выполнении команды будет в Проводнике будет открыта папка: C:\Users\%UserName%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

Для запуска любого из объектов Windows, используя его имя, примҐется команда:

Вы можете найти нужные Вам имена объектов в разделах ветки реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\FolderDescriptions или воспользоваться таблицей №2.

Таблица №2.

Имя программы или папки | Адрес папки | Команда
32-разрядный Internet Explorer | C:\Program Files\Internet Explorer или C:\Program Files (x86)\Internet Explorer | shell:InternetFolder
Common Files (в 32-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommon
Common Files (в 64-битной Windows 7) | C:\Program Files\Common Files | shell:ProgramFilesCommonX64
Common Files (в 64-битной Windows 7) | C:\Program Files (x86)\Common Files | shell:ProgramFilesCommonX86
Cookies | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies | shell:Cookies
Credentials | C:\Users\User-Name\AppData\Roaming\Microsoft\Credentials | shell:CredentialManager
Crypto | C:\Users\User-Name\AppData\Roaming\Microsoft\Crypto | shell:CryptoKeys
DeviceMetadataStore | C:\ProgramData\Microsoft\Windows\DeviceMetadataStore | shell:Device Metadata Store
Documents | C:\Users\Public\Documents | shell:Common Documents
Fonts (шрифты) | C:\Windows\Fonts | shell:Fonts
Gadgets | C:\Program Files\Windows Sidebar\Gadgets | shell:default Gadgets
Gadgets | C:\Users\User-Name\AppData\Local\Microsoft\WindowsSidebar\Gadgets | shell:Gadgets
GameExplorer | C:\ProgramData\Microsoft\Windows\GameExplorer | shell:PublicGameTasks
GameExplorer (Обозреватель игр) | C:\Users\User-Name\AppData\Local\Microsoft\Windows\GameExplorer | shell:GameTasks
History | C:\Users\User-Name\AppData\Local\Microsoft\Windows\History | shell:History
ImplicitAppShortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts | shell:ImplicitAppShortcuts
Local | C:\Users\User-Name\AppData\Local | shell:Local AppData
LocalLow | C:\Users\User-Name\AppData\LocalLow | shell:LocalAppDataLow
Low | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Cookies\Low | shell:Cookies\Low
Network Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\NetworkShortcuts | shell:NetHood
Printer Shortcuts | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\PrinterShortcuts | shell:PrintHood
Program Files | C:\Program Files | shell:ProgramFiles
Program Files (x86) (в 64-битной Windows 7) | C:\Program Files (x86) | shell:ProgramFilesX86
Program Files (в 64-битной Windows 7) | C:\Program Files | shell:ProgramFilesX64
ProgramData | C:\ProgramData | shell:Common AppData
Protect | C:\Users\User-Name\AppData\Roaming\Microsoft\Protect | shell:dpapiKeys
Quick Launch (Быстрый запуск) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch | shell:Quick Launch
Resources (содержит темы Windows) | C:\Windows\Resources | shell:ResourceDir
Ringtones | C:\ProgramData\Microsoft\Windows\Ringtones | shell:CommonRingtones
Roaming | C:\Users\User-Name\AppData\Roaming | shell:AppData
SendTo (элементы контекстного меню Отправить) | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\SendTo | shell:SendTo
System32 | C:\Windows\System32 | shell:System
SystemCertificates | C:\Users\User-Name\AppData\Roaming\Microsoft\SystemCertificates | shell:SystemCertificates
SysWOW64 | C:\Windows\SysWOW64 | shell:SystemX86
Templates | C:\ProgramData\Microsoft\Windows\Templates | shell:Common Templates
Templates | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Templates | shell:Templates
Temporary Internet Files | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Temporary Internet Files | shell:Cache
User Pinned (Закрепленные элементы) | C:\Users\User-Name\AppData\Roaming\Microsoft\InternetExplorer\Quick Launch\User Pinned | shell:User Pinned
User-Name (файлы Вашей учетной записи) | C:\Users\User-Name | shell:UsersFilesFolder
User-Name (Ваш учетный профиль) | C:\Users\User-Name | shell:Profile
Windows (главная папка системы) | C:\Windows | shell:Windows
Автозагрузка | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup | shell:Common Startup
Автозагрузка | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup | shell:Startup
Администрирование | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Administrative Tools
Администрирование | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools | shell:Common Administrative Tools
Библиотеки | Библиотеки | shell:Libraries
Библиотеки | Библиотеки | shell:UsersLibrariesFolder
Видео | Библиотеки\Видео | shell:VideosLibrary
Временная папка для записи | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Burn\Burn | shell:CD Burning
Все элементы панели управления | Панель управления\Все элементы панели управления | shell:ControlPanelFolder
Главное меню | C:\ProgramData\Microsoft\Windows\Start Menu | shell:Common Start Menu
Главное меню | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu | shell:Start Menu
Документы | Библиотеки\Документы | shell:DocumentsLibrary
Домашняя группа | Домашняя группа | shell:HomeGroupFolder
Загрузки | C:\Users\User-Name\Downloads | shell:downloads
Згрузки | C:\Users\Public\Downloads | shell:CommonDownloads
Игры | Игры | shell:Games
Избранное | C:\Users\User-Name\Favorites | shell:Favorites
Изображения | C:\Users\Public\Pictures | shell:CommonPictures
Изображения | C:\Users\User-Name\Pictures | shell:My Pictures
Изображения | Библиотеки\Изображения | shell:PicturesLibrary
Компьютер | Компьютер | shell:MyComputerFolder
Контакты | C:\Users\User-Name\Contacts | shell:Contacts
Конфликты | Панель управления\Все элементы панели управления\Центр синхронизации\Конфликты | shell:ConflictFolder
Корзина | Корзина | shell:RecycleBinFolder
Мои видеозаписи | C:\Users\User-Name\Videos | shell:CommonVideo
Мои видеозаписи | C:\Users\User-Name\Videos | shell:My Video
Мои документы | C:\Users\User-Name\Documents | shell:Personal
Моя Музыка | C:\Users\Public\Music | shell:CommonMusic
Моя музыка | C:\Users\User-Name\Music | shell:My Music
Музыка | Библиотеки\Музыка | shell:MusicLibrary
Настройка синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Настройка синхронизации | shell:SyncSetupFolder
Недавние документы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\Recent | shell:Recent
Образцы видео | C:\Users\Public\Videos\Sample Videos | shell:SampleVideos
Образцы изображений | C:\Users\Public\Pictures\Sample Pictures | shell:SamplePictures
Образцы музыки | C:\Users\Public\Music\Sample Music | shell:SampleMusic
Общие | C:\Users\Public | shell:Public
Папка с рингтонами Windows 7 | C:\Users\User-Name\AppData\Local\Microsoft\Windows\Ringtones | shell:Ringtones
Поиск Windows | search-ms: | shell:SearchHomeFolder
Поиски (информация о поисках) | C:\Users\User-Name\Searches | shell:Searches
Получение программ | Панель управления\Все элементы панели управления\Получение программ | shell:AddNewProgramsFolder
Пользователи | C:\Users | shell:UserProfiles
Принтеры | Все элементы панели управления\Принтеры | shell:PrintersFolder
Программы | C:\ProgramData\Microsoft\Windows\Start Menu\Programs | shell:Common Programs
Программы | C:\Users\User-Name\AppData\Roaming\Microsoft\Windows\StartMenu\Programs | shell:Programs
Программы и компоненты | Панель управления\Все элементы панели управления\Программы и компоненты | shell:ChangeRemoveProgramsFolder
Рабочий стол | C:\Users\Public\Desktop | shell:Common Desktop
Рабочий стол | C:\Users\User-Name\Desktop | shell:desktop
Результаты синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации\Результаты синхронизации | shell:SyncResultsFolder
Сетевые подключения | Панель управления\Все элементы панели управления\Сетевые подключения | shell:ConnectionsFolder
Сеть | Сеть | shell:NetworkPlacesFolder
Сохраненные игры | C:\Users\User-Name\Saved Games | shell:SavedGames
Ссылки | C:\Users\User-Name\Links | shell:Links
Установленные обновления | Программы и компоненты\Установленные обновления | shell:AppUpdatesFolder
Центр синхронизации | Панель управления\Все элементы панели управления\Центр синхронизации | shell:SyncCenterFolder
Имя программы или папки | Адрес папки | Команда

Чтобы создать ярлык, используя названия или {GUID} команды Windows Shell, в поле Укажите расположение объекта введите:

или

или

Например, для создания ярлыка папки Компьютер, в поле Укажите расположение объекта введите:

или

Для упрощения работы с командами Windows Shell Вы можете скачать небольшую бесплатную программу Shell Dump.
Данная программа проанализирует Ваш реестр и отобразит список команд, которые Вы можете использовать. Вам всего лишь достаточно выбрать команду и нажать кнопку Run для ее запуска.


5. Создание ярлыка для функции Windows Flip 3D (переключение между окнами под углом).

1. Щелкните правой кнопкой мыши по рабочему столу, выберите Создать и затем Ярлык.
2. В поле "Укажите расположение объекта" введите следующее: RunDll32 DwmApi #105 и нажмите Далее.
3. Наберите имя вашего будущего (например, Flip3D) ярлыка и нажмите Готово.

Для переключения между окнами в режиме Flip3D, Вы можете использовать комбинацию клавиш Win   + Tab ↹ или же удерживая нажатой клавишу Win   прокручивать колесо мыши.


6. Использование переменных окружения для быстрого перехода к системным папкам.

Для быстрого перехода в системные папки Вы можете воспользоваться переменными, введя их в адресной строке Проводника и нажав клавишу Enter ↵.
Чтобы узнать какие из переменных присутствуют в Вашей системе:

1) Введите в строке поиска меню Пуск cmd и нажмите Enter ↵.
2) В окне команд введите команду set и нажмите Enter ↵.
В таблице ниже приведен полный список стандартных переменных окружения Windows.

Переменная | Соответствие расположению в системе
%ALLUSERSPROFILE% | C:\ProgramData
%APPDATA% | C:\Users\UserName\AppData\Roaming
%CommonProgramFiles% | C:\Program Files\Common Files
%CommonProgramFiles(x86)% | C:\Program Files (x86)\Common Files
%CommonProgramW6432% | C:\Program Files\Common Files
%ComSpec% | Запуск cmd.exe из папки, в которой будет употреблен
%HOMEDRIVE% | C:\
%HOMEPATH% | C:\Users\UserName
%LOCALAPPDATA% | C:\Users\UserName\AppData\Local
%ProgramData% | C:\ProgramData
%ProgramFiles% | C:\Program Files
%ProgramW6432% | C:\Program Files
%ProgramFiles(x86)% | C:\Program Files (x86)
%PSModulePath% | C:\Windows\System32\WindowsPowerShell\v1.0\Modules
%PUBLIC% | C:\Users\Public
%SystemDir% | C:\Windows\System32
%SystemDrive% | C:\
%SystemRoot% | C:\Windows
%TEMP% | C:\Users\UserName\AppData\Local\Temp
%TMP% | C:\Users\UserName\AppData\Local\Temp
%USERPROFILE% | C:\Users\UserName
%windir% | C:\Windows

Если Вы решите создать собственную переменную типа:
%MyFolder%=C:\MyFolder

1) Пройдите:
Компьютер → Свойства → Дополнительные параметры системы → Дополнительно → Переменные среды
2) Нажмите Создать...
3) Укажите Имя переменной и Значение переменной
4) Нажмите на каждое ОК
5) Перезагрузите компьютер (иначе она не будет работать)


7. Установка положения курсора в диалоговом окне на кнопке, выбираемой по умолчанию.

Для многих пользователей весьма удобным считается, чтобы курсор мыши при открытии диалогового окна занимал позицию на кнопке Открыть, Сохранить или аналогичной по умолчанию. Данное действие позволяет Вам сэкономить время необходимое для наведения курсора.

1) Откройте Панель управления → Мышь
2) Перейдите на вкладку Параметры указателя
3) В графе "Исходное положение в диалоговом окне" установите флажок "На кнопке, выбираемой по умолчанию"
4) Нажмите ОК. Перейти к началу Общего списка советов.


8. Уточнение даты и времени загрузки системы.

Вариант 1.

Если Вам необходимо узнать дату и время установки Windows на компьютер или дату и время когда компьютер был запущен, то сделайте следующее:

1) Запустите командную строку с правами администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду systeminfo

В графе с одноименным названием Вы найдете необходимое Вам значение.

Вариант 2.

1) Скачайте с сайта Microsoft программу uptime.exe (http://support.microsoft.com/kb/232243)
2) Скопируйте ее в папку C:\Windows\System32
3) Запустите командную строку с правами администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4) Введите команду uptime.exe.

Вариант 3.

Скачайте и установите специальный гаджет.

systemuptime.zip


9. Сворачивание всех неактивных окон, кроме текущего активного, используя Aero Shake.

В интерфейс Windows Aero добавлена новая функция Aero Shake, позволяющая свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти» влево-вправо.

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Взаимодействие.


10. Закрытие всех запущенных приложений одним кликом.

Утилита под названием Close All Windows позволяет закрыть все работающие приложения с помощью всего одного клика. Она не требует установки и не использует ресурсов, так как посылает только команду "Закрыть" всем действующим приложениям.

1) Скачайте программу CloseAll
2) Распакуйте архив в удобное Вам место для использования.
3) Откройте папку 1.3
4) Переместите файл на панель задач файл CloseAll.exe, если у Вас 32-бит версия, или файл CloseAll_x64.exe, если у вас 64-бит система.

Чтобы назначить клавишу быстрого вызова и добавить исключения для программ, которые закрываться не будут:

1) Щелкните правой кнопкой мыши на иконке в панели задач.
2) Щелкните правой кнопкой мыши на "Close All Windows" и нажмите Свойства
3) В поле Быстрый вызов нажмите нужное сочетание клавиш, для сопоставления выбранной комбинации с программой.
4) В поле Объект добавьте -x="программа.exe"
Для добавления нескольких программ разделите их "|", например:

5) Нажмите ОK для сохранения настроек.

В версии 2.0 при запуске программы откроется окно, в котором Вам необходимо будет установить флажки напротив программ, которые Вы желаете закрыть и нажать кнопку ОК.


11. Открытие командной строки из конкретной папки.

1)Нажмите на клавиатуре клавишу ⇑ Shift.
2) Удерживая ее нажатой, щелкните правой кнопкой мыши на папке из которой Вы желаете открыть командную строку.
3) В контекстном меню нажмите пункт Открыть окно команд (“Open Command Window Here”).

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Взаимодействие.


12. Просмотр файлов .nfo и .diz с ASCII графикой.

Часто вместе со скаченной Вами в интернете игрой или программой может присутствовать .nfo или .diz файл.
В нем помимо информации, необходимой Вам для установки, также может содержаться ASCII графика - изображения в текстовом файле нарисованные при помощи знаков (букв и символов).
Для их корректного отображения Вы можете скачать и установить программу GetDiz

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Взаимодействие.


13. Использование возможности Windows Flip 3D в Windows 7 Домашняя базовая и Начальная.

Несмотря на то, что некоторые из советов сборника помогают решить проблему с отсутствием в домашней базовой версии Windows 7 возможностей присутствующих в других версиях Windows, их использование не добавляет функции Windows Flip 3D.
Однако, чтобы полностью ощутить радость от использования переключения между окнами под углом, Вы можете скачать программу стороннего производитЈ.

Ссылка для скачивания: WFlip.zip


14. Запуск программы с параметрами командной строки из контекстного меню Проводника.

Чтобы запустить программу с параметрами - обычно Вам необходимо: либо создать ярлык к программе и при создании указать параметры, либо Пуск → Открыть (Win   + R) ввести программу, указав путь к ней и затем дописать параметры.
Всё это проще позволит сделать программа ExecParm. Данная программа является позволяет запускать исполняемые(.exe, .com) и командные файлы(.cmd, .bat) с параметрами, используя расширение встраиваемое в контекстное меню Проводника. Чтобы его использовать Вам сделайте следующее:

1) Скачайте архив программы ExecParm с необходимой разрядностью: 32-бит, 64-бит .
2) Распакуйте архив в любую папку.
3) Откройте папку с распакованным содержимым. В ней будут три файла: ExecParm.txt, Execparm.dll, Execparm.inf)
4) Щелкните правой кнопкой мыши по файлу Execparm.inf и выберите Установить
Данное действие добавит пункт в контекстное меню для запуска приложения с параметрами.
5) Щелкните правой кнопкой по исполняемому файлу и выберите в контекстном меню пункт Execute With Parameters...
6) Введите необходимые параметры для запуска программы и нажмите ОК.


15. Расчет хеш-суммы для любого файла, а также открытие .sfv и .md5 файлов, используемых для контроля целостности файлов.

Случается, что при выкладывании файла, автор указывает значения контрольных сумм (хеш-сумм) данного файла, таких как md5, crc32, sha-1 или других.
Данные значения необходимы, чтобы проверить целостность полученных данных или же сравнить с уже имеющимся значением аналогичного файла.

Существует много программ предлагающих расчитать значения хеш-функций, но наиболее удобной из них является программа HashTab.

Данная программа добавляет в окно Свойства для любого файла дополнительную вкладку Хеш-суммы файлов.
При переходе на данную вкладку программа HashTab автоматически расчитает значение выбранных Вами хеш-функций.
По умолчанию расчитываются значения md5, crc32, sha-1.

Если Вам необходимы значения других хеш-сумм, то:

1) На вкладке Хеш-суммы файлов нажмите ссылку Настройки.
2) Установите в открывшемся окне флажки рядом с необходимой Вам хеш-функцией и нажмите ОК
Выбирать сразу все не рекомендуется, так как это может привести к длительному вычислению значений хеш-сумм.

Чтобы сравнить хеш-суммы двух аналогичных файлов:

1) На вкладке Хеш-суммы файлов выберите необходимую хеш-функцию для сравнения (по умолчанию используется crc32)
2) Нажмите кнопку Сравнить файл.
2) Выберите необходимый Вам файл для сравнения и нажмите кнопку Открыть.
Если хеш-сумма окажется другой, то рядом с ее значением появится красный крест.
Если хеш-сумма окажется идентичной, то рядом с ее значением появится зеленый флажок.

При скачивании с торрент-трекеров или при распаковке какого-либо архива Вы можете обнаружить среди файлов SFV-файл или MD5-файл.

Данные файлы необходимы для контроля целостности файлов, находящихся рядом в папке, используя контрольную сумму для ее проверки.
При открытии SFV-файла или MD5-файла текстовым редактором внутри можно найти ¤ файла и его контрольную сумму.
Чтобы не сравнивать вручную каждое значение хеш-суммы файла с упомянутым в SFV-файле или MD5-файле, Вы можете воспользоваться программой QuickSFV.

Для этого, в соответствии с разрядностью Вашей операционной системы скачайте и установите текущую версию (Current version) программы QuickSFV.
Если Вам необходимо проверить хеш-сумму только одного из файлов, находящихся в папке рядом с SFV-файлом или MD5-файлом, то щелкните на проверяемом файле правой кнопкой мыши и выберите пункт Verify Individual File.
Для проверки хеш-сумм всех файлов щелкните на SFV-файле или MD5-файле.
Если значения хеш-сумм окажутся идентичными, то рядом с именем файла появится зеленый флажок, а в колонке Status отобразится значение ОК.


16. Быстрая вставка путей к файлу или папке в окно команд Windows 7.

Наиболее часто используемым способом вставки путей к файлу или папке в окно команд Windows (окно командной строки) является следующее:

1) Выделяете в адресной строке Проводника путь к папке.
2) Щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
3) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить → Вставить
А если необходимо еще добавить имя и расширение файла, то:
4) Щелкаете по файлу правой кнопкой мыши и выбираете Переименовать.
5) Выделяете имя и расширение файла, щелкаете на выделенном правой кнопкой мыши и выбираете Копировать.
6) Щелкаете по заголовку окна команд правой кнопкой мыши и выбираете в контекстном меню пункты Изменить → Вставить

В Windows 7 существуют более быстрые способы сделать это:

Способ 1.

1) Удерживая нажатой клавишу ⇑ Shift щелкните правой кнопкой мыши на папке или файле, путь к которому Вы желаете добавить в окно команд Windows (окно командной строки).
2) В контекстном меню выберите пункт Копировать как путь (“Copy as path”).
3) Щелкните внутри окна команд и выберите пункт Вставить.

Способ 2.

Перетащите файл или папку (путь к которому Вы желаете добавить) напрямую внутрь окна команд Windows.

Примечание: Окно из которого вы перетаскиваете файл или папку в окно команд, должно иметь более высокие или одинаковые права и разрешения, чем само окно команд.


17. Запуск командной строки из "Диспетчера задач" без ввода команды CMD.

1) Запустите Диспетчер задач нажав на клавиатуре комбинацию клавиш Ctrl + ⇑ Shift + Esc.
2) Удерживая нажатой клавишу Ctrl выберите в главном меню пункт Файл и щелкните → Новая задача (Выполнить...)

Примечание:

Если у Вас включен Контроль учётных записей (UAC) или Диспетчер задач запущен в ограниченной учётной записи, окно команд откроется без прав администратора.
Если у Вас отключен Контроль учётных записей (UAC) или Диспетчер задач запущен с правами администратора, окно команд откроется с правами администратора. Перейти к началу Общего списка советов.


18. Изменение действий осуществляемых системой при использовании щелчков мыши.

Если Вы привыкли к поведению мыши в браузере, то Вы можете переключить режим используемый при щелчке мышью в системе на идентичный. Для этого выполните следующие действия:

1) Откройте Панель управления в режиме просмотра всех элементов: Пуск → Панель управления\Все элементы панели управления
2) Запустите Параметры папок
3) На вкладке Общие установите значение переключателя в
Открывать одним щелчком, выделять указателем → Подчеркивать подписи значков при наведении
4) Нажмите ОК. Перейти к началу Общего списка советов.


19. Команды для распаковки *.cab, *.exe, *.msi, *.msp и *.msu файлов от Microsoft.

Приведенные в примерах команды подразумевают, что Вы запустили окно команд из папки, где находится сам файл.
Чтобы запустить окно команд из папки, где расположен исходный файл, удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке и выберите пункт Открыть окно команд.

Microsoft Cabinet File (.cab):

Команда для запуска:

Пример:

Microsoft Hotfix Installer (.exe):

Команда для запуска:

Пример:

Windows Installer Package (.msi):

Команда для запуска:

Пример:

Microsoft Update Standalone Package (.msu):

Команда для запуска:

Пример:

Microsoft Patch File (.msp)

Скачайте программу MSI_Extractor, распакуйте архив и скопируйте файл msix.exe в папку C:\Windows\System32

Команда для запуска:

Пример:

Также Вы можете распаковать .msu, .cab или .exe файл обновления, используя программу KB_Extractor.
Чтобы распаковать данный файл перекиньте его на значок программы KB_Extractor.exe и распакованные файлы и папки из данного обновления окажутся в папке %TEMP% . Перейти к началу Общего списка советов.


20. Быстрое открытие ещё одной копии приложения.

Если у вас уже открыто какое-либо приложение и вы хотите быстро открыть его вторую копию, то удерживая клавишу ⇑ Shift просто нажмите на иконку данного приложения на Панели задач. И вместо переключения в существующее окно будет открыта новая копия этого приложения. Того же эффекта можно добит© кликнув по иконке приложения на Панели задач, средней кнопкой мыши.

Перейти к началу раздела Интерфейс.
Перейти к началу подраздела Интерфейс - Взаимодействие.


21. Сохранение настроек интерфейса в Windows.

Чтобы у Вас в Windows корректно сохранялись настройки, например такие как настройки гаджетов рабочего стол, расположение значков на панели и т.д. Вам возможно понадобит© установить пароль на учетную запись администратора и работать из под нее.

Для создания пароля к своей учетной записи сделайте следующее:

1) Откройте папку Учетные записи пользователей в Панели управления.

Панель управления\Все элементы панели управления\Учетные записи пользователей
Панель управления\Учетные записи пользователей и семейная безопасность\Учетные записи пользователей

2) Нажмите ссылку Создание пароля своей учетной записи.
3) Введите новый пароль и его подтверждение.
4) Нажмите кнопку Создать пароль.

Также, может помочь отключение контроля учетных записей (UAC).


22. Переключение с активного окна на неактивное, путем наведении на него курсора.

В Windows существует параметр, позволяющий активизировать окно при наведении на него указателя мыши. Данное использование мыши облегчает выбор или активацию окон, позволяя переключит© на неактивное окно при наведении на него указателя мыши без необходимости выполнения щелчка.

Для настройки данной возможности мыши сделайте следующее:

1) Откройте Панель управления → Центр специальных возможностей
2) Нажмите на ссылку Облегчение работы с мышью (изменение параметров мыши или другого указывающего устройства).
3) В разделе Упрощенное управление окнами установите флажок "Активизировать окно при наведении на него указателя мыши" и нажмите кнопку ОК.

или так:

1) Введите в строке поиска меню Пуск слово: мыши.
2) В списке результатов выберите: Изменение параметров мыши.
3) В разделе Упрощенное управление окнами установите флажок "Активизировать окно при наведении на него указателя мыши" и нажмите кнопку ОК.


23. Создание ярлыка для очистки буфера обмена.

Если Вам приходится часто работать с данными содержащими конфиденциальную информацию (пароли, номера кредитных карт и т.д.) или же с данными большого объема, используя буфер обмена, то Вам наверняка может потребоваться его очистить.

Для создания специального ярлыка, осуществляющего очистку буфера обмена, выполните указанные ниже действия.

1) Щелкните правой кнопкой мыши по свободному пространству рабочего стола.
2) Выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите:

4) Нажмите кнопку Далее и укажите название ярлыка, после чего нажмите на кнопку Готово.
Теперь достаточно запустить созданный ярлык и буфер обмена будет очищен.

5) Замените иконку командной строки на более подходящую:
5.1) Нажмите правой кнопкой мыши на созданном Вами ярлыке и выберите пункт Свойства.
5.2) В открывшемся окне нажмите кнопку Сменить значок
5.3) Выберите необходимую Вам иконку для отображения и нажмите кнопку ОК.


24. Обнаружение указателя мыши на рабочем столе.

Если Вам бывает необходимо быстро найти курсор мыши на экране, то Вы можете включить функцию обнаружения курсора на экране.

1) В строке поиска меню Пуск введите слово Мышь и нажмите Enter ↵ или откройте Панель управления и выберите компонент Мышь
2) Перейдите на вкладку Параметры указателя
3) В разделе Видимость установите флажок Обозначить расположение указателя при нажатии клавиши Ctrl и нажмите кнопку ОК.

Теперь, чтобы обнаружить курсор мыши нажмите сочетание клавиш Win   + Ctrl и месторасположение курсора обозначится кольцами.


25. Быстрый постоянный доступ к собственной папке из меню Пуск.

Если Вам необходимо добавить собственную папку в меню Пуск для быстрого доступа к часто используемым файлам, то Вы можете сделать это следующим образом.

1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт Свойства.
2) В открывшемся окне нажмите кнопку Настроить.
3) Установите для элемента ТВ-записи переключатель в желаемое значение и нажмите ОК в каждом окне:
3.1) Отображать как меню, для доступа из меню Пуск к файлам в Вашей папке.
3.2) Отображать как ссылку, для открытия Вашей папки из меню Пуск.
4) Откройте меню Пуск, щелкните правой кнопкой мыши на элемент ТВ-записи и выберите пункт Свойства.
5) В открывшемся окне нажмите кнопку Добавить папку, укажите какую папку Вы желаете добавить и нажмите кнопку Добавить папку.
При необходимости Вы можете удалить папку Общедоступные ТВ-записи, выделив ее и нажав кнопку Удалить. Вы можете добавить любое количество папок.
6) В зависимости от содержимого Вашей папки укажите, как ее необходимо оптимизировать.
7) Нажмите кнопку ОК.
8) Откройте меню Пуск, щелкните правой кнопкой мыши на элемент ТВ-записи и выберите пункт Переименовать.
9) Введите желаемое имя для отображаемого элемента в меню Пуск. Перейти к началу Общего списка советов.


26. Добавление, изменение и удаление пунктов в контекстном меню.

Если Вам необходимо добавить или удалить пункт в контекстном меню, то наиболее простым способом это сделать является программа Ultimate Windows Context Menu Customizer.
Созданные пункты меню могут служить ссылкой на системные папки (Компьютер, Рабочий стол), произвольные папки и файлы. Вы также можете добавлять ссылки на веб-страницы.

Скачать программу Вы можете по ссылке: Ultimate Windows Context Menu Customizer

Добавление произвольного пункта в контекстное меню:

1) Запустите программу от имени администратора.
2) Выберите расположение пункта контекстного меню из списка Context Menu Location.
3) В поле Text введите текст, который будет отображаться в контекстном меню.
4) В текстовом поле Command введите команду, которая будет выполняться при нажатии пункта контекстного меню.
Чтобы созданный Вами пункт меню открыл файл, введите путь к файлу. Вы можете нажать на кнопку ..., чтобы найти файл.
Чтобы созданный Вами пункт меню открыл папку, введите explorer, пробел и путь к папке.
Чтобы созданный Вами пункт меню открыл веб-страницу, введите имя браузера (chrome для Google Chrome, firefox для Mozilla Firefox, iexplore для Internet Explorer), пробел и адрес веб-страницы.
5) В текстовом поле Icon введите путь к иконке. Вы можете нажать на кнопку ..., чтобы найти иконку.
6) Из ниспадающего меню Position выберите местоположение пункта контекстного меню. (Top - Вверху, Middle - Посередине, Bottom - Внизу)
7) Установите флажок Extended, чтобы пункт контекстного меню появлялся только, когда Вы нажимаете клавишу Shift и щелкаете правую кнопку мыши.
8) Установите флажок Disabled, чтобы временно отключить пункт контекстного меню.
9) Нажмите кнопку Add Item и созданный Вами пункт будет добавлен в контекстное меню.

Добавление предопределенного пункта в контекстное меню:

1) Запустите программу от имени администратора.
2) Выберите расположение пункта контекстного меню из списка Context Menu Location.
3) Выберите пункт/пункты, которые необходимо добавить из списка Add Pre-Defined Items.
4) Нажмите кнопку Add Item и созданный Вами пункт будет добавлен в контекстное меню.

Изменение пункта в контекстном меню:

1) Запустите программу от имени администратора.
2) Выберите расположение пункта контекстного меню из списка Context Menu Location.
3) Выберите из списка Context Menu Items пункт, который требуется изменить и область Add/Edit Item будет заполнена.
4) Измените поля в области Add/Edit Item, как Вам нравится, и нажмите кнопку Edit Item.

Удаление пункта из контекстного меню:

1) Запустите программу от имени администратора.
2) Выберите расположение пункта контекстного меню из списка Context Menu Location.
3) Выберите из списка Context Menu Items пункт/пункты, которые Вы хотите удалить.
4) Нажмите кнопку Remove Item. Перейти к началу Общего списка советов.


27. Добавление пункта "Диспетчер устройств" в контекстное меню Компьютер на рабочем столе.

Если у Вас на рабочем столе присутствует значок Компьютер, то Вам может пригодиться в его контекстном меню пункт Диспетчер устройств.
Для быстрого добавления данного пункта в контекстное меню потребуется программа – Ultimate Windows Context Menu Customizer

1) Запустите программу от имени администратора.
2) Выберите в списке Context Menu Location пункт Computer.
3) В поле Text введите текст: Диспетчер устройств
4) В текстовом поле Command введите команду: control hdwwiz.cpl
5) Нажмите кнопку Add Item Перейти к началу Общего списка советов.


28. Добавление вкладки Icons в Свойства файла.

Если Вы работаете с иконками файлов, то для упращения работы Вам может понадобит© программа IconViewer.
Данная программа позволяет напрямую из Проводника узнать какие иконки содержаться внутри того или иного файла и сохранить их в виде *.ico файлов.
IconViewer добавляет дополнительную вкладку Icons в окно Свойства, вызываемое из контекстного меню, появляющегося при нажатии правой кнопки мыши.

Скачать программу Вы можете по ссылке: http://www.botproductions.com/iconview/download.html
Примечание: Скачивайте версию программы в соответствии с разрядностью Вашей операционной системы (32-бит/64-бит).


29. Добавление ярлыков программ в список "Избранное" Проводника.

Список «Избранное» в Проводнике Windows служит для доступа к часто используемым папкам, однако при желании Вы можете добавить туда и ярлыки к часто используемым программам.

1) Введите в адресной строке Проводника %userprofile%\Links или C:\Users\имя_пользователя\Links, чтобы открыть папку со ссылками.
2) Скопируйте в данную папку, ярлыки которые Вы желаете увидеть в левой колонке Проводника в списке «Избранное».

По-умолчанию ярлыки в списке расположены в алфавитном порядке, но Вы можете передвинуть любой из них прямо в списке.

Примечание: Некоторые приложения, для которых в свойствах ярлыка не задан прямой путь к исполняемому файлу, могут не запустит© таким образом. Поэтому для них необходимо создать новый ярлык, учитывая данный факт.


30. Открытие одновременно двух рядом расположенных копий Проводника.

Если Вы желаете открыть одновременно два окна Проводника расположенных рядом, то Вы можете сделать это воспользовавшись созданным мною скриптом.

1) Скачайте архив TESBS.zip и распакуйте его в любую папку (Например: C:\TESBS)
2) Щелкните правой кнопкой мыши на пустом месте в папке и выберите Создать → Ярлык
3) В поле Расположение объекта введите указанную ниже команду и нажмите кнопку Далее.

где, C:\TESBS - путь к vbs-файлу.

4) Введите имя ярлыка (Например: Два Проводника Рядом) и нажмите Готово.

Для смены значка у ярлыка.

5.1) Щелкните правой кнопкой мыши на созданном ярлыке и выберите пункт Свойства.
5.2) Нажмите кнопку Сменить значок на вкладке Ярлык.
5.3) В поле Искать значки в следующем файле введите: C:\Windows\System32\shell32.dll и нажмите Enter ↵.
5.4) Выберите желаемый значок и нажмите кнопку ОК.

Для закрепления данного ярлыка в панели задач.

6) Щелкните правой кнопкой мыши на созданном ярлыке и выберите пункт Закрепить на панели задач.

Примечание: Изменяйте значок перед закреплением ярлыка в панели задач.


31. Закрепление программы в меню Пуск или на панели задач, используя скрипт.

Если Вы желаете закрепить программу на панели задач или в меню Пуск не используя контекстного меню, то Вы можете это сделать используя vbs-скрипт.

1) Скачайте и распакуйте в любую папку архив: PinUnpinItemScript.zip
2) В зависимости от языка Вашей системы скопируйте в папку C:\Windows файл PinItem.vbs из папки Eng(для английской версии) или Rus(для русской версии).
3) Запустите командную строку (Win+R → cmd → OK)
4) Введите необходимую Вам команду, используя шаблон и нажмите Enter ↵:

Параметры:

/item:"Путь к объекту" - Путь к объекту для закрепления.
/taskbar - (параметр) Закрепить на панели задач вместо меню ""Пуск"".
/unpin - (параметр) Открепить закрепленный объект.

Примеры:

Закрепить программу Calc.exe в меню Пуск:

Открепить программу Calc.exe из меню Пуск:

Закрепить программу Calc.exe на панели задач:

Открепить программу Calc.exe с панели задач:

Примечание:

П1) Скрипт не открепляет объекты закрепленные с помощью контекстного меню, только закрепленные при помощи скрипта.
П2) Скрипт не закрепляет объекты, если закрепление запрещено групповой политикой или параметром NoPinningToTaskbar в реестре.


32. Открытие папок Проводника в новых вкладках, как в интернет браузере.

Если Вы желаете, чтобы у Вас в Проводнике появилась возможность открывать вкладки также как в интернет браузере, то скачайте для этого программу QTTabBar.

Сайты для скачивания:

http://qttabbar.wikidot.com/download - требует установки Microsoft .Net Framework 4.0, включения вручную панелей QTTabBar, QT Button Bar и множества дополнительных настроек.
http://qttabbar.sourceforge.net/ - не требует установки Microsoft .Net Framework 4.0

Далее в совете описывается версия не требующая установки Microsoft .Net Framework 4.0.

1) Чтобы подключить русский языковой файл:

1.1) Зайдите на сайт http://sourceforge.net/projects/qttabbar/files/Language%20Files/
1.2) Скачайте файл Lng_QTTabBar_Russian.xml.
1.3) Скопируйте его в папку C:\Program Files\QTTabBar (для 64-битной Windows в папку C:\Program Files (x86)\QTTabBar)
1.4) Щелкните на свободном месте на панель вкладок QTTabBar и выберите пункт Options.
1.5) Перейдите на вкладку General
1.6) В поле Language file укажите путь к Вашему файлу Lng_QTTabBar_Russian.xml и нажмите кнопку ОК.
1.7) Перезапустите Проводник.

2) Чтобы открыть необходимую Вам папку в новой вкладке, щелкните по ней средней кнопкой мыши или перетащите ее на панель вкладок QTTabBar.

При щелчке на значок рядом с названием вкладки отобразится содержимое папки.

Для быстрого перехода между вкладками Вы можете использовать комбинацию клавиш Ctrl + Tab ↹.

3) Чтобы закрыть вкладку, щелкните по ней правой кнопкой мыши и выберите пункт Закрыть или нажмите на кнопку с крестиком на панели QTTab Standard Buttons.

4) Чтобы открытые Вами вкладки запомнились после закрытия Проводника и отобразились при повторном его открытии:

4.1) Щелкните на свободном месте на панель вкладок QTTabBar и выберите пункт Настройки.
4.2) Перейдите на вкладку Окно
4.3) Установите флажок Восстановить вкладки и нажмите кнопку ОК. Перейти к началу Общего списка советов.


33. Создание ярлыка для быстрого доступа к настройкам Визуальные эффекты.

Если Вам бывает необходимо освобождать ресурсы компьютера, путем отключения визуальных эффектов, для работы с ресурсоемкими приложениями, то Вы можете создать значок для быстрого доступа к данным настройкам.

Для создания данного ярлыка, выполните указанные ниже действия.

1) Щелкните правой кнопкой мыши по свободному пространству рабочего стола.
2) Выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите:

4) Нажмите кнопку Далее и укажите название ярлыка (Визуальные эффекты), после чего нажмите на кнопку Готово.

5) Чтобы заменить иконку на более подходящую:
5.1) Нажмите правой кнопкой мыши на созданном Вами ярлыке и выберите пункт Свойства.
5.2) В открывшемся окне нажмите кнопку Сменить значок.
5.3) Выберите необходимую Вам иконку для отображения и нажмите кнопку ОК.


34. Сохранение часто используемых условий поиска в Проводнике.

Если Вы часто используете одинаковые значения в поле поиска (например, периодически ищите файлы pdf на компьютере), то Вам пригодится указанное ниже решение, позволяющее сохранить условия для поиска.

1) Щелкните на пустом месте панели задач и нажмите клавишу F3
2) Введите в текстовом поле желаемое значение для поиска.
3) В разделе Повторить поиск в: укажите желаемую область поиска.
4) Нажмите правой кнопкой мыши в свободной области с результатами поиска и выберите в меню Вид - способ представления результатов.
5) Нажмите правой кнопкой мыши в свободной области с результатами поиска и выберите в меню Сортировать - по какой колонке упорядочить результаты и в каком порядке (по возрастанию; по убыванию).
6) Нажмите правой кнопкой мыши в свободной области с результатами поиска и выберите пункт Сохранить условия поиска.
7) Укажите папку, где необходимо сохранить файл с условиями поиска и с каким именем и нажмите кнопку Сохранить.

Когда Вам понадобится найти файлы или папки с сохраненными условиями поиска, то откройте папку куда Вы сохранили файл с условиями поиска и нажмите на него.

Для информации:

Данный файл сохраняет только условия поиска, а не его результ.
Если Вы добавите в систему новые файлы, подходящие под условия поиска, то они также будут включены в результат.


35. Автоматическое закрытие окна команд сразу после запуска программы с помощью CMD-файла.

Обычно, если Вы запускаете программу используя CMD-файл, то окно команд не закрывается до окончания работы программы.
Чтобы Ваше окно команд закрылось сразу после запуска программы, добавьте перед Вашим файлом для запуска программы, команду start с двумя двойными кавычками.

Пример:

С включенным режимом вывода команд на экран:

С выключенным режимом вывода команд на экран:


36. Установка клавиши Backspace в Проводнике для перехода в папку, расположенную на уровень выше.

В предыдущих версиях Windows, клавиша ⟵ Backspace использовалась для перехода в папку, расположенную на один уровень вверх.
В последствии, данное действие для этой клавиши осталось только в диалоговых окнах "Открыть", "Сохранить как".
Клавиша ⟵ Backspace в Проводнике стала выполнять функцию перехода обратно по истории просмотренных папок.
А для перехода в папку, расположенную на уровень выше, стало использоваться сочетание клавиш Alt + ↑ .
Чтобы установить клавишу ⟵ Backspace в качестве клавиши, выполняющей функцию перехода в папку, расположенную на один уровень вверх воспользуйтесь предложенным ниже решением.

Для единоразового использования данной программы:

1) Скачайте и распакуйте в любую папку архив с программой: HTGBack.zip
2) Запустите файл HTGBack.exe.

Для постоянного использования данной программы:

1) Скачайте и распакуйте в любую папку архив с программой: HTGBack.zip
2) Скопируйте файл HTGBack.exe в папку C:\Windows.
3) Создайте и примените reg-файл указанного ниже содержания.


37. Запуск командных файлов (.bat, .cmd) без отображения окна команд.

Чтобы запустить командный файл (.bat, .cmd) без отображения окна команд воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1. Используя vbs-скрипт с указыванием в нем запускаемого командного файла.

1) Создайте специальный скрипт.

1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).

Вместо name.bat - укажите имя Вашего командного файла и путь к нему, если Вы планируете использовать скрипт из другой папки.
Для запуска нескольких командных файлов, повторите данную строку заменив name.bat на другое значение.

1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "HideBatCmdStart.vbs")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Запустите vbs-скрипт и Ваш командный файл запустит© без открытия окна команд.

Вариант 2. Используя единый vbs-скрипт для всех командных файлов.

1) Создайте специальный скрипт.

1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "HideAllStart.vbs")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
2) Скопируйте данный vbs-файл в папку C:\Windows\System32

Для запуска Вашего командного файла Вы можете воспользоваться диалоговым окном Выполнить (Win   + R) или добавить его запуск в папку автозапуска реестра (HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run) используя следующую команду:

Вместо name.bat - укажите имя Вашего командного файла и путь к нему.

Например, для запуска с рабочего стола выполните следующую команду:

Вариант 3. Используя программу стороннего производитЈ.

1) В соответствии с разрядностью Вашей системы скачайте программу NirCmd: 32-бит или 64-бит
2) Распакуйте архив и скопируйте программу nircmd.exe в папку С:\Windows\System32.

Для запуска Вашего командного файла Вы можете воспользоваться диалоговым окном Выполнить (Win   + R) или добавить его запуск в папку автозапуска реестра (HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run) используя следующую команду:

Вместо name.bat - укажите имя Вашего командного файла и путь к нему.


38. Одновременное переименование большого количества файлов и папок.

Очень часто бывает необходимо переименовать группу файлов или папок по какому-то общему шаблону, а стандартных возможностей Проводника может оказаться недостаточно.
В таких случаях приходится использовать дополнительные программы.
Программ для одновременного переименования большого количества файлов существует очень много, но одной из самых удобных из них является Rename Master.
Используя данную программу, Вы сможете легко и быстро упорядочить коллекции документов, музыки, видеоматериалов и изображений, состоящие из множества по-разному названных файлов и папок.
Кроме стандартных функций (таких как добавление символов в любую часть имени файла, замена текста, смена заглавных букв на строчные и др.) программа позволяет извлекать информацию из свойств файла или из мета-тэгов (в файлах MP3, JPG, JPEG и TIFF).

Чтобы переименовать необходимую Вам группу файлов и/или папок:

1) Скачайте и распакуйте в любую папку архив с программой.
2) Запустите программу.
3) Используя адресную строку идентичную строке Проводника перейдите в папку, где располагаются файлы для переименования.
4) Выберите необходимый Вам способ отображения данных в папке: Files(Файлы), Folders(Папки), Files&Folders(Файлы и Папки).
5) Перейдите на нужную вкладку и отметьте нужную опцию.
6) Задайте условия для переименовывания и нажмите кнопку Rename на первой вкладке.

Наиболее часто ипользуемые условия.

Вкладка Renaming Script:

[01] Remove Words/Numbers - Удаляет фразу или число из имени/расширения файла/папки.
[02] Remove Beginning/Ending - Удаляет определенное количество символов от начала/конца из имени/расширения файла/папки. При установке флажка Replace with заменяет указанным значением.
[03] Remove by Position - Удаляет/оставляет определенное количество символов от и до указанного расположения.
[04] Remove Before/After - Удаляет все до/после заданной фразы. При установке флажка Replace with заменяет указанным значением.
[05] Remove/Replace Expression - Удаляет/заменяет в имени файла фразу начинающуюся/заканчивающуюся с определенного символа/фразы.
[07] Replace/Find and Replace - Находит и заменяет имя/расширение целиком или фразу в имени/расширении на указанное значение.
[09] Select and Move - Перемещает текст до или после указанной фразы, конкретно заданный текст или текст с такого-то по такой-то символ в указанное место в имени файла/папки.
[12] Add to Beginning/Ending - Добавляет указанную фразу в начало/конец имени/расширения файла/папки.
[13] Add by Position - Добавляет указанную фразу в имя/расширение расположенную в определенной позиции относительно начала/конца файла.
[14] Add Before/After - Добавляет указанную фразу в имя/расширение расположенную до/после заданной фразы.
[15] Add Counter - Добавляет порядковый номер в начало/конец имени файла/папки.

Вкладка Case & Wildcards:

Установите флажок Change Case для включения условий переименования.
Установите флажок Preserve Extension для исключения расширения файла из условий переименования.
Установите флажок Detect and capitalize Roman Numerals для преобразования римских цифр из строчных букв в заглавные.

Значения переключателя:

UPPERCASE - Заменяет все бувы на заглавные.
lowercase - Заменяет все бувы на прописные.
Capitalize Words - Заменяет первую букву каждого слова на заглавную, а остальные буквы на строчные.
Capitalize sentence - Заменяет первую букву первого слова на заглавную, а остальные буквы на строчные.
Capitalize with Title Case - Заменяет первую букву каждого слова, не являющегося словом/символом связкой (предлоги, апострофы), на заглавную, а остальные буквы на строчные. Перейти к началу Общего списка советов.


39. Активация функции прокрутки у неактивного окна или не выбранной части активного окна.

По умолчанию в Windows прокрутка привязана к активному окну или выбранной его части, не зависимо от того, где находится сам курсор мыши.
И если Вам понадобит© прокрутить неактивное окно или другую область активного окна, то для этого Вам необходимо будет на него переключит©.

Существует программа Tordex Wheel, которая позволяет убрать данный недостаток Windows.
При ее использовании Вы сможете прокрутить любую часть как активного, так и неактивного окна всего лишь наведя на нее курсор мыши.
После запуска программы в трее появит© ее значок, нажав на который Вы сможете добавить данную программу в автозагрузку.
Для этого Вам необходимо будет щелкнуть правой кнопкой мыши на значок программы и выбрать пункт Run on Startup.

Скачать: http://www.tordex.com/wheel/index.html


1. Конфигурация служб Windows 7 по умолчанию, способы их запуска и отключения.

Если Вы желаете изменить или восстановить значения служб установленных в системе по умолчанию, то Вы можете воспользоваться указанными ниже таблицами, для внесения изменений вручную. (Подробное описание действий находится под таблицами).

Для быстрого восстановления значений всех служб по умолчанию, выполните действия предложенные в одном из указанных ниже вариантов:

Вариант 1.

1) Зайдите на сайт http://technet.microsoft.com/ru-ru/sysinternals/bb897553
2) Скачайте комплект программ PsTools и распакуйте в любую папку.
3) Скопируйте файл PsExec.exe в папку C:\Windows\System32
4) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
5) Введите указанную ниже команду и нажмите Enter ↵:

При первом запуске PsExec надо будет нажать кнопку Agree. При последующих запусках данный запрос выводится не будет.
6) Скачайте архив ServiceDefaultRegistryEntries.zip, содержащий набор reg-файлов для восстановления значений служб по умолчанию и распакуйте в любую папку.
7) В редакторе реестра нажмите Файл → Импорт
В случае появления окна Location is not available (Расположение не доступно) нажмите в нем кнопку ОК.
8) Выберите reg-файл соответствующий редакции и разрядности Вашей Windows и нажмите кнопку ОК.

В безопасном режиме и в обычном режиме загружаются разные службы, поэтому в архиве ServiceDefaultRegistryEntries.zip содержаться две папки с подпапками.
В папке Default находятся reg-файлы для восстановления значения служб по умолчанию в обычном режиме.
В папке SafeMode находятся reg-файлы для восстановления значения служб по умолчанию в безопасном режиме.

9) Перезагрузите компьютер.

Вариант 2.

1) Скачайте архив ServiceDefaultRegistryEntries.zip и распакуйте в любую папку.
2) Перезапустите компьютер
3) До начала запуска Windows нажмите на клавишу F8.
Если клавиша F8 используется материнской платой, то выберите диск на котором у Вас установлена Windows, нажмите Enter ↵, а затем сразу же F8.
4) В появившемся списке вариантов загрузки Дополнительные варианты загрузки (Advanced Boot Options) выберите пункт Устранение неполадок компьютера (Repair Your Computer) и нажмите Enter ↵.
5) Выберите метод ввода с клавиатуры (keyboard input method) - США (US) и нажмите Next (Далее)
6) В списке инструментов выберите командную строку - Командная строка (Command Prompt).
7) Введите команду regedit и нажмите кнопку Enter ↵.
8) В редакторе реестра нажмите Файл → Импорт
9) Выберите reg-файл соответствующий редакции и разрядности Вашей Windows и нажмите кнопку Открыть (Open).

В безопасном режиме и в обычном режиме загружаются разные службы, поэтому в архиве ServiceDefaultRegistryEntries.zip содержаться две папки с подпапками.
В папке Default находятся reg-файлы для восстановления значения служб по умолчанию в обычном режиме.
В папке SafeMode находятся reg-файлы для восстановления значения служб по умолчанию в безопасном режиме.

10) Закройте окна реестра и командной строки и нажмите кнопку Перезагрузка (Restart).

Таблица 1. Общие сведения о службах.

Отображаемое имя (русское) | Отображаемое имя (английское) | Имя службы | Исполняемый файл | Вход от имени
BranchCache | BranchCache | PeerDistSvc | C:\Windows\System32\svchost.exe -k PeerDist | Сетевая служба
DHCP-клиент | DHCP Client | Dhcp | C:\Windows\system32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
DNS-клиент | DNS Client | Dnscache | C:\Windows\system32\svchost.exe -k NetworkService | Сетевая служба
KtmRm для координатора распределенных транзакций | KtmRm for Distributed Transaction Coordinator | KtmRm | C:\Windows\System32\svchost.exe -k NetworkServiceAndNoImpersonation | Сетевая служба
Microsoft .NET Framework NGEN v2.0.50727_X64 Microsoft .NET Framework NGEN v2.0.50727_X86 | Microsoft .NET Framework NGEN v2.0.50727_X64 Microsoft .NET Framework NGEN v2.0.50727_X86 | clr_optimization_v2.0.50727_64 clr_optimization_v2.0.50727_32 | C:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorsvw.exe C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorsvw.exe | Локальная cистема
Microsoft .NET Framework NGEN v4.0.30319_X64 Microsoft .NET Framework NGEN v4.0.30319_X86 | Microsoft .NET Framework NGEN v4.0.30319_X64 Microsoft .NET Framework NGEN v4.0.30319_X86 | clr_optimization_v4.0.30319_64 clr_optimization_v4.0.30319_32 | C:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscorsvw.exe C:\Windows\Microsoft.NET\Framework\v4.0.30319\mscorsvw.exe | Локальная cистема
Parental Controls | Parental Controls | WPCSvc | C:\Windows\system32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Plug-and-Play | Plug and Play | PlugPlay | C:\Windows\system32\svchost.exe -k DcomLaunch | Локальная система
Quality Windows Audio Video Experience | Quality Windows Audio Video Experience | QWAVE | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Superfetch | Superfetch | SysMain | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Telnet | Telnet | TlntSvr | C:\Windows\System32\tlntsvr.exe | Локальная служба
Windows Audio | Windows Audio | AudioSrv | C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Windows CardSpace | Windows CardSpace | idsvc | "C:\Windows\Microsoft.NET\Framework64\v3.0\Windows Communication Foundation\infocard.exe" | Локальная система
Windows Driver Foundation – User-mode Driver Framework | Windows Driver Foundation - User-mode Driver Framework | wudfsvc | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Windows Search | Windows Search | WSearch | C:\Windows\system32\SearchIndexer.exe /Embedding | Локальная система
WMI Performance Adapter | WMI Performance Adapter | wmiApSrv | C:\Windows\system32\wbem\WmiApSrv.exe | Локальная система
Автонастройка WWAN | WWAN AutoConfig | WwanSvc | C:\Windows\system32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Автономные файлы | Offline Files | CscService | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Агент защиты сетевого доступа | Network Access Protection Agent | napagent | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Агент политики IPsec | IPsec Policy Agent | PolicyAgent | C:\Windows\system32\svchost.exe -k NetworkServiceNetworkRestricted | Сетевая служба
Адаптер прослушивателя Net.Msmq | Net.Msmq Listener Adapter | NetMsmqActivator | "C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe" -NetMsmqActivator | Сетевая служба
Адаптер прослушивателя Net.Pipe | Net.Pipe Listener Adapter | NetPipeActivator | "C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe" | Локальная служба
Адаптер прослушивателя Net.Tcp | Net.Tcp Listener Adapter | NetTcpActivator | "C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe" | Локальная служба
Адаптив регулировка яркости | Adaptive Brightness | SensrSvc | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Архивация Windows | Windows Backup | SDRSVC | C:\Windows\system32\svchost.exe -k SDRSVC | Локальная система
Биометрическая служба Windows | Windows Biometric | WbioSrvc | C:\Windows\system32\svchost.exe -k WbioSvcGroup | Локальная система
Брандмауэр Windows | Windows Firewall | MpsSvc | C:\Windows\system32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Браузер компьютеров | Computer Browser | Browser | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Веб-клиент | WebClient | WebClient | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Виртуальный диск | Virtual Disk | vds | C:\Windows\System32\vds.exe | Локальная система
Вспомогательная служба IP | IP Helper | iphlpsvc | C:\Windows\System32\svchost.exe -k NetSvcs | Локальная система
Вторичный вход в систему | Secondary Logon | seclogon | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Группировка сетевых участников | Peer Networking Grouping | p2psvc | C:\Windows\System32\svchost.exe -k LocalServicePeerNet | Локальная служба
Дефрагментация диска | Disk Defragmenter | defragsvc | C:\Windows\system32\svchost.exe -k defragsvc | Локальная система
Диспетчер автоматических подключений удаленного доступа | Remote Access Auto Connection Manager | RasAuto | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Диспетчер печати | Print Spooler | Spooler | C:\Windows\System32\spoolsv.exe | Локальная система
Диспетчер подключений удаленного доступа | Remote Access Connection Manager | RasMan | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Диспетчер сеансов диспетчера окон рабочего стола | Desktop Window Manager Session Manager | UxSms | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Диспетчер удостоверения сетевых участников | Peer Networking Identity Manager | p2pimsvc | C:\Windows\System32\svchost.exe -k LocalServicePeerNet | Локальная служба
Диспетчер учетных данных | Credential Manager | VaultSvc | C:\Windows\system32\lsass.exe | Локальная система
Диспетчер учетных записей безопасности | Security Accounts Manager | SamSs | C:\Windows\system32\lsass.exe | Локальная система
Доступ к HID-устройствам | Human Interface Device Access | hidserv | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Журнал событий Windows | Windows Event Log | eventlog | C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Журналы и оповещения производительности | Performance Logs & Alerts | pla | C:\Windows\System32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Защита программного обеспечения | Software Protection | sppsvc | C:\Windows\system32\sppsvc.exe | Сетевая служба
Защитник Windows | Windows Defender | WinDefend | C:\Windows\System32\svchost.exe -k secsvcs | Локальная система
Защищенное хранилище | Protected Storage | ProtectedStorage | C:\Windows\system32\lsass.exe | Локальная система
Изоляция ключей CNG | CNG Key Isolation | KeyIso | C:\Windows\system32\lsass.exe | Локальная система
Инструментарий управления Windows | Windows Management Instrumentation | Winmgmt | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Информация о совместимости приложений | Application Experience | AeLookupSvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Клиент групповой политики | Group Policy Client | gpsvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Клиент для NFS | Client for NFS | NfsClnt | C:\Windows\system32\nfsclnt.exe | Сетевая служба
Клиент отслеживания изменившихся связей | Distributed Link Tracking Client | TrkWks | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Координатор распределенных транзакций | Distributed Transaction Coordinator | MSDTC | C:\Windows\System32\msdtc.exe | Сетевая служба
Кэш шрифтов Windows Presentation Foundation 3.0.0.0 | Windows Presentation Foundation Font Cache 3.0.0.0 | FontCache3.0.0.0 | C:\Windows\Microsoft.Net\Framework64\v3.0\WPF\PresentationFontCache.exe | Локальная служба
Ловушка SNMP | SNMP Trap | SNMPTRAP | C:\Windows\System32\snmptrap.exe | Локальная служба
Локатор удаленного вызова процедур (RPC) | Remote Procedure Call (RPC) Locator | RpcLocator | C:\Windows\system32\locator.exe | Сетевая служба
Маршрутизация и удаленный доступ | Routing and Remote Access | RemoteAccess | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Модули ключей IPsec для обмена ключами в Интернете и протокола IP с проверкой подлинности | IKE and AuthIP IPsec Keying Modules | IKEEXT | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Модуль запуска процессов DCOM-сервера | DCOM Server Process Launcher | DcomLaunch | C:\Windows\system32\svchost.exe -k DcomLaunch | Локальная система
Модуль поддержки NetBIOS через TCP/IP | TCP/IP NetBIOS Helper | lmhosts | C:\Windows\system32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Настройка сервера удаленных рабочих столов | Remote Desktop Configuration | SessionEnv | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Немедленные подключения Windows – регистратор настройки | Windows Connect Now - Config Registrar | wcncsvc | C:\Windows\System32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Обнаружение SSDP | SSDP Discovery | SSDPSRV | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Обнаружение интерактивных служб | Interactive Services Detection | UI0Detect | C:\Windows\system32\UI0Detect.exe | Локальная система
Общий доступ к подключению к Интернету (ICS) | Internet Connection Sharing (ICS) | SharedAccess | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Определение оборудования оболочки | Shell Hardware Detection | ShellHWDetection | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Основные службы доверенного платформенного модуля | TPM Base Services | TBS | C:\Windows\System32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Очередь сообщений | Message Queuing | MSMQ | C:\Windows\system32\mqsvc.exe | Сетевая служба
Перенаправитель портов пользовательского режима служб удаленных рабочих столов | Remote Desktop Services UserMode Port Redirector | UmRdpService | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Перечислитель IP-шин PnP-X | PnP-X IP Bus Enumerator | IPBusEnum | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Питание | Power | Power | C:\Windows\system32\svchost.exe -k DcomLaunch | Локальная система
Планировщик заданий | Task Scheduler | Schedule | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Планировщик классов мультимедиа | Multimedia Class Scheduler | MMCSS | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Поддержка элемента панели управления "Отчеты о проблемах и их решениях" | Problem Reports and Solutions Control Panel Support | wercplsupport | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Политика удаления смарт-карт | Smart Card Removal Policy | SCPolicySvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Поставщик домашней группы | HomeGroup Provider | HomeGroupProvider | C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Проводная автонастройка | Wired AutoConfig | dot3svc | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Программный поставщик теневого копирования (Microsoft) | Microsoft Software Shadow Copy Provider | swprv | C:\Windows\System32\svchost.exe -k swprv | Локальная система
Прослушиватель RIP | RIP Listener | iprip | C:\Windows\System32\svchost.exe -k ipripsvc | Локальная служба
Прослушиватель домашней группы | HomeGroup Listener | HomeGroupListener | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Простые службы TCP/IP | Simple TCP/IP Services | simptcp | C:\Windows\System32\tcpsvcs.exe | Локальная служба
Протокол PNRP | Peer Name Resolution Protocol | PNRPsvc | C:\Windows\System32\svchost.exe -k LocalServicePeerNet | Локальная служба
Публикация ресурсов обнаружения функции | Function Discovery Resource Publication | FDResPub | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Рабочая станция | Workstation | LanmanWorkstation | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Распространение сертификата | Certificate Propagation | CertPropSvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Расширяемый протокол проверки подлинности (EAP) | Extensible Authentication Protocol | EapHost | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Сборщик событий Windows | Windows Event Collector | Wecsvc | C:\Windows\system32\svchost.exe -k NetworkService | Сетевая служба
Сведения о приложении | Application Information | Appinfo | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Сервер | Server | LanmanServer | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Сервер упорядочения потоков | Thread Ordering Server | THREADORDER | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Сетевой вход в систему | Netlogon | Netlogon | C:\Windows\system32\lsass.exe | Локальная система
Сетевые подключения | Network Connections | Netman | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Система событий COM+ | COM+ Event System | EventSystem | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Системное приложение COM+ | COM+ System Application | COMSysApp | C:\Windows\system32\dllhost.exe /Processid:{02D4B3F1-FD88-11D1-960D-00805FC79235} | Локальная система
Служба FTP (Майкрософт) | Microsoft FTP Service | FTPSVC | C:\Windows\system32\svchost.exe -k ftpsvc | Локальная система
Служба IIS Admin | IIS Admin Service | IISADMIN | C:\Windows\system32\inetsrv\inetinfo.exe | Локальная система
Служба LPD | LPD Service | LPDSVC | C:\Windows\System32\svchost.exe -k LPDService | Локальная система
Служба SNMP | SNMP Service | SNMP | C:\Windows\System32\snmp.exe | Локальная система
Служба SSTP | Secure Socket Tunneling Protocol Service | SstpSvc | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба автоматического обнаружения веб-прокси WinHTTP | WinHTTP Web Proxy Auto-Discovery Service | WinHttpAutoProxySvc | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба автонастройки WLAN | WLAN AutoConfig | Wlansvc | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба активации Windows | Windows Process Activation Service | WAS | C:\Windows\system32\svchost.exe -k iissvcs | Локальная система
Служба базовой фильтрации | Base Filtering Engine | BFE | C:\Windows\system32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Служба ввода планшетного ПК | Tablet PC Input Service | TabletInputService | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба веб-публикаций | World Wide Web Publishing Service | W3SVC | C:\Windows\system32\svchost.exe -k iissvcs | Локальная система
Служба времени Windows | Windows Time | W32Time | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба загрузки изображений Windows (WIA) | Windows Image Acquisition (WIA) | StiSvc | C:\Windows\system32\svchost.exe -k imgsvc | Локальная служба
Служба индексирования | Indexing Service | CISVC | C:\Windows\system32\CISVC.EXE | Локальная служба
Служба инициатора Майкрософт iSCSI | Microsoft iSCSI Initiator Service | MSiSCSI | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Служба интерфейса сохранения сети | Network Store Interface Service | nsi | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба кэша шрифтов Windows | Windows Font Cache Service | FontCache | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Служба медиаприставки Media Center | Media Center Extender Service | Mcx2Svc | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Служба модуля архивации на уровне блоков | Block Level Backup Engine Service | wbengine | C:\Windows\system32\wbengine.exe | Локальная система
Служба общего доступа к портам Net.Tcp | Net.Tcp Port Sharing Service | NetTcpPortSharing | "C:\Windows\Microsoft.NET\Framework64\v3.0\Windows Communication Foundation\SMSvcHost.exe" | Локальная служба
Служба общих сетевых ресурсов проигрывателя Windows Media | Windows Media Player Network Sharing Service | WMPNetworkSvc | "C:\Program Files\Windows Media Player\wmpnetwk.exe" | Сетевая служба
Служба перечислителя переносных устройств | Portable Device Enumerator Service | WPDBusEnum | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба планировщика Windows Media Center | Windows Media Center Scheduler Service | ehSched | C:\Windows\ehome\ehsched.exe | Сетевая служба
Служба поддержки Bluetooth | Bluetooth Support Service | bthserv | C:\Windows\system32\svchost.exe -k bthsvcs | Локальная служба
Служба поддержки узла приложений | Application Host Helper Service | AppHostSvc | C:\Windows\system32\svchost.exe -k apphost | Локальная служба
Служба политики диагностики | Diagnostic Policy Service | DPS | C:\Windows\System32\svchost.exe -k LocalServiceNoNetwork | Локальная служба
Служба помощника по совместимости программ | Program Compatibility Assistant Service | PcaSvc | C:\Windows\system32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба профилей пользователей | User Profile Service | ProfSvc | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Служба публикации имен компьютеров PNRP | PNRP Machine Name Publication Service | PNRPAutoReg | C:\Windows\System32\svchost.exe -k LocalServicePeerNet | Локальная служба
Служба регистрации ошибок Windows | Windows Error Reporting Service | WerSvc | C:\Windows\System32\svchost.exe -k WerSvcGroup | Локальная система
Служба ресивера Windows Media Center | Windows Media Center Receiver Service | ehRecvr | C:\Windows\ehome\ehRecvr.exe | Сетевая служба
Служба сведений о подключенных сетях | Network Location Awareness | NlaSvc | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Служба состояния ASP.NET | ASP.NET State Service | aspnet_state | C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_state.exe | Сетевая служба
Служба списка сетей | Network List Service | netprofm | C:\Windows\System32\svchost.exe -k LocalService | Локальная служба
Служба технологий активации Windows | Windows Activation Technologies Service | WatAdminSvc | C:\Windows\system32\Wat\WatAdminSvc.exe | Локальная система
Служба уведомления SPP | SPP Notification Service | sppuinotify | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Служба уведомления о системных событиях | System Event Notification Service | SENS | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Служба удаленного управления Windows (WS-Management) | Windows Remote Management (WS-Management) | WinRM | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Служба управления сетью | Web Management Service | WMSvc | C:\Windows\system32\inetsrv\wmsvc.exe | Локальная служба
Служба хранилища | Storage Service | StorSvc | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Служба шифрования дисков BitLocker | BitLocker Drive Encryption Service | BDESVC | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Служба шлюза уровня приложения | Application Layer Gateway Service | ALG | C:\Windows\System32\alg.exe | Локальная служба
Службы криптографии | Cryptographic Services | CryptSvc | C:\Windows\system32\svchost.exe -k NetworkService | Сетевая служба
Службы удаленных рабочих столов | Remote Desktop Services | TermService | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Смарт-карта | Smart Card | SCardSvr | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Сопоставитель конечных точек RPC | RPC Endpoint Mapper | RpcEptMapper | C:\Windows\system32\svchost.exe -k RPCSS | Сетевая служба
Средство построения конечных точек Windows Audio | Windows Audio Endpoint Builder | AudioEndpointBuilder | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Телефония | Telephony | TapiSrv | C:\Windows\System32\svchost.exe -k NetworkService | Сетевая служба
Темы | Themes | Themes | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Теневое копирование тома | Volume Shadow Copy | VSS | C:\Windows\system32\vssvc.exe | Локальная система
Тополог канального уровня | Link-Layer Topology Discovery Mapper | lltdsvc | C:\Windows\System32\svchost.exe -k LocalService | Локальная служба
Триггеры очереди сообщений | Message Queuing Triggers | MSMQTriggers | C:\Windows\system32\mqtgsvc.exe | Сетевая служба
Удаленный вызов процедур (RPC) | Remote Procedure Call (RPC) | RpcSs | C:\Windows\system32\svchost.exe -k rpcss | Сетевая служба
Удаленный реестр | Remote Registry | RemoteRegistry | C:\Windows\system32\svchost.exe -k regsvc | Локальная служба
Удостоверение приложения | Application Identity | AppIDSvc | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Узел системы диагностики | Diagnostic System Host | WdiSystemHost | C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted | Локальная система
Узел службы диагностики | Diagnostic Service Host | WdiServiceHost | C:\Windows\System32\svchost.exe -k LocalService | Локальная служба
Узел универсальных PNP-устройств | UPnP Device Host | upnphost | C:\Windows\system32\svchost.exe -k LocalServiceAndNoImpersonation | Локальная служба
Управление приложениями | Application Management | AppMgmt | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Управление сертификатами и ключом работоспособности | Health Key and Certificate Management | hkmsvc | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Установщик ActiveX (AxInstSV) | ActiveX Installer (AxInstSV) | AxInstSV | C:\Windows\system32\svchost.exe -k AxInstSVGroup | Локальная система
Установщик Windows | Windows Installer | msiserver | C:\Windows\system32\msiexec.exe /V | Локальная система
Установщик модулей Windows | Windows Modules Installer | TrustedInstaller | C:\Windows\servicing\TrustedInstaller.exe | Локальная система
Факс | Fax | Fax | C:\Windows\system32\fxssvc.exe | Сетевая служба
Фоновая интеллектуальная служба передачи (BITS) | Background Intelligent Transfer Service | BITS | C:\Windows\System32\svchost.exe -k netsvcs | Локальная система
Хост библиотеки счетчика производительности | Performance Counter DLL Host | PerfHost | C:\Windows\SysWow64\perfhost.exe | Локальная служба
Хост поставщика функции обнаружения | Function Discovery Provider Host | fdPHost | C:\Windows\system32\svchost.exe -k LocalService | Локальная служба
Цветовая система Windows (WCS) | Windows Color System | WcsPlugInService | C:\Windows\system32\svchost.exe -k wcssvc | Локальная служба
Центр обеспечения безопасности | Security Center | wscsvc | C:\Windows\System32\svchost.exe -k LocalServiceNetworkRestricted | Локальная служба
Центр обновления Windows | Windows Update | wuauserv | C:\Windows\system32\svchost.exe -k netsvcs | Локальная система
Шифрованная файловая система (EFS) | Encrypting File System (EFS) | EFS | C:\Windows\System32\lsass.exe | Локальная система
Отображаемое имя (русское) | Отображаемое имя (английское) | Имя службы | Исполняемый файл | Вход от имени

Таблица 2. Настройка для служб значений параметра "Тип запуска" в соответствии с редакцией Windows.

Указанные в шапке названия версий Windows, описывают стандартные конфигурации служб по умолчанию в соответствующих редакциях Windows 7.

"Безопасная" - это конфигурация, которую могут использовать 95% из пользователей с небольшими или без побочных эффектов.
Она также сводит к минимуму количество «ошибок» отображаемых в оснастке «Просмотр событий».
Данная конфигурация не гарантирует стопроцентной работы у Вас, но если Вы желаете попробовать изменить настройки служб, то это именно то с чего Вам возможно следовало бы начать.
20 параметров служб было изменено от установленного по умолчанию. Внесенные изменения помечены (*) звездочкой.

"Настроенная" - это конфигурация, позволяющая сократить количество запущенных служб, сохраняя при этом безопасность системы.
Данная конфигурация не гарантирует стопроцентной работы у Вас.
61 параметр служб было изменен от установленного по умолчанию. Внесенные изменения помечены (*) звездочкой.
Данная конфигурация позволяет системе, по-прежнему выполнять многие сетевые функции, такие как: общий доступ к файлам и принтерам, доступ к домашней группе, использование беспроводных сетей (ноутбук), а также оставляет активными несколько "возможностей" связанных с безопасностью: Защитник Windows, Брандмауэр Windows и Центр обновлений Windows.
Эта конфигурация не подходит для пользователей использующих Windows Media Center.

"Минимум" - ВНИМАНИЕ, данная конфигурация отключает многие встроенные функции для Windows 7, а также нескольких возможностей обеспечивающих безопасность. ПримҐть ее могут лишь опытные пользователи.
86 параметров служб было изменено от установленного по умолчанию. Внесенные изменения помечены (*) звездочкой.
Данная конфигурация не подходит для системы, которая непосредственно связана с Интернет, так как Защитник Windows, Брандмауэр Windows и Центр обновлений Windows отключены!
Данная конфигурация не подходит для ноутбука, в связи с тем, что беспроводные сети (также как и Защитник и Брандмауэр) отключены, и не смогут сдержать атаку во время роуминга в случайных беспроводных подключениях за пределами дома.
Такая конфигурация не для системы, где внутренние сетевые атаки являются проблемой. Например: Многофункциональный компьютер с несколькими членами семьи и неопытными пользователями.
Это не для системы, которая обеспечивает сетевые ресурсы, такие как принтеры, Media Center, и библиотеки WMP для других компьютеров, подключенных к локальной сети. Используйте данную конфигурацию на свой собственный риск.
Она приведена здесь в качестве минимальной конфигурации служб для Вашей системы, к которой Вам следует добавлять необходимые для работы службы.

Данные конфигурации

Автоматически - службы в этом состоянии, будут запускаться при загрузке. Некоторые службы, когда больше не будут обходимы, также автоматически остановятся. Если Вы обнаружите службу, которая Вам не требуется, то установите для нее тип запуска в положение Вручную или Отключена.
Автоматически (отложенный запуск) - службы в этом состоянии, будут запущены только после загрузки. Некоторые службы, когда больше не будут обходимы, также автоматически остановятся. Если Вы обнаружите службу, которая Вам не требуется, то установите для нее тип запуска в положение Вручную или Отключена.
Вручную - ручной режим позволяет запускать службы Windows в случае необходимости. Однако, очень немногие службы, когда потребуется будут запущены в ручном режиме. Если Вы предполагаете, что Вам для работы требуется определенная служба, то установите для нее тип запуска в положение Автоматически.
Отключена - эта настройка остановит запуск службы, даже если ее запуск необходим. В оснастке "Просмотр событий" будут показаны жалобы на этот факт. Некоторые службы, пока будут отключены, будут постоянно жаловаться. Однако о данной ситуации можно позаботит© установив тип запуска для службы в положение Вручную.
Запущена - служба при любом установленном значении: Вручную или Автоматически, работает по умолчанию или запускается сразу после загрузки.
Не установлена - данная служба не установлена по умолчанию, для ее установки используйте элемент Компоненты Windows (Панель управления\Все элементы панели управления\Программы и компоненты → Включение или отключение компонентов Windows)
Не доступна - служба не примҐется в конкретной версии Windows.
Удалена - данная служба удалена при помощи окна Компоненты Windows (Панель управления\Все элементы панели управления\Программы и компоненты → Включение или отключение компонентов Windows)

По умолчанию в таблице отключено отображение конфигурации для "Windows 7 Начальная", а также для специально настроенных конфигураций: "Безопасная", "Оптимизированная", "Минимум".
Чтобы включить/отключить столбец с нужной конфигурацией Вам необходимо воспользоваться кнопкой "Показать / Скрыть столбцы" в верхнем левом углу таблицы.
Данная кнопка позволяет отобразить или спрятать указанные Вами столбцы.
Для осуществления данных действий установите или снимите флажок напротив названия столбца.
Для закрытия списка выбора столбцов, щелкните либо в любом месте затемненного прозрачного слоя, либо на саму кнопку "Показать / Скрыть столбцы".

Отображаемое имя | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Максимальная | Корпоратив | "Безопасная" | "Настроенная" | "Минимум"
BranchCache | Не доступна | Не доступна | Не доступна | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
DHCP-клиент | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
DNS-клиент | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
KtmRm для координатора распределенных транзакций | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Microsoft .NET Framework NGEN v2.0.50727_X64 Microsoft .NET Framework NGEN v2.0.50727_X86 | Вручную | Вручную | Вручную | Автоматически (Отложенный запуск, Запущена) | Вручную | Автоматически (Отложенный запуск, Запущена) | Вручную | Вручную | Вручную
Microsoft .NET Framework NGEN v4.0.30319_X64 Microsoft .NET Framework NGEN v4.0.30319_X86 | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Автоматически (Отложенный запуск), Запущена) | Не установлена (Вручную) | Не установлена (Автоматически (Отложенный запуск), Запущена) | Вручную | Вручную | Вручную
Parental Controls | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Plug and Play | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Quality Windows Audio Video Experience | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Superfetch | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Telnet | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена (Отключена) | Не установлена | Не установлена | Не установлена
Windows Audio | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Windows CardSpace | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Удалена *
Windows Driver Foundation - User-mode Driver Framework | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Windows Search | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Отключена * | Отключена * | Удалена *
WMI Performance Adapter | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Автонастройка WWAN | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Автономные файлы | Не доступна | Не доступна | Не доступна | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Отключена * | Отключена * | Отключена *
Агент защиты сетевого доступа | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Агент политики IPsec | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Адаптер прослушивателя Net.Msmq | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Адаптер прослушивателя Net.Pipe | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Адаптер прослушивателя Net.Tcp | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Адаптив регулировка яркости | Не доступна | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Архивация Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Биометрическая служба Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Брандмауэр Windows | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Браузер компьютеров | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Веб-клиент | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Виртуальный диск | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Вспомогательная служба IP | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Отключена * | Отключена * | Отключена *
Вторичный вход в систему | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Группировка сетевых участников | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Дефрагментация диска | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Диспетчер автоматических подключений удаленного доступа | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Диспетчер печати | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Диспетчер подключений удаленного доступа | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Диспетчер сеансов диспетчера окон рабочего стола | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Диспетчер удостоверения сетевых участников | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Диспетчер учетных данных | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Диспетчер учетных записей безопасности | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Доступ к HID-устройствам | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Журнал событий Windows | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Журналы и оповещения производительности | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Защита программного обеспечения | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск)
Защитник Windows | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск) | Отключена *
Защищенное хранилище | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Изоляция ключей CNG | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Инструментарий управления Windows | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Информация о совместимости приложений | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Клиент групповой политики | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Клиент для NFS | Не доступна | Не доступна | Не доступна | Не доступна | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Клиент отслеживания изменившихся связей | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Отключена * | Отключена * | Отключена *
Координатор распределенных транзакций | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Кэш шрифтов Windows Presentation Foundation 3.0.0.0 | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Удалена *
Ловушка SNMP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Локатор удаленного вызова процедур (RPC) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Маршрутизация и удаленный доступ | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена
Модули ключей IPsec для обмена ключами в Интернете и протокола IP с проверкой подлинности | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Модуль запуска процессов DCOM-сервера | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Модуль поддержки NetBIOS через TCP/IP | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Настройка сервера удаленных рабочих столов | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Немедленные подключения Windows – регистратор настройки | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Обнаружение SSDP | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Вручную
Обнаружение интерактивных служб | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Общий доступ к подключению к Интернету (ICS) | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена
Определение оборудования оболочки | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Основные службы доверенного платформенного модуля | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Очередь сообщений | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Перенаправитель портов пользовательского режима служб удаленных рабочих столов | Не доступна | Не доступна | Не доступна | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Перечислитель IP-шин PnP-X | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Питание | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Планировщик заданий | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Планировщик классов мультимедиа | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Поддержка элемента панели управления "Отчеты о проблемах и их решениях" | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Политика удаления смарт-карт | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Поставщик домашней группы | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Отключена *
Проводная автонастройка | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Программный поставщик теневого копирования (Microsoft) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Прослушиватель RIP | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Прослушиватель домашней группы | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Простые службы TCP/IP | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Протокол PNRP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Публикация ресурсов обнаружения функции | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Отключена * | Отключена *
Рабочая станция | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Распространение сертификата | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Расширяемый протокол проверки подлинности (EAP) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Сборщик событий Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Сведения о приложении | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Вручную
Сервер | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Сервер упорядочения потоков | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Сетевой вход в систему | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Сетевые подключения | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Вручную
Система событий COM+ | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Системное приложение COM+ | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Служба FTP (Майкрософт) | Не доступна | Не доступна | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба IIS Admin | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба LPD | Не доступна | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба SNMP | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба SSTP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Служба автоматического обнаружения веб-прокси WinHTTP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба автонастройки WLAN | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Служба активации Windows | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена (Вручную, Запущена) | Не установлена | Не установлена | Не установлена
Служба базовой фильтрации | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Служба ввода планшетного ПК | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба веб-публикаций | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба времени Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Служба загрузки изображений Windows (WIA) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Служба индексирования | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба инициатора Майкрософт iSCSI | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Служба интерфейса сохранения сети | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Служба кэша шрифтов Windows | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена)
Служба медиаприставки Media Center | Не доступна | Не доступна | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Удалена *
Служба модуля архивации на уровне блоков | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Служба общего доступа к портам Net.Tcp | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Отключена | Удалена *
Служба общих сетевых ресурсов проигрывателя Windows Media | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Отключена * | Отключена * | Удалена *
Служба перечислителя переносных устройств | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба планировщика Windows Media Center | Не доступна | Не доступна | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Удалена *
Служба поддержки Bluetooth | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Служба поддержки узла приложений | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Служба политики диагностики | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Отключена * | Отключена *
Служба помощника по совместимости программ | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба профилей пользователей | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Служба публикации имен компьютеров PNRP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба регистрации ошибок Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба ресивера Windows Media Center | Не доступна | Не доступна | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Удалена *
Служба сведений о подключенных сетях | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Служба состояния ASP.NET | Не доступна | Не доступна | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена | Не установлена | Не установлена
Служба списка сетей | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Вручную | Вручную
Служба технологий активации Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Служба уведомления SPP | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Служба уведомления о системных событиях | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Служба удаленного управления Windows (WS-Management) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба управления сетью | Не доступна | Не доступна | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена (Вручную) | Не установлена | Не установлена | Не установлена
Служба хранилища | Не доступна | Не доступна | Не доступна | Вручную | Не доступна | Вручную | Отключена * | Отключена * | Отключена *
Служба шифрования дисков BitLocker | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Служба шлюза уровня приложения | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Службы криптографии | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Службы удаленных рабочих столов | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Смарт-карта | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Сопоставитель конечных точек RPC | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Средство построения конечных точек Windows Audio | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Телефония | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Темы | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Отключена *
Теневое копирование тома | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Тополог канального уровня | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Триггеры очереди сообщений | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена (Автоматически, Запущена) | Не установлена | Не установлена | Не установлена
Удаленный вызов процедур (RPC) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически (Запущена) | Автоматически | Автоматически | Автоматически
Удаленный реестр | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Удостоверение приложения | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Узел системы диагностики | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Узел службы диагностики | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Отключена * | Отключена *
Узел универсальных PNP-устройств | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Управление приложениями | Не доступна | Не доступна | Не доступна | Вручную | Вручную | Вручную | Отключена * | Отключена * | Отключена *
Управление сертификатами и ключом работоспособности | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Установщик ActiveX (AxInstSV) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Установщик Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Установщик модулей Windows | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную
Факс | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Удалена *
Фоновая интеллектуальная служба передачи (BITS) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена *
Хост библиотеки счетчика производительности | Не доступна | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Хост поставщика функции обнаружения | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную (Запущена) | Вручную | Отключена * | Отключена *
Цветовая система Windows (WCS) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Центр обеспечения безопасности | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск) | Отключена *
Центр обновления Windows | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск, Запущена) | Автоматически (Отложенный запуск) | Автоматически (Отложенный запуск) | Отключена *
Шифрованная файловая система (EFS) | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Вручную | Отключена * | Отключена *
Отображаемое имя | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Максимальная | Корпоратив | "Безопасная" | "Настроенная" | "Минимум"

Изменение у службы значения "Тип запуска".

1) Откройте одним из предложенных ниже способов оснастку Службы:

1.1) Откройте Панель управления\Система и безопасность\Администрирование и запустите оснастку Службы.
1.2) Откройте Панель управления\Все элементы панели управления\Администрирование и запустите оснастку Службы.
1.3) Откройте Пуск → Администрирование → Службы.
1.4) В строке поиска меню Пуск или в окне Выполнить (Win   + R) введите services.msc и нажмите Enter ↵.
2) Откройте одним из предложенных ниже способов Свойства необходимой Вам службы:
2.1) Дважды щелкните левой кнопкой мыши на имени необходимой Вам службы.
2.2) Щелкните на необходимой Вам службе правой кнопкой мыши и выберите пункт Свойства.
3) На вкладке Общие, в ниспадающем списке напротив надписи Тип запуска установите желаемое значение.

Управление работой служб из командной строки

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Для выполнения необходимого Вам действия в соответствии с шаблоном введите требуемую команду и нажмите Enter ↵.

Запуск службы:

Установка режима запуска службы:

Используйте кавычки, если имя службы содержит пробелы.
Между знаком равенства и значением параметра должен быть пробел.
Тип запуска: auto (автоматически), demand (вручную), disabled (отключена).

Остановка службы:

Удаление службы:

Примеры:

Для установки типа запуска службы „Windows Search“ в положение отключено введите команду:

Для остановки службы „Windows Search“ введите команду:

Управление работой служб из редактора реестра

1) Запустите редактор реестра (Win   + R → regedit → OK)
2) Откройте раздел: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services.
3) Откройте подраздел необходимой Вам службы. Имя данного подраздела соответствует имени службы.
Пример: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WSearch

Для изменения значения Тип запуска установите значение DWORD-параметра Start на указанные ниже:

Значение DWORD-параметра | Тип запуска
2 | Автоматически
3 | Вручную
4 | Отключена

Чтобы установить Тип запуска в значение Автоматически (отложенный запуск) сделайте следующее:

Установите значение DWORD-параметра Start равным 2.
Создайте в подразделе необходимой Вам службы DWORD-параметр с именем DelayedAutoStart и значением равным 1.

Для изменения значения Исполняемый файл установите значение строкового (String) параметра ImagePath на указанное в таблице.
Для изменения значения Вход от имени службы установите значение строкового (String) параметра ObjectName на указанное ниже:

Значение строкового (String) параметра | Вход от имени
NT AUTHORITY\LocalService | Локальная служба
NT Authority\NetworkService | Сетевая служба
LocalSystem | Локальная система

Примечание: В случае наличия у Вас указанных ниже разделов, замените указанные выше значения для служб и в них.

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\Имя_службы
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Имя_службы

Пример:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\WSearch
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\WSearch

4) Перезагрузите компьютер после внесения изменений.

Перейти к началу раздела Настройки.


2. Быстрое отображение (скрытие) значков в области уведомлений.

Чтобы быстро изменить поведение значков уведомлений, не используя диалогового окна Значки области уведомлений, открывающегося при нажатии на ссылку Настроить....

Перетащите нужный значок из скрытой области в область уведомлений для его отображения на панели задач.
Перетащите нужный значок в скрытую область из области уведомлений для его скрытия с панели задач.

Перейти к началу раздела Настройки.


3. Изменение параметров загрузки в Windows 7 (msconfig вместо boot.ini).

Начиная с Windows Vista такого файла больше нет, но Вы можете изменить необходимые Вам для загрузки параметры используя инструмент Конфигурация системы.
Окно Конфигурация системы запускается так: Панель управления → Администрирование → Конфигурация системы → Загрузка (или нажав Win   + R → msconfig → ОК)

Данный инструмент позволяет:
- получить информацию о текущей и загружаемой по умолчанию системах;
- выбрать систему, загружаемую по умолчанию;
- удалить ненужную запись из меню загрузки.
- отредактировать время в секундах (таймаут), по истечении которого будет загружена операционная система, выбранная по умолчанию.
- включить\выключить экран приветствия(Без GUI);
- включить\выключить загрузку стандартных драйверов VGA, вместо драйверов экрана, соответствующих видеооборудованию компьютера(Базовое видео).

А через Дополнительные параметры:

- Число процессоров, используемых при загрузке.
- Максимальный объем памяти в мегабайтах, используемый для моделирования конфигурации с малым объемом памяти.

При помощи окна Конфигурация системы нельзя изменить(но это возможно, при помощи программы Bcdedit):

- наименование существующих записей;
- положение записи в меню загрузки.

Для выбора системы, загружаемой по умолчанию, выберите необходимую Вам операционную систему и нажмите кнопку «Использовать по умолчанию».
Для удаления ненужной записи выберите ее из списка и нажмите кнопку «Удалить».
Для редактирование таймаута, в нужном поле установите желаемое количество секунд.

Для применения, сделанных Вами изменений - перезагрузите компьютер.

Перейти к началу раздела Настройки.


4. Принудительная установка числа ядер, используемых при загрузке.

1) Откройте диалоговое меню Выполнить: Пуск → Выполнить(или Win   + R)
2) Введите msconfig и нажмите OK
3) Перейдите на вкладку Загрузка
4) Нажмите Дополнительные параметры
5) Поставьте флажок напротив значения Число процессоров
6) Выберите в активировавшемся ниспадающем меню число ядер Вашего процессора (По умолчанию 1)
Установка меньшего значения, чем количество ядер Вашего процессора не рекомендуется, так как система может продолжить использование указанного Вами числа ядер и после завершения загрузки.
7) Нажмите OK и перезагрузите компьютер

Перейти к началу раздела Настройки.


5. Установка временной зоны из командной строки в Windows 7.

В Windows 7 появилась новая утилита командной строки tzutil.exe, позволяющая изменять настройки временной зоны.
Для изменения временной зоны сделайте следующее:

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду:

3) Выберите необходимую Вам временную зону и введите в соответствии с ней команду.

Например, для установки значения временной зоны по Гринвичу выполните команду:

Замените значение между кавычками на необходимое Вам.
tzutil /g - отображает текущие установки временной зоны;
tzutil /? - выводит справку по работе утилиты.

Перейти к началу раздела Настройки.


6. Назначение клавиш быстрого вызова для утилиты "Ножницы".

"Ножницы" - это утилита для снятия скриншотов выделенной зоны.

Чтобы задать для данной программы клавишу быстрого вызова, сделайте следующее:

1) Откройте Пуск → Все программы → Стандартные.
2) Щелкните правой кнопкой мыши на программу "Ножницы" и выберите пункт Свойства.
3) Задайте в поле Быстрый вызов необходимую Вам комбинацию клавиш.
Изначально, для использования Вам предложат первые две клавиши Ctrl + Alt +.
Вы можете либо выбрать третью клавишу, либо задать другую комбинацию клавиш.

Перейти к началу раздела Настройки.


7. Отключение(включение) неиспользуемых компонентов Windows.

В Windows существует много дополнительных функций и компонентов. Вы можете просмотреть их и решить для себя какие из них Вы будете использовать, а какие нет. Неиспользуемые компоненты можно отключить и, тем самым, немного разгрузить использование ресурсов компьютера системой.
Для просмотра и отключения (включения) дополнительных функций и компонентов, проделайте следующие действия:

1) Откройте Панель управления
2) Откройте оснастку Программы и компоненты
3) Перейдите по ссылке слева Включение или отключение компонентов Windows
4) Просмотрите компоненты и снимите флажки с тех, которые включены, но Вами не используются

Перейти к началу раздела Настройки.


8. Изменение программы, заданной по умолчанию, для открытия определенного типа файла.

Если Вам необходимо изменить программу, с помощью которой будет открываться определенный тип файла, то Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Щелкните правой кнопкой мыши на файле с необходимым Вам расширением и выберите пункт Свойства.
2) На вкладке "Общие" напротив пункта Приложение нажмите кнопку Изменить.
3) Нажмите на стрелочку напротив Другие программы, выберите необходимую Вам программу из списка и нажмите ОК.
4) Если программа отсутствует в списке, то нажмите кнопку Обзор.
5) В окне "Открыть с помощью", откройте папку Вашей программы, выберите в ней exe-файл и нажмите кнопку Открыть, а затем кнопку ОК.

Вариант 2.

1) Щелкните правой кнопкой мыши на файле с необходимым Вам расширением и выберите одно из имеющихся у Вас пунктов.
1.1) Пункт Открыть с помощью....
1.2) Пункт Открыть с помощью → Выбрать программу... .
2) Нажмите на стрелочку напротив Другие программы, выберите необходимую Вам программу из списка и нажмите ОК.
3) Если программа отсутствует в списке, то нажмите кнопку Обзор.
4) В окне "Открыть с помощью", откройте папку Вашей программы, выберите в ней exe-файл и нажмите кнопку Открыть, а затем кнопку ОК.

Вариант 3. Для неизвестных системе файлов.

1) Щелкните правой кнопкой мыши на файле с необходимым Вам расширением и выберите пункт Открыть.
2) Установите переключатель в значение Выбор программы из списка установленных программ и нажмите кнопку ОК.
3) Выберите необходимую Вам программу из списка и нажмите ОК.
4) Если программа отсутствует в списке, то нажмите кнопку Обзор.
5) В окне "Открыть с помощью", откройте папку Вашей программы, выберите в ней exe-файл и нажмите кнопку Открыть, а затем кнопку ОК.

Вариант 4.

1) Откройте меню Пуск и выберите пункт Панель управления.
2) Установите вид просмотра Крупные значки и выберите Программы по умолчанию.
3) Щелкните на Сопоставление типов файлов или протоколов конкретным программам.
4) Выберите необходимое расширение файла и нажмите кнопку Изменить программу.
5) Нажмите на стрелочку напротив Другие программы, выберите необходимую Вам программу из списка и нажмите ОК.
6) Если программа отсутствует в списке, то нажмите кнопку Обзор.
7) В окне "Открыть с помощью", откройте папку Вашей программы, выберите в ней exe-файл и нажмите кнопку Открыть, а затем кнопку ОК.

Вариант 5.

1) Скачайте архив DefaultProgramsEditor.zip и распакуйте его в любую папку.
2) Щелкните правой кнопкой мыши на файл "Default Programs Editor.exe" и выберите пункт Запуск от имени администратора.
3) Нажмите File Type Settings → Context Menu
4) Выберите необходимое расширение файла и нажмите кнопку Next.
5) Выделите пункт Open или Edit (при отсутствии Open) и нажмите кнопку Edit Selected Command.
6) Нажмите на кнопку Browse рядом с полем Program path.
7) Откройте папку программы, используемой для открытия файлов данного типа, выберите exe-файл и нажмите кнопку Открыть.

8) При желании, Вы также можете выбрать значок для типа файла:
8.1) Нажмите на кнопку Browse рядом с полем Item icon.
8.2) Нажмите на кнопку Обзор...
8.3) Выберите иконку(.ico) или файл содержащий значки(.dll, .exe) и нажмите кнопку Открыть.
8.4) Выберите изображение иконки и нажмите ОК.

9) Нажмите кнопку Next, затем кнопку Save Context Menu, а после ОК и Close.

Перейти к началу раздела Настройки.


9. Отключение всплывающих подсказок.

Отключить всплывающие подсказки можно используя Редактор локальной групповой политики.

1) Нажмите Пуск, в поле поиска напишите gpedit.msc и нажмите ОК.
2) Перейдите в раздел Конфигурация пользователя → Административные шаблоны → Меню Пуск и Панель задач.
3) Откройте параметр "Удалить всплывающие подсказки яў элементов главного меню",
4) Установите переключатель в значение Включить и нажмите ОК.

Перейти к началу раздела Настройки.


10. Изменение функции кнопки питания на корпусе вашего компьютера.

По умолчанию кнопка выключения компьютера в Windows 7 находится в состоянии "Завершение работы". Если вы перезагружаете компьютер по несколько раз в день, Вам наверное было бы удобнее переключить кнопку выключения в состояние "Перезагрузка". Для этого выполните следующие действия:

1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт меню Свойства.
2) Перейдите на вкладку Меню "Пуск".
3) Переключите значение “Действие кнопки питания” в состояние "Перезагрузка". Также Вы можете выбрать функции "Блокировка", "Смена пользователя" и "Завершение сеанса".

Перейти к началу раздела Настройки.


11. Быстрый переход к часто используемой папке.

Если вы часто работаете с какими-то 4-мя — 5-ю папками, то их можно быстро прикрепить к кнопке Проводника на панели задач. Удерживая кнопку мыши, перетащите папку на панель задач, и она автоматически будет помещена в «Закреплено» кнопки Проводника.

Перейти к началу раздела Настройки.


12. Редактирование меню загрузки операционных систем при помощи Bcdedit.

bcdedit - инструмент, позволяющий изменить значения загрузчика Windows, а также произвести его(загрузчика) восстановление.
Чтобы увидеть предлагаемые системой для изменения параметры: запустите командную строку от имени администратора
(В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵), наберите в ней bcdedit и нажмите Enter ↵.
Все команды, приведенные в данном варианте, необходимо будет запускать в командной строке, запущенной от имени администратора. Также данные команды могут выполняются в командной строке среды восстановления или в командной строке MSDaRT (ранее ERD Commander).

Некоторые значения параметров BCD записаны в фигурных скобках – {}. Это идентификаторы – {CLSID}. Любой идентификатор имеет буквенно-цифровой код вида {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}. Стандартные идентификаторы имеют названия, например: {default}, {bootmgr}, {ntldr} и так далее.

Наиболее интересующими нас компонентами являются:

идентификатор – CLSID той или иной записи;
device – показывает раздел, на котором расположены файлы загрузки (это может быть операционная система или папка BOOT);
osdevice – показывает раздел, на котором расположены системные файлы операционной системы. Обычно, значения параметров device и osdevice равны;
path – если device определял раздел диска, который содержит файлы операционной системы, то этот параметр определяет остальной путь к загрузчику операционной системы;
default – показывает ID операционной системы, загружаемой по умолчанию, если операционная система, в которой запустили командную строку, загружается по умолчанию, параметру default присваивается значение {current};
displayorder – показывает порядок, в котором расположены записи о загружаемых системах;
timeout – таймаут(время - по истечении которого будет загружена операционная система), значение показано и устанавливается в секундах;
locale – указывает язык загрузочного меню или меню дополнительных параметров загрузки;
description – показывает название операционной системы, отображающееся в меню загрузки.

Внимание: Если в выполняемой Вами команде, с использованием программы bcdedit.exe, отсутствует параметр /set с дальнейшим указанием идентификатора, то внесенные Вами изменения будут добавлены в Диспетчер загрузки Windows (Windows Boot Manager), а не в Загрузка Windows (Windows Boot Loader)

Перед тем, как начнете вносить необходимые Вам изменения, создайте резервную копию загрузчика. Для этого, создайте на любом диске папку с названием BCDREZ и выполните следующую команду:

где X - буква диска, на котором находится папка BCDREZ.

Если Вы решите вернуть все сделанные Вами изменения к начальным настройкам, то выполните следующую команду:

Для дальнейших примеров, предположим, что наше меню загрузки содержит три записи с идентификаторами {ID1}, {ID2}, {ID3}.

Изменение системы, загружаемой по умолчанию

Введите параметр /default и {ID} той системы, которую Вы хотите загружать по умолчанию. Например, для системы с {ID2} команда:

Данная команда не перемещает запись о системе, загружаемой по умолчанию, на верхнюю строчку меню загрузки.

Изменение расположения записей в меню загрузки

1) Перемещение выбранной записи вверх списка:

2) Перемещение выбранной записи вниз списка:

3) Формирование меню в выбранном порядке:

Изменение таймаута

где XX – время в секундах.

Изменение языка диспетчера загрузки

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение языка меню дополнительных вариантов загрузки

В связи с тем, что программа восстановления запуска, выполняющаяся из среды восстановления, использует параметры "по-умолчанию", меню дополнительных вариантов загрузки, которое появляется при нажатииF8 после наведения на строку меню с нужной операционной системой, может стать англоязычным. Вернуть необходимый Вам язык, можно выполнив следующую команду:

где ln-LN – выбранное обозначение языка. Для русского – это ru-RU, для английского – en-US и т.д.

Изменение названия загружаемой системы

После использования среды восстановления, в названии операционной системы появляется надпись - (восстановлено).
Вы также можете исправить значение "Предыдущая версия Windows" на более удобное Вам "Windows XP" или добавить версию и разрядность к текущей(используемой по умолчанию) версии Windows.
Вы можете изменить это указанной ниже командой:

Например:

Изменение буквы раздела, на котором расположена папка операционной системы и ее загрузочные файлы

где X – буква раздела жесткого диска. Обычно значения device и osdevice совпадают.

Добавление новой операционной системы (Windows Vista или Windows 7) в загрузчик.

1) Скопируйте существующую запись текущей системы с новым названием:

2) Дождитесь сообщение «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
3) Измените значения параметров device и osdevice на соответствующие добавляемой операционной системе.

где X – буква диска, на котором находится операционная система. Вместо крестиков, введите значение {ID}, полученное после успешного окончания копирования.
4) Выполните команду, добавляющую новую запись в диспетчер загрузки:

Запись будет добавлена внизу существующего списка.

Удаление записи загрузки системы из BCD и диспетчера загрузки.

Удаление записи об установленной операционной системе из BCD и диспетчера загрузки выполняется с помощью команды bcdedit /delete {ID}.
Есть особенность выполнения команды: если в качестве ID указывается известная запись, например {ntldr}, то команда должна выполняться с ключом /f:

Если же ID записывается в буквенно-цифровом коде, ключ /f не нужен.

В случае отсутствия одного из файлов, необходимых для работы с загрузчиком, Вы можете скачать архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe; Bootrec.exe)

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Перейти к началу раздела Настройки.


13. Установка пользовательского разрешения экрана.

У некоторых мониторов разрешение экрана может не соответствовать ни одному из предлагаемых Windows.

Если у Вас установлена видеокарта Nvidia Вы можете добавить своё разрешение экрана одним из указанных способов:

Способ 1.

1) Запустить Панель управления Nvidia.
2) Открыть Дисплей → Изменение разрешения → Добавить разрешения... → Создать пользовательское разрешение
3) Задать нужные Вам параметры, протестировать их и добавить его в список для выбора
4) Выбрать его и использовать.

Способ 2.

Используя реестр добавить нужное Вам разрешение в параметр NV_Modes

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{some number}\0000

Также можете найти другие ветки содержащие параметр NV_Modes и также добавить в них необходимое Вам разрешение экрана.

Способ 3. Перед установкой драйвера.

Откройте файл "nv_disp.inf" в папке C:\NVIDIA\Win7\xxx.xx и найдите значение [nv_commonDisplayModes_addreg]
Под ним в NV_Modes будут все доступные разрешения экрана, добавьте туда свое.

Но бывает что даже после указанных выше манипЈций, новое разрешение не хочет добавляться. В таком случае, для принудительного добавления пользовательского разрешения Вам придется использовать специальные программы. Рекомендую поискать в интернете следующие программы:

PowerStrip - Программа управления параметрами видеоподсистемы вашего компьютера, поддерживается огромное разнообразие видео карт. Это - фактически единственная программа своего рода, которая поддерживает видео карты из многочисленного набора чипсетов и поставщиков, одновременно, под любой операционной системой. Программа спокойно сидит в трее и оттуда обеспечивает доступ к более 500 элементов управления над вашими дисплейными аппаратными средствами, включая цветные инструментальные средства коррекции, установки уровня периода экранной геометрии, и драйверо-независимыми элементами управления часов.

Screen Resolution Manager - Программа, позволяющая каждому пользователю компьютера устанавливать свое разрешение экрана. Помимо разрешения можно настроить глубину цвета, частоту, яркость и контрастность, цветовую гамму и другие настройки, которые автоматически вступят в силу после загрузки профиля определенного пользователя.

Перейти к началу раздела Настройки.


14. Создание диска восстановления системы и загрузка с него.

Если у вас есть установочный диск Windows 7, создавать диск восстановления необязательно. Если же установочного диска у вас нет, создать диск восстановления нужно обязательно - он вам рано или поздно пригодится. С установочного диска можно загрузит© в среду восстановления Windows RE.

Создание диска восстановления системы

1) Вставьте чистый компакт-диск в привод.
2) Откройте Пуск → Панель Управления → Архивация и восстановление (Backup and Restore)
3) В левой панели щелкните ссылку Создать диск восстановления системы.

Загрузка с диска восстановления системы

1) Вставьте диск восстановления в привод и перезагрузитесь
2) В BIOS должен быть установлен приоритет загрузки с привода. Будет выполнена загрузка в Windows RE.
3) Выберите систему, которую вы хотите восстановить.
4) Установите переключатель Используйте средства восстановления... и нажмите кнопку Далее. Вы увидите окно с вариантами восстановления.

Перейти к началу раздела Настройки.


15. Изменение строки в загрузочном меню Windows 7 с "Предыдущая версия Windows" на "Windows ХР".

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Выполните следующие команды, нажимая после введения каждой Enter ↵.

Перейти к началу раздела Настройки.


16. Перенесение файлов загрузки, при удалении из системы одного из жестких дисков.

Вы решили заменить или продать один из ваших жестких дисков. Прежде чем это сделать, убедитесь что файлы загрузки Windows 7 не содержаться на удаляемом Вами из системы жестком диске.
Windows 7 хранит свои файлы для загрузки на активном диске, который может отличаться от того на котором установлена Windows 7. Файлами загрузки яў Windows 7 являются файл bootmgr и хранилище данных конфигурации загрузки BCD (Boot Configuration Data), находящееся в скрытой и системной папке Boot.

При загрузке Windows 7 проверяет соблюдение 3 условий:

- Является ли диск, с которого выполняется загрузка активным;
- Совместима ли Главная Загрузочная Запись (Master Boot Record - MBR) с bootmgr (Диспетчером загрузки Windows);
- Находит© ли файлы загрузки операционной системы на активном диске должны.

В случае не соблюдения одного из условий, загрузка становится невозможной.

Предположим, что Ваша Windows 7 установлена на диск С:, который не активен. Активным является только диск D:, который Вы собираетесь удалить из системы и на котором находятся Файлы загрузки Windows 7, имеющие атрибуты Скрытый и Системный.

В качестве решения предлагаю Вам выполнить перенесение файлов загрузки Windows 7 с активного раздела (удаляемый жесткий диск) на неактивный раздел (остающийся в системе жесткий диск, с присвоением ему атрибута - Активный).

1) Выяснение атрибутов дисков и присвоение остающемуся в системе жесткому диску атрибута Активный.

Способ 1. Используя оснастку "Управление дисками".

1.1.1) Нажмите Win   + R, в строке "Выполнить" наберите diskmgmt.msc и нажмите OK
1.1.2) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7
Буква тома здесь, идентична букве диска с Window 7 из Мой Компьютер.
1.1.3) Под буквой тома, размером диска и файловой системой будут указаны атрибуты диска. Посмотрите имеет ли наш том атрибут "Активный".
Если да, то Вы сможете спокойно удалить Ваш диск из системы. Если же нет, то Вам необходимо будет присвоить данный атрибут, в соответствии с написанным ниже.
1.1.4) Если Ваша Windows 7 установлена на жесткий диск, разбитый на несколько разделов, то выберите первый слева раздел остающегося у Вас диска, его мы сделаем загрузочным и активным. Если же раздел всего один, то выберите его.
1.1.5) Щелкните правой кнопкой мыши по выбранному разделу и выберите в контекстном меню пункт "Сделать раздел активным". Учтите, что этот раздел должен иметь атрибут "Основной".

Способ 2. Используя командную строку.

1.2.1) Запустите командную строку с правами администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
1.2.2) Последовательно выполните все команды без выхода из командной строки:

где X - номер диска, который предполагается оставить, в списке дисков (команда list disk).

2) Перезапись загрузочного сектора MBR и установка его совместимости с bootmgr:

2.1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe; Bootrec.exe).
2.2) Создайте папку Boot.
2.3) Распакуйте скачанный архив и скопируйте файлы нужной Вам битности в созданную Вами папку Boot.
2.4) Запустите командную строку с правами администратора.

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /force - принудительно отключает один или несколько томов во время обновления загрузочного кода. Необходим, при наличии в конфигурации 2-х и более жестких дисков.

3) Перенесение BCD (Boot Configuration Data) и файла bootmgr на новый активный раздел:

где Х - буква диска, на котором содержится программа Bootsect.exe
- ключ /l - выбор языковых параметров менеджера загрузки. Если ваша система не русскоязычная, используйте другие значения этого ключа, например, для английского языка - en-US, для немецкого - de-DE, и т.д.
- ключ /s - определяет букву тома, назначенную целевому системному разделу, в который копируются файлы среды загрузки. Это раздел, который мы сделали активным. Windows 7 использует текущий загрузочный раздел (в нашем случае - раздел D:) до завершения своей работы. Поэтому применение этого ключа с указанием буквы нового загрузочного раздела (в нашем случае - раздел С:) - обязательно.

Перейти к началу раздела Настройки.


17. Способы доступа к элементам Панели управления.

В разных статьях Вы можете увидеть разное описание пути к одинаковым элементам Панели управления. Такое происходит потому что в Windows существует два вида отображения элементов: Категория(элементы сгруппированы по тематикам) и Крупные или Мелкие значки (элементы отображаются полным списком) Имхо, наиболее удобным является Крупные или Мелкие значки(их полный список).

Существует несколько способов доступа к элементам Панели управления:

1) Через меню Пуск.

Для быстрого доступа к элементам Панели управления, рекомендуется добавить в меню Пуск всплывающее меню содержащее все элементы Панели Управления.
1.1) Нажмите правой кнопкой мыши на кнопке Пуск и щелкните на пункте Свойства.
1.2) Нажмите Настроить...
1.3) Промотайте до записи Панель управления.
1.4) Установите значение переключателя под ней в положение Отображать как меню и нажмите OK
Всплывающее меню Панели управления будет отображаться полным списком, независимо от Вашего выбора вида отображения.

2) Через Проводник Windows.

2.1) Запустите Проводник
2.2) В панели меню выберите Сервис и нажмите Параметры папок
2.3) Под надписью Область переходов установите флажок напротив значения Показать все папки и нажмите OK
Теперь Панель управления будет доступна в Проводнике в Области переходов слева. Преимущество данного способа в том что Вы можете работать, как сразу с полным списком элементов: Проводник → Панель управления → Все элементы панели управления, так и с отдельными разделами: Проводник → Панель управления → Нужный Вам раздел.

3) На рабочем столе.

3.1) Щелкните правой кнопкой мыши на Рабочем столе и нажмите Персонализация
3.2) Щелкните Изменение значков рабочего стола
3.3) Установите флажок напротив Панель управления и нажмите ОК
На Рабочем столе появится ярлык запускающий папку Панель управления. Способ отображения зависит от выбранного Вами значения параметра Просмотр.

4) Запуск папки Панель управления используя {GUID}

Для её запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win   + R) и введите команду:

shell:::{26EE0668-A00A-44D7-9371-BEB064C98683}

5) Запуск элементов Панели управления, используя канонические имена.

Русское название элемента | Английское название элемента | Команда
Панель управления | Control Panel | control
Windows CardSpace | Windows CardSpace | control /name Microsoft.CardSpace
Windows SideShow | Windows SideShow | control /name Microsoft.WindowsSideShow
Автозапуск | AutoPlay | control /name Microsoft.AutoPlay
Автономные файлы | Offline Files | control /name Microsoft.OfflineFiles
Администрирование | Administrative Tools | control /name Microsoft.AdministrativeTools
Архивация и восстановление | Backup and Restore | control /name Microsoft.BackupAndRestore
Биометрические устройства | Biometric Devices | control /name Microsoft.BiometricDevices
Брандмауэр Windows | Windows Firewall | control /name Microsoft.WindowsFirewall
Восстановление | Recovery | control /name Microsoft.Recovery
Гаджеты рабочего стола | Desktop Gadgets | control /name Microsoft.DesktopGadgets
Дата и Время | Date and Time | control /name Microsoft.DateAndTime
Датчик расположения и другие датчики | Location and Other Sensors | control /name Microsoft.LocationAndOtherSensors
Диспетчер устройств | Device Manager | control /name Microsoft.DeviceManager
Диспетчер учетных данных | Credential Manager | control /name Microsoft.CredentialManager
Домашняя группа | HomeGroup | control /name Microsoft.HomeGroup
Защитник Windows | Windows Defender | control /name Microsoft.WindowsDefender
Звук | Sound | control /name Microsoft.Sound
Значки области уведомлений | Notification Area Icons | control /name Microsoft.NotificationAreaIcons
Игровые устройства | Game Controllers | control /name Microsoft.GameControllers
Инициатор iSCSI | iSCSI Initiator | control /name Microsoft.iSCSIInitiator
Инфракрасная связь | Infrared | control /name Microsoft.Infrared
Клавиатура | Keyboard | control /name Microsoft.Keyboard
Мышь | Mouse | control /name Microsoft.Mouse
Панель задач и меню "Пуск" | Taskbar and Start Menu | control /name Microsoft.TaskbarAndStartMenu
Папка "Fonts" | Fonts Folder | control /name Microsoft.Fonts
Параметры индексирования | Indexing Options | control /name Microsoft.IndexingOptions
Параметры папок | Folder Options | control /name Microsoft.FolderOptions
Параметры планшетного компьютера | Tablet PC Settings | control /name Microsoft.TabletPCSettings
Перо и сенсорные устройства | Pen and Touch | control /name Microsoft.PenAndTouch
Персонализация | Personalization | control /name Microsoft.Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | RemoteApp and Desktop Connections | control /name Microsoft.RemoteAppAndDesktopConnections
Получение программ | Get Programs | control /name Microsoft.GetPrograms
Приступая к работе | Getting Started | control /name Microsoft.GettingStarted
Программы и компоненты | Programs and Features | control /name Microsoft.ProgramsAndFeatures
Программы по умолчанию | Default Programs | control /name Microsoft.DefaultPrograms
Распознавание речи | Speech Recognition | control /name Microsoft.SpeechRecognition
Расположение по умолчанию | Default Location | control /name Microsoft.DefaultLocation
Родительский контроль | Parental Controls | control /name Microsoft.ParentalControls
Свойства обозревателя | Internet Options | control /name Microsoft.InternetOptions
Свойства речи | Text to Speech | control /name Microsoft.TextToSpeech
Система | System | control /name Microsoft.System
Сканеры и камеры | Scanners and Cameras | control /name Microsoft.ScannersAndCameras
Соседние пользователи | People Near Me | control /name Microsoft.PeopleNearMe
Счетчики и средства производительности | Performance Information and Tools | control /name Microsoft.PerformanceInformationAndTools
Телефон и модем | Phone and Modem | control /name Microsoft.PhoneAndModem
Управление цветом | Color Management | control /name Microsoft.ColorManagement
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control /name Microsoft.DevicesAndPrinters
Учетные записи пользователей | User Accounts | control /name Microsoft.UserAccounts
Центр мобильности Windows | Windows Mobility Center | control /name Microsoft.MobilityCenter
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | control /name Microsoft.ActionCenter
Центр синхронизации | Sync Center | control /name Microsoft.SyncCenter
Центр специальных возможностей | Ease of Access Center | control /name Microsoft.EaseOfAccessCenter
Центр управления сетями и общим доступом | Network and Sharing Center | control /name Microsoft.NetworkAndSharingCenter
Шифрование диска BitLocker | BitLocker Drive Encryption | control /name Microsoft.BitLockerDriveEncryption
Экран (размер текста) | Display (size of text) | control /name Microsoft.Display
Электропитание | Power Options | control /name Microsoft.PowerOptions
Язык и региональные стандарты | Region and Language | control /name Microsoft.RegionAndLanguage
Русское название элемента | Английское название элемента | Команда

При отсутствии в системе необходимого устройства, драйверов или определенных компонентов, соответствующий ему элемент Панели управления может не запустит©.

Перейти к началу раздела Настройки.


18. Отключение залипания клавиш, озвучивания данного действия и озвучивания нажатия клавиши CAPS LOCK, NUM LOCK, или SCROLL LOCK.

Чтобы отключить озвучивание перекдючений клавиш клавиатуры, а также залипание клавиш выполните указанные ниже действия.

1) Откройте Пуск → Панель управления → Центр специальных возможностей.
2) Нажмите на ссылку Облегчение работы с клавиатурой.
3) В разделе Упростить набор текста снимите указанные ниже флажки и нажмите кнопку Применить:

Включить озвучивание переключений
Включить озвучивание переключений путем нажатия и удерживания клавиши NUM LOCK в течение 5 секунд.

4) Нажмите на ссылку Настройка залипания клавиш.
5) Снимите все флажки в открывшемся окне и нажмите кнопку ОК.
6) Закройте окно Облегчение работы с клавиатурой.

Перейти к началу раздела Настройки.


19. Добавление своей программы в утилиту msconfig (Конфигурация системы).

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните с именем mscfgtlc.xml
3) Скопируйте файл в папку C:\Windows\system32\

Например:

или

Добавленная Вами программа появится во вкладке Сервис (Tools).
Для использования русских букв файл необходимо сохранить файл в кодировке UTF-8.
В качестве пути можно указать только файлы из папок Windows или Program Files включая подпапки.

Перейти к началу раздела Настройки.


20. Настройка параметров индексирования для ускорения выполнения поиска в системе.

Операционная система Windows использует индекс для выполнения быстрого поиска наиболее часто используемых файлов. По умолчанию индексируются все самые распространенные файлы на компьютере. Повысить производительность поиска в Windows 7 можно, следующим образом.

Добавление или удаление расположения из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter ↵.
2) Щелкните Изменить.
3) Установите или снимите флажок с папок в списке Изменение выбранных расположений, которые Вы желаете добавить или удалить для ускорения поиска, а затем нажмите кнопку ОК.
4) Если в списке отображаются не все расположения на компьютере, нажмите кнопку Показать все расположения. (Если в списке отображаются все расположения на компьютере, кнопка Показать все расположения недоступна.) Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
5) Если требуется добавить папку, исключая некоторые вложенные папки, щелкните папку и затем снимите флажки рядом с теми вложенными папками, которые не требуется индексировать. Эти папки будут отображены в столбце «Исключить» в разделе Сводный список выбранных расположений.

Индексировать все файлы на компьютере не рекомендуется, так как если сделать индекс слишком большим или добавить в индекс расположения системных файлов (например, папки «Program Files»), поиск будет выполняться медленно.

Добавление или удаление типа файла из индекса.

1) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter ↵.
2) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
3) Перейдите на вкладку Типы файлов.
4) Снимите флажок с расширений в списке, которые Вы желаете удалить для ускорения поиска.
5) В поле Добавить новое расширение введите расширение имени файла, которые Вы желаете добавить для ускорения поиска, а затем нажмите кнопку Добавить.
6) Установите переключатель в значение Индексировать только свойства при большом количестве выделенных расширений или Индексировать свойства и содержимое файлов при небольшом, а затем нажмите кнопку ОК.

Перейти к началу раздела Настройки.


21. Выполнение задачи (запуск программы) после выхода из спящего режима или гибернации.

Чтобы запустить какую-либо программу при выходе из гибернации Вам придется воспользоваться планировщиком заданий.
При выходе системы из спящего режима или гибернации Windows 7 записывает событие с номером 300 в один из журналов событий.
Вы можете посмотреть это в оснастке Просмотр событий (Win   + R → eventvwr.msc → ОК) открыв: Журналов приложений и служб → Microsoft → Windows → Diagnostics-Performance
Использовав данный факт Вы сможете создать необходимую Вам задачу. Для ее создания выполните указанные ниже действия:

1) В строке поиска меню Пуск введите: план и выберите в найденном Планировщик заданий.
2) В правой панели планировщика щелкните Создать простую задачу.
3) Введите имя задачи и нажмите Далее.
4) На странице Триггер задачи установите переключатель в значение При занесении в журнал указанного события и нажмите кнопку Далее.
5) На странице При записи определенного события в журнал укажите нижеследующие значения для параметров и нажмите кнопку Далее.

Журнал: Microsoft-Windows-Diagnostics-Performance
Источник: Diagnostics-Performance
Код события: 300

6) На странице Действие установите переключатель в значение Запустить программу и нажмите кнопку Далее.
7) На странице Запуск программы укажите путь к Вашей программе и дополнительные параметры, если необходимо.

Например, для установки VPN-подключения введите в поле Программа или сценарий:команду rasdial "имя подключения" login password
вместо "имя подключения" - укажите название Вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету

8) Если откроется окно информирующее о том, что Вы включили аргументы в текстовое поле "Программы", то нажмите кнопку Да
9) На странице Сводка нажмите кнопку Готово.
10) Дважды щелкните на созданную Вами задачу в списке, чтобы открыть ее Свойства
11) Перейдите на вкладку Параметры
12) Поставьте флажки напротив:

Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.

13) Уберите флажок Останавливать задачу выполняемую дольше .
14) Если у Вас ноутбук, то перейдите на вкладку Условия и снимите флажок Запускать только при питании от электросети
15) Нажмите кнопку ОК для принятия внесенных изменений.

Перейти к началу раздела Настройки.


22. Автоматическая очистка журнала недавно открывавшихся документов при выходе из системы.

Если Вам необходимо при выходе из Windows очистить историю папки «Недавние документы», то Вы можете сделать это воспользовавшись одним из предложенных ниже решений.

Вариант 1. Автоматически, используя оснастку Редактор локальной групповой политики.

1) В строке поиска меню Пуск введите gpedit.msc и нажмите Enter ↵.
2) Перейдите с следующую папку: Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач.
3) Щелкните дважды на пункт Очищать журнал недавно открывавшихся документов при выходе или щелкните правой кнопкой мыши на нем и выберите Изменить.
4) Установите переключатель в значение Включить и нажмите кнопку ОК.
5) Перезагрузите компьютер.

Вариант 2. Автоматически, используя редактор реестра.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте Dword-параметр ClearRecentDocsOnExit и установите его значение равным 1.
4) Перезагрузите компьютер.

Перейти к началу раздела Настройки.


23. Отключение автоматической загрузки процесса sidebar.exe (Гаджеты рабочего стола Windows).

Вариант 1.

1) Откройте Пуск → Панель управления → Программы и компоненты.
2) В списке слева нажмите Включение или отключение компонентов Windows.
3) Cнимите флажок Платформа гаджетов Windows и нажмите OK.
4) Перезагрузите компьютер.

Вариант 2.

1) В строке поиска меню Пуск, введите gpedit.msc и нажмите Enter ↵.
2) В меню слева перейдите Политика «Локальный компьютер» → Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Гаджеты рабочего стола
3) Дважды щелкните на параметр Отключить гаджеты рабочего стола или нажмите на нем правой кнопкой мыши и выберите пункт Изменить.
4) Установите переключатель в значение Включить и нажмите OK.
5) Перезагрузите компьютер.

Вариант 3.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте Dword-параметр TurnOffSidebar и установите его значение равным 1.
4) Проверьте присутствует ли в одном из указанных ниже разделов, отвечающих за автозагрузку параметр Sidebar. В случае его обнаружения - удалите его.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

5) Перезагрузите компьютер.

Перейти к началу раздела Настройки.


24. Удаление компонента Windows Media Center или отключение его автозапуска.

Вариант 1. Удаление компонента Windows Media Center из системы.

1) Откройте Пуск → Панель управления → Программы и компоненты.
2) В списке слева нажмите Включение или отключение компонентов Windows.
3) В группе Компоненты для работы с мультимедиа снимите флажок Windows Media Center.
4) Перезагрузите компьютер.

Вариант 2. Отключение автозапуска Windows Media Center.

1) Запустите Windows Media Center
2) Перейтите в меню Задачи → Настройка → Общие → Запуск и Поведение
3) Снимите флажок Запускать Windows Media Center при запуске Windows и нажмите Сохранить
4) Откройте Пуск → Панель Управления → Администрирование и запустите Службы (services.msc)
5) Установите Тип запуска для указанных ниже служб в значение Вручную или Отключена.
Для изменения значения параметра дважды щелкните по необходимой Вам службе или щелкните на ней правой кнопкой мыши и выберите пункт Свойства.

Служба медиаприставки Media Center
Служба планировщика Windows Media Center
Служба ресивера Windows Media Center

6) Запустите Редактор реестра (Win   + R → regedit → ОК)
7) Удалите параметр ehTray из разделов реестра отвечающих за автозапуск:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

6) Перезагрузите компьютер.

Перейти к началу раздела Настройки.


25. Отключение индексирования файлов для ускорения работы Windows.

Если Вы редко используете поиск файлов на компьютере, то Вы можете добавить быстродействия своей операционной системе, отключив индексирование файлов.
Хотя это и немного замедлит поиск, зато освободит процессорное время и виртуальную память системы.
Для отключения индексирования файлов выполните следующие действия.

1) Откройте Панель управления → Администрирование и запустите Службы (Win   + R → services.msc → ОК)
2) Щелкните дважды на службе Windows Search.
3) Установите тип запуска в значение Отключена и нажмите кнопку ОК.
4) В меню Пуск щелкните правой кнопкой мыши на папку Компьютер и нажмите Открыть.
5) Щелкните правой кнопкой мыши на жестком диске и выберите пункт Свойства.
6) Уберите флажок Разрешить индексировать содержимое файлов на этом диске в дополнение к свойствам файлов и нажмите кнопку ОК.
7) Установите переключатель в значение К диску X:\ и ко всем вложенным папкам и файлам (X:\ - буква Вашего жесткого диска) и нажмите кнопку ОК.
8) Если всплывет окно Отказано в доступе нажмите Продолжить, если всплывет окно Ошибка изменения атрибутов, то выберите пункт Пропустить все.
9) Перезагрузите компьютер.

Перейти к началу раздела Настройки.


26. Изменение времени затрачиваемого на автоматический выбор пункта из списка загрузок.

Если Вы желаете уменьшить или увеличить количество времени затрачиваемого на автоматический выбор пункта из списка загрузок, то воспользуйтесь указанным ниже решением.

1.1) Откройте меню Пуск, щелкните правой кнопкой кнопкой мыши на Компьютер и выберите пункт Свойства.

или

1.2) Откройте Пуск → Панель управления → Система.

2) Нажмите на ссылку Дополнительные параметры системы.
3) В разделе Загрузка и восстановление нажмите кнопку Параметры.
4) Установите флажок напротив пункта Отображать список операционных систем, если он не установлен.
5) Введите необходимое Вам значение в секундах от 1 до 999 и нажмите кнопку ОК.

Перейти к началу раздела Настройки.


27. Просмотр списка устройств, которым разрешено выводить компьютер из ждущего режима, а также разрешение и запрет выполнения данного действия.

Чтобы показать список, каким устройствам разрешено выводить Ваш компьютер из ждущего, выполните указанные ниже действия.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды и нажмите Enter ↵.

Чтобы запретить какому-либо устройству выводить Ваш компьютер из ждущего, выполните указанные ниже действия.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды и нажмите Enter ↵.

где, имя устройства - полное имя устройства, из списка полученного с помощью команды powercfg -devicequery wake_armed или указанное в Диспетчере устройств.

Чтобы разрешить какому-либо устройству выводить Ваш компьютер из ждущего, выполните указанные ниже действия.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды и нажмите Enter ↵.

где, имя устройства - полное имя устройства, из списка полученного с помощью команды powercfg -devicequery wake_armed или указанное в Диспетчере устройств.

Перейти к началу раздела Настройки.


28. Изменение количества используемых ядер процессора и приоритета для запущенного приложения.

Если Вы запустите несколько копий одной программы одновременно для выполнения одинаковых действий (Например, расшифровка забытого Вами пароля для файла), то нагрузка на ядра процессора может быть неправильной.
Чтобы равномерно распределить загрузки на все ядра процессора, рекомендуется для каждого процесса запущенной программы, указать используемые ядра процессора вручную.

Для осуществление этого, выполните указанные ниже действия.

1) Откройте Диспетчер задач Windows, для этого одновременно нажмите Ctrl + ⇑ Shift + Esc
2) Перейдите на вкладку Процессы.
3) В главном меню выберите Вид → Выбрать столбцы... установите флажок напротив пункта Путь к образу и нажмите кнопку ОК.
Это позволит Вам легче найти, необходимый процесс программы, учитывая ее месторасположение.
4) Нажмите правой кнопкой мыши на процесс, соответствующий запущенной программе и выберите пункт Задать соответствие.
5) Установите флажки напротив ядер процессора, которые Вы желаете использовать для данной копии программы и нажмите кнопку ОК.
6) Перейдите к следующей копии процесса запущенной программы и повторите действия указанные в пунктах 4) и 5).

Если кроме программы с которой Вы работаете запущенны одновременно другие программы, которые Вам менее необходимы на данный момент, то Вы можете изменить для них приоритет на более низкий.

Для осуществление этого, выполните указанные ниже действия.

1) Откройте Диспетчер задач Windows, для этого одновременно нажмите Ctrl + ⇑ Shift + Esc
2) Перейдите на вкладку Процессы.
3) В главном меню выберите Вид → Выбрать столбцы... установите флажок напротив пункта Путь к образу и нажмите кнопку ОК.
Это позволит Вам легче найти, необходимый процесс программы, учитывая ее месторасположение.
4) Нажмите правой кнопкой мыши на процесс, соответствующий запущенной программе и выберите пункт Приоритет.
5) Из всплывающего списка выберите пункт Низкий или Ниже среднего.
6) После окончания работы с основной программой рекомендуется вернуть значение приоритета для дополнительных программ в изначальное.

Перейти к началу раздела Настройки.


1. Общие рекомендации для восстановления работоспособности системы.

1. Общие рекомендации для устранения неполадок и восстановления работоспособности системы.

Перед тем, как попытаться найти решение для какой-либо проблемы в системе, воспользуйтесь общими рекомендациями для восстановления работоспособности системы.

Вариант 1. Использование точки восстановления.

Используйте данный вариант для возврата системных файлов и параметров к состоянию на определенный момент времени.
В процессе восстановления будут удалены все программы и драйверы, которые были установлены в систему, после выбранной Вами точки восстановления.
Ваши документы (текстовые файлы, рисунки и т.п.) восстановлением затронуты не будут.

1) Нажмите кнопку Пуск.
2.1) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства
или
2.2) В адресной строке Проводника введите Панель управления\Система и безопасность\Система и нажмите Enter ↵.
3) Слева нажмите ссылку Защита системы.
4) В открывшемся окне нажмите кнопку Восстановление.
5) Нажмите кнопку Далее.
6) Установите флажок "Показать другие точки восстановления".
7) Выберите желаемую точку восстановления из списка и нажмите кнопку Далее.
8) Нажмите кнопку "Поиск затрагиваемых программ" для уточнения какие программы и драйверы будут удалены и восстановлены.
9) Нажмите кнопку Закрыть, и если выбранная Вами точка восстановления Вам подходит, то нажмите кнопку Далее.
10) Нажмите кнопку Готово, а затем кнопку Да.

Вариант 2. Проверка диска на наличие ошибок.

Используйте данный вариант для проверки системного диска на наличие ошибок и их исправления.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵.

где:
c: - Системный диск на который у Вас установлена Windows.
/f - парамер, отвечающий за исправление всех ошибок, найденных на диске
/r - парамер, отвечающий за восстановление информации, поддающейся чтению, на поврежденных секторах диска

3) Введите английскую букву y и нажмите Enter ↵.
4) Перезагрузите компьютер.

Вариант 3. Восстановление измененных системных файлов.

Используйте данный вариант для проверки целостности всех защищенных системных файлов и замены неправильных версий правильными.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵.

Вариант 4. Использование средств устранения неполадок.

Используйте данный вариант для автоматического разрешения некоторых распространенных проблем, таких как проблемы при работе с сетью, аппаратным обеспечением и устройствами, проблемы с использованием Интернета, а также проблемы совместимости программ.

1.1) В адресной строке Проводника введите Панель управления\Все элементы панели управления\Устранение неполадок и нажмите Enter ↵.
или
1.2) Нажмите Win   + R, введите указанную ниже команду и нажмите Enter ↵.

2) Слева нажмите ссылку Просмотр всех категорий.
3) В соответствии с описанием запустите необходимое Вам средство устранения неполадок.
4) Щелкните ссылку Дополнительно и снимите флажок Автоматически применять исправления
5) Нажмите кнопку Далее
6) Выбирайте в диалоговом окне ответы на уточняющие вопросы и снова нажимайте кнопку Далее, чтобы продолжить.

Вариант 5. Удаление (восстановление) неправильно работающих программ.

Используйте данный вариант для удаления программ установленных без Вашего ведома или для устранения проблем с неправильно работающими установленными программами.

1.1) В адресной строке Проводника введите Панель управления\Программы\Программы и компоненты и нажмите Enter ↵.
или
1.2) Нажмите Win   + R, введите команду appwiz.cpl и нажмите Enter ↵.
2) Щелкните правой кнопкой мыши на необходимой Вам программе из списка и нажмите Удалить или на пункт Восстановить (если он есть).
Если удаленная Вами программа относится к категории необходимых, то попробуйте найти и установить другую ее версию (более раннюю или более позднюю).

Вариант 6. Удаление программ запускающихся автоматически при запуске Windows.

Используйте данный вариант для отключения программ, стороннних служб, драйверов или назначенных заданий, запускающихся при запуске компьютера.

1) Скачайте и запустите программу Sysinternals AutoRuns (английская версия или русская версия)
2) Для отключения элементов (программ, стороннних служб, драйверов и т.д.), которые не нужно запускать автоматически при запуске системы, снимите флажки рядом с их названиями.
Для полного удаления из автозагрузки, выделите в списке необходимый Вам элемент и нажмите клавишу Delete, а затем клавишу Enter ↵.

Вариант 7. Очистка жесткого диска.

Используйте данный вариант для удаления временных файлов, очистки корзины и удаления других элементов, которые могут вызывать неполадки в работе системы.

1) Нажмите Win   + R, введите команду cleanmgr и нажмите Enter ↵.
2) Выберите диск на который у Вас установлена Windows (По умолчанию диск C:) и нажмите кнопку ОК.
3) Нажмите кнопку Очистить системные файлы и введите пароль администратора, если требуется.
Если Вы работаете с отключенным Контролем учетных записей, то системные файлы доступные для удаления, будут сразу отображены в общем списке.
4) Установите флажки яў тех типов файлов, которые требуется удалить, и нажмите кнопку ОК. Желательно установить флажки яў всех типов файлов.
5) В окне сообщения нажмите кнопку Удалить файлы.

Вариант 8. Установка последних обновлений.

Используйте данный вариант для устранения проблем связанных с неправильной работой программ, драйверов или проблем с безопасностью.

1.1) В адресной строке Проводника введите Панель управления\Все элементы панели управления\Центр обновления Windows и нажмите Enter ↵.
или
1.2) Нажмите Win   + R, введите указанную ниже команду и нажмите Enter ↵.

2) Слева нажмите ссылку Поиск обновлений и подождите, пока Windows выполнит поиск последних обновлений для вашего компьютера.
3) Нажмите кнопку Установить обновления.

Остальные варианты:

1) Перезагрузите несколько раз компьютер с периодичностью в несколько часов.
Перезагрузка позволит Вам очистить память и завершить ошибочные процессы и службы, которые начали работу.

2) Установите наиболее подходящие (самые новые или более старые) драйвера для имеющегося в Вашей системе оборудования.
Подборка правильных драйверов позволит Вам исправить некорректную работу устройства и улучшить его функциональность.

3) Проверьте Ваш компьютер с помощью антивирусных и антишпионских программ.
Их использование может помочь Вам освободится от устанавленных без Вашего ведома следящих программ, появления неожиданных всплывающих сообщений, самостоятельного запуска программ, звука постоянно работающего жесткого диска.


2. Использование оснастки «Просмотр событий» для выявления неполадок в работе Windows.

Каждые произошедшие в Windows события (Предупреждения, Сведения или Ошибки) записываются в Журналы событий.
Если Вам кажется, что в работе системы наблюдаются какие-то неполадки, то для анализа произошедших событий и выявления среди них ошибок требующих исправления, Вы можете воспользоваться оснасткой «Просмотр событий».

Вы можете запустить данную оснастку любым из указанных ниже вариантов.

1) В строке поиска меню Пуск введите слово просмотр и нажмите на Просмотр событий.
2) Нажмите комбинацию клавиш Win   + R, введите eventvwr.msc и нажмите Enter ↵.
3) Откройте меню Пуск, и выберите во всплывающем меню Администрирование пункт Просмотр событий.
4) Откройте меню Пуск и щелкните правой кнопкой мыши на значке Кoмпьютер, выберите из контекстного меню пункт Управление, в открывшемся окне разверните элемент Служебные программы и щелкните на Просмотр событий.

Все журналы разделены на две категории: Журналы Windows и Журналы приложений и служб, каждая из них объединяет в себе несколько других журналов.

Журналы Windows:

Приложение

В указанном журнале содержатся данные, относящиеся к работе приложений и программ. События, регистрируемые в журнале приложений, определяются разработчиками соответствующих приложений.

Безопасность

Данный журнал содержит такие события, как успешные и неуспешные попытки входа в систему, а также события, относящиеся к использованию ресурсов, такие как создание, открытие и удаление файлов и других объектов.

Установка

В этом журнале содержатся данные, относящиеся к установке приложений.

Система

Данный журнал содержит события, записываемые системными компонентами Windows. Например, в журнале системы регистрируются сбои при загрузке драйвера или других системных компонентов в процессе загрузки системы. Типы событий, которые регистрируются компонентами системы, определены на уровне операционной системы.

Перенаправленные события

Данный журнал используется для хранения событий, собранных с удаленных компьютеров.

Журналы приложений и служб

В этих журналах хранятся события из отдельных приложений или компонентов, а не события, способные повлиять на работоспособность всей системы. Также в них хранятся сведния о неполадках в работе оборудования. Кроме описания, зачастую в комментарии к произошедшему событию можно найти подсказку помогающую быстрее найти решение в сложившийся ситуации.
Данные журналы представляют большей частью интерес для анализа и диагностики проблем или событий у ИТ-специалистов и зачастую не предназначены для обычных пользователей. Перейти к началу Общего списка советов.


3. Решение проблемы с доступом к wim-файлу при работе с программой Dism.

При возникновении ошибок с доступом при работе с wim файлом в программе DISM, Вы можете воспользоваться одним из предложенных вариантов.

Вариант 1. Новые имена папок.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

3) Создаете новую папку для wim-файла и переместите в нее Ваш wim-файл. (Например: вместо текущей папки mWim, создайте новую mWim1)
4) Создайте новую папку, куда Вы будете монтировать Ваш wim-файл для работы. (Например: вместо текущей папки Mount, создайте новую Mount1)
5) Продолжайте работу с новыми папками.

Вариант 2. Старые имена папок.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

3) Переместите Ваш wim-файл в любую другую папку.
4) Удалите папки, которые Вы использовали яў wim-файла и монтирования индекса.
5) Создайте заново папки с теми же названиями.
6) Верните wim-файл обратно.
7) Продолжайте работу с теми же папками, что и раньше. Перейти к началу Общего списка советов.


4. Очистка или изменение размера кэша иконок, для решения проблем с их отображением.

Если у Вас возникли проблемы с отображением иконок, то Вам может помочь удаление кэша иконок или изменение его размера.
После удаления кэша - иконки вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов.

Для очистки кэша иконок.

1) В Проводнике откройте папку %USERPROFILE%\AppData\Local\ и удалите файл IconCache.db
2) Перезагрузите компьютер или перезайдите в Windows.

Также Вы можете добавить пункт Rebuild Icon Cache в контекстное меню папок в Проводника. Выбор данного пункта приведет к удалению файла IconCache.db и перезапуску Проводника.
Для добавления указанного пункта в меню:

1) Скачайте и распакуйте архив: Rebuild_Icon_Cache_v2.zip
2) Запустите файл Rebuild Icon Cache.exe. Данное действие скопирует скрипт Rebuild Icon Cache.Vbs в папку Windows.
3) Примените один из reg-файлов:

Install(Bottom).reg - для добавления пункта Rebuild Icon Cache в нижнюю часть контекстного меню папок.
Install(Middle).reg - для добавления пункта Rebuild Icon Cache в среднюю часть контекстного меню папок.
Install(Top).reg - для добавления пункта Rebuild Icon Cache в верхнюю часть контекстного меню папок.

Для увеличения размера кэша иконок.

Создайте и примените reg-файл указанного ниже содержания:


5. Причины перехода цветовой схемы на упрощенный стиль.

Отображение сообщения об отключении некоторых визуальных элементов, таких как прозрачность рамки окна, или о замене цветовой схемы на упрощенный стиль может быть вызвано одной из следующих причин:

1) Запущенная программа несовместима с темами Aero. В этом случае некоторые визуальные элементы автоматически отключаются. После завершения работы такой программы отключенные визуальные элементы автоматически включаются.
2) Возможно, уровень заряда батареи переносного компьютера очень низкий. Темы Aero или прозрачность окон в системе Windows могут быть отключены для экономии энергии батареи.
3) Было изменение конфигурации оборудования компьютера или разрешения экрана. После изменения разрешения экрана, параметров видеокарты или монитора компьютер, возможно, больше не соответствует минимальным требованиям для запуска тем Aero.
4) Недостаточный объем памяти компьютера для выполнения всех запущенных программ и использования темы Aero.

Если ОС Windows автоматически изменила тему на упрощенный стиль, но необходимо вернуться к теме Aero, закройте несколько окон, чтобы освободить память, а затем выполните следующие действия:

1) Используйте "Запуск средства устранения неполадок интерфейса Aero".
1.1) Откройте меню Пуск и введите команду в строке поиска, щелкните на ней и нажмите Enter ↵
или
1.2) Нажмите Win   + R и введите команду в диалоговом окне Выполнить

2) Нажмите Далее Перейти к началу Общего списка советов.


6. Выбор настроек во время установки яў предотвращения замены русских букв знаками вопросов.

На начальном этапе установки выводится окно, содержащее три строчки.
Первая строчка - язык, на котором работает система (английский US или русский RU). При возможности выберите русский.
Вторая строчка - месторасположение компьютера, для выбора страны (от Афганистана и до Ямайки). Выберите страну - Russian Federation.
Третья строчка - язык раскладки клавиатуры по умолчанию. При выборе во второй строчке страны (РФ), здесь автоматически устанавливается русский. Вы можете выбрать здесь любой используемый Вами язык раскладки клавиатуры.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Администрирование и Интерфейс.


7. Решение проблемы с неправильным отображением русских букв.

Вариант 1.

1.1) Запустите редактор реестра: Win   + R → regedit → ОК или введите regedit в строке поика меню Пуск и нажмите Enter ↵.
1.2) Откройте ветку реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
1.3) Измените значение параметра 1252 с "c_1252.nls" на "c_1251.nls"
1.4) Откройте папку C:\WINDOWS\system32\ и найдите файлы c_1251.nls и c_1252.nls и задайте полный доступ к данным файлам.
1.5) Переименуйте файл c_1252.nls в c_1252.bak.
1.6) Создайте здесь же копию файла c_1251.nls.
1.6.1) Щелкните правой кнопкой мыши на файле и выберите Копировать.
1.6.2) Щелкните правой кнопкой мыши в пустом месте папки C:\WINDOWS\system32\ и выберите Вставить.
1.7) Переименуйте c_1251 - копия.nls в c_1252.nls. В итоге файл c_1252.nls, должен быть переименованной копией c_1251.nls
1.8) Перезагрузите компьютер.
Для 64-битной версии, при необходимости, выполните указанные выше действия в папке C:\Windows\SysWOW64

Если у Вас установлена Русская Windows или Английская+русский MUI, то проделайте также следующее:

2.1) Запустите редактор реестра: Win   + R → regedit → ОК или введите regedit в строке поиска меню Пуск и нажмите Enter ↵.
2.2) Откройте ветку реестра HKEY_CURRENT_USER\Control Panel\International
2.3) Проверьте значение параметров Locale и LocaleName
Параметр Locale должен иметь значение 00000419, а параметр LocaleName должен иметь значение ru-RU
2.4) Если значения параметров другие: дважды щелкните на параметре, который необходимо изменить, введите необходимое значение параметра и нажмите OK.
2.5) Перезагрузите компьютер.

3.1) Откройте Язык и региональные стандарты.
Пуск → Панель управления → Язык и региональные стандарты (или Win   + R → control /name Microsoft.RegionAndLanguage → OK)
3.2) Перейдите на вкладку Дополнительно. Можете сразу открыть её: Win   + R → control intl.cpl,,3 → OK
3.3) В блоке Язык программ, не поддерживающих Юникод нажмите на кнопку Изменить язык системы
3.4) Выберите язык системы Русский (Россия) и нажмите ОК.

Вариант 2.

1) Скачайте и распакуйте файл: RusCodePage.zip
2) Откройте необходимую папку для запуска командного файла.

Windows 7 English + Russian MUI - откройте данную папку, если у Вас установлена английская версия+русский языковой пакет, так как группа администраторов обозначается как administrators.
Windows 7 Russian - откройте данную папку, если у Вас установлена русская версия, так как группа администраторов обозначается как администраторы.

3) В соответствии с разрядностью Вашей системы запустите bat-файл.

Для восстановления значений по умолчанию примените bat-файл содержащий в названии файла слово Default.

Вариант 3.

Если у Вас установлена английская Windows 7 и Язык программ, не поддерживающих Юникод установлен в значение Russian (Russia), то попробуйте следующее:

1) Откройте Region and Language.
Start → Control Panel → Region and Language (или Win   + R → control intl.cpl → ОК)
2) В ниспадающем списке под словом Format: выберите любое значение отличающееся от Вашего (Например: English (Belize)) и нажмите кнопку Apply.
3) В ниспадающем списке под словом Format: выберите значение Russian (Russia) и нажмите кнопку Apply.
4) Перейдите на вкладку Keyboards and Languages и нажмите на кнопку Change keyboards...
5) Выделите раскладку клавиатуры соответствующую языку выбранному Вами на втором шаге (Например: English (Belize)) и нажмите кнопку Remove.
6) Нажмите кнопку ОК и еще раз кнопку ОК для применения настроек.


8. Запись последовательности действий пользователя для анализа их разработчиком.

Одной из встроенных диагностических утилит, чтобы отсылать отчеты об ошибках является "Средство записи действий по воспроизведению неполадок".
Эта функция, которая позволяет пользователям записывать свои действия в любом используемом приложении и предоставлять подробное представление действий со снимками экрана с соответствующими комментариями.
Для того, чтобы открыть приложение "Средство записи действий по воспроизведению неполадок" нужно нажать на кнопку меню «Пуск» и в поле поиска ввести psr.
Для того, чтобы начать запись действий, с которыми возникают проблемы или вопросы нужно просто нажать на кнопку "Начать запись". После этого можно выполнять любые действия с операционной системой и установленными приложениями для воспроизведения проблемы.
Чтобы приостановить на время запись действий, необходимо нажать на кнопку "Приостановить запись".
Для того, чтобы снова возобновить запись действий нажимаем на кнопку "Возобновить запись".
Сразу после остановки записи откроется диалоговое окно "Сохранить как", в котором нужно ввести ¤ файла и нажать на кнопку "Сохранить". После выполнения этих действий файл будет сохранен в указанной директории с расширением ZIP.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Администрирование и Интерфейс.


9. Решение проблемы с выходом из спящего/ждущего режима в черный экран.

Если при попытке выходе из спящего/ждущего режима Вы попадаете в черный экран или в BSOD (синий экран смерти) Вы можете попробовать несколько способов. Первым делом, скачайте и установите более новые версии драйверов для Вашей видеокарты, чем те что у Вас есть.

Вариант 1. Изменение настроек BIOS:

1) Во времени загрузки зайдите в BIOS (для этого нажмите клавишу Delete после начала загрузки компьютера)
2) В BIOS пройдите на вкладку Power
3) Попробуйте изменить значение параметра Suspend Mode (Auto, S1 (POS) Only, S3 Only) названия может отличаться, ищите похожие со значениями S1, S3.
4) Также попробуйте включить\отключить ACPI 2.0 Support → Enabled\Disabled

Вариант 2. Запрет вывода из спящего режима используя USB мышь или USB клавиатуру.

Некоторые USB-устройства неправильно поддерживают спящий режим Windows. Два основных устройства с помощью которых Вы можете выйти из спящего режима - это клавиатура и мышь. Одно из них может блокировать Вам выход, в таком случае ему надо просто запретить это делать. Внимание: Не запрещайте одновременно клавиатуре и мыши, иначе Вы не сможете выйти из него.

1) Запустите Диспетчер устройств. Для этого пройдите в Пуск → Выполнить (или Win   + R) → devmgmt.msc → OK
2) В Диспетчере устройств разверните узел Мыши и иные указывающие устройства или Клавиатуры
3) Щелкните правой кнопкой на USB-мышь или USB-клавиатуру и выберите пункт Свойства.
4) Откройте вкладку Управление электропитанием.
5) Снимите флажок Разрешить устройству вывод компьютера из спящего режима и нажмите кнопку ОК.

Вариант 3. Отключение спящего/ждущего режима.

1) Пройдите в Пуск → Выполнить (Win   + R) → powercfg.cpl → OK
2) Выберите слева пункт Настройка перехода в спящий режим
3) Присвойте обоим параметрам: Отключать дисплей и Переводить компьютер в спящий режим, значение - Никогда.
Также можно отключить и функцию сна. Выберите пункт "Изменить дополнительные параметры питания". Найдите в окне режим Сон, разверните Сон после и установите значение находящихся там параметров на Никогда
Если несмотря на проделанное выше, компьютер по прежнему продолжает отключаться, то Вам необходимо выполнить ещё некоторые действия:
4) Скачайте reg-файл PowerSettings.reg и примените его.
5) Откройте вкладку Сон
6) Установите следующие значения параметрам, открыв их вкладки:
6.1) Сон после - значение равным 0, оно идентично значению Никогда
6.2) Разрешить политику требуемую системой - значение Да (это предотвратит автоматический переход в ждущий режим)
6.3) Разрешить таймеры пробуждения - Включить (позволит автоматически выводить компьютер из спящего режима при помощи заданных событий)
7) Если у Вас одно из устройств USB например мышь, а второе клавиатура PS/2, то Вы можете отключать USB порт на время работы спящего режима.
Откройте вкладку Параметры USB, а в ней вкладку Параметр временного отключения USB-порта и установите значение в Разрешено.
8) Нажмите OK Перейти к началу Общего списка советов.


10. Восстановление загрузки Windows 7 без установочного диска.

Вариант 1. Автоматически - при помощи среды восстановления Windows RE в Windows 7.

Во время установки Windows 7 на жестком диске автоматически создается служебный раздел, обеспечивающий доступ в среду восстановления Windows RE (Recovery Environment). Используя данный служебный раздел, Вы можете:

- загрузит© в среду восстановления с жесткого диска
- создать компакт-диск, содержащий среду восстановления

1) Выполните загрузку в среду восстановления с жесткого диска или диска восстановления системы.
Для того чтобы войти в меню Дополнительные варианты загрузки, нажмитеF8 после включения компьютера (но до загрузки операционной системы).
2) Выберите первый пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter ↵.
3) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи.
4) Введите пароль администратора. После ввода пароля вы увидите окно с вариантами восстановления.
5) Выберите пункт Восстановление запуска(Startup repair), также иногда может помочь пункт Восстановление системы (System Restore), позволяющий вернуться к точке, созданной до возникновения проблемы.

Вариант 2. Восстановление вручную, с созданием мультизагрузочного меню.

Здесь главное - это добраться до командной строки яў введения дальнейших команд.

1) Скачайте архив Bootfiles_x86+x64.zip (содержит файлы: Bcdboot.exe; Bcdedit.exe; Bootsect.exe; Bootrec.exe).
2) Создайте папку Boot.
3) Распакуйте скачанный архив и скопируйте файлы нужной Вам битности в созданную Вами папку Boot.
4) Запустите среду необходимую для работы:
5) Загрузитесь в Windows, установленную на другой диск или в среду восстановления (На жестком диске запускается нажатием, клавишиF8. Если клавишаF8 используется материнской платой, после выбора диска нажмитеF8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter ↵)
6) Запустите командную строку.
В Windows: Win   + R → cmd → ОК.
В среде восстановления: Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt)

Далее все команды вводимые в командную строку будут одинаковы как в Windows, так и в среде восстановления.

1) Windows 7 использует усовершенствованный метод загрузки - хранилище данных конфигурации загрузки. Это хранилище содержит все сведения обо всех операционных системах, установленных на компьютере. Следовательно, загрузчики более ранних операционных систем Windows, не могут быть использованы для ее запуска. Итак, для восстановления, загрузочного сектора Windows 7, перезаписываем загрузочный сектор на всех разделах:

где Х - буква диска, на котором содержится программа Bootsect.exe
2) Если у Вас вторая система Windows XP, то Вам необходимо выполнить ещё ряд действий:

Создайте в хранилище загрузки Windows 7 - хранилище для загрузки Windows XP.

Если же система откажется это делать, значит данное хранилище уже создано, поэтому необходимо его только переименовать:

Далее укажите загрузчику Windows 7 устройство расположения файлов загрузки Windows XP:

Затем укажите загрузчику Windows 7 путь к загрузчику Windows XP:

После добавьте строчку о выборе Windows XP в меню загрузки и расположив ее под остальными:

Также для работы с загрузчиками, Вы можете воспользоваться программой EasyBCD, позволяющей выполнять указанные выше действия, используя графический интерфейс.

Для информации:

Главная Загрузочная Запись (Master Boot Record - MBR), совместимая с загрузчиком операционной системы (ntldr - для Windows XP и bootmgr - для Windows 7/Vista);
Файлы загрузки: для Windows XP - файлы ntdetect.com и boot.ini, для Windows 7/Vista - хранилище загрузки - Boot Configuration Data (BCD), которое расположено в скрытой системной папке BOOT.

Вариант 3. Восстановление вручную, при помощи bootrec.exe.

1) Загрузитесь в среду восстановления (На жестком диске запускается нажатием, клавишиF8. Если клавишаF8 используется материнской платой, после выбора диска нажмитеF8 снова, выберите пункт меню Устранение неполадок компьютера (Repair your computer) и нажмите Enter ↵)
2) Выберите операционную систему, которую необходимо восстановить, и нажмите "Next"("Далее").
3) В окне Опции системы восстановления (System Recovery Options) выберите пункт Командная строка (Command Prompt).
4) Откроется окно интерпретатора командной строки cmd.exe, где следует ввести:

Параметр /FixMbr записывает в системный раздел основную загрузочную запись, совместимую с Windows 7. Этот параметр не перезаписывает существующую таблицу разделов. Данный параметр следует использовать для устранения проблем, связанных с повреждением основной загрузочной записи, или если необходимо удалить из основной загрузочной записи нестандартный код.

Параметр /FixBoot записывает в системный раздел новый загрузочный сектор с использованием загрузочного сектора, совместимого с Windows 7. Этот параметр следует использовать, если выполняется хотя бы одно из перечисленных ниже условий.

- Загрузочный сектор Windows 7 был заменен нестандартным загрузочным сектором
- Загрузочный сектор поврежден
- После установки Windows 7 на компьютер была установлена более ранняя версия операционной системы Windows. В данном случае для запуска компьютера вместо диспетчера загрузки Windows (Bootmgr.exe) используется загрузчик Windows NT (NTLDR).

Параметр /RebuildBcd выполняет поиск установленных операционных систем, совместимых с Windows 7, на всех дисках. Кроме того, этот параметр позволяет выбрать установленные системы, которые необходимо добавить в хранилище данных конфигурации загрузки. Этот параметр следует использовать в том случае, если необходимо выполнить полную перестройку данных конфигурации загрузки.

Если Вы не запомнили необходимого Вам значения Вы можете просто ввести:

и утилита выведет справку по доступным ключам командной строки. Перейти к началу Общего списка советов.


11. Восстановление стандартного анимированного экрана загрузки Windows 7.

В некоторых случаях новый экран загрузки произвольно заменяется старым в стиле Vista. Чаще всего это происходит, после неудачно внесенных различного рода изменений в загрузчик ОС. Предлагаю Вам простые и действенные решения:

Вариант 1

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду и нажмите Enter ↵: sfc /scannow

Вариант 2

1. Откройте командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2. В открытом окне консоли введите команду:

Обратите внимание, что вышеуказанная команда предусмотрена для английской версии Windows, поэтому если вы используете другую языковую версию, необходимо заменить "en-US" на языковой идентификатор используемой вами версии.
3. Закройте окно командной строки.
4. Перезагрузите Ваш компьютер.

Вариант 3

1) Откройте диалоговое меню Выполнить: Пуск → Выполнить (или Win   + R)
2) В открытом окне консоли введите команду: msconfig и нажмите OK
3) Перейдите на вкладку "Загрузка" и проверьте не установлен ли флажок напротив значения "Без GUI". Если флажок установлен - снимите его.
4) Закройте окно Конфигурации системы.
5) Перезагрузите компьютер Перейти к началу Общего списка советов.


12. Восстановление значений реестра и асоциаций с программами по умолчанию для различных типов файлов.

Если у Вас возникли проблемы при открытии каких-либо файлов с расширениями определенного типа, исчезла или неправильно отображается иконка для них или пропали записи в реестре, то Вы можете восстановить для данного типа файлов изначальные настройки.

Чтобы применить необходимый Вам reg-файл для восстановления настроек для файлов с заданным расширением:

1) Скачайте архив Restore_Default_File_Extentions.zip и распакуйте в любую папку архив.
2) Щелкните правой кнопкой мыши на reg-файле, содержащем в своем названии, расширение файла для которого Вы желаете восстановить настройки в реестре по умолчанию.
3) Выберите пункт Слияние, а затем нажмите Да → ОК.

или

1) Удерживая нажатой клавишу ⇑ Shift, щелкните правой кнопкой мыши на папке куда Вы распаковали архив и выберите пункт Открыть окно команд.
2) Введите используя команду, используя указанный ниже шаблон и нажмите Enter ↵.

где XXX обозначает необходимое Вам расширение файла. Перейти к началу Общего списка советов.


13. Моргание игр в режиме OpenGL.

Переименуйте файлы: ..\windows\system32\glu.dll в glu32.dll ..\windows\system32\opengl.dll в opengl32.dll

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Администрирование и Интерфейс.


14. Исправление невозможности запуска службы Центра обеспечения безопасности.

1) Отключены компоненты от которых зависит данная служба.

1.1) Откройте: Администрирование → Службы
1.2) Проверьте включены ли следующие службы:

- Инструментарий управления Windows
- Удаленный вызов процедур (RPC)
- Модуль запуска процессов DCOM-сервера
- Сопоставитель конечных точек RPC

2) Восстановите начальные параметры в реестре, используя значения с компьютера, на котором данная служба работает.

2.1) Загрузите и примените готовый reg-файл. wscsvc.zip Перейти к началу Общего списка советов.


15. Исправление отсутствия компонентов в окне "Включение или отключение компонентов Windows".

1.1) Запустите редактор реестра: Win   + R → regedit → ОК
1.2) Откройте ветку реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows
1.3) Измените значение параметра CSDVersion на 0.
1.4) Перезагрузите компьютер

2) В соответствии с разрядностью и языком Вашей Windows, скачайте и установите обновление KB947821:

Windows6.1-KB947821-v26-x86.msu
Windows6.1-KB947821-v26-x64.msu Перейти к началу Общего списка советов.


16. Исправление невозможности изменения настроек User Account Control (UAC).

В разделе Панели управления Системы и безопасность Вы можете изменить параметры контроля учетных записей User Account Control (UAC).
Если у Вас при работе в диалоговом окне Параметры управления учетными записями пользователей после перемещения ползунка управления и нажатия кнопки ОК или клавиши Enter ↵, диалоговое окно не закрывается, и/или не вносятся никакие изменения, то вероятнее всего у Вас произошел сбой Реестра.
Вы можете восстановить нормальную работу User Account Control (UAC) одним из 2 способов.

Вариант 1. С помощью специального дополнения от Microsoft.

Скачайте и запустите файл: fixit_kb978591.diagcab

Вариант 2. При помощи созданного Вами reg-файла.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "UAC.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Примените полученный файл UAC.reg (Двойной щелчок → Да)

Готовый reg-файл Вы можете скачать по ссылке: uac_repair.zip. Перейти к началу Общего списка советов.


17. Диагностика проблемы высокой загрузки процессора и частых обращений к жесткому диску при запуске или выключении Windows.

Чтобы определить какая программа или драйвер больше всего загружает Ваш процессор, Вам понадобит© программа от Microsoft - Windows Performance Tools Kit и в дополнение к ней программа XPerfUI от Richard Macdonald, при координации Microsoft.

1) В соответствии с Вашей разрядностью, скачиваете архив: wpt_x86.zip - для 32-бит или wpt_x64.zip - для 64-бит.
2) Устанавливаете программу Windows Performance Tools Kit
3) Копируйте файл XPerfUI.exe в папку с установленной программой и запускаете его.

4) Используя всплывающее меню открываете Tools → Trace Session → Boot Trace
5) В блоке Trace Type выбираете, для какого действия Вы хотите провести диагностику: Boot (для анализа запуска) или Shutdown (для анализа выключения)
6) В блоке Trace Flags устанавливаете переключатель на значение Base, дополнительно отмечаете пункты CSWITCH, DRIVERS, POWER
7) В поле Result path указываете путь, куда будет сохранен результат анализа. (Например: C:\Temp )
8) Нажмите кнопку Start для начала диагностики.

Компьютер перезагрузится.
9) Если Вы выбрали Boot (для анализа запуска), то после перезапуска системы, программа запустит трассировку (процесс пошагового выполнения программы) для данного действия и сохранит результаты в указанную Вами папку.
Если Вы выбрали Shutdown (для анализа выключения), то после перезапуска системы, программа запустит трассировку, снова перезапустит компьютер, снова запустит трассировку и сохранит результаты в указанную Вами папку.

10) Запускаете программу Performance Analyzer. В появившемся окне нажимаете кнопку Да.
Пуск → Все программы → Microsoft Windows Performance Toolkit → Performance Analyzer
или файл xperfview.exe из папки, где установлена программа.
11) Открываете в окне программы (File → Open) etl-файл, являющийся созданным в процессе трассировки log-файлом с результатами анализа. Местом нахождения etl-файла будет папка, указанная Вами при запуске трассировки.
12) Программа загрузит графики.
13) В меню программы нажимаете Graphs и ставите флажок CPU Sampling by Process.
14) В меню программы нажимаете Trace и ставите флажок Load Symbols.
15) Находите график CPU Sampling by Process.
16) Чтобы вывести сводную таблицу, нажимаете на нем правой кнокой мыши и выбираете пункт Summary Table
Процесс с наибольшим значением Weight и будет тем самым процессом, который забирает ресурсы процессора при загрузке или выключении. При нажатии на значок +, рядом с наименованием процесса Вы сможете узнать какой именно файл потребляет больше всего ресурсов процессора.

17) Также Вы можете посмотреть какая программа больше всего делает обращений к жесткому диску. Для этого найдите график Disk I/O в основном окне графиков программы, нажмите на нем правой кнопкой мыши и выберите пункт Summary Table. Процесс с наибольшим значением Service Time и будет тем самым процессом, который больше всего делает обращений к жесткому диску.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Администрирование и Интерфейс.


18. Устранение проблемы открытия папок в отдельном окне, при установленном положении переключателя "Открывать папки в одном и том же окне".

1) Нажмите Пуск и введите в строке поиска cmd.exe
2) Нажмите на найденном правой кнопкой мыши и выберите пункт "Запуск от имени Администратора".
3) Поочередно введите команды, после написания каждой нажмите Enter ↵.


19. Удаление лишних пунктов из Диспетчера загрузки Windows.

1) Нажмите кнопку Пуск
2) Наберите в строке поиска msconfig и нажмите Enter ↵
3) Перейдите на вкладку Загрузка
4) Выделите строку которую Вы желаете удалить и нажмите кнопку Удалить
5) Нажмите кнопку ОК и перезагрузите компьютер

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Администрирование и Интерфейс.


20. Извлечение файлов Windows 7 из установочного DVD и замена ими поврежденных системных файлов.

Если у Вас в Windows появились поврежденные системные файлы, то Вам нет необходимости сразу переустанавливать Windows, так как Вы можете просто восстановить поврежденный файл используя DVD-диск или образ установочного диска. Вам всего лишь надо удалить имеющийся системный файл и заменить его извлеченным.

Инструкция восстановления системных файлов:

1) Извлеките из установочного диска необходимый файл.
2) Удалите поврежденный файл.
3) Скопируйте на место удаленного файла извлеченный.
4) Перезагрузите компьютер.

Извлечение файлов с диска Windows 7.

Вариант 1. При помощи программы DISM.

Подключение образа в DISM.

1) Вставьте установочный диск Windows 7 в DVD-привод, или смонтируйте ISO-образ.
2) Откройте папку sources и скопируйте из нее файл install.wim на диск D.
Внимание: в качестве папки яў подключения образа install.wim НЕЛЬЗЯ использовать корень диска C (тот на котором установлена Windows), так как install.wim содержит системные папки Windows, Program Files, Program Data, Users и др.
3) Создайте папку на диске D и назовите ее, например, Image. В эту папку будет подключен образ install.wim.
4) Откройте Пуск → Все программы → Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
5) Выполните команду:

Пояснения:

dism – встроенная в Windows 7 утилита командной строки, позволяющая подключать образы WIM и управлять ими.
Параметр /Mount-Wim подключает файл WIM.
Параметр /WimFile позволяет указать расположение и имя файла WIM, который нужно подключить.
Параметр /name позволяет указать название выпуска Windows 7, который будет смонтирован.
Параметр /MountDir: указывает папку, в которую будет смонтирован образ WIM.

6) Дождитесь, пока образ подключится. Это может занять несколько минут.
7) Откройте папку D:\Image, найдите в ней (в папках) нужный файл и скопируйте его в любое место на жестком диске.

После копирования нужных файлов образ можно отключить.

Отключение образа в DISM.

1) Закройте все папки и файлы.
2) Откройте Пуск → Все программы → Стандартные, щелкните правой кнопкой мыши по значку командной строки и выберите Запуск от имени администратора.
3) Выполните команду:

Пояснения:

Параметр /Unmount-Wim отключает образ.
Параметр /MountDir: указывает папку, в которую смонтирован образ, который нужно отключить.
Параметр /discard отменяет все внесенные в образ изменения.

4) Дождитесь отключения образа.
5) Удалите папку Image и файл install.wim с диска D.

Вариант 2. При помощи программы 7Zip.

1) Скачайте и установите программу 7Zip
2) Cмонтируете образ лицензионного диска с Windows 7 или вставьте установочный DVD-диск.
3) Используя программу 7Zip откройте файл H:\sources\install.wim
где (H:) - буква диска с установкой Windows
4) Откройте в данном файле папку, соответствующую идентичной в системе.
5) Скопируйте файл(простым переносом из программы 7Zip) в идентичную папку в реальной системе.

Способы удаления:

1) Обычное удаление.
Просто нажмите правой кнопкой мыши на файле и выберите пункт Удалить.

2.1) Скачайте и установите программу Unlocker
2.2) Нажмите правой кнопкой мыши на файле и выберите пункт Unlocker.
2.3) В выпадающем меню выберите пункт Удалить и нажмите на кнопку Разблокировать все.

3) Удаление в безопасном режиме.
3.1) Перезагрузите компьютер в безопасный режим.
Для этого нажмите F8 в начале загрузки компьютера до появления логотипа Windows и выберите пункт Безопасный режим.
3.2) Нажмите правой кнопкой мыши на файле и выберите пункт Удалить. <

4) Загрузитесь в MSDaRT (ранее ERD Commander).
4.1) Для сопоставления букв дисков целевой операционной системе нажмите Да (Yes).
4.2) В окне выбора опреационной системы не выбирайте никакую систему(должно сняться выделение с какой-либо системы) и нажмите кнопку Далее (Next).
4.3) Нажмите Micosoft Diagnostics and Recovery Toolset → Explorer
4.4) Откройте папку файла, нажмите правой кнопкой мыши на нем и выберите пункт Удалить.


21. Настройка периодичности создания точек восстановления системы.

Чтобы изменить периодичность создания точек восстановления сделайте следующее:

1) Запустите Планировщик заданий. Пуск → Панель управления → Администрирование → Планировщик заданий

2) В дереве слева откройте Библиотека планировщика задач → Microsoft → Windows → SystemRestore

3) Щелкните правой кнопкой мыши в верхнем среднем окне на файл SR и выберите Свойства.

4) В открывшемся окне перейдите на вкладку Триггеры.

5) Нажмите Создать и задайте необходимые Вам временные параметры, либо выберите уже имеющийся триггер (Например, Ежедневно) и нажмите Изменить. Для удаления созданых триггеров выберите его и нажмите Удалить.

6) Нажмите на ОК для принятия изменений. Перейти к началу Общего списка советов.


22. Восстановление веток реестра из резервных копий службы System Restore в Windows 7.

Большая часть системного реестра находится в следующих местах:

Раздел HKEY_CURRENT_USER - в файле C:\Users\ИМЯ_ПОЛЬЗОВАТЕЛЯ\NTUSER.dat.
Все остальные разделы - C:\Windows\system32\config

Если Вам необходимо восстановить какую-то определенную часть системного реестра Windows 7 или Вы хотите посмотреть, какие значения имел определенный ключ, некоторое время назад, то Вам необходимо сделать следующее:

Для примера, получим доступ к предыдущим значениям ключа HKEY_LOCAL_MACHINE\SOFTWARE.

1) Откройте папку C:\Windows\system32. Найдите в ней директорию Config.
2) Щелкните по папке Config правой кнопкой мыши, выберите пункт меню Свойства и перейдите на вкладку Предыдущие версии.
3) Два раза щелкните по папке, относящейся к интересующей вас дате. Вы увидите перечень файлов, для которых доступна предыдущая версия. В данном случае нас интересует файл SOFTWARE, так как именно в нем хранятся ключи раздела HKEY_LOCAL_MACHINE\SOFTWARE.
4) Скопируйте файл в любое удобное вам место, перетащив его в открытое окно Проводника, либо выбрав команду Копировать из контекстного меню файла SOFTWARE.
Предположим, вы поместили его в корень диска D:.
5) Запустите редактор реестра (Пуск → Выполнить → regedit.exe), установите курсор на корневой ключ HKEY_LOCAL_MACHINE и выполните команду главного меню Файл → Загрузить куст...
6) Задайте имя, под которым будет смонтирован файл D:\SOFTWARE (Например: oldsoftware)
7) Доступ к значениям ключей и разделов реестра будет возможен по пути HKEY_LOCAL_MACHINE\oldsoftware.
8) Смонтированный куст представляет собой предыдущую версию HKEY_LOCAL_MACHINE\Software, где Вы можете посмотреть предыдущие значения нужных ключей.
Если значения Вам необходимо поместить в рабочий реестр системы, переходите к следующему пункту.
9) Найдите интересующий Вас ключ или параметр, и экспортируйте его в reg-файл:
10) Выделите ключ, и в его контекстном меню выберите команду Экспортировать.
11) Отредактируйте только что экспортированный файл Блокнотом, заменив все вхождения "\oldsoftware\" на "\SOFTWARE\".
12) Сохраните reg-файл и двойным щелчком мыши по нему импортируйте его в текущий реестр операционной системы. Перейти к началу Общего списка советов.


23. Использование "чистой загрузки" для устранения неполадок в работе Windows.

"Чистая загрузка" - это безопасный режим, в котором компьютер запускается с минимальным количеством работающих программ и служб. Если при запуске компьютера в безопасном режиме ошибок не возникает, это означает, что проблема вызвана одной из программ или служб автозагрузки. В режиме "чистой загрузки" компьютер запускается с отключенными программами и службами автозагрузки, которые затем включаются и отключаются по одной до тех пор, пока источник проблемы не будет локализован.

Действие 1. "Чис  загрузка" системы

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter ↵, чтобы запустить Конфигурация системы.
3) На вкладке Общие установите переключатель на Выборочный запуск
4) Снимите флажок Загружать элементы автозагрузки. (Флажок Использовать оригинальную конфигурацию загрузки недоступен.)
5) Перейдите на вкладку Службы
6) Установите флажок Не отображать службы Майкрософт и нажмите кнопку Отключить все.
7) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 2. Включите половину служб.

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter ↵, чтобы запустить Конфигурация системы.
3) Откройте вкладку Службы и установите флажок Не отображать службы Майкрософт.
4) Установите флажки яў половины служб в списке Службы.
5) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 3. Определите возможную причину неисправности.

Если неисправность осталась, повторите действия 1 и 2. В действии 2 снимите в списке Службы установленные флажки.
Если проблема исчезла, повторите действия 1 и 2. В действии 2 установите половину из еще не установленных флажков в списке Службы. Повторяйте эти действия, пока не будут установлены все флажки.
Если в списке Службы осталась выбранной только одна служба и проблема по-прежнему наблюдается, то именно эта служба ее и вызывает.
Если проблема вызвана одной из служб, перейдите к действию 6, в противоположном случае продолжайте поиск неисправности перейдя к действию 4.

Действие 4. Разрешите запуск половины элементов списка автозагрузки.

1) Выполните чистую загрузку, повторив действие 1.
2) Откройте вкладку Автозагрузка и установите флажки яў половины элементов списка элементов автозагрузки.
3) Нажмите кнопку ОК и щелкните Перезагрузка.

Действие 5. Определите возможную причину неисправности.

Если неисправность осталась, повторите действия 1 и 4. В действии 4 снимите в списке элементов автозагрузки установленные флажки.
Если проблема исчезла, повторите действия 1 и 4. В действии 4 установите половину из еще не установленных флажков в списке элементов автозагрузки. Повторяйте эти действия, пока не будут установлены все флажки.
Если в списке элементов автозагрузки остался только один элемент и проблема по-прежнему наблюдается, то именно этот элемент ее и вызывает.
Если проблема вызвана одним из элементов автозагрузки, перейдите к действию 6.
Если неполадка не вызвана ни одним из элементов автозагрузки, вероятнее всего, ее вызывает одна из служб Майкрософт. Чтобы определить, какая именно служба вызывает неполадку, повторите действия 1 и 2, не устанавливая флажок Не отображать службы Майкрософт в действии 2.

Действие 6. Устраните проблему.

Определив программу или службу, являющуюся причиной проблемы сделайте одно из предложенным действий:

1) Установите более новую версию программы или удалите текущую.
2) Обратитесь к разработчикам программы в службу поддержки.
3) Используя Конфигурация системы снимите флажок проблемного элемента в списке Службы или в списке элементов автозагрузки.
4) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
5) Введите команду и нажмите Enter ↵: sfc /scannow

Действие 7. Перезагрузите систему в обычный режим Windows.

Завершив устранение неполадок, для перезагрузки в обычнй режим Windows выполните описанные далее действия:

1) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter ↵, чтобы запустить Конфигурация системы.
2) На вкладке Общие установите переключатель на Обычный запуск
3) Нажмите кнопку ОК и щелкните Перезагрузка. Перейти к началу Общего списка советов.


24. Сброс пароля для учетной записи администратора.

Вариант 1.

1) Загрузитесь с установочного DVD диска или флеш-накопитЈ Windows 7.
2) Запустите окно команд нажав комбинацию клавиш ⇑ Shift + F10.
3) Введите regedit и нажмите клавишу Enter ↵. Для переключения раскладок клавиатуры используйте комбинацию клавиш ⇑ Shift + Alt.
4) В редакторе реестра выделите раздел HKEY_LOCAL_MACHINE
5) В главном меню нажмите Файл и выберите пункт Загрузить куст.
6) Перейдите на диск, где установлена Ваша Windows 7 (сопоставление букв дисков может отличаться)
7) Откройте папку <буква_диска>:\Windows\System32\config, выделите файл SYSTEM и нажмите кнопку Открыть
8) Введите произвольное имя для загружаемого раздела. Например: 123 и нажмите кнопку ОК.
9) Перейдите в раздел реестра HKEY_LOCAL_MACHINE\123\Setup
10) Измените значения указанных ниже параметров. Для этого щелкните на необходимом параметре правой кнопкой мыши и выберите пункт Изменить, введите нужное значение и нажмите ОК.
Укажите для параметра CmdLine значение cmd.exe
Укажите для параметра SetupType значение 2
11) Выделите раздел 123 в HKEY_LOCAL_MACHINE.
12) В главном меню нажмите Файл и выберите пункт Выгрузить куст.
13) В открывшемся окне нажмите кнопку Да для подтверждения выгрузки.
14) Закройте редактор реестра и командную строку.
15) Выйдите из установки Windows (для этого закройте окно выбора языковых параметров) и извлеките установочный DVD диск или отсоедините флеш-накопитель.
16) Продолжите обычную загрузку Windows и у Вас откроется окно команд. Вы можете либо задать новый пароль для уже имеющейся учетной записи администратора, либо создать новую учетную запись администратора.
17) Введите команду: net user и нажмите Enter ↵, чтобы отобразить все имеющиеся у Вас учётные записи.

Для сброса пароля введите следующую команду и нажмите клавишу Enter ↵:

Внимание: Если ¤ пользователя и/или пароль содержат пробелы, то их необходио вводить в кавычках. Например:

Для создания новой учетной записи администратора последовательно введите указанные ниже команды, нажимая после введения каждой клавишу Enter ↵.

В русской (локализованной) версии Windows:

В английской версии Windows:

18) Закройте окно команд и войдите в систему, используя имеющуюся у Вас учетную запись с правами администратора и пароль. Если компьютер после закрытия окна команд зависнет, то просто перезагрузите его и Вы окажетесь в экране пользователей, где Вам необходимо будет ввести пароль.

Вариант 2.

1) Загрузитесь с установочного DVD диска или флеш-накопитЈ Windows 7.
2) В окне выбора языковых параметров нажмите кнопку Далее (Next)
3) Щелкните на ссылку Восстановление системы
4) Выберите в списке Вашу операционную систему и нажмите кнопку Далее (Next)
5) В списке инструментов для восстановления выберите пункт Командная строка (Command Prompt).
6) Найдите имя диска, где установлена Windows 7, вводя поочередно букву диска с двоеточием и нажимая клавишу Enter ↵. Для просмотра содержимого диска вводите команду dir
7) Введите последовательно указанные ниже команды, нажимая после введения каждой клавишу Enter ↵ (замените c: правильной буквой, если Windows не находится на диске C:)

8) Закройте окно команд и нажмите кнопку Перезагрузка в окне выбора средств восстановления.
9) Когда Вы окажетесь в экране выбора пользователей нажмите пять раз клавишу ⇑ Shift и у Вас откроется окно команд. Вы можете либо задать новый пароль для уже имеющейся учетной записи администратора, либо создать новую учетную запись администратора.
10) Введите команду: net user и нажмите Enter ↵, чтобы отобразить все имеющиеся у Вас учётные записи.

Для сброса пароля введите следующую команду и нажмите клавишу Enter ↵:

Внимание: Если ¤ пользователя и/или пароль содержат пробелы, то их необходио вводить в кавычках. Например:

Для создания новой учетной записи администратора последовательно введите указанные ниже команды, нажимая после введения каждой клавишу Enter ↵.

В русской (локализованной) версии Windows:

В английской версии Windows:

11) Закройте окно команд.
Если Вы просто изменили пароль, то можете сразу войти в систему, используя новый пароль.
Если Вы создали новую учетную запись с правами администратора, то для ее использования необходимо перезагрузить компьютер.
12) После входа в систему откройте папку C:\Windows\System32 и задайте полный доступ к файлу sethc.exe
13) Скопируйте из корня диска, где установлена Windows 7 в папку C:\Windows\System32 с заменой текущего, файл sethc.exe

Вариант 3.

1) Перезагрузите компьютер в MSDaRT. Создание образа MSDaRT (ранее ERD Commander) описано в совете 9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы). из раздела Разное.
2) В окне "Инициализировать подключение к сети в фоновом режиме?" (Would you like to initialize network connectivity in the background?) нажмите кнопку Нет (No).
3) В окне "Переназначить буквы дисков таким образом, чтобы они соответствовали буквам дисков целевой операционной системы?" (Would you like to remap the drive letters to match the mappings from the target operating system?) нажмите кнопку Да (Yes), чтобы в MSDaRT для обозначения дисков использовались те же буквы, что и в системе с которой Вы будете работать.
4) В окне Выберите метод ввода с клавиатуры (Select a keyboard input method) из ниспадающего списка выберите раскладку клавиатуры США (USA) и нажмите кнопку Далее.
5) В окне для выбора операционной системы для восстановления установите переключатель в значение "Используйте средства восстановления, позволяющие устранить проблемы при запуске Windows." (Use recovery tools that can help fix problems starting Windows.)
6) Выберите в списке Вашу операционную систему и нажмите кнопку Далее.
7) Выберите пункт Micosoft® Diagnostics and Recovery Toolset
8) Щелкните на ссылку Мастер изменения паролей (Locksmith) и в открывшемся окне нажмите кнопку Далее (Next).
9) Из ниспадающего списка выберите учетную запись у которой Вы хотите изменить пароль.
10) Введите одинаковое значение пароля в поля Новый пароль (New Password) и Подтверждение (Confirm Password) и нажмите кнопку Далее (Next).
11) Для закрытия мастера нажмите кнопку Готово (Finish).
12) В окне Средства MSDaRT (MSDaRT Tools) нажмите кнопку Закрыть и нажмите кнопку Перезагрузка в окне выбора средств восстановления.
13) Оказавшись после перезагрузки компьютера в экране пользователей, выберите учетную запись и введите пароль.
14) Появится сообщение о необходимости смены пароля перед первым входом. Нажмите кнопку ОК.
15) Введите в первой строке текущий пароль, заданный в MSDaRT, а во второй и третьей одинаковое значение нового пароля и нажмите на кнопку со стрелкой.
При желании, Вы можете ввести во все три строки одинаковые значения пароля, соответствующие заданному Вами паролю в MSDaRT. Перейти к началу Общего списка советов.


25. Устранение неполадок с поиском и индексированием.

Если результаты поиска отображаются не полностью, а также поиск в системе происходит медленно независимо от установленных настроек, то сделайте следующее:

1) Откройте меню Пуск, введите в строке поиска Устранение неполадок и нажмите Enter ↵.
2) Нажмите кнопку Просмотр всех категорий, а затем выберите раздел Поиск и индексирование.
3) Нажмите кнопку Далее, затем в диалоговых окнах выбирайте ответы для уточнения имеющейся у Вас проблемы и нажимайте соответствующие кнопки.

Если файлы из индексированной папки не отображаются в результатах поиска, то сделайте следующее:

Причиной могут быть параметры безопасности, установленные для этой папки. Для индексирования папки и ее содержимого для нее необходимо установить разрешение система. Для большинства папок данное разрешение уже настроено, но в некоторых случаях разрешение система для папки может отсутствовать.

Добавление для папки разрешения система.

1) Щелкните папку правой кнопкой мыши, выберите пункт Свойства и откройте вкладку Безопасность.
2) Если вариант система не отображается в списке Группы или пользователи, щелкните Изменить.
3) Щелкните Добавить, введите в открывшемся окне система, затем щелкните Проверить имена.
4) В разделе Введите имена выбираемых объектов щелкните система, затем нажимайте кнопку ОК, пока не будут закрыты все открытые диалоговые окна.
5) Откройте меню Пуск, введите в строке поиска Параметры индексирования и нажмите Enter ↵.
6) Щелкните Дополнительно. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
7) В диалоговом окне Дополнительно перейдите на вкладку Параметры индексирования, а затем нажмите кнопку Перестроить. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.

Перестроение индекса может занять несколько часов, и до тех пор пока индекс не будет перестроен, результаты поиска могут быть неполными.


26. Исправление проблемы, когда автоматически не обновляется значок корзины, после ее очистки.

Вариант 1.

1) Запустите текстовый редактор, например «Блокнот».
2) Скопируйте в него текст указанный ниже:

3) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3.1) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DefaultIcon.reg")
3.2) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
4) Примените полученный reg-файл. Щелкните на нем дважды и нажмите кнопку Да, а затем ОК.

Вариант 2.

1) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Персонализация.
2) Нажмите ссылку Изменение значков рабочего стола.
3) Выберите значок Корзина (полная) и нажмите кнопку Сменить значок.
4) В диалоговом окне Смена значка, выберите значок полной корзины и нажмите кнопку ОК.
5) Выберите значок Корзина (пустая) и нажмите кнопку Сменить значок.
6) В диалоговом окне Смена значка, выберите значок пустой корзины и нажмите кнопку ОК.
7) В диалоговом окне Параметры значков рабочего стола нажмите кнопку ОК. Перейти к началу Общего списка советов.


27. Исправление ошибки из журнала событий: "Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".

При запуске и использовании (чтение, переход по страницам) в Windows файла справки с расширением *.CHM в журнале событий может появляться сообщение:
"Не удается найти описание для идентификатора события 1904 из источника HHCTRL.".
Это происходит из-за неправильного задания уровня безопасности системой для Местной интрасети в контейнере файла-справки.

Чтобы узнать появляется ли у Вас данная ошибка:

1) Откройте оснастку Просмотр событий
1.1) В строке поиска меню Пуск введите команду eventvwr.msc и нажмите Enter ↵
или
1.2) Пройдите Панель управления\Все элементы панели управления\Администрирование и откройте Просмотр событий.
2) Слева в древовидном списке оснастки Просмотр событий перейдите Просмотр событий (Локальный) → Журналы Windows → Приложение
3) В центральном окне будут описаны события произошедшие при работе с программами.

Для исправления данной ошибки, создайте и примените reg-файл следующего содержания:


28. Перезагрузка в Безопасный Режим при отсутствии данного пункта в меню Диспетчера загрузки.

Если у Вас в меню Диспетчера загрузки (вызывается нажатием клавишиF8 до появления экрана с логотипом Windows) отсутствует пункт для запуска Безопасного режима, то Вы можете попробовать перезагрузит© в Безопасный режим используя утилиту Windows - Настройка системы, для этого:

1) В строке поиска меню Пуск введите команду: msconfig
2) Перейдите на вкладку Загрузка
3) Установите флажок напротив пункта Безопасный режим.
4) Установите переключатель в нужное значение:

Минимальная - загрузка графического интерфейса пользователя ОС Windows (Проводника Windows) в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты отключены.
Другая оболочка - загрузка командной строки Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты и графический интерфейс пользователя отключены.
Восстановление Active Directory - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб и службы каталогов Active Directory.
Сеть - загрузка графического интерфейса пользователя Windows в безопасном режиме с запуском только самых важных системных служб. Сетевые компоненты включены.

5) Установите необходимые флажки:

Без GUI - во время загрузки Windows экран приветствия не отображается.
Журнал загрузки - вся информация, касающаяся процесса загрузки, сохранится в файле %SystemRoot%\Ntbtlog.txt.
Базовое видео - загрузка графического интерфейса пользователя Windows в минимальном режиме VGA. В этом режиме загружаются стандартные драйверы VGA вместо драйверов экрана, соответствующих видеооборудованию компьютера. Установка данного пункта позволяет загрузит© в безопасный режим при проблемах с драйверами видеокарты.
Информация об ОС - отображает имена загружаемых драйверов в процессе загрузки системы. Устанавливайте, если желаете самостоятельно определить проблемный драйвер или библиотеку мешающие загрузке.

6) Нажмите в текущем окне ОK, затем во всплывшем окне нажмите Перезагрузка.


29. Исправление ошибки 4201, возникающей при попытке запуска службы Журнал событий Windows (Windows Event Log).

Вариант 1.

1) В соответствии с разрядностью Вашего Windows скачайте и установите программу Unlocker
2) В Проводнике откройте папку C:\Windows\System32\LogFiles\WMI
3) Нажмите правой кнопкой на папке RtBackup и в контекстном меню выберите пункт Unlocker.
4) В ниспадающем списке выберите пункт Удалить и нажмите на кнопку Разблокировать Все
5) Перезагрузите компьютер
6) Запустите службу Журнал событий Windows.

Вариант 2.

1) Перезагрузитесь в безопасный режим с полным отключением всех служб (для этого воспользуйтесь утилитой msconfig)
2) Откройте папку C:\Windows\System32\LogFiles\WMI
3) Удалите подпапку RtBackup со всем его содержимым.
Если необходимо, то задайте перед удалением для данной папки полные права. Иногда помогает сначала удаление файлов из папки, а затем самой папки.
4) Перезагрузитесь обратно в нормальный режим.
5) Запустите службу Журнал событий Windows. Перейти к началу Общего списка советов.


30. Способы исправления ошибок при работе с программой sysprep.

Средство подготовки системы (Sysprep) - это технология, которую можно использовать вместе с другими средствами развертывания для установки операционных систем Windows® на новое оборудование.
Средство Sysprep подготавливает компьютер к созданию образа диска или к доставке клиенту путем настройки компьютера для создания нового идентификатора безопасности (SID) при перезапуске компьютера.
Кроме того, средство Sysprep удаляет параметры пользователя и системы, а также данные, которые не нужно копировать на конечный компьютер.
В случае возникновения проблем с ее использованием, Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1. Отключение конфликтующей службы.

1) Нажмите Пуск, введите в строке поиска Services.msc и нажмите Enter ↵ (Пуск → Администрирование → Службы)
2) Дважды щелкните на службу Служба общих сетевых ресурсов проигрывателя Windows Media
3) Установите Тип запуска в значение Отключена и нажмите ОК.
4) Перезапустите sysprep с необходимыми Вам параметрами.

Вариант 2. Завершение процесса конфликтующей службы.

1) Запустите sysprep
2) Выберите необходимые опции
3) Запустите Диспетчер задач (Ctrl + ⇑ Shift + Esc)
4) В Диспетчере задач завершите процесс wmpnetwk.exe
5) В окне sysprep быстро нажмите кнопку OK (до момента перезапуска процесса wmpnetwk.exe)

Вариант 3. Восстановление системы в исходное состояние лицензирования.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду: c:\windows\system32\slmgr.vbs –rearm

Вариант 4.

1) Откройте папку C:\Windows\Panther
2) В случае наличия в данной папке файла unattended.xml откройте его в блокноте
3) Измените используемые по умолчанию значения параметра PersistAllDeviceInstalls с true на false.
4) Сохраните измененные значения и закройте блокнот.
5) Запустите sysprep с необходимыми Вам параметрами.

Вариант 5.

1) Откройте папку C:\Windows\Panther
2) Скопируйте файл setup.etl на другой раздел (диск) во временную папку. Например, в D:\Test
3) Удерживая нажатой клавишу ⇑ Shift, щелкните правой кнопкой мыши на папку D:\Test и выберите пункт Открыть окно команд
4) Введите команду: tracerpt setup.etl -o logfile.csv
5) Закройте окно команд и откройте файл logfile.csv
6) Проанализируйте данный файл на предмет раздела реестра или процесса вызывающего ошибку.
7) Исправьте значение найденных конфликтующих параметров реестра на правильные, завершите конфликтующий процесс или удалите приложение, которому он принадлежит.
8) Запустите sysprep с необходимыми Вам параметрами.

Также рекомендую Вам почитать Техническое руководство по Sysprep от Microsoft Technet Возможно, информация указанная там, также укажет Вам путь к верному решению.


31. Компьютер не видит локальный диск с предыдущей ОС или диск отображается без буквы.

1) Щелкните правой кнопкой мыши на Компьютер (например в меню Пуск) и выберите Управление.
2) В левом окне выберите Управление дисками
3) Посередине вверху посмотрите, какие из томов не имеют букву.
Если среди томов присутствует раздел размером 200 МБ, то Вы ему букву не изменяете.
4) Присвойте букву тому диску, в котором находится предыдущая Windows (смотрим по размеру). Для этого щелкните на нем правой кнопкой мыши и в контекстном меню выберите пункт Изменить букву диска или путь к диску.
5) Нажмите Добавить, выберите букву и нажмите OK.
6) Через несколько секунд должно открыться окно автозапуска диска. А сам диск появится в Компьютере.
7) Откройте Панель управления → Параметры папок
8) Перейдите на вкладку Вид и проверьте установлен ли флажок Отображать буквы дисков, если нет, то установите его.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Администрирование и Интерфейс.


32. Восстановление фонового рисунка в экране авторизации пользователей (экране приветствия).

Вы можете восстановить (изменить) экран приветствия следующим образом:

1) Откройте в Проводнике папку C:\Windows\System32\oobe\
2) Если в ней присутствует папка info, то удалите ее.
3) Скачайте файл Full_access.zip, разархивируйте его и примените reg-файл.

4) Если у Вас 32-бит Windows, то:

4.1) Откройте папку C:\Windows\System32
4.2) Щелкните на файле imageres.dll правой кнопкой мышки и выберите пункт Стать владельцем и задать полный доступ к объекту

5) Если у Вас 64-бит Windows, то:

5.1) Откройте папку C:\Windows\System32
5.2) Щелкните на файле imageres.dll правой кнопкой мышки и выберите пункт Стать владельцем и задать полный доступ к объекту
5.3) Откройте папку C:\Windows\SysWOW64
5.4) Щелкните на файле imageres.dll правой кнопкой мышки и выберите пункт Стать владельцем и задать полный доступ к объекту

6) Скачайте файл Imageres.dll.zip и разархивируйте его.
7) В соответствии с разрядностью Вашей операционной системы скопируйте файлы в указанные выше папки.
8) Перезагрузите компьютер. Перейти к началу Общего списка советов.


33. Получение информации о проблемах при запуске и при завершении работы Windows 7.

Если запуск Windows или завершение ее работы занимают долгое время, а также если происходит какой-либо сбой, то скорее всего причины приведшие к этому будут записаны в журнале событий.

Для получения информации о причинах возникновения проблемы при запуске системы, сделайте следующее:

1) В диалоговом меню Выполнить (Win   + R) или в строке поиска меню Пуск введите eventvwr.msc и нажмите Enter ↵.
2) В списке слева перейдите Журналы приложений и служб → Microsoft → Windows → Diagnostics-Performance → Работает.

Внимание: Журнал с данными о загрузке системы формируется спустя некоторое время после запуска, поэтому не открывайте журнал сразу после загрузки, а подождите несколько минут.

Каждой загрузке соответствует событие с кодом 100. События с кодами со 101 по 199 описывают причины, приведшие к замедлению(сбою) процесса запуска системы.
Для более удобного анализа информации о загрузке, отфильтруйте журнал:

3) В меню Действия, расположенном справа от основного окна выберите команду Фильтр текущего журнала.
4) В открывшемся окне в поле <Все коды событий> укажите диапазон чисел, для этого введите: 101-199 и нажмите кнопку ОК.
Для того чтобы отменить действия фильтра, в меню Действия выберите команду Очистить фильтр. Для получения информации о причинах возникновения проблемы при завершении работы, сделайте следующее:

1) В диалоговом меню Выполнить (Win   + R) или в строке поиска меню Пуск введите eventvwr.msc и нажмите Enter ↵.
2) В списке слева перейдите Журналы приложений и служб → Microsoft → Windows → Diagnostics-Performance → Работает.

Каждому завершению работы соответствует событие с кодом 200. События с кодами со 201 по 299 описывают причины, приведшие к замедлению(сбою) процесса завершения работы системы.
Для более удобного анализа информации о загрузке, отфильтруйте журнал:

3) В меню Действия, расположенном справа от основного окна выберите команду Фильтр текущего журнала.
4) В открывшемся окне в поле <Все коды событий> укажите диапазон чисел, для этого введите: 201-299 и нажмите кнопку ОК.
Для того чтобы отменить действия фильтра, в меню Действия выберите команду Очистить фильтр. Перейти к началу Общего списка советов.


34. Решение проблем в работе компонента "Защита системы" и/или оснастки "Восстановление системы".

Воспользуйтесь данным советом в случае возникновения указанных проблем:

1) Не работает оснастка Восстановление системы (Пуск → Панель управления → Восстановление).
2) Неактивны кнопки в компоненте Защита системы (Пуск → Панель управления → Система → Защита системы).
3) Невозможно изменить настройки яў доступных дисков.
4) Не работает вкладка Предыдущие версии в свойствах файлов.
5) Проблемы при создании точки восстановления системы для какого-либо из дисков.

Для начала проверьте включена ли у Вас функция Защита системы для требуемого диска.

1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
2) Нажмите ссылку Защита системы
3) В открывшемся окне в пункте Параметры защиты Вы увидите перечень дисков, в котором напротив каждого указано, включена защита или нет (сразу после установки Windows 7 защита включена только для диска, на который установлена операционная система).
4) Кликните левой кнопкой мыши по нужному диску и нажмите кнопку Настроить.
5) В открывшемся окне в пункте Параметры восстановления отметьте Восстановить параметры системы и предыдущие версии файлов и нажмите ОК.
6) Создайте точку восстановления системы, нажав на кнопку Создать.

Если указанное выше у Вас не работает или же наоборот все включено, но возникают проблемы, то выполните поочередно действия предложенные далее в вариантах.

Вариант 1.

1) Проверьте права и пользователей установленные для папок System Volume Information на Ваших дисках.
1.1) Щелкните правой кнопкой мыши на папке System Volume Information и выберите пункт Свойства
1.2) Перейдите на вкладку Безопасность.

По умолчанию в разделе группы или пользователи должно стоять только - система (SYSTEM) с полным доступом прав.
Если Вы добавили пользователя или изменили права для пользователя система (SYSTEM), то верните все в изначальные значения.

Вариант 2.

1) Откройте Панель управления → Администрирование и запустите Службы (Win   + R → services.msc → ОК)
Проверьте установленный тип запуска для служб:

Программный поставщик теневого копирования (Microsoft Software Shadow Copy Provider).
Теневое копирование тома (Volume Shadow Copy)

По умолчанию они должны быть установлены в значение Вручную.
2) Если одна из данных служб отключена, то дважды щелкните на нее и в открывшемся окне установите тип запуска в значение Вручную.

Вариант 3.

1.1) Запустите Редактор локальной групповой политики (Win   + R → gpedit.msc → ОК)
1.2) Откройте Конфигурация компьютера → Административные шаблоны → Система → Восстановление системы.

Значения параметров Отключить конфигурацию и Отключить восстановление системы в столбце Состояние должно быть указано Не задана.
Если в столбце Состояние значение для любого из данных параметров указано как Включена, то:

1.3) Щелкните правой кнопкой мыши на необходимом параметре и выберите пункт Изменить
1.4) В открывшемся окне установите переключатель в значение Не задано и нажмите кнопку ОК.

Вариант 4.

Создайте и примените reg-файл с указанным ниже текстом.

где: DiskPercent = Объем дискового пространства, зарезервированный под точки восстановления системы (5%)
RPLifeInterval = Число секунд, в течении которых будут хранит© точки восстановления перед их удалением (7776000 секунд или 90 дней)

Вариант 5.

Удалите имеющиеся у Вас точки восстановления и попробуйте создать точку восстановления заново.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите необходимую команду и нажмите Enter ↵:

Удаление всех теневых копий на всех томах: vssadmin delete shadows /all
Удаление теневых копий на томе: vssadmin delete shadows /for=C:

где C: - буква тома

3) Скачайте архив: SCRP+script.zip и распакуйте его.
4) Щелкните правой кнопкой мыши на файле SCRP.exe и выберите пункт Запуск от имени администратора.
5) Перезагрузите компьютер проверьте появилась ли точка восстановления созданная программой. если не появилась, то:
6) Откройте папку куда Вы распаковали архив SCRP+script.zip
7) Откройте папку elevateWHSScript, щелкните правой кнопкой мыши на файле ElevateWSHScript.inf и выберите в контекстном меню пункт Установить
8) Вернитесь в предыдущую папку.
9) Щелкните правой кнопкой мыши на файле crp.vbs и выберите пункт Запуск от имени администратора.
10) Перезагрузите компьютер проверьте появилась ли точка восстановления созданная с помощью скрипта.

Вариант 6.

Измените минимальный размер области хранения теневых копий.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VolSnap
3) Создайте новый параметр типа DWORD (32 бита) c именем MinDiffAreaFileSize
4) Щелкните правой кнопкой мыши по параметру MinDiffAreaFileSize и выберите пункт Изменить...
5) В текстовом поле Значение установите значение: 3000
Данное значение равно 3000 МБ.
6) Перезагрузите компьютер.

Измените максимальный объем хранилища теневой копии.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду vssadmin list shadowstorage и нажмите Enter ↵.
3) Запомните букву в пункте Для тома: и значение пункта Максимальный объем хранилища теневой копии (Предположим он равен 15 GB).
4) Уменьшите значение данного параметра, введя команду и нажав Enter ↵:

5) Верните прежнее значение обратно, введя команду и нажав Enter ↵:

где C: - буква тома, а /Maxsize=15GB - максимальный объем хранилища теневой копии. Перейти к началу Общего списка советов.


35. Исправление ошибок связанных с отсутствием папки Desktop в папках "C:\Windows\System32\config\systemprofile" и/или "C:\Windows\SysWOW64\config\systemprofile".

Если у Вас возникают ошибки связанные с отсутствием папки Desktop в какой-либо из папок "C:\Windows\System32\config\systemprofile" и/или "C:\Windows\SysWOW64\config\systemprofile", то скорее всего У Вас произошло повреждение файла пользователя Система, так как по умолчанию папка Desktop в указанных папках в Windows 7 отсутствует.

Для исправления данной проблемы воспользуйтесь одним из указанных ниже вариантов.

Вариант 1.

1) Откройте папку Вашего профиля в C:\Users (Например: C:\Users\Administrator)
2) Если в ней Вы обнаружите две папки Desktop, то удалите ту которая пустая.
3) Откройте C:\Windows\System32\config\systemprofile
4) Если в ней Вы обнаружите папку Desktop, то удалите ее целиком, если она пустая или удалите ее содержимое, если в ней содержаться какие-либо файлы.
5) Для 64-битных систем дополнительно откройте папку C:\Windows\SysWOW64\config\systemprofile и убедитесь, что в ней присутствует папка Desktop.
Также Вы можете скопировать содержимое папки Desktop из Вашего профиля в папки:
C:\Windows\System32\config\systemprofile и C:\Windows\SysWOW64\config\systemprofile.

Вариант 2.

1) Скачайте и распакуйте архив systemprofile.zip в любую папку.
2) Откройте папку C:\windows\system32\config\systemprofile
3) Удалите все файлы содержащие в названии NTUSER.
4) Откройте папку куда Вы распаковали архив.
5) В зависимости от разрядности Вашей Windows cкопируйте содержимое папки systemprofile_x64 (для 64-битных) или systemprofile_x86 (для 32-битных) в соответствующие папки.
6) Перезагрузите компьютер. Перейти к началу Общего списка советов.


36. Исправление ошибки: Недостаточно места для создания файла для хранения файла теневой копии.

Если у Вас возникает ошибка Недостаточно места для создания файла для хранения файла теневой копии, то для ее решения попробуйте один из предложенных вариантов:

Вариант 1.

Убедитесь, что размер занятого пространства на диске для которого Вы делаете архивацию менее, размера свободного места на диске, куда Вы сохраняете образ системы.
А размер свободного пространства на диске для которого Вы делаете архивацию более 40 МБ.

Вариант 2.

Исключите из архивирования содержимое библиотек и попробуйте снова.

Вариант 3. Очистка места занимаемого USN журналом на скрытом разделе.

Возможно у Вас не хватает места для записи метаданных на скрытом разделе "100 МБ Зарезервировано системой", необходимых для создания архивной копии.
Вам необходимо примерно 40 МБ свободного пространства для этого.

1) В строке поиска меню Пуск введите diskmgmt.msc и нажмите Enter ↵.
2) Щелкните правой кнопкой мыши на разделе размером 100 мегабайт и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву (Пример: Z) и нажмите кнопку OK.
3) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4) Введите последовательно набор команд, нажимая для подтверждения каждой из них клавишу Enter ↵.

5) Повторите архивацию данных.
6) После успешного создания теневой копии, снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете раздел в 100 мегабайт снова Скрытым.

Вариант 4. Удалите скрытый раздел и переместите загрузочные файлы для Windows со скрытого раздела на диск на котором установлена Ваша Windows.

ПримҐйте данный вариант, только если Вам не помог Вариант 3.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду и нажмите клавишу Enter ↵ для ее подтверждения.

3) В строке поиска меню Пуск введите diskmgmt.msc и нажмите Enter ↵.
4.1) В нижней части окна, где находится графическое представление разделов, найдите том (раздел) на котором установлена Ваша Windows 7.
Буква тома здесь, идентична букве диска с Window 7 из Компьютер.
4.2) Щелкните правой кнопкой мыши по данному разделу и выберите в контекстном меню пункт Сделать раздел активным.
5) Перезагрузите компьютер.
6) В строке поиска меню Пуск введите diskmgmt.msc и нажмите Enter ↵.
7) Щелкните правой кнопкой мыши на разделе размером 100 мегабайт и выберите пункт Удалить том и нажмите кнопку Да.
8) Перезагрузите компьютер и выполните архивацию снова. Перейти к началу Общего списка советов.


37. Решение проблем: "Консоль управления не может создать оснастку" и "MMC не удается инициализировать оснастку".

Если у Вас возникла одна из проблем: Консоль управления не может создать оснастку и/или MMC не удается инициализировать оснастку, то для ее/их решения выполните следующие действия.

1) Откройте папку С:\Users\ВашПрофиль\AppData\Roaming\Microsoft\MMC\ и удалите все файлы находящиеся в ней.
2) Откройте Панель управления\Система и безопасность\Система и нажмите ссылку Дополнительные параметры системы.
3) Нажмите на кнопку Переменные среды.
4) Щелкните дважды на переменную Path в разделе Системные переменные для открытия окна Изменение системной переменной.
5) Проверьте чтобы в текстовом поле Значение переменной среди всех адресов присутствовали следующие адреса, причем, именно в указанном порядке:

Если они отсутствуют, то добавьте их в самое начало. Для отделения их от уже имеющихся значений используйте знак ; (точка с запятой).
6) Откройте Панель управления\Все элементы панели управления\Программы и компоненты
7) Нажмите слева на ссылку Просмотр установленных обновлений.
8) Удалите все обновления из групп Microsoft .NET Framework 4 Client Profile и Microsoft .NET Framework 4 Extended. Перезагрузите компьютер, если система предложит.
9) Нажмите стрелку назад, чтобы вернуться Панель управления\Все элементы панели управления\Программы и компоненты.
10) Удалите программы Microsoft .NET Framework 4 Client Profile и Microsoft .NET Framework 4 Extended. Перезагрузите компьютер, если система предложит.
11) Нажмите слева на ссылку Включение или отключение компонентов Windows.
12) Найдите в списке Microsoft .NET Framework 3.5.1 и снимите флажок (или затененный флажок) и нажмите кнопку ОК. Перезагрузите компьютер, если система предложит.
13) Откройте Панель управления\Система и безопасность\Администрирование и запустите оснастку Службы.
14) Остановите службы Microsoft .NET Framework NGEN v2.0.50727_X86 и Microsoft .NET Framework NGEN v2.0.50727_X64 (для 64-битной Windows)
15) Откройте папку C:\Windows и задайте полный доступ к папке Microsoft.NET используя решение предложенное в совете 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
16) Удалите все возможное содержимое папки C:\Windows\Microsoft.NET.
17) Нажмите Ctrl + ⇑ Shift + Esc, перейдите в Диспетчере задач на вкладку Процессы и завершите все процессы WmiPrvSE.exe.
18) Удалите оставшиеся файлы используя программу Unlocker, упоминаемую в совете 5. Разблокирование файла используемого какой-либо программой для действий с ним. из раздела Тонкие настройки.
Не перезагружайте компьютер!
19) Откройте программой 7zip файл install.wim из папки sources на установочном диске.
20) Откройте в нем папку Windows и извлеките куда-нибудь папку Microsoft.NET.
21) Скопируйте все содержимое из папки Microsoft.NET извлеченной из файла install.wim в папку C:\Windows\Microsoft.NET.
Те у кого отсутствует установочный диск могут скачать готовый архив с папкой Microsoft.NET.
Ссылка: для 32-битной версии Windows 7 или для 64-битной версии Windows 7.
22) Откройте Панель управления\Все элементы панели управления\Программы и компоненты
23) Нажмите слева на ссылку Включение или отключение компонентов Windows.
24) Найдите в списке Microsoft .NET Framework 3.5.1 и установите затененный флажок и нажмите кнопку ОК. Перезагрузите компьютер, если система предложит.
25) Установите Microsoft .NET Framework 4.5.2 (Полная версия).
26) Откройте Панель управления\Система и безопасность\Центр обновления Windows и установите все обновления для Microsoft .NET Framework. Перезагрузите компьютер, если система предложит.
27) Откройте Панель управления\Система и безопасность\Администрирование и запустите оснастку Службы.
28) Установите для служб Microsoft .NET Framework NGEN v2.0.50727_X86, Microsoft .NET Framework NGEN v2.0.50727_X64 (для 64-битной Windows), Microsoft .NET Framework NGEN v4.0.30319_X86 и Microsoft .NET Framework NGEN v4.0.30319_X64 (для 64-битной Windows) тип запуска: Автоматически.
Для этого щелкните дважды на службе, установите тип запуска: Автоматически и нажмите кнопку ОК.
29) Перезагрузите компьютер.
30) Запустите оснастку, в которой была обнаружена указанная ошибка. Проблема должна исчезнуть. Перейти к началу Общего списка советов.


38. Решение проблемы при запуске Планировщика заданий: Задание <имя_задачи>: Образ задачи поврежден или изменен.

Если при запуске Планировщика заданий появляется ошибка Образ задачи поврежден или изменен., то для ее решения выполните следующие действия:

1) Запустите редактор реестра (Win + R → regedit → OK)
2) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree
3) Найдите подраздел, соответствующий поврежденной задаче (в нем должно содержаться ее имя)

Пример:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\Customer Experience Improvement Program\Uploader
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\PerfTrack\BackgroundConfigSurveyor

4) Щелкните на подраздел реестра, соответствующий поврежденной задаче, и запишите значение {GUID} параметра Id.

Пример:

{5380A838-E45C-48BC-AD22-C757867B640E} для задачи Uploader.
{3B28E4FF-1F90-45CB-8090-EB8372567E3E} для задачи BackgroundConfigSurveyor.

5) Запустите Планировщик заданий.
5.1) Откройте меню Пуск → Панель управления → Администрирование → Планировщик заданий или в строке поиска меню Пуск введите taskschd.msc и нажмите Enter ↵.
6) В левой области разверните список Библиотека планировщика заданий и найдите папку с поврежденной задачей.
Обычно ее имя соответствует названию раздела, в котором находится подраздел поврежденной задачи в реестре.
А путь к ней совпадает с путем к подразделу поврежденной задачи в реестре.

Пример:

Библиотека планировщика заданий → Microsoft → Windows → Customer Experience Improvement Program для задачи Uploader.
Библиотека планировщика заданий → Microsoft → Windows → PerfTrack для задачи BackgroundConfigSurveyor.

7) Щелкните на задачу, и запишите значение поля Размещение.
Обычно данное значение соответствует пути к подразделу поврежденной задачи в реестре.

Пример:

\Microsoft\Windows\Customer Experience Improvement Program для задачи Uploader.
\Microsoft\Windows\PerfTrack для задачи BackgroundConfigSurveyor.

8) Закройте Планировщик заданий.
9) Откройте в Проводнике папку C:\Windows\System32\Tasks
10) Откройте в ней папку, используя значение указанное в поле Размещение.

Пример:

C:\Windows\System32\Tasks\\Microsoft\Windows\Customer Experience Improvement Program для задачи Uploader.
C:\Windows\System32\Tasks\\Microsoft\Windows\PerfTrack для задачи BackgroundConfigSurveyor.

11) Скопируйте файл, соответствующий поврежденной задаче в любую временную папку.
12) Удалите файл, соответствующий поврежденной задаче, из папки C:\Windows\System32\Tasks\<путь_к_папке_с_поврежденной_задачей>

Пример:

Удалите файл Uploader из папки C:\Windows\System32\Tasks\Microsoft\Windows\Customer Experience Improvement Program
Удалите файл BackgroundConfigSurveyor из папки C:\Windows\System32\Tasks\Microsoft\Windows\PerfTrack

13) Используя найденное Вами ранее значение {GUID} найдите и удалите подраздел, соответствующий поврежденной задаче, из указанного ниже раздела реестра.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks

Пример:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\{5380A838-E45C-48BC-AD22-C757867B640E} для задачи Uploader.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tasks\{3B28E4FF-1F90-45CB-8090-EB8372567E3E} для задачи BackgroundConfigSurveyor.

14) Используя найденное Вами ранее значение {GUID} найдите и удалите подраздел, соответствующий поврежденной задаче, из указанных ниже разделов реестра.
Задача может находит© только в одном из них.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Boot
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Logon

Пример:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain\{5380A838-E45C-48BC-AD22-C757867B640E} для задачи Uploader.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Plain\{3B28E4FF-1F90-45CB-8090-EB8372567E3E} для задачи BackgroundConfigSurveyor.

15) Удалите подраздел, соответствующий поврежденной задаче, из указанного ниже раздела реестра.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree

Пример:

Подраздел Uploader из раздела
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\Customer Experience Improvement Program
Подраздел BackgroundConfigSurveyor из раздела
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\PerfTrack

16) Запустите Планировщик заданий.
17) В левой области разверните список Библиотека планировщика заданий и откройте папку, в которой раньше находилась поврежденная задача.

Пример:

Библиотека планировщика заданий → Microsoft → Windows → Customer Experience Improvement Program для задачи Uploader.
Библиотека планировщика заданий → Microsoft → Windows → PerfTrack для задачи BackgroundConfigSurveyor.

18) Щелкните на данной папке правой кнопкой мыши и выберите команду Импортировать задачу.
19) В диалоговом окне Открыть выберите пункт Все файлы (*.*).
20) Откройте временную папку с резервной копией задачи и выберите соответствующий файл.
21) Нажмите кнопку Открыть и в Планировщике заданий появится восстановленная задача.


39. Изменение параметров отправки отчета при отказе работы программы.

Если произошел отказ в работе программы, то в зависимости от настроек системы, Windows предложит либо найти решение в Интернете, либо закрыть программу.
Чтобы настроить какое действие должно выполнятся при отказе в работе программы сделайте следующее:

1) Откройте Панель управления\Система и безопасность\Центр поддержки
2) Разверните группу настроек Обслуживание.
3) В разделе Поиск решений для указанных в отчетах проблем нажмите на ссылку Параметры.

В открывшемся окне Вы увидите несколько значений переключателя от выбора значений которого зависит выполняемые действия при отказе работы программы.

4.1) При выборе значения Автоматически проверять наличие новых решений при нажатии пункта Закрыть программу произойдет закрытие программы, после чего Windows соединится с интернетом и только проверит имеется ли решение для данной проблемы.

4.2) При выборе значения Автоматически проверять на наличие новых решений и при необходимости отправлять дополнительные данные отчета при нажатии пункта Закрыть программу произойдет закрытие программы, после чего Windows соединится с интернетом, проверит имеется ли решение для данной проблемы и при необходимости отправит отчет с данными об ошибке.

4.3) При выборе значения Каждый раз при возникновении проблемы отображать запрос до проверки на наличие решений:

4.3.1) При нажатии пункта Искать решение проблемы в Интернете и закрыть программу (Выполнить поиск решения и закрыть программу) произойдет закрытие программы, после чего Windows соединится с интернетом, проверит имеется ли решение для данной проблемы и при необходимости отправит отчет с данными об ошибке.
4.3.2) При нажатии пункта Закрыть программу произойдет только закрытие программы.

4.4) При выборе значения Не проверять на наличие новых решений при нажатии пункта Закрыть программу произойдет только закрытие программы.

5) Выберите необходимое Вам значение и нажмите кнопку ОК. Перейти к началу Общего списка советов.


40. Использование монитора ресурсов для уточнения цели ожидания приложением, которое не отвечает.

Приложения, которые не отвечают, могут ожидать завершения других процессов.
Возможно также, что для продолжения работы таких приложений необходим доступ к системным ресурсам.
Чтобы просмотреть цепочку ожидания процесса и завершить процессы, которые мешают программе правильно работать, необходимо воспользоваться Монитором ресурсов Windows.
Чтобы проанализировать процесс при помощи монитора ресурсов, выполните следующие действия.

1) Нажмите комбинацию клавиш Win   + R
2) Введите команду resmon и нажмите Enter ↵.
3) Щелкните правой кнопкой мыши на имени исполняемого файла процесса, который нужно проанализировать, и выберите команду Анализ цепочки ожидания.

Если процесс выполняется в нормальном режиме и не ожидает других процессов, то никаких сведений о цепочке ожидания не отображается.
Если процесс ожидает другой процесс, то будет показано дерево зависимостей от других процессов.

Чтобы завершить один или несколько процессов в дереве, установив флажки рядом с именами процессов и нажмите кнопку Завершить процесс. Перейти к началу Общего списка советов.


41. Исправление ошибки 0x80071A91 выдаваемой каким-либо из элементов Windows.

Если у Вас при работе с каким-либо элементом Windows возникает ошибка 0x80071A91, то возможно это является сбоем журнала транзакций файловой системы или журнала общего назначения.
Чтобы исправить данную ошибку воспользуйтесь одним из предложенных ниже решений.

Вариант 1.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

Примечание: Предполагается, что Windows установлена в папке по умолчанию на диске C:\.

Вариант 2.

1) Перезагрузите компьютер
2) До начала запуска Windows нажмите на клавишуF8. При ¦влении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter ↵, а затем сразуF8.
3) Выберите пункт Устранение неполадок компьютера (Repair your computer) и нажмите клавишу Enter ↵.
4) Выберите язык раскладки клавиатуры, на котором у вас задан пароль административной учетной записи. Введите пароль администратора. Выберите пункт Командная строка (Command Prompt).
5) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵:

Примечание: Предполагается, что Windows установлена в папке по умолчанию на диске C:\.

6) Закройте командную строку и перезагрузите компьютер обратно в Windows.


42. Исправление ошибки: "... не является внутренней или внешней командой исполняемой программой или пакетным файлом".

Если при запуске какой-либо из системных программ (например: reg, regedit, ipconfig, telnet) у Вас появляется ошибка:

То для её решения воспользуйтесь одним из указанных ниже вариантов:

Вариант 1.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\Environment
3) Проверьте присутствует ли в данном разделе строковый параметр Path
Если данный параметр у Вас отсутствует, то:
3.1) Щелкните правой кнопкой мыши на разделе Environment и выберите Создать → Строковый параметр
3.2) Щелкните правой кнопкой мыши на созданном параметре и выберите Переименовать
3.3) Введите Path и нажмите Enter ↵

4) Щелкните дважды на параметре Path и введите указанное ниже значение, а затем нажмите кнопку ОК.

5) Перезагрузите компьютер.

Вариант 2.

1) Создайте и примените reg-файл указанного ниже содержания.

2) Перезагрузите компьютер. Перейти к началу Общего списка советов.


43. Решение проблемы с некорректной работой анимации или Диспетчера окон рабочего стола (dwm.exe).

Если у Вас некорректно работает анимация окон или Вам кажется, что "Диспетчер окон рабочего стола" (dwm.exe) работает некорректно, то Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1. Перезапуск файла dwm.exe.

Чтобы перезапустить файл dwm.exe, Вам необходимо перезапустить службу "Диспетчер сеансов диспетчера окон рабочего стола".

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.

Вариант 2. Отключение визуальных эффектов, связанных с анимацией.

1) Откройте Пуск → Панель управления → Система.
2) Слева в списке нажмите ссылку Дополнительные параметры системы.
3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
4) На вкладке Визуальные эффекты снимите флажки напротив указанных ниже пунктов и нажмите кнопку ОК:

Анимация в меню "Пуск” и панели задач
Анимация окон при свертывании и развертывании
Анимированные элементы управления и элементы внутри окна
Затухание меню после вызова команды
Эффекты затухания или скольжения при обращении к меню
Эффекты затухания или скольжения при ¦влении подсказок


44. Исправление ошибки "Не удалось открыть объект групповой политики на этом компьютере. Возможно, у вас недостаточно прав."

Если у Вас при запуске редактора глобальной групповой политики (gpedit.msc) появляется сообщение об ошибке:

Не удалось открыть объект групповой политики на этом компьютере. Возможно, у вас недостаточно прав.

или

Failed to open the Group Policy Object on this computer. You might not have the appropriate rights.

То для исправления данной проблемы:

1) Закройте данное сообщение об ошибке.
2) Запустите Проводник (Windows Explorer).
3) Откройте папку C:\Windows\System32\GroupPolicy и удалите папку Machine (C:\Windows\System32\GroupPolicy\Machine).
4) Запустите редактор глобальной групповой политики (gpedit.msc).

Если удаления папки C:\Windows\System32\GroupPolicy\Machine окажется недостаточным для исправления данной проблемы, то удалите папку C:\Windows\System32\GroupPolicy.


45. Исправление ошибки "Пространство имен "Microsoft.Policies.Sensors.WindowsLocationProvider" уже определено как целевое пространство имен для другого файла в хранилище".

Если у Вас при запуске редактора глобальной групповой политики (gpedit.msc) появляется сообщение об ошибке:

Пространство имен "Microsoft.Policies.Sensors.WindowsLocationProvider" уже определено как целевое пространство имен для другого файла в хранилище.

или

Namespace "Microsoft.Policies.Sensors.WindowsLocationProvider" is already defined as the target namespace for another file in the store.

То для исправления данной проблемы:

1) Скачайте архив TakeOwnershipEx.zip и распакуйте в любую папку.
2) Откройте данную папку, нажмите правой кнопкой мыши на exe-файл и выберите пункт Запуск от имени администратора.
3) Выберите необходимый Вам язык Russian (Русский) или English (Английский) и нажмите кнопку ОК.
4) Нажмите последовательно кнопки Далее, Принимаю, Далее, Установить, Готово (Next, I Agree, Next, Install и Finish).
5) Откройте папку C:\Windows\PolicyDefinitions
6) Щелкните правой кнопкой мыши на файле LocationProviderADM.admx и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
7) Во всплывшем окне нажмите кнопку ОК.
8) Удалите LocationProviderADM.admx
9) Щелкните правой кнопкой мыши на файле Microsoft-Windows-Geolocation-WLPAdm.admx и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
10) Во всплывшем окне нажмите кнопку ОК.
11) Переименуйте файл Microsoft-Windows-Geolocation-WLPAdm.admx в LocationProviderADM.admx
12) Щелкните правой кнопкой мыши на файле LocationProviderADM.admx и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
13) Во всплывшем окне нажмите кнопку ОК.
14) Откройте папку C:\Windows\PolicyDefinitions\en-US
15) Щелкните правой кнопкой мыши на файле LocationProviderADM.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
16) Во всплывшем окне нажмите кнопку ОК.
17) Удалите LocationProviderADM.adml
18) Щелкните правой кнопкой мыши на файле Microsoft-Windows-Geolocation-WLPAdm.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
19) Во всплывшем окне нажмите кнопку ОК.
20) Переименуйте файл Microsoft-Windows-Geolocation-WLPAdm.adml в LocationProviderADM.adml
21) Щелкните правой кнопкой мыши на файле LocationProviderADM.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
22) Во всплывшем окне нажмите кнопку ОК.
23) Откройте папку C:\Windows\PolicyDefinitions\ru-RU
24) Щелкните правой кнопкой мыши на файле LocationProviderADM.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
25) Во всплывшем окне нажмите кнопку ОК.
26) Удалите LocationProviderADM.adml
27) Щелкните правой кнопкой мыши на файле Microsoft-Windows-Geolocation-WLPAdm.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
28) Во всплывшем окне нажмите кнопку ОК.
29) Переименуйте файл Microsoft-Windows-Geolocation-WLPAdm.adml в LocationProviderADM.adml
30) Щелкните правой кнопкой мыши на файле LocationProviderADM.adml и выберите пункт Получить доступ/Восстановить права (Take Ownership/Restore Rights).
31) Во всплывшем окне нажмите кнопку ОК. Перейти к началу Общего списка советов.


1. Исправление исчезновения панели быстрого запуска после перезагрузки.

Если Вы создаете панель быстрого запуска, но после перезагрузки она исчезает, то попробуйте любое из предложенных ниже решений.

1) Попробуйте создать панель быстрого запуска со значением отличающимся от Вашего:

%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch
%appdata%\Microsoft\Internet Explorer\Quick Launch
C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch

2) Установите ползунок контроля учетных записей (UAC) в предпоследнее значение.

3) Создайте и добавьте в реестр следующий reg-файл:

4) Откройте C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Internet Explorer
Добавьте на вкладке Свойства → Безопасность пользователя Все и задайте ему полный доступ.

5) В диалоговом окне Выполнить из меню Пуск (Win   + R) введите команду control userpasswords2 и нажмите Enter ↵.
Поставьте флажок на "Требовать ввод имени пользователя и пароля"

6) В диалоговом окне Выполнить из меню Пуск (Win   + R) введите команду gpedit.msc и нажмите Enter ↵.
Откройте Конфигурация пользователя → Административные Шаблоны → Меню "Пуск" и панель задач
Измените параметр политики Отображение панели быстрый запуск на панели задач на значение Включить.

7) Закройте Языковую панель и установите вместо неё Punto Switcher.


2. Исправление сбоев возникающих при установке, обновлении или удалении программы с помощью установщика Windows (msiexec.exe).

Вариант 1

1) Перейдите Пуск→Все программы→Стандартные
2) Щелкните правой кнопкой мыши на пункт Командная строка и нажмите Запуск от имени Администратора
3) Скопируйте следующую строчку в окно команд и нажмите Enter ↵:

Вариант 2

1) Откройте меню Пуск, введите в строке поиска regedit и нажмите Enter ↵.
2) Перейдите в раздел HKLM\SOFTWARE\Microsoft\SQMClient\Windows
3) Щелкните правой кнопкой мыши на разделе DisabledSessions и нажмите Удалить. Перейти к началу Общего списка советов.


3. Восстановление пункта "Выполнить" в меню "Пуск".

Если у Вас отмечен пункт Команда "Выполнить" в "Настройка меню Пуск" (На кнопке Пуск нажмите правую кнопку мыши и выберите пункт Свойства, нажмите кнопку Настроить), а меню "Выполнить" не показывает Вы можете восстановить его так:
1) В Меню "Пуск" в строке поиска наберите gpedit.msc и откройте найденный файл gpedit.msc (Редактор групповых политик)
2) В левой части открывшегося окна пройти к вкладке:
Политика "Локальный компьютер"\Конфигурация пользователя\Административные шаблоны\Меню «Пуск» и панель задач
3) Выделите в правой части строку Добавить команду "Выполнить" в меню "Пуск"
4) Щелкните по строке Изменить параметр политики, в появившемся окне выделите пункт "Включить" и нажмите Применить и OK.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


4. Убирание появляющейся в меню Пуск полоски, пропадающей при повторном открытии.

Данная ошибка исправлена в Сервисном Пакете 1 (Service Pack 1).

1) Переключаете язык интерфейса в английскую версию Windows: Панель управления→Язык и Региональные Стандарты→Языки и Клавиатуры→Язык интерфейса→выбираете английский
2) Перелогиниваетесь или перезапускаете компьютер
3) Задаёте полный доступ к файлу aero.msstyles.mui из папки C:\Windows\Resources\Themes\Aero\ru-RU
4) Копируете с заменой aero.msstyles.mui из C:\Windows\Resources\Themes\Aero\en-US в C:\Windows\Resources\Themes\Aero\ru-RU
5) Возвращаете язык интерфейса на русский
Для тех у кого изначально русская, выкладываю данный файл отдельно aero.msstyles.mui.zip

Также Вы можете скачать и запустить от имени Администратора готовый патч: MenuFix_Rus_x86_x64_Final.rar
После его применения понадобит© перезагрузить компьютер.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


5. Восстановление ассоциации для *.cpl файлов.

Если какая-нибудь программа сбила Вам ассоциацию приложения Windows c файлами *.cpl.

1) Щелкните правой кнопкой мыши на любом файле *.cpl и выберите Свойства
2) На вкладке Общие напротив надписи Приложение нажмите кнопку Изменить.
3) В открывшемся окне нажмите кнопку Обзор
4) Зайдите в папку C:\Windows\System32 и выберите файл control.exe
5) Нажмите ОК

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


6. Исправление вылета Проводника при нажатии правой кнопки мыши на файле или папке.

Скачайте небольшую утилиту ShellExView: английскую версию с официального сайта или русскую версию с зеркала.

Вариант 1.

Оптимальным решением проблемы может быть отключение расширения оболочки CmdLineExt.dll.
1) Запустите ShellExView.
2) Найдите среди выведенных ею расширений оболочки - расширение с именем CmdLineContextMenu Class
3) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
4) Перезагрузите компьютер.

или

1) Нажмите Пуск → Выполнить (Win   + R)
2) Введите команду regsvr32 /u CmdLineExt.dll и нажмите ОК.
3) Перезагрузите компьютер.

Вариант 2.

1) Запустите ShellExView.
2) Сделайте сортировку по столбцу Type (щелкните мышкой на названии столбца). Вас будут интересовать записи, где Type = Context Menu, а в столбце File Extensions есть звездочка.
3) Отключайте записи по очереди, начав с расширений, не принадлежащих Microsoft. Отключение выполняется щелчком правой кнопкой мыши → Disable Selected Items или клавишей F7.
4) Отключив запись, проверьте работу Проводника.

Если Вы отключили все расширения, но проблема не решилась, то запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
Введите команду и нажмите Enter ↵: sfc /scannow

Если данное действие не возымеет успеха, то перезагрузитесь в безопасный режим Windows.
Если в безопасном режиме данная проблема пропадает, тогда всё нормально, значит, проблема вызвана одной из установленных у вас программ, драйверов, кодеков или служб и Вам придется вручную искать причину вызвавшую сбой. Удалять по одной программе, отключать по одной службе или откатываться к предыдущим версиям установленных драйверов, либо используя точки восстановления возвращаться к предыдущим состояниям системы и наблюдать на каком этапе исчезла ошибка. Перейти к началу Общего списка советов.


7. Восстановление исчезнувшей языковой панели.

Исчезновение языковой панели, чаще всего происходит после использования чистильщика или оптимизатора системы.
Перед использованием одного из предложенных вариантов, сделайте следующее:

1) Откройте редактор реестра (Win   + R → regedit → OK )
2) Проверьте, не добавлен ли запрет на запуск языковой панели в следующую папку реестра:

3) Проверьте, присутствует ли в реестре ветки:

Region and Language

Keyboard

4) Проверьте значение параметров, в ветке реестра:реестра:

– значение REG_SZ-параметра AppName должно быть ctfmon.exe
– значение REG_SZ-параметра AppPath должно быть С:\Windows\system32.

где C: - буква диска на который у Вас установлена Windows

Вариант 1

1) Откройте Панель управления → Язык и региональные стандарты
2) Выполните все по пунктам на скриншотах.

3) На вкладке Языки и Клавиатуры нажмите кнопку Изменить клавиатуру.
4) На вкладке Языковая панель установите переключатель в положение Закреплена в панели задач, отметьте флажок Отображать текстовые метки на языковой панели и нажмите OK
5) Щелкните правой кнопкой на панели задач, выбираете Свойства.
6) В пункте Область уведомлений щелкаем кнопку Настроить

7) В открывшемся окне поставьте флажок напротив Всегда показывать все значки и уведомления на панели задач и нажмите OK

Вариант 2

В контекстном меню панели задач уберите флажок со значения Закрепить панель задач, расширьте границы для всех панелей, а затем снова поставьте флажок напротив Закрепить панель задач.

Вариант 3

Найдите файл ctfmon.exe и добавьте его в Автозагрузку или создайте reg-файл со следующим содержанием:

Вариант 4

1) Откройте Языки и службы текстового ввода

Так:

1.1.1) Откройте Пуск → Выполнить (или нажмите на клавиатуре Win   + R)
1.1.2) Введите команду: RunDll32.exe shell32.dll,Control_RunDLL C:\Windows\system32\input.dll
1.1.3) Нажмите OK.

Или так:

1.2.1) Откройте Панель управления\Часы, язык и регион
1.2.2) Нажмите на ссылку Смена раскладки клавиатуры или других способов ввода
1.2.3) Нажмите на кнопку Изменить клавиатуру
2) На вкладке Общие удалите все раскладки клавиатуры кроме Английский
3) На вкладке Языковая панель снимите все флажки и установите переключатель в значение Скрыта
4) Выгрузите вручную библиотеки.
4.1) Откройте Пуск → Выполнить (или нажмите на клавиатуре Win   + R)
4.2) Выполните поочередно команды:

5) Перезагрузите компьютер.
6) Откройте Языки и службы текстового ввода
7) На вкладке Общие добавьте нужные Вам раскладки клавиатуры
8) На вкладке Языковая панель установите переключатель в значение Закреплена в панели задач и установите флажок напротив пункта Отображать текстовые метки на языковой панели.
9) Нажмите OK.

Как альтернативный вариант Вы можете установить программу Punto Switcher, она добавляет собственную языковую панель и функцию автоматического переключения раскладки при неправильном её выборе.


8. Исправление ошибки, когда папки "Недавние места" и "Недавние документы" пустые.

1) Щелкните правой кнопкой мыши на кнопке Пуск и нажмите на Свойства
2) Установите флажки напротив пунктов:
"Хранить и отображать список недавно открывшихся программ в меню "Пуск"
"Хранить и отображать список недавно открывшихся элементов в меню "Пуск" и на панели задач"
3) Нажмите OK.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


9. Удаление появившейся на рабочем столе папки "Недавние места".

1) Удалите папку C:\Users\Default\AppData\Roaming\Microsoft\Windows\Recent
2) Перезагрузите компьютер или перезапустите систему
3) Зайдите в C:\Users\Default\AppData\Roaming\Microsoft\Windows\
4) Если Windows 7 не восстановил папку Recent заново, создайте её самостоятельно.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


10. Решение ошибки "Отсутствует исполняющее ядро для расширения имени файла js"

Иногда какое-то приложение может изменить ассоциацию к файлам ".js" (Например, текстовый редактор, использующий скрипты).
Что может привести к ошибке "Отсутствует исполняющее ядро для расширения имени файла js".
Переустановка Java от Sun Microsystems или компонентов с сайта Майкрософт, не всегда исправляет эту ошибку.

Необходимо восстановить через реестр значение по умолчанию "JSFile" .

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Запустите reg-файл.


11. Исправление неполадок в работе гаджетов.

Если у Вас появились неполадки в работе гаджетов, то для их решения Вы можете воспользоваться одним из предложенных вариантов.

Вариант 1. Если гаджет не работает при отключенном контроле учетных записей (UAC).

1) Создайте reg-файл указанного ниже содержания.

2) Примените его и перезагрузите компьютер.

Вариант 2. Если гаджет погоды, пишет: "Не удалось подключится к службе" (Service unavailable for your region)

Для начала запустите Internet Explorer и проверьте отсутствие в меню Файл установленного флажка Работать автономно.

1) Запустите Диспетчер задач нажав комбинацию клавиш Ctrl + ⇑ Shift + Esc.
2) Завершите процесс sidebar.exe
3) Запустите Гаджеты: щелкните правой кнопкой мыши на рабстоле и выберите в контекстном меню пункт Гаджеты.

Если данного действия оказалось недостаточно, то:

1) Откройте меню Пуск и введите в строке поиска слово: блокнот.
2) Щелкните на найденном блокноте правой кнопкой мыши и выберите пункт "Запуск от имени администратора".
3) Нажмите в блокноте комбинацию клавиш Ctrl + O
4) Перейдите в папку Windows\System32\drivers\etc\
5) Откройте файл hosts.
6) Добавьте следующие строки:

Если указанные действия не помогли, то поставьте другой гаджет погоды, например: AccuWeather.com® Forecast Gadget или HTC Home

Вариант 3. Если после добавления собственного гаджета, не загружается процесс sidebar.exe и/или не работают родные гаджеты.

1) Откройте в Проводнике указанные ниже папки, удалите из них данный гаджет (папку с именем и расширением .Gadget) и перезагрузите систему.

%ProgramFiles%\Windows Sidebar\Gadgets
%ProgramFiles%\Windows Sidebar\Shared Gadgets
%LOCALAPPDATA%\Microsoft\Windows Sidebar\Gadgets

2) Откройте папку %LOCALAPPDATA%\Microsoft\Windows Sidebar\
3) Откройте в блокноте файл Settings.ini и удалите раздел [Hashes] со всеми его значениями.
4) Сохраните файл и перезагрузите компьютер.

Вариант 4. Если групповой политикой полностью отключены гаджеты и/или отключена установка неподписанных гаджетов и/или гаджетов установленных пользователем.

1) Создайте reg-файл указанного ниже содержания.

2) Примените его и перезагрузите компьютер.

Вариант 5. Удаление в реестре лишней зоны безопасности яў Internet Explorer.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\
3) Удалите все лишние разделы, кроме разделов с 0-го по 4-й.

Вариант 6. Повторная регистрация необходимых библиотек.

1) Запустите командную строку от имени Администратора (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
2) По очереди введите команды указанные ниже, нажимая после введения каждой Enter ↵:


12. Восстановление функциональности пункта "Закрепить программу в панели задач".

Если у Вас не отображается пункт "Закрепить программу в панели задач":

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Примените созданный reg-файл и перезагрузите компьютер.

Если при выборе пункта "Закрепить программу в панели задач" не закрепляется программа:

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .bat
3) Если выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "test.bat")
4) Если выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Щелкните на созданном Вами файле правой кнопкой мыши и нажмите "Запуск от имени администратора". Перейти к началу Общего списка советов.


13. Пользовательские папки отображаются обычными иконками.

Если у вас пользовательские папки, такие как Документы, Изображения и т.п., отображаются в Проводнике с обычными иконками, как и любые другие папки, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в таких папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать с указанным ниже содержимым и с указанными выше атрибутами.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Содержимое файлов desktop.ini для стандартных пользовательских папок

Документы

Изображения

Музыка

Видео

Поиски

Загрузка

Избранное

Контакты

Рабочий стол

Ссылки

Сохраненные игры

Общий рабочий стол

Общие документы

Общая музыка

Общие изображения

Общее видео


14. Исправление проблемы, с дублированием ярлыков на рабочем столе.

Если при создании, копировании или перемещении на рабочий стол любого документа/ярлыка/папки, после обновления экрана или перезагрузки компьютера, у Вас появляются их дубликаты (точная копия, без (2) в названии), то это означает, что Ваш собственный рабочий стол и общий рабочий стол прописаны в реестре в одной папке. Данная проблема решается указанием для них отдельных отличающихся между собою папок.

1) Запустите Редактор реестра. Для этого в строке поиска в меню Пуск введите regedit и нажмите Enter ↵
2) Откройте раздел: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
3) Измените значение параметра Common Desktop на одно из предложенных ниже:

C:\Users\Public\Desktop - значение Windows по умолчанию
C:\Users\ВашПрофиль\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок.

4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
5) Измените значение параметра Common Desktop на одно из предложенных ниже:

%Public%\Desktop - значение Windows по умолчанию
%USERPROFILE%\Public\Desktop - рекомендуемое значение при изменении путей системных папок и при удалении общих папок. Перейти к началу Общего списка советов.


15. Восстановление поиска в Проводнике и в меню Пуск.

1) Используя Реестр (Win   + R → regedit)
1.1) Откройте ветку реестра:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
1.2) В случае обнаружения параметра NoFind, удалите его.

2) Используя Панель управления
2.1) Откройте Панель управления\Программы\Программы и компоненты
2.2) Запустите "Включение и отключение компонентов Windows" (или Win   + R → OptionalFeatures.exe)
2.3) Проверьте, включен ли у Вас компонент Windows Search (Поиск Windows).

3) Используя Редактор локальной групповой политики.
3.1) В диалоговом окне Выполнить из меню Пуск (Win   + R) введите команду gpedit.msc и нажмите Enter ↵.
3.2) Откройте Конфигурация пользователя → Административные Шаблоны → Меню "Пуск" и панель задач
3.3) Измените следующие параметры политики на значение Не задана:

- Добавить ссылку "Поиск в Интернете" в меню "Пуск"
- Удалить ссылку "Поиск" из меню "Пуск" Перейти к началу Общего списка советов.


16. Исправление всплывающей подсказки оказывающейся за панелью задач Windows.

Если у Вас возникает ошибка, когда всплывающая подсказка оказывается за панелью задач Windows, и её видно частично или совсем не видно, то Вы можете воспользоваться небольшой программой ToolTipFixer, которая исправляет эту ошибку, возвращая на место всплывающую подсказку.

Скачайте и установите программу ToolTipFixer: с официального сайта или с зеркала


17. Решение проблемы пропадания значков в панели задач.

Это происходит потому, что загружаемые программы пытаются установить иконки раньше, чем Проводник успевает инициировать трей.
Для установки задержки запуска программ, Вы можете воспользоваться менеджером автозагрузки Startup Delayer.

В дополнение к программе воспользуйтесь твиком реестра.

Скачайте и примените его: tray_icons.reg Перейти к началу Общего списка советов.


18. Удаление ярлыков на отсутствующие в системе элементы в папке "Недавние места".

18. Удаление ярлыков на остутствующие в системе элементы в папке "Недавние места".

Для удаления ярлыков на отсутствующие в системе элементы из папки "Недавние места" предлагаю Вам следующие варианты решения.

Вариант 1.

1) Откройте в Проводнике папку Недавние документы (%AppData%\Microsoft\Windows\Recent)
Просьба не путать с папкой Недавние места (это другая папка)
2) Щелкните правой кнопкой мыши ярлык на отсутствующий в системе элемент(папку или файл) и выберите пункт Удалить.
3) Щелкните правой кнопкой мыши на рабочем столе и выберите пункт Обновить. Данное действие необходимо, чтобы убрать появившуюся на рабочем столе папку Недавние места.

Вариант 2.

Для его выполнения необходима программа Registry Workshop - заменяющая стандартный редактор реестра.

1) Запустите Registry Workshop
2) Нажмите Search (Поиск) → Find...(Поиск...)
3) В открывшемся окне установите переключатель на Search in key: (В разделе:)
4) Введите HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RecentDocs
5) В текстовом поле Find what: (Запрос:) введите наименование отсутствующего в системе элемента (папки или файла)
6) Нажмите кнопку Find (Поиск)
7) Выделите найденное с помощью левой кнопки мыши или нажмите комбинацию клавиш Ctrl + A, чтобы выделить все.
8) Щелкните на выделенном правой кнопкой мыши и выберите пункт Delete From Registry (Удалить из реестра) Перейти к началу Общего списка советов.


19. При загрузке Windows автоматически открывается окно Проводника.

Варианты решений:

1) Откройте Пуск → Панель управления → Параметры папок → и уберите флажок "Восстанавливать прежние окна папок при входе в систему".
2) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
3) Введите команду и нажмите Enter ↵: sfc /scannow
4) Создайте и примените reg-файл:


20. Восстановление запуска Exe-файлов в системе.

Данные проблема связана с изменением какой-нибудь программой в реестре параметров отвечающих за ассоциации exe-файлов.
Для устранения данной проблемы попробуйте один из следующих вариантов.

Вариант 1.

1) Откройте папку C:\Windows\System32
2) Сделайте копию файла regedt32.exe
3) Переименуйте данную копию в regedt32.com
4) Щелкните на данном файле правой кнопкой мыши и выберите Запуск от имени администратора.
5) Откройте ветку HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe
6) Удалите раздел UserChoice

Вариант 2.

1) Скачайте файл exefix_win7.zip
2) Разархивируйте его и примените reg-файл.

или же создайте самостоятельно в блокноте reg-файл следующего содержания:


21. Исправление ошибки Проводника "Не удалось найти этот элемент" (Could not find this item).

Если у Вас возникает ошибка "Не удалось найти этот элемент" (Could not find this item), то скорее всего у Вас сбились описания для системных папок, а также возможно данные об их местоположении.

Чтобы это исправить Вам необходимо восстановить значения указанных ниже разделов реестра по умолчанию:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions (дополнительно для 64-битных систем)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders (дополнительно для 64-битных систем)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\ProfileList (дополнительно для 64-битных систем)

Вы можете сделать это скачав и применив один из созданных мною reg-файлов.

1) Скачайте файл NotFindThisItem_Repair.zip
2) Распакуйте его в любую папку.
3) В соответствии с разрядностью Вашей Windows примените reg-файл, восстанавливающий настройки описания папок в изначальные.
4) Перезагрузите компьютер.


22. Исправление появляющегося окна предупреждения системы безопасности "Неизвестный издатель", при открытии программы из меню Пуск.

1) Запустите командную строку от имени Администратора
(Нажмите Пуск → в строке поиска введите cmd → щелкните правой кнопкой мыши по найденному файлу cmd.exe → выберите пункт Запуск от имени Администратора)
2) Поочередно введите команды, нажимая для их выполнения клавишу Enter ↵:


23. Если у вас при запуске файлов *.chm неправильно определяется кодировка.

Если при создании *.chm файла принудительно не указать на каждой странице кодировку, то при его чтении у некоторых людей могут возникнуть трудности с определением кодировки. Для решения данной проблемы:

1) Закройте *.chm файл
2) Зайдите в Internet Explorer
3) Нажмите правую кнопку мыши
4) В появившемся меню наведите указатель на слово Кодировка и поставьте галочку напротив пункта Автовыбор
5) Запустите ваш *.chm и система сама определит кодировку.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Рабочий стол, Проводник, Панель задач.


24. Проводник не обновляет содержимое папки.

Если Вы желаете исправить проблему, когда в Проводнике автоматически не обновляется содержимое папки и приходится нажимать клавишу F5 чтобы обновить ее содержимое, то для этого существует очень большое количество решений и для каждой из систем подходит разное.

Вариант 1. Обновление BIOS до последней версии.

Скачайте и обновите в интернете последнюю версию BIOS для Вашей материнской платы.

Вариант 2. Установите подходящие драйвера.

Установите для Ваших устройств (сетевая карта, жесткие диски, видеокарта, звуковая карта) другие драйвера отличающиеся от Ваших:

- новые с сайта производитЈ
- старые с прилагаемого к устройству диска
- последние поставляемые службой Windows Update от Microsoft.

Вариант 3. Сhkdsk.

1) Запустите командную строку (Win   + R → cmd → OK).
2) Введите команду chkdsk и нажмите Enter ↵.

Вариант 4. Sfc /scannow.

1) Запустите командную строку (Win   + R → cmd → OK).
2) Введите команду sfc /scannow и нажмите Enter ↵.

Вариант 5. Сброс вида папок в Параметрах папок.

1) В меню Пуск откройте Панель управления
2) Установите Просмотр на Крупные значки и выберите Параметры папок
3) Перейдите на вкладку Вид и нажмите кнопку Сброс вида папок.
4) В открывшемся окне нажмите кнопку Да.

Вариант 6. Изменение значения контроля учетных записей (UAC).

1) Откройте Пуск → Панель управления → Учетные записи пользователей
2) Нажмите на ссылку Изменение параметров контроля учетных записей.
3) Установите переключатель в предпоследнее значение и нажмите кнопку ОК.

Вариант 7. Очистка кэша иконок и увеличение его размера.

1) Откройте Проводник
2) Введите в адресной строке %LOCALAPPDATA% и нажмите Enter ↵.
3) Удалите файл IconCache.db
4) Запустите редактор реестра (Win   + R → regedit → ОК)
5) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
6) Создайте строковый параметр (String-параметр) с именем Max Cached Icons
7) Щелкните на нем дважды введите значение 12000 и нажмите ОК.

Вариант 8. Отключение индексирования файлов.

1) Откройте Панель управления → Администрирование и запустите Службы (Win   + R → services.msc → ОК)
2) Щелкните дважды на службе Windows Search.
3) Установите тип запуска в значение Отключена и нажмите кнопку ОК.
4) В меню Пуск откройте папку Компьютер
5) Щелкните правой кнопкой мыши на жестком диске и выберите пункт Свойства.
6) Уберите флажок Разрешить индексировать содержимое файлов на этом диске в дополнение к свойствам файлов и нажмите кнопку ОК.
7) Установите переключатель в значение К диску X:\ и ко всем вложенным папкам и файлам и нажмите кнопку ОК.
8) Если всплывет окно Отказано в доступе нажмите Продолжить, если всплывет окно Ошибка изменения атрибутов, то выберите пункт Пропустить все.
9) Перезагрузите компьютер.

Вариант 9. Отключение всех не-Microsoft служб и надстроек для Проводника.

1) Войдите в систему с учетной записью, имеющей права администратора.
2) Нажмите кнопку Пуск, в строке поиска введите команду msconfig.exe и нажмите клавишу Enter ↵, чтобы запустить Конфигурация системы.
3) Перейдите на вкладку Службы
4) Установите флажок Не отображать службы Майкрософт и нажмите кнопку Отключить все.
5) Нажмите кнопку ОК и щелкните Перезагрузка.

6) Скачайте небольшую утилиту ShellExView: английскую версию с официального сайта или русскую версию с зеркала.
7) Запустите ShellExView.
8) Найдите среди выведенных ею расширений оболочки - надстройки, которые не принадлежат Microsoft и отключите их.
9) Выделите и нажмите клавишу F7 или через контекстное меню выберите опцию Disable Selected Items.
10) Перезагрузите компьютер.

Вариант 10. Отключение сетевого обнаружения и общего доступа.

1) Щелкните правой кнопкой мыши на значок Сеть на Панели задач и выберите пункт Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
3) Щелкните на профиль Домашний или рабочий
4) Установите переключатели в значения:

Отключить сетевое обнаружение
Отключить общий доступ к файлам и принтерам

5) Щелкните на профиль Общий
6) Установите переключатели в значения:

Отключить сетевое обнаружение
Отключить общий доступ к файлам и принтерам

7) Нажмите на кнопку Сохранить изменения.

Вариант 11. Отключение пункта "Клиент для сетей Microsoft" в Свойствах "Подключение по локальной сети".

1) Щелкните правой кнопкой мыши на значок Сеть на Панели задач и выберите пункт Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменение параметров адаптера.
3) Щелкните правой кнопкой мыши на Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
4) Снимите флажок Клиент для сетей Microsoft и нажмите кнопку ОК.

Вариант 12. Установка размера буферов передачи и приема сетевой карты на максимальные значения.

1) Щелкните правой кнопкой мыши на значок Сеть на Панели задач и выберите пункт Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменение параметров адаптера.
3) Щелкните правой кнопкой мыши на Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
4) Нажмите кнопку Настроить
5) Перейдите на вкладку Дополнительно
6) Установите для свойств Receive Buffers и Transmit Buffers максимальные значения, и нажмите кнопку ОК.

Вариант 13. Создание дополнительных параметров в реестре с различными значениями.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Измените или создайте в следующих ниже разделах указанные параметры:

2.1) Изменить значение DWORD-параметра NtfsDisableLastAccessUpdate на противоположное в разделе HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem.
2.2) Создать DWORD-параметр NoNetCrawling со значением 1 в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced.
2.3) Создать DWORD-параметр NoSimpleNetIDList со значением 1 в разделе HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer.

Вариант 14. Отключение библиотек в панели навигации проводника Windows.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder
3) В списке слева, щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Разрешения.
4) Щелкните левой кнопкой мыши на группу Администраторы:
6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.
7) Дважды щелкните на параметре Attributes и измените его значение с b080010d на b090010d.
8) Закройте редактор реестра и перезапустите компьютер.

Пользователям Windows x64 также следует внести идентичные изменения в раздел:
HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder

Вариант 15. Отключение очистки буфера кэша записей.

1) Откройте Пуск → Панель управления → Диспетчер устройств
2) Разверните объект Дисковые устройства
3) Щелкните правой кнопкой мыши на устройстве и выберите пункт Свойства.
4) Перейдите на вкладку Политика
5) Установите флажок Отключить очистку буфера кэша записей Windows для этого устройства и нажмите кнопку ОК.
Если у Вас несколько дисковых устройств, то повторите данные действия для каждого устройства.

Вариант 16. Изменение режима обновлений для объектов групповой политики в домене.

1) Создайте reg-файл.
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "updatemode.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Примените полученный reg-файл. Щелкните на нем дважды и нажмите кнопку Да.

Вариант 17. Удаление и запрет создания параметра ExpandedState в реестре.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Modules\NavPane
3) Удалите параметр ExpandedState
4) В списке слева, щелкните правой кнопкой мыши на разделе реестра NavPane и выберите пункт Разрешения.
5) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
6) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
7) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
8) Нажмите кнопку Дополнительно и перейдите на вкладку Разрешения
9) Уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажмите кнопку Удалить.
10) Нажмите поочередно кнопки Добавить... → Дополнительно... → Поиск
11) В результатах поиска выберите Все и нажмите кнопку OK, и еще раз ОК.
12) Установите флажок в колонке Разрешить напротив следующих разрешений:

Запрос значения
Перечисление подразделов
Уведомление
Чтение разрешений

13) Нажмите кнопку ОК
14) Перезагрузите компьютер.

Примечание:

Ошибка не появляется и всё автоматически обновляется, если выключена локальная сеть или если завершить все процессы explorer.exe и запустить их заново.


25. Создание ярлыка и комбинации клавиш для закрытия зависших приложений и перезапуска Проводника.

Создание ярлыка и комбинации клавиш для закрытия зависших приложений.

1) Щелкните по рабочему столу и выберите во всплывшем меню Создать → Ярлык.
2) В поле Укажите расположение объекта введите команду

3) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
4) В поле Быстрый вызов назначьте комбинацию клавиш для использования.

Создание ярлыка и комбинации клавиш для перезапуска Проводника.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).

2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .cmd. Например: restart_explorer.cmd
3) Щелкните по рабочему столу и выберите во всплывшем меню Создать → Ярлык.
4) В поле Укажите расположение объекта выберите созданный Вами командный файл.
5) Щелкните правой кнопкой мыши на ярлыке и выберите Свойства
6) В поле Быстрый вызов назначьте комбинацию клавиш для использования. Перейти к началу Общего списка советов.


26. Восстановление в всплывающем меню "Создать" пункта "Папку".

Если у Вас из всплывающего меню Создать находящегося в основном контекстном меню(вызывается нажатием правой кнопки мыши) пропал пункт Папку, то Вы можете скачать и применить reg-файл содержащий изначальные настройки яў данного пункта меню в реестре.

Чтобы применение reg-файла прошло успешно, воспользуйтесь небольшой инструкцией:

1) Измените разрешения (установите полный доступ) и владельца для раздела реестра: HKEY_CLASSES_ROOT\CLSID\{11dbb47c-a525-400b-9e80-a54615a090c0}

1.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
1.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
1.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
1.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
1.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

2) Скачайте и примените reg-файл. NewFolderFix.zip
3) Перезагрузите компьютер. Для желающих создать данный reg-файл самостоятельно его текст:


27. Исправление отсутствия в папке Все программы из меню Пуск папки "Стандартные".

Для исправления данной ситуации Вам необходимо создать новый профиль и скопировать из него необходимые папки.

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter ↵.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в средней части окна и выберите Новый пользователь.
4) Введите любое имя пользователя (Например: Demo) и снимите флажок "Требовать смены пароля при следующем входе в систему"
5) Нажмите Создать, а когда кнопка станет не активной нажмите Закрыть.
6) Выйдите из системы и войдите в систему, используя только что созданную учётную запись.
7) Выйдите из системы и войдите в систему, используя Вашу учётную запись.
8) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter ↵.

где Demo - имя созданной Вами учетной записи.
9) Щелкните правой кнопкой мыши на папке Стандартные (Accessories) и выберите пункт Копировать
10) Откройте Проводник введите в адресной строке указанный ниже адрес папки и нажмите Enter ↵.

где UserName - имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
11) Щелкните правой кнопкой мыши в пустой части окна данной папки и выберите пункт Вставить
12) Перезагрузите компьютер.

Для удаления созданной Вами учетной записи пользователя:

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter ↵.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в списке на имя созданной Вами учетной записи и выберите пункт Удалить
4) Нажмите во всплывшем окне кнопку Да и выйдите из оснастки "Локальные пользователи и группы"
5) Откройте в Проводнике папку C:\Users и удалите папку с именем созданной Вами учетной записи.


28. В папке "Библиотеки" вложенные папки (Изображения, Видео, Документы, Музыка) стали отображаться на английском языке.

Если у Вас пользовательские папки, такие как Изображения, Видео, Документы, Музыка в Проводнике стали отображаться на английском языке, то это может быть вызвано отсутствием или повреждением файлов desktop.ini, расположенных в данных папках. Или же эти файлы имеют неправильные атрибуты.
Если файл desktop.ini присутствует в папке, его атрибуты должны быть Скрытый и Только чтение.
В случае если файла desktop.ini нет в папке, его необходимо создать заново.
Для вступления в силу изменений необходимо завершение сеанса или перезагрузка.

Вариант 1. Создайте новый профиль и скопируйте из него необходимые Desktop.ini файлы.

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter ↵.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в средней части окна и выберите Новый пользователь.
4) Введите любое имя пользователя (Например: Demo) и снимите флажок Требовать смены пароля при следующем входе в систему
5) Нажмите Создать, а когда кнопка станет не активной нажмите Закрыть.
6) Выйдите из системы и войдите в систему, используя только что созданную учётную запись.
7) Выйдите из системы и войдите в систему, используя Вашу учётную запись.
8) Откройте Проводник и введите в адресной строке необходимой адрес папки из указанного ниже списка и нажмите Enter ↵.

где Demo - имя созданной Вами учетной записи.
9) Щелкните правой кнопкой мыши на файле desktop.ini и выберите пункт Копировать
10) Введите в адресной строке Проводника адрес папки, соответствующий наименованию папки, откуда Вы скопировали файл desktop.ini и нажмите Enter ↵.

где UserName - замените на имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
Public - имя общей учетной записи (не заменяется).

11) Щелкните правой кнопкой мыши в пустой части окна данной папки и выберите пункт Вставить
12) Перезагрузите компьютер.

Для удаления созданной Вами учетной записи пользователя:

1) В строке поиска меню Пуск введите lusrmgr.msc и нажмите Enter ↵.
2) Перейдите в папку Пользователи
3) Щелкните правой кнопкой мыши в списке на имя созданной Вами учетной записи и выберите пункт Удалить
4) Нажмите во всплывшем окне кнопку Да и выйдите из оснастки Локальные пользователи и группы
5) Откройте в Проводнике папку C:\Users и удалите папку с именем созданной Вами учетной записи.

Вариант 2. Создайте файлы desktop.ini самостоятельно в указанных ниже папках.

Создайте вручную в каждой из указанных ниже папок файл desktop.ini с приведенным далее текстом.

где UserName - замените на имя Вашей учетной записи (его можно узнать открыв папку C:\Users).
Public - имя общей учетной записи (не заменяется).

Внимание: перед параметром [.ShellClassInfo] должна быть пустая строка отступ.

Для папки Videos:

Для папки Documents:

Для папки Pictures:

Для папки Music:


29. Восстановление пропавшего из контекстного меню пункта создания текстового документа (txt-файл).

Если у Вас из контекстного меню создать вызываемого нажатием правой кнопки мыши пропал пункт Создать → Текстовый документ (Text Document), то для восстановления возможности создания текстовых документов выполните указанные ниже действия:

1) Создайте reg-файл указанного ниже содержания.

2) Примените его и перезагрузите компьютер. Перейти к началу Общего списка советов.


30. Решение проблемы в работе AeroPeek, при которой рабочий стол не показывается при наведении мыши на край панели задач.

Если у Вас не работает функция AeroPeek, при которой рабочий стол показывается при наведении мыши на край панели задач, то выполните следующие действия:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Установите значение Dword-параметра DisablePreviewDesktop равным 0.
4) Перезагрузите компьютер или перезайдите в систему.
5) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите Свойства.
6) Нажмите на ссылку Дополнительные параметры системы и в открывшемся окне перейдите на вкладку Дополнительно.
7) В разделе Быстродействие нажмите на кнопку Параметры.
8) Установите переключатель на Обеспечить наилучшее быстродействие и нажмите кнопку Применить
9) Установите переключатель в значение Обеспечить наилучший вид и нажмите кнопку ОК.
10) Закройте окно Свойства системы. Перейти к началу Общего списка советов.


31. Исправление нечитабельности текста под значками на рабочем столе при использовании однотонного фонового изображения.

Шрифт, используемый по умолчанию в иконках Рабочего стола отбрасывает тень.
Иногда из-за этого, при наложении текста на однотонное фоновое изображение, его невозможно прочитать.
Решением в данном случае является отключение тени шрифта.

Вариант 1.

1) Щелкните в меню Пуск правой кнопкой мыши на Компьютер и выберите пункт Свойства
2) В открывшемся окне в списке слева щелкните по ссылке Дополнительные параметры системы.
3) Нажмите кнопку Параметры в разделе Быстродействие.
4) Снимите флажок Отбрасывание теней значками на рабочем столе и нажмите ОК.

Вариант 2.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Щелкните дважды на параметре ListviewShadow или щелкните правой кнопкой мыши на нем и выберите Изменить
4) Установите значение данного параметра равным 0.
5) Перезагрузите компьютер. Перейти к началу Общего списка советов.


32. Восстановление пункта "Очистить список последних элементов" в контекстном меню "Недавние документы".

Данную проблему можно исправить следующим образом.

1) Отключите отображение пункта Недавние документы в меню Пуск.
1.1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт Свойства
1.2) Перейдите на вкладку Меню "Пуск" и нажмите кнопку Настроить
1.3) Снимите флажок Недавние документы и нажмите кнопку OK.
2) Откройте в меню Пуск диалоговое окно Выполнить (Win   + R), введите: %AppData%\Microsoft\Windows и нажмите Enter ↵.
3) Щелкните правой кнопкой мыши на папку Недавние документы (Recent) и выберите пункт Удалить.

Если такой пункт отсутствует, то воспользуйтесь программой Unlocker для удаления данной папки.

3.1) В соответствии с разрядностью Вашего Windows cкачайте и установите программу Unlocker
3.2) Нажмите правой кнопкой на файле и в контекстном меню выберите Unlocker.
3.3) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все.

4) Откройте в меню Пуск диалоговое окно Выполнить (Win   + R), введите: shell:recent и нажмите Enter ↵. (Данное действие заново создаст папку Недавние документы.)
5) Перезагрузите компьютер или перезайтите в систему.
6) Включите пункт Недавние документы в меню Пуск.
6.1) Щелкните правой кнопкой мыши на кнопку Пуск и выберите пункт Свойства
6.2) Перейдите на вкладку Меню "Пуск" и нажмите кнопку Настроить
6.3) Установите флажок Недавние документы и нажмите кнопку OK.


33. Очистка кэша эскизов, для решения проблем с их отображением.

Если у Вас возникли проблемы с отображением эскизов, то Вам может помочь удаление кэша эскизов.
Для очистки кэша эскизов, выполните указанные ниже действия.

1) Нажмите комбинацию клавиш Win   + R, в поле Открыть напишите cleanmgr и нажмите OK.
2) Выберите диск на который у Вас установлена Windows (по умолчанию C:) и после оценки объема места, которое можно освободить, отметьте Эскизы и нажмите OK.
Данное действие приведет к удалению из папки %LocalAppData%\Microsoft\Windows\Explorer файлов:

thumbcache_32.db
thumbcache_96.db
thumbcache_256.db
thumbcache_1024.db
thumbcache_idx.db
thumbcache_sr.db

После удаления кэша - эскизы вновь будут записаны при обращении к папкам с обрабатываемыми типами файлов.


34. Изменение атрибутов папки или файла при недоступном поле для установки флажка атрибутов в свойствах объекта в Проводнике.

Если поле для установки флажка для установки атрибутов в свойствах объекта в Проводнике стало неактивным (затенненым), то для изменения атрибутов файла, сделайте следующее.

1) Нажмите кнопку Пуск
2) Перейдите Все Программы → Стандартные
3) Щелкните правой кнопкой мыши на Командная строка и выберите пункт Запуск от имени администратора.
4) Введите необходимую Вам команду в соответствии с указанным ниже шаблоном и нажмите Enter ↵:

Где:

+R - установить атрибут Только чтение
-R - снять атрибут Только чтение

+A - установить атрибут Архивный
-A - снять атрибут Архивный

+S - установить атрибут Только чтение
-S - снять атрибут Только чтение

+H - установить атрибут Скрытый
-H - снять атрибут Скрытый

/S - Обработка файлов с указанными именами в текущем каталоге и во всех его подкаталогах.
/D - Обработка файлов и каталогов.

Пример:

Снятие всех установленных атрибутов, кроме Архивный у папки C:\Users - это сделает папку видимой и разрешит вносить в нее изменения.


35. Исправление проблемы появления в меню Вид пункта Расширенная плитка вместо Плитка.

Если у Вас в контекстном меню Вид, используемом для изменения стиля отображения значков в папке появился пункт Расширенная плитка вместо привычного пункта Плитка, то воспользуйтесь следующим решением:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
3) Удалите подразделы Bags и BagMRU.
4) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
5) Удалите параметр FullRowSelect (если он существует).
6) Перезагрузите компьютер.

или

Создайте и примените reg-файл, указанного ниже содержания.


36. Исправление ошибки, когда сначала перетаскивается рамка Проводника, а лишь затем окно.

Если у Вас при попытке переместить окно Проводника, сначала перетаскивается рамка Проводника, а лишь затем окно, то воспользуйтесь следующим решением:

1) Откройте Пуск → Панель управления → Система.
2) Слева в списке нажмите ссылку Дополнительные параметры системы.
3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
4) На вкладке Визуальные эффекты установите флажок напротив пункта: Отображение содержимого окна при перетаскивании и нажмите кнопку Применить.

Если у Вас уже установлен флажок напротив данного пункта, то снимите его и нажмите кнопку Применить, после чего снова установите флажок и §ть нажмите Применить.

Также Вы можете создать reg-файл, указанного ниже содержания, после применения которого Вам будет необходимо перезагрузить компьютер.


37. Удаление рекламных баннеров с рабочего стола.

Если у Вас на экране рабочего стола появился рекламный баннер с требованием указать номер телефона или отправить деньги на интернет-кошелёк, то для его удаления воспользуйтесь предложенной ниже инструкцией.

1) Вставьте или подключите установочный DVD-диск или флеш-диск (флешку) к компьютеру.
2) Перезагрузите компьютер.
3) Нажмите кнопку для вызова загрузочного меню (Boot Menu) (В зависимости от производитЈ материнской платы F8, F11, F12)
4) Выберите в списке Ваш диск и нажмите клавишу Enter ↵.
5) После загрузки в установочный экран Windows нажмите ⇑ Shift + F10.
6) Введите regedit и нажмите клавишу Enter ↵.
7) Нажмите на раздел HKEY_LOCAL_MACHINE
8) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
9) Откройте папку C:\Windows\System32\config (D:\Windows\System32\config), выберите файл SOFTWARE и нажмите кнопку Открыть (Open).
10) Задайте временное имя для куста (Например: SOFTWARE_original)
11) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows NT\CurrentVersion\Winlogon
12) Щелкните на параметр Shell и нажмите клавишу Enter ↵.
13) Введите указанное ниже значение и снова нажмите клавишу Enter ↵.

14) Щелкните на параметр Userinit и нажмите клавишу Enter ↵.
15) Введите указанное ниже значение (включая запятую) и снова нажмите клавишу Enter ↵.

16) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows NT\CurrentVersion\Windows
17) Щелкните на параметр AppInit_DLLs и нажмите клавишу Enter ↵.
18) Полностью удалите любое указанное значение для данного параметра и снова нажмите клавишу Enter ↵.
19) Откройте поочередно указанные ниже ветки реестра и удалите любые подозрительные программы из автозапуска.

HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\SOFTWARE_original\Wow6432Node\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE_original\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce

20) Нажмите на куст SOFTWARE_original
21) Откройте меню Файл (File) и нажмите Выгрузить куст (Unload Hive)

22) Нажмите на раздел HKEY_USERS
23) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
24) Откройте папку Вашего профиля C:\Users\Username (Например: C:\Users\Nizaury)
25) Введите в поле Имя файла (File name) ntuser.dat и нажмите кнопку Открыть (Open).
26) Задайте временное имя для куста (Например: Username_original)
27) Откройте поочередно указанные ниже ветки реестра и удалите любые подозрительные программы из автозапуска.

HKEY_USERS\Username_original\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_USERS\Username_original\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce

28) Нажмите на куст Username_original
29) Откройте меню Файл (File) и нажмите Выгрузить куст (Unload Hive)


1. Невозможно переместить Временные файлы Интернета на другой логический диск (D:\Cash).

Установите, как минимум, пониженный уровень UAC.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Локальная сеть и Интернет.


2. В настройках сети пропадает или периодически не определяется шлюз, указанный по умолчанию.

Если у Вас пропадает или периодически не определяется шлюз, указанный по умолчанию в настройках сети, то выполните указанные ниже действия.

Вариант 1.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

где:
route - команда выводящая на экран и/или изменяющая записи в локальной таблице IP-маршрутизации.
add конечная_точка - Добавляет маршрут и определяет конечную точку маршрута. Если данный параметр не указывается, то для маршрута по умолчанию используется значение 0.0.0.0.
-p - при использовании данного параметра с командой add, указанный маршрут добавляется в реестр и используется для инициализации таблицы IP-маршрутизации каждый раз при запуске протокола TCP/IP.
mask маска_сети - Указывает маску подсети (сети). Если данный параметр не указывается, то для маршрута по умолчанию используется значение 0.0.0.0.
шлюз - значение параметра Шлюз по умолчанию IPv4, его можно узнать следующим образом:

2.1) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
2.2) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Отключить
2.3) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Включить
2.4) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите Состояние
2.5) Нажмите на кнопку Сведения и запишите значение параметра Шлюз по умолчанию IPv4

Пример готовой команды с указанным значением шлюза:

3) Перезагрузите компьютер.

Вариант 2.

1) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
2) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Отключить
3) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Включить
4) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите Состояние
5) Нажмите на кнопку Сведения и запишите указанные значения.
6) Нажмите на кнопку Закрыть, а затем нажмите кнопку Свойства
7) Установите курсор на Протокол интернета версии 4 (TCP/IPv4) и нажмите кнопку Свойства.
8) Введите записанные ранее значения параметров-IP вручную и нажмите ОК.
9) Запустите редактор реестра (Win   + R → regedit → ОК)
10) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces
11) Откройте раздел относящийся к Вашему проблемному сетевому соединению. Вы можете определить его по значению параметров, которые Вы записали ранее в пункте 5.
12) Щелкните дважды на параметр DefaultGateway или нажмите на нем правой кнопкой мыши и выберите пункт Изменить
13) Удалите любые пустые строки, оставив только одну строку - значение параметра Шлюз по умолчанию IPv4, которые Вы записали ранее в пункте 5.
14) Перезагрузите компьютер. Перейти к началу Общего списка советов.


3. Устранение ошибок в работе Центра обновления Windows (Windows Update).

Если Центр обновления Windows (Windows Update) выдает у Вас сообщение об ошибке, то для ее исправления Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Отключите используемое Вами антивирусное программное обеспечение
2) Отключите любой из ускорителей интернета.
3) Выполните проверку наличия обновлений.

Вариант 2.

1) В адресной строке Проводника введите Панель управления\Все элементы панели управления\Устранение неполадок и нажмите Enter ↵.
2) В разделе Система и безопасность выберите пункт Устранение неполадок с помощью Центра обновления Windows.
3) В открывшемся окне нажмите кнопку Далее.
4) В случае обнаружения проблемы следуйте указаниям программы.

Вариант 3.

1) Скачайте Microsoft Fix It Tools для восстановления исходных параметров компонентов Центра обновления Windows.
2) Запустите программу и нажмите Применить
3) Нажмите кнопку Выявить проблемы и установить исправления.
4) В случае обнаружения проблемы следуйте указаниям программы.

Вариант 4.

1) В строке поиска меню Пуск введите указанную ниже команду и нажмите Enter ↵: notepad %windir%\system32\drivers\etc\hosts
2) Установите знак # в начале строки перед каждым IP-адресов, относящимся к Microsoft.
3) В главном меню Файл выберите команду Сохранить
4) Перезагрузите компьютер и повторно выполните проверку наличия обновлений.

Вариант 5.

1) Остановите службу Центр обновления Windows
1.1.1) Откройте Пуск → Панель управления → Администрирование → Службы.
1.1.2) Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Остановить.
или
1.2) Введите в командной строке (Win   + R → cmd → ОК) команду net stop wuauserv и нажмите Enter ↵.

2) Введите в адресной строке Проводника %SystemRoot% и нажмите Enter ↵
3) Удалите полностью папку SoftwareDistribution (По умолчанию, C:\Windows\SoftwareDistribution).
Внимание: Данное действие приведет к удалению временных файлов обновлений, а также журнала Центра обновления Windows.

4) Запустите службу Центр обновления Windows
4.1.1) Откройте Пуск → Панель управления → Администрирование → Службы.
4.1.2) Щелкните на службе Центр обновления Windows правой кнопкой мыши и выберите пункт Запустить.
или
4.2) Введите в командной строке (Win   + R → cmd → ОК) команду net start wuauserv и нажмите Enter ↵.
5) В Центре обновления Windows загрузите и установите все новые обновления.
6) Перезагрузите компьютер и повторно выполните проверку наличия обновлений.

Вариант 6.

1) Нажмите на часы в области уведомлений и в появившемся окне перейдите по ссылке Изменение настроек даты и времени.
2) Перейдите на вкладку Время по Интернету и нажмите на кнопку Изменить параметры.
3) Нажмите на кнопку Обновить сейчас, после обновления нажмите кнопку ОК и еще раз ОК.
4) Повторно выполните проверку наличия обновлений. Перейти к началу Общего списка советов.


4. Решение проблемы с punkbuster на Windows 7.

Вариант 1.

Решение проблемы вылетов игр (Например: COD 5 и Battlefield 2) с ошибкой: punkbuster kiked player *** for 0 minets. RESTRICTION: unknow windows APL function 131132 (131131, 131134, 131136).
1) Обновите PunkBuster:
1.1) Скачайте программу обновления PunkBuster
1.2) Установите программу и запустите ее.
1.3) Добавьте туда игру, для которой нужно обновить punkbuster и нажмите check for updates. По завершению появится сообщение об окончании обновления.
2) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
3) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора. (PnkBstrB.exe еще есть в папке с игрой. Например: C:\Users\*username*\AppData\Local\PunkBuster\BF2\pb).

Вариант 2.

1) Откройте папки C:\Windows\System32 (для х86) и/или C:\Windows\SysWOW64 (для х64)
2) Установите в свойствах файлов PnkBstrA.exe и PnkBstrB.exe совместимость с Windows XP или Windows Vista и уровень прав администратора.
3) На рабочем столе создайте bat-файл со следующим содержанием:

4) Запускайте данный bat-файл перед запуском игр. Перейти к началу Общего списка советов.


5. Исправление длительного времени задержки (лагов) в компьютерных сетях.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\
3) Найдите в ней раздел соответствующий интерфейсу, по которому у Вас работает интернет. Если Вы его не нашли, то дальнейшие действия произведите во всех разделах.
4) Создайте DWORD-параметр и назовите его TcpAckFrequency
5) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
6) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.
7) Откройте Пуск → Панель управления → Программы и Компоненты
8) В меню слева нажмите ссылку Включение и отключение компонентов Windows.
9) Найдите пункт Сервер очереди сообщений Майкрософт (MSMQ) (Microsoft Message Queue (MSMQ) Server) и установите на нем флажок. Также установите флажки на всех компонентах внутри.

10) Перезагрузите компьютер.
11) Запустите Редактор реестра (Win   + R → regedit → ОК)
12) Откройте ветку: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters
13) Создайте DWORD-параметр и назовите его TCPNoDelay
14) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить
15) Установите значение переключателя на Шестнадцатеричное, введите значение параметра 1 и нажмите ОК.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Локальная сеть и Интернет.


6. При вызове справки пишет "Internet Explorer не удается загрузить / из help".

При вызове справки "Справка и поддержка" появляется сообщение об ошибке:

Это может происходить по причине неправильного сопоставления программам типа файлов .xml
Для исправления ошибки скопируйте код в новый текстовый файл, сохраните его, присвоив расширение .reg, запустите и согласитесь с внесением изменений в реестр.


7. Если при VPN соединении через bat-файл у вас появляется ошибка 623.

Переименуйте имя соединения на английский язык и всё должно заработать.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Локальная сеть и Интернет.


8. Устранение неполадки в Центре обновления Windows: Некоторые параметры задаёт системный администратор.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте ветку [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate]
3) Удалите параметр DisableWindowsUpdateAccess
4) Закройте Редактор реестра и перезагрузите компьютер.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Локальная сеть и Интернет.


9. Постоянно пропадает подключение к локальной сети и/или интернету.

Общие рекомендации:

1) Скачайте и установите новые драйвера для сетевой карты или установите родные драйвера с диска вместо определенных Windows.
2) Разрешите в используемом Вами брандмауре (firewall) для программ, в которых Вы скачиваете файлы - автоматически использовать необходимые порты и передавать необходимые пакеты, в ином случае Ваш firewall может просто отключать соединение при большой нагрузке на сеть, приняв его за атаку.

Вариант 1. Запрещение отключения сетевого адаптера для экономии энергии.

1) Запустите Диспетчер устройств (Win   + R → devmgmt.msc → ОК)
1.1) Откройте меню Пуск
1.2) Нажмите правой кнопкой на Компьютер и выберите пункт Свойства (Панель управления\Все элементы панели управления\Система)
1.3) Нажмите на ссылку Диспетчер устройств
2) Откройте Сетевые адаптеры
3) Щелкните правой кнопкой мыши на Вашем сетевом адаптере и выберите пункт Свойства
4) Перейдите на вкладку Управление электропитанием
5) Уберите флажок Разрешить отключение этого устройства для экономии энергии.

Вариант 2. Отключение протокола интернета версии 6 (TCP/IPv6) и отключение разъединения в случае простоя.

1) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
2) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите Свойства
3) Снимите флажок Протокол интернета версии 6 (TCP/IPv6) и нажмите ОК.
Если помимо локальной сети у Вас присутствует другие типы соединений, то продолжайте далее:
4) Щелкните правой кнопкой мыши на созданном Вами соединении и выберите Свойства
5) Перейдите на вкладку Параметры
6) В ниспадающем списке параметра Время простоя до разъединения установите значение никогда
7) Перейдите на вкладку Сеть
8) Снимите флажок Протокол интернета версии 6 (TCP/IPv6) и нажмите ОК.

Вариант 3. Введение параметров-IP вручную.

1) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
2) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Отключить
3) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите пункт Включить
4) Щелкните правой кнопкой мыши на Подключение по локальной сети и выберите Состояние
5) Нажмите на кнопку Сведения и запишите указанные значения
6) Нажмите на кнопку Закрыть, а затем нажмите кнопку Свойства
7) Установите курсор на Протокол интернета версии 4 (TCP/IPv4) и нажмите кнопку Свойства.
8) Введите записанные ранее значения параметров-IP вручную и нажмите ОК.

Вариант 4. Настройка параметров сетевого адаптера.

1) Откройте Пуск → Панель управления → Диспетчер устройств
2) Найдите щелкните правой кнопкой мыши по Вашему сетевому адаптеру и выберите пункт Свойства
3) Перейдите на вкладку Дополнительно
4) Установите значение параметра Flow Control (Управление потоком) в положение Disabled (Выключено) и нажмите ОК

Вариант 5. Сброс установленных значений.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите поочередно указанные ниже команды, нажимая после введения каждой, клавишу Enter ↵.

Если после выполнения указанных выше действий пропадет соединение с сетью - проверьте записи в Журнале событий:

1) Пройдите Панель управления\Все элементы панели управления\Администрирование и откройте Просмотр событий.
2) Слева в древовидном списке оснастки откройте Просмотр событий (Локальный) → Журналы Windows и проверьте в каждом из подразделов: Приложения и Система была ли описана какая-нибудь ошибка, связанная с разрывом соединения.

Также свяжитесь со службой поддержки Вашего провайдера и проверьте настройки.


10. Восстановление пропавших иконок для htm/html/mht/url файлов.

Если у Вас в системе пропали значки яў htm/html/mht/url файлов, то для их восстановления создайте и примените, в зависимости от браузера используемого по умолчанию, необходимый Вам reg-файл из указанных ниже.

Internet Explorer

Mozilla Firefox в 32-битной Windows.

Mozilla Firefox в 64-битной Windows.

Opera в 32-битной Windows.

Opera в 64-битной Windows.

Google Chrome.


11. Ошибки, возникающие при создании подключений удаленного доступа и VPN-подключений и способы их решения.

Если при подключении к Интернету возникла какая-либо из указанных ниже ошибок, то выполните рекомендуемые действия, для ее исправления.

Ошибка 52.
Варианты исправлений:
Эта ошибка обычно возникает при регистрации компьютера в сети.
Причина - совпадение IP-адреса VPN-соединения (этот адрес назначается автоматически) с IP-адресом, который уже есть в системе.
Убедитесь, что идентичный адрес не используется DVB-платой, Адаптером 1394, Адаптером Microsoft или иным подключением, если такое имеется.

Ошибки с кодами 6XX.

Ошибки 600, 601, 603, 606, 607, 610, 613, 614, 616, 618, 632, 637, 645.
Варианты исправлений:
1) Перезагрузите компьютер.
2) Если ошибка не исчезает, то проверьте Ваш компьютер на предмет наличия вирусов.
3) Удалите недавно установленные программы.
4) Отмените недавно внесенные изменения в настройки Windows.

Ошибки 604, 605, 608, 609, 615, 620.
Варианты исправлений:
1) Перезагрузите компьютер.
2) Если ошибка не исчезает, то удалите и заново создайте VPN-соединение.

Ошибка 611.
Варианты исправлений:
1) Перезагрузите компьютер и убедитесь, что локальная сеть на Вашем компьютере функционирует нормально.
2) Если ошибка не исчезает, то обратитесь в службу технической поддержки, для корректировки имеющихся настроек.

Ошибка 612.
Варианты исправлений:
1) Аналогичен варианту исправления ошибки 611.
2) Возможно на Вашем компьютере не хватает ресурсов (памяти).
3) Попробуйте закрыть запущенные программы.

Ошибка 617.
Варианты исправлений:
1) Подождите несколько минут.
2) Если после нескольких попыток подключение не установилось, то перезагрузите компьютер.

Ошибка 619.
Варианты исправлений:

Вариант 1.

1) В свойствах VPN-соединения откройте вкладку Безопасность.
2) Установите Тип VPN в значение Автоматически (либо убедитесь, что установлено значение рекомендуемое провайдером).
3) В ниспадающем списке выберите "необязательное (подключит© даже без шифрования)".
4) Оставьте установленным только флажок "Незашифрованный пароль (PAP)", если у Вас подключение типа PPTP или флажок "Протокол проверки пароля (CHAP), если у Вас подключение типа L2TP".
5) Нажмите ОК для подтверждения изменения настроек, перезагрузите компьютер и попробуйте подключит© еще раз.
6) Проверьте настройки Вашего брандмауэра, и, если не уверены в их правильности, отключите его.

Вариант 2.

Возможно на балансе Вашего счета недостаточно средств.
Пополните счет и попытайтесь подключит© снова.

Ошибка 629.
Варианты исправлений:
Обратитесь в службу технической поддержки, для корректировки имеющихся настроек.

Ошибка 642, 652.
Варианты исправлений:
1) Откройте Панель управления\Все элементы панели управления\Система.
2) В разделе Имя компьютера, имя домена и параметры рабочей группы нажмите на ссылку Изменить параметры.
3) Нажмите на кнопку Изменить
4) Введите другое имя компьютера и нажмите ОК.
5) Перезагрузите компьютер и попытайтесь подключит© снова.
6) Удалите и заново создайте соединение используемое для подключения к Интернету.
7) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибка 678.
Варианты исправлений:
1) Перезагрузите компьютер и убедитесь, что локальная сеть на Вашем компьютере функционирует нормально.
2) Проверьте настройки соединения и настройки Вашего брандмауэра (firewall).
3) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибка 633.
Варианты исправлений:
Возможно Ваше подключение "зависло".
Перезагрузите компьютер и попытайтесь подключит© снова.

Ошибка 635.
Варианты исправлений:
1) Удалите и заново создайте соединение используемое для подключения к Интернету.
2) В командной строке запущенной с правами администратора выполните команду sfc /scannow.
3) Если ошибка не исчезает, то обратитесь в службу технической поддержки, для корректировки имеющихся настроек.

Ошибки 638, 651.:
Варианты исправлений:
1) Проверьте, правильно ли подключен кабель сети/модема к компьютеру.
2) Проверьте наличие связи между компьютером и сетью с помощью соответствующего индикатора на кабеле и/или модеме.
3) Проверьте наличие питания на Вашем модеме (для модемов с внешним источником питания).
4) Переустановите драйвера сетевой карты или модема и убедитесь в Диспетчере устройств, что они установились корректно.
5) Проверьте правильность установки настроек подключения к интернету.
6) В случае использования отдельного кабеля для подключения, убедитесь, что ипользуете правильный его тип.

Ошибка 650.
Варианты исправлений:
1) Проверьте правильность установки настроек подключения к интернету.
2) В Диспетчере устройств удалите Ваш сетевой адаптер и установите его заново.
3) Проверьте физическую исправность сети.

Ошибка 678.
Варианты исправлений:
1) Проверьте правильность подключения кабеля к компьютеру.
2) Проверьте правильность установки настроек подключения к интернету и настройки Вашего брандмауэра (firewall).

Ошибка 691.
Варианты исправлений:
1) Проверьте правильность введения данных для подключения: логин/пароль.
2) Проверьте баланс средств на Вашем счету.
3) Удалите и заново создайте соединение используемое для подключения к интернету.
4) Перезагрузите компьютер и попробуйте заново подключит© к интернету.
5) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибки с кодами 7ХХ.

Ошибка 711.
Варианты исправлений:

Вариант 1.

Эта ошибка может возникнуть, если не запущены все или некоторые из перечисленных ниже служб.

Диспетчер автоматических подключений удаленного доступа
Диспетчер подключений удаленного доступа
Телефония

Для устранения этой ошибки выполните следующие действия для каждой из указанных выше служб.

1) Нажмите кнопку Пуск
2) Откройте Панель управления → Администрирование → Службы (или Win   + R → services.msc)
3) Щелкните правой кнопкой мыши на одну из указанных выше служб и затем щелкните Свойства.
4) На вкладке Общие в пункте Тип запуска выберите вариант Вручную.
5) Нажмите Применить, а затем нажмите Запустить.

Вариант 2.

1) Скачайте и установите программу Unlocker
2) Откройте папку C:\Windows\System32
3) Щелкните правой кнопкой мыши на папку LogFiles и выберите пункт Unlocker.
4) В ниспадающем списке выберите Переименовать, укажите имя LogFiles_old и нажмите кнопку ОК, и еще раз ОК.
5) В окне Выполнить переименование при следующей загрузке системы? нажмите кнопку Да.
6) Перезагрузите компьютер.

Вариант 3.

1) Щелкните правой кнопкой мыши на папке C:\Windows и выберите пункт Свойства
2) Перейдите на вкладку Безопасность
3) Проверьте, что в окне "Группы и пользователи" присутствуют указанные ниже пользователи и группы с разрешением полного доступа для них: "СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ" (CREATOR OWNER), "система" (SYSTEM), "TrustedInstaller"
Дополнительно могут быть группы "Администраторы" (Administrators), "Пользователи" (Users) со своими правами.
4) Нажмите кнопку Дополнительно и в открывшемся окне перейдите на вкладку Владелец
Проверьте, что владельцем папки Windows является TrustedInstaller
5) Если указано иное, то нажмите кнопку Изменить... → Другие пользователи или группы...
6) В текстовом поле введите NT SERVICE\TrustedInstaller и нажмите ОК.
7) В окне Изменить владельца на: выберите TrustedInstaller и нажмите ОК.

Вариант 4.

1) Откройте меню Пуск и в строке поиска введите cmd
2) Щелкните правой кнопкой мыши на найденном файле и выберите строку "Запуск от имени администратора"
3) Введите указанную ниже команду и нажмите Enter ↵:

Ошибки 718, 721, 733, 734, 735, 741, 742, 743.
Варианты исправлений:
1) Убедитесь, что в свойствах TCP/IP подключения по локальной сети все настройки получаются автоматически.
2) Убедитесь, что в настройках протокола TCP/IP VPN-соединения не указан конкретный IP-адрес, и все настройки получаются автоматически.
3) В свойствах VPN-соединения откройте вкладку Безопасность и выберите в ниспадающем списке "необязательное (подключит© даже без шифрования)".
4) Оставьте установленным только флажок "Незашифрованный пароль (PAP)", если у Вас подключение типа PPTP или флажок "Протокол проверки пароля (CHAP), если у Вас подключение типа L2TP".
5) Удалите и заново создайте соединение используемое для подключения к интернету.
6) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибка 769.
Варианты исправлений:
1) Убедитесь, что локальная сеть на Вашем компьютере функционирует нормально (Если она отключена, то включите ее).
2) Проверьте правильность установки настроек подключения к интернету и настройки Вашего брандмауэра (firewall).
Также смотрите варианты исправлений для ошибок 638, 651..

Ошибка 789.
Варианты исправлений:
1) В свойствах VPN-соединения откройте вкладку Безопасность, выберите другой Тип VPN и попробуйте подключит©.
2) Создайте и примените reg-файл указнного ниже содержания.

3) Перезагрузите компьютер.

Ошибка 797.
Варианты исправлений:
1) Откройте Панель управления\Все элементы панели управления\Система.
2) В разделе Имя компьютера, имя домена и параметры рабочей группы нажмите на ссылку Изменить параметры.
3) Нажмите на кнопку Изменить.
4) Введите другое имя компьютера и нажмите ОК.
5) Перезагрузите компьютер и попытайтесь подключит© снова.
6) Переустановите драйвера сетевой карты или модема и убедитесь в Диспетчере устройств, что они установились корректно.
7) Удалите и заново создайте соединение используемое для подключения к интернету.
8) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибки с кодами 8ХХ.

Ошибки 800, 814, 815, 868.
Варианты исправлений:
1) Проверьте компьютер на отсутствие вирусов.
2) Проверьте соединительный кабели, выньте и вставьте его в гнездо сетевой карты.
3) Проверьте правильность установки настроек подключения к интернету и настройки Вашего брандмауэра (firewall).
4) Переустановите драйвера сетевой карты или модема и убедитесь в Диспетчере устройств, что они установились корректно.
5) Убедитесь, что локальная сеть на Вашем компьютере функционирует нормально (Если она отключена, то включите ее).
6) Удалите и заново создайте соединение используемое для подключения к интернету.
7) Попробуйте в свойствах подключения указать другой Тип VPN, а в настройках протокола TCP/IP VPN-соединения принудительно указать используемый провайдером DNS-сервер.
8) Если ошибка не исчезает, то обратитесь в службу технической поддержки.

Ошибки с кодами 1XХХ.

Ошибка 1068.
Варианты исправлений:
Смотрите варианты исправлений для ошибки 711. Перейти к началу Общего списка советов.


12. Исправление ошибки Internet Explorer: "Internet Explorer has stopped working".

Вариант 1.

1) Нажмите кнопку Пуск
2) Откройте Панель управления и запустите Свойства обозревателя
3) Перейдите на вкладку Дополнительно
4) Нажмите кнопку Сброс...
5) Прочитайте информационное сообщение и нажмите кнопку Сброс
6) Нажмите Закрыть и перезапустите Internet Explorer.

Вариант 2.

1) Нажмите кнопку Пуск
2) Откройте Панель управления и запустите Свойства обозревателя
3) Перейдите на вкладку Безопасность
4) Уберите флажок Включить защищенный режим.
5) Перезапустите Internet Explorer (если он был запущен).

Вариант 3.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте ветку HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions
3) Удалите все параметры, кроме параметра (По умолчанию)

Вариант 4.

1) Откройте меню Пуск.
2) В строке поиска введите gpedit.msc и нажмите Enter ↵
3) Перейдите к Конфигурация компьютера\Административные шаблоны\Система\Управление связью через Интернет\Параметры связи через интернет
4) Щелкните дважды левой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows.
5) Установите переключатель в значение Включить и нажмите ОK. Перейти к началу Общего списка советов.


13. Восстановление исходного состояния компонентов Центра обновления Windows.

Если у Вас при работе с Центром обновлений Windows (Windows Update) возникает какая-либо ошибка, то воспользуйтесь предложенным ниже решением для исправления большинства из них.

1) Восстановите изначальные значения параметров в реестре для службы Система событий COM+.
1.1) Создайте и примените reg-файл указанного ниже содержания:

2) Восстановите изначальные значения параметров в реестре для службы Фоновая интеллектуальная служба передачи (BITS).
2.1) Создайте и сохраните reg-файл указанного ниже содержания:

2.2) Скачайте комплект программ PsTools, распакуйте в любую папку и скопируйте файл PsExec.exe в папку C:\Windows\System32.
2.3) В строке поиска меню Пуск введите команду: cmd, нажмите на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
2.4) Введите указанную ниже команду и нажмите Enter ↵:

2.5) Перейдите Файл → Импорт (File → Import), укажите созданный Вами reg-файл и нажмите кнопку Открыть.
3) Перезагрузите компьютер.
4.1) Откройте папку C:\ProgramData\Microsoft\Network\Downloader и очистите ее содержимое.
4.2) Если указанная папка отсутствует, то откройте папку C:\ProgramData\Microsoft\Network и создайте в ней папку Downloader
5) Очистите кэш обновлений, а также перезапустите и перерегистрируйте компоненты Центра обновлений Windows (Windows Update).
5.1) Для этого создайте и запустите от имени администратора bat-файл, указанного ниже содержания.
Внимание: Очистка кэша обновлений приведет к очистке списка установленных на данный момент обновлений.

6) Перезапустите компьютер.

Также Вы можете скачать архив WindowsUpdateRepair.zip с готовыми файлами из указанного совета.

EventSystemWin7.reg - восстанавливает службу "Система событий COM+"
BITSWin7.reg - восстанавливает службу "Фоновая интеллектуальная служба передачи (BITS)" примҐть через пункт Импорт в редактре реестра, запущенном от имени пользователя система.
PsExec.exe - позволяет запустить приложение от имени пользователя система.
Reset_Windows_Update_Full.bat - очищает кэш обновлений, а также перезапускает и перерегистрирует компоненты Центра обновлений Windows. Перейти к началу Общего списка советов.


14. Не получается включить сетевое обнаружение в дополнительных параметрах общего доступа.

1) Откройте Панель управления\Сеть и Интернет\Центр управления сетями и общим доступом
2) Измените расположение для сети на Домашняя сеть щелкнув на ссылку Общественная сеть под Вашим подключением.
3) Откройте Панель управления → Администрирование → Службы и проверьте включены ли у Вас службы

4) Некоторые антивирусные программы также могут блокировать данные действия. Попробуйте отключить антивирусное обеспечение, затем измените настройку и проверьте сохранятся ли настройки. Перейти к началу Общего списка советов.


15. Восстановление в Mozilla Firefox окна "Выход из Firefox" с кнопками "Сохранить и Выйти", "Выйти" и "Отмена".

1) В главном меню откройте Инструменты → Настройки
2) На вкладке Основные в разделе Запуск установите значение "При запуске Firefox: Показывать домашнюю страницу" и нажмите ОК.
3) В адрессной строке введите about:config и нажмите Enter ↵.
4) В строке Фильтр введите browser.showQuitWarning
5) Дважды щелкните на найденном параметре, чтобы его значение переключилось на true.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Локальная сеть и Интернет.


16. Ftp-сервер при вводе адреса в Проводнике открывается в Internet Explorer.

1) В Internet Explorer откройте Свойства обозревателя.
Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажмите на значок шестеренки.
2) Перейдите на вкладку Дополнительно
3) Установите флажок: Разрешить просмотр FTP-папок (за пределами Internet Explorer)

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Локальная сеть и Интернет.


17. Восстановление пропавшего звука в интернет браузерах.

1) Проверьте уровень громкости в самом Flash плеере.

2) Удалите полностью, а затем поставьте заново:
2.1) Adobe Flash Player.
Удаление: ссылка
Установка: ссылка
2.2) Кодеки в системе (K-lite codeck pack, Shark007 Windows 7 Codecs или др.)
2.3) Браузеры. (Mozilla Firefox, Opera, Google Chrome или др.)
2.4) Драйвера звуковой карты

3) В Internet Explorer, проверьте стоит ли у Вас флажок в пункте Воспроизводить звуки на веб-страницах Сервис → Свойства обозревателя → Дополнительно → Раздел Мультимедиа.

4) Проверьте, установлен ли запуск службы Windows Audio Автоматически.
Панель Управления → Администрирование → Службы → двойной щелчок на Windows Audio → Тип запуска: Автоматически
Затем нажмите Остановить, потом Запустить.

5) Запустите редактор реестра (Win   + R → regedit)
Перейдите к ветке: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32
Проверьте значение строкового(String) параметра wavemapper. Его значение должно быть msacm32.drv. Если данного параметра нет, то создайте его. Перейти к началу Общего списка советов.


18. Удаление и/или переименование сетей с названиями Сеть 2 (Network 2), Сеть 3 (Network 3) и т.д..

Удаление и/или переименование сетей с названиями Сеть 2 (Network 2), Сеть 3 (Network 3) и т.д..

1) Запустите редактор реестра (Win   + R → regedit → ОК)

Если параметры локальной сети задаются автоматически и не требуют настройки.

2) Перейдите в раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles
3) Удалите все имеющиеся подразделы.
4) Перезагрузите компьютер и сеть с названием Сеть (Network) будет создана заново.

Если параметры локальной сети задаются вручную и требуют настройки.

2) Перейдите в раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles
3) Найдите подраздел, в котором значение параметра ProfileName соответствует названию Вашей текущей сети (Сеть 2 (Network 2), Сеть 3 (Network 3) и т.д.).
4) Удалите другие подразделы из раздела HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles, оставив только найденный.
5) Щелкните дважды на параметре ProfileName, измените значение на Сеть (Network) и нажмите Enter ↵.
6) Перезагрузите компьютер и Ваша сеть будет переименована в Сеть (Network). Перейти к началу Общего списка советов.


1. При использовании сторонних плееров для видео выкидывает синий экран.

Данную проблему можно решишь, если установить в расширенных настройках видео: Режим рендеринга или фильтр рендеринга для DirectShow Video на "Улучшенный обработчик видео" или "Enhanced Video Renderer" (EVR).

В Media Player Classic данный параметр находится View - Options - Playback - Output - Directshow Video - EVR.
В Bsplayer Pro данный параметр находится Опции - Настройки - Видео - Вывод видео - Режим рендеринга - EVR (Enhanced Video Renderer).

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Устройства и BSOD.


2. В папке "Компьютер" не отображаются DVD-дисководы.

Уберите флажок в Панель управления-Параметры папок-Вид "Скрыть пустые диски в папке "Компьютер""

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Устройства и BSOD.


3. В Windows и Nero не стираются диски DVD RW и CD RW.

Если при попытке стереть данные диски "DVD RW" и/или "CD RW" Вы получаете сообщение: "Не перезаписываемый диск" или "Диск защищён от записи", то это означает, что на диск была добавлена метка из-за которой программы определяют его как DVD-R.

Чтобы убрать эту метку зайдите в Alcohol 120% и уберите метки в пунктах Сервис → Настройки → Эмуляция → Игнорировать тип носитЈ, в Daemon Tools Спрятать CD-R.
Значение этой опции: Bынудить дpугиe пpoгpaммы нe oпpeдeлять зaпиcывaeмый тип диcкa, пpинимaя eгo зa CD-ROM или DVD-ROM.
После этого заново сотрите эти диски в Alcohol 120% или в Daemon Tools.


4. Определение драйвера, вызвавшего BSOD.

Включение записи дампов памяти

1) Нажмите комбинацию клавиш Win+Pause
2) Щелкните ссылку Дополнительные параметры системы
3) Перейдите на вкладку Дополнительно
4) Нажмите кнопку Параметры в Загрузка и восстановление

5) По умолчанию они будут сохраняться в папку %SystemRoot%\Minidump

Анализ дампа памяти и определение драйвера, вызвавшего ошибку:

Вариант 1

1) В соответствии с разрядностью Вашей Windows загрузите и установите Debuggers And Tools for Windows (Автономные средства отладки яў Windows): с официального сайта Microsoft или с зеркал: Debuggers And Tools для 32-битной версии Windows и Debuggers And Tools для 64-битной версии Windows.
2) Загрузите командный файл kdfe.cmd (Kernel Debugger Front End) со скриптом для облегчения анализа дамп-файлов, создаваемых Windows при STOP ошибках (BSoD), оригинальный его код взят на ресурсе sysadmins.ru.
3) Распакуйте архив в любую папку.
4) Скопируйте файл kdfe.cmd в папку C:\Windows\Minidump

Программы необходимые для работы скрипта по умолчанию устанавливаются в папку:

C:\Program Files\Windows Kits\8.1\Debuggers\x86 - для 32-бит.
C:\Program Files\Windows Kits\8.1\Debuggers\x64 - для 64-бит.

Примечание: Если Вы изменили расположение данной папки, то в файле kdfe.cmd необходимо указать другой путь к папке, где расположен файл kd.exe.
Путь к папке указан после параметра set dbgpath=
4) Удерживая нажатой клавишу ⇑ Shift, слева в списке папок щелкните правой кнопкой мыши на папку Minidump, и выберите пункт Открыть окно команд.
5) Введите команду для запуска процесса аннализа дампа и нажмите клавишу Enter ↵ (в примере ниже файл называется Mini1110307-01.dmp)

Если Вы скопировали файл kdfe.cmd в папку C:\Windows\System32, то Вы сможете запустить анализа дампа из любой папки, указав путь к dmp-файлу.

6) Дождитесь завершения анализа. По окончании вы увидите драйвер, послуживший причиной ошибки.

Вариант 2

1) Скачайте утилиту BlueScreenView: английская версия, русская версия.
2) Распакуйте архив и запустите программу BlueScreenView.

Поиск дампов производится в папке %systemroot%\Minidump, также можно настроить и собственную папку (Options → Advanced).
Для найденных дампов памяти утилита отображает:
  • В верхней панели – название файла, дату создания, название стоп-ошибки, код ошибки, параметры, а также драйвер, предположительно вызвавший проблему (Caused By Driver).
  • В нижней панели – (в зависимости от настроек в Options → Lower Pane Mode) все драйверы, загруженные во время ошибки, или только драйверы, найденные в стеке. Среди всех драйверов - на розовом фоне отображаются предположительно вызвавшие проблему драйверы. Также, утилита может отображать синий экран, очень похожий на тот, который все так любят.
Примечание: При определении драйвера не нужно полагаться только на имя файла в столбце Caused by Driver. Следует рассмотреть драйверы в нижней панели (или только выделенные розовым цветом, если включено отображение всех драйверов), в первую очередь обращая внимание на несистемные драйверы. Перейти к началу Общего списка советов.


5. Расшифровка значений ошибок синего экрана смерти (BSOD) и способы их устранения.

Если у Вас появляется какая-либо ошибка синего экрана смерти, и Вы задумываетесь из-за чего же она произошла, то Вы можете:

1) Скачать подборку наиболее часто встречающихся ошибок и способов устранения многих из них: BSOD.rar
2) Почитать на форуме Oszone.net темы входящие в состав темы: Устранение критических ошибок Windows Перейти к началу Общего списка советов.


6. В Windows x64 стало показывать меньше памяти, чем есть.

Зайдите:
Панель управления→Администрирование→Конфигурация системы>вкладка Загрузка→Дополнительные параметры
Проверьте максимум памяти. Или уберите галочку или поставьте нужное вам значение.

Также посмотрите значение функций в BIOS:

1. HPET Mode должно быть 64-bit (если есть такая функция)
или
2. Memory Remap Feature должно быть Enabled
3. Memory Hole должно быть Disabled Перейти к началу Общего списка советов.


7. Windows зависает после перезагрузки с ошибкой Verifying DMI Pool Data.

Попробуйте следующие варианты решений:

1) Попробуйте установить другую сборку или версию Windows 7.
2) Сбросьте настройки BIOS в стандартные и установите Windows заново.
3) Обнулите на материнской плате CMOS: либо переустановив и вернув перемычку, либо нажав на кнопку сброса на материнской плате.
4) Установите в списке загрузок с жестких дисков в BIOS, приоритет загрузки Вашего диска с Windows 7 на первое место.
5) Подключите диск выделенный для Windows 7, как Primary Master.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Устройства и BSOD.


8. Восстановление работы дополнительных клавиш на мультимедиа-клавиатуре.

Если на Вашей мультимедиа или офисной клавиатуре перестали работать дополнительные клавиши расширяющие её функциональность, то сделайте следующее.
Во-первых, проверьте установлено ли у Вас программное обеспечение с диска идущего в комплекте к клавиатуре или с официального сайта.
Если же оно установлено, то одной из наиболее часто встречающихся причин может быть остановка службы Доступ к HID-устройствам.

1) Зайдите в Панель управления\Система и безопасность\Администрирование и запустите Службы или
Нажмите кнопку Пуск, введите в строке поиска services.msc и нажмите клавишу Enter ↵.
2) Проверьте указано ли в колонке Состояние, напротив службы Доступ к HID-устройствам значение: Работает
Если данная служба отключена и не работает, сделайте следующее:
3) Нажмите на ней правой кнопкой мыши и в появившемся меню выберите Свойства
4) Для запуска службы нажмите на кнопку Запустить
5) Также Вы можете установить Тип запуска: Автоматически, и система будет автоматически запускать данную службу при старте Windows.
6) Перейдите на вкладку Восстановление и установите действия выполняющиеся при первом или втором сбое, а также при последующих сбоях на значение Перезапуск службы и нажмите OK.

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Устройства и BSOD.


9. Исправление появившихся красных крестиков на значках локальных дисков.

1) Откройте Панель Управления → Диспетчер Устройств
1.1) Проверьте включены ли все IDE ATA/ATAPI контроллеры
1.2) Проверьте включены ли все Дисковые устройства

2) Если есть общий доступ, попробуйте его отключить
Щелкните правой кнопкой мыши на диске → Общий доступ → Расширенная настройка общего доступа... → Расширенная настройка...

3) Почистите кэш иконок: для этого в папке %USERPROFILE%\AppData\Local\ удалите файл IconCache.db
4) Воспользуйтесь специальными утилитами для оптимизации работы компьютера. Например:

4.1) TuneUp Utilities

4.1.1) Нажмите Overview of all functions (Обзор всех функций) и выберите Change Windows appearance (Изменить оформление Windows)
4.1.2) В меню слева в списке группы Icons (Значки) выберите Repair (Исправление)
4.1.3) Нажмите на кнопку Reload Icons (Перезагрузить значки), а после на кнопку Repair Icon Cache (Восстановить значки)

4.2) Windows 7 Manager

4.2.1) В меню слева во вкладке Information выберите Repair Center
4.2.2) В меню слева в Repair Center нажмите Icon Repair
4.2.3) В разделе Rebuild Icon Cache нажмите Rebuild Перейти к началу Общего списка советов.


10. Восстановление автозапуска для всех типов приводов и устройств.

Вариант 1.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Примените созданный reg-файл и перезапустите компьютер.

Вариант 2.

1) Скачайте решение предложенное компанией Microsoft: MicrosoftFixit50475.msi
2) Запустите программу и следуйте указаниям мастера.

Для информации: Автозапуск могут заблокировать антивирусные программы, эмуляторы виртуальных дисков и программа VMware Workstation, используемой для создания виртуальной машины.


11. Исправление ошибок 0x0000007A, 0x00000077 или 0x000000F4 для SATA дисков после выхода из ждущего или спящего режимов.

На подготовку к работе жесткого диска отводится 10 секунд. Если накопитель не успеет за это время сообщить о своей работоспособности, то операционная система воспримет это как ошибку. Такое может происходить с винчестерами с интерфейсом SATA. Для устранения данной ошибки Microsoft выпустила обновление KB977178. Если же в вашей системе на базе Windows 7 подобных ошибок не возникает, то устанавливать исправление не рекомендуется.
Ссылка для скачивания исправления: KB977178.zip

Перейти к началу раздела Устранение неполадок.
Перейти к началу подраздела Устранение неполадок - Устройства и BSOD.


12. Cистема находит Bluetooth-адаптер, а Bluetooth-устройства его не обнаруживают.

1) Нажмите Win   + R (или Пуск → Выполнить)
2) Введите команду:

или

и нажмите Параметры Bluetooth

3) Установите необходимые Вам настройки.

Чтобы сделать компьютер обнаруживаемым устройствами с поддержкой Bluetooth, установите флажок Разрешить устройствам Bluetooth обнаруживать этот компьютер.
Чтобы разрешить добавление устройств с поддержкой Bluetooth на компьютер, установите флажок Разрешить устройствам Bluetooth подключаться к этому компьютеру.
Чтобы получать уведомления о попытках устройств с поддержкой Bluetooth подключит© к компьютеру, установите флажок Оповещать при подключении нового устройства Bluetooth. Перейти к началу Общего списка советов.


13. Восстановление значка "Безопасное извлечение устройства".

1.1) Создайте и импортируйте в реестр reg-файл указанного ниже содержания. После чего перезагрузите компьютер.

1.2) Перезайдите в систему или перезагрузите компьютер.

2) Откройте Пуск → Выполнить (Win   + R) и запустите поочередно следующие команды

3.1) Щелкните по рабочему столу и выберите во всплывшем меню Создать → Ярлык.
3.2) В поле Укажите расположение объекта введите команду

3.3) Перенесите созданный Вами ярлык на панель задач, чтобы закрепить его там.

Также Вы можете просто запустить окно "Безопасное извлечение устройства" введя команду в диалоговом окне Выполнить (Win   + R) :


14. Решение проблемы пропадания места на системном жестком диске.

Прежде всего выполните проверку жесткого диска, если дело окажется в ошибках, то система поможет Вам их исправить:

1) Нажмите кнопку Пуск и в строке поиска введите cmd
2) Нажмите правой кнопкой мыши на найденной команде и выберите "Запустить от имени Администратора"
3) Введите команду SFC /scannow и нажмите Enter ↵.

Для увеличения свободного пространства Вы можете сделать следующее:

1) Запустите Очистка диска. Нажимаете кнопку Пуск → Все программы → Стандартные → Служебные.
1.1) На вкладке Очистка диска Вы можете удалить временные файлы
1.2) На вкладке Дополнительно Вы можете удалить все точки восстановления, кроме самой последней.

2) Отключите функцию создания точек восстановления или уменьшите размер используемого дискового пространства.
2.1) Нажмите кнопку Пуск
2.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
2.3) Слева нажмите ссылку Защита системы
2.4) В открывшемся окне нажмите кнопку Настроить
2.5) Отключите защиту системы или измените используемый ею размер дискового пространства.

4) Отключите режим гибернации.
4.1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4.2) Введите команду powercfg /h off и нажмите Enter ↵.

5) Измените размер файла подкачки.
5.1) Нажмите кнопку Пуск
5.2) Щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства (Панель управления\Система и безопасность\Система)
5.3) Слева нажмите ссылку Дополнительные параметры системы
5.4) В разделе Быстродействие нажмите кнопку Параметры
5.5) Перейдите на вкладку Дополнительно и нажмите кнопку Изменить

6) Очистите папку кэша C:\Windows\rescache
7) Очистите папку временных файлов обновлений C:\Windows\SoftwareDistribution\Download
8) Очистите временные папки (карантин) используемой Вами системы защиты (Norton, Kaspersky, Eset 32 и др.), в некоторых стоит отключить трассировки.
9) Скачайте программу Scanner by Steffen Gerlach для анализа содержимого жестких дисков. Эта программа поможет Вам увидеть, какая папка или файл занимает большую часть вашего диска. Перейти к началу Общего списка советов.


15. Windows не определяет второй жесткий диск после установки.

Данное действие иногда происходит по причине неправильной установки скрытого раздела System Reserved (Зарезервировано системой).
Например, если у Вас один жесткий диск, то Windows 7 при инсталляции выделяет скрытый раздел System Reserved (Зарезервировано системой) для защиты загрузочных файлов операционной системы.
Если во время инсталляции были подключены два жестких диска, то иногда Windows может некорректно определить второй жесткий диск и использовать его как скрытый раздел System Reserved (Зарезервировано системой). В результате чего, у него будет отсутствовать буква диска.

Для добавления буквы диска сделайте следующее:

1) Запустите оснастку Управление дисками (В поле поиска меню Пуск введите diskmgmt.msc и нажмите Enter ↵).
2) Находите Ваш диск, у него будет отсутствовать буква диска.
3) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску.
4) В открывшемся окне нажимаете кнопку Добавить выбираете необходимую Вам букву и нажимаете ОК.

Если диск не появился в Проводнике(Windows Explorer), то перезагрузите компьютер.


16. Не переименовывается диск (не меняется метка тома) в Windows 7.

Данная проблема может возникнуть, в результате появления в корне диска файла или папки с именем "Autorun.inf".
Если Вы не создавали его самостоятельно для защиты от вирусов использующих автозапуск, то файл (папка) мог создаться какой-либо программой.
Для исправления данной проблемы сделайте следующее:

1) Откройте Пуск → Панель управления и запустите "Параметры папок"
2) Перейдите на вкладку "Вид" и установите переключатель отвечающий за "Скрытые файлы и папки" в значение "Показывать скрытые папки, файлы и диски".
3) Удалите в корне диска файл или папку с именем "Autorun.inf".
4) Перезагрузите компьютер.
5) Измените метку диска (Win   + R → label.exe → OK)
Если же Вы создали файл "Autorun.inf" сами, то просто добавьте в него следующее:

Вместо Метка тома подставьте необходимое Вам значение. Перейти к началу Общего списка советов.


17. Отключение отображения внутренних жестких дисков в "Безопасное извлечение устройств и дисков".

В Windows 7 система использует универсальный драйвер как для SATA (интерфейс подключения внутренних устройств), так и eSATA (интерфейс подключения внешних устройств).
Поэтому, независимо от того к которому из них подключен жесткий диск система определяет поддерживает ли устройство функцию извлечения "на лету".
Если Ваша система использует режим AHCI, то в списке Безопасное извлечение устройств и дисков на панели задач появятся Ваши жесткие диски. Это обусловлено функциональными особенностями AHCI режима, а именно функцией "горячей" замены (HotPlug), означающей возможность извлечения оборудования в компьютерной системе во время работы.
Если Вы не используете мобильное шасси (Mobile Rack) для внутренних жестких дисков и не планируете их извлекать, то Вы можете отключить их отображение в списке Безопасное извлечение устройств и дисков.

Вариант 1. Установите родные драйвера для чипсета к которому подключены жесткие диски. Например для чипсета Intel, драйвера для технология хранения Intel® Rapid.

Вариант 2. Укажите системе, что устройство должно использовать внутренний порт.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды и нажмите Enter ↵.

Где (n)- номер контроллера, на котором висит диск, а (N) - номер канала. В большинстве случаев по умолчанию это 0 в обоих случаях.

Повторите данное действие для каждого диска, заменив значения на необходимые. Номер контроллера в большинстве случаев по умолчанию равен 0 для каждого из Ваших дисков. Номер канала Вы можете посмотреть в диспетчере устройств, на вкладке Сведения, в свойствах Вашего жесткого диска. Значения каналов имеют порядковые номера, начинающиеся с цифры 0.
Например, если у Вас 2 жестких диска, то Вам, скорее всего, нужно будет ввести следующие команды:

Вариант 3. Использование стороннего программного обеспечения.

1) Скачайте и установите программу USB Safely Remove. Данная программа заменит встроенную в Windows функцию Безопасное извлечение устройств и дисков на собственную утилиту.
2) Для того, чтобы иконка пряталась, когда нет ни одного подключенного устройства, включите опцию "Hide icon when there are no devices to be stopped". Она располагается на закладке настроек "Look and Feel". Перейти к началу Общего списка советов.


18. Проверка драйверов для выявления неполадок в работе Windows.

Если Вы предполагаете, что какой-либо из драйверов работает некорректно или, проанализировав дамп памяти, Вы определили драйвер вызвавший ошибку, то для более тщательной проверки работы драйверов Вы можете самостоятельно выполнить проверку драйверов с помощью встроенного в операционную систему средства проверки Verifier.exe.

Проверка неподписанных драйверов.

1) В строке поиска меню Пуск введите verifier и нажмите Enter ↵.
2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
5) Установите переключатель в значение Автоматически выбирать неподписанные драйверы и нажмите кнопку Далее.

Если неподписанные драйверы обнаружены, система отобразит Вам их список, в котором будут указаны файлы драйверов и их описание. Причем найденные драйвера могут принадлежать как устройствам, так и приложениям. Не закрывайте пока окно средства проверки драйверов и не нажимайте никаких кнопок.

Дальше возможно три варианта предпринимаемых Вами действий.

Вариант 1. Обновление программы или драйвера.

6) Посетите сайт производитЈ устройства или автора программы и скачайте более новую версию.
7) Переустановите программу или обновите драйвер.
8) После обновления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
9) Перезагрузите компьютер и продолжайте работу в операционной системе.
Если в системе не возникают ошибки связанной с данным драйвером, значит обновление драйвера или программы устранило её.

Вариант 2. Удаление программы или драйвера.

6.1) Удалите программу, которой принадлежит данный драйвер.
6.1.1) Откройте Панель управления\Все элементы панели управления\Программы и компоненты и удалите приложение, которому принадлежит драйвер.
Перед удалением программы убедитесь, что у Вас присутствует ее установочный диск или ее установка сохранена у Вас на диске.

6.2) Удалите драйвер в Диспетчере устройств.
6.2.1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
6.2.2) Нажмите в списке слева на Диспетчер устройств.
6.2.3) В Диспетчере устройств найдите устройство, щелкните по нему правой кнопкой мыши и выберите из контекстного меню пункт Свойства.
6.2.4) Перейдите на вкладку Драйвер и нажмите кнопку Удалить.

7) После удаления приложения или драйвера закройте окно средства проверки драйверов, нажав кнопку Отмена.
8) Перезагрузите компьютер и продолжайте работу в операционной системе.

Если в системе не возникают ошибки связанной с данным драйвером, значит удаление драйвера или программы устранило её.

Вариант 3. Проверка неподписанных драйверов.

Внимание! После проверки неподписанных драйверов система может не загрузит© (прежде чем переходить к дальнейшим действиям, прочтите данный вариант до конца).

6) Нажмите кнопку Готово и перезагрузите компьютер.

Если же после перезагрузки ¦вился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

7) Перезагрузите компьютер
8) До начала запуска Windows нажмите на клавишуF8. При ¦влении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter ↵, а затем сразуF8.
9) Выберите пункт Безопасный режим
10) Откройте диалоговое меню Выполнить: Пуск → Выполнить или нажмите комбинацию Win   + R
11) Введите команду verifier.exe /reset и нажмите Enter ↵.

Если система загрузилась в обычном режиме, проверка неподписанных драйверов завершилась успешно - они не являются источником проблем.

Проверка подписанных драйверов.

1) В строке поиска меню Пуск введите verifier и нажмите Enter ↵.
2) Выберите пункт Создать нестандартные параметры (для кода программ) и нажмите кнопку Далее.
3) Установите переключатель в значение Выбрать отдельные параметры из полного списка и нажмите кнопку Далее.
4) Отметьте все флажки кроме флажка Имитация нехватки ресурсов и нажмите кнопку Далее.
5) Установите переключатель в значение Выбрать имя драйвера из списка и нажмите кнопку Далее.
6) Нажмите на заголовок колонки Поставщик для сортировки драйверов по их поставщику.
7) Выберите первые 10-15 драйверов установив напротив них флажки в колонке Проверить.
Не выбирайте все драйверы сразу, так как их проверка займет много времени и ресурсов системы.
8) Нажмите кнопку Готово и перезагрузите компьютер. Если система загрузилась в обычном режиме, проверка выбранных драйверов завершилась успешно - они не являются источником проблем. В таком случае повторите описанные выше действия выбрав следующие 10-15 драйверов.

Если же после перезагрузки ¦вился синий экран с ошибкой, проблемный драйвер определен - его название будет включено в сообщение об ошибке. В таком случае:

1) Перезагрузите компьютер
2) До начала запуска Windows нажмите на клавишуF8. При ¦влении окна выбора дисков: выберите диск на котором у Вас установлена Windows, нажмите Enter ↵, а затем сразуF8.
3) Выберите пункт Безопасный режим
4) Откройте диалоговое меню Выполнить: Пуск → Выполнить или нажмите комбинацию Win   + R
5) Введите команду verifier.exe /reset и нажмите Enter ↵. Если проверка всех драйверов завершилась успешно, то скорее всего, драйверы не являются причиной критической ошибки, возникающей в Вашей системе. Перейти к началу Общего списка советов.


19. В окне выбора раздела на диске при установке Windows создается раздел с нулевым размером.

19. При установке Windows, в окне выбора раздела на диске создается раздел с нулевым размером.

В случае появления, при установке Windows, в окне выбора раздела на диске - пункта: Незанятое место на диске 0. Полный размер 0.0МБ, свободно 0.0МБ, выполните указанные ниже действия:

Если у Вас несколько дисков, то для выполнения указанной ниже инструкции оставьте подключенным только тот диск, для которого создается нулевой раздел. Остальные диски отключите.

1) Установите в BIOS режим для дисков на IDE.

Если Вы не можете войти в BIOS для изменения настроек (из-за того что компьютер висит), тогда: 1.1) Выключите компьютер, отсоедините SATA-кабель от диска
1.2) Включите компьютер и измените режим.
1.3) Выключите компьютер, подсоедините SATA-кабель к диску
1.4) Включите компьютер

2) Загрузитесь с Вашего Windows 7 DVD, выберите Установить.
3) Когда Вы окажетесь в окне выбора раздела для установки Windows, удалите все возможные разделы на диске. (Не обращая внимания, на то, что остались не удаленными нулевые разделы.)
4) Выйдите из программы установки Windows. Не продолжайте.
5) Перезапустите компьютер. При желании измените в BIOS режим для дисков с IDE на AHCI.
6) Опять загрузитесь с Вашего Windows 7 DVD, и снова выберите Установить.
7) Когда Вы окажетесь в окне выбора раздела для установки Windows, разделов с 0 размером быть не должно.
8) Укажите все доступное пространство для создание одного раздела.
9) Продолжите установку как обычно.


20. Определение устройства выведшего Windows 7 из спящего режима.

Если уходя от компьютера Вы оставили его в спящем режиме, а вернувшись обнаружили что он включен (разбужен), то для определения устройства выведшего Windows из спящего режима сделайте следующее:

1) Запустите командную строку от имени Администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите команду: powercfg -lastwake и нажмите ОК.
3) Результатом работы данной программы будет указание на идентификатор устройства.

Чтобы узнать, что это за устройство:

4) Запустите Редактор реестра (Win   + R → regedit → ОК)
5) Откройте ветку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\.
6) Найдите искомое Вами устройство, согласно полученному при выполнении powercfg результату.
Наименование устройства будет отображено в найденном Вами ключе в параметре DeviceDesc Перейти к началу Общего списка советов.


21. Отключение автоматической перезагрузки при появлении синего экрана смерти (BSOD).

Для этого отключите автоматическую перезагрузку при его появлении:

1) Нажмите комбинацию клавиш "Win+Pause"
2) Щелкните ссылку "Дополнительные параметры системы"
3) Перейдите на вкладку "Дополнительно"
4) Нажмите кнопку "Параметры" в "Загрузка и восстановление"
5) Cнимите флажок "Выполнять автоматическую перезагрузку" и нажмите ОК. Перейти к началу Общего списка советов.


22. Восстановление используемых по умолчанию планов электропитания.

Варинт 1. Сброс и Восстановление всех планов электропитания.

Это может пригодиться, если у Вас отсутствует один или все планы управления электропитанием по умолчанию и Вы хотели бы вернуть все настройки в изначальные.

1) Запустите командную строку от имени администратора. (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
2) В командной строке введите: powercfg -restoredefaultschemes и нажмите Enter ↵.
3) Закройте командную строку и перезагрузите компьютер.

Варинт 2. Восстановление отдельного плана электропитания.

Данный вариант пригодиться, в случае неправильной настройки параметров для отдельного плана электропитания.

1) В строке поиска меню Пуск введите powercfg.cpl и нажмите Enter ↵.
или откройте Панель управления\Все элементы панели управления\Электропитание
2) Выберите план для которого Вы желаете восстановить настройки по умолчанию и нажмите на ссылку Настройка плана электропитания
3) Нажмите на ссылку Восстановить для плана параметры используемые по кмолчанию и нажмите кнопку Да.
или нажмите на ссылку Изменить дополнительные параметры питания, а затем на кнопку Восстановить параметры по умолчанию и кнопку Да. Перейти к началу Общего списка советов.


23. Сброс (обнуление) всех значений индекса производительности.

Вариант 1. Сброс значений индексов и повторная оценка.

Чтобы полностью удалить все значения индекса производительности, Вам необходимо воспользоваться вторым или третьим вариантом.

1) Щелкните правой кнопкой мыши на иконку Компьютер в меню Пуск и выберите пункт Свойства.
2) Щелкните по ссылке Индекс производительности Windows.
3) В меню слева щелкните по ссылке Дополнительные инструменты.
4) Щелкните по ссылке Очистить все значения индекса производительности Windows и выполнить повторную оценку.
Значения индексов сбросятся и будут вычислены заново. В папке C:\Windows\Performance\WinSat\DataStore создастся новый набор xml-файлов с результатами тестов, содержащий в названии дату проведения текущей оценки.

Вариант 2. Удаление значений индексов, используя командную строку.

1) Запустите командную строку от имени администратора. (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
2) Введите указанную ниже команду и нажмите Enter ↵.

3) Закройте командную строку.

Все значения индексов будут удалены. В системе будет указано, что оценка индекса производительности не производилась. Вам необходимо будет самостоятельно произвести оценку.

Вариант 3. Удаление значений индексов, используя Проводник.

1) Откройте в Проводнике папку C:\Windows\Performance\WinSat\DataStore
2) Выделите все xml-файлы и удалите их.
3) Закройте Проводник.

Все значения индексов будут удалены. В системе будет указано, что оценка индекса производительности не производилась. Вам необходимо будет самостоятельно произвести оценку.


24. Восстановление неработающего жесткого диска или флеш-диска (флешки), используя низкоуровневое форматирование.

Если при попытке форматирования Вашего жесткого диска или флеш-диска (флешки) у Вас постоянно показывает ошибку "Windows не удается завершить форматирование".
Если на Ваш жесткий диск или флеш-диск (флешку) невозможно ничего записать или считать с него.
Если Ваш диск перестал определятся средствами Windows.
То Вы можете попытаться восстановить их работоспособность используя программу HDD Low Level Format Tool.

1) Скачайте и распакуйте в любую папку архив HDDLLFTOOL.zip
2) Запустите файл HDDLLFTOOL_Eng.exe (английская версия) или HDDLLFTOOL_Rus.exe (русская версия).
3) Выделите в списке Ваш диск и нажмите кнопку Continue (Продолжить).
4) Перейдите на вкладку LOW-LEVEL FORMAT (НИЗКОУРОВНЕВОЕ ФОРМАТИРОВАНИЕ) и нажмите кнопку FORMAT THIS DEVICE (ФОРМАТИРОВАТЬ ЭТО УСТРОЙСТВО).
При незначительных проблемах для ускорения процесса форматирования Вы можете установить флажок Perfom quick wipe (Выполнять быструю очистку).
Большего эффекта дает низкоуровневое форматирование без установки данного флажка.
5) Нажмите кнопку Да, в окне предупреждающем о потере имеющихся данных в результате форматирования.
6) Когда процесс форматирования достигнет 100% закройте программу.
7) Откройте в Проводнике папку компьютер и щелкните правой кнопкой мыши на Вашем диске.
8) Выберите пункт Форматировать и отформатируйте Ваш диск.
Некоторые диски начинают работать, только если их отформатировать сначала в формат FAT32.
В таком случае, после форматирования в FAT32 переподключите диск и отформатируйте его в другую файловую систему (NTFS, exFAT или FAT). Перейти к началу Общего списка советов.


1. Принципы работы Portable-программы и подготовка компьютера к её созданию.

Portable (портабельная, переносимая) программа — программное обеспечение, которое не требует установки яў своего запуска, может запускаться с флеш-диска или жесткого диска, вносит минимальные изменения в операционную систему и максимально приближено по функционалу к инсталлируемой версии.
Для создания большинства Portable-программ используется принцип выявления внесенных изменений в системе, путем сравнения первого и второго снимков состояний системы.
Поэтому, состояние операционной системы, на которой будет создаваться Portable-версия программы, желательно должно быть максимально приближенно к свежеустановленной Windows.
Принцип работы Portable-программы состоит либо в эмуляции псевдоустановки в реальную систему, либо в виртуализации ресурсов (разделы реестра, системные папки), необходимых для запуска Portable-программы.
Виртуальная среда в которой виртуализируются ресурсы принято называть "Песочницей".
В большинстве случаев, рядом с exe-файлом, либо в папках %APPDATA% или %LOCALAPPDATA%, создается папка содержащая файлы необходимые для запуска программы.

Не виртуализируются или крайне сложно и проблемно виртуализируются следующие типы приложений:

1) Программы, изначально неподдерживаемые в операционной системе, где производится их запуск;
2) Плагины, Add-in-ы и прочие типы исполняемых и dll файлов которые встраиваются в приложение другого производитЈ, расширяя его функциональность.
3) Программы взаимодействующее с Windows сервисом запущенным под системным аккаунтом.
4) Программы, требующие установки драйверов устройств. Программа будет работать, если требуемые драйверы предустановлены в системе.
5) Программы с аппаратной защитой от копирования.

Рекомендации при работе с приложениями для создания Portable-программ.
1) Используйте виртуальную систему (VMware Workstation, Oracle VirtualBox) с свежеустановленной Windows для создания Portable-программ.
2) Если в приложении отсутствует функция сравнения изменений в системе и Вам необходимо вручную указать, что добавить, то для выявления изменений в системе используйте программу SysTracer: официальный сайт или зеркало.
3) Установите все возможные обновления через Центр обновления Windows.
4) Отключите Контроль учетных записей:
4.1) Откройте Панель управления\Все элементы панели управления\Учетные записи пользователей.
4.2) Нажмите на ссылку Изменение параметров контроля учетных записей.
4.3) Передвиньте ползунок в самое нижнее положение и нажмите ОК.
4.4) Перезагрузите компьютер
5) Отключите Защиту системы ()создание точек восстановления).
5.1) В меню Пуск щелкните правой кнопкой мыши на Компьютер и выберите пункт Свойства.
5.2) Нажмите ссылку Защита системы и в открывшемся окне нажмите кнопку Настроить.
5.3) Установите переключатель в положение Отключить защиту системы и нажмите кнопку ОК.
6) Отключите индексирование файлов.
6.1) Откройте в меню Пуск папку Компьютер или запустите Проводник.
6.2) Щелкните правой кнопкой мыши на жестком диске и выберите пункт Свойства.
6.3) На вкладке Общие снимите флажок Разрешить индексировать содержимое файлов на этом диске в дополнение к свойствам файла и нажмите кнопку Применить.
6.4) Установите переключатель в значение К диску X:\ и ко всем вложенным папкам и файлам (X:\ - буква Вашего жесткого диска) и нажмите кнопку ОК.
6.5) Если всплывет окно Отказано в доступе нажмите Продолжить, если всплывет окно Ошибка изменения атрибутов, то выберите пункт Пропустить все.
7) Отключите имеющиеся в системе службы, работа которых может помешать созданию будущей Portable-программы:

Superfetch
Windows Search
Архивация Windows
Брандмауэр Windows
Защитник Windows
Программный поставщик теневого копирования (Microsoft)
Служба индексирования
Служба регистрации ошибок Windows
Теневое копирование тома
Центр обеспечения безопасности
Центр обновления Windows

7.1) Откройте Панель управления → Администрирование и запустите Службы (Win   + R → services.msc → ОК)
7.2) Щелкните дважды на необходимой службе.
7.3) Установите Тип запуска в значение Отключена и нажмите кнопку Применить.
7.4) Если служба запущена, то нажмите кнопку Остановить и дождитесь остановки службы.
7.5) Нажмите кнопку ОК и закройте Службы.
8) Перезагрузите компьютер.

Перейти к началу раздела Портабелизация.


2. Создание Portable-версии приложения в программе Cameyo.

Для создания Portable-версии приложения в программе Cameyo сделате следующее.

1) Зайдите на сайт http://online.cameyo.com/login.aspx и нажмите Create free account.
2) Создайте аккаунт и подтвердите его со своего e-mail.
3) Зайдите на http://www.cameyo.com и скачайте последнюю версию Cameyo.
4) Запустите скаченный файл, нажмите на ссылку Login вверху программы.
5) Введите Ваши логин и пароль и нажмите кнопку Login.
6) В зависимости от конфигурации Вашей системы и доступности Microsoft .Net Framework Вы увидите один из двух вариантов интерфейса.
6.1) В расширенном варианте перейдите на вкладку Studio и нажмите Capture app localy.
6.2) В упрощенном интерфейсе нажмите Capture installation.

7) Упаковщик программы Cameyo начнет захват снимка текущего состояния Вашей системы.
8) После завершения процесса захвата появится окно с кнопками Install done и Cancel:

Пока ничего в нем не нажимайте.
9) Установите в систему программу которую Вы желаете сделать Portable.
Если Вы желаете, чтобы созданная Вами Portable-программа запускалась с необходимыми Вам настройками, то запустите установленную программу и настройте ее.
Если Вам необходимо, чтобы она была зарегистрирована/активирована, то сделайте это сейчас, в ином случае программа будет запускаться в пробном режиме.
10) Нажмите кнопку Install done. Упаковщик программы Cameyo снова сделает снимок текущего состояния Вашей системы и проанализирует внесенные в систему изменения.
Теперь Вы можете либо нажать либо кнопку ОК и завершить создание Portable-программы, либо нажать кнопку Edit package и отредактировать, что будет в нее упаковано и как программа будет взаимодействовать с системой.

На вкладке General выберите способ взаимодействия программы с системой, в которой она будет запущена.

Isolation mode:

Data mode - приложение может сохранять файлы только на рабочем столе и в папке Документы.
Isolated - приложение не может вносить изменения в систему.
Full access - приложение может вносить изменения в системные файлы и в реестр.

Data storage (для открытия окна настроек нажмите ссылку Change):

Default - при запуске с жесткого диска хранилище данных (рабочая папка) будет создана в системной папке %APPDATA%, а при запуске с флеш-диска - рядом с папкой, содержащей файлы для запуска exe-файла.
Under the executable's directory - хранилище данных (рабочая папка) будет создана рядом с папкой, содержащей файлы для запуска exe-файла.
Custom location - Вы можете указать любое желаемое расположение. Пример, %ExeDir% , что обозначает папку, содержащую файлы для запуска exe-файла.

Icon (для открытия окна настроек нажмите ссылку Change icon) - позволяет установить иконку для Вашей Portable-программы.

На вкладке Files Вы можете выбрать какие файлы будут включены в виртуальный пакет. Это набор файлов которые программа будет использовать. Вы можете удалить или добавить новые папки и файлы.
Названия папок указаны в виде переменных для большей совместимости с системой, в которой будет запущена Portable-программа.

Переменная (значение в дереве программы) | Соответствие расположению в реальной системе
%Program Files% | C:\Program Files
%Windows% | C:\Windows
%Fonts% | C:\Windows\Fonts
%System% | C:\Windows\System32
%Profile% | C:\Users\UserName
%Local AppData% | C:\Users\UserName\AppData\Local
%Internet History% | C:\Users\UserName\AppData\Local\Microsoft\Windows\History
%Internet Temp% | C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files
%AppData% | C:\Users\UserName\AppData\Roaming
%NetHood% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Network Shortcuts
%Recent% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Recent
%SendTo% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo
%Programs% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
%Startup% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
%Templates% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Templates
%Desktop% | C:\Users\UserName\Desktop
%Personal% | C:\Users\UserName\Documents
%Favorites% | C:\Users\UserName\Favorites
%MyPictures% | C:\Users\UserName\Pictures
%MyVideo% | C:\Users\UserName\Videos
%Common AppData% | C:\ProgramData
%Common Profile% | C:\ProgramData
%Common StartMenu% | C:\ProgramData\Microsoft\Windows\Start Menu
%Common Programs% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs
%Common Startup% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
%Common Desktop% | C:\Users\Public\Desktop
Переменная (значение в дереве программы) | Соответствие расположению в реальной системе

На вкладке Registry Вы можете выбрать какие записи реестра будут включены в виртуальный пакет. Это набор разделов и параметров реестра которые программа будет использовать. Вы можете удалить или добавить новые разделы или параметры.

На вкладке Advanced Вы можете выбрать удалять ли следы программы при выходе.

No clean up, leave app ready to run - ничего не удаляется, приложение готово к повторному запуску.
Leave no registry traces - не оставлять следов реестра.
Remove all virtual data upon exit - приложение удаляет все данные и настройки.
Ask for confirmation before removal - спрашивать ли подтверждения при удалении.

11) После внесения желаемых изменений выберите в главном меню File пункт Save (процесс сохранения может занять несколько минут), а затем пункт Exit.
12) Созданная Вами Portable-программа будет помещена в папку Мои документы\Cameyo apps.

Для информации: При первом запуске программы Cameyo, она распаковывает себя в папку %userprofile%\AppData\Roaming\VOS\Cameyo.

Перейти к началу раздела Портабелизация.


3. Создание Portable-версии приложения в программе Spoon Virtual Application Studio.

Для создания Portable-версии приложения в программе Spoon Virtual Application Studio сделате следующее.

1) Зайдите на сайт http://spoon.net
2) Нажмите вверху страницы Apps и выберите пункт Virtual Application Studio.
3) Введите данные необходимые для регистрации и нажмите кнопку SIGN UP.
4) Скачайте и установите программу.
5) Щелкните вверху страницы на Ваш e-mail и нажмите пункт Account Settings.
6) Нажмите внизу страницы на кнопку VIEW CERTIFICATE напротив Spoon Virtual Application Studio.
7) Скопируйте текст из открывшегося окна Spoon Studio License в буфер обмена.
8) Запустите программу Spoon Virtual Application Studio.
9) Откройте Options → Install License Certificate, вставьте текст из буфера обмена и нажмите ОК.
11) Создайте на диске C:\ папку, куда будут сохранены результаты сравнения снимков состояния системы. (Пример: C:\CheatEnginePortable)
12) Нажмите кнопку Capture Before для создания снимка текущего состояния системы.
13) Установите в систему программу которую Вы желаете сделать Portable.
14) Запустите ее, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
15) Если программа требует перезагрузки, то закройте Virtual Application Studio, перезагрузите компьютер, а после перезагрузки запустите снова.
16) Нажмите кнопку Capture and Diff, выберите созданную Вами папку для сохранения результатов и нажмите ОK. (Пример: C:\CheatEnginePortable)

17) Нажмите Filesystem и выберите файлы и папки необходимые для добавления в Portable-программу.

Переменная (значение в дереве программы) | Соответствие расположению в реальной системе
@APPDIR@ (Application Directory) | Папка с запускающим модулем для Portable-программы
@SYSDRIVE@ (System Drive) | C:\
@PROGRAMFILES@ (Program Files) | C:\Program Files
@PROGRAMFILESCOMMON@ (Program Files\Common) | C:\Program Files\Common Files
@WINDIR@ (Windows) | C:\Windows
@SYSTEM@ (System Drive\Windows\System32) | C:\Windows\System32
@PROFILE@ (Current User Directory) | C:\Users\UserName
@APPDATALOCAL@ (Current User Directory\Local Application Data) | C:\Users\UserName\AppData\Local
@APPDATA@ (Current User Directory\Application Data) | C:\Users\UserName\AppData\Roaming
@STARTMENU@ (Current User Directory\Start Menu) | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu
@PROGRAMS@ (Current User Directory\Start Menu\Programs) | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
@STARTUP@ (Current User Directory\Start Menu\Programs\Startup) | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
@TEMPLATES@ (Current User Directory\Templates) | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Templates
@DESKTOP@ (Current User Directory\Desktop) | C:\Users\UserName\Desktop
@DOCUMENTS@ (Current User Directory\My Documents) | C:\Users\UserName\Documents
@FAVORITES@ (Current User Directory\Favorites) | C:\Users\UserName\Favorites
@MUSIC@ (Current User Directory\My Music) | C:\Users\UserName\Music
@PICTURES@ (Current User Directory\My Pictures) | C:\Users\UserName\Pictures
@APPDATACOMMON@ (All Users Directory\Application Data) | C:\ProgramData
@PROFILECOMMON@ (All Users Directory) | C:\ProgramData
@STARTMENUCOMMON@ (All Users Directory\Start Menu) | C:\ProgramData\Microsoft\Windows\Start Menu
@PROGRAMSCOMMON@ (All Users Directory\Start Menu\Programs) | C:\ProgramData\Microsoft\Windows\Start Menu\Programs
@STARTUPCOMMON@ (All Users Directory\Start Menu\Programs\Startup) | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
@TEMPLATESCOMMON@ (All Users Directory\Templates) | C:\ProgramData\Microsoft\Windows\Templates
@DESKTOPCOMMON@ (All Users Directory\Desktop) | C:\Users\Public\Desktop
@DOCUMENTSCOMMON@ (All Users Directory\Documents) | C:\Users\Public\Documents
@FAVORITESCOMMON@ (All Users Directory\Favorites) | C:\Users\Public\Favorites
@MUSICCOMMON@ (All Users Directory\Music) | C:\Users\Public\Music
@PICTURESCOMMON@ (All Users Directory\Pictures) | C:\Users\Public\Pictures
Переменная (значение в дереве программы) | Соответствие расположению в реальной системе

18) Нажмите Registry и выберите, разделы и параметры реестра, необходимые для добавления в Portable-программу.

Значение в дереве программы | Пример соответствия месторасположения
Classes root | HKEY_CLASSES_ROOT
Current User root | HKEY_CURRENT_USER
Local Machine | HKEY_LOCAL_MACHINE
Users root | HKEY_USERS

19) Для любого файла/папки или раздела/параметра реестра Вы можете выбрать один из предложенных в программе режимов из Јции виртуальной среды Portable-программы от основной (хостовой) системы.
В случае возникновения конфликтов между данными в хостовой системе и виртуальной среде, данные в виртуальной среде имеют преимущество.

Full: Portable-программе видны файлы и параметры рестра только из виртуальной файловой системы, даже если идентичные и существует на хост-устройстве. Записи перенаправляются в область данных песочницы.
Merge: Существующие в виртуальной среде файлы и параметры рестра будут объединены с идентичными на хост-машине. Записи в хостовые файлы и параметры рестра будут происходить через хост-устройство, а записи в виртуальные файлы и параметры рестра будут перенаправлены в область данных песочницы.
Write Copy: Используется, когда виртуальному приложению необходимо прочитать из файлов и и параметров рестра уже присутствующих на хост-устройстве, но из Јция хост-устройства по-прежнему необходима. Существующие на хост-устройстве файлы и и параметры рестра видны в виртуальной среде, но любые изменения их содержимого перенаправляются в область данных песочницы.
Hide: Используется, когда файл или параметр рестра на хост-машине может затруднить корректную работу приложения. Файлы и параметры рестра с включенным режимом Hide, не будут найдены Portable-программой во время ее выполнения как в виртуальной файловой системе и виртуальном реестре, так и в хост-системе и хост-реестре.

Чтобы применить выбранный режим ко всем подпапкам:
19.1) Щелкните правой кнопкой мыши на папке и выберите пункт Isolation.
19.2) В ниспадающем списке выберите необходимый Вам режим и установите флажок Apply to Subfolders и нажмите ОК.

Если в Вашей Portable-программе один exe-файл, который Вы желаете запускать, то:

21) В поле Startup File укажите какой файл следует запускать при запуске Portable-программы.
22) Нажмите кнопку Browse рядом с полем Output File, укажите имя и расположение для готового файла Portable-программы и нажмите кнопку Сохранить.
23) Нажмите на круглую кнопку "молоток с диском" и выберите пункт Save Configuration для сохранения внесенных в проект изменений.
24) Нажмите на кнопку Build и начнется сборка Portable-программы, а при ¦влении сообщения Finished нажмите кнопку ОК.
Ваша Portable-программа готова для использования.

Если в Вашей Portable-программе несколько exe-файлов, который Вы желаете запускать, то:

21) Скачайте и распакуйте архив SpoonStudioExeBuilder.zip, а затем скопируйте файл ExeBuilder.exe в папку к xappl-файлу проекта. (Пример: C:\CheatEnginePortable\Snapshot.xappl)
22) Откройте Setup → Shortcuts → Program Menu и нажмите кнопку Add shortcut.

23) В окне Edit Shortcut Settings нажмите кнопку Edit List.

24) В окне Startup Files выберите основной exe-файл для запуска, установив;§дом с ним флажок в графе AutoStart.

25) Если необходимый Вам exe-файл отсутствует в списке, то укажите путь к нему в поле File над горизонтальным разделителем и нажмите Enter ↵.
(Пример: @PROGRAMFILES@\Cheat Engine 6.2\Tutorial-x86_64.exe)
Файл автоматически добавится в список под горизонтальным разделителем.
26) В поле Trigger рядом с дополнительным exe-файлов введите значение, которое позволит его запускать. (Пример: Tutorial-x86_64)
27) Нажмите кнопку ОК и Вы вернетесь в окно Edit Shortcut Settings.
28) В ниспадающем списке Target выберите добавленный файл. (Пример: Tutorial-x86_64.exe)
29) В поле Name введите имя ярлыка для запуска exe-файла и нажмите ОК. (Пример: Cheat Engine tutorial (64-bit))
30) Нажмите кнопку Browse рядом с полем Output File, укажите имя и расположение для готового файла Portable-программы и нажмите кнопку Сохранить.
31) Нажмите на круглую кнопку "молоток с диском" и выберите пункт Save Configuration для сохранения внесенных в проект изменений.
32) Нажмите на кнопку Build и начнется сборка Portable-программы, а при ¦влении сообщения Finished нажмите кнопку ОК.

33) Закройте программу Spoon Virtual Application Studio.
34) Откройте папку, где находится Ваш xappl-файл проекта и куда Вы сохранили утилиту ExeBuilder. (Пример: C:\CheatEnginePortable)
35) Запустите программу ExeBuilder и нажмите кнопку Proceed, а по завершении создания exe-файлов для запуска отдельных компонентов Portable-программы нажмите кнопку ОК.

36) Скопируйте готовые exe-файлы из папки, где находится Ваш xappl-файл проекта в папку, где находится готовый файл Portable-программы.
Ваша Portable-программа с exe-файлами яў запуска отдельных компонентов, готова для использования.

Перейти к началу раздела Портабелизация.


4. Создание Portable-версии приложения в программе VMware ThinApp.

Для создания Portable-версии приложения в программе VMware ThinApp сделате следующее.

1) Откройте страницу https://my.vmware.com/web/vmware/evalcenter?p=vmware-thinapp и перейдите на вкладку Create an Account.
2) В поле First Name введите Ваше имя, в поле Last Name введите Вашу фамилию, в поле Email Address - Ваш e-mail и нажмите Continue.
3) Заполните все поля анкеты отмеченные звездочкой.
4) Установите флажки I agree to the terms and conditions outlined in the My VMware Terms of Use Agreement. и I agree to the terms and conditions outlined in the Evaluation End User License Agreement. и нажмите кнопку Start Free Trial.
5) Откройте письмо пришедшее на Ваш e-mail, указанный при регистрации и нажмите на ссылку activate для активации Вашего аккаунта на сайте VMware.
6) Введите пароль указанный при регистрации и нажмите Continue.
7) Скопируйте серийный номер для программы VMware ThinApp в буфер обмена.
8) Нажмите на ссылку Manually Download рядом с VMware ThinApp X.X.X (где X.X.X - номер версии).
9) Запустите установку программы и нажимайте кнопки Next (Continue).
10) В окне Enter License Key вставьте скопированный серийный номер и нажмите кнопку Enter, а в следующем окне нажмите кнопку Finish.
11) Запустите программу ThinApp Setup Capture из папки VMware в меню Пуск.
12) Нажмите кнопку Next в программе для перехода к следущему шагу.
13) Нажмите кнопку Advanced Scan Locations, выберите какие диски и разделы реестра должны быть просканированы для создания текущего снимка системы и нажмите кнопку ОК.
14) Нажмите кнопку Prescan для создания текущего снимка системы.

15) При ¦влении окна Setup Capture - Install Application сверните его в Панель задач.

16) Установите в систему программу которую Вы желаете сделать Portable.
17) Запустите ее, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
18.1) Если Ваша программа для продолжения требует перезагрузки, то перезагрузите компьютер.
18.1.1) После перезагрузки автоматически ¦вится окно Setup Capture - Welcome.

18.1.2) Установите переключатель в значение Continue installation process, нажмите кнопку Next и Вы снова окажетесь в окне Setup Capture - Install Application.
18.2) Если Ваша программа для продолжения не требует перезагрузки, то восстановите свернутое окно Setup Capture - Install Application.
19) Нажмите кнопку Postscan для создания нового снимка системы.
20) Нажмите кнопку ОК в маленьком всплывшем окне Setup Capture.
21.1) В окне Setup Capture - Entry Points установите флажок напротив основного exe-файла, если при запуске Portable-программы должен запускаться один исполняемый файл и нажмите кнопку Next.

21.2) В окне Setup Capture - Entry Points установите флажки напротив нескольких exe-файлов, если при запуске Portable-программы должен запускаться любой указанный исполняемый файл из выбранных. (Например: Misrosoft Office) и нажмите кнопку Next.
22) В окне Setup Capture - Manage with Horizon нажмите кнопку Next.
23) В окне Setup Capture - Groups оставьте переключатель установленным по умолчанию в значении Everyone и нажмите кнопку Next.
24) В окне Setup Capture - Isolation выберите режим изоляции виртуальной среды Portable-программы от основной (хостовой) системы и нажмите кнопку Next.

Full write access to non-system directories (Merged Isolation Mode) - Portable-программа может читать и записывать файлы в реальную систему. Изменения, вносимые в системные папки, папки программы и %APPDATA%, будут сохранены в виртуальной среде.
Restricted write access (WriteCopy Isolation Mode) - Запрещает Portable-программе записывать в большиство папок. Рекомендуется для старых или ненадежных программ. Изменения, вносимые вне папок Рабочий стол (Desktop) и Мои документы (Documents), будут сохранены в виртуальной среде.

25) В окне Setup Capture - Sandbox выберите расположение песочницы (рабочей папки, куда будут сохранятся конфигурация и необходимые данные для работы Portable-программы) и нажмите кнопку Next.

User profile (%AppData%\Thinstall) - В папке профиля пользователя (C:\Users\Administrator\AppData\Roaming) в реальной системе будет создана папка Thinstall.
Same directory as the application (use with USB and portable media) - в папке рядом с Portable-программой.
Custom location or network drive - в указанной Вами папке.

26) В окне Setup Capture - Quality Assurance Statics выберите желаете ли Вы отправлять анонимную статистику в компанию VMware (Yes/Да или No/Нет) и нажмите кнопку Next.
27) В окне Setup Capture - Project Settings укажите имя и месторасположение для сохранения Вашего проекта и нажмите кнопку Next.

28.1) В разделе Primary data container окна Setup Capture - Package Settings установите переключатель в значение Use one of the entry points, если программа содержит один исполняемый файл, который должен запускаться при запуске Portable-программы.
Выбор данного пункта приведет к созданию одного exe-файла для запуска основного файла программы.

28.2) В разделе Primary data container окна Setup Capture - Package Settings оставьте переключатель установленным в значение Use separate .DAT file, если при запуске Portable-программы должен запускаться любой указанный исполняемый файл из выбранных. (Например: Misrosoft Office). Также данный пункт рекомендуется выбирать при больших размерах проекта.
Выбор данного пункта приведет к созданию одного dat-файла, включающего в себя виртуальную среду выполнения ThinApp, доступную только для чтения виртуальную файловую систему и виртуальный реестр и отдельных небольших exe-файлов для запуска каждой отдельной программы.
29) В разделе MSI package generation оставьте флажок Generate MSI package не установленным для большинства проектов. Generate MSI package - позволяет упаковать Вашу Portable-программу в msi-файл, являющийся пакетом установщика Windows. Его установка будет производится в папку C:\Program Files. Это может быть удобно администраторам для доставки и развертывания программы на группе машин.
30) В разделе Compression установите флажок Compress virtual package, если Вы желаете уменьшить размер будущей Portable-программы. Внимание: Процесс сжатия потребует значительного времени!
31) Нажмите кнопку Save для сохранения файлов и ключей реестра в папку проекта. Если всплыло окно Setup Capture, то нажмите в нем кнопку Да.
32) В окне Setup Capture – Ready to Build нажмите кнопку Open Project Folder и настройте какие файлы, папки, разделы и параметры реестра должны быть включены в Вашу Portable-программу.

Переменная (значение в дереве программы) | Соответствие расположению в реальной системе
%Drive_c% | C:\
%ProgramFilesDir% | C:\Program Files
%Program Files Common% | C:\Program Files\Common Files
%SystemRoot% | C:\Windows
%Fonts% | C:\Windows\Fonts
%Resources% | C:\Windows\Resources
%Resources Localized% | C:\Windows\Resources\<language_ID>
%SystemSystem% | C:\Windows\System32
%Common AppData% | C:\ProgramData
%Common StartMenu% | C:\ProgramData\Microsoft\Windows\Start Menu
%Common Programs% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs
%Common AdminTools% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools
%Common Startup% | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
%Common Templates% | C:\ProgramData\Microsoft\Windows\Templates
%Profiles% | C:\Users
%Common Desktop% | C:\Users\Public\Desktop
%Common Documents% | C:\Users\Public\Documents
%Common Favorites% | C:\Users\Public\Favorites
%Profile% | C:\Users\UserName
%Local AppData% | C:\Users\UserName\AppData\Local
%CDBurn Area% | C:\Users\UserName\AppData\Local\Microsoft\Windows\Burn\Burn
%History% | C:\Users\UserName\AppData\Local\Microsoft\Windows\History
%Internet Cache% | C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files
%TEMP% | C:\Users\UserName\AppData\Local\Temp
%AppData% | C:\Users\UserName\AppData\Roaming
%Cookies% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Cookies
%NetHood% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Network Shortcuts
%PrintHood% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Printer Shortcuts
%Recent% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Recent
%SendTo% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo
%Programs% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
%AdminTools% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools
%Startup% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
%Templates% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Templates
%Desktop% | C:\Users\UserName\Desktop
%Personal% | C:\Users\UserName\Documents
%Favorites% | C:\Users\UserName\Favorites
%My Pictures% | C:\Users\UserName\Pictures
%My Videos% | C:\Users\UserName\Videos
%Drive_m% | M:\
Переменная (значение в дереве программы) | Соответствие расположению в реальной системе

Для удобства редактирования созданного Вами проекта Вы можете воспользоваться программой ThinAppHelper.
Чтобы отредактировать проект Вам необходимо открыть файл Package.ini, находящийся в папке Вашего проекта:
C:\Program Files\VMware\VMware ThinApp\Captures\AppName.
AppName - имя проекта и будущей Portable-программы (Например: C:\Program Files\VMware\VMware ThinApp\Captures\Adobe Reader X (10.1.3) - Russian)

33) Вернитесь в окно Setup Capture – Ready to Build и нажмите кнопку Build, чтобы приступить к созданию Portable-программы.
34) В окне Setup Capture – Build Project оставьте установленным флажок Open folder containing project executables after clicking Finish и нажмите кнопку Finish для завершения процесса создания Portable-программы и открытия папки содержащей готовую Portable-программу.

Если Вы решите пересобрать Вашу Portable-программу, изменив входящие в нее папки, файлы, разделы или параметры реестра, то Вы можете быстро сделать это используя ThinAppHelper. После внесения изменений нажмите на значок молотка, чтобы собрать проект в новую Portable-программу.

Перейти к началу раздела Портабелизация.


5. Создание Portable-версии приложения, используя PortableApps.com Launcher и PortableApps.com Installer.

Так как каждый случай для создания в данной программе уникален, то далее будет приведен самый простой шаблон создания Portable-программы.
Для создания Portable-версии приложения в программе PortableApps.com Platform сделате следующее.

1) Зайдите на сайт http://Portableapps.com/development и скачайте программу PortableApps.com Installer.
2) Установите ее в папку C:\PortableApps\PortableApps.comInstaller.
3) Зайдите на сайт http://Portableapps.com/development и скачайте программу PortableApps.com Launcher.
4) Установите ее в папку C:\PortableApps\PortableApps.comLauncher.
5) Зайдите на сайт http://Portableapps.com/apps/development/nsis_Portable и скачайте программу NSIS Portable (Unicode вариант).
6) Установите ее в папку C:\PortableApps\NSISPortable.
7) Создайте на диске C:\ рабочую папку с именем AppNamePortable, где AppName имя Вашей будущей Portable-программы. (Пример: C:\FoxitReaderPortable)
8) Создайте в данной папке папку с именем App. (Пример: C:\FoxitReaderPortable\App)
9) Скачайте программу SysTracer с официального сайта или зеркала.
10) Используя ее сделайте текущий снимок системы.
11) Установите программу, которую Вы желаете сделать Portable в директорию C:\AppNamePortable\App в соответствии с необходимыми Вам настройками.
(Пример: C:\FoxitReaderPortable\App\Foxit Reader)
12) Запустите ее, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
13) Вернитесь в SysTracer и сделайте новый снимок системы.
14) Проанализируйте внесенные изменения в реестр.
15) Откройте редактор реестра и сделайте экспорт найденных измененных веток реестра.
16) Объедините их в один reg-файл. (Пример: Foxit Software.reg)
17) Создайте в папке C:\AppNamePortable\App папку DefaultData, а в ней папку settings. (Пример: C:\FoxitReaderPortable\App\DefaultData)
18) Скопируйте в нее Ваш reg-файл.
19) Создайте в папке C:\AppNamePortable\App папку AppInfo. (Пример: C:\FoxitReaderPortable\App\AppInfo)
20) Скопируйте из папки C:\PortableApps\PortableApps.comLauncher\App\AppInfo в папку C:\AppNamePortable\App\AppInfo основную иконку для Portable-программы - appinfo.ico и дополнительные иконки - appicon_16.png, appicon_32.png, appicon_128.png. Также Вы можете использовать собственные файлы иконок с идентичными именами и расширениями файла.
21) Создайте в папке C:\AppNamePortable\App\AppInfo файл appinfo.ini, указанного ниже содержания:

Замените AppName на имя Вашей программы. Пример:

22) Создайте в папке C:\AppNamePortable\App\AppInfo папку Launcher. (Пример: C:\FoxitReaderPortable\App\AppInfo\Launcher)
23) Создайте в папке C:\AppNamePortable\App\AppInfo\Launcher файл AppNamePortable.ini, указанного ниже содержания: (Пример: FoxitReaderPortable.ini)

Пример:

24) Скопируйте файл help.html из папки C:\PortableApps\PortableApps.comLauncher в папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable\help.html)
25) Откройте папку C:\PortableApps\PortableApps.comLauncher и запустите файл PortableApps.comLauncherGenerator.exe.
26) Нажмите кнопку Next в программе для перехода к следущему шагу.
27) Укажите папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable) и нажмите кнопку Go.

28) Нажмите кнопку Finish, чтобы выйти.

29) Откройте папку C:\PortableApps\PortableApps.comInstaller и запустите файл PortableApps.comInstaller.exe.
30) Нажмите кнопку Next в программе для перехода к следущему шагу.
31) Укажите папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable) и нажмите кнопку Go.

32) Нажмите кнопку Finish, чтобы выйти.

33) Ваша готовая Portable-программа упакованная в PAF-инсталлятор будет находится в корне диска C:\.

Перейти к началу раздела Портабелизация.


6. Создание Portable-версии приложения, используя Portable App Creator и PortableApps.com Installer.

Для создания Portable-версии приложения, используя программу Portable App Creator сделате следующее.

1) Создайте на диске C:\ рабочую папку с именем AppNamePortable, где AppName имя Вашей будущей Portable-программы. (Пример: C:\FoxitReaderPortable)
2) Создайте в данной папке папку с именем App. (Пример: C:\FoxitReaderPortable\App)
3) Создайте на диске C:\ папку PortableApps (C:\PortableApps)
4) Cкачайте архив с программой PortableAppCreator_0__99_beta_English.zip.
5) Разархивируйте его и установите программу в папку C:\PortableApps\PortableAppCreator.
6) Зайдите на сайт http://www.autoitscript.com/site/autoit/downloads/ и скачайте AutoIt- Self Extracting Archive.
7) Распакуйте данный архив в папку C:\PortableApps\AutoIt.
8) Зайдите на сайт: http://upx.sourceforge.net/#downloadupx и скачайте архив с Ultimate Packer for eXecutables (UPX) для Win32/i386.
9) Скопируйте файл upx.exe из данного архива в папку C:\PortableApps\PortableAppCreator\App\Portable App Creator с заменой имеющегося.
10) Откройте папку C:\PortableApps\PortableAppCreator и запустите файл Portable App Creator.exe.
11) После того как необходимые файлы будут скопированы (Появится надпись: Copied the AutoIt files) нажмите кнопку Continue.
12) Выберите диск на который будет произведена установка программы, которую Вы желаете сделать Portable и нажмите кнопку Next.
13) Нажмите кнопку Browse и выберите установочный файл программы, которую Вы желаете сделать Portable и нажмите кнопку Next.

14) Нажмите кнопку Take 1st Shot или Next для создания снимка текущего состояния системы.

15) Нажмите кнопку Install Application или Next для начала установки программы.
16) Нажмите кнопку ОК в окне напоминающем, что установка должна быть произведена на диск C:\.
17) Установите программу в директорию C:\AppNamePortable\App в соответствии с необходимыми Вам настройками.
(Пример: C:\FoxitReaderPortable\App\Foxit Reader)

18) Нажмите кнопку Get Shortcut Info или Next.
19) Нажмите кнопку Browse рядом с Get the location of the application to run и укажите какой файл следует запускать при запуске Portable-программы.
(Пример: C:\FoxitReaderPortable\App\Foxit Reader\Foxit Reader.exe)

20) Нажмите кнопку Browse рядом с Get the location for the launcher, укажите папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable) и необходимое Вам имя файла для запускающего модуля будущей Portable-програмы.
(Пример: C:\FoxitReaderPortable\FoxitReaderPortable.exe)
21.1) Если Вы желаете использовать встроенный значок Вашей программы, то оставьте переключатель в значении Use the icon of the application to run.
21.2) Если Вы желаете использовать собственный значок, то установите переключатель в значении Use alternative icon, нажмите кнопку Browse рядом и укажите путь к значку.
22) Нажмите кнопку Next для перехода к следущему шагу.
23) Нажмите кнопку Open/Close или Next для запуска Вашей будущей Portable-программы.
24) Если необходимо, зарегистрируйте ее, настройте и установите обновления, после чего закройте.
25) Нажмите кнопку Take 2st Shot или Next для создания нового снимка текущего состояния системы.
26) Нажмите кнопку Process Shots или Next для выявления изменений между снимками. Процесс может занять продолжительное время.
Для уменьшения длительной задержки на данном шаге снимите флажок Compress the software using UPX на шаге Install application.
27) После того как название кнопки Process Shots изменится на Done нажмите кнопку Next для создания Portable-программы.
28) После окончания создания программы нажмите кнопку Done, чтобы завершить работу в программе Portable App Creator и закрыть ее.

29) Если Вы желаете указать какие параметры необходимо добавить в реестр при запуске Portable-программы, то откройте папку C:\AppNamePortable\Data (Пример: C:\FoxitReaderPortable\Data) и используя любой текстовый редактор отредактируйте содержимое файла AppNamePortable.prl (Пример: FoxitReaderPortable.prl).

Запускающий модуль для Вашей Portable-программа готов.
Теперь Вы можете либо скопировать папку C:\AppNamePortable в необходимое Вам расположение (например: флеш-диск), либо заархивировать ее в архив (лучше самораспаковывающийся), либо упаковать используя PortableApps.com Installer, как описано ниже.

30) Зайдите на сайт http://Portableapps.com/development и скачайте программу PortableApps.com Installer.
31) Установите ее в папку C:\PortableApps\PortableApps.comInstaller.
32) Скопируйте файл help.html из папки C:\PortableApps\PortableApps.comInstaller в папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable\help.html)
33) Создайте в папке C:\AppNamePortable\App папку AppInfo. (Пример: C:\FoxitReaderPortable\App\AppInfo)
34) Скопируйте из папки C:\PortableApps\PortableApps.comInstaller\App\AppInfo в папку C:\AppNamePortable\App\AppInfo основную иконку для установщика Portable-программы - appinfo.ico и дополнительные иконки - appicon_16.png, appicon_32.png, appicon_128.png.
35) Скопируйте из папки C:\PortableApps\PortableApps.comInstaller\App\default_bits в папку C:\AppNamePortable\App\AppInfo файл appinfo.ini.
36) Откройте скопированный файл appinfo.ini и добавьте в конец файла в раздел [Control] под Icons=1 параметр Start=AppNamePortable.exe

Должно получит© как в примере ниже:

37) Скопируйте папку Data со всем ее содержимым из папки C:\AppNamePortable в папку C:\AppNamePortable\App. (Пример: C:\FoxitReaderPortable\App\Data)
38) Создайте в папке C:\AppNamePortable папку Other, а в папке Other папку Source. (Пример: C:\FoxitReaderPortable\Other\Source)
39) Создайте в любом текстовом редакторе файл указанного ниже содержания и сохраните его в кодировке UTF-8 с именем PortableApps.comInstallerCustom.nsh в папке C:\AppNamePortable\Other\Source.

40) Откройте папку C:\PortableApps\PortableApps.comInstaller и запустите файл PortableApps.comInstaller.exe.
41) Нажмите кнопку Next в программе для перехода к следущему шагу.
42) Укажите папку C:\AppNamePortable (Пример: C:\FoxitReaderPortable) и нажмите кнопку Go.
42.1) Флажок Interactive Mode оставьте установленным.
43) В окне Enter the Portable app's name введите имя для Portable-программы (Пример: Foxit Reader Portable) и нажмите ОК.
44) В окне Enter the Portable app's App ID нажмите ОК.
45) В окне Enter the publisher укажите свое имя или никнэйм и нажмите ОК.
46) В окне Enter the Portable app's homepage укажите либо адрес своего сайта, либо адрес сайта издателя программы, либо просто введите portableapps.com и нажмите ОК.
47) В окне Enter the app's category укажите к какой категории относится Ваша программа и нажмите ОК. (Пример: Office)
48) В окне Enter the app's description введите описание программы и нажмите ОК.
48.1) Можете взять его из пункта Описание файла на вкладке Подробно в Свойствах exe-файла Вашей программы. (Пример: Best PDF Reader for Everyday Use!)
49) В окне Enter the Portable app's language введите Multilingual и нажмите ОК.

50) В следующих четырех окнах связанных с лицензией нажмите Да.

51) В окне Enter the Portable app's display version укажите полный номер версии программы и нажмите ОК. (Пример: 5.3.0.0423)
52) В окне Enter the Portable app's package version снова укажите полный номер версии программы и нажмите ОК. (Пример: 5.3.0.0423)

53) Нажмите кнопку Finish произойдет создание инсталлятора Вашей Portable-программы.
54) В последнем окне нажмите кнопку Finish, чтобы выйти из программы или установите флажок Test Installer и нажмите кнопку Finish, чтобы протестировать работу Вашей Portable-программы.
55) Ваша готовая Portable-программа упакованная в PAF-инсталлятор будет находится в корне диска C:\.

Перейти к началу раздела Портабелизация.


7. Создание Portable-версии приложения в программе P-Apps.

Для создания Portable-версии приложения в программе P-Apps сделате следующее.

1) Зайдите на сайт http://Portable-app.com/Downloads.aspx
2) Введите название компании и Ваш e-mail, на который Вам пришлют ссылку.
3) Используя полученную в e-mail ссылку, скачайте и запустите скаченный файл.
4) Программа распакует себя рядом в папку с именем, идентичным имени установочного файла и автоматически запустит©.
5) Нажмите кнопку PreScan для создания снимка текущего состояния системы.

6) Нажмите кнопку Next в программе для перехода к следущему шагу.
7) На шаге с надписью Install Your Application сверните программу P-Apps и установите в систему программу которую Вы желаете сделать Portable.

8) После завершения процесса установки запустите Вашу программу, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
9) Разверните программу P-Apps и нажмите кнопку Next в программе для создания нового снимка системы.
Процесс создания нового снимка и сравнения с предыдущим может занять некоторое время.
10) На шаге с надписью Post Scan Completed нажмите кнопку Next для перехода к следущему шагу.

11) На шаге с надписью Launch File укажите какой файл следует запускать при запуске Portable-программы и нажмите кнопку Next.

12) На шаге с надписью Choose the system modes выберите режим изолированности Portable-программы от реальной системы и нажмите кнопку Next:

Low Secured - Portable-программа сможет сохранять данные и файлы в реальной операционной системе в любые месторасположения, за исключением системных папок.
При попытке доступа к ним, данные будут записаны в виртуальную систему. Medium Secured - Portable-программа сможет сохранять данные и файлы, только на Рабочий стол и в пользовательскую папку Мои Документы.
При попытке доступа в другие месторасположения, данные будут записаны в виртуальную систему. High Secured - Portable-программа будет полностью изолирована от реальной системы. любые данные и файлы будут записаны в виртуальную систему.

Изменение режима изолированности Portable-программы может сказаться на времени ее запуска и скорости работы.

13) Укажите, куда следует сохранить готовую Portable-программу и нажмите кнопку Finish.

Перейти к началу раздела Портабелизация.


8. Создание Portable-версии приложения в программе Evalaze.

Для создания Portable-версии приложения в программе Evalaze сделате следующее.

1) Скачайте и запустите программу Evalaze.
2) Нажмите кнопку Start Wizard в окне Welcome to Evalaze или кнопку Wizard в главном окне программы.

3) В появившемся окне нажмите кнопку Next для продолжения.
4) В разделе Application Name введите название для будущей Portable-программы.
5) Выберите папку, куда будут сохранены файлы найденные после сканирования изменений.
6) Нажмите кнопку Select Scan Range и укажите область сканирования (Папки и диски в файловой системе, разделы реестра).

7) Нажмите кнопку Next для создания снимка текущего состояния Вашей системы.
8) Нажмите кнопку Select Setup и выберите установочный файл программы, которую Вы желаете сделать Portable. Начнется обычная установка программы.

9) По завершении процесса установки запустите Вашу программу, если необходимо, зарегистрируйте, настройте и установите обновления, после чего закройте.
10) Нажмите кнопку Next в программе Evalaze для перехода к следущему шагу.
11) Нажмите кнопку Next для создания нового снимка текущего состояния Вашей системы.
12) Выберите exe-файл для запуска и нажмите кнопку Next.

13) В ниспадающем списке выберите, где будет располагаться папка с файлами, необходимыми для запуска Portable-программы (папка "песочницы").

Same path as the application - в той же папке, где будет находит© exe-файл Portable-программы.
The users Applicationdata-folder - в папке C:\Users\UserName\AppData\Roaming
Temp directory - во временной папке Вашего профиля C:\Users\UserName\AppData\Local
Static path - принудительно указанной Вами папке.

14) В случае необходимости установите флажки:

Make Application Portable - создает полностью изолированную Portable-программу. (Папка "песочницы" не создается.)
Delete Sandbox After Exit - удалять папку с файлами, необходимыми для запуска Portable-программы после выхода из приложения.

15) Укажите какие данные будут на всплывающем окне при запуске программы или отключите его убрав флажок Show Splash Screen.

16) Нажмите кнопку Next в программе для перехода к следущему шагу.
17) В разделе Output location укажите папку, где будет сохранено готовая Portable-программа.
18) Если у Вас версия программы Professional, то оставьте флажок Save Project установленным и укажите папку, где будет сохранен проект программы Evalaze.
Это позволит Вам в будущем собрать Вашу Portable-программу с модифицированным набором данных.

19) Нажмите кнопку Next в программе для перехода к созданию готового exe-файла Вашей программы.
20) Portable-программа создана. Нажмите Exit, чтобы выйти из программы Evalaze.

Если у Вас версия программы Professional, то для пересборки Portable-программы с другим набором включенных в нее данных:

21) Перезапустите программу Evalaze.
22) Выберите в списке Recent Projects Ваш проект.
23) Перейдите на вкладку Filesystem и выберите файлы необходимые для добавления в Portable-программу.
24) Перейдите на вкладку Registry и выберите разделы и параметры реестра, необходимые для добавления в Portable-программу.
25) Перейдите обратно на вкладку Virtual Application и нажмите на значек Create Application.
26) Укажите месторасположение для сохранения готовой Portable-программы.

Перейти к началу раздела Портабелизация.


9. Создание Portable-версии приложения в программе Enigma Virtual Box.

Для создания Portable-версии приложения в программе Enigma Virtual Box сделате следующее.

1) Зайдите на сайт: http://enigmaprotector.com/ru/aboutvb.html
2) Скачайте и установите последнюю версию Enigma Virtual Box.
3) Установите программу, которую Вы желаете сделать Portable.
4) Запустите ее, если необходимо, зарегистрируйте и настройте, после чего закройте.
5) Запустите программу Enigma Virtual Box, выберите в меню Language пункт Russian и нажмите ОК.
6) Закройте программу и запустите снова.
7) Нажмите кнопку Открыть рядом с полем Введите имя исходного файла.
8) Выберите exe-файл который запускает программу, которую Вы желаете сделать Portable.
9) Выберите имя и месторасположение будущего exe-файла Portable-программы.
10) Откройте в Проводнике папку C:\Program Files.
11) Перетащите папку в которую установилась программа (Пример: папку Foxit Software) в окно Enigma Virtual Box.
12) Переключитесь обратно в программу Enigma Virtual Box.

13) В диалоговом окне выберите из ниспадающего меню пункт %Program Files FOLDER% и нажмите кнопку Принять.
14) Идентичным способом Вы можете добавить другие папки, связанные с Вашей программой.

Переменная (значение в дереве программы) | Соответствие расположению в реальной системе
%DEFAULT FOLDER% | Папка в которую установлена программа. (Выберите, если программа не установлена в папку C:\Program Files)
%Program Files FOLDER% | C:\Program Files
%Program Files, Common FOLDER% | C:\Program Files\Common Files
%AllUsers, ApplicationData FOLDER% | C:\ProgramData
%AllUsers, Documents FOLDER% | C:\Users\Public\Documents
%Local, ApplicationData FOLDER% | C:\Users\UserName\AppData\Local
%History FOLDER% | C:\Users\UserName\AppData\Local\Microsoft\Windows\History
%Internet Cache FOLDER% | C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files
%Temp FOLDER% | C:\Users\UserName\AppData\Local\Temp
%ApplicationData FOLDER% | C:\Users\UserName\AppData\Roaming
%Cookies FOLDER% | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Cookies
%My Documents FOLDER% | C:\Users\UserName\Documents
%My Pictures FOLDER% | C:\Users\UserName\Pictures
%WINDOWS FOLDER% | C:\Windows
%SYSTEM FOLDER% | C:\Windows\System32
Переменная (значение в дереве программы) | Соответствие расположению в реальной системе

15) Если Вам неоходимо уменьшить размер будущей Portable-программы, то на вкладке Файлы нажмите на кнопку Опции для файлов.
16) Установите флажок Сжать файлы и нажмите на кнопку Принять. (Процес сжатия может занять продолжительное время.)
17) Если Вам необходимо добавить записи реестра, то перейдите на вкладку Реестр и нажмите на кнопку Опции для реестра.
18) Установите флажок Включить виртуализацию реестра и нажмите на кнопку Принять.
19) Используя меню вызываемое правой кнопкой мыши, вручную создайте необходимые Вам ключи и параметры.
20) Нажмите кнопку Обработать, чтобы начать ее создание.
21) В открывшемся окне Прогресс... нажмите кнопку Запустить.
22) Установите программу в соответствии с необходимыми Вам настройками.
23) В окне Прогресс... нажмите кнопку Закрыть.

Перейти к началу раздела Портабелизация.


10. Создание Portable-версии приложения, используя Universal Extractor и WinRAR.

Для создания Portable-версии приложения, используя Universal Extractor и WinRAR сделате следующее.

1) Скачайте и установите Universal Extractor и WinRAR.
2) Нажмите правой кнопкой мыши на установочном файле Вашей программы и выберите пункт Извлечь с помощью UniExtract.

Содержимое установочного файла будет распаковано рядом с ним, в папку с идентичным названием (Пример: C:\Portable\FoxitReader530.0423_enu_Setup).
3) Откройте данную папку, а в ней откройте папку {app} (Пример: C:\Portable\FoxitReader530.0423_enu_Setup\{app}).
4) Найдите в данной папке exe-файл запускающий программу (Пример: Foxit Reader.exe).
Запустите его, чтобы убедит©, что программа запускается нормально, после чего закройте.
5) Выделите все файлы в папке {app}, щелкните на выделенном правой кнопкой мыши и выберите пункт Добавить в архив.

6) В открывшемся диалоговом окне задайте имя для будущей Portable-версии программы.
7) Установите флажок Создать SFX-архив.
8) В ниспадающем списке Метод сжатия выберите значение Максимальный.

9) Перейдите на вкладку Дополнительно и нажмите кнопку Параметры SFX.

10) В открывшемся окне перейдите на вкладку Установка и в поле Выполнить введите имя exe-файла запускающего программу (Пример: Foxit Reader.exe).

11) Перейдите на вкладку Режимы, установите флажок Распаковать во временную папку и переключатель в значение Скрыть всё.

12) Перейдите на вкладку Обновление и установите нижний переключатель в значение Перезаписывать все файлы без запроса.

13) Если Вы желаете задать значек (ico-файл) для будущей Portable-программы, то перейдите на вкладку Текст и графика и укажите путь к нему в поле Загрузить значок SFX из файла. (В моем примере значек был заранее извлечен программой Restorator из самого Foxit Reader.exe)

14) Нажмите кнопку ОК для подтвержения внесенных настроек.
15) Нажмите кнопку ОК для создания Вашей Portable-программы.

Готовый exe-файл появится в папке {app} (Пример: C:\Portable\FoxitReader530.0423_enu_Setup\{app}).

Перейти к началу раздела Портабелизация.


11. Создание Portable-версии приложения, используя Universal Extractor, UPX и Bat_To_Exe_Converter.

Для создания Portable-версии приложения, используя Universal Extractor, Ultimate Packer for eXecutables (UPX) и Bat_To_Exe_Converter сделате следующее.

1) Скачайте и установите Universal Extractor.
2) Нажмите правой кнопкой мыши на установочном файле Вашей программы и выберите пункт Извлечь с помощью UniExtract.
Содержимое установочного файла будет распаковано рядом с ним, в папку с идентичным названием (Пример: C:\Portable\FoxitReader530.0423_enu_Setup).
3) Откройте данную папку, а в ней откройте папку {app} (Пример: C:\Portable\FoxitReader530.0423_enu_Setup\{app}).
4) Найдите в данной папке exe-файл запускающий программу (Пример: Foxit Reader.exe).
Запустите его, чтобы убедит©, что программа запускается нормально, после чего закройте.
5) Зайдите на сайт: http://upx.sourceforge.net/#downloadupx и скачайте архив с Ultimate Packer for eXecutables (UPX) для Win32/i386.
6) Скопируйте файл upx.exe из данного архива в папку {app} (Пример: C:\Portable\FoxitReader530.0423_enu_Setup\{app}\upx.exe).
7) Удерживая нажатой клавишу ⇑ Shift, щелкните правой кнопкой мыши на папку {app} и выберите пункт Открыть окно команд.
8) Введите указанную ниже команду и нажмите Enter ↵ :

9) Дождитесь окончания сжатия dll и exe-файлов (Данный процесс может занять продолжительное время).
10) После завершения сжатия всех файлов удалите файл upx.exe.
12) В строке поиска меню Пуск введите notepad и нажмите Enter ↵.
13) Введите имя exe-файла запускающего программу. Имя файла содержащее пробелы должно быть указано в кавычках (Пример: "Foxit Reader.exe").
14) Нажмите Ctrl + S, установите тип файла в значение Все файлы (*.*).
15) В поле Имя файла укажите месторасположение и название Вашего bat-файла и нажмите кнопку Сохранить (Пример: C:\Install\FoxitReader530.0423_enu_Setup\{app}\Start.bat).

16) Запустите данный файл, чтобы убедит©, что программа запускается нормально.
17) Скачайте программу Bat_To_Exe_Converter.
18) Распакуйте архив, в зависимости от разрядности Вашей операционной системы откройте папку Windows (32 bit) или Windows (64 bit) и запустите файл Bat_To_Exe_Converter.exe.
19) В поле Batch file укажите путь к Вашему bat-файлу (Пример: C:\Install\FoxitReader530.0423_enu_Setup\{app}\Start.bat).
20) В поле Save as укажите путь для exe-файла будущей Portable-программы (Пример: C:\Install\FoxitReaderPortable.exe).
21) На вкладке Options утановите переключатели в значения:

Invisible application
Temporary directory
Delete at exit

21) Установите флажки Add administrator manifest и Overwrite existing files.

22) Перейдите на вкладку Include и нажмите кнопку Add.

23) Добавьте все файлы, которые необходимы для запуска Вашей программы.
Внимание: Программа Bat_To_Exe_Converter добавляет все файлы из подпапок в одну папку. Программы, которые используют для работы файлы из подпапок работать не будут.
24) Если у Вас есть ico-файл, то Вы можете добавить его как иконку для Portable-программы на вкладке Versioninformations.
25) Нажмите кнопку Compile для создания Вашей Portable-программы.

Перейти к началу раздела Портабелизация.


1. Сравнение версий Windows 7.

Доступные возможности | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Корпоратив | Максимальная
Условия продажи | Продажа только по OEM-лицензиям | Продажа в розницу и по OEM-лицензиям (только на развивающихся рынках, включая российский) | Продажа в розницу и по OEM-лицензиям | Продажа в розницу, по OEM и корпоративным лицензиям | Продажа только под корпоративными лицензиями | Продажа в розницу и по OEM-лицензиям
Окончание поддержки | 14.01.2020 | 14.01.2020 | 14.01.2020 | 14.01.2020 | 14.01.2020 | 14.01.2020
Наличие 64-битной версии | Нет | Да | Да | Да | Да | Да
Максимальный размер оперативной памяти (для 64-битных версий) | 2 Гб (для 32-битной версии) | 8 Гб | 16 Гб | 128 Гб | 128 Гб | 128 Гб
Центр восстановления Windows | Нет поддержки домена | Нет поддержки домена | Нет поддержки домена | Да | Да | Да
Функция «Домашняя группа» (создание и присоединение к группе) | Только присоединение | Только присоединение | Да | Да | Да | Да
Интерфейс Windows Aero | Нет | Только базовая тема оформления | Да | Да | Да | Да
Поддержка нескольких мониторов | Нет | Да | Да | Да | Да | Да
Быстрое переключение между пользователями | Нет | Да | Да | Да | Да | Да
Возможность смены фонового рисунка рабочего стола | Нет | Да | Да | Да | Да | Да
Диспетчер рабочего стола | Нет | Да | Да | Да | Да | Да
Центр мобильности Windows | Нет | Да | Да | Да | Да | Да
Multitouch и улучшенное распознавание рукописного ввода | Нет | Нет | Да | Да | Да | Да
Windows Media Center | Нет | Нет | Да | Да | Да | Да
Дополнительные игры | Нет | Нет | Да | Отключены по умолчанию | Отключены по умолчанию | Да
Эмулятор Windows XP(Windows XP Mode) | Нет | Нет | Нет | Да | Да | Да
EFS (система шифрования данных) | Нет | Нет | Нет | Да | Да | Да
Печать с учетом информации о местоположении | Нет | Нет | Нет | Да | Да | Да
Возможность выступать в качестве хост-компьютера Удаленного рабочего стола | Нет | Нет | Нет | Да | Да | Да
Подключение к домену | Нет | Нет | Нет | Да | Да | Да
Возможность даунгрейда до Vista или XP | Нет | Нет | Нет | Да | Да | Да
Поддержка нескольких процессоров | Нет | Нет | Нет | Да | Да | Да
AppLocker | Нет | Нет | Нет | Нет | Да | Да
BitLocker и BitLocker To Go | Нет | Нет | Нет | Нет | Да | Да
Branch Cache | Нет | Нет | Нет | Нет | Да | Да
DirectAccess | Нет | Нет | Нет | Нет | Да | Да
Подсистема для запуска Unix-приложений | Нет | Нет | Нет | Нет | Да | Да
Мультиязычная пользовательская среда | Нет | Нет | Нет | Нет | Да | Да
Загрузка с VHD (файла-образа Microsoft Virtual PC) | Нет | Нет | Нет | Нет | Да | Да
Запуск оснастки lusrmgr.msc (Local Users and Groups) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки gpedit.msc (Local Group Policy Editor) | Нет | Нет | Нет | Да | Да | Да
Запуск оснастки secpol.msc (Local Security Policy) | Нет | Нет | Нет | Да | Да | Да
Доступные возможности | Начальная | Домашняя базовая | Домашняя расширенная | Профессиональная | Корпоратив | Максимальная

Windows Aero — анимация окон при открытии, закрытии, сворачивании, восстановления окна, делающая работу с операционной системой более понятной. Прозрачные элементы окон с размывкой заднего плана позволяют пользователю сконцентрироваться только на содержимом активного окна. Компоненты Windows Aero:

Aero Glass — прозрачные (с размывкой заднего плана) заголовки и панели в окнах.
Windows Flip — новый вид меню Alt + Tab ↹, в котором показываются эскизы открытых окон и их значки.
Windows Flip 3D — замена Alt + Tab ↹, вызываемая сочетанием Win   + Tab ↹, теперь все окна выстраиваются в ряд в 3D. При помощи стрелок клавиатуры или колесика мышки можно прокручивать окна.
Aero Shake — позволяет свернуть все неактивные приложения движением мыши. Для ее активации достаточно захватить заголовок окна и немного «потрясти».
Aero Peek — позволяет отображать уменьшенные копии окон при наведении мыши на значок панели задач, переключаться между окнами приложения простым кликом по значку, перетаскивать и фиксировать на панели задач различные окна и приложения, просматривать рабочий стол одним наведением в специальную область экрана и многое другое.
Aero Snap — позволяет движением мыши разворачивать окно на полэкрана, весь экран или только по вертикальной оси.

Диспетчер рабочего стола (англ. Desktop Window Manager, DWM), ранее Desktop Compositing Engine, DCE — система графического интерфейса рабочего стола в Windows Vista и Windows 7, который используется в графическом интерфейсе Windows Aero.

Центр мобильности Windows — объединяет настройки мобильного ПК в одном месте для обеспечения быстрого доступа к ним. Из одного и того же местоположения можно выполнять различные операции, например регулировать громкость мобильного ПК, проверять состояние беспроводного сетевого подключения или настраивать яркость дисплея.

Мультитач (англ. multitouch или multi-touch) — технология, по которой сенсорный экран или тачпад отслеживает одновременно несколько точек нажатия. Например, сближая пальцы рук, можно уменьшить картинку на дисплее, а раздвигая — увеличить. Кроме того, мультитач-экраны позволяют работать с устройством одновременно нескольким пользователям.

Windows Media Center (кодовое имя Freestyle) является приложением для проигрывания мультимедиаконтента (музыки, изображений и потокового телевидения) на домашнем медиацентре.

Encrypting File System (EFS) — система шифрования данных, реализующая шифрование на уровне файлов. Данная система предоставляет возможность «прозрачного шифрования» данных, хранящихся на разделах с файловой системой NTFS для защиты потенциально конфиденциальных данных от несанкционированного доступа при физическом доступе к компьютеру и дискам.

Домен Windows — группа компьютеров одной сети, имеющих единый центр (который называется контроллером домена), использующий единую базу пользователей (то есть учётные записи находятся не на каждом в отдельности компьютере, а на контроллере домена, т.н. сетевой вход в систему), единую групповую и локальную политики, единые параметры безопасности (применимо к томам с файловой системой NTFS), ограничение времени работы учётной записи и прочие параметры, значительно упрощающие работу системного администратора организации, если в ней эксплуатируется большое число компьютеров.

AppLocker — расширенная версия политик ограниченного использования программ. Позволяет разрешать или запрещать запуск программ при определенных условиях. Например, "Разрешить запуск Adobe Acrobat версии выше 7.0".

BitLocker и BitLocker To Go — позволяет защитить все данные, от документов до паролей, путем шифрования всего диска, на котором хранятся системные файлы Windows и данные пользователей. BitLocker используется для встроенных дисков, BitLocker To Go - для съемных запоминающих устройств, таких как внешние жесткие диски и USB-устройства флэш-памяти.

BranchCache — это технология кэширования на ресурсах локальной сети данных, расположенных на удаленных серверах. Если пользователю в локальной сети потребуется файл, который уже был загружен кем-то из пользователей его сети, — он сможет получить его из локального кэш-хранилища, а не использовать канал с ограниченной пропускной способностью.

DirectAccess — обеспечивает доступ пользователей к корпоративной сети при наличии выхода в Интернет. В отличие от большинства традиционных VPN соединений, которые должны быть запущены и прерваны явно действиями пользователя, подключения DirectAccess создаются автоматически компьютером, на котором работает пользователь.

Подсистема для UNIX-приложений — представляет собой многопользовательскую среду UNIX, которая предоставляет инструментарий и библиотеки API переноса приложений для работы на компьютерах под управлением операционной системы Windows.

Загрузка с VHD-файла — использование для загрузки операционной системы Windows - VHD-файла, содержащего в себе виртуальную операционную систему имеющую полную структуру и содержание сходные с жестким диском.

Мультиязычная пользовательская среда (MUI) — Выбор нужного языка интерфейса и возможность переключения между 35 доступными языками.

Перейти к началу раздела Разное.


2. Открытие файлов справки с расширением .hlp.

Начиная с Windows Vista, компания Майкрософт отменила поддержку открытия данного типа файлов, с использованием системной программы WinHlp32.exe.
Для открытия данного типа файлов установите обновление Windows6.1-KB917607-x86.msu или Windows6.1-KB917607-x64.msu, в зависимости от разрядности.
Официальная ссылка: здесь
Альтернатив ссылка KB917607_WinHlp32.zip

Перейти к началу раздела Разное.


3. Список программ Windows, запускаемых в диалоговом окне Выполнить.

Диалоговое окно Выполнить используется в Windows для открытия программы, папки или документа.
Диалоговое окно Выполнить запускается либо Пуск → Выполнить, либо нажатием комбинации клавиш Win   + R на клавиатуре.
Самые известные команды выполняемые в окне Выполнить это cmd (Командная строка) и regedit (Редактор реестра).
Зная точное названия команды Вы можете запустить любое системное приложения или оснастку Windows.
Чтобы запускать какое-либо приложение в данном диалоговом окне с правами администратора - у Вас должен быть отключен контроль учетных записей.

Для выполнения команды введите её название и нажмите Enter ↵.

Русское название элемента | Английское название элемента | Команда
Ftp-протокол (командная строка) | Ftp-protocol (command prompt) | ftp
Iexpress Wizard (не переведена) | Iexpress Wizard | iexpress
Internet Explorer | Internet Explorer | iexplore
Paint | Paint | mspaint
Wordpad | Wordpad | write
Администратор источников данных ODBC | ODBC Data Source Administrator | odbcad32
Администрирование | Administrative Tools | control admintools
Архивация и восстановление | Backup and Restore | sdclt
Блокнот | Notepad | notepad
Брандмауэр Windows | Windows Firewall | firewall.cpl
Брандмауэр Windows в режиме повышенной безопасности | Windows Firewall with Advanced Security | WF.msc
Визуальные эффекты | Visual Effects | SystemPropertiesPerformance
Включение и отключение компонентов Windows | Turn Windows features on or off | OptionalFeatures.exe
Восстановление системы | System Restore | rstrui
Выйти из системы | Log Out Of Windows | logoff
Дата и Время | Date and Time | timedate.cpl
Дефрагментация диска | Disk Defragmenter | dfrgui
Диспетчер авторизации | Authorization Manager | azman.msc
Диспетчер задач Windows | Windows Task Manager | taskmgr
Диспетчер проверки драйверов | Driver Verifier Manager | verifier
Диспетчер устройств | Device Manager | devmgmt.msc
Диспетчер устройств | Device Manager | hdwwiz.cpl
Дополнительные часы | Additional Clocks | control timedate.cpl,,1
Завершение работы Windows | Shuts Down Windows | shutdown /s
Записки | Sticky Note | StikyNot
Защита БД учетных записей Windows | Securing the Windows Account Database | syskey
Звук | Sound | mmsys.cpl
Звуки (звуковая схема) | Sounds (sound theme) | control mmsys.cpl,,2
Звукозапись | Sound Recorder | soundrecorder
Игровые устройства | Game Controllers | joy.cpl
Инициализация оборудования безопасности яў TPM | Initialize the TMP security hardware | TpmInit
Калибровка цветов экрана | Display Color Calibration | dccw
Калькулятор | Calculator | calc
Командная строка | Command Prompt | cmd
Компоненты Windows | Windows Features | OptionalFeatures
Консоль управления(MMC) | Microsoft Management Console | mmc
Конфигурация системы | System Configuration | msconfig
Локальная политика безопасности | Local Security Policy | secpol.msc
Локальные пользователи и группы | Local Users and Groups | lusrmgr.msc
Мастер загрузки изображений Windows | Windows Picture Acquisition Wizard | wiaacmgr
Мастер создания общих ресурсов | Create A Shared Folder Wizard | shrpubw
Мастер установки драйверов устройств | Driver Package Installer | dpinst
Мастер установки оборудования | Add Hardware Wizard | hdwwiz
Микшер громкости | Sound Volume | sndvol
Монитор ресурсов | Resource Monitor | perfmon.exe /res
Монитор ресурсов | Resource Monitor | resmon
Настройка доступа программ и умолчаний | Set Program Access and Computer Defaults | control appwiz.cpl,,3
Настройка Контроля Учетных Записей | User Account Control Settings | UserAccountControlSettings
Ножницы | Snipping Tool | snippingtool
Общие папки | Shared Folders | fsmgmt.msc
Очистка диска | Disk Cleanup Utility | cleanmgr
Панель математического ввода | Math Input Panel | mip
Панель управления | Control Panel | control
Папка "Fonts" | Fonts Folder | fonts
Папка "Загрузки" | "Downloads" Folder | Downloads
Параметры папок | Folder Options | control folders
Перезагрузка | Restart Windows | shutdown /r
Перенос принтеров | Printer Migration | PrintBrmUi
Перо и сенсорные устройства | Pen and Touch | TabletPC.cpl
Персонализация | Personalization | control desktop
Планировщик заданий | Task Sheduler | control schedtasks
Планировщик заданий | Task Sheduler | taskschd.msc
Подключение к удаленному рабочему столу | Remote Desktop Connection | mstsc
Подключение к сетевому проектору | Connect to a Network Projector | NetProj
Подключить к проектору | Connect to a Projector | displayswitch
Получение программ | Get Programs | control appwiz.cpl,,1
Приступая к работе | Getting Started | RunDLL32 oobefldr.dll,ShowWelcomeCenter
Проверка диска | Check Disk Utility | chkdsk
Проверка и восстановление системных файлов | System File Checker (Scan and Repair) | sfc /scannow
Проверка подписи файла | File Signature Verification | sigverif
Проводник | Windows Explorer | explorer
Проводник: C:\ | Windows Explorer: C:\ | \
Проводник: С:\Users\Ваше_имя | Windows Explorer: С:\Users\Your_name | .
Проводник: С:\Users\ | Windows Explorer: С:\Users\ | ..
Программа DiskPart | Disk Partition Manager | diskpart
Программы и компоненты | Programs and Features | appwiz.cpl
Просмотр событий | Event Viewer | eventvwr.msc
Разрешение экрана | Screen Resolution | desk.cpl
Редактор личных знаков | Private Character Editor | eudcedit
Редактор локальной групповой политики | Local Group Policy Editor | gpedit.msc
Редактор реестра | Registry Editor | regedit
Редактор реестра | Registry Editor | regedt32
Редактор титульных страниц факсов | Fax Cover Sheet Editor | fxscover
Результирующая политика | Resultant Set of Policy | rsop.msc
Сведения о системе | System Information | msinfo32
Свойства системы | System Properties | sysdm.cpl
Свойства системы: Дополнительно | System Properties: Advanced | SystemPropertiesAdvanced
Свойства системы: Защита системы | System Properties: System Protection | SystemPropertiesProtection
Свойства системы: Оборудование | System Properties: Hardware | SystemPropertiesHardware
Свойства системы: Удаленный доступ | System Properties: Remote | SystemPropertiesRemote
Свойства: Инициатор iSCSI | iSCSI Initiator Properties | iscsicpl
Свойства: Интернет | Internet Properties | inetcpl.cpl
Свойства: Интернет: Общие | Internet Properties: General | control inetcpl.cpl,,0
Свойства: Интернет: Безопасность | Internet Properties: Security | control inetcpl.cpl,,1
Свойства: Интернет: Конфиденциальность | Internet Properties: Privacy | control inetcpl.cpl,,2
Свойства: Интернет: Содержание | Internet Properties: Content | control inetcpl.cpl,,3
Свойства: Интернет: Подключения | Internet Properties: Connections | control inetcpl.cpl,,4
Свойства: Интернет: Программы | Internet Properties: Programs | control inetcpl.cpl,,5
Свойства: Интернет: Дополнительно | Internet Properties: Advanced | control inetcpl.cpl,,6
Свойства: Клавиатура | Keyboard Properties | control keyboard
Свойства: Мышь | Mouse Properties | control mouse
Свойства: Мышь | Mouse Properties | main.cpl
Свойства: Мышь: Параметры указателя | Mouse Properties: Pointer Options | control main.cpl,,2
Свойства: Мышь: Указатели (схема) | Mouse Properties: Pointers | control main.cpl,,1
Сертификаты | Sertificates | certmgr.msc
Сетевые подключения | Network Connections | control netconnections
Сетевые подключения | Network Connections | ncpa.cpl
Системный монитор | Performance Monitor | perfmon.msc
Служба индексирования | Indexing Service | ciadv.msc
Службы | Services | services.msc
Службы компонентов | Component Services | dcomcnfg
Службы компонентов | Component Services | comexp.msc
Совместимость программы | Program Compatibility | msdt.exe -id PCWDiagnostic
Создать диск восстановления системы | Create a system repair disk | recdisc
Соседние пользователи | People Near Me | collab.cpl
Сохранение имен пользователей и паролей | Stored User Names and Passwords | credwiz
Средство диагностики DirectX | Direct X Troubleshooter | dxdiag
Средство диагностики службы технической поддержки | Microsoft Support Diagnostic Tool | msdt
Средство калибровки дигитайзера | Ditilizer Calibration Tool | tabcal
Средство настройки текста ClearType | ClearType Text Tuner | cttune
Средство переноса данных Windows | Windows Easy Transfer | migwiz
Средство проверки памяти Windows | Windows Memory Diagnostic | MdSched
Средство просмотра XPS | XPS Viewer | xpsrchvw
Стредство записи действий по воспроизведению неполадок | Problem Steps Recorder | psr
Таблица символов | Character Map | charmap
Телефон и модем | Phone and Modem | telephon.cpl
Удаленный помощник Windows | Windows Remote Assistance | msra
Управление дисками | Disk Management | diskmgmt.msc
Управление компьютером | Computer Management | compmgmt.msc
Управление компьютером | Computer Management | compmgmtlauncher
Управление печатью | Print Management | printmanagement.msc
Управление цветом | Color Management | colorcpl
Установка или удаление языков интерфейса | Install or uninstall display languages | lpksetup
Устранение неполадок | Troubleshooting | control /name Microsoft.Troubleshooting
Устройства и принтеры | Devices and Printers | control printers
Учетные записи пользователей | User Accounts | control userpasswords2
Учетные записи пользователей | User Accounts | Netplwiz
Цвет и внешний вид окна | Window Color and Appearance | control color
Центр мобильности Windows | Windows Mobility Center | mblctr
Центр обновления Windows | Windows Update | control /name Microsoft.WindowsUpdate
Центр поддержки | Action Center | wscui.cpl
Центр синхронизации | Sync Center | mobsync
Центр специальных возможностей | Ease of Access Center | utilman
Шифрующая файловая система (EFS) | Encryption File System | rekeywiz
Шрифты (добавление или удаление) | Fonts | control fonts
Экран (размер текста) | Display (size of text) | dpiscaling
Экранная клавиатура | On-Screen Keyboard | osk
Экранная лупа | Magnifier | magnify
Экранный диктор | Microsoft Narrator | narrator
Электропитание | Power Options | powercfg.cpl
Электропитание: Дополнительные параметры | Power Options: Advanced Settings | control powercfg.cpl,,1
Элемент управления WMI | Windows Management Infrastructure | wmimgmt.msc
Язык и региональные стандарты | Region and Language | intl.cpl
Язык и региональные стандарты: Дополнительно | Region and Language: Administrative | control intl.cpl,,3
Язык и региональные стандарты: Расположение | Region and Language: Location | control intl.cpl,,1
Язык и региональные стандарты: Форматы | Region and Language: Formats | control intl.cpl
Язык и региональные стандарты: Языки и клавиатуры | Region and Language: Keyboards and Languages | control intl.cpl,,2
Русское название элемента | Английское название элемента | Команда

Если какой-либо из элементов списка не запускается, то скорее всего это означает что он неустановлен. Многие из компонентов Windows можно установить в Пуск → Панель Управления → Программы и Компоненты → Включение и отключение компонентов Windows

Перейти к началу раздела Разное.


4. Список сочетаний клавиш используемых в Windows 7.

Во многих статьях Вы можете увидеть текст наподобие: Win   + R.
Данный текст обозначает, что Вам необходимо нажать на клавиатуре сочетание клавиши с логотипом Windows и буквы R.
Сочетания клавиш — это комбинации двух или более клавиш, нажав которые, можно выполнять задачи, обычно требующие применения мыши или другого указывающего устройства.
Существуют следующие наиболее часто используемые сочетания клавиш.

Сочетания клавиш для работы с текстом.

Клавиши | Действие
Ctrl + A | Выделить весь текст.
Ctrl + C (или Ctrl + Insert) | Копировать выделенный фрагмент текста.
Ctrl + X | Вырезать выделенный фрагмент текста.
Ctrl + V (или ⇑ Shift + Insert) | Вставить выделенный фрагмент текста.
Ctrl + ← | Переместить курсор в начало предыдущего слова.
Ctrl + → | Переместить курсор в начало следующего слова.
Ctrl + ↑ | Переместить курсор в начало предыдущего абзаца.
Ctrl + ↓ | Переместить курсор в начало следующего абзаца.
⇑ Shift + → | Выделить текст вперед посимвольно.
⇑ Shift + ← | Выделить текст назад посимвольно.
Ctrl + ⇑ Shift + → | Выделить текст от положения курсора до начало следующего слова.
Ctrl + ⇑ Shift + ← | Выделить текст от положения курсора до начало предыдущего слова.
⇑ Shift + Home | Выделить текст от положения курсора до начала строки.
⇑ Shift + End | Выделить текст от положения курсора до окончания строки.
Alt слева + ⇑ Shift | Переключить язык ввода, если используется несколько языков ввода.
Ctrl + ⇑ Shift | Переключить раскладку клавиатуры, если используется несколько раскладок клавиатуры.
Ctrl слева + ⇑ Shift Ctrl справа + ⇑ Shift | Изменение направления чтения текста для языков с письмом справа налево.

Сочетания клавиш для работы с окнами и рабочим столом.

Клавиши | Действие
F5 (или Ctrl + R) | Обновление активного окна или рабочего стола (если активен).
F6 или Tab ↹ | Циклическое переключение между элементами в окне или на рабочем столе.
Alt + Esc | Циклическое переключение между элементами в том порядке, в котором они были открыты.
Alt + Tab ↹ | Циклическое переключение между окнами в обычном режиме.
Ctrl + Alt + Tab ↹ | Открыть окно для переключения между окнами в обычном режиме. Для перехода между ними используйте клавиши со стрелками.
Win + Tab ↹ | Циклическое переключение между элементами (окнами, программами) в режиме Flip3D.
Ctrl + Win + Tab ↹ | Открыть окно для переключения между окнами в режиме Flip3D. Для перехода между ними используйте клавиши со стрелками.
Ctrl + колесо мыши (вверх\вниз) на рабочем столе | Увеличить / Уменьшить размер значков на Рабочем столе.
Удерживая ⇑ Shift + ↑ | Выделение вверх нескольких элементов в окне или на рабочем столе, включая текущий.
Удерживая ⇑ Shift + ↓ | Выделение вниз нескольких элементов в окне или на рабочем столе, включая текущий.
Удерживая Ctrl + Пробел | Выделение любых нескольких отдельных элементов в окне или на рабочем столе. Для перехода ипользовать клавиши стрелок.
Ctrl + A | Выделить все элементы в окне или на рабочем столе.
Ctrl + C (или Ctrl + Insert) | Копирование выделенных элементов.
Ctrl + X | Вырезание выделенных элементов.
Ctrl + V (или ⇑ Shift + Insert) | Вставка выделенных элементов.
Alt + Enter ↵ | Открытие диалогового окна свойств для выбранного файла, папки.
Alt + Пробел | Отображение контекстного меню активного окна.
Alt + F4 | Закрытие текущего элемента или выход из активной программы.
⇑ Shift + F10 | Открытие контекстного меню для выделенного элемента.
Win + ↑ | Развернуть окно на весь экран.
Win + ⇑ Shift + ↑ | Растянуть окно до верхней и нижней части экрана.
Win + ↓ | Свернуть в окно, либо свернуть на панель задач.
Win + ← | Развернуть и прикрепить окно к левому краю экрана.
Win + → | Развернуть и прикрепить окно к правому краю экрана.
Win + M | Свернуть все сворачиваемые окна. Несворачиваемые окна (Например: Свойства файла) останутся на экране.
Win + ⇑ Shift + M | Восстановить все свернутые окна.
Win + D | Показать рабочий стол / Вернуться в программу. Сворачивает и восстанавливает всё, включая несворачиваемые окна.
Win + G | Циклическое переключение между гаджетами.
Win + Home | Свернуть / Восстановить все окна, кроме активного.
Win + Пробел | Показать рабочий стол без сворачивания окон.

Сочетания клавиш для работы с несколькими мониторами.

Клавиши | Действие
Win + ⇑ Shift + ← | Переключит© на левый монитор.
Win + ⇑ Shift + → | Переключит© на правый монитор.
Win + ⇑ Shift + ← | Перемещение окна на левый монитор.
Win + ⇑ Shift + → | Перемещение окна на правый монитор.
Win + P | Выбор режима отображения презентации.

Сочетания клавиш для работы с Панелью задач.

Клавиши | Действие
⇑ Shift + щелчок по значку на панели задач | Открытие программы или быстрое открытие другого экземпляра программы.
⇑ Shift + щелчок правой кнопкой мыши по значку на панели задач | Отображение окна меню для программы.
⇑ Shift + щелчок правой кнопкой мыши по сгруппированному значку на панели задач | Отображение окна меню для группы.
Ctrl + щелчок по сгруппированному значку на панели задач | Циклическое переключение между окнами группы.
Ctrl + ⇑ Shift + щелчок по значку на панели задач | Открытие программы от имени администратора.
Ctrl + Tab ↹ | Переключение между эскизами в одной группе.
Win + Цифра | Запустить / Переключит© в программу, используя расположение ее значка на панели задач. Цифры от 1 до 9 – это порядковый номер приложения на панели задач, считая слева (0 – десятое приложение).
⇑ Shift + Win + Цифра | Запуск нового экземпляра программы, используя расположение ее значка на панели задач.
Ctrl + Win + Цифра | Переключение между окнами программы, начиная с последнего активного, используя расположение ее значка на панели задач.
Alt + Win + Цифра | Открытие списка переходов для программы, используя расположение ее значка на панели задач.
Win + T | Циклическое переключение между значками на панели задач. (Слева направо)
Win + ⇑ Shift + T | Циклическое переключение между значками на панели задач. (Справа налево)
Ctrl + Win + B | Переключение на программу, отображающую сообщение в области уведомлений.
Win (или Ctrl + Esc) | Открытие или закрытие меню «Пуск».
Win + R | Открытие диалогового окна «Выполнить».
Ctrl + ⇑ Shift + Enter ↵ | Запуск выделенной в меню Пуск программы от имени администратора.

Сочетания клавиш для работы в Проводнике Windows.

Клавиши | Действие
Win   + E | Запустить Проводник Windows.
Alt + ← Просмотр предыдущей папки.
Alt + → Просмотр следующей папки.
Alt + ↑ Просмотр папки, расположенной на уровень выше.
Alt + D | Выбор адресной строки.
Alt + P | Отображение области просмотра.
Ctrl + E | Выбор поля поиска.
Ctrl + ⇑ Shift + E | Отображение всех папок, в которые вложена выделенная папка.
Ctrl + F | Выбор поля поиска.
Ctrl + N | Открытие нового окна.
Ctrl + ⇑ Shift + N | Создание новой папки.
Ctrl + W | Закрытие текущего окна.
Ctrl + . | Поворот изображения по часовой стрелке.
Ctrl + , | Поворот изображения против часовой стрелки.
Ctrl + колесо прокрутки мыши | Изменение размера и внешнего вида значков файлов и папок.
Home | Переход к верхней позиции активного окна.
End | Переход к нижней позиции активного окна.
Delete
(или Ctrl + D) 		Удаление выделенного элемента в «Корзину».
⇑ Shift + Delete | Удаление выделенного элемента без помещения его в «Корзину».
F2 | Переименование выделенного элемента.
F4 | Отображение списка предыдущих расположений для адресной строки в проводнике Windows.
F11 | Разворачивание активного окна на весь экран / Сворачивание обратно.
← Свертывание выделенного элемента (если он развернут) или выбор родительской папки.
→ Отображение выделенного элемента (если он свернут) или выделение первой подпапки.
⟵ Backspace | Просмотр предыдущей папки.
Num
Lock + * на цифровой дополнительной клавиатуре 		Отображение всех папок, вложенных в выделенную папку.
Num
Lock + + на цифровой дополнительной клавиатуре 		Отображение содержимого выделенной папки.
Num
Lock + — на цифровой дополнительной клавиатуре 		Свертывание выделенной папки.

Сочетания клавиш для диалогового окна.

Клавиши | Действие
F4 | Отображение элементов активного списка.
⟵ Backspace | Открытие папки на один уровень выше от папки, выделенной в окне «Сохранить как» или «Открыть».
Tab ↹ | Переход вперед по параметрам.
⇑ Shift + Tab ↹ | Переход назад по параметрам.
Ctrl + Tab ↹ | Переход вперед по вкладкам.
Ctrl + ⇑ Shift + Tab ↹ | Переход назад по вкладкам.
Alt + подчеркнутая буква | Выполнение команды (или выбор параметра), которая начинается с этой буквы.
Пробел, удерживая Ctrl или ⇑ Shift | Установка или снятие флажка, если он активен.
↑, ↓, ←, → | Выбор кнопки, если активна группа кнопок.

Сочетания клавиш для работы со справкой Windows.

Клавиши | Действие
F1 | Открытие справки текущего элемента.
Win + F1 | Запустить встроенный диалог Windows: Справка и Поддержка.
F3 | Перемещение курсора в поле «Поиск».
F10 | Переход к меню «Параметры».
Alt + A | Переход на страницу поддержки пользователей.
Alt + C | Отображать оглавление.
Alt + N | Переход к меню «Параметры подключения».
Alt + ← | Возврат к предыдущему просмотренному разделу.
Alt + → | Переход к следующему (ранее просмотренному) разделу.
Alt + Home | Переход на домашнюю страницу справки и поддержки.
Home | Переход в начало раздела.
End | Переход в конец раздела.
Ctrl + F | Поиск в текущем разделе.
Ctrl + P | Вывод раздела на печать.

Сочетания клавиш для работы с Центром специальных возможностей.

Клавиши | Действие
Win   + U | Запустить Центр специальных возможностей.
Num
Lock (удерживать более пяти секунд) 		Включить / Отключить режим озвучивания при нажатии клавиш Caps Lock, Num
Lock и Scroll
Lock .
⇑ Shift (нажать пять раз) | Включить / Отключить режим залипания клавиш (позволяет использовать клавиши ⇑ Shift, Ctrl, Alt, Win   нажимая их по отдельности).
⇑ Shift справа (удерживать более восьми секунд) | Включить / Отключить фильтрацию ввода (позволяет игнорировать краткие и повторные нажатия клавиш).
Alt слева + ⇑ Shift слева + PrtScr (или Print
Screen) 		Включить / Отключить режим высокой контрастности.
Alt слева + ⇑ Shift слева + Num
Lock (или Num) 		Включить / Отключить управление указателем мыши с клавиатуры.

Сочетания клавиш для работы с программой "Экранная лупа".

Клавиши | Действие
Win + + | Запуск программы "Экранная лупа". Увеличить масштаб.
Win + — | Уменьшить масштаб.
Win + Esс | Закрытие программы "Экранная лупа".
Ctrl + Alt + D | Переключение в режим «Закреплено» (увеличенная область показывается в отдельном закрепленном окне).
Ctrl + Alt + F | Переключение в режим «Во весь экран» (увеличивается весь экран).
Ctrl + Alt + L | Переключение в режим «Увеличение» (увеличивается область вокруг указателя мыши).
Ctrl + Alt + R | Изменение размера окна, отображающего увеличенную область экрана.
Ctrl + Alt + Пробел | Предварительный просмотр рабочего стола в полноэкранном режиме.
Ctrl + Alt + I | Инверсия цветов.
Ctrl + Alt + ↑ | Прикрепление окна с увеличенной областью к верхнему краю экрана. («Закреплено») Передвижение окна с увеличенной областью вверх. («Увеличение») Передвижение по увеличенной области вверх. («Во весь экран»)
Ctrl + Alt + ↓ | Прикрепление окна с увеличенной областью к нижнему краю экрана. («Закреплено») Передвижение окна с увеличенной областью вниз. («Увеличение») Передвижение по увеличенной области вниз. («Во весь экран»)
Ctrl + Alt + ← | Прикрепление окна с увеличенной областью к левому краю экрана. («Закреплено») Передвижение окна с увеличенной областью влево. («Увеличение») Передвижение по увеличенной области влево. («Во весь экран»)
Ctrl + Alt + → | Прикрепление окна с увеличенной областью к правому краю экрана. («Закреплено») Передвижение окна с увеличенной областью вправо. («Увеличение») Передвижение по увеличенной области вправо. («Во весь экран»)

Остальные сочетания клавиш.

Клавиши | Действие
Enter ↵ | Заменяет щелчки мышью для запуска приложения, нажатия на кнопку или выбора пункта в меню.
Esc | Идентично нажатию кнопки Отмена в диалоговом окне.
F3
(или Win   + F) 		Открытие встроенного диалогового окна Windows для поиска файла или папки.
Ctrl + F | Открытие окна поиска или переход в поле поиска в активном окне.
Ctrl + Win   + F | Поиск по компьютеру из домена (при нахождении в сети).
Ctrl + ⇑ Shift + Esc | Запуск Диспетчера задач.
Ctrl + Alt + Delete | Вызов окна Безопасность Windows (Включает кнопки Блокировать компьютер, Сменить пользователя, Выйти из системы, Сменить пароль, Запустить диспетчер задач).
Win   + L | Блокирование компьютера или переключение пользователей.
Win   + X | Запустить Центр мобильности Windows.
Win   + Pause
Break 		Запустить элемент Система из Панели Управления (пункт Свойства при нажатии правой кнопкой мыши на Компьютер в меню Пуск).
Удерживая ⇑ Shift при вставке компакт-диска | Предотвращение автоматического воспроизведения компакт-диска.
Ctrl + Tab ↹ | Переключение между элементами (вкладками, окнами, документами) в программах, допускающих одновременное открытие нескольких документов.
Ctrl + F4 | Закрытие активного документа (в программах, допускающих одновременное открытие нескольких документов).
Alt + Enter ↵ | Развернуть активную программу на полный экран / Свернуть в окно.
Alt + подчеркнутая буква Отображение соответствующего меню.
Выполнение команды меню (или другой подчеркнутой команды).
F10 | Активизация строки меню текущей программы.
← Открытие следующего меню слева или закрытие подменю.
→ Открытие следующего меню справа или открытие подменю.
Ctrl + N | Создать...
Ctrl + O | Открыть...
Ctrl + S | Сохранить сделанные изменения.
Ctrl + Z | Отмена действия.
Ctrl + Y
Ctrl + ⇑ Shift + Z 		Повтор действия.

Перейти к началу раздела Разное.


5. Перезагрузка компьютера в безопасный режим без использования клавиатуры (клавиши F8) при загрузке.

Для того, чтобы перезагрузит© в Безопасный режим достаточно во время загрузки нажать клавишуF8 и выбрать пункт Safe Mode. А чтобы вернуться обратно в Нормальный режим достаточно всего лишь перезагрузить компьютер (не нажимаяF8) и система вернется в своё стандартное состояние.
Но на некоторых материнских платах клавишаF8 используется для выбора физического устройства, с которого должен начать загрузку компьютер.
В этом случае необходимо выбрать жесткий диск, на котором установлена операционная система. После нажатия клавиши Enter ↵ необходимо сразу же снова нажимать клавишуF8 до тех пор, пока на экране не появится меню выбора вариантов загрузки ОС Windows. Вы должны успеть сделать это довольно быстро, а иначе начнется обычная загрузка Windows.
Если же нет желания играть на скорость, есть более легкий вариант решения:

1) Откройте Конфигурация системы (Пуск → Выполнить → msconfig → ОК или Win   + R → msconfig → ОК)
2) Перейдите на вкладку Загрузка
3) Поставьте галочку напротив значения Безопасный режим в разделе Параметры загрузки
4) Нажмите ОК и перезагрузите компьютер.
5) Чтобы вернуться обратно в Нормальный режим: находясь в Безопасном режиме уберите данную галочку и перезагрузите компьютер.

Перейти к началу раздела Разное.


 6. Определение букв назначенных дискам в среде восстановления или среде предустановки.

6. Определение букв назначенных дискам в среде восстановления или среде предустановки.

Загрузившись в среду восстановления или в среду предустановки Windows, Вы можете столкнуться с необходимостью определения буквы диска.
Например, чтобы запустить приложения с флэш-диска или проверить диск на наличие ошибок.

Виртуальному диску создаваемому в среде восстановления или среде предустановки всегда соответствует буква Х:, а для определения букв остальных дисков Вы можете выбрать одно из предложенных решений.

Вариант 1. По размеру и типу диска.

1) Перейдите в папку X:\Sources; для этого в командной строке введите указанную ниже команду и нажмите Enter ↵:

2) Запустите Блокнот (Notepad); для этого в командной строке введите указанную ниже команду и нажмите Enter ↵:

3) В главном меню блокнота выберите Файл → Открыть (или нажмите сочетание клавиш Ctrl + O)
4) Щелкните на значок Компьютер в области переходов слева

Примечание: Для лучшего отображения содержимого папки Компьютер, дважды щелкните по заголовку окна, чтобы его развернуть.

Вариант 2. По содержимому папки.

Также Вы можете определить буквы дисков напрямую из командной строки.

1) Переходите с диска на диск вводя его букву и нажимая Enter ↵. Например:

Если Вам необходимо перейти к предполагаемой папке на диске, то переключайтесь используя команду:

Например:

2) Для отображения содержимого диска(папки) вводите команду:

Перейти к началу раздела Разное.


7. Автоматическое переключение русской и английской раскладок клавиатуры.

Часто бывает, что напечатав какой-то текст, Вы поднимаете глаза на монитор и вместо слова "Программа" видите слово "Ghjuhfvvf".

Для того чтобы сохранить Ваше терпение и нервы, существуют две замечательные программы:

Punto Switcher(если вы в основном работаете с русской или английской клавиатурой)
Key Switcher(если вы работаете с несколькими европейскими языками).

Данные программы предназначены для автоматического переключения между различными раскладками клавиатуры в операционных системах семейства Microsoft Windows.
Основное назначение данных программ — увеличение продуктивности и удобства при работе с компьютером.
Работая в фоновом режиме, они проводят статистический анализ последовательностей вводимых символов слова, и, если сочетание букв оказывается нетипичным для языка, на котором вводятся символы, то переключают язык ввода, заменяя текст исправленным.
Каждая из программ является отдельным законченным продуктом и не требует запуска другой.

Перейти к началу раздела Разное.


8. Удаление Windows 7 без форматирования раздела и без потери данных.

Для удаления Windows 7 описанным здесь способом вам потребуются:

а) MSDaRT (ранее ERD Commander);
б) Установочный диск Windows 7;

Шаг I. Удаление загрузочной информации Windows 7.

1) Загрузитесь в MSDaRT и вставьте установочный диск Windows 7 в свой DVD-привод.
2) Запустите Command Prompt
3) В открывшемся окне введите команду

Где, E: - Буква вашего DVD-привода, а C: - Буква вашего жесткого диска, с которого удаляется Windows 7

Шаг II. Удаление файлов и папок Windows 7.

1) Запустите Micosoft Diagnostics and Recovery Toolset → Explorer
2) Как в обычном Проводнике, тем же способом удалите следующие папки:
  • PerfLogs
  • Users
  • Windows
  • Recycle.Bin
  • Documents and Settings
  • ProgramData
  • Recovery

Перейти к началу раздела Разное.


9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы).

Если Вам необходимо:

1) Получить полный доступ к системным файлам и папкам.
2) Получить доступ к системному реестру и настройкам системы.
3) Восстановить неработающую Windows или отдельно какой-либо из ее компонентов.

то воспользуйтесь загрузочным образом с набором средств диагностики и восстановления - Microsoft Diagnostics and Recovery Toolset (MSDaRT).

Вы можете создать образ MSDaRT самостоятельно, на основе имеющегося у вас дистрибутива Windows, или же скачать уже готовый образ, созданный мною.
Создавать образ MSDaRT для Windows 7 и запускать его необходимо с учетом разрядности Вашей операционной системы.

Готовые ISO-образы Microsoft Diagnostics and Recovery Toolset (MSDaRT) для Windows 7 со встроенными Debuggers And Tools:

DART70X86RUS_Disk.zip - архив с самозагружаемым ISO-образом MSDaRT для 32-битной версии Windows 7.
DART70X64RUS_Disk.zip - архив с самозагружаемым ISO-образом MSDaRT для 64-битной версии Windows 7.

Создание iso-образа диска MSDaRT:

1) Вставьте установочный DVD-диск Windows 7 или подключите установочный флеш-накопитель (флешку) или смонтируйте iso-образ дистрибутива Windows 7 в виртуальный дисковод (Alcohol 120%, Daemon Tools, UltraISO), соответствующий разрядности Windows в которой Вы будете создавать образ.
2) В зависимости от разрядности Вашей Windows скачайте и установите мастер создания образа MSDaRT: DaRT70x86.zip - для 32-бит или DaRT70x64.zip - для 64-бит.
3) Скачайте и установите Debuggers And Tools: DebuggersAndTools-x86.zip - для 32-бит или DebuggersAndTools-x64.zip - для 64-бит.
4) Скопируйте файл dbghelp.dll из папки Win7_dbghelp в папку C:\Program Files\Windows Kits\8.1\Debuggers\x86 - для 32-бит или в папку C:\Program Files\Windows Kits\8.1\Debuggers\x64 - для 64-бит.
5) Запустите Пуск → Все программы → Microsoft DaRT 7 → Образ для восстановления DaRT
6) На вкладке "Выбор образа загрузки" укажите диск с Windows 7.

7) Щелкните ОК, затем несколько раз кнопку Далее.
8) На вкладке "Выбор программных средств" нажмите кнопку Далее.
9) На вкладке "Удаленные подключения" установите флажок Разрешить удаленные подключения и нажмите кнопку Далее.
10) На вкладке "Анализатор сбоев" установите переключатель в значение "Использовать средства отладки яў Windows из следующей папки."
Укажите папку C:\Program Files\Windows Kits\8.1\Debuggers\x86 - для 32-бит или папку C:\Program Files\Windows Kits\8.1\Debuggers\x64 - для 64-бит и нажмите кнопку Далее.

11) На вкладке "Загрузка определения автономного средства проверки системы" установите переключатель в значение "Нет, загрузить определения вручную позднее" и нажмите кнопку Далее.
12) На вкладке "Дополнительные драйверы" добавьте драйвера в образ, которые автоматически не определяются Windows (если они у Вас есть) и нажмите кнопку Далее.

13) На вкладке "Дополнительные файлы" нажмите кнопку Показать файлы и скопируйте в открывшуюся папку все необходимые Вам файлы, которые Вам могут понадобит© в MSDaRT.
Закройте Проводник и нажмите в мастере создания образа MSDaRT кнопку Далее.

14) На вкладке "Создание образа загрузки" укажите местоположение для сохранения iso-файла созданного образа и нажмите кнопку Далее. По умолчанию образ создается на Рабочем столе.
15) Установите или снимите флажок "Записать образ с помощью следующего устройства записи CD/DVD-дисков" в зависимости от устройства на которе Вы собираетесь записать и нажмите кнопку Далее.

15.1) Для записи на DVD-диск, вставьте чистый диск в DVD-дисковод и оставьте флажок установленным.
15.2) Для дальнейшей записи на USB флеш-накопитель (флешку) - снимите флажок.
16) В последнем окне нажмите кнопку Готово.

Запись iso-образа MSDaRT на USB флеш-накопитель (флешку).

Данное действие проще всего совершить с помощью программы UltraISO.
1) Открываете образ в UltraISO.
2) В главном меню выбираете Самозагрузка → Записать образ жесткого диска...
3) Нажимаете кнопку Записать

Начало работы с загрузочным носителем (DVD, флеш-диск) MSDaRT.

1) Вставьте загрузочный DVD-диск или подключите флеш-диск с MSDaRT и перезагрузите компьютер.
2) Нажмите клавишу для вызова меню загрузки (Boot menu, BBS Popup). В зависимости от производитЈ она может быть F8, F11 или F12.
3) Выберите необходимый Вам диск и нажмите Enter ↵.
4) В окне "Инициализировать подключение к сети в фоновом режиме?" (Would you like to initialize network connectivity in the background?) нажмите кнопку Да (Yes), если собираетесь восстанавливать настройки сети (Интернет или Локальной), в остальных случаях нажмите кнопку Нет (No).
5) В окне "Переназначить буквы дисков таким образом, чтобы они соответствовали буквам дисков целевой операционной системы?" (Would you like to remap the drive letters to match the mappings from the target operating system?) нажмите кнопку Да (Yes), чтобы в MSDaRT для обозначения дисков использовались те же буквы, что и в системе с которой Вы будете работать, в остальных случаях нажмите кнопку Нет (No).
6) В окне Выберите метод ввода с клавиатуры (Select a keyboard input method) из ниспадающего списка выберите раскладку клавиатуры и нажмите кнопку Далее (Next).
7) В окне для выбора операционной системы для восстановления установите переключатель в значение "Используйте средства восстановления, позволяющие устранить проблемы при запуске Windows." (Use recovery tools that can help fix problems starting Windows.)
7.1) Для работы с программами, восстанавливающими Windows выберите в списке Вашу операционную систему.
7.2) Для работы с системными файлами и папками (удаление, переименование или их замена) уберите в списке выделение с какой-либо системы.
Для этого установите переключатель в значение "Восстановление компьютера с помошью созданного ранее образа системы." (Restore your computer using a system image that you created earlier), а затем снова выберите пункт "Используйте средства восстановления, позволяющие устранить проблемы при запуске Windows." (Use recovery tools that can help fix problems starting Windows.) или же просто щелкните мышью в свободное пространство под списком операционных систем.
8) Нажмите кнопку Далее (Next).
Примечание: Чтобы запустить Проводник (Windows Explorer), выберите в списке пункт "Microsoft® Diagnostic and Recovery Toolset". В открывшемся окне будет необходимый Вам пункт.

Перейти к началу раздела Разное.


10. Активация Windows 7 по телефону, используя лицензионный ключ.

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵
2) Установите Ваш ключ системы. Введите указанные ниже команды и нажмите Enter ↵.

где, вместо крестиков укажите Ваш лицензионный ключ продукта.

3) Выберите страну в которую Вы будете звонить для активации продукта и нажмите кнопку Далее.
4) Позвоните по бесплатному номеру (в некоторые страны можно бесплатно позвонить через программу Skype) .
5) Робот начнет перечислять варианты активации.
6) Нажмите на телефоне 1 (Активировать продукт Майкрософт).
7) На вопрос на скольких компьютерах установлен продукт, нажмите 1.
8) Когда вас попросят ввести код, введите. В ответ робот продиктует 8 блоков по 6 цифр (каждый блок дважды для проверки).
9) Внесите цифры в окно активации.
10) Нажмите Далее. Интернет, может быть отключен (без разницы).
Windows 7 активирована.

Перейти к началу раздела Разное.


11. Быстрое переключение с одного монитора на другой или с монитора на проектор.

Если у Вас к компьютеру подключено несколько мониторов, либо кроме монитора подключен также и проектор, то для быстрого переключения между ними Вы можете воспользоваться указанными ниже сочетаниями клавиш.

Клавиши | Действие
Win + ⇑ Shift + ← | Переключит© на левый монитор.
Win + ⇑ Shift + → | Переключит© на правый монитор.
Win + ⇑ Shift + ← | Перемещение окна на левый монитор.
Win + ⇑ Shift + → | Перемещение окна на правый монитор.
Win + P | Выбор режима отображения презентации.

Вы также можете запустить DisplaySwitch.exe и выбрать предпочитаемый дисплей.
Вызов данной утилиты не будет иметь результатов, если к компьютеру подключен только один монитор.

Перейти к началу раздела Разное.


12. Где можно скачать справочник от Microsoft, содержащий полное описание утилит командной строки?

Вы можете скачать справочник от Microsoft (на английском языке), содержащий полное описание утилит командной строки.

1) Перейдите по ссылке http://www.microsoft.com/en-us/download/details.aspx?id=2632
2) Нажмите Download.

Перейти к началу раздела Разное.


13. Уточнение времени работы компьютера с момента последней загрузки.

Вариант 1.

Если Вам необходимо узнать сколько времени работает Ваш компьютер с момента последней загрузки, то Вы можете создать скрипт-файл и запускать его при необходимости.

1) Скопируйте указанный выше код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs в любой папке (Например, на диске C:)
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "crp.vbs")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы узнать сколько времени работает компьютер, просто запустите созданный Вами скрипт, как обычную программу.

Вариант 2.

Скачайте и установите специальный гаджет SystemUptime.

systemuptime.zip

Перейти к началу раздела Разное.


14. Автоматическая очистка временных папок при выходе из Windows.

Чтобы не чистить вручную временные папки: C:\Users\Administrator\AppData\Local\Temp или C:\Users\YourNickname\AppData\Local\Temp и C:\Windows\Temp, Вы можете автоматизировать данный процесс при выходе из системы.

1) Создайте командный файл сценария:

Инструкция:

1. Скопируйте код в любой текстовый редактор (например, Блокнот).
2. Нажмите Ctrl + S и сохраните файл с любым именем и расширением .cmd
3. Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "tempdirclean.cmd")
4. Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Скопируйте его для удобства в корневую папку диска С:
3) Запустите Редактор локальной групповой политики: Пуск → Выполнить → gpedit.msc или Win   + R → gpedit.msc
4) Откройте ветвь Конфигурация пользователя → Конфигурация Windows → Сценарии (вход/выход из системы).
5) В правой части два раза кликните по параметру Выход из системы или нажмите правую кнопку мыши и выберите пункт Свойства.
6) Нажмите кнопку Добавить, укажите месторасположение созданного Вами командного файла c:\tempdirclean.cmd
7) Нажмите ОК, затем снова ОК.
Теперь при выходе из системы, а также при завершении работы временные папки очистятся автоматически.

Внимание: Если по указанной выше схеме Вы добавите командный файл сценария в свойства параметра Выход из системы, находящийся в ветке Конфигурация компьютера → Конфигурация Windows → Сценарии (запуск/завершение), то пользовательская временная папка очищена не будет, а очистится только временная папка самой Windows.

Готовый CMD-файл Вы можете скачать по ссылке: tempdirclean.zip

Перейти к началу раздела Разное.


15. Отключение Центра отправки Microsoft Office.

Чтобы отключить Центр отправки (Upload Center) Microsoft Office, выполните указанные ниже рекомендации.

Вариант 1.

1) Запустите Диспетчер задач: Ctrl + ⇑ Shift + Esc
2) Завершите все процессы связанные с Microsoft Office, включая MSOUC.exe и MSOSYNC.exe
3) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4) Введите указанную ниже команду и нажмите Enter ↵. После выполнения команды перезагрузите компьютер.

Где, вместо GUID введите идентификатор для Вашей редакции Microsoft Office.

32-битные версии:

{90150000-0011-0000-0000-0000000FF1CE} = Microsoft Office Professional Plus 2013 / Microsoft Office Профессиональный Плюс 2013
{90150000-0012-0000-0000-0000000FF1CE} = Microsoft Office Standard 2013 / Microsoft Office Стандартный 2013
{90150000-0013-0000-0000-0000000FF1CE} = Microsoft Office Home and Business 2013 / Microsoft Office Для Дома и Бизнеса 2013
{90150000-002F-0000-0000-0000000FF1CE} = Microsoft Office Home and Student 2013 / Microsoft Office Для Дома и Учебы 2013

64-битные версии:

{90150000-0011-0000-1000-0000000FF1CE} = Microsoft Office Professional Plus 2013 / Microsoft Office Профессиональный Плюс 2013
{90150000-0012-0000-1000-0000000FF1CE} = Microsoft Office Standard 2013 / Microsoft Office Стандартный 2013
{90150000-0013-0000-1000-0000000FF1CE} = Microsoft Office Home and Business 2013 / Microsoft Office Для Дома и Бизнеса 2013
{90150000-002F-0000-1000-0000000FF1CE} = Microsoft Office Home and Student 2013 / Microsoft Office Для Дома и Учебы 2013

Например:

Для 32-битной версии Microsoft Office для дома и учебы 2013:

Для 64-битной версии Microsoft Office Professional Plus 2013:

Если Вы не знаете какая у Вас версия или редакция Microsoft Office, то 1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
А если 32-бит версия Microsoft Office установлена на 64-битную Windows, то HKEY_LOCAL_MACHINE \Software\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall
3) Найдите идентификатор GUID, наподобие упомянутого ранее, указывающий на версию и редакцию Microsoft Office.

Более подробное описание схемы нумерации для идентификаторов GUID кода продукта:

Для Office 2010: http://support.microsoft.com/kb/2186281/ru-ru
Для Office 2013: http://support.microsoft.com/kb/2786054/ru-ru

Вариант 2.

1) Скачайте и запустите программу Sysinternals AutoRuns (английская версия или русская версия)
2) Удалите все записи, которые содержат слова SYNC и путь к которым начинается "C:\Program Files\Microsoft Office"
3) Перезагрузите компьютер.

Вариант 3.

1) Запустите Диспетчер задач: Ctrl + ⇑ Shift + Esc
2) Завершите все процессы связанные с Microsoft Office, включая MSOUC.exe и MSOSYNC.exe
3) Запустите редактор реестра (Win   + R → regedit → ОК)
4) Найдите и удалите все значения MSOSYNC
5) Откройте меню Пуск → Панель управления → Администрирование → Планировщик заданий
6) Щелкните правой кнопкой мыши на задачу "Microsoft Office 15 Sync Maintenance for..."
7) В контекстном меню нажмите Отключить (Disable)
8) Перезагрузите компьютер.

Перейти к началу раздела Разное.


16. Извлечение MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

16. Извлечение загрузочного MS-DOS образа из файла diskcopy.dll и дальнейшая работа с ним.

Многие используя в Windows функцию Форматировать, замечали пункт Создание загрузочного диска MS-DOS. Он используется для создания загрузочного диска MS-DOS на определенных типах устройств, для других же типов устройств он заблокирован.
Выясняя откуда Windows берет образ MS-DOS для записи, я узнал что он содержится в файле diskcopy.dll. Но тут появился другой вопрос, а как его оттуда извлечь? Предлагаю Вам несколько способов его извлечения.

Способ 1 Использование редакторов ресурсов.

Открываете файл diskcopy.dll любым редактором ресурсов и извлекаете(сохраняете) ресурс 1 из папки BINFILE как diskcopy.img

Способ 2 Программа Disk Extract

1) Указываете в поле File(s) to search and extract byte sequence (wildcards *.* accepted) - файл для поиска и извлечения необходимого количества байтов: C:\Windows\System32\diskcopy.dll
2) Указываете в поле Byte sequence to find - с какого байта искать: EB3C90
3) Указываете в поле Bytes to copy - сколько байт скопировать: 1474560
4) Указываете в поле Save as - куда и под каким именем сохранить (например так): D:\Temp\diskcopy\diskcopy.img
5) Нажимаете на кнопку Play
6) В появившемся окне Confirm нажимаете Yes

Способ 3 Программа GETBTDSK со скриптом

Запускаете файл GETBTDSK.bat и получаете в итоге готовый файл diskcopy.img
Некоторые антивирусные программы могут воспринять попытку её обращения к системному файлу как разновидность вируса, поэтому для работы скрипта либо изолируйте файл GETBTDSK.EXE, или папку где он находится из поиска антивирусной программой, либо воспользуйтесь первым способом.

Хорошо, образ мы извлекли и у нас есть готовый файл diskcopy.img. Что же дальше, спросите Вы. А дальше, Вы можете:

1) Распаковать полученный файл с помощью программы архиватора 7zip и дальше работать с файлами по-своему усмотрению.

2) Записать загрузочный MS-DOS образ diskcopy.img на USB флеш-накопитель (флешку).

1. Открываете файл diskcopy.img в программе UltraISO
2. Выбираете Самозагрузка → Записать образ жесткого диска...
3. Метод записи оставляете USB-HDD+
4. Нажимаете Записать

Чтобы не искать в интернете эти программы, Вы можете скачать архив с ними: msdosboot.zip

Перейти к началу раздела Разное.


17. Термины и сокращения используемые Microsoft для маркировки своих продуктов.

Скачивая какой-либо продукт Microsoft в интернете, помимо его названия Вы можете увидеть дополнительные обозначения в наименовании. Если Вам интересно, что означает "CTP", "Escrow", "LDR", "RC", "RTM" и тому подобное - предлагаю Вам, расшифровку особо часто встречающихся из них.

BBT - Basic Block Tools или Binary Profile Feedback Optimization framework
BBT - пакет инструментов оптимизации, помогающий уменьшить требования к рабочему набору Win32 приложения. Для этого примҐется дополнительный статический анализ и эвристика кода. Также в результате мониторинга потока выполнения программы происходит интеграция профиля данных. Для дополнительной компрессии страниц памяти, BBT реорганизовывает статистические данные и секции ресурсов.
BBT - специальный анализатор, оптимизирующий величину кода, путем игнорирования не используемой части, и архивации оставшейся.
Другое значение BBT - это “Black Box Testing”, тестирование "чёрного ящика" или что-то в этом духе.

BVT - Build Verification Test
Небольшой набор тестов, проверяющих уровень качества сборки, на этапе её создания. Например, BVT для Блокнота может выглядеть как: "Запустить, напечатать текст, сохранить, выйти". Если сборка не проходит данный тест, то во избежание дальнейших ошибок при тестировании, она отправляется на доработку. Порядок действий BVT редко меняется, а результаты - тщательно контролируются.

CPP - Customer Preview Program
Программа предварительного ознакомления.

CTP - Community Technology Preview
Предварительный технологический релиз для сообщества, впервые использован для сборки Vista build 5219, так называемый январский CTP.

DNSRV - .NET (DotNet) Server
Раннее кодовое имя Windows Server 2003.

EBS - Essential Business Server
Серверное решение от Microsoft, имеет в своей основе ядро Windows Small Business Server 2008, ориентировано на рынок среднего бизнеса.

EDW - External Developer Workstation
Этот термин, использовался во времена разработки Windows Vista, для обозначения сборок выпущенных между RC и RTM сборками.

Escrow
Сборки, не имеющие серьёзных ошибок. Они, как правило, становятся в итоге Релиз-кандидатами или RTM (после того, как сборка подписана к выпуску).

Exit Criteria
Набор тестов, проверяющих наиболее важные аспекты корректной работы основных функций приложения. Как выглядит тот или иной тест, определяется командой-разработчиком функции, результаты прохождения теста должны точно совпадать с ожидаемыми. Полное прохождение таких тестов ознаменует переход к следующему этапу разработки.

FBL - Feature build lab
Группа разработки какого-либо функционала.

FVT - Feature Verification Tests
Тоже самое, что и BVT, только для конкретной функции.

GA - General Availability
Означает, что програмное обеспечение доступно на основном рынке через Интернет или на каком-либо физическом носителе.

GDR - General Distribution Release
Используется для обновлений и хотфиксов, содержащих только заплатки критических ошибок и исправления, влияющие на стабильность.

HSBS - Home and Small Business Server

IDS - Internal Developer Server

IDW - Internal Developer Workstation

IDX - Internal Developer Client/Server

LCTP - Limited Community Technology Preview
Ограниченный предварительный технологический релиз.

LDR - Limited Distribution Release
Используется для обновлений и хотфиксов, содержащих “прочие” исправления, как правило, для ошибок, возникающих у весьма специфической группы пользователей.

MMS - Mid-Market Server
Раннее название Essential Business Server.

QFE - Quick Fix Engineering
Аналогично LDR.

QHSV - Q Home Server
Раннее название Windows Home Server.

RC - Release Candidate
Качество сборки на данной стадии разработки наиболее близко к стабильному, критические ошибки уже исправлены, однако, в ходе текущего тестирования могут быть найдены новые ошибки.

RDP - Rapid Deployment Program

RTM - Release To Manufacturing
Стабильная сборка, прошедшая все стадии тестирования, в которой исправлены все найденные ошибки, и готовая к применению.

RTW - Release To Web
Это RTM, предназначенный для распространения через Интернет.

SBS - Small Business Server

Self host
Сброки, прошедшие тесты Exit Criteria tests, готовые к более глубокому тестированию.

Self test
Сборки, прошедшие BVT и FVT тесты.

Self toast
Сборки, не прошедшие BVT.
Sign-off
Подписание, означает, что функция/продукт готова к продаже.

TAP - Technology Adoption Program
Программа технологического утверждения, в ходе которого собираются отзывы тестеров, в качестве которых могут выступать и заказчики компании.

TP - Technical Preview

VBL - Virtual Build Lab
Термин обозначает группу разработчиков объединенных в виртуальную лабораторию.

WHS - Windows Home Server

WSSG - Windows Server Solutions Group

WSUS - Windows Server Update Services

Перейти к началу раздела Разное.


18. Удаление установленного обновления.

Если Вы установили обновление в Windows, для добавления дополнительной функции, а оно Вам не понравилось, то Вы можете спокойно его удалить.
Для удаления любого обновления сделайте следующее:

1) Откройте Панель управления\Программы
2) Нажмите на ссылку Просмотр установленных обновлений
3) Нажмите правой кнопкой на любом обновлении, которое желаете удалить и щелкните на появившемся слове Удалить.
4) В случае необходимости, перезагрузите компьютер.

Перейти к началу раздела Разное.


19. Создание значков управления состоянием компьютера.

Для быстрого изменения состояния системы Вы можете создать на рабочем столе ярлыки позволяющие изменить его одним нажатием мыши.

Для создания ярлыков выполните следующие действия:
1) Нажмите правую клавишу мыши на рабочем столе, выберите пункт меню Создать → Ярлык
2) В поле Укажите расположение объекта введите необходимую команду для создания ярлыка и нажмите OK.

Блокировка компьютера

Выход из системы

Завершение работы

Перезагрузка

Сон

Вы также можете скачать архив SystemModesShortcuts.zip с уже готовыми данными ярлыками.

Если Вы желаете добавить указанные ярлыки в виде каскадного меню в контекстное меню рабочего стола, то скачайте и примените reg-файл Add_Power_to_Desktop_Context_Menu.reg из архива PowerMenuDesktop.zip.

Перейти к началу раздела Разное.


20. Копирование текста из окон сообщений и всплывающих оповещений в буфер обмена.

Текст из окна сообщения Windows выделить для копирования невозможно, так как он заблокирован. Но Вы можете скопировать данный текст в буфер обмена.
Для того чтобы это нажмите комбинацию клавиш Ctrl + C, а затем вставьте текст из буфера в любой текстовый редактор используя комбинацию клавиш Ctrl + V. Окно, текст которого нужно скопировать, должно быть активным.
Например, попробуйте закрыть окно оснастки Службы при открытом окне свойств отдельной службы, и Вы увидите одно из таких сообщений Windows.

Перейти к началу раздела Разное.


21. Удаление данных без возможности восстановления.

При удалении файла или папки, не происходит полного физического удаления информации, очищается лишь только «оглавление» файловой системы. С помощью утилиты cipher возможно частичное решение этой проблемы, так как существует возможность выполнить очистку свободного места на диске затиранием её.
Место, занимаемое содержимым папки, будет перезаписано нулями, потом единицами, а после этого - набором случайных символов в каждом секторе.

Для полного удаления данных:

1) Удалите необходимые файлы или папки из Вашего каталога, которые должны быть затерты.
2) Запустите командную строку с правами администратора
2.1) Нажмите кнопку Пуск
2.2) В строке поиска введите cmd
2.3) Щелкните на найденной программе правой кнопкой мыши и выберите Запуск от имени администратора
3) В командной строке введите:

каталог - путь к любой папке на разделе подлежащим очистке. (Например: cipher /w:c:\temp) Если Вы удалили папку или файл из корня диска, то Вы можете указать в качестве пути только букву диска. (Например: cipher /w:c:\)

Перейти к началу раздела Разное.


22. Выполнение дефрагментации дисков в Windows 7 используя командную строку.

В Windows существует программа Дефрагментация диска. Данная программа производит упорядочение фрагментированной информации для более эффективной работы дисков и дисководов. Программа дефрагментации диска работает по заданному расписанию, но можно запускать анализ и дефрагментацию дисков вручную. В программе Вы можете увидеть время прошлого запуска, уровень фрагментированности дисков и запланированное время следующего запуска.
Если Вы не отключали планировщик заданий, значение уровня фрагментированности дисков будет равно 0%, а при нажатии кнопки Анализировать диск система покажет уровень фрагментированности не более 10%. При желании Вы можете запустить дефрагментацию вручную нажав кнопку Дефрагментация диска или настроить запуск по расписанию, в удобное для Вас время.

Графический интерфейс программы Вы можете запустить: Пуск → Все программы → Стандартные → Служебные. Однако он весьма ограничен в возможностях, и их хватит начинающему или малоопытному пользователю, если же Вы продвинутый или опытный пользователь, то Вам будет интересен командный режим данной программы.

1) Нажмите кнопку Пуск и в строке поиска наберите cmd
2) Нажмите на найденной программе правой кнопкой мыши и выберите пункт Запуск от имени администратора.
3) Вы можете запустить утилиту defrag.exe используя следующие параметры командной строки:

Параметр | Описание
/A | Анализирует указанный том. Логично выполнить анализ перед ручной дефрагментацией. В результатах будет сказано, каким разделам она нужна.
/C | Выполняет операцию на всех томах. Этот параметр избавляет от необходимости перечислять все буквы разделов при анализе или дефрагментации.
/E | Выполняет операцию на всех томах, кроме указанных. Еще один параметр, экономящий время.
/H | Выполняет операцию с обычным приоритетом (по умолчанию используется низкий). Ускоряет процесс дефрагментации, но может замедлить работу других приложений, обращающихся к диску в это время.
/M | Выполняет операцию на всех томах одновременно в фоновом режиме. Стандартное поведение дефрагментатора – последовательная работа над томами.
/T | Отслеживает текущую операцию на указанном томе.
/U | Выводит прогресс текущей операции на указанном томе в процентном отношении.
/V | Выводит подробный отчет о томах, их фрагментированности, файлах и папках, а также о свободном пространстве и MFT.
/X | Объединяет свободное пространство на указанных томах.
/R | Выполняет частичную дефрагментацию (поведение по умолчанию), пытаясь объединять только фрагменты размером менее 64 Мб.
/W | Выполняет полную дефрагментацию, пытаясь объединять любые фрагменты вне зависимости от их размера.
/F | Выполняет принудительную дефрагментацию, даже если на диске недостаточно свободного пространства.

Примеры команд

Команда | Описание
defrag /A /C /U /V | Анализирует фрагментированность всех разделов, отображая ход операции, и выводит подробный отчет.
defrag C: /W /V | Выполняет полную дефрагментацию раздела C, а затем выводит подробный отчет.
defrag C: /E /H /F | Выполняет дефрагментацию всех разделов кроме C с обычным приоритетом вне зависимости от количества свободного пространства на них.

Перейти к началу раздела Разное.


23. Уменьшение размера файла изображения без потери качества.

Если у Вас хранится большое количество файлов изображений на компьютере или Вы добавляете изображения в текстовые документы или Вы размещаете их в интернете, то данный совет поможет Вам уменьшить занимаемое ими место без потери качества.

1) Скачайте и разархивируйте в любую удобную Вам папку архив PictureBeaver.zip
2) Выделите необходимый Вам файл-изображение, группу файлов или папку с изображениями
3) Перетащите выделенное на файл optimize.wsf.
4) Откроется окно командной строки (процесс действий в окне отображаться не будет), по завершении процесса оптимизации оно само закроется .
5) Результаты появятся в той же папке, где и Ваши исходные файлы изображений. Оптимизированные файлы изображений будут в папке (папках) Optimized, отчёт о сэкономленном объеме в файле Optimization Report.html

Данный скрипт для оптимизации использует программы:

gifsicle - для оптимизации GIF изображений
jpegtran - для оптимизации JPG изображений
optipng - для оптимизации PNG изображений

Перейти к началу раздела Разное.


24. Где можно скачать последнюю версию DirectX?

Полная версия: DirectX End-User Runtimes
Web версия(обновляется раньше, чем полная): DirectX End-User Runtime Web Installer

Перейти к началу раздела Разное.


25. Запуск программы с определенной датой без изменения системных настроек.

Если Вы являетесь разработчиком программного обеспечения и по истечении тестового периода работы Ваша программа должна прекратить работу по причине выхода финальной версии или же Вам просто интересно как будет работать программа при изменении даты, то Вам нет необходимости изменять настройки системы.

Для запуска программы с определенной датой в прошлом или будущем Вы можете скачать программу RunAsDate

Вы можете запустить необходимую Вам программу непосредственно из программы RunAsDate или же создать ярлык для запуска с Рабочего Стола.

Перейти к началу раздела Разное.


26. Изменение атрибутов и времени/даты создания, изменения и открытия (доступа) файла.

Если Вам необходимо изменить дату создания, дату изменения и дату открытия (доступа) файла, то для этого Вы можете воспользоваться программой BulkFileChanger, которую Вы можете скачать здесь.

Чтобы изменить атрибуты и/или любую из указанных времени/дат, сделайте следующее:

1) Добавьте Ваш файл в программу.
1.1) Воспользуйтесь методом тащи-и-бросай (drag-and-drop), просто перекиньте Ваш файл на окно программы.
или
1.2) В главном меню выберите Файл → Добавить файлы (клавиша F2), выберите файл(ы) для добавления и нажмите Открыть.

2) Выделите файл(ы) и в главном меню выберите Действия → Изменить время/атрибуты (клавиша F6)
3) Установите необходимые атрибуты и/или время/дату файла и нажмите кнопку Выполнить.

Примечание. Если Вы не живете в Великобритании, Гренландии, Ирландии, Исландии, Португалии или Канарских островах, то не забудьте снять флажок Время указано по Гринвичу.

Перейти к началу раздела Разное.


27. Список всех обновлений вошедших в SP1 с краткими объяснениями и ссылками.

Если Вам необходимо узнать какие обновления вошли в Сервисный пакет обновлений 1, то Вы можете скачать с сайта Microsoft документ в котором описаны все обновления вошедшие в него, и также даны краткие пояснения и ссылки на страницы самих обновлений.

Скачать: Документация к пакету обновления 1 (SP1) для Windows 7 и Windows Server 2008 R2 (KB976932)

Файл при запуске откроется на странице Legal Disclaimer, для прочтения кратких пояснений к каждому вошедшему в SP1 обновлению и уточнения принадлежащих им ссылок перейдите в xls-файле на страницу Update List.

Перейти к началу раздела Разное.


28. Список горячих клавиш, используемых в окне команд Windows 7.

В окне командной строки также как и в других окнах Windows существует набор используемых горячих клавиш, которые Вы можете использовать.

↑ - переход к раннее введенной команде.
Последовательно нажимая ↑, в командной строке будет появляться предыдущая введенная команда.

↓ - переход к позднее введенной команде.
Перейдя ↑ к самой первой команде, можно вернуться к последней нажимая ↓.

Esc - очистка строки ввода.
При нажатии стрелок для перемещения, переход по истории команд продолжится с того же места, где Вы остановились.

Tab ↹ - автозавершение названия файла/папки.
Пример: Если находясь в корне диска C:, Вы введете команду cd prog и нажмете клавишу Tab ↹, то у Вас автоматически отобразится cd "Program Files".
При наличии объектов с одинаково начинающим© названиями нажимайте Tab ↹, до появления необходимого значения. Подстановка имен происходит в алфавитном порядке.
Если в 64-битной системе, учитывая предыдущий пример, Вы нажмете клавишу Tab ↹ снова, то у Вас автоматически отобразится cd "Program Files (x86)".

F1 - побуквенный ввод выбранной команды из истории команд.

F2 - скопировать в строку ввода часть командной строки, выбранной в истории, от начала строки до указанного Вами символа.
Копируется именно выбранная команда стрелочками, а не тот текст, что введен в данный момент.

Пример работы:
Выберите в истории, необходимую команду. Для примера: cd "Program Files"
Нажмите Esc. Строка очистится.
Нажмите F2. В появившемся диалоге нажмите m. В строке отобразится: cd "Progra

F3 - вставка текущей команды из истории.

F4 - удаление до указанного символа в текущем набранном тексте

F5 - вставка предыдущей команды из истории.

F7 - отображение нумерованного списка историю команд.

F8 - аналог клавиши ↑.

F9 - ввод команды из истории команд по ее номеру. Под номером понимается цифра, присвоенная команде в списке, отображаемом по F7.

Alt + F7 - очистка истории команд.

Ctrl + C - прекращение выполнения текущего командного файла или консольного приложения.

Перейти к началу раздела Разное.


29. Получение информации о длительности загрузки Windows 7.

Каждый раз при загрузке система собирает сведения о скорости загрузки ядра, инициализации драйверов и железа, а также о работе суперпрефетчера.
О данном событии Windows создает отчет, хранящийся в журналах приложений и служб.

Для получения информации о продолжительности загрузки, сделайте следующее:

1) В диалоговом меню Выполнить (Win   + R) или в строке поиска меню Пуск введите eventvwr.msc и нажмите Enter ↵.
2) В списке слева перейдите Журналы приложений и служб → Microsoft → Windows → Diagnostics-Performance → Работает.

Внимание: Журнал с данными о загрузке системы формируется спустя некоторое время после запуска, поэтому не открывайте журнал сразу после загрузки, а подождите несколько минут.

Каждой загрузке соответствует событие с кодом 100.

3) В меню Действия, расположенном справа от основного окна выберите команду Фильтр текущего журнала.
4) В открывшемся окне в поле <Все коды событий> введите код события: 100 и нажмите кнопку ОК.
Для того чтобы отменить действия фильтра, в меню Действия выберите команду Очистить фильтр.

5) В списке событий выберите желаемое по времени событие.
6) Ниже под списком событий расположена информация о текущем выбранном событии. Перейдите на вкладку Подробности.

Для анализа скорости загрузки интерес представляют следующие парамеры:

BootTime – общая длительность загрузки
BootPostBootTime – время с момента появления рабочего стола до полного окончания загрузки
MainPathBootTime — суммированное время до появления рабочего стола, включая все критические сервисы и драйверы, необходимые для основной работы системы

Исходя из этого можно вывести формулу: BootTime = MainPathBootTime + BootPostBootTime

BootKernelInitTime — время инициализации ядра
BootDriverInitTime — время инициализации драйверов
BootDevicesInitTime — время инициализации устройств
BootPrefetchInitTime — время работы суперпрефетчера
BootSmssInitTime — время инициализации диспетчера сеанса
BootPostBootTime — время запуска всех некритических сервисов уже при готовом рабочем столе
BootUserProfileProcessingTime – время загрузки профиля
BootNumStartupApps – количество программ в автозагрузке

Время в данных параметрах журнала указано в миллисекундах. 1 секунда = 1000 милисекунд.
Соответственно для перевода значений в секунды нужно либо разделить его на 1000, либо для получения приблизительного значения - убрать три последних цифры.

Каждому произошедшему событию присваивается определенный уровень.
Уровень события с кодом 100 (загрузка системы) устанавливается в результате достижения определенных условий:

Уровень события 100 | Условие (время в секундах)
Предупреждение | MainPathBootTime < 60 И BootPostBootTime < 30
Ошибка | 60 < MainPathBootTime < 120 И 30 < BootPostBootTime < 60
Критический | MainPathBootTime > 120 ИЛИ BootPostBootTime > 60

Уровень Предупреждение будет присвоен, если у Вас быстро загружается как система (драйверы и службы), так и пользовательская среда (рабочий стол и программы в автозагрузке).
Уровень Ошибка будет присвоен, если общая длительность загрузки (BootTime) более 90 секунд.
Уровень Критический будет присвоен при общей длительности загрузки более двух минут.

Перейти к началу раздела Разное.


30. Скрытие одного файла в другом используя альтернативные потоки данных в NTFS.

Иcпользуя возможности файловой системы NTFS можно спрятать один файл в другой, просто добавив его как альтернативный поток данных.

Добавление одного файла в другой в качестве альтернативного потока данных.

1) Создайте на диске временную папку для работы (Например: D:\Temp) и скопируйте в нее файлы которые Вы желаете объединить.
2) Запустите командную строку (Win   + R → cmd → OK)
3) В соответствии с шаблоном введите команду и нажмите Enter ↵:

где type - команда MS-DOS,
file1 - полный путь к файлу, который будет спрятан в альтернативный поток, включая его имя и расширение,
file2 - полный путь к файлу, в который будет добавлен альтернативный поток, включая его имя и расширение,
file3 - присвоенное имя скрытому файлу альтернативного потока данных. (Может быть идентичным наименованию файла из file1)
Символ перенаправления (>) записывает содержимое файла в другое месторасположение.

Например, чтобы добавить (спрятать) файл file1.pdf в файл file2.jpg введите:

Внимание: После добавления альтернативного потока данных размер файла в Проводнике визуально останется прежним.

Просмотр наличия альтернативных потоков данных в файле.

1) Запустите командную строку (Win   + R → cmd → OK)
2) В соответствии с шаблоном введите команду и нажмите Enter ↵:

где file - полный путь к файлу, включая его имя и расширение, для которого необходимо отобразить альтернативные потоки данных.

Пример:

Открытие скрытого файла в альтернативном потоке данных.

1) Запустите командную строку (Win   + R → cmd → OK)
2) В соответствии с шаблоном введите команду и нажмите Enter ↵:

где program - полный путь к программе, необходимой для открытия альтернативного потока данных,
file - полный путь к файлу, содержащему альтернативный поток данных.
stream - наименование скрытого файла в альтернативном потоке

Примечание: Если Вы желаете добавить (спрятать) в качестве альтернативного потока данных файл-архив, то используйте rar-архив.
Пример открытия rar-архива из альтернативного потока данных:

Удаление альтернативного потока данных:

1) Запустите командную строку (Win   + R → cmd → OK)
2) Переименуйте Ваш файл, для этого в соответствии с шаблоном введите команду и нажмите Enter ↵:

где file - полный путь к файлу, включая его имя и расширение, из которого необходимо удалить альтернативные потоки данных. tempfile - временный файл с любым именем, но с идентичным расширением.

Пример:

3) Удалите временный файл, для этого в соответствии с шаблоном введите команду и нажмите Enter ↵:

Пример:

Если Вы желаете управлять альтернативными потоками данных файлов не только в командной строке, но и в графической оболочке, то скачайте одну из предложенных ниже программ:
1) AlternateStreamView: английская версия, русская версия
2) ADS Tool: английская версия, альтернатив ссылка.
3) NTFS Stream Explorer: многоязычная версия, альтернатив ссылка.

Данные программы позволяют добавить, сохранить в виде отдельного файла и/или удалить альтернативные потоки данных, плюс несколько дополнительных своих функций у каждой.

Перейти к началу раздела Разное.


31. Извлечение файлов из cab-архива, созданного в InstallShield.

Наиболее известные cab-архивы бывают двух типов:

- Microsoft Cab Archive
- InstallShield Cab Archive

Если с извлечением файлов из cab-архивов от Microsoft проблем не возникает, так как их можно распаковать большинством архиваторов, то cab-архивы созданные в InstallShield так просто распаковать не получится.
Данные файлы обычно имеют вид data1.cab, data2.cab. Для получения файлов из них Вам понадобятся специальные программы. В большинстве случаев необходимо открыть файл data1.cab, и данные из других скорее всего подхватятся.

InstallShield Cabinet and Log File Viewer.

Официальная программа InstallShield Cabinet and Log File Viewer от создателей InstallShield: InstallShield_Cabinet_File_Viewer.zip
Чтобы открыть архив используйте меню File → Open
Чтобы просмотреть структуру папок и файлов используйте меню View → Components
Чтобы извлечь файл, выделите его и используйте меню Tools → Extract Files
Основной минус данной программы - извлекает по одному файлу за раз.

ZipScan.

1) Скачайте и распакуйте архив ZipScan.zip
2) Установите программу.
3) Скопируйте файл zd51145.dll в папку программы
В 32-битной Windows скопируйте его в: C:\Program Files\ZipScan
В 64-битной Windows скопируйте его в: C:\Program Files (x86)\ZipScan
4) Выберите в меню File пункт Open Archive File
5) Выделите необходимые Вам файлы для извлечения и щелкните на выделенном правой кнопкой мыши.
6) В контекстном меню выберите пункт Extract, укажите путь для извлечения и нажмите OK.

ISCAB.

Если Вам необходимо извлечь сразу все файлы или несколько файлов, то Вы также можете воспользоваться утилитой ISCAB запускаемой из командной строки.

1) Скачайте и распакуйте архив ISCAB.zip в папку, где находится cab-архив (data1.cab) из которого Вам необходимо извлечь файлы.
2) Удерживая нажатой клавишу ⇑ Shift, щелкните правой кнопкой мыши на данной папке в Проводнике и выберите пункт Открыть окно команд.
3) Введите команду для создания списка файлов, находящихся внутри cab-архива (после опции -i пробела быть недолжно!):

4) Введите команду для извлечения файлов указанных в списке (после опции -i пробела быть недолжно!):

Для изменения пути у какого-либо извлекаемого файла: откройте файл allfiles.ini в текстовом редакторе и добавьте рядом с ним необходимый Вам путь.

Пример.

У Вас в allfiles.ini указано, что файл MyApp.exe будет извлечен в текущую папку.

Вы желаете извлечь файл MyApp.exe в папку C:\MyFolder. Для этого измените указанную выше строчку на следующую:

Если Вы желаете извлечь только некоторые файлы, то отредактируйте в текстовом редакторе файл allfiles.ini, оставив в списке только те файлы, которые Вам необходимы.

Перейти к началу раздела Разное.


32. Восстановление экранной заставки Windows Energy из предыдущих версий Windows.

В предыдущих версиях Windows (Vista и бетаверсии Windows 7) присутствовала экранная заставка Windows Energy, которая не вошла в финальную редакцию.

Чтобы восстановить данную экранную заставку сделайте следующее:

1) Скачайте архив WindowsEnergyScreensaver.zip
2) Распакуйте его в любую папку.
3) Переместите файл Windows Energy.scr в папку C:\Windows\System32

Чтобы выбрать данную заставку экрана.

1) Щелкните на рабочем столе и выберите пункт Персонализация.
2) Нажмите на ссылку Заставка.
3) В открывшемся окне из ниспадающего списка выберите Windows Energy и нажмите кнопку ОК.

Перейти к началу раздела Разное.


33. Быстрое чтение QR-кодов, "Data Matrix", PDF417 и Actec кодов.

При работе с различными сайтами в интернете Вы можете увидеть изображения похожие на одно из указанных выше.

QR-код | Data Matrix | Aztec | PDF417

Они являются наиболее популярными разновидностями двухмерных штрих-кодов (2D-штрихкод), и способны вместить большое количество информации.
Чтобы расшифровать их воспользуйтесь одним из предложенных ниже вариантов:

Вариант 1. Распознавание QR-кодов и "Data Matrix" кодов без необходимости открытия изображения в самой программе.

1) Скачайте архив с программой Bar Capture и распакуйте его в любую папку.
BarCapture.zip
2) Запустите программу.
3) Откройте интернет страницу в браузере, pdf-файл или рисунок в просмотрщике изображений с QR-кодом или "Data Matrix" кодом.
4) Нажмите на значек фотоаппарата (Screen Shot).
Код распознается программой автоматически.

Если программа не распознала текст, то это означает, что либо текст плохого качества (нарушена перспектива изображения), либо рядом присутствует мешающая распознаванию информация.
Вам необходимо выделить изображение QR-кода, "Data Matrix"-кода и распознать его снова.

1) Нажмите на значек с двумя перекрещенными уголками (Capture).
2) Выделите изображение с кодом, оставив небольшой отступ с кажой стороны.
Программа автоматически считает изображение и отобразит результат.

Если распознанный текст отобразился непонятными символами, то это означает, что при создании QR-кода, "Data Matrix"-кода использовалась другая кодировка.
Вам необходимо переключить кодировку на другую и снова распознать изображение. Чтобы это сделать выполните следующие действия:

1) В главном меню программы Bar Capture нажмите File.
2) Наведите курсор мыши на пункт Charset и во всплывающем меню выберите другую кодировку.
3) Нажмите на значек фотоаппарата (Screen Shot).

Вариант 2. Распознавание QR-кодов, "Data Matrix", Aztec и PDF417 кодов с необходимостью открытия изображения в самой программе.

Если Вам необходимо кроме QR-кодов и "Data Matrix" кодов, распознать еще и PDF417 или Aztec коды, то для их распознавания Вам потребуется более мощное решение.
Это программы bcTester или BarCodeReader.

Чтобы распознать двухмерный штрихкод в программе bcTester:

1) Скачайте и установите программу bcTester (портатив версия)
2) Нажмите File → Open и укажите изображение со штрихкодом, которое Вы желаете распознать.
3) Откройте меню Barcode и в соответствии с типом штрихкода выберите необходимый Вам пункт.

Чтобы распознать двухмерный штрихкод в программе BarCodeReader:

1) Скачайте и установите программу BarCode Reader SDK for Windows
2) Откройте папку C:\Program Files\Bytescout BarCode Reader SDK
3) Скопируйте папку BarCodeReader в любое удобное для Вас место.
4) Используя оснастку Программы и компоненты удалите программу Bytescout BarCode Reader SDK.
5) Запустите программу BarCodeReader из скопированной папки.
6.1) Нажмите File → Open и укажите изображение со штрихкодом, которое Вы желаете распознать.
или
6.2) Откройте в дереве папок, папку в которой находится изображение и щелкните на нем.
7) Нажмите на панели быстрого доступа кнопку с названием типа штрихкода.
Если у Вас возникли проблемы с некорректным отображением распознанного текста, то измените в настройках программы (Options) кодировку для распознаваемого 2D-баркода (Text Encoding).
Ссылка на извлеченные BarCode Reader + BarCode Generator.

Также Вы можете воспользоваться сайтом в интернете: http://zxing.org/w/decode.jspx

Перейти к началу раздела Разное.


34. Соответствие наименований папок в Windows XP и Windows 7.

Если до Windows 7 Вы раньше пользовались Windows XP, то заметели что многие системные папки стали называться по-другому.
Ниже приводится таблица соответствия старых путей новым.

Расположение в Windows XP | Расположение в Windows 7
C:\Documents and Settings | C:\Users
C:\Documents and Settings\All Users | C:\ProgramData
C:\Documents and Settings\All Users\Application Data | C:\ProgramData
C:\Documents and Settings\All Users\Desktop | C:\Users\Public\Desktop
C:\Documents and Settings\All Users\Documents | C:\Users\Public\Documents
C:\Documents and Settings\All Users\Documents\My Music | C:\Users\Public\Music
C:\Documents and Settings\All Users\Documents\My Pictures | C:\Users\Public\Pictures
C:\Documents and Settings\All Users\Documents\My Videos | C:\Users\Public\Videos
C:\Documents and Settings\All Users\Favorites | C:\Users\Public\Favorites
C:\Documents and Settings\All Users\Start Menu | C:\ProgramData\Microsoft\Windows\Start Menu
C:\Documents and Settings\All Users\Start Menu\Programs | C:\ProgramData\Microsoft\Windows\Start Menu\Programs
C:\Documents and Settings\All Users\Start Menu\Programs\Administrative Tools | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools
C:\Documents and Settings\All Users\Start Menu\Programs\Startup | C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
C:\Documents and Settings\All Users\Templates | C:\ProgramData\Microsoft\Windows\Templates
C:\Documents and Settings\UserName | C:\Users\UserName
C:\Documents and Settings\UserName\Application Data | C:\Users\UserName\AppData\Roaming
C:\Documents and Settings\UserName\Cookies | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Cookies
C:\Documents and Settings\UserName\Desktop | C:\Users\UserName\Desktop
C:\Documents and Settings\UserName\Favorites | C:\Users\UserName\Favorites
C:\Documents and Settings\UserName\Local Settings\Application Data | C:\Users\UserName\AppData\Local
C:\Documents and Settings\UserName\Local Settings\Application Data\Microsoft\CD Burning | C:\Users\UserName\AppData\Local\Microsoft\Windows\Burn\Burn
C:\Documents and Settings\UserName\Local Settings\History | C:\Users\UserName\AppData\Local\Microsoft\Windows\History
C:\Documents and Settings\UserName\Local Settings\Temp | C:\Users\UserName\AppData\Local\Temp
C:\Documents and Settings\UserName\Local Settings\Temporary Internet Files | C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files
C:\Documents and Settings\UserName\My Documents | C:\Users\UserName\Documents
C:\Documents and Settings\UserName\My Documents\My Music | C:\Users\UserName\Music
C:\Documents and Settings\UserName\My Documents\My Pictures | C:\Users\UserName\Pictures
C:\Documents and Settings\UserName\My Documents\My Videos | C:\Users\UserName\Videos
C:\Documents and Settings\UserName\My Recent Documents | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Recent
C:\Documents and Settings\UserName\NetHood | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Network Shortcuts
C:\Documents and Settings\UserName\PrintHood | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Printer Shortcuts
C:\Documents and Settings\UserName\SendTo | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo
C:\Documents and Settings\UserName\Start Menu\Programs | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs
C:\Documents and Settings\UserName\Start Menu\Programs\Administrative Tools | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Administrative Tools
C:\Documents and Settings\UserName\Start Menu\Programs\Startup | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
C:\Documents and Settings\UserName\Templates | C:\Users\UserName\AppData\Roaming\Microsoft\Windows\Templates
Расположение в Windows XP | Расположение в Windows 7

Перейти к началу раздела Разное.


35. Способы вставки среднего и длинного тире в Проводнике и в Microsoft Word.

Используя клавиатуру Вы можете установить только короткое тире (дефис).
Если Вам необходимо добавить в имя папки, файла или в текст среднее или длинное тире, воспользуйтесь предложенным ниже решением.

В Проводнике, Блокноте или других текстовых поля или редакторах.

1) Зажмите клавишу левого Alt
2) Наберите с помощью цифровой клавиатуры цифры 0150 для установки среднего тире или 0151 для установки длинного.
3) Отпустите клавишу Alt.

В Microsoft Word.

1) Наберите:
число 2012 или 2013 для установки среднего тире.
число 2014 или 2015 для установки длинного тире.
2) Нажмите сочетание клавиш Alt + X (икс).

Перейти к началу раздела Разное.


1. Получение полного доступа к разделу реестра, используя программу regedit или командную строку.

Для поддержания безопасности системы, после внесения изменений в реестр верните исходные права и восстановите владельца.

Изменение разрешений и владельца для получения полного доступа к разделу реестра.

1) Нажмите кнопку Пуск и введите в строке поиска regedit
2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
3) Откройте раздел реестра, права которого Вы желаете изменить.
4) В списке слева, щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Разрешения.
5) Щелкните левой кнопкой мыши на группу Администраторы (Administrators):
6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

7) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
8) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
9) Выделите группу Администраторы (Administrators), установите флажок Полный доступ и нажмите кнопку ОК.

10) Если у Вас отсутствует группа Администраторы (Administrators), то нажмите поочередно кнопки Добавить... → Дополнительно... → Поиск
11) В результатах поиска выберите Администраторы (Administrators) и нажмите кнопку OK, и еще раз ОК.
12) Щелкните левой кнопкой мыши на группу Администраторы (Administrators) и установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

Восстановление настроек, если владельцем являлись служба TrustedInstaller или учетная запись Система.

1) Щелкните правой кнопкой мыши на разделе реестра, права которого Вы желаете восстановить и выберите пункт Разрешения.
2) Щелкните левой кнопкой мыши на группу Администраторы:
3) Снимите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку Применить.
4) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
5) Нажмите кнопку Другие пользователи или группы... и в качестве имени объекта в текстовом поле введите:
  • NT SERVICE\TrustedInstaller , если владельцем являлась служба TrustedInstaller
  • система , если владельцем являлась учетная запись Система (в английской Windows 7 нужно вводить System)

    • 6) В окне Изменить владельца на: выберите TrustedInstaller или система .
    7) Установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.

    Далее рассказывается как можно изменить разрешения, используя командную строку запущенную от имени администратора.
    (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
    Если после использовании команды, разрешения не сменятся, то возможно Вам придется зайти в систему под встроенной учётной записью "Администратор" для их выполнения заново.

    Изменение разрешений используя командную строку.

    1) Создайте в любом месте txt-файл (Например в папке D:\Reg создайте файл regperm.txt)
    2) Добавьте в данный файл разделы реестра и присваиваемые им разрешения в следующем формате:

    где куст – имя куста реестра, раздел – имя раздела реестра, а [разрешения] – двоичный числовой формат разрешений.

    Обозначения используемые для кустов реестра:

    Наименование куста реестра | Следует указывать
HKEY_CLASSES_ROOT | \Registry\machine\software\classes
HKEY_CURRENT_USER | \Registry\user\user_sid где user_sid — идентификатор безопасности пользователя.
HKEY_LOCAL_MACHINE | \Registry\machine
HKEY_USERS | \Registry\user
HKEY_CURRENT_CONFIG | \Registry\machine\SYSTEM\CurrentControlSet\Hardware Profiles\0001

    Если Вы не знаете свой SID, то узнать его Вы сможете введя в командной строке команду:

    Двоичные числовые представления разрешений имеют следующий вид (выборочно):

    Значение | Задаваемое разрешение
1 | Администратор, полный доступ
2 | Администратор, чтение
3 | Администратор, чтение и запись
4 | Администратор, чтение, запись и удаление
5 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, полный доступ
6 | СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ, чтение и запись
7 | Все, полный доступ
8 | Все, чтение
9 | Все, чтение и запись
10 | Все, чтение, запись и удаление
11 | Опытные пользователи, полный доступ
12 | Опытные пользователи, чтение и запись
13 | Опытные пользователи, чтение, запись и удаление
17 | Система, полный доступ
18 | Система, чтение и запись
19 | Система, чтение

    Пример:

    Чтобы задать полный доступ группам и пользователям Администратор, СОЗДАТЕЛЬ-ВЛАДЕЛЕЦ и Система для раздела реестра:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer в txt-файл необходимо добавить

    3) Запустите командную строку от имени администратора.
    В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
    4) Введите указанную ниже команду и нажмите Enter ↵:

    Например:


2. Запуск редактора реестра от имени пользователя Система, для удаления и редактирования заблокированных разделов.

Бывает, что при редактировании реестра доступ к некоторым разделам закрыт даже для администратора, а при попытке добавить нового пользователя, Вы получаете сообщение: Отказано в доступе.
В таком случае Вам поможет программа от Microsoft - PsExec. Данная программа позволяет запустить процесс от имени пользователя Система.

1) Зайдите на сайт http://technet.microsoft.com/ru-ru/sysinternals/bb897553
2) Скачайте комплект программ PsTools и распакуйте в любую папку.
3) Скопируйте файл PsExec.exe в папку C:\Windows\System32
4) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
5) Введите указанную ниже команду и нажмите Enter ↵:

Эта команда запустит редактор реестра в интерактивном режиме из системной учетной записи.

Таким же образом, Вы можете запустить и другие программы для редактирования реестра, например: Registry Workshop.

Внимание: При работе с PsExec обязательно полностью указывайте путь к программе, которую Вы желаете запустить от имени пользователя Система. А если в пути содержатся пробелы, то заключайте его в кавычки. Перейти к началу Общего списка советов.


3. Запуск редактора реестра от имени пользователя TrustedInstaller, для удаления и редактирования заблокированных разделов.

Если Вам необходимо запустить программу от имени пользователя TrustedInstaller, то выполните для этого следующее:

1) Зайдите на сайт http://developex.com/custom-software/devxexec.html
2) Скачайте файл devxexec.exe.
3.1) Если у Вас 32-бит Windows, то скопируйте файл devxexec.exe в папку C:\Windows\System32
3.2) Если у Вас 64-бит Windows, то скопируйте файл devxexec.exe в папки: C:\Windows\System32 и C:\Windows\SysWOW64
4) Откройте диалоговое меню Выполнить из меню Пуск (Win   + R)
5) Введите указанную ниже команду и нажмите Enter ↵:

Эта команда запустит редактор реестра от имени пользователя TrustedInstaller.

Таким же образом, Вы можете запустить и другие программы для редактирования реестра, например: Registry Workshop.

Внимание: При работе с Devxexec обязательно полностью указывайте путь к программе, которую Вы желаете запустить от имени пользователя TrustedInstaller. Если в пути содержатся пробелы, то заключайте его в кавычки.


4. Запрещение создания и изменения значения параметров в указанном разделе реестра.

Если Вам необходимо запретить возможность создания или изменения какой-либо программой значений параметров в указанном Вами разделе реестра, то выполните следующие действия:

1) Запустите Редактор реестра (Win   + R → regedit → OК)
2) В списке слева, щелкните правой кнопкой мыши на разделе реестра, в котором необходимо запретить создание и/или изменение параметров и выберите пункт Разрешения.
3) Нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
4) Щелкните левой кнопкой мыши на свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
6) Нажмите кнопку Дополнительно и перейдите на вкладку Разрешения
7) Уберите флажок Добавить разрешения, наследуемые от родительских объектов. В случае запроса системой дальнейшего действия нажмите кнопку Удалить.
8) Нажмите поочередно кнопки Добавить... → Дополнительно... → Поиск
9) В результатах поиска выберите Все и нажмите кнопку OK, и еще раз ОК.
10) Установите флажок в колонке Разрешить напротив следующих разрешений:

Запрос значения
Перечисление подразделов
Уведомление
Чтение разрешений

11) Нажмите кнопку ОК и перезагрузите компьютер.


5. Отключение проверки подписи для загруженных программ.

Избавляет от этого:

1) Откройте Панель управления → Свойства обозревателя → вкладка Дополнительно
2) Уберите флажок "Проверка подписи для загруженных программ" и поставьте флажок "Разрешать выполнение или установку программы, имеющую недопустимую подпись".
3) Создайте и примените reg-файл следующего содержания.


6. Удаление устаревших значков из области уведомления панели задач.

После установки/запуска программ, которые размещаются в области уведомлений, данный список все время растет.
С помощью следующего твика реестра, можно оставить в текущем диалоге отображаться только те значки, которые расположены в области уведомлений на данный момент.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Скачать готовый reg-файл Вы можете по ссылке: CleanTrayNotify.zip Перейти к началу Общего списка советов.


7. Очистка истории расположений фонов рабочего стола в Windows 7.

В окне настроек фонового рисунка рабочего стола (ПКМ на рабочем столе → Персонализация → Фоновый рисунок рабочего стола) есть пункт Расположение изображения, содержащий список папок, в которых хранятся картинки, которые можно использовать в качестве обоев рабочего стола. По умолчанию в этом списке всегда есть указания на четыре папки:

1. Фоны рабочего стола Windows;
2. Библиотека изображений;
3. Самые популярные фотографии;
4. Сплошные цвета.

Если Вы добавляете картинку из папки, которой нет в списке, то она(папка) автоматически добавится в данный список. Со временем, этот список будет увеличиваться, дополняясь новыми папками. При чём, в списке будут указаны папки, которых на диске физически уже нет, а запись о них осталась.

Чтобы очистить список Расположение изображения от ненужных записей и оставить только стандартные названия, нужно в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\Images удалить все параметры ID под номерами от 0 до 9, которые содержат в зашифрованном виде пути нахождения изображений, выбранных пользователем.

Теперь при повторном открытии окна настроек фонового рисунка рабочего стола (ПКМ на рабочем столе → Персонализация → Фоновый рисунок рабочего стола) в пункте Расположение изображения Вы увидите список, содержащий только записи по умолчанию.

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Администрирование и Безопасность.


8. Удаление папки Общие Документы и пользовательского профиля Общие.

Для спокойного удаления папки Общие Документы и пользовательского профиля Общие указанные ниже действия рекомендуется выполнять на чистой установленной системе. Если же у Вас система уже установлена, и на ней уже установлены программы, то прежде чем выполнять инструкции ниже скопируйте все папки из C:\Users\Public\* в C:\Users\ВашПрофиль\*

Вариант 1.

1) Запустите редактор реестра ( Win   + R → regedit → OK)
2) Откройте раздел реестра:

3) Затем нажмите правой кнопкой мыши на правой панели и выберите Создать → Параметр "DWORD".
4) Дайте этому параметру имя NoSharedDocuments и присвойте ему значение 1
5) Перезагрузите компьютер

Вариант 2.

1) Запустите редактор реестра ( Win   + R → regedit → OK)
2) Откройте раздел реестра:

3) Удалите следующий раздел:

4) Пройдите к разделу реестра:

5) Удалите следующий раздел (если есть):

Вариант 3.

1) Откройте Панель управления\Все элементы панели управления\Система(или Пуск → Компьютер → Свойства)
2) Откройте Дополнительные параметры системы
3) Пройдите на вкладку Имя Компьютера и нажмите Идентификация...
4) Выберите пункт Компьютер предназначен для домашнего использования.
5) Нажмите Далее, затем Готово, затем ОК
6) Перезагрузите компьютер

После того, как воспользуйтесь решением одного из вариантов проделайте следующие действия:

1) В разделе реестра:

замените значения с C:\Users\Public\ на C:\Users\ВашПрофиль\

2) В разделе реестра:

замените значения с %PUBLIC%\ на %USERPROFILE%\

3) Удалите папки (если они остались):

Диск С: → Пользователи → Общие (C:\Users\Public\)
Библиотеки → Документы → Общие Документы

Внимание: Если не хотите, чтобы у Вас на рабочем столе появились дублирующиеся иконки файлов, не устанавливайте значение параметра Common Desktop, идентичное рабочему столу Вашего профиля. Например, вместо C:\Users\ВашПрофиль\Desktop укажите C:\Users\ВашПрофиль\Public\Desktop, а вместо %USERPROFILE%\Desktop укажите %USERPROFILE%\Public\Desktop. Перейти к началу Общего списка советов.


9. Отключение и включение контекстного меню в Проводнике, на рабочем столе и на панели задач.

Для отключения контекстного меню для иконок на панели задач, создайте и примените reg-файл указанного ниже содержания:

Для включения контекстного меню для иконок на панели задач, создайте и примените reg-файл указанного ниже содержания:

Для отключения контекстного меню в Проводнике и на рабочем столе, создайте и примените reg-файл указанного ниже содержания:

Для включения контекстного меню в Проводнике и на рабочем столе, создайте и примените reg-файл указанного ниже содержания:


10. Удаление пункта меню Файл из Проводника.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в NoFileMenu
5) Измените значение на 1.
6) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:

Данный пункт будет также удален из всех мест, использующих оболочку Windows. Перейти к началу Общего списка советов.


11. Запрещение запуска программ.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD
4) Переименуйте его в RestrictRun
5) Измените значение на 1.
6) Перезагрузите компьютер.
7) Создайте подраздел с аналогичным именем RestrictRun
8) Создайте в разделе (HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun) список разрешенных к запуску программ для текущего пользователя.
8.1) Создайте строковые(String) параметры
8.2) Укажите названия для создаваемый строковых параметров, начиная с 1 и далее
8.3) Установите в значениях параметров пути к Вашим приложениям и их имена. Файлы должны указываться с расширением. Например:

1 REG_SZ regedit.exe
2 REG_SZ calc.exe
3 REG_SZ Iexplore.exe

Не забудьте указать файл regedit.exe, чтобы Вы могли зайти в него и отменить установленные Вами ограничения!
Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0 или удалить его.

Если Вы забыли указать regedit.exe в списке или не создали подраздел RestrictRun, чтобы запретить запуск всех программ. Для отмены запрета проделайте следующее:

1) Перезапустите компьютер.
2) До начала запуска Windows нажмите на клавишуF8 и выберите пункт Безопасный режим с поддержкой командной строки
3) В командной строке введите regedit и нажмите Enter ↵.
4) Откройте раздел реестра: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
5) Удалите ключ RestrictRun или установите его значение на 0.

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Администрирование и Безопасность.


12. Удаление записей из истории диалогового окна "Выполнить".

Если Вы используете диалоговое окно "Выполнить" в меню "Пуск" (Win   + R), то для удаления записей из его истории проделайте следующее.

1) Запустите редактор реестра: Win   + R → regedit
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU

Команды, введенные вами ранее, хранятся в виде значений параметров a,b,c,d и так далее используя буквы английского алфавита.

3) Для удаления записи - удалите параметр с ненужной командой, и она пропадет из истории диалога "Выполнить".

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Администрирование и Безопасность.


13. Удаление и восстановление предупреждающего окна о внесении изменений в msconfig (Конфигурация системы).

При внесении изменений в утилиту msconfig (Конфигурация системы), появляется окно Настройка системы, в котором Вам предлагается на выбор: либо перезагрузить компьютер, либо выйти без перезагрузки.

Чтобы отключить данное предупреждение установите флажок Больше не показывать это предупреждение, и окно больше появляться не будет.

Для восстановления данного окна:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKCU\Software\Microsoft\Shared Tools\MsConfig
3) Удалите параметр NoRebootUI.

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Администрирование и Безопасность.


14. Удаление лишних записей из утилиты msconfig (Конфигурация системы).

Если в окне утилиты msconfig (Конфигурация системы) скопилось много записей и Вы хотели бы удалить ненужные. То сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKLM\SOFTWARE\Microsoft\Shared Tools\MSConfig
3) Просмотрите все подразделы данном разделе реестра и удалите ненужные Вам записи.
4) Также записи могут хранит© в файле mscfgtlc.xml, находящимся в папке C:\Windows\system32\. В 64-битных Windows данный файл также находится в папке C:\Windows\SysWOW64\.
5) Откройте данный файл Блокнотом, удалите ненужные записи и сохраните. Если Вы хотите удалить все лишние записи, то просто удалите файл mscfgtlc.xml.

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Администрирование и Безопасность.


15. Отключение напоминания о необходимости перезагрузки после установки обновлений.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU.
3) Создайте параметр NoAutoRebootWithLoggedOnUsers типа DWORD и присвойте ему значение 1.

или

откройте диалоговое меню Выполнить (Win   + R) и введите команду:

Для вступления изменений в силу перезайдите в систему или перезагрузите компьютер. Перейти к началу Общего списка советов.


16. Запуск нескольких копий редактора реестра одновременно.

Пользователи, которые работают с редактором реестра Windows наверняка сталкивались с ситуацией, когда необходимо сверить содержимое веток реестра. Весьма удобно было бы открыть два редактора реестра, разместить их рядом и сравнить. Однако при повторной попытке запуска программы, система переключает Вас на открытое окно программы. Запуск с удерживанием клавиши Shift тоже не работает.

Для запуска второй копии редактора реестра:

1) Откройте диалоговое меню "Выполнить" (Win   + R)
2) Введите команду regedit, используя параметр -m и нажмите Enter ↵.


17. Дополнительные параметры для настройки функций "Защита системы" и "Восстановление системы".

В Windows 7 для функций "Защита системы" и "Восстановление системы" существуют дополнительные настройки, которые скрыты от обычных пользователей. Чтобы их изменить Вам необходимо создать соответствующий настройке параметр в реестре.

1) Откройте диалоговое меню "Выполнить" (Win   + R)
2) Введите команду regedit и нажмите Enter ↵.
3) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore\Cfg
4) Создайте параметр типа DWORD с именем из списка указанного ниже
5) Щелкните правой кнопкой мыши на созданном параметре и выберите пункт Изменить.
6) Установите переключатель в положение Десятич и введите необходимое Вам значение.

DiskPersent - указывает, какой объем дискового пространства в процентах будет использовать система для точек восстановления.

CompressionBurst - указывает время сжатия данных в секундах при простое системы. При простое системы в течение времени, указанного в данном параметре System Restore будет упаковывать данные, после чего прекратит свою работу до следующего периода простоя системы.

DSMin - указывает минимальное количество свободного дискового пространства, которое требуется System Restore. В случае уменьшения свободного дискового пространства до указанного размера точки восстановления системы перестанут создаваться.

1 день(сутки) равен 86400 секунд, 1 час равен 3600 секунд, 1 минута равна 60 секунд.

RPGlobalInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой контрольной точки.

RPLifeInterval - указывает время в секундах, в течение которого будут хранит© точки восстановления перед удалением их с компьютера.

RPSessionlnterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед созданием новой системной контрольной точки при включенном компьютере. Значением по умолчанию является ноль, что означает, что эта функция выключена. Вы можете установить свое значение (например, интервал в один час), чтобы программа создавала контрольные точки автоматически через заданный интервал.

ThawInterval - указывает количество времени в секундах, в течение которого System Restore ожидает перед тем, как возобновить свою работу после того, как появилось достаточное количество дискового пространства. Перейти к началу Общего списка советов.


18. Запрещение запуска командной строки и обработки пакетных файлов (bat, cmd).

Если Вам необходимо запретить запуск командной строки и выполнение пакетных файлов, то выполните следующие действия:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows
3) Создайте раздел System
4) В разделе HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System создайте DWORD-параметр DisableCMD
Установите значение данного параметра в зависимости от требуемых ограничений:

2 - Запрещает пользователям запускать окно командной строки Cmd.exe, но не запрещает обработку сценариев в командной строке.
1 - Запрещает пользователям запускать окно командной строки Cmd.exe, также запрещает обработку сценариев в командной строке.
0 - Разрешает пользователям запускать окно командной строки Cmd.exe, также разрешает обработку сценариев в командной строке.

Вы также можете настроить данные параметры в редакторе локальной групповой политики:

1) В строке поиска меню Пуск или в окне Выполнить (Win   + R) введите gpedit.msc и нажмите Enter ↵.
2) Перейдите в Конфигурация пользователя\Административные шаблоны\Система
3) Щелкните дважды на параметре Запретить использование командной строки или щелкните правой кнопкой мыши на нем и выберите Изменить
4) Установите переключатель в значение Включить, чтобы запретить использование командной строки.
5) В ниспадающем списке выберите значение Да для запрета обработки сценариев в командной строке.
Для отмены внесенных изменений установите переключатель в значение Не задано.


19. Удаление сведений об использованном USB-флэш диске.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра:

Здесь Вы увидите список разделов, обозначающих подключаемые когда-либо флеш-диски к Вашей системе.
3) Найдите раздел соответствующий, флеш диску, упоминание о котором Вы хотите удалить из реестра. (Например: Disk&Ven_Corsair&Prod_Flash_Voyager&Rev_1100)

4) Откройте данный раздел.
Путь к данному разделу, в моем примере:

5) В данном разделе Вы увидите подраздел (Например: AB00000000005136&0)
Путь к данному подразделу, в моем примере:

6) Откройте раздел реестра:

7) Отрывая поочередно каждый из подразделов данного раздела, найдите подраздел содержащий в названии AB00000000005136
Путь к данному разделу, в моем примере:

8) Удалите найденные в результате анализа разделы реестра. В моем примере, необходимо удалить следующие разделы:

9) Перезагрузите компьютер. Перейти к началу Общего списка советов.


20. Удаление программ в Безопасном Режиме, использующих установщик Windows Installer.

В большинстве случаев при попытке удаления программы в Безопасном Режиме, если программа не использует собственный инсталлятор (Например: Winamp) Вы получите предупреждающее сообщение:

Для включения возможности удаления программ в Безопасном Режиме сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal
3) Создайте здесь раздел MSIService
4) Присвойте строковому параметру По умолчанию значение Service.
5) Перезагрузите компьютер. Перейти к началу Общего списка советов.


21. Отмена ограничения использования команд в контекстном меню, при выделении более 15 файлов.

Как известно, при выделении более 15 файлов команды контекстного меню, такие как "Открыть/Печать/Редактировать" становятся недоступны.
Для отмены данного ограничения проделайте следующее:

1) Запустите редактор реестра ( Win   + R → regedit → OK)
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
3) Создайте в нем параметр MultipleInvokePromptMinimum типа DWORD.
4) Установите значение данного параметра равным 16.

Для уменьшения количества файлов на которых действует ограничение применения команд, введите значение от 1 до 15.
При выделении файлов выше выбранного Вами значения команды в контекстном меню примҐться не будут. При указании значения 0 произойдет полное отключение команд, включая команду "Открыть".

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Администрирование и Безопасность.


22. Отключение отображения последних открывавшихся документов в меню Пуск.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте новый параметр NoRecentDocsHistory типа DWORD.
4) Щелкните правой кнопкой мыши по параметру NoRecentDocsHistory и выберите пункт Изменить
5) Введите значение 1 и нажмите ОК.
6) Закройте редактор реестра и перезапустите компьютер.

Также эти настройки можно установить используя Редактор локальной групповой политики:

1) Нажмите кнопку Пуск, в строке поиска введите команду gpedit.msc и нажмите клавишу Enter ↵.
2) Откройте Конфигурация пользователя → Административные шаблоны → Меню «Пуск» и панель задач
3) Дважды щекните на пункте Не хранить сведения о недавно открывавшихся документах.
4) Установите переключатель в значение Включить и нажмите кнопку ОК. Перейти к началу Общего списка советов.


23. Запрещение добавления программ в разделы реестра отвечающие за автозагрузку.

Если Вы не хотите, чтобы неизвестная программа без предупреждения добавлялась в какой-либо из разделов реестра отвечающих за автозапуск, то после установки всех программ которые Вы желаете добавить в автозагрузку - Вы можете заблокировать доступ к соответствующим разделам реестра.

Для этого, выполните поочередно для каждого из указанных ниже разделов, решение предложенное в совете 4. Запрещение создания и изменения значения параметров в указанном разделе реестра. из раздела Твики Реестра - Администрирование и Безопасность.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run (текущий пользователь)
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce (текущий пользователь, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run (все пользователи)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run (текущий пользователь, только 64-бит версия)
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\RunOnce (все пользователи, запуск один раз, только 64-бит версия)

Данное решение, может быть неплохим дополнением к мерам по увеличению безопасности системы. Оно позволит Вам не допустить самостоятельного прописывания вирусов, троянов, блокировщиков системы и различных нежелательных программ в автозагрузку.
Если же у Вас возникнет необходимость добавить какую-либо программу в автозагрузку, то Вы можете либо поместить ее в папку «Автозагрузка» в меню Пуск, либо на время установки программы выставить разрешение «Полный доступ», а затем вернуть разрешения указанные выше.

Также Вы можете воспользоваться готовыми пакетными bat-файлами, позволяющими заблокировать и разблокировать данные разделы реестра.

1) Скачайте архив AutorunBlockUnblock.zip, распакуйте в любую папку.
2) Щелкните правой кнопкой мыши на необходимом файле и выберите пункт Запуск от имени администратора.

3.1) Для блокировки разделов реестра от внесения изменений:
Запустите файл autorun_registry_block_rus.bat, если у Вас установлена русская Windows 7.
Запустите файл autorun_registry_block_eng.bat, если у Вас установлена английская Windows 7 + русский MUI.

3.2) Для разблокировки разделов реестра от внесения изменений:
Запустите файл autorun_registry_unblock_rus.bat, если у Вас установлена русская Windows 7.
Запустите файл autorun_registry_unblock_eng.bat, если у Вас установлена английская Windows 7 + русский MUI.


24. Открытие окна команд с правами администратора из контекстного меню Проводника.

Чтобы запустить окно командной строки из контекстного меню Проводника, Вам необходимо удерживая нажатой клавишу ⇑ Shift нажать правой кнопкой мыши на папку и выбрать пункт Открыть окно команд.
Если же у Вас включен контроль учетных записей (UAC), то при выборе данного пункта откроется обычное окно командной строки.
Вы можете добавить в контекстное меню пункт, позволяющий открыть из текущей папки окно команд с правами администратора.
Для добавления указанного выше пункта, воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1. Если у Вас в контекстном меню нет пункта "Стать владельцем и задать полный доступ к объекту".

Создайте и примените reg-файл следующего содержания:

Вариант 2. Если у Вас в контекстном меню есть пункт "Стать владельцем и задать полный доступ к объекту".

1) Откройте папку C:\Windows\System32
2) Скопируйте файл cmd.exe в папку C:\Windows
3) Щелкните правой кнопкой мыши на файле cmd.exe скопированном в папку C:\Windows и выберите пункт Свойства.
4) Перейдите на вкладку Совместимость
5) Установите флажок Выполнять эту программу от имени администратора и нажмите кнопку ОК.
6) Создайте и примените reg-файл следующего содержания:

Вы можете скачать архив с готовыми reg-файлами по ссылке: ElevatedCMDInContextMenu.zip

Add_Elevated_CMD_In_Context_Menu.reg - используйте для добавления пункта "Открыть окно команд с правами администратора", при наличии пункта "Стать владельцем и задать полный доступ к объекту".
Add_Elevated_CMD_In_Context_Menu2.reg - используйте для добавления пункта "Открыть окно команд с правами администратора", при отсутствии пункта "Стать владельцем и задать полный доступ к объекту".

Remove_Elevated_CMD_In_Context_Menu.reg - используйте для удаления пункта "Открыть окно команд с правами администратора", при наличии пункта "Стать владельцем и задать полный доступ к объекту".
Remove_Elevated_CMD_In_Context_Menu2.reg - используйте для удаления пункта "Открыть окно команд с правами администратора", при отсутствии пункта "Стать владельцем и задать полный доступ к объекту". Перейти к началу Общего списка советов.


25. Сохранение и восстановление содержимого раздела реестра, а также его владельца и разрешений.

Если Вы желаете сохранить содержимое раздела реестра, а также владельца и заданные разрешения, чтобы в последствии их восстановить, то Вы можете воспользоваться одним из предложенных ниже решений:

Вариант 1. Создание файла куста реестра.

1) Запустите редактор реестра (Win   + R → regedit → ОК)

Чтобы сохранить содержимое, заданные разрешения и владельца для раздела:

2) Перейдите в раздел реестра для которого Вы желаете осуществить указанные выше действия.
3) Щелкните на данном разделе реестра правой кнопкой мыши и выберите пункт Экспортировать.
4) Задайте имя для файла, в который будут сохранена информация для указанного Вами раздела. (Например: my_regkey_backup.hiv)
5) В ниспадающем меню Тип файла выберите Файлы кустов реестра и нажмите кнопку Сохранить.

Чтобы восстановить содержимое, заданные разрешения и владельца для раздела:

6) Перейдите в раздел реестра для которого Вы желаете восстановить указанное выше.
7) В главном меню Файл нажмите пункт Импорт.
8) В ниспадающем меню выберите Файлы кустов реестра
9) Выберите файл, в который Вы сохранили информацию для указанного Вами раздела и нажмите кнопку Открыть.
10) Нажмите кнопку Да.
Внимание: Данное действие полностью удалит все содержимое для указанного Вами реестра. Взамен этого, поверх будут записаны значения из выбранного файла.
11) Нажмите кнопку ОК.

Вариант 2. Создание резервной копии реестра (точки восстановления).

Указанные ниже программы позволяют создать резервную копию (наподобие точки восстановления) для выбранных разделов реестра или для реестра целиком.

Registry Workshop.

1) Скачайте архив с программой: Registry Workshop и распакуйте его в любую папку.
2) Запустите программу и в главном меню Файл выберите пункт Резервирование и восстановление.
3.1) Для сохранения владельца и разрешений для раздела нажмите кнопку Резервировать.
3.2) Для восстановления владельца и разрешений для раздела нажмите кнопку Восстановить.
4) Укажите какие разделы реестра необходимо сохранить/восстановить и нажмите кнопку ОК(Да).

Mz Registry Backup

1) Скачайте и установите программу Mz Registry Backup: английская версия или русская версия
2) Запустите программу и на вкладке Backup Registry (Резервирование реестра) установите переключатель в необходимое значение:

2.1) Create complete registry backup (Резервная копия всего реестра) - для сохранения резервной копии всего реестра
2.2) Create custom registry backup (Резервная копия выбранных разделов реестра) - для сохранения резервной копии выбранных разделов реестра

3) При выборе второго значения переключателя укажите для каких разделов необходимо создать резервную копию.
4) Введите в поле Description (Описание) - описание для создаваемой резервной копии.
5) Нажмите кнопку Create Backup Now (Создать резервную копию) для запуска, а по-завершении нажмите кнопку ОК.

Для восстановления реестра из резервной копии:

6) Перейдите на вкладку Restore Registry (Восстановление реестра).
7) Выберите резервную копию и нажмите кнопку Restore Registry Now (Восстановить реестр).
8) По-завершении нажмите кнопку ОК.

Внимание: Для восстановления содержимого реестра произойдет перезагрузка компьютера.

Для большего контроля за изменением содержимого раздела реестра, а также его владельца и разрешений - создавайте больше резервных копий.
Так как для каждой копии указывается дата и время создания, то Вы можете использовать их как точки восстановления реестра. Перейти к началу Общего списка советов.


26. Добавление пунктов "Запуск от имени администратора" и "Извлечь все"" в контекстное меню MSI файлов.

Чтобы добавить пункт Запуск от имени администратора в контекстное меню MSI файлов, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Запуск от имени администратора из контекстного меню MSI файлов, создайте и примените reg-файл указанного ниже содержания.

Чтобы добавить пункт Извлечь все в контекстное меню MSI файлов, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Извлечь все из контекстного меню MSI файлов, создайте и примените reg-файл указанного ниже содержания.


27. Запрещение отображения окна "Программы и компоненты" и его элементов.

Для отключения отображения содержимого всех элементов окна Программы и компоненты, создайте и примените reg-файл указанного ниже содержания:

Для отключения возможности запуска Компоненты Windows, создайте и примените reg-файл указанного ниже содержания:

Для отключения отображения содержимого списка Установленные программы, создайте и примените reg-файл указанного ниже содержания:

Для отключения отображения содержимого списка Установленные обновления, создайте и примените reg-файл указанного ниже содержания:

Для восстановления всех функций окна Программы и компоненты, создайте и примените reg-файл указанного ниже содержания:


28. Отключение или включение отображения истории запросов в строке поиска Проводника.

Для отключения отображения истории запросов в строке поиска Проводника, создайте и примените reg-файл указанного ниже содержания:

Для восстановления отображения истории запросов в строке поиска Проводника, создайте и примените reg-файл указанного ниже содержания:

Перезагрузите компьютер для принятия изменений. Перейти к началу Общего списка советов.


29. Удаление и восстановление пунктов меню из диалогового окна Безопасность Windows (Ctrl+Alt+Del).

Чтобы удалить или восстановить пункты из списка диалогового окна вызываемого нажатием комбинации клавиш Ctrl + Alt + Delete, известного как Безопасность Windows, воспользуйтесь предложенными ниже решениями.

Для удаления пункта Блокировать компьютер из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

Для удаления пункта Сменить пароль из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

Для удаления пункта Сменить пользователя из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

Для удаления пункта Выйти из системы из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

Для удаления пункта Запустить диспетчер задач из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

Для удаления кнопки управления питанием из диалогового окна Безопасность Windows (данные пункты также удалятся из меню Пуск), создайте и примените reg-файл указанного ниже содержания.

Для удаления кнопки управления питанием на экране переключения пользователей из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания.

Для восстановления указанных пунктов из диалогового окна Безопасность Windows, создайте и примените reg-файл указанного ниже содержания:


30. Добавление в Панель управления оснастки "Учетная запись опытного пользователя" (netplwiz), для расширенного управления учетными записями.

Чтобы добавить в Панель управления оснастку Учетная запись опытного пользователя (netplwiz), для расширенного управления учетными записями, создайте и примените указанный ниже reg-файл.

Чтобы удалить из Панели управления оснастку Учетные записи пользователей (netplwiz), для расширенного управления учетными записями, создайте и примените указанный ниже reg-файл.


31. Настройка параметров, отвечающих за информацию, отображаемую в оснастке Программы и компоненты, а также за удаление установленных программ.

Каждая установленная программа записывает в реестр необходимую о себе информацию, которая используется элементом Панели управления - Программы и компоненты.

Сведения, отображаемые для программ на странице Установленные программы, а также параметры задающие настройки их удаления, восстановления или изменения хранятся в разделах веток реестра:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall - в 32-битных и в 64-битных версиях Windows.
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall - только в 64-битных версиях Windows.

Ниже указаны наиболее используемые из них.

AuthorizedCDFPrefix - данный строковый параметр указывает ссылку на канал обновлений для приложения.
Comments - данный строковый параметр указывает текст примечанияк программе.
Contact - данный строковый параметр указывает контактную информацию для свзи с автором программы.
DisplayIcon - данный строковый параметр указывает иконку.
DisplayName — данный строковый параметр указывает название программы.
DisplayVersion — данный строковый параметр указывает номер версии программы.
HelpLink - данный строковый параметр указывает ссылку на страницу справки программы. Часто в нем просто указывают ссылку на главную страницу сайта программы.
HelpTelephone - данный строковый параметр указывает телефон технической службы поддержки программы.
InstallDate — данный строковый параметр указывает дату, когда была установлена программа. (Например, 20120827).
InstallLocation — данный строковый параметр указывает путь к папке, в которую была установлена программа.
InstallSource - данный строковый параметр указывает путь к папке откуда была установлена программа.
ModifyPath - данный строковый параметр указывает команду, которая будет выполнена при попытке изменения программы.
ProductID - данный строковый параметр указывает значение кода продукта для программы.
Publisher — данный строковый параметр указывает издателя (имя автора или название компании) программы.
Readme - данный строковый параметр указывает путь к файлу Readme. Обычно им является файл Readme.txt.
RegCompany - данный строковый параметр указывает сведения о зарегистрированной компании программы.
RegOwner - данный строковый параметр указывает сведения о зарегистрированном владельце программы.
UninstallString - данный строковый параметр указывает команду, которая будет выполнена при попытке удаления программы.
URLInfoAbout - данный строковый параметр указывает ссылку на страницу, содержащую информацию о программе. Часто в нем просто указывают ссылку на главную страницу сайта программы.
URLUpdateInfo - данный строковый параметр указывает ссылку на страницу, где можно скачать обновления к программе. Часто в нем просто указывают ссылку на главную страницу сайта программы.

EstimatedSize - данный Dword-параметр указывает размер программы в килобайтах.
Language - данный Dword-параметр указывает язык используемый приложением по умолчанию. Английский - 0x00000409(1033), русский - 0x00000419(1049).
NoModify - данный Dword-параметр задает возможность изменения программы. Значение параметра равное 1 запрещает изменять установленную программу, значение 0 разрешает.
NoRemove - данный Dword-параметр задает возможность удаления программы. Значение параметра равное 1 запрещает удалять установленную программу, значение 0 разрешает.
NoRepair - данный Dword-параметр задает возможность восстановления программы. Значение параметра равное 1 запрещает восстанавливать установленную программу, значение 0 разрешает.
SystemComponent - данный Dword-параметр указывает является ли программа системной (скрытой). Значение параметра равное 1 запрещает отображение программы в списке Программы и компоненты.
WindowsInstaller - данный Dword-параметр указывает установленно ли приложение с использованием установщика Windows. Если да, то значение параметра равно 1.
VersionMajor - данный Dword-параметр указывает основной номер версии программы. Соответствует числу до первой точки в параметре DisplayVersion.
VersionMinor - данный Dword-параметр указывает дополнительный номер версии программы. Соответствует числу после первой точки в параметре DisplayVersion.


32. Отключение запоминания последнего пользователя и включение запроса имени пользователя и пароля на экране пользователей.

По умолчанию в системе на экране пользователей отображаются имена пользователей.
Данный факт может облегчить доступ в Вашу систему нежелательных пользователей, которым надо будет набрать лишь пароль, чтобы войти.
Вы можете усилить безопасность собственного компьютера, включив использование классического окна для входа в систему.
При включении данного параметра, на экране пользователей для входа в систему, будет запрашиваться не только пароль, но и ¤ пользователя.

Чтобы включить использование классического окна для входа в систему, требующего введения имени пользователя и пароля, создайте и примените указанный ниже reg-файл.

Чтобы отключить использование классического окна для входа в систему, требующего введения имени пользователя и пароля, создайте и примените указанный ниже reg-файл.

Примечание:

Если у Вас не задан пароль, то оставьте отведенное для него поле пустым.
Для входа пользователей, присоединенных к домену введите в поле Пользователь - Имя домена (Имя компьютера)/Имя пользователя.


33. Удаление или добавление из контекстного меню исполняемых файлов пункта Запуск от имени другого пользователя.

При удерживании клавиши ⇑ Shift и нажатии правой кнопкой мыши на исполняемом файле (exe, bat, cmd, msc или msi) в контекстном меню появляется пункт Запуск от имени другого пользователя.

Чтобы удалить из контекстного меню исполняемых файлов пункт "Запуск от имени другого пользователя", создайте и примените указанный ниже reg-файл.

Чтобы восстановить в контекстном меню исполняемых файлов пункт "Запуск от имени другого пользователя", создайте и примените указанный ниже reg-файл.


34. Включения требования ввода пароля администратора для отключения контроля учетных записей при необходимости запуска программы с повышенными правами.

Если Вы используете Контроль Учетных Записей (UAC) для блокировки запуска программы с повышенными правами, то в качестве дополнительной меры безопасности, Вы можете включить функцию требования пароля администратора для отключения UAC.

Чтобы включить требование ввода пароля для UAC при запуске программы, создайте и примените указанный ниже reg-файл:

Чтобы отлючить требование ввода пароля для UAC при запуске программы, создайте и примените указанный ниже reg-файл:


35. Отключение возможности записи на компакт-диск.

Чтобы отключить возможность записи на компакт-диск в системе, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить возможность записи на компакт-диск, создайте и примените reg-файл указанного ниже содержания.


36. Добавление собственной программы в список "Программы по умолчанию".

Чтобы добавить собственную программу в список Программы по умолчанию, создайте и примените reg-файл, используя шаблон ниже:

Пояснения к reg-файлу:

1) Вместо myprogram.exe укажите имя exe-файла, запускающего программу.
2) Вместо D:\\Programs\\MyProgram\\ укажите путь к exe-файлу программы.
3) Вместо D:\\Programs\\MyProgram\\FileIcons\\Icon.ico укажите путь к иконке, для файлов сопоставляемых с данной программой.
4) В остальных местах вместо MyProgram укажите имя программы.
5) В значении параметра ApplicationDescription введите описание программы.
6) В значении параметра ApplicationName введите имя программы.
7) Вместо .ext введите расширение файла, которое должно быть сопоставлено с программой.
8) Для добавления поддерживаемых расширений:

8.1) Скопируйте указанные ниже строки яў каждого нового расширения.
Сделав изменения в соответствии с описанными выше пунктами.

8.2) Добавьте новое расширение ".ext"="MyProgram.ext" в ветку [HKEY_LOCAL_MACHINE\SOFTWARE\MyProgram\Capabilities\FileAssociations\]
Сделав изменения в соответствии с описанными выше пунктами.

Пример:


1. Распаковка Хотфиксов(обновлений Microsoft с расширением EXE) из контекстного меню.

Для распаковки инсталляций, удобно пользоваться Universal Extractor-ом, но последняя версия не все хотфиксы от MS распаковывает правильно и приходится пользоваться другими методами. Одним из вариантов является добавление в контекстное меню команды Unpack HotFix.
1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Чтобы добавить данный пункт в контекстное меню, создайте следующий reg-файл:

Например, при распаковке Windows6.1-KB917607-x64.exe, на выходе получаем папку Windows6.1-KB917607-x64.exe_unpacked с извлечёнными файлами.
Минус один - команда Unpack HotFix встраивается в контекстное меню всех exe-файлов, а не только файлов от Microsoft.

Чтобы удалить данный пункт из контекстного меню, создайте следующий reg-файл:

Готовые reg-файлы Вы можете скачать по ссылке: UnpackHotFix.zip Перейти к началу Общего списка советов.


2. Добавление пункта "Открыть в блокноте" в контекстное меню файлов.

1) Создайте reg-файл.
1.1) Скопируйте код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Notepad.reg")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

2) Примените полученный reg-файл. Щелкните на нем дважды и нажмите кнопку Да. Перейти к началу Общего списка советов.


3. Добавление системных ярлыков в папку Компьютер.

Создайте и примените reg-файлы следующего содержания:

Администрирование

Корзина

Панель управления

Принтеры и факсы

Учетные записи пользователей


4. Добавление произвольной команды в контекстное меню рабочего стола.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "fix.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Примените его.

Вместо Название команды укажите необходимое Вам название пункта, которое будет отображаться в контекстном меню. Например: Панель управления
Вместо выполняемая команда укажите какая команда должна быть запущена при нажатии созданного Вами пункта в контекстном меню. Например: control
Вместо путь к значку иконки укажите путь к иконке, отображаемой рядом с Вашим пунктом в контекстном меню.
Вместо Расположение укажите месторасположение Вашего пункта в контекстном меню. Top - вверху, Bottom - внизу.

Описанным выше способом можно добавить практически любую команду.
Например, reg-файл для добавления пункта Панель управления в контекстное меню рабочего стола будет выглядеть так:


5. Распаковка файлов и директорий из CAB-архивов (а так же упаковка в CAB-архивов) из контекстного меню "Отправить".

Reg-файл добавляет в расширенное меню оболочки функции для упаковки и распаковки CAB.
С папками, в пути к которым есть пробелы и спецсимволы, к сожалению, не работает.


6. Добавление пункта "Удалить содержимое папки" в контекстное меню.

Как добавить в контекстное меню папки команду для удаления содержимого папки без удаления самой папки? Вы можете создать себе пункт Удалить содержимое папки в контекстном меню и Вам достаточно будет его только выбрать. Вам не придется открывать папку, выделять все файлы и нажимать на клавишу Delete.

Вариант 1.

1) Запустите редактор реестра: Win   + R → regedit → ОК
2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
3) Создайте в ней раздел DeleteFolderContent
4) Создайте в нем строковый(String) параметр MUIVerb со строкой Удалить содержимое папки.
5) В разделе DeleteFolderContent создайте подраздел command
6) Измените значение параметра (По умолчанию) раздела command на следующее:

Вариант 2.

1) Запустите редактор реестра: Win   + R → regedit → ОК
2) Откройте ветку реестра HKEY_CLASSES_ROOT\Directory\shell
3) Создайте в ней раздел Удалить содержимое папки
4) В разделе Удалить содержимое папки создайте подраздел command
6) Измените значение параметра (По умолчанию) раздела command на следующее:

Вариант 3.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Вы можете скачать готовые reg-файлы: DeleteFolderContent.zip Перейти к началу Общего списка советов.


7. Добавление пунктов "Копировать в папку" и "Переместить в папку" в контекстное меню.

По какой-то неизвестной причине, разработчики Microsoft решили не включать в контекстное меню Проводника пункты Копировать в папку (Copy To) и Переместить в папку (Move To). Используя их, можно легко и быстро скопировать или переместить файл или папку. Для этого, достаточно выбрать желаемое место их размещения в соответствующем диалоговом окне. Для того, чтобы добавить эти команды в контекстное меню, достаточно создать, соответствующие им параметры в реестре.

Вариант 1

1) Запустите Редактор Реестра (нажмите копку «Пуск» (Start), введите regedit в строке «Найти программы и файлы» и нажмите Enter ↵).
2) Откройте ветку реестра HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers
3) Создайте в ней раздел со следующим именем (включая фигурные скобки):
Для добавления в контекстное меню пункта Копировать в папку

Для добавления в контекстное меню пункта Переместить в папку

4) Нажмите Enter ↵
5) Перезагрузите Проводник (Windows Explorer) или перезайдите в систему, и данные пункты появятся в контекстном меню.

Вариант 2

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "DeleteFolderContent.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
5) Примените созданный reg-файл и перезапустите компьютер.


8. Добавление своего ярлыка папки или программы в папку Компьютер.

Если Вы часто пользуйтесь какой-либо программой, то помимо добавления её значка на рабочий стол, Вы также можете добавить его в папку Компьютер. Поскольку скопировать напрямую или создать ярлык в данной папке нельзя, то предлагаю Вам решение, как это возможно осуществить.

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

2) Скачайте программу Microsoft Exchange Server GUID Generator
3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
4) Установите переключатель на значение Registry Format
5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
7) Вставьте вместо {GUID}, сгенерированный программой GUID.
Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {FF4A6226-C00B-409e-88A6-6C401C52BD98}
8) Замените значения "Наименование папки или программы", "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" на необходимые Вам.
Внимание! При указывании пути к иконке и файлу объекта слэш должен быть двойным.
Например, если путь к программе: C:\MyProgram\MyProgram.exe, то необходимо указать его как: C:\\MyProgram\\MyProgram.exe
Так как, чаще всего икона программы встроена в саму программу, то значения "Путь к иконке для ярлыка" и "Путь к папке или файлу программы" могут совпадать.
9) При добавлении ярлыка папки измените "Путь к иконке для ярлыка" на %SystemRoot%\\system32\\SHELL32.dll,4
А значение "Путь к папке или файлу программы" на explorer /n, /e, C:\\ВашаПапка
10) После указания всех необходимых значений, нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
10.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
10.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
11) Примените получившийся reg-файл.

Пример reg-файла для добавления программы WinDjView в папку Компьютер:

Пример reg-файла для добавления папки Downloads в папку Компьютер:

В итоге Вы получите тот же самый эффект, что был упомянут в совете 3 раздела "Твики Реестра - Дополнительная функциональность". Перейти к началу Общего списка советов.


9. Добавление в контекстное меню DLL- или OCX-файлов пунктов "Регистрация" и "Отмена регистрации".

Если вам часто приходится работать с ocx-файлами или с dll-файлами, которые требуют регистрации в реестре с помощью Regsvr32.exe, то будет гораздо удобнее внести соответствующую запись в реестр, чем каждый раз использовать командную строку для каждого файла.

Запустите редактор реестра (Win   + R → regedit → ОК )

Создание пункта "Регистрация" в меню DLL- или OCX-файлов.

1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
2) Создайте раздел Регистрация, а в нем подраздел command
3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Регистрация\command и HKEY_CLASSES_ROOT\dllfile\Shell\Регистрация\command присвойте строковому параметру По умолчанию значение: regsvr32.exe "%1"

Создание пункта "Отмена регистрации" в меню DLL- или OCX-файлов.

1) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell и HKEY_CLASSES_ROOT\dllfile\Shell
2) Создайте раздел Отмена регистрации, а в нем подраздел command
3) В ветках реестра HKEY_CLASSES_ROOT\ocxfile\Shell\Отмена регистрации\command и HKEY_CLASSES_ROOT\dllfile\Shell\Отмена регистрации\command присвойте строковому параметру По умолчанию значение: regsvr32.exe /u "%1"

Теперь при нажатии правой кнопкой мыши на DLL- или OCX-файле, в меню появятся пункты "Регистрация" и "Отмена регистрации".

Также Вы можете создать reg-файл следующего содержания или скачать готовый Dll_Ocx_register-unregister.reg


10. Увеличение кэша памяти яў вида папок.

Можно увеличить количество папок, для которых Windows будет запоминать настройки вида.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
3) Создайте параметр DWORD BagMRU Size и присвоить ему десятичное значение, например, 20000.

Также Вы можете создать reg-файл.

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: " folder_cache.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.


11. Добавление опций "Выполнить", "Поиск" и "Очистить корзину" в контекстное меню рабочего стола.

Для быстрого доступа к необходимой Вам системной опции, Вы можете добавить её в контекстное меню рабочего стола. Чтобы это осуществить, Вам необходимо создать и применить reg-файл следующего содержания.

Добавление пункта Выполнить для вызова одноименного диалогового меню.

Добавление пункта Поиск для вызова одноименного окна.

Добавление пункта Очистить корзину.

Архив с готовыми reg-файлами Вы можете скачать по ссылке: RunSearchRecycleBinContextMenu.zip Перейти к началу Общего списка советов.


12. Создание меню с ярлыками избранных приложений в контекстном меню рабочего стола.

Вариант 1.

Добавление ссылок на избранные программы в контекстное меню рабочего стола Windows сводится к двум частям:

Часть 1. Создание каскадных меню в контекстном и добавление ярлыков.
Часть 2. Добавление функциональности ярлыкам путем их регистрации.

Часть 1. Создание контекстных меню и добавление ярлыков.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте ветку HKEY_CLASSES_ROOT\DesktopBackground\Shell
3) Создайте в данной ветке новый раздел. Нажмите правой кнопкой мыши на ключе "Shell" и выберите "Создать → Раздел". (Например, Menu1)
4) Выберите только что созданный раздел "Menu1" и в правой части окна создайте 4 строковых параметра:

Icon - в значении данного параметра следует указать путь к значку меню.
Position - данный параметр определяет позицию каскадного меню в контекстном. По умолчанию это середина контекстного меню, но Вы можете выбрать значения Top (сверху) или Bottom (снизу).
MUIVerb - имя каскадного меню, которое будет отображаться в контекстном меню. Например, "Мои программы", "Браузеры" и т.д.
SubCommands - содержит список команд, разделенных точкой с запятой (;). Эти команды будут показаны в каскадном меню. Вы не можете напрямую добавить ярлык приложения. Сначала в этом списке Вам нужно дать команде имя, а после этого зарегистрировать ее согласно инструкции во второй части статьи.

Предположим, что Вы уже создали каскадное меню "Браузеры", и теперь Вы хотите добавить в него ярлыки Internet Explorer и Mozilla Firefox. В таком случае Вам нужно параметру SubCommands задать значение:

Параметры Icon и Position Вы можете и не создавать, а вот MUIVerb и SubCommands — обязательны.

Часть 2. Добавление функциональности ярлыкам путем их регистрации.

Как только Вы добавите ярлыки программ в каскадное меню, Вам необходимо будет их зарегистрировать следующим образом:

1) Откройте ветку HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\Shell
2) Создайте для каждой из команд, указанных ранее в строковом параметре SubCommands, собственный одноименный раздел. В нашем примере мы использовали две команды: firefox и iexplore, поэтому нам нужно создать два раздела с такими же именами.
3) Выберите созданный раздел и в правой части окна редактора реестра задайте параметру Default (По умолчанию) имя, которые Вы хотите видеть в каскадном меню. Например, введите сюда Internet Explorer (для раздела iexplore) или Mozilla Firefox (для раздела firefox).
4) Если Вы хотите добавить ярлыку иконку, создайте новый строковой параметр с именем Icon и установите его значением путь к EXE файлу приложения или любой другой иконке.
Например, чтобы показать иконку Internet Explorer, Вы должны задать параметру Icon значение C:\Program Files\Internet Explorer\iexplore.exe
5) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
Выберите его и в правой части окна установите значением Default (По умолчанию) путь к EXE-файлу необходимой программы. Например, если ярлык должен открывать Internet Explorer, то должно быть установлено значение C:\Program Files\Internet Explorer\iexplore.exe

Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

Чтобы удалить созданное данным образом каскадное меню, необходимо удалить созданные разделы.

Вариант 2.

1) Создайте в ветке реестра HKEY_CLASSES_ROOT\DesktopBackground\Shell раздел с именем Вашего меню (Например, Menu1) и параметрами:

2) Укажите в параметре Icon путь к иконке для меню, а в параметре MUIVerb - имя каскадного меню.
3) Параметр SubCommands оставьте пустым.
4) Создайте в ветке Вашего меню раздел shell. (Например: HKEY_CLASSES_ROOT\DesktopBackground\Shell\Menu1\shell).
5) Создайте в данном разделе shell для каждого пункта меню собственный раздел. Пункты в полученном меню будут отсортированы по названию данных разделов.
Чтобы изменить расположение пункта в меню, указывайте его порядковый номер: 01, 02 и так далее до 16. Максимальное число пунктов одном каскадном меню, включая его подменю не может быть более 16.
Например, чтобы добавить пункты: firefox и iexplore, создайте два раздела с такими же именами.
6) Выберите созданный раздел и измените значение параметра По умолчанию на имя, которые Вы хотите видеть в каскадном меню.
Например, укажите Internet Explorer для раздела 01.iexplore и Mozilla Firefox для раздела 02.firefox.
7) Если Вы хотите добавить ярлыку иконку, создайте новый строковой параметр с именем Icon и установите его значением путь к EXE файлу приложения или любой другой иконке.
Например, чтобы показать иконку Internet Explorer, Вы должны задать параметру Icon значение C:\Program Files\Internet Explorer\iexplore.exe
8) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
9) Измените значение параметра По умолчанию на путь к EXE-файлу необходимой программы. Например, для открытия Internet Explorer установлено значение C:\Program Files\Internet Explorer\iexplore.exe Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

Главным плюсом данного метода является то, что все пункты меню расположены в папках одного раздела.
А чтобы удалить меню целиком Вам не надо удалять разделы отвечающие за отдельные пункты меню.
Достаточно удалить начальный раздел реестра.

Вариант 3.

1) Создайте в ветке реестра HKEY_CLASSES_ROOT\DesktopBackground\Shell раздел с именем Вашего меню (Например, Menu1) и параметрами:

2) Укажите в параметре Icon путь к иконке для меню, а в параметре MUIVerb - имя каскадного меню.
3) В параметре ExtendedSubCommandsKey укажите путь к папке shell в разделе HKEY_CLASSES_ROOT, где находятся пункты Вашего меню. (Например: DesktopBackground\\ContextMenus\\Menu1 для раздела HKEY_CLASSES_ROOT\DesktopBackground\ContextMenus\Menu1\shell
4) Откройте (создайте) ветку реестра путь к которой Вы указали в параметре ExtendedSubCommandsKey и создайте для каждого пункта меню собственный раздел.
5) Измените в созданных разделах значения параметров По умолчанию на имена, которые Вы хотите видеть для каждого пункта в каскадном меню.
6) В каждом из только что созданных разделов создайте новый раздел и назовите его command.
7) Измените значение параметра По умолчанию на путь к EXE-файлу необходимой программы. Готовый reg-файл контекстное меню рабочего стола (из описанного примера):

Чтобы удалить созданное данным образом каскадное меню, необходимо удалить созданные разделы.


13. Ускорение запуска Windows и выключения компьютера.

Если Вы желаете снизить время, затрачиваемое на запуск Windows и/или на выключение компьютера, то создайте и примените reg-файл указанного ниже содержания:

Значения используемых в данном reg-файле параметров:

AutoEndTasks = Автоматическое завершение зависших приложений.
HungAppTimeout = Определяет интервал времени (в миллисекундах), в течение которого программа должна ответить на запрос системы. Если в течение этого времени программа не ответила на запрос, то она считается зависшей.
LinkResolveIgnoreLinkInfo = Отключение проверки сопоставления ярлыков программам (Каждый раз при загрузке Windows, происходит проверка пути в ярлыках, которые находятся на рабочем столе, и если система не находит программу по указанному в ярлыке пути, то начинает вести ее поиск.)
LowLevelHooksTimeout = Время ожидания перехватчика событий для обработки команд перед завершением работы Windows. (Например: для перехвата нажатий клавиш клавиатуры или мыши.)
NoInternetOpenWith = Указывает, следует ли использовать веб-службы Microsoft для поиска приложений, чтобы открыть файлы с необработанными файловыми ассоциа ми.
NoLowDiskSpaceChecks = Отключение проверки доступного свободного места на диске.
NoResolveSearch = Запрещает системе осуществлять поиск целевого устройства по его ярлыку.
NoResolveTrack = Блокирует функциональные возможности системы по отслеживанию NTFS, при поиске целевых файлов ярлыков оболочки;
WaitToKillAppTimeout = Указывает интервал времени (в миллисекундах), в течение которого программа должна закончить свою работу при завершении работы операционной системы. Если программа не завершит свою работу в течение указанного интервала времени, то она будет завершена автоматически. При этом все несохранённые данные будут утеряны.
WaitToKillServiceTimeout = Определяет интервал времени (в миллисекундах) в течение которого служба должна закончить свою работу при завершении работы операционной системы.

Также Вы можете скачать архив Speed_up_Win7.zip с готовыми reg-файлами и применить нужный Вам:

Speed_up_Win7.reg - файл, содержащий указанные выше параметры для настройки системы.
Undo_Speed_up_Win7.reg - файл, устанавливающий значение параметров по умолчанию.


14. Ускорение анимации всплывающего меню в меню Пуск.

Если Вы желаете изменить время задержки до показа всплывающего меню в меню Пуск, проделайте следующее:

1)Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
3) Создайте в нем(или измените) параметр MenuShowDelay
4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
6) Выберите желательное значение от 1 до 4000, означающее задержку в миллисекундах, до показа всплывающего меню в меню Пуск.
7) Закройте regedit и перезагрузите систему.

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Дополнительная функциональность.


15. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows (реестр).

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Запустите редактор реестра (Нажмите Win   + R, введите команду regedit.exe и нажмите Ок)
2) Пройдите по следующему пути: HKEY_CURRENT_USER\Control Panel\Accessibility
3) Измените значение параметра MessageDuration.

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Дополнительная функциональность.


16. Настройка параметров всплывающих эскизов окон в панели задач.

Изменив несколько настроек в реестре Вы сможете придать своим всплывающим эскизам окон больше эффективности в работе.

1) Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Создайте в нем(или измените) параметры:

ExtendedUIHoverTime - Задержка до появления всплывающего эскиза окна на экране, после наведения курсора мыши на иконку в панели задач.
ThumbnailLivePreviewHoverTime - Задержка до появления окна программы, после наведения курсора мыши на всплывший эскиз окна.

4) Для создания щелкните правой кнопкой мыши, выберите пункт Создать, и выберите параметр DWORD (32-bit).
5) Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
6) В графе Система исчисления установите значение параметра на Десятич.
7) Введите необходимое Вам значение. Значение 1000 = 1 секунде.

8) Откройте в реестре раздел: HKEY_CLASSES_ROOT\SystemFileAssociations\image
9) Сделайте двойной щелчок на параметре Treatment - Данный параметр изменяет вид бордюра всплывающего эскиза окна.
10) Выберите необходимое Вам значение:

0 - Без бордюра
1 - Бордюр с тенью
2 - Фоторамка (по умолчанию)
3 - Видеорамка

11) Закройте regedit и перезагрузите систему. Перейти к началу Общего списка советов.


17. Настройка скорости отображения рабочего стола при наведении курсора мыши в угол экрана.

Когда Вы наводите курсор на крайнюю кнопку, находящуюся за часами на панели задач (обычно правый нижний угол экрана), система показывает Вам рабочий стол. При желании Вы можете ускорить или замедлить данный процесс.

1) Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) Измените значение параметра DesktopLivePreviewHoverTime. Для изменения, щелкните правой кнопкой мыши на параметре, выберите пункт Изменить
4) В графе Система исчисления установите значение параметра на Десятич.
5) Введите необходимое Вам значение. Значение 1000 = 1 секунде.
6) Закройте regedit, перезайдите в систему или перезагрузите систему.

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Дополнительная функциональность.


18. Добавление кнопки запуска необходимой программы на панель Проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели Проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
Для добавления кнопки запуска необходимой программы во все папки Проводника - добавьте кнопку во все шаблоны.

Все шаблоны хранятся в разделах следующей ветки реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для добавления кнопки запуска необходимой программы сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра необходимого Вам шаблона.
Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5c4f28b5-f869-4e84-8e60-f11db97c5cc7}

А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{5f4eab9a-6833-4f61-899d-31cf46979d49}

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать → Раздел.)

TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {422299D4-C2DD-4e24-AAAB-FED22CC8E8DE})
7.1) Скачайте и распакуйте архив GUIDGen.zip
7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

Title – определяет название кнопки
InfoTip – определяет название всплывающей подсказки к кнопке

9) В разделе с уникальным GUID последовательно создайте подразделы:

shell
InvokeTask
command

10) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к программе, которую Вы хотите запустить.

Примечание:

Если Вы добавляете программу для открытия в ней файлов, то после указания пути к программе добавьте параметр %*
Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1).
Если Вы добавляете программу которая должна просто запускаться, без открытия в ней файлов, то параметр добавлять не надо. Перейти к началу Общего списка советов.


19. Добавление кнопки "Открыть в текстовом редакторе" на панель Проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели Проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
Для добавления кнопки "Открыть в текстовом редакторе" во все папки Проводника - добавьте кнопку во все шаблоны.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для добавления кнопки "Открыть в текстовом редакторе" сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра необходимого Вам шаблона.
Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Документы» откройте:

А для добавления кнопки в папку ««Документы»», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать → Раздел.)

TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {433399D4-C2DD-4e24-AAAB-FED22CC8E8DE})
7.1) Скачайте и распакуйте архив GUIDGen.zip
7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

Title – определяет название кнопки
InfoTip – определяет название всплывающей подсказки к кнопке

9) В разделе с уникальным GUID последовательно создайте подразделы:

shell
InvokeTask
command

10) Скачайте файл архив со скриптом texteditor.zip и распакуйте его в любую папку. (Например: C:\Scripts)

10.1) Вы можете создать его самостоятельно. Для этого скопируйте нижеследующий текст в текстовый редактор и сохраните файл с именем texteditor и расширением *.js .

11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту:

Примечание:

Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1). Перейти к началу Общего списка советов.


20. Добавление кнопок "Копировать в папку" и "Переместить в папку" на панель Проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели Проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок.
Для добавления кнопок "Копировать в папку" и "Переместить в папку" во все папки Проводника - добавьте кнопки во все шаблоны.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для добавления кнопок "Копировать в папку" и "Переместить в папку" сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра необходимого Вам шаблона.
Например: для добавления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

А для добавления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

4.1) Откройте необходимый из указанных подразделов, если Вы добавляете кнопку в шаблоны Библиотек и/или в шаблонах поиска результатов в них.
4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать → Раздел.)

TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Удалить.
Выполняя данное действие Вы отказываетесь от набора стандартных кнопок, но позволяете использовать произвольные кнопки.

6) В разделе TasksItemsSelected создайте подраздел с именем 0. Он будет содержать в себе параметры первой кнопки (отсчет начинается с нуля), все последующие кнопки должны создаваться в разделах 1, 2, и т.д.

7) В разделе 0 создайте подраздел с уникальным GUID. (Например: {455599D4-C2DD-4e24-AAAB-FED22CC8E8DE})
7.1) Скачайте и распакуйте архив GUIDGen.zip
7.2) Запустите программу GUIDGEN.EXE, установите переключатель на Registry Format и нажмите кнопку New GUID, а затем Copy.

8) Щелкните созданный раздел с уникальным GUID и создайте в нем два строковых параметра:

Title – определяет название кнопки
InfoTip – определяет название всплывающей подсказки к кнопке

9) В разделе с уникальным GUID последовательно создайте подразделы:

shell
InvokeTask
command

10) Скачайте файл архив со скриптом ExplorerBarUtilities.zip и распакуйте его в любую папку. (Например: C:\Scripts)

11) В разделе command дважды щелкните параметр (По умолчанию) и измените его значение на путь к скрипту: Для создания кнопки "Копировать в папку" измените значение на:

Для создания кнопки "Переместить в папку" измените значение на:

Примечание:

Параметр %* указывает программе, что необходимо использовать одновременно несколько параметров: путь к отображаемой папке(%0) и путь к выделенному объекту(%1). Перейти к началу Общего списка советов.


21. Добавление собственной папки в Рабочий стол области переходов Проводника.

Если Вы часто пользуйтесь какой-либо папкой, то Вы можете добавить ее в Рабочий стол области переходов Проводника. Поскольку копирование папки напрямую или создание ярлыка на рабочем столе не добавляет её в область переходов, то предлагаю Вам решение, как это возможно осуществить.

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот):

2) Скачайте программу Microsoft Exchange Server GUID Generator
3) Распакуйте архив и запустите программу (GUIDGEN.EXE)
4) Установите переключатель на значение Registry Format
5) Нажмите на кнопку New GUID, и программа сгенерирует Вам новый GUID
6) Нажмите на кнопку Copy, и программа скопирует его в буфер обмена
7) Вставьте вместо {GUID}, сгенерированный программой GUID.
Теперь у Вас вместо {GUID}, должен быть цифровой идентификатор, например: {1a51a488-17d4-4169-a212-a2cf152268b6}
8) Замените значения "Название папки" и "Путь к папке" на необходимые Вам.
Внимание! При указывании пути к папке слеш должен быть двойным.
Например, если путь к папке: C:\My Folder\Downloads, то необходимо указать его как: C:\\My Folder\\Downloads
9) После указания всех необходимых значений, нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
9.1) Если Вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "GUID.reg")
9.2) Если Вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
10) Примените получившийся reg-файл.

Пример reg-файла для добавления папки Downloads в Рабочий стол области переходов Проводника.


22. Скрытие апплетов отображаемых в Панели управления.

Существует много способов, чтобы скрыть элементы в Панели Управления. Ниже прив њтся, наиболее часто используемые.

1) Создайте reg-файл используя шаблон в одном из предложенных ниже вариантов.
2) Примените его.
3) Перезагрузите систему.

Вариант 1. Показать все кроме.

Созданный reg-файл позволяет Вам отобразить все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowCpl
Чтобы исключить определенные апплеты из Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
Имена параметров должны быть - непрерывные номера начинающиеся с 1: 1, 2, 3, …
Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

Пример reg-файла для английской Windows:

Вариант 2. Скрыть все кроме.

Созданный reg-файл позволяет Вам скрыть все апплеты в Панели управления, исключая те которые добавлены в ветку: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictCpl
Чтобы отобразить определенные апплеты в Панели управления, создайте в данном разделе строковые параметры (REG_SZ).
Имена параметров должны быть непрерывные - номера начинающиеся с 1: 1, 2, 3, …
Значения - имя апплета точно таким же, как оно отображается в Панели Управления в зависимости от выбранного языка интерфейса. Пример reg-файла для русской Windows:

Пример reg-файла для английской Windows:

Русское название элемента | Английское название элемента
Windows CardSpace | Windows CardSpace
Windows SideShow | Windows SideShow
Автозапуск | AutoPlay
Автономные файлы | Offline Files
Администрирование | Administrative Tools
Архивация и восстановление | Backup and Restore
Биометрические устройства | Biometric Devices
Брандмауэр Windows | Windows Firewall
Восстановление | Recovery
Гаджеты рабочего стола | Desktop Gadgets
Дата и Время | Date and Time
Датчик расположения и другие датчики | Location and Other Sensors
Диспетчер устройств | Device Manager
Диспетчер учетных данных | Credential Manager
Домашняя группа | HomeGroup
Защитник Windows | Windows Defender
Звук | Sound
Значки области уведомлений | Notification Area Icons
Игровые устройства | Game Controllers
Инфракрасная связь | Infrared
Клавиатура | Keyboard
Мышь | Mouse
Панель задач и меню ''Пуск'' (кавычки два раза одинарные) | Taskbar and Start Menu
Параметры индексирования | Indexing Options
Параметры папок | Folder Options
Параметры планшетного компьютера | Tablet PC Settings
Перо и сенсорные устройства | Pen and Touch
Персонализация | Personalization
Подключения к удаленным рабочим столам и приложениям RemoteApp | Remote Desktop Connection
Получение программ | Get Programs
Приступая к работе | Getting Started
Программы и компоненты | Programs and Features
Программы по умолчанию | Default Programs
Распознавание речи | Speech Recognition
Расположение по умолчанию | Default Location
Родительский контроль | Parental Controls
Свойства обозревателя | Internet Options
Система | System
Сканеры и камеры | Scanners and Cameras
Счетчики и средства производительности | Performance Information and Tools
Телефон и модем | Phone and Modem
Управление цветом | Color Management
Устранение неполадок | Troubleshooting
Устройства и принтеры | Devices and Printers
Учетные записи пользователей | User Accounts
Центр мобильности Windows | Windows Mobility Center
Центр обновления Windows | Windows Update
Центр поддержки | Action Center
Центр синхронизации | Sync Center
Центр специальных возможностей | Ease of Access Center
Центр управления сетями и общим доступом | Network and Sharing Center
Шифрование диска BitLocker | BitLocker Drive Encryption
Шрифты | Fonts
Экран | Display
Электропитание | Power Options
Язык и региональные стандарты | Region and Language
Русское название элемента | Английское название элемента


23. Увеличение пространства, отведенного в NTFS для главной таблицы файлов.

В ядре файловой системы NTFS содержится файл, который называется главной таблицей файлов (MFT). MFT (Master File Table) — главная файловая таблица (база данных), в которой хранится информация о содержимом тома с файловой системой NTFS, представляющая собой таблицу, строки которой соответствуют файлам тома, а столбцы — атрибутам файлов.
Поскольку средства дефрагментации томов NTFS не могут перемещать записи MFT, а также из-за того, что значительная фрагментация MFT может негативно влиять на быстродействие системы, NTFS резервирует для MFT дисковое пространство, чтобы по мере увеличения размера MFT подвергался минимальной фрагментации.
По мере появления новых файлов в томе NTFS в файл MFT добавляются новые записи, и, таким образом, размер MFT увеличивается. При удалении файлов из тома NTFS соответствующие записи в файле MFT помечаются как свободные и могут использоваться повторно, однако размер MFT при этом не сокращается. Таким образом, дисковое пространство, используемое этими записями, остается недоступным.
При переполнении зоны MFT пространство для новых записей MFT начинает выделяться из незарезервированного дискового пространства, что снова приводит к фрагментации MFT.

Существует параметр реестра, позволяющий увеличить (зарезервировать) пространство, отведенное в NTFS для основной таблицы файлов. Для его добавления выполните следующие действия:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem
3) В меню Правка выберите Создать → Параметр DWORD (32 бита).
4) Задайте имя параметра NtfsMftZoneReservation
5) Дважды щелкните на данном параметре и введите необходимое Вам значение от 1 до 4.
6) Закройте редактор реестра и перезапустите компьютер.

Если на ваших разделах NTFS мало файлов, но они большого размера, то наилучшим значением созданного параметра будет 1.
Если у Вас среднее количество файлов на диске, то оптимальным значением является 2, если же их большое количество, то значение 3.
Значение 4 (максимальное значение) следует использовать только в случае, если у вас на диске очень большое количество файлов. Перейти к началу Общего списка советов.


24. Увеличение процессорного времени, выделяемого программе, работающей на переднем плане.

Для начала убедитесь, что параметр Распределение времени процессора настроен на оптимизацию работы программ. Для этого:

1) Откройте меню Пуск
2) Нажмите правой кнопкой мыши на пункт Компьютер и выберите Свойства
3) В списке слева нажмите на ссылку Дополнительные параметры системы
4) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
5) Откройте вкладку Дополнительно и в разделе Распределение времени процессора установите переключатель в значение: программ.

Теперь Вам необходимо изменить количество квантов выделяемых программе, работающей на переднем плане.
Квантом называется единица процессорного времени, выделяемая конкретной программе для работы. По истечении квантов, выделенных одной программе, управление будет передано другой программе, ожидающей в очереди (а программа, которая только что работала, будет помещена в конец очереди) — и эта программа будет работать до тех пор, пока не истекут кванты, выделенные для нее. После этого управление перейдет следующей программе из очереди.
Особенностью Windows является увеличенное количество квантов, которое выделяется программе, работающей в данный момент на переднем плане. То есть, программа переднего плана будет работать быстрее всех программ, работающих в данный момент в фоновом режиме.
Так реализована многозадачность операционной системы Windows.

Для изменения количества квантов, выделяемых программе, работающей на переднем плане, сделайте следующее:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\PriorityControl
3) Дважды щелкните на DWORD-параметре Win32PrioritySeparation и введите необходимое Вам значение.
4) Закройте редактор реестра и перезапустите компьютер.

По умолчанию значение равно 2.
Максимальное значение равно 26 в шестнадцатеричной системе исчисления или 38 в десятичной системе.
Необходимое Вам значение выясняется экспериментальным путем.
Не ставьте сразу большое значение, постепенно увеличивайте значение пока не найдете оптимальное.
Например: На одних машинах улучшения в работе системы с программами будут видны при максимальном значении 26, на других же оптимальным значением может оказаться 12.


25. Отключение выгрузки драйверов режима ядра и системного кода режима ядра из оперативной памяти на диск.

Если у Вас на компьютере большое количество оперативной памяти, то приложения будут быстрее откликаться на Ваши действия, если драйвера режима ядра и системный код режима ядра будут оставаться в оперативной памяти.

За данное действие отвечает параметр реестра DisablePagingExecutive, который определяет, могут ли драйвера режима ядра и системный код режима ядра быть выгружены из оперативной памяти на диск, когда они не используется.

Значение 0 указывает, что при необходимости драйвера режима ядра и системный код режима ядра могут быть выгружены из оперативной памяти на диск, когда они не используется.
Значение 1 указывает, что драйвера режима ядра и системный код режима ядра должны оставаться в оперативной памяти.

Для изменения данного параметра сделайте следующее:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
3) Дважды щелкните на параметре DisablePagingExecutive и введите значение 1.
4) Закройте редактор реестра и перезапустите компьютер.

Если же у Вас такой параметр отсутствует, то создайте в данном разделе реестра DWORD-параметр с указанным именем и значением. Перейти к началу Общего списка советов.


26. Удаление пункта "Восстановить прежнюю версию" из контекстного меню Проводника.

Чтобы удалить пункт "Восстановить прежнюю версию" из контекстного меню Проводника, сделайте следующее:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\
3) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
4) Откройте раздел реестра: HKEY_CLASSES_ROOT\Directory\shellex\ContextMenuHandlers\
5) Удалите раздел {596AB062-B4D2-4215-9F74-E9109B0A8153}
6) Закройте все процессы Проводника и запустите его заново или перезайдите в систему. Перейти к началу Общего списка советов.


27. Переименование Панели управления в области переходов и на рабочем столе.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра, соответствующий местонахождению Панели управления, которую Вы желаете переименовать.

Панель управления в Области переходов: HKEY_CLASSES_ROOT\CLSID\{26EE0668-A00A-44D7-9371-BEB064C98683}
Панель управления на Рабочем столе: HKEY_CLASSES_ROOT\CLSID\{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}

3) Задайте полный доступ к данному разделу реестра.
3.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел {длинное число} и выберите пункт Разрешения.
3.2) Нажмите кнопку Дополнительно.
3.3) Перейдите на вкладку Владелец.
3.4) Выберите Ваш аккаунт администратора и нажмите ОК.
3.5) Вверху выберите группу Администраторы (Administrators).
3.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

4) Щелкните правой кнопкой мыши на параметре LocalizedString и выберите пункт Изменить.
5) Введите любое значение вместо имеющегося, соответствующее названию, которое Вы желаете задать и нажмите ОК.
6) Закройте редактор реестра и перезагрузите компьютер.

Примечание: Для восстановления значения по умолчанию измените значение параметра LocalizedString на указанное ниже:


28. Переименование папки Избранное в области переходов.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}

3) Задайте полный доступ к данному разделу реестра.
3.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел {323CA680-C24D-4099-B94D-446DD2D7249E} и выберите пункт Разрешения.
3.2) Нажмите кнопку Дополнительно.
3.3) Перейдите на вкладку Владелец.
3.4) Выберите Ваш аккаунт администратора и нажмите ОК.
3.5) Вверху выберите группу Администраторы (Administrators).
3.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

4) Щелкните правой кнопкой мыши на параметре LocalizedString и выберите пункт Изменить.
5) Введите любое значение вместо имеющегося, соответствующее названию, которое Вы желаете задать и нажмите ОК.
6) Закройте редактор реестра и перезагрузите компьютер.

Примечание: Для восстановления значения по умолчанию измените значение параметра LocalizedString на указанное ниже:


29. Переименование папки Сеть в области переходов.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}

3) Задайте полный доступ к данному разделу реестра.
3.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел {F02C1A0D-BE21-4350-88B0-7367FC96EF3C} и выберите пункт Разрешения.
3.2) Нажмите кнопку Дополнительно.
3.3) Перейдите на вкладку Владелец.
3.4) Выберите Ваш аккаунт администратора и нажмите ОК.
3.5) Вверху выберите группу Администраторы (Administrators).
3.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

4) Щелкните правой кнопкой мыши на параметре LocalizedString и выберите пункт Изменить.
5) Введите любое значение вместо имеющегося, соответствующее названию, которое Вы желаете задать и нажмите ОК.
6) Закройте редактор реестра и перезагрузите компьютер.

Примечание: Для восстановления значения по умолчанию измените значение параметра LocalizedString на указанное ниже:


30. Изменение иконки Панели управления.

Вариант 1. Изменение иконки Панели управления для текущего пользователя.

1) Создайте и примените reg-файл указанного ниже содержания:

2) Запустите редактор реестра (Win   + R → regedit → ОК)
3) Откройте раздел реестра, соответствующий местонахождению Панели управления, для которой Вы желаете изменить значок.

Панель управления в Области переходов:

Панель управления в меню Пуск и на Рабочем столе:

4) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите пункт Изменить.
5) Укажите путь к иконке, которую Вы желаете задать и нажмите ОК.
Если Вы собираетесь использовать собственную иконку, то Вам потребуется иконка размером 256x256 пикселей, сделанная для Windows 7 и поддерживающая все возможные для отображения размеры.
Если же Вы собираетесь использовать иконку из имеющихся в Windows, то Вам необходимо указать полный путь к *.exe или dll-файлу в котором содержится иконка и ее номер в данном файле, используя следующий шаблон:

Например:

или

Наиболее простой способ быстро узнать номер значка - это воспользоваться программой IconViewer, которая добавляет дополнительную вкладку Icons в Свойства файла.
6) Закройте редактор реестра и перезагрузите компьютер.

Примечание: Для восстановления значения по умолчанию создайте и примените reg-файл указанного ниже содержания:

Вариант 2. Изменение иконки Панели управления для всех пользователей.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра, соответствующий местонахождению Панели управления, для которой Вы желаете изменить значок.

Панель управления в Области переходов:

Панель управления в меню Пуск и на Рабочем столе:

3) Задайте полный доступ к данному разделу реестра.
3.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел DefaultIcon и выберите пункт Разрешения.
3.2) Нажмите кнопку Дополнительно.
3.3) Перейдите на вкладку Владелец.
3.4) Выберите Ваш аккаунт администратора и нажмите ОК.
3.5) Вверху выберите группу Администраторы (Administrators).
3.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

4) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите пункт Изменить.
5) Укажите путь к иконке, которую Вы желаете задать и нажмите ОК.
Если Вы собираетесь использовать собственную иконку, то Вам потребуется иконка размером 256x256 пикселей, сделанная для Windows 7 и поддерживающая все возможные для отображения размеры.
Если же Вы собираетесь использовать иконку из имеющихся в Windows, то Вам необходимо указать полный путь к *.exe или dll-файлу в котором содержится иконка и ее номер в данном файле, используя следующий шаблон:

Например:

или

Наиболее простой способ быстро узнать номер значка - это воспользоваться программой IconViewer, которая добавляет дополнительную вкладку Icons в Свойства файла.
6) Закройте редактор реестра и перезагрузите компьютер.

Примечание: Для восстановления значения по умолчанию создайте и примените reg-файл указанного ниже содержания:


31. Изменение иконок элементов в Панели управления при просмотре как Крупные значки/Мелкие значки.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CLASSES_ROOT\CLSID
3) В соответствии с таблицей ниже, перейдите в раздел соответствующий элементу в Панели управления, значок для которого Вы желаете заменить.

Таблица 1.

Русское название элемента | Английское название элемента | Расположение CLSID в реестре
Windows CardSpace | Windows CardSpace | {78CB147A-98EA-4AA6-B0DF-C8681F69341C}\DefaultIcon
Windows SideShow | Windows SideShow | {E95A4861-D57A-4be1-AD0F-35267E261739}\DefaultIcon
Автозапуск | AutoPlay | {9C60DE1E-E5FC-40f4-A487-460851A8D915}\DefaultIcon
Администрирование | Administrative Tools | {D20EA4E1-3957-11d2-A40B-0C5020524153}\DefaultIcon
Архивация и восстановление | Backup and Restore | {B98A2BEA-7D42-4558-8BD1-832F41BAC6FD}\DefaultIcon
Биометрические устройства | Biometric Devices | {0142e4d0-fb7a-11dc-ba4a-000ffe7ab428}\DefaultIcon
Брандмауэр Windows | Windows Firewall | {4026492F-2F69-46B8-B9BF-5654FC07E423}\DefaultIcon
Восстановление | Recovery | {9FE63AFD-59CF-4419-9775-ABCC3849F861}\DefaultIcon
Гаджеты рабочего стола | Desktop Gadgets | {37efd44d-ef8d-41b1-940d-96973a50e9e0}\DefaultIcon
Дата и Время | Date and Time | {E2E7934B-DCE5-43C4-9576-7FE4F75E7480}\DefaultIcon
Датчик расположения и другие датчики | Location and Other Sensors | {E9950154-C418-419e-A90A-20C5287AE24B}\DefaultIcon
Диспетчер устройств | Device Manager | {74246bfc-4c96-11d0-abef-0020af6b0b7a}\DefaultIcon
Диспетчер учетных данных | Credential Manager | {1206F5F1-0569-412C-8FEC-3204630DFB70}\DefaultIcon
Домашняя группа | HomeGroup | {67CA7650-96E6-4FDD-BB43-A8E774F73A57}\DefaultIcon
Защитник Windows | Windows Defender | {D8559EB9-20C0-410E-BEDA-7ED416AECC2A}\DefaultIcon
Звук | Sound | {F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}\DefaultIcon
Значки области уведомлений | Notification Area Icons | {05d7b0f4-2121-4eff-bf6b-ed3f69b894d9}\DefaultIcon
Инфракрасная связь | Infrared | {A0275511-0E86-4ECA-97C2-ECD8F1221D08}\DefaultIcon
Клавиатура | Keyboard | {725BE8F7-668E-4C7B-8F90-46BDB0936430}\DefaultIcon
Мышь | Mouse Properties | {6C8EEC18-8D75-41B2-A177-8831D59D2D50}\DefaultIcon
Параметры индексирования | Indexing Options | {87D66A43-7B11-4A28-9811-C86EE395ACF7}\DefaultIcon
Параметры папок | Folder Options | {6DFD7C5C-2451-11d3-A299-00C04F8EF6AF}\DefaultIcon
Параметры планшетного компьютера | Tablet PC Settings | {80F3F1D5-FECA-45F3-BC32-752C152E456E}\DefaultIcon
Перо и сенсорные устройства | Pen and Touch | {F82DF8F7-8B9F-442E-A48C-818EA735FF9B}\DefaultIcon
Персонализация | Personalization | {ED834ED6-4B5A-4bfe-8F11-A626DCB6A921}\DefaultIcon
Подключения к удаленным рабочим столам и приложениям RemoteApp | RemoteApp and Desktop Connections | {241D7C96-F8BF-4F85-B01F-E2B043341A4B}\DefaultIcon
Приступая к работе | Getting Started | {CB1B7F8C-C50A-4176-B604-9E24DEE8D4D1}\DefaultIcon
Программы и компоненты | Programs and Features | {7b81be6a-ce2b-4676-a29e-eb907a5126c5}\DefaultIcon
Программы по умолчанию | Default Programs | {17cd9488-1228-4b2f-88ce-4298e93e0966}\DefaultIcon
Распознавание речи | Speech Recognition | {58E3C745-D971-4081-9034-86E34B30836A}\DefaultIcon
Родительский контроль | Parental Controls | {96AE8D84-A250-4520-95A5-A47A7E3C548B}\DefaultIcon
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | {0DF44EAA-FF21-4412-828E-260A8728E7F1}\DefaultIcon
Свойства обозревателя | Internet Properties | {A3DD4F92-658A-410F-84FD-6FBBBEF2FFFE}\DefaultIcon
Система | System | {BB06C0E4-D293-4f75-8A90-CB05B6477EEE}\DefaultIcon
Счетчики и средства производительности | Performance Information and Tools | {78F3955E-3B90-4184-BD14-5397C15F1EFC}\DefaultIcon
Телефон и модем | Phone and Modem | {40419485-C444-4567-851A-2DD7BFA1684D}\DefaultIcon
Управление цветом | Color Management | {B2C761C6-29BC-4f19-9251-E6195265BAF1}\DefaultIcon
Устранение неполадок | Troubleshooting | {C58C4893-3BE0-4B45-ABB5-A63E4B8C8651}\DefaultIcon
Устройства Bluetooth | Bluetooth Devices | {28803F59-3A75-4058-995F-4EE5503B023C}\DefaultIcon
Устройства и принтеры | Devices and Printers | {A8A91A66-3A7D-4424-8D24-04E180695C7A}\DefaultIcon
Учетные записи пользователей | User Accounts | {60632754-c523-4b62-b45c-4172da012619}\DefaultIcon
Центр мобильности Windows | Windows Mobility Center | {5ea4f148-308c-46d7-98a9-49041b1dd468}\DefaultIcon
Центр обновления Windows | Windows Update | {36eef7db-88ad-4e81-ad49-0e313f0c35f8}\DefaultIcon
Центр поддержки | Action Center | {BB64F8A7-BEE7-4E1A-AB8D-7D8273F7FDB6}\DefaultIcon
Центр синхронизации | Sync Center | {9C73F5E5-7AE7-4E32-A8E8-8D23B85255BF}\DefaultIcon
Центр специальных возможностей | Ease of Access Center | {D555645E-D4F8-4c29-A827-D93C859C4F2A}\DefaultIcon
Центр управления сетями и общим доступом | Network and Sharing Center | {8E908FC9-BECC-40f6-915B-F4CA0E70D03D}\DefaultIcon
Шифрование диска BitLocker | BitLocker Drive Encryption | {D9EF8727-CAC2-4e60-809E-86F80A666C91}\DefaultIcon
Шрифты | Fonts | {BD84B380-8CA2-1069-AB1D-08000948F534}\DefaultIcon
Экран | Display | {C555438B-3C23-4769-A71F-B6D3D9B6053A}\DefaultIcon
Электропитание | Power Options | {025A5937-A6BE-4686-A844-36FE4BEC8B6D}\DefaultIcon
Язык и региональные стандарты | Region and Language | {62D8ED13-C9D0-4CE8-A914-47DD628FB1B0}\DefaultIcon
Русское название элемента | Английское название элемента | Расположение CLSID в реестре

4) Задайте полный доступ к данному разделу реестра.
4.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел DefaultIcon и выберите пункт Разрешения.
4.2) Нажмите кнопку Дополнительно.
4.3) Перейдите на вкладку Владелец.
4.4) Выберите Ваш аккаунт администратора и нажмите ОК.
4.5) Вверху выберите группу Администраторы (Administrators).
4.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите пункт Изменить.
6) Укажите путь к иконке, которую Вы желаете задать и нажмите ОК.

Примечание: Вам потребуются иконки размером 256x256 пикселей, сделанные для Windows 7 и поддерживающие все возможные для отображения размеры.

Для восстановления иконки по умолчанию измените значение параметра (По умолчанию) на указанное ниже:

Таблица 2.

Русское название элемента | Английское название элемента | Значение параметра по умолчанию
Windows CardSpace | Windows Cardspace | %SystemRoot%\System32\icardres.dll,-4096
Windows SideShow | Windows SideShow | %SystemRoot%\System32\AuxiliaryDisplayCpl.dll,-1
Автозапуск | Autoplay | %SystemRoot%\System32\autoplay.dll,-1
Администрирование | Administrative Tools | %SystemRoot%\System32\imageres.dll,-114
Архивация и восстановление | Backup and Restore | %SystemRoot%\System32\sdcpl.dll,-1
Биометрические устройства | Biometric Devices | %SystemRoot%\System32\biocpl.dll,-1
Брандмауэр Windows | Windows Firewall | C:\Windows\system32\FirewallControlPanel.dll,-1
Восстановление | Recovery | %SystemRoot%\System32\imageres.dll,-1022
Гаджеты рабочего стола | Desktop Gadgets | %ProgramFiles%\Windows Sidebar\Sidebar.exe,-100
Дата и Время | Date and Time | %SystemRoot%\System32\timedate.cpl,-50
Датчик расположения и другие датчики | Location and Other Sensors | %SystemRoot%\System32\SensorsCpl.dll,-1
Диспетчер устройств | Device Manager | %SystemRoot%\system32\devmgr.dll,-201
Диспетчер учетных данных | Credential Manager | %SystemRoot%\system32\Vault.dll,-1
Домашняя группа | HomeGroup | %SystemRoot%\System32\imageres.dll,-1013
Защитник Windows | Windows Defender | %ProgramFiles%\Windows Defender\MsMpRes.dll,-103
Звук | Sound | %SystemRoot%\System32\mmsys.cpl,-100
Значки области уведомлений | Notification Area Icons | %SystemRoot%\System32\taskbarcpl.dll,-1
Инфракрасная связь | Infrared | %SystemRoot%\System32\irprops.cpl,-129
Клавиатура | Keyboard | %SystemRoot%\System32\main.cpl,-200
Мышь | Mouse | %SystemRoot%\system32\main.cpl,-100
Параметры индексирования | Indexing Options | %SystemRoot%\System32\srchadmin.dll,-201
Параметры папок | Folder Options | %SystemRoot%\system32\imageres.dll,-166
Параметры планшетного компьютера | Tablet PC Settings | %SystemRoot%\System32\tabletpc.cpl,-10200
Перо и сенсорные устройства | Pen and Touch | %SystemRoot%\System32\tabletpc.cpl,-10201
Персонализация | Personalization | %SystemRoot%\System32\themecpl.dll,-1
Подключения к удаленным рабочим столам и приложениям RemoteApp | RemoteApp and Desktop Connections | %SystemRoot%\System32\tsworkspace.dll
Приступая к работе | Getting Started | %SystemRoot%\branding\shellbrd\shellbrd.dll
Программы и компоненты | Programs and Features | imageres.dll,-87
Программы по умолчанию | Default Programs | %SystemRoot%\System32\imageres.dll,-24
Распознавание речи | Speech Recognition | %SystemRoot%\System32\Speech\SpeechUX\speechuxcpl.dll,-1
Родительский контроль | Parental Controls | %SystemRoot%\System32\wpccpl.dll,-1
Свойства панели задач и меню "Пуск" | Taskbar and Start Menu | %SystemRoot%\System32\imageres.dll,-80
Свойства обозревателя | Internet Options | C:\Windows\System32\inetcpl.cpl,-4487
Система | System | %SystemRoot%\System32\imageres.dll,-149
Счетчики и средства производительности | Performance Information and Tools | %SystemRoot%\System32\PerfCenterCPL.dll,-1
Телефон и модем | Phone and Modem | %SystemRoot%\System32\telephon.cpl,-100
Управление цветом | Color Management | %systemroot%\system32\colorcpl.exe,-5
Устранение неполадок | Troubleshooting | %SystemRoot%\System32\DiagCpl.dll,-1
Устройства Bluetooth | Bluetooth Devices | %systemroot%\system32\DevicePairingFolder.dll,-200
Устройства и принтеры | Devices and Printers | %systemroot%\system32\DeviceCenter.dll,-1
Учетные записи пользователей | User Accounts | %SystemRoot%\System32\usercpl.dll,-1
Центр мобильности Windows | Windows Mobility Center | %SystemRoot%\system32\mblctr.exe,0
Центр обновления Windows | Windows Update | %SystemRoot%\system32\wucltux.dll,-1
Центр поддержки | Action Center | %SystemRoot%\System32\ActionCenterCPL.dll,-1
Центр синхронизации | Sync Center | %SystemRoot%\System32\SyncCenter.dll,-1000
Центр специальных возможностей | Ease of Access Center | %SystemRoot%\System32\accessibilitycpl.dll,-1
Центр управления сетями и общим доступом | Network and Sharing Center | %SystemRoot%\System32\netcenter.dll,-1
Шифрование диска BitLocker | BitLocker Drive Encryption | %SystemRoot%\System32\fvecpl.dll,-1
Шрифты | Fonts | %SystemRoot%\System32\fontext.dll
Экран | Display | %SystemRoot%\System32\Display.dll,-1
Электропитание | Power Options | %SystemRoot%\System32\Powercpl.dll,-1
Язык и региональные стандарты | Region and Language | %SystemRoot%\System32\intl.cpl,-200
Русское название элемента | Английское название элемента | Значение параметра по умолчанию


32. Изменение иконок для элементов в меню Пуск.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CLASSES_ROOT\CLSID
3) В соответствии с таблицей ниже, откройте раздел соответствующий элементу в меню Пуск, значок для которого Вы желаете заменить.

Таблица 1.

Русское название элемента | Английское название элемента | Расположение CLSID в реестре
Администрирование | Administrative Tools | HKEY_CLASSES_ROOT\CLSID\{D20EA4E1-3957-11d2-A40B-0C5020524153}\DefaultIcon
Выполнить | Run | HKEY_CLASSES_ROOT\CLSID\{2559a1f3-21d7-11d4-bdaf-00c04f60b9f0}\DefaultIcon
Игры | Games | HKEY_CLASSES_ROOT\CLSID\{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}\DefaultIcon
Компьютер | Computer | HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\DefaultIcon
Недавние документы | Recent Items | HKEY_CLASSES_ROOT\CLSID\{0C39A5CF-1A7A-40C8-BA74-8900E6DF5FCD}\DefaultIcon
Панель управления | Control Panel | HKEY_CLASSES_ROOT\CLSID\{5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}\DefaultIcon
Подключение к | Connect To | HKEY_CLASSES_ROOT\CLSID\{38A98528-6CBF-4CA9-8DC0-B1E1D10F7B1B}\DefaultIcon
Программы по умолчанию | Default Programs | HKEY_CLASSES_ROOT\CLSID\{E44E5D18-0652-4508-A4E2-8A090067BCB0}\DefaultIcon
Сеть | Network | HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\DefaultIcon
Справка и Поддержка | Help and Support | HKEY_CLASSES_ROOT\CLSID\{2559a1f1-21d7-11d4-bdaf-00c04f60b9f0}\DefaultIcon
Устройства и принтеры | Devices and Printers | HKEY_CLASSES_ROOT\CLSID\{A8A91A66-3A7D-4424-8D24-04E180695C7A}\DefaultIcon
Русское название элемента | Английское название элемента | Расположение CLSID в реестре

4) Задайте полный доступ к данному разделу реестра.
4.1) В левой части редактора реестра щелкните правой кнопкой мыши на раздел DefaultIcon и выберите пункт Разрешения.
4.2) Нажмите кнопку Дополнительно.
4.3) Перейдите на вкладку Владелец.
4.4) Выберите Ваш аккаунт администратора и нажмите ОК.
4.5) Вверху выберите группу Администраторы (Administrators).
4.6) Установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите пункт Изменить.
6) Укажите путь к иконке, которую Вы желаете задать и нажмите ОК.

Примечание: Вам потребуются иконки размером 256x256 пикселей, сделанные для Windows 7 и поддерживающие все возможные для отображения размеры.

Для восстановления иконки по умолчанию измените значение параметра (По умолчанию) на указанное ниже:

Таблица 2.

Русское название элемента | Английское название элемента | Расположение CLSID в реестре
Администрирование | Administrative Tools | %SystemRoot%\system32\imageres.dll,-114
Выполнить | Run | %SystemRoot%\system32\imageres.dll,-100
Игры | Games | %SystemRoot%\system32\imageres.dll,-14
Компьютер | Computer | %SystemRoot%\system32\imageres.dll,-109
Недавние документы | Recent Items | %SystemRoot%\system32\imageres.dll,-117
Панель управления | Control Panel | %SystemRoot%\system32\imageres.dll,-27
Подключение к | Connect To | %SystemRoot%\system32\imageres.dll,-171
Программы по умолчанию | Default Programs | %SystemRoot%\system32\imageres.dll,-24
Сеть | Network | %SystemRoot%\system32\imageres.dll,-25
Справка и Поддержка | Help and Support | %SystemRoot%\System32\imageres.dll,-99
Устройства и принтеры | Devices and Printers | %systemroot%\system32\DeviceCenter.dll,-1
Русское название элемента | Английское название элемента | Расположение CLSID в реестре


33. Добавление подменю "Запустить с приоритетом" в контекстное меню exe-файлов.

Если Вы желаете запускать программы с различным уровнем приоритета, то Вы можете добавить подменю Запустить с приоритетом в контекстное меню exe-файлов.
Для использования данной возможности Вы должны быть администратором компьютера и у Вас должен быть отключен Контроль Учетных записей (UAC).
Иногда, для некоторых программ изменение приоритета может не действовать.
Для отображения данного пункта в контекстном меню Проводника Вам достаточно нажать правой кнопкой мыши на exe-файле.
Для отображения данного пункта в контекстном меню элементов меню Пуск или элементов, закрепленных на Панели задач, Вам необходимо удерживать клавишу ⇑ Shift, при нажатии правой кнопкой мыши на файле.

Чтобы добавить указанное подменю, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить указанное подменю, создайте и примените reg-файл указанного ниже содержания.


34. Добавление подменю "Запустить на процессоре" в контекстное меню exe-файлов.

Если Вы желаете запускать программы, используя не все ядра процессора одновременно, а используя какое-либо заданное ядро, то Вы можете добавить подменю Запустить на процессоре в контекстное меню exe-файлов.
Для использования данной возможности Вы должны быть администратором компьютера и у Вас должен быть отключен Контроль Учетных записей (UAC).
Иногда, для некоторых программ указание ядра процессора может не действовать.
Для отображения данного пункта в контекстном меню Проводника Вам достаточно нажать правой кнопкой мыши на exe-файле.
Для отображения данного пункта в контекстном меню элементов меню Пуск или элементов, закрепленных на Панели задач, Вам необходимо удерживать клавишу ⇑ Shift, при нажатии правой кнопкой мыши на файле.

1) Уточните количество ядер Вашего процессора 2, 3, 4, 6, 8 или 12.
1.1) Запустите Диспетчер задач Windows (Ctrl + ⇑ Shift + Esc)
1.2) Перейдите на вкладку Быстродействие.
Количество ядер процессора будет соответствовать - количеству столбцов в разделе Хронология загрузки ЦП.

2) Создайте и примените reg-файл указанного ниже содержания.

Так как в системе CPU0 соответствует 1 столбцу (ядру процессора), CPU1 соответствует 2 столбцу (ядру процессора), ..., CPU11 соответствует 12 столбцу (ядру процессора), то

Если у Вас 12 столбцов (ядер процессора), скопируйте весь текст.

Если у Вас 8 столбцов (ядер процессора), скопируйте текст до строки [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\shell\CPU8Affinity].
А в параметре SubCommands оставьте только значения CPU0Affinity;CPU1Affinity;CPU2Affinity;CPU3Affinity;CPU4Affinity;CPU5Affinity;CPU6Affinity;CPU7Affinity;

Если у Вас 4 столбца (ядер процессора), скопируйте текст до строки [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\shell\CPU4Affinity].
А в параметре SubCommands оставьте только значения CPU0Affinity;CPU1Affinity;CPU2Affinity;CPU3Affinity;

Чтобы удалить указанное подменю, создайте и примените reg-файл указанного ниже содержания.

Для информации:
По своему желанию Вы также можете добавить в меню другие значения в контекстное меню, для этого Вам необходимо Вычислить значение параметра /affinity.
Принцип вычисления его значения следующий:

1) Пишите в обратном порядке количество ядер Вашего процессора:
Например у Вас их восемь.

ЦП 7 ЦП 6 ЦП 5 ЦП 4 ЦП 3 ЦП 2 ЦП 1 ЦП 0

2) Снизу пишите желаемое состояние запуска для каждого ядра.

0 - выключено
1 - включено

Например:

ЦП 7 | ЦП 6 | ЦП 5 | ЦП 4 | ЦП 3 | ЦП 2 | ЦП 1 | ЦП 0
0 | 1 | 1 | 0 | 1 | 1 | 0 | 1

В данном примере для запуска приложения будут использованы ядра: ЦП 0, ЦП 2, ЦП 3, ЦП 5, ЦП 6, а ядра ЦП 1, ЦП 4, ЦП 7 использоваться не будут.

3) Запускаете калькулятор и в режиме Программист переводите получившееся у Вас число из двоичной системы (Bin) в десятичную (Dec)

Например:

1101101 = 109

4) А в reg-файле дописываете строки


35. Добавление в контекстное меню BAT, CMD, LOG, REG, TXT, VBS файлов всплывающего меню Копировать в буфер обмена.

Если Вы желаете скопировать в буфер обмена содержимое BAT, CMD, LOG, REG, TXT или VBS файла, не открывая его, то Вы можете добавить в контекстное меню для данных файлов подменю Копировать в буфер обмена.

Чтобы добавить всплывающее меню Копировать в буфер обмена с возможностью выбора кодировки, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить данное контекстное меню создайте и примените reg-файл указанного ниже содержания.


36. Удаление и добавление программ из списка в окне "Выбор программы" (Открыть с помощью).

При щелчке правой кнопкой мыши на многих файлах, можно использовать команду Открыть с помощью, чтобы выбрать программу для открытия файла.
Каждая используемая Вами программа, независимо от того, удалось ли ей открыть указанный Вами файл или нет, добавляется в список отображаемый в окне Выбор программы для данного типа файлов.
Например, если Вы выберите Paint (mspain.exe) в диалоговом окне Выбор программы, при открытии текстового документа (файл с расширением .txt), программа Paint сохранится в списке Выбор программы для всех текстовых документов, несмотря на то, что используя Paint невозможно открыть текстовые документы.
Чтобы удалить какую-либо программу из списка Выбор программы, воспользуйтесь предложенным ниже решением.

Для удаления какой-либо программы из списка Рекомендуемые программы в окне Выбор программы для отдельного типа файла:

1) Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
2) Откройте в реестре раздел: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.extension\OpenWithList
где .extension - расширение файла для типов файлов, у которых вы желаете очистить список Открыть с помощью.
3) Удалите все значения в данном разделе реестра.

Для удаления какой-либо программы из списка Другие программы в окне Выбор программы:

1) Запустите редактор реестра: Пуск → Выполнить → regedit → OK (или Win   + R → regedit → OK)
2) Откройте в реестре раздел: HKEY_CLASSES_ROOT\Applications
3) Удалите подраздел, отвечающий за Вашу программу. Он будет иметь название идентичное исполняемому файлу Вашей программы.

Для добавления какой-либо программы в список Другие программы в окне Выбор программы, создайте и примените указанный ниже reg-файл.

Укажите вместо ВашаПрограмма - имя исполняемого файла программы.
Укажите между @="\" и \" %1" путь к исполняемому файлу программы.
При указании в значение параметра пути к файлу или папке используйте два обратных слеша.

Пример:

Для восстановления программ используемых по умолчанию (без удаления уже имеющихся сторонних программ) в списке Другие программы в окне Выбор программы, скачайте и примените reg-файл из архива:
Open_with_all_defaults.zip

Также для работы со списком программ окна Выбор программы (Открыть с помощью) Вы можете скачать программу OpenWithView.


37. Добавление каскадного меню "Сжатие до реального размера" в контекстное меню файлов и папок.

Если Вы желаете сжать занимаемое папкой или файлом место на Вашем диске до реального размера, то Вы можете добавить для этого специальное всплывающее меню в контекстное меню файлов и папок.

Чтобы добавить каскадное меню Сжатие до реального размера, создайте и примените указанный ниже reg-файл.

Чтобы удалить каскадное меню Сжатие до реального размера, создайте и примените указанный ниже reg-файл.


38. Добавление каскадных меню Панель управления, Администрирование, Стандартные, Служебные и Специальные возможности в контекстное меню рабочего стола.

Для добавления меню Панель управления в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.
Ввиду ограничения системой количества разрешенных пунктов для использования в меню, данное меню разделено на три части.

Для удаления меню Панель управления из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Для добавления меню Администрирование в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Для удаления меню Администрирование из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Для добавления меню Стандартные в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Для удаления меню Стандартные из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Для добавления меню Служебные в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Для удаления меню Служебные из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Для добавления меню Специальные возможности в контекстное меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Для удаления меню Специальные возможности из контекстного меню рабочего стола, создайте и примените reg-файл указанного ниже содержания.

Также Вы можете скачать архив FFSMTDM.zip с указанными выше файлами и применить готовые reg-файлы:

Add_ControlPanel.reg - Добавить каскадное меню Панель управления в контекстное меню рабочего стола.
Remove_ControlPanel.reg - Удалить каскадное меню Панель управления из контекстного меню рабочего стола.

Add_Administrative_Tools.reg - Добавить каскадное меню Администрирование в контекстное меню рабочего стола.
Remove_Administrative_Tools.reg - Удалить каскадное меню Администрирование из контекстного меню рабочего стола.

Add_Accessories.reg - Добавить каскадное меню Стандартные в контекстное меню рабочего стола.
Remove_Accessories.reg - Удалить каскадное меню Стандартные из контекстного меню рабочего стола.

Add_System_Tools.reg - Добавить каскадное меню Служебные в контекстное меню рабочего стола.
Remove_System_Tools.reg - Удалить каскадное меню Служебные из контекстного меню рабочего стола.

Add_Ease_of_Access.reg - Добавить каскадное меню Специальные возможности в контекстное меню рабочего стола.
Remove_Ease_of_Access.reg - Удалить каскадное меню Специальные возможности из контекстного меню рабочего стола.


39. Добавление пункта "Очистить корзину без подтверждения" в контекстное меню Корзины.

Если Вы желаете очищать Корзину в Вашей операционной системе без всплывающего сообщения о подтверждении удаления, то Вы можете добавить для данного действия отдельный пункт в контекстное меню Корзины.

1) Скачайте программу NirCmd с сайта http://www.nirsoft.net/utils/nircmd.html
2) Распакуйте архив и переместите файл NirCmd.exe в папку C:\Windows\System32
3) Создайте и примените reg-файл указанного ниже содержания:


1. Включение скрытых настроек электропитания.

Чтобы настроить в Windows 7 параметры электропитания, необходимо открыть Панель управления\Система и безопасность\Электропитание. Там можно выбрать нужный план электропитания и при необходимости более детально настроить параметры, перейдя в Настройка плана электропитания → Изменить дополнительные параметры питания.
Однако более детально настроить параметры электропитания помогает консольная утилита Powercfg. Но работать в командной строке, разбираясь с каждым параметром может занять продолжительное время. Для того чтобы функции предоставляемые powercfg стали доступны Вам в графической оболочке, необходимо внести некоторые изменения в ветке реестра:

В данной ветке содержатся разделы, отвечающие за определенную группу настроек.
Например, раздел 0012ee47-9041-4b5d-9b77-535fba8b1442 относится к настройкам управления питанием жесткого диска, а 54533251-82be-4824-96c1-47b60b740d00 к настройкам управления питанием процессора.
В свою очередь, в каждом из данных разделов есть подразделы, отвечающие за какую-либо настройку электропитания. Описание каждой из настроек указано в значении параметра Description, а её отображение в графической оболочке в значении параметра Attributes. По умолчанию, многие настройки имеют значение параметра Attributes равное «1», для того, чтобы необходимая Вам настройка был виден в графической оболочке, необходимо заменить его на «0». Доступные для отображения настройки, на ноутбуке и стационарном компьютере могут отличаться, в связи с особенностью их систем электропитания.

Для отображения политики простоя устройств, создайте и примените reg-файл следующего содержания:

Для отображения скрытых параметров по настройке работы жесткого диска, создайте и примените reg-файл следующего содержания:

Для отображения скрытых параметров по настройке кнопок питания, создайте и примените reg-файл следующего содержания:

Для отображения скрытых параметров по настройке управления питания процессора, создайте и примените reg-файл следующего содержания:

Импортированное значение реестра позволяет увидеть только малую часть параметров, доступных для настройки управлением процессора. Всего их более 30.

Для отображения скрытых параметров по настройке спящего режима, создайте и примените reg-файл следующего содержания:

Для отображения скрытых параметров по настройке экрана, создайте и примените reg-файл следующего содержания:

Также к этому разделу относится настройка параметров графического адаптера, но доступность конкретных настроек будет определяется драйвером.

У себя в системе я обнаружил 54 скрытых настройки электропитания. Для включения сразу всех скрытых настроек электропитания: экспортируйте всю ветку HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings в reg-файл. Отредактируйте полученный reg-файл: оставьте в нем только наименование веток реестра и их параметры Attributes и присвойте им значения «0».
Также Вы можете скачать и применить, готовый reg-файл PowerSettings.reg Перейти к началу Общего списка советов.


2. Добавление классического всплывающего меню Программы (Programs) в меню Пуск.

Для быстрого доступа к элементам списка Все программы (All Programs), Вы можете добавить его как всплывающее меню взамен меню Избранное (Favorites) или меню Файлы для загрузки (Downloads)

Вариант 1. Вместо меню Файлы для загрузки (Downloads).

Если Вы для загрузки файлов из интернета используете собственную папку или сохраняете на Рабочий стол, а также в качестве интернет-браузера используете Internet Explorer, то Вам подойдет данный вариант.

1) Включите меню Файлы для загрузки (Downloads)
1.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
1.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
1.3) Прокрутите список до пункта Файлы для загрузки (Downloads)
1.4) Установите переключатель в значение Отображать как меню (Display as a menu), затем нажмите OK.
2) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter ↵.
3) Откройте раздел реестра:

4) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

5) Откройте раздел реестра:

6) Щелкните дважды на параметр {374DE290-123F-4565-9164-39C4925E467B} и замените текущий путь на этот:

7) Закройте regedit, и перезагрузите Ваш компьютер.

Вариант 2. Вместо меню Избранное (Favorites)

Если Вы в качестве интернет-браузера используете альтернативный браузер: Mozilla Firefox, Opera или Google Chrome, то Вам подойдет данный вариант.

1) Установите любой понравившийся Вам браузер Mozilla Firefox, Opera или Google Chrome
2) При его установке импортируйте закладки из Internet Explorer(если необходимо)
3) Включите меню Избранное (Favorites)
3.1) Щелкните правой кнопкой мыши на кнопке Пуск, затем нажмите Свойства (Properties).
3.2) Откройте вкладку Меню "Пуск" (Start Menu) и нажмите кнопку Настроить (Customize)
3.3) Прокрутите список до пункта Избранное (Favorites) и установите на него флажок, затем нажмите OK.
4) Нажмите кнопку Пуск, в поле поиска введите regedit и нажмите Enter ↵.
5) Откройте раздел реестра:

6) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

7) Откройте раздел реестра:

8) Щелкните дважды на параметр Favorites и замените текущий путь на этот:

9) Закройте regedit, и перезагрузите Ваш компьютер.

Теперь, когда Вы нажмете Пуск, в правой его части Вы увидите меню Программы (Programs), наподобие меню в предыдущих версиях Windows.

Для исключения дублирования, Вы также можете убрать стандартный пункт меню Все программы (All Programs) из меню Пуск.
Для этого создайте и примените reg-файл следующего содержания:

Для возвращения стандартного пункта меню Все программы (All Programs) из меню Пуск.
Для этого создайте и примените reg-файл следующего содержания:


3. Добавление функции произвольного выравнивания иконок в Проводнике.

В Windows 7 возможность отключения автоматического выравнивания иконок в Проводнике недоступна. В контекстном меню "Вид" в Проводнике, пункт "Упорядочить значки автоматически" отсутствует, соответственно Вы не можете располагать значки произвольным образом.
Предложенные ниже варианты включают возможность произвольного выравнивания иконок в Проводнике и добавляют в контекстное меню "Вид" в Проводнике пункты "Выравнивать автоматически" и "Выровнять по сетке".

Вариант 1.

1) Скачайте программу Folder Options X.
С официального сайта: английская версия
С зеркала: русская версия
2) Закройте все окна Проводника.
3) Откройте в меню Пуск папку T800 Productions\Folder Options X и запустите программу.
3) Снимите все флажки и нажмите кнопку Apply.
4) Установите флажок Включить произвольное выравнивания иконок в папке и нажмите кнопку OK.
Установка данного флажка добавляет в контекстное меню Вид: пункты Выровнять автоматически и Выровнять по сетке.
Для произвольного выравнивания иконок, флажки рядом с ними должны быть сняты.
5) Перезайдите в систему или перезагрузите компьютер.

Вариант 2.

В виду сложившейся необходимости, для работы данного твика режимы "Плитка" и "Содержимое" были объединены в режим "Расширенная плитка".

Чтобы воспользоваться твиком Вы можете скачать и применить готовое решение: DisableAutoArrange.zip

disableautoarrange.reg - reg-файл вносящий изменения в контекстное меню Проводника
undo.reg - reg-файл возвращающий все настройки Проводника "по умолчанию".

Также Вы можете создать данные reg-файлы самостоятельно.

Для внесения изменений создайте и примените reg-файл следующего содержания:

Для отмены изменений создайте и примените reg-файл следующего содержания:


4. Использование Windows Media Player х64 по умолчанию (для Windows 7 х64).

Microsoft до сих пор использует 32-битную версию Windows Media Player в 64-битной версии ОС, но есть способ это изменить.
Преимущество использования WMP х64 заключается лишь в том, что установив 64-битную версию кодеков, вы получите гораздо более чистую и легко управляемую систему.

1) Запустите командную строку от имени администратора. (В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.)
2) Введите команду

(команда чувствительна к регистру)
3) Запустите редактор реестра (Win   + R → regedit → ОК)
4) Откройте раздел реестра:

и кликните два раза по значению Path
5) Измените

на

6) Закройте редактор реестра и наслаждайтесь Windows Media Player х64

Готовые bat-файлы Вы можете скачать по ссылке: WindowsMediaPlayerx64.zip Перейти к началу Общего списка советов.


5. Настройка диалога переключения между окнами ("Alt"+"Tab").

1) Запустите Редактор Реестра (Win   + R → Regedit → ОК)
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AltTab, если он отсутствует, то создайте его (щелкните на папке Explorer правой кнопкой мыши, выберите Создать → Раздел и назовите его AltTab).
В данном разделе создайте или измените указанные ниже параметры. Все параметры, которые будут создаваться или изменятся имеют тип REG_DWORD. Для применения изменений необходимо перезапустить процесс explorer.exe, перезайти в систему или перезапустить компьютер.

Для создания твика, воспользуйтесь инструкцией:

1) Скопируйте код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .reg
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "demo.reg")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

Параметры, отвечающие за количество отображаемых столбцов и строк

Columns - данный параметр отвечает за количество столбцов, из которых состоит диалог переключения между окнами.
Rows - данный параметр отвечает за количество строк, из которых состоит диалог переключения между окнами.

Пример твика реестра с использованием этих параметров:

Параметры, отвечающие за отступы в диалоге переключения между окнами

Упомянутые ниже параметры указываются в пикселях.

TopMarginPx - величина верхнего поля, добавляемого в диалог
SideMarginPx - величина бокового поля, добавляемого в диалог
BottomMarginPx - величина нижнего поля, добавляемого в диалог
MinWidthPx - минимальная возможная ширина диалога AltTab
ThumbSpacingXPx - интервал между эскизами смежных окон по горизонтали
ThumbSpacingYPx - интервал между эскизами смежных окон по вертикали

Пример твика реестра с использованием этих параметров:

Параметры, отвечающие за значки эскизов окон

Упомянутые ниже параметры указываются в пикселях.

OverlayIconDXPx - величина смещения значка, вправо от эскиза окна
OverlayIconDYPx - величина смещения значка, вниз от эскиза окна
OverlayIconPx - размер значков, отображаемых в правом нижнем углу эскиза окна в диалоге переключения между окнами

Пример твика реестра с использованием этих параметров:

Параметры, отвечающие за размер эскизов окон и заголовок диалога переключения между окнами

Упомянутые ниже параметры указываются в пикселях.
MaxThumbSizePx - максимальный размер эскизов окон
MinThumbSizePcent - минимальный размер эскизов окон в процентах, относительно максимального размера установленного в MaxThumbSizePx
TextButtomPx - высота заголовка диалога переключения между окнами

Пример твика реестра с использованием этих параметров:

Параметры, изменяющие задержку времени в отображении диалога и управляющие его прозрачностью

FadeOut_ms - количество миллисекунд, в течении которого окно будет исчезать
FadeIn_ms - количество миллисекунд, в течении которого окно будет появляться
FadeOutThreshold_ms Используется для мгновенного исчезновения диалога(присвойте данному параметру значение 0x1000).

StartAlpha - начальная прозрачность диалога переключения между окнами
FinalAlpha - конечная прозрачность диалога переключения между окнами

Пример твика реестра с использованием этих параметров:

Для включения классического диалога переключения между окнами, используемого в предыдущих версиях Windows при нажатии Alt + Tab ↹, создайте DWORD-параметр AltTabSettings в разделе реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer и присвойте данному параметру значение 1. Перейти к началу Общего списка советов.


6. Настройка диалогового окна "Выбор программы".

Когда Вы щелкаете на файле с незарегистрированным в системе расширением, то появляется окно “Выбор программы”, в котором вам предлагается выбрать из предложенного списка программу, способную обработать неизвестный тип файла.
В данном окне по умолчанию установлен флажок “Использовать выбранную программу для всех файлов такого типа”. Чтобы убрать флажок и заблокировать возможность его установки, Вам необходимо изменить запись в реестре.

1) Запустите редактор реестра (Win   + R → regedit → OK)
2) Откройте раздел HKEY_CLASSES_ROOT\Unknown\shell\opendlg\command
3) Измените значение параметра По умолчанию (Default)

Список программ, которые выводятся в диалоговом окне выбора программы, формируется при помощи списка подразделов раздела HKEY_CLASSES_ROOT\Applications.
В данном разделе вы можете видеть, что имена подразделов соответствуют именам программ, установленных на вашем компьютере. Если вы хотите, чтобы какая-то из этих программ никогда не выводилась в диалоговом окне выбора программы, то в подразделе этой программы создайте строковый параметр NoOpenWith без какого-либо значения. Перейти к началу Общего списка советов.


7. Включение окна выбора начальных параметров при запуске проигрывателя Windows Media.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Удалите полностью следующую ветку реестра со всем содержимым:

Вместо XXXXXX-XXXXXX-XXXXXX-XXXX у Вас будет собственное значение.
Например: S-1-5-21-83440259-2036283413-1691820529-1000 или S-1-5-21-2717813001-1445373200-4062485642-500

3) Перезайдите в систему или перезагрузите компьютер.


8. Изменение действия по умолчанию при перетаскивании файлов между папками в Проводнике.

При перетаскивании любого файла между двумя папками-окнами Проводника, в Windows 7 по умолчанию выполняется его перемещение. Вы можете самостоятельно настроить действие, которое будет выполняться при перетаскивании файла между папками: копирование; перемещение; создание ярлыка.

Действие по умолчанию при перетаскивании конкретного типа файлов.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Перейдите в раздел HKEY_CLASSES_ROOT
3) Найдите раздел интересующего Вас расширения. Для примера возьмем раздел .exe:
4) Обратите внимание на значение параметра По умолчанию, которое служит идентификатором расширения.
Для .exe файла данным значением будет exefile, следовательно все параметры необходимо создавать в разделе с идентичным именем.
5) Откройте раздел реестра: HKEY_CLASSES_ROOT\exefile.
6) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
7) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
8) В текстовом поле Значение: задайте необходимое Вам значение:

1 - копирование;
2 - перемещение;
4 - создание ярлыка.

Действие по умолчанию для всех файлов при перетаскивании.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_CLASSES_ROOT\*.
3) Создайте новый параметр типа DWORD c именем DefaultDropEffect
4) Создайте новый параметр типа DWORD (32 бита) c именем DefaultDropEffect
5) Щелкните правой кнопкой мыши по параметру DefaultDropEffect и выберите пункт Изменить...
6) В текстовом поле Значение: задайте необходимое Вам значение:

1 - копирование;
2 - перемещение;
4 - создание ярлыка. Перейти к началу Общего списка советов.


9. Удаление пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов.

Для удаления пункта "Исправление неполадок совместимости" из контекстного меню ярлыков и исполняемых файлов, создайте и примените reg-файл следующего содержания:

Для восстановления пункта "Исправление неполадок совместимости" в контекстном меню ярлыков и исполняемых файлов, создайте и примените reg-файл следующего содержания:


10. Удаление и восстановление стрелок на ярлыках Windows.

Готовые файлы для убирания стрелок вы можете скачать по ссылке:
Shortcut_Arrows.zip
1) Распакуйте и откройте папку нужного вам варианта
2) Для удаления стрелок с ярлыков запустите Remove_Shortcut_Arrow.bat или Remove_Shortcut_Arrow.reg
3) Для восстановления стрелок на ярлыках запустите Restore_Shortcut_Arrow.bat или Restore_Shortcut_Arrow.reg

Вариант 1

Для удаления стрелок с ярлыков:

1) Запустите диалоговое окно "Выполнить" (Win   + R)
2) Скопируйте код указанный ниже и нажмите OK

Для восстановления стрелок на ярлыках:

Или в ручную удалите данную ветку.

Вариант 2

Для удаления стрелок с ярлыков:

1) Создайте пустой файл иконки назовите его Blank.ico
2) Скопируйте его в папку C:\Windows
3) Запустите диалоговое окно "Выполнить" (Win   + R)
4) Скопируйте код указанный ниже и нажмите OK

Для восстановления стрелок на ярлыках:

1) Удалите файл Blank.ico из папки C:\Windows
2) Запустите диалоговое окно "Выполнить" (Win   + R)
3) Скопируйте код указанный ниже и нажмите OK

Или в ручную удалите данную ветку.

Побочным эффектом при использовании данного варианта является, появление черных квадратиков вместо стрелочек, если в папке Windows у Вас будет отсутствовать файл Blank.ico.

Вариант 3

1) Скопируйте текст в блокнот.
2) Сохраните как Remove_Shortcut_Arrow.reg (для удаления) или Restore_Shortcut_Arrow.reg (для восстановления).
3) Выполните файл, чтобы его содержание было внесено в реестр.
4) Обратите внимание на знак минуса в команде "IsShortCut"=-. Вокруг него нет кавычек. Эта команда удаляет значение IsShortCut и сам ключ IsShortCut. Если вы введёте команду "IsShortCut"="-", то тогда ключ удалён не будет, а его значение поменяется на минус. "IsNotShortCut"="" создаёт ключ и присваивает ему нулевое значение.

Файл .reg для удаления стрелок с ярлыков

Файл .reg для восстановления стрелок на ярлыках

Побочным эффектом при использовании данного варианта является, исчезновение пункта "Закрепить программу в панели задач". Если Вам необходимо будет закрепить какую-либо программу в Панели задач, то воспользуйтесь reg-файлом для восстановления стрелок на ярлыках, закрепите программу, а затем снова воспользуйтесь reg-файлом для удаления стрелок с ярлыков. Перейти к началу Общего списка советов.


11. Удаление папок из Рабочего стола в области переходов Проводника.

Если Вы хотите, удалить лишние папки в области переходов Проводника, воспользуйтесь одним из предложенных ниже вариантов.
Перед применением решения предложенного в любом из указанных ниже вариантов закройте Проводник.

Вариант 1

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace
3) Сделайте себе экспорт указанного раздела, на случай восстановления (нажмите правой кнопкой мыши на разделе NameSpace → Экспортировать).
4) Удалите необходимые Вам разделы:

Favorites(Избранное) | {323CA680-C24D-4099-B94D-446DD2D7249E}
Libraries(Библиотеки) | {031E4825-7B94-4dc3-B131-E946B44C8DD5}
Homegroup(Домашняя группа) | {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}
Shared Documents(Общие Документы) | {59031a47-3f72-44a7-89c5-5595fe6b30ee}
Computer(Компьютер) | {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Network(Сеть) | {F02C1A0D-BE21-4350-88B0-7367FC96EF3C}
Control Panel(Панель управления) | {26EE0668-A00A-44D7-9371-BEB064C98683}
Recycle Bin(Корзина) | {645FF040-5081-101B-9F08-00AA002F954E}

Вариант 2

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder
где вместо {GUID} вставьте необходимое Вам значение из указанной ниже таблицы.
Например: HKEY_CLASSES_ROOT\CLSID\{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder
3) В левой части редактора реестра щелкните правой кнопкой мыши на раздел ShellFolder и выберите из меню пункт Разрешения.
4) Выделите группу Администраторы, установите флажок в колонке Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК.
5) Щелкните дважды на параметре Attributes и введите значение из таблицы, указанное в колонке Удаление, чтобы удалить желаемую папку.
Для восстановления папки обратно, введите значение из таблицы, указанное в колонке По умолчанию.

Наименование | {GUID} | Удаление | По умолчанию
Favorites(Избранное) | {323CA680-C24D-4099-B94D-446DD2D7249E} | a9400100 | a0900100
Libraries(Библиотеки) | {031E4825-7B94-4dc3-B131-E946B44C8DD5} | b090010d | b080010d
Homegroup(Домашняя группа) | {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} | b094010c | b084010c
Computer(Компьютер) | {20D04FE0-3AEA-1069-A2D8-08002B30309D} | b094010c | b084010c
Network(Сеть) | {F02C1A0D-BE21-4350-88B0-7367FC96EF3C} | b0940064 | b0040064
Recycle Bin(Корзина) | {645FF040-5081-101B-9F08-00AA002F954E} | 70 01 00 20 | 40 01 00 20
Папка пользователя (обычно идентична Вашему нику): | {59031a47-3f72-44a7-89c5-5595fe6b30ee} | f094012d | f084012d


12. Отключение суффикса "-Ярлык" при создании новых ярлыков.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
3) В правой части окна, дважды щелкните на параметр реестра "link".
4) Измените значение на 00 00 00 00.
5) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:


13. Отключение всплывающих подсказок для элeмeнтoв paбoчeгo cтoлa.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
3) В правой части окна, дважды щелкните на параметр реестра "ShowInfoTip".
4) Измените значение на 0.
5) Перезагрузите компьютер.

Вы можете также создать и применить reg-файл следующего содержания:


14. Отключение диалога "Не удалось открыть файл".

Если системе не знаком тип файла, который вы пытаетесь открыть, то сначала выводится диалоговое окно для поиска программы в интернете.

Система предлагает Вам:

Поиск соответствия в интернете. Если вы выберите этот вариант, то запускается веб-служба
shell. windows. com/fileassoc/0409/xml/redir. asp? Ext=fb2 (пример для случая с FB2-файлом).
Выбор программы из списка установленных программ. Открывает окно выбора программы для открытия файла на локальном компьютере.

Для того чтобы не выводить окно для поиска файла в интернете, а сразу открывать окно выбора программы, воспользуйтесь одним из предложенных решений:

1) Откройте редактор реестра (Win   + R → regedit)
2) Перейдите в раздел реестра HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте DWORD-параметр NoInternetOpenWith и установите его значение равным 1.

или

1) Нажмите кнопку "Пуск", и в строке поиска напечатайте cmd.exe.
2) Щелкните на найденной программе правой кнопкой мыши и нажмите Запуск от имени администратора
3) В командой строке напечатайте следующее:


15. Максимально возможное отключение сглаживания шрифтов (ClearType) в Windows 7.

Если Вы хотите максимально возможно отключить использование ClearType в aero-темах Windows 7, то Вам необходимо сделать следующее.

Вариант 1.

1) Отключите ClearType в системе.
1.1) Откройте Панель управления → Шрифты → Настройка текста ClearType
1.2) Снимите флажок "Включить ClearType".
2) Отключите сглаживание любого типа шрифта.
2.1) Откройте Панель управления → Система → Дополнительные параметры системы
2.2) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры
2.3) На вкладке Визуальные эффекты в списке снимите флажок Сгладить неровности экранных шрифтов
3) Измените шрифт элементов окна.
3.1) Откройте Панель управления → Персонализация → Цвет окна →Дополнительные параметры оформления
3.2) Установите для всех элементов вместо шрифта Segoe UI любой другой шрифт. Например: Tahoma; для всех элементов установите размер 8, для элементов "Заголовок активного окна" и "Заголовок неактивного окна", оставьте размер 9.
4) Запустите редактор реестра (Win   + R → regedit → ОК)
5) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts
6) Удалите присвоенные значения для указанных ниже параметров:

Для изменения значения параметра щелкните на необходимом Вам параметре правой кнопкой мыши и нажмите Изменить.

7) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
8) Создайте строковый (String) параметр с именем Segoe UI
9) Щелкните на нем правой кнопкой мыши и нажмите Изменить.
10) Установите значение параметра Tahoma и нажмите ОК.
11) Перезагрузите компьютер.

Примечание:

П.1) Если крупный шрифт покажется Вам с нечеткими краями установите снятый флажок Сгладить неровности экранных шрифтов обратно.
П.2) Если шрифт в Проводнике и панели задач кажется расплывчатым, измените в ветке HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes значение параметра Segoe UI с Tahoma на MS Sans Serif
П.3) При выборе шрифтов Tahoma или MS Sans Serif в калькуляторе пропадает изображение стрелки на клавише стереть последнюю цифру.
П.4) Указанные действия применимы для 100% размера шрифта. Если у Вас стоит увеличение масштаба шрифта (чаще у широкоформатных мониторов), то проделайте следующее:
П.4.1) Верните масштаб шрифта в 100% значение.
П.4.2) Примените указанное в данном совете решение, включая перезагрузку.
П.4.3) Установите необходимый Вам масштаб

Вы можете скачать готовые reg-файлы, которые выполняют описанные выше действия: ClearType_on-off.zip
Описание содержимого архива:

ClearType-off.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен.
ClearType_off+FS.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен.
ClearType_off+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов включен, изменен шрифт на MS Sans Serif.
ClearType_off+FS+font.reg - выполняет действия описанные в совете, флажок Сгладить неровности экранных шрифтов отключен, изменен шрифт на MS Sans Serif.
ClearType-restore.reg - Восстановить исходные значения по умолчанию.

Вариант 2. Ручная установка и удаление Windows Aero (Tahoma Font).

Главным плюсом в отличие от предыдущего варианта является полное удаление привязки системы к шрифту Segoe UI и наличие изображения стрелки в калькуляторе.

Установка Windows Aero (Tahoma Font).

1) Скачайте и распакуйте в любую папку файл WindowsAero(TahomaFont).zip
2) Откройте папку Manual и в соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
3) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Patch.
4) Переключите интерфейс Вашей системы на классическую тему.
5) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles, для этого воспользуйтесь советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
6) Переименуйте файл aero.msstyles в aero.msstyles.backup.
7) Скопируйте модифицированный файл aero.msstyles из папки Manual в папку C:\Windows\Resources\Themes\Aero\.
8) Примените reg-файл "NoSegoe - Tahoma.reg".
9) Откройте Панель управления → Шрифты → Настройка текста ClearType и снимите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
10) Перезагрузите компьютер.
11) Переключите обратно на Aero-тему.

Удаление Windows Aero (Tahoma Font).

1) Переключите интерфейс Вашей системы на классическую тему.
2) Откройте папку C:\Windows\Resources\Themes\Aero\. Задайте полный доступ к файлу aero.msstyles, для этого воспользуйтесь советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование.
3) Удалите файл aero.msstyles
4) Переименуйте файл aero.msstyles.backup обратно в aero.msstyles.
5) Откройте папку Manual из папки, где распакован архив и примените reg-файл "NoSegoe - Restore Segoe UI.reg".
6) В соответствии с разрядностью Вашей системы запустите Universal Theme Patcher. Данное действие позволит использовать Вам неподписанные темы.
7) Нажмите кнопку Да (Yes), а затем напротив каждого из файлов кнопку Restore.
8) Откройте Панель управления → Шрифты → Настройка текста ClearType и установите флажок "Включить ClearType". Нажмите несколько раз кнопку Далее, а затем кнопку Готово.
9) Перезагрузите компьютер.
10) Переключите обратно на Aero-тему.

Вариант 3. Автоматическая установка Windows Aero (Tahoma Font).

Установка Windows Aero (Tahoma Font).

1) Скачайте и распакуйте в любую папку файл WindowsAero(TahomaFont).zip
2) Откройте папку Auto.
3) Нажмите правой кнопкой мыши на файле Windows Aero (Tahoma Font).exe и выберите пункт Запуск от имени администратора
4) Нажмите клавишу Next в первом окне, во втором окне установите переключатель в значение I accept the agreement и нажмите кнопку Next.
5) В окне Information также нажмите кнопку Next.
6) В окне Select Components установите все флажки и нажмите кнопку Next.
7) В окне Ready to Install нажмите кнопку Install и запустится установка.
8) В окне Windows Aero (Tahoma Font) Setup информирующем о переключении интерфейса на классическую тему нажмите кнопку ОК.
9) После того как программа переключится на классическую тему вернитесь обратно в программу.
10) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
11) Установите переключатель в значение Yes, restart the computer now и нажмите кнопку Finish.
12) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

Удаление Windows Aero (Tahoma Font).

1) Откройте Панель управления → Программы и компоненты и щелкните на Windows Aero (Tahoma Font)
2) В появившемся окне нажмите Да, а в следующем ОК.
3) В окне Windows Aero (Tahoma Font) Setup информирующем о необходимости нажатия кнопки Yes при запуске скриптов для данной программы нажмите кнопку ОК.
4) В окне предлагающем перезапустить компьютер нажмите Да
5) Компьютер перезагрузится и если у Вас включен Контроль учетных записей (UAC), то в окнах предлагающих запустить Microsoft Windows Based Script Host нажмите кнопку Да (Yes).

Примечание:

П. Если после установки или удаления программа не переключила обратно на Вашу aero-тему, то сделайте это вручную. Перейти к началу Общего списка советов.


16. Изменение набора кнопок на панели Проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели Проводника почти везде присутствуют кнопки Упорядочить и Новая папка. Остальной набор кнопок на панели изменяется динамически, в зависимости от выбранного типа файла или папки.
Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор кнопок в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора кнопок во всех папках Проводника добавьте или удалите кнопки во все шаблоны.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для изменения отображаемых кнопок сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра необходимого Вам шаблона.
Например: для добавления или удаления кнопки в обычную папку использующую шаблон типа папки «Общие элементы» откройте:

А для добавления или удаления кнопки в папку «Общие элементы», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TasksItemsSelected или TasksNoItemsSelected.

4.1) Откройте необходимый из указанных подразделов, если Вы изменяете набор кнопок в шаблонах Библиотек и/или в шаблонах поиска результатов в них.
4.2) Создайте раздел заново, если Вы изменяете шаблон для типа обычных папок. (В правой части окна щелкните правой кнопкой мыши и выберите Создать → Раздел.)

TasksItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке что-либо выделено.
TasksNoItemsSelected - отвечает за набор кнопок, которые отображаются, когда в папке ничего не выделено.

5) Щелкните правой кнопкой мыши на параметре (По умолчанию) и выберите Изменить.
6) Добавьте к существующим значениям необходимые или удалите ненужные.
Порядок значений в списке соответствует порядку отображения кнопок на панели. Значения отделяются друг от друга точкой с запятой (;).
Например: Windows.Copy;Windows.Paste;Windows.Delete;

Список возможных кнопок для добавления Вы можете узнать из названий подразделов в ветке реестра:

В таблице ниже указаны значения наиболее часто используемых кнопок.

Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей Проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected
Кнопка | Действие | Использование

В качестве альтернативного варианта Вы можете воспользоваться утилитой Custom Explorer Toolbar.
Данная программа позволяет Вам изменить отображаемые на панели Проводника кнопки всего лишь в несколько нажатий мыши. Работа в данной программе сводится к следующему:

1) Выберите в ниспадающем меню Действие, что вы желаете сделать с кнопками Добавить/Удалить.
2) Выберите в ниспадающем меню Режим панели, событие при котором данная кнопка должна появлятся на панели.
Например, кнопки Копировать, Вырезать или Удалить уместнее добавить если выбран хотя бы один элемент, а кнопку "Вставить" имеет смысл отобразить, если ничего не выбрано.
3) В разделе Типы папок установите флажки, в каких шаблонах должны появит© выбранные Вами кнопки. Перейти к началу Общего списка советов.


17. Изменение состава меню "Упорядочить" на панели Проводника Windows 7.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

На панели Проводника почти везде присутствуют кнопка Упорядочить, при нажатии на которую появляется меню с определенным набором выполняемых команд и подменю Представление.

Для изменения пунктов отображающихся в данном меню сделайте следующее:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра:

Для внесения изменений в меню Упорядочить:

Для внесения изменений в меню Представление:

3) Задайте полные права на доступ к выбранному разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Щелкните правой кнопкой мыши на параметре SubCommands и выберите Изменить.
5) Добавьте к существующим значениям необходимые или удалите ненужные.
Порядок значений в списке соответствует порядку отображения пунктов списка. Значения отделяются друг от друга точкой с запятой (;) , символ | означает разделитель меню, после него также ставится точка с запятой.

Список значений параметра SubCommands для меню Упорядочить по умолчанию:

Список значений параметра SubCommands для подменю Упорядочить по умолчанию:

Список пунктов возможных для добавления Вы можете узнать из названий подразделов в ветке реестра:

В таблице ниже указаны значения наиболее часто используемых пунктов.

Кнопка | Действие | Использование
Windows.burn | Записать на оптический диск | TasksItemsSelected
Windows.closewindow | Закрыть (окно) <ALT+F4> | TasksItemsSelected, TasksNoItemsSelected
Windows.copy | Вырезать <CTRL+C> | TasksItemsSelected
Windows.cut | Копировать <CTRL+X> | TasksItemsSelected
Windows.delete | Удалить <Del> | TasksItemsSelected
Windows.email | Электронная почта | TasksItemsSelected
Windows.folderoptions | Параметры папок и поиска | TasksNoItemsSelected
Windows.includeinlibrary | Включить в библиотеку | TasksItemsSelected
Windows.layout | Представление (вкл. и выкл. областей Проводника) | TasksNoItemsSelected
Windows.librarypane | Область библиотек (под панелью кнопок) | TasksNoItemsSelected
Windows.menubar | Строка меню (ALT) | TasksNoItemsSelected
Windows.navpane | Область переходов | TasksNoItemsSelected
Windows.newfolder | Создать новую папку | TasksNoItemsSelected
Windows.paste | Вставить (CTRL+V) | TasksItemsSelected, TasksNoItemsSelected
Windows.previewpane | Область сведений | TasksNoItemsSelected
Windows.print | Печать | TasksItemsSelected
Windows.properties | Свойства (файла, папки, библиотеки) <ALT+Enter> | TasksItemsSelected, TasksNoItemsSelected
Windows.readingpane | Область предпросмотра <Alt+P> | TasksNoItemsSelected
Windows.redo | Вернуть (возврат последнего отмененного действия) <CTRL+Y> | TasksNoItemsSelected
Windows.removeproperties | Удалить свойства (файла, папки, библиотеки) | TasksItemsSelected, TasksNoItemsSelected
Windows.rename | Переименовать <F2> | TasksItemsSelected
Windows.selectall | Выделить все <CTRL+A> | TasksNoItemsSelected
Windows.separator | Разделитель (кнопка без подписи и действия) | TasksItemsSelected, TasksNoItemsSelected
Windows.Share | Общий доступ | TasksItemsSelected
Windows.slideshow | Показ слайдов | TasksItemsSelected, TasksNoItemsSelected
Windows.undo | Отменить <CTRL+Z> | TasksNoItemsSelected
Кнопка | Действие | Использование


18. Изменение отображаемых по умолчанию свойств для файла в Проводнике.

При выделении файла в Проводнике, система отображает в области сведений соответствующую ему информацию. Также сведения отображаются при наведении на него курсора мыши или на вкладке Подробно в окне Свойства, вызываемом из контекстного меню.

Для настройки сведений, отображаемых для файла в Проводнике, сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел соответствующий наименованию необходимого Вам расширения файла в указанных ниже ветках реестра:

2.1) чтобы изменить отображаемые сведения для всех пользователей на компьютере (если Вы администратор компьютера):

2.2) чтобы изменить отображаемые сведения для текущей записи:

Например, для расширения .mp3 откройте:

3) Измените значения параметров:

InfoTip - отвечает за информацию отображаемую во всплывающей подсказке
PreviewDetails - отвечает за информацию отображаемую в области сведений Проводника
FullDetails - отвечает за информацию отображаемую во вкладке Подробно в Свойствах файла

4) Щелкните правой кнопкой мыши на выбранном параметре и выберите Изменить.
5) После слова prop: добавьте к существующим значениям необходимые или удалите ненужные.
Порядок значений в списке соответствует порядку отображения пунктов в системе. Значения отделяются друг от друга точкой с запятой.

Например, для файлов с расширением .mp3 Вы можете выставить значение:

В таблице ниже, указаны значения наиболее часто используемых значений данных параметров.

Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока
Наименование значения параметра | Отображаемое значение


19. Изменение используемых по умолчанию столбцов в Проводнике для папок, при выборе отображения в виде таблицы.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

При выборе в Проводнике вида отображения Таблица, система показывает определенные столбцы. Вы можете настроить для любой папки свой собственный набор столбцов, щелкнув правой кнопкой мыши на любом из них и во всплывающем меню выбрав пункт Подробнее..., если же Вам необходимо изменить столбцы отображаемые по умолчанию, то Вам необходимо внести соответствующие изменения в реестр.

Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените набор столбцов в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора столбцов во всех папках Проводника добавьте или удалите значения во всех шаблонах.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для настройки столбцов, используемых по умолчанию в Проводнике, сделайте следующее:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра необходимого Вам шаблона.
Например: для добавления или удаления столбцев в обычной папке использующей шаблон типа папки «Музыка» откройте:

А для добавления или удаления столбцев в папке «Музыка», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TopViews
5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра ColumnList (щелчок правой кнопкой мыши на параметре → Изменить) стоящие после слова prop: .
6) Для включения необходимого Вам столбца измените значение стоящее перед ним на 0. Цифра 0 перед указанным Вами параметром сообщит системе, что данный столбец необходимо отобразить. Если необходимый Вам столбец отсутствует, то Вы можете добавить его самостоятельно, указав перед ним цифру 0. Значения отделяются друг от друга точкой с запятой (;). Например: для изменения столбцов как на рисунке, в начале совета значение параметра ColumnList примет вид:

В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока
Наименование значения параметра | Отображаемое значение

7) Перезагрузите компьютер
8) Для папок из библиотек, щелкните правой кнопкой мыши внутри основной папки (Видео, Документы, Изображения, Музыка) выберите Упорядочить → Очистить изменения
9) Для обычных папок измените шаблон на другой вид в Свойства → Настройка, а затем верните обратно.
10) Также очистите в реестре указанный ниже раздел, удалив все папки кроме AllFolders.

Очистка данного раздела реестра удалит все настройки яў папок сделанные пользователями, до применения данного совета.


20. Изменение пунктов контекстного меню "Сортировка" используемых по умолчанию в Проводнике.

Перед применением данного совета рекомендую создать точку восстановления системы и экспортировать изменяемые ветки реестра в reg-файл. После успешного завершения вносимых Вами действий Вы сможете их удалить, в обратном же случае восстановить исходные значения и попробовать заново.

При нажатии правой кнопки мыши в любой папке в Проводнике, система показывает контекстное меню. В данном меню есть пункт Сортировка, содержащий свое собственное меню. Вы можете настроить для любой папки свой собственный вид меню Сортировка, выбрав в нем пункт Подробнее..., если же Вам необходимо изменить вид данного меню отображаемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените вид меню Сортировка в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения набора пунктов во всех папках Проводника добавьте или удалите значения во всех шаблонах.

Все шаблоны хранятся в разделах следующей ветки реестра:

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для настройки меню Сортировка, используемого по умолчанию в Проводнике, сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте ветку необходимого Вам шаблона.
Например: для добавления или удаления пунктов в меню Сортировка для обычной папки использующей шаблон типа папки «Музыка» откройте:

А для добавления или удаления пунктов в меню Сортировка для папки «Музыка», входящей в Библиотеки откройте:

3) Задайте полные права на доступ к этому разделу реестра.

3.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
3.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
3.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
3.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
3.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

4) Перейдите в раздел TopViews
5) Поочередно открывая подразделы типа {XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX} измените значения параметра SortByList (щелчок правой кнопкой мыши на параметре → Изменить) стоящие после слова prop: .
6) Добавьте к существующим значениям необходимые или удалите ненужные.
Порядок значений в списке соответствует порядку отображения пунктов в меню. Значения отделяются друг от друга точкой с запятой (;).
Например:

В таблице ниже, указаны значения наиболее часто используемых значений данного параметра.

Наименование значения параметра | Отображаемое значение
System.Audio.ChannelCount | Каналы, количество
System.Audio.EncodingBitrate | Скорость потока
System.Audio.EncodingBitrate | Скорость потока
System.Audio.SampleRate | Частота дискретизации
System.Author | Авторы
System.Comment | Комментарии
System.ComputerName | Компьютер
System.Copyright | Авторские права
System.DateCreated | Дата создания
System.DateModified | Дата изменения
System.FileAttributes | Атрибуты
System.FileOwner | Владелец
System.Image.BitDepth | Глубина цвета
System.Image.Dimensions | Размеры
System.Image.HorizontalResolution | Горизонтальное разрешение
System.Image.HorizontalSize | Ширина
System.Image.ResolutionUnit | Единица разрешения
System.Image.VerticalResolution | Разрешение по вертикали
System.Image.VerticalSize | Высота
System.ItemFolderPathDisplay | Путь к папке
System.ItemNameDisplay | Имя
System.ItemType | Тип элемента
System.Keywords | Ключевые слова
System.Media.DateEncoded | Дата создания мультимедиа
System.Media.Duration | Продолжительность
System.Media.SubTitle | Субтитры
System.Media.Year | Год
System.Music.Artist | Участвующие исполнители
System.Music.Genre | Жанр
System.Photo.DateTaken | Дата съемки
System.PropGroup.Audio | Группа Аудио
System.PropGroup.Content | Группа Содержание
System.PropGroup.Description | Группа Описание
System.PropGroup.FileSystem | Группа Файл
System.PropGroup.Image | Группа Изображение
System.PropGroup.Media | Группа Носитель
System.PropGroup.Origin | Группа Источник
System.PropGroup.Video | Группа Видео
System.Rating | Оценка
System.SharedWith | Общий доступ
System.Size | Размер
System.Subject | Тема
System.Title | Название
System.Video.EncodingBitrate | Скорость передачи данных
System.Video.FrameHeight | Высота кадра
System.Video.FrameRate | Частота кадров
System.Video.FrameWidth | Ширина кадра
System.Video.TotalBitrate | Общая скорость потока
Наименование значения параметра | Отображаемое значение


21. Запрещение подмены функции кнопки "Завершения работы" при необходимости обновления системы.

При наличии обновлений, ожидающих установки, на кнопке завершения работы Windows появляется значок со щитом.

Если не применить данный твик реестра, то когда имеются обновления, доступные для установки, при выборе в меню Пуск команды Завершение работы по умолчанию выберется действие - Установить обновления и завершить работу.
Чтобы отключить данную функцию в диалоговом окне Завершение работы Windows и отобразить по умолчанию параметр, выбранный при последнем выключении (Гибернация, Перезагрузка и т. д.), вне зависимости от доступности параметра Установить обновления и завершить работу в списке создайте и примените reg-файл следующего содержания:


22. Постоянное отображение команд "Открыть окно команд" и "Копировать как путь" в контекстном меню Проводника.

Если Вы будете удерживать клавишу ⇑ Shift при нажатии правой кнопки мыши, то в контекстном меню появятся дополнительные пункты Открыть командную строку и Копировать как путь.

Чтобы пункт Открыть командную строку отображался без нажатия ⇑ Shift создайте и примените нижеследующий reg-файл:

Чтобы заставить пункт Открыть командную строку снова отображаться только при нажатии ⇑ Shift создайте и примените нижеследующий reg-файл:

Чтобы пункт Копировать как путь отображался без нажатия ⇑ Shift создайте и примените нижеследующий reg-файл:

Минус такого решения - появляющееся на доли секунды окно командной строки.

Чтобы заставить пункт Копировать как путь снова отображаться только при нажатии ⇑ Shift создайте и примените нижеследующий reg-файл:

Если Вам не нравится появляющееся на долю секунды окно командной строки, то Вы можете воспользоваться утилитой NirCmd
Данная утилита позволяет выполнять команды командной строки без отображения окна команд.
Для отображения пункта Копировать как путь без нажатия ⇑ Shift, сделайте следующее:

1) Скачайте утилиту NirCmd в соответствии с разрядностью Вашей Windows
2) Распакуйте скаченный zip-архив в папку C:\NirCmd
3) Запустите Редактор реестра (Win   + R → regedit → ОК)
4) Откройте раздел HKEY_CLASSES_ROOT\AllFilesystemObjects\shell\CopyAsPath\Command
5) Измените значение параметра По умолчанию на:


23. Добавление произвольного системного элемента ActiveX в Рабочий стол области переходов Проводника.

23. Добавление произвольного системного ActiveX-элемента в Рабочий стол области переходов Проводника.

По умолчанию в Проводнике отображается определенный набор объектов ActiveX: Избранное, Библиотеки, Компьютер и Сеть или более расширенный, если у Вас в настройках элемента Параметры папок установлен флажок Показать все папки.

Чтобы добавить какой-либо из системных объектов в область переходов, Вам необходимо знать его статистически уникальный 128-битный идентификатор - {GUID}.
Список всех идентификаторов ({GUID}) находится в разделе реестра: HKEY_CLASSES_ROOT\CLSID\{GUID}. Из данного списка в область переходов, добавить Вы можете, те ActiveX-объекты, которые имеют интерфейс IShellFolder (интерфейс для объектов, расширяющих пространство имен оболочки). Данный факт определяется наличием в {GUID} разделе реестра подраздела ShellFolder.
Для экономии времени, необходимого на поиск нужного элемента Вы можете воспользоваться утилитой CLSID Dump, позволяющей получить список всех ActiveX-объектов, имеющих IShellFolder интерфейс.

1) Скачайте CLSID Dump, распакуйте архив и запустите программу.
2) Найдите в CLSID Dump, необходимый Вам {GUID} ActiveX-объекта и откройте его в реестре:
2.1) Нажмите в самой программе на кнопку Open Regedit
или
2.2) Запустите редактор реестра (Win   + R → regedit → ОК) и откройте раздел

где вместо {GUID} вставьте найденное Вами значение.
3) Откройте в данном разделе подраздел ShellFolder.

Например: элементу "Все задачи" соответствует {GUID} равный {ED7BA470-8E54-465E-825C-99712043E01C}, следовательно необходимо открыть:

4) Задайте полные права на доступ к разделу HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder.

4.1) Щелкните правой кнопкой мыши на выбранном разделе реестра и выберите из меню пункт Разрешения.
4.2) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.
4.3) Если флажок недоступен или Вы видите сообщение об ошибке, то нажмите кнопку Дополнительно и перейдите на вкладку Владелец.
4.4) Выделите свою учетную запись, установите флажок Заменить владельца подконтейнеров и объектов и нажмите кнопку ОК.
4.5) Выделите группу Администраторы, установите флажок Полный доступ и нажмите кнопку ОК.

5) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder присутствует строковый параметр WantsParseDisplayName, то удалите его.
6) Если в разделе HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder отсутствует строковый параметр PinToNameSpaceTree, то создайте его с пустым значением.

Включите отображение объекта для перечисления.

7) Если необходимо, измените значение параметра Attributes таким образом, чтобы третья цифра стала равна 0. Например: вместо 20100004 задайте 20000004 .

Добавьте Ваш ActiveX-объект в пространство имен Рабочего стола.

8) Перейдите в раздел:

9) Создайте здесь подраздел с названием идентичным Вашему {GUID}. Например:

Разрешите отображение Вашего объекта только в области переходов Проводника, исключая отображение его на Рабочем столе.

11) Перейдите в раздел:

12) Создайте здесь DWORD-параметр с названием идентичным Вашему {GUID} и задайте ему значение равное 1.
13) Закройте редактор реестра.
14) Выйдите из системы и войдите в неё заново или перезагрузите компьютер.

Описанным выше способом, Вы можете добавить почти любой из ActiveX-объектов имеющих интерфейс IShellFolder.


24. Изменение вида приглашения в командной строке.

Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка).

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
3) Создайте PROMPT типа REG_EXPAND_SZ (расширяемый строковый параметр)
4) Присвойте ему любое из следующих значений (значения можно объединять):

$B - | (вертикальная черта)
$D - текущая дата
$G - > (знак больше)
$L - < (знак меньше)
$N - текущий диск
$P - текущий диск и путь
$Q - = (знак равно)
$T - текущее время
$V - версия Windows
$$ - $ (знак доллара)
$A - & (амперсанд)
$C - ( (левая скобка)
$F - ) (правая скобка)
$S - пробел
[%computername%] - имя Вашего компьютера
$_ - переход к началу новой строки экрана

5) Перезагрузите компьютер.

Например при введении знгачения:

Вы увидите строку наподобие:


25. Изменение языка интерфейса установленного по умолчанию (язык системы), для возможности его удаления или правильного определения программами.

Иногда бывает, если у Вас установлена английская версия и сверху русский языковой пакет, то некоторые программы, имеющие встроенную функцию определения языка могут некорректно определить язык Вашей системы и автоматически запускаться с английским языком интерфейса.
Также, если Вы решите удалить английский язык из системы после установки сверху русского языкового пакета, то система не позволит Вам этого сделать. Это происходит потому, что для Windows английский язык - это язык системы или язык интерфейса установленный по умолчанию, а русский язык - дополнительный язык интерфейса.

Чтобы переключить язык интерфейса установленного по умолчанию создайте и примените reg-файл, после чего перезагрузите компьютер.

Чтобы установить русский язык, в качестве языка используемого по умолчанию (язык системы):

Чтобы установить английский язык, в качестве языка используемого по умолчанию (язык системы):


26. Настройка вида, используемого по умолчанию для папок в Проводнике и в диалоговом окне "Открыть/Сохранить файл".

При нажатии правой кнопки мыши в любой папке в Проводнике, система показывает контекстное меню. В данном меню есть пункт Вид, используя который Вы можете настроить для любой папки свой собственный вид. Но если же Вам необходимо изменить вид папки используемый по умолчанию для всех папок, то Вам необходимо внести соответствующие изменения в реестр.

Для папки входящей в "Библиотеки" используются один шаблон, для всех входящих в нее папок. Для обычных папок, тип каждой папки выбирается на вкладке "Настройка" в свойствах папки.
В зависимости от месторасположения папок используемых Вами яў хранения файлов, измените значения в шаблонах папок библиотек или в шаблонах обычных папок. Для изменения вида папок по умолчанию во всех папках Проводника добавьте или удалите значения во всех шаблонах.

Вид используемого шаблона | GUID (Имя раздела)
Шаблоны для обычных папок, не входящих в Библиотеки.
Шаблон для типа папки «Общие элементы» | {5c4f28b5-f869-4e84-8e60-f11db97c5cc7}
Шаблон для типа папки «Документы» | {7d49d726-3c21-4f05-99aa-fdc2c9474656}
Шаблон для типа папки «Изображения» | {b3690e58-e961-423b-b687-386ebfd83239}
Шаблон для типа папки «Музыка» | {94d6ddcc-4a68-4175-a374-bd584a510b78}
Шаблон для типа папки «Видео» | {5fa96407-7e77-483c-ac93-691d05850de8}
Шаблоны, используемые для папок входящих в Библиотеки.
Шаблон для папки «Документы», входящей в Библиотеки | {fbb3477e-c9e4-4b3b-a2ba-d3f5d3cd46f9}
Шаблон для папки «Изображения», входящей в Библиотеки | {0b2baaeb-0042-4dca-aa4d-3ee8648d03e5}
Шаблон для папки «Музыка», входящей в Библиотеки | {3f2a72a7-99fa-4ddb-a5a8-c604edf61d6b}
Шаблон для папки «Видео», входящей в Библиотеки | {631958a6-ad0f-4035-a745-28ac066dc6ed}
Шаблон для папки «Общие элементы», входящей в Библиотеки | {5f4eab9a-6833-4f61-899d-31cf46979d49}
Шаблоны, используемые для результатов поиска в папках входящих в Библиотеки.
Результаты поиска в папке «Документы», входящей в Библиотеки | {36011842-dccc-40fe-aa3d-6177ea401788}
Результаты поиска в папке «Изображения», входящей в Библиотеки | {4dcafe13-e6a7-4c28-be02-ca8c2126280d}
Результаты поиска в папке «Музыка», входящей в Библиотеки | {71689ac1-cc88-45d0-8a22-2943c3e7dfb3}
Результаты поиска в папке «Видео», входящей в Библиотеки | {ea25fbd7-3bf7-409e-b97f-3352240903f4}
Результаты поиска в папке «Общие элементы», входящей в Библиотеки | {7fde1a1e-8b31-49a5-93b8-6be14cfa4943}

Для настройки используемого по умолчанию вида папки, сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) В зависимости от того, для чего Вы хотите настроить используемый по умолчанию вид папки, откройте соответствующий раздел реестра.

Для использования по умолчанию в Проводнике:

Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

3) Создайте раздел, соответствующий GUID выбранного Вами шаблона. Например, для настройки вида папок использующих наиболее часто встречающийся шаблон "Общие элементы" создайте:

Для использования по умолчанию в Проводнике:

Для использования по умолчанию в стандартном диалоге "Открыть/Сохранить файл":

4) Создайте в данном разделе три параметра DWORD: IconSize,LogicalViewMode и Mode и задайте им значения в соответствии с нижеследующей таблицей. Для удобства использования значения предоставлены в двух системах исчисления.

Вид папки: | Система исчисления | IconSize | LogicalViewMode | Mode
Огромные значки | Десятич | 256 | 3 | 1
 | Шестнадцатерич | 100 | 3 | 1
Крупные значки | Десятич | 96 | 3 | 1
 | Шестнадцатерич | 60 | 3 | 1
Обычные значки | Десятич | 48 | 3 | 1
 | Шестнадцатерич | 30 | 3 | 1
Мелкие значки | Десятич | 16 | 3 | 1
 | Шестнадцатерич | 10 | 3 | 1
Список | Десятич | 16 | 4 | 3
 | Шестнадцатерич | 10 | 4 | 3
Таблица | Десятич | 16 | 1 | 4
 | Шестнадцатерич | 10 | 1 | 4
Плитка | Десятич | 48 | 2 | 6
 | Шестнадцатерич | 30 | 2 | 6
Содержимое | Десятич | 32 | 5 | 8
 | Шестнадцатерич | 20 | 5 | 8

Например, чтобы установить вид папки Крупные значки создайте DWORD-параметры IconSize=60, LogicalViewMode=3 и Mode=1.

5) Перезагрузите компьютер или перезайдите в систему.

Примечание:

Если Вы ранее в Проводнике вручную изменяли вид для какой-либо папки, то система записала Ваши изменения в реестр, и чтобы желаемый Вами вид папки установился также и в них, то Вам необходимо, выполнить на выбор одно из предложенных действий:

1) Удалить из раздела HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags все папки, кроме AllFolders
2) Изменить параметры Mode, LogicalViewMode и IconSize на необходимые Вам значения в разделах:

где XXX - номер папки (раздела), в который записаны значения измененных Вами параметров.
{GUID} - данный GUID соответствует типу папки. Перейти к началу Общего списка советов.


27. Удаление открываемых путей из истории в адресной строке Проводника.

Когда Вы вводите путь в адресную строку Проводника, то он сохраняется в журнал расположений. И если Вы в дальнейшем нажмете на стрелку вниз в конце адресной строки, то откроется список предыдущих расположений.
Если Вам необходимо его очистить,то Вы можете либо полностью стереть историю открываемых путей или удалить отдельные записи.

Чтобы очистить всю Вашу историю посещений в Проводнике, щелкните правой кнопкой мыши на адресной строке и выберите из меню пункт Удалить журнал.

Чтобы удалить отдельные записи:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TypedPaths
3) Удалите параметры, в которых содержатся ненужные вам пути.
4) Перезайдите в систему или закройте все процессы Проводника и запустите его снова.


28. Добавление OEM информации (лого, производитель и т.д.) в окно просмотра сведений о компьютере - Система.

Если Вы купили уже готовый компьютер, собранный какой-либо компанией, то при открытии окна Система (Win   + Pause
Break) Вы скорее всего увидите сведения о производителе.
Данную информацию обычно принято называть OEM информацией.

Чтобы изменить или указать собственную OEM информацию, Вы можете воспользоваться одним из предложенных ниже вариантов:

Вариант 1.

1) Создайте рисунок с нужным Вам логотипом.
2) Сохраните его с разрешением 120x120 в формате .bmp (Например, в папке C:\Windows\System32 под именем OEMLogo.bmp).
3) Запустите редактор реестра (Win   + R → regedit → OK)
4) Откройте раздел HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OEMInformation
5) Создайте строковые параметры с необходимыми Вам значениями. Например:

Model - Название модели
Manufacturer - Название фирмы
SupportPhone - Телефон поддержки
SupportURL - Адрес сайта службы поддержки
SupportHours - Время работы тех.поддержки
Logo - Путь к Вашему логотипу.

6) Перезагрузите компьютер.

Также Вы можете создать и применить reg-файл.

Пример:

Введите необходимые Вам значения, вместо указанных в примере.

Вариант 2.

1) Скачайте и распакуйте в любую папку архив Windows7OemInfoEditor.zip.
2) Запустите необходимую Вам версию программы.

Windows7OemInfoEditor_en.exe - оригинальная английская версия программы: Windows 7 Oem Info Editor.
Windows7OemInfoEditor_ru.exe - версия программы переведенная мною на русский язык: Редактор OEM Информации в Windows 7.

3) Введите желаемые значения полей и нажмите сначала кнопку Сохранить (Save), а затем кнопку Выйти (Exit).
4) Перезагрузите компьютер или перезайдите в систему.


29. Изменение режима работы полос прокрутки.

По умолчанию, чтобы воспользоваться полосой прокрутки в неактивном окне Вам необходимо переключит© на него.
Указанные ниже твики реестра позволяют изменить поведение полос прокрутки.
Чтобы задействовать работу полос прокрутки в данных режимах, Вам необходимо будет только перевести курсор мыши на неактивное окно.

Вариант 1. Активация полос прокрутки неактивного окна без переключения на него.

1) Создайте и примените reg-файл следующего содержания

2) Перезагрузите компьютер или перезайдите в систему.

Вариант 2. Активация полос прокрутки неактивного окна путем переключения на него.

1) Создайте и примените reg-файл следующего содержания.

2) Перезагрузите компьютер или перезайдите в систему.

Чтобы восстановить изначальные значения создайте и примените reg-файл следующего содержания, после чего перезагрузите компьютер.


30. Включение отключенного диалога подтверждения удаления в аплете "Программы и компоненты".

Если Вы в диалоге подтверждения действия, появляющемся при удалении программ в аплете "Программы и компоненты" установили флажок "Больше не показывать это диалоговое окно", то вернуть обратно данное диалоговое окно Вы сможете только внеся изменения в реестр, для этого выполните следующие действия:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\DontShowMeThisDialogAgain
3) Измените значение параметра {948e51fb-0a48-44f0-86ac-33c36def540c} на YES, либо удалите данный параметр.
4) Перезагрузите компьютер или перезайдите в систему.


31. Настройка анимации иконки пользователя в меню Пуск.

Вверху меню Пуск содержится изображение пользователя, которое меняется при наведении курсора на другой пункт меню.
Путем внесения изменений в реестр Вы можете изменить скорость анимации яў данной иконки, либо полностью отключить эффект смены изображений.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\StartPage
3) Создайте в данном разделе, необходимые Вам параметры из указанных ниже.
4) Для применения внесенных Вами настроек перезагрузите компьютер или перезаудите в систему.

Настройка времени паузы перед сменой изображения.

1) Создайте DWORD-параметр StartPanel_FadeDelay
2) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
3) Переключите систему исчисления на десятичную и установите значение данного параметра равным времени задержки в миллисекундах (1000 миллисекунд=1 секунда).

Отключение смены изображений.

1) Создайте DWORD-параметр StartPanel_FadeDelay
2) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
3) Установите значение данного параметра в шестнадцатеричной системе равным FFFFFFFF или в десятеричной 4294967295 .

Настройка скорости исчезновения текущего изображения.

1) Создайте DWORD-параметр StartPanel_FadeIn
2) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
3) Переключите систему исчисления на десятичную и установите значение данного параметра равным скорости исчезновения текущего значка в миллисекундах (1000 миллисекунд=1 секунда).
При установке значения параметра StartPanel_FadeIn равным нулю, текущее изображение исчезнет моментально, и начнет появляться новая иконка.

Настройка скорости ¦вления нового изображения.

1) Создайте DWORD-параметр StartPanel_FadeOut
2) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
3) Переключите систему исчисления на десятичную и установите значение данного параметра равным скорости ¦вления нового значка в миллисекундах (1000 миллисекунд=1 секунда).
При установке значения параметра StartPanel_FadeOut равным нулю, новое изображение появляется моментально, сразу после исчезновения текущей иконки.

Отключение анимации при смене изображений.

Для моментальной смены изображения, без использования анимации установите значений обеих параметров: StartPanel_FadeOut и StartPanel_FadeIn равными нулю. Перейти к началу Общего списка советов.


32. Изменение интервала автоматической синхронизации времени компьютера с сервером.

По умолчанию, автоматическая синхронизация времени компьютера с сервером проиходит раз в неделю.
При такой настройке часы Вашего компьютера могут получить погрешность во времени.
Поэтому рекомендуется уменьшить интервал между обновлениями, что позволит поддерживать точность хода часов Вашего компьютера.
Для этого Вам необходимо внести изменения в системный реестр Windows.

1) Запустите редактор реестра (Win   + R → regedit → OK)
2) Откройте раздел HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpClient
3) Измените значение параметра SpecialPollInterval на необходимое Вам.
Данное значение указывается в секундах. По умолчанию оно равно 604800, что соответствует неделе. Для синхронизации времени каждый час установите значение 3600.
4) Перезагрузите компьютер.


33. Удаление области уведомлений (System Tray) с панели задач.

Если Вы желаете удалить с панели задач область уведомлений (System Tray), то создайте и примените reg-файл указанного ниже содержания, а затем перезагрузите компьютер:

Чтобы вернуть область уведомлений обратно на панель задач, то создайте и примените reg-файл указанного ниже содержания, а затем перезагрузите компьютер:

Также Вы можете воспользоваться программой Hide Systemtray, которая позволяет выполнить указанные операции автоматически.


34. Отключение всплывающего уведомления "Цветовая схема изменена на Windows 7 — упрощенный стиль".

Если Вы желаете отключить всплывающее уведомление "Цветовая схема изменена на Windows 7 — упрощенный стиль", то Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

Создайте и примените reg-файл указанного ниже содержания, а после применения перезагрузите компьютер:

Вариант 2.

1) Запустите командную строку (Win+R → cmd → OK)
2) Введите необходимую Вам команду и нажмите Enter ↵:

Отключение всплывающего уведомления "Цветовая схема изменена на Windows 7 — упрощенный стиль"

Включение всплывающего уведомления "Цветовая схема изменена на Windows 7 — упрощенный стиль"


35. Отключение и включение отображения эскизов панели задач.

Если Вы желаете, чтобы вместо эскизов панели задач для всплывающих подсказок использовался стандартный текст, то сделайте следующее.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD.
4) Переименуйте его в TaskbarNoThumbnail
5) Измените значение на 1.
6) Перезагрузите компьютер.

Также Вы можете также создать и применить reg-файл следующего содержания:

Чтобы вернуть отображение эскизов обратно - удалите параметр TaskbarNoThumbnail из раздела реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


36. Удаление и восстановление вкладок из окна Свойства файла.

При нажатии правой кнопкой мыши на файле и выборе пункта Свойства откроется окно с информацией о файле.
При желании Вы можете удалить некоторые из отображаемых вкладок.

Чтобы удалить вкладку Безопасность из окна Свойства файла создайте и примените указанный ниже reg-файл:

Чтобы удалить вкладку Подробно из окна Свойства файла создайте и примените указанный ниже reg-файл:

Чтобы удалить вкладку Предыдущие версии из окна Свойства файла создайте и примените указанный ниже reg-файл:

Чтобы удалить вкладку Совместимость из окна Свойства файла создайте и примените указанный ниже reg-файл:

Чтобы восстановить вкладку Безопасность из окна Свойства файла создайте и примените указанный ниже reg-файл:

Чтобы восстановить вкладку Подробно из окна Свойства файла создайте и примените указанный ниже reg-файл:

Чтобы восстановить вкладку Предыдущие версии из окна Свойства файла создайте и примените указанный ниже reg-файл:

Чтобы восстановить вкладку Совместимость из окна Свойства файла создайте и примените указанный ниже reg-файл:


37. Запрещение и разрешение изменения положения панели задач на экране.

Чтобы запретить изменение положения панели задач на экране, создайте и примените reg-файл указанного ниже содержания, после чего перезагрузите компьютер.

Чтобы разрешить изменение положения панели задач на экране, создайте и примените reg-файл указанного ниже содержания, после чего перезагрузите компьютер.


38. Настройка мигания иконки фоновой программы на панели задач, требующей активизации.

Существуют определенные моменты, когда на панели задач начинает мигать кнопка программы, требующей активизации (открытия окна, ввода данных и т.д.).
Вы можете настроить количество миганий иконки, следующим образом:

1) Запустите редактор реестра (Win   + R → regedit → OK)
2) Откройте раздел HKEY_CURRENT_USER\Control Panel\Desktop
3) Щелкните правой кнопкой мыши на параметре ForeGroundFlashCount и выберите Изменить.
4) Установите Система исчисления в значения Десятич.
5) Введите необходимое Вам значение и нажмите ОК.
Внимание: значение 0 не отключает мигание, а заставляет иконку мигать постоянно. Значение по умолчанию равно 7.
6) Перезагрузите компьютер.

Вы также можете настроить параметр ForegroundLockTimeout, который указывает величину интервала времени, отведенного на мигание.
После истечения данного интервала программа, требующая фокус, автоматически перейдет на передний план. Значение данного параметра по умолчанию равно 200000 мс.


39. Удаление и восстановление пункта Настроить папку из контекстного меню.

Чтобы удалить пункт Настроить папку из контекстного меню, создайте и примените указанный ниже reg-файл.

Чтобы восстановить пункт Настроить папку в контекстном меню, создайте и примените указанный ниже reg-файл.


40. Удаление и восстановление пунктов Открыть в новом окне и Добавить в библиотеку из контекстного меню дисков и папок.

Для удаления пункта Открыть в новом окне из контекстного меню дисков и папок, создайте и примените reg-файл указанного ниже содержания.

Для восстановления пункта Открыть в новом окне в контекстном меню дисков и папок, создайте и примените reg-файл указанного ниже содержания.

Для удаления пункта Добавить в библиотеку из контекстного меню дисков и папок, создайте и примените reg-файл указанного ниже содержания.

Для восстановления пункта Добавить в библиотеку в контекстном меню дисков и папок, создайте и примените reg-файл указанного ниже содержания.


41. Удаление пункта "Следующее фоновое изображение рабочего стола" из контекстного меню рабочего стола.

Чтобы удалить пункт Следующее фоновое изображение рабочего стола из контекстного меню рабочего стола, создайте и примените указанный ниже reg-файл.

Чтобы восстановить пункт Следующее фоновое изображение рабочего стола из контекстного меню рабочего стола, создайте и примените указанный ниже reg-файл.


42. Удаление и восстановление пункта Отправить в контекстном меню.

Чтобы удалить пункт Отправить из контекстного меню, создайте и примените указанный ниже reg-файл.

Чтобы восстановить пункт Отправить в контекстном меню, создайте и примените указанный ниже reg-файл.


43. Удаление и восстановление пунктов из раздела Дополнительные параметры на вкладке Вид в диалоговом окне Параметры папок.

Для настройки дополнительных параметров папок, необходимо открыть Пуск → Панель управления → Параметры папок → Вид.
Вы можете удалить пункты из данного раздела, используя предложенные ниже решения.

Чтобы удалить пункт Восстанавливать прежние окна папок при входе в систему (Restore previous folder windows at logon) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Восстанавливать прежние окна папок при входе в систему (Restore previous folder windows at logon) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Всегда отображать значки, а не эскизы (Always Show Icons, Never Thumbnails) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Всегда отображать значки, а не эскизы (Always Show Icons, Never Thumbnails) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Всегда отображать меню (Always show menus) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Всегда отображать меню (Always show menus) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Выводить полный путь в строке заголовка (Display the Full Path in the Title Bar) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Выводить полный путь в строке заголовка (Display the Full Path in the Title Bar) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Запускать окна с папками в отдельном процессе (Launch folder windows in a separate process) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Запускать окна с папками в отдельном процессе (Launch folder windows in a separate process) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Использовать мастер общего доступа (Use Sharing Wizard) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Использовать мастер общего доступа (Use Sharing Wizard) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Использовать флажки яў выбора элементов (Use check boxes to select items) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Использовать флажки яў выбора элементов (Use check boxes to select items) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Отображать буквы дисков (Show drive letters) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Отображать буквы дисков (Show drive letters) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Отображать значки файлов на эскизах (Display file icon on thumbnails) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Отображать значки файлов на эскизах (Display file icon on thumbnails) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Отображать обработчики просмотра в панели просмотра (Show preview handlers in preview panel) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Отображать обработчики просмотра в панели просмотра (Show preview handlers in preview panel в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Отображать описания для папок и элементов рабочего стола (Show pop-up descriptions for folders and desktop items) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Отображать описания для папок и элементов рабочего стола (Show pop-up descriptions for folders and desktop items) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Отображать сведения о размере файлов в подсказках папок (Display file size information in folder tips) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Отображать сведения о размере файлов в подсказках папок (Display file size information in folder tips) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Отображать сжатые или зашифрованные файлы другим цветом (Show encrypted or compressed NTFS files in color) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Отображать сжатые или зашифрованные файлы другим цветом (Show encrypted or compressed NTFS files in color) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт При вводе текста в режиме "Список" (When typing into list view) с обеими его переключателями из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт При вводе текста в режиме "Список" (When typing into list view) с обеими его переключателями в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Скрывать защищенные системные файлы (рекомендуется) (Hide protected operating system files (Recommended)) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Скрывать защищенные системные файлы (рекомендуется) (Hide protected operating system files (Recommended)) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Скрывать пустые диски в папке "Компьютер" (Hide empty drives in the Computer folder) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Скрывать пустые диски в папке "Компьютер" (Hide empty drives in the Computer folder) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Скрывать расширения для зарегистрированных типов файлов (Hide extensions for known file types) из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Скрывать расширения для зарегистрированных типов файлов (Hide extensions for known file types) в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы удалить пункт Скрытые файлы и папки (Hidden files and folders) с обеими его переключателями из раздела Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.

Чтобы восстановить пункт Скрытые файлы и папки (Hidden files and folders) с обеими его переключателями в разделе Дополнительные параметры, создайте и примените reg-файл указанного ниже содержания.


44. Удаление пункта SkyDrive Pro из контекстного меню.

Чтобы удалить из контекстного меню пункт SkyDrive Pro, добавляемый Microsoft Office, выполните указанные ниже действия:

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_CLASSES_ROOT\AllFilesystemObjects\shell
3) Удалите подраздел SPFS.ContextMenu. Перейти к началу Общего списка советов.


45. Использование реестра для управления файлом подкачки pagefile.sys.

Для создания, изменения или удаления файлов подкачки необходима перезагрузка компьютера.

1) Запустите редактор реестра (Win   + R → regedit → OK).
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
3) Измените значение мультистрокового параметра PagingFiles (REG_MULTI_SZ) на одно из указанных ниже, для получения необходимого Вам результата.

Чтобы установить флажок Автоматически выбирать объем файла подкачки:

Снятие флажка Автоматически выбирать объем файла подкачки происходит при указании размера файла подкачки яў одного из имеющихся дисков.

1) Чтобы создать файл подкачки только на диске C: и установить для него значение Размер по выбору системы. И отключить файл подкачки яў всех остальных дисков (соответствует переключателю Без файла подкачки).

2) Чтобы создать файл подкачки и установить для него значение Размер по выбору системы для нескольких из имеющихся дисков, укажите путь к файлу подкачки на диске и рядом два нуля разделенные пробелом.
Например:
При наличие дисков C:, D:, E:, F: установить значение Размер по выбору системы, только для файлов подкачки на дисках C: и E:.
На дисках D: и F: отключить файл подкачки (соответствует переключателю Без файла подкачки).

3) Чтобы создать файл подкачки на диске C: и установить для него значение Размер по выбору системы, а на диске D: создать файл подкачки заданного размера.

Первое число после пути к файлу подкачки указывает исходный размер файла подкачки, а второе число задает максимальный размер файла подкачки.

4) Чтобы отключить использование всех существующих файлов подкачки (соответствует переключателю Без файла подкачки) полностью очистите значение указанное для мультистрокового параметра PagingFiles (REG_MULTI_SZ).

Готовые reg-файлы:

Чтобы установить флажок Автоматически выбирать объем файла подкачки:

Чтобы снять флажок Автоматически выбирать объем файла подкачки, создать файл подкачки только на диске C: и установить для него значение Размер по выбору системы:

Чтобы отключить использование всех существующих файлов подкачки (соответствует переключателю Без файла подкачки):


46. Замена мест расположения в диалоговых окнах "Открыть" и "Сохранить как" на собственные значения.

Если предложенный список мест расположения в диалоговых окнах "Открыть" и "Сохранить как" Вам кажется неудобным, то для ускорения навигации Вы можете заменить его на собственный.
Для этого создайте и примените reg-файл, указанного ниже содержания:

Внимание.: При указании путей к папкам в reg-файле используйте двойной слэш вместо одинарного.

Для добавления команд Shell, использующих имя объектов, Вы можете воспользоваться таблицей №2 из
Раздел: Интерфейс - Взаимодействие.
Совет: 4. Запуск команд Windows Shell, используя названия и {GUID} объектов.


1. Запуск Редактора реестра, создание и применение reg-файла.

Запуск Редактора Реестра:

Вариант 1.

1.1) Откройте меню Пуск → Все программы → Стандартные → Выполнить (или нажмите сочетание клавиш Win   + R)
1.2) Введите команду regedit и нажмите ОК
Если Вы работаете под учетной записью администратора, то при отключенном UAC (контроле учетных записей) програма запустит© с правами администратора.

Вариант 2.

2.1) Откройте меню Пуск
2.2) В строке поиска введите regedit и нажмите Ctrl + ⇑ Shift + Enter ↵ для запуска с правами администратора.

Вариант 3.

3.1) Откройте в Проводнике папку C:\Windows
3.2) Щелкните правой кнопкой мыши на по файлу regedit.exe и выберите пункт Запуск от имени администратора.

Вариант 4.

4.1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4.2) Введите команду regedit и нажмите клавишу Enter ↵.

Создание reg-файла.

Вариант 1.

1.1) Откройте Блокнот (Notepad).
1.1.1) Откройте меню Пуск → Все программы → Стандартные → Блокнот (или нажмите сочетание клавиш Win   + R → введите notepad → нажмите ОК).
1.2) Скопируйте необходимый Вам код в окно программы Блокнот.
1.3) В меню программы нажмите Файл и выберите пункт Сохранить.
1.4) В открывшемся окне:
1.4.1) Укажите место сохранения файла.
1.4.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
1.4.3) Выберите тип файла: Все файлы (*.*).

Внимание:
Если Вы оставите тип файла: Текстовые файлы (*.txt), то имя файла обязательно нужно взять в кавычки. (Например: "Demo.reg")

1.5) Нажмите на кнопку Сохранить.

Вариант 2.

Если у Вас убран флажок Скрывать расширения для зарегистрированных типов файлов в Параметры папок (Панель управления\Оформление и персонализация\Параметры папок → Вкладка Вид), то Вы можете создать reg-файл следующим способом:

2.1) В папке, где Вы хотите создать reg-файл, щелкните правой кнопкой мыши.
2.2) Во всплывшем меню выберите Создать → Текстовый документ.
2.3) Сотрите имя и расширение файла .txt, укажите необходимое Вам имя файла и расширение .reg, нажмите клавишу Enter ↵, а затем кнопку Да.
2.4) Щелкните на созданном Вами файле правой кнопкой мыши и выберите пункт Изменить.
2.5) Скопируйте необходимый Вам код в окно программы Блокнот.
2.6) Нажмите сочетание клавиш Ctrl + S.

Вариант 3.

3.1) Возьмите любой готовый reg-файл.
3.2) Щелкните на нем правой кнопкой мыши и выберите пункт Изменить.
3.3) Скопируйте необходимый Вам код в окно программы Блокнот.
3.4) В меню программы нажмите Файл и выберите пункт Сохранить Как.
3.5) В открывшемся окне:
3.5.1) Укажите место сохранения файла.
3.5.2) Укажите имя файла и расширение .reg (Например: Demo.reg)
3.5.3) Выберите тип файла: Все файлы (*.*).
3.6) Нажмите на кнопку Сохранить

Применение reg-файла.

Вариант 1.

1) Щелкните два раза левой кнопкой мыши на reg-файле и нажмите кнопку Да.

Вариант 2.

2.1) Щелкните правой кнопкой мыши на reg-файле.
2.2) Выберите пункт Слияние и нажмите кнопку Да.

Вариант 3.

3.1) Откройте меню Пуск → Все программы → Стандартные → Выполнить (или нажмите сочетание клавиш Win   + R)
3.2) Введите команду regedit /s Путь_к_файлу\имя_файла.reg и нажмите ОК (Например: regedit /s D:\myfile.reg)
Для применения многих reg-файлов необходимо, чтобы Вы работали под учетной записью администратора и Контроль Учетных Записей (UAC) был отключен.

Вариант 4.

4.1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4.2) Введите команду regedit /s Путь_к_файлу\имя_файла.reg и нажмите клавишу Enter ↵. (Например: regedit /s D:\myfile.reg)

Внимание: Если у Вас в реестре уже будет присутствовать параметр добавляемый reg-файлом, то при применении reg-файла, имеющиеся значения параметров будут заменены на новые.


2. Создание и переименование раздела или параметра, а также изменение параметра в редакторе реестра.

Вы запустили программу "Редактор реестра" как описано в совете 1. Запуск программы "Редактор реестра", создание и применение reg-файла. из раздела Твики Реестра - Общие. Используя дерево папок открыли нужный Вам раздел, и теперь, Вам необходимо создать, переименовать параметр (раздел), либо изменить значение параметра реестра. Существует несколько способов сделать это.

Создание раздела или параметра в редакторе реестра.

Вариант 1.

1) Щелкните в главном меню пункт Правка.
2) Наведите курсор мыши на пункт меню Создать.
3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

Вариант 2.

1) Щелкните правой кнопкой мыши в любом пустом месте области параметров (правая часть окна).
2) Наведите курсор мыши на пункт меню Создать.
3) В раскрывающемся меню выберите раздел или тип параметра, который Вы желаете добавить.

Переименование раздела или параметра в редакторе реестра.

Вариант 1.

1) Выберите раздел или параметр, который Вы желаете переименовать.
2) Щелкните в главном меню пункт Правка, а затем на пункт Переименовать.

Вариант 2.

1) Щелкните правой кнопкой мыши на раздел или параметр, который Вы желаете переименовать.
2) Щелкните левой кнопкой мыши на пункт Переименовать.

Изменение значения параметра в редакторе реестра.

Вариант 1.

1) Выберите параметр, который Вы желаете изменить.
2) Щелкните в главном меню пункт Правка, а затем на пункт Изменить.

Вариант 2.

1) Щелкните правой кнопкой мыши на параметр, который Вы желаете изменить.
2) Щелкните левой кнопкой мыши на пункт Изменить

Вариант 3.

Щелкните дважды на параметре, который Вы желаете изменить. Перейти к началу Общего списка советов.


3. Аббревиатуры используемые для обозначения веток реестра.

Для обозначения пути к разделу или ключу реестра могут использоваться следующие аббревиатуры:

Наименование раздела | Используемая аббревиатура
HKEY_CLASSES_ROOT | HKCR
HKEY_CURRENT_USER | HKCU
HKEY_LOCAL_MACHINE | HKLM
HKEY_USERS | HKU
HKEY_CURRENT_CONFIG | HKCC


4. Быстрый переход в необходимый раздел реестра.

Если яў работы с реестром Вы предпочитаете не использовать альтернативные программы, то для быстрого перехода в необходимый Вам раздел реестра Вы можете воспользоваться одним из указанных ниже вариантов.

Вариант 1.

1) Скачайте маленькую бесплатную утилиту от Microsoft: RegJump
2) Распакуйте архив в любую папку и скопируйте файл regjump.exe в папку C:\Windows\System32
3) Теперь любую ветку реестра можно открыть прямо из диалогового меню Выполнить или из строки поиска в меню Пуск.
3.1) В диалоговом меню Выполнить (Win   + R), либо в строке поиска из меню Пуск введите команду regjump и путь к разделу, указав его в кавычках.

Например:

3.2) Нажмите клавишу Enter ↵, при вводе из окна Выполнить или ⇑ Shift + Enter ↵ при вводе в строку поиска:

Вариант 2.

1) Скачайте и установите программу Registry Workshop.
Данная программа позволит Вам переходить в разделы реестра, используя reg:// протокол.
2) Для перехода в любой раздел реестра введите в адресной строке Проводника, Internet Explorer или Mozilla Firefox необходимый Вам адрес ключа в реестре, как указано ниже и нажмите клавишу Enter ↵:

Например:

Вариант 3

1) Создайте специальный скрипт.

1.1) Скопируйте указанный код в любой текстовый редактор (например, Блокнот).
1.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .vbs
1.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "regkey.vbs")
1.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.
2) Переместите созданный Вами скрипт в любую удобную Вам папку.
Теперь для открытия раздела реестра:
3) Скопируйте в буфер обмена(Ctrl + C или Щелчок правой кнопкой мыши → Копировать) необходимую Вам ветку реестра.
4) Щелкните на созданный Вами скрипт-файл.

Минусом использования данного скрипта является отсутствие поддержки аббревиатур.


5. Отключение вывода диалогового окна при применении reg-файла.

При запуске reg-файла, система выводит диалоговое окно в котором пользователь должен подтвердить достоверность источника, откуда получены импортируемые в реестр сведения. Для отключения данного окна выполните указанные ниже действия:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_CLASSES_ROOT\regfile\shell\open\command
3) Дважды щелкните на параметре По умолчанию и введите значение:

4) Закройте редактор реестра и перезапустите компьютер.

Минусом данного решения является то, что помимо указанного диалогового окна запроса подтверждения, также не будет выводит© окно об успешном импортировании в реестр данных. Перейти к началу Общего списка советов.


6. Значения разделов реестра ControlSet001, ControlSet002 и CurrentControlSet.

Разделы реестра ControlSet содержат информацию о конфигурации системы, такую как драйверы устройств и службы.
При просмотре реестра Вы можете заметить несколько экземпляров ControlSet.
Некоторые из них являются копиями или зеркальными отображения других, а некоторые являются уникальными.

Различное количество подразделов реестра ControlSet может находит© в кустах реестра HKEY_CURRENT_USER, HKEY_LOCAL_MACHINE, HKEY_CURRENT_CONFIG в ветке SYSTEM.
Может существовать несколько ControlSet это зависит от того, как часто Вы изменяете параметры системы или как часто возникают неполадки с выбранными параметрами.
Обычно после установки Windows в реестре могут присутствовать следующие разделы:

\ControlSet001
\ControlSet002
\CurrentControlSet

Раздел ControlSet001 содержит информацию о последней конфигурации с которой Вы загрузили текущую систему.
Раздел ControlSet002 содержит информацию о последней удачной конфигурации или конфигурации последней успешной загрузки Windows.
Раздел CurrentControlSet на самом деле является указателем на один из разделов ControlSetXXX.

Чтобы лучше понять, как используются разделы ControlSet, Вам нужно узнать об еще одном разделе - Select

Раздел Select также находится в ветке SYSTEM и содержит следующие значения:

Current
Default
Failed
LastKnownGood

Каждое из этих значений содержит тип данных REG_DWORD и ссылаться на определенный ControlSet.
Например, если значение Current установлено 0x1, значит CurrentControlSet ссылается на ControlSet001.
Аналогично Если LastKnownGood равно 0x2, то последней удачной конфигурацией является ControlSet002.
Значение Default обычно идентично Current, а значение Failed ссылается на последнюю неудавшуюся загрузку Windows.
Если Вам необходимо изменить параметры системного реестра, то лучше выбрать CurrentControlSet, поскольку она является текущей конфигурацией и если внесенные Вами изменения нанесут вред системе, то Вы по-прежнему сможете воспользоваться последней удачной конфигурацией.


7. Создание и удаление разделов или параметров реестра используя reg-файл.

Добавление значений в реестр, используя reg-файл.

Для добавления раздела в реестр, создайте reg-файл используя следующий шаблон:

Например:

Для добавления(изменения) значения параметра в реестре, создайте reg-файл используя следующий шаблон:

Примеры:

Добавление(изменение) строкового параметра:

Добавление(изменение) параметра DWORD:

Добавление(изменение) двоичного параметра:

Добавление(изменение) параметра (По умолчанию):

Удаление значений из реестра, используя reg-файл.

Для удаления раздела из реестра, создайте reg-файл используя следующий шаблон:

Например:

Для удаления значения (присвоения ему нулевого значения) параметра из реестра, создайте reg-файл используя следующий шаблон:

Для полного удаления параметра из реестра, создайте reg-файл используя следующий шаблон:

Например:

Можно выделить следующие принципы построения reg-файла:

В reg-файле первой должна идти строка: Windows Registry Editor Version 5.00, затем пустая строка, и только после нее раздел, в который следует добавить необходимый Вам параметр.
Значок @ в reg-файле соответствует параметру (По умолчанию).
Название раздела реестра должно быть указано в квадратных скобках: []
При указании в значение параметра пути к файлу или папке используйте два обратных слеша: \\
Значения строкового параметра заключайте в кавычки, за исключением знака минус.
При удалении раздела реестра знак минус добавлятся перед открывающейся квадратной скобкой: [-
При удалении параметра реестра знак минус добавляется после знака равно: =-
При обнулении значения параметра после знака равно ставятся двойные кавычки: =""
При удалении раздела реестра не надо прописывать удаление параметров, имеющихся в данном разделе, так как они удалятся автоматически.


8. Создание и удаление разделов или параметров реестра используя командную строку.

Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.

Внимание: Значения содержащие пробелы должны быть заключены в кавычки.

Добавление значений в реестр, используя командную строку.

Для добавления значений в реестр используется команда REG ADD.

Путь - Полный путь к разделу реестра в виде КОРЕНЬ\Подраздел.
КОРЕНЬ - Корневой радел. Значения [ HKLM | HKCU | HKCR | HKU | HKCC].
Подраздел - Полный путь к разделу реестра в выбранном корневом разделе.

/v - Добавить параметр с определенным именем в указанном разделе.
/ve - Добавить параметр (По умолчанию) в указанный раздел.

/t - Типы данных [REG_SZ | REG_EXPAND_SZ | REG_MULTI_SZ | REG_DWORD | REG_BINARY]
REG_SZ - строковый параметр
REG_EXPAND_SZ - расширяемый строковый параметр
REG_MULTI_SZ - мультистроковый параметр
REG_DWORD - DWORD-параметр
REG_BINARY - Двоичный параметр
По умолчанию, считается равным REG_SZ.

/d - Значение, присваемое добавляемому параметру реестра.
/f - Принудительно перезаписать существующие записи реестра без предупреждения.
\0 - Перенос на другую строку в мультистроковом параметре.
^ - Используется для указывания путей в виде переменных перед знаком процента % в значениях параметров.

Примеры команды REG ADD:

1) Добавить подраздел MyCompany в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE:

2) Добавить строковый параметр с именем: Data и значением: C\MyProgram\MyFile.exe в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

3) Добавить DWORD-параметр с именем: Data и значением: FF (или 0xFF) в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

4) Добавить двоичный параметр с именем: Data и значением: fe340ead в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

5) Добавить расширяемый строковый параметр с именем: Data и значением: %systemroot%\Minidump\* /s в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение:

6) Добавить мультистроковый параметр с именем: Data в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany и указанным ниже значением из двух строк без вывода запроса на подтверждение:

%systemroot%\Minidump\* /s
%systemroot%\memory.dmp

7) Добавить параметр (По умолчанию) со значением: 00000419 в раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

Удаление значений из реестра, используя командную строку.

Для удаления значений из реестра используется команда REG DELETE.

Путь - Полный путь к разделу реестра в виде КОРЕНЬ\Подраздел.
КОРЕНЬ - Корневой радел. Значения [ HKLM | HKCU | HKCR | HKU | HKCC].
Подраздел - Полный путь к разделу реестра в выбранном корневом разделе.

/v - Удалить параметр с определенным именем в указанном разделе.
/ve - Удалить значение параметра (По умолчанию) в указанном разделе.
/va - Удалить все параметры в указанном разделе.

/f - Удалить принудительно, без дополнительного предупреждения.

Примеры команды REG DELETE:

1) Удалить подраздел MyCompany из раздела реестра HKEY_LOCAL_MACHINE\SOFTWARE

2) Удалить параметр Data из раздела реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

3) Удалить значение параметра (По умолчанию) в разделе реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.

4) Удалить все параметры реестра из раздела реестра HKEY_LOCAL_MACHINE\SOFTWARE\MyCompany без вывода запроса на подтверждение.


9. Добавление возможности создания файла реестра (reg-файла) из контекстного меню.

Если Вы часто создаете reg-файлы, то для Вас будет удобно добавить пункт для их создания в контекстное меню Создать.

Чтобы добавить возможность создания reg-файла из контекстного меню Создать, создайте и примените любой из указанных ниже reg-файлов.

или


10. Альтернативные программы используемые для редактирования реестра.

Входящая в состав Windows программа Редактор реестра (regedit.exe) при всем её великолепии имеет ряд ограничений по функциональности. Например, в ней нет адресной строки. Для полноценной работы с реестром рекомендуется использовать программы сторонних производителей. Наиболее известными являются: Registry Workshop, Registry Commander, RegEditX и Reg Organizer.

Registry Workshop

Данная программа является расширенным редактором системного реестра. Может быть идеальной заменой стандартному редактору, встроенному в операционную систему. В добавок к обычным функциям редактора, программа обладает различными мощными возможностями яў полноценного обслуживания реестра, при этом работая быстрее стандартного RegEdit. Все совершенные действия в программе могут быть отменены, даже в случае неоднократного перезапуска этой утилиты. Вы не будете переживать за совершенные ошибки при редактировании реестра, ведь в случае чего, их всегда можно будет отменить. Также Registry Workshop позволяет чистить реестр от различных ошибок и неправильных записей, обнаруживать и уничтожать троянских коней, вирусы и шпионские данные. А также позволяет создавать закладки, резервировать реестр и восстанавливать его из резервной копии, дефрагментировать реестр, сравнивать ветви реестра, открывать REG-файлы в отдельных вкладках и редактировать их.

Возможности Registry Workshop:

» Многоуровневые отмена и повтор действий с сохранением истории на диск.
» Поиск и замена ключей, значений и данных реестра с помощью быстрого поискового алгоритма.
» Сравнение реестра между компьютерами или отдельными REG-файлами с большой скоростью.
» Соединение с реестром мобильных устройств через ActiveSync.
» Вырезание, копирование и вставка ключей и значений реестра.
» Поддержка функции drag and drop.
» Редактирование REG-файлов и POL-файлов в отдельной вкладке.
» Резервирование и восстановление реестра.
» Дефрагментация реестра с предварительным просмотром.
» Добавление раздела или параметра в Избранное.
» Удобное и быстрое управление реестром с помощью адресной строки, закладок и историей посещений.
» Переход к одному и тому же ключу в HKLM, Wow6432Node или HKCU через контекстное меню.
» Открытие несколько окон реестра.
» Редактирование двоичных данных в BYTE, WORD или DWORD форматах.
» Добавление поддержки reg:// протокола в систему, для быстрого перехода в необходимый раздел реестра, используя Internet Explorer, Проводник или Mozilla FireFox.

Registry Commander

Данная программа является является хорошей альтернативой стандартному редактору реестра, который поставляется вместе с Windows. Она предлагает те же самые функции, а также немного больше. Основным различием между Registry Commander и RegEdit, является визуальное отображение данных реестра. Вместо наличия всех ключей слева в виде дерева, они отображаются в том же окне так, как если бы они были обычными папками с файлами.

Возможности Registry Workshop:

» Копирование или Переименовывание/Перемещение всех ключей и значений из одного ключа в другой.
» Вырезание или Копирование ключей и значений из одного места и вставка их в другое.
» Колонка, отображающая размер в байтах данных в значении.
» Поддержка всех 12 типов данных, определенных в файле заголовков "winnt.h". Большинство других редакторов реестра обрабатывают только Строковый (String), Двоичный (Binary), DWORD, Расширяемый Строковый (Expanded Strings) и также иногда Мультистроковый (Multi-String).
» Создание закладок на ключи или значения, позволяющие получить к ним более быстрый доступ. С каждой закладкой можно связать комментарий.
» Поиск в части или во всей базе данных реестра, Вы можете искать не только по ключевому слову, но Вы также можете искать по размеру или типу данных.
» Изменение типа данных для значения. То есть Вы можете изменить строковое в двоичное значение, без изменения данных в значении.
» Возможность интерпретировать одно значение для другого, без изменения данных. Это позволит Вам просматривать строковое значение, сохраненное как двоичное значение или наоборот.
» С помощью reg:// протокола, Вы сможете создавать ссылки на определенный ключ в реестре, он работает так же, как и http:// протокол.
» Добавленный список истории позволит Вам быстро перейти от текущего ключа к предыдущему.

RegEditX

Все новые функции являются интерфейсной настройкой над regedit. Но вначале нужно изменить расположение кнопок, так как по умолчанию они настроены для условно-бесплатной программы Registry Crawler. Выберите "RegEditX | Options" и укажите в качестве редактора Regedit.

Основным отличием от стандартной программы "Редактор реестра" является дополнительная адресная строка. Она очень удобна, когда нужно найти ключ реестра, скопированный, например, с веб сайта. В эту строку можно вставить скопированный путь к ключу. Программа уберет лишние пробелы и откроет соответствующую ветвь реестра. Кроме того, редактор автоматически сохранит строку, и вы сможете быстро получить к ней доступ в следующий раз, выбрав ее из выпадающего списка.

Reg Organizer

Это многофункциональная программа для чистки реестра и его обслуживания. Позволяет просматривать и редактировать системный реестр, проводить поиск и автоматическую замену данных в реестре, осуществлять предварительный просмотр импортируемых reg-файлов (в том числе и из Проводника).
Функция поиска в реестре также предоставляет возможность производить глубокий поиск, находя все ключи, относящиеся к интересующему приложению. Кроме того, Reg Organizer позволяет производить полное удаление программного обеспечения, подчищая все "хвосты", остающиеся в системе после обычного удаления.

Основные возможности программы:

» Редактор реестра для просмотра и редактирования системного реестра, позволяющий производить различные операции c ключами и значениями системного реестра, экспортировать, импортировать, копировать значения ключей и т.д.
» Функция чистки реестра для поиска ненужных записей в реестре, а также для поиска и исправления проблем в реестре.
» Функция поиска в реестре позволяет найти ключи, относящиеся к интересующему Вас приложению, и удалить их при необходимости. Это полезно, например, в случае, когда какое-либо приложение не имеет программы деинсталляции и после его удаления "вручную" в реестре остаются ненужные записи, которые могут приводить к некорректному функционированию других приложений. В то же время, Reg Organizer производит более глубокий поиск и позволяет зачастую найти даже те ключи, связанные с данным приложением, которые не будут найдены другими аналогичными программами.
» Дефрагментация и сжатие реестра. Эти процедуры позволяют повысить скорость работы с реестром и, как следствие, скорость работы Вашей системы в целом.
» Возможность изменения многих "тонких настроек" Windows (tweaks). В частности, Вы можете ускорить работу Вашей системы, приказав системе использовать кэш-память большего объема, или заставив систему выгружать неиспользуемые библиотеки из памяти и т.д.
» Возможность получать информацию о любом ключе реестра и следить за изменениями в нем.
» Предварительный просмотр файлов реестра (*.reg) перед импортом их содержимого, в том числе и непосредственно из Проводника. При просмотре импортируемого reg-файла его содержимое представляется в виде древовидной структуры, что позволяет представить в наглядной форме все ключи, которые будут импортированы в реестр.
» Функциональный редактор файлов реестра для редактирования ключей и параметров, добавления и удаления данных, содержащихся в .reg-файлах.
» Просмотр и редактирование автоматически запускаемых программ, т.е. приложений, которые загружаются при старте Windows или входе в систему.
» Режим поиска и замены в реестре представляет собой удобный инструмент для нахождения (и, при необходимости, изменения) ключей или параметров системного реестра, отвечающих критериям поиска.
» Встроенная функция деинсталляции любых приложений. Она может сделать "снимок" системы до и после установки приложения, после чего можно полностью "откатить" внесенные в систему изменения, как будто приложение не было установлено.
» Инструмент "Чистка дисков" позволяет производить автоматическую чистку жестких дисков вашего компьютера от различных ненужных файлов, а также выполнять поиск и исправление неверных ярлыков. Перейти к началу Общего списка советов.


11. Изменение параметров реестра, используя установочный диск.

Если Вам необходимо изменить параметры реестра, к которым Вы не можете получить доступ из работающей Windows, то Вы можете отредактировать используя установочный диск Windows.
Чтобы сделать это:

1) Вставьте или подключите установочный DVD-диск или флеш-диск (флешку) к компьютеру.
2) Перезагрузите компьютер.
3) Нажмите кнопку для вызова загрузочного меню (Boot Menu) (В зависимости от производитЈ материнской платы F8, F11, F12)
4) Выберите в списке Ваш диск и нажмите клавишу Enter ↵.
5) После загрузки в установочный экран Windows нажмите ⇑ Shift + F10.
6) Введите regedit и нажмите клавишу Enter ↵.

Для разделов ветки HKEY_LOCAL_MACHINE.

7.1) Нажмите на раздел HKEY_LOCAL_MACHINE
7.2) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
7.2) Откройте папку C:\Windows\System32\config (D:\Windows\System32\config).
7.3) Выберите файл в котором хранятся параметры необходимой Вам ветки реестра и нажмите кнопку Открыть (Open).

HKEY_LOCAL_MACHINE\SAM | C:\Windows\System32\config\SAM
HKEY_LOCAL_MACHINE\SECURITY | C:\Windows\System32\config\SECURITY
HKEY_LOCAL_MACHINE\SOFTWARE | C:\Windows\System32\config\SOFTWARE
HKEY_LOCAL_MACHINE\SYSTEM | C:\Windows\System32\config\SYSTEM

В некоторых случаях вместо диска C: данные файлы следует искать на диске D: в папке D:\Windows\System32\config.

7.4) Задайте временное имя для куста. Например:

SAM_original для HKEY_LOCAL_MACHINE\SAM
SECURITY_original для HKEY_LOCAL_MACHINE\SECURITY
SOFTWARE_original для HKEY_LOCAL_MACHINE\SOFTWARE
SYSTEM_original для HKEY_LOCAL_MACHINE\SYSTEM

7.5) Отредактируйте необходимые Вам параметры в добавленных ветках, идентично редактированию в самой Windows.

Имя добавленной ветки | Имя соответствующей ветки в Windows
HKEY_LOCAL_MACHINE\SAM_original | HKEY_LOCAL_MACHINE\SAM
HKEY_LOCAL_MACHINE\SECURITY_original | HKEY_LOCAL_MACHINE\SECURITY
HKEY_LOCAL_MACHINE\SOFTWARE_original | HKEY_LOCAL_MACHINE\SOFTWARE
HKEY_LOCAL_MACHINE\SYSTEM_original | HKEY_LOCAL_MACHINE\SYSTEM

Пример.

Название необходимых веток для редактирования:
HKEY_LOCAL_MACHINE\SOFTWARE_original\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE_original\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

Имя соответствующей ветки в Windows:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

Для раздела HKEY_USERS\.DEFAULT.

8.1) Нажмите на раздел HKEY_USERS
8.2) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
8.3) Откройте папку C:\Windows\System32\config (D:\Windows\System32\config), выберите файл DEFAULT и нажмите кнопку Открыть (Open).
8.4) Задайте временное имя для куста (Например: DEFAULT_original)
8.5) Отредактируйте необходимые Вам параметры в ветке HKEY_USERS\DEFAULT_original, идентично редактированию ветки HKEY_USERS\.DEFAULT в самой Windows.

Для раздела HKEY_CURRENT_USER.

9.1) Нажмите на раздел HKEY_USERS
9.2) Откройте меню Файл (File) и нажмите Загрузить куст (Load Hive)
9.3) Откройте папку Вашего профиля C:\Users\ИмяПользователя (Например: C:\Users\Nizaury)
9.4) Введите в поле Имя файла (File name) значение ntuser.dat и нажмите кнопку Открыть (Open).
9.5) Задайте временное имя для куста (Например: Username_original)
9.6) Отредактируйте необходимые Вам параметры в ветке HKEY_USERS\Username_original, идентично редактированию ветки HKEY_CURRENT_USER в самой Windows.

Пример.

Название необходимой ветки яў редактирования:
HKEY_USERS\Username_original\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

Имя соответствующей ветки в Windows:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

10) После внесения необходимых изменений нажмите на добавленный Вами куст (SOFTWARE_original, Username_original или др.)
11) Откройте меню Файл (File) и нажмите Выгрузить куст (Unload Hive)
12) Перезагрузите компьютер, чтобы вернуться обратно в Windows.


1. Автоматическое VPN-подключение к интернет при запуске Windows (реестр).

1) Создайте ваше VPN-подключение, но не подключайтесь к интернету или если подключились, то не отключайтесь от интернета до окончания описанных ниже действий.
2) Запустите редактор реестра (Win   + R → regedit → ОК)
3) Откройте необходимый раздел реестра:

(если хотите сделать автозапуск только для текущего пользователя) или

(если хотите сделать автозапуск для всех пользователей)
В этой ветке создайте "строковый параметр" (правой кнопкой мыши → «Создать» → «строковый параметр») с произвольным именем.
4) В качестве значения созданного параметра внесите строку вида:

5) Закройте реестр и перезагрузите компьютер. Перейти к началу Общего списка советов.


2. Конвертирование reg-файлов в *.inf формат из контекстного меню, с помощью утилиты.

1) Скачайте утилиту Reg2Inf
2) Скопируйте её в C:\Windows\System32
3) Создайте и примените reg-файл следующего содержания:

В контекстное меню reg-файлов добавится пункт reg2inf при нажатии которого созданный Вами reg-файл переконвертируется в inf-файл. Например, файл test.reg переконвертируется в test.reg.inf Перейти к началу Общего списка советов.


3. Включение клавиш-индикаторов Num Lock, Caps Lock, Scroll Lock при загрузке.

Если у Вас при входе в систему выключен переключатель клавиатуры Num Lock, то для его включения сделайте следующее.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_CURRENT_USER\Control Panel\Keyboard
3) Щелкните на параметре InitialKeyboardIndicators правой кнопкой мыши и нажмите Изменить.
4) Выберите и установите необходимое Вам значение.

0 – все переключатели выключены.
1 – Caps Lock включен.
2 – Num Lock включен.
3 – Caps Lock и Num Lock включены.
4 – Scroll Lock включен.
5 – Caps Lock и Scroll Lock включены.
6 – Num Lock и Scroll Lock включены.
7 – Caps Lock, Num Lock и Scroll Lock включены.

Если же Вам необходимо изменить состояние клавиш-индикаторов до входа в систему, в экране приветствия, то для управления ими измените значение параметра InitialKeyboardIndicators в разделе HKEY_USERS\.DEFAULT\Control Panel\Keyboard

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Устройства и Сети.


4. Отмена автозапуска для носителей и устройств.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр DWORD с именем NoDriveTypeAutoRun

Допустимые значения ключа:

0x1 - отключить автозапуск на приводах неизвестных типов
0x4 - отключить автозапуск съемных устройств
0x8 - отключить автозапуск НЕсъемных устройств
0x10 - отключить автозапуск сетевых дисков
0x20 - отключить автозапуск CD-приводов
0x40 - отключить автозапуск RAM-дисков
0x80 - отключить автозапуск на приводах неизвестных типов
0xFF - отключить автозапуск вообще всех дисков.

Для информации: параметр NoDriveTypeAutoRun автоматически добавляется в реестр при установке программы VMware Workstation, используемой для создания виртуальной машины.

Помимо указанных Выше действий, Вы можете также запретить обработку файла autorun.inf.
Для этого создайте и примените reg-файл следующего содержания:

Данный параметр подменяет содержимое файла autorun.inf значением из реестра, которое нарочно задаётся пустым/неверным.
Это приводит к тому, что если на диске и есть файл autorun.inf, то он воспринимается как пустой. Перейти к началу Общего списка советов.


5. Уменьшение фрагментируемости больших файлов на диске.

Для того чтобы операционная система при записи файла на диск сначала нашла для него наиболее подходящее по размеру место и поместила его туда, как можно меньше дробя на части сделайте следующее:

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem
3) Создайте DWORD-параметр ContigFileAllocSize
4) Щелкните на нем правой кнопкой мыши и выберите Изменить.
5) Установите значение 00000200 и нажмите ОК

Данный параметр определяет максимальный размер нефрагментируемого блока данных на диске. При желании размер такого блока можно еще увеличить. Данная настройка может быть очень полезной при работе с мультимедиа (уменьшается нагрузка на диск и процессор при записи и воспроизведении видео или звуковых файлов).
Эта настройка полезна тем, у кого много файлов большого размера, при большом количестве маленьких файлов - она становится менее актуальной. Перейти к началу Общего списка советов.


6. Изменение состояния встроенного динамика персонального компьютера.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_CURRENT_USER\Control Panel\Sound
3) Измените значение параметра Beep на "No" чтобы отключить и на "Yes" чтобы включить.

Также Вы можете включить/отключить его в Диспетчере устройств:

1) Откройте меню Пуск → Панель управления и запустите Диспетчер устройств
2) В меню Вид установите флажок на Показать скрытые устройства
3) Откройте Драйверы несамонастраиваемых устройств
4) Щелкните правой кнопкой мыши на Beep и выберите пункт Свойства
5) Перейдите на вкладку Драйвер и установите тип автозагрузки на Отключено чтобы отключить и на Авто чтобы включить.
6) Для изменения текущего состояния нажмите на Остановить чтобы отключить и на Запустить чтобы включить.
7) Нажмите кнопку ОК для применения настроек. Перейти к началу Общего списка советов.


7. Переназначение гнезд звуковой карты Realtek используя реестр.

На некоторых материнских платах, отсутствует возможность переназначения гнезд встроенной звуковой карты Realtek. А это значит, что каждое гнездо четко привязано к определенному устройству и определяется только автоматически при включении его в гнездо.
Например, если Вы включите Микрофон или Наушники в гнездо, предназначенное для устройства Боковые динамики, то Realtek будет по-прежнему считать, что у Вас подключены Боковые динамики, а не Микрофон или Наушники.
Однако из данной ситуации есть выход. Вы можете переназначить гнезда вручную, при помощи реестра.

1) Установите драйвера звуковой карты
2) Запустите редактор реестра (Win+К → regedit → ОК)
3) Пройдите к папке

4) Откройте папку Drv6278_DevType_0888_SS10438357 или с аналогичным названием (DrvXXXX_DevType_XXXX_SSXXXXXXXX, где вместо X могут быть любые цифры, зависящие от версии драйвера и номера вашего устройства)
5) Создайте двоичный параметр (Binary-Параметр) задаете ему необходимое имя и значение из списка указанного ниже или отредактируйте уже имеющийся.

Наиболее часто номера пинов соответствуют указанным ниже значениям.
Иногда, после установки нового драйвера, номер пина может изменит©. Например: с Pin04 на Pin17.
Для определения номера пина, выньте необходимый Вам штекер из гнезда и вставьте его заново. Данное действие приведет к созданию пина с необходимым Вам номером в разделе реестра:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\DrvXXXX_DevType_XXXX_SSXXXXXXXX

Имя (вставлять без кавычек):

"Pin01" или "Pin14" = Заднее зеленое гнездо
"Pin02" или "Pin15" = Заднее черное гнездо
"Pin03" или "Pin16" = Заднее коричневое гнездо
"Pin04" или "Pin17" = Заднее серое гнездо
"Pin05" или "Pin18" = Заднее розовое гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Микрофон)
"Pin07" или "Pin1a" = Заднее синее гнездо (на некоторых материнских платах, даже изменения его в реестре не изменят, его со значения Линейный вход)

"Pin06" или "Pin19" = Переднее розовое гнездо
"Pin08" или "Pin1b" = Переднее зеленое гнездо

Значение (вставлять без кавычек):

"00 00 00 00" = Линейный вход
"01 00 00 00" = Микрофон
"02 00 00 00" = Наушники
"04 00 00 00" = Передние динамики
"05 00 00 00" = Тыловые динамики
"06 00 00 00" = Центральный канал/Сабвуфер
"07 00 00 00" = Боковые динамики

Если у Вас после перезагрузки компьютера сбрасываются настройки, то сразу после изменения настроек установите значение параметра ChannelConfig равным 00 00 00 00

Также вы можете создать reg-файл наподобие указанного ниже, заменив значения на необходимые:

Drv6278_DevType_0888_SS10438357 - на версию вашего драйвера
(имя папки по адресу HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\)
Pin04 - на любое значение из списка Имя
hex:02,00,00,00 - на любое значение из списка Значение (просто исправьте 2 на соответствующую цифру) Reg-файл для настройки устройства Наушники вместо устройства Боковые динамики


8. Замена компонента Устройства и принтеры в Панели управления на папку Принтеры.

1) Откройте Редактор групповой локальной политики (Win   + R → gpedit.msc → ОК)
2) Перейдите в раздел Конфигурация пользователя\Административные шаблоны\Панель управления.
3) Выберите команду Скрыть указанные элементы панели управления
4) Установите переключатель в значение Включить.
5) Нажмите на кнопку Показать.
6) Добавьте новую запись: Microsoft.DevicesAndPrinters и нажмите ОК.
7) Запустите редактор реестра (Win   + R → regedit.exe → ОК).
8) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel\NameSpace
9) Создайте в ней новый раздел {2227a280-3aea-1069-a2de-08002b30309d}.
10) Присвойте параметру По умолчанию значение - Принтеры (Printers).

Данную папку Вы сможете увидеть в Панели управления в контекстном меню Пуск, если у Вас установлено значение "Отображать как меню" или при просмотре полного списка всех элементов при её открытии.

Перейти к началу раздела Твики Реестра.
Перейти к началу подраздела Твики Реестра - Устройства и Сети.


9. Удаление цифры при пересоздании адаптера сети в Диспетчере устройств.

Вариант 1

1) Удалите драйвер сетевого адаптера
2) В ветке реестра

установите значение адаптера сети на 0.
3) Создайте драйвер сетевого адаптера

Вариант 2

1) Удалите драйвер сетевого адаптера
2) В ветке реестра

удалите ваш сетевой адаптер.
3) Создайте драйвер сетевого адаптера. Перейти к началу Общего списка советов.


10. Отключение или переназначение клавишы Caps Lock.

Если вы не используете клавишу Caps Lock по назначению, то вы можете отключить или переназначить клавишу, путем редактирования параметра реестра.
Для этого необходимо изменить значение параметра Scancode Map, который расположен в разделе реестра

Ниже представлены reg-файлы для переназначения и отключения клавиши Caps Lock.

Клавиша Caps Lock будет выполнять действие клавиши Ctrl.

Клавиша Caps Lock будет выполнять действие клавиши ⇑ Shift.

Отключает Caps Lock и переназначает действие клавиши Scroll
Lock на выполнение Caps Lock.

Отключает клавишу Caps Lock.

Отменяет все предыдущие переназначения клавиш(возвращает значение по умолчанию)


11. Отключение USB порта после Безопасного извлечения устройства.

Если Вы присоединили USB-устройство к компьютеру с запущенной Windows 7, а затем Отключаете устройство в "Диспетчере устройств" или в "Безопасное Извлечение устройств и дисков", используя иконку в системном трее, то Вы можете наблюдать один из следующих симптомов:
  • USB-устройство показывает продолжающееся признаки яњтельности (такие, как остающийся гореть LED-индикатор)
  • USB-устройство продолжает получать USB-пакеты и продолжает потреблять энергию соответствующую состоянию активного устройства.
  • Физическое отсоединение Отключенного или Безопасно Удаленного USB-устройства может, в некоторых случаях, вызывать ошибку в активной передаче на другое USB-устройство.

    • Чтобы исправить данную ошибку Вам необходимо сделать следующее:

    Для определенного устройства.

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbflags
    3) Откройте в данном разделе подраздел соответствующий, подключенному к Вашему компьютеру USB-устройству.
    4) Если неоходимого Вам раздела нет, то создайте его.

    4.1) Щелкните правой кнопкой мыши на usbflags
    4.2) Выберите пункты Создать → Раздел
    4.3) Задайте имя нового раздела в следующем виде: vvvvpppprrrr
    где vvvv - 4-значный шестнадцатеричный номер, обозначающий Vendor ID устройства
    pppp - 4-значный шестнадцатеричный номер, обозначающий Product ID устройства
    rrrr - 4-значный бинарно-закодированный десятиричный номер, обозначающий Revision number устройства

    Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
    4.3.1) Откройте Пуск → Панель управления → Диспетчер устройств
    4.3.2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
    4.3.3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.

    5) Создайте в открытом разделе HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\usbflags\vvvvpppprrrr параметр DWORD (32 бита) с именем DisableOnSoftRemove
    6) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    7) В текстовом поле Значение: введите 1 и нажмите ОК.

    Для всех устройств:

    1) Запустите Редактор реестра (Win   + R → regedit → ОК)
    2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\usbhub\hubg
    Если данного раздела нет, то создайте его.
    3) Щелкните правой кнопкой мыши и создайте параметр DWORD (32 бита) с именем DisableOnSoftRemove
    4) Щелкните правой кнопкой мыши по параметру DisableOnSoftRemove и выберите пункт Изменить...
    5) В текстовом поле Значение: введите 1 и нажмите ОК. Перейти к началу Общего списка советов.


12. Отключение сообщения: "Хотите выполнить проверку и исправление ошибок на ..." для съемных дисков.

Вариант 1

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\AutoCheckSelect
3) Щелкните на параметре CheckedValue правой кнопкой мыши и нажмите Изменить.
4) Установите значение 0 и нажмите ОК

Вариант 2

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
3) Щелкните на параметре BootExecute правой кнопкой мыши и нажмите Изменить.
4) По умолчанию значение данного параметра должно быть autocheck autochk *.
* означает, что все диски выбраны для проверки. Чтобы добавить исключение проверки яў определенного диска, добавьте перед звездочкой параметр /K:<Буква_диска>. Параметр /K отключает проверку диска при его автозапуске. Например для съемного диска H: значение ключа BootExecute примет вид:

Если Вы желаете добавить несколько дисков в исключения (например: H и I диски), то значение ключа BootExecute примет вид:

Вариант 3

1) Откройте меню Пуск
2) Введите в диалоговом окне Выполнить (Win   + R) или в строке поиска команду msconfig и нажмите Enter ↵.
3) Перейдите на вкладку Службы и уберите флажок: Определение оборудования оболочки
4) Откройте меню Пуск
5) Введите в диалоговом окне Выполнить (Win   + R) или в строке поиска команду services.msc и нажмите Enter ↵.
6) В открывшейся оснастке Службы щелкаете правой кнопкой мыши на Определение оборудования оболочки и выбираете пункт Свойства
7) Выбираете Тип запуска - Отключена и нажимаете кнопку Остановить
8) Нажимаете ОК.

Данное действие также отключит автозагрузку со съемных носителей.


13. Отключение проверки системой наличия подключения к Интернет используя функцию NCSI и изменение ее параметров.

В Windows 7 есть функция Network Connectivity Status Indicator (NCSI) означающая в переводе Индикатор Статуса Сетевого Подключения. За ее работу отвечает служба «Служба сведений о подключенных сетях» (Network Awareness). Одной из задач данной функции является определение определение возможности выхода компьютера в Интернет.

Порядок определения подключения следующий:

1) Windows пытается открыть текстовый файл http://www.msftncsi.com/ncsi.txt
Указанный файл содержит строку Microsoft NCSI. Ожидаемый ответ от сервера – заголовок 200 ОК и данная строка.
2) Windows проверяет работоспособоность DNS-сервера.
Для этого NCSI пытается определить IP-адрес хоста dns.msftncsi.com. Ожидаемое значение – 131.107.255.255.

В результате:

Если оба шага успешно завершены – система рапортует о наличии соединения с Интернет.
Если файл ncsi.txt недоступен, а dns.msftncsi.com определяется с другим адресом, либо его IP невозможно установить – система сообщает о недоступности подключения к Интернет.
Если файл ncsi.txt недоступен, но dns.msftncsi.com определяется корректно – система уведомляет пользователя о возможной необходимости аутентификации посредством браузера.

Веб сервер, установленный на сайте www.msftncsi.com хранит в логах все IP-адреса, c которых был запрошен файл ncsi.txt. Согласно заявлению Microsoft эти данные не используются для установления личности пользователя, с компьютера которого пришел запрос.

Изменение настроек NCSI.

Для изменения адреса веб-сервера, имени и содержимого файла, запрашиваемого NCSI, а также имени и IP-адреса хоста, используемого для проверки DNS выполните следующие действия:

1) Запустите редактор реестра (Win   + R → regedit → OK)
2) Откройте раздел: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet
3) Измените значения указанных ниже параметров данного раздела на необходимые Вам.

ActiveDnsProbeContent – IP-адрес хоста для проверки DNS
ActiveDnsProbeHost – имя хоста для проверки DNS
ActiveWebProbeHost – адрес веб-сайта, на котором размещен файл для проверки наличия подключения к Internet
ActiveWebProbePath – путь к файлу проверки
ActiveWebProbeContent – содержимое файла проверки

Например, Вы размещаете на www.yoursite.com файл test.txt с содержимым Internet Check и изменяете значения на следующие:

ActiveWebProbeHost на www.yoursite.com
ActiveWebProbePath на test.txt
ActiveWebProbeContent на Internet Check

Отключение функции NCSI.

1) Запустите редактор реестра (Win   + R → regedit → OK)
2) Откройте раздел: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet
3) Измените значение параметра EnableActiveProbing на 0
4) Откройте раздел: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator
3) Создайте параметр DWORD, переименуйте его в NoActiveProbe и измените значение на 1

Также Вы можете создать и применить reg-файл, указанного ниже содержания:


14. Увеличение скорости передачи данных для USB-носителей.

У Microsoft существует пакет исправлений для Windows 7, позволяющий изменять максимальный размер передачи данных для USB-носителей с 64 Кб до 2 Мб и немного увеличить скорость работы носитЈ.
Чтобы воспользоваться этой возможностью, выполните указанные ниже действия.

1) Скачайте пакет исправлений:

1.1) Перейдите по ссылке на сайт Microsoft: http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2581464&kbln=ru-ru
1.2) Выберите исправления ссылки яў которых Вы желаете получить на e-mail.
1.3) Укажите e-mail для получения ссылок для скачивания, введите набор символов с картинки и нажмите кнопку Запросить исправление.
1.4) Скачайте файл по полученной ссылке и распакуйте.

Альтернатив ссылка на архив с уже распакованными версиями пакетов исправлений для обеих разрядностей: KB2581464.zip

2) Установите обновление Windows6.1-KB2581464-x86.msu или Windows6.1-KB2581464-x64.msu в зависимости от разрядности Windows.

3) Запустите редактор реестра (Win   + R → regedit → ОК)
4) Откройте раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbstor
5) Создайте в нем раздел VVVVPPPP

где VVVV - 4-значный шестнадцатеричный номер, обозначающий Vendor ID устройства
PPPP - 4-значный шестнадцатеричный номер, обозначающий Product ID устройства

Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
5.1) Откройте Пуск → Панель управления → Диспетчер устройств
5.2) Откройте ветку Контроллеры USB
5.3) Нажмите правой кнопкой мыши на необходимом Вам устройстве (Например: Запоминающее устройство для USB) и выберите пункт Свойства
5.4) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.

Например: если у Вас указан ИД оборудования: USB\VID_090C&PID_2000, то Вам необходимо создать раздел 090С2000.

6) Откройте созданный Вами новый раздел (В моем примере: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\usbstor\090С2000)
7) Создайте в нем DWORD-параметр с названием MaximumTransferLength
8) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить
9) В поле Значение укажите значение в диапазоне от 64 КБ до 2 МБ.
Например, выберите Десятичное число и введите значение в диапазоне от 65535 (64 КБ) до 2097120 (2 МБ), в соответствиями с рекомендациями Microsoft.
Либо в диапазоне от 65536 (64 КБ) до 2097152 (2 МБ), в соответствиями с точным соответствием данных значений байтовому эквиваленту.
10) Нажмите кнопку ОК и перезагрузите компьютер.


15. Изменение иконки яў *.url файлов, при использовании браузера Internet Explorer по умолчанию.

Если в качестве браузера по умолчанию в системе Вы используете Internet Explorer, и желаете заменить иконку используемую в системе для *.url файлов, являющим© ярлыками интернета в системе, то Вам необходимо сделать следующее:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Открывая по очереди каждый из указанных ниже разделов реестра измените значение параметра (По умолчанию)

HKEY_CLASSES_ROOT\ftp\DefaultIcon
HKEY_CLASSES_ROOT\http\DefaultIcon
HKEY_CLASSES_ROOT\https\DefaultIcon

Изначальное значение данного параметра равно: C:\Windows\System32\url.dll,0 Перейти к началу Общего списка советов.


16. Удаление и восстановление вкладок в оснастке Свойства обозревателя из Панели управления.

Чтобы удалить вкладку Общие в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы восстановить вкладку Общие в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы удалить вкладку Безопасность в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы восстановить вкладку Безопасность в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы удалить вкладку Конфиденциальность в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы восстановить вкладку Конфиденциальность в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы удалить вкладку Содержание в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы восстановить вкладку Содержание в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы удалить вкладку Подключения в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы восстановить вкладку Подключения в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы удалить вкладку Программы в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы восстановить вкладку Программы в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы удалить вкладку Дополнительно в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.

Чтобы восстановить вкладку Дополнительно в оснастке Свойства обозревателя, создайте и примените указанный ниже reg-файл.


17. Удаление и восстановление возможности изменения масштаба в Internet Explorer.

Чтобы удалить возможность изменения масштаба в Internet Explorer, создайте и примените указанный ниже reg-файл.

Чтобы восстановить возможность изменения масштаба в Internet Explorer, создайте и примените указанный ниже reg-файл.


18. Добавление в контекстное меню рабочего стола пункта "Безопасное извлечение устройства".

Чтобы добавить в контекстное меню рабочего стола пункт Безопасное извлечение устройства, создайте и примените указанный ниже reg-файл.

Чтобы удалить из контекстного меню рабочего стола пункт Безопасное извлечение устройства, создайте и примените указанный ниже reg-файл.


19. Настройка отображения букв дисков в папке Компьютер.

Чтобы настроить отображение дисков в папке Компьютер, создайте и примените reg-файл указанного ниже содержания:

В зависимости от того, какую цифру Вы поставите вместо последней цифры в значении параметра ShowDriveLettersFirst, Вы сможете изменить порядок отображения буквы у диска.

0 | Отображать буквы всех дисков после их описания. (По умолчанию)
1 | Отображать буквы сетевых дисков перед их описанием, а буквы локальных дисков после их описания.
2 | Не отображать буквы дисков
4 | Отображать буквы всех дисков перед их описанием.


20. Настройка параметров, отвечающих за установку драйверов.

При установке в систему нового оборудования происходит установка необходимых для него драйверов.
Используя реестр Вы можете настроить параметры, влияющие на данный процесс.
Большинство из них изначально отсутствуют в реестре и Вам необходимо будет их создать.

Настройка параметров, отвечающих за поиск драйверов.

Если операционная система находит драйвер для нового оборудования среди драйверов, поставляемых с Windows, то установка драйвера выполняется автоматачески.
Иначе операционная система предложит Вам либо указать путь к драйверу, либо поискать новый драйвер в Интернете на сайте Microsoft.
Для настройки параметров, влияющих на поиск драйверов, выполните указанные ниже действия.

1) Откройте Пуск → Выполнить (Win   + R)
2) Введите необходимую Вам команду из предложенных ниже и нажмите Enter ↵.

Параметр DontPromptForWindowsUpdate может иметь следующие значения:

0x00000000 — отображать запрос поиска новых драйверов на веб-узле корпорации Microsoft.
0x00000001 — не отображать запрос поиска новых драйверов на веб-узле корпорации Microsoft.

Параметр DontSearchCD может иметь следующие значения:

0x00000000 — разрешить поиск новых драйверов на компакт-дисках.
0x00000001 — запретить поиск новых драйверов на компакт-дисках.

Параметр DontSearchWindowsUpdate может иметь следующие значения:

0x00000000 — разрешить поиск новых драйверов на веб-узле корпорации Microsoft.
0x00000001 — запретить поиск новых драйверов на веб-узле корпорации Microsoft.

Параметр SearchOrderConfig может иметь следующие значения:

0x00000000 — не искать в Центре обновления Windows.
0x00000001 — искать в Центре обновления Windows в первую очередь.
0x00000002 — искать в Центре обновления Windows в последнюю очередь.

Настройка установки драйверов, не подписанных корпорацией Microsoft.

1) Откройте Пуск → Выполнить (Win   + R)
2) Введите необходимую Вам команду из предложенных ниже и нажмите Enter ↵.

Параметр AllSigningEqual может иметь следующие значения:

0x00000000 — отдавать предпочтение драйверам, подписанным корпорацией Microsoft.
0x00000001 — не различать драйверы, подписанные Microsoft и драйверы с подписью других производителей.

Параметр BehaviorOnFailedVerify может иметь следующие значения:

0x00000000 — установка драйверов без цифровой подписи Microsoft разрешена.
0x00000001 — при установке драйверов без цифровой подписи Microsoft будет выдаваться предупреждение.
0x00000002 — установка драйверов без цифровой подписи Microsoft запрещена.

Настройка параметров, влияющих на процесс установки драйверов устройств.

Чтобы настроить данную группу параметров, воспользуйтесь предложенным ниже решением.

1) Откройте Пуск → Выполнить (Win   + R)
2) Введите необходимую Вам команду из предложенных ниже и нажмите Enter ↵.

Параметр InstallTimeout указывает максимально возможное время установки нового оборудования (в секундах). По истечении данного времени либо устройство должно быть установлено, либо установка будет прекращена и операционная система выдаст сообщение об ошибке. По умолчанию устройство может устанавливаться не более пяти минут, что соответствует 300 секундам или значению 0x0000012с.

Параметр DisableSendGenericDriverNotFoundToWER может иметь следующие значения:

0x00000000 — отправлять в Microsoft отчет об ошибке, если драйвер устройства запрашивает дополнительное программное обеспечение в ходе установки.
0x00000001 — не отправлять в Microsoft отчет об, если драйвер устройства запрашивает дополнительное программное обеспечение в ходе установки.

Параметр DisableSendRequestAdditionalSoftwareToWER может иметь следующие значения:

0x00000000 — отправлять в Microsoft отчет об ошибке при установке универсального драйвера операционной системы (вместо драйвера производитЈ).
0x00000001 — не отправлять в Microsoft отчет об ошибке при установке универсального драйвера операционной системы (вместо драйвера производитЈ).

Параметр DisableBalloonTips может иметь следующие значения:

0x00000000 — отображать уведомление "Найдено новое оборудование" в области уведомлений.
0x00000001 — не отображать уведомление "Найдено новое оборудование" в области уведомлений.

Параметр DisableSystemRestore может иметь следующие значения:

0x00000000 — создавать точку восстановления при установке нового драйвера устройства.
0x00000001 — не создавать точку восстановления при установке нового драйвера устройства.

Параметр DenyRemovableDevices может иметь следующие значения:

0x00000000 — разрешить установку и обновление драйверов для съемных устройств.
0x00000001 — запретить установку и обновление драйверов для съемных устройств.


21. Удаление сведений о месторасположениях для поиска драйверов.

Если Вы осуществляли поиск драйверов вручную для устройства установленного на компьютере, то чтобы удалить сведения о месторасположениях для установки драйверов:

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup
3) Щелкните дважды на параметре Installation Sources.
4) Удалите несуществующие пути в списке значений и нажмите ОК.
В 64-битной Windows значения данного параметра в разделе HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Setup изменятся автоматически. Перейти к началу Общего списка советов.


22. Изменение версии Interenet Explorer эмулируемой для CHM-файлов справки и других приложений.

Некоторые программы использующие для своей работы браузер Interenet Explorer прописывают в реестре какую его версию им использовать.
Если эмулируемая для программы версия браузера окажется недостаточно высокой, то при просмотре html-файлов может отсутствовать полная или частич поддержка JavaScript, HTML5 и CSS3.

Одной из таких программ является программа для просмотра CHM-файлов справки (hh.exe).
Чтобы изменить какую версию Internet Explorer эмулировать, выполните указанные ниже действия.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION
3) Создайте DWORD-параметр с именем hh.exe
4) Щелкните дважды на данном параметре или щелкните правой кнопкой мыши на нем и выберите Изменить.
5) Переключите систему исчисления на десятичную и установите значение данного параметра равным необходимой Вам версии.

9000 - для Internet Explorer 9
10000 - для Internet Explorer 10
11000 - для Internet Explorer 11
и так далее.

В 64-битной версии Windows дополнительно создайте идентичный DWORD-параметр в разделе:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_BROWSER_EMULATION


1. Настройка локальной сети между компьютерами.

Соедините между собою с помощью кабеля (витая пара) сетевые карты компьютеров, которые должны быть включены в локальную сеть.
Для объединения более чем 2-х компьютеров подключите сетевые карты компьютеров к хабу (сетевому концентратору), используя для подключения каждого компьютера свой кабель.

I. Установка имени рабочей группы.

1) Откройте меню Пуск, нажмите правой кнопкой мыши на пункт Компьютер и в контекстном меню выберите пункт Свойства.
2) В колонке слева нажмите на ссылку Дополнительные параметры системы.
3) В открывшемся окне Свойства системы, перейдите на вкладку Имя компьютера и нажмите кнопку Изменить.
4) Введите имя рабочей группы (Например: HOMELAN), в которую будут входить компьютеры в локальной сети и нажмите кнопку ОК.

5) В окне Изменение имени компьютера или домена нажмите кнопку ОК, и снова кнопку ОК.
6) В окне Свойства системы нажмите кнопку Закрыть.
7) Во всплывшем окне нажмите кнопку Перезагрузить сейчас.

II. Настройка параметров адаптера.

1) Щелкните правой кнопкой мыши на значок сети на панели задач, выберите пункт Центр управления сетями и общим доступом и перейдите по ссылке слева Изменение параметров адаптера (Win   + R → ncpa.cpl → ОК)

2) Нажмите правой кнопкой мыши на значок Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
3) Снимите флажок напротив Протокол интернета версии 6 (TCP/IPv6) (Internet Protocol Version 6 (TCP/IPv6)).

4) Щелкните на Протокол интернета версии 4 (TCP/IPv4) (Internet Protocol Version 4 (TCP/IPv4)) и нажмите кнопку Свойства.
5) Установите переключатель на Использовать следующий IP-адрес.
6) Введите значение 192.168.1.2 в поле IP-адрес.
7) Введите значение 255.255.255.0 в поле Маска подсети.
8) Введите значение 192.168.1.1 в поле Основной шлюз.
9) Введите значение 192.168.1.1 в поле Предпочитаемый DNS-сервер.
10) Введите значение 192.168.1.0 в поле Альтернативный DNS-сервер.
11) Нажмите кнопку ОК, а затем кнопку Закрыть.

III. Настройка общего доступа к файлам, папкам и принтерам.

1) Щелкните правой кнопкой мыши на значок сети на панели задач, выберите пункт Центр управления сетями и общим доступом и перейдите по ссылке слева Изменить дополнительные параметры общего доступа.
2) Откройте профиль сети Домашний или рабочий.
3) Установите переключатели в значения:

Включить сетевое обнаружение.
Включить общий доступ к файлам и принтерам.
Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках.
Использовать 128-битное шифрование для защиты подключений общего доступа (рекомендуется).
Отключить общий доступ с парольной защитой.
Разрешить Windows управлять подключениями домашней группы (рекомендуется).

4) Откройте профиль сети Общий.
5) Установите переключатели в значения:

Включить сетевое обнаружение.
Включить общий доступ к файлам и принтерам.
Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках.
Использовать 128-битное шифрование для защиты подключений общего доступа (рекомендуется).
Отключить общий доступ с парольной защитой.

6) Нажмите кнопку Сохранить изменения и закройте окно Дополнительные параметры общего доступа.

IV. Открытие общего доступа к папке или диску.

1) В Проводнике щелкните правой кнопкой мыши на папку или диск для которого необходимо открыть общий доступ и выберите пункт Свойства.
2) Перейдите на вкладку Доступ и нажмите кнопку Расширенная настройка.
3) Установите флажок Открыть общий доступ к этой папке и нажмите кнопку Разрешения.
4) Установите для группы Все (Everyone) флажок в колонке Разрешить напротив пункта Полный доступ и нажмите кнопку ОК.

5) В окне Расширенная настройка общего доступа нажмите кнопку ОК.
6) В окне свойств диска или папки перейдите на вкладку Безопасность и нажмите кнопку Изменить.
7) Нажмите кнопку Добавить в окне Разрешения для группы.
8) Введите в текстовом поле слово Все (Everyone) и нажмите кнопку ОК.

9) Установите для группы Все (Everyone) флажок в колонке Разрешить напротив пункта Полный доступ и нажмите кнопку ОК.

10) В окне свойств диска или папки нажмите кнопку Закрыть.

Повторите все описанные в данном совете действия для каждого подсоединяемого к локальной сети компьютера.
При введении IP-адреса для каждого компьютера укажите различающиеся значения.
Например, укажите значение 192.168.1.3 для второго подключаемого компьютера, 192.168.1.4 для третьего подключаемого компьютера и т.д..

Перейти к началу раздела Сети (Интернет и Локальная).


2. Создание собственной Wi-Fi точки доступа без использования роутера.

Если у Вас имеется ноутбук или персональный компьютер с беспроводным (Wi-Fi) адаптером и Вы желаете создать собственную точку доступа Wi-Fi, то Вы можете воспользоваться предложенной ниже инструкцией.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.
3) Создайте размещенную сеть:

Укажите вместо имя_сети - имя для для создаваемой Wi-Fi сети (данное имя будет идентификатором SSID).
Укажите вместо пароль_к_сети - пароль для создаваемой Wi-Fi сети (данный пароль будет ключом безопасности пользователя, используемым сетью).

4) Запустите размещенную сеть:

5) Закройте окно команд.
6) Щелкните правой кнопкой мыши на значок сети на панели задач, выберите пункт Центр управления сетями и общим доступом и перейдите по ссылке слева Изменение параметров адаптера (Win   + R → ncpa.cpl → ОК)
7) Нажмите правой кнопкой мыши на значок Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
8) Перейдите на вкладку Доступ и установите флажок Разрешить другим пользователям сети использовать подключение к Интернету данного компьютера.
9) В ниспадающем списке выберите созданное Вами виртуальное соединение и нажмите кнопку ОК, а затем кнопку Закрыть.
10) Щелкните правой кнопкой мыши на значок сети на панели задач, выберите пункт Центр управления сетями и общим доступом и перейдите по ссылке слева Изменить дополнительные параметры общего доступа.
11) Откройте профиль сети Домашний или рабочий.
12) Установите переключатели в значения:

Включить сетевое обнаружение.
Включить общий доступ к файлам и принтерам.
Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках.
Использовать 128-битное шифрование для защиты подключений общего доступа (рекомендуется).
Отключить общий доступ с парольной защитой.
Разрешить Windows управлять подключениями домашней группы (рекомендуется).

13) Откройте профиль сети Общий.
14) Установите переключатели в значения:

Включить сетевое обнаружение.
Включить общий доступ к файлам и принтерам.
Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках.
Использовать 128-битное шифрование для защиты подключений общего доступа (рекомендуется).
Отключить общий доступ с парольной защитой.

15) Нажмите кнопку Сохранить изменения и закройте окно Дополнительные параметры общего доступа.

Чтобы посмотреть состояние размещенной сети - количество клиентов, параметры соединений, протокол работы, воспользуйтесь командой:

Чтобы остановить работу данной сети, воспользуйтесь командой:

Также, для создания собственной Wi-Fi точки доступа Вы можете обратить свое внимание на программы сторонних производителей: Connectify Pro, MyPublicWiFi, mHotSpot.

Перейти к началу раздела Сети (Интернет и Локальная).


3. Объединение или удаление сетевых размещений (подключений).

1) Щелкните правой кнопкой мыши на значок Сеть на панели задач и выберите пункт Центр управления сетями и общим доступом
2) Если у Вас отсутствует данный значок, то нажмите комбинацию клавиш Win   + R → введите команду

и нажмите OK
3) Нажмите на значке (дом, офис или скамейка - зависит от типа выбранной Вами сети)
4) В открывшемся окне Настройка свойств сети нажмите на ссылку Объединение или удаление сетевых размещений.
5) Выделите сетевое размещение или несколько сетевых размещений, которые Вы хотите слить в единое сетевое размещение или которые Вы хотите удалить.
Используемые подключения нельзя удалить или слить, для их слия или удаления Вам необходимо отключится от сети.
6) Нажмите кнопку Слияние или Удаление, во всплывшем окне нажмите кнопку Да.

Перейти к началу раздела Сети (Интернет и Локальная).


4. Автоматическое подключение к ADSL-интернету при запуске Windows.

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом.
2) Нажмите ссылку Изменение параметров адаптера.
3) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Свойства.
4) Перейдите на вкладку Параметры и снимите флажки Отображать ход подключения, Запрашивать имя, пароль, сертификат и т.д..
5) Нажмите кнопку ОК.
6) Щелкните правой кнопкой мыши на Вашем ADSL-соединении и выберите пункт Создать ярлык.
7) В диалоговом окне нажмите Да и у Вас на рабочем столе появится ярлык ADSL-соединения.
8) Откройте Пуск → Все программы .
9) Нажмите правой кнопкой мыши на Автозагрузка и выберите пункт Открыть.
10) Переместите ярлык созданного Вами ADSL-соединения с рабочего стола в открывшуюся папку Автозагрузка.

Перейти к началу раздела Сети (Интернет и Локальная).


5. Автоматическое VPN-подключение к интернет при запуске Windows.

Вариант 1

Вы можете добавить задачу в Планировщик заданий.
1) Откройте планировщик задний
1.1) Откройте меню Пуск → Панель управления → Администрирование → Планировщик заданий или в строке поиска меню Пуск введите taskschd.msc и нажмите Enter ↵.
2) Нажмите Создать задачу...
3) На вкладке Общие введите в поле Имя - Имя подключения
4) Перейдите на вкладку Триггеры и нажмите кнопку Создать...
5) Выберите в ниспадающем списке напротив пункта Начать задачу: значение При входе в систему и нажмите ОК.
6) Перейдите на вкладку Действия и нажмите кнопку Создать...
7) Выберите в ниспадающем списке напротив пункта Действие: значение Запуск программы.
8) Введите в поле Программа или сценарий: команду rasdial "имя подключения" login password
вместо "имя подключения" - укажите название Вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету
9) Нажмите кнопку ОК.
10) Перейдите на вкладку Параметры
11) Поставьте флажки напротив:
Немедленно запускать задачу, если пропущен плановый запуск
При сбое выполнения перезапускать через 1 мин.
Количество попыток перезапуска 99.
12) Уберите флажок Останавливать задачу выполняемую дольше и нажмите ОК.

Вариант 2

1) Скачайте и распакуйте в любую папку файл connect.zip, содержащий скрипт для соединения с интернетом.
2) Щелкните правой кнопкой мыши на файле connect.bat и нажмите Изменить
3) Измените название подключения, логин(имя пользователя) и пароль в соответствии с Вашими настройками и сохраните файл.
4) Скачайте архив со скриптом скрытого запуска:
hs_exec.zip - для использования командного bat-файла, содержащего скрипт запуска
hide_program.zip - для использования яваскрипта, содержащего скрипт запуска
5) Распакуйте архив в ту же самую папку, где у Вас находится файл connect.bat
6) Добавьте в папку автозагрузки (Пуск → Все программы →Автозагрузка) ярлык (не сам файл скрипта) для hide_program.js в случае использования яваскрипта, либо для load.bat в случае использования командного bat-файла.

Вариант 3

1) Создайте командный bat-файл (Например: Connect.bat) следующего содержания:

вместо "имя подключения" - укажите название вашего подключения к интернету
вместо login - укажите Ваш логин(имя пользователя) для подключения к интернету
вместо password - укажите Ваш пароль для подключения к интернету

2) Добавьте ярлык (не сам файл скрипта) на файл connect.bat в папку автозагрузки (Пуск → Все программы →Автозагрузка)

Внимание: "имя подключения" должно быть на английском иначе может быть ошибка 623.

Перейти к началу раздела Сети (Интернет и Локальная).


6. Отключение запроса пароля при использовании папки общего доступа.

Даже если Вы не устанавливали пароль для папки общего доступа, система может у Вас его запросить.

Для отключения данного запроса сделайте следующее:

1) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом
2) Нажмите на ссылку Изменить дополнительные параметры общего доступа
3) В графе Общий доступ с парольной защитой установите переключатель на значение Отключить общий доступ с парольной защитой.

Перейти к началу раздела Сети (Интернет и Локальная).


7. Просмотр исходного кода любой страницы в интернете.

Очень многие страницы в интернете любят скрывать свой код или блокировать копирование. Но это легко можно решить. Данный метод позволяет узнать любой код зашифрованный криптографами или измененный обфускаторами.

В Firefox

1)Установите расширение Web Developer.
Затем перейдите в меню Web Developer → Код и нажмите Сгенерированный код.
Если исходный код был зашифрован, то промотайте вниз и увидите реальный код. Если код не был зашифрован, то увидете его сразу.
Вы можете сохранить его либо скопировав в буфер обмена и вставив в нужное место, либо Файл → Сохранить страницу как → page.htm

В Internet Explorer

1) Нажмите на значок шестеренки и выберите Средства разработчика (F12)
2) Щелкните на значек курсора (Ctrl + B)
3) Выберите нужный элемент на странице и увидите его код.
4) Для сохранения исходного кода нажмите на значок дискетки
5) Выберите место сохранения файла и нажмите кнопку Сохранить.

Перейти к началу раздела Сети (Интернет и Локальная).


8. Использование swf-файлов взаимодействующих с удаленным приложением, на локальном компьютере.

Если Вы попытаетесь запустить локально swf-файл, который должен взаимодействовать с JavaScript на странице или с серверным приложением, запущенным на компьютере или должен загружать данные с удаленного домена, то Flash Player заблокирует его выполнение в целях безопасности.

Для решения проблемы Вы можете воспользоваться следующими вариантами:

Вариант 1.

Если у Вас есть интернет соединение, то воспользуйтесь менеджером настроек (Settings Manager) плеера.

1) Откройте специальную страницу настроек менеджера на сайте Macromedia в любом браузере:
http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html
2) Выберите в ниспадающем списке Изменить местоположение (Edit locations) → Добавить местоположение (Add location) → Обзор файлов
3) Укажите путь к swf-файлу. Вы можете выделить сразу несколько swf-файлов.
4) Перезапустите браузер и откройте локальную страницу с swf-файлом.

Вариант 2.

Если у Вас отсутствует интернет соединение, то можно добавить swf-файл или папку в доверенную зону (Local-Trusted sandbox) используя конфигурационный файл FlashPlayerTrust.

1) Создайте в папке: C:\Имя_пользователя\Administrator\AppData\Roaming\Macromedia\Flash Player\#Security\FlashPlayerTrust любой файл с расширением *.cfg
Где Имя_пользователя - это имя текущего пользователя компьютера.
2) Укажите путь к необходимому Вам swf-файлу или путь к папке в которой он находится. Вы можете указать путь к нескольким swf-файлам сразу, по одному в строке.

При создании файла учитывайте следующее:
- новый путь пишется с новой строки
- комментарии (если необходимы) начинаются с решетки #
- если путь содержит не ASCII символы, файл должен быть в формате UTF-8 или UTF-16
- пути только к локальным папкам и файлам, возможны пробелы, кавычки не желательны

3) Перезапустите браузер и откройте локальную страницу с swf-файлом.

Вариант 3.

Создайте и запустите в папке с Вашими swf-файлами командный bat-файл.

1) Скопируйте указанный ниже код в любой текстовый редактор (например, Блокнот).
2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .bat
3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "localswf.bat")
4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

5) Запустите созданный Вами bat-файл.
6) Перезапустите браузер и откройте локальную страницу с swf-файлом.

Перейти к началу раздела Сети (Интернет и Локальная).


9. Сохранение интернет соединения при переключении между пользователями.

При создании нового интернет подключения поставьте флажок на "Разрешить использовать это подключение другим пользователям".
Установление галочки в уже созданном подключении может работать некорректно в некоторых VPN соединениях.

По умолчанию при переключении между пользователями Windows сбрасывает dial-up и некоторые виды других соединений. Можно изменить это поведение следующим образом.

1) Запустите редактор реестра (Win   + R → Regedit → OK)
2) Откройте раздел реестра: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters
3) Щелкните правой кнопкой мыши на Dword-параметр KeepRASConnections, выберите Изменить и присвойте параметру значение 1
4) Закройте редактор реестра и завершите текущий сеанс для вступления изменений в силу.

Если Вы хотите, чтобы соединения сбрасывались, то используйте значение 0 или удалите этот параметр.

Перейти к началу раздела Сети (Интернет и Локальная).


10. Перемещение HOST, LMHOST и других файлов из Windows\System32\drivers\etc в другое место.

Если вы хотите переместить файлы из Windows\System32\drivers\etc в другое место (например, по соображениям безопасности) из папки Windows\System32\drivers\etc, то для этого Вам необходимо выполнить следующее:
1) Скопируйте файлы в новое место
2) Запустите редактор реестра (Win   + R → regedit → ОК).
3) Откройте следующий раздел реестра: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
4) Измените значение параметра DataBasePath на новый путь к папке
5) Перезагрузитесь и удалите файлы из %SystemRoot%\System32\drivers\etc

Перейти к началу раздела Сети (Интернет и Локальная).


11. Поиск на веб-сайтах из Проводника (Windows Explorer).

Windows 7 теперь позволяет вести поиск на веб-сайтах из Windows Explorer (Проводника). Данный поиск основан на спецификации OpenSearch.
Чтобы добавить в Windows провайдер OpenSearch, нужно предоставить файл определения в формате OSDX. Этот формат позволяет указывать описательную информацию наряду с необходимыми URL и другими параметрами.
Эти файлы сопоставляются с Windows Explorer и добавляются в папку Searches: C:\Users\{USER}\Searches.
Чтобы создать файл OSDX, нужно предоставить URL для вызова и ¤ провайдера.

1) Откройте текстовый редактор. (Например, Блокнот)
2) Скопируйте и вставьте в него следующий текст:

3) В меню программы нажмите Файл и выберите пункт Сохранить.
3.1) В открывшемся окне укажите место сохранения файла.
3.2) Укажите имя файла и расширение .osdx и ™зательно в кодировке UTF-8 (Например: Сохраните его как Bing.osdx)
3.3) Выберите тип файла: Все файлы (*.*).

Дважды щелкните по получившемуся osdx-файлу для внесения дополнений в систему.

Чтобы искать на добавленном Вами веб-сайте из Проводника:

1) Запустите Проводник (Windows Explorer)
2) Откройте папку C:\Users\{USER}\Searches, для чего просто введите %UserProfile%\Searches и нажмите Enter ↵.
3) Выберите установленный Вами поиск, в строке поиска укажите значение для поиска и нажмите Enter ↵.
4) Если Вы хотите, чтобы при нажатии на результат поиска в Проводнике показывались найденная страница, то нажмите на значок включения Области предварительного просмотра (находится, в верхней правой части экрана перед значком вопроса)

Вы можете скачать уже готовые файлы определения (.osdx) по ссылке: OSDX.zip

Перейти к началу раздела Сети (Интернет и Локальная).


12. Смена динамического IP-адреса, для обхода времени ожидания на файлообменниках.

Многие файлообменники и программы для скачивания разделяют обычных пользователей по IP адресу. Если Вы не используйте прокси-сервера и при каждом подключении к интернету провайдер дает Вам новый IP адрес, то это означает что у Вас динамический адрес и Вы можете создать командный файл разрывал бы связь и снова соединялся с интернетом. В итоге у вас будет новый адрес и яў файлообменника Вы будете уже новым клиентом.
Данная возможность позволит Вам обойти ограничение по времени и качать без ожиданий.

Инструкция по созданию командного файла:

1) Откройте любой текстовый редактор (Например, Блокнот).
2) Откройте меню Пуск → Все программы → Стандартные → Блокнот (или нажмите сочетание клавиш Win   + R → введите notepad → нажмите ОК)
3) Скопируйте необходимый Вам код в окно программы Блокнот.
4) В меню программы нажмите Файл и выберите пункт Сохранить.
В открывшемся окне:
5) Укажите место сохранения файла.
6) Укажите имя файла и расширение .bat (Например: reconnect.bat)
7) Выберите тип файла: Все файлы (*.*).
8) Для смены IP-адреса запустите созданный Вами командный файл просто щелкнув на нем.

Вариант 1. Внешний динамический адрес, прямое подключение по локальной сети.

Вариант 2. Внешний динамический адрес, подключение через модем или через USB-ADSL.

Способ 1.

Чтобы узнать имя требуемого интерфейса:
1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵:

Способ 2.

Вариант 3. Внешний динамический адрес, подключение через LAN-ADSL или через роутеры.
Скачиваете и устанавливаете программу Router Control, а файл reconnect.bat создаете в папке программы.

Перейти к началу раздела Сети (Интернет и Локальная).


13. Включение и настройка общего доступа к файлам и папкам.

В Windows 7 папка «Общее» заменена на отдельные общие папки яў каждого типа файлов: Общие документы, Общие рисунки, Общая музыка или Общее видео. В Проводнике Вы можете попасть в них через Библиотеки, открыв папку Документы, Рисунки, Музыка или Видео, а затем папку Общие документы, Общие рисунки, Общая музыка или Общее видео.

Предоставление общего доступа к файлам или папкам, находящимся в Общих папках с использованием домашней группы.

1) Нажмите кнопку Пуск и откройте Панель управления.
2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
3) Щелкните Выбор домашней группы и параметров общего доступа.
4) Нажмите на кнопку Создать домашнюю группу
5) Выберите элементы, к которым нужно предоставить общий доступ и нажмите кнопку Далее.
6) В окне с паролем для добавления других компьютеров к домашней группе нажмите кнопку Готово.
7) Нажмите на ссылку Изменить дополнительные параметры общего доступа
8) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
9) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

Предоставление общего доступа к любым файлам или папкам без перемещения их в Общие папки с использованием домашней группы.

I. Настройка конкретных папок или файла для общего доступа.

1) Перейдите в место размещения файла или папки, к которым необходимо предоставить общий доступ.
2) Щелкните файл или папку правой кнопкой мыши и выберите пункт Общий доступ → Конкретные пользователи
3) Введите имя или нажмите стрелку вниз и в ниспадающем меню выберите Все, а затем нажмите кнопку Добавить
4) Напротив имени Все установите необходимый Вам Уровень разрешений:
Чтение - Пользователи могут открывать файл, но им не разрешается изменять или удалять его.
Чтение и запись - Пользователи могут открывать, изменять и удалять файл.
5) Нажмите кнопку Общий доступ. Если отображается запрос на ввод пароля администратора или его подтверждения, укажите пароль или предоставьте подтверждение.
6) Нажмите правой кнопкой мышки на папке и выберите Копировать ссылку. Ваша ссылка будет скопирована в буфер обмена. Теперь вставьте ссылку в сообщение электронной почты, мгновенное сообщение или другую программу, или же сохраните в блокноте.
7) По завершении нажмите кнопку Готово.

II. Настройка портов для общего доступа.

1) Откройте Пуск → Панель управления → Система и безопасность и запустите Брандмауэр Windows.
2) Нажмите ссылку Дополнительные параметры, чтобы добавить новые правила для Firewall.
3) В открывшемся окне, в меню слева, выберите Правила для входящих подключений
4) В меню справа нажмите кнопку Создать правило….
5) В открывшемся окне, установите переключатель на тип правила Для порта и нажмите кнопку Далее.
6) Установите переключатель на Протокол TCP.
7) В текстовое поле напротив Определенные локальные порты: впишите через запятую 139, 445 и нажмите кнопку Далее.
8) В следующем окне оставьте установленное по умолчанию значение Разрешить подключение и нажмите кнопку Далее.
9) В окне выбора профилей снова нажмите кнопку Далее.
10) Введите имя и описание Вашего правила. Например: Shared Folders (TSP ports).
11) Нажмите кнопку Готово.

Повторите действия указанные в пунктах с 4) по 11) для типа протокола UDP.
В 6) пункте инструкции установите переключатель на Протокол UDP, в 7) пункте впишите порты 137, 138, а имя задайте Shared Folders (UDP ports).

III. Отключение запроса пароля.

1) Щелкните правой кнопкой мыши на значок сетевого подключения на панели задачи и выберите пункт Центр управления сетями и общим доступом.
2) Просмотрите Ваши активные сети. Тип сетевого размещения используемого для разрешения взаимодействия с другими компьютерами должен быть установлен как Домашняя сеть. Для смены типа сетевого размещения на Домашняя сеть:
2.1) Нажмите мышкой по имеющейся у Вас надписи Сеть предприя или Общественная сеть
2.2) В открывшемся окне выберите Домашняя сеть и нажмите кнопку Закрыть .
Если тип Вашего сетевого размещения уже установлен как Домашняя сеть, то Вам менять его не нужно.
3) Нажмите на ссылку Изменить дополнительные параметры общего доступа
4) В графе Общий доступ с парольной защитой установите переключатель в значение Отключить общий доступ с парольной защитой.
5) Нажмите на кнопку Сохранить изменения и закройте окно настроек.

Предоставление общего доступа к файлам и папкам, находящимся в Общих папках без использования домашней группы.

1) Нажмите кнопку Пуск и откройте Панель управления.
2) Установите режим просмотра "Крупные значки" и запустите компонент Центр управления сетями и общим доступом.
3) Щелкните Изменить дополнительные параметры общего доступа в левой области
4) Установите переключатели в следующие параметры:

- Включить сетевое обнаружение.
- Включить общий доступ к файлам и принтерам
- Включить общий доступ, чтобы сетевые пользователи могли читать и записывать файлы в общих папках (делает доступными папки "Общие документы", "Общая музыка", "Общие рисунки" и "Общее видео")
- Отключить общий доступ с парольной защитой

Примечания

Для включения общего доступа с парольной защитой, необходимо иметь две совершенно одинаковые учетные записи и пароли пользователя на обоих компьютерах.
Если ¤ пользователя и пароль, с которыми выполнен вход в систему, отличаются от зарегистрированного на другом компьютере, к которому осуществляется попытка доступа, возможно, будет запрошена информация для входа в систему.
Если на другом компьютере разрешен доступ всем в сети, автоматическое подключение будет предоставлено с правами гостя. Это означает, что доступ будет предоставлен только к файлам в общих папках.

Если при предоставлении общего доступа у Вас возникают проблемы, то Вы можете использовать средство устранения неполадок для автоматического поиска и устранения некоторых распространенных проблем.

1) Запустите командную строку с правами администратора.
1.1) Откройте Пуск → Все программы → Стандартные
1.2) Щелкните правой кнопкой мыши на Командная строка и выберите Запуск от имени администратора
2) Введите следующую команду и нажмите Enter ↵:

3) Нажмите кнопку Далее и следуйте инструкциям средства устранения неполадок.

Перейти к началу раздела Сети (Интернет и Локальная).


14. Автоматическая загрузка последних версий драйверов и реалистичных значков для подключенных устройств.

1) Откройте Пуск → Панель управления → Устройства и принтеры.
2) Щелкните правой кнопкой мыши ¤ компьютера и выберите пункт Параметры установки устройств.
3) Выберите пункт Да, делать это автоматически (рекомендуется) и нажмите кнопку Сохранить изменения.

Windows сохранит фирменные значки производитЈ для подключенных Вами устройств в папку:

%LOCALAPPDATA%\Microsoft\Device Metadata\dmrccache\

Внутри папки, в соответствии с вашим регионом (например, en-US), должны располагаться отдельные папки содержащие в названии GUID для каждого устройства с соответствующими метаданными. Иконка будет находится в папке DeviceInformation каждого устройства.

Перейти к началу раздела Сети (Интернет и Локальная).


15. Вычисление сайтов посещаемых пользователем в приватном режиме просмотра браузера.

Приватный режим посещения сайтов в браузерах не сохраняет на компьютере куки-файлы, временные файлы Интернета, журнал просмотра и другие сведения.
Но не смотря на это вся информация о посещенных сайтах в интернете и присутствующих на данном сайте компонентах сохраняется в кэше сопоставления имен клиентов.
В нем хранится такая информация, как IP адрес и ¤ домена, на основе которых можно вычислить адрес посещаемого сайта. Для просмотра данного кэша не требуются права администратора на компьютере.

Для отображения кэша сопоставления имен клиентов выполните следующее:

1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win   + R → cmd → OK) .
2) Введите команду и нажмите Enter ↵:

Чтобы была пауза после отображения каждого экрана выходных данных команды, введите:

3) Если Вам необходимо сохранить данную информацию в текстовый файл выполните команду:

Данные будут сохранены в файл DNScache.txt на диск C: .

Для сбрасывания данных кэша сопоставления имен клиентов выполните следующее:

1) Запустите командную строку нажмите кнопку Пуск и выберите Все программы, Стандартные и Командная строка (Win   + R → cmd → OK) .
2) Введите команду и нажмите Enter ↵::

Перейти к началу раздела Сети (Интернет и Локальная).


16. Месторасположение кэша браузера и его просмотр.

Каждый браузер по умолчанию сохраняет содержимое веб-страниц (изображения, flash-ролики, видео, аудио и др.), просмотренных вами на жёсткий диск в кэш, во избежание их повторной загрузки.

Microsoft's Internet Explorer.

Кэш для данного браузера хранится в отдельных профайлах для каждого пользователя по адресу:

С:\Users\Имя_пользователя\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5

Внутри директории \Content.IE5 содержаться дополнительные папки со "случайно" сгенерированными именами, в которых хранит© информация о посещение того или иного веб ресурса, а в файле index.dat, в котором и содержится интересующая нас информация. Файл index.dat для просмотра можно открыть программой Index.dat Analyzer.
Для сканирования содержимого index.dat файлов нажмите кнопку Quick rescan for index.dat files.

Также Вы можете открыть Свойства обозревателя, в графе История просмотра нажать Параметры, а затем кнопку Показать файлы.

Mozilla Firefox.

Mozilla Firefox использует особый алгоритм кэширования страниц. Папка, в которой хранит© интересующая Вас информация:

С:\Users\Имя_пользователя\AppData\Local\Mozilla\Firefox\Profiles\Имя_профиля\Cache

Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке about:cache?device=disk и нажмите Enter ↵.

Opera

Кэш для данного браузера хранится в отдельных подпапках по адресу:

С:\Users\Имя_пользователя\AppData\Local\Opera\Opera\cache

Для просмотра кэша: Откройте новую вкладку, наберите в адресной строке opera:cache и нажмите Enter ↵.

Также Вы можете скачать и использовать для просмотра кэша браузеров Internet Explorer, Mozilla Firefox или Opera программу Cache View Plus. Данная программа позволяет Вам напрямую (в режиме предпросмотра) увидеть файлы находящиеся в кэше файлы в соответствии с их типом: изображения, видео, звуки, swf-файлы.

Перейти к началу раздела Сети (Интернет и Локальная).


17. Отключение автоматической отправки сведений на сервера корпорации Microsoft, собранных программой улучшения качества программного обеспечения.

В корпорации Microsoft существует программа улучшения качества программного обеспечения, которая собирает сведения о продуктах Microsoft, а также ограниченные данные о произведенных независимыми компаниями приложениях, которые взаимодействуют с продуктами Microsoft и отсылает их на сервера Microsoft.

Более подробно о ней Вы можете прочитать на сайте: http://www.microsoft.com/products/ceip/ru-ru/default.mspx

Если Вы не желаете участвовать в данной программе, то сделайте следующее:

1) В строке поиска меню Пуск введите команду gpedit.msc и нажмите Enter ↵.
2) Перейдите в папку:

3) Щелкните правой кнопкой мыши на Отключить программу по улучшению качества программного обеспечения Windows и выберите пункт Изменить.
4) Установите переключатель в значение Включить и нажмите кнопку OK.

Перейти к началу раздела Сети (Интернет и Локальная).


18. Добавление индикатора сетевой активности на панель задач.

Значок Сеть в области уведомлений на панели задач при наведении на него отображает всего лишь текущее подключение и не мигает при наличии сетевой активности.
Если Вы желаете добавить значок в область уведомлений, позволяющий увидеть размер входящего и исходящего траффика, а также просмотреть статистику подключения, то Вы можете скачать небольшую бесплатную программу Network Activity Indicator, максимально приближенную к интерфейсу Windows.

Если Вы желаете заменить стандартную иконку Сеть на иконку данной программы, то проделайте следующее:

1) Зайдите на сайт: http://www.itsamples.com/network-activity-indicator.html
2) Скачайте программу Network Activity Indicator и язык интерфейса к ней.
3) Распакуйте программу и язык интерфейса для программы в одну и ту же папку.
4) Откройте папку, куда Вы распаковали программу и запустите файл NetworkIndicator.exe
5) Нажмите правой кнопкой мыши на иконку программы и выберите пункт Настройки
6) Установите флажки:
Отображать UDP пакеты
Отображать ICMP пакеты
Запускать при старте Windows
Показывать неактивную иконку если интерфейс отсоединен.
Использовать иконки Vista
7) Нажмите кнопку Применить.
8) Щелкните правой кнопкой мыши на панели задач и выберите пункт Свойства.
9) В графе Область уведомлений щелкните на кнопку Настроить...
10) Нажмите на ссылку Включить или выключить системные значки.
11) Напротив значка Сеть из ниспадающего списка выберите Выкл.
12) Нажмите ОК и еще раз ОК.

Перейти к началу раздела Сети (Интернет и Локальная).


19. Создание ярлыка для запуска Internet Explorer в режиме приватного просмотра.

1) Щелкните правой кнопкой мыши на свободном месте рабочего стола, и выберите Создать → Ярлык.

2) Для 32-битных Windows 7:

2.1) В поле Укажите расположение объекта введите:

2.2) Переходите к пункту 4.

3) Для 64-битных Windows 7:

3.1) Чтобы использовать 32-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

3.2) Чтобы использовать 64-битную версию Internet Explorer, в поле Укажите расположение объекта введите:

4) Нажмите кнопку Далее.
5) В поле Введите имя ярлыка напишите Internet Explorer (просмотр InPrivate) и нажмите кнопку Готово. (Примечание: Вы можете указать любое имя для ярлыка.)
6) Теперь Вы можете переместить созданный Вами ярлык в любое удобное для Вас место. Например, Вы можете закрепить ярлык в панели задач.

Перейти к началу раздела Сети (Интернет и Локальная).


20. Создание ярлыка в папке Компьютер для просмотра часто используемого ftp как одного из дисков.

1) В Проводнике или в меню Пуск щелкните правой кнопкой мыши на Компьютер
2) Выберите в списке пункт Подключить сетевой диск
3) Нажмите ссылку Подключение к сайту, на котором можно хранить документы и изображения.
4) В открывшем окне нажмите кнопку Далее, а затем снова кнопку Далее.
5) В текстовом поле введите имя ftp-сервера и нажмите кнопку Далее.

Например: ftp://ftp.mozilla.org/pub/firefox/

6) Уберите флажок "Анонимный вход" и введите имя пользователя и нажмите кнопку Далее.
Если яў входа не нужна идентификация пользователя, то оставьте флажок "Анонимный вход" установленным.
7) Введите имя для отображаемого ярлыка в Проводнике и нажмите Далее.
8) Для завершения создания ярлыка нажмите кнопку Готово.

Перейти к началу раздела Сети (Интернет и Локальная).


21. Быстрая очистка истории обзора Internet Explorer при помощи специально созданного ярлыка.

Если Вы используете браузер Internet Explorer, то для очистки истории обзора(временных файлов, кэша, паролей и др.) Вы делаете следующее:

1) В Internet Explorer открываете Свойства обозревателя.
Если у Вас включена Строка меню, то данный пункт расположен в меню Сервис, если Строка меню отключена, то нажимаете на значок шестеренки.
2) На вкладке Общие в графе История просмотра нажимаете кнопку Удалить... .
3) Устанавливаете необходимые флажки и нажимаете кнопку Удалить.

Чтобы ускорить данный процесс Вы можете создать специальный ярлык для очистки определенных данных из истории просмотра Internet Explorer на рабочем столе.

1) Щелкните по рабочему столу правой кнопкой мыши, выберите команды "Создать" - "Ярлык".
2) В текстовом поле введите необходимую Вам команду для запуска.

Удаление истории посещений (журнала):

Удаление Cookies:

Удаление временных файлов/веб страниц:

Удаление данных веб-форм:

Удаление паролей:

Полное удаление всей истории:

Полное удаление всей истории и данных надстроек браузера:

3) Нажмите кнопку Далее
4) Укажите имя для ярлыка и нажмите Готово.

Так же можно комбинировать номера, суммируя их.
Например:

Это удалит временные файлы (+8) и журнал посещений (+1).

Перейти к началу раздела Сети (Интернет и Локальная).


22. Поиск необходимого файла на крупнейших файлобменниках.

Если Вам часто бывает необходимо найти какой-либо конкретный файл (видео, музыку, программное обеспечение, документы и т.д.), а крупнейшие поисковики наподобие Google или Bing либо его не находят, либо выдают много лишних результатов после поиска, то существует специальная поисковая система, помогающая найти файлы на различных хостинговых сайтах.

Даннная поисковая система общедоступных файлов помогает найти файлы, соответствующие Вашим критериям, среди тех файлов, которые недавно были отслежены на сайтах их собственным уникальным сканером по поиску информации. Каждая найденная при помощи этого сканера информация хранится в базе данных. Осуществляя поиск используя данную поисковую систему, Вы получаете результаты напрямую из этой базы данных.

Кроме того, на странице результата поиска, в случае его наличия указывается сайт, на котором были обнаружены данные ссылки. Это бывает полезно, если скаченный Вами архив окажется запаролен.

Для обеспечивания лучшего результата поиска не указывайте в текстовом поле разрешение файла, а выбирайте его из ниспадающего списка (при наличие).

Ссылка на поисковую систему: FilesTube

Перейти к началу раздела Сети (Интернет и Локальная).


23. Создание url-файла, для перехода на указанную страницу в интернете.

Наверное Вы замечали, что при установке многие программы создают файл .url (Ярлык Интернета), при нажатии на который в браузере открывается домашняя страница программы.

Вы также можете создать такой файл-ссылку, для этого выполните указанные ниже действия:

1) Щелкните правой кнопкой мыши по свободному пространству в папке, где Вы хотите создать url-файл.
2) Выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите адрес страницы в интернете. Например: http://www.google.com
4) Нажмите кнопку Далее и укажите название ярлыка, после чего нажмите на кнопку Готово.

Перейти к началу раздела Сети (Интернет и Локальная).


24. Восстановление содержимого файла hosts по умолчанию.

Если в файл hosts были внесены какие-либо изменения, например, для блокировки соединения с определенными сайтами, то Вы можете восстановить параметры файла hosts по умолчанию, для этого выполните указанные ниже действия:

1) Откройте меню Пуск, выберите пункт Выполнить (Win   + R), введите команду %systemroot%\system32\drivers\etc и нажмите кнопку ОК.
Примечание. Если используется 64-разрядная версия Windows, введите команду %systemroot%\SysWOW64\drivers\etc.
2) Переименуйте файл hosts в hosts.old.
3) Создайте новый файл hosts по умолчанию. Для этого выполните указанные ниже действия.
4) Щелкните правой кнопкой мыши в свободном месте в папке %WinDir%\system32\drivers\etc, выберите пункт Создать, щелкните элемент Текстовый документ, введите имя hosts и нажмите клавишу Enter ↵.
5) Нажмите кнопку Да, чтобы подтвердить, что имя файла не будет иметь расширение TXT.
6) Откройте новый файл hosts в текстовом редакторе. Например, откройте файл в программе "Блокнот".
7) Скопируйте в файл приведенный ниже текст.

8) Сохраните и закройте файл.

Перейти к началу раздела Сети (Интернет и Локальная).


25. Одновременное использование сайтов (скриптов) из локальной сети и из интернета, при включенном VPN-подключении к интернету.

Если локальный сайт открывается у Вас только при выключенном интернете, а Вы не желаете отключаться от интернета.
Если сайт одновременно использует содержимое как из локальной сети, так и из интернета.
То Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1. Автоматическое определение указанного Вами сайта как локального.

1) Откройте Пуск → Панель управления → Свойства обозревателя
2) Перейдите на вкладку Безопасность
3) Выберите зону Местная интрасеть и нажмите кнопку Узлы.
4) Нажмите кнопку Дополнительно.
5) Введите адрес сайта, который должен определятся как принадлежащий локальной сети и нажмите кнопку Добавить.
6) Закройте окна настроек свойств обозревателя.
7) Закройте все браузера, переподключитесь к интернету и зайдите в браузер снова.

Вариант 2. Использование основного шлюза в удаленной сети.

1) Отключитесь от VPN-подключения, если Вы подключены.
2) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
3) Щелкните правой кнопкой мыши на Вашем VPN-подключении и выберите пункт Свойства.
4) Перейдите на вкладку Сеть
5) Щелкните на Протокол Интернета версии 4 (TCP/IPv4) и нажмите кнопку Свойства.
6) Нажмите кнопку Дополнительно...
7) Снимите флажок Использовать основной шлюз в удаленной сети.
8) Нажмите OK, OK, OK.
9) Подключитесь к VPN-подключению.
10) Если у Вас данный вариант не сработал, то верните флажок обратно.

Вариант 3. Получение автоматических настроек.

1) Отключитесь от VPN-подключения, если Вы подключены.
2) Откройте Панель управления\Сеть и Интернет\Сетевые подключения
3) Щелкните правой кнопкой мыши на Подключение по локальной сети (Local Area Connection) и выберите пункт Свойства.
4) Щелкните на Протокол Интернета версии 4 (TCP/IPv4) и нажмите кнопку Свойства.
5) Если Вы самостоятельно не устанавливали настройки, то запишите себе куда-нибудь текущие значения полей.
6) Установите переключатели в значения: Получить IP-адрес автоматически и Получить адрес DNS-сервера автоматически.
7) Нажмите OK, OK.
8) Подключитесь к VPN-соединению.
9) Если у Вас данный вариант не сработал, то:
10) Установите переключатели в значения: Использовать следующий IP-адрес и Использовать следующие адреса DNS-серверов.
11) Введите записанные Вами значения обратно.

Перейти к началу раздела Сети (Интернет и Локальная).


26. Открытие сайта из другой страны не прописывая в браузере прокси-сервера.

Если Вы желаете, чтобы сайты определяли в качестве страны Вашего местоположения определяли какую-либо другую страну, но при этом не собираетесь прописывать в настройки браузера прокси-сервер, то Вы можете воспользоваться следующим решением.

1) Зайдите на сайт http://sourceforge.net/projects/advtor/ и скачайте программу Advanced Onion Router.
Данная программа использует анонимную сеть TOR, предоставляющую передачу данных в зашифрованном виде.
2) Распакуйте архив и запустите программу.

Прежде всего Вам необходимо добавить в программу черный список серверов.

3) В списке слева перейдите Plugin → IP Blacklist (Blacklist.dll)
4) Введите http://list.iblocklist.com/?list=ijfqtofzixtwayqovmxn и нажмите кнопку Download
5) Дождитесь пока загрузится список.

6) Внизу окна программы Advanced Onion Router нажмите кнопку Connect.
7) Дождитесь когда появится надпись Connected to the OR network.
8) В списке слева перейдите Intercept → Quick Start
9) Справа в окне программы нажмите кнопку Run
10) Укажите путь к Вашему браузеру.
10.1) Откройте папку, где находится Ваш браузер.
10.2) Выделите запускаемый файл программы и нажмите кнопку Открыть.

Запустится браузер, а для скрытия Вашего местоположения будет выбран случайный сервер.

11) Чтобы сменить текущий ip-адрес на новый, нажмите внизу окна программы Advanced Onion Router кнопку New Identity.
12) Чтобы выбрать какую-либо конкретную страну местоположения:
12.1) Нажмите кнопку >> рядом с кнопкой New Identity.
12.2) В ниспадающем списке Country выберите необходимую страну и нажмите кнопку Select.

Примечание:

П.1) Так как черный список серверов часто обновляется, то действия указанные в пунктах с 3 по 5 рекомендуется выполнять периодически.
П.2) Каждый сервер, используемый для скрытия Вашего местоположения может иметь различную скорость.
П.3) Для возврата к собственному местоположению (ip-адресу) просто выйдите из программы Advanced Onion Router и перезапустите браузер.

Перейти к началу раздела Сети (Интернет и Локальная).


27. Включение log-файла журнала брандмауэра Windows.

Если Вы используете встроенный в Windows брандмауэр, то для наибольшего контроля за его действиями Вы можете включить ведение log-файла журнала.

Чтобы это сделать, выполните указанные ниже действия:

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵

2) Введите указанные далее команды, нажимая после введения каждой из них клавишу Enter ↵.

2.1) Включите брандмауэр Windows.

2.2) Задайте имя и месторасположение log-файла журнала.

2.3) Задайте максимальный размер log-файла фурнала в килобайтах (Например: 10 МБ = 10240 КБ).

2.4) Включение протоколирования разорванных подключений.

2.5) Включение протоколирования разрешенных подключений.

Перейти к началу раздела Сети (Интернет и Локальная).


28. Удаление из Internet Explorer плагина, у которых отсутствует или заблокирована кнопка Удалить.

1) В Internet Explorer нажмите на значек шестеренки и выберите пункт Надстройки.
2) Щелкните правой кнопкой мыши на необходимый Вам плагин и выберите пункт Подробнее.
3) Запишите значения указанные для ID класса, Файл и Папка.
4) Закройте Internet Explorer.
5) В Проводнике откройте указанную папку и удалите (или переименуйте) найденный файл.
6) Запустите редактор реестра (лучше Registry Workshop).
7) Найдите и удалите все папки с названием, содержащим значение ID класса.

Перейти к началу раздела Сети (Интернет и Локальная).


29. Закрепление вебсайта на панели задач, а также отключение и восстановление данной возможности.

Чтобы закрепить вебсайт на панели задач, выполните следующие действия.

1) В Internet Explorer нажмите на значек шестеренки и выберите пункт Файл.
2) Во всплывающем меню выберите пункт Добавить сайт в меню "Пуск".
3) В открывшемся окне нажмите кнопку Добавить.
4.1) Щелкните правой кнопкой мыши на появившийся в панели задач значок и выберите пункт Закрепить программу в панели задач.

или

4.2.1) Нажмите кнопку Пуск → Все программы
4.2.2) Щелкните правой кнопкой мыши на Вашем сайте и выберите пункт Закрепить на панели задач.

Примечание: Все сайты кроме панели задач, также закрепляются в папке Все программы в меню Пуск. Если там они Вам не нужны, то Вы можете их оттуда удалить.

При желании Вы можете отключить возможность закрепления файлов в меню Пуск и на панели задач, для этого создайте и примените указанный ниже reg-файл:

Чтобы восстановить возможность закрепления сайта на панели задач, создайте и примените reg-файл указанного ниже содержания:

Перейти к началу раздела Сети (Интернет и Локальная).


30. Установка вручную плагина VLC Web Plugin для программы Mozilla Firefox.

Многие сайты, осуществляющие потоковое вещание различных телеканалов в интернете, требуют установки специальных плагинов "Windows Media Player Firefox Plugin" и "VLC Web Plugin".

Если яў установки плагина "Windows Media Player Firefox Plugin", Вам достаточно лишь скачать небольшой файл с самим плагином, то для установки новой версии плагина VLC Web Plugin Вам необходимо установить VLC media player (Videolan) и выбрать во время установки пункт Web plugins.

Чтобы установить последнюю версию плагина VLC Web Plugin, при этом не устанавливая сам плеер, Вы можете воспользоваться предложенным ниже решением.

1) Зайдите на сайт http://nightlies.videolan.org/build/win32/last/
2) Скачайте zip-архив с программой VLC media player и разархивируйте его в любую папку.
3) Закройте Mozilla Firefox.
4) Скопируйте из папки, куда Вы разархивировали zip-архив в папку C:\Program Files (x86)\Mozilla Firefox\browser\plugins файлы axvlc.dll, libvlc.dll, libvlccore.dll, npvlc.dll и папку plugins.
Для старых версий Mozilla Firefox копировать необходимо в папку: C:\Program Files (x86)\Mozilla Firefox\Plugins.
5) Запустите Mozilla Firefox.

Перейти к началу раздела Сети (Интернет и Локальная).


31. Быстрый доступ к редактированию файла Hosts.

Если Вам приходится работать с программами, которым необходимо запрещать доступ к интернету, и Вы делаете это с помощью файла hosts из папки C:\Windows\System32\drivers\etc, то Вы можете воспользоваться указанными ниже решениями для быстрого доступа к нему.

Вариант 1.

Для создания специального ярлыка, открывающего в Блокноте файл hosts, выполните указанные ниже действия.

1) Щелкните правой кнопкой мыши по свободному пространству рабочего стола.
2) Выберите в контекстном меню Создать → Ярлык.
3) В открывшемся окне мастера, в строке «Укажите расположение объекта» введите:

4) Нажмите кнопку Далее и укажите название ярлыка (Например, Редактировать HOSTS), после чего нажмите на кнопку Готово.
Теперь достаточно запустить созданный ярлык и файл hosts откроется в Блокноте для редактирования.

Вариант 2.

Для добавления в контекстное меню рабочего стола пункта Редактировать HOSTS файл, создайте и примените указанный ниже reg-файл.

Чтобы удалить пункт Редактировать HOSTS файл из контекстного меню рабочего стола, создайте и примените указанный ниже reg-файл.

Перейти к началу раздела Сети (Интернет и Локальная).


32. Отключение использования вкладок в Internet Explorer.

Чтобы отключить использование вкладок в Internet Explorer:

1) Откройте Пуск → Панель управления → Свойства обозревателя
2) В разделе вкладки нажмите на кнопку Параметры.
3) Снимите установленный флажок Включить обзор с вкладками (после запуска) и нажмите кнопку ОК.
4) Перезапустите Internet Explorer (если он был у Вас запущен).

Перейти к началу раздела Сети (Интернет и Локальная).


33. Переустановка браузера Internet Explorer.

Чтобы переустановить Internet Explorer, Вам для начала необходимо его полностью удалить.
Так как удаление Internet Explorer через "Пуск → Панель управления → Программы и компоненты → Включение или отключение компонентов Windows" его полностью не удаляет, то для полного его удаления воспользуйтесь предложенным ниже решением.

1) Скачайте и установите программу Unlocker.
2) Зайдите на сайт http://windows.microsoft.com/ru-RU/internet-explorer/downloads/ie и скачайте последнюю версию Internet Explorer.
Для удобства поместите скаченный файл установки Internet Explorer на рабочий стол.
3) Щелкните правой кнопкой мыши по значку Internet Explorer на панели задач (в случае его наличия там) и выберите пункт Изъять программу из панели задач.
4) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd, щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
5) В окне команд введите указанную ниже команду и нажмите клавишу Enter ↵.

При ¦влении окон с ошибкой 0x8007005 нажимайте кнопку ОК или клавишу Enter ↵.
6) Откройте папку C:\Program Files\Internet Explorer и выделите все ее содержимое.
7) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
8) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
В 64-битной версии Windows повторите действия описанные в пунктах с пятого по седьмой для папки C:\Program Files (x86)\Internet Explorer.
9) Перезагрузите компьютер.
10) Снова запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd, щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора.
11) В окне команд снова введите команду указанную ниже и нажмите клавишу Enter ↵.

При ¦влении окон с ошибкой 0x8007005 нажимайте кнопку ОК или клавишу Enter ↵.
12) Перезагрузите компьютер.
13) Запустите с рабочего стола установщик Internet Explorer и нажмите кнопку Установить.
14) Щелкните в окне установщика на слово Проводник.
15) Установите переключатель в значение Закрыть программы (Моя работа сохранена) и нажмите кнопку Продолжить.
После окончания установки Internet Explorer автоматически запустится.
16) Щелкните правой кнопкой мыши по значку Internet Explorer на панели задач и выберите пункт Закрепить программу в панели задач.
17) Закройте Internet Explorer, нажав при закрытии на кнопку Закрыть все вкладки.

Перейти к началу раздела Сети (Интернет и Локальная).


34. Открытие сайтов использующих IPv6 протокол без внесения изменения в настройки системы.

Если у Вас отсутствует возможность открывать сайты использующие IPv6, и Вы не можете или не хотите вносить изменения в настройки системы, то Вы можете воспользоваться специальными прокси-сайтами, позволяющими открывать через них необходимые Вам ipv6 сайты.

http://www.ipv6proxy.net/

Вводите Ваш ipv6 сайт и нажимаете кнопку GO.

http://www.sixxs.net/tools/gateway/

В поле рядом с кнопкой Browse over IPv4 введите Ваш ipv6 сайт и нажимаете данную кнопку.

Перейти к началу раздела Сети (Интернет и Локальная).


35. Просмотр интернет-страницы (html-документа) в предыдущей версии Internet Explorer из текущей версии.

Чтобы просмотреть как выглядит страница при открытии в предыдущей версии браузера:

1) Запустите имеющуюся у Вас версию Internet Explorer.
2) Откройте необходимую страницу или html-документ.
3) Нажмите клавишу F12.
4) Нажмите сочетание клавиш Alt+B и выберите из списка версию Internet Explorer в которой Вы желаете просмотреть html-документ.

Перейти к началу раздела Сети (Интернет и Локальная).


36. Сохранение видео с интернета на компьютер.

Чтобы скачать видео с большинства сайтов Вы можете воспользоваться одним из предложенных вариантов.

Вариант 1.

Скачайте и установите специальное дополнение для интернет-браузера, которое сгенерирует Вам прямую ссылку(и) для скачивания.
Достаточно всего лишь проиграть видео в течение несколько секунд.
Такие дополнения обычно либо добавляют кнопку Download (Скачать) под просматриваемое Вами видео, либо кнопку-значек на панель навигации, панель дополнений (она же строка состояний).
Наиболее популярными из них являются:

1) SaveFrom.net helper (работает во всех браузерах)
2) Video DownloadHelper: стабильная, бета версии. (дополнение для Mozilla Firefox)
3) FVD Video Downloader (дополнение для Opera)

Вариант 2.

Скачайте и установите менеджер загрузок Internet Download Manager.
Основными плюсами данной программы, по сравнению с дополнениями, являются поддержка Internet Explorer и закачка потокового rtmp-видео (данный способ вещания используется большинством веб-камер).
Данная программа содержит специальную панель скачивания небольшого размера, которая позволит Вам скачать просматриваемое видео.
Для этого:
1) Запустите воспроизведение видеофайла и установите необходимое качество видео.
В течение несколько секунд у Вас появится панель скачивания.
2) Нажмите на значок воспроизведения на этой панели, а затем нажмите кнопку Начать качать.
3) Если Вы скачиваете потоковое видео, то нажмите кнопку Стоп, а затем кнопку Да, для прекращения записи, в остальных случаях закачка завершится сама.
Для повторной закачки потокового видео иногда может понадобится перезагрузить браузер.
Для повторной закачки обычного видео просто обновите страницу и повторите указанные выше действия.

Перейти к началу раздела Сети (Интернет и Локальная).


37. Смена поиска по умолчанию в Mozilla Firefox.

Если какая-либо программа изменила в Firefox Ваш поисковой движок на собственный, то для его восстановления сделайте следующее:

Щелкните в поле Поиск на значок лупы и выберите необходимый Вам поисковой движок.
Если браузер для поиска продолжит использовать другой движок, то:

1) Введите в адресной строке Firefox:

about:config

2) Нажмите на кнопку подтверждающую, что Вы будете осторожны.
3) Введите в поле поиска параметр keyword.url
3) Измените его значение на:

Для Google.Com:
http://www.google.com/search?&q=

Для Yandex.Ru:
http://yandex.ru/yandsearch?text=

Для Bing.Com:
http://www.bing.com/search?q=

Перейти к началу раздела Сети (Интернет и Локальная).


38. Добавление ссылки Поиск в Интернете при использовании поиска в меню Пуск.

В Windows Vista была предложена новая функция. При наборе текста в поле поиска меню Пуск, прямо над окном поиска появлялась ссылка "Поиск в Интернете". При её нажатии набранный текст посылался напрямую в браузер, используемый по умолчанию для поиска.
В Windows 7 данная функция по умолчанию отключена. Microsoft удалила его из меню "Пуск". Чтобы включить "Поиск в Интернете" через меню «Пуск» необходимо проделать следующие действия.

1) Откройте диалоговое меню Выполнить (Win   + R)
2) Введите gpedit.msc.
3) Перейдите в раздел Конфигурация пользователя → Административные шаблоны → «Меню «Пуск» и панель задач».
4) Нажмите правой кнопкой мыши на строке Добавить ссылку «Поиск в интернете» в меню «Пуск» и выберете пункт «Изменить».
5) В открывшемся окне установите переключатель в значение «Включить».
6) Нажмите «OK» и закройте Редактор локальной групповой политики.

Также Вы можете создать reg-файл, выполняющий данную функцию или скачать и применить уже готовый. После применения перезайдите в систему или перезагрузите компьютер.

Готовый файл: AddSearchInternetLinkInStartMenu.zip

Перейти к началу раздела Сети (Интернет и Локальная).


39. Обмен файлами между компьютерами без создания локальной сети и использования облачных хранилищ данных.

Если Вам необходимо создать собственное хранилище файлов на одном компьютере, так чтобы их можно было скачать с другого компьютера, используя адрес в интернете, то воспользуйтесь предложенной ниже инструкцией.

1) Скачайте архив с программой HFS ~ Http File Server и распакуйте его в любую папку.
2) Откройте данную папку, нажмите правой кнопкой мыши на exe-файл и выберите пункт Запуск от имени администратора.
3) В случае появления окна фаервола, разрешите программе доступ в сеть.
4) В окне с запросом Do you want HFS in your shell context menu? нажмите кнопку Yes для добавления программы в контекстное меню Проводника или кнопку No для отказа.
5) Нажмите Menu → IP adress → Find external address
6) Во всплывшем окне нажмите кнопку ОК.
7) Нажмите Port:any введите 8080 и нажмите кнопку ОК.
8) В окне Virtual File System нажмите правой кнопкой мыши на косую черту рядом с домиком и воспользуйтесь:
8.1) пунктом Add files → Open для добавления файлов
8.2) пунктом Add folder from disk → Real folder для добавления папки.
9) Нажмите на кнопку Server is currently OFF.
Теперь Вы можете использовать Ваш IP-адрес и номер порта, как доступ к Вашему файловому хранилищу.
Пример: (Ваш адрес к папке будет выглядеть подобным образом)
http://159.148.75.20:8080/Temp

Если у Вас не открывается доступ по созданной Вами ссылке, то:

1) Добавьте программу Http File Server (hfs.exe) в используемый Вами фаервол и разрешите ей доступ к порту 8080 как на исходящие, так и на входящие соединения.
2.1) В настройках Вашего роутера (при его наличии) найдите настройку Переадресация портов, Перенаправление портов, Виртуальный сервер, Port Forwarding или Virtual Server.
2.2) Добавьте доступ к порту 8080 для IP-адреса присвоенного роутером Вашему компьютеру (Пример: 192.168.1.111).

Перейти к началу раздела Сети (Интернет и Локальная).


40. Подключение и настройка общего доступа к сетевому принтеру.

1) Настройте локальную сеть и параметры общего доступа, в соответствии с инструкцией из совета Настройка локальной сети между компьютерами из раздела Сети (Интернет и Локальная).
2) Подключите Ваш принтер к основному компьютеру.
Если Ваш принтер подключен к USB-порту, то в большинстве случаев драйвера для Вашего принтера будут установлены автоматически.
Если Ваш принтер не был обнаружен системой, то установите драйвера для него самостоятельно.
3) Откройте меню Пуск и нажмите пункт Панель управления.
4) Установите вид просмотра Крупные значки и выберите Устройства и принтеры.
5) Щелкните на Ваш принтер и в открывшемся окне нажмите Настройка принтера.
6) Перейдите на вкладку Доступ.
7) Установите флажок Общий доступ к данному принтеру.
8) В поле Имя общего ресурса введите имя Вашего принтера и нажмите кнопку ОК.
9) На сетевом компьютере откройте меню Пуск и нажмите пункт Панель управления.
10) Установите вид просмотра Крупные значки и выберите Устройства и принтеры.
11) Нажмите на Установка принтера.
12) Щелкните на Добавить сетевой, беспроводной или Bluetooth-принтер.
13) Нажмите на Необходимый принтер отсутствует в списке.
14) Установите переключатель в значение Выбрать общий принтер по имени и нажмите кнопку Обзор.
15) Откройте компьютер к которому подключен Ваш принтер.
16) Щелкните правой кнопкой мыши на Вашем принтере и нажмите пункт Выбрать.
17) В окне Установка принтера нажмите кнопку Далее и еще раз кнопку Далее, а затем кнопку Готово.

Перейти к началу раздела Сети (Интернет и Локальная).


1. Отключение "гибернации" для исправления ошибки BSOD и получения дополнительного места на жестком диске.

Бывает при выходе из режима гибернации многие видят только черный экран или ошибку BSOD. После чего приходится выключать кнопкой питания и включать заново. Одним из решений в такой ситуации является отключение гибернации.

1) Запустите командную строку с правами администратора
1.1) В строке поиска в меню Пуск введите cmd
1.2) Щелкните на найденном правой кнопкой мыши и выберите пункт Запуск от имени администратора
2) Введите команду и нажмите Enter ↵:

Чтобы выключить гибернацию:

Чтобы включить:

Отключение гибернации также приведет к тому, что файл hiberfil.sys, расположенный в корне диска на котором у вас установлена Windows автоматически удалится, освобождая дополнительное пространство на накопителе.

Перейти к началу раздела Тонкие настройки.


2. Удаление значка "Центр поддержки" из области уведомлений на панели задач.

Если во время работы у Вас в трее появился флаг "Центра поддержки", и Вы хотите его убрать, то проделайте следующее.

1) Щелкните правой кнопкой мыши на свободное место на панели задач и нажмите пункт Свойства
2) Нажмите кнопку Настроить...
3) Щелкните по ссылке Включить или выключить системные значки
4) Напротив надписи Центр поддержки выберите из ниспадающего списка значение Выкл нажмите ОК.

Перейти к началу раздела Тонкие настройки.


3. Удаление текста под значком ярлыка или файла.

1) Щелкните правой кнопкой мыши на иконке и нажмите Переименовать.
2) Удерживая нажатой клавишу Alt, напечатайте на цифровой клавиатуре подряд цифры 2, 5, 5.
Данная комбинация позволяет добавить невидимый символ с кодом 255 в название ярлыка или файла.
Для переименования несколько ярлыков/файлов, находящихся рядом, добавляйте к каждому следующему дополнительно на один невидимый символ больше.
Для введения нескольких символов подряд отпускайте клавишу Alt после каждого введения цифр 2, 5, 5.

Перейти к началу раздела Тонкие настройки.


4. Создание (восстановление) панели быстрого запуска (Quick Launch).

1) Щелкните правой кнопкой мыши по панели задач и наведите курсор на Панели (Toolbars )
2) Нажмите на пункт Создать панель инструментов... (New Toolbar)
3) Введите путь к папке: %appdata%\Microsoft\Internet Explorer\Quick Launch и нажмите клавишу Enter ↵.
4) Нажмите кнопку Выбор папки (Select Folder).
5) Щелкните правой кнопкой мыши по панели задач и уберите флажок Закрепить панель задач.
6) Щелкните левой кнопкой мыши на панели Quick Launch и не отпуская клавиши перетащите панель в левую сторону.
7) Щелкните правой кнопкой мыши на панели Quick Launch и уберите флажки Показывать подписи" и Показывать заголовок.
8) Щелкните правой кнопкой мыши по панели задач и поставьте флажок Закрепить панель задач.

Перейти к началу раздела Тонкие настройки.


5. Разблокирование файла используемого какой-либо программой для действий с ним.

Если при попытке удаления, переименования или перемещения файла или папки, система не позволяет Вам сделать этого, так как файл (папка) используется другим приложением или у Вас нет прав доступа для осуществления данного действия, то для разблокировки используемого файла (папки) Вы можете воспользоваться замечательной утилитой Unlocker.
Программа является дополнением к Проводнику Windows, а ее вызов осуществляется через контекстное меню, вызываемое нажатием правой кнопкой мыши на файле (папке).

Инструкция:

1) В соответствии с разрядностью Вашего Windows cкачайте и установите программу Unlocker
2) Нажмите правой кнопкой на файле и в контекстном меню выберите Unlocker.
3) Выберите необходимое Вам действие и нажмите на кнопку Разблокировать Все.
Если блокирующий дескриптор не найден, то после выбора необходимого Вам действия нажмите на кнопку ОК.
4) В окне Готово нажмите ОК.

Для замены защищенного файла Windows сделайте следующее:

1) Скопируйте файл(ы) для дальнейшей замены в буфер обмена.
2) С помощью инструкции выше, удалите заменяемый(е) Вами файл(ы).
3) После удаления файла(ов), вставьте заранее скопированный(е) файл(ы) (Сделать это надо в первые секунды после удаления, так как система может восстановить файл из кэша)
4) Перезайдите в систему или перезагрузите компьютер.
P.S. Если после перезагрузки, некоторые (или все) изменения не вступили в силу, удалите содержимое папки C:\Windows\rescache и в случае необходимости проделайте описанное выше ещё раз.

Перейти к началу раздела Тонкие настройки.


6. Удаление надписей из правого нижнего угла рабочего стола.

Чтобы удалить водяные знаки на рабочем столе, такие как "Пробная копия", "Только для тестов", "Тестовый режим", воспользуйтесь одним из предложенных вариантов.

Вариант 1.

1) Откройте с помощью программы Restorator или PE Explorer файлы:

C:\Windows\System32\ru-RU\user32.dll.mui
C:\Windows\System32\en-US\user32.dll.mui

2) В разделе Строковая таблица (String) удалите строчки с 715 по 718 включительно и строки 737 и 738 .

715 %wsWindows %ws
716 %ws Сборка %ws
717 Пробная копия.
718 Только для тестов.

737 Ваша копия Windows не является подлинной
738 Тестовый режим

3) Перезагрузите компьютер.
Если после перезагрузки надписи не исчезли, то Вам необходимо перестроить кэш MUI.
4) Нажмите кнопку Пуск и в строке поиска введите cmd
5) Щелкните правой кнопкой мыши на найденной программе и выберите пункт Запуск от имени администратора
6) Введите команду: mcbuilder и нажмите Enter ↵
7) Перезагрузите компьютер.

Вариант 2.

1) Скачайте архив UniversalWatermarkRemover.zip и распакуйте его в любую папку.
2) Нажмите правой кнопкой мыши на exe-файл и выберите пункт "Запуск от имени администратора"
3) Нажмите в программе кнопку Remove.
4) В появившемся окне нажмите кнопку Да для перезапуска системы.

Для восстановления удаленных водяных знаков нажмите в программе кнопку Restore.

Если при запуске программы у Вас неактивна кнопка Remove, а активна кнопка Restore, то для удаления водяных знаков:

1) Нажмите кнопку Restore, а затем кнопку Да для перезапуска системы.
2) После перезапуска Windows, снова запустите программу Universal Watermark Remover и нажмите кнопку Restore, а затем кнопку Да для перезапуска системы.
Водяные знаки должны исчезнуть после перезагрузки системы.

Перейти к началу раздела Тонкие настройки.


7. Смена названия операционной системы c Максимальная на Ultimate.

Чтобы заменить название операционной системы Windows c Максимальная на Ultimate Вы можете воспользоваться одним из приведенных ниже вариантов.

Вариант 1. Замена c Максимальная на Ultimate в экране пользователей.

1) В соответствии с разрядностью Вашей Windows скачайте и установите английский языковой пакет.

Для 32-bit (x86) Windows 7 без SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe

Для 64-bit (x64) Windows 7 без SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe

Для 32-bit (x86) Windows 7 с установленным SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x86-en-us_783d6dd59e2ec8fb0995a059c9c121795bde46c8.exe

Для 64-bit (x64) Windows 7 с установленным SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x64-en-us_9b9c8a867baff2920507fbf1e1b4a158572b9b87.exe

2) Откройте Пуск → Панель управления → Язык и региональные стандарты
3) Перейдите на вкладку Языки и клавиатуры, выберите язык интерфейса English и нажмите кнопку ОК.
4) Нажмите кнопку Выйти из системы сейчас.
5) Зайдите обратно в систему.
6) Откройте Start → Control Panel → Region and Language
7) Перейдите на вкладку Administrative и нажмите кнопку Copy settings
8) Установите флажок Welcome screen and system accounts и нажмите кнопку ОК.
9) Нажмите кнопку Cancel и перейдите на вкладку Keyboard and Languages.
10) Выберите язык интерфейса русский и нажмите кнопку ОК.
11) Нажмите кнопку Log off now.
12) Зайдите обратно в систему.

Теперь у Вас в экране смены пользователей будет надпись Windows Ultimate.

Вариант 2. Замена файла basebrd.dll.mui из русской версии Windows на аналогичный из английской.

1) Скачайте файл Full_access.zip, разархивируйте его и примените reg-файл.
2) Откройте папку C:\Windows\Branding\Basebrd\ru-RU
3) Щелкните на файле basebrd.dll.mui правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту"
4) Скопируйте файл basebrd.dll.mui из папки C:\Windows\Branding\Basebrd\en-US в папку C:\Windows\Branding\Basebrd\ru-RU, подтвердив замену.
4.1) В случае отсутствия папки C:\Windows\Branding\Basebrd\en-US, скачайте архив basebrd.dll.mui_en.zip с английскими версиями файлов.
4.2) Распакуйте архив и скопируйте файл basebrd.dll.mui аналогичной разрядности Вашей системы в созданную Вами папку C:\Windows\Branding\Basebrd\en-US.
5) Создайте и примените reg-файл указанного ниже содержания.

Также Вы можете скачать и применить готовый reg-файл: welcome_screen_lang.zip

6) Перезагрузите компьютер.

Вариант 3. Удаление папки C:\Windows\Branding\Basebrd\ru-RU.

1) Скачайте файл Full_access.zip, разархивируйте его и примените reg-файл.
2) Щелкните на папке C:\Windows\Branding\Basebrd\ru-RU правой кнопкой мышки и выберите пункт "Стать владельцем и задать полный доступ к объекту"
3) Удалите папку C:\Windows\Branding\Basebrd\ru-RU
4) Создайте и примените reg-файл указанного ниже содержания.

Также Вы можете скачать и применить готовый reg-файл: welcome_screen_lang.zip

5) Перезагрузите компьютер.

Вариант 4. Использование патча.

1) Отключите антивирусное программное обеспечение
2) Скачайте файл Rename_To_Ultimate_Patch.rar и разархивируйте данный архив с патчем.
3) Запустите файл Run.cmd
4) Нажмите на клавиатуре клавишу S для замены надписи c Максимальная на Ultimate.
5) Дождитесь перезагрузки компьютера.
6) Включите антивирусное программное обеспечение.

Перейти к началу раздела Тонкие настройки.


8. Использование всей оперативной памяти в 32-битных Windows.

Данная программа добавляет второе ядро для загрузки операционной системы: ntkr128g.exe
Статьи (на английском), объясняющие причины использования 32-битными системами меньше памяти чем установлено и помогающие понять принцип работы данной программы:

http://support.microsoft.com/kb/978610
http://www.geoffchappell.com/notes/windows/license/memory.htm

Вариант 1.

1) Скачайте ReadyFor4GB от deepxw.
2) Распакуйте его в любую папку и запустите ReadyFor4GB.exe

3) Нажмите на кнопку Check, затем на кнопку Apply.

4) Нажмите на кнопку Да (Yes) для пропатчивания ntkrnlpa.exe

5) Нажмите на кнопку ОК для подтверждения места сохранения файла ntkr128g.exe

6) Закройте окно программы ReadyFor4GB.
7) Нажмите правой кнопкой мыши на файл AddBootMenu.cmd и выберите пункт Запуск от имени администратора
8) Нажмите клавишу "Y" для подтверждения или клавишу "Q" для выхода, и нажмите Enter ↵.

9) Дождитесь окончания работы скрипта и закройте программу.

10) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора

11) Нажмите клавишу "Y" для подтверждения.

Резервная копия "user32.dll.mui" будет сохранена как \Windows\System32\en-US\user32.dll.mui.backup.
Строка "en-US" зависит от языка Вашей системы.
12) Дождитесь окончания патча и перезагрузите компьютер.
13) Компьютер перезагрузится, покажет Диспетчер загрузки Windows (Windows Boot Manager) и загрузит Microsoft Windows [128GB with ntkr128g.exe]

14) Если надпись "Тестовый режим" после перезагрузки осталась на Вашем рабочем столе, то Вам надо перестроить кэш MUI. Для этого:
14.1) Нажмите правой кнопкой мыши на файл RemoveWatermarkX86.exe и выберите пункт Запуск от имени администратора
14.2) Нажмите клавишу "R" для подтверждения.

14.3) Дождитесь окончания перестройки кэша, а затем перезагрузите компьютер.

Примечание:

П.1) Файлы обязательно запускать от имени администратора, и только в операционной системе Windows 7 x86 (32-Bit).
П.2) Для удаления записи о другой Windows из диспетчера загрузки:
П.2.1) Запустите Конфигурация системы: Панель управления → Администрирование → Конфигурация системы (или нажав Win   + R → msconfig → ОК)
П.2.2) Перейдите на вкладку Загрузка.
П.2.3) Выделите пункт загрузки, который Вы желаете удалить и нажмите кнопку Удалить.
П.3) Если после применения патча у Вас по-прежнему показывает значение менее 4 Гб, то Вы можете скачать архив с готовым файлом ntkr128g.exe и скопировать его в папку C:\Windows\System32.

Вариант 2.

1) Скачайте c официального сайта и распакуйте архив PatchPae2.zip.
2) Скопируйте файл PatchPae2.exe в папку C:\Windows\System32.
3) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵
Убедитесь, что командная строка открылась в папке C:\Windows\System32.
4) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.

5) Скопируйте сгенерированный {GUID} в буффер обмена.
5.1) Щелкните на окне команд правой кнопкой мыши и выберите пункт Пометить.
5.2) Мышью выделите {GUID}, а затем нажмите Enter ↵ для копирования текста в буффер обмена.
6) Введите поочередно указанные ниже команды, нажимая после ввода каждой из них клавишу Enter ↵.
Вместо {GUID} вставляйте скопированный Вами в буффер обмена сгенерированный {GUID}.
6.1) Щелкните на окне команд правой кнопкой мыши и выберите пункт Вставить.

7) Закройте окно команд и перезагрузите компьютер.

Также Вы можете воспользоваться специально созданным мною командным файлом с автоскритом.
Данный автоскрипт самостоятельно пропатчит системные файлы и добавит дополнительный пункт в загрузочное меню.
Внимание: по завершении работы патча произойдет перезагрузка компьютера!

1) Скачайте и распакуйте архив PatchPae2_Autopatch.zip.
2) Нажмите правой кнопкой мыши на файл Autopatch_Win7.cmd и выберите пункт Запуск от имени администратора.

Если Вы решите отказаться от использования всей памяти и вернуться обратно к непропатченным файлам Windows, то воспользуйтесь файлом Restore_Win7.cmd.
Данный файл также необходимо запускать от имени администратора и по окончании его исполнения также произойдет перезагрузка компьютера.

Если и после этого у Вас не появится 4 гб памяти, то видимо Ваша оператив память не отдает доступ к необходимым адресам памяти.
Следовательно для использования полностью всей оперативной памяти рекомендую Вам установить 64-битную Windows.

Перейти к началу раздела Тонкие настройки.


9. Изменение папки открываемой по умолчанию в Проводнике.

Если Вы желаете, чтобы нажатие на кнопку Проводник (Windows Explorer) приводило в указанную Вами папку, вместо Библиотеки (Libraries), то воспользуйтесь предложенной ниже инструкцией.

1) Нажмите правой кнопкой мыши на значок Проводника в Панели задач.
2) Нажмите правой кнопкой мыши на Проводник
3) Нажмите левой кнопкой мыши на Свойства
4) Измените поле Объект (Target) на %SystemRoot%\explorer.exe /n, /e, С:\My Folder
где C:\My Folder - путь к Вашей папке.
Для запуска папки Компьютер измените на значение: %SystemRoot%\explorer.exe ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
Чтобы это изменение затронуло и ссылку в меню Пуск, то вам потребуется изменить поле Объект в свойствах ярлыка Проводник в папке Стандартные (Accessories) из меню Пуск.
Комбинация клавиш Win+E откроет Проводник в «Компьютере»

Перейти к началу раздела Тонкие настройки.


10. Добавление или Ёмой запуск папки Все задачи (для разработчиков и тестеров), и других системных папок.

10. Добавление или Ёмой запуск папки Все задачи (для разработчиков и тестеров).

Для быстрого доступа разработчиков и тестеров ко всем системным задачам в бета версиях Windows, была создана специальная папка Все задачи, содержащая Список задач всех программ. В финальных версиях Windows её так и не убрали, а поэтому и Вы можете воспользоваться ею для быстрого доступа к нужной Вам задаче.

Для её добавления Вам необходимо, создать новую папку, и задать ей следующее имя:

All Tasks.{ED7BA470-8E54-465E-825C-99712043E01C}

Также Вы можете запустить её напрямую. Для запуска напрямую пройдите: Пуск — Выполнить (или нажмите Win   + R) и введите команду:

shell:::{ED7BA470-8E54-465E-825C-99712043E01C}

Перейти к началу раздела Тонкие настройки.


11. Настройка интервалов времени отображения на экране диалоговых окон уведомления Windows.

Что такое уведомления системного трэя, знает каждый пользователь Windows 7. Хотя бы раз оно всплывает в жизни и на экране персонального компьютера.
Благодаря следующей настройке, Вы сможете установить время, в течение которого уведомления будут отображаться на экране, прежде чем они будут закрыты.

1) Нажмите кнопку "Пуск",
2) Перейдите в "Панель управления" и там выберите "Центр специальных возможностей".
3) Выберите параметр "Использование компьютера без экрана" или "Облегчение сосредоточения"
4) Находите «Как долго должны оставаться открытыми диалоговые окна уведомлений Windows?» и выставляете из выпадающего списка то время, которое Вам нужно.

В выпадающем списке выберите подходящее для Вас значение.

Перейти к началу раздела Тонкие настройки.


12. Использование рисунков из вложенных папок в окне "Фоновый рисунок рабочего стола".

У многих пользователей есть папка, в которой они хранят различные необходимые им изображения. Назовем её, для примера, Pictures. Внутри этой папки, часто находятся вложенные папки, с разной тематикой рисунков.

Если в настройках фонового рисунка рабочего стола, вызываемых:

1) ПКМ на Рабочем столе → Персонализация → Фоновый рисунок рабочего стола
2) Пуск\Панель управления\Все элементы панели управления\Персонализация\Фоновый рисунок рабочего стола
Вы попытаетесь указать вашу папку Pictures, то далее увидите либо рисунки, находящиеся только в ней, либо надпись: «Нет элементов, удовлетворяющих условиям поиска», если в самой папке Pictures не будет рисунков. Так как подпапки поддерживаются только в системной папке C:\Windows\Web\Wallpaper, используемой Windows для хранения фоновых рисунков рабочего стола по умолчанию.

Если же Вы хотите использовать собственную папку, с вложенными в неё подпапками и не менять значение системной папки находящийся в реестре(Win   + R → Regedit → OK) по адресу:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers\knownfolders\0\Windows Wallpapers\MergeFolders
cо значения %SystemRoot%\web\wallpaper на Ваше собственное, к примеру: D:\Nickname\Pictures, то есть нужный Вам вариант решения.

Вы можете создать новую библиотеку и добавить в неё Ваши папками.

1) Открываете папку Библиотеки. У кого она удалена из Проводника, тот может открыть её введя в адресную строку Windows Explorer:

2) Нажимаете ПКМ → Создать → Библиотека
3) Переименовываете её. Например: Обои яў рабочего стола
4) Щелкаете ПКМ и выбираете Свойства
5) Добавляете отдельно каждую папку
6) В графе Оптимизировать эту библиотеку: выбираете Изображения
7) Нажимаете применить, затем Ок.
8) После этого открываем раздел Персонализация → Фон рабочего стола → и в меню Расположение изображения с помощью кнопки Обзор... указываем путь к только что созданной нами библиотеке.

Внимание: Вы можете спокойно удалить созданную Вами библиотеку из общего списка библиотек, что никак не повлияет на Ваши файлы. Однако если Вы удалите любой файл из папки, созданной Вами библиотеки- он также удалит© из системы(из той папки, в которой он находится).

Для облегчения работы с библиотеками Вы можете воспользоваться программой Librarian. Librarian - это утилита управления библиотеками Windows 7.

Программа расширяет стандартный функционал Windows 7 в области управления библиотеками.

Её ключевые возможности:
- Создание библиотеки из произвольного набора папок.
- Смена значка библиотеки на выбранный пользователем. Вы можете задач значок библиотеки, используя стандартный диалог Windows, вызываемый при смене значка ярлыка.
- Переименование библиотеки.
- Указание типа содержимого новой или редактируемой библиотеки.
- Смена папки, используемой по умолчанию для сохранения файлов в библиотеку.
- Управление отображением библиотеки в панели навигации Проводника.
- Отображение библиотеки в виде XML-файла.
- Отображение системного диалога папок, включенных в библиотеку.

Ссылка для скачивания программы: Librarian2.zip.

Перейти к началу раздела Тонкие настройки.


13. Увеличение скорости работы USB-мыши, с помощью повышения опросов USB-порта.

Вы любите играть в игры, где важна быстрота реакции, но Ваша USB-мышь не относится к классу игровых мышек - просто увеличьте частоту опросов USB мыши. Например: игровая мышь Logitech G7 имеет частоту опроса равную 530 MHz, а обычная 125 MHz.

Для установки необходимы права локального администратора.

1) Скачайте архив MouseRate.zip и распакуйте его в папку.
2) Откройте папку Direct Input Mouse Rate и в ней запустите программу dimr.exe
3) Подвигайте максимально быстро курсором Вашей мыши по экрану.
4) Запомните значение из графы Peak - это максимальная величина опросов Вашей мышки.
5) Откройте папку HIDUSBF
6) Нажмите правой кнопкой мыши на файл HIDUSBF.INF и выберите пункт Установить.
7) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
8) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Если у Вас появится сообщение о неподписанных драйверах - не волнуйтесь, все нормально. Подпишем его программой Driver Signature Enforcement Overrider, о которой упоминалось в совете Как добавить подпись к драйверам? из раздела Установка. На время её работы UAC(Контроль учетных записей пользователей) в Windows должен быть отключен.

1) Запустите файл dseo13b.exe из папки Driver Signature Enforcement Overrider и выберите там "Enable Test Mode".
2) Перезапустите компьютер.
3) После перезапуска снова откройте файл dseo13b.exe и выберите "Sign a system file".
4) В окне пропишите: "C:\Windows\System32\Drivers\HIDUSBF.sys". Если вы сделали это правильно, то вы увидите сообщение: "Система была подписана успешно" ("The system file has been signed succesfully")
5) Снова перезапустите компьютер.
6) Запустите файл setup.exe Найдите там свою мышку (она там подсвечена синим цветом) и внизу окна поставьте галочку на "Filter On Device" и поставьте там свой rate, который вам нужен.
7) Нажмите на "Restart" и снова откройте dimr.exe. Если у вас до сих пор там стоит Ваше старое значение, то перезагрузите компьютер еще раз.

Перейти к началу раздела Тонкие настройки.


14. Перемещение системных папок и изменение их путей.

Перенос системных папок лучше сделать сразу после установки Windows, до установки программ и драйверов, т.к. при установке драйверов и в особенности программ будут создаваться каталоги и ярлыки в эти самые системные папки. Если Вы используете для хранения файлов системные папки, то перенос системных папок пользователя на не системный диск, поможет Вам сохранить свои файлы. В случае сбоя Windows, при её переустановке заданные по умолчанию системные папки будут затерты полностью, со всеми находящим© в них файлами. Но если Вы зададите свои пути к системным папкам, то всё их содержимое останется целым.

Раньше в предыдущих версиях Windows, чтобы переместить какую-либо системную папку или изменить её путь, Вам надо было править нужное Вам значение в одной из следующих веток реестра:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Компания Microsoft понимая, что многие пользователи могут захотеть переместить свои системные папки, упростила пользователям эту задачу, избавив их от надобности редактировать реестр. Для перемещения системных папок и изменения их путей продеайте следующее:

1) Создайте новую папку, желательно с аналогичным перемещаемой папке наименованием.
2) Откройте в Проводнике (Windows Explorer) → Рабочий стол\Ваш Профиль (Например: Рабочий стол\Администратор)
3) Щелкните правой кнопкой мыши на название папки, которую Вы собираетесь переместить (Например: Мои Документы) и выберите Свойства.
4) Откройте вкладку Расположение
5) Нажмите кнопку Переместить и укажите путь к созданной Вами новой папке
6) Далее система спросит Вас: Переместить все файлы из старого расположения в новое? (Рекомендуемый ответ - Да)
7) Согласитесь с новыми параметрами применяя их и выходите.
8) Перезагрузите Компьютер.

Перейти к началу раздела Тонкие настройки.


15. Скрытие выбранных дисков из окна папки "Компьютер".

Если Вы используйте флэш-диск для ускорения работы системы (ReadyBoost) или у Вас установлен картридер который Вы используйте для чтения только одного типа карт, то у Вас может появится желание скрыть выбранные Вами диски из папки Компьютер. Чтобы сделать это Вы можете воспользоваться одним из предложенных ниже вариантов.

Вариант 1.

1) Откройте меню Пуск, введите в строке поиска gpedit.msc и нажмите Enter ↵. (Win   + R → gpedit.msc → ОК)
2) Перейдите по пути слева Конфигурация пользователя → Административные шаблоны → Компоненты Windows → Проводник Windows..
3) Щелкните дважды по параметру Скрыть выбранные диски из окна "Мой компьютер".
4) Установите переключатель на значение Включить.
5) В раскрывающемся списке выберите одну из предложенных комбинаций и нажмите ОК.

Вариант 2.

1) Запустите Редактор реестра (Win   + R → regedit → ОК)
2) Откройте следующий раздел реестра: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
3) Создайте параметр NoDrives типа DWORD
4) Значение данного параметра обрабатывается Windows в двоичной системе исчисления, но указывается в реестре в десятичной или шестнадцатеричной.
Для расчета двоичного значения воспользуйтесь таблицей.

Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0

В данной таблице каждой букве соответствует цифра, которая может быть либо единицей, либо нулём. Единица означает "скрыть диск", ноль - "показать диск".
Для получения числа в двоичной системе исчисления замените для диска который Вы желаете скрыть цифру 0 на цифру 1.

Например, для скрытия дисков A, B, F, G заменив цифры с 0 на 1 получится следующий вид:

Z | Y | X | W | V | U | T | S | R | Q | P | O | N | M | L | K | J | I | H | G | F | E | D | C | B | A
0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 1 | 1

Так как значение параметра формируется Windows в двоичной системе исчисления, а для добавления в реестр Вам необходимо данное значение в шестнадцатиричной или десятиричной системе, то для преобразования значения из одной системы исчисления в другую воспользуйтесь калькулятором Windows.

5) Запустите Калькулятор (Пуск → Все программы → Стандартные)
6) В меню программы нажмите Вид и выберите значение Программист
7) Установите переключатель в значение Bin
8) Введите значение полученное с помощью таблицы. В моем примере это число 1100011.
9) Установите переключатель в значение Dec
10) Скопируйте полученное число(Правка → Копировать или Ctrl + C) в буфер обмена или запомните его. В моем примере 99.
11) Закройте калькулятор и вернитесь в редактор реестра.
12) Измените значение параметра NoDrives на полученное Вами в калькуляторе значение.

12.1) Щелкните правой кнопкой мыши по параметру и выберите пункт Изменить...
12.2) Установите переключатель на значение Десятич
12.3) В текстовое поле введите запомненное Вами число из калькулятора или нажмите Ctrl + V, если Вы копировали в буфер обмена.

Перейти к началу раздела Тонкие настройки.


16. Добавление или удаление элементов из контекстного меню "Отправить".

При попытке открыть более 15 элементов сразу используя меню, вызываемое правой кнопкой мыши в Проводнике, пункт меню Открыть пропадет.
Если Вам необходимо открыть большее количество элементов одновременно, то Вы можете сделать это добавив нужную Вам программу в контекстное меню "Отправить".

Для добавления своей программы в контекстное меню "Отправить":

1) Откройте папку C:\Users\UserName\AppData\Roaming\Microsoft\Windows\SendTo , где UserName - Ваше имя пользователя.
Также Вы можете открыть данную папку так:
1.1) В адресной строке Проводника введите команду shell:SendTo и нажмите Enter ↵.
1.2) Нажмите Win   + R, введите команду shell:SendTo и нажмите Enter ↵.
2) Создайте в открывшейся папке ярлык для необходимой Вам программы:
2.1) Используйте меню, вызываемое правой кнопкой мыши. Создать → Ярлык → Укажите расположение программы → Введите имя ярлыка
2.2) Удерживая нажатой клавишу Alt скопируйте Вашу программу в вышеуказанную папку и переименуйте ярлык.

Для удаления какого-либо из пунктов меню "Отправить":

1) Откройте Пуск → Выполнить (Win   + R)
2) Введите команду: shell:sendto и нажмите Enter ↵.
3) Удалите ярлык, соответствующий необходимому Вам пункту меню.

Для восстановления удаленных системных пунктов меню "Отправить" по умолчанию.

1) Скачайте архив SendTo.zip и распакуйте в любую папку.
2) Откройте Пуск → Выполнить (Win   + R)
3) Введите команду: shell:sendto и нажмите Enter ↵.
4) Скопируйте все ярлыки, соответствующие необходимым Вам пунктам меню, из папки куда Вы распаковали архив в папку SendTo.

Перейти к началу раздела Тонкие настройки.


17. Быстрое добавление своего ярлыка папки или программы в папку Компьютер.

Скопируйте необходимый Вам ярлык в папку C:\Users\ИмяПользователя\AppData\Roaming\Microsoft\Windows\Network Shortcuts
где Имя пользователя - это имя Вашей учетной записи (Например: Администратор).

Перейти к началу раздела Тонкие настройки.


18. Замена элементов в диалоговом окне открытия/сохранения файлов.

Вы можете заменить стандартные папки из диалогового окна открытия/сохранения файлов на указанные Вами.

1) Откройте меню Пуск
2) В строке поиска введите gpedit.msc
3) Откройте папку Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Проводник Windows.\Общее диалоговое окно открытия файлов
4) Сделайте двойной щелчок мышью на Элементы, отображаемые в панели мест
5) Установите переключатель на значение Включить
6) Введите в текстовых полях напротив Элементов, пути к папкам и нажмите ОК.
Для добавления папки Рабочий стол необходимо ввести: shell:desktop

Перейти к началу раздела Тонкие настройки.


19. Изменение настроек режима самовосстановления для повышения производительности Windows.

Если Вы периодически, не реже раза в неделю, делаете проверку файловой системы и пустого дискового пространства используя утилиту CHKDSK, то возможно Вас заинтересует изменение настроек режима самовосстановления. Это изменение позволит Вам повысить производительность Вашей операционной системы, путем высвобождения ресурсов затрачиваемых на данный режим.

1) Запустите командную строку от имени администратора.
1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
2) Проверьте состояние функции самовосстановления, для этого введите в командной строке и нажмите Enter ↵:

Где ИМЯ_ДИСКА - буква присвоенная жесткому диску или одному из его разделов. Например:

3) Включите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Данное действие необходимо для получения возможности смены режима самовосстановления. Введите в командной строке и нажмите Enter ↵:

4) Перезагрузите компьютер.
5) Снова запустите командную строку от имени администратора.
6) Переключите режим общего восстановления, в режим однократной проверки ошибок при первом случае повреждения. Для этого введите в командной строке и нажмите Enter ↵:

7) Отключите режим отображения системой BSOD (синего экрана смерти) при обнаружении программой CHKDSK ошибки. Для этого введите в командной строке и нажмите Enter ↵:

8) Перезагрузите компьютер.

Вы можете отключить функцию самовосстановления как у отдельных дисков (разделов), так и у всех сразу, повторив приведенный выше порядок действий для каждого из них. Данное решение работает только с дисками отформатированными в файловую систему NTFS.

Внимание. Побочным эффектом при выборочном отключении проверки (на отдельных дисках) может быть срабатывание защитного антивирусного программного обеспечения.

Перейти к началу раздела Тонкие настройки.


20. Изменение стандартной мелодии запуска Windows 7.

В предыдущих версий Windows, стандартная мелодия запуска находилась в папке C:\Windows\Media.
В операционной системе Windows 7 стандартная мелодия запуска содержится в файле библиотеки: imageres.dll, находящемся в папке C:\Windows\System32
Для изменения данного файла воспользуйтесь программами: Restorator или PE Explorer.
Перед изменением файла убедитесь, что у Вас очищена папка C:\Windows\rescache

В программе PE Explorer:

1) Откройте файл imageres.dll
2) Нажмите комбинацию клавиш Ctrl + R или перейдите в меню View → Resources
3) Откройте папку WAVE, щелкните правой кнопкой мыши на ресурс 5080 и выберите пункт Edit Resource
4) В открывшемся окне нажмите комбинацию клавиш Ctrl + O или на значок папки со стрелочкой.
5) Выберите мелодию в формате WAV для замены, после нажмите ОК, а затем Yes

В программе Restorator:

1) Откройте файл imageres.dll
2) Откройте папку WAVE и перетяните на ресурс 5080 файл, которым Вы хотите заменить мелодию запуска.
3) Сохраните внесенные изменения нажав Ctrl + S

Также Вы можете воспользоваться специальной программой, позволяющей легко изменить используемую мелодию запуска по умолчанию: Startup Sound Changer

Перейти к началу раздела Тонкие настройки.


21. Отключение журналирования для ускорения работы диска и освобождения дискового пространства.

Чтобы отключить журналирования для диска, сделайте следующее:

1) Запустите командную строку (Win   + R → cmd → OK)
2) Введите в командной строке:

где H: - буква диска для которго необходимо отключить журналирование.

Если возникнет необходимость включить журналирование опять, то сделать сделайте следующее:

1) Запустите командную строку (Win   + R → cmd → OK)
2) Введите в командной строке:

Перейти к началу раздела Тонкие настройки.


22. Распределение файла подкачки между несколькими жесткими дисками яў увеличения производительности системы.

Файл подкачки (Pagefile.sys) — это скрытый файл на жестком диске компьютера, который используется системой Windows по принципу оперативной памяти. Файл подкачки и физическая память вместе составляют виртуальную память. По умолчанию Windows хранит файл подкачки в разделе, в котором установлена операционная система.
Рекомендуемый размер файла подкачки должен быть примерно в 1,5 - 3 раза больше общего объема оперативной памяти.

Если у вас установлено 2 (или более) жестких диска,то для повышения быстродействия работы системы оптимальным решением будет создание одного файла подкачки в загрузочном разделе, а второго — в разделе, который используется реже (на другом жестком диске, если такой имеется). Кроме того, для второго файла подкачки по возможности лучше всего отвести отдельный раздел, где нет других данных и системных файлов. Система в первую очередь использует файл подкачки из менее загруженного раздела (а не файл подкачки из загрузочного раздела, количество обращений к которому намного больше).

По умолчанию система использует файл подкачки динамически, то есть размер файла изменяется автоматически, в зависимости от текущей потребности операционной системы. В большинстве же случаев наилучшая производительность системы достигается при статическом размере файла подкачки, так как это не требуется каждый раз изменять размер файла подкачки, что снижает его фрагментацию.

Учитывая описанное выше сделайте следующее:

1) Откройте Панель управления → Система.
2) Слева в списке нажмите ссылку Дополнительные параметры системы.
3) На вкладке Дополнительно в разделе Быстродействие нажмите кнопку Параметры.
4) Откройте вкладку Дополнительно и в разделе Виртуальная память нажмите кнопку Изменить.
5) Снимите флажок Автоматически выбирать объем файла подкачки.
6) Выберите диск, на котором Вы хотите создать файл подкачки.
7) Установите переключатель в значение Указать размер
8) Введите в поля Исходный размер (МБ) и Максимальный размер (МБ) одинаковые размеры создаваемого файла подкачки в мегабайтах, равного величине в 1,5 - 3 раза больше общего объема оперативной памяти.
9) Нажмите кнопку Задать,
10) Выберите следующий диск и проделайте указанные выше операции, после чего нажмите кнопку ОК.
11) Перезагрузите компьютер.

Перейти к началу раздела Тонкие настройки.


23. Регистрация необходимых и выгрузка из памяти неиспользуемых библиотек (dll-файлов).

Чтобы загрузить в память определенную библиотеку (dll-файл) Вам необходимо ее зарегистрировать. Для того, чтобы это сделать введите команду:

Если dll-файл расположен в системной папке (System32), то:

Например:

Если dll-файл расположен не в системной папке, то:

Например:

Чтобы выгрузить из памяти определенную библиотеку (dll-файл) Вам необходимо отменить ее регистрацию.

Если dll-файл расположен в системной папке (System32), то:

Например:

Если dll-файл расположен не в системной папке, то:

Например:

Если Вам необходимо освободить часть оперативной памяти, то Вы можно сделать это добавив в реестр параметр, отвечающий за автоматическую выгрузку из памяти неиспользуемых библиотек.

1) Запустите редактор реестра (Win   + R → regedit → ОК)
2) Откройте раздел реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
3) В меню Правка выберите Создать → Параметр DWORD (32 бита).
4) Задайте имя параметра AlwaysUnloadDll
5) Дважды щелкните на данном параметре и введите значение 1.
6) Закройте редактор реестра и перезапустите компьютер.

Перейти к началу раздела Тонкие настройки.


24. Обход ограничения времени доступа к компьютеру при включенной функции Родительский контроль.

Для обхода ограничения по времени при включенной функции Родительский контроль Вам необходимо изменить системное время в BIOS.

1) Cразу после включения компьютера, до появления окна "Запуск Windows" нажмите клавишу для входа в BIOS.
Наиболее распространённые — Delete , F2 , F10 или Esc.
2) Зайдите в раздел Standart CMOS Features (Standart CMOS Setup) или перейдите на вкладку Main и измените системное время и дату на необходимую Вам.
3) Нажмите клавишу F10 для выхода с сохранением настроек.

Перейти к началу раздела Тонкие настройки.


25. Использование файлов autorun.inf и desktop.ini для задания собственных значков на съемных накопитЈх.

Если Вам необходимо, чтобы в любой системе, где Вы используете Ваш съемный накопитель (Например: флеш-диск), отображались идентичные значки яў самого устройства и/или для находящихся на нем папок, то специально для этого Вам потребуется создать файлы конфигурации или файл сведений.

Чтобы установить значок для самого устройства, создайте в любом текстовом редакторе файл autorun.inf, который сохраните в корне Вашего накопитЈ.
Данные об иконке укажите в соответствии со следующим шаблоном:

Пример 1.

Пример 2.

Чтобы установить значок для папки, находящейся на данном устройстве, создайте в любом текстовом редакторе файл desktop.ini, который сохраните в самой папке.
Данные об иконке укажите в соответствии со следующим шаблоном:

Пример 1.

Пример 2.

Чтобы во всех системах значек распознавался корректно, рекомендуется указывать значек из файлов расположенных на самом съемном накопителе.

Перейти к началу раздела Тонкие настройки.


26. Сохранение настроенных параметров групповой политики для последующего использования.

Чтобы перенести(сохранить) настройки Вашей "локальной груповой политики" выполните следующие действия.

1) Экспортируйте в reg-файлы содержимое разделов реестра:

HKEY_CURRENT_USER\Software\Policies
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Editor
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
HKEY_LOCAL_MACHINE\SOFTWARE\Policies

для 64-битных версий также:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Group Policy
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies

2) Скопируйте куда-нибудь указанные ниже папки со всем содержимым:

C:\Windows\PolicyDefinitions
C:\Windows\System32\GroupPolicy
C:\Windows\System32\GroupPolicyUsers

для 64-битных версий также:

C:\Windows\SysWOW64\GroupPolicy
C:\Windows\SysWOW64\GroupPolicyUsers

Примечание: в системе должно быть включено отображение скрытых папок и файлов.

3) После переустановки Windows примените созданные Вами reg-файлы.
Для получения полного доступа к разделам реестра воспользуйтесь решением предложенным в совете: 1. Получение полного доступа к разделу реестра, используя программу regedit или командную строку. из раздела Твики Реестра - Администрирование и Безопасность.

4) Загрузитесь в MSDaRT (ранее ERD Commander) или в командную строку с загрузочного диска (⇑ Shift + F10) и перекопируйте содержимое Вашей папки PolicyDefinitions в C:\Windows\PolicyDefinitions.

Перейти к началу раздела Тонкие настройки.


27. Удаление с панели задач кнопки "Свернуть все окна", показывающей рабочий стол.

Если Вы желаете освободить дополнительное место на панели задач, то Вы можете удалить с панели задач кнопку Свернуть все окна, показывающую рабочий стол при наведении.
Чтобы это сделать, Вам понадобится скачать программу Windows 7 Show Desktop Button Remover:
с официального сайта или зеркала.

Для удаления кнопки с панели задач нажмите в программе Remove Show Desktop Button.
Для возвращения кнопки "Свернуть все окна" обратно нажмите в программе Add Show Desktop Button.

Перейти к началу раздела Тонкие настройки.


28. Использование командной строки яў управления файлом подкачки pagefile.sys.

Для создания, изменения или удаления файлов подкачки необходима перезагрузка компьютера.

1.1) Нажмите кнопку Пуск и введите в строке поиска cmd
1.2) Щелкните правой кнопкой мыши на найденном файле и выберите пункт "Запуск от имени администратора"
2) Введите в командной строке необходимые Вам команды из указанных ниже и нажмите Enter ↵:

Чтобы снять флажок Автоматически выбирать объем файла подкачки:

или

Чтобы установить флажок Автоматически выбирать объем файла подкачки:

или

Прежде чем использовать дальнейшие команды, Вам необходимо снять флажок Автоматически выбирать объем файла подкачки.

Чтобы отключить использование существующего файла подкачки (соответствует переключателю Без файла подкачки):

где:
name="C:\\pagefile.sys" - расположение файла подкачки.

Чтобы отключить использование всех существующих файлов подкачки (соответствует переключателю Без файла подкачки):

Чтобы создать файл подкачки (соответствует переключателю Размер по выбору системы):

Чтобы принудительно задать размер существующего файла подкачки (соответствует переключателю Указать размер):

где:
name="C:\\pagefile.sys" - расположение файла подкачки.
InitialSize - исходный размер файла подкачки
MaximumSize - максимальный размер файла подкачки

Чтобы просмотреть общую информацию об имеющихся у Вас файлах подкачки:

Чтобы просмотреть дополнительную информацию о файлах подкачки, если Вы принудительно задавали их размер.

Перейти к началу раздела Тонкие настройки.


29. Разблокировка курсора мыши при достижении края экрана.

В Windows присутствует возможность продолжения движения мыши с противоположной стороны при достижении текущего края экрана.
Чтобы воспользоваться данной функцией Вам понадобится программа Unlimited Mouse.

Для активации разблокировки краев экрана.

1) Скачайте и распакуйте в любую папку архив UnlimitedMouse.zip
2) Запустите программу Unlimited Mouse и щелкните правой кнопкой мыши на значке в области уведомлений.
3) В контекстном меню нажмите на пункт Unlock mouse.

Чтобы снова включить блокировку краев экрана: либо закройте программу, либо в ее контекстном меню выберите пункт Lock mouse.

Перейти к началу раздела Тонкие настройки.


30. Сохранение изображения в программе Ножницы (Snipping Tool) с расширением написанным по умолчанию маленькими буквами.

Если Вы используете программу Ножницы (Snipping Tool) для создания скриншотов экрана, то Вы наверное заметили одну неприятную особенность в ее работе.
Данная программа сохраняет файлы с разрешениями написанными большими буквами. Многим пользователям приходится вручную их исправлять на маленькие.
(.GIF → .gif, .JPG → .jpg, .PNG → .png, .MHT → .mht)
Выполните указанные ниже действия, чтобы расширение файла по умолчанию сохранялось написанным маленькими буквами.

1) Откройте в Проводнике папку C:\Windows\System32
2) Щелкните правой кнопкой мыши на файле SnippingTool.exe и выберите пункт Свойства.
3) Перейдите на вкладку Безопасность и нажмите кнопку Дополнительно.
4) Перейдите на вкладку Владелец и нажмите кнопку Изменить.
5) В окне Изменить владельца на выберите группу Администраторы (Administrators), нажмите ОК.
6) Перейдите на вкладку Разрешения и нажмите кнопку Изменить разрешения.
7) Выберите группу Администраторы (Administrators) и нажмите кнопку Изменить.
8) Установите все флажки Разрешить напротив разрешения Полный доступ и нажмите кнопку ОК, а затем кнопку Применить.
9) Во всплывшем окне с предупреждением нажмите кнопку Да.
10) Нажмите в каждом окне кнопки ОК, чтобы закрыть их.
11) Скачайте и запустите любой hex-редактор (Например: HxD)
12) Откройте в нем файл C:\Windows\System32\SnippingTool.exe
13.1) В 32-битной версии программы Snipping Tool пройдите к строке 000101E0.
13.2) В 64-битной версии программы Snipping Tool пройдите к строке 000033C0.
14) Замените код отвечающий за крупные буквы в названии расширения, на код отвечающий за маленькие буквы.

Таблица Hex-кодов для замены.

C:\Windows\System32\SnippingTool.exe
Windows 32-Bit (000101E0)
Windows 64-Bit (000033C0)
MHT | 4D 00 48 00 54 | → | mht | 6D 00 68 00 74
JPG | 4A 00 57 00 47 | → | jpg | 6A 00 77 00 67
GIF | 47 00 49 00 46 | → | gif | 67 00 69 00 66
PNG | 50 00 4E 00 47 | → | png | 70 00 6E 00 67

5) Нажмите Ctrl + S, чтобы сохранить сделанные изменения в файле.
Теперь Ваша программа Ножницы (Snipping Tool) будет сохранять расширение строчными (маленькими) буквами.

Вы можете скачать архив с готовыми версиями программы Ножницы (Snipping Tool) для обеих разрядностей Windows 7 по ссылке ниже.
SnippingToolLowercaseExtension.zip

Перейти к началу раздела Тонкие настройки.


31. Отключение и включение Панели задач.

Чтобы полностью отключить Панель задач воспользуйтесь любой из предложенных ниже программ.

Hide Taskbar
Запустите программу и нажмите сочетание клавиш Ctrl + Esc для включения или выключения отображения Панели задач.
Особенности данной программы:

- Не исчезает кнопка Пуск
- Выделение объектов и вызов контекстного меню на месте отключенной Панели задач не работает.

Ссылка для скачивания: Hide Taskbar

Taskbar Eliminator

Особенности данной программы:

- Исчезает кнопка Пуск
- Работает выделение объектов и вызов контекстного меню на месте отключенной панели задач.
- Если Вы закроете программу Taskbar Eliminator, когда Панель задач будет скрыта, то Вам необходимо будет снять флажок Автоматически скрывать панель задач в Свойствах Панели задач для повторного ее отображения.

Нажмите сочетание клавиш Alt + T для включения или выключения отображения Панели задач.
Нажмите сочетание клавиш Ctrl + Alt + T для отображения окна настроек программы.

Ссылка для скачивания: Taskbar Eliminator

Перейти к началу раздела Тонкие настройки.


32. Изменение сообщений на экране пользователей при входе или выходе из системы (Welcome, Shutting down, Logging off, Please wait).

Когда Вы входите или выходите из Windows, а также когда Вы завершаете работу компьютера, на экране пользователей отображаются соответствующие сообщения.

Если яў экрана пользователей у Вас установлен английский язык.

При входе в Windows - Welcome.
При завершении работы или перезагрузке Windows - Shutting down....
При выходе из системы - Logging off....
При ожидании системы - Please wait....

Если яў экрана пользователей у Вас установлен русский язык.

При входе в Windows - Добро пожаловать.
При завершении работы или перезагрузке Windows - Завершение работы....
При выходе из системы - Завершение сеанса....
При ожидании системы - Пожалуйста, подождите....

Чтобы изменить данные значения, воспользуйтесь предложенным ниже решением.

1) Скачайте и установите программу Unlocker.
2) Учитывая язык, использующийся у Вас на экране пользователей, откройте соответствующую папку:
Для английского языка: C:\Windows\System32\en-US\
Для русского языка: C:\Windows\System32\ru-RU\
3) Воспользовавшись советом 1. Получение полного доступа к файлу или папке. из раздела Администрирование, задайте полный доступ к файлам: winlogon.exe.mui и wininit.exe.mui.
4) Скопируйте данные файлы на Рабочий стол.
5) В зависимости от того, какую надпись Вы желаете изменить откройте с помощью программы Restorator необходимый Вам файл.

winlogon.exe.mui - для изменения надписей: Добро пожаловать (Welcome), Завершение сеанса... (Logging off...) и Пожалуйста, подождите... (Please wait...).
wininit.exe.mui - для изменения надписей: Завершение работы... (Shutting down...)

6) Откройте раздел Строковая таблица (String) → Русский (Russian) или Английский (English).
7) Нажмите клавишу F6 для включения режима редактирования.
8.1) Для изменения надписей: Добро пожаловать (Welcome) измените в файле winlogon.exe.mui значения в строках 1002 и 1005.
8.2) Для изменения надписей: Завершение сеанса... (Logging off...) измените в файле winlogon.exe.mui значение в строке 1003.
8.3) Для изменения надписей: Пожалуйста, подождите... (Please wait...) измените в файле winlogon.exe.mui значение в строке 1008.
8.4) Для изменения надписей: Завершение работы... (Shutting down...) измените в файле wininit.exe.mui значение в строке 1002.
9)Нажмите клавиши F8, чтобы принять изменения и Ctrl + S, чтобы сохранить файл и закройте Restorator.
10) Скопируйте измененные Вами файлы winlogon.exe.mui и/или wininit.exe.mui с рабочего стола обратно в соответствующую папку:
Для английского языка: C:\Windows\System32\en-US\
Для русского языка: C:\Windows\System32\ru-RU\
11) Откройте папку C:\Windows\rescache и выделите все ее содержимое.
12) Нажмите на выделенном правой кнопкой мыши и выберите пункт Unlocker.
13) В ниспадающем списке выберите Удалить и нажмите на кнопку Разблокировать Все, либо кнопку ОК.
14) Перезагрузите компьютер.

Перейти к началу раздела Тонкие настройки.


33. Уменьшение занимаемого на диске места папкой WinSxS.

33. Уменьшение места занимаемого на диске папкой WinSxS.

Спустя некоторое время, после использования Windows, размер папки C:\Windows\WinSxS, в которой расположено хранилище компонентов системы может увеличиваться.

Вариант 1. Очистка устаревших компонентов.

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Введите указанную ниже команду и нажмите Enter ↵.

Данная команда очистит следы от установки сервисного пакета и предыдущие версии замененных компонентов.

Вариант 2. Сжатие папки средствами Windows.

1) Запустите командную строку от имени администратора.
Для этого, в строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
Вводите поочередно указанные ниже команды, нажимая после ввода каждой из них Enter ↵.
2) Перейдите в папку Windows.

3) Остановите службы "Установщик Windows" (msiserver) и "Установщик модулей Windows" (TrustedInstaller) и измените для них тип запуска.

Внимание: Перед знаком равно пробела быть недолжно, пробел обязан быть только после знака равно.

4) Сохраните в файл список управления доступом, чтобы восстановить позже

5) Установите себя в качестве владельца папки WinSxS.

6) Установите для себя права полного доступа к папке WinSxS.

7) Сожмите папку WinSxS средствами системы.

8) Восстановите TrustedInstaller в качестве владельца папки WinSxS.

9) Восстановите из ранее сохраненного файла права доступа к папке WinSxS.

Вариант 3. Создание жестких ссылок на более новые версии файла.

Внимание: Примерно в 20% случаев данный вариант может привести к непоправимым последствиям, исправить которые можно будет только переустановкой системы.
Используйте его под свою ответственность.
Перед запуском скрипта, закройте все запущенные у Вас программы, завершите запущенные процессы и не запускайте их до окончания работы скрипта.

1) Скачайте и распакуйте архив со скриптом WinsxsLite v1.88 и необходимыми программами яў его работы:

Если яў Вас приоритетными являются английский и русский языки, то переходите ко второму пункту данного совета.
Если яў Вас приоритетными являются другие языки, то для добавления/изменения приоритетных языков:
1.1) Откройте в текстовом редакторе файл WinsxsLite.bat
1.2) Добавьте необходимый Вам язык под каждой найденной строкой ru-ru=KEEP или измените его.
Например: uk-ua=KEEP, he-il=KEEP
1.3) Нажмите Ctrl + S для сохранения изменений.

2) Щелкните правой кнопкой мыши на файл WinsxsLite.bat и выберите пункт Запуск от имени администратора.
3) Введите q и нажмите Enter ↵ для создания файла конфигурации и выхода из программы.
4) Повторно запустите файл WinsxsLite.bat от имени администратора.
5) Введите 1 и нажмите Enter ↵ для выбора действий, относящихся к первой фазе работы скрипта.
6) Введите s и нажмите Enter ↵ для начала сканирования.
По результатам сканирования будет создан файл ToDo1.txt, содержащий лист файлов, которые должны быть заменены жесткими ссылками на более новые их версии.
7) Введите 1 и нажмите Enter ↵ для выбора действий, относящихся к первой фазе работы скрипта.
8) Введите a и нажмите Enter ↵ для применения результатов сканирования в дальнейшей работе скрипта.
9) Введите q и нажмите Enter ↵ для выхода из программы.
10) Перезагрузите компьютер.
11) Повторно запустите файл WinsxsLite.bat от имени администратора.
12) Введите 2 и нажмите Enter ↵ для выбора действий, относящихся к второй фазе работы скрипта.
13) Введите s и нажмите Enter ↵ для начала сканирования.
По результатам сканирования на основе выбранных языковых приоритетов, будет создан файл ToDo2.txt, содержащий лист файлов, которые должны быть заменены жесткими ссылками на их английскую версию.
14) Введите 2 и нажмите Enter ↵ для выбора действий, относящихся к второй фазе работы скрипта.
15) Введите a и нажмите Enter ↵ для применения результатов сканирования в дальнейшей работе скрипта.
Незамененными на жесткие ссылки останутся только те языковые версии файлов, которые были добавлены Вами на первом шаге данной инструкции. По умолчанию - это русские языковые версии файлов.
16) Введите q и нажмите Enter ↵ для выхода из программы.
17) Перезагрузите компьютер.
18) Повторно запустите файл WinsxsLite.bat от имени администратора.
19) Введите q и нажмите Enter ↵ для выхода из программы.

Перейти к началу раздела Тонкие настройки.


1. Добавление вручную нового устройства (драйвера).

1) Нажмите кнопку Пуск, введите в строке поиска hdwwiz и нажмите Enter ↵. (или Win   + R → hdwwiz → ОК)
2) В открывшемся окне, нажмите Далее (Next)
3) В следующем окне выберите Установка оборудования, выбранного из списка вручную. (Install the hardware that I manually select from a list) и нажмите Далее (Next)
4) Выберите в списке самую верхнюю строчку Показать все устройства (Show all devices) и нажмите Далее (Next)
5) В следующем окне нажмите на кнопку Установить с диска (Install From Disk), в нижнем правом углу.
6) В открывшемся окне нажмите кнопку Обзор (Browse) и укажите путь к файлу драйвера (inf-файл), затем нажмите ОК, а после Далее (Next)
7) Подтвердите желание установить нажатием Далее (Next)

Перейти к началу раздела Установка, Обновления, Языки.


2. Место сохранения обновлений полученных через Центр обновления Windows (Windows Update).

Все обновления, которые Вы скачиваете или устанавливаете через внутреннюю службу Windows Центр обновления Windows (Windows Update) хранятся в папке: C:\Windows\SoftwareDistribution\Download, а также в подпапках внутри неё. После установки обновлений, Вы можете сохранить их себе на компьютер просто скопировав из папки нужный Вам файл. Файлы содержащие в своем названии -express, могут повторно не установит©. Следовательно Вы можете их и не копировать.

Перейти к началу раздела Установка, Обновления, Языки.


3. Определение неизвестного устройства в Диспетчере устройств.

Узнайте VendorID(VEN) или DeviceID(DEV) устройства.

Данные сведения Вы можете узнать воспользовавшись Диспетчером устройств.
1) Откройте Пуск → Панель управления → Диспетчер устройств
2) Нажмите правой кнопкой мыши на необходимом Вам устройстве и выберите пункт Свойства
3) Перейдите на вкладку Сведения и в ниспадающем списке выберите ИД оборудования.
4) Зайдите на сайт: http://www.pcidatabase.com и введите одно из найденных Вами значений.

Если в указанной выше вкладке этого нет посмотрите также в вкладках:

Совместимые ИД
Путь к экземпляру устройства
Родитель
Родственные

там тоже это указывается.

Перейти к началу раздела Установка, Обновления, Языки.


4. Где можно найти драйвера, зная VendorID(VEN) или HardwareID(DEV)?

Для поиска драйверов, используя VendorID(VEN) или HardwareID(DEV) воспользуйтесь сайтом с постоянно обновляющейся базой данных: http://devid.info

Если Вам не удалось найти на данном сайте необходимые драйвера, то для поиска драйверов для Ваших устройств, Вы можете воспользоваться специальными программами: DevID Agent, либо программой DriverChecker которая имеет постоянно обновляющуюся базу драйверов.

Перейти к началу раздела Установка, Обновления, Языки.


5. Установка Windows 7 с USB флеш-накопитЈ (флешки).

Создание загрузочного флеш-диска.

Вариант 1. Используя командную строку.

Подготовка USB флеш-накопитЈ (флешки) для будущей загрузки и установки Windows 7:

1) Подключите USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
2) В строке поиска меню Пуск введите cmd.exe, щелкните на найденном правой кнопкой мыши и нажмите Запуск от имени администратора
3) Запустите утилиту управления дисками diskpart, дождитесь приглашения DISKPART>
4) Выполните команду list disk (отображает список всех дисков ПК)
5) Найдите среди них Ваш диск USB. (Пример: Disk 2)
6) Выполните команду select disk # (где # – это номер Вашего USB-драйва, полученного в предыдущей команде). (Пример: select disk 2).
Данная команда указывает diskpart, что все дальнейшие операции будут проводит© с данным диском.
7) Выполните команду clean (стирает все данные и разделы на USB диске).
8) Выполните команду create partition primary (создает новый раздел на диске).
9) Выполните команду select partition 1 (выбирает раздел, как объект для дальнейших манипЈций).
10) Выполните команду active – делает выбранный раздел активным.
11) Выполните команду format fs=NTFS – форматирует раздел в файловую систему NTFS.
12) Выполните команду assign – активирует процесс подключения устройства, получения букв для созданных разделов (если включен Автозапуск – всплывет окно, как будто Вы только что подключили USB-диск)
13) exit – выходит из diskpart в командную строку.

14) Вставьте имеющийся у Вас дистрибутив Windows 7 в дисковод, или смонтируете образ в виртуальный диск.
15) Допустим, что он у Вас установлен в дисковод H:, тогда в командной строке (не в diskpart !!!) выполните команду:

где I: – буква, полученная только что подготовленным USB-драйвом.
Данная команда подменяет на диске I: файлы загрузчика на те, которые необходимы для загрузки Windows 7.
Битность базовой ОС и дистрибутива Windows должны быть одинаковыми .
16) Скопируйте все файлы с Вашего дистрибутива на Ваш USB флеш-накопитель (флешку). Используйте для этого либо Windows Explorer, либо команду:

Всё, USB-драйв готов.

Для ускорения процесса копирования опытные пользователи могут воспользоваться программой RichCopy, она является графической оболочкой команды robocopy, и включает в себя большое количество настроек. В число многочисленных параметров входят сортировка файлов по атрибутам и папкам, предотвращение ошибок, смена атрибутов, тайминг копирования, редактирование отметки о времени, установка количества потоков и размера используемого кэша.

Вариант 2. Используя программу от Microsoft - Windows 7 USB/DVD Download Tool.

1) Скачайте программу Windows 7 USB/DVD Download Tool (установщик) или Windows 7 USB/DVD Download Tool (портабельная версия)
2) Установите и запустите программу.
3) Укажите на первом шаге путь к Вашему ISO-файлу и нажмите кнопку Next.

4) Нажмите на втором шаге кнопку USB Device

5) Нажмите на третьем шаге кнопку Begin copying

6) На четвертом шаге запустится процесс создания установочного загрузочного флеш-диска.

7) По окончании процесса создания закройте программу.

Информация: Программа Windows 7 USB/DVD Download Tool форматирует флеш-диск в файловую систему NTFS. Данная система не подходит для установки Windows 7 с флеш-диска в режиме EFI.

Вариант 3. Используя программу стороннего произодителя - UltraISO.

1) Вставьте Ваш флеш-диск в USB-порт.
2) Откройте ISO-образ Windows программой UltraISO

2.1) Щелкните на ISO-файле правой кнопкой мыши и выберите пункт Открыть, используя UltraISO
или
2.2) В программе UltraISO в меню Файл нажмите на пункт Открыть, выберите нужный Вам образ Windows 7 и нажмите Открыть.

3) Убедившись, что образ открыт - выберите в меню Самозагрузка пункт Записать образ Жесткого диска
4) В списке Disk Drive:, выберите Ваш флеш-накопитель, в пункте Метод записи: USB-HDD+ и нажмите Записать.
5) В появившемся окне об уничтожении информации Подсказка, нажмите кнопку Да. Дождитесь, когда завершится запись (от 5 до 20 минут).

Особенности установки с флеш-диска.

1) Вставьте флеш-диск в USB-порт и перезагрузите компьютер.
2) Сразу после начала перезапуска нажмите на клавиатуре клавишу для входа в BIOS.
Наиболее распространённые — Delete , F2 , F10 или Esc.
3) В BIOS установите загрузку в первую очередь с USB-HDD+.
4) Сохраните настройки и выйдите из BIOS. Компьютер перезапустит© и начнет загрузку с флеш-накопитЈ.
5) Процесс установки мало чем отличается от установки с загрузочного DVD-диска, но есть один момент.
Когда завершится копирование и распаковка файлов, и компьютер в первый раз пойдет на перезагрузку, необходимо снова зайти в BIOS и установить обратно приоритет загрузки (по умолчанию с жесткого диска) или вытащить флешку.
Иначе, возможно, загрузка снова пойдет с флеш-диска.

Если Вы не желаете изменять очередность загрузки в BIOS, то сразу после запуска компьютера, но до начала установки вызовите загрузочное меню и выбрать в нем Ваш флеш-диск.
Наиболее распространённые клавиши для вызова загрузочного меню — F8 , F11 , F12 или Esc.

Перейти к началу раздела Установка, Обновления, Языки.


6. Создание DVD или USB флеш-диска для установки Windows в режиме EFI (UEFI).

На компьютерах поддерживающих UEFI интерфейс для улучшения работоспособности операционной системы, рекомендуется устанавливать Windows в режиме EFI.
Для установки Windows в режиме EFI Вам понадобит© образ 64-битной операционной системы Windows 7 SP1 или новее.
Системный диск на который будет установлена Windows в режиме EFI, должен быть размечен в 64-битной версии Windows утилите Diskpart (не Acronis!!!) и отконвертирован в формат GPT.

Вариант 1. Создание USB флеш-диска для установки Windows в режиме EFI.

1) Создайте стандартный флеш-накопитель (флешку) для установки Windows 7.

Ваш загрузочный флеш-диск должен быть отформатирован в файловую систему FAT32, чтобы быть распознанным как загрузочное устройство UEFI.
Для создания флеш-диска Windows 7 в режиме EFI не используйте утилиту Microsoft - Windows 7 USB/DVD Download Tool. Данная утилита форматирует установочный флеш-диск в NTFS.

1.1) Подключите USB флеш-накопитель (флешку) не менее 4 Гб к USB-порту.
1.2) В строке поиска меню Пуск введите cmd.exe, щелкните на найденном правой кнопкой мыши и нажмите Запуск от имени администратора
1.3) Введите поочередно команды, нажимая после ввода каждой из них клавишу Enter ↵.

где # – это номер Вашего USB-драйва, полученного в предыдущей команде.
Указанные далее команды приведут к полной очистке всего содержимого на выбранном диске.

1.4) Распакуйте ISO-файл образа установочного диска во временную папку и скопируйте все его содержимое на созданный Вами флеш-диск.

Для создания загрузочного диска Вы также можете воспользоваться программой UltraISO.
Данная программа сразу создает установочный флеш-диск отформатированный в файловую систему FAT32.
Инструкцию Вы можете прочитать в третьем варианте совета 5. Установка Windows 7 с USB флеш-накопитЈ (флешки). из раздела Установка, Обновления, Языки.

2) Откройте на Вашем установочном флеш-диске папку *:\efi (* - буква Вашего флеш-диска с установочными файлами Windows 7).
3) Создайте новую папку внутри данной папки с именем boot. (*:\efi\boot).
4) Скопируйте все содержимое папки *:\efi\microsoft\boot в созданную Вами папку *:\efi\boot .
5) Используя архиватор 7-zip откройте файл *:\sources\boot.wim или *:\sources\install.wim .
6) Перейдите в архиве в папку *:\sources\boot.wim\1\Windows\Boot\EFI\ .
7) Скопируйте из данной папки в архиве файл bootmgfw.efi в созданную Вами папку *:\efi\boot на флеш-диске.
8) Переименуйте скопированный файл bootmgfw.efi (*:\efi\boot\bootmgfw.efi) в bootx64.efi (*:\efi\boot\bootx64.efi)

Теперь в созданной Вами папке *:\efi\boot\ должно быть все содержимое, скопированное из папки *:\efi\microsoft\boot и файл bootx64.efi полученный из boot.wim или install.wim.
Для некоторых материнских плат дополнительно требуется скопировать файл bootx64.efi в корень флеш-диска либо с идентичным именем файла, либо с именем shellx64.efi.

Вариант 2. Создание DVD диска для установки Windows в режиме EFI.

1) Скачайте архив с программой Microsoft CD/DVD Premastering Utility и распакуйте его в любую папку.
2) Скопируйте файл oscdimg.exe в папку C:\Windows\System32.
3) Распакуйте ISO-файл образа установочного диска во временную папку. (Например, в папку D:\Win_7_x64)
4) В строке поиска меню Пуск введите cmd.exe, щелкните на найденном правой кнопкой мыши и нажмите Запуск от имени администратора
5) Введите указанную ниже команду для создания ISO-файла образа установочного диска и нажмите клавишу Enter ↵.

где:

-l - Задает метку тома. Не используйте пробелы.
-m - Игнорирует ограничение максимального размера образа.
-o - Оптимизирует хранилище используя алгоритм хэширования MD5 для сравнения файлов.
-u1 - Создает образ, который имеет как файловую систему UDF, так и файловую систему ISO 9660. Файловая система ISO 9660 записывается с использованием имен файлов 8.3, совместимых с DOS. Файловая система UDF записывается с использованием имен файлов в Юникоде.
-p - Указывает значение для идентификатора платформы в каталоге El Torito. Для представления системы UEFI используется идентификатор EF. Не используйте пробелы.
-e - Отключает эмуляцию дискеты в каталоге El Torito.
-b - Указывает файл загрузочного сектора El Torito, который будет записан в загрузочном секторе или секторах диска. Не используйте пробелы.
D:\Win_7_x64 – Указывает расположение исходных файлов.
D:\Win_7_x64_UEFI.iso – Указывает путь к создаваемому ISO-файлу.

Особенности установки Windows в режиме EFI.

- Если Вы разгоняли какое-либо аппаратное обеспечение, то восстановите настройки в стандартные значения.
- В UEFI/BIOS установите в значение AHCI для SATA режима и включите ACPI 2.0, если отключено.
- Если загрузка с устройства не происходит, то в UEFI/BIOS установите Ваш флеш-диск первым в очереди загрузки.
- Если у Вас имеются как USB 3.0 порты, так и USB 2.0, то для успешной установки рекомендуется подключить флеш-диск в USB 3.0 порт.
(Флеш-диски USB 2.0 можно успешно подключить к порту USB 3.0.) Скопируйте на Ваш флеш-диск папку с драйверами яў порта USB 3.0.

1) Подсоедините флеш-диск и перезагрузите компьютер.
2) Нажмите при загрузке клавишу для вызова Boot Menu. (В зависимости от производитЈ материнской платы F8, F11 или F12)
3) Выберите в списке "UEFI:[имя Вашего устройства]".

При установке на чистый неразмеченный диск перейдите к седьмому пункту.
При установке на диск уже имеющий какие-либо разделы и использующий MBR, вместо GPT, продолжите со следующего пункта.
4) После загрузки в установочный экран Windows нажмите ⇑ Shift + F10.
5) Введите поочередно команды, нажимая после ввода каждой из них клавишу Enter ↵.

где # – это номер Вашего жесткого диска, на который будет установлена Windows, полученный в предыдущей команде.
Указанные далее команды приведут к полной очистке всего содержимого на выбранном диске.

6) Закройте окно команд и продолжите установку Windows.
7) Укажите драйвера для порта USB 3.0, если Вы подключали флеш-диск к нему вместо порта USB 2.0.
8) В окне выбора диска для установки Windows, выделите пункт Неразмеченное место на диске и нажмите кнопку Создать у Вас автоматически будет создано 3 раздела (системный раздел EFI (ESP), резервный раздел Майкрософт (MSR) и основной раздел Windows.)
9) Выберите основной раздел и продолжите установку Windows в режиме EFI, как обычную установку.

Примечание: Если установка завершилась успешно, а система не загружается, то в UEFI/BIOS установите "Windows Boot Manager" первым в очереди загрузки.

Перейти к началу раздела Установка, Обновления, Языки.


7. Интегрирование языковых пакетов и обновлений в дистрибутив Windows 7.

Вариант 1 вручную с помощью DISM.

Для работы Вам потребуются программа DISM, входящая в состав Windows 7 и программа UltraISO

Внесение изменений в install.Wim (Для добавления языка в систему, которую Вы установите)
1) Создаете на диске D: папки ISO, Lip, Mount и mWim
2) Распаковываете в папку D:\ISO iso-образ Вашего установочного диска.
3) Изменяете текст файла lang.ini в папке D:\ISO\sources на следующий:

4) Копируете файл языкового пакета lp.cab и все файлы обновлений (MSU и CAB) в папку Lip
5) Создаете в папке D:\Lip папку uLip
6) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл install.wim
7) Запускаете командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
8) Узнаете номер индекса Вашей Windows 7, используя команду:

9) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса Вашей операционной системы (Например, для Windows 7 Enterprise независимо от разрядности он равен 1, для 32-битной версии Windows 7 Ultimate он равен 5, а для 64-битной версии Windows 7 Ultimate он равен 4), используя команду:

10) Интегрируете языковой пакет и обновления:
Для интеграции языкового пакета введите команду:

Для интеграции обновления, используйте команду аналогичную предыдущей, подставляя вместо lp.cab, наименование интегрируемого обновления. Вот пример интеграции произвольного обновления:

11) ПримҐете все настройки яў русского языка командой:

Примеры запуска команд DISM для установки локальных настроек:

12) Демонтируете образ с сохранением изменений:

Демонтаж без сохранения:

13) Удаляете файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Перемещаете файл install.wim из папки D:\mWim в папку D:\ISO\Sources

Внесение изменений в Boot.Wim (Для добавления языка в программу установки запускаемую с установочного DVD или флеш-диска при старте компьютера)
1) Распаковываете lp.cab в папку D:\Lip\uLip

2) Очищаете папку D:\Mount (удаляете из нее любые следы, которые могли остаться от работы с файлом install.wim)
3) Перемещаете из папки D:\ISO\Sources в папку D:\mWim файл boot.wim
4) Монтируете файл boot.wim в папку D:\Mount (индекс указываете 2, так как он соответствует программе установки)

5) Добавляете в boot.wim русский язык:

6) Добавляете в boot.wim файлы лицензий:

7) Изменяете текст файла lang.ini в папке D:\Mount\sources на следующий:

8) Демонтируете файл boot.wim с сохранением:

9) Перемещаете файл boot.wim из папки D:\mWim в папку D:\ISO\Sources

Работа с папкой будущего образа.

1) Добавляете русский язык, в программу установки запускаемую в среде Windows или с Live-CD:

2) Добавляете файлы лицензий, в программу установки запускаемую в среде Windows или с Live-CD.:

3) Удаляете с диска D: папки Lip, Mount и mWim
4) Используя программу UltraISO создаете iso-образ установочного диска.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программами DISM Tool или DISM GUI. Они позволяет выполнить, все необходимые Вам команды, используя графический интерфейс. С их помощью Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(Add Packages в DISM Tool или Package Management в DISM GUI). Ссылка на архив с программами: DISM_Graphical.zip

Вариант 2. Используя программу RT Se7en Lite.

Данная программа интегрирует языковой пакет только в будущую систему (install.wim). Программа установки (boot.wim) остается на оригинальном языке.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте архив с программой RT Se7en Lite и распакуйте его в любую папку.
3) Установите программу необходимой Вам разрядности в зависимости от того, с каким ISO-образом Вы собираетесь работать.
4) Нажмите кнопку Browse и выберите пункт Select OS Path.
5) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
6) В появившемся окне List of operating system выберите Вашу редакцию Windows 7 и нажмите ОК.
7) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок Integration.
8) В столбце слева нажмите кнопку Integration.
9) Перейдите на вкладку Language Packs и нажмите кнопку Add.
10) Укажите путь к Вашему cab-файлу языкового пакета и нажмите Открыть.
11) Нажмите кнопку Apply, а затем кнопку Commit.
12) В окне Do you want to enable ISO bootable task? нажмите Да.
13) Нажмите кнопку Finish, а затем кнопку Да.
14) Используя программу UltraISO создаете iso-образ установочного диска.

Вариант 3 с помощью интегратора

1) Скачайте W7Mount.zip
2) Распакуйте архив и запустите программу.
3) Укажите (выберите) необходимы вам опции.
4) Нажмите на кнопку Выполнить
5) Дождитесь успешного выполнения и увидите результат.

Вариант 4 с помощью командного файла скрипта.

1) Скачайте LPIntegrator.zip
2) Распакуйте скачанный архив в папку
3) Нажмите правой кнопкой мыши на файле LPIntegrator.bat и щелкните на пункте меню Изменить
4) Измените значение параметра set LANG=ru-RU, на язык интегрируемого языкового пакета, где en-US - для английского языка, de-DE - для немецкого языка и т.д.
5) Сохраните изменения и закройте редактирование.
6) Запустите LPIntegrator.bat
7) Выберите версию Вашего образа Windows 7
8) Распакуйте ISO-образ в папку C:\7Work\DVD или скопируйте туда все файлы Вашего инсталляционного диска.
9) Скопируйте языковой пакет, который Вы хотите интегрировать в папку C:\7Work\LP
10) Скопируйте обновления, которые Вы хотите интегрировать в папку C:\7Work\CABS
11) Нажмите любую клавишу(например, Enter ↵) для продолжения.

Перейти к началу раздела Установка, Обновления, Языки.


8. Добавление и использование новых языков интерфейса в Windows.

Для добавления языков интерфейса необходимо установить дополнительные языковые файлы. После установки языковых файлов можно просматривать текст мастеров, диалоговых окон, меню, разделов справки и прочих элементов Windows на другом языке. Существуют 2 варианта добавления новых языков интерфейса: первый - через Центр обновления Windows(Windows Update), а второй - скачав и установив файл языкового пакета вручную. Перед началом работы измените в Панели Управления (Control Panel) способ просмотра(View by), вместо Категория(Category) на Крупные (Large icons) или Мелкие значки(Small icons).

Вариант1. Через Центр обновления Windows(Windows Update)

1) Откройте Центр обновления Windows
Пуск → Все программы → Центр обновления Windows (Start → All Programs → Windows Update)
или
Панель управления\Все элементы панели управления\Центр обновления Windows (Control Panel\All Control Panel Items\Windows Update)

1a) Также вы можете нажать Win   + R, в поле Выполнить ввести указанную ниже комманду и нажать ОК

2) Выберите пункт Необязательных обновлений XX шт. доступны (XX options updates are available)
3) Поставьте флажок напротив нужного Вам языкового пакета (Language Pack) и нажмите ОК

Вариант 2. При наличии файла языка интерфейса lp.cab

1) Заходите в Панель Управления(Control Panel)
2) Открываете Язык и региональные стандарты (Regional and Language)
3) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
4) Нажимаете Установить или удалить язык (Install/uninstall languages...)
4a) Также вы можете нажать Win   + R, в поле Выполнить ввести lpksetup и нажать ОК
5) Нажимаете Установить языки интерфейса (Install display languages)
6) Нажимаете кнопку Обзор...(Browse...)
7) Указываете путь к папке с lp.cab и нажимаете ОК
8) Выбираете необходимый Вам язык и нажимаете Далее(Next)

Вариант 3. Установка файла скачанного с сервера Windows Update

Вы можете установить необходимый Вам язык интерфейса, скачав exe-файл по прямой ссылке с сервера Windows Update и просто запустив его.

Смена Вашего языка интерфейса на новый:

1) Заходите в Панель Управления(Control Panel)
1.1) Открываете Язык и региональные стандарты (Regional and Language)
1.1a) Также вы можете нажать Win   + R, в поле Выполнить ввести intl.cpl и нажать ОК
1.2) Переходите на вкладку Языки и клавиатуры (Keyboards and Languages)
2) Выбираете в пункте Выберите язык интерфейса (Choose a display language:) нужный Вам язык и нажимаете ОК
3) Нажимаете кнопку Выйти из системы сейчас (Log off now)
4) В появившемся экране выбираете своего пользователя.
5) В случае необходимости вводите свой пароль и попадаете в Windows на выбранном Вами языке

Перейти к началу раздела Установка, Обновления, Языки.


9. Автоматическое введение ключа при инсталляции Windows.

Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.

Вариант 1. Для 32-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

Вариант 2. Для 64-битных систем.

Если у Вас ключ для Retail или OEM версии, то создайте файл Autounattend.xml следующего содержания:

Если у Вас MAK-ключ, то создайте файл Autounattend.xml следующего содержания:

Перейти к началу раздела Установка, Обновления, Языки.


10. Отключение проверки цифровой подписи драйверов и её добавление в 64-битных Windows 7.

Многие из нас сталкивались с проблемой установки неподписанного драйвера. Например, необходимо поставить драйвер какой-либо программы, но ее драйвер не устанавливается, ибо у него нет цифровой подписи.

В качестве решения Вы можете либо отключить проверку подписи, либо попытаться самостоятельно добавить к нему подпись.

Если Вам необходимо поработать с программой, устанавливающий свой драйвер без перезагрузки системы, то Вы можете загрузит© в специальный режим Windows.
1) Сразу после включения компьютера нажмитеF8. Далее Вы попадете либо в меню Дополнительные варианты загрузки, либо в меню выбора диска для загрузки.
2) Вам нужно меню Дополнительные варианты загрузки, поэтому если Вы попали в меню выбора дисков, то выберите диск на котором установлена Ваша Windows и нажмите Enter ↵, а затем быстро нажмитеF8 до начала запуска Windows.
3) Выберите пункт Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) и нажмите Enter ↵
Вы загрузитесь в специальный режим Windows, на котором будет только отключена проверка подписи, а все остальные функции будут работать в обычном режиме. После перезагрузки компьютера Вы вернетесь обратно в обычный режим с проверкой драйверов.
Иногда при установке драйвера в этом режиме система может выдать сообщение, что драйвер не подписан, просто закройте его и система нормально установит драйвер.

Чтобы самостоятельно подписать драйвер Вам понадобит© программа Driver Signature Enforcement Overrider(DSEO). Она позволяет создавать свои собственные непроверенные свидетельства. Для нормальной работы программы Контроль учетных записей (User Account Control (UAC)) должен быть выключен.

Скачать:

С официального сайта
С зеркала

1) Запускаете программу и нажимаете Next, а затем Next
2) Выбираете пункт "Enable Test Mode" и нажимаете Next
3) Выбираете пункт "Sign a System File" и нажимаете Next
4) Указываете имя Вашего файла, включая путь к нему и нажимаете Next
Например, если файл драйвера InetLock.sys расположен в каталоге C:\Windows\System32\Drivers, то Вам необходимо указать C:\Windows\System32\Drivers\InetLock.sys. В случае если необходимо подписать несколько файлов, то просто повторите эту процедуру несколько раз.
5) Перезапускаете компьютер
6) Устанавливаете необходимый Вам драйвер и пользуетесь им.

Иногда на рабочем столе возле часов может появит© маленькая надпись, сообщающая версию сборки операционной системы и тот факт, что Вы работаете в тестовом режиме. Для убирания данной надписи воспользуйтесь советом 6. Удаление надписей из правого нижнего угла рабочего стола. из раздела Тонкие настройки.

Данный режим также как и описанный в предыдущем варианте является штатным методом, предусмотренным Microsoft для тестирования разработчиками новых версий своих драйверов.
Отключить тестовый режим Вы можете просто запустив программу, выбрав пункт "Disable Test Mode" и нажав Next.

Плюсы данных методов в том, что они не изменяют загрузчик системы или какие-либо её системные файлы.

Также Вы можете скачать и установить программу ReadyDriver Plus она добавит небольшое изменение в загрузчик, которое автоматизирует процесс выбора Вами пункта Отключение обязательной проверки подписи драйверов (Disable Driver Signature Enforcement) при загрузке.

При правильном указании загрузочной папки Boot, данная программа будет работать у большинства пользователей. В программе ReadyDriver Plus на этапе выбора пути к папке Boot, по умолчанию, указан путь C:\Boot. Так как папка Boot с загрузочными файлами Windows 7 может располагаться не только на диске С:\ , то прежде чем продолжить установку ReadyDriver Plus выясните, где у Вас находится папка Boot.

Папка Boot может располагаться (рекомендации по нахождению):

1) На том же разделе, где у Вас установлена Windows 7

1.1) Откройте Проводник → Компьютер → Локальный диск (C:)
1.2) В Панели меню выберите Сервис → Параметры папок
1.3) Уберите флажок со значения Скрывать защищенные системные файлы
1.4) Установите переключатель в значение Показывать скрытые файлы, папки и диски
1.5) Смотрите в Проводнике, если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriver Plus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

2) На скрытом разделе 100 мегабайт (присвойте ему букву, для его выбора)

2.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win   + R
2.2) Введите diskmgmt.msc
2.3) Найдите раздел размером 100 мегабайт. Если у Вас его нет, то читайте о другом месте нахождения папки Boot.
2.4) Так как данный раздел скрыт, то нам для указания его необходимо сделать его видимым. Для этого щелкните на нем правой кнопкой мыши и выберите пункт Изменить букву диска или путь к диску, затем Изменить, назначьте букву (Например: Z) и нажмите кнопку OK
2.5) Откройте Проводник → Компьютер → Локальный диск (буква диска, в нашем примере Z:)
2.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriver Plus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

После установки программы ReadyDriver Plus снова пройдите в меню Изменить букву диска или путь к диску, но только выберите пункт Удалить, тем самым Вы сделаете его снова Скрытым

3) На крайнем слева разделе, от того на который установлена Ваша Windows

3.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win   + R
3.2) Введите diskmgmt.msc
3.3) Найдите крайний слева раздел, от того на который установлена Ваша Windows
3.4) Если он является активным, то запомните его букву, если он не является активным, то читайте о другом месте нахождения папки Boot.
3.5) Откройте Проводник → Компьютер → Локальный диск (буква диска)
3.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriver Plus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

4) На другом, являющимся активным разделе жестком диска.

4.1) Откройте в меню Пуск диалоговое меню Выполнить или нажмите Win   + R
4.2) Введите diskmgmt.msc
4.3) Найдите раздел жесткого диска являющийся активным
4.4) Запомните его букву
4.5) Откройте Проводник → Компьютер → Локальный диск (буква диска)
4.6) Если у Вас появилась скрытая папка Boot, то спокойно продолжайте установку программы ReadyDriver Plus, если данной папки у Вас нет, то читайте о другом месте нахождения папки Boot.

При установке программы ReadyDriver Plus, на этапе выбора пути к папке Boot, укажите путь к диску, где мы её обнаружили (Например: Z:\Boot или D:\Boot). После установки программы ReadyDriver Plus перезагрузитесь.

В процессе загрузки система даст Вам три секунды для выбора варианта загрузки: обычного или без проверки подписи. Если Вы не будете выбирать обычный режим, то система сама постоянно будет загружать Вас в режим без проверки подписей.

Перейти к началу раздела Установка, Обновления, Языки.


11. Где можно скачать последние обновления для Windows 7?

Компания Microsoft периодически выпускает обновления для Windows.
Чтобы скачать какое-либо из них, воспользуйтесь одним из предложенных ниже вариантов.

Вариант 1.

1) Откройте в браузере Internet Explorer официальный сайт Каталог Центра обновления Майкрософт:

http://catalog.update.microsoft.com/v7/site/home.aspx

2) Когда сайт предложит установить надстройку Microsoft Update Catalog, нажмите кнопку Установить.
3) При ¦вления окна Контроля Учетных Записей нажмите кнопку Да.
4) В текстовом поле поиска введите номер Вашего обновления и нажмите кнопку Поиск (Search).
5) Нажмите кнопку Добавить (Add), чтобы добавить необходимое Вам обновление в корзину загрузки. (Не забывайте про наличие разрядности у обновлений!)
6) Щелкните пункт просмотреть корзину (view basket) под полем Поиск, чтобы просмотреть корзину загрузки.
7) Нажмите кнопку Загрузить (Download) для начала загрузки обновления.
8) В открывшемся окне нажмите кнопку Обзор (Browse), укажите папку, в которую будет сохранено обновление и нажмите ОК.
Также Вы можете ввести полный путь к папке вручную.
9) Нажмите кнопку Продолжить (Continue), чтобы начать загрузку.
10) После завершения загрузки, нажмите кнопку Закрыть (Close), чтобы закрыть окно загрузки.

Также Вы можете поискать обновления на сайтах:

Microsoft Download Center.
Microsoft Knowledge Base monitoring

Вариант 2.

1) Скачайте файл WHDownloader.zip и распакуйте архив в любую папку.
2) Щелкните правой кнопкой мыши на файл програмы и выберите пункт Запуск от имени администратора.
3) Нажмите на стрелочку в верхнем левом углу (Download all Latest Update Lists) для скачивания списков всех последних обновлений.
4) Выберите в ниспадающем списке (Select a Category) версию Вашей Windows соответствующей разрядности (Например: Windows 7-x64).
5) Установите флажки напротив обновлений, которые Вы желаете скачать.
6) Нажмите на кнопку Download в нижнем левом углу.
Обновления будут скачены в папку Updates, находящуюся в папке программы WHDownloader.

Перейти к началу раздела Установка, Обновления, Языки.


12. Повышение оценки производительности жесткого диска.

Перед установкой Windows, зайдите в BIOS и укажите режим работы IDE/SATA-контроллера чипсета, как AHCI.

В разных BIOS, опции для настройки режима работы IDE/SATA-контроллера чипсета, могут иметь разные названия. Например:

Configure SATA As
SATA RAID/AHCI Mode
Onboard SATA Type
SATA Controller Mode

Менять режим работы стандартного IDE/SATA-контроллера чипсета необходимо до установки операционной системы.
Если система установлена, простая смена режима в BIOS приведет к появлению «синего экрана смерти».

Для устранения неполадок перед изменением режима SATA загрузочного диска включите драйвер AHCI в реестре. Для этого выполните следующие действия:

1) Закройте все программы Windows.
2) Откройте меню Пуск, в окне Начать поиск введите regedit и нажмите клавишу ВВОД.
3) Если откроется окно Учетные записи пользователей, нажмите кнопку Продолжить.
4) Найдите и выберите один из следующих подразделов реестра:

5) На правой панели щелкните правой кнопкой мыши параметр Start в столбце Имя, затем нажмите Изменить.
6) В поле Значение введите 0 и нажмите кнопку ОК.
7) В меню Файл выберите команду Выход, чтобы закрыть редактор реестра.

Перейти к началу раздела Установка, Обновления, Языки.


13. Автоматическая установка OEM-информации.

Предлагаю Вашему вниманию файл ответов, позволяющий автоматизировать процесс установки Windows путем занесения ответов на вопросы инсталлятора в специальный файл.
Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

Используемые параметры:

Extend - расширение раздела до размеров всего свободного неразмеченного пространства на диске. Если установлено значение true, раздел будет расширен. Если установлено значение false, необходимо указать размер с помощью параметра Size. Для каждого раздела задается либо значение параметра Extend, либо значение параметра Size, но никак не оба.
Order - порядковый номер операции по созданию раздела на диске. Нумерация начинается с единицы. В примере указано значение 1, т. е. раздел будет создан первым.
Size - размер раздела в мегабайтах.В первый раздел будет установлена Windows 7, поэтому не рекомендуется создавать раздел малого размера.
Type - тип раздела. Можно создать основной (Primary) или дополнительный (Extended) раздел.
Active - назначает раздел активным. Для назначения используется значение true. Так как на основной раздел установится Windows 7, то этот раздел следует назначить активным.
Format - формат файловой системы. Установка Windows 7 возможна только на файловую систему NTFS.
Label - метка тома. Установите по своему усмотрению.
Letter - буква диска. Логично задать для первого раздела букву C.
PartitionID - идентификатор раздела, по сути - его порядковый номер. Нумерация начинается с единицы.
DiskID - идентификатор диска. Значение 0 обозначает первый физический диск
NetworkLocation - задает тип сети, к которой подключается пользователь
WillWipeDisk - удаление всех разделов жесткого диска. Если установлено значение true, все разделы будут удалены.
WillShowUI - отображение интерфейса программы установки. Значение OnError предписывает программе установки отображать интерфейс в случае ошибки.
InputLocale - раскладка клавиатуры.
SystemLocale - язык для программ, не поддерживающих Юникод. Для русской Windows 7 указывается ru-RU, а для английской - en-US.
UILanguage - язык интерфейса операционной системы.
UserLocale - пользовательские параметры отображения чисел, денежных единиц, дат и времени.
Вместо xxxxx-xxxxx-xxxxx-xxxxx-xxxxx введите Ваш ключ.
Для 32-битных систем замените значение processorArchitecture="x64" на processorArchitecture="amd86"

Внимание!!! Предложенный файл ответов в данном совете стирает все разделы и логические диски при установке.

Для редактирования файла Autounattend.xml в графическом режиме воспользуйтесь программой Windows System Image Manager (WSIM), входящей в состав Microsoft Windows AIK.
Если же Вас интересует только, автоматический ввод ключа или OEM-Logo, обратитесь к советам №9 и №14 данного раздела (Установка, Обновления, Языки.).

Перейти к началу раздела Установка, Обновления, Языки.


14. Автоматическая установка OEM-Logo.

Создайте файл Autounattend.xml с указанным ниже текстом и скопируйте данный файл в корневую папку и в папку \Sources установочного диска.

1) Создайте в папке \Sources установочного диска папки: \$OEM$\$$\SYSTEM32\
2) Скопируйте Ваш файл oemlogo.bmp, содержащий изображение с Вашим логотипом в папку \Sources\$OEM$\$$\System32\oemlogo.bmp установочного диска.
3) Для 64-битных систем замените значение processorArchitecture="x86" на processorArchitecture="amd64"

Перейти к началу раздела Установка, Обновления, Языки.


15. Установка локальных наборов тем и настроек, а также пакетов обновления, предоставленных в виде CAB-файлов.

Чтобы добавить локальный набор тем и настроек в Windows, выполните следующие действия:

1) Найдите локальный набор тем и настроек и скопируйте его в доступное расположение.
2) Запустите командную строку от имени администратора.
2.1) Нажмите кнопку Пуск и в строке поиска введите cmd
2.2) Щелкните правой кнопкой мыши на найденном файле cmd.exe и выберите пункт Запуск от имени администратора
3) В окне командной строки введите следующую команду:

Например, если Вы скопируйте файл Windows-LocalPack-RU-Package.cab в папку «C:\Local Packs», то Вам необходимо будет ввести следующую команду:

Содержимое всех локальных наборов тем и настроек устанавливается в ходе работы программы установки Windows в скрытый каталог "%WINDIR%\globalization\MCT"

Описанным выше способом, можно установить любой пакет обновления, предоставленный в виде CAB-файла.

Перейти к началу раздела Установка, Обновления, Языки.


16. Автономная установка обновлений Windows.

16. Автоматическая установка обновлений Windows.

Вариант 1. Использование Bat-файла (для MSU и CAB обновлений).

1) Создайте папку Updates
2) Создайте в папке Updates файл Update.bat с указанным ниже содержанием.
2.1) Для этого скопируйте код в любой текстовый редактор (например, Блокнот).
2.2) Нажмите Ctrl + S и сохраните файл с любым именем и расширением .bat
2.3) Если вы выбираете тип файла: Текстовые файлы, то имя файла в кавычки брать обязательно. (Например: "Update.bat")
2.4) Если вы выбираете тип файла: Все файлы, то имя файла в кавычки брать не надо.

3) Создайте в папке Updates папки CAB и MSU.
4) Поместите в папку CAB все файлы обовлений с расширением .cab (Пример файла: Windows6.1-KB123456-x64.cab)
5) Поместите в папку MSU все файлы обовлений с расширением .msu (Пример файла: Windows6.1-KB123456-x64.msu)
6) Запустите Update.bat и дождитесь закрытия окна командной строки.

Для правильности работы скрипта проверьте у себя соблюдение следующих пунктов:

1) Убедитесь, что разрядность обновлений (х86\х64) соответствует разрядности Вашей системы.
2) В имени файла не должно быть слова EXPRESS, такое обновление копировать бесполезно, оно не установится.
3) Файл Update.bat должен находит© в папке на один уровень выше папок CAB и MSU.

Скачать готовый Update.bat

Вариант 2. Использование программы Windows 7 Update Pack Tool.

Наиболее простым решением для автоматической установки обновлений является программа Windows 7 Update Pack Tool.

Инструкция:

1) Скачайте Windows 7 Update Pack Tool
2) Создайте новую папку. Например: Updates
3) Поместите в неё файл Update.exe
4) Поместите в неё все обновления с расширениями .msu и .cab, которые Вы желаете установить.
5) Создайте внутри Вашей папки Updates папку SpecialUpdates
6) Поместите в папку SpecialUpdates все обновления с расширениями .msi и .exe, которые Вы желаете установить.
7) Запустите файл Update.exe
8) Выберите пункт Install updates. Для этого нажмите на клавиатуре цифру 1 и затем Enter ↵.
9) Программа произведет поиск обновлений: .msu и .cab в главной папке, и .msi и .exe в папке SpecialUpdates
10) Нажмите любую клавишу(например: Enter ↵) и программа установит обновления
11) По окончании установки программа напишет список устанавливаемых обновлений и попросит перезагрузки.
12) Перезагрузите компьютер и Вы получите систему с установленными обновлениями.

Перейти к началу раздела Установка, Обновления, Языки.


17. Отключение сообщения "Эта программа, возможно, установлена неправильно".

Если при установке какого-либо приложения Вы решили отменить установку или в случае, когда с приложением были известны какие-либо проблемы совместимости, Windows может отобразить подобное окно:

За данную функцию отвечает "Помощник по совместимости программ". Вы можете отключить его используя следующие варианты:

Вариант 1.

1) В строке поиска меню Пуск или в окне Выполнить (Win   + R) введите services.msc и нажмите Enter ↵.
2) Щелкните дважды на службу "Служба помощника по совместимости программ" ("Program Compatibility Assistant") или щелкните правой кнопкой мыши на ней и выберите Свойства
3) Измените значение Тип запуска на "Отключена".
4) Нажмите кнопку Остановить ("Stop")

Вариант 2.

1) В строке поиска меню Пуск или в окне Выполнить (Win   + R) введите gpedit.msc и нажмите Enter ↵
2) Перейдите в Конфигурация пользователя\Административные шаблоны\Компоненты Windows\Совместимость приложений
3) Щелкните дважды на параметре "Отключение помощника по совместимости программ" или щелкните правой кнопкой мыши на нем и выберите Изменить
4) Выставите значение "Включить".

Вариант 3.

Отключение для текущего пользователя.

Отключение для всех пользователей.

Перейти к началу раздела Установка, Обновления, Языки.


18. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1.

24. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1.

По указанным ниже ссылкам Вы сможете скачать языковые пакеты для Windows 7 и языковые пакеты для Windows 7 с установленным сервисным Пакетом обновлений 1 (SP1) напрямую с сайта Microsoft.

Чтобы скачать необходимый Вам языковой пакет нажмите на прямую ссылку напротив выбранного Вами языка.
Также Вы можете самостоятельно вручную сделать полную ссылку. Для этого добавьте к имени файла языкового пакета (независимо от разрядности) указанному в колонке Прямая ссылка место расположения файла:

Для Windows 7:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/
Например, если ¤ файла языкового пакета латышского языка для 64-битной версии Windows 7: windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2009/08/windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe

Для Windows 7 SP1:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/
Например, если ¤ файла языкового пакета латышского языка для 32-битной версии Windows 7 SP1: windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe, то ссылка будет:

http://download.windowsupdate.com/msdownload/update/software/updt/2011/02/windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x86-ar-sa_210ccc96338a1ff683803eb4034e5f53d6d54c97.exe
Bulgarian | Болгарский | windows6.1-kb972813-x86-bg-bg_2e5d91b00775e0f974d4ec213fc20d470ff6850e.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x86-zh-cn_ab024143b556395e6638e26712b1e0f3bc031fcf.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x86-zh-hk_90617b75cfaab716a43e7c082b00490a6d475376.exe
Croatian | Хорватский | windows6.1-kb972813-x86-hr-hr_d8a4131aee5d5de039a3a0dc517ca0c07ebc3472.exe
Czech | Чешский | windows6.1-kb972813-x86-cs-cz_2759680ec6e2f4a7629c7d02b1fbce0a0d410a4e.exe
Danish | Датский | windows6.1-kb972813-x86-da-dk_e1c57a4dcbd336ac73e349a9bb9d30de17ac093f.exe
Dutch | Нидерландский | windows6.1-kb972813-x86-nl-nl_194a2ca7b589e77b0be73b822f77760823183c51.exe
English | Английский | windows6.1-kb972813-x86-en-us_22ee3397a02372681b375ddabf6ffa33662fd500.exe
Estonia | Эстонский | windows6.1-kb972813-x86-et-ee_3a99769fac5d6a11e6616297f842a9074c045699.exe
Finnish | Финский | windows6.1-kb972813-x86-fi-fi_dd1973cc63ab7dea0e5d660af06869a8beefe36a.exe
French | Французский | windows6.1-kb972813-x86-fr-fr_1878fd391b990054787a14b0db4a5db00b793bf1.exe
German | Немецкий | windows6.1-kb972813-x86-de-de_1b86ff9b8f4c517dd341d76f24c74399278b05fc.exe
Greek | Греческий | windows6.1-kb972813-x86-el-gr_1f366d5e4fbde7df89b106821236fc1d3b3c9230.exe
Hebrew | Иврит | windows6.1-kb972813-x86-he-il_a3d6a6ae858f33ffa11a14c2a966e6603c134ef9.exe
Hungarian | Венгерский | windows6.1-kb972813-x86-hu-hu_12feb47da4bb28f60b6a30d379044356581c20f8.exe
Italian | Итальянский | windows6.1-kb972813-x86-it-it_079a3afeb88f14d24a3b4204812225e78c2e0bb8.exe
Japanese | Японский | windows6.1-kb972813-x86-ja-jp_08758c23cc64a53949072d53dd7bf6bbc8b45420.exe
Korean | Корейский | windows6.1-kb972813-x86-ko-kr_bb2de1652c37394be4de87438661b129f8b56908.exe
Latvian | Латышский | windows6.1-kb972813-x86-lv-lv_8b7a0b361dd37f7cd3926f798a79a90d378b18b2.exe
Lithuanian | Литовский | windows6.1-kb972813-x86-lt-lt_7aee9ce232cb46701f479fafdb0aea369ce1ad6a.exe
Norwegian | Норвежский | windows6.1-kb972813-x86-nb-no_d65ea89195cf5f7d3170ccb1db7bae3c157f5b24.exe
Polish | Польский | windows6.1-kb972813-x86-pl-pl_9199018040692bc732a590e9b092a18120d326b2.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x86-pt-br_0a3fe79820d6d199dd43495d4efa5c40f270e45a.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x86-pt-pt_4165bd9cd083abd8ddd81986e18b1fd86aab5ce9.exe
Romanian | Румынский | windows6.1-kb972813-x86-ro-ro_e1c324236046eb608e478570cf4396776ff02a72.exe
Russian | Русский | windows6.1-kb972813-x86-ru-ru_f4df4bcb8d3194323f17a086a17f46dd0c9c492a.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x86-sr-latn-cs_6e049bae4d75b82405b28455e2def0a0d0055a9c.exe
Slovak | Словацкий | windows6.1-kb972813-x86-sk-sk_dd2ce36a7e94fceff650cb892b8c954b8af6025a.exe
Slovenian | Словенский | windows6.1-kb972813-x86-sl-si_17786270766d556ba9bf3693762cb98805df9f50.exe
Spanish | Испанский | windows6.1-kb972813-x86-es-es_1943a073d8f00e387301deb22cd177bf77319ee8.exe
Swedish | Шведский | windows6.1-kb972813-x86-sv-se_687085e8bbdf9c17a668b801f28f7f9c74e7a86a.exe
Thai | Тайский | windows6.1-kb972813-x86-th-th_780885dd42c039d9926ac004c76ba3ba9c30c6d0.exe
Turkish | Турецкий | windows6.1-kb972813-x86-tr-tr_13015cb75811f874c83fdd679beb4c22c930a57c.exe
Ukrainian | Украинский | windows6.1-kb972813-x86-uk-ua_0a467bf14bc4f524c18877f570a20c58e91ceba9.exe
Английское название языка | Русское название языка | Прямая ссылка

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb972813-x64-ar-sa_aaac936bd625c12b607dffea19fab8be9cfa28f6.exe
Bulgarian | Болгарский | windows6.1-kb972813-x64-bg-bg_155634f17868659db4b65cfeff57059b2436515f.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb972813-x64-zh-cn_a649e9af1e28514d48bdc51f7956be08060e54bc.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb972813-x64-zh-hk_d428bc1cca4aea20163936e6687221c0e6b99ec4.exe
Croatian | Хорватский | windows6.1-kb972813-x64-hr-hr_06468f799a1c1f295bc3abbc85c14116e2645122.exe
Czech | Чешский | windows6.1-kb972813-x64-cs-cz_f136df3188c54ff234ca77253fee2cf3e91966b7.exe
Danish | Датский | windows6.1-kb972813-x64-da-dk_2b7590d389ca96af6f367408150cb6bc9aa8f4b4.exe
Dutch | Нидерландский | windows6.1-kb972813-x64-nl-nl_2ac14543f6e46c61ae226d7f0f5aee7f4d500e9f.exe
English | Английский | windows6.1-kb972813-x64-en-us_483a3e51038f1a369bc5b5cdf5fc32df3ea4ad27.exe
Estonian | Эстонский | windows6.1-kb972813-x64-et-ee_3c0479d7049109bcb42fd9ec59d1c65449704687.exe
Finnish | Финский | windows6.1-kb972813-x64-fi-fi_4378f72d1233b00e2bdfc680a13f62ae11ab0fcb.exe
French | Французский | windows6.1-kb972813-x64-fr-fr_0e50cd2ea794e4cdfac861b194d2e996b7bbc8d8.exe
German | Немецкий | windows6.1-kb972813-x64-de-de_399ac15b2d55fd5dea0770d98825d7e75f4ad533.exe
Greek | Греческий | windows6.1-kb972813-x64-el-gr_9ae588ba70896f9100a10cb8ed68a79678d6fc32.exe
Hebrew | Иврит | windows6.1-kb972813-x64-he-il_86c22105bb32269c9c0deaf2710fcb1531a29817.exe
Hungarian | Венгерский | windows6.1-kb972813-x64-hu-hu_e5c47bffe398b9ace42d4326de2646a6172d39b5.exe
Italian | Итальянский | windows6.1-kb972813-x64-it-it_3f0f5d78202e074e17a495beec821e1d326a8e2a.exe
Japanese | Японский | windows6.1-kb972813-x64-ja-jp_9d73b1c1270deacbe7a2329559476a94daddb848.exe
Korean | Корейский | windows6.1-kb972813-x64-ko-kr_e6b3322c3865cfd328d84376e192c4f9d41aa0e6.exe
Latvian | Латышский | windows6.1-kb972813-x64-lv-lv_70c1f8bda213f20aea07e46a6c9ed976f0d151ce.exe
Lithuanian | Литовский | windows6.1-kb972813-x64-lt-lt_ede5a878aae2b0d64e81ff739e950b6f105df580.exe
Norwegian | Норвежский | windows6.1-kb972813-x64-nb-no_1b7f93a0906a62eecd6b200979f8df986a7556f1.exe
Polish | Польский | windows6.1-kb972813-x64-pl-pl_6b228326c2f7ef6406242671600b499746ff3454.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb972813-x64-pt-br_276b65f3b6b2657c8fe936f9841dc1243e02dc7b.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb972813-x64-pt-pt_f8310aa4a73841aec29b3f4e74ecaece56b695e9.exe
Romanian | Румынский | windows6.1-kb972813-x64-ro-ro_810f2d590dd5aac92561eea5884ed1c70f34dbd9.exe
Russian | Русский | windows6.1-kb972813-x64-ru-ru_f0acfc688d609ee45d43cc60c6412a3071a665bd.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb972813-x64-sr-latn-cs_275e0a17cbec543aa1bd7eebc883a1d21c11b514.exe
Slovak | Словацкий | windows6.1-kb972813-x64-sk-sk_15f397de2ceaaff8dbfe670bcc6c013791a297c3.exe
Slovenian | Словенский | windows6.1-kb972813-x64-sl-si_8cfc82e0d15ed94634d3da69674008dc56755b93.exe
Spanish | Испанский | windows6.1-kb972813-x64-es-es_2e593c26d9e23ad8176224a53c68a04f996ee014.exe
Swedish | Шведский | windows6.1-kb972813-x64-sv-se_1f4c415e0f4ca77064d597975f6ac7a9e0b8af63.exe
Thai | Тайский | windows6.1-kb972813-x64-th-th_080c8631d44a53c34ffdab8fd73820572dd87be4.exe
Turkish | Турецкий | windows6.1-kb972813-x64-tr-tr_6bd6660158289e0b5d4b5a7f7fded6e3528a9a04.exe
Ukrainian | Украинский | windows6.1-kb972813-x64-uk-ua_c6c4e44c9d903049a4c60fed9d42effa18f345bd.exe
Английское название языка | Русское название языка | Прямая ссылка

Официальные языковые пакеты (language packs) для 32-bit (x86) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x86-ar-sa_5add6e4a36127029d431ba98d99708c44ef9b53f.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x86-bg-bg_a8a5013e477366119cfdc5fbda43b904755db450.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x86-zh-cn_ae61ea226215f96fc95be33201ffc96755ac7eb5.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x86-zh-hk_411a6bb68728f12f5ced712d9a33fee9ebe0b0b3.exe
Croatian | Хорватский | windows6.1-kb2483139-x86-hr-hr_685e217ce007af8005db4726087893d04e19dade.exe
Czech | Чешский | windows6.1-kb2483139-x86-cs-cz_bb5061f4bd24437dd31a3714e1b54318ced7e63a.exe
Danish | Датский | windows6.1-kb2483139-x86-da-dk_67fecaab0a940e2e537bc8dcd8a9ebb8ab4ed102.exe
Dutch | Нидерландский | windows6.1-kb2483139-x86-nl-nl_b7e1c3046b218fb45a665ab5f5ed8a5ea8125760.exe
English | Английский | windows6.1-kb2483139-x86-en-us_783d6dd59e2ec8fb0995a059c9c121795bde46c8.exe
Estonian | Эстонский | windows6.1-kb2483139-x86-et-ee_d0f798de315b696bf560b559f6f90064687c0b7b.exe
Finnish | Финский | windows6.1-kb2483139-x86-fi-fi_5259ca6a22a981dbdee352dde5b8e65c2fddd407.exe
French | Французский | windows6.1-kb2483139-x86-fr-fr_f57427487dfc2f49da67cac22480ab1f48983d22.exe
German | Немецкий | windows6.1-kb2483139-x86-de-de_acb9b88b96d432749ab63bd93423af054d23bf81.exe
Greek | Греческий | windows6.1-kb2483139-x86-el-gr_5aeecda7e1d689a083975128901da8156751dfc5.exe
Hebrew | Иврит | windows6.1-kb2483139-x86-he-il_1849d14777a76c7c5b4ef766490dccc8aed5c56b.exe
Hungarian | Венгерский | windows6.1-kb2483139-x86-hu-hu_a7a5af62c59ab7a4e8cb0f21242b42606b95195b.exe
Italian | Итальянский | windows6.1-kb2483139-x86-it-it_1d54a8d0047674fc1b5b6f41292a0074d9fe3cc5.exe
Japanese | Японский | windows6.1-kb2483139-x86-ja-jp_bc46078938ae9129c7ce86a9c176fa517e4c0a3d.exe
Korean | Корейский | windows6.1-kb2483139-x86-ko-kr_18f213428cc6fde96d8c76c6dd91446348e86ce6.exe
Latvian | Латышский | windows6.1-kb2483139-x86-lv-lv_97b58149699a2e8b02bd7cac720ac0795b51c98b.exe
Lithuanian | Литовский | windows6.1-kb2483139-x86-lt-lt_297c5ee6e98ab646b14f1492716b67cc0970fcd8.exe
Norwegian | Норвежский | windows6.1-kb2483139-x86-nb-no_5bd6fc76ad54b7a232d4ceb4a5f5c7c366bf90b6.exe
Polish | Польский | windows6.1-kb2483139-x86-pl-pl_c460a8c1392d7f3d35d1c0b37e56017d3552d245.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x86-pt-br_6e1d337b2fd56669d461e82601aa51004fecbd24.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x86-pt-pt_5cc92ef98ed177b2f6bbae3a0420ee2f12764fab.exe
Romanian | Румынский | windows6.1-kb2483139-x86-ro-ro_d8d9b2b4c5c457fe6a7dcb09a5f645cfe77cc30c.exe
Russian | Русский | windows6.1-kb2483139-x86-ru-ru_6532a8f36ad7d15277d5d60da92555f0fbee4daa.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x86-sr-latn-cs_e3d9acfcc9f608cf7687bd3b5ee7f0d9658b7bc9.exe
Slovak | Словацкий | windows6.1-kb2483139-x86-sk-sk_4c7b17a6cb292b09bede4c8731ad4f24cd09ab2a.exe
Slovenian | Словенский | windows6.1-kb2483139-x86-sl-si_de7f366819e1c12954557e3e65b7c0f059f49b67.exe
Spanish | Испанский | windows6.1-kb2483139-x86-es-es_6aef75f7d83edaabc2a921a6b157cc7005628286.exe
Swedish | Шведский | windows6.1-kb2483139-x86-sv-se_bd65af75e8995bd865d93c8d8c8a35091499083f.exe
Thai | Тайский | windows6.1-kb2483139-x86-th-th_8248f2b209d65a39ddaeb36e1782fcc0f6664f73.exe
Turkish | Турецкий | windows6.1-kb2483139-x86-tr-tr_228dfa5fbaa4606b17f93d6fcd51c8c85c0f1fd3.exe
Ukrainian | Украинский | windows6.1-kb2483139-x86-uk-ua_7f01db99ad2b2d41598bfc71aaa9bd4be04b6369.exe
Английское название языка | Русское название языка | Прямая ссылка

Официальные языковые пакеты (language packs) для 64-bit (x64) Windows 7 SP1:

Английское название языка | Русское название языка | Прямая ссылка
Arabic | Арабский | windows6.1-kb2483139-x64-ar-sa_f07f2cc7b55b17076eebceea2c2c2826b08b8f63.exe
Bulgarian | Болгарский | windows6.1-kb2483139-x64-bg-bg_e4c9392592ed2d4a8c7ec68270b5140430df197a.exe
Chinese (Simplified) | Китайский (упрощенное письмо) | windows6.1-kb2483139-x64-zh-cn_2c1884b4fdf6c8e91986369d88bbcaae01c6f187.exe
Chinese (Traditional) | Китайский (традиционное письмо) | windows6.1-kb2483139-x64-zh-hk_285282b1e2f750eeed91466918443b657968d977.exe
Croatian | Хорватский | windows6.1-kb2483139-x64-hr-hr_e7c6d648436d81466af331ab1ece07dd22be5fda.exe
Czech | Чешский | windows6.1-kb2483139-x64-cs-cz_1ea5b71d701e2480017b464b6560a2987e0d8971.exe
Danish | Датский | windows6.1-kb2483139-x64-da-dk_d753d19cc1a0fe95aef21548193393c04a6a8024.exe
Dutch | Нидерландский | windows6.1-kb2483139-x64-nl-nl_12c90c70d408b08f51f500d6e974878a5d662398.exe
English | Английский | windows6.1-kb2483139-x64-en-us_9b9c8a867baff2920507fbf1e1b4a158572b9b87.exe
Estonian | Эстонский | windows6.1-kb2483139-x64-et-ee_b4fd94f6e461e21b7eec54d1e379e2807861aea2.exe
Finnish | Финский | windows6.1-kb2483139-x64-fi-fi_223465e1b382484d1d82f8f2ccfcd9ed2f902c76.exe
French | Французский | windows6.1-kb2483139-x64-fr-fr_0f18e2a244dd9ff04664112a82776d2bd2177798.exe
German | Немецкий | windows6.1-kb2483139-x64-de-de_4f4ce6bd38530b4a02199172863b21a0cba13773.exe
Greek | Греческий | windows6.1-kb2483139-x64-el-gr_583791fea2fea71725388a746844d5be6488ca45.exe
Hebrew | Иврит | windows6.1-kb2483139-x64-he-il_617029400059f0847d7d90d4da673ae4ed43ebd9.exe
Hungarian | Венгерский | windows6.1-kb2483139-x64-hu-hu_1c298d99baf7af3d830dcd1e2632eeb65d7ee395.exe
Italian | Итальянский | windows6.1-kb2483139-x64-it-it_6d8223c065d6974d833d0eaa162f3ceb7680850f.exe
Japanese | Японский | windows6.1-kb2483139-x64-ja-jp_aeaf7e9b0b6c2173bf757330017a7f655f1f8715.exe
Korean | Корейский | windows6.1-kb2483139-x64-ko-kr_0ea76f748e3d5309d568147ad1337b2664090944.exe
Latvian | Латышский | windows6.1-kb2483139-x64-lv-lv_3919fb044a307144f1fc55cf4313aff45cde9a46.exe
Lithuanian | Литовский | windows6.1-kb2483139-x64-lt-lt_c894f0a591735553ba68f9fb94b1b85133ca922c.exe
Norwegian | Норвежский | windows6.1-kb2483139-x64-nb-no_78df68604970041a6337b4058a3e5339f79e50b4.exe
Polish | Польский | windows6.1-kb2483139-x64-pl-pl_24d00a966a7a75132c3af5627634483d3e2d01e7.exe
Portuguese (Brazil) | Португальский (Бразилия) | windows6.1-kb2483139-x64-pt-br_f8035731c55d774c95c7c673aedfd42d52479294.exe
Portuguese (Portugal) | Португальский (Португалия) | windows6.1-kb2483139-x64-pt-pt_78485491088298110a3e78b7a5f95e55ff7808df.exe
Romanian | Румынский | windows6.1-kb2483139-x64-ro-ro_6e7a63541f2cb534dab3db719330fee5cfbb4e0f.exe
Russian | Русский | windows6.1-kb2483139-x64-ru-ru_0587eb296a2f04e0d3699650d39b53ee18b97a79.exe
Serbian (Latin) | Сербский (латиница) | windows6.1-kb2483139-x64-sr-latn-cs_5f487007933585def54c67087895e74e25e699a9.exe
Slovak | Словацкий | windows6.1-kb2483139-x64-sk-sk_f1fb8a395d7d656649830f4f06496a5311ad572a.exe
Slovenian | Словенский | windows6.1-kb2483139-x64-sl-si_84606ed6bc061c72f756bbc061621b490fb761f7.exe
Spanish | Испанский | windows6.1-kb2483139-x64-es-es_fdbdf4061b960324efb9eedf7106df543ed8ce33.exe
Swedish | Шведский | windows6.1-kb2483139-x64-sv-se_81051fe3083afdb4f2d1d23752c587de9bb35025.exe
Thai | Тайский | windows6.1-kb2483139-x64-th-th_dc9c0cc12ae488ed3e8dcaecb4392eef91ec213b.exe
Turkish | Турецкий | windows6.1-kb2483139-x64-tr-tr_07e7e3b34426fe68be813e911d3843b941a268b7.exe
Ukrainian | Украинский | windows6.1-kb2483139-x64-uk-ua_1ca449545a2bcfdeeed6080768186fc29f163504.exe
Английское название языка | Русское название языка | Прямая ссылка

Если необходимый Вам язык отсутствует в данных таблицах, то это означает, что для данного языка вместо языкового пакета Вы можете скачать, только пакет интерфейса пользователя.
Такие пакеты устанавливаются в любом выпуске Windows 7 и предоставляют переведенную версию только самых широко используемых диалоговых окон, пунктов меню и содержимого справки. В качестве базы для их установки в системе должен быть установлен требуемый базовый язык (Английский, Испанский, Русский или др.)
Русская версия страницы загрузки пакетов интерфейса пользователя (не языковых пакетов!):
http://windows.microsoft.com/ru-ru/windows/language-packs
Английская версия страницы загрузки пакетов интерфейса пользователя (не языковых пакетов!):
http://windows.microsoft.com/en-US/windows/language-packs

Перейти к началу раздела Установка, Обновления, Языки.


19. Проверка установленных версий .NET Framework и установка отсутствующих.

«.NET Framework – всесторонняя и согласованная модель программирования Майкрософт для построения приложений, обладающих превосходным интерфейсом пользователя, прозрачными и безопасными средствами љзи, а также возможностью создания разнообразных бизнес-процессов». Платформа .NET Framework используется для разработки и последующего запуска приложений. Если разработчик пишет приложение с использованием одной из версий .NET Framework, то для запуска этого приложения потребуется аналогич версия .NET Framework на компьютере пользователя.

.NET Framework 1.0 - 1.1

Версия 1.0 практически не используется, в состав ОС не входит.
Версия 1.1 используется редко, в состав ОС не входит. Устанавливать только при необходимости.

Если установка .NET Framework 1.1 и пакета обновления (SP1) завершаться ошибкой, то в ручном режиме данная программа устанавливается так:

1) Создайте на диске С: папку DotNet в корне диска "С" (C:\DotNet).
2) Скачайте в созданную папку Предназначенный для повторного распространения пакет платформы Microsoft® .NET версии 1.1 и Пакет обновления Service Pack 1 для платформы Microsoft .NET версии 1.1.
3) Запустите командную строку с правами администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
4) Последовательно введите следующие команды и подтвердите выполнение каждой из них клавишей "Enter":

5) Ответьте положительно на вопросы в диалоговых окнах и продолжите ввод команд:

После ввода последней команды начнётся установка. Через несколько минут окна автоматически закроются - установка завершена.

.NET Framework 2.0 - 3.5.1

Версии 2.0 - 3.5.1 являются компонентами Windows 7 (Пуск → Панель управления → Программы и компоненты → Включение и отключение компонентов Windows).
Скачать .NET Framework 3.5 с пакетом обновления 1 (SP1) (полный пакет)

.NET Framework 4.0

Полная версия .NET Framework 4.0 предназначена в первую очередь для разработчиков ПО, клиентский профиль разработан для выполнения клиентских приложений и обеспечения быстрого развёртывания технологий Windows Presentation Foundation (WPF) и Windows Forms. Клиентский профиль распространяется в виде рекомендуемого обновления KB982670.

Скачать .NET Framework 4 (Полная версия)
Скачать .NET Framework 4 (Клиентский профиль)

.NET Framework 4.5.2

Скачать .NET Framework 4.5.2 (Полная версия)

Проверка наличия установленных версий

Вы можете проверить какие версии .NET Framework установлены в Вашей системе воспользовавшись программой .NET Version Detector

Или открыв раздел системного реестра (Win   + R → regedit → ОК): HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP

Перейти к началу раздела Установка, Обновления, Языки.


20. Быстрый запуск командной строки из среды предустановки Windows.

Если Вам необходимо быстро воспользоваться окном команд (командной строкой) за пределами основной среды Windows, и у Вас есть установочный DVD или флеш-диск, то Вы можете запустить командную строку сразу из первого окна программы установки Windows. Чтобы выполнить это сделайте следующее:

1) Загрузитесь с установочного DVD или флеш-диска
2) В первом окне нажмите сочетание клавиш ⇑ Shift + F10.

Откроется окно команд (командная строка) в которой Вы сможете либо ввести необходимую Вам команду, либо запустить необходимую Вам программу.

Перейти к началу раздела Установка, Обновления, Языки.


21. Интегрирование Сервисного Пакета в установочный ISO-образ Windows 7.

Вариант 1. При помощи команды Dism.

1) Создайте папки необходимые для работы (Например, на диске D: папки Temp, SP1, mWim и Mount)
2) Откройте окно команд в папке, где у Вас находится exe-файл сервисного пакета
2.1) Удерживая нажатой клавишу Shift щелкните правой кнопкой мыши на папке в области переходов.
2.2) В контекстном меню выберите пункт Открыть окно команд
3) Распакуйте exe-файл сервисного пакета во временную папку, используя команду:
Для 64-битной версии:

Для 32-битной версии:

4) Закройте окно команд.
5) Откройте в Проводнике папку D:\Temp и запустите в ней окно команд как описано в пункте 2.
6) Распакуйте cab-файл KB976932, используя команду:
Для 64-битной версии:

Для 32-битной версии:

7) Закройте окно команд.
8) Откройте в Проводнике папку D:\SP1 и запустите в ней окно команд как описано в пункте 2.
9) Распакуйте все cab-файлы языков в папку D:\SP1, поочередно выполнив команды (соглашаясь, если система спросит о перезаписи):

10) После окончания распаковки удалите все cab-файлы языков, используя команду:

11) Распакуйте cab-файл NestedMPPContent.cab в папку D:\SP1, используя команду (соглашаясь, если система спросит о перезаписи):

12) После окончания распаковки удалите cab-файл NestedMPPContent.cab, используя команду:

13) Удалите из папки D:\SP1 файлы cabinet.cablist.ini и old_cabinet.cablist.ini, используя команду:

14) Закройте окно комманд.
15) В папке D:\SP1 откройте в любом текстовом редакторе файл update.ses, замените все Absent на Installed и сохраните изменения.
16) В папке D:\SP1 откройте в любом текстовом редакторе файл update.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
17) В папке D:\SP1 откройте в любом текстовом редакторе файл Для 64-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~amd64~~6.1.1.17514.mum

или

Для 32-битной версии: Windows7SP1-KB976933~31bf3856ad364e35~x86~~6.1.1.17514.mum, замените allowedOffline="false" на allowedOffline="true" и сохраните изменения.
18) Скопируйте файл install.wim из папки \Sources Вашего установочного ISO-образа в папку D:\mWim
19) Узнаете номер индекса Вашей Windows 7, используя команду:

20) Монтируете файл install.wim в папку D:\Mount учитывая номер индекса (Например, для 64-битной версии Windows 7 Enterprise он равен 1), используя команду:

21) Интегрируете сервисный пакет, используя команду:

22) Демонтируйте образ с сохранением изменений, используя команду:

23) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

24) Если Вас устраивает размер получившегося файла install.wim, то замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\mWim\install.wim
25) Если Вас не устраивает размер получившегося файла install.wim, то Вы можете осуществить его сжатие.

25.1) Скачайте и установите (Пакет автоматической установки Windows® (AIK) для Windows® 7) или выше.
Если у Вас Windows 7 SP1, то также скачайте Дополнительный компонент пакета автоматической установки Windows® (AIK) для Windows® 7 с пакетом обновления 1 (SP1), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.
25.2) Создайте дополнительную папку необходимую для работы (Например, на диске D: папку Compress)
25.3) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
25.4.1) Если в Вашем install.wim содержится один образ (Например: Windows 7 Enterprise), то введите следующую ниже команду, нажав после ее ввода клавишу Enter ↵:

25.4.2) Если в Вашем install.wim содержится несколько образов (Например: Windows 7 Ultimate), то для создания итогового файла install.wim выполните указанную выше команду для каждого образа, заменяя индекс 1 на соответствующий, и нажимая после ввода каждой из них клавишу Enter ↵.

Например для 32-битной версии Windows 7 Ultimate:

Например для 64-битной версии Windows 7 Ultimate:

26) Замените файл install.wim из папки \Sources Вашего установочного ISO-образа, файлом D:\Compress\install.wim
27) Удалите папки Compress, Mount, mWim, SP1 и Temp.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программами DISM Tool или DISM GUI. Они позволяет выполнить, все необходимые Вам команды, используя графический интерфейс. С их помощью Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(Add Packages в DISM Tool или Package Management в DISM GUI). Ссылка на архив с программами: DISM_Graphical.zip

Вариант 2. Используя программу RT Se7en Lite.

1) Распакуйте ISO-образ установочного диска (в который Вы собираетесь интегрировать сервисный пакет) в любую папку.
2) Скачайте архив с программой RT Se7en Lite и распакуйте его в любую папку.
3) Установите программу необходимой Вам разрядности в зависимости от того, с каким ISO-образом Вы собираетесь работать.
4) Нажмите кнопку Browse и выберите пункт Select OS Path.
5) Укажите путь к папке в которую Вы распаковали ISO-образ установочного диска и нажмите ОК.
6) В появившемся окне List of operating system выберите Вашу редакцию Windows 7, установите флажок Slipstream Service Pack и нажмите ОК.
7) В появившемся окне RT Service Pack Slipstream нажмите нопку Browse
8) Укажите путь к exe-файлу сервисного пакета (windows6.1-KB976932-X64.exe или windows6.1-KB976932-X86.exe) и нажмите Открыть.
9) Нажмите кнопку Start и дождитесь завершения.
10) Нажмите кнопку Proceed.
11) В столбце слева нажмите кнопку Task и в открывшемся окне установите флажок ISO Bootable.
12) В столбце слева нажмите кнопку ISO Bootable
13) В ниспадающем меню ----Select a mode---- выберите пункт Create Image
14) В текстовом поле Volume name укажите какое имя для ISO-образа будет использоваться при монтировании.
15) Нажмите кнопку Make ISO для создания ISO-образа установочного диска с интегрированным сервисным пакетом.
16) Введите имя файла и нажмите кнопку Сохранить.

Перейти к началу раздела Установка, Обновления, Языки.


22. Создание установочного образа Windows с двумя видами разрядности (32-бит и 64-бит) в одном iso-образе.

В этом руководстве Вы будете работать с диском D:, но Вы можете выбрать любую букву диска.

Вариант 1. Быстрый и простой способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Ultimate (x86)
Windows 7 Enterprise (x86) (при необходимости)
Windows 7 Ultimate (x64)
Windows 7 Enterprise (x64) (при необходимости)

Программное обеспечение:

Шестнадцатеричный редактор (Например: HxD)
Пакет автоматической установки Windows® (AIK) для Windows® 7
Если у Вас Windows 7 SP1, то также скачайте Дополнительный компонент пакета автоматической установки Windows® (AIK) для Windows® 7 с пакетом обновления 1 (SP1), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.

1) Скачайте iso-образ Windows (AIK), смонтируйте его и установите Windows (AIK).
2) Если у Вас Windows 7 SP1, то также скачайте iso-образ Дополнительного компонента для Windows (AIK), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.

Этап 1: Упорядочивание файлов.

1) Создайте следующие папки:

D:\AIO\DVD
D:\AIO\DVD\sourc64
D:\AIO\ISO
D:\AIO\WIMs

2) Извлеките содержимое образа Windows 7 Ultimate (x86) в папку D:\AIO\DVD
3) Удалите все файлы с расширением .clg и файл ei.cfg из папки D:\AIO\DVD\sources, чтобы разблокировать все x86 версии Windows 7.
4) Переместите install.wim из папки D:\AIO\DVD\sources в папку D:\AIO\WIMs
5) Переименуйте файл install.wim в ULTx86.wim
6) Извлеките файл install.wim из образа Windows 7 Ultimate (x64) в папку D:\AIO\WIMs
7) Переименуйте файл install.wim в ULTx64.wim
8) При необходимости извлеките файлы install.wim из образа Windows 7 Enterprise (x86) и Windows 7 Enterprise (x64) в папку D:\AIO\WIMs, и переименуйте их в ENTx86.wim и ENTx64.wim соответственно.
9) Извлеките содержание папки sources (за исключением install.wim, ei.cfg и всех файлов .clg) из образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD\sourc64.
10) Скопируйте файл setup.exe из корня образа Windows 7 Ultimate (x64) в папку D:\AIO\DVD как setup64.exe

Этап 2. Создание Wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter ↵:

Примечание: Вы можете пропустить команды для Windows 7 Enterprise, если Вы решили их не включать.

Этап 3: Изменение BCD

Здесь Вы измените файл данных конфигурации загрузки BCD, чтобы добавить консоль восстановления для 64-битной Windows.

1) Запустите командную строку с правами администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) Перейдите к папке D:\AIO\DVD введя нижеследующие команды, нажимая после ввода каждой из них клавишу Enter ↵:

3) Сделайте копию загрузчика по умолчанию, выполнив команду:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

4) Установите новый загрузчик, чтобы загружать 64-битную PE, выполнив команды:

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

5) Установите время ожидания загрузки по умолчанию:

Этап 4. Добавление поддержки обновлений во время установки яў 64-битных систем.

Так как добавление данной возможности в двухразрядную сборку Windows предполагает Hex-редактирование файлов, то минусом здесь является поломка цифровой подписи.
Но это является наиболее простым способом решения проблемы с обновлениями.

1) Откройте файл D:\AIO\DVD\setup64.exe в hex-редакторе.
2) Найдите и замените все значения Юникодовой строки (без учета регистра) с sources\ на sourc64\.
Хотя данное действие сломает подпись, но оно не нарушит работоспособность самой программы, так как обе строки имеют одинаковую длину.
3) Откройте файл D:\AIO\DVD\sourc64\autorun.dll и замените все значения Юникодовой строки (без учета регистра) с sources\setup.exe на sourc64\upg64.cmd
4) Cоздайте в папке D:\AIO\DVD\sourc64 файл названный upg64.cmd, содержащих следующее:

Использование командного файла добавит второй небольшой минус, до начала установки на короткое время появится окно команд.

5) Измените содержание файла autorun.inf в папке D:\AIO\DVD на следующее:

Этап 5: Создание ISO-образа (опционально)

1) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
2) Введите нижеследующую команду и нажмите клавишу Enter ↵:

Указанные здесь параметры:

-u2 - Создает образ, который имеет файловую систему UDF.
-l - Задает метку тома. Между параметрами l и метка пробелов быть не должно.
-b - Указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - Включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - Игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

Вариант 2. Сложный и долгий способ.

Для создания собственного образа установочного диска Вам потребуется следующее:

Образы:

Windows 7 Enterprise (x86)
Windows 7 Enterprise (x64)

Программное обеспечение:

Шестнадцатеричный редактор (Например: HxD)
Пакет автоматической установки Windows® (AIK) для Windows® 7
Если у Вас Windows 7 SP1, то также скачайте Дополнительный компонент пакета автоматической установки Windows® (AIK) для Windows® 7 с пакетом обновления 1 (SP1), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.
Текстовый редактор с возможностью сохранения в кодировке 866. (Например: AkelPad)

1) Скачайте iso-образ Windows (AIK), смонтируйте его и установите Windows (AIK).
2) Если у Вас Windows 7 SP1, то также скачайте iso-образ Дополнительного компонента для Windows (AIK), смонтируйте его и скопируйте все содержимое диска в папку C:\Program Files\Windows AIK\Tools\PETools с заменой.

Этап 1: Подготовка к работе.

1) Создайте указанную ниже структуру папок с подпапками:

D:
│
└─AIO
   │
   ├───DVD
   │    │
   │    └───sources
   │           │
   │           ├───x64
   │           │
   │           └───x86
   ├───WIMs
   ├───ISO
   ├───offline
   └───temp
         ├───x64
         └───x86

2) Скопируйте все папки и все файлы, исключая папку sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD
3) Скопируйте содержимое папки sources из iso-образа Windows 7 Enterprise (64) в папку D:\AIO\DVD\sources\x64, исключая файлы:

4) Переместите файл install_Windows 7 ENTERPRISE.clg из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\temp\x64
5) Переместите файл install.wim из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\WIMs
6) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx64.wim
7) Извлеките файл install_Windows 7 ENTERPRISE.clg из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\temp\x86
8) Извлеките файл install.wim из iso-образа Windows 7 Enterprise (x86) в папку D:\AIO\WIMs
9) Переименуйте файл install.wim в папке D:\AIO\WIMs в ENTx86.wim

Этап 2. Создание файла install.wim.

Теперь Вы должны создать install.wim (файл, который содержит различные версии Windows), путем экспорта имеющихся у Вас в папке D:\AIO\WIMs образов.

1) В Командной строке средств развертывания введите нижеследующие команды, нажимая после ввода каждой из них клавишу Enter ↵:

Этап 3. Создание файлов winpe.wim.

1) В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter ↵:

2) Создайте в папке в D:\AIO\temp\x86 командный файл startnet.cmd:
3) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

4) Создайте в папке в D:\AIO\temp\x64 командный файл startnet.cmd:
5) Откройте его в AkelPad добавьте в него нижеследующий текст и сохраните в кодировке 866:

6) Смонтируйте файл D:\AIO\temp\x86\winpe.wim, выполнив команду:

7) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x86 соглашаясь на замену.
8) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x86 в папку D:\AIO\offline\Windows\System32
9) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
10) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
11) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\x86_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
12) Демонтируйте образ с сохранением.

13) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

14) Смонтируйте файл D:\AIO\temp\x64\winpe.wim, выполнив команду:

15) Скопируйте в папку D:\AIO\offline\Windows\system32 файл startnet.cmd из папки D:\AIO\temp\x64 соглашаясь на замену.
16) Скопируйте файл background_cli.bmp из папки D:\AIO\DVD\sources\x64 в папку D:\AIO\offline\Windows\System32
17) Удалите файл winpe.bmp из папки D:\AIO\offline\Windows\System32
18) Переименуйте файл background_cli.bmp в папке D:\AIO\offline\Windows\System32 на winpe.bmp.
19) Скопируйте файл winpe.bmp из папки D:\AIO\offline\Windows\System32 в папку
D:\AIO\offline\Windows\winsxs\amd64_microsoft-windows-winpe-background_31bf3856ad364e35_6.1.760X.XXXXX_none_XXXXXXXXXXXXXXXX
(значения вместо X зависят от версии WAIK) соглашаясь на замену.
20) Демонтируйте образ с сохранением.

21) Удалите файлы и папки, которые могли остаться после демонтирования wim-образа, используя команду:

22) Экспортируйте образы winpe:

Этап 4. Создание файлов ответов.

1) Запустите из меню Диспетчер образов системы Windows (расположен в папке Microsoft Windows AIK в меню Пуск)
2) Нажмите в главном меню Файл → Выбрать образ Windows
3) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x86
4) Нажмите в главном меню Файл → Новый файл ответов
5) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

6) На панели Файл отчетов пройдите:

7) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
8) На панели Файл отчетов пройдите:

9) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 1
10) На панели Файл отчетов пройдите:

11) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
12) Нажмите в главном меню Файл → Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x86.xml
13) Нажмите в главном меню Файл → Закрыть файл ответов, а затем Закрыть образ Windows

14) Нажмите в главном меню Файл → Выбрать образ Windows
15) Выберите файл каталога install_Windows 7 ENTERPRISE.clg из папки D:\AIO\temp\x64
16) Нажмите в главном меню Файл → Новый файл ответов
17) На панели Образ Windows поочередно щелкая правой кнопкой мыши на указанных ниже компонентах, выберите этап конфигурации (пункт Добавление параметра для прохода 1 WindowsPE):

18) На панели Файл отчетов пройдите:

19) На панели Свойства: SetupUILanguage присвойте параметру UILanguage значение ru-RU
20) На панели Файл отчетов пройдите:

21) На панели Свойства: SetupUILanguage присвойте параметру Key значение /IMAGE/INDEX, а параметру Value значение 2
22) На панели Файл отчетов пройдите:

23) На панели Свойства: InstallFrom присвойте параметру Path значение %diskroot%\sources\install.wim
24) Нажмите в главном меню Файл → Сохранить файл ответов как и сохраните его как D:\AIO\DVD\sources\install-x64.xml
25) Нажмите в главном меню Файл → Закрыть файл ответов, а затем Закрыть образ Windows

Этап 5: Добавление в загрузочное меню пункты для выбора разрядности установки.

1) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x86).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter ↵:

2) Добавьте в загрузочное меню пункт Установка Windows 7 Enterprise (x64).
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter ↵:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Установите время ожидания загрузки по умолчанию::

Этап 6: Добавление в загрузочное меню пункты для выбора разрядности среды восстановления.

1) Добавьте файлы сред восстановления системы (winre.wim) для каждой разрядности:

1.1) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.2) Скопируйте из папки D:\AIO\DVD\sources\install.wim\1\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.3) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x86.wim
1.4) Откройте с помощью программы 7-zip файл install.wim из папки D:\AIO\DVD\sources
1.5) Скопируйте из папки D:\AIO\DVD\sources\install.wim\2\Windows\System32\Recovery в папку D:\AIO\DVD\sources файл winre.wim.
1.6) Переименуйте файл winre.wim из папки D:\AIO\DVD\sources в winre-x64.wim

2) Добавьте новые записи в загрузочное меню для среды восстановления Windows x86:
В Командной строке средств развертывания введите команды, нажимая после ввода каждой из них клавишу Enter ↵:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

3) Добавьте новые записи в загрузочное меню для среды восстановления Windows x64:

Примечание: Эта команда сообщит Вам {GUID} сделанной копии, запишите его.

Примечание: (Замените {GUID} идентификатором GUID, который Вы записали.)

(Если в D:\AIO\DVD\boot\ появились файлы BCD.LOG, bcd.LOG1, bcd.LOG2 - их можно удалить)

Этап 7: Создание ISO-образа.

1) Скопируйте bcd из папки D:\AIO\DVD\boot в папку D:\AIO\DVD\efi\microsoft\boot заменяя оригинал.
2) Запустите Командную строку средств развертывания (расположена в папке Microsoft Windows AIK в меню Пуск) от имени администратора.
3) Введите нижеследующую команду и нажмите клавишу Enter ↵:

Указанные здесь параметры:

-u2 - Создает образ, который имеет файловую систему UDF.
-l - Задает метку тома. Между параметрами l и метка пробелов быть не должно.
-b - Указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - Включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - Игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7_AIO_x86-x64.ISO будет находится в папке D:\AIO\ISO.

Перейти к началу раздела Установка, Обновления, Языки.


23. Прямые ссылки с официального сайта Microsoft для скачивания сервисного Пакета обновлений 1 (SP1) для Windows 7.

Если Вам необходимо скачать сервисный Пакет обновлений 1 (SP1) для Windows 7, то Вы можете сделать это, воспользовавшись указанными ниже прямыми ссылками с сайта Microsoft.

ISO-образ, содержащий Пакеты обновлений 1 (SP1) для обоих разрядностей Windows 7 (x86 и x64):

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/7601.17514.101119-1850_Update_Sp_Wave1-GRMSP1.1_DVD.iso

Сервисный Пакет обновлений 1 (SP1) для 32-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X86.exe

Сервисный Пакет обновлений 1 (SP1) для 64-битной версии Windows 7:

http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X64.exe

Перейти к началу раздела Установка, Обновления, Языки.


24. Изменение языка интерфейса в редакциях Windows 7 Starter/Home Basic/Home Premium/Professional.

На большинстве новых моделей ноутбуков или стационарных компьютеров изначально установлена Windows 7 Home Basic, Windows 7 Home Premium или Windows 7 Professional. Данные версии не поддерживают установку нового языка и его смену, используя стандартные возможности Windows. Если Вам необходимо изменить язык в одной из таких версий Windows 7, то порядок действий следующий.

Вариант 1.

1) Создайте папку, в которой будут выполняться все промежуточные операции, например C:\Work.
1.1) Откройте Windows Explorer (анг.) или Windows-Explorer (нем.) или Проводник (рус.) и перейдите на диск C:
1.2) Щелкните правой кнопкой мыши и выберите New → Folder (анг.) или Neu → Ordner (нем.) или Создать → Папку (рус.)

2) Создайте папку для языкового файла C:\Lang, куда переложите lp.cab.
Чтобы добыть файл lp.cab из exe-установщика языкового пакета, запустите скаченный exe-файл и когда рядом появится файл lp.cab быстро скопируйте его.

3) Перезагрузите компьютер в Windows Boot Manager (анг.) или Windows-Start-Manager (нем.) или Диспетчер загрузки Windows (рус.), для этого нажмите клавишу F8 после экранов BIOS, но до появления загрузочного экрана системы.
4) В списке установленных систем выберите Windows 7, и еще раз нажмите клавишу F8.
5) В появившемся списке вариантов загрузки Advanced Boot Options (анг.) или Erweiterte Startoptionen (нем.) или Дополнительные варианты загрузки (рус.) выберите первый пункт — Repair Your Computer (анг.) или Computer reparieren (нем.) или Устранение неполадок компьютера (рус.).
6) В списке инструментов выберите командную строку Command Prompt (анг.) или Eingabeaufforderung (нем.) или Командная строка (рус.).
7) Найдите имя диска, где установлена Windows 7. Переходите между дисками, используя C:, D: и т.д. и найдите текущий по содержимому с помощью команды dir.
Для примера предположим, что Вы обнаружили Windows на диске D: . Далее работаем с DISM (Deployment Image Servicing and Management tool).

Далее приводится последовательный алгоритм команд, выполнив которые, вы получите локализованную версию вашей Windows 7.

1) Проверьте список языковых пакетов, установленных в системе.

Параметр /image:d: указывает, что Вы нашли папку Windows и Program files, т.е. установленную Windows 7 на диске D: .
Если в списке пакетов, Вы обнаружили необходимый Вам, содержащий строку 'Client-LanguagePack', то добавлять новый языковой пакет не надо и Вы можете перейти к 3 шагу.
2) Установите новый языковой пакет в систему.

Параметр /scratchdir указывает папку, в которую для обработки будет распаковано содержимое lp.cab.
3) Укажите системе язык, необходимый для использования по умолчанию.

Это может быть любой из установленных в системе языков, например en-US или de-DE.
4) Проверьте установленные языковые параметры:

Если напротив строки Default system UI language: (анг.) или Standardmäßige Benutzeroberflächenschprache des Systems (нем.) или Язык пользовательского интерфейса по умолчанию: (рус.) указано буквенное обозначение Вашего языка, то закройте окно и перезагрузите компьютер.
5) В Windows 7 запустите командную строку с правами администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
6) Смените язык экрана загрузки.

или буквенное обозначение языка, который Вам нужен.
7) Смените язык менеджера загрузки (вызывается клавишейF8 перед загрузкой Windows)

Внимание: DISM может выдать ошибку доступа в том случае, если вы открывали в командной строке какие-либо папки на разделе с системой. В этом случае сначала верните командную строку в корень этого раздела, выполнив команду cd \

Вариант 2.

1) В соответствии с разрядностью и наличием установленного сервисного пакета Вашей Windows cкачайте необходимый Вам языковой пакет.
Ссылки указаны в совете 18. Официальные прямые ссылки на языковые пакеты для Windows 7 и Windows 7 SP1. из раздела Установка, Обновления, Языки.

2) Запустите скаченный exe-файл и когда рядом появится файл lp.cab быстро скопируйте его на диск C:\
3) Запустите командную строку от имени Администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.

Далее приводится последовательный алгоритм команд, выполнив которые, вы получите локализованную версию вашей Windows 7. После ввода каждой команды нажимайте на клавиатуре Enter ↵.

4) Установите новый языковой пакет в систему.

5) Смените язык экрана загрузки.

где ln-LN – выбранное обозначение языка. Для русского замените его на значение ru-RU, для английского – en-US и т.д.

6) Измените язык диспетчера загрузки

где ln-LN – выбранное обозначение языка. Для русского замените его на значение ru-RU, для английского – en-US и т.д.

7) Изменените язык меню дополнительных вариантов загрузки

где ln-LN – выбранное обозначение языка. Для русского замените его на значение ru-RU, для английского – en-US и т.д.

8) Создайте и примените указанный ниже reg-файл.

где 0419 (00000419) соответствует числовому обозначению идентификатора русского языка. Для изменения на английский язык укажите значения 0409 (00000409), для немецкого языка - 0407 (00000407).

9) Перезагрузите компьютер.

Для переключения между установленными языками интерфейса, замените в указанном выше файле реестра числовое обозначение идентификатора языка на необходимое Вам, примените reg-файл и перезагрузите компьютер.

Перейти к началу раздела Установка, Обновления, Языки.


25. Установка Windows 7 без создания учетной записи и имени компьютера, а также добавление драйверов в систему на этапе установки Windows.

Если Вам необходимо установить драйвера для устройств в процессе установки Windows 7.
Если Вы желаете не создавать собственную учетную запись и не указывать имя компьютера.
Воспользуйтесь для этого предложенным ниже решением.

1) Начните обычную установку Windows 7.
2) Сразу после первой перезагрузки нажмите клавишу F8.
3) Выберите пункт Безопасный режим (Safe Mode) и нажмите Enter ↵.
4) При ¦влении окна о невозможности продолжить установку в безопасном режиме не нажимая кнопки ОК, нажмите ⇑ Shift + F10.

Установка драйверов.

5) В командной строке введите compmgmtlauncher и нажмите Enter ↵.
У Вас загрузится оснастка Управление компьютером (Computer Management).
6) Перейдите Служебные программы → Диспетчер устройств (System Tools → Device Manager).
7) Щелкните правой кнопкой мыши на устройстве для которого необходимо установить драйвер и выберите пункт Обновить драйверы (Update Driver Software).
8) Выберите пункт Выполнить поиск драйверов на этом компьютере (Browse my computer for device software).
9) Укажите в поле Искать драйверы в следующем месте путь (Search for driver software in this location) путь к папке с драйверами и нажмите кнопку Далее (Next).
10) Закройте оснастку оснастка Управление компьютером (Computer Management) и командную строку.
11) Нажмите кнопку ОК в окне о невозможности продолжить установку в безопасном режиме.
Компьютер перезагрузится и продолжит установку в обычном режиме.

Включение встроенной учётной записи администратора, вместо создания собственной учетной записи.

12) При ¦влении окна ввода имени пользователя и имени компьютера нажмите ⇑ Shift + F10.
13) В окне команд введите команду compmgmtlauncher и нажмите клавишу Enter ↵.
14) Перейдите Служебные программы → Локальные пользователи и группы → Пользователи (System Tools → Local Users an Groups → Users)
15) Щелкните правой кнопкой учетную запись Администратор (Administrator) и выберите Свойства (Properties).
16) Откроется окно Свойства: Администратор (Administrator Properties).
17) На вкладке Общие (General) снимите флажок Отключить учетную запись (Acount is disabled) и нажмите кнопку OK.
18) В командной строке введите explorer и нажмите Enter ↵.
19) В командной строке введите taskmgr и нажмите Enter ↵.
20) Выделите приложение msoobe и нажмите Снять задачу (End Task) → Завершить сейчас (End Now).
21) Подождите немного и Windows самостоятельно загрузится на рабочий стол.
22) Закройте Диспетчер задач Windows (Windows Task Manager), окно команд, настройте расположение сети и перезагрузите компьютер.
Ваша Windows готова к работе.

Перейти к началу раздела Установка, Обновления, Языки.


26. Добавление и удаление сведений об играх имеющихся в системе, в папку Обозреватель игр (Игры).

Многие игры во время установки записывают сведения о себе в специальную папку Обозреватель игр (Пуск → Все программы → Игры → Обозреватель игр).
Если Вы установили игру, а игра не добавилась в указанную папку, то Вы можете сделать это самостоятельно, используя программу Game Explorer Builder, переведенную мною на русский язык.

Добавление сведений об игре в папку Обозреватель игр.

1) Скачайте архив GameExplorerBuilder_RUS.zip и распакуйте в любую папку.
2) Запустите программу Game Explorer Builder.
3) Щелкните правой кнопкой мыши в области списка программы и откройте Добавить игру → Создать ресурс.
4) На вкладке Общие укажите имя и описание игры.
5) На вкладке Детали введите версию игры, ее дату выпуска и минимальную и рекомендуемую оценку параметров компьютера для игры.
6) На вкладке Разработчики нажмите на значок Добавить запись и укажите имя и веб-сайт разработчика.
7) На вкладке Издатели нажмите на значок Добавить запись и укажите имя и веб-сайт издателя.
8) На вкладке Жанры нажмите на значок Добавить запись и укажите жанр игры.
9) На вкладке Рисунки нажмите на текстовое поле под словом Иконка и укажите путь к иконке (ico-файл) программы.
10) Затем нажмите на текстовое поле под словосочетанием Обложка игры и укажите путь к обложке игры (png, jpg или bmp-файл) программы.
11) Нажмите на текстовое поле под словосочетанием Выходной файл и укажите где и под каким именем следует сохранить файл ресурсов.
По умолчанию создается файл GDFResource.dll.
Хотя Вы можете задать любое имя файла и расположение, рекомендуется не изменять название dll-файла и сохранять его в самой папке игры.
12) Нажмите кнопку Создать для создание dll-файла ресурсов с информацией об игре. Откроется окно установки файла ресурсов.
13) В разделе Ярлыки нажмите на значок Добавить запись.
14) Введите в текстовом поле Имя слово Играть.
15) Нажмите на текстовое поле напротив слова Ярлык, укажите файл запускающий игру и нажмите кнопку ОК.
16) В разделе Ссылки техподдержки нажмите на значок Добавить запись.
17) Введите в текстовом поле Имя слово Техподдержка (Поддержка, Тех.Помощь или др.).
18) Введите в текстовом поле Ссылка адрес техподдержки в интернете и нажмите кнопку ОК.
19) Нажмите кнопку Установить, чтобы добавить из созданного Вами dll-файла сведения об игре в Обозреватель игр.

Удаление сведений об игре из папки Обозреватель игр.

1) Выделитие игру, информацию о которой Вы желаете удалить из Обозревателя игр.
2) Щелкните на выделенном правой кнопкой мыши и выберите Выбранные игры → Удалить выбранные.
3) Нажмите кнопку Да для подтверждения.

Перейти к началу раздела Установка, Обновления, Языки.


27. Интегрирование MSDaRT в установочный ISO-образ Windows 7.

Воспользовавшись данным советом Вы сможете интегрировать "Microsoft Diagnostic and Recovery Toolset (MSDaRT)" в установочный ISO-образ Windows, который затем Вы сможете записать на DVD-диск или флеш-диск.
Чтобы открыть "Microsoft Diagnostic and Recovery Toolset (MSDaRT)" используя полученный установочный диск:

1) Запустите обычную установку Windows.
2) На первом экране нажмите кнопку Далее.
3) На втором экране нажмите ссылку Восстановление системы.
4) Установите переключатель на значение: Используйте средства восстановления, позволяющие устранить проблемы при запуске Windows. и нажмите кнопку Далее.
Microsoft Diagnostic and Recovery Toolset (MSDaRT) будет последним в списке.

Чтобы интегрировать "Microsoft Diagnostic and Recovery Toolset (MSDaRT)" в установочный образ Windows Вам понадобится следующее:

  • Архиватор 7zip.
  • ISO-образ установочного диска с Windows 7.
  • Самозагружаемый ISO-образ Microsoft Diagnostics and Recovery Toolset (MSDaRT).
Вы можете создать ISO-образ MSDaRT самостоятельно или скачать уже готовый ISO-образ Microsoft Diagnostics and Recovery Toolset (MSDaRT) для Windows 7 со встроенными Debuggers And Tools:

DART70X86RUS_Disk.zip - архив с самозагружаемым ISO-образом MSDaRT для 32-битной версии Windows 7.
DART70X64RUS_Disk.zip - архив с самозагружаемым ISO-образом MSDaRT для 64-битной версии Windows 7.

  • Набор инструментов из Пакета автоматической установки Windows (AIK): Waik_Tools.zip
Инструкция.

1) Используя программу 7zip, распакуйте ISO-образ установочного диска с Windows 7 в любую папку. Например, D:\WIN7ISO.
2) Распакуйте самозагружаемый ISO-образ MSDaRT в папку D:\DARTISO.
3) Создайте на диске D:\ папки DARTMOUNT, WIM и ISO.
4) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
После введения каждой из указанных ниже команд в командной строке нажимайте Enter ↵ для их примененния.
5) Смонтируйте первый образ из файла boot.wim из папки D:\DARTISO в папку D:\DARTMOUNT.

6.1) Если Вам не требуется поддержка сети в MSDaRT, то удалите файл winpeshl.ini из папки D:\DARTMOUNT\Windows\System32.

6.2) Если Вам необходима поддержка сети, то откройте в текстовом редакторе файл winpeshl.ini, находящийся в папке D:\DARTMOUNT\Windows\System32.

7) Замените последнюю строку %SYSTEMDRIVE%\sources\recovery\recenv.exe на %SYSTEMDRIVE%\setup.exe
8) Сохраните изменения winpeshl.ini в файле, нажав Ctrl + S и закройте Блокнот.

Внимание: Если Вы решите не удалять файл winpeshl.ini, то требование инициализировать сеть будет появлятся всегда при загрузке в среду установкки Windows.

9) Откройте в Проводнике папку D:\DARTMOUNT.
10) Откройте в программе 7zip файл boot.wim из папки D:\WIN7ISO\sources.
11) Извлеките файл setup.exe из папки D:\WIN7ISO\sources\boot.wim\2\ в папку D:\DARTMOUNT.
12) Извлеките файл setup.exe из папки D:\WIN7ISO\sources\boot.wim\2\sources\ в папку D:\DARTMOUNT\sources.
13) Закройте все окна Проводника и программы 7zip.
14) Демонтируйте образ D:\DARTMOUNT с сохранением внесенных изменений.

15) Скачайте архив Waik_Tools.zip, содержащий набор инструментов из Пакета автоматической установки Windows (AIK).
16) Распакуйте архив, скопируйте файлы imagex.exe и oscdimg.exe, в соответствии с разрядностью Вашей системы в папку C:\Windows\System32.
17) Экспортируйте необходимые образы из имеющихся boot.wim, для создания нового boot.wim.

18) Скопируйте полученный boot.wim файл в папку, куда Вы распаковали установочный ISO-образ с заменой имеющегося файла.

19) Соберите ISO-файл установочного диска Windows 7 с интегрированным MSDaRT.

Указанные здесь параметры:

-u2 - Создает образ, который имеет файловую систему UDF.
-l - Задает метку тома. Между параметрами l и метка пробелов быть не должно.
-b - Указывает на загрузочный файл образа, который используется для создания загрузочного сектора на DVD-диске или образе.
-h - Включает в создаваемый образ все скрытые файлы и папки, расположенные по указанному пути
-m - Игнорирует ограничение максимального размера образа.

Готовый файл iso-образа: WIN7DART.ISO будет находится в папке D:\ISO.

Перейти к началу раздела Установка, Обновления, Языки.


28. Список буквенных и числовых обозначений идентификаторов языка.

Если Вы желаете установить языковой пакет или изменить языковые параметры системы при помощи командной строки, reg-файла или путем редактирования реестра, то Вам могут понадобит© буквенные или числовые обозначения локальных идентификаторов языка.
Ниже приводится их список.

Языковые пакеты

Английское название языка | Русское название языка | Буквенный идентификатор языка (имя языка) | Шестнадцатеричный идентификатор языка | Десятичный идентификатор языка
Arabic (Saudi Arabia) | Арабский (Саудовская Аравия) | ar-SA | 0x0401 | 1025
Bulgarian (Bulgaria) | Болгарский (Болгария) | bg-BG | 0x0402 | 1026
Chinese (Hong Kong S.A.R.) | Китайский (Гонконг) | zh-HK | 0x0c04 | 3076
Chinese (PRC) | Китайский (КНР) | zh-CN | 0x0804 | 2052
Chinese (Taiwan) | Китайский (Тайвань) | zh-TW | 0x0404 | 1028
Croatian (Croatia) | Хорватский (Хорватия) | hr-HR | 0x041a | 1050
Czech (Czech Republic) | Чешский (Республика Чехия) | cs-CZ | 0x0405 | 1029
Danish (Denmark) | Датский (Дания) | da-DK | 0x0406 | 1030
Dutch (Netherlands) | Голландский (Нидерланды) | nl-NL | 0x0413 | 1043
English (United States) | Английский (США) | en-US | 0x0409 | 1033
Estonian (Estonia) | Эстонский (Эстония) | et-EE | 0x0425 | 1061
Finnish (Finland) | Финский (Финляндия) | fi-FI | 0x040b | 1035
French (France) | Французский (Франция) | fr-FR | 0x040c | 1036
German (Germany) | Немецкий (Германия) | de-DE | 0x0407 | 1031
Greek (Greece) | Греческий (Греция) | el-GR | 0x0408 | 1032
Hebrew (Israel) | Иврит (Израиль) | he-IL | 0x040d | 1037
Hungarian (Hungary) | Венгерский (Венгрия) | hu-HU | 0x040e | 1038
Italian (Italy) | Итальянский (Италия) | it-IT | 0x0410 | 1040
Japanese (Japan) | Японский (Япония) | ja-JP | 0x0411 | 1041
Korean (Korea) | Корейский (Республика Корея) | ko-KR | 0x0412 | 1042
Latvian (Latvia) | Латышский (Латвия) | lv-LV | 0x0426 | 1062
Lithuanian (Lithuania) | Литовский (Литва) | lt-LT | 0x0427 | 1063
Norwegian, Bokmål (Norway) | Норвежский, букмол (Норвегия) | nb-NO | 0x0414 | 1044
Polish (Poland) | Польский (Польша) | pl-PL | 0x0415 | 1045
Portuguese (Brazil) | Португальский (Бразилия) | pt-BR | 0x0416 | 1046
Portuguese (Portugal) | Португальский (Португалия) | pt-PT | 0x0816 | 2070
Romanian (Romania) | Румынский (Румыния) | ro-RO | 0x0418 | 1048
Russian (Russia) | Русский (Россия) | ru-RU | 0x0419 | 1049
Serbian (Latin, Serbia) | Сербский (латиница, Сербия) | sr-Latn-CS | 0x081a | 2074
Slovak (Slovakia) | Словацкий (Словакия) | sk-SK | 0x041b | 1051
Slovenian (Slovenia) | Словенский (Словения) | sl-SI | 0x0424 | 1060
Spanish (Spain) | Испанский (Испания) | es-ES | 0x0c0a | 3082
Swedish (Sweden) | Шведский (Швеция) | sv-SE | 0x041d | 1053
Thai (Thailand) | Тайский (Таиланд) | th-TH | 0x041e | 1054
Turkish (Turkey) | Турецкий (Турция) | tr-TR | 0x041f | 1055
Ukrainian (Ukraine) | Украинский (Украина) | uk-UA | 0x0422 | 1058
Английское название языка | Русское название языка | Буквенный идентификатор языка (имя языка) | Шестнадцатеричный идентификатор языка | Десятичный идентификатор языка

Пакеты интерфейса пользователя

Такие пакеты устанавливаются в любом выпуске Windows 7 и предоставляют переведенную версию только самых широко используемых диалоговых окон, пунктов меню и содержимого справки.

Английское название языка | Русское название языка | Буквенный идентификатор языка (имя языка) | Шестнадцатеричный идентификатор языка | Десятичный идентификатор языка
Afrikaans (South Africa) | Африкаанс (Южная Африка) | af-ZA | 0x0436 | 1078
Albanian (Albania) | Албанский (Албания) | sq-AL | 0x041c | 1052
Amharic (Ethiopia) | Амхарский (Эфио ) | am-ET | 0x045e | 1118
Armenian (Armenia) | Армянский (Армения) | hy-AM | 0x042b | 1067
Assamese (India) | Ассамский (Индия) | as-IN | 0x044d | 1101
Azeri (Latin, Azerbaijan) | Азербайджанский (латиница, Азербайджан) | az-Latn-AZ | 0x042c | 1068
Basque (Basque) | Баскский (Страна Басков) | eu-ES | 0x042d | 1069
Bengali (Bangladesh) | Бенгальский (Бангладеш) | bn-BD | 0x0845 | 2117
Bengali (India) | Бенгальский (Индия) | bn-IN | 0x0445 | 1093
Bosnian (Cyrillic, Bosnia and Herzegovina) | Боснийский (кириллица, Босния и Герцеговина) | bs-Cyrl-BA | 0x201a | 8218
Bosnian (Latin, Bosnia and Herzegovina) | Боснийский (латиница, Босния и Герцеговина) | bs-Latn-BA | 0x141a | 5146
Catalan (Catalan) | Каталанский (Каталония) | ca-ES | 0x0403 | 1027
Filipino (Philippines) | Филиппинский (Филиппины) | fil-PH | 0x0464 | 1124
Galician (Galician) | Галисийский (Галисия) | gl-ES | 0x0456 | 1110
Georgian (Georgia) | Грузинский (Грузия) | ka-GE | 0x0437 | 1079
Gujarati (India) | Гуджарати (Индия) | gu-IN | 0x0447 | 1095
Hausa (Latin, Nigeria) | Хауса (латиница, Нигерия) | ha-Latn-NG | 0x0468 | 1128
Hindi (India) | Хинди (Индия) | hi-IN | 0x0439 | 1081
Icelandic (Iceland) | Исландский (Исландия) | is-IS | 0x040f | 1039
Igbo (Nigeria) | Игбо (Нигерия) | ig-NG | 0x0470 | 1136
Indonesian (Indonesia) | Индонезийский (Индонезия) | id-ID | 0x0421 | 1057
Inuktitut (Latin, Canada) | Инуктитут (латиница, Канада) | iu-Latn-CA | 0x085d | 2141
Irish (Ireland) | Ирландский (Ирландия) | ga-IE | 0x083c | 2108
isiXhosa (South Africa) | Исикоса (Южная Африка) | xh-ZA | 0x0434 | 1076
isiZulu (South Africa) | Исизулу (Южная Африка) | zu-ZA | 0x0435 | 1077
Kannada (India) | Каннада (Индия) | kn-IN | 0x044b | 1099
Kazakh (Kazakhstan) | Казахский (Казахстан) | kk-KZ | 0x043f | 1087
Khmer (Cambodia) | Кхмерский (Камбоджа) | km-KH | 0x0453 | 1107
Kiswahili (Kenya) | Суахили (Кения) | sw-KE | 0x0441 | 1089
Konkani (India) | Конкани (Индия) | kok-IN | 0x0457 | 1111
Kyrgyz (Kyrgyzstan) | Киргизский (Киргизия) | ky-KG | 0x0440 | 1088
Luxembourgish (Luxembourg) | Люксембургский (Люксембург) | lb-LU | 0x046e | 1134
Macedonian (Former Yugoslav Republic of Macedonia) | Бывшая Югославская Республика Македония | mk-MK | 0x042f | 1071
Malay (Brunei Darussalam) | Малайский (Бруней-Даруссалам) | ms-BN | 0x083e | 2110
Malay (Malaysia) | Малайский (Малайзия) | ms-MY | 0x043e | 1086
Malayalam (India) | Малаялам (Индия) | ml-IN | 0x044c | 1100
Maltese (Malta) | Мальтийский (Мальта) | mt-MT | 0x043a | 1082
Maori (New Zealand) | Маори (Новая Зеландия) | mi-NZ | 0x0481 | 1153
Marathi (India) | Маратхи (Индия) | mr-IN | 0x044e | 1102
Nepali (Nepal) | Непальский (Непал) | ne-NP | 0x0461 | 1121
Norwegian, Nynorsk (Norway) | Норвежский, нюнорск (Норвегия) | nn-NO | 0x0814 | 2068
Oriya (India) | Ория (Индия) | or-IN | 0x0448 | 1096
Persian | Фарси | fa-IR | 0x0429 | 1065
Punjabi (India) | Пенджабский (Индия) | pa-IN | 0x0446 | 1094
Quechua (Peru) | Кечуа (Перу) | quz-PE | 0x0c6b | 3179
Serbian (Cyrillic, Serbia) | Сербский (кириллица, Сербия) | sr-Cyrl-CS | 0x0c1a | 3098
Sesotho sa Leboa (South Africa) | Северный сото (Южная Африка) | nso-ZA | 0x046c | 1132
Setswana (South Africa) | Тсвана (Южная Африка) | tn-ZA | 0x0432 | 1074
Sinhala (Sri Lanka) | Сингальский (Шри-Ланка) | si-LK | 0x045b | 1115
Tamil (India) | Тамильский (Индия) | ta-IN | 0x0449 | 1097
Tatar (Russia) | Татарский (Россия) | tt-RU | 0x0444 | 1092
Telugu (India) | Телугу (Индия) | te-IN | 0x044a | 1098
Urdu (Islamic Republic of Pakistan) | Урду (Исламская Республика Пакистан) | ur-PK | 0x0420 | 1056
Uzbek (Latin, Uzbekistan) | Узбекский (латиница, Узбекистан) | uz-Latn-UZ | 0x0443 | 1091
Vietnamese (Vietnam) | Вьетнамский (Вьетнам) | vi-VN | 0x042a | 1066
Welsh (United Kingdom) | Валлийский (Соединенное Королевство) | cy-GB | 0x0452 | 1106
Yoruba (Nigeria) | Йоруба (Нигерия) | yo-NG | 0x046a | 1130
Английское название языка | Русское название языка | Буквенный идентификатор языка (имя языка) | Шестнадцатеричный идентификатор языка | Десятичный идентификатор языка

Перейти к началу раздела Установка, Обновления, Языки.


1. Работа с виртуальными жесткими дисками (VHD-файлами) в Windows 7.

VHD (Virtual Hard Disk) - это формат файлов, используемых виртуальными машинами для эмуляции жесткого диска. Вы сможете создать себе виртуальный диск и использовать его для хранения виртуальных операционных систем, программ и других файлов в одном файле-образе, который можно открыть различными программами виртуализации или виртуальными машинами. Виртуальные жесткие диски позволяют нескольким операционным системам одновременно находит© на одном компьютере.

Вариант 1. Работа с виртуальными дисками используя графический интерфейс.

Создание виртуального жесткого диска.

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win   + R) введите diskmgmt.msc и нажмите Enter ↵.
3) Откроется оснастка "Управление дисками". В панели меню выберите пункт Действие и нажмите на Создать виртуальный жесткий диск

4) В открывшемся окне укажите:

4.1) Имя файла и его расположение. Вы можете как написать это вручную, так и нажав на кнопку Обзор и воспользовавшись диалоговым окном Просмотр файлов виртуального диска
4.2) Размер виртуального диска. Возле текстового поля, в которое нужно ввести размер диска, присутствует раскрывающийся список, где можно выбрать размер жесткого диска. Доступные значения – мегабайты, гигабайты и терабайты. Создайте размер не меньше 20 ГБ.
4.3) Тип виртуального диска. Динамически расширяемый дисковый образ обеспечивает объем пространства, необходимый для хранения данных.
Размер VHD-файла в момент создания диска небольшой, но увеличивается по мере добавления данных на диск. Распределение данных осуществляется в блоках. При удалении данных с виртуального жесткого диска размер VHD-файла автоматически не уменьшается. Фиксированный размер создает VHD-файл, размер которого задается при создании виртуального жесткого диска. Размер VHD-файла остается постоянным независимо от объема хранимых данных.
5) Нажмите на кнопку «ОК».

Чтобы диспетчер локальных дисков смог получить доступ к созданному Вами виртуальному диску его необходимо инициализировать и создать на нем простой том. Для этого также используется оснастка "Управление дисками".

Инициализация виртуального жесткого диска.

1) Найдите Ваш виртуальный диск и щелкните на нем правой кнопкой мыши
2) Нажмите на пункт Инициализировать диск

3) Выберите стиль разделов - MBR и нажмите OK

Создание простого тома на виртуальном жестком диске.

После того как Вы проинициализировали Ваш виртуальный диск, на нем необходимо создать простой том.

1) Найдите Ваш виртуальный диск и щелкните на нераспределенной области справа от него
2) Нажмите на пункт Создать простой том

3) В первом диалоге Мастера создания простого тома нажмите на кнопку Далее
4) В диалоге указания размера тома, укажите размер будущего тома в мегабайтах и нажмите на кнопку Далее

5) В диалоге Назначение буквы диска или пути укажите букву для будущего диска и нажмите на кнопку Далее

6) В диалоге Форматирование раздела укажите нужную файловую систему, размер кластера, название диска и установите флажок возле опции Быстрое форматирование - для того, чтобы диск был сразу отформатирован. После чего нажмите на кнопку Далее

7) Для принятия всех настроенных параметров в диалоге Завершение мастера создания простого тома нажмите на кнопку Готово.
8) Виртуальный диск появится в таблице дисков. В оснастке управления дисками, значок виртуального диска визуально отличается от значков физических дисков. В Проводнике Windows виртуальные диски выглядят так же, как и физические.

Присоединение виртуального жесткого диска.

Если у Вас уже имеется созданный виртуальный жесткий диск, то Вы также можете присоединить его в оснастке "Управление дисками".

1) Откройте меню Пуск.
2) В строке поиска, или в диалоговом меню Выполнить (можете просто нажать Win   + R) введите diskmgmt.msc и нажмите Enter ↵.
3) В панели меню выберите пункт Действие и нажмите на Присоединить виртуальный жесткий диск.

4) Укажите расположение для виртуального жесткого диска на компьютере и нажмите OK Указать расположение Вы можете либо введя значение вручную, либо нажав на кнопку Обзор, и используя диалоговое окно Просмотр файлов виртуального диска. Если Вам не нужно записывать данные на диск, то в этом диалоге можно установить флажок Только для чтения.

Отсоединение (удаление) виртуального жесткого диска.

1) Найдите виртуальный диск, который хотите отсоединить, нажмите на нем правой кнопкой мыши
2) Нажмите на пункт Отсоединить виртуальный жесткий диск

3) Если Вы желаете отсоединить виртуальный диск без удаления его из системы, то нажмите OK. Для полного удаления диска из системы, отметьте Удалить виртуальный диск после удаления диска и после этого нажмите OK.

Вариант 2. Работа с виртуальными дисками используя программу Diskpart в командной строке.

Создание виртуального жесткого диска.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) В командной строке наберите Diskpart и нажмите Enter ↵
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для создания виртуального диска воспользуйтесь командой Create Vdisk. Синтаксис команды следующий:

Где:

File=<"имя_файла"> - Указание полного пути и имени файла виртуального диска.
Maximum=<n> - Максимальное дисковое пространство, предоставляемое виртуальным диском, заданное в мегабайтах (МБ).
[Type={Fixed|Expandable}] - Используется для указания формата виртуального диска. Существует два значения для данного параметра:
Fixed создает файл виртуального диска фиксированного размера;
Expandable создает динамически расширяемый образ виртуального диска.
[Source=<"имя_файла">] - Путь к существующему файлу виртуального диска для предварительного заполнения нового файла виртуального диска. При использовании параметра Source данные из исходного файла виртуального диска копируются блок за блоком в создаваемый файл виртуального диска. Если Вы при копировании динамического диска не укажете параметр Type=Expandable, то копия будет создана максимального размера выделенного для исходного диска, независимо от его текущего размера.

Примеры использования команды:

Присоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) В командной строке наберите Diskpart и нажмите Enter ↵
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk. Синтаксис команды следующий:

Пример использования команды:

4) Для присоединения выбранного виртуального диска воспользуйтесь командой Attach Vdisk. Синтаксис команды следующий:

[Readonly] - Присоединяет виртуальный диск в режиме только для чтения. Любая операция записи приведет к возникновению ошибки ввода-вывода устройства.
[Usefilesd] - Указывает, что для виртуального диска следует использовать дескриптор безопасности самого виртуального файла. Если параметр не указан, то у диска не будет явно заданного дескриптора безопасности, если не был также задан параметр SD=(строка SDDL).
[SD=<строка sddl>] - Задает дескриптор безопасности в формате SDDL. По умолчанию дескриптор безопасности обеспечивает доступ, аналогичный любому физическому диску. Дополнительные сведения о формате строки SDDL см. в справке по команде Create Vdisk.

Примеры использования команды:

Отсоединение виртуального жесткого диска.

1) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
2) В командной строке наберите Diskpart и нажмите Enter ↵
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Для выбора Вашего виртуального диска по имени файла и перемещения фокуса на него, используйте команду Select Vdisk.
4) Для отсоединения выбранного виртуального диска воспользуйтесь командой Detach Vdisk.

Перейти к началу раздела Виртуализация.


2. Создание загрузочного образа ISO Windows 7 из VHD-образа + интеграция LIP.

Для работы Вам потребуются:

1) Пакет автоматической установки Windows® (AIK) для Windows® 7
2) Архиватор 7-zip
3) Программа GImageX v2.1.1 (русская версия) или GImageX (английская версия)
4) Программа WinImage
5) MSDaRT (ранее ERD Commander)
5.1) Мастера для сборки MSDaRT образа: DaRT70x86.zip - для 32-бит или DaRT70x64.zip - для 64-бит.
или
5.2) Готовые образы MSDaRT: DART70X86RUS_Disk.zip - для 32-бит или DART70X64RUS_Disk.zip - для 64-бит.

Вариант 1

1) Создайте на диске C: папки DVD, VHD, Lip, Mount, Temp и mWim
2.1) Запустите утилиту WinImage и откройте в ней VHD-образ. В открывшемся диалоге щелкните ОК.
2.2) Выделите справа все файлы и щелкните на выделенном правой кнопкой.
2.3) Выберите Extract, затем щелкните Browse и выберите папку VHD. Чуть ниже выберите Extract with pathname.
Дождитесь завершения процесса распаковки. Если ¦вится ошибка, просто нажмите Продолжить.

3) Используя программу 7zip, распакуйте ISO-образ установочного диска с Windows 7 в папку C:\DVD
4) Скопируете в папку C:\Lip файл lp.cab и создайте в ней подпапку uLip
5) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
6) Распакуйте lp.cab в папку C:\Lip\uLip выполнив в консоли команду:

7) При помощи GimageX узнаете индекс Ultimate

8) Экспортируйте из файла install.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 5 для x86 или 4 для x64) как install.wim

9) При помощи GimageX узнаете индекс Microsoft Windows Setup (x64)

10) Экспортируйте из файла boot.wim в папке C:\DVD\sources в папку C:\mWim образ Ultimate (индекс 2) как boot.wim

11) Перезагрузите компьютер.
Примечание: Команды DISM Вы можете также выполнять в командной строке MSDaRT, чтобы не думать о проблемах доступа к папкам.
12) Запустите командную строку от имени администратора.
В строке поиска меню Пуск введите команду: cmd и нажмите одновременно Ctrl + ⇑ Shift + Enter ↵.
13) Монтируете файл C:\mWim\install.wim в папку C:\Mount выполнив в консоли команду:

14) Интегрируете LIP в install.wim

15) ПримҐете все настройки яў русского языка командой:

16) Копируете все файлы и папки из C:\VHD в C:\Mount, кроме папки C:\VHD\Boot и файла C:\VHD\bootmgr (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer)
17) Демонтируете install.wim с сохранением изменений из C:\Mount:

18) Монтируете файл C:\mWim\boot.wim в папку C:\Mount

19) Добавляете в boot.wim русский язык:

20) Добавляете в boot.wim файлы лицензий:

21) Правите текст файла (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer) C:\Mount\sources\lang.ini

22) Демонтируете boot.wim с сохранением изменений из C:\Mount:

23) Правите текст файла (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer) C:\DVD\sources\lang.ini, в котором должно быть следующее:

24) Заменяете файл (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer) C:\DVD\sources\install.wim в дистрибутиве, файлом C:\mWim\install.wim
25) Заменяете файл (Если Вы в MSDaRT, то через Micosoft Diagnostics and Recovery Toolset → Explorer) C:\DVD\sources\boot.wim в дистрибутиве, файлом C:\mWim\boot.wim
26) Перезагружаетесь в Windows
27) Открываете с помощью UltraISO образ дистрибутива. Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
28) Удаляете из него все содержимое и копируем в него содержимое папки C:\DVD
29) Сохраняете в другое место или под другим именем.

Вариант 2

1) Открываете меню Пуск, в поле поиска пишите diskmgmt.msc и нажимаете Enter ↵.
2) В верхнем меню нажимаете Действие → Присоединить виртуальный жесткий диск.
3) Указываете местонахождение VHD-образа, жмете ОК

4) Выбираете нужную вам букву для данного диска
5) Установите Windows AIK
6) Запустите программу GImageX и укажите в параметрах как на рисунке:

Source: - путь к виртуальному диску
Destination - путь куда будет сохранен готовый install.wim файл
Name - Имя образа (Windows 7 Ultimate)
Description - Описание образа (Windows 7 Ultimate)
Compression - Сжатие полученного install.wim файла (Maximum)

7) Открываете с помощью UltraISO образ дистрибутива Windows 7
8) Удаляете в папке \Sources файл install.wim
9) Добавляете созданный вами новый install.wim вместо старого.
10) Сохраняете образ под новым именем.
11) Записываете образ на USB флеш-накопитель (флешку) или DVD.

Также для работы с программой DISM в графическом режиме Вы можете воспользоваться программами DISM Tool или DISM GUI. Они позволяет выполнить, все необходимые Вам команды, используя графический интерфейс. С их помощью Вы сможете смонтировать (Mount WIM) и демонтировать (Dis-Mount WIM) образ, интегрировать языковой пакет или необходимое Вам обновление(Add Packages в DISM Tool или Package Management в DISM GUI). Ссылка на архив с программами: DISM_Graphical.zip

Перейти к началу раздела Виртуализация.


3. Установка и загрузка Windows 7 из VHD-файла.

Вариант 1

Первое, что потребуется - это сам VHD-образ. Второе - необходимо подготовить логический диск. Вы можете воспользоваться любым диском, на котором не установлено никакой другой операционной системы, и на котором имеется 15-25 Гб свободного места. Третье, это утилита WinImage.

1) Запустите утилиту WinImage.
2) Откройте в Winimage Ваш VHD-образ.
3) В открывшемся диалоге нажмите ОК.
4) Выделите справа все файлы.
5) Нажмите на выделенном правой кнопкой мыши и выберите Extract
6) Нажмите Browse и выберите предварительно подготовленный диск.
7) Ниже выберите Extract with pathname. Дождитесь завершения процесса распаковки.
8) После завершения распаковки скачайте и запустите утилиту EasyBCD.
9) В окне приложения нажмите Add/Remove Entries
10) В поле Add entries выберите имя для Вашей новой операционной системы (к примеру, Windows 7 - VHD)
11) Укажите тип (Windows Vista/7)
12) Выберите диск, на который Вы извлекли содержимое образа.
13) Нажмите Add entry, а затем вверху нажмите Save. В списке теперь должно быть два пункта.
14) Зайдите в раздел Change Settings
15) Выберите в качестве ОС, загружаемой по умолчанию, Windows 7 - VHD.
16) Нажмите Save settings и перезагрузите компьютер.

Вариант 2 как основная система.

1) Создайте папку VHD на любом разделе диска.
2) Откройте VHD-образ утилитой WinImage
3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите пункт Extract
4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения распаковки.
5) Перезагрузите компьютер в MSDaRT (ранее ERD Commander), чтобы не думать о проблемах доступа к папкам.
Создание образа MSDaRT описано в совете 9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы). из раздела Разное.
6) Выберите пункт Micosoft Diagnostics and Recovery Toolset → Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
7) Перенесите все файлы из папки VHD на диск C:/. Для этого:
7.1) Откройте папку VHD и выделите все файлы.
7.2) Щелкните правой кнопкой мыши на них, нажмите "move to" и выберите диск С:\
8) Удалите папку VHD.
9) Перезагрузитесь снова в MSDaRT. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончании поиска нажмите repair and restart (исправить и перезагрузит©).

Вариант 3 как вторая система.

Способ 1. Автоматически.

1) Создайте папку VHD на любом разделе диска.
2) Откройте VHD-образ утилитой WinImage.
3) Выделите справа все файлы, щелкните на выделенном правой кнопкой мыши и выберите Extract.
4) Щелкните Browse и выберите папку VHD. Не забудьте выбрать Extract with pathname. Дождитесь завершения распаковки.
5) Перезагрузите компьютер в MSDaRT (ранее ERD Commander), чтобы не думать о проблемах доступа к папкам.
Создание образа MSDaRT описано в совете 9. Создание образа и использование MSDaRT (ранее ERD Commander) (необходим для полного доступа к файлам и восстановления системы). из раздела Разное.
6) Выберите Micosoft Diagnostics and Recovery Toolset → Explorer и удалите все файлы с диска C:\ (Диск с уже установленной Windows 7). Процесс может быть длительным, ждите.
7) Перенесите все файлы из папки VHD на диск C:/. Папка VHD → выделите все файлы → щелкните правой кнопкой → параметр move to → выберите диск С:\
8) Удалите папку VHD.
9) Перезагрузитесь снова в MSDaRT. После выбора раскладки клавиатуры, будет автоматический поиск установленных систем. По окончанию поиска нажмите repair and restart (исправить и перезагрузит©).
10) После перезагрузки нам станет доступен выбор из двух ОС. Нас интересует вторая Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено). Выберите её и ждите пока закончится настройка системы.
В процессе, компьютер будет два раза перезагружен, не забывайте после каждой перезагрузки выбирать вторую ОС Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено).
11) Если загружаетесь через Windows 7 Ultimate(recovered), в русской версии Windows 7 Ultimate(восстановлено) , то диск с основной ОС будет недоступен (при загрузке через основную ОС диски доступны все). Если хотите сделать этот диск доступным, воспользуйтесь встроенной утилитой Disk Management (Выполнить → compmgmt.msc). Открыв Disk Management, Вы увидите что у раздела с основной ОС не назначена буква. Щелкните правой кнопкой мыши на диске, выберите Change Drive Letter and Paths, нажмите Add, выберите любую букву для диска, ОК, диск доступен.

Способ 2. В ручную без Winimage, при помощи программы Bcedit.

Для данного способа используйте программу bcedit, входящую в состав средств Windows или средств Восстановления.

1) Запустите командную строку от имени администратора в Windows или в командной строке средств Восстановления, или в Erd Commander (при запуске необходимо выбрать текущую систему). Все дальнейшие команды вводите в командной строке.
2) При помощи указанной команды, скопируйте существующую запись текущей системы с новым названием:

3) Дожидаетесь сообщения «Запись успешно скопирована в {хххххххх-хххх-хххх-хххх-хххххххххххх}».
Указанный в данном сообщении буквенно-цифровой код, подставляйте в команды, указанные ниже вместо {ID}:
4) Укажите раздел, на котором расположены файлы загрузки (device) и раздел, на котором расположены системные файлы операционной системы (osdevice). Так как у нас виртуальный диск, то значения параметров device и osdevice будут равны.

где X:\DIR\filename.vhd – полный путь к файлу VHD и указание имени файла.
5) Для форсирования автоматического определения в Windows диска через соответствующий уровень абстракции — Hardware Abstraction Layer (разрешать ли операционной системе ускоренное автоматическое определение версии HAL и файла ядра при загрузке), выполните следующую команду:

6)Установите добавленную систему на последнее место в списке загрузок

7) Перезагрузите компьютер

Если посмотреть на диски, присутствующие в системе, будет видно, что помимо виртуального диска на 16 Гб (обведен оранжевым), с которого, собственно, загружена Windows 7, также присутствуют второй раздел виртуального диска на 200 Мб под системные файлы и реальный(!) жесткий диск, установленный на компьютере. Если открыть диск, где ранее располагался vhd-файл, то можно обнаружить, что его размер увеличился до тех самых 16Гб, причем размер этот теперь строго ограничен.

Некоторые сайты также советуют внести в листинг menu.lst(должен появится при загрузке компьютера) следующие изменения:

Перейти к началу раздела Виртуализация.


4. Установка Windows 7 на виртуальный диск в VHD-файл.

Установив систему на виртуальный диск, в один VHD-файл, Вы получаете такие преимущества по сравнению с обычной системой:

1) сможете сделать копию операционной системы просто скопировав VHD-файл
2) сможете тестировать бета версии программ, не беспокоясь за систему
3) сможете изучать систему, экспериментировать с реестром, не боясь её испортить.

Однако существуют некоторые ограничения при установке Windows на VHD-диск, отмечу наиболее актуальные из них:

1) Если VHD-файл поместить на диске, зашифрованном с помощью BitLocker, загрузка из этого файла будет невозможна. Использование BitLocker в системе, установленной на VHD-диск, хотя и возможно, но не является поддерживаемой конфигурацией.
2) Для установки на VHD-диск можно использовать только Windows 7 Корпоративную (Enterprise) и Windows 7 Максимальную (Ultimate). Другие редакции тоже можно установить на VHD-диск, однако по лицензионным соображениям они не будут оттуда запускаться.
3) Система, установленная на VHD-диск, не может переходить в состояние гибернации, вместо нее возможно только использование спящего режима.
4) Каждая система на VHD-диске должна иметь отдельную лицензию и активироваться.
5) Имеется некоторое снижение производительности системы, при работе Windows на VHD-диске.
6) Не работает функция оценки индекса производительности.

1) Вставьте установочный диск Windows 7 в привод, загрузитесь с него
2) Доходите до шага мастера установки, где Вас просят выбрать или создать тот раздел диска, на который будет установлена Windows 7.
3) Нажмите комбинацию клавиш ⇑ Shift + F10.
Это сочетание клавиш предоставит доступ к командной строке. Напечатайте в ней Diskpart и нажмите Enter ↵.
Командная строка примет следующий вид: DISKPART>. Это говорит о том, что запущен интерпретатор DiskPart.
3) Введите в DISKPART следующую команду:

Она означает - создать файл win7.vhd расширяемого типа, максимальный размер ограничить 30 Гигабайтами. Замените E: на имя диска, на котором вы хотите хранить создаваемый файл.

4) Смонтируйте VHD-файл, чтобы он был доступен программе установки:

5) После успешного выполнения всех операций, набираете команду exit для выхода из утилиты diskpart, и еще раз команду exit – уже в приглашении CMD.EXE для закрытия командной строки.

6) Вы снова окажетесь в окне Выберите раздел для установки.
7) Нажмите кнопку Обновить, расположенную под списком дисков и Вы увидите Ваш новый диск
8) Так как на нем ещё нет разделов, то будет написано Незанятое место на диске...
9) Выберите его и нажмите Настройка диска
10) Щелкните на кнопке "Создать", укажите объем создаваемого радела и щелкните на кнопке "Применить".
11) Ещё раз убедитесь, что Вы выбрали созданный Вами виртуальный диск и нажмите Далее, игнорируя предупреждение: Невозможно установить Windows на диск...

Процесс установки Windows 7 на раздел VHD-диска продолжится так, как будто это обычный логический раздел жесткого диска. При этом будет не только установлена новая ОС, но и подменен загрузчик на "физическом" системном разделе для успешного старта с VHD. При установке Windows 7 на "чистую" систему, мастер установки автоматически создаст на диске системный раздел в 100МБ, на котором помещается загрузчик, а уже для самой системы создаст отдельный раздел.

Перейти к началу раздела Виртуализация.


5. Конвертирование тома жесткого диска в VHD-файл.

Для создания VHD-файлов из томов жесткого диска, Вам необходимо воспользоваться утилитой Disk2vhd. Она позволяет создать VHD-образ прямо с запущенной операционной системы. Для своей работы, программа использует Модуль теневого копирования тома (Volume Snapshot), являющийся функцией используемой операционной системой для создания последовательных снимков томов на определенный момент времени. Таким образом, Вы сможете создать VHD-файл прямо на том же разделе, который в него упаковываете. При создании VHD-файла, программа включает в него только системный том и исключает разделы с данными.

Созданный утилитой виртуальный диск может быть подключен к виртуальной машине как IDE-диск. Не используйте VHD-файл, для загрузки через менеджер загрузки Windows 7 на реальной машине. Windows специальным образом подписывает жесткие диски, и присваивает VHD-диску новый уникальный идентификатор. При попытке загрузки с VHD система выдаст ошибку об отсутствии загрузочного диска или просто перезагрузится без уведомления пользователя. Но при использовании данного VHD-образа в Virtual PC, система отлично стартует и работает.

Для работы с Вашим VHD-файлом Вы также можете использовать оснастку Управление дисками (diskmgmt.msc).
Если снимаете образ системного диска, и у вас есть раздел восстановления (System Reserved), не забудьте включить его в VHD-образ, так как без него система не загрузится. Для создания VHD-файла сделайте следующее:

1) Скачайте программу Disk2vhd
2) Разархивируйте скачанный архив и запустите Disk2vhd
3) В поле под VHD File name укажите путь и ¤ создаваемого Вами VHD-файла.
4) Установите флажки напротив томов жесткого диска, которые необходимо включить в создаваемый Вами VHD-файл.
5) Нажмите Create

Для создания скриптов утилита поддерживает командную строку:

Укажите какие тома необходимо включить в VHD-файл или используйте * для конвертирования всех томов.

Перейти к началу раздела Виртуализация.


6. Конвертирование DVD-образа Windows 7 в VHD-файл.

Для конвертирования DVD-образа Windows 7 в VHD-файл, Вам потребуются Пакет автоматической установки Windows® (AIK) для Windows® 7 и инструмент командной строки WIM2VHD

WIM2VHD - это сценарий Windows Scripting Host, предназначенный для использования в командной строке и позволяющий создать аппаратно-независимый VHD-файл из инсталляционного диска Windows 7, при инициализации которого система минует стадию начальной загрузки и распаковки файлов и будет готова к определению оборудования компьютера, на котором она запущена.

Суть метода заключается в преобразовании файла install.wim в VHD-файл.

1) Установите Пакет автоматической установки Windows® (AIK) для Windows® 7
2) Поместите скаченный файл WIM2VHD.WSF в папку C:\Program Files\Windows AIK\Tools\x86\, если используете 32-разрядную систему, или в C:\Program Files\Windows AIK\Tools\amd64\, если 64-разрядную.
3) Запустите командную строку с правами администратора, для чего нажмите "Пуск", в поле поиска введите cmd.exe и нажмите Ctrl + ⇑ Shift + Enter ↵.
4) Перейдите в папку со скриптом используя команду CD . Например:

Для 32-битной Windows:

Для 64-битной Windows:

Измените пути на соответствующие Вашей системе.

5) Запустите скрипт wim2vhd. Для этого, введите в командной строке следующее:

Командная строка расшифровывается так:
Взять файл h:\sources\install.wim, и редакцию Ultimate преобразовать в e:\vhd\win7.vhd

6) Дождитесь окончания операции.

7) Для подключения полученного VHD-файла к имеющемуся загрузчику Windows 7, используйте команду:

Команда дублирует загрузочную запись текущей запущенной Windows 7. Вместо "Windows 7 Virtual" Вы можете написать любое значение.

8) Bcdedit выведет на экран {GUID} только что созданной записи-дубликата - скопируйте его в буфер обмена и используйте для внесения VHD-файла в опции загрузки:

Для информации:

Работа скрипта WIM2VHD базируется на использовании утилиты imagex.exe из WAIK.
Более подробную информацию и другие примеры использования скрипта WIM2VHD Вы можете прочитать в прилагаемом файле "WIM2VHD Documentation.pdf".

Перейти к началу раздела Виртуализация.


7. Включение Aero Glass в Windows на Virtual PC.

1. Установить Windows 7 на компьютер, к которому вы будете отдалённо получать доступ (VM).
2. Установить Windows 7 на компьютер, с которого вы будете отдалённо получать доступ (host).
3. Сборка Windows 7 на обоих должна быть одинаковой, чтобы всё работало корректно.
4. Компьютер, к которому вы будете получать доступ, должен иметь графический адаптер, поддерживающий Glass, который должен быть включен.
5. Установить Сетевое соединение между двумя компьютерами.

На VM нужно активировать Remote Desktop (не забудьте разрешить доступ приложения в Брандмауэре)
С компьютера host запустите Remote Desktop, введите имя или IP адрес VM. Если вы хотите настроить размер окна, глубину цвета, скорость соединения, то заходите в соответствующие настройки.
Нажмите Connect и вводите логин.

Сессия Remote Desktop стартует, и рабочий стол VM будет показывать DWM эффекты.

В итоге, это не совсем Glass, но этот эффект возможно сделать так, чтобы он выглядел, как Glass, используя разработки команды Remote Desktop.

Перейти к началу раздела Виртуализация.


8. Установка Windows 7 в виртуальную машину VirtualBox.

VirtualBox - специальная программа для создания в памяти ПК виртуальных компьютеров. Каждый виртуальный компьютер может содержать произвольный набор виртуальных устройств и отдельную операционную систему. Область применения виртуальных компьютеров очень широка - от выполнения функций по тестированию ПО до создания целых сетей, которые легко масштабировать, распределять нагрузку и защищать. VirtualBox распространяется бесплатно, с открытым исходным кодом.

1) Скачайте последнюю версию программы VirtualBox с официального сайта: http://www.virtualbox.org/wiki/Downloads
2) Установите ее на свой компьютер.

2.1) Запустите установщик; В первом окне нажмите Next
2.2) Выберите необходимые Вам компоненты для установки и нажмите пункт Next.
2.3) Нажмите Next, а затем Yes для начала установки.
2.4) Нажмите на кнопку Install. Внимание: После нажатия кнопки Install произойдет разрыв связи с сетью (как локальной, так и Интернет)
2.5) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
2.6) В последнем окне оставьте флажок, чтобы приступить к созданию виртуальной машины сразу или уберите флажок для создания виртуальной машины позднее. Нажмите кнопку Finish. Если Вы убрали флажок, то для запуска программы воспользуйтесь значком на рабочем столе.

3) В главном окне программы нажмите на кнопке Создать. Откроется Мастер создания новой виртуальной машины. Нажмите кнопку Вперед.
4) Введите имя виртуальной машины, в разделе Тип ОС установите значения:
Операционная система: Microsoft Windows
Версия: Windows 7.
Нажмите кнопку Вперед.

5) Введите размер оперативной памяти, выделяемый для виртуальной машины.
Внимание: Память будет выделяться из физической памяти установленной в Вашем компьютере. Не устанавливайте память ниже 512 Мегабайт и выше 50% от размера установленной физической памяти. Нажмите кнопку Вперед.
6) Выберите загрузочный виртуальный жесткий диск. Установите переключатель в значение: Создать новый жесткий диск. Нажмите кнопку Вперед.

7) Откроется Мастер создания нового виртуального диска. Нажмите кнопку Вперед.
8) Выберите тип виртуального жесткого диска. Динамический образ изначально займет немного места, и будет расширяться постепенно. Фиксированный образ сразу создаст диск указанного размера - это может занять продолжительное время. Нажмите кнопку Вперед.

9) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\.VirtualBox.
Выберите размер виртуального жесткого диска. (По умолчанию 20 Гигабайт). Нажмите кнопку Вперед.

10) Нажмите на кнопку Готово и Вы вернетесь в предыдущее окно, где будут указаны параметры создаваемой Вами виртуальной машины. Нажмите на кнопку Финиш в окне Итог, и Вы создадите новую виртуальную машину.

Виртуальная машина для установки на нее Windows 7 создана.

11) Перед началом установки Windows 7 на Вашу виртуальную машину ее необходимо настроить. Для настройки Вашей виртуальной машины нажмите на кнопку Свойства.
12) В разделе настроек из списка слева выберите Дисплей. Установите размер видеопамяти, доступной для виртуальной машины не менее 26 Мегабайт. Поставьте флажки яў элементов настроек Включить 3D-ускорение и Включить 2D-ускорение видео.

13) В разделе настроек из списка слева выберите Носители.
14) Нажмите значок DVD-диска рядом с ниспадающим меню в графе Атрибуты.

Если у Вас установочный диск Windows 7 записан на DVD-диск, то вставьте его в DVD-привод и выберите привод с соответствующей буквой. Также установите флажок для Разрешить прямой доступ.
Если у Вас установочный диск Windows 7 имеется в виде ISO-образа, то выберите пункт Выбрать образ оптического диска... нажмите на значок папки, чтобы открыть Менеджер виртуальных носителей
15) В окне Выберите образ оптического диска выберите файл образа и нажмите Открыть.
16) Ваш образ добавится в дерево настроек Носители информации. Нажмите кнопку OK.

17) Вы окажетесь в основном окне программы. Нажмите на кнопку Старт
18) Если ¦вятся информационные окна, то нажмите в них на кнопку OK
19) Щелкните кнопкой мыши внутри экрана виртуальной машины, и в информационном окне нажмите на кнопку Захватить
20) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
21) После завершения установки Windows 7 на виртуальную машину, VirtualBox сразу запустит Вам Windows 7 внутри виртуальной машины.

22) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Right Control.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Дополнения гостевой ОС. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Устройства → Установить Дополнения гостевой ОС

23) Во всплывшем окне Автозапуск нажмите VBoxWindowsAdditions.exe и установите программу.
23.1) В появляющихся окнах контроля учетных записей нажмите Да.
23.2) Для перехода к каждому последующему шагу нажмите Next, для установки кнопку Install, для завершения Finish.
23.3) В появляющихся окнах Установить программное обеспечение для данного устройства? нажмите на кнопку Установить
24) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Машина → Закрыть → Выключить машину.
25) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Старт.

Перейти к началу раздела Виртуализация.


9. Установка Windows 7 в виртуальную машину Microsoft Virtual PC.

Microsoft Virtual PC - это мощная программа, которая позволяет эмулировать на одном компьютере работу сразу нескольких виртуальных машин. Каждая из таких машин может находит© под управлением своей собственной операционной системы (Windows любой версии, Netware, Linux, Solaris и т.д.), выполнять уникальную задачу, иметь собственную конфигурацию и т.д.

1) Скачайте последнюю версию программы Virtual PC с официального сайта:
http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=24439
2) Установите программу. Внимание программа установки без предупреждения выключит соединение с сетью (как локальной, так и Интернет).
3) Скачайте и установите обновление KB958162.msp для Virtual PC
4) Запустите программу. Нажмите кнопку Пуск → Все программы → Microsoft Virtual PC
5) В окне с надписью: "You are not running on a supported operating system" нажмите ОК.
6) В окне New Virtual Machine Wizard нажмите кнопку Next. Данное окно Вы также можете запустить нажав кнопку New в Virtual PC Console или в меню File выбрать New Virtual Machine Wizard.

7) Установите переключатель на Create a Virtual Machine. Нажмите кнопку Next.

8) Выберите имя и расположение для файла Вашей виртуальной машины. По умолчанию имя файла New Virtual Machine, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке C:\Users\UserName\Documents\My Virtual Machines. Нажмите кнопку Next.
9) Выберите тип операционной системы. В связи с отсутствием пункта Windows 7 в Virtual PC, выберите Windows Vista или Other. Нажмите кнопку Next.

10) Установите переключатель на Adjusting the RAM. Выберите необходимое Вам количество оперативной памяти выделяемое виртуальной машине, не менее 512 Мегабайт. Нажмите кнопку Next.

11) Установите переключатель на A new virtual hard disk, чтобы создать новый виртуальный образ. Нажмите кнопку Next.
12) Выберите имя и расположение для файла Вашего виртуального диска. По умолчанию имя файла соответствует имени виртуальной машины, к котрой добавлено Hard Disk, а сам файл располагается на том же жестком диске, где установлена реальная Windows 7, в папке:
C:\Users\UserName\Documents\My Virtual Machines\ИмяВиртуальнойМашины\
Укажите величину создаваемого вами виртуального жесткого диска в мегабайтах. Рекомендую указать 20480 Мб (20 Гб). Для информации: 1 Гб = 1024 Мб. Нажмите кнопку Next.

13) Нажмите кнопку Finish, для создания виртуальной машины. Вы снова окажетесь в окне Virtual PC Console.
14) Выберите созданную Вами виртуальную машину и нажмите кнопку Start
15) Виртуальная машина начнет свою работу и остановится с сообщением: Reboot and Select proper Boot device or Insert Boot Media in selected Boot device, поскольку отсутствует инсталляционный диск с Windows 7. Выберите команду CD>Capture CD Image и укажите образ ISO с Windows 7.

16) Перезагрузите виртуальную машину, выбрав команду Action → Ctrl + Alt + Del или нажав Alt + Del в окне виртуальной машины.
17) Установите Windows 7. Установка Windows 7 на виртуальную машину ничем не отличается от обычной установки на реальную машину.
18) После завершения установки Windows 7 на виртуальную машину, Microsoft Virtual PC сразу запустит Вам Windows 7 внутри виртуальной машины.
19) Использование мыши и клавиатуры в виртуальной машине блокирует их для использования в реальной (хостовой) Windows. Для переключения между окном виртуальной машины и окном основной Windows, приходится использовать хост-клавишу Alt справа.
Чтобы виртуальная машина не захватывала курсор мыши и клавиатуру, и Вы могли бы спокойно перемещать курсор мыши между гостевой (виртуальной) и хостовой (основной) системами, а также буфер обмена стал бы общим, Вам необходимо установить Virtual Machine Additions. Для их установки проделайте следующее: в меню запущенной виртуальной машины выберите Action → Install or Update Virtual Machine Additions и нажмите Continue.

20) Во всплывшем окне Автозапуск нажмите Setup.exe и установите программу.
21) Нажмите Yes по окончанию установки Virtual Machine Additions и виртуальная машина перезагрузится.
22) Чтобы выключить виртуальную машину, в меню запущенной виртуальной машины выберите Action → Close → Turn Off и нажмите OK.
23) Чтобы запустить установленную Windows 7 в основном окне программы нажмите на кнопку Start.

Перейти к началу раздела Виртуализация.


10. Установка Windows 7 в виртуальную машину VMware Workstation.

VMware Workstation — популярная программа для виртуализации систем. VMware Workstation является массивным решением для разработчиков программного обеспечения и системных админов, создающих и тестирующих полно-комплексные сетевые приложения класса серверов, работающие в разнообразных средах.

1) Откройте страницу Download VMware Workstation Trial и нажмите кнопку Download Now, рядом с VMware Workstation XX for Windows (где XX - номер версии).
2) Запустите установку программы и нажимайте кнопки Next (Continue).
3) В окне Enter License Key нажмите кнопку Skip, а в следующем окне нажмите кнопку Finish.
4) Запустите программу VMware Workstation, установите переключатель в значение "I want to try VMware Workstation 12 for 30 days", введите свой e-mail и нажмите кнопку Continue, а в следующем окне нажмите кнопку Finish.
Для использования демонстрационной версии:
5) В окне VMware Workstation Activation нажмите кнопку Close.
Для ввода имеющегося у Вас серийного номера:
6) В окне VMware Workstation Activation нажмите Help → Enter Serial Number...
7) В открывшемся окне нажмите Enter Serial Number..., введите новый серийный номер и нажмите ОК.
8) В главном окне программы нажмите на значок New Vitual Machine.

9) Установите переключатель на Typical (recommended). Нажмите кнопку Next.

10) Установите переключатель на Installer disk image file (iso). Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Next.

11) Выберите из ниспадающего списка Вашу редакцию Windows 7, укажите свой инсталляционный код Windows 7, имя пользователя и пароль и нажмите кнопку Next.
Если Вы решили ввести эти данные позже, то после нажатия кнопки Next, нажмите на кнопку Yes.

12) Выберите имя и расположение для файла Вашей виртуальной машины. Нажмите кнопку Next.

13) Задайте размер Вашего виртуального жесткого диска в гигабайтах и укажите, как следует создать виртуальный диск - одним (single) или несколькими (multiple) файлами.
Размер виртуального диска изначально будет создан небольшого размера, и будет увеличиваться при добавлении программ, файлов, данных в виртуальную машину.

14) Установите флажок Power on this virtual machine after creation и нажмите кнопку Finish, для начала создания виртуальной машины.

После завершения автоматической установки Windows 7 на виртуальную машину, VMware Workstation сразу запустит Windows 7 внутри виртуальной машины, установит дополнительные инструменты VMware Tools, а также в случае наличия у Вас подключения к Интернету, установит все необходимые драйвера.
VMware Tools позволят Вам одновременно использовать курсор мыши как в виртуальной системе, так и в основной. Плюс к этому Вы сможете копировать файлы из/в виртуальную машину, а также использовать единый буфер обмена.
Используйте комбинацию клавиш Ctrl + Alt для разблокировки курсора мыши одновременного использования мыши как в виртуальной системе, так и в основной.

15) Для выключения виртуальной машины, завершите работу в виртуальной Windows 7 как в обычной Windows. Пуск → Завершение работы.
16) Для включения виртуальной машины, перейдите на вкладку с названием Вашей виртуальной машины (по умолчанию Windows 7) и нажмите ссылку Power on this virtual machine или щелкните на Вашу виртуальную машину в списке слева и нажмите кнопку Power on this virtual machine, расположенную под меню File.

Дополнительная информация:

Чтобы отключить Easy Install и установить Windows в обычном режиме.

1) На шаге выбора iso-образа для установки Вашей операционной системы, установите переключатель в значение I will install the operating system later и нажмите кнопку Next.
2) Выберите из ниспадающего списка Windows 7 или Windows 7 x64, в соответствии с разрядностью устанавливаемой системы, и нажмите кнопку Next.

3) Выберите имя и расположение для файла Вашей виртуальной машины, и нажмите кнопку Next.
4) Задайте размер Вашего виртуального жесткого диска в гигабайтах и укажите, как следует создать виртуальный диск - одним (single) или несколькими (multiple) файлами.
5) Нажмите кнопку Finish, чтобы закрыть мастер предварительных настроек виртуальной машины.
6) Щелкните на Вашу виртуальную машину в списке слева и нажмите ссылку Edit virtual machine settings
7) Нажмите в списке устройств на пункт CD/DVD (IDE) или CD/DVD (SATA) и установите переключатель на Use ISO image file.

8) Нажмите кнопку Browse и укажите путь к ISO-образу Windows 7. Нажмите кнопку Открыть, а затем кнопку ОК.
9) Запустите Вашу виртуальную машину. Щелкните на Вашу виртуальную машину в списке слева и нажмите ссылку Power on this virtual machine.
И у Вас начнется обычная установка Windows.

Чтобы отключить сообщение об отсутствии floppy-дисковода:

1) Откройте VMware Workstation, но систему, пока не запускайте.
2) В разделе Devices щелкните дважды на слово Floppy.
3) В открывшемся окне Virtual Machine Settings выделите пункт Floppy и нажмите кнопку Remove.
4) Нажмите кнопку ОК.
Должно стать как на скриншоте выше.
Теперь Вы можете запускать виртуальную Windows.

Если у Вас возникли проблемы с входом в интернет после установки VMware Workstation:

1) Зайдите в Панель управления\Сеть и Интернет\Сетевые подключения
2) Отключите VMware Network Adapter VMnet1 и VMware Network Adapter VMnet8.
3) Перезагрузите компьютер.

Перейти к началу раздела Виртуализация.


11. Создание общей папки яў виртуальной и основной Windows в VirtualBox.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VirtualBox и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Устройства → Общие папки

2) Нажмите на клавиатуре кнопку Insert, либо нажмите на значок папки с плюсом.

3) Установите флажок для параметра Создать постоянную папку.
4) В ниспадающем меню рядом с текстом Путь к папке выберите пункт Другой....
5) Укажите путь к Вашей папке и нажмите на каждую кнопку ОК.

Если Вы хотите, чтобы гостевая ОС автоматически подключала данную папку в процессе загрузки поставьте флажок у Авто-подключение.
Если Вы хотите, чтобы общая папка была постоянной для данной машины установите флажок у Создать постоянную папку, иначе выбранная общая папка будет временной.
6) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник → Сеть → VBOXSVR → Ваша папка

Перейти к началу раздела Виртуализация.


12. Создание общей папки яў виртуальной и основной Windows в Microsoft Virtual PC.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину Microsoft Virtual PC и хостовой (реальной) Windows 7, сделайте следующее:

1) В меню запущенной виртуальной машины откройте Edit → Settings или нажмите сочетание клавиш: правый Alt + E

2) Выберите в списке Shared Folders и нажмите кнопку Share Folder...

3) Установите флажок на Share Every Time, укажите Вашу общую папку и установите букву диска в виде которого будет отображаться папка в виртуальной Windows, затем нажмите OK.

4) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник → Компьютер → Отключенное сетевое устройство (назначенная вами буква диска)

Перейти к началу раздела Виртуализация.


13. Создание общей папки яў виртуальной и основной Windows в VMware Workstation.

Чтобы создать общую папку для гостевой (виртуальной) Windows 7 установленной в виртуальную машину VMware Workstation и хостовой (реальной) Windows 7, сделайте следующее:

1) В списке виртуальных машин щелкните правой кнопкой мыши на Вашей виртуальной машине и выберите пункт Settings или же на вкладке с названием Вашей виртуальной машины (по умолчанию Windows 7) нажмите ссылку Edit virtual machine settings

2) Перейдите на вкладку Options и выделите пункт Shared Folders
3) Установите переключатель в положение Always enabled и поставьте флажок Map as a network drive in Windows guests.

4) Нажмите кнопку Add..., а затем кнопку Next.
5) Нажмите кнопку Browse. Укажите путь к Вашей общей папке в хостовой (реальной) Windows 7 и ее имя в виртуальной Windows, затем нажмите OK.

6) Нажмите кнопку Next, а затем кнопку Finish. Выйдите из опций нажав кнопку OK.
7) Чтобы открыть общую папку в гостевой (виртуальной) Windows 7, откройте Проводник → Компьютер → Shared Folders → Ваша папка

Перейти к началу раздела Виртуализация.


14. Запуск старых 16-битных приложений и DOS-игр в Windows, используя программу DosBox.

Для запуска старых 16-битных приложений и DOS-игр в Windows, Вы можете использовать программную среду DosBox. Чтобы Вам легче было в ней работать Вы можете воспользоваться одной из предлагаемых на сайте графических оболочек.

1) Скачайте и установите графическую оболочку D-Fend Reloaded
2) Нажмите Файл → Настройки программы.
3) Перейдите на вкладку Язык в Пользовательский интерфейс и установите значения параметров в соответствии с языковыми требованиями программы, которую Вы собираетесь запустить и нажмите ОК.
4) Чтобы добавить новое 16-битное приложение (DOS-игру), просто перетащите мышкой ZIP-архив с программой или распакованную папку с файлами приложения (игры) в окно программы.
5) В зависимости от выбранного Вами действия, появится окно Импорт архива или окно Импорт папки.
6) В данном окне нажмите ОК и профиль для данной игры добавится в программу, чтобы Вы могли в любой момент запустить её.
7) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить настройку.
8) Настройте параметры запуска игры и выйдите из программы настройки.
9) Нажмите правой кнопкой мыши на созданном профиле игры и выбираете пункт Запустить программу.

Дополнения:

Переключение между экранным и оконным режимами осуществляется комбинацией клавиш Alt + Enter ↵.
Звуковую карту указывать Sound Blaster/Sound Blaster Pro
Иногда для выхода приходится в ручную вводить команду Exit и нажимать Enter ↵.

Перейти к началу раздела Виртуализация.


15. Отключение синхронизации времени с хостовой системой в виртуальной машине VirtualBox.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение VirtualBox.
2) Откройте окно команд из папки, куда установлена программа и в которой находится утилита VBoxManage.exe.
Для этого щелкните правой кнопкой мыши по паке, удерживая нажатой клавишу ⇑ Shift и выберите Открыть окно команд.
3) Введите указанную ниже команду:

Где: <name> - имя Вашей виртуальной машины, а <-msec> - разница в миллисекундах между текущей датой и той, что требуется. Указанное значение будет постоянно отматываться назад.

Для получения необходимого Вам значения в милисекундах воспользуйтесь утилитой Date Offset Calculator

Перейти к началу раздела Виртуализация.


16. Отключение синхронизации времени с хостовой системой в виртуальной машине Microsoft Virtual PC.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение Microsoft Virtual PC.
2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (С:\Users\ИмяПользователя\AppData\Local\Microsoft\Windows Virtual PC\Virtual Machines) и имеет расширение .vmс
3) Найдите тег </microsoft> и вставьте перед ним нижеследующий текст:

4) Найдите тег </bios> и вставьте перед ним нижеследующий текст:

В итоге у Вас должно получит© примерно так:

Если у Вас уже имеются указанные разделы, но значения параметров установлены true, то просто измените их на false.

5) Сохраните файл и запустите Virtual PC.
6) Зайдите в BIOS виртуальной машины, и установите необходимую Вам дату и время, и после перезагрузки/выключения машины они не будут синхронизированы с хостовой системой.

Перейти к началу раздела Виртуализация.


17. Отключение синхронизации времени с хостовой системой в виртуальной машине VMware Workstation.

Если в виртуальной Windows Вам необходиомо, чтобы при запуске виртуальной системы была установлена уже прошедшая дата и виртуальная машина не синхронизировала данные с основной системой, то выполните указанные ниже действия.

1) Выйдите из виртуальной машины и закройте приложение VMware Workstation.
2) Откройте в любом текстовом редакторе файл конфигурации Вашей виртуальной машины.
Данный файл расположен в той же папке, где и созданная Вами виртуальная машина (C:\Users\ИмяПользователя\Documents\Virtual Machines) и имеет расширение .vmx
3) Добавьте в конце файла нижеследующие строки:

Параметры с первого до предпоследнего отключают синхронизацию времени с хостовой машиной при различных операциях.
Последний параметр rtc.startTime определяет дату в биосе при запуске машины. Его значение – это требуемая дата в формате Unix Timestamp, равняется количеству секунд прошедших с полночи с 31 декабря 1969 года на 1 января 1970 года до необходимой Вам даты и времени.

Для получения необходимого Вам значения скачайте программу конвертер: Unix Timestamp Converter или воспользуйтесь онлайн конвертером: Unix Time Convertion

4) Сохраните файл и перезапустите VMware Workstation.

Внимание: После внесения изменений проверьте отсутствие дублирующихся строк, иначе машина не запустится.

Перейти к началу раздела Виртуализация.


18. Открытие виртуальных образов дисков (*.mdx, *.mds/*.mdf, *.iso, *.nrg), монтирование их в виртуальные приводы.

Часто в интернете выкладывают виртуальные образы дисков имеющие расширения *.mdx, *.mds/*.mdf, *.iso, *.nrg. После скачивания данных файлов, возникает вопрос о способе их дальнейшего использования.
Для работы с ними, Вам необходимо установить эмулятор виртуальных дисков. Это позволит Вам монтировать и демонтировать виртуальные диски в виртуальные приводы, что анологично тому как Вы вставляете и вынимаете DVD/Blue-Ray диск из дисковода. Для монтирования виртуальных образов дисков Вы можете использовать следующие программы:

DAEMON Tools Lite

1) Скачайте программу и установите ее.
1.1) В процессе установки выберите значение переключателя Бесплатная лицензия и убедитесь,что в компонентах установлен флажок SPTD.
2) Запустите программу DAEMON Tools Lite и нажмите в ней на значек шестеренки яў запуска элемента программы Настройки
3) В списке слева выберите пункт Интеграция.
4) Выделите все типы файлов и нажмите кнопку Применить, а затем кнопку Закрыть.
5) Теперь для монтирования виртуального диска, щелкните правой кнопкой мыши на файле образа и выберите пункт Открыть.
Файл будет автоматически смонтирован в виртуальный привод и запустит© автозапуск для диска (если он у Вас не отключен) .
6) Для демонтирования диска, щелкните правой кнопкой мыши по виртуальному диску в папке Компьютер и выберите пункт Извлечь.
При использовании гаджета для монтирования нажмите значок Play, для демонтирования файла нажмите на значок Stop.

Alcohol 52% Free Edition

1) Скачайте программу и установите ее.
2) Запустите программу Alcohol 52% и в главном меню выберите Сервис → Настройки
3) В списке слева выберите пункт Ассоциации файлов и нажмите кнопку Выбрать все
4) Установите флажок Другие расширения и введите mdx, а затем нажмите кнопку ОК.
5) Теперь для монтирования виртуального диска, щелкните на файле образа правой кнопкой мыши и выберите пункт Смонтировать образ.
Файл будет автоматически смонтирован в виртуальный привод и запустит© автозапуск для диска (если он у Вас не отключен) .
6) Для демонтирования диска, щелкните правой кнопкой мыши по виртуальному диску в папке Компьютер и выберите пункт Демонтировать образ.

WinCDEmu

1) Скачайте программу и установите ее.
2) Для монтирования виртуального диска, щелкните на файле образа правой кнопкой мыши и выберите пункт Выбрать букву диска и монтировать.
3) Выберите необходимую Вам букву для виртуального диска и нажмите ОК.
Файл будет автоматически смонтирован в виртуальный привод и запустит© автозапуск для диска (если он у Вас не отключен).
4) Для демонтирования диска, щелкните правой кнопкой мыши по виртуальному диску в папке Компьютер и выберите пункт Извлечь.

Перейти к началу раздела Виртуализация.


19. Настройка параметров для использования интернета в VMware Workstation, при наличии VPN-соединения.

Если у Вас в реальной (хостовой) Windows для входа в интернет используется vpn-подключение, то иногда виртуальная Windows может не правильно определять сеть, что приводит к отсутствию интернета в виртуальной системе.
Чтобы настроить интернет в виртуальной системе сделайте следующее:

1) Закройте программу VMware Workstation, если она у Вас запущена.
2) Отключите VPN-подключение к интернету.
3) Откройте Пуск → Все программы → VMware и запустите Virtual Network Editor (vmnetcfg.exe).
4) Нажмите на кнопку Restore Default, а затем в всплывшем окне нажмите кнопку Да.
5) После того как программа переустановит драйвера и пересоздаст заново виртуальные сети нажмите кнопку ОК.
6) Откройте Панель управления\Все элементы панели управления\Центр управления сетями и общим доступом.
7) Нажмите ссылку Изменение параметров адаптера.
8) Щелкните правой кнопкой мыши на Вашем VPN-соединении и выберите пункт Свойства.
9) Перейдите на вкладку Доступ и в ниспадающем списке выберите VMware Network Adapter VMnet8.
10) Установите флажок Разрешить другим пользователям сети использовать подключение к Интернету данного компьютера и нажмите кнопку ОК.
11) Во всплывшем окне Сетевые подключения нажмите Да.
12) Подключите VPN-подключение к интернету.
13) В списке виртуальных машин щелкните правой кнопкой мыши на Вашей виртуальной машине и выберите пункт Settings.
14) Щелкните на пункт Network Adapter.
15) В разделе Network Connection установите переключатель в значение Custom: Specific virtual network.
16) В ниспадающем списке выберите VMnet8 (NAT) и нажмите кнопку ОК.
17) Запустите Вашу виртуальную Windows и она автоматически определит существующее подключение к интернету.

Перейти к началу раздела Виртуализация.


20. Проведение тестирования программ в виртуальной системе.

Вы установили виртуальную Windows, чтобы в ней проверять незнакомые программы прежде, чем устанавливать их в хостовую (основную) Windows.
Чтобы собранных Вами сведений Вам хватило бы для анализа программы, в процессе ее тестирования Вы должны выявить:

1) Какие неизвестные службы добавляются в систему?

Откройте Панель управления → Администрирование → Службы и найдите службы неявляющиеся стандартными.

Используя Sysinternals Process Explorer (английская версия или русская версия).

2) Какие процессы загружает установленная программа при запуске?
3) Какие процессы остаются загруженными после закрытия программы?
4) Сколько ресурсов процессора, оперативной памяти, графической памяти использует программа?
5) Как часто происходит чтение/запись на диск?
6) Сколько ресурсов сети использует программа?

Общие индикаторы расположены в верхней части Sysinternals Process Explorer.
Чтобы просмотреть данные о процессе, нажмите правой кнопкой мыши на процессе (файле) и выберите пункт Properties (Свойства).
Наиболее необходимая Вам информация находится на вкладках: Performance Graph (График производительности), GPU Graph (График ГП), Performane (Производительность), Disk and Network (Диски и Сети).

Используя Sysinternals AutoRuns (английская версия или русская версия).

7) Какие записи настроеные на запуск в процессе загрузки или входа в систему, добавляются в папку автозагрузки или в разделы реестра отвечающие за автозагрузку?

Используя SysTracer (официальный сайт или зеркало).

8) Внесенные изменения на диске и в реестре после установки программы.
9) Оставшиеся следы на диске и в реестре после удаления программы.

Создайте три точки яў сравнения: до установки, после установки и после удаления и сравните сначала первую точку со второй, а затем первую точку с третьей.
Подробнее описано в совете 30. Отслеживание изменений на диске и в реестре, путем сравнения снимков системы. из раздела Администрирование.

После проведения подобного анализа, Вы решаете, необходимо ли Вам использование тестируемой программы на хостовой (основной) Windows.

Перейти к началу раздела Виртуализация.